Abilis CPX Technical manual - Main page

Abilis CPX technical manual

Attention Under revision for version 4.8.0 compliance Attention

Revised chapters have the mark "Revised for CPX 4.8.0" on the upper right corner.

Start with introduction

Visit Abilis.net website

Click the image to visit Abilis.net website


The CPX hardware

Chassis and modularity
Abilis CPX Base-S
Abilis CPX Base-L
Watchdog hardware
How it works
Benefits

Adapters: ISA and PCI bus

Synchronous adapters
Asynchronous adapters
LAN adapters
Analogue voice (FXS/FXO) adapters
ISDN (only data) adapters
ISDN enhanced adapters

Chassis and modularity top

Abilis CPX is produced in two versions of different sizes and number of free slots:

  • CPX-Base-S
    • 3 slots PCI
    • 2 slots ISA
    • sizes 392x319x180 mm
    • weight 8 Kg
  • CPX-Base-L
    • 3 slots PCI
    • 7 slots ISA
    • sizes 440x319x180 mm
    • weight 10 Kg

Abilis CPX is costantly improving, that's why those specifications are subject to change without notice on this manual.

Abilis CPX Base-S top

Front panel

For more detailed descriptions of all the accessible functions from the front panel, please refer to the section Front panel commands.

Frontale Cpx Base-S
Figure 1. Base-S, front panel.

Back panel

The following figure shows the back panel; just as example, some adapters are already plugged in.

Retro Cpx Base-S
Figure 2. Base-S, back panel.

Abilis CPX Base-L top

Front panel

For more detailed descriptions of all the accessible functions from the front panel, please refer to the section Front panel commands.

Frontale Cpx Base-L
Figure 3. Base-L, front panel.

Back panel

The following figure shows the back panel; just as an example, some adapters are already plugged in.

Retro Cpx Base-L
Figure 4. Base-L, back panel.

Watchdog hardware top

The module "Watchdog hardware", or simply "Watchdog" is an Abilis working mode Supervisor. It is set on the front panel, where also are set leds "1" and "2" and the keys "Select" and "OK".

This module is based on an autonomous processor, which constantly checks a signal generated by Abilis CPX during its regular functioning.

When Abilis is switched on, and during all the software loading procedure, the Watchdog quickly blinks led 1 and keeps off led 2. It is watching the starting procedure of Abilis CPX.

When the software is definitely loaded and running, both leds start to light simultaneously with a regular time interval of 1 second. The module is watching the CPX in its normal working mode.

How it works

During its regular working mode, the Abilis CPX change the "LIVE" signal status every (c.a.) second.

The Watchdog, not only checks this signal, but it signals its status by switching on and off leds "1" and "2" with the same frequency.

If the LIVE signal variations are not detected for a time interval bigger than "TLIVE" (set by the dip-switch SW1), the Watchdog will find out the anomaly, save it for next readings and reset the Abilis CPX.

A similar procedure is executed also while the software is loading, i.e. every time the Abilis CPX is switched on, or after every reset (warm start, restart system, auto warm start): the Watchdog expects 5 status variations of the LIVE signal in a TBOOT time interval (set by the dip-switch SW1).

If this will happen, then the Watchdog will start monitoring the system using the TLIVE timer, while if it won't happen the Watchdog will detect the anomaly, save it for next readings and reset the Abilis CPX.

Benefits

During the normal working mode of the Abilis CPX, the Watchdog doesn't bring benefits, however it gives safety in those applications called "mission critical" and "unattended".

In such applications, it is extremely important the system never stops working, however software complexity and the events amount to be handled is such that even the most tested system may have some bugs.

Let's suppose an event would occur and stop working the system, communications would be cut until (maybe even the day after) the technician would fix that bug.

In this critical situation, the Watchdog will detect the absence of activity (if the system stops, it doesn't generate the LIVE signal) and reset the Abilis CPX.

At every start, the Watchdog checks whether the previous time it has detected anomalies and, if yes, saves the event in the System Log.

Tabella 1. SW1 configuration for setting TLIVE and TBOOT timers.
3 | 2 | 1 | TBOOT | 6 | 5 | 4 | TLIVE
off | off | off | 1 Minute | off | off | off | 15 seconds
ON | off | off | 2 Minutes | ON | off | off | 30 seconds
off | ON | off | 3 Minutes | off | ON | off | 45 seconds
ON | ON | off | 5 Minutes | ON | ON | off | 1 Minute
off | off | ON | 7 Minutes | off | off | ON | 2 Minutes
ON | off | ON | 10 Minutes | ON | off | ON | 3 Minutes
off | ON | ON | 13 Minutes | off | ON | ON | 4 Minutes
ON | ON | ON | 16 Minutes | ON | ON | ON | 5 Minutes

Fpanel whatchdog
Figure 5. Watchdog, position of SW1 on the front panel.

The correct configuration for the current version is: 3 minutes for TBOOT and 30 seconds for TLIVE.

The SW1 position on the Watchdog module and the default configuration have been described in the figures shown above.

ISA and PCI bus top

Both PCI and ISA adapters,depending on the number of free slots, can be plugged in the Abilis CPX.

When the CPX hardware configuration is chosen, i.e. all the needed adapters are selected, it is also necessary to verify the availability of free slots (PCI and ISA) in the requested CPX base model.

print Print this page


Off-line configurator

Revised for CPX 4.3.0.
Introduction
Off-line configurator activation
Off-line configurator options
Commands available in the off-line configurator

Introduction top

By having a personal computer with the WIN95(C) (or successive), it is possible to configure the Abilis CPX, without connecting to the Control Port, using the CONFIG.EXE utility program.

This method is very useful when it is not possible to connect to the Control Port, or when the user wants to configure an Abilis CPX diskette without having the Abilis CPX equipment available.

The CONFIG.EXE utility program is contained in an additional diskette distributed together with the Abilis CPX diskette.

The off-line configuration program interface and the rules that set up the command language are the same usually offered by the Control Port of a working Abilis CPX.
However some command are meaningless and they cannot be used. In the Commands available in the off-line configurator the full list of commands offered by the off-line commands interpreter is reported.

Off-line configurator activation top

After verifying the operative system WIN95(C) (or successive) is installed, the user must check whether the system can read 1.44 Mbytes formatted disks.

In the case that the personal computer is equipped with only one floppy disk drive, it is neccessary to copy the CONFIG.EXE program to the hard disk and then to insert the Abilis CPX diskette in the floppy drive (let's suppose "A:").

In the case that the personal computer is equipped with two floppy disk drives, it is possible to insert the diskette holding the CONFIG.EXE program in one floppy drive (let's suppose "A:") and to insert the Abilis CPX diskette in the other floppy drive (let's suppose "B:").

Using a PC with one floppy disk drives

  1. Call the "MS-DOS prompt", usually placed in the "Programs" menu of WIN95 (C).
  2. Insert the diskette holding the CONFIG.EXE program in the floppy drive (let's suppose "A:").
  3. Activate the floppy unit (let's suppose "A:") containing the disk already inserted
  4. Copy the the CONFIG.EXE program on the hard disk in any directory (let's suppose "C:\").
    A:\> COPY A:CONFIG.EXE C:\<enter>
       1 file copyed.
  5. Extract the diskette holding the CONFIG.EXE program and insert the Abilis CPX diskette in the available floppy drive (let's suppose "A:").
  6. Go to the CONFIG.EXE program location and execute it. For example:
    A:\> C:<enter>

C:\> CONFIG.EXE<enter>
  7. After the loading phase the CONFIG.EXE program searches for the file DRIVERS.CFG in the same directory from which it was executed. Because the file is located in the Abilis CPX diskette, the following message will appear:
    ERROR: File 'DRIVERS.CFG' not found.

Enter 'DRIVERS.CFG' directory path (press Esc to exit):
  8. Type the letter corresponding to the unit holding the Abilis CPX diskette (let's suppose "A:") and press enter:
    ERROR: File 'DRIVERS.CFG' not found.

Enter 'DRIVERS.CFG' directory path (press Esc to exit): A:<enter>

    the Control Port prompt will appear. For example:

     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Logged as SUPERUSER

[15:52:50] ABILIS_CPX:
  9. In the case that one or more password has been configured, in the Control Port, the login and access password request will be shown. For example:
     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Login:
  10. In this case, the user has to insert the login, correspondent to the requested privilege level, and related password followed by <enter>; if the inserted password is not correct, after 3 wrong tries, the program will terminate. After inserting the correct password, if configured, the Control Port prompt will be shown. For example:
     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Login: user<enter>
Password: *******<enter>
Logged as USER

[15:56:21] ABILIS_CPX:

Now it is possible to undergo the commands usually available by the Control Port of a working Abilis CPX.

Using a PC with two floppy disk drives

  1. Call the "MS-DOS prompt", usually placed in the "Programs" menu of WIN95 (C).
  2. Insert the diskette holding the CONFIG.EXE program in one floppy drive (let's suppose "A:").
  3. Activate the floppy unit (let's suppose "A:") containing the disk already inserted:
    C:\> A:<enter>
  4. Insert the Abilis CPX diskette in the other floppy drive (let's suppose "B:").
  5. Execute the program CONFIG.EXE.
    A:\> CONFIG<enter>
  6. After the loading phase the CONFIG.EXE program searches for the file DRIVERS.CFG in the same directory from which it was executed. Because the file is located in the Abilis CPX diskette, the following message will appear:
    ERROR: File 'DRIVERS.CFG' not found.

Enter 'DRIVERS.CFG' directory path (press Esc to exit):
  7. Type the letter corresponding to the unit holding the Abilis CPX diskette (let's suppose "B:") and press enter:
    ERROR: File 'DRIVERS.CFG' not found.

Enter 'DRIVERS.CFG' directory path (press Esc to exit): B:<enter>:

    the Control Port prompt will appear. For example:

     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Logged as SUPERUSER

[15:52:50] ABILIS_CPX:
  8. In the case that one or more password has been configured, in the Control Port, the login and access password request will be shown. For example:
     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Login:
  9. In this case, the user has to insert the login, correspondent to the requested privilege level, and related password followed by <enter>; if the inserted password is not correct, after 3 wrong tries, the program will terminate. After inserting the correct password, if configured, the Control Port prompt will be shown. For example:
     - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Login: user<enter>
Password: *******<enter>
Logged as USER

[15:56:21] ABILIS_CPX:

Now it is possible to undergo the commands usually available by the Control Port of a working Abilis CPX.

Off-line configurator options top

On the execution line of the CONFIG.EXE program, together with the program name, it is possible to specify one of the following options:

Option | Description
-? | This option make possible to display the program version and the program usage instruction.
-p (or -P) | This option make possible to specify the DRIVERS.CFG directory path.
-i (or -I) | This option make possible to specify an input file from which the program will get the commands.
-o (or -O) | This option make possible to specify an output file on which the program will copy the result of executed commands.

More then one off-line configurator program options can be used in the same time, with the only exception of the '-?' option.

Here are some examples, useful to understand the above-mentioned options functionalities:

EXAMPLE N.1

The following figure shows the full list of CONFIG.EXE program options, displayed in correspondence of the "CONFIG -?" command execution:

 - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

 Usage: CONFIG [-?] [-pPath] [-iFilename] [-oFilename]

 Options:
 -?                     Program version and usage are displayed.
                        Es.: CONFIG -?
 -pPath                 DRIVERS.CFG directory path.
                        Es.: CONFIG -pA:
 -iFilename             Inputs commands from the specified file.
                        Es.: CONFIG -iINPUT.TXT
 -oFilename             Saves output results in the specified file.
                        Es.: CONFIG -oOUTPUT.TXT

EXAMPLE N.2

Thanks to the '-p' option, it is possible to cut short the off-line configurator start up phase entering the DRIVERS.CFG directory path directly on the CONFIG.EXE execution line:

C:\> CONFIG -pA:<enter>

The present example shows the execution result:

 - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Logged as SUPERUSER

[16:54:29] ABILIS_CPX:

EXAMPLE N.3

Thanks to the '-i' option, it is possible to pass to the off-line configurator the name and full path of a textual file holding a set of commands to be executed. Each command must occupy a single line and must be ended by a new line character. For example:

D R
A R PR:0 POI:301 POO:302 CDI:* CDO:* UDI:* UDO:*
D R
QUIT
Y

The present example shows how to instruct the CONFIG.EXE program to execute the previously listed commands, stored in the 'BatchCom.txt' file:

C:\> CONFIG -pA: -iC:\BatchCom.txt<enter>

Here it the execution result:

 - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Logged as SUPERUSER

[17:29:15] ABILIS_CPX:D R

---+----+----+----+---------------+---------------+------------+--------------
PR |COMP|POI |POO |CDI            |CDO            |UDI         |UDO
   |NEXT|         |CGI            |CGO            |FFO
   |              |IPSRC          |IPDEST
------------------------------------------------------------------------------
0   NO   *    0    *               *               CP           *
------------------------------------------------------------------------------

[17:29:15] ABILIS_CPX:A R PR:0 POI:301 POO:302 CDI:* CDO:* UDI:* UDO:*

COMMAND EXECUTED

[17:29:15] ABILIS_CPX:D R

---+----+----+----+---------------+---------------+------------+--------------
PR |COMP|POI |POO |CDI            |CDO            |UDI         |UDO
   |NEXT|         |CGI            |CGO            |FFO
   |              |IPSRC          |IPDEST
------------------------------------------------------------------------------
0   NO   301  302  *               *               *            *
------------------------------------------------------------------------------
1   NO   *    0    *               *               CP           *
------------------------------------------------------------------------------

[17:29:15] ABILIS_CPX:QUIT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)?Y

VALIDATION IN PROGRESS ...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[17:29:21] ABILIS_CPX:

Program exits.

EXAMPLE N.4

Thanks to the '-o' option, it is possible to make th off-line configurator to store the result of its execution into a textual file, whose name and full path must be specified on the program execution line:

C:\> CONFIG -pA: -oC:\Output.txt<enter>

After the previous line execution, suppose to enter the "D VER" command to the off-line configurator command line interpreter.
A copy of the program output will be saved in textual format in the specified file:

C:\> TYPE Output.txt<enter>

 - CONFIG - v. 1013    - 07/03/2002 - For CPX release 1128 - build 1128 -
 - (c) 1994/2002 - Abilis -

Logged as SUPERUSER

[17:44:44] ABILIS_CPX:D VER

      Abilis CPX - Ver. 1128/V/E - 21/03/2002 - Build 1128 - 21/03/2002
                       CONFIG - v. 1013    - 07/03/2002
                            (c) 1994/2002 - Abilis

CX        : v. 1035    - 19/03/2002       CP        : v. 1192    - 20/03/2002
COR       : v. 1001    - 03/07/2001       CNFG      : v. 1158    - 14/03/2002
COMMON    : v. 1046    - 13/03/2002

[17:44:46] ABILIS_CPX:exit

Program exits.

C:\>

Commands available in the off-line configurator top

Here is the complete list of commands offered by the off-line configurator command interpreter:

A D
A DHCP HOST
A DHCP HOST:
A DHCP LAN
A DHCP LAN:
A DHCP PROF:
A EG
A ER
A IPACL
A IPP:
A LIST:
A NAT
A PVC
A R
A RAS
A SIPR
A TDM
A VD
A VG
A VR
BOOT CARD:
C D
C DHCP HOST
C DHCP HOST:
C DHCP LAN
C DHCP LAN:
C DHCP PROF:
C EG
C ER
C IPACL
C IPP:
C L
C LE
C LIST:
C NAT
C PVC
C R
C RAS
C SIPR
C TDM
C VD
C VG
C VR
COPY PO:
CLOSE
D ACT
D CRKEY
D CRKEY:
D D
D DE
D DHCP
D DHCP HOST
D DHCP HOST:
D DHCP LAN
D DHCP LAN:
D DHCP PROF
D DHCP PROF:
D EG
D EID
D ER
D ERE
D G
D I
D INACT
D IPACL
D IPP
D IPP:
D ITEM
D L
D LDD
D LE
D LIST
D LIST:
D NAT
D P
D PVC
D R
D RAS
D RE
D SIPR
D TDM
D TREE
D VD
D VER
D VG
D VR
EXIT
F IPACL
F LIST:
F RAS
LIST CREATE
LIST DELETE
LIST DESCRIPTION
LIST RENAME
LOGIN
LOGOUT
M ER
M IPACL
M NAT
M R
M TDM
QUIT
SAVE CONF
SAVE CONF BACKUP
SAVE CONF TEST
S ACT
S CARD:
S D
S DHCP HOST:
S DHCP LAN
S DHCP LAN:
S DHCP PROF:
S EG
S EID
S ER
S G
S INACT
S IPACL
S IPP:
S NAT
S P
S PVC
S R
S NAT
S SIPR
S TDM
S VD
S VG
S VR
TRACE DISPLAY
TRACE DISPLAY EXTENDED
TRACE PARAM
TRACE PARAM SET
VALIDATE


Supervision

Revised for CPX 4.7.0.
Displaying general configuration of the system
Displaying and setting up date and time
Displaying CPU load percentages

Supervision of the communication ports
Supervision of connections
Logging functionalities
The front panel
The front panel of MfIde equipped systems

Besides the configuration functionalities, Abilis CPX offers some important functions to supervise ONLINE the entire system, i.e. without interfering with the current connections.

Supervision functions are accessible through the Control Port, so that they can be executed by local users (using the serial port) or by remote users (accessing through X.25 or through a TCP/IP network).

A sub-set of the supervision functions offered by the Control Port, is accessible also through the SNMPv1 Agent of the Abilis CPX. It can be reached by remote users through a TCP/IP network.

In such way, all the installed Abilis CPX can be accessed, queried and configured from a single control station accessing the X.25 network or through a TCP/IP network.

This feature, known as tele-assistance and tele-installation, allows activating a timely and effective assistance service, provided by the user himself, the Abilis CPX seller or by the Abilis CPX itself depending on the difficulty of the troubles occurred, or simply according to the contractual agreement.

Supervision functions don't provided only information about Abilis CPX, but about DTE user and network.

The Events Log and System Log contain information about events occurred in the last period [1], so that it is easier to detect problems and then solve them.

Displaying general configuration of the system top

The table of general configuration of the system contains some parameters useful to optimize the memory resources used by the Abilis CPX according to the installation types, and to display some meaningful value for a better understanding and management of the system.

Such information are displayed and configured through D G and S G commands.

Here is an example of displaying the general parameters of the system, all the shown values are examples:

[19:16:58] ABILIS_CPX: D G

- Not Saved (SAVE CONF) -------------------------------------------------------

         Conf.Value Act.Value                Description
------------------------------------------------------------------------------
vconn:        32         0    Max number of VOICE connections [32..255]
VDIGITS:       3         -    Number of digits used to dial a number [1..4]
VTOUT:         3         0    VOICE connections protection timeout [1..5 sec.]
VCALLT:        5         -    VOICE calling timeout [1..60 sec.]
VALTT:        20         -    VOICE alerting timeout [1..60 sec.]
DTMF:    OUTBAND         -    DTMF processing mode [NO, INBAND, OUTBAND]
DTMFHI:        8         -    Change gains for High tone frequency [1..15]
DTMFLO:        8         -    Change gains for Low tone frequency [1..15]
FDRELAY:     YES         -    Fax/Data relay [NO, YES]
FDLEVEL:       9         -    Generated Fax/Data level in 1 dB step [0..15]
tact:         NO        NO    TRACE activation state [NO, YES]
sound:        ON        ON    Alarm sound enable/disable [OFF, ON]
ndict:         -         0    Number of available dictionaries     <Read Only>
lccomp:        -         0    Max number of compressed LC          <Read Only>
fdict:         -         0    Number of free dictionaries          <Read Only>
hwint:         -     MFIDE    Front Panel/WatchDog interface type  <Read Only>
isapnp:      YES       YES    Enable/disable PNP for ISA cards [NO, YES]
------------------------------------------------------------------------------
DBGF:      ALL
CONTACT:   Leo_Mantovani
SYSNAME:   CPX_Antek
LOCATION:  Antek_(MN)
SYSUPTIME: 0 days 06:10:14 (Wednesday 03/04/2002 13:22:37)         <Read Only>
SYSRBTIME: # (System Reboot time not set)
DATE&TIME: Wednesday 03/04/2002 19:32:51 (GMT+2.00)                <Read Only>
TIMEZONE:  CET - Central Europe (Rome, Paris, Berlin, Prague, Brussels)

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The previous table shows the value used at the system start (column "Act.Value") and the ones eventually modified by a new configuration, the last ones will be used at the next system start (column "Conf. Value").

Those parameters, whose values need a system restart to be activated, are displayed in low case characters. The parameters, that can be immediatly activated are written in high case characters.

The "<Read Only>" note showed in the parameter description indicates the not modifiable ones which correspond to fixed values and depend on the hardware, not only software, configuration (for example the parameter NDICT:, which correspond to the number of dictionaries, related to the RAM memory of the compression module).

As well as for other commands, adding the character "?" at the end of the command, it is possible to obtain a short description of the system parameters and their allowed values.

[19:32:51] ABILIS_CPX: S G ?

General system parameters:

VCONN:     Max number of VOICE connections [32..255]
VDIGITS:   Number of digits used to dial a number [1..4]
VTOUT:     VOICE connections protection timeout [1..5 sec.]
VCALLT:    VOICE calling timeout [1..60 sec.]
VALTT:     VOICE alerting timeout [1..60 sec.]
DTMF:      DTMF processing mode [NO, INBAND, OUTBAND]
DTMFHI:    Change gains for High tone frequency [1..15]
DTMFLO:    Change gains for Low tone frequency [1..15]
FDRELAY:   Fax/Data relay [NO, YES]
FDLEVEL:   Generated Fax/Data level in 1 dB step [0..15]
TACT:      TRACE activation state [NO, YES]
SOUND:     Alarm sound enable/disable [OFF, ON]
NDICT:     Number of available dictionaries                         <Read Only>
LCCOMP:    Max number of compressed LC                              <Read Only>
FDICT:     Number of free dictionaries                              <Read Only>
HWINT:     FP/WDG interface type [FP-HSCB, FP-LPT, FP-IDE, MFIDE]   <Read Only>
ISAPNP:    Enable/disable PNP for ISA cards on Pentium systems [NO, YES]
DBGF:      Debug Log Event filter [DIAG, COR, MLM, EIR, EIRE, PPP, ML, ALL]
           Event filters can be joined using "," operator
CONTACT:   Name of contact person and how to contact them
SYSNAME:   Node fully qualified domain name
LOCATION:  Physical location of node
SYSUPTIME: System start-up elapsed time [days hh:mm:ss]             <Read Only>
SYSRBTIME: System reboot time [#, hh:mm], where 'hh' [0..2400], 'mm' [0..59]
DATE&TIME: Current date and time [dd/mm/yyyy hh:mm:ss (TimeZone)]   <Read Only>
TIMEZONE:  Time zone [UDF, GMT, ICE, WET, CET, EET, AST, EST, CST, MST, PST]
TZOFFSET:  Time zone offset vs. GMT [GMT+hh.mm or GMT-hh.mm] <For TIMEZONE:UDF>
DSTOFFSET: Time changes offset [+hh.mm]                      <For TIMEZONE:UDF>
TODSTTIME: Change to Daylight Savings Time [dd/mm hh:mm, #]  <For TIMEZONE:UDF>
TOSTDTIME: Change to Standard Time [dd/mm hh:mm, #]          <For TIMEZONE:UDF>

Details of the general parameters of the system

VCONN: | Maximum number of voice connections in VR (Voice router)
no value | from 32 up to 255

It sets the maximum number of voice connections allowed in VR (Voice router).

If modified, the parameter will be activated at the next system restart.

VDIGITS: | Maximum number of digits per each telephone number in VR (Voice router)
3 | from 1 up to 4

It sets the maximum number of digits making the telephone numbers for voice connections.

If modified, the parameter will be activated after executing the command INIT VR.

VTOUT: | Protection time out for voice connections VR (Voice router)
3 | 1 up to 5 seconds

If the VR (Voice router) doesn't receive packets for VTOUT time, the VR (Voice router) assumes a broken path and drops the call.

Each direction (TX and RX) is checked independently to ensure that packets are regularly flowing in both direction.

Call will be dropped if either directions runs in time out.

If modified, the parameter will be activated after executing the command INIT VR.

VCALLT: | Calling time out for voice connections in VR (Voice router)
5 | from 1 up to 60

It sets the maximum time that VR (Voice router) waits in "Calling" state before aborting the call.

If modified, the parameter will be activated after executing the command INIT VR.

VALTT: | Alerting time out in Voice ports
20 | from 1 up to 60

It sets the maximum time that a Voice port stays in "Alerting" state.

Upon expiration (e.g. because the user didn't pick-up the phone), the call is dropped.

If modified, the parameter will be activated after executing the command INIT VR.

DTMF: | DTMF transfer mode on the compressed channel
OUTBAND | NO, INBAND, OUTBAND

It defines how DTMF are handled in compressed connection.

It is used by both EIR and VR connections.

If modified, the parameter will be activated after executing the respective commands: R ACB or R EBIB / R EPIB.

DTMFHI: | Intensity of the high frequency in DTMF tones
8 | from 1 up to 15

It sets the intensity, in 1 dbm step, of the higher tone frequency in the generated DTMF signal.

The value 8 correspond to default value of -1 dbm.

If modified, the parameter will be activated after executing the respective commands: R ACB or R EBIB / R EPIB.

DTMFLO: | Intensity of the low frequency in DTMF tones
8 | from 1 up to 15

It sets the intensity, in 1 dbm step, of the lower tone frequency in the generated DTMF signal.

The value 8 correspond to default value of -3 dbm.

If modified, the parameter will be activated after executing the respective commands: R ACB or R EBIB / R EPIB.

FDRELAY: | Fax/modem signals treatment
YES | NO, YES

It enables/disables the detection and relaying of fax/modem signals.

Note that in order to allow fax/modem to work over the compressed channel, FDRELAY must be set to YES.

Also note that during the relaying period any "human" speech is cut, therefore a "false" detection may appear as a broken call: user on the phone at one side hears a "fax tone" while the user at the other side hears "silence".

warning! A "false" detection can occur if a fax machine is "noising" close to the user phone while he is speaking. The fax "noise" can be captured by the phone microphone and trigger the fax detection and subsequent relaying!

If modified, the parameter will be activated after executing the respective commands: R ACB or R EBIB / R EPIB.

FDLEVEL: | Fax/modem signal output level
9 | from 0 up to 15

It sets the intensity, in 1 dbm step, of re-modulated fax/modem signal.

The value 9 correspond to the default value of -9.5 dbm.

If modified, the parameter will be activated after executing the respective commands: R ACB or R EBIB / R EPIB.

TACT: | Activating of internal events tracing at the system start
YES | NO, YES

It make possible to automatically activate internal events tracing functionality when the system starts.

If "TACT:" is set to "NO", this functionality won't be automatically executed at the system start, but it can be afterwards activated through the Control Port, using the suitable command TRACE ACT.

If it is set to "YES", the tracing functionality is automatically activated every time the system starts by using the parameters saved in a previous system activation through the command TRACE PARAM SAVE.

If modified, the parameter will be activated at the next system restart.

SOUND: | Enabling/disabling of acoustic signalling in case of alarm occurrence
ON | OFF, ON

It enables or disables the acoustic signalling generation in case of alarm occurrence.

If modified, the new parameter value will be shown in the column "Conf.Value" and, if saved, it will be activated at the next system restart.

The parameter value shown in the column "Act.Value" stands for the value actually used. It can be modified either through the commands SOUND ENABLE and SOUND DISABLE provided by the command language of the Control Port, or through the commands available in the UTILITY of the LCD display of the front panel.

NDICT: | Number of available dictionaries
no value | from 0 up to 64

It sets the number of available dictionaries in the system. This value depends on the compression adapter in use and, as it follows, on the quantity of RAM memory installed.

This parameter is not modifiable: any try to modify it, won't be successful, even if the message "COMMAND EXECUTED" will be shown.

For more information refer to the section Dictionaries and memory of chapter Compression data protocols.

LCCOMP: | Number of logical compressible channels
no value | 0 - 32

It shows the number of logical channels that can be compressed simultaneously. This value is related to the number of dictionaries and to the quantity of RAM memory installed.

Inside the Abilis CPX there is a adapter dedicated to real time data compression; it is able to compress data at about 250 Kbytes/sec (2Mbit/sec) and it is provided with a RAM memory of 1 up to 32 Mbytes.

As already seen, the quantity of RAM memory installed on the compression adapter set the number of logical channels that can be compressed simultaneously.

The compression adapter can accept two memory SIMM (30pins) modules [2], so that installing one or two modules of the available capacity, it is possible to have the following combinations[3]:

Table 1. Memory and compressible channels.
N. | SIMM Module | RAM installed | LC compressible
1 | SIMM 1 Mbyte | 1 Mbyte | 1 LC
2 | SIMM 1 Mbyte | 2 Mbyte | 2 LC
1 | SIMM 4 Mbyte | 4 Mbyte | 4 LC
2 | SIMM 4 Mbyte | 8 Mbyte | 8 LC
1 | SIMM 8 Mbyte | 8 Mbyte | 8 LC
2 | SIMM 8 Mbyte | 16 Mbyte | 16 LC
1 | SIMM 16 Mbyte | 16 Mbyte | 16 LC
2 | SIMM 16 Mbyte | 32 Mbyte | 32 LC

The parameter "LCCOMP:" is not modifiable: any try to modify it won't be successful, even if the message "COMMAND EXECUTED" will be shown.

FDICT: | Number of free dictionaries
no value | from 0 up to 64

It shows the number of unused dictionaries. This value depends on the number of logical channels compressed and active in the system.

The parameter is not modifiable: any try to modify it won't be successful, even if the message "COMMAND EXECUTED" will be shown.

HWINT: | Type of Front Panel/WatchDog
no value | FP-HSCB, FP-LPT, FP-IDE, MFIDE, NONE

It shows the type of Front Panel/WatchDog interface currently installed and running in the system.

The parameter is not modifiable: any try to modify it won't be successful, even if the message "COMMAND EXECUTED" will be shown.

ISAPNP: | Enable/disable PNP for ISA card
YES | NO, YES

It enables/disable PNP for ISA cards on Pentium systems.

If modified, the parameter will be activated at the next system restart.

DBGF: | Selection of events to save in the Debug Log
ALL | DIAG, COR, MLM, EIR, EIRE, PPP, ML, ALL

It selects the events type that can be saved in the Debug Log. Each mnemonic represents an event class.

The events classes are showed in the following table:

Table 2. Events classes
Mnemonic | Events classes
DIAG | Events related to port diagnostic and status.
COR | Events related to the Connection Oriented Router.
MLM | Events related to the Multi Link Manager driver.
EIR | Events related to the Enhanced ISDN Router.
EIRE | Extension of the events class related to the Enhanced ISDN Router.
PPP | Events related to the Point-to-Point Protocol driver.
ML | Events related to the Multi Links driver.

If one or more events class have to be selected, mnemonics can be combined together, separated by the character "," (comma), without using any space.

For example "S G DBGF:DIAG,MLM,EIR", requests to save only the diagnostics events, events related to the Multi Link Manager driver and to the Enhanced ISDN Router driver.
At the end, the value "ALL" means that every kind of event will be saved into the Debug Log.

The parameter is run-time modifiable, the value, once set, is immediately active.

CONTACT: | People to refer to in case of eventual assistance
no value | any string (max. length 32 characters, no spaces)

It sets the person (or more) to refer to in case of eventual assistance.

SYSNAME: | System name
no value | any string (max. length 32 characters, no spaces)

It sets the system name.

LOCATION: | System location
no value | any string (max. length 32 characters, no spaces)

It sets the location where the system works.

SYSUPTIME: | Elapsed time since the system start
no value | ddd:hh:mm:ss (day of week dd/mm/yyyy hh:mm:ss)

The parameter shows the elapsed time (format: "days:hours:minutes:seconds) since the system start, which is also displayed inside parentheses (format "day of the week", "day/month/year" and "hour:minutes:seconds").

This parameter is not modifiable. If it is tried to be modified, the following message will be shown: "READ ONLY PARAMETER".

SYSRBTIME: | Missing time to the system reboot
# | hhhh:mm, #

The parameter set the time interval (format: "hour:minute") missing to the next system reboot.

The character '#' means the system restart has not been set.

The system reboot can be set by specifying the time interval in hours and minutes, for, at maximum, 2400 hours (i.e. 100 days) and 59 minutes.

Once the parameter is set, the execution of the command D G will display the time interval elapsed since it was set to the system reboot.

For example "SYSRBTIME: 01:19 (System will reboot at 29/07/1999 11:07:41)", shows the interval missing to the reboot and its scheduled time. When the time-out will be over, the system, after saving into the System Log the message "AUTO WARM START", will reboot.

DATE&TIME: | Current date and time
no value | dd/mm/yyyy hh:mm:ss (Time Zone)

The parameter shows the current date and time (format: "day/month/year hours:minutes:seconds (Time Zone)").

This parameter is not modifiable. If it is tried to be modified, the following message will be shown: "READ ONLY PARAMETER".

TIMEZONE: | Current time zone
CET | UDF, GMT, ICE, WET, CET, EET, AST, EST, CST, MST, PST

It shows the Time Zone actually set. Choosing the time zone will affect the difference between the local time and the GMT (Greenwich Mean Time) one, the eventual change from "Standard time" to "Daylight Savings Time" and vice versa.

A set of "standard" time zones is available, where the differences between local time and the GMT one, rules related to the "Standard/Daylight Savings". Time changes are fixed by international agreements, universally known. The User could also decide to configure the Time Zone setting on his own.

Here is a table showing the "standard" time Zones currently supported and their characteristics.

Table 3. Time Zones available on the Abilis CPX.
Mnemonic | Difference with GMT | Description and main geographic areas of reference | Changing from Standard time to Daylight Savings Time | Changing from Daylight Savings Time to Standard Time
GMT | GMT+0.00 | Greenwich Mean Time (London, Belfast, Dublin) | Last sunday of March | Last sunday of October
ICE | GMT+0.00 | Iceland (Reykjavik) | Daylight Savings Time not in use | Daylight Savings Time not in use
WET | GMT+0.00 | Western Europe (Lisbon, Madeira, Canaries) | Last sunday of March | Last sunday of October
CET | GMT+1.00 | Central Europe (Rome, Paris, Berlin, Prague, Bruxel) | Last sunday of March | Last sunday of October
EET | GMT+2.00 | Eastern Europe (Sofia, Bucarest, Kiev, Athen, Istanbul) | Last sunday of March | Last sunday of October
AST | GMT-4.00 | US, Atlantic Standard Time | First sunday of April | Last sunday of October
EST | GMT-5.00 | US, Eastern Standard Time (New York) | First sunday of April | Last sunday of October
CST | GMT-6.00 | US, Central Standard Time (Chicago) | First sunday of April | Last sunday of October
MST | GMT-7.00 | US, Mountain Standard Time (Denver) | First sunday of April | Last sunday of October
PST | GMT-8.00 | US, Pacific Standard Time (Los Angeles) | First sunday of April | Last sunday of October

Before setting his own time zone, the User has to configure the parameter "UDF" (User Defined). After this, besides the already described parameters, the following ones will be also shown:

Parameter | Description
TZOFFSET: | set the difference between the local time and the GMT one
DSTOFFSET: | set the difference between the standard and the Daylight Savings Time
TODSTTIME: | date of the Daylight Savings Time activation;
TOSTDTIME: | date of the Daylight Savings Time ending

Handling these parameters, the User is able to customize the Time Zone settings.

TZOFFSET: | Local Time offset (Only for TIMEZONE:UDF)
GMT+0.0 | GMT+hh.mm or GMT-hh.mm

This parameter set the difference in hours and minute between the local time and the GMT one.

The allowed formats are:

  • GMT +hh.mm
  • GMT -hh.mm

Where: hh=hours, mm=minutes.

DSTOFFSET: | Daylight Savings Time offset (Only for TIMEZONE:UDF)
+1.0 | +hh.mm

The parameter set the difference in hours and minutes between the Standard and the Daylight Savings Time. When the date set in the parameter TODSTTIME: (correspondent to the Daylight Savings Time starting), or in the parameter TOSTDTIME: (correspondent to the Daylight Savings Time ending) has gone, the local time will be automatically incremented or decremented of the value set in this parameter.

The allowed format is:

  • +hh.mm

Where: hh = hours, mm = minutes.

TODSTTIME: | Day, month, hour of the Daylight Savings Time starting (Only for TIMEZONE:UDF)
# | dd/mm hh:mm, #

The parameter set day, month and hour when to change from the Standard Time to the Daylight Savings one.

The allowed format is:

  • dd/mm1 hh:mm2

Where: dd = day; mm1 = month; hh = hour, mm2 = minutes.

Once it has been set, the system will yearly execute this change at the fixed date and time, incrementing the current time by the value, set in the parameter DSTOFFSET:.

The value "#" can be used to disable this change.

TOSTDTIME: | Day, month, hour of the Daylight Savings Time ending (Only for TIMEZONE:UDF)
# | dd/mm hh:mm, #

The parameter set day, month and hour when to change from the Daylight Savings Time to the Standard one.

The allowed format is:

  • dd/mm1 hh:mm2

Where: dd = day; mm1 = month; hh = hour, mm2 = minutes.

Once it has been set, the system will yearly execute this change at the fixed date and time, decrementing the current time by the value, set in the parameter DSTOFFSET:.

The value "#" can be used to disable this change.

Displaying and setting up date and time top

Abilis CPX has got an internal clock for indicating time and date of the system. Once they are set, it keeps on working even if the Abilis CPX is off.

The commands for managing the time and date are described in the section Commands related to time and date. The available commands are:

D T
D TE
S T

Here is an example of displaying time and date using an extended format:

[09:56:16] ABILIS_CPX: D T

Current Local Time    : Thursday 04/04/2002 09:56:19 (GMT+2.00)
Local Time Zone       : Central Europe (Rome, Paris, Berlin, Prague, Brussels)
Currently Observing   : Daylight Savings Time (DST)

[09:56:19] ABILIS_CPX: D TE

Current Local Time     : Thursday 04/04/2002 09:56:25 (GMT+2.00)
Current GMT Time       : Thursday 04/04/2002 07:56:25
Local Time Zone        : CET - Central Europe (Rome, Paris, Berlin, Prague...
Currently Observing    : Daylight Savings Time (DST)
DST time will start on : Sunday 30/03/2003 at 02:00
DST time will end on   : Sunday 27/10/2002 at 03:00

Examples on how to set time and/or date:

[14:40:11] ABILIS_CPX: S T 06/01/2002

[14:40:11] ABILIS_CPX: S T 18:50:11

[14:40:11] ABILIS_CPX: S T 06/01/2002 18:50

Displaying CPU load percentages top

Abilis CPX offers a function to estimate the average CPU load over a given time interval. It gives an estimated percentage load for the last 1 second, 15 seconds and 5 minutes.

The command that can be used to inspect the current CPU load percentages is described in the section CPU Load Measurements.

Here is an example of displaying it:

[09:56:19] ABILIS_CPX: D CPU

+---------+--------------+--------------+--------------+
|         | Last 1 sec.  | Last 15 sec. | Last 5 min.  |
+---------+--------------+--------------+--------------+
|CPU Load |       3%     |      11%     |       1%     |
+---------+--------------+--------------+--------------+

[1] Time required to save the events strongly depends on their amount. Refer to the proper chapters for more information.

[2] Accessing time to the memory modules must be equal or smaller than 70ns.

[3] Throughput provided by a two SIMMs configuration is double than a single SIMM configuration.


Elements List

Elements Lists

Configuration of the Lists
Configuration of the Elements

By the terms "Elements Lists" we refer to a list of objects, belonging to the same homogenous type, that are identified by the generic term "item".

Within the Abilis CPX, the following element types have been referred as relevant:

  • ISDN numbers;
  • ISDN sub-addresses;
  • EIR Cluster identifiers;
  • X.25 NUA;
  • X.25 User data fields;
  • IP addresses.
  • Dialling numbers.
  • CPX ports.
  • TCP/UDP ports.
  • Internet protocols.

For each object type, Abilis CPX offers the possibility to create homogenous lists which can be used by Routers for improving routing performances and/or providing a simple authentication/identification service: accessing specific services can be authorized or denied to users and/or group of users.

Beside the possibility to create objects lists of the above-mentioned type, it is also allowed to arrange more Items lists together and to define criteria to be used for their manipulation (through AND, OR, NOT logical operators). This kind of object is called "Rule".

Therefore, the Elements Lists types provided by the Abilis CPX are:

Mnemonic | List type
IN | List of ISDN numbers
IS | List of ISDN sub-addresses
EC | List of EIR Cluster identifiers
XN | List of X25 NUA
XU | List of X25 User Data Field
IP | List of IP addresses
IR | List of IP group addresses
DN | List of Dialling numbers
CP | List of CPX ports
TUP | List of TCP and UDP ports ranges
IPT | List of Internet protocols
MAC | List of MAC addresses
SAP | List of SAP values
RU | List of Rules
MR | List of Master Rules

The service of the Elements Lists can be used by the Enhanced ISDN Router for accepting and/or refusing calls depending on the source numbers, the sub-addresses and the EIR Cluster identifiers of the incoming call. By the way, it is also possible to define and configure IN, IS, and RU lists type in the "input" fields of the ISDN-EIR routings.

The service of the Elements Lists can be used by the Connection Oriented Router for accepting and/or refusing calls depending on the X.25 NUA and User Data fields of the incoming calls. By the way, it is also possible to define and configure XN, XU and RU lists type in the "input" fields of the SVC routings.

Finally, this service can be used in the IP environment for accepting and/or refusing calls or packets depending on the IP source address, on Internet protocol and on TCP/UDP ports. By the way, it is also possible to define and configure IP lists type, IP addresses group lists (IR type), TCP/UDP ports group lists (TUP type) and Internet protocols lists (IPT type).

Items lists are split in two tables, inside the Abilis CPX: Lists table and Items table.

The first one is used for simple operations such as creating, modifying or deleting an item list, while the last one is used for operation such as inserting, deleting or searching items within lists.

Configuration of the Lists top

The Lists table can store up to 64 different list definitions, univocally identified within the system by a "name", assigned by the user during its creation.

Lists definition are identified not only by their name, but through a numeric identifier (from 1 to 64). It is automatically chosen by the system among the ones already not in use, and assigned to the list. Lists definitions might not be sequential, the table is not sorted every time a list has been removed. Vacancies are assigned when a new list is going to be created.

The Lists table can be modified while the Abilis CPX is running, without needing to restart it. Modifications made on the Lists table are immediately active.

Commands for configuring and displaying lists are described in the section Commands related to the Items Lists.

The allowed commands are:

LIST CREATE
LIST DELETE
LIST DESCRIPTION
LIST RENAME
D LIST

The following example shows how to display a single list and its elements.

[18:14:08] ABILIS_CPX: D LIST:Local

LIST:Local - IN, Allowed_callers_from_local_area
     0038*                   0038123123123           0376396967
     064556                  123456

This one shows how to display all the lists and their current elements:

[18:14:08] ABILIS_CPX: D LIST:A

LIST:Disabled - IN, Temporary_disabled_callers
     0376399495

LIST:Far - IN, Allowed_callers_from_different_areas
     0376*                   03383223124             0338959456

LIST:Local - IN, Allowed_callers_from_local_area
     0038*                   0038123123123           0376396967
     0644556                 123456

LIST:Special - IS, Special_servicee_validation

LIST:Callers - RU, Full_allowed_callers
     Local.OR.Far.AND.NOT.Disabled

LIST:D_Numbers - DN, Dialling_numbers
     Order  DialingNumber         MaxConn  Nrty
     1      0376366128            2        NOMAX
     2      5557893               2        NOMAX
     3      3383223444            2        5

LIST:IpServices - TUP,
     ssh(22)        telnet(23)     snmp(161)      rip(520)

LIST:IpProtocol - IPT,
     tcp            udp            ospf

This example shows how to display the Lists table.

[18:14:08] ABILIS_CPX: D LIST

List-Number:8   Items-Number:20    Used-Resources:468    Free-Resources:20012
Id Name                 Type Description                         Ref First Numb
-------------------------------------------------------------------------------
 2 Disabled             IN   Temporary_disabled_callers          0   4     1
 3 Far                  IN   Allowed_callers_from_different_...  0   5     3
 6 Local                IN   Allowed_callers_from_local_area     0   15    5
 7 Special              IS   Special_servicee_validation         0   0     0
 8 Callers              RU   Full_allowed_callers                0   20    1
 1 D_Numbers            DN   Dialling_numbers                    0   1     3
 5 IpServices           TUP                                      0   11    4
 4 IpProtocol           IPT                                      0   8     3
-------------------------------------------------------------------------------
IN:ISDN Numbers,         IS:ISDN Sub Addresses,   EC:EIR Clusters,
XN:X25 NUAs,             XU:X25 UDFs,             IP:IP Addresses,
IR:IP Addresses Ranges,  RU:Rules,                MR:Master Rules,
DN:Dialling Numbers,     CP:CPX Ports,            TUP:TCP and UDP ports ranges,
IPT:Internet Protocols.
-------------------------------------------------------------------------------

As the above mentioned example shows, displayed lists are sorted firstly by their type (as the legend, at the bottom of the table, shows) and then by alphabetical order. The numeric index preceding the list name is its identifier.

Detail of LISTS parameters

List-Number: | Number of lists currently configured
none | 0 - 64

Total number of lists currently configured.

Items-Number: | Number of items currently configured
none | 0 - 2000

Total number of items currently configured.

Used-Resources: | Memory resources used by the Lists service
none | 0 - 20 Kbytes (in bytes)

It shows the overall memory size (in bytes) dedicated, in the configuration file, for storing the elements lists currently configured.

In order to not penalize the other services provided by the Abilis CPX and to guarantee that configurations cannot exceed the available resources in the system, the Lists services has been assigned of a 20Kbyte maximum space in the configuration file.

If while lists and/or elements are configured that limit is reached or passed, the current command will be stopped and fail, the following message will be shown: "LIST SERVICE RESOURCES LIMIT REACHED".

Free-Resources: | Memory resources still free to be used by the Lists service
none | 0 - 20 Kbytes (in bytes)

It shows the overall memory size (in bytes) still available, in the configuration file, for configurating the elements lists.

In order to not penalize the other services provided by the Abilis CPX and to guarantee that configurations cannot exceed the available resources in the system, the Lists services has been assigned of a 20Kbyte maximum space in the configuration file.

If while lists and/or elements are configured that limit is reached or passed, the current command will be stopped and fail, the following message will be shown: "LIST SERVICE RESOURCES LIMIT REACHED".

Id: | List identifier
none | 1 - 64

The index is assigned by the system to each list when it is created. User can use this value, instead of the List name, for executing some commands on the list. The Lists table can have "Id" vacancies, which will eventually be reused when a new list is going to be created.

Name: | List name
none | string (max. length 20 characters [0 - 9, a - z, A - Z, _ ])

The parameter "Name" is the name the User wants to assign to the List during its creation. Names of the lists can be string with maximum length of 20 characters (alphabetical, numerical, "_" underscore). String cannot start with a numerical character and the terms "A", "And", "Or", "Not" are not allowed. The name can be modified by the command LIST RENAME.

Name completely identifies the list within the system. Two or more lists with the same "Name" cannot be defined. There is no difference between low case and uppercase characters.

For example the following strings "FirstList", "FIRSTLIST", "firstlist" are equivalent.

Type: | List type
none | IN, IS, EC, XN, XU, IP, IR, RU, MR, DN, CP, TUP, IPT

"Type" parameter is the type the User wants to assign the list during its creation; it is not modifiable and it can be chosen among the following mnemonics:

Mnemonic | List type
IN | List of ISDN numbers
IS | List of ISDN sub-addresses
EC | List of EIR Cluster identifiers
XN | List of X25 NUA
XU | List of X25 User Data Field
IP | List of IP addresses
IR | List of IP group addresses
RU | List of Rules
MR | List of Master Rules
DN | List of Dialling numbers
CP | List of CPX ports
TUP | List of TCP and UDP ports ranges
IPT | List of Internet protocols
Description: | Description associated to the list
none | string (max. length 71 printable characters, spaces are not included)

List description eventually assigned by the User to the list during its creation. It can also be set and/or modified after creating the list through the command LIST DESCRIPTION. Description is a string of (at maximum) 71 ASCII printable characters, without spaces.

Ref: | Number of references to the list
0 | 0 - 255

It shows the number of references to the list made in the routings: that is the list name has been set as a value in the input fields of the routings.

The list definition can be removed only after its "Ref:" is zero: no routings refer to the List.

First: | Identifier of the first Item stored in the list
none | 0 - 2000

Numeric identifier of the first element of the Item table. If this parameter value is zero, it means the list is empty.

Numb: | Number of items stored in a list
none | 0 - 2000

It shows the overall number of elements contained in the list. If this parameter value is zero, it means the list is empty.

Configuration of the Elements top

The Item table can contain up to 2000 definitions, distinguished and univocally identified, within the system, by the item value (set by the User) and the belonging list.

The Item table is kept contiguous and sorted by increasing values of identifier of the list which the item belongs to. Each new item added to a list will create a new definition in the Item table, its position will be defined according to the belonging list and its value, so that searching operations will be optimised. In the same way, after one item is removed the table is "compressed" again and, eventually, sorted basing on the remaining definitions.

The Item table can be modified will the Abilis CPX is working, without needing to restart it. Changes are immediately active.

As already mentioned, while the elements lists are configured, it must be kept in mind that in order to not penalize other services provided by the Abilis CPX and to guarantee that configurations don't exceed the available resources in the system, the Lists services has been assigned of a 20Kbyte maximum space in the configuration file. If while lists and/or elements are configured that limit is reached or passed, the current command will be stopped and fail, the following message will be shown: "LIST SERVICE RESOURCES LIMIT REACHED".

Commands for configuring and displaying the items are described in the section Commands related to the Items Lists.

The allowed commands are:

D ITEM
A LIST
C LIST
D LIST
F LIST

The following example shows how to display the Item table:

[18:14:08] ABILIS_CPX: D ITEM

Item List Type  Value
-------------------------------------------------------------------------------
   1    1   DN  1      0376366128            2        NOMAX
   2    1   DN  2      5557893               2        NOMAX
   3    1   DN  3      3383223444            2        5
   4    2   IN  0376399495
   5    3   IN  0376*
   6    3   IN  03383223124
   7    3   IN  0338959456
   8    4  IPT  tcp
   9    4  IPT  udp
  10    4  IPT  ospf
  11    5  TUP  ssh(22)
  12    5  TUP  telnet(23)
  13    5  TUP  snmp(161)
  14    5  TUP  rip(520)
  15    6   IN  0038*
  16    6   IN  0038123123123
  17    6   IN  0376396967
  18    6   IN  0644556
  19    6   IN  123456
  20    8   RU  Local.OR.Far.AND.NOT.Disabled
-------------------------------------------------------------------------------
IN:ISDN Numbers,         IS:ISDN Sub Addresses,   EC:EIR Clusters,
XN:X25 NUAs,             XU:X25 UDFs,             IP:IP Addresses,
IR:IP Addresses Ranges,  RU:Rules,                MR:Master Rules,
DN:Dialling Numbers,     CP:CPX Ports,            TUP:TCP and UDP ports ranges,
IPT:Internet Protocols.
-------------------------------------------------------------------------------

Detail of ITEMS parameters

Item: | Item identifier
none | from 1 up to 2000

This is the index assigned by the system to each table element. It has a strictly internal value and the user cannot use it in any list managing operation. The index value is, in fact, continuously, modified by the adding, modifying, removing operations, because the Item table is always kept sorted and indexes are sequential: there are no intermediate vacancies.

List: | Identifier of the list the item belongs to
none | from 1 up to 64

It is the identifier of the list that the item belongs to.

Items are increasingly sorted according to the belonging list identifier. Items of the same list are sorted depending on their type and content:

  • IN type: numbers containing the characters wildcards ('*', '?') always precede the ones without them and they are increasingly sorted depending on the number length (number of digits and/or characters composing the item). Numbers with the same length are sorted alphabetically such as the ones that don't containing the wildcards.

  • IS type: sub-addresses containing the characters wildcards ('*', '?') always precede the ones without them and they are increasingly sorted depending on the sub-address length (number of digits and/or characters composing the item). Sub-addresses with the same length are sorted alphabetically such as the ones that don't containing the wildcards.

  • EC type: identifiers of EIR remote cluster are increasingly sorted depending on their numeric identifier in the Table of EIR remote cluster Identifiers.

  • XN type: NUAs containing wildcards ('*', '?') always precede the ones without them and they are increasingly sorted depending on the NUA length (number of digits and/or characters composing the item). NUAs with the same length are sorted alphabetically such as the ones that don't containing the wildcards.

  • XU type: UDF fields UDF containing wildcards ('*', '?') always precede the ones without them and they are increasingly sorted depending on the UDF length (number of digits and/or characters composing the item). UDFs with the same length are sorted alphabetically such as the ones that don't containing the wildcards.

  • IP type: IP addresses are increasingly sorted.

  • IR type: IP addresses intervals are increasingly sorted depending on the first interval extreme.

  • RU type: no sorting method is used, because the RU list can contain only one element.

  • MR type: no sorting method is used, because the MR list can contain only one element.

  • DN type: dialling numbers are increasingly sorted depending on the assigned order number.

  • CP type: CPX ports are increasingly sorted.

  • TUP type: single TCP/UDP ports are increasingly sorted, while TCP/UDP ports ranges are always added at the end of the list.

  • IPT type: Internet protocols are increasingly sorted.

Type: | Item type
none | IN, IS, EC, XN, XU, IP, IR, RU, MR, DN, CP, TUP, IPT

Type of the list that the item belongs to. Consequently this is also the item type.

Value: | Item value
none | See further

Real value of the item. Allowed values for each item depend on the list type.

  • Lists of ISDN numbers: sequences (maximum length 20 characters) are allowed: numeric digits [0 - 9], characters '*' and '?'. The character '*' can be used at the beginning or the end of a sequence, with the meaning of "any digit sequence" (E.g.: '123*' or '321*'). The character '?' can be used within a digit sequence, with the meaning "any digit" (E.g.:'?654' or '1234???').

  • Lists of ISDN sub-addresses: sequences (maximum length 20 characters) are allowed: numeric digits [0 - 9], alphabetical [a - z, A - Z], characters '*' and '?'. The character '*' can be used at the beginning or the end of a sequence, with the meaning of "any digit or letter sequence" (E.g.: '123Abc*' or 'Abc321*'). The character '?' can be used within a digit sequence, with the meaning "any digit or letter" (E.g.:'?654ABC' or '12AA???').

  • Lists of EIR Cluster identifiers : sequences (maximum length 8 characters) are allowed: numeric digits [0 - 9], alphabetical [a - z, A - Z], characters '_' (underscore).

  • Lists of X25 NUA: sequences (maximum length 15 characters) are allowed: numeric digits [0 - 9], characters '*' and '?'. The character '*' can be used at the beginning or the end of a sequence, with the meaning of "any digit sequence" (E.g.: '123*' or '321*'). The character '?' can be used within a digit sequence, with the meaning "any digit" (E.g.:'?654' or '1234???').

  • Lists of X25 User Data fields X25 : sequences (maximum length 12 characters [1]) are allowed: numeric digits [0 - 9], alphabetical [a - z, A - Z], characters '*' and '?'. The character '*' can be used at the beginning or the end of a sequence, with the meaning of "any digit or letter sequence" (E.g.: '123Abc*' or 'Abc321*'). The character '?' can be used within a digit sequence, with the meaning "any digit or letter" (E.g.:'?654ABC' or '12AA???').

  • Lists of IP addresses : IP addresses are allowed in the D.D.N (E.g.:'192.168.00.210').

  • Lists of IP addresses intervals: couples of IP numbers are allowed in the D.D.N. and separated by the character ':' (double colon) (E.g.: '192.168.000.210:192.168.000.250').

  • Lists of Rules: expressions (maximum length 127 characters) are allowed, they contain a set of name of lists types IN, IS, EC, XN, XU, IP, IR, and logical operators AND, OR, NOT, separated by the character '.' (full stop). Spaces are not allowed and there is no distinction between upper case and low case characters (E.g.: 'List1.AND.List2.OR.List3.AND.NOT.List4').

  • Lists of Master Rules: expressions (maximum length 127 characters) are allowed, they contain a set of name of lists types IN, IS, EC, XN, XU, IP, IR, and logical operators AND, OR, NOT, separated by the character '.' (full stop). Spaces are not allowed and there is no distinction between upper case and low case characters (E.g.: 'List1.AND.List2.OR.List3.AND.NOT.List4').

  • Lists of Dialling Numbers: Sequences of four values separated by ',' (comma) are allowed, e.g.: 'o,n,c,r', where: 'o' is the order [1 - 32], 'n' is a dialing number i.e. a sequence of max 20 number, 'c' is the max number of connections [0 - 32], 'r' is the max number of retries [0 - 65534, NOMAX] (E.g.: '2,0376334412,2,5' or '1,4445521,32,NOMAX').

  • Lists of CPX ports: CPX port numbers in the range [0 - 999] are allowed (E.g.:'900' or '301').

  • Lists of TCP/UDP ports: a single TCP or UDP port mnemonic or decimal value in the range [1 - 65535] is allowed or two TCP or UDP ports mnemonic or decimal value in the range [1 - 65535] separated by ':' (colon) (E.g.: '123' or 'telnet' or '1024:65535').

  • Lists of Internet Protocols: Internet protocol mnemonics or decimal values in the range [1 - 254] are allowed (E.g.: 'tcp' or '6').

[1]X25 User Data fields are always handled by the Abilis CPX starting from the 5th byte. The first four bytes are never modified, however if the incoming call contains less than 4 bytes in that field and, according to the SVC routing settings, Abilis CPX has to add User Data starting from the 5th byte, the vacancies will be filled up with the character 00.


Data Compression Protocols

General Considerations
No Compression
MBIT compression protocol
X.25-to-X.25
SDLC-to-X25
HDLC-to-X.25
IP-to-X.25
PAD-to-X.25
QLLC compression protocol
Dictionaries and Memory

General Considerations top

Data compression is a procedure which substitutes long sequences of characters by shorter ones, and is made possible by the presence of information redundancy: the greater, the more efficient will be the compression.

However, even though Abilis CPX is fed with "already compressed" data, situations exist where it is capable of providing even further compression. This is because many other compression methods exist, not all of which achieve the maximum possible level. A very common case is that host computers IBM 370, 390, IBM AS/400 etc., where a compression software can be present, which at application level optimises the exchange of data with terminals and printers: this "compression" procedure is very different from the compression carried out by Abilis CPX, which if used in these cases, can reduce the data transferred even further.

By "Compression protocols" is meant the totality of the measures which Abilis CPX puts into practice, in order to create the block of data to be compressed and transported correctly to the corresponding Abilis CPX, and to restore the information in its original form.

Abilis CPX allows compression to be applied to one single logical channel, sometimes called session. This guarantees the greatest possible flexibility in the application of data compression.

For every protocol the principal characteristics are listed below and we offer some suggestions as to their use.

Warning! The channel/session which transports the compressed data can only use X25 and SDLC ports configured as "NETWORK".

No Compression top

In the configuring of an SVC routing or a PVC connection with the parameter "COMP:NO", the Abilis CPX is instructed to deal with that logical channel without compression, i.e. the data received from the entry port are sent to the exit port without modifications.

MBIT compression protocol top

To activate the MBIT protocol, set up an SVC routing, or a PVC connection with the parameter "COMP:MBIT"

Data Compression X.25-to-X.25

In this case, an X.25 port is used as the "USER" port.

To create the block of data to be compressed, the MBIT protocol utilises a "complete sequence" of X.25 packages, thus obtaining greater compression, both in characters and in segments, than with single packages.

The meaning of "complete sequence" of X.25 packages is defined in recommendation X.25 of the CCITT published in the "Blue Book", and can be summarised as follows: a complete sequence is composed of an X.25 packet with M-bit= 0, preceded by full contiguous packets with M-bit = 1.

In the event that the DTE does not send complete sequences to Abilis, i.e. only sends packets with M-bit = 0, the compression takes place packet by packet, resulting in an unsatisfactory compression.

Data Compression SDLC-to-X25

In this case an SDLC port is utilised as a "USER" port.

The MBIT protocol compresses every SDLC frame separately, therefore the longer the frame, the greater is the efficiency of compression; however, the delay is also increased.

Both the informative and the unnumbered frames are compressed.

Data Compression HDLC-to-X.25

In this case an HDLCT port is used as the "USER " port.

The MBIT protocol compresses every HDLC frame separately, therefore the longer the frame, the greater is the efficiency of compression; however, the delay is also increased.

Data Compression IP-to-X.25

In this case the IPRTR port is used as a "USER" port.

The MBIT protocol compresses every IP datagram separately, therefore the longer the datagram, the greater is the efficiency of the compression; however, the delay is also increased.

Data Compression PAD-to-X.25

In this case a PAD port is used as a "USER" port.

The MBIT protocol compresses every data package created by the PAD separately, therefore the larger the package, the greater is the efficiency of the compression; however, the delay is also increased.

QLLC compression protocol top

The QLLC protocol can be used when one or both sides involved in the data compression use an SDLC/QLLC access to the network.

The compression is carried out exclusively for the informative frames and whenever an unnumbered frame (e.g. XID or QXID, SRNM or QSRNM etc.) is transferred, the dictionary values are cleared.

To activate the QLLC protocol, set out an SVC routing or a PVC connection with the parameter "COMP: QLLC".

Warning! The maximum dimension of the informative frame accepted by the network is to be at least 9/8 of the maximum dimension of the SDLC/QLLC informative frame configured for the user systems.

Dictionaries and Memory top

The selection of compression data requires the installation on the HSCB Gold adaptor of the data compression processor; this processor has the ability to compress data at the speed of approx. 250 Kbytes/sec (2 Mbits/sec) and is equipped with a quantity of RAM memory which goes from 1 to 32 Mbytes.

The quantity of RAM memory installed on the HSBC Gold adaptor determines how many logic channels/sessions can be compressed simultaneously.

It is possible to accommodate 2 x 30 pins SIMM [1] memory modules, therefore by installing 1 or 2 SIMM modules in the sizes available, the following combinations are obtained [2] :

N. | SIMM module | RAM installed | LC compressible
1 | 1 Mbyte | 1 Mbyte | 1 LC
2 | 1 Mbyte | 2 Mbyte | 2 LC
1 | 4 Mbyte | 4 Mbyte | 4 LC
2 | 4 Mbyte | 8 Mbyte | 8 LC
1 | 8 Mbyte | 8 Mbyte | 8 LC
2 | 8 Mbyte | 16 Mbyte | 16 LC
1 | 16 Mbyte | 16 Mbyte | 16 LC
2 | 16 Mbyte | 32 Mbyte | 32 LC

[1] The memory modules must have an access time less than 70 nanoseconds.

[2] The "two SIMMs" configuration have a throughput which is the double of the "one SIMM" configuration.

The compression method used by Abilis CPX makes use of dictionaries holding 512 Kilobytes each, so that the repeated sequences of characters and the, obviously shorter, corresponding codification symbols, are memorised.

Two dictionaries are used for every logical channel: one to compress the data received by the USER port and one to expand the data received by the NETWORK port.

Submitting the command D G, it is possible to visualise how many dictionaries are present (parameter ndict:), how many logical channels can be compressed simultaneously (parameter lccomp:) and the number of dictionaries currently not in use (parameter fdict:).

If for example 32 Mbytes are installed, the result should be the following:

         Conf.Value Act.Value                Description
------------------------------------------------------------------------------
. . .
ndict:         -        64    Number of available dictionaries     <Read Only>
lccomp:        -        32    Max number of compressed LC          <Read Only>
fdict:         -        64    Number of free dictionaries          <Read Only>
------------------------------------------------------------------------------
. . .

Data compression also requires the use of system memory. In case it is not sufficient, there could happen to be a greater number of dictionaries available than those truly usable and the result could be as follows:

         Conf.Value Act.Value                Description

------------------------------------------------------------------------------
. . .
ndict:         -        64    Number of available dictionaries     <Read Only>
lccomp:        -        16    Max number of compressed LC          <Read Only>
fdict:         -        32    Number of free dictionaries          <Read Only>
------------------------------------------------------------------------------
. . .

This is because although Abilis has 32 "pairs" of dictionaries available, it is only able to make use of 16.

Normally Abilis CPX is supplied with 8 or 16 Mbytes of system memory, sufficient to support very complicated configurations. It is however possible to expand the system memory up to 64 Mbytes.

Warning! Dictionaries are cleared with the disconnection of the SVC channel or with the despatch of the Reset packets through the PVC channels. To obtain the maximum output it is advisable to maintain the logic channel open for as long as possible.


The IP ROUTER port (IPRTR)

Revised for CPX 4.5.2.
Configuration of the IP router port
Statistics of the IP router port
Configuration of the IP ports
State and statistics of the ip ports

The IP router port is used within the Abilis CPX to route IP datagrams between LAN and WAN ports, whether they are Ethernet, X.25 ports type or non-X.25 synchronous links. Also the PPP link support is present.

IP datagrams transport over LAN Ethernet or Token Ring is carried out using at the same time the ports IPLAN and ETH, ETH100 or TR, which provide the ARP-RARP (RFC 826) address resolution services and the Media Access Control (MAC).

IP datagrams are transported within X.25 packets according to the RFC 877 standard (fragmentation/defragmentation of IP datagrams into X.25 packets and vice versa) and the typical X.25 network level functionalities are guaranteed:

  • management of bi-directional switched and permanent channels;

  • routing of the X.25 SVC incoming calls;

  • X.25 SVC calls generation;

  • Idle SVC connections can be closed.

IP datagrams are transported over non-X.25 synchronous links by using the SYNC, MLM, ML, Frame-Relay or LAPB ports.

IP datagrams are encapsulated into HDLC, HDLC-CISCO, FR-CISCO, FR-IETF frames by the SYNC, MLM, ML or Frame-Relay ports (it depends on the lower port), while the LAPB ports encapsulate IP datagrams and add the LAPB error recover procedure.

IP datagrams transported over PPP IPPort allow to establish connection between PPP ports using Point-to-point connection.

Finally, there is the possibility to have VIRTUAL IPPorts that allow to have more IPPort on the same physical IPPort (called primary port).

Configuration of the IP ROUTER port top

The IP Router port is labelled within the Abilis CPX by the acronym "IPRTR", it is provided with the parameters described in this section:

Here is an example of the IPRTR port parameters. All of them are DEFAULT values.

[18:45:45] ABILIS_CPX: D P PO:900

PO:900 ------------------------------------------------------------------------
IPRTR  LOG:NO         TYPE:USER       MCAU:NO         ps:2048       DFTTTL:64
       maxroute:500   tracerec:100    R-ID:AUTO (192.168.000.253)   NAT:NO
       ACL:NO         ACLBYPASS:#
       COS:DISABLED   COSDFT:NORMAL   COSBALANCE:NO   NORMRATE:50   LOWRATE:50
       PPP-DNS-PRI:000.000.000.000    PPP-DNS-SEC:000.000.000.000
       DEF-LOCAL-AD:0     DEF-STATIC-AD:1     DEF-OSPF-AD:110   DEF-RIP-AD:120

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the IP ROUTER port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

TYPE: | Port type
USER | USER

This parameter sets how the port behaves if data compression is activated.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user device USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The IPRTR can be only a USER port.

MCAU: | Cause code modification in CLEAR packets sent
NO | NO, YES

It affects only X.25 communications.

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PS: | Maximum IP packet size (bytes)
2048 | 16, 32, 64, 128, 256, 512, 1024, 2048

This parameter affects only X.25 communications, because it sets the maximum X.25 packet size.

DFTTTL: | Default TTL of IP datagrams internally generated
64 | 0 - 255

It sets the default TTL (Time To Live) of IP datagrams internally generated by the Abilis CPX, such as ICMP messages or RIP, UDP, TCP, TELNET, SNMP, SNTP and DNS ports datagrams.

MAXROUTE: | Maximum number of routings in the homonym table
500 | 100 - 10000

It sets the maximum number of routing that the homonym table can store.

If the table will be full, no more routings can be added and an informative message will be shown in the System Log.

TRACEREC: | Maximum number of trace records of the TCP/IP events
100 | 0 - 255

It sets the maximum number of records in the TCP/IP events trace. The trace is handled circularly, that is, once its maximum has been reached, the less recent events are progressively deleted, in order to free place to the more recent ones.

If the parameter is set to 0, the TCP/IP tracing function is not active.

R-ID: | Router ID address
AUTO | 1.x.x.x-126.x.x.x, 128.x.x.x-223.x.x.x

It shows the Router ID address.
AUTO: This value is obtained considering the first IP port of the homonym table, whose address is not 0.0.0.0. This value means that no IP port has got the needed characteristics.

Eventual changes made on the IP ports table will affect this parameter value.

NAT: | NAT IN/OUT side
NO | NO, INSIDE, OUTSIDE

It indicates the side of the IPRTR when remote hosts connects to R-ID IP address.

This information is required by NAT in order to determine if the IP address must be translated or not.

When configured as NO, means that NAT is not configured.
When configured as INSIDE, means that R-ID address in in the INSIDE IPPort.
When configured as OUTSIDE, means that R-ID address in in the OUTSIDE IPPort.

warning! This parameter can be set only when R-ID is not set as AUTO.

ACL: | Activation of the service IP Access List
NO | NO, STD, EXT

It activates the IP Access List service and choose the operating mode.

The service IP access list is a security procedure for filtering traffic in transit to and from Abilis CPX, depending on the address and services requested. Datagrams are filtered according to their header and not to their content. There are two way of filtering:

"STD" (Standard): datagrams are filtered by their source and destination addresses (address filtering);

"EXT" (Extended): datagrams are filtered by their source and destination addresses but also by the internet protocol. For TCP and UDP protocols even the port logic number is checked (that is the service requested).

If this parameter is set to "NO" the service IP access list is disabled.

ACLBYPASS: | IP address passed by the IP Access List service
NO | #, *, 0.0.0.0 - 223.255.255.255

It sets the IP address (source and/or destination) of the IP datagram received that will be managed without considering filters eventually defined in the IP Access List.

The value "#" stands for "no IP address", that is the IP access list service will NOT be applied to any IP datagrams.

The value "*" stands for "any IP address", that is the IP access list service will be applied to any IP datagrams.

COS: | Activation of IP Class of Service
DISABLED | ENABLED, DISABLED

It activates/deactivates the IP classes of service. Class of service is a feature used to assign different priorities to specific paths of IP datagrams.
The assignment of this priority is done by IPRTR upon reception of every IP datagram, using the informations present in the IPACL.

COSDFT: | Class of IP service default value
NORMAL | LOW, NORMAL, HIGH

It sets the Class of IP service default value.

The IP classes of service available are:

Class of service | Meaning
LOW | Class of service "low"
NORMAL | Class of service "normal"
HIGH | Class of service "high"

COSBALANCE: | Activation of the balance service of resources allocated for the IP service classes
NO | NO, YES

It activates/deactivates the balance functionality of the IP classes of service. This procedure provides an acceptable service to each class; by avoiding that higher priority classes are too prevalent respect the lower ones. The user, through the parameters NORMRATE: and LOWRATE:, can set the percentage balance ratio.

NORMRATE: | Balance percentage of resources allocated to the "NORMAL" service class compared with the "HIGH" ones
50 | 0 - 100

It sets the percentage balance ratio between resources allocated for the classes with "NORMAL" priority and the ones with "HIGH" priority.

LOWRATE: | Balance percentage of resources allocated to the "LOW" service class compared with the "NORMAL" ones
50 | 0 - 100

It sets the percentage balance ratio between resources allocated for the classes with "LOW" priority and the ones with "NORMAL" priority.

PPP-DNS-PRI: | Primary DNS provided by local PPPs to remote PPPs
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

it is the IP address of the primary DNS server.
This information is provided by local PPPs to remote PPPs

warning! When set to 0.0.0.0 means that no primary DNS server is present.

PPP-DNS-SEC: | Secondary DNS provided by local PPPs to remote PPPs
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

it is the IP address of the secondary DNS server.
This information is provided by local PPPs to remote PPPs

warning! When set to 0.0.0.0 means that no secondary DNS server is present.

IPR_DEF-LOC-AD: | Default administrative distance for local-connected routes.
0 | 0 - 255

Default administrative distance for local-connected routes.

When IPRTR gets routing from different routings protocol, must give them a specific priority. This is needed because it is possible to have routings gained from different routing protocols, but that are the same (e.g. in case of IPRTR receives the same NET/MASK information from RIP and OSPF).
When this situation occurs, IPRTR will use the routing protocol with the better distance (the lower is the distance, the better is the protocol).
This parameter can be overridden in case of current routing is present into IPRTR administrative distance table.

IPR_DEF-STATIC-AD: | Default administrative distance for static routes.
1 | 0 - 255

Default administrative distance for static routes.

When IPRTR gets routing from different routings protocol, must give them a specific priority. This is needed because it is possible to have routings gained from different routing protocols, but that are the same (e.g. in case of IPRTR receives the same NET/MASK informations from RIP and OSPF).
When this situation occurs, IPRTR will use the routing protocol with the better distance (the lower is the distance, the better is the protocol).
This parameter can be overridden in case of current routing is present into IPRTR administrative distance table.

IPR_DEF-OSPF-AD: | Default administrative distance for OSPF routes.
110 | 0 - 255

Default administrative distance for OSPF routes.

When IPRTR gets routing from different routings protocol, must give them a specific priority. This is needed because it is possible to have routings gained from different routing protocols, but that are the same (e.g. in case of IPRTR receives the same NET/MASK information from RIP and OSPF).
When this situation occurs, IPRTR will use the routing protocol with the better distance (the lower is the distance, the better is the protocol).
This parameter can be overridden in case of current routing is present into IPRTR administrative distance table.

IPR_DEF-RIP-AD: | Default administrative distance for RIP routes.
120 | 0 - 255

Default administrative distance for RIP routes.

When IPRTR gets routing from different routings protocol, must give them a specific priority. This is needed because it is possible to have routings gained from different routing protocols, but that are the same (e.g. in case of IPRTR receives the same NET/MASK in formations from RIP and OSPF).
When this situation occurs, IPRTR will use the routing protocol with the better distance (the lower is the distance, the better is the protocol).
This parameter can be overridden in case of current routing is present into IPRTR administrative distance table.

Statistics of the IPRTR port top

The IPRTR port overall statistics are shown through the command D IPS, while the commands D S and D SE display state and statistics of the IP ports.

Here is how to check the IPRTR port statistics.

[18:45:45] ABILIS_CPX: D IPS

PO:900 ------------------------------------------------------------------------
IPRTR  ROUTINGS TABLE Diagnostics
       -----------|---State---|-Current%--|--Current--|---Peak----|----Max----|
       ROUTINGS   |  OVERFLOW |          2|         50|        100|       2500|
       ------------------------------------------------------------------------
       --- Cleared 000:00:04:41 ago, on 03/12/2002 at 11:23:01 ----------------
       ROUTER Statistics
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       DGM        |1264600    |1224330    |HDR-ERR    |0          |           |
       ADDR-ERR   |0          |           |FRW-DGM    |           |0          |
       UNK-PROT   |0          |           |DISCARDS   |0          |0          |
       LOCAL-DGM  |1264571    |           |NO-ROUT    |           |0          |
       REAS-TOUT  |0          |           |REAS-REQD  |32         |           |
       REAS-OK    |12         |           |REAS-FAIL  |4          |           |
       FRAG-OK    |           |16         |FRAG-FAIL  |           |0          |
       FRAG-CREATE|           |32         |ROUT-DISC  |0          |           |
       ------------------------------------------------------------------------
       ICMP Statistics
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       MSG        |59         |77         |ERR        |0          |           |
       DEST-UNREAC|11         |5          |T-EXCEED   |27         |0          |
       PARM-PROB  |0          |0          |SRC-QUENCH |0          |0          |
       REDIRECT   |0          |0          |ECHO       |13         |59         |
       ECHO-REP   |8          |13         |TSTAMP     |0          |0          |
       TSTAMP-REP |0          |0          |ADMASK     |0          |0          |
       ADMASK-REP |0          |0          |
       ------------------------------------------------------------------------

IPRTR port statistics are divided into three groups: one dedicated to the ROUTING table diagnostics, one to IP Router statistics, the other one to the ICMP statistics.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the ROUTING table diagnostic

State: | State of the ROUTING table.
 | NORMAL, WARNING, DANGER, OVERFLOW

Indicates the state of the routing table, depending on the number of routings present into table.

Possible routing table states are:

  • NORMAL (routings used are less than 60%).
  • WARNING (routings used went over 60%. A DANGER_IN message will be written in the system LOG. To go back to normal, routings must decrease to 55%).
  • DANGER (routings used went over 80%. To go back to warning, routings must decrease to 75%. A DANGER_OUT message will be written in the system LOG).
  • OVERFLOW (routings used reached 100%. An OVERFLOW message will be written in the system LOG).
Current%: | Current routing percentage.
 | 0 - 100

Indicates the current PERCENTAGE of routings present into routing table.

Current: | Current routing number.
 | 0 - MAXROUTE

Indicates the current NUMBER of routings present into routing table.

Peak: | Maximum routing peak.
 | 0 - MAXROUTE

Indicates the maximum number of routings reached from start-up into table.

Max: | Maximum number of routings present into table.
 | MAXROUTE

This information indicate the MAXROUTE parameter present into IPRTR port.

Detail of the statistics fields of the IP Router

DGM: | Number of IP datagrams sent/received
 | 0 - 4.294.967.295

The counter DGM (INPUT) is incremented every time an IP datagram is received, while the DGM (OUTPUT) one every time an IP datagram is sent.

HDR-ERR: | Number of IP datagrams discarded due to header errors
 | 0 - 4.294.967.295

The counter HDR-ERR (INPUT) is incremented every time an IP datagram is received, but it has an error in its header (Bad Checksum and/or elapsed TTL and/or wrong version and/or etc.).

ADDR-ERR: | Number of IP datagrams discarded due to wrong destination address
 | 0 - 4.294.967.295

The counter ADDR-ERR (INPUT) is incremented every time an IP datagram, whose destination address is not valid, is received.

FRW-DGM: | Number of IP datagrams received and forwarded
 | 0 - 4.294.967.295

The counter FRW-DGM (OUTPUT) is incremented every time an IP datagram is received and forwarded to the IP port, where it can be immediately transmitted or queued.

UNK-PROT: | Number of IP datagrams discarded due to unknown protocol value
 | 0 - 4.294.967.295

The counter UNK-PROT (INPUT) is incremented every time an IP datagram, whose protocol value is unknown, is received.

DISCARDS: | Number of IP datagrams discarded because of the absence of free buffers
 | 0 - 4.294.967.295

The counter DISCARDS (INPUT) is incremented every time an IP datagram is discarded owing to the absence of free buffers.

LOCAL-DGM: | Number of IP datagrams really delivered to the proper driver
 | 0 - 4.294.967.295

The counter DELIVERS (INPUT) is incremented every time an IP datagram is really delivered to a X.25 channels, a "LAN" or "LINK" port.

NO-ROUT: | Number of IP datagrams discarded because the proper routing IP was missing
 | 0 - 4.294.967.295

The counter NO-ROUT (INPUT) is incremented every time an IP datagram is discarded because the proper IP routing was missing.

REAS-TOUT: | Number of times that the IP fragments reassembling timeout ran over
 | 0 - 4.294.967.295

The counter REAS-TOUT (INPUT) shows how many times the IP fragment reassembling procedure was aborted. The already received fragments are lost because the waiting timeout of the missing ones ran over.

REAS-REQD: | Number of IP fragments received
 | 0 - 4.294.967.295

The counter REAS-REQD (INPUT) shows the number of IP fragments received.

REAS-OK: | Number of IP datagrams reassembled
 | 0 - 4.294.967.295

The counter REAS-OK (INPUT) is incremented every time an IP datagram is correctly reassembled.

REAS-FAIL: | Number of IP datagrams "reassembling" failed
 | 0 - 4.294.967.295

The counter REAS-FAIL (INPUT) is incremented every time an error occurs during an IP datagram reassembling.

FRAG-OK: | Number of IP datagrams fragmented
 | 0 - 4.294.967.295

The counter FRAG-OK (OUTPUT) is incremented every time an IP datagram is correctly fragmented.

FRAG-FAIL: | Number of IP datagrams not fragmented
 | 0 - 4.294.967.295

The counter FRAG-FAIL (OUTPUT) is incremented every time an IP datagram has not been fragmented because the flag "don't fragment" was set.

FRAG-CREATE: | Number of IP fragments created
 | 0 - 4.294.967.295

The counter FRAG-CREATE (OUTPUT) shows the number of IP fragments created by the fragmentation.

ROUT-DISC: | Number of IP routings discarded
 | 0 - 4.294.967.295

The counter ROUT-DISC (INPUT) is incremented every time the IP routing is discarded.

Detail of the statistics fields of the ICMP

MSG: | Number of ICMP messages sent/received
 | 0 - 4.294.967.295

The counter MSG (INPUT) is incremented every time an ICMP message is received, while the MSG (OUTPUT) every time it is sent.

ERR: | Number of bad ICMP messages received
 | 0 - 4.294.967.295

The counter ERR (INPUT) is incremented every time a bad ICMP message is received (i.e. bad Checksum field).

DEST-UNREAC: | Number of "Unreachable destination" ICMP messages
 | 0 - 4.294.967.295

The counter DEST-UNRICH (INPUT) is incremented every time an "Unreachable destination" ICMP message is received, while the DEST-UNRINCH (OUTPUT) one every time it is sent.

T-EXCEED: | Number of "Time Exceeded" ICMP messages
 | 0 - 4.294.967.295

The counter T-EXCEED (INPUT) is incremented every time a "Time Exceeded" ICMP message is received, while the T-EXCEED (OUTPUT) one every time it is sent.

PARM-PROB: | Number of "Parameter Problem" ICMP messages
 | 0 - 4.294.967.295

The counter PARM-PROB (INPUT) is incremented every time a "Parameter Problem" ICMP message is received, while the PARM-PROB (OUTPUT) one every time it is sent.

SRC-QUENCH: | Number of "Source Quench" ICMP messages
 | 0 - 4.294.967.295

The counter SRC-QUENCH (INPUT) is incremented every time a "Source Quench" ICMP message is received, while the SRC-QUENCH (OUTPUT) one every time it is sent.

REDIRECT: | Number of "Redirect" ICMP messages
 | 0 - 4.294.967.295

The counter REDIRECT (INPUT) is incremented every time a "Redirect" ICMP message is received, while the REDIRECT (OUTPUT) one every time it is sent.

ECHO: | Number of "Echo Request" ICMP messages
 | 0 - 4.294.967.295

The counter ECHO (INPUT) is incremented every time a "Echo Request" ICMP message is received, while the ECHO (OUTPUT) one every time it is sent.

ECHO-REP: | Number of "Echo Reply" ICMP messages
 | 0 - 4.294.967.295

The counter ECHO-REP (INPUT) is incremented every time a "Echo Reply" ICMP message is received, while the ECHO-REP (OUTPUT) one every time it is sent.

TSTAMP: | Number of "Timestamp Request" ICMP messages
 | 0 - 4.294.967.295

The counter TSTAMP (INPUT) is incremented every time a "Timestamp Request" ICMP message is received, while the TSTAMP (OUTPUT) one every time it is sent.

TSTAMP-REP: | Number of "Timestamp Reply" ICMP messages
 | 0 - 4.294.967.295

The counter TSTAMP-REP (INPUT) is incremented every time a "Timestamp Reply" ICMP message is received, while the TSTAMP-REP (OUTPUT) one every time it is sent.

ADMASK: | Number of "Address mask Request" ICMP messages
 | 0 - 4.294.967.295

The counter ADMASK (INPUT) is incremented every time a "Address mask Request" ICMP message is received, while the ADMASK (OUTPUT) one every time it is sent.

ADMASK-REP: | Number of "Address mask Reply" ICMP messages
 | 0 - 4.294.967.295

The counter ADMASK -REP (INPUT) is incremented every time a "Address mask Reply" ICMP message is received, while the ADMASK -REP (OUTPUT) one every time it is sent.

Configuration of the IP port top

The IP Router of Abilis CPX can manage up to 64 IP ports (LAN, PPP, VIRTUAL, X.25 logical channels and non-X.25 synchronous ports).

To each IP port correspond a different destination, a remote router or LAN: a transmission queue, whose size is set by the OUTBUF parameter, is dedicated to each of them. Parameters of each IP port can be separately configured depending of the connection.

IP port configuration is also made through a table, called IP ports table, where the configuration parameters of each port are stored.

The IP port table can me modified while the Abilis is working, however only some parameters changes can be immediately activated through the command INIT IPP, the rest needs the Abilis CPX to be restarted.

All the commands for managing the IP ports are described in the section IP Ports of the chapter Commands related to the IP Router. The available commands are:

A IPP
C IPP
D IPP
S IPP

Here is an example on how to show all the IP ports, whose identifiers do not have to be mandatory sequential. Values for ports from 0 to 4 are examples of primary ports, while port 10 is a virtual port that has port 0 as its primary port.
The parameters values of port 63 are the default ones given by the command A IPP.

[16:20:42] ABILIS_CPX:d ipp

IPRTR (PO:900) parameters:  R-ID:AUTO (010.000.000.001)

IPP:0  - Verso_router_a_Milano:10.0.0.50/32 -----------------------------------
ACT    IPADD:010.000.000.001                       MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LAN            REDIS:YES             RP:NO
       BRD:NET               LOWPO:155   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:YES        LOSPEED:128           HISPEED:10000

IPP:1  ------------------------------------------------------------------------
ACT    IPADD:192.168.001.200 NEIGH:000.000.000.000 MTU:1500       FRAG:FRF12
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50      FRAGSIZE:128
       IFTYPE:LINK           REDIS:YES             RP:NO
       ENC:RAW-IP            LOWPO:1     HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO

IPP:2  ------------------------------------------------------------------------
ACT    IPADD:192.168.002.200 NEIGH:000.000.000.000 MTU:1500
                             NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:PPP            REDIS:YES             RP:NO
                             LOWPO:541   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO

IPP:3  ------------------------------------------------------------------------
ACT    IPADD:192.168.003.200 NEIGH:000.000.000.000 MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:X25BSVC        REDIS:YES             RP:NO
       CDI:NO                            HIDE:NO   FAIRQUEUE:YES
       CDO:NO                DT:0        TB:6      RTY:INC        NRTY:NOMAX

IPP:4  ------------------------------------------------------------------------
ACT    IPADD:192.168.004.200 NEIGH:000.000.000.000 MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:X25PVC         REDIS:YES             RP:NO
       PVC:NONE                          HIDE:NO   FAIRQUEUE:YES

IPP:5  ------------------------------------------------------------------------
ACT    IPADD:192.168.005.200 NEIGH:000.000.000.000 MTU:1500       FRAG:NO
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NO
       ENC:FR-IETF           LOWPO:101   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO

IPP:6  ------------------------------------------------------------------------
ACT    IPADD:192.168.006.200 NEIGH:000.000.000.000 MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NO
       ENC:FR-CISCO          LOWPO:102   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       KEEPALIVE:YES         KA-DELAY:10           KA-LIMIT:6

IPP:7  ------------------------------------------------------------------------
ACT    IPADD:192.168.007.200 NEIGH:000.000.000.000 MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NO
       ENC:HDLC-CISCO        LOWPO:2     HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       KEEPALIVE:NO

IPP:10 ------------------------------------------------------------------------
ACT    IPADD:192.168.010.200
       MASK :255.255.255.000
       IFTYPE:VIRTUAL        REDIS:YES             RP:NO
       BRD:NET               P-IPP:0     HIDE:NO

IPP:62 ------------------------------------------------------------------------
ACT    IPADD:192.168.062.200                       MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LAN            REDIS:YES             RP:RIP,OSPF
       BRD:NET               LOWPO:NONE  HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - RIP section ----------------------------------------------------------
       RIPSEND:RIP2B    RIPRECV:BOTH     RIPNU:YES    RIPMETRIC:1
       - OSPF section ---------------------------------------------------------
       OAREA:#                   ONETTYPE:BN     OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

IPP:63 ------------------------------------------------------------------------
NEW    IPADD:000.000.000.000 NEIGH:000.000.000.000 MTU:1500       FRAG:NO
       MASK :255.255.255.255 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NONE
       ENC:RAW-IP            LOWPO:NONE  HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO

[16:20:46] ABILIS_CPX:

As the example shows, for each IP port is also displayed its eventual description. If IP ports of type "LAN", "LINK" and "PPP" has not a specific description and their lower level port have it, this last one will be displayed.

Detail of the IP port parameters

IPP: | IP port identifier
none | from 0 up to 63

This identifier is used into IP routings to refer to the same port.

It can also be used to refer to the port during configurating operation of the IP ports table.

As it can be seen from the example, the IP ports table can contain "empty places" and it never get compacted. A new IP port can be added only if its ID is not already in use.

When the IPRTR port receives a X.25 SVC call, coming from the Connection Oriented Router (COR), the search of the port matching the content of the "Calling address" field starts from port 0. Therefore if one or more IP ports match the incoming call, the call will be forwarded to the port with the smallest ID value.

In order to avoid unexpected behaviours, mainly due to inconsistencies between the addresses of the IP networks linked, it is absolutely necessary to avoid these situations of ambiguity.

IPP STATUS | Status of the IPPort
none | ACT, NEW

It indicates if the IPP is currently active or not.
When set to ACT, means that IPP was already present when CPX booted.
When set to NEW, means that IPP is simply added in configuration, but IPP cannot be used.

warning! To make IPP status from NET to ACT, a CPX reboot is reaquired.

IPADD: | IP address of the IP port
000.000.000.000 | (see following table)

It sets the IP address of the port. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of D class and class E and are not currently supported.

For IP ports of type WAN ("LINK", "X25BSVC", "X25PVC"), is possible to avoid the assignment of an IP address leaving setting the value to 0.0.0.0. In this case, the obtained configurations are known as "half-router" where WAN unnumbered links are used.

In the configurations of WAN unnumbered links, the possibilities of using the RIP protocol are limited and sometime is not possible at all. For the complete understanding of thematic related to the use of protocols of dynamic routing such as RIP, refer to the relative banns of the IETF, that is to the RFC (Request for Comment).

MASK: | Mask relative of the IP port
255.255.255.255 | 0 - 255.255.255.255

It establishes the mask to be used by IP port.

In case of a "LAN" port, the mask MUST absolutely coincide with the value of the mask used by all the LAN stations. Parameter "MASK:" it can be only set to values that contain a consecutive sequence of bit set to 1, estimated starting from the more meaningful bit to the less meaningful one.

By doing the "logical And" between the value contained in parameter "MASK:" with the value contained in parameter IPADD: we have the value of the network associated to IP port, and will be the value exported like NET in the routing table, obviously if parameter REDIS: is set to "YES".

warning! Abilis CPX executes a validity check for the networks identified with parameters IPADD: and MASK: of IP ports, that is the networks must be different and not overlapped.

IFTYPE: | Connection type
X25BSVC | X25PVC, X25BSVC, LINK, LAN, PPP, VIRTUAL

It sets the connection type.

Value | Description
X25PVC | Permanent X.25 connection.
X25BSVC | Switched X.25 connection.
LINK | non-X.25 synchronous link, which uses the ports type SYNC, MLM, ML, LAPB or FR.
LAN | Ethernet link type, Fast Ethernet or Token Ring, used by the port type IPLAN.
PPP | PPP point to point protocol.
VIRTUAL | The use of virtual enables the possibility to simulate more IPPorst with different network addresses on the same primary IPPort.

LOWPO: | Number of the lower level port (only if IFTYPE:LAN/LINK/PPP)
NONE | 0 - 999, NONE

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "LINK", "PPP" or "LAN", because in these case the lower level port is specified.

If the connection type is "LINK", the lower level CPX port type can only be SYNC, MLM, ML, LAPB or FR.

If the connection type is "PPP", the lower level CPX port type can only be PPP.

IF the connection type is "LAN", the lower level CPX port type can only be IPLAN.

PVC: | Identifier of the permanent channel (only if IFTYPE:X25PVC)
NONE | 1 - 255, NONE

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25PVC", because in this case the PVC connection identifier is specified.

NEIGH: | ID Address (only if IFTYPE:X25BSVC/X25PVC/LINK/PPP)
000.000.000.000 | 0 - 255.255.255.254

The parameter is visualized and configurable only if the connection type set in the parameter IFTYPE: is "LINK", "PPP" or "X25BSVC" or "X25PVC", because the IP address of the neighbour router is specified.

The value of "NEIGH:" must be set to the value "router-id" of the neighbour router and, at the same time, the parameter MASK: must correspond to the mask used by network containing the "router-id".

In order to use protocol RIP with unnumbered links, that is if parameter IPADD: of the port in object is set to 0.0.0.0., this parameter must correctly set.

If numbered links are used (IPADD: not 0.0.0.0.), the value of parameter "NEIGH:" can be 0.0.0.0. or it must be a valid address for the network identified by IPAPP and MASK.

If unnumbered links are used (IPADD:0.0.0.0) without the protocol RIP, the value of "NEIGH:" it can be 0.0.0.0.

MTU: | Maximum size of the IP datagram
1500 | 320 - 1500

It sets the maximum size of the IP datagram that can be sent without fragmentation.

OUTBUF: | Number of available buffers in the transmission queue
50 | 1 - 255

It shows the number of buffers available in the transmission queue. Every buffer can contain only one IP datagram.

The default value is a good trade-off between buffering ability and the maximum delays permissible for an efficient communication; normally it is not necessary to modify it.

For the complete understanding of thematic related to buffering and the delays refer to the relative banns of the IETF, that is to the RFC (Request for Comment).

FRAG: | Fragmentation mode (only if IFTYPE:LINK)
NO | NO, FRF12, ABILIS

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "LINK", because in these cases it is possible to select and apply datagrams fragmentation.

FRAGSIZE: | Maximum size of a frame fragment (only if IFTYPE:LINK and FRAG:FRF12/ABILIS)
128 | 32 - 1500 (in bytes)

It sets Maximum size of a frame fragment generated during the fragmentation procedure.

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "LINK", and if the parameter FRAG: is set to "FRF12" or "ABILIS".

REDIS: | Enabling creation of a "connected" routing (redistribute)
YES | NO, YES

If it is set to "YES", the IP port will automatically add a new routing (connected type) to the IP routing table. The values NET:, MASK:, METRIC: and IPP: of routing will be obtained from the IP port configuration, particularly the NET: field of the routing will be obtained doing the "local And" between the current values of parameters IPADD: and MASK: of the IP port.

If the parameter is set to "NO" the connected routing won't be created.

HIDE: | Hide the connected routing in the RIP updates
YES | NO, YES

It sets whether the connected routing has to be hidden to the other routers during RIP updating.

If the parameter is set to "NO", the routing will be insert in the RIP updates sent to other router, otherwise it won't be inserted.

BRD: | Generation mode of Broadcast over LAN (only if IFTYPE:LAN)
NET | NO, NET, LAN

IP networks support two kind of broadcast:

  • limited, -1 (255.255.255.255);

  • direct, <net><-1> (ex 192.168.0.255 in case that MASK:255.255.255.0).

For both type the Abilis CPX doesn't route, as the RFC 1812 requires. However it is possible that Abilis CPX has to send broadcast datagram on IP port in the following cases:

  • internally generated by "local protocols", such as RIP.

  • datagram received from others and it could not be identified as broadcast until it reached its destination. This situation usually happens when dealing with sub-networks.

The parameter "BRD:" set how the Abilis CPX behaves during broadcast transmission:

Value | Meaning
NO | eventual datagrams are discarded;
NET | broadcasts are sent as "directs", <net><-1> (i.g. 192.168.0.255);
LAN | broadcasts are sent as "limited", 255.255.255.255;

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "LAN".

FAIRQUEUE: | Activation of the "fair queuing" function
YES | NO, YES

It activates the functionality of balancing the traffic queues according to the modality "fair queuing".
Priority is divided in 3 classes: HIGH, NORMAL, LOW. For more details see IP classes of service.

CDI: | X.25 called address of the incoming call (only if IFTYPE:X25BSVC)
NO | from 1 up to 15 decimal digits, *, NO

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It specifies the X.25 called address of the incoming call must have to be accepted by the IP port in object.

  • if the parameter is set to "NO", the IP port do not accept any incoming call.

  • if it contains only the character "*", the X.25 called address of the incoming call can have any value.

  • if it contains a numeric value, the X.25 called address of the incoming call must match this value.

The character "*" can be used as well as a prefix of a sequence of digits with the meaning of " any number of digits and any sequence". The character "*" cannot be used inside or at the end of a sequence of digits. For example "123*" and "12*123" are not allowed.

CDO: | X.25 called address of the outgoing call (only if IFTYPE:X25BSVC)
NO | from 1 up to 15 decimal digits, NO

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It specifies the X.25 called address of the outgoing call.

  • if the parameter is set to "NO", the IP port do not make outgoing call.

  • if it contains a numeric value, the X.25 called address of the outgoing call will correspond to this value.

DT: | Idle timeout (only if IFTYPE:X25BSVC)
0 | from 0 up to 255 (seconds)

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It specifies the maximum idle time interval after which the connection will be teared down:

  • if the parameter is set to 0, the BSVC connection stays on.

  • if the parameter is set to a value higher than 0, the BSVC connection will be teared down after DT seconds from the last received/sent datagram.

TB: | Interval of call repetition (only if IFTYPE:X25BSVC)
6 | from 6 up to 255 (seconds)

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It sets the minimal time interval to wait between the failed call attempt and the next try.

RTY: | Call retry mode (only if TYPE:X25BSVC)
INC | LIN, INC

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It sets the call retry mode:

Value | Meaning
LIN | Time interval to be waited between a call attempt and the next one is constant and configurable through the parameter TB:
INC | Time interval to be waited between a call attempt and the next one is doubled at every try starting from the one set in the parameter IPP_TB:

"#TB"
NRTY: | Maximum number of call retries (only if IFTYPE:X25BSVC)
1 | 0 - 65534, NOMAX

The parameter is displayed and configurable only if the connection type currently set in the parameter IFTYPE: is "X25BSVC".

It sets the maximum number of call retries:

  • if the parameter is set to 0, no calls are placed.

  • if the parameter is set to NOMAX, calls are repeated indefinitely.

  • if the parameter is set to a value higher than 0, once the this value run over, the BSVC connection will reach the state X25WAITING.

NAT: | NAT activation
NO | NO, INSIDE, OUTSIDE

Indicates if NAT is activated on this IPPort, and in which side this IPPort is set.
NAT side information is strictly needed, because is used by NAT to determine the type of IP address conversion that should be made on the INCOMING/OUTGOING IP datagram passing throught this interface.
When NAT is set as INSIDE, means that this IPPort is connected with an INSIDE network.
When NAT is set as OUTSIDE, means that this IPPort is connected with an OUTSIDE network.

warning! In case of NAT port is not active, this parameter is not used by IPRTR.

SRCV: | Source address validate
NO | YES, NO

Used to activate IP address source checking.
When this parameter is activated, IPRTR checks into its internal routing table, if it has a valid routing to reach the sender of the IP datagram being checked.

warning! If a routing to reach the sender host is present in IP routing table, but the outgoing IPPort is different from the IPPort that received the datagram, IPRTR consider source validate check as a failure, and datagram is discarded.

SPEEDLIMIT: | Speed limitation activation
NO | YES, NO

Used to activate/deactivate speed limitation.
Speed limit is a feature that allows IPRTR to reduce the rate of its outgoing datagrams on a specific IPPort.
The reason of this limitation could happen because IPRTR can be used as a gateway into a LAN that allow an Internet access to the hosts present on this LAN. Could happen that IPRTR is connected to the Internet passing through another gateway that is connected with CPX by LAN. This could cause that CPX's IPRTR sends datagrams to the gateway directly connected to the Internet using LAN bandwidth, without considering that the gateway is connected to the Internet using a slower line. In this situation the gateway could fill all its outgoing buffers and discard some datagrams.
With SPEEDLIMIT solution, we can force IPPort to limit it is transfer rate to the bandwidth of the line between gateway connected to the Internet and the ISP, in order to avoid this lost datagrams.
In this way we have a direct control on IPPort's outgoing buffers, and eventually, increase their number as required.

LOSPEED: | Lower limitation speed (Only for SPEEDLIMIT:YES)
128 | 64 - 100000 (KBit/sec)

Speed of next interface (KByte/sec). This speed is the bandwidth to reduce the IPPort interface where IPRTR is going to send datagrams.

HISPEED: | Higher limitation speed (Only for SPEEDLIMIT:YES)
10000 | 64 - 100000 (KBit/sec)

Current speed of IPPort interface (KByte/sec). This speed is the real bandwidth of the IPPort interface where IPRTR is going to send datagrams.

ENC: | Encapsulation type (Only for IFTYPE:LINK)
RAW-IP | RAW-IP, FR-IETF, FR-CISCO, HDLC-CISCO

Indicates the type of encapsulation of the IPPort. Possible values are:

  • RAW-IP: datagrams are sent as IP datagrams, without encapsulation.

  • FR-IETF: datagrams are encapsulated into standard IETF Frame-Relay (0x03CC).

  • FR-CISCO: datagrams are encapsulated into CISCO Frame-Relay protocol.

  • HDLC-CISCO: datagrams are encapsulated into CISCO HDLC protocol.

KEEPALIVE: | Keep-Alive activation (only for IFTYPE:LINK and ENC:FR-CISCO/HDLC-CISCO)
NO | YES, NO

Keep Alive activation. It is used to indicate that Keep-alive feature is active on this IPPort.
This parameter is used by IPRTR only if the encapsulation type is CISCO (FR or HDLC, see ENC: parameter for more details).

KA-DELAY: | Keep-Alive delay (Only for KEEPALIVE:YES)
10 | 10 - 240 (seconds)

CISCO Keep Alive interval. Is the interval to wait after a Keep-Alive requests before submitting next request.
If in this interval, an answer from remote host is received, previous request is considered successfull.
If no answers arrives in this interval, the keep-alive counter for LINK-DOWN is increased. After consecutive KA-LIMIT failures, IPPort state is set to DOWN.

KA-LIMIT: | Keep-Alive limit (Only for KEEPALIVE:YES)
6 | 3 - 100

CISCO Max Alive Count value. When IPPort state is UP, it indicates the number of consecutive failure attempts before considering link as DOWN.
This parameter is also used to indicate the number of consecutive successful attempts before considering link as UP when IPPort was previously DOWN.

P-IPP: | Primary IP port (only for IFTYPE:VIRTUAL)
NONE | NONE, 0 - 63

Primary IPPort number in case of virtual port. When we create an IPPort with IFTYPE:VIRTUAL, we have to indicate also which is the primary IPPort used. This information will be used by IPRTR when has to forward datagrams on the virtual IPPort.

RP: | Indicates routing protocol that runs on this interface.
NO | NO, RIP, OSPF

This parameter is used to activade/deactivate routing protocols on this interface.
It is bitmapped and means that it can contain "NO", "RIP", "OSPF" settings and also "RIP,OSPF" together.
When RIP or OSPF protocol will be selected, the specific parameter section will be activated.

METRIC: | Assigned metrics
1 | 1 - 16

It sets the metric associated to IP port according to meant and the rules prescribed by the routing algorithm RIP.

The metric is a general concept related to the IP routing. For its complete understanding refer to the relative banns of the IETF, that is to the RFC (Request for Comment).

Generally in the context of IP routing, it represents the number of hops that the packet must cross in order to reach the destination network, reason for which the corrected minimal value is 1.

To the aim to process a specific strategy of routing preferences, it remains however the possibility to assign to IP ports an arbitrary metric.

Even if it is possible to assign metric 0, such assignment must be ABSOLUTELY avoided because it can cause problems with protocol RIP.

If in the network is present a router on which the protocol RIP is active, whose table contains a routing with metric 0, it is opportune to correct the value or to deactivate the RIP.

RIPSEND: | Protocol used for sending RIP updates
RIP2B | RIP1, RIP2B, RIP2M, NO

It sets the protocol used for sending RIP updates.

Value | Meaning
RIP1 | RIP version 1. RIP V1 do not support sub-networks
RIP2B | RIP version 2 through Ethernet broadcast frames
RIP2M | RIP version 2 through Ethernet multicast frames; actually not supported
NO | NO RIP updates are sent

RIPRECV: | Protocol accepted for receiving RIP updates
BOTH | RIP1, RIP2, BOTH, NO

It sets the protocol accepted for receiving RIP updates.

Value | Meaning
RIP1 | only RIPV1 updates are accepted
RIP2 | only RIPV2 updates are accepted
BOTH | both RIPV1 and RIPV2 updates are accepted
NO | RIP updates eventually accepted are ignored

RIPNU: | RIP normal update
YES | NO, YES

It sets whether RIP updates have to be sent regularly or only in case of variations.

If the parameter is set to "NO", updates are sent only if the routing table is changed, otherwise they are sent regularly according to the RIP port.

OAREA: | Area ID which this IPP belongs to.
# | 0 - 255.255.255.255, #

Setting the value "#" indicates that there is no AREA configured. Setting a value between 0.0.0.0 and 255.255.255.255, will make the following options:

  • if the specified Area Id value is present into OSPF area table cnfg will save it as a "valid" value.
  • if the specified Area Id value is NOT present into OSPF area table cnfg will NOT save it and will output the message "AREA xxx.xxx.xxx.xxx not defined". The setting fails.
ONETTYPE: | Type of network.
BN | BN, NBMA, PP, PMP, UPP

Indicates to OSPF protocol which type of network has the interface.

Defines the type of the connected network from the following range:

  • BN - broadcast network.
  • NBMA - non-broadcast network yet still multi-access.
  • PP - point-to-point.
  • PMP - Point-to-multipoint networks.
  • UPP - unnumbered point-to-point.

The values is cross-checked with IPP_IFTYPE:

IPP_IFTYPE | IPP_OSPF_NETTYPE
LAN | BN, NBMA, PP, PMP
X25PVC | PP, UPP
X25BSVC | PP, UPP
LINK | PP, UPP
PPP | PP, UPP
VIRTUAL | PP, UPP or BN, NBMA, PP, PMP depending on the IFTYPE of the PRI-IPP

Config executes cross-check between iftype and nettype to guarantee that the above table is satisfied.

When changes occur to IFTYPE, the NETTYPE is immediately verified and, if the current NETTYPE value is not acceptable, config will force it to the valid default value, which is:

  • BN for LAN, and for VIRTUAL whose PRI-IPP is LAN.
  • PP for PPP/LINK/X25xxx, and for VIRTUAL whose PRI-IPP is PPP/LINK/X25xxx.
OPRIO: | Interface priority.
0 | 0 - 255

When two routers attached to a network both attempt to become Designated Router, the one with the highest Interface Priority takes precedence. If there is still a tie, the router with the highest Router ID takes precedence.
A router whose Interface Priority is set to 0 is ineligible to become Designated Router on the attached network. Interface Priority is only configured for interfaces to multi-access networks. A router whose Interface Priority is set to 0 is ineligible to become Designated Router on the attached network.

OCOST: | OSPF output cost.
1 | 1 - 65535

The cost of sending a data packet on the interface, expressed in the link state metric. This is advertised as the link cost for this interface in the router links (RL LSA) advertisement. The cost of an interface must be greater than zero.

ORXMT: | Retransmission interval.
5 | 1 - 150

The number of seconds between link state advertisement retransmissions, for adjacencies belonging to this interface. Also used when retransmitting Database Description and Link State Request Packets. This should be well over the expected round-trip delay between any two routers on the attached network. The setting of this value should be conservative or needless retransmissions will result. It will need to be larger on low speed serial lines and virtual links.

OTRDEL: | Transmit delay interval.
1 | 1 - 30

The estimated number of seconds it takes to transmit a Link State Update Packet over this interface. Link state advertisements contained in the update packet must have their age incremented by this amount before transmission. This value should take into account the transmission and propagation delays of the interface.

OHELLO: | Hello interval.
10 | 1 - 120

The length of time, in seconds, between the Hello Packets that the router sends on the interface. This value is advertised in the router's Hello Packets. It must be the same for all routers attached to a common network. The smaller the Hello Interval, the faster topological changes will be detected, but more OSPF routing protocol traffic will ensue. Sample value for a X.25 PDN network: 30 seconds. Sample value for a local area network: 10 seconds.

The value of this parameter must be less than a value of the ODEAD interval.
We recommend you to use relation 1 to 6-10 (6-10 HELLO intervals are equal to ODEAD interval).

ODEAD: | Router dead interval.
60 | 1 - 1200

After ceasing to hear a router's Hello Packets, the number of seconds before its neighbors declare the router down. This is also advertised in the router's Hello Packets in their Router Dead Interval field. This value again must be the same for all routers attached to a common network.

This should be some multiple of the HELLO interval (say 6-10 times).

OMAX-NEI: | Maximum number of neighbours for the interface.
5 | 1 - 255

Maximum OSPF neighbours for the interface. This parameter is visible only for LAN interfaces (IFTYPE:LAN).
This value must be set equal or greater than the sum of neighbours configured in the OSPF neighbours table and the neighbours detected by the Hello protocol.
For interfaces with a "not-LAN" IFTYPE (e.g. IFTYPE:LINK,PPP,X25) OMAX-NEI is forced to 1 and hidden from configuration.

If IFTYPE is changed from LAN to "not-LAN", the OMAX-NEI value will be automatically hidden and internally forced to 1. At the opposite (from not-LAN to LAN), the OMAX-NEI value will be displayed and set with the default value of 5, which can be later changed as desired.

Each neighbour needs about 50 kbytes of the system RAM! Don't set unnecessary high values.

State and statistics of the IP ports top

As it was already mentioned, the commands D S and D SE of the IPRTR shows state and statistics of the IP port. The same visualization will be obtained by executing the command D S IPP. Here is an example on how to check state and statistics of the IP ports.

[18:45:45] ABILIS_CPX: D S IPP

PO:900 ------------------------------------------------------------------------
IPRTR  IPP:0  -----------------------------------------------------------------
              IFTYPE:LAN                     LOWPO:155    STATE:LINKREADY
       IPP:1  -----------------------------------------------------------------
              IFTYPE:LINK     ENC:RAW-IP     LOWPO:1      STATE:LINKREADY
       IPP:2  -----------------------------------------------------------------
              IFTYPE:PPP      ENC:NONE       LOWPO:541    STATE:LINKREADY
       IPP:3  -----------------------------------------------------------------
              IFTYPE:X25BSVC  CDI:2376003115              STATE:X25READY
                              CDO:23760031
       IPP:4  -----------------------------------------------------------------
              IFTYPE:X25PVC   PVC:NONE                    STATE:X25READY
       IPP:5  -----------------------------------------------------------------
              IFTYPE:LINK     ENC:FR-IETF    LOWPO:101    STATE:LINKREADY
       IPP:6  -----------------------------------------------------------------
              IFTYPE:LINK     ENC:FR-CISCO   LOWPO:102    STATE:LINKDOWN
       IPP:7  -----------------------------------------------------------------
              IFTYPE:LINK     ENC:HDLC-CISCO LOWPO:2      STATE:LINKREADY
       IPP:10 -----------------------------------------------------------------
              IFTYPE:VIRTUAL                 P-IPP:0      STATE:LINKREADY
       IPP:63 -----------------------------------------------------------------
              IFTYPE:LINK     ENC:RAW-IP     LOWPO:NONE   STATE:LINKNOTPRESENT

Extended statistics are available for IP ports too. Here is an example on how to check them using the command D SE IPP:

[18:45:45] ABILIS_CPX: D SE IPP

PO:900 ------------------------------------------------------------------------
IPRTR  --- Cleared 025:04:52:02 ago, on 14/04/2000 at 11:12:50 ----------------
       IPP:0  - Verso_router_a_Milano:192.200.121.10/32 -----------------------
       TYPE: LAN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |67257102   |78524106   |
       DG         |1266162    |1225718    |ICMP       |84         |93         |
       TCP        |513580     |606189     |UDP        |752498     |619436     |
       BRD        |0          |           |CAL        |0          |0          |
       RST        |0          |           |LONG       |0          |           |
       SHORT      |0          |           |LOST-LOOP  |           |0          |
       LOST-BUF   |           |0          |LOST-OTH   |           |0          |
       B-VER      |0          |           |B-ICMP     |0          |           |
       B-LEN      |0          |           |NO-ROUTE   |0          |           |
       B-FCS      |0          |           |UNK-PROT   |0          |           |
       TTL-EXP    |           |0          |LOST-INC-DG|0          |           |
       LOST-ACC   |0          |           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          1|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------
       IPP:1  -----------------------------------------------------------------
       IFTYPE:LINK     ENC:RAW-IP
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |      18927|      11668|
       DG         |        198|        143|ICMP       |          0|          0|
       TCP        |        122|        143|UDP        |         76|          0|
       BRD        |          0|           |CAL        |          0|          0|
       RST        |          0|           |LONG       |          0|          0|
       SHORT      |          0|           |LOST-LOOP  |           |          0|
       LOST-BUF   |           |          0|LOST-OTH   |           |          0|
       B-VER      |          0|           |B-ICMP     |          0|           |
       B-LEN      |          0|           |NO-ROUTE   |          0|           |
       B-FCS      |          0|           |UNK-PROT   |          0|           |
       TTL-EXP    |           |          0|LOST-INC-DG|          0|           |
       LOST-ACC   |          0|           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          1|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------
       IPP:10 -----------------------------------------------------------------
       IFTYPE:VIRTUAL  on P-IPP:0
       ------------------------------------------------------------------------

The following example shows how it is possible, through the command D SE, to display the extended statistics of each IP port.

[18:10:37] ABILIS_CPX: D SE IPP:1

PO:900 ------------------------------------------------------------------------
IPRTR  --- Cleared 000:03:19:20 ago, on 16/06/2000 at 14:51:20 ----------------
       IPP:1  -----------------------------------------------------------------
       IFTYPE:LINK     ENC:RAW-IP
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |      18927|      11668|
       DG         |        198|        143|ICMP       |          0|          0|
       TCP        |        122|        143|UDP        |         76|          0|
       BRD        |          0|           |CAL        |          0|          0|
       RST        |          0|           |LONG       |          0|          0|
       SHORT      |          0|           |LOST-LOOP  |           |          0|
       LOST-BUF   |           |          0|LOST-OTH   |           |          0|
       B-VER      |          0|           |B-ICMP     |          0|           |
       B-LEN      |          0|           |NO-ROUTE   |          0|           |
       B-FCS      |          0|           |UNK-PROT   |          0|           |
       TTL-EXP    |           |          0|LOST-INC-DG|          0|           |
       LOST-ACC   |          0|           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          1|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

As the example shows, for each IP port is also displayed its eventual description. If IP ports of type "LAN", "LINK" and "PPP" has not a specific description and their lower level port have it, this last one will be displayed.

Detail of the state field and statistics of the IP ports

IPP: | IP port identifier
 | 0 - 63

IP port identifier.

TYPE: | Connection type
 | X25PVC, X25BSVC, LAN, LINK, LINK-FR

Connection type used by the IP port.

LOWPO: | Number of the lower level port (only if TYPE: LAN/LINK/LINK-FR)
 | 0 - 999, NONE

Lower level port used by the IP port.

PVC: | PVC connection identifier (only if TYPE:X25PVC)
 | 1 - 255, NONE

PVC connection identifier.

CDI: | Called address of the incoming call (only if TYPE:X25BSVC)
 | from 1 up to 15 numerical characters, *, NO

X.25 called address of the incoming call.

CDO: | Called address of the outgoing call (only if TYPE:X25BSVC)
 | from 1 up to 15 numerical characters, NO

X.25 called address of the outgoing call.

STATE: | Current state of the IP port
 | LINKDOWN, LINKREADY, LINKNOTPRESENT, HALTED, FAILED, ERR, X25READY, X25CALLING, X25CALLED, X25CONNECTED, X25DELAYING, X25WAITING, HALTED, FAILED, ERR, X25READY, X25CONNECTED, HALTED, FAILED, ERR

It shows the current value of the IP port. The shown values depend on the connection type used by the IP port.

Driver | States | States | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
IPRTR (IP port of type "LAN", "LINK", "LINK-FR") | LINKDOWN | The lower level port (LOWPO:) is out of service |  |  |
 | LINKREADY | The lower level port (LOWPO:) is ready |  |  |
 | LINKNOTPRESENT | The lower level port (LOWPO:) is not present or not working |  |  |
 | HALTED | The IP port is halted or blocked owing to a fatal error |  |  |
 | FAILED | The IP port has not been activated because of an initialization error |  |  |
 | ERR | Software error. contact Abilis assistance. |  |  |
IPRTR (IP port of type "X25BSVC") | X25READY | The Ip port is ready, the BSVC connection is closed |  |  |
 | X25CALLING | The IP port made a call and it is waiting for acknowledgement |  |  |
 | X25CALLED | The IP port received a call but it hadn't sent the acknowledgement |  |  |
 | X25CONNECTED | The IP port has established the BSVC connection and data are exchanged |  |  |
 | X25DELAYING | The IP port is in a wait state because the call try failed |  |  |
 | X25WAITING | The IP port has reached the maximum number of call retries. |  |  |
 | HALTED | The IP port is halted or blocked owing to a fatal error |  |  |
 | FAILED | The IP port has not been activated because of an initialization error |  |  |
 | ERR | Software error. contact Abilis assistance. |  |  |
IPRTR (IP port of type "X25PVC") | X25READY | The IP port is ready to open the PVC connection. |  |  |
 | X25CONNECTED | The PVC connection is active and the IP port is exchanging data |  |  |
 | HALTED | The IP port is halted or blocked owing to a fatal error |  |  |
 | FAILED | The IP port has not been activated because of an initialization error |  |  |
 | ERR | Software error. contact Abilis assistance |  |  |

Detail of the extended statistics of the IP ports

IPP: | IP port identifier
 | 0 - 31

IP port identifier.

TYPE: | Connection type
 | X25PVC, X25BSVC, LAN, LINK, LINK-FR

Connection type used by the IP port.

SEG: | Number of X.25 segments sent/received (only if TYPE:X25BSVC/X25PVC)
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the IP port receives a data packet from the Connection Oriented Router (COR). The counter SEG (OUTPUT) is incremented every time the IP port sends a data packet to the Connection Oriented Router (COR).

Segments are obtained by dividing the number of bytes by 64, according to the X.25 standard.

CHAR: | Number of characters sent/received
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a datagram is received, while the CHAR (OUTPUT) one every time it is sent.

DG: | Number of IP datagrams sent/received
 | 0 - 4.294.967.295

The counter DG (INPUT) is incremented every time an IP datagram is received, while the DG (OUTPUT) one every time it is sent.

ICMP: | Number of ICMP datagrams sent/received
 | 0 - 4.294.967.295

The counter ICMP (INPUT) is incremented every time an ICMP datagram is received, while the ICMP (OUTPUT) one every time it is sent.

TCP: | Number of TCP datagrams sent/received
 | 0 - 4.294.967.295

The counter TCP (INPUT) is incremented every time an TCP datagram is received, while the TCP (OUTPUT) one every time it is sent.

UDP: | Number of UDP datagrams sent/received
 | 0 - 4.294.967.295

The counter UDP (INPUT) is incremented every time an UDP datagram is received, while the UDP (OUTPUT) one every time it is sent.

BRD: | Number of broadcasts received
 | 0 - 4.294.967.295

The counter BRD (INPUT) shows the number of broadcasts received.

CAL: | Number of Call X.25 received/sent (only if TYPE:X25BSVC)
 | 0 - 4.294.967.295

The counter CAL (INPUT) is incremented every time a Call Request X.25 is received, while the CAL (OUTPUT) one every time it is sent.

RST: | Number of Reset X.25 received (only if TYPE:X25BSVC/X25PVC)
 | 0 - 4.294.967.295

The counter RST (INPUT) is incremented every time a Reset X.25 is received.

LONG: | Number of too long IP datagrams
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time a too long IP datagram is received.

SHORT: | Number of too short IP datagrams
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time a too short IP datagram is received.

LOST-LOOP: | Number of IP datagrams sent to a not valid port by the IP Router
 | 0 - 4.294.967.295

The counter LOST-LOOP (OUTPUT) is incremented every time a datagram is discarded because of a routing loop, probably caused by a bad routing.

warning! Within IP networks, a datagram can't be rout to the port where it came from.

LOST-BUF: | Number of lost datagrams owing to the absence of free buffers
 | 0 - 4.294.967.295

The counter LOST-BUT (OUTPUT) is incremented every time a datagram must be discarded because there is no free buffer.

LOST-OTH: | Number of received IP datagrams but lost for unknown reasons
 | 0 - 4.294.967.295

The counter LOST-OTH (OUTPUT) is incremented every time a datagram must be discarded because of unknown causes. Typically, it happens when buffers are forcedly emptied by the execution of the command INIT IPP or INIT IPR

B-VER: | Number of IP datagrams received with a bad version field
 | 0 - 4.294.967.295

The counter B-VER (INPUT) is incremented every time a datagram, whose version field is bad, is received.

B-ICMP: | Number of unknown ICMP datagrams or received with a wrong Checksum
 | 0 - 4.294.967.295

The counter B-ICMP (INPUT) is incremented every time is received an unknown ICMP datagram or the Checksum procedure fails.

B-LEN: | Number of IP datagrams received with bad length
 | 0 - 4.294.967.295

The counter B-LEN (INPUT) is incremented every time is received a datagram with a bad length.

NO-ROUTE: | Number of datagrams which no routing is associated to
 | 0 - 4.294.967.295

The counter NO-ROUTE (INPUT) is incremented every time a datagram is received, but there is no routing associated to its destination address.

B-FCS: | Number of IP datagrams received with a wrong Checksum
 | 0 - 4.294.967.295

The counter B-FCS (INPUT) is incremented every time a datagram is received but the Checksum verifying procedure fails.

UNK-PROT: | Number of datagrams with unknown protocol
 | 0 - 4.294.967.295

The counter UNK-PROT (INPUT) is incremented every time a datagram is received, but its protocol is unknown.

TTL-EXP: | Number of datagrams discarded because the TTL reach the value "0"
 | 0 - 4.294.967.295

The counter TTL-EXP (OUTPUT) is incremented every time a datagram is discarded because its TTL field expired, that is it reached the value "0".

The TTL field value is incremented by 1 before routing the datagram.

LOST-INC-DG: | Number of fragments discarded it was not possible to compose the datagram
 | 0 - 4.294.967.295

The counter LOST-INC-DG (INPUT) is incremented every time a datagram fragment is discarded because it is not possible to compose the datagram.

warning! This statistic is not related to IP fragmentation (RFC 791).
This fragmentation is activated using FRAG: and FRAGSIZE: parameters.

LOST-ACC: | Number of datagrams discarded according to IP access list
 | 0 - 4.294.967.295

The counter LOST-ACC (INPUT) is incremented every time a datagram is discarded because it doesn't match any of the IP access list currently configured or because it matches a "denied access list".

B-FR-HDR: | Number of incoming frames discarded because the FR header is not as expected (0x03CC and/or 0x03B1)
 | 0 - 4.294.967.295

It is incremented in 2 cases:
- When incoming Frame-Relay header is not 0x03B1 (FRF12 fragmentation); - When incoming Frame-Relay header is not 0x03CC (complete frame);

SLARP-FRM: | Number of incoming/outgoing CISCO SLARP frames
 | 0 - 4.294.967.295

The counter SLARP-FRM (INPUT) is incremented every time an IP datagram encapsulated into a CISCO SLARP frame is received, while the SLARP-FRM (OUTPUT) one every time it is sent: it is incremented by 1 for every frame received/sent.

SLARP-CHAR: | Number of incoming/outgoing CISCO SLARP characters
 | 0 - 4.294.967.295

The counter SLARP-CHR (INPUT) is incremented every time an IP datagram encapsulated into a CISCO SLARP frame is received, while the SLARP-CHR (OUTPUT) one every time it is sent: in this case the statistic will be increased by the number of BYTEs that the frames contains.

SLARP-KEEP: | Number of incoming/outgoing CISCO SLARP Keep Alive frames
 | 0 - 4.294.967.295

The counter SLARP-KEEP (INPUT) is incremented every time a CISCO SLARP keep-alive frame is received, while the SLARP-KEEP (OUTPUT) one every time it is sent: it is incremented by 1 for every frame received/sent.

SLARP-DOWN: | Number of times CISCO SLARP keepalive detected down condition
 | 0 - 4.294.967.295

The counter SLARP-DOWN is incremented every time KEEPALIVE has detected a DOWN condition.

IPP-DOWN: | Number of time that global IPP state changed from UP to DOWN.
 | 0 - 4.294.967.295

The counter IPP-DOWN is incremented every time IPPort global state changed from UP to DOWN. One of the possible reason can could be that the lower layer went DOWN.

SP-LIM-OVFL: | Number of time calculation for speed reduction that has overflown the time limit.
 | 0 - 4.294.967.295

SP-LIM-OVFL indicates the number of time calculation for speed reduction that has overflown the time limit.

warning! This value should stay 0, value > 0 may indicate sw errors, please contact Abilis assistance.


Transmission Control Protocol (TCP)

Configuration of the TCP port
Statistics of the TCP ports

The TCP port is used within the Abilis CPX to provide a transport service of Connection-Oriented type to the upper level ports which implement TCP/IP applicative services, such as the TELNET or HTTP ports.

The TCP port uses, at its lower level, the network service provided by the IP Router port.

The Transmission Control Protocol (TCP) supports the typical functionalities of the 4th level protocol of OSI architecture:

  • Connection-Oriented type communications;

  • Client/Server approach;

  • Control and Restore of the correct data flow in the communication;

  • fragmentation, ordering and data reassembling.

Configuration of the TCP port top

The TCP port is labelled within the Abilis CPX by the acronym "TCP" and it is provided with the parameters described in the following section:

The following example shows how to display parameters of TCP ports. Shown value are only examples.

[18:17:22] ABILIS_CPX: D P PO:901

PO:901 ------------------------------------------------------------------------
TCP    sesnum:22   tcpwin:2048

All changes made on the TCP port parameters, displayed by low case characters, can be activated only restarting the system.

Detail of the TCP port parameters

SESNUM: | Number of TCP sessions
none | 0 - 255

It shows the number of maximum sessions that the TCP driver can manage. This value is automatically calculated by the system during the Validation procedure, according to the application services using the TCP port.

The parameter value is only informative and it cannot be modified.

TCPWIN: | Size (in bytes) of the TCP window
2048 | 2048 - 8192 (in bytes)

It sets the size (in bytes) of the TCP window.

Statistics of the TCP ports top

How to check the state and statistics of the TCP ports through the command D S.

[18:17:22] ABILIS_CPX: D D PO:901

PO:901 ------------------------------------------------------------------------
TCP    ID TOP-State  TCP/IP-State  LocAdd-LocPort         RemAdd-RemPort
       ------------------------------------------------------------------------
       0  CONNECTED  ESTABLISHED   192.168.000.253-23     192.168.000.002-1254
       1  LISTEN     LISTEN        000.000.000.000-2060
       2  LISTEN     LISTEN        000.000.000.000-23
       3  LISTEN     LISTEN        000.000.000.000-23
       4  LISTEN     LISTEN        000.000.000.000-23
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |       4040|       5679|CHAR       |       2403|     613710|
       REP-SEG-UP |           |          1|OPEN       |         34|          0|
       REP-SEG-DN |           |          1|OPEN_FAIL  |          0|          8|
       CLOSE      |         31|          2|RST        |           |          0|
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHK-ERR    |          0|           |ERR        |        999|           |
       RST-SEG    |           |        999|CURR-ESTAB |          1|           |
       ------------------------------------------------------------------------

Extended statistics are also available for the TCP ports. Here is an example on how to check them using the command D SE:

[18:17:22] ABILIS_CPX: D SE PO:901

PO:901 ------------------------------------------------------------------------
TCP    --- Cleared 003:22:05:49 ago, on 12/05/2000 at 12:11:40 ----------------
       ID TOP-State  TCP/IP-State  LocAdd-LocPort         RemAdd-RemPort
       ------------------------------------------------------------------------
       0  CONNECTED  ESTABLISHED   192.168.000.253-23     192.168.000.002-1254
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |       1366|       1971|CHAR       |        842|     224216|
       REP-SEG-UP |           |          0|OPEN       |          8|          0|
       REP-SEG-DN |           |          0|OPEN_FAIL  |          0|          0|
       CLOSE      |          6|          1|RST        |           |          0|
       ------------------------------------------------------------------------
       1  LISTEN     LISTEN        000.000.000.000-2060
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |       1771|       2614|CHAR       |        977|     305591|
       REP-SEG-UP |           |          0|OPEN       |          7|          0|
       REP-SEG-DN |           |          0|OPEN_FAIL  |          0|          0|
       CLOSE      |          6|          1|RST        |           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the TCP ports

ID: | TCP session identifier
 | 0 - (SESNUM: - 1)

It identifies the TCP session.

TOP-State: | Current state of the session
 | READY, LISTEN, CALLING, CONNECTED, CLOSING, UNDEFINED, ERR

It shows the current state of the session.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
TCP (Session X25) | READY | The session is ready to send connection requests to the TCP/IP network, it means an application port of the upper level is able to make connection requests |  |  |
 | LISTEN | The session is ready to receive connection requests coming from the TCP/IP network, it means an application port of the upper level is waiting the connection requests |  |  |
 | CALLED | Session is going to open the connection |  |  |
 | CALLING |  |  |  |
 | CONNECTED | Session is connected |  |  |
 | CLEARED | Session is going to clear the connection |  |  |
 | CLEARING |  |  |  |
 | UNDEFINED | Session is into an error state |  |  |
 | ERR | Software error. Contact the Abilis assistance. |  |  |

TCP/IP-State: | Current state of the TCP level connection
 | CLOSED, LISTEN, SYN-SENT, SYN-RCVD, ESTABLISHED, FIN-WAIT-1, FIN-WAIT-2, CLOSE-WAIT, LAST-ACK, CLOSING, TIME-WAIT, DELETE-TCB, UNDEFINED, ERR

It shows the current state of the TCP level connection.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
TCP (TCP connection) | CLOSED | Connection is closed |  |  |
 | LISTEN | The driver is waiting connection requests |  |  |
 | SYN-SENT | The driver sent a connection request |  |  |
 | SYN-RCVD | The driver received a connection request |  |  |
 | ESTABLISHED | Connection established |  |  |
 | FIN-WAIT-1 | Active closing. The driver sent a disconnection request. |  |  |
 | FIN-WAIT-2 | Active closing. The driver received an acknowledgement to a disconnection request |  |  |
 | CLOSE-WAIT | Passive closing. The driver received a disconnection request |  |  |
 | LAST-ACK | Passive closing. The driver sent the last acknowledgement to a disconnection request |  |  |
 | CLOSING | Both parts require the connection to be closed |  |  |
 | TIME-WAIT | Session closed. The driver will reach the state CLOSED (after the time-out) |  |  |
 | DELETE-TCB | Error detected. Contact the Abilis assistance. |  |  |
 | UNDEFINED |  |  |  |
 | ERR | Software error, contact the Abilis assistance |  |  |

LocAdd: | IP local address used by the connection
 | 0 - 255.255.255.255

It shows the IP local address used by the TCP connection, only if it is not in the state CLOSED.

LocPort: | Number of the IP local port used by the connection
 | 0 - 65535

It shows the number of the IP local port used by the TCP connection, only if it is not in the state CLOSED.

RemAdd: | IP remote address used by the connection
 | 0 - 255.255.255.255

It shows the IP remote address used by the TCP connection, only if it is not in the state CLOSED or LISTEN.

RemPort: | Number of the IP remote port used by the connection
 | 0 - 65535

It shows the number of the IP remote port used by the TCP connection, only if it is not in the state CLOSED or LISTEN.

SEG: | Overall number of segments received/sent in all the sessions
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a frame is received, while the SEG (OUTPUT) one every time it is sent.

CHAR: | Overall number of characters received/sent in all the sessions
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a frame is received, while the CHAR (OUTPUT) one every time it is sent

REP-SEG-UP: | Overall number of segments repeated in all the sessions when session state is UP
 | 0 - 4.294.967.295

The counter REP-SEG-UP (OUTPUT) is incremented every time a frame is repeatedly sent on UP state.

REP-SEG-DN: | Overall number of segments repeated in all the sessions when session state is DOWN
 | 0 - 4.294.967.295

The counter REP-SEG-DN (OUTPUT) is incremented every time a frame is repeatedly sent on DOWN state.

OPEN: | Overall number of OPENs in all the sessions
 | 0 - 4.294.967.295

The counter OPEN (OUTPUT) is incremented every time that the session state changes from CLOSED to SYN-SENT (correspondent to sending a connection request).

The counter OPEN (INPUT) is incremented every time that the session state changes from CLOSED to SYN-RCVD (correspondent to receiving a connection request).

OPEN_FAIL: | Overall number of failed attempts to establish a connection
 | 0 - 4.294.967.295

The counter OPEN-FAIL is incremented every time a connection establishment fails. Input/Output indicates on which call direction there were the failure.

CLOSE: | Overall number of connections closed
 | 0 - 4.294.967.295

The counter CLOSE is incremented every time a connection established is closed. Input/Output indicates on which direction there were the closure (input=close started from remote host. output=close started locally).

RST: | Overall number of connection reset
 | 0 - 4.294.967.295

The counter ESTAB-RST (OUTPUT) is incremented every time the connection state changes from ESTABLISHED or CLOSE-WAIT to CLOSED (correspondent to the connection clearing).

CHK-ERR: | Overall number of checksum errors detected during reception of segments
 | 0 - 4.294.967.295

The counter CHK-ERR (INPUT) is incremented every time a segment, containing a checksum error, is received.

ERR: | Overall number of bad segments received
 | 0 - 4.294.967.295

The counter ERR (INPUT) is incremented every time a segment, containing an error, is received.

RST-SEG: | Overall number of segments sent with "RST"
 | 0 - 4.294.967.295

The counter RST-SEG (OUTPUT) is incremented every time a segment containing the "RST" information, is sent.

CURR-ESTAB: | Overall number of connections whose state is ESTABLISHED or CLOSED-WAIT
 | 0 - 4.294.967.295

The counter CURR-ESTAB (INPUT) shows the overall number of connections whose state is ESTABLISHED or CLOSED-WAIT

Detail of the extended statistics of the TCP ports

Fields displayed by the extended statistics are the same of the ones showed by the execution of the command D S, but they refers to the single session of the TCP port.


User Datagram Protocol (UDP)

Configuration of the udp port
Statistics of the udp ports

The UDP port of Abilis CPX implements the homonymous protocol for TCP/IP networks, which provides a transport service of Connection-Less type.

The protocol User Datagram Protocol (UDP) has functionalities less developed compared to the TCP one, without low control and capability of control and restore the correct data flow in the communication.

Within the Abilis CPX, the UDP port is used by the application services of the TCP/IP family, such as the RIP or SNMP ports. The UDP port uses, at its lower level, the network service provided by the IP Router port.

Configuration of the UDP port top

The UDP port is labelled within the Abilis CPX by the acronym "UDP" and it is provided with the parameters described in the following section:

Here is how to display parameters of UDP ports. Shown value are only examples.

[18:38:04] ABILIS_CPX: D P PO:902

PO:902 ------------------------------------------------------------------------
UDP    CHK:YES  reas-dg-num:10   reas-dg-size:2200

All changes made on the UDP port parameters, displayed by low case characters, can be activated only restarting the system.

Detail of the UDP port parameters

CHK: | Checksum control activation
YES | NO, YES

It activates the control of the Checksum field of the UDP datagrams.

reas-dg-num: | Number of reassembly buffers
10 | 2 - 100

Maximum number of incomplete datagrams buffered in reassembler.

reas-dg-size: | Size of a single buffer reassembler
2200 | 576 - 32768

Maximum size of a reassembled datagram.

Statistics of the UDP ports top

How to check the state and statistics of the UDP ports through the command D S.

[18:38:04] ABILIS_CPX: D S PO:902

PO:902 ------------------------------------------------------------------------
UDP    ID  Lsn  LocPort
       ------------------------------------------------------------------------
       1   1    123
       2   2    161
       3   3    2114
       4   4    58072
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |     107670|      95185|NO-PORT    |      15129|           |
       CHK-ERR    |          0|           |ERR        |          0|           |
       LOST       |          0|           |
       ------------------------------------------------------------------------

Extended statistics are also available for the UDP ports. Here is an example on how to check them using the command D SE:

[18:38:04] ABILIS_CPX: D SE PO:902

PO:902 ------------------------------------------------------------------------
UDP    --- Cleared 003:22:25:43 ago, on 12/05/2000 at 12:11:38 ----------------
       ID  Lsn  LocPort
       ------------------------------------------------------------------------
       1   1    123
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |          0|          0|LOST       |          0|           |
       CHAR       |          0|          0|
       ------------------------------------------------------------------------
       2   2    161
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |          0|          4|LOST       |          0|           |
       CHAR       |          0|        594|
       ------------------------------------------------------------------------
       3   3    2114
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |      92457|      95097|LOST       |          0|           |
       CHAR       |    1682538|    1690714|
       ------------------------------------------------------------------------
       4   4    58072
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |         96|         96|LOST       |          0|           |
       CHAR       |       5760|       5760|
       ------------------------------------------------------------------------

In both shown examples, there are two applicative ports requesting the UDP service. If no port of the upper level is requesting the UDP service, the following message will be shown: "No UDP connections".

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the UDP ports

ID: | Identifier of the UDP session
 | 1 - 255

It identifies the UDP session.

LSN: | Local identifier given to the session by the UDP port
 | 1 - 255

It identifies the Local (Local Session Number) identifier given to the session by the UDP port.

LocPort: | Number of the IP local port used by the UDP connection
 | 0 - 65535

It shows the number of the IP local port used by the UDP connection.

FRM: | Overall number of datagrams received/sent
 | 0 - 4.294.967.295

The counter FRM (INPUT) is incremented every time a frame is received, while the FRM (OUTPUT) one every time it is sent.

NO-PORT: | Overall number of datagrams discarded because of destination port value
 | 0 - 4.294.967.295

The counter NO-PORT (INPUT) is incremented every time the UDP port receives and discards a datagram containing a destination port value for which no Abilis CPX application is active.

LOST: | Overall number of datagrams discarded
 | 0 - 4.294.967.295

The counter LOST (INPUT) is incremented every time the UDP port receives and discards a datagram because the upper application level port is not ready to receive.

ERR: | Overall number of bad datagrams received in all the sessions
 | 0 - 4.294.967.295

The counter ERR (INPUT) is incremented every time a datagram, containing an error (e.g. with a bad length) is received.

CHK-ERR: | Overall number of checksum errors detected during reception of segments
 | 0 - 4.294.967.295

The counter CHK-ERR (INPUT) is incremented every time a segment, containing a checksum error, is received.

Detail of the extended statistics of the UDP ports

ID: These statistics are the same shown in basic command and already explained
LSN:
LocPort:
FRM:
LOST:
CHAR: | Number of characters received/sent
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a frame is received, while the counter CHAR (OUTPUT) every time a frame is sent.


IP routings

IP routings
IP Routing Administrative Distances table
Saved static IP routings
IP source routings

Generally, only two IP routing types exist: the static and the dynamic one. The main difference between the two types is the method of construction of the routing tables.

A table dynamic IP routings is made and automatically updated by the specialized software processes of IP Router. Through opportune routing protocols such processes provide periodic exchange of routing information with the others router present in the network, their processing and inserting of the obtained routing in the suitable routing table.

A table of static IP routings is made and manually managed by the network manager and it needs of being stored in a support of not volatile memory, in case the system is switched off.

In Abilis CPX the IP routings table contains all the routing topologies, leaving however the distinction between the types. In the current version Abilis CPX allows to add manually static routing, routing connected (to a subset of the static routing), and to acquire dynamic routing through protocols RIP1 and RIP2 and OSPF.

In this section, IP routings table and the modality of configuration of saved static routings will be described.

Refer to the chapter Configuration of IP ports for connected routing and to chapters The Routing Information Protocol (RIP) port for dynamic routing retrieved by the RIP routing protocol and The Open Shortest Path First Protocol (OSPF) port for dynamic routing retrieved by the OSPF routing protocol.

IP routings top

In IP routings table, static routings can be added/modified/deleted while the Abilis CPX works without needing to restart it, changes are active immediately.

When the command SAVE CONF is executed, only static routings that are currently presents in the table are saved in the configuration file.

The maximum size of the IP routings table can be configured through the parameter MAXROUTE: of the IP Router port, whose default value is 500. However, in the configuration files up to 255 static routings are saved, while the connected routing are derived from the configurations of IP ports.

All the commands for managing the IP routings are described in the section IP routings of the chapter Commands relating to IP Router.

The available commands are the following:

A IPR
C IPR
D IPR
S IPR

Here is an example of displaying all the IP routings:

[11:18:14] ABILIS_CPX: D IPR

Unconditional source routes:
+-------+--------------------+--------------------+-----------------+----+---+
|       |     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|   |
|       |                    |   SRNET:/SRMASK:   |                 |    |   |
+-------+--------------------+--------------------+-----------------+----+---+
|       | 002.002.000.000/16 | 255.255.000.000    |                 |    |   |
|       |                    | 005.005.005.005/32 |                 |D  2|   |
|       |                    | 005.005.005.005/32 |                 |D  1|   |
+-------+--------------------+--------------------+-----------------+----+---+

Destination routes and conditional source routes:
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|B|P|S|H|     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|AD:|
| | | | |                    |   SRNET:/SRMASK:   |                 |    |   |
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|*|S| | | 001.001.001.001/32 | 255.255.255.255    |                 |D  1|  1|
| |S| | | 001.001.001.001/32 | 255.255.255.255    |                 |NONE|  1|
| | | | |                    | 005.005.005.005/32 |                 |NONE|   |
|*|S| | | 001.005.005.005/32 | 255.255.255.255    |                 |NONE|  1|
|*|S| |*| 002.002.002.002/32 | 255.255.255.255    |                 |  10|  1|
|*|S| | | 002.002.002.003/32 | 255.255.255.255    |                 |  10|  1|
|*|S| |*| 005.005.005.005/32 | 255.255.255.255    |                 |   5|  1|
|*|S| | | 005.005.005.006/32 | 255.255.255.255    |                 |   6|  1|
|*|S| | | 009.009.009.009/32 | 255.255.255.255    |                 |NONE|  1|
|*|S| | | 010.000.000.001/32 | 255.255.255.255    |                 |   5|  5|
|*|S| | | 032.032.032.032/32 | 255.255.255.255    |                 |  32|  1|
|*|S| | | 192.168.000.005/32 | 255.255.255.255    |                 |  15|  1|
|*|R| | | 192.168.000.060/32 | 255.255.255.255    | 192.168.000.060 |   0|120|
|*|C| | | 192.168.000.213/32 | 255.255.255.255    |                 |R-ID|  0|
|*|C| | | 192.168.010.001/32 | 255.255.255.255    |                 |  30|  0|
|*|C| | | 192.168.031.213/32 | 255.255.255.255    |                 |  31|  0|
|*|C| | | 212.025.018.178/32 | 255.255.255.255    |                 |  30|  0|
|*|C| | | 006.006.006.000/24 | 255.255.255.000    |                 |D 63|  0|
|*|C| | | 192.168.000.000/24 | 255.255.255.000    |                 |   0|  0|
|*|R| | | 192.168.001.000/24 | 255.255.255.000    | 192.168.000.060 |   0|120|
|*|S| | | 192.168.006.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
|*|S| | | 192.168.008.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
|*|C| | | 002.002.000.000/16 | 255.255.000.000    |                 |  40|  0|
| |S| | | 002.002.000.000/16 | 255.255.000.000    |                 |  40|  1|
| | | | |                    | 005.005.005.005/32 |                 |   0|   |
| | | | |                    | 005.005.005.005/32 |                 |NONE|   |
|*|S| | | 010.000.000.000/16 | 255.255.000.000    | 192.168.000.253 |   0|  1|
+-+-+-+-+--------------------+--------------------+-----------------+----+---+

In the following example, only those routings matching the specified "filter" (MASK:255.255.255.0) are shown:

[18:14:08] ABILIS_CPX: D IPR MASK:255.255.255.0

Unconditional source routes:
+-------+--------------------+--------------------+-----------------+----+---+
|       |     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|   |
|       |                    |   SRNET:/SRMASK:   |                 |    |   |
+-------+--------------------+--------------------+-----------------+----+---+

Destination routes and conditional source routes:
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|B|P|S|H|     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|AD:|
| | | | |                    |   SRNET:/SRMASK:   |                 |    |   |
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|*|C| | | 006.006.006.000/24 | 255.255.255.000    |                 |D 63|  0|
|*|C| | | 192.168.000.000/24 | 255.255.255.000    |                 |   0|  0|
|*|R| | | 192.168.001.000/24 | 255.255.255.000    | 192.168.000.060 |   0|120|
|*|S| | | 192.168.006.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
|*|S| | | 192.168.008.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
+-+-+-+-+--------------------+--------------------+-----------------+----+---+

In the Unconditional source routes section of the displayed information, unconditional source routings are listed; while in the Destination routes and conditional source routes section, both destination routings and conditional source routings are displayed.

Details of the IP routing parameters

B: | Best routing
no value | ' '=NO, *=YES

This parameter has only an informative value and it cannot be modified. In the case that two or more routings with the same NET: value are present, it identifies the best one.

P: | Origin of routing
no value | C=CONNECTED, S=STATIC, O=OSPF, R=RIP

This parameter has only an informative value and it cannot be modified. It shows the origin of the routing.

The following table lists allowed values and their meaning:

Value | Meaning
C | The routing has been obtained from the configuration table of the IP ports; this kind of routing is referred as directly connected or, simply, connected.
S | It is a static routing, obtained from the table of saved static IP routings.
R | The routing has been obtained from the RIP protocol.
O | The routing has been obtained from the OSPF protocol.
S: | Status of the routing.
no value | ' '=NORMAL, A=ADDED, C=CHANGED, D=DELETING, H=HIDDEN

This parameter has only an informative value and it cannot be modified. It indicates the state of the single routing. Every time some changes occurs to IPRTR table, routings could change their state. This could be due to changes into IP ports, changes with static and dynamic routings.

Value | Meaning
 | Normal state: routings is in normal state, nothing has been changing.
A | Added state: routing is just added into table and is going to be accepted. Once confirmed by IPRTR, it will go into normal state.
C | Changed state: routing has changed some parameters and is going to be accepted. Once confirmed by IPRTR, it will go into normal state.
D | Deleted state: routing is just requested for being deleted from table. Once request is confirmed by IPRTR, routing will be removed from table.
H | Hidden state: routing hidden parameter is changed from NO to YES. Once request is confirmed by IPRTR, routing will go into normal state.
H: | Hiding static routings from dynamic routing protocols like RIP and OSPF.
NO | ' '=NO, *=YES

It sets whether the static routing has to be hidden to the other dynamic routing protocols like RIP and OSPF.

If the parameter is set to "NO", the field will be empty and the routing will be inserted in the RIP and OSPF local table.

Setting the parameter to "YES", the character '*' will be shown, meaning that the routing won't be inserted in the RIP and OSPF local table.

NET: | Destination network
no value | see below

It sets the destination network of the routing.

The destination network address and the related mask can be specified either using the in Slash Notation (e.g. NET:x.x.x.x/yy) or using the Dotted Decimal Notation for both the network address and the related mask (e.g. NET:x.x.x.x MASK:y.y.y.y).

Allowed values for the destination network address are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

When Slash Notation is used, valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between the destination network address and the MASK: value, the result should be the destination network itself; if not the message "INVALID STATIC NETWORK" will be shown and the value refused.

MASK: | Mask related to the destination network
no value | 0.0.0.0 - 255.255.255.255

It sets the mask related to the destination network.

The parameter must be expressed in Dotted Decimal Notation and can only be configured to values that contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between this parameter and the related network address (see NET:), the result should be the destination network itself; if not the message "INVALID STATIC NETWORK" will be shown and the value refused.

The destination network mask is also displayed in the table, together with the related network address using the Slash Notation, in the NET: field.

The MASK: filed of the table can also display the Source routing network (see SRNET:).

SRNET: | Source routing network
no value | see below

It display the Source routing network address and the related mask, expressed in Slash Notation.

Allowed values for the Source routing network address, in Dotted Decimal Notation, are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The mask related to the Source routing network, must be a value that contains sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one. Therefore it will be a value in the range [1-32].

Doing the "logical AND" between the Source routing network and the related mask, the result should be the Source routing network itself.

GW: | IP address of the destination gateway [1]
no value | ' '=0.0.0.0, see below

It sets the address of the destination gateway, in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

If the parameter is set to "0.0.0.0", the field will be empty in the table.

IPP: | IP port where to route to
no value | 0..63, NONE, R-ID=Router-ID

It sets the IP port where to route the IP datagram.

If, at the moment of the visualization, the IP port that is referenced by the routing is in "DOWN" state, beside the port index, the character "D" will appear.

The value "NONE" stands for "no IP port"; it can be used for deactivating the IP routing without canceling it.

The value "R-ID", stands for "Router-ID"; it cannot be manually set and it means that the specified routing is the Router ID.

AD: | Administrative distance
no value | 0 - 255

Distance used for route priority into IP Routing table.

This is a particular metric used to indicate priorities between routings of the same and different protocol route.

The less is the AD value and the better will be the routing priority.

warning! This value is assigned in this way: once a routing must be added into IPRTR table, first must be checked if there is a record into Administrative Distance Table that matches with route. If matches, the specific AD will be assigned, else will be taken from its IPR_DEF-LOC-AD: parameter

.

IP Routing Administrative Distances table top

This table contains information about rules for routes priority into IP Routing table.

Commands for managing the IP Routing Administrative Distances Table are described in the section IP Routing administrative distances of Commands relating to IP Router.

The following commands are available:

A IPAD
C IPAD
D IPAD
S IPAD

Here is an example of how to display IP Routing Administrative Distances Table:

[10:49:13] ABILIS_CPX: D IPAD

+--------------------+----------+-----------+--------+
|        NET:        |   PROT:  | DISTANCE: |  IPP:  |
+--------------------+----------+-----------+--------+
| 192.168.006.002/32 |  RIP     |      110  |        |
| 192.168.006.000/24 |  RIP     |      120  |        |
| 192.168.006.000/24 |  OSPF    |      100  |        |
| 010.000.000.000/8  |  STATIC  |       10  |  NONE  |
| 000.000.000.000/0  |  LOCAL   |        5  |        |
+--------------------+----------+-----------+--------+

Here is an example of how to display a specific entry of the table:

[16:54:38] ABILIS_CPX: D IPAD NET:192.168.006.002/32 PROT:RIP

+--------------------+----------+-----------+--------+
|        NET:        |   PROT:  | DISTANCE: |  IPP:  |
+--------------------+----------+-----------+--------+
| 192.168.006.002/32 |  RIP     |      110  |        |
+--------------------+----------+-----------+--------+

The IP Routing Administrative Distances Table can store up to 256 entries.
Every entry in the table is unambiguously identified by its NET: and PROT: parameters values, i.e. NET: can be duplicated only for different PROT: value.
Entries are kept sorted by NET: and PROT: values: longer Network Mask first and lower Network address first.

NET: | Destination network
no value | see below

It specifies the destination network IP address and mask used for setting administrative distance, in Slash Notation (i.e. x.x.x.x/yy).

The allowed values for network addresses are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

By doing the "logical And" between the destination network IP address and the related network mask, the result should be the destination network itself; if not the message "INVALID VALUE 'NET:x.x.x.x/yy'" will be shown and the value refused.

PROT: | Routing protocol
NONE | NONE, LOCAL, STATIC, OSPF, RIP

This parameter defines a routing protocol for which this distance will be applied.

Value | Meaning
NONE | IPRTR doesn't consider this record.
LOCAL | Administrative distance is referred to LOCAL routing protocol.
STATIC | Administrative distance is referred to STATIC routing protocol.
OSPF | Administrative distance is referred to OSPF routing protocol.
RIP | Administrative distance is referred to RIP routing protocol.
DISTANCE: | Administrative distance
255 | 0 - 255

This parameter defines the distance that will be used for route priority into IP Routing table.

IPP: | IP port
See below | 0..63, NONE, *

This parameter defines the IP port value. It is allowed only when PROT: parameter is set to STATIC.

The value "NONE" stands for "no IP port".
The value "*" stands for "any IP port".

Saved static IP routings top

In Abilis CPX all routing types are managed through a single IP routings table, which is built in memory adding the static, connected and dynamic routing.

Contrarily to the dynamic routing, static and connected ones must be stored into a not volatile support (i.e. into the floppy disk) in order to be re-used after each Abilis CPX restart.

Connected routing are obtained from the IP ports configurations, therefore they are implicitly saved in a permanent way in the same configuration set of IP ports.

On the other hand, static routings are separately saved by the Abilis CPX through the table of saved static IP routings.

The table of saved static IP routings can hold up to 255 routings; it is automatically kept aligned with the IP routings table content and it is automatically saved on the floppy disk by the execution of SAVE CONF command.

On running Abilis CPXs it is also possible to inspect the content of the table of saved static IP routings, without being able to modify it directly.

On the contrary, using the off-line configurator command interpreter, it is possible to display and modify the content of the table of saved static IP routings freely.

All commands for managing table of saved static IP routings are described in the section Saved static IP routing of the chapter Commands relating to the IP Router.

Commands that are available from the command interpreter of working Abilis CPXs are:

D IPRS and D SIPR

Commands that are available from off-line configuration command interpreter are:

A IPRS and A SIPR
C IPRSand C SIPR
D IPRS and D SIPR
S IPRS and S SIPR

Here is an example of the visualization of all the saved static IP routings. Shown values are only examples:

[18:14:08] ABILIS_CPX: D SIPR

+-----+-------+-----------------+-----------------+-----------------+------+
| ID: | HIDE: |      NET:       |      MASK:      |       GW:       | IPP: |
+-----+-------+-----------------+-----------------+-----------------+------+
|   0 |  NO   | 001.001.001.001 | 255.255.255.255 | 000.000.000.000 |    1 |
|   1 |  NO   | 001.001.001.001 | 255.255.255.255 | 000.000.000.000 | NONE |
|   3 |  NO   | 002.002.002.002 | 255.255.255.255 | 000.000.000.000 | NONE |
|   5 |  YES  | 002.002.002.002 | 255.255.255.255 | 000.000.000.000 |   10 |
|   6 |  NO   | 002.002.002.003 | 255.255.255.255 | 000.000.000.000 |   10 |
|   8 |  YES  | 005.005.005.005 | 255.255.255.255 | 000.000.000.000 |    5 |
|   9 |  NO   | 005.005.005.006 | 255.255.255.255 | 000.000.000.000 |    6 |
|  10 |  NO   | 010.000.000.001 | 255.255.255.255 | 000.000.000.000 |    5 |
|  11 |  NO   | 032.032.032.032 | 255.255.255.255 | 000.000.000.000 |   32 |
|  13 |  NO   | 192.168.006.000 | 255.255.255.000 | 192.168.000.251 |    0 |
|  14 |  NO   | 192.168.008.000 | 255.255.255.000 | 192.168.000.251 |    0 |
|  15 |  NO   | 002.002.000.000 | 255.255.000.000 | 000.000.000.000 |   40 |
|  16 |  NO   | 010.000.000.000 | 255.255.000.000 | 192.168.000.253 |    0 |
+-----+-------+-----------------+-----------------+-----------------+------+

As it is possible to note, the static IP routing identifiers do not have to be strictly sequential.

Details of the saved static IP routing parameters

ID: | IP routing identifier
no value | from 0 up to 254

It is the identifier of the saved static IP routing. It unambiguously identifies the routing entry and it is used for any operations of insertion, modification, deleting.

The table of saved static IP routings can hold up to 255 routings. They are indexed starting from 0 up to 254.

Identifiers do not have to be strictly sequential, i.e. the table can contain "empty" places.

Deleting operations do not cause a table re-sorting, but simply leave the entry of the removed routing free. Vacancies are re-assigned when a new static IP routing is going to be created.

The order of the saved static IP routings is not meaningful: at every CPX start or every time the command INIT IPR is executed, the saved static IP routings are added the IP routings table and inserted into in the correct position.

HIDE: | Hiding static routings from dynamic routing protocols like RIP and OSPF.
NO | NO, YES

It sets whether the static routing has to be hidden to the other dynamic routing protocols like RIP and OSPF.

If the parameter is set to "NO", the routing will be inserted in the RIP and OSPF local table.

Setting the parameter to "YES", the routing won't be inserted in the RIP and OSPF local table.

NET: | IP address identifying the destination network
000.000.000.000 | see table

It sets the destination network IP address. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Doing the "logical AND" between values of this parameter and MASK:, the result should be the destination network itself, if not the message "CONFLICTING VALUE" will be shown and the value refused.

MASK: | Destination network mask
255.255.255.255 | 0 - 255.255.255.255

It sets the mask related to the destination network. The parameter can only be configured to values that contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between values of this parameter and NET:, the result should be the destination network itself if not the message "CONFLICTING VALUE" will be shown and the value refused.

GW: | IP address of the destination gateway [1]
000.000.000.000 | see table

It sets the IP address of the destination gateway. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

IPP: | IP port where to route to
NONE | 0 - 63, NONE

It sets the IP port where to route the IP datagram.

The value "NONE" stands for "no IP port" it can be used for deactivating the IP routing without deleting it.

IP source routings top

IP source routing is an extended way to define paths to reach hosts and networks.
Usually routing behaviour consists of checking the destination address for each incoming IP datagram or internally generated IP datagram that must be forwarded to a network.

The list of entries that specify the path for every destination is present into Abilis CPX IP routings table and moreover static routings are separately saved by the Abilis CPX through the table of saved static IP routings. These tables can be considered as a destination routing tables.

The table of IP source routings is similar to the table of saved static IP routings; but it allows the specification of the source routing network address/mask, in addition to the destination network address/mask, to the destination gateway IP address and to the outgoing IP port.
This is an important addition because it allows to specify which source addresses can match the routing.

Rules for IP datagrams forwarding are the same of a destination table, plus an additional match with the IP source address.

List of addresses is strictly sorted in order to assign the most selective address/mask for routing detection.
The sorting rules are the following:

  • destination network mask (from most selective to least selective. From 255.255.255.255 to 0.0.0.0).
  • destination network address (sorting is made from lower value to higher value).
  • source routing network mask (from most selective to least selective. From 255.255.255.255 to 0.0.0.0).
  • source routing network address (sorting is made from lower value to higher value).

The interaction between IP source routings and destination routings is very important.
In the case case of matching in both source and destination routings tables (and the destination net/mask matching of both tables are the same), the source routing has an higher priority.

The table of IP source routings can hold up to 255 entries; it is automatically kept aligned with the IP routings table content and it is automatically saved on the floppy disk by the execution of SAVE CONF command.

On running Abilis CPXs it is also possible to inspect the content of the table of IP source routings, without being able to modify it directly.

On the contrary, using the off-line configurator command interpreter, it is possible to display and modify the content of the table of IP source routings freely.

All commands for managing table of IP source routings are described in the section IP source routing of the chapter Commands relating to the IP Router.

Command that is available from the command interpreter of working Abilis CPXs is:

D IPSR

Commands that are available from off-line configuration command interpreter are:

A IPSR
C IPSR
D IPSR
S IPSR

Here is an example of the visualization of all the IP source routings. Shown values are only examples:

[11:02:59] ABILIS_CPX: D IPSR

+-----+--------------------+--------------------+-----------------+------+----+
| ID: |     NET:/MASK:     |   SRNET:/SRMASK:   |        GW:      | IPP: | UN:|
+-----+--------------------+--------------------+-----------------+------+----+
|   0 | 001.001.001.001/32 | 005.005.005.005/32 | 000.000.000.000 | NONE | NO |
|   1 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    0 | NO |
|   2 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 | NONE | NO |
|   3 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    2 | YES|
|   4 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    1 | YES|
+-----+--------------------+--------------------+-----------------+------+----+

As it is possible to note, the IP source routing identifiers do not have to be strictly sequential.

Details of the IP source routing parameters

ID: | IP routing identifier
no value | from 0 up to 254

It is the identifier of the IP source routing. It unambiguously identifies the routing entry and it is used for any operations of insertion, modification, deleting.

The table of IP source routings can hold up to 255 routings. They are indexed starting from 0 up to 254.

Identifiers do not have to be strictly sequential, i.e. the table can contain "empty" places.

Deleting operations do not cause a table re-sorting, but simply leave the entry of the removed routing free. Vacancies are re-assigned when a new IP source routing is going to be created.

The order of the IP source routings is not meaningful: at every CPX start or every time the command INIT IPR is executed, the IP source routings are added the IP routings table and inserted into in the correct position.

NET: | Destination network
000.000.000.000 | see table

It sets the destination network.

The destination network address and the related mask can be specified either using the in Slash Notation (e.g. NET:x.x.x.x/yy) or using the Dotted Decimal Notation for both the network address and the related mask (e.g. NET:x.x.x.x MASK:y.y.y.y).

Allowed values for the destination network address are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

When Slash Notation is used, valid values for the network mask mast be in the range [0-32]; while values in the range [0.0.0.0 - 255.255.255.255] are accepted in Dotted Decimal Notation. Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between destination network address and the mask values, the result should be the destination network address itself; if not the message "CONFLICTING VALUE" will be shown and the value refused.

MASK: | Destination network mask
255.255.255.255 | 0.0.0.0 - 255.255.255.255

It sets the mask related to the destination network, expressed in Dotted Decimal Notation.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between values of this parameter and NET:, the result should be the destination network itsef; if not the message "CONFLICTING VALUE" will be shown and the value refused.

The destination network mask value can also be configured using the NET: parameter, using the Slash Notation. In this case the network mask mast be a value in the range [0-32].

SRNET: | Source network
000.000.000.000 | see table

It sets the source network.

The source network address and the related mask can be specified either using the in Slash Notation (e.g. SRNET:x.x.x.x/yy) or using the Dotted Decimal Notation for both the network address and the related mask (e.g. SRNET:x.x.x.x SRMASK:y.y.y.y).

Allowed values for the source network address are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

When Slash Notation is used, valid values for the network mask mast be in the range [0-32]; while values in the range [0.0.0.0 - 255.255.255.255] are accepted in Dotted Decimal Notation. Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between source network address and the mask values, the result should be the source network address itself; if not the message "CONFLICTING VALUE" will be shown and the value refused.

SRMASK: | Source network mask
255.255.255.255 | 0 - 255.255.255.255

It sets the mask related to the source network, expressed in Dotted Decimal Notation.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one.

Doing the "logical AND" between values of this parameter and SRNET:, the result should be the source network itsef; if not the message "CONFLICTING VALUE" will be shown and the value refused.

The source network mask value can also be configured using the SRNET: parameter, using the Slash Notation. In this case the network mask mast be a value in the range [0-32].

GW: | IP address of the destination gateway [1]
000.000.000.000 | see table

It sets the IP address of the destination gateway. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

IPP: | IP port where to route to
NONE | 0 - 63, NONE

It sets the IP port where to route the IP datagram.

The value "NONE" stands for "no IP port" it can be used for deactivating the IP routing without deleting it.

UN: | Unconditional source routing
NO | NO, YES

It sets the source routing to unconditional.

[1] Historically the "router" was called "gateway". Nowadays the term "gateway" it is widely used in TCP/IP terminology, also if it isn't correct, so the terms "router" and "gateway" are perfectly interchangeable.


IP access lists

Configuration of the IP access list

The IP access list is a security procedure through that the Abilis CPX executes control, basing on base addresses and the requested services, and check functionalities on the datagrams in transit from and to Abilis CPX.

Transit datagrams are filtered and then selected basing on the information carried by the header (source address and destination, internet protocol version and numbers of logical port) and not on their content. Two ways of filtering are allowed:

  • STD (Standard): in this case the such called "address filtering" procedure is executed; only IP source and destination addresses of the packet are checked.

  • EXT (Extended): in this case the "service filtering" procedure is executed; not only IP source and destination addresses of the packet are checked but also the internet protocol version and for TCP, UDP protocols the logical port numbers (indeed also the requested service).

By defining suitable filters in the IP access list it is so possible to set which data can transit and which no. This list provide two different kinds of filters:

Filter type | Meaning
PERMIT | Permitted to transit.
DENY | Denied to transit.

Filters also allow assigning each datagram data flow a different service class:

Service class | Meaning
HIGH | Service class "HIGH".
NORMAL | Service class "NORMAL".
LOW | Service class "LOW".

Usually the service classes are also called "priorities" so that it is possible to speak of "the traffic prioritisation"; further on the filter priorities will be introduced, the User should not confuse the two definition of priority, with the latter it is meant the evaluation order of filters.

Moreover it is possible to activate the cryptographic functionalities of data content in datagrams:

Parameters related tot the cryptographic functions | Description
CRKEY: | Cryptography key to be used.
CRDIR: | Cryptography direction (encode decode).

Filters can be added, modified, deleted from the IP access list during Abilis CPX working mode, without needing to restart it. Changes are immediately active.

The IP access list can store up to 256 filters definitions.

Configuration of the IP access list top

All the commands for IP routing management are described in the section IP access list of the chapter Commands related to the IP Router.

The available commands are:

A IPACL
C IPACL
D IPACL
F IPACL
M IPACL
S IPACL

Here is an example on how to display all the filters.

As it is possible to note, the filter identifiers represent the verifying priority and they are automatically kept in sequential order.

[18:14:08] ABILIS_CPX: D IPACL

IPRTR (PO:900) parameters:  ACL:NO        ACLBYPASS:#
                            COS:DISABLED  COSDFT:NORMAL
Tot-IPACL-Number:4

-------------------------------------------------------------------------------
PR: TYPE:  SA:                               DA:
    IPCOS: PROT:                  SPO:/PO:               DPO:
           SIPP:  DIPP:  CRDIR:   CRKEY:
-------------------------------------------------------------------------------
0   PERMIT 001.001.001.001                   002.002.002.002
    DFT    tcp                    telnet(23)
-------------------------------------------------------------------------------
1   DENY   001.001.001.001                   002.002.002.002
           ospf
-------------------------------------------------------------------------------
2   PERMIT 001.001.001.001                   002.002.002.002
    LOW    udp                    snmp(161)              *
           *      INT    NONE
-------------------------------------------------------------------------------
3   PERMIT *                                 *
    LOW    *                      *
           *      *      ENCRYPT  DFT
-------------------------------------------------------------------------------

This description desn't display information about parameters whose values are the default ones. They will be only displayed if their values have been changed from the default ones. In such way, the description of single entry is simply contained in two rows.

Single filter displaying:

[18:14:08] ABILIS_CPX: D IPACL PR:1

IPRTR (PO:900) parameters:  ACL:NO        ACLBYPASS:#
                            COS:DISABLED  COSDFT:NORMAL
Tot-IPACL-Number:3
-------------------------------------------------------------------------------
PR: TYPE:  SA:                               DA:
    IPCOS: PROT:                  SPO:/PO:               DPO:
           SIPP:  DIPP:  CRDIR:   CRKEY:
-------------------------------------------------------------------------------
1   DENY   001.001.001.001                   002.002.002.002
           ospf
-------------------------------------------------------------------------------

Details of the filters parameters

PR: | Filter priority (The 0 priority is the highest)
none | from 0 up to 255

The priority index set the filter verifying order. The verifying procedure is executed on each datagram that has to be routed.

It starts from the filter with priority 0 and continues until the suitable datagram will be found or the list will end.

If the IP datagram doesn't match any filter, it will be routed; if the IP services class functionality is activated, the Router will assign to the datagram the default priority set in the parameter "COSDFT" of the port IPRTR.

The filter index is also use by the adding, modifying and deleting commands for referring to it.

Priority indexes, every time a filter is added or deleted, in the list are automatically kept in sequential order.

TYPE: | It sets the filter type
none | DENY, PERMIT

This command set whether the datagram, matching the filter, have to be routed (filter matched type "PERMIT") or discharded (filter matched type "DENY").

Datagrams that don‘t match any filter are always routed with the default priority.

IPCOS: | It sets the Service classes assigned to datagram (Only for TYPE:PERMIT)
DFT | DFT (or D), HIGH (or H), NORMAL (or N), LOW (or L)

This parameter is displayed and configurable only for "PERMIT" filters type. It is considered only if the IP classes service are activated (parameter COS:,of the IPRTR port, set to "ENABLED").

The following values are allowed:

Allowed values for the service class. | Meaning
DFT (or D) | Default service class, the one set in the COSDFT: parameter of the IPRTR port, is assigned to datagram.
HIGH (or H) | "High" service class is assigned.
NORMAL (or N) | "Normal" service class is assigned.
LOW (or L) | "Low" service class is assigned.
SA: | IP source address or interval of addresses.
none | see table, x.x.x.x:y.y.y.y, *, 'list'

It sets the IP address (interval of addresses) that the datagrams source address has to match (or be contained in) for satisfying the filter. The allowed IP addresses must have the decimal dot notation and be contained in the intervals defined in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not actually supported.

Couples of IP addresses are also supported in the decimal dot notation, if separated by the character ':' (colon), for example: 192.168.000.210:192.168.000.250.

The value "*" when used, means "any IP source address": any IP source address is, in this way, accepted.

The name of an Elements List of type IP or IR or RU or MR is also supported, if between primes, for example: 'My_List'.

DA: | IP destination address or interval of addresses.
none | see table, x.x.x.x:y.y.y.y, *, 'list'

It sets the IP address (IP interval of addresses) that the datagrams destination address has to match (or be contained in) for satisfying the filter. The allowed IP addresses must have the decimal dot notation and be contained in the intervals defined in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not actually supported.

Couples of IP addresses are also supported in the decimal dot notation, if separated by the character ':' (colon), for example: 192.168.000.210:192.168.000.250.

The value "*" when used, means "any IP destination address": any IP destination address is, in this way, accepted.

The name of an Elements List of type IP or IR or RU or MR is also supported, if between primes, for example: 'My_List'.

PROT: | Internet protocol
none | 1 - 254 (or correspondent mnemonic), *, tcpudp, 'list'

It sets the Internet protocol where the filter can be applied on.

The protocol can be specified through the mnemonic or the numeric value correspondent to it, for example: 6 or "tcp", 17 or "udp".

The value "*" means "any Internet protocol" and it allows accepting every Internet protocol.

The value "tcpudp" means "tcp and/or udp protocols" and it allows accepting both tcp and udp protocols.

The name of an Elements List of type IPT or RU or MR is also supported, if between primes, for example: 'My_List'.

SPO: | Source port or interval of source ports (only for PROT:tcp/udp)
none | 1 - 65535 (or correspondent mnemonic), *, 'list'

This parameter is used only for TCP and UDP protocols type. It sets the source port (interval of ports) that the datagrams source port has to match (or be contained in), for satisfying the filter.

Numerical values are allowed in the interval [1 - 65535], or for port from 1 up to 1024, the mnemonic of the service (TCP or UDP) associated to them: for example 23 or "telnet", 161 or "snmp".

Couples of numeric values are also accepted, if separated by the character ':' (colon), for example: 1:1024.

The value "*" when used, means "any port": it allows accepting any source TCP/UDP port.

The name of an Elements List of type TUP or RU or MR is also supported, if between primes, for example: 'My_List'.

DPO: | Destination port or interval of destination ports (only for PROT:tcp/udp)
none | 1 - 65535 (or correspondent mnemonic), *, 'list'

This parameter is used only for TCP and UDP protocols type. It sets the destination port (interval of ports) that the datagrams destination port has to match (or be contained in), for satisfying the filter.

Numerical values are allowed in the interval [1 - 65535], or for port from 1 up to 1024, the mnemonic of the service (TCP or UDP) associated to them: for example 23 or "telnet", 161 or "snmp".

Couples of numeric values are also accepted, if separated by the character ':' (colon), for example: 1:1024.

The value "*" when used, means "any port": it allows accepting any destination TCP/UDP port.

The name of an Elements List of type TUP or RU or MR is also supported, if between primes, for example: 'My_List'.

PO: | Port or interval of source/destination ports. (only for PROT:tcp/udp)
none | 1 - 65535 (or correspondent mnemonic), *, 'list'

This parameter is used only for TCP and UDP protocols type, in alternative to the parameters SPO: and DPO:. It sets the port value (or an interval of values) that the datagram source or destination port has to match (or be contained in) for satisfying the filter.

Numerical values are allowed in the interval [1 - 65535], or for port from 1 up to 1024, the mnemonic of the service (TCP or UDP) associated to them: for example 23 or "telnet", 161 or "snmp".

Couples of numeric values are also accepted, if separated by the character ':' (colon), for example: 1:1024.

The value "*" when used, means "any port": it allows accepting any destination or any source TCP/UDP port.

The name of an Elements List of type TUP or RU or MR is also supported, if between primes, for example: 'My_List'.

SIPP: | IP port from where the datagram would come in
* | 0 - 63, INT, *

It sets the IP port from where the datagrams have to come in for matching the filter.

The value "*" means "any IP port": it allows accepting any IP port.

The value "INT" means "internal IP port": it allows accepting datagrams coming from any internal IP port.

DIPP: | IP port where the datagram would be routed to
* | 0 - 63, INT, *

It sets the IP port where the datagrams have to be routed to for matching the filter.

The value "*" means "any IP port": it allows accepting any IP port.

The value "INT" means "internal IP port": it allows accepting datagrams routed to any internal IP port.

CRDIR: | Activating the encryption/decryption of datagram matching the IP access list.
none | NONE, ENCRYPT, DECRYPT

It specifies whether the datagrams, matching the filter, have to be routed transparently (value "NONE") or they have to be encrypted (value "ENCRYPT") or decrypted (value "DECRYPT").

CRKEY: | Index of the cryptographic key (Only for CRDIR:ENCRYPT/DECRYPT)
DFT | DFT, 1 - 63

It defines the cryptographic key to be used for datagrams matching the filter.

User can choose to use the default cryptographic key ("CRKEY:DFT") provided by the system, or one of the keys defined in a proper table, by indicating its index ([1 - 63]). If the specified value is meaningless, i.e. the correspondent key is not present in the table, the "CRKEY:" parameter value will be shown inside square brackets. For example "CRKEY:[5]" means that no key, whose index is "5", is present in the table.

The content of the parameter "CRKEY:" is considered only if the parameter CRDIR: is not set to "NONE".


The Routing Information Protocol (RIP) port

Configuration of the RIP port
Statistics of the RIP port

RIP External Routes filter table

The RIP port is used within the Abilis CPX to implement the homonym routing protocols RIP1 and RIP2 for TCP/IP networks.

The Routing Information Protocol (RIP) gets information about IP networks routing and particularly it uses the Connection-Less transport service provided by the UDP protocol.

RIP1 and RIP2 protocols are based on periodic information extraction from IP Routings table and sending those informations to the neighbour systems.

Sent information consists of:

  • a list of destination networks managed by the IP router of Abilis CPX
  • the "distance" needed to reach the destination networks.

The "distance" or metric is estimated by RIP as the number of hops; a path to a destination on a network is a series of hops, through routers. If, for example, a destination network has metric equal to 3, it means it is reachable transiting through 3 networks.

The longest distance allowed by the protocol is 15 hops: a network, far more than 15 hops, is considered unreachable.

Configuration of the RIP port top

The RIP port is labelled within the Abilis CPX with the acronym "RIP" and it is provided with the parameters described in this section.

Here is an example on how to show the RIP parameters. Shown values are examples.

[13:25:49] ABILIS_CPX: D P PO:RIP

PO:903 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
RIP    ------------------------------------------------------------------------
       lowpo:902   ACT:YES  locport:520  fifo:15  max-routes:500    SH:PR
       AUT:NO      PWD:                  UT:30    LT:180   GT:120   ASBR:YES
       - ASBR section ---------------------------------------------------------
       LOCAL:YES           STATIC:YES           OSPF:NO
       LOCAL-METRIC:*      STATIC-METRIC:*      OSPF-METRIC:*
       DEF-METRIC:1

The parameters reported in the "ASBR section" are displayed only if the ASBR: parameter is set to "YES".

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the RIP port parameters

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be an UDP port.

Value "NONE" isolates the RIP port.

ACT: | Routing functionalities activation
NO | NO, YES

It activates the routing functionalities above mentioned. If the parameter is set to "NO", even if the RIP port is configured and active, it won't carry out any functionality within the system.

locport: | Identifier of the IP local port used
520 | 520

It sets the local IP port used by the RIP port.

The IP number assigned by default to the RIP service is 520.

The parameter has got only an informative value, it cannot be modified.

fifo: | Size of the receiving FIFO
15 | 1 - 50

It sets the number of buffers available in the FIFO for receiving from the RIP port. Once the FIFO is full, the RIP port won't be able to receive datagram any more. The datagrams sent to it will be discarded by the UDP lower level port.

max-routes: | Maximum number of routing that the RIP table can store.
500 | 500 - 10000

If the table will be full, no more routings can be added and an informative message will be shown in the System Log.

SH: | Selection of routing update mode
PR | NO, YES, PR

This parameter set the routing update mode used by the RIP port.

Value | Meaning
NO | Update information sent by the RIP ports on the net will include all the IP routings stored in the IP routing table
YES | Update information sent by the RIP ports on the net will only include those routings not obtained from the interface where the information are sent to. This updating procedure is referred as Split Horizon.
PR | Routings should not be included in the update information, however they are sent as well but their metric is set to 16 hops. This updating procedure is referred as Split Horizon and Poison Reverse

AUT: | Selection of the authentication functionality
NO | NO, STD, MD5

This parameter set the authentication functionality of information received and forwarded by the RIP port.

Value | Meaning
NO | NO authentication is applied on the information exchanged by the Abilis CPX with other routers
STD | Authentication algorithm includes sending update messages of the password as it is set in the parameter PWD:
MD5 | The algorithm MD5 is used for authenticating the update messages (requested by the RFC1321) jointly with the password set in the parameter PWD:

PWD: | Authentication password
none | from 0 up to 16 ASCII characters [33..126]

The parameter set the password used for the authentication function.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made

Once it is configured, the password is saved on disk encrypted.

To delete the access password do not set the value of the parameter: "S P PO:xxx PWD:", where "xxx" stands for the RIP port identifier.

UT: | Time interval between two consecutive generations of update messages
30 | 10 - 600 (in seconds)

It sets the time interval that the RIP port has to wait, before generating the next update message of routing information to be forwarded to other routers.

LT: | Route Life Time
180 | 30 - 1800 (in seconds)

This parameter set the time interval during which an IP routing is considered valid, even if no update has been received. When this interval elapses the routing becomes invalid and the RIP will delete it only after GT: seconds in order to allow the network other routers to be updated.

GT: | Garbage Collection Period
120 | 10 - 1800 (in seconds)

It sets how long the IP invalid routings have to be stored in the IP routing table. When this time interval elapses the IP routing is deleted.

ASBR: | Defines this router as Autonomous System Boundary Router (ASBR).
YES | YES, NO

ASBR router locates in point where RIP AS connects with other AS that does not use RIP routing protocol. ASBR router can redistribute routes between different AS.
Usually this parameter will set to YES, because only in this case RIP can import external routing. In fact, in case that ASBR is set to NO, RIP table will be filled only by routings obtained by other RIP routers in the network.

LOCAL: | ASBR LOCAL activation
YES | YES, NO

It enables/disables the use of LOCAL (connected) routes present in the routes table of IPRTR for redistribution into RIP.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

STATIC: | ASBR STATIC activation
YES | YES, NO

It enables/disables the use of STATIC routes present in the routes table of IPRTR for redistribution into RIP.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

OSPF: | ASBR OSPF activation
NO | YES, NO

It enables/disables the use of OSPF routes present in the routes table of IPRTR for redistribution into RIP.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

LOCAL-METRIC: | ASBR LOCAL metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of LOCAL type, imported from the IPRTR route table into RIP.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

STATIC-METRIC: | ASBR STATIC metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of STATIC type, imported from the IPRTR route table into RIP.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

OSPF-METRIC: | ASBR OSPF metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of OSPF type, imported from the IPRTR route table into RIP.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

DEF-METRIC: | ASBR DEFAULT metric
1 | 0 - 16

It sets the default metric value that will be used for redistribution routes, of any type, imported from the IPRTR route table into RIP.
Used when a "protocol specific" value does not override it, i.e.:

  • LOCAL-METRIC = * for local routes
  • STATIC-METRIC = * for static routes
  • OSPF-METRIC = * for OSPF routes
For specific routes this value may also be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

Statistics of the RIP port top

Here it is a sample of the D S command execution to check the state and statistics of the RIP port.

[14:43:54] ABILIS_CPX: D S PO:RIP

PO:903 ------------------------------------------------------------------------
RIP    STATE:INACTIVE
       ------------------------------------------------------------------------
       RIP ROUTINGS TABLE Diagnostics
       -----------|---State---|-Current%--|--Current--|---Peak----|----Max----|
       ROUTINGS   |NORMAL     |          0|          0|          0|        500|
       ------------------------------------------------------------------------
       CHANGES:0             QUERIES:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM-V1     |          0|          0|FRM-V2     |          0|          1|
       BAD-VER    |          0|           |BAD-CMD    |          0|           |
       BAD-ROUT   |          0|           |LOST       |           |          0|
       ------------------------------------------------------------------------

The RIP ports also have extended statistics that can be displayed by the execution of the command D SE:

PO:903 ------------------------------------------------------------------------
RIP    --- Cleared 000:20:06:10 ago, on 17/03/2004 at 20:11:35 ----------------
       CHANGES:0             QUERIES:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM-V1     |          0|          0|FRM-V2     |          0|          1|
       BAD-VER    |          0|           |BAD-ROUT   |          0|           |
       REQ-UPD    |          0|          1|RESP-UPD   |           |          0|
       NORM-UPD   |           |          0|FLASH-UPD  |           |          0|
       REQ-CMD    |          0|          1|RESP-CMD   |          0|          0|
       OTHER-CMD  |          0|          0|BAD-CMD    |          0|           |
       LOST       |           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the RIP port

STATE: | Current state of the RIP port
 | INACTIVE, READY, DOWN, ERR

It shows the current state of the RIP port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
RIP | INACTIVE | The configuration parameter ACT: is set to "NO". As consequence the driver is active, but not working. By setting its value to "YES" and executing the command INIT PO:the driver will be effectively activated. |  |  | IN
 | READY | The configuration parameter ACT: is set to "YES" and driver is successfully connected to the UDP port. It is ready to work. |  |  | RD
 | DOWN | The configuration parameter ACT: is set to "YES" but the driver is not connected to the UDP port or the parameter LOWPO: is set to NONE. |  |  | DN
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

ROUTINGS - State | Current state of the RIP routing table
 | NORMAL, WARNING, DANGER, OVERFLOW

Indicates the current state of the RIP routing table. Depending on the number of routings present into table, possible routing table states are:

States | Description
NORMAL | Used routings are less than 60%.
WARNING | Used routings went over 60%. A DANGER_IN message will be written in the System Log. To go back to normal, routings must decrease to 55%.
DANGER | Used routings went over 80%. To go back to warning, routings must decrease to 75%. A DANGER_OUT message will be written in the System Log.
OVERFLOW | routings used reached 100%. An OVERFLOW message will be written in the System Log.

ROUTINGS - Current% | Current routing percentage
 | 0 - 100

Indicates the current PERCENTAGE of routings present into routing table.

ROUTINGS - Current | Current routing number
 | 0 - MAX-ROUTES

Indicates the current NUMBER of routings present into routing table.

ROUTINGS - Peak | Maximum routing peak
 | 0 - MAX-ROUTES

Indicates the maximum number of routings reached from start-up into table.

ROUTINGS - Max | Maximum number of routings present into table
 | MAX-ROUTES

This information indicate the MAX-ROUTES parameter present into RIP port.

CHANGES: | Number of changes of the IP routing table
 | 0 - 4.294.967.295

The counter CHANGES shows the number of changes made by the RIP on the IP routing table.

QUERIES: | Number of responses sent to the queries received from other routers
 | 0 - 4.294.967.295

It shows the number of responses sent by the RIP port to the queries received from other routers.

FRM-V1 | Number of RIP version 1 messages sent/received
 | 0 - 4.294.967.295

The counter FRM-V1 (INPUT) shows the number of RIP version 1 messages received. The counter FRM-V1 (OUTPUT) shows the number of RIP version 1 messages sent.

FRM-V2 | Number of RIP version 2 messages sent/received
 | 0 - 4.294.967.295

The counter FRM-V2 (INPUT) shows the number of RIP version 2 messages received. The counter FRM-V2 (OUTPUT) shows the number of RIP version 2 messages sent.

BAD-VER | Overall number of messages received with a bad RIP version
 | 0 - 4.294.967.295

The counter BAD-VER (INPUT) is incremented every time the RIP port receives a datagram whose RIP protocol version is bad.

BAD-CMD | Overall number of messages received with a bad RIP command
 | 0 - 4.294.967.295

The counter BAD-CMD (INPUT) is incremented every time the RIP port receives a message with a bad command.

BAD-ROUT | Overall number of messages received with a bad routing
 | 0 - 4.294.967.295

The counter BAD-ROUT (INPUT) shows the number of routing received by the RIP port whose IP network address or IP gateway address is not valid. They will be discarded.

The not valid addresses are LOOPBACK, BROADCAST, MULTICAST and all those address higher than the C class addresses.

LOST | Overall number of messages lost during transmission
 | 0 - 4.294.967.295

The counter LOST (OUTPUT) is incremented every time a sent datagram is lost.

REQ-UPD | Number of update request received/sent
 | 0 - 4.294.967.295

The counter REQ-UDP (INPUT) is incremented every time the RIP port receives an update request. The counter REQ-UDP (OUTPUT) is incremented every time the RIP port sends an update request.

RESP-UPD | Number of responses (sent/received) to the update request
 | 0 - 4.294.967.295

The counter RESP-UDP (INPUT) is incremented every time the RIP port receives a response to an update request. The counter RESP-UDP (OUTPUT) is incremented every time the RIP port sends a response to an update request.

NORM-UPD | Number of "NORMAL" update messages sent/received
 | 0 - 4.294.967.295

The counter NORM-UDP (INPUT) is incremented every time the RIP port receives a "NORMAL" update message. The counter NORM-UDP (OUTPUT) is incremented every time the RIP port sends a "NORMAL" update message.

FLASH-UPD | Number of "FLASH" update messages sent/received
 | 0 - 4.294.967.295

The counter NORM-UDP (INPUT) is incremented every time the RIP port receives a "FLASH" update message. The counter RESP-UDP (OUTPUT) is incremented every time the RIP port sends a "FLASH" update message.

REQ-CMD | Number of datagrams with a REQUEST command sent/received
 | 0 - 4.294.967.295

The counter REQ-CMD (INPUT) is incremented every time the RIP port receives a REQUEST command. The counter REQ-CMD (OUTPUT) is incremented every time the RIP port sends a REQUEST command.

RESP-CMD | Number of datagrams with a RESPONSE command sent/received
 | 0 - 4.294.967.295

The counter RESP-CMD (INPUT) is incremented every time the RIP port receives a RESPONSE command. The counter RESP-CMD (OUTPUT) is incremented every time the RIP port sends a RESPONSE command.

OTHER-CMD | Number of datagrams sent/received with a command different from REQUEST or RESPONSE
 | 0 - 4.294.967.295

The counter OTHER-CMD (INPUT and OUTPUT) shows the number of command frames (received/sent) different from REQUEST and RESPONSE.


The Open Shortest Path First (OSPF) Version 2 port

Protocol overview
Terminology
Types of OSPF packets

Configuration of the OSPF port
Statistics of the OSPF port

Configuration of OSPF tables

Configuration examples

The Open Shortest Path First (OSPF) is classified as an Interior Gateway Protocol (IGP).
This means that it distributes routing information between routers belonging to a single Autonomous System.
The Open Shortest Path First (OSPF) protocol is based on link-state or SPF technology.

Protocol overview top

The Open Shortest Path First (OSPF) protocol routes IP datagrams based solely on the destination IP address found in the IP datagram header. IP datagrams are routed "as they are", i.e. they are not encapsulated in any further protocol headers as they transit the Autonomous System (AS).
OSPF is a dynamic routing protocol. It quickly detects topological changes in the Autonomous System (such as router interface failures) and calculates new loop-free routes after a period of convergence.
This period of convergence is short and involves a minimum of routing traffic.

In a link-state routing protocol, each router maintains a database describing the Autonomous System's topology.
This database is referred to as the link-state database. Each participating router has an identical database. Each individual piece of this database is a particular router's local state, e.g. the router's usable interfaces and reachable neighbors. The router distributes its local state throughout the Autonomous System by flooding.

All routers run exactly the same algorithm, in parallel. From the link-state database, each router constructs a tree of shortest paths with itself as root. This shortest-path tree gives the route to each destination in the Autonomous System. Externally derived routing information appears on the tree as leaves.

The Open Shortest Path First (OSPF) protocol allows sets of networks to be grouped together.
Such a grouping is called an area.
The topology of an area is hidden from the rest of the Autonomous System. This information hiding enables a significant reduction in routing traffic. Also, routing within the area is determined only by the area's own topology, lending the area protection from bad routing data.
An area is a generalization of an IP subnetted network.

The Open Shortest Path First (OSPF) protocol enables the flexible configuration of IP subnets. Each route distributed by OSPF has a destination and mask. Two different subnets of the same IP network number may have different sizes (i.e. different masks). This is commonly referred to as variable length subnetting.
A datagram is routed to the best (i.e., longest or most specific) match. Host routes are considered to be subnets whose masks are "all ones" (0xFFFFFFFF).

All OSPF protocol exchanges are authenticated. This means that only trusted routers can participate in the Autonomous System's routing. A variety of authentication schemes can be used: in fact, separate authentication schemes can be configured for each IP subnet.

Externally derived routing data (e.g. routes learned from an Exterior Gateway Protocol such as BGP) is advertised throughout the Autonomous System. This externally derived data is kept separate from the OSPF protocol's link state data. Each external route can also be tagged by the advertising router, enabling the passing of additional information between routers on the boundary of the Autonomous System.

Terminology top

Router. A level three Internet Protocol packet switch. Formerly called a gateway in much of the IP literature.

Autonomous System (AS). A group of routers exchanging routing information via a common routing protocol. Abbreviated as AS.

Interior Gateway Protocol (IGP). The routing protocol spoken by the routers belonging to an Autonomous system. Abbreviated as IGP. Each Autonomous System has a single IGP. Separate Autonomous Systems may be running different IGPs.

Router ID. A 32-bit number assigned to each router running the OSPF protocol. This number uniquely identifies the router within an Autonomous System.

Network. In this documentation, an IP network/subnet/supernet. It is possible for one physical network to be assigned multiple IP network/subnet numbers. We consider these to be separate networks. Point-to-point physical networks are an exception - they are considered a single network no matter how many (if any at all) IP network/subnet numbers are assigned to them.

Network mask. A 32-bit number indicating the range of IP addresses residing on a single IP network/subnet/supernet. This specification displays network masks as hexadecimal numbers. For example, the network mask for a class C IP network is displayed as 0xFFFFFF00. Such a mask is often displayed elsewhere in the literature as 255.255.255.0.

Multi-access networks.Those physical networks that support the attachment of multiple (more than two) routers. Each pair of routers on such a network is assumed to be able to communicate directly (e.g., multi-drop networks are excluded).

Area. OSPF allows collections of contiguous networks and hosts to be grouped together. Such a group, together with the routers having interfaces to any one of the included networks, is called an area. Each area runs a separate copy of the basic link-state routing algorithm. This means that each area has its own topological database and corresponding graph. The topology of an area is invisible from the outside of the area. Conversely, routers internal to a given area know nothing of the detailed topology external to the area. This isolation of knowledge enables the protocol to effect a marked reduction in routing traffic as compared to treating the entire Autonomous System as a single link-state domain.

Area ID. This is a 32-bit number that identifies the area. The Area ID of 0.0.0.0 is reserved for the backbone. If the area represents a subnetted network, the IP network number of the subnetted network may be used for the Area ID.

The backbone area of the Autonomous System.The backbone area consists of those networks not contained in any area, their attached routers, and those routers that belong to multiple areas. The backbone must be contiguous.

The Virtual Link. It is possible to define areas in such a way that the backbone is no longer contiguous. In this case the system administrator must restore backbone connectivity by configuring virtual links. Virtual links can be configured between any two backbone routers that have an interface to a common non-backbone area. Virtual links belong to the backbone. The protocol treats two routers joined by a virtual link as if they were connected by an unnumbered point-to-point network. On the graph of the backbone, two such routers are joined by arcs whose costs are the intra-area distances between the two routers. The routing protocol traffic that flows along the virtual link uses intra-area routing only.

Interface. The connection between a router and one of its attached networks. An interface has state information associated with it, which is obtained from the underlying lower level protocols and the routing protocol itself. An interface to a network has associated with it a single IP address and mask (unless the network is an unnumbered point-to-point network). An interface is sometimes also referred to as a link.

Neighboring routers. Two routers that have interfaces to a common network. On multi-access networks, neighbors are dynamically discovered by OSPF's Hello Protocol.

Adjacency. A relationship formed between selected neighboring routers for the purpose of exchanging routing information. Not every pair of neighboring routers become adjacent.

Link state advertisement. Describes the local state of a router or network. This includes the state of the router's interfaces and adjacencies. Each link state advertisement is flooded throughout the routing domain. The collected link state advertisements of all routers and networks form the protocol's topological database.

Hello Protocol. The part of the OSPF protocol used to establish and maintain neighbor relationships. On multi-access networks the Hello Protocol can also dynamically discover neighboring routers.

Designated Router. Each multi-access network that has at least two attached routers has a Designated Router. The Designated Router generates a link state advertisement for the multi-access network and has other special responsibilities in the running of the protocol. The Designated Router is elected by the Hello Protocol. The Designated Router concept enables a reduction in the number of adjacencies required on a multi-access network. This in turn reduces the amount of routing protocol traffic and the size of the topological database.

Backup Designated Router. In order to make the transition to a new Designated Router smoother, there is a Backup Designated Router for each multi-access network. The Backup Designated Router is also adjacent to all routers on the network, and becomes Designated Router when the previous Designated Router fails. If there were no Backup Designated Router, when a new Designated Router became necessary, new adjacencies would have to be formed between the new Designated Router and all other routers attached to the network.

Point-to-point networks. A network that joins a single pair of routers. A 56Kb serial line is an example of a point-to-point network.

Broadcast networks. Networks supporting many (more than two) attached routers, together with the capability to address a single physical message to all of the attached routers (broadcast). Neighboring routers are discovered dynamically on these nets using OSPF's Hello Protocol. The Hello Protocol itself takes advantage of the broadcast capability. The protocol makes further use of multicast capabilities, if they exist. An ethernet is an example of a broadcast network.

Non-broadcast networks. Networks supporting many (more tan two) routers, but having no broadcast capability. Neighboring routers are also discovered on these nets using OSPF's Hello Protocol. However, due to the lack of broadcast capability, some configuration information is necessary for the correct operation of the Hello Protocol. On these networks, OSPF protocol packets that are normally multicast need to be sent to each neighboring router, in turn. An X.25 Public Data Network (PDN) is an example of a non-broadcast network.

Internal routers. A router with all directly connected networks belonging to the same area. Routers with only backbone interfaces also belong to this category. These routers run a single copy of the basic routing algorithm.

Area border routers (ABR). A router that is attacheed to multiple areas. Area border routers run multiple copies of the basic algorithm, one copy for each attached area and an additional copy for the backbone. Area border routers condense the topological information of their attached areas for distribution to the backbone. The backbone in turn distributes the information to the other areas.

Backbone routers. A router that has an interface to the backbone. This includes all routers that interface to more than one area (i.e., area border routers). However, backbone routers do not have to be area border routers. Routers with all interfaces connected to the backbone are considered to be internal routers.

AS boundary routers. (ASBR) A router that exchanges routing information with routers belonging to other Autonomous Systems. Such a router has AS external routes that are advertised throughout the Autonomous System. The path to each AS boundary router is known by every router in the AS. This classification is completely independent of the previous classifications: AS boundary routers may be internal or area border routers, and may or may not participate in the backbone.

Host. Hosts attached directly to routers (referred to as host routes) appear on the graph as stub networks. The network mask for a host route is always 0xFFFFFFFF, which indicates the presence of a single node.

Stub areas. In some Autonomous Systems, the majority of the topological database may consist of AS external advertisements. An OSPF AS external advertisement is usually flooded throughout the entire AS. However, OSPF allows certain areas to be configured as "stub areas". AS external advertisements are not flooded into/throughout stub areas; routing to AS external destinations in these areas is based on a (per-area) default only. This reduces the topological database size, and therefore the memory requirements, for a stub area's internal routers. The OSPF protocol ensures that all routers belonging to an area agree on whether the area has been configured as a stub. This guarantees that no confusion will arise in the flooding of AS external advertisements. There are a couple of restrictions on the use of stub areas. Virtual links cannot be configured through stub areas. In addition, AS boundary routers cannot be placed internal to stub areas.

List of address ranges. An OSPF area is defined as a list of address ranges. Each address range consists of the following items:

  • [IP address, mask]. Describes the collection of IP addresses contained in the address range. Networks and hosts are assigned to an area depending on whether their addresses fall into one of the area's defining address ranges. Routers are viewed as belonging to multiple areas, depending on their attached networks' area membership.
  • Status. Set to either Advertise or DoNotAdvertise. Routing information is condensed at area boundaries. External to the area, at most a single route is advertised (via a summary link advertisement) for each address range. The route is advertised if and only if the address range's Status is set to Advertise. Unadvertised ranges allow the existence of certain networks to be intentionally hidden from other areas. Status is set to Advertise by default.

Types of OSPF packets top

The Open Shortest Path First (OSPF) protocol runs directly over IP, using IP protocol 89. It does not provide any explicit fragmentation/reassembly support.
When fragmentation is necessary, IP fragmentation/reassembly is used. OSPF protocol packets have been designed so that large protocol packets can generally be split into several smaller protocol packets.
This practice is recommended; IP fragmentation should be avoided whenever possible.

OSPF protocol uses the types of packets that are described below:

HELLO | The Hello packet (Hello) | These packets are sent periodically on all interfaces (including virtual links) in order to establish and maintain neighbor relationships. In addition, Hello Packets are multicast on those physical networks having a multicast or broadcast capability, enabling dynamic discovery of neighboring routers.
DD | The Database Description packet | These packets are exchanged when an adjacency is being initialized. They describe the contents of the topological database. Multiple packets may be used to describe the database. For this purpose a poll-response procedure is used.
LSR | The Link State Request packet | After exchanging Database Description packets with a neighboring router, a router may find that parts of its topological database are out of date. The Link State Request packet is used to request the pieces of the neighbor's database that are more up to date. Multiple Link State Request packets may need to be used. The sending of Link State Request packets is the last step in bringing up an adjacency.
LSU | The Link State Update packet | These packets implement the flooding of link state advertisements. Each Link State Update packet carries a collection of link state advertisements one hop further from its origin. Several link state advertisements may be included in a single packet. Link State Update packets are multicast on those physical networks that support multicast/broadcast. In order to make the flooding procedure reliable, flooded advertisements are acknowledged in Link State Acknowledgment packets. If retransmission of certain advertisements is necessary, the retransmitted advertisements are always carried by unicast Link State Update packets.
LSA | The Link State Acknowledgment packet | To make the flooding of link state advertisements reliable, flooded advertisements are explicitly acknowledged. This acknowledgment is accomplished through the sending and receiving of Link State Acknowledgment packets. Multiple link state advertisements can be acknowledged in a single Link State Acknowledgment packet.

Configuration of the OSPF port top

The Open Shortest Path First (OSPF) port is referred by the "OSPF" abbreviation and it has all the parameters described in this chapter.

Here there is an example of the OSPF port parameters. Displayed values are the default ones.

[00:50:16] ABILIS_CPX: D P PO:OSPF

PO:913 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
OSPF   ------------------------------------------------------------------------
       LOG:DS       ACT:NO        max-lsa:200      max-routes:500
       RFC1583COMP:YES            OSPF-RID:AUTO (192.168.000.060)   ASBR:YES
       - ASBR section ---------------------------------------------------------
       LOCAL:NO            STATIC:NO            RIP:NO
       LOCAL-METRIC:*      STATIC-METRIC:*      RIP-METRIC:*
       DEF-METRIC:1

The parameters reported in the "ASBR section" are displayed only if the ASBR: parameter is set to "YES".

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on low case parameters it is enough to execute the initialization command INIT PO:.
The changes made on the LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Details of the OSPF port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

OSPF_ACT: | OSPF runtime activation/deactivation
NO | NO, YES

NO: OSPF is disabled.

YES: OSPF is enabled.

max-lsa: | The size of LSA's database
200 | 1 - 1500

The router use LSA's database for detecting state of links between routers this AS. A router generate some LSA that describe a state of its interfaces. All routers belong to one area have copys of all this LSAs in their LSA's database. That is why the size of LSA's database can be large. To calculate a precision size of LSA database not simply. It depends of many other paramaters (count of areas, count of neighbors, etc).

max-routes: | The size of the route table
500 | 1 - 10000

The route table of each OSPF route is contain routes to points of destination. This table is contain as routes that was detected during work OSPF protocol as routes that was received from other routing protocols.

RFC1583COMP: | Enable/disable compatibility with RFC1583
YES | NO, YES

This parameter permit OSPF compatibility with RFC 1583. In order to minimize the chance of routing loops, all OSPF routers in an OSPF routing domain should have RFC1583COMP set identically.

OSPF-RID: | OSPF Router ID
AUTO | AUTO, 0.0.0.0 - 255.255.255.255

This parameter allows to set the OSPF Router ID.

ASBR: | Defines this router as Autonomous System Boundary Router (ASBR)
YES | YES, NO

ASBR router locates in point where OSPF AS connects with other AS that does not use OSPF routing protocol. ASBR router can redistribute routes between different AS.
Usually this parameter will set to YES, because only in this case OSPF can import external routing. In fact, in case that ASBR is set to NO, OSPF table will be filled only by routings obtained by other OSPF routers in the network.

LOCAL: | ASBR LOCAL activation
YES | YES, NO

It enables/disables the use of LOCAL (connected) routes present in the routes table of IPRTR for redistribution into OSPF.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

STATIC: | ASBR STATIC activation
YES | YES, NO

It enables/disables the use of STATIC routes present in the routes table of IPRTR for redistribution into OSPF.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

RIP: | ASBR RIP activation
NO | YES, NO

It enables/disables the use of RIP routes present in the routes table of IPRTR for redistribution into OSPF.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

LOCAL-METRIC: | ASBR LOCAL metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of LOCAL type, imported from the IPRTR route table into OSPF.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

STATIC-METRIC: | ASBR STATIC metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of STATIC type, imported from the IPRTR route table into OSPF.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

RIP-METRIC: | ASBR RIP metric
* | 0 - 16, *

It sets the default metric value that will be used for redistribution routes, of RIP type, imported from the IPRTR route table into OSPF.

The value "*" stands for "use default", i.e. indicates to use the DEF-METRIC: parameter value.

For specific routes this value may be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

DEF-METRIC: | ASBR DEFAULT metric
1 | 0 - 16

It sets the default metric value that will be used for redistribution routes, of any type, imported from the IPRTR route table into OSPF.
Used when a "protocol specific" value does not override it, i.e.:

  • LOCAL-METRIC = * for local routes
  • STATIC-METRIC = * for static routes
  • RIP-METRIC = * for RIP routes

For specific routes this value may also be overriden by a "not-*" value in the External routes.

This parameter is diaplyed and can be set only when ASBR: parameter is set to "YES".

Statistics of the OSPF port top

How to check the state and statistics of the OSPF ports by the command D S.

[14:43:54] ABILIS_CPX: D S PO:OSPF

PO:910 ------------------------------------------------------------------------
OSPF   STATE:READY    ID:00000000 ITF:3   AREA:2    RANGE:0  HOST:1    NEI:8
       ------------------------------------------------------------------------
       OSPF ROUTINGS TABLE Diagnostics
       -----------|---State---|-Current%--|--Current--|---Peak----|----Max----|
       LSA ARRAY  |NORMAL     |          5|         11|         11|        200|
       ROUTE TABLE|NORMAL     |          0|          0|          0|        500|
       ------------------------------------------------------------------------
       INTERFACE Diagnostics
       -Itf-|--IP Address---|----AREA ID----|------TYPE-------|-----STATE-----|
        0   |192.168.000.200|010.000.000.000|NonBroadcast     |DR             |
       ------------------------------------------------------------------------
       -Itf-|--IP Address---|----AREA ID----|------TYPE-------|-----STATE-----|
        1   |192.168.001.200|020.000.000.000|Broadcast        |DR-OTHER       |
       ------------------------------------------------------------------------

[14:43:54] ABILIS_CPX:

The OSPF ports also have extended statistics that can be displayed by the execution of the command D SE:

[14:45:06] ABILIS_CPX: D SE PO:OSPF

PO:910 ------------------------------------------------------------------------
OSPF   --- Cleared 000:00:02:21 ago, on 22/04/2003 at 09:56:10 ----------------
       ------------------------------------------------------------------------
       SENT:27          RECEIVED:0           DROPPED:0
       - INTERFACE Statistics -------------------------------------------------
       ITF:0    MAX-NEI:0      EVENTS:2
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRAME      |          0|         13|LOST       |          0|           |
       HELLO      |          0|         13|DD         |          0|          0|
       LSU        |          0|          0|LSR        |          0|          0|
       LSA        |          0|          0|           |           |           |
       ------------------------------------------------------------------------
       ITF:1    MAX-NEI:0      EVENTS:1
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRAME      |          0|         14|LOST       |          0|           |
       HELLO      |          0|         14|DD         |          0|          0|
       LSU        |          0|          0|LSR        |          0|          0|
       LSA        |          0|          0|           |           |           |
       ------------------------------------------------------------------------

[14:45:06] ABILIS_CPX:

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsesed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the OSPF ROUTING table diagnostic

STATE: | Current state of the OSPF port driver
 | INACTIVE, DOWN, READY, ERR

It shows the current state of the OSPF port.

Driver | States | Meaning | Value shown in:
 |  |  | System Log | Events Log | Display LCD
OSPF | INACTIVE | The configuration parameter ACT: is set to "NO". As consequence the driver is active, but not working. By setting its value to "YES" and executing the command INIT PO:the driver will be effectively activated. |  |  | IN
 | DOWN | The configuration parameter ACT: is set to "YES" but the driver is not connected to the IPRTR. |  |  | DN
 | READY | The configuration parameter ACT: is set to "YES" and driver is successfully connected to the UDP port. It is ready to work. |  |  | RD
 | ERR | Software error. Contact Abilis assistance. |  |  | NA

ID: | ROUTER ID
 | 00000000 - FFFFFFFF

Indicates the configured OSPF ROUTER-ID into hexadecimal format.

ITF: | Number of interfaces
 | 0 - 63

Number of IP interfaces configured (it counts also those interfaces that don't have RP:OSPF set).

AREA: | Number of areas
 | 0 - 255

Number of areas configured.

RANGE: | Number of ranges
 | 0 - 255

Number of ranges configured.

HOST: | Number of hosts
 | 0 - 255

Number of hosts configured.

NEI: | Max number of neighbours
 | 0 - 255

Maximum number of neighbours configurable by user.

State: | State of the LSA table
 | NORMAL, WARNING, DANGER, OVERFLOW

Indicates the state of the LSA table, depending on the number of routings present into table.

Possible LSA table states are:

  • NORMAL (routings used are less than 60%).
  • WARNING (routings used went over 60%. A DANGER_IN message will be written in the system LOG. To go back to normal, routings must decrease to 55%).
  • DANGER (routings used went over 80%. To go back to warning, routings must decrease to 75%. A DANGER_OUT message will be written in the system LOG).
  • OVERFLOW (routings used reached 100%. An OVERFLOW message will be written in the system LOG).
Current%: | Current LSA percentage
 | 0 - 100

Indicates the current PERCENTAGE of routings present into LSA table.

Current: | Current LSA routing number
 | 0 - max-lsa

Indicates the current NUMBER of routings present into LSA table.

Peak: | Maximum LSA routing peak
 | 0 - max-lsa

Indicates the maximum number of routings reached from start-up into LSA table.

Max: | Maximum number of routings present into LSA table
 | max-lsa

This information indicate the max-lsa parameter present into OSPF port.

State: | State of the ROUTING table
 | NORMAL, WARNING, DANGER, OVERFLOW

Indicates the state of the routing table, depending on the number of routings present into table.

Possible routing table states are:

  • NORMAL (routings used are less than 60%).
  • WARNING (routings used went over 60%. A DANGER_IN message will be written in the system LOG. To go back to normal, routings must decrease to 55%).
  • DANGER (routings used went over 80%. To go back to warning, routings must decrease to 75%. A DANGER_OUT message will be written in the system LOG).
  • OVERFLOW (routings used reached 100%. An OVERFLOW message will be written in the system LOG).
Current%: | Current routing percentage
 | 0 - 100

Indicates the current PERCENTAGE of routings present into routing table.

Current: | Current routing number
 | 0 - max-routes

Indicates the current NUMBER of routings present into routing table.

Peak: | Maximum routing peak
 | 0 - max-routes

Indicates the maximum number of routings reached from start-up into table.

Max: | Maximum number of routings present into table
 | max-routes

This information indicate the max-routes parameter present into OSPF port.

ITF: | Interface number
 | 0 - 63

Index referred to specific interface. All the following statistics/diagnostics informations refers to that interface.

IP Address: | Local IP address
 | 0.0.0.0 - 255.255.255.255

This information shows the IP address configured into specific IP interface.

AREA ID: | Area ID
 | 0.0.0.0 - 255.255.255.255

Indicates which area value is set for the specified interface.

TYPE: | Interface type
 | Broadcast, NonBroadcast, PointToPoint, VirtualLink, PointToMultipoint, ERR

Type of network which this interface is connected.

STATE: | Interface state
 | DOWN, LOOPBACK, WAITING, POINT-TO-POINT, DR-OTHER, BACKUP, DR, ERR

State of interface.

  • Down - This is the initial interface state.
  • Loopback - In this state, the router's interface to the network is looped back.
  • Waiting - In this state, the router is trying to determine the identity of the (Backup) Designated Router for the network.
  • Point-to-point - In this state, the interface is operational, and connects either to a physical point-to-point network or to a virtual link.
  • DR Other - The interface is to a multi-access network on which another router has been selected to be the Designated Router.
  • Backup - In this state, the router itself is the Backup Designated Router on the attached network.
  • DR - In this state, this router itself is the Designated Router on the attached network.
  • ERR - Interface do not work properly

Detail of state fields and statistics of the OSPF ports

SENT: | Total number of OSPF messages sent on all interfaces
 | 0 - 4.294.967.295

This counter is incremented every time an OSPF message is sent on an interface.

RECEIVED: | Total number of OSPF messages received from all interfaces
 | 0 - 4.294.967.295

This counter is incremented every time an OSPF message is received from an interface.

DROPPED: | Total number of OSPF dropped messages from all interfaces
 | 0 - 4.294.967.295

This counter is incremented every time an OSPF message is dropped.

MAX-NEI: | Maximum configurable neighbours
 | 0 - 4.294.967.295

This value indicates the maximum number of configurable neighbours into the specified interface.

EVENTS: | Number of events
 | 0 - 4.294.967.295

This value indicates the number of events happened into the specified interface. Each event may produce different effects, depending on the current state of the interface. Usually event initiates changing a state of the interface.

FRAME: | Number of OSPF packets sent/received
 | 0 - 4.294.967.295

The counter FRAME (INPUT) shows the number of OSPF packets received. The counter FRAME (OUTPUT) shows the number of OSPF packets sent.

LOST: | Number of OSPF packets lost
 | 0 - 4.294.967.295

The counter LOST (INPUT) is incremented every time the OSPF port receives a datagram whose OSPF protocol is bad or cannot be filled into queues.

HELLO: | Number of HELLO packets sent/received
 | 0 - 4.294.967.295

The counter HELLO (INPUT) shows the number of OSPF HELLO packets received. The counter HELLO (OUTPUT) shows the number of OSPF HELLO packets sent.

DD: | Number of DD packets sent/received
 | 0 - 4.294.967.295

The counter DD (INPUT) shows the number of OSPF DD packets received. The counter DD (OUTPUT) shows the number of OSPF DD packets sent.

LSU: | Number of LSU packets sent/received
 | 0 - 4.294.967.295

The counter LSU (INPUT) shows the number of OSPF LSU packets received. The counter LSU (OUTPUT) shows the number of OSPF LSU packets sent.

LSR: | Number of LSR packets sent/received
 | 0 - 4.294.967.295

The counter LSR (INPUT) shows the number of OSPF LSR packets received. The counter LSR (OUTPUT) shows the number of OSPF LSR packets sent.

LSA: | Number of LSA packets sent/received
 | 0 - 4.294.967.295

The counter LSA (INPUT) shows the number of OSPF LSA packets received. The counter LSA (OUTPUT) shows the number of OSPF LSA packets sent.


The Internet Protocol Security port (IPsec)

Revised for CPX 4.8.0.
Introduction
Terminology
Configuration of the IPsec port
Diagnostics of the IPsec port
Statistics of the IPsec port

Configuration of the IPsec port tables

The Internet Key Exchange port (IKE)

Configuration examples (CPX-to-CPX).
Configuration examples (CPX-to-Win2k/XP).

Introduction top

IPsec driver is designed to provide interoperable, high quality, cryptographically-based security for IP.
The set of security services offered includes access control, connectionless integrity, data origin authentication, protection against replays (a form of partial sequence integrity), confidentiality (encryption), and limited traffic flow confidentiality. These services are provided at the IP layer, offering protection for IP and/or upper layer protocols.

Terminology top

VPN. Virtual Private Network, a network which can safely be used as if it were private, even though some of its communication uses insecure connections. All traffic on those connections is encrypted. IPSEC. Internet Protocol Security, security functions authentication and encryption implemented at the IP level of the protocol stack.

AH. The IPsec Authentication Header protocol, added after the IP header and provides authentication service.

ESP. Encapsulated Security Payload, the IPsec protocol which provides encryption. It can also provide authentication service and may be used with null encryption (which we do not recommend).

SA. Security Association, the channel negotiated by the higher levels of an IPsec implementation and used by the lower ESP and AH protocols. SAs are unidirectional; you need a pair of them for two-way communication. An SA is defined by three things: the destination, the protocol (AH or ESP) and the SPI, security parameters index. It is used as an index to look up other things such as session keys and intialisation vectors.

SA bundle. or "security association bundle" is a sequence of SAs through which traffic must be processed to satisfy a security policy.

SPI. Security Parameter Index, an index used within IPsec to keep connections distinct. A Security Association (SA) is defined by destination, protocol and SPI. Without the SPI, two connections to the same gateway using the same protocol could not be distinguished.

Transport mode. An IPsec application in which the IPsec gateway is the destination of the protected packets, a machine acts as its own gateway. Contrast with tunnel mode.

Tunnel mode. An IPsec application in which an IPsec gateway provides protection for packets to and from other systems. Contrast with transport mode.

Configuration of the IPsec port top

The IPsec port is referred by the "IPsec" abbreviation and it has all the parameters described in this chapter.

Here is an example of the IPsec port parameters.

[18:18:41] ABILIS_CPX: D P PO:IPsec

PO:920 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:IKE     mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
The changes made on the LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Details of the IPsec port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ACT: | Runtime activation/deactivation of IPsec
NO | NO, YES

This parameter allows to run-time activate/deactive IPsec functionalities.

When it is set to "YES", the port is configured, active, and the IPsec driver performs its activities.

When it is set to "NO", the port is configured, active, but the IPsec driver does not execute any action.

MODE: | Working mode of IPsec
MANUAL | MANUAL, IKE

It specifies working mode of IPsec port.

When it is set to "MANUAL", the IPsec port is in manual mode and manipulates manually-keyed IPsec connections.

When it is set to "IKE", the IPsec port is in automatic IKE mode and manipulates automatically-keyed IPsec connections.
For IKE mode IKE driver must be configured and activated.

mxps: | Maximum length of IP datagram which can be processed by IPsec
2048 | 2048-4096

It specifies maximum length of IP datagram which can be processed by IPsec driver port.

This value cannot be changed without CPX restart.

IN-CHK: | Runtime activation/deactivation of IPsec inbound policy check
YES | NO, YES

Specifies inbound policy check flag of IPsec port.

When it is set to "YES", inbound policy check is ON.

When it is set to "NO", inbound policy check is OFF.

TTL: | IPsec IP Time-To-Live option
0 | 0, 1-255

Specifies the Time-To-Live field for the outer IP header in IPsec TUNNEL mode.

If value is not specified (equal to 0), TTL field will be copied from the inner IP header to the outer (tunnel) one.

If value is specified, TTL field of the outer IP header will be set to the specified value from the config.

ECN: | IPsec ECN consideration mode
FORBIDDEN | ALLOWED, FORBIDDEN, NOCARE

Specifies ECN consideration mode on IPsec tunnels in TUNNEL mode.

ALLOWED: draft-ietf-ipsec-ecn-02.txt - ECN-friendly IPSEC tunnel.

  • Encapsulate. Copy TOS bits except for ECN CE from inner to outer IP header. Set ECN CE bit to 0.
  • Decapsulate. Use inner TOS bits with some change. If outer ECN CE bit is 1, enable ECN CE bit on the inner IP header.

FORBIDDEN: draft-ietf-ipsec-ecn-02.txt - ECN-friendly IPSEC tunnel.

  • Encapsulate. Copy TOS bits except for ECN from inner to outer IP header. Set ECN bits to 0.
  • Decapsulate. Drop TOS bits on outer IP header. Use inner TOS bits as is.

NOCARE: RFC2401 - normal IPsec tunnel. No consideration for ECN.

  • Encapsulate. Copy all TOS bits from inner to outer IP header.
  • Decapsulate. Drop TOS bits on outer IP header. Use inner TOS bits as is.

General strategy for configuration is as follows:

  • if both IPsec tunnel endpoint are capable of ECN-friendly behavior, you'd better configure both end to "ECN allowed".
  • if the other end is very strict about TOS bit, use "RFC2401".
  • in other cases, use "ECN forbidden"
DF: | IPsec DF (Don't Fragment) bit manipulation mode
CLEAR | CLEAR, SET, COPY

Specifies DF (Don't Fragment) bit manipulation in IPsec TUNNEL mode during encapsulation.

CLEAR: Clear DF bit on outer IP header.

SET: Set DF bit on outer IP header.

COPY: Copy DF bit from inner to outer IP header.

Diagnostics of the IPsec port top

Example on how to show state and diagnostics of the IPsec through the command D S:

[15:00:45] ABILIS_CPX:D S PO:IPsec

PO:920 ------------------------------------------------------------------------
IPSEC  STATE:ACTIVE         MODE:IKE         IN-CHK:YES
       POLICY-IN :1         SA-IN :1         SA-BND-IN :1
       POLICY-OUT:1         SA-OUT:1         SA-BND-OUT:1
       - Security Associations diagnostics: -----------------------------------
       SA  Bundle State   SPI      SrcIp           Auth     SoftTime
           Prot   Tunnel           DstIp           Cipher   HardTime
       ------------------------------------------------------------------------
       0   0      MATURE  C4DCB36E 192.168.006.002 MD5      INFINITE
           ESP    YES              192.168.006.001 3DES     INFINITE
       ------------------------------------------------------------------------
       1   1      MATURE  1969FC22 192.168.006.001 MD5      INFINITE
           ESP    YES              192.168.006.002 3DES     INFINITE
       ------------------------------------------------------------------------

Detailes of the IPsec port diagnostics

STATE: | Current state of the IPsec port.
 | INACTIVE, ACTIVE

It shows the current state of the IPsec port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
IPsec | INACTIVE | IPsec port is running, but the ACT: parameter is set to "NO". |  |  | dn
 | ACTIVE | IPsec port is fully ready to work. |  |  | RD

MODE: | Working mode of the IPsec port.
 | MANUAL, IKE

It shows the current working mode of the IPsec port driver.

MANUAL: The IPsec port is in manual mode.
IKE: The IPsec port is in IKE mode. It is controlled by IKE driver.

IN-CHK: | IPsec port inbound policy check flag.
 | NO, YES

It shows state of the IPsec port inbound policy check flag.

POLICY-IN: | Number of inbound security policies.
 | 0-63

It shows number of installed inbound (IN) security policies in the policy table.

POLICY-OUT: | Number of outbound security policies.
 | 0-63

It shows number of installed outbound (OUT) security policies in the policy table.

SA-IN: | Number of inbound Security Associations.
 | 0-127

It shows number of installed inbound (IN) Security Associations in the SA table.

SA-OUT: | Number of outbound Security Associations.
 | 0-127

It shows number of installed outbound (OUT) Security Associations in the SA table.

SA-BND-IN: | Number of inbound Security Association bundles.
 | 0-127

It shows number of installed inbound (IN) Security Association bundles in the SA table.

SA-BND-OUT: | Number of outbound Security Association bundles.
 | 0-127

It shows number of installed outbound (OUT) Security Association bundles in the SA table.

Detailes of the IPsec Security Associations diagnostics

SA: | Identifier of Security Association record.
 | 0-127

It shows identifier of Security Association record Security Association bundles in the SA table.

Bundle: | Number of bundle of Security Association record.
 | 0-127

It shows number of bundle of Security Association record.

State: | State of Security Association record.
 | LARVAL, MATURE, DYING, DEAD

It shows state of Security Association record.

LARVAL: Security Association is one that was created by IKE, but is not working yet. Displayed in IKE mode only.
MATURE: Security Association is in working mode. In MANUAL mode Security Association always is in this state.
DYING: Security Association is one whose soft lifetime has expired. Displayed in IKE mode only.
DEAD: Security Association is one whose hard lifetime has expired, but hasn't been reaped by system garbage collection. Incoming and outgoing IP packets will be dropped. Displayed in IKE mode only.

SPI: | Security Parameter Index (SPI) of Security Association.
 | 0x100-0xFFFFFFFF

It shows Security Parameter Index (SPI) of Security Association.

In IKE mode this value is assigned by IKE driver.

Prot: | IPsec protocol of Security Association.
 | AH, ESP

It shows IPsec protocol of Security Association.

In IKE mode this value is assigned by IKE driver.

Tunnel: | Tunnel mode flag of Security Association.
 | NO, YES

It shows tunnel mode flag of Security Association.

NO: Security Association in transport mode.
YES: Security Association in tunnel mode.

In IKE mode this value is assigned by IKE driver.

SrcIp: | Source IP address of the Security Association.
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

It shows source IP address of the Security Association.

In IKE mode this value is assigned by IKE driver.

DstIp: | Destination IP address of the Security Association.
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

It shows destination IP address of the Security Association.

In IKE mode this value is assigned by IKE driver.

Auth: | Authentication method for the AH or ESP protocols.
 | MD5, SHA

It shows authentication method for the AH or ESP protocols for the Security Association.

In IKE mode this value is assigned by IKE driver.

Cipher: | Encryption algorithm for the ESP protocol.
 | DES, 3DES, IDEA, CAST, BLOWFISH

It shows encryption algorithm for ESP protocol for the Security Association.

In IKE mode this value is assigned by IKE driver.

Statistics of the IPsec port top

Example on how to show state and diagnostics of the IPsec port through the command D SE:

[15:00:45] ABILIS_CPX:D SE PO:IPsec

PO:920 ------------------------------------------------------------------------
IPSEC  --- Cleared 000:00:09:29 ago, on 22/03/2005 at 22:53:43 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRM        |        100|        694|CHR        |      23508|      41366|
       FRM-OK     |         65|         75|CHR-OK     |       7304|       4285|
       FRM-DROP   |          4|          0|CHR-DROP   |        116|          0|
       FRM-BYPASS |         31|        619|CHR-BYPASS |      16088|      37081|
       FRM-FRAG   |          0|           |CHR-FRAG   |          0|           |
       FRM-REASS  |          0|           |CHR-REASS  |          0|           |
       ------------------------------------------------------------------------
       FRM-IKE    |         31|         31|NATT-KA    |          4|          6|
       NO-POLICY  |          0|        598|LONG       |          0|          0|
       BAD-SA     |          0|          0|NO-SA      |          0|          0|
       BAD-FMT    |          0|          0|AUTH-FAIL  |          0|           |
       BAD-CBLK   |          0|           |BAD-CHK    |          0|           |
       REP-CHK    |          0|          0|BAD-ECN    |          0|           |
       ------------------------------------------------------------------------
       - Security Associations statistics: ------------------------------------
       SA:0    CHR:6264        AUTH-FAIL:0            BAD-CBLK:0
               FRM:65          REPLAY-CHK:0           BAD-ECN:0
       ------------------------------------------------------------------------
       SA:1    CHR:8424        AUTH-FAIL:0            BAD-CBLK:0
               FRM:75          REPLAY-CHK:0           BAD-ECN:0
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detailes of the IPsec port statistics

FRM: | Total number of IP frames received/sent by IPsec port from/to IP
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port receives a IP frame from IP.

The OUTPUT counter is incremented every time IPsec port sends a IP frame to IP

CHR: | Total number of characters received/sent by IPsec port from/to IP
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port receives a IP frame from IP.

The OUTPUT counter is incremented every time IPsec port sends a IP frame to IP.

FRM-OK: | Total number of successful processed incoming/outgoing IP frames
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port successful processes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port successful processes an outgoing IP frame.

CHR-OK: | Total number of successful processed incoming/outgoing characters
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port successful processes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port successful processes an outgoing IP frame.

FRM-OK: | Total number of successful processed incoming/outgoing IP frames
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port successful processes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port successful processes an outgoing IP frame.

CHR-OK: | Total number of successful processed incoming/outgoing characters
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port successful processes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port successful processes an outgoing IP frame.

FRM-DROP: | Total number of dropped incoming/outgoing IP frames
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame.

CHR-DROP: | Total number of dropped incoming/outgoing characters
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame.

FRM-BYPASS: | Total number of bypassed incoming/outgoing IP frames
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port bypasses an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port bypasses an outgoing IP frame.

CHR-BYPASS: | Total number of bypassed incoming/outgoing characters by IPsec port
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port bypasses an incoming IP frame.

The OUTPUT counter is incremented every time IPsec port bypasses an outgoing IP frame.

FRM-FRAG: | Total number of fragmented incoming IP frames
 | 0-4.294.967.295

The counter is incremented every time IPsec port receives a fragmented incoming IP frame.

CHR-FRAG: | Total number of characters from a fragmented incoming IP frames
 | 0-4.294.967.295

The counter is incremented every time IPsec port receives a fragmented incoming IP frame.

FRM-REASS: | Total number of reassembling incoming IP frames
 | 0-4.294.967.295

The counter is incremented every time IPsec port receives an incoming IP frame, which is reassembling.

CHR-REASS: | Total number of characters from a reassembling incoming IP frames
 | 0-4.294.967.295

The counter is incremented every time IPsec port receives an incoming IP frame, which is reassembling.

FRM-IKE: | Total number of bypassed incoming/outgoing IKE packets
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port bypasses an incoming IKE packet.

The OUTPUT counter is incremented every time IPsec port bypasses an outgoing IKE packet.

NATT-KA: | Total number of dropped incoming/outgoing NAT-traversal keep-alive packets
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming NAT-traversal keep-alive packet.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing NAT-traversal keep-alive packets.

NO-POLICY: | Total number of dropped incoming/outgoing IP frames, for which IPsec policy is not found
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame, for which inbound IPsec policy is not found.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame, for which outbound IPsec policy is not found.
Note: Now such frames are bypassed.

LONG: | Total number of dropped too long incoming/outgoing IP frames
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes a too long incoming IP frame.

The OUTPUT counter is incremented every time IPsec port droppes a too long outgoing IP frame.

BAD-SA: | Total number of dropped incoming/outgoing IP frames, for which corresponding SA is not in working state
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame, for which corresponding inbound SA is not in working (MATURE) state.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame, for which corresponding outbound SA is not in working (MATURE) state.

NO-SA: | Total number of dropped incoming/outgoing IP frames, for which corresponding SA is not found
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame, for which corresponding inbound SA is not found.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame, for which corresponding outbound SA is not found.

BAD-FMT: | Total number of dropped incoming/outgoing IP frames with bad format
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame with bad format.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame with bad format.

AUTH-FAIL: | Total number of dropped incoming IP frames with authentication errors
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming IP frame with authentication errors.

BAD-CBLK: | Total number of dropped encrypted incoming IP frames with bad cipher block
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes encrypted incoming IP frame with bad cipher block.

BAD-CHK: | Total number of dropped an incoming IP frames with inbound policy check error
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming IP frame with inbound policy check error.

REP-CHK: | Total number of dropped an incoming/outgoing IP frames with sequence number errors
 | 0-4.294.967.295

The INPUT counter is incremented every time IPsec port droppes an incoming IP frame with sequence number errors.

The OUTPUT counter is incremented every time IPsec port droppes an outgoing IP frame with sequence number errors.

BAD-ECN: | Total number of dropped an incoming IP frames with ECN handling errors
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming IP frame with ECN handling error.

Detailes of the IPsec Security Associations statistics

SA: | Identifier of Security Association record.
 | 0-127

It shows identifier of Security Association record Security Association bundles in the SA table.

CHR: | Total number of incoming/outgoung characters processed by Security Association
 | 0-4.294.967.295

The counter is incremented every time Security Association (IN/OUT) processes incoming/outgoung IP frame with corresponding IPsec protocol (AN or ESP).

FRM: | Total number of incoming/outgoung IP frames processed by Security Association
 | 0-4.294.967.295

The counter is incremented every time Security Association (IN/OUT) processes incoming/outgoung IP frame with corresponding IPsec protocol (AN or ESP).

AUTH-FAIL: | Total number of dropped incoming IP frames with authentication errors
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming IP frame with authentication errors.

BAD-CBLK: | Total number of dropped encrypted incoming IP frames with bad cipher block
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes encrypted incoming IP frame with bad cipher block.

REPLAY-CHK: | Total number of dropped an incoming/outgoing IP frames with sequence number errors
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming/outgoing IP frame with sequence number errors.

BAD-ECN: | Total number of dropped an incoming IP frames with ECN handling errors
 | 0-4.294.967.295

The counter is incremented every time IPsec port droppes an incoming IP frame with ECN handling error.


The Internet Key Exchange port (IKE)

Revised for CPX 4.8.0.
Introduction
Terminology
Configuration of the IKE port
Diagnostics of the IKE port
Statistics of the IKE port

Configuration of the IKE port tables

The Internet Protocol Security port (IPsec)

Configuration examples (CPX-to-CPX)
Configuration examples (CPX-to-Win2k/XP)

Introduction top

Terminology top

DH. Diffie-Hellman (DH) key exchange protocol. A protocol that allows two parties without any initial shared secret to create one in a manner immune to eavesdropping. Once they have done this, they can communicate privately by using that shared secret as a key for a block cipher or as the basis for key exchange.

PSK. Pre-shared Keys. When two parties have arranged for a trusted method of distributing secret keys for their mutual authentication, they can be used for authentication.

Configuration of the IKE port top

The IKE port is referred by the "IKE" abbreviation and it has all the parameters described in this chapter.

Here is an example of the IKE port parameters.

[01:14:19] ABILIS_CPX:d p po:ike

PO:921 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
IKE    ------------------------------------------------------------------------
       LOG:DS       lowpo:902       ACT:YES      mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:AUTO    NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
The changes made on the LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Details of the IKE port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be an UDP port.

Value "NONE" isolates the IKE port.

ACT: | Runtime activation/deactivation of IKE
NO | NO, YES

This parameter allows to run-time activate/deactive IKE functionalities.

When it is set to "YES", the port is configured, active, and the IKE driver performs its activities.

When it is set to "NO", the port is configured, active, but the IKE driver does not execute any action.

mxps: | Maximum length of UDP datagram which can be processed by IKE driver
2048 | 2048-4096

It specifies maximum length of UDP datagram which can be processed by IKE driver port.

This value cannot be changed without CPX restart.

NRTY: | Maximum number of IKE packet retransmissions
3 | 1-5

It specifies maximum number of IKE packet retransmissions.

TB: | Retransmission IKE packet delay
10 | 5-30

It specifies retransmission IKE packet delay.

WDIR: | Directory where IKE.CNS file is located
C:\APP\IKE\ | from 1 up to 128 ASCII extended characters [32..255]

This parameter selects the directory where IKE.CNS file is saved. It cannot be empty. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. The maximum accepted working directory string length is 128 characters. Case is preserved and spaces are allowed, but strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\").

NATT: | NAT traversal working mode
NO | NO, YES, AUTO

Specifies NAT traversal working mode for IKE port.

NO: NAT traversal is disabled
YES: Forced NAT traversal mode
AUTO: NAT traversal is automatically detected

NATT-N-IKE: | NAT traversal port floating flag
NO | NO, YES

Specifies whether the NAT traversal port floating is enabled or disabled.

NO: Port floating is disabled
YES: Port floating is enabled

NATT-PF: | NAT traversal NON-IKE marker flag
NO | NO, YES

Specifies whether the NAT traversal NON-IKE marker is enabled or disabled.

NO: NON-IKE marker is disabled
YES: NON-IKE marker is enabled

NATT-KA | NAT traversal keep-alive timer
20 | 10-240

Specifies the NAT traversal keep-alive timer.

Diagnostics of the IKE port top

Example on how to show state and diagnostics of the IKE through the command D S:

[15:00:45] ABILIS_CPX:D S PO:IKE

PO:921 ------------------------------------------------------------------------
IKE    IKE-STATE:ACTIVE       IPSEC-STATE:ACTIVE
       ISAKMP-SA:1    ISAKMP-SA-EST:1    IPSEC-SA:1    IPSEC-SA-EST:1
       - Security Associations diagnostics: -----------------------------------
       SerialNo   Name                                     Type     Side
                  LocIp-LocPort         LocNet/LocMask     State    ReplaceTime
                  RemIp-RemPort         RemNet/RemMask     Pending  ExpiryTime
       ------------------------------------------------------------------------
       13                                                  IPsec    RESPONDER
                  192.168.006.001/500   192.168.006.001/32 QUICK-R2 3422
                  192.168.006.002/500    192.168.006.002/32 0        3542
       ------------------------------------------------------------------------
       12                                                  ISAKMP   RESPONDER
                  192.168.006.001/500   000.000.000.000/00 MAIN-R3  3420
                  192.168.006.002/500    000.000.000.000/00 0        3540
       ------------------------------------------------------------------------

Detailes of the IKE port diagnostics

IKE-STATE: | Current state of the IKE port
 | DOWN, INACTIVE, ACTIVE, INIT

It shows the current state of the IKE port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
IKE | DOWN | State set when registration to lower UDP port fail (UDP service is not possible). |  |  | dn
 | INACTIVE | IKE port is running, but the ACT: parameter is set to "NO". |  |  | na
 | ACTIVE | IKE port is fully ready to work. |  |  | RD
 | INIT | IKE port is in init state. |  |  | in

IPSEC-STATE: | Current state of the IPsec port
 | INACTIVE, ACTIVE

It shows the current state of the IPsec port driver.

INACTIVE: IPsec port is not "ready" to work with IKE driver.
ACTIVE: IPsec port is fully ready to work.

ISAKMP-SA: | Current number of the ISAKMP Security Associations
 | 0-128

It shows current number of the ISAKMP Security Associations (Main mode of IKE).

ISAKMP-SA-EST: | Current number of the established ISAKMP Security Associations
 | 0-128

It shows current number of the established ISAKMP Security Associations (Main mode of IKE).

IPSEC-SA: | Current number of the IPsec Security Associations
 | 0-128

It shows current number of the IPsec Security Associations (Quick mode of IKE).

IPSEC-SA-EST: | Current number of the established IPsec Security Associations
 | 0-128

It shows current number of established the IPsec Security Associations (Quick mode of IKE).

Detailes of the IKE Security Associations diagnostics

SerialNo: | Serial number of the ISAKMP/IPsec Security Associations
 | 1-4.294.967.295

It shows serial number of the ISAKMP/IPsec Security Associations.

Name: | Name of the ISAKMP/IPsec Security Association
 | from 0 up to 32 ASCII printable characters. Spaces are not allowed. Case is preserved.

Specifies name of the ISAKMP/IPsec Security Association.

Type: | Type of the Security Association
 | ISAKMP, IPsec

Specifies type of the Security Association.

Side: | Side of the Security Association
 | ININIATOR, RESPONDER

Specifies side of the Security Association.

LocIp-LocPort: | Local IP address/local IKE UDP port
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x/500, 4500

Local IP address/local IKE UDP port.

RemIp-RemPort: | Remote IP address/remote IKE UDP port
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x/0-65535

Remote IP address/remote IKE UDP port.

LocNet/LocMask: | Local client network number/mask
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x/0-32

Local client network number/mask. For IPsec SA only.

RemNet/RemMask: | Remote client network number/mask
 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x/0-32

Remote client network number/mask. For IPsec SA only.

State: | Current state (phase) of IKE negotiation for the Security Association
 | MAIN-R0, MAIN-R1, MAIN-R2, MAIN-R3 MAIN-I1, MAIN-I2, MAIN-I3, MAIN-I4 QUICK-R0, QUICK-R1, QUICK-R2 QUICK-I1, QUICK-I2

It shows the current state (phase) of IKE negotiation for the Security Association.

ISAKMP SA. Main mode of IKE negotiation:

State | Description
MAIN-R0, MAIN-R1 | 1 IKE message is received from peer (responder side).
MAIN-R2 | 2 IKE message is received from peer (responder side).
MAIN-R3 | 3 IKE message is received from peer (responder side). ISAKMP SA is established.
MAIN-I1 | 1 IKE message is sent to peer (initiator side).
MAIN-I2 | 2 IKE message is sent to peer (initiator side).
MAIN-I3 | 3 IKE message is sent to peer (initiator side).
MAIN-I4 | 3 IKE message is received from peer (initiator side). ISAKMP SA is established.

IPsec SA. Quick mode of IKE negotiation:

State | Description
QUICK-R0, QUICK-R1 | 1 IKE message is received from peer (responder side).
QUICK-R2 | 2 IKE message is received from peer (responder side). IPsec SA is established.
QUICK-I1 | 1 IKE message is sent to peer (initiator side).
QUICK-I2 | 2 IKE message is sent to peer (initiator side). IPsec SA is established.
Pending: | Number of the pending IPsec SA connections for the current ISAKMP SA
 | 0-128

Specifies number of the pending IPsec SA connections for the current negotiating ISAKMP SA.

ReplaceTime: | Remaining time to begin replace current ISAKMP/IPsec SA
 | 0-4.294.967.295

Specifies remaining time (in seconds) to begin replace current ISAKMP/IPsec SA.

ExpiryTime: | Remaining time to expiry current ISAKMP/IPsec SA
 | 0-4.294.967.295

Specifies remaining time (in seconds) to expiry current ISAKMP/IPsec SA.

Statistics of the IKE port top

Example on how to show state and diagnostics of the IKE port through the command D SE:

[15:00:45] ABILIS_CPX:D SE PO:IKE

PO:921 ------------------------------------------------------------------------
IKE    --- Cleared 000:00:10:02 ago, on 22/03/2005 at 22:53:43 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |      15220|       1756|LONG       |          0|          0|
       FRM        |         31|         23|BAD-FMT    |          0|           |
       FRM-LOST   |          0|           |DUPLICATED |          6|           |
       ------------------------------------------------------------------------
       -----------|--ISAKMP---|---IPSEC---|
       SA-R       |          4|          9|
       SA-I       |          0|          0|
       SA-EST-R   |          3|          1|
       SA-EST-I   |          0|          0|
       AUTH-FAIL  |          0|          0|
       NO-PROP    |          0|          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detailes of the IKE port statistics

CHR: | Total number of characters received/sent by IKE port from/to UDP
 | 0-4.294.967.295

The INPUT counter is incremented every time IKE port receives a UDP datagram from UDP.

The OUTPUT counter is incremented every time IKE port sends a UDP datagram to UDP.

FRM: | Total number of UDP datagrams received/sent by IKE port from/to UDP
 | 0-4.294.967.295

The INPUT counter is incremented every time IKE port receives a UDP datagram from UDP.

The OUTPUT counter is incremented every time IKE port sends a UDP datagram to UDP

FRM-LOST: | Total number of lost incoming UDP datagrams: buffer is full
 | 0-4.294.967.295

The counter is incremented every time a UDP datagram is discarded because there are no available receiving buffers.

LONG: | Total number of discarded too long incoming/outgoing UDP datagrams
 | 0-4.294.967.295

The INPUT counter is incremented every time the IKE port discards a too long incoming UDP datagram.

The OUTPUT counter is incremented every time the IKE port discards a too long outgoing UDP datagram.

BAD-FMT: | Total number of discarded incoming UDP dtagrams with bad format
 | 0-4.294.967.295

The counter is incremented every time the IKE port discards an incoming UDP datgram with bad format.

DUPLICATED: | Total number of duplicated incoming UDP dtagrams
 | 0-4.294.967.295

The counter is incremented every time the IKE port discards a duplicated incoming UDP datgram.

SA-R: | Total number of ISAKMP/IPsec negotiation attempts (responder side).
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the remote IKE peer begins ISAKMP SA negotiation (Main mode).

IPSEC: The counter is incremented every time the remote IKE peer begins IPsec SA negotiation (Quick mode).

SA-I: | Total number of ISAKMP/IPsec negotiation attempts (initiator side).
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the local IKE port begins ISAKMP SA negotiation (Main mode).

IPSEC: The counter is incremented every time the local IKE port begins IPsec SA negotiation (Quick mode).

SA-EST-R: | Total number of ISAKMP/IPsec successful established negotiations (responder side).
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the ISAKMP SA is successfully established (Main mode).

IPSEC: The counter is incremented every time the IPsec SA is successfully established (Quick mode).

SA-EST-I: | Total number of ISAKMP/IPsec successful established negotiations (initiator side).
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the ISAKMP SA is successfully established (Main mode).

IPSEC: The counter is incremented every time the IPsec SA is successfully established (Quick mode).

AUTH-FAIL: | Total number of ISAKMP/IPsec failed authentications.
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the ISAKMP SA negotiation is dropped because authentication is fail (Main mode).

IPSEC: The counter is incremented every time the IPsec SA negotiation is dropped because authentication is fail (Quick mode)

NO-PROP: | Total number of dropped ISAKMP/IPsec negotiations, because proposal not choosen
 | 0-4.294.967.295

ISAKMP: The counter is incremented every time the ISAKMP SA negotiation is dropped because ISAKMP proposal not choosen (Main mode).

IPSEC: The counter is incremented every time the IPsec SA negotiation is dropped because IPsec proposal not choosen (Quick mode)


Enhanced ISDN Router (EIR) port

Terminology
What is EIR?
Configuration of the EIR port
Statistics of the EIR port
EIR use examples

Terminology top

ISDN port
Modern digital telecomunication port. There are two types of ISDN ports: BRI and PRI.
D channel
Stands for "Data channel", used to transport signalling information between the user and the network.
B channel
Stands for "Bearer channel", used to transport voice or data between end users.
BRI
Basic Rate Interface - one type of ISDN connection. It supports one D channel for signalling and two B channels for voice or data transport.
PRI
Primary Rate Interface - one type of ISDN connection. It supports one D channel for signalling and 30 B channels for voice or data transport.
Cluster
Physical (via e.g. SYNC) or logical (via e.g. UDP) connection between two Abilis CPXs. This connection can be shared by several compressed voice connections.

What is EIR? top

The Enhanced ISDN Router (EIR) is a key part of ISDN subsystem in Abilis CPX. ISDN subsystem constists of:

  • Layer 1 - physical layer - BRI or PRI.
  • Layer 2 - link layer - LAPD/Q.921.
  • Layer 3 - signalling layer - DSS1/Q.931
  • Layer 4 - EIR

EIR is a smart ISDN telephone exchange. It manages connections among ISDN ports and clusters. As a simplified description we may say that EIR processes an incoming call in following steps: it receives the call request, it finds an appropriate routing, it performs the outgoing call.

EIR supports several types of connection:

  • Transparent - connection between two ISDN port (voice or data)
  • VtoC, CtoV, CtoC - Voice to Cluster, Cluster to Voice, Cluster to Cluster. All these connection types are related to compressed voice transfer. Voice side of such connection is a digitised voice stream, Cluster side of such connection is a compressed voice stream in form of data packets.
  • Data - data connection (HDLC framing) from Abilis CPX to ISDN port or from ISDN port to Abilis CPX.
  • Cluster - dial-up data connection (HDLC framing) between two CPXs used for compressed voice transfer.
  • VSP - permanent data connection (HDLC framing) between Abilis CPX and an ISDN or E1 port.

Connections can also be:

  • Switched - these connections are "governed" by the EIR routings table.
  • Permanent - these are only data connection and are "governed" by the TDM connections table.
  • Pseudo permanent - these are switched connections that through simulation of the call phases actually behave as permanent ones. They are "governed" by the EIR routings table and require the use of sQ931 ports (simulated Q931).

Configuration of the EIR port top

The Enhanced ISDN Router port is labelled within the Abilis CPX with the acronym "EIR" and it is provided with the parameters described in this section.

Here is an example on how to display the EIR port parameters. Shown values are only examples.

[12:05:12] ABILIS_CPX: D P PO:EIR

PO:200 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
EIR    ------------------------------------------------------------------------
       lowpo:100   mxpc:20          +----- EPQ931, EBQ931 and sQ931 ports ----+
       ac-buf:5    pl-buf:5         | 296 297 280 281 282 283 .   .   .   .   |
       Active P-Links  : 1 - 8      +-----------------------------------------+
       Inactive P-Links: 9 - 64     | .   .   .   .   .   .   .   .   .   .   |
      +---------- P-Link ports -----------+-----------------------------------+
      |    PL: ID:      MXBW:    CURBW:   |    pl: id:      mxbw:    curbw:   |
      |--+--------------------------------|--+--------------------------------|
      |1 | 751 TEST1    NOMAX    0        |9 | .   .        NOMAX    N/A      |
      |2 | 752 TEST2    NOMAX    0        |10| .   .        NOMAX    N/A      |
      |3 | .   .        NOMAX    .        |11| .   .        NOMAX    N/A      |
      |4 | .   .        NOMAX    .        |12| .   .        NOMAX    N/A      |
      |5 | .   .        NOMAX    .        |13| .   .        NOMAX    N/A      |
      |6 | .   .        NOMAX    .        |14| .   .        NOMAX    N/A      |
      |7 | .   .        NOMAX    .        |15| .   .        NOMAX    N/A      |
      |8 | .   .        NOMAX    .        |16| .   .        NOMAX    N/A      |
      +--+--------------------------------+--+--------------------------------+

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the EIR port parameters

lowpo: | Identifier of the lower level Abilis CPX port
NONE | 1 - 999, NONE

It sets the lower level port; it can only be the EIM port.

The value "NONE" isolates the EIR port from the lower level ones.

mxpc: | Maximum number of simultaneous pendent calls
20 | 0 - 255

It sets the maximum number of simultaneous calls "under construction", which are also defined "pendent" calls.

Warning! If a new call causes to exceed the limit the call will fail immediately, the message "W: MXPC EXCEED" will be written in the System Log, and an equivalent message will be written in the Debug Log.

Info Calls in calling or alerting state are pendent calls.
Calls in connected, disconnecting or releasing state are not pendent calls.

EPQ931, EBQ931, sQ931 ports: | Lower layer ports
NONE | 0 - 999, NONE

It displays the list of lover level ports.
It is not possible to configure this list manually, it is automatically compiled by the Validation procedure with the EPQ931, EBQ931 and sQ931 ports, that are configured and active at the moment of its execution.
If the ports are less than 18, the remaining positions are set to "NONE", displayed by the character "." (full stop).

AC-buf: | Number of buffers used by ACs for jitter compensation
5 | 5 - 50

It sets the number of buffers used by Audio Compressors (ACs) for jitter compensation.
The default value of 5 is optimal when packetised voice is carried over leased lines or whenever the jitter is minimal.
For VoIP applications, i.e. when the packetised voice is sent within IP packets over IP networks, and mainly over the Internet, this value should be increased. Usually a value of 20 provides acceptable results.

Warning! Each buffer contains 30 msec of voice, so for each buffer added we increase the jitter compensation of 30 msec.

PL-buf: | Number of transmission buffers used for P-Links
5 | 5 - 50

It sets the number of transmission buffers used by P-Links.
The default value of 5 is optimal for all the current applications.

Active P-Links: | Interval of P-Link ports currently active
NONE | 1-8, 1-16, 1-24, 1-32, 1-40, 1-48, 1-56, 1-64

This is only an informative parameter and it is not configurable.
It shows the interval of P-Link channels currently active because they were activated at the system start.
This condition is also highlighted by the fact that parameters' tokens, related to the active P-Link group, are displayed in uppercase.

Info The parameters of "Active P-Links" can be configured and made active runtime through the INIT PO: command.

Info The first 8 P-links are always activated at system start, even if they are not configured.

Inactive P-Links: | Interval of P-Link ports currently not-active
NONE | 9-64, 17-64, 25-64, 33-64, 41-64, 49-64, 57-64, 0-0

This is only an informative parameter and it is not configurable.
It shows the interval of P-Link channels currently inactive because they were not activated at the system start.
This condition is also highlighted by the fact that parameters' tokens, related to the active P-Link group, are displayed in lowercase.

Info Parameters' values, eventually configured for those ports, will be activated at the next system start.

PL1: - PL64: | PLink lower level port
NONE | 0 - 999, NONE

It shows the P-LINK lower level ports which will transport compressed voice, they can only be MLM ports.

The value "NONE", displayed by the "." character, disables the P-LINK channel.

ID1: - ID64: | Identifiers of Cluster channels from/to remote EIRs
NONE | from 1 up to 8 alphanumerical characters, #

The EIR port driver uses this parameter value to assign a Cluster identifier to the PLink channel.

The same identifier can be used for more PLink channels, which actually creates a unique Cluster out of several PLink channels. Outgoing compressed call will be routed on these PLinks using a priority scheme, starting from the lower number PLink (e.g. first PL1 until MXBW: is reached or a failure is detected and then PL2).

The value "NONE", configurable by the character "#", is displayed into this table by "." (full stop) and it disables the P-LINK channel.

MXBW1: - MXBW64: | Maximum bandwidth usable by the correspondent Plink port
NOMAX | 0 - 2.048.000, NOMAX

It sets the maximum bandwidth that compressed voice connections are allowed to use on this PLink.
The value "NOMAX" removes any limit.

Warning! A value greater than the actual link capacity may cause voice disruptions when the bandwidth demand actually exceeds the link capacity.

Warning! A value very close to the actual link capacity may not leave enough bandwidth for "data services". However if data service are not multiplexed on the same link this is not a problem.

CURBW1: - CURBW64: | Bandwidth currently used by the correspondent PLink port
NONE | 0 - 2.048.000, NONE, N/A

This is only an informative parameter and it is not configurable.
It shows the currently used bandwidth by compressed voice connections on this link.

Info If one or more connections were established with the "silence compression" feature, instantaneous values could be lower and the saved bandwidth is instantaneously available for data services.
However the shown value will not flow, actually showing the "maximum bandwidth need".

The value "." means that the PLink channel, even if active, is not working.

The value "N/A" means that the PLink channel was not activated at the system start-up.

Statistics of the EIR port top

How to check state and statistics of the EIR port by the command D S.

[10:49:05] ABILIS-CPX: d s po:EIR

PO:200 ------------------------------------------------------------------------
EIR    -- Number of simultaneous calls ----------------------------------------
                      | State: Alerting/Connected |        State: Any         |
       ---------------|---Current---|----Peak-----|---Current---|----Peak-----|
       TR             |            0|            0|            0|            0|
       DATA           |            0|            1|            0|            1|
       CLUS           |            0|            0|            0|            0|
       VtoC           |            0|            0|            0|            0|
       CtoC           |            0|            0|            0|            0|
       CtoV           |            0|            0|            0|            0|
       ALL            |            0|            1|            0|            1|
       ------------------------------------------------------------------------

This table shows how many simultaneous connection, of the specified type (TR, DATA,CLUS, VtoC, CtoC, CtoV), the EIR is currently handling (Current), or the peak reached since system start or statistics clearing (Peak).

Connection types are:

TR | Transparent connection between two ISDN port (voice or data)
DATA | Data connection from Abilis CPX to ISDN port or from ISDN port to Abilis CPX
CLUS | Dial-up data connection between two CPXs used for compressed voice transfer
VtoC | Voice stream from ISDN compressed to packet form sent to cluster
CtoC | Compressed voice in packet form from cluster sent to another (or the same) cluster
CtoV | Compressed voice in packet from from cluster extracted to voice stream form sent to ISDN port
All | Any type of connection. It is important to note that while for "current" connections this field is equal to the sum of all the current connection types, for "peak" connections it represents the peak value of concurrent calls of any type, which is not the sum of individual peaks!

There are two main pairs of columns:

State: Alerting/Connected | Number of simultaneous connections in alerting or connected state.
State: Any | Numbers of simultaneous connections in any state.

For each of them there are two sub-columns:

Current | Number of current simultaneous connections.
Peak | Peak value of simultaneous connections reached since system start or statistics clearing.

How to check the extended and statistics of the EIR port by the command D SE.

[11:08:45] ABILIS-CPX: d se po:EIR

PO:200 ------------------------------------------------------------------------
EIR    --- Cleared 000:04:19:32 ago, on 22/03/2002 at 06:49:18 ----------------
       -- Number of successful (connected) calls, updated at call end ---------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|          4|          0|           |          4|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|          4|          0|          0|          4|
       ------------------------------------------------------------------------
       -- Seconds of successful (connected) calls, updated at call end --------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|        508|          0|           |        508|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|        508|          0|          0|        508|
       ------------------------------------------------------------------------
       -- Number of unsuccessful calls ----------------------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|          0|          0|           |          0|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Internal failures for not connected calls ---------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       NoRoute    |           |           |           |           |          0|
       NoDest     |           |           |           |           |          0|
       NoPcmRes   |          0|          0|          0|          0|          0|
       NoAcRes    |          0|          0|           |          0|          0|
       NoHdlcRes  |          0|          0|          0|           |          0|
       PlinkFail  |          0|          0|           |          0|          0|
       ClusFail   |          0|          0|           |          0|          0|
       BwLimit    |           |          0|           |          0|          0|
       IsdnL1down |          0|          0|          0|          0|          0|
       IsdnL2down |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Internal failures after call connected ------------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       PlinkFail  |          1|          2|           |          0|          3|
       ClusFail   |          0|          0|           |          0|          0|
       IsdnL1down |          0|          0|          0|          0|          0|
       IsdnL2down |          7|          5|          0|          0|         12|
       ------------------------------------------------------------------------

This table is almost self explaining.

All the counters have the range 0 - 4.294.967.295. They are cleared at system start-up and upon the C S command.

In first three tables there are rows TR, DATA, CLUS, VtoC, CtoC, CtoV indicating the connection type.

It is necessary to explain the columns - INPUT, OUTPUT, LOCAL, TRANSIT - i.e. connection direction.

Each ISDN port has a configuration parameter TYPE:, which can be set to "USER" or "NETWORK", depending on how we want to consider the port, as a part of the network (NETWORK) or as a part of the user appliances.
The most common use is to set "NETWORK" for ports connected to the public ISDN network, and "USER" for ports connected to a PABX or to other user's apppliances.
Please note that a "Cluster port" is always internally set to "NETWORK".

The TYPE: parameter above mentioned is available in the layer 3 driver of the ISDN stack, that is in the Q931/EBQ931/EPQ931 ports.

Connection direction (INPUT, OUTPUT etc.) is evaluated from ISDN ports type:

LOCAL | Incoming port type is USER, Outgoing port type is USER
OUTPUT | Incoming port type is USER, Outgoing port type is NETWORK
INPUT | Incoming port type is NETWORK, Outgoing port type is USER
TRANSIT | Incoming port type is NETWORK, Outgoing port type is NETWORK

It is necessary to explain the internal failures of not connected calls:

NoRoute | EIR received call but no routing in routing table matched
NoDest | EIR received call, routing matched but no outgoing port existed
NoPcmRes | EIR received call but connection capacity was exhausted
NoAcRes | EIR received call but voice compressors were exhausted
NoHdlcRes | EIR received call but channels for data via B channel transfer were exhausted
PlinkFail | EIR detected a failure on cluster via permanent link
ClusFail | EIR detected a failure on cluster
BwLimit | EIR reached a bandwidth limit on cluster
IsdnL1Down | EIR detected a failure on layer 1 (physical layer) of ISDN stack
IsdnL2Down | EIR detected a failure on layer 2 (LAPD) of ISDN stack

It is also necessary to explain the internal failures after call connection:

PlinkFail | EIR detected a failure on used cluster via permanent link
ClusFail | EIR detected a failure on used cluster
IsdnL1Down | EIR detected a failure on layer 1 (physical layer) of ISDN stack of used port
IsdnL2Down | EIR detected a failure on layer 2 (LAPD) of ISDN stack of used port

EIR use examples top

  • Voice (fax) interconnection of two offices via ISDN and FR network (VoFR - Voice over Frame Relay)

    Interconnection of two sites via frame relay and ISDN

    Figure 1. Interconnection of two sites via frame relay and ISDN.

  • Voice (fax) interconnection of two offices via IP network (e.g. Internet (VoIP - Voice over IP)

    Interconnection of two sites via IP network

    Figure 2. Interconnection of two sites via IP network.


The port Enhanced ISDN Master (EIM)

Configuration of the EIM port
Statistics of the EIM port

Configuration of the EIM port top

The Enhanced ISDN Master port is labelled within the Abilis CPX with the acronym "EIM" and it is provided with the parameters described in this section.

Here is an example on how to display the EIM port parameters. Shown values are only examples.

[18:11:52] ABILIS_CPX: D P PO:EIM

PO:100 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
EIM    ------------------------------------------------------------------------
       CLK:ANYTE       frame:2100    rxbuf:14      txbuf:1
       SIGSET:USERDEF  DIALT1:6985   DIALS1:0      DIALT2:6985   DIALS2:0
                       RINGT1:1210   RINGS1:3080   RINGT2:1210   RINGS2:3080
                       BUSY:550      DISC:275
       +-------------- EPISDN and EBISDN ports for clock recovery ------------+
       |1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20 |
       |----------------------------------------------------------------------|
    Px:|97 82 83 .  .  .  .  .  .  .   .   .   .   .   .   .   .   .   .   .  |
       +----------------------------------------------------------------------+

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the EIM port parameters

CLK: | Mode of clock source detection
ANYTE | INT, ANYTE, LIST

The parameter allows the selection of the modality for detecting the clock signal source.

Value | Meaning
INT | Clock signal is internally generated at 4.096 Mhz
ANYTE | The driver will use as clock sources the ports specified by the parameters P1: to P20:, the port configured in the parameter "P1:" will be he first one to be considered, then "P2:" and so on. The complete ports list is automatically compiled by the Abilis CPX during the Validation procedure, starting from the EBISDN and EPISDN ports configured as TE and actives when the procedure is executed. If no one of the ports in the list is considered to be a valid clock source, the driver will use the clock signal internally generated (4.096 Mhz)
LIST | The driver will consider the list of ports configured in the parameters P1: to P20:, as it has manually configured by the User. The Validation procedure will check, during its execution, the validity of the configured values and it will, eventually, set to "NONE" the parameters P1: to P20:, if they do not match the required specifications. If no one of the ports in the list is considered to be a valid clock source, the driver will use the clock signal internally generated (4.096 Mhz)

frame: | Maximum length of DATA frames on the B channel
2100 | 64 -2100 bytes

This parameter sets the maximum length (in bytes) of DATA frames on the B channel.

rxbuf: | Number of receiving buffers
14 | 1..255

It sets the number of receiving buffers.

txbuf: | Number of transmission buffers
1 | 1..255

It sets the number of transmission buffers.

SIGSET: | Modality of signal generation
USERDEF | USERDEF

It selects the modality of signal generation.
The value "USERDEF", standing for "defined by the User", allows the User to select, at will, the combination of tones and silences in the "Dialling", "Alerting", etc. signals by setting the proper parameters later on defined.

DIALT1: | Length of the first tone in the "Dialling" signal
6985 | 0 - 6985 (milliseconds)

It sets the duration of the first tone in the "Dialling" signal.

DIALS1: | Length of the first silence in the "Dialling" signal
0 | 0 - 6985 (milliseconds)

It sets the duration of the first silence in the "Dialling" signal.

DIALT2: | Length of the second tone in the "Dialling" signal
6985 | 0 - 6985 (milliseconds)

It sets the duration of the second tone in the "Dialling" signal.

DIALS2: | Length of the second silence in the "Dialling" signal
0 | 0 - 6985 ( milliseconds)

It sets the duration of the second silence in the "Dialling" signal.

RINGT1: | Length of the first tone in the "Alerting" signal
1210 | 0 - 6985 (milliseconds)

It sets the duration of the first tone in the "Alerting" signal.

RINGS1: | Length of the first silence in the "Alerting" signal
3080 | 0 - 6985 (milliseconds)

It sets the duration of the first silence in the "Alerting" signal.

RINGT2: | Length of the second tone in the "Alerting" signal
1210 | 0 - 6985 (milliseconds)

It sets the duration of the second tone in the "Alerting" signal.

RINGS2: | Length of the second silence in the "Alerting" signal
3080 | 0 - 6985 (milliseconds)

It sets the duration of the second silence in the "Alerting" signal.

BUSY: | Length of tone and silence in the "Busy" signal
550 | 0 - 6985 (milliseconds)

It sets the duration of tone and silence in the "Busy" signal.

DISC: | Length of tone and silence in the disconnection signal
275 | 0 - 6985 (milliseconds)

It sets the duration of tone and silence in the disconnection signal.

P1: - P20: | EBISDN and/or EPISDN ports used as clock signal sources
NONE | 0..999, NONE

List of EBISDN and/or EPISDN ports used as clock signal sources

The value "NONE" disables the parameter and it is displayed through the character "." (full stop).

They are only used if the parameter CLK: is set to "ANYTE" or "LIST" according to the above mentioned rules.

Statistics of the EIM port top

How to check state and statistics of the EIM port by the command D S.

[11:47:16] ABILIS_CPX: D S PO:EIM

PO:100 ------------------------------------------------------------------------
EIM    CLK:INT
       ------------------------------------------------------------------------
       HDLC STATE        TS    CPN  Bch   | AC   STATE        TS    CPN  Bch
       -----------------------------------|------------------------------------
       0    IN-USE       32-35 97   28-31 | 0    FREE         0     .    .
       1    IN-USE       36-39 96   28-31 | 2    IN-USE/VOICE 2     .    .
       2    FREE         .     .    .     | 3    FREE         .     .    .
       3    FREE         .     .    .     | 4    FREE         .     .    .
       4    FREE         .     .    .     | 5    FREE         .     .    .
       5    FREE         .     .    .     | 6    FREE         .     .    .
       6    FREE         .     .    .     | 7    FREE         .     .    .
       7    FREE         .     .    .     |
       ------------------------------------------------------------------------

How to check the extended and statistics of the EIM port by the command D SE.

[11:47:16] ABILIS_CPX: D SE PO:EIM

PO:100 ------------------------------------------------------------------------
EIM    --- Cleared 000:01:41:30 ago, on 15/06/2000 at 13:27:17 ----------------
       VSP-ID:1
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |13         |13         |FRM-D      |4          |4          |
       FRM-C      |4103       |4104       |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------
       VSP-ID:2
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |13         |13         |FRM-D      |4          |4          |
       FRM-C      |4103       |4104       |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

As the following example shows, through the command D SE, it is also possible to display the extended statistics relating to a single connection:

[11:47:16] ABILIS_CPX: D SE PO:100 VSP-ID:2

PO:100 ------------------------------------------------------------------------
EIM    --- Cleared 000:01:41:30 ago, on 15/06/2000 at 13:27:17 ----------------
       VSP-ID:2
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |13         |13         |FRM-D      |4          |4          |
       FRM-C      |4103       |4104       |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the EIM port

CLK: | Source of the clock signal
 | 0 - 999, INT

It shows the source of the clock signal. The numeric value shows the EBISDN or EPISDN port currently used as clock source. The value "INT" means that the clock is internally generated and it is set to 4.096 Mhz.

HDLC: | Index of the HDLC module
 | 0 - 31

It shows the index of the HDLC module. There can be, at maximum, 32 HDLC modules, indexed from 0 to 31.

STATE: | Current state of the HDLC module
 | FREE, RESERVED, IN-USE, FAILED-RUN, RES-TRANS, USED-TRANS, ERR

It shows the current state of the HDLC module.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
EIM (HDLC Module) | FREE | The correspondent module is ready and available |  |  |
 | RESERVED | The correspondent module is not available because reserved to a further use |  |  |
 | IN-USE | The correspondent module is in use and currently connected to the CPX port and the B channel specified by the fields CPN e Bch |  |  |
 | FAILED-RUN | The correspondent module is not available because a fatal error occurred |  |  |
 | RES-TRANS | The correspondent module is reserved to a transparent connection |  |  |
 | USED-TRANS | The correspondent module is used by a transparent connection |  |  |
 | ERR | Software error, contact the Abilis assistance |  |  |

TS: | Time slot or set of time slots PCM associated to the HDLC module
NONE | 0 - 255, ".", NONE

This parameter shows the number of the time slot or set of time slots PCM associated to the HDLC module.

CPN: | Number of the Abilis CPX port connected to the HDLC module
NONE | 0..999, ".", NONE

This parameter shows the number of the Abilis CPX port connected to the HDLC module.

Bch: | Single B channel or group of B channels used by the HDLC module
NONE | 1 - 31, ".", NONE

This parameter shows the number of the single B channel or group of B channels used by the HDLC module.

AC: | Index of the AC module
 | 0 - 31

It shows the index of the HDLC module. There can be, at maximum, 32 HDLC channels, indexed from 0 to 31.

STATE: | Current state of the AC module
 | FREE, RESERVED, IN-USE, FAILED-DWNL, FAILED-INIT, FAILED-RUN, RES-TRANS, USED-TRANS, ERR

It shows the current state of the AC module:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
EIM (AC Module) | FREE | The correspondent module is ready and available |  |  |
 | RESERVED | The correspondent module is not available because reserved to a further use |  |  |
 | IN-USE | The correspondent voice module is in use and currently connected to the CPX port and B channel specified in the fields CPN and Bch. If possible it is also displayed information about the type of data exchanged: - IN-USE/VOICE: voice traffic; - IN-USE/FAX: fax data traffic; - IN-USE/--: in this case no information is available. |  |  |
 | FAILED-DWNLD | The correspondent module is not available because a fatal error occurred during software loading |  |  |
 | FAILED-INIT | The correspondent module is not available because a fatal error occurred during its initialisation |  |  |
 | FAILED-RUN | The correspondent module is not available because a fatal error occurred |  |  |
 | RES-TRANS | The correspondent module is reserved to a transparent connection |  |  |
 | USED-TRANS | The correspondent module is used by a transparent connection |  |  |
 | ERR | Software error, contact the Abilis assistance |  |  |

TS: | Time slot or set of time slots PCM associated to the AC module
NONE | 0 - 255, ".", NONE

This parameter shows the number of the time slot or set of time slots PCM associated to the AC module.

CPN: | Number of the Abilis CPX port connected to the AC module
NONE | 0..999, ".", NONE

This parameter shows the number of the Abilis CPX port connected to the AC module.

Bch: | Single B channel or group of B channels used by the AC module
NONE | 1 - 31, ".", NONE

This parameter shows the number of the single B channel or group of B channels used by the AC module.

Detail of the extended statistics of the VSP connections

VSP-ID: | Identifier of the VSP connection
1 - 32 |

It shows the identifier of the VSP connection.

RX-OVR: | Number of "overrun" occurred in the communication board
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time an "overrun" occurs in the communication board.

TX-UND: | Number of "underrun" occurred in the communication board
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time an "underrun" occurs in the communication board.

BAD-FCS: | Number of received frames with wrong FCS
 | 0 - 4.294.967.295

The counter FCS-I is incremented every time the FCS control of a received frame is unsuccessful.

ABORT: | Number of aborted received frames or aborted during the transmission
 | 0 - 4.294.967.295

The counter ABORT (INPUT) is incremented every time an "abort" event occurs while a frame is received. The counter ABORT (OUTPUT) is incremented every time an "abort" event occurs while a frame is going to be sent.

DATA-CHR: | Number of received/sent DATA characters
 | 0 - 4.294.967.295

The counter DATA-CHR (INPUT) is incremented every time a DATA frame is received. The counter DATA-CHR (OUTPUT) is incremented every time a DATA frame is sent.

FRM-D: | Number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter FRM-D (INPUT) is incremented every time a DATA frame is received. The counter FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

FRM-C: | Number of received/sent Link-Check frames
 | 0 - 4.294.967.295

The counter FRM-C (INPUT) is incremented every time a Link-Check frame is received. The counter FRM-C (OUTPUT) is incremented every time a Link-Check frame is sent.

FRM-V: | Number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

LONG-D: | Number of too long DATA frames received
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time the DATA frame received is too long. The counter LONG-D (OUTPUT) is incremented every time the upper level ports requests to send a DATA frame longer than the maximum length.

LONG-C: | Number of too long Link-Check frames received
 | 0 - 4.294.967.295

The counter LONG-C (INPUT) is incremented every time the Link-Check frame received is too long. The counter LONG-C (OUTPUT) is incremented every time the upper level ports request to send a Link-Check frame longer than the maximum length.

LONG-V: | Number of too long VOICE frame received
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time the VOICE frame received is too long. The counter LONG-V (OUTPUT) is incremented every time the upper level ports request to send a VOICE frame longer than the maximum length.

LOST-D: | Number of DATA frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-D (INPUT) is incremented every time a DATA frame is discarded because there are no buffer available to receive.

LOST-C: | Number of Link-Check frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-C (INPUT) is incremented every time a Link-Check frame is discarded because there are no buffer available to receive.

LOST-V: | Number of VOICE frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-V (INPUT) is incremented every time a VOICE frame is discarded because there are no buffer available to receive.


ISDN-EIR Connections

Revised for CPX 4.1.0.
Configuration of EIR connections
Configuration of EIR groups
Identifiers of remote EIR clusters

Configuration of TDM switches

Configuration of EIR connections top

The EIR routings table can store up to 100 routing definitions, indexed from 0 up to 99. The routing priority index sets the routing verification order for each incoming call.

The verification starts from the routing with priority 0 and continues until a routing is found matching the incoming call or the end of the table is reached.

The priority index for EIR routing is also utilized as a reference for operations of insertion, modification and deletion.

The EIR routings table is automatically maintained with consecutive indexes of priority, that is without "empty" places. Therefore every action of deleting or insertion makes the system to reorder all the table entries.

It is possible to modify the EIR routings table during the operation of Abilis CPX without the need to restart it. The modifications effected in the table are activated immediately with the command INIT ER.

All the commands for the manipulation of the EIR routings table are described in the EIR Routings section of the chapter Commands relating to the Enhanced ISDN Router. Available commands are the following:

A ER
C ER
D ER
D ERE
M ER
S ER

Example of a view of all the EIR routings in a short format (values are examples).

[18:56:10] ABILIS CPX: D ER

---+----+---------+--------+--------+--------------------+--------------------
PR |TYPE|NEXT     |POI/SR  |POO/DS  |CDI                 |CDO
   |    |ID-DT-MC/SP-VOL-LVOL-SC    |CGI                 |CGO
   |    |                           |SDI                 |SDO
   |    |                           |SGI                 |SGO
   |    |TI1 .. TI5
------------------------------------------------------------------------------
0   DATA NO        292      200      *                    *
                                     *                    *
                                     *                    *
                                     PBX*                 *
------------------------------------------------------------------------------
1   DATA NO        G5       200      98765                *
------------------------------------------------------------------------------
2   DATA UNLIMITED 200      292      'albacom'            10062'CDI'
------------------------------------------------------------------------------
3   DATA NO        200      292      *                    *
------------------------------------------------------------------------------
4   VtoC NO        G6       CPXTEM   99*                  'CDI.S3'
         4800  8  8  NO              *                    *
------------------------------------------------------------------------------
5   TR   NO        *        G2       90588*               'CDI.S2'
------------------------------------------------------------------------------
6   VtoC NO        G6       CPXTEM   9*                   'CDI.S2'
------------------------------------------------------------------------------
7   CtoC NO        CPXTEM   CPXTEM   9*                   'CDI.S2'
                                     *                    *
                                     *                    *
                                     DISABLED             *
------------------------------------------------------------------------------
8   CtoV NO        CPXTEM   291      *                    *
------------------------------------------------------------------------------
9   CtoV NO        LUX      285      0376390774           'CDI.S2'
         6400  8  8  YES             *                    *
------------------------------------------------------------------------------
10  CtoV NO        *        G1       0376397398           'CDI.S2'

This short representation will not display information about parameters set to their default values. Such information is displayed only if the parameters are set to not default values. In this way representation of one EIR routing is usually contained in a row.

Example of a view of all the EIR routings in extended format:

[18:41:46] ABILIS_CPX: D ERE

PR:0   TYPE:DATA POI:292     CDI:*                    SDI:*
NEXT:N                       CGI:*                    SGI:PBX*
                 POO:200     CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:1   TYPE:DATA POI:G5      CDI:98765                SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:200     CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:2   TYPE:DATA POI:200     CDI:'albacom'            SDI:*
NEXT:U                       CGI:*                    SGI:*
                 POO:292     CDO:10062'CDI'           SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:3   TYPE:DATA POI:200     CDI:*                    SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:292     CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:4   TYPE:VtoC POI:G6      CDI:99*                  SDI:*
NEXT:N SP:4800               CGI:*                    SGI:*
       VOL:8     DS:CPXTEM   CDO:'CDI.S3'             SDO:*
       LVOL:8    SC:NO       CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:5   TYPE:TR   POI:*       CDI:90588*               SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:G2      CDO:'CDI.S2'             SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------

Detail of the EIR connection parameters

PR: | Priority of the EIR routing; priority 0 (zero) is the highest
none | from 0 to 99

It represents the EIR routing priority index. The priority establishes the order in which EIR routings are verified for each incoming call.

The verification goes out from the EIR routing with priority 0 and continues until a routing is found which satisfies the incoming call, or else the end of the table is reached.

The priority index for EIR routing is also utilized as a reference for operations of insertion, modification and deletion.

The EIR routing table is automatically maintained with consecutive indices of priority, i.e. without any "empty spaces", therefore every action of cancellation or insertion causes a rearrangement of all the indices following the one which is being referred to.

TYPE: | Type of EIR connection requested
TR | TR, VtoC, CtoV, CtoC, DATA, Clus

It identifies the type of EIR routing and the type of "information" which can travel on the connection corresponding to it.

The types of routing are as follows:

Type | Meaning
TR | routing for transparent VOICE connection;
VtoC | routing for compressed VOICE connection;
CtoV | routing for compressed VOICE connection;
CtoC | routing for compressed VOICE connection;
DATA | routing for DATA connection;
Clus | routing for Clusters.
NEXT: | Enable search of an alternative routing
N (NO) | N (No), L (Limited), U (Unlimited), T (Transfer)

It sets up the possibility of carrying out a search for an alternative routing in the EIR routings table, in the event of failure of the call attempted with the routing under consideration.

The search for an alternative routing proceeds by starting from the routing with priority that is subsequent to the one used earlier and is always based on the data present in the incoming call. If the data of the call are suitable for a new routing, a new attempt at connecting is put into effect, using the information configured in this new matching routing.

In the case of the procedure for searching for an alternative routing, the user can recognize, from the Events Log, all earlier attempts successfully carried through to the end and also final failure in attempts at connecting.

The admitted values are the following:

Value | Meaning
N (No) | In the event of failure of the routing, no procedure for seeking an alternative routing is put into effect.
L (Limited) | The process of searching for an alternative routing is only activated in the instance where the call attempted with the routing under consideration fails, owing to causes attributed to a temporary unavailability of the service (network out of service, all channels engaged, etc....).
U (Unlimited) | The process of searching for an alternative routing is activated for all the causes except USER BUSY and NO USER RESPONDING USER ALERTED, and starting from the next routing continues until the routings present in the table are used up.
T (Transfer) | The process of searching for an alternative routing is activated for ANY the cause, and starting from the next routing continues until the routings present in the table are used up.
POI: | Port or entry group of the call (Only for TYPE:TR/VtoC/DATA/Clus)
NONE | 0 - 999, *, #, NONE, G1 - G31, G*

It establishes the port or the group of ports from where the call must enter in order to satisfy the routing.

If a port number is indicated, it must correspond with a port of type EBQ931 or EpQ931 which is active inside the system.

The string "*" is utilized to specify "any port".

If the identifier of an EIR group is indicated, it must correspond with a group among those configured in the table of EIR groups.

The value "G*" is utilized to specify "any group".

The value "NONE" or the string "#", stands for "no port and no group of ports" and can be utilized to deactivate the routing without cancelling it.

The parameter is made visible and can be configured only if the connection is of type TR, VtoC, DATA or Clus.

SR: | Identification of the remote EIR from where the call has originated; (Only for TYPE: CtoV/CtoC)
# | from 1 up to 8 characters '0' - '9', 'a' - 'z', 'A' - 'Z', '_' (underlined), *, #, 'List'

It establishes the remote EIR cluster from where the call must arrive to satisfy the routing.

If the filed is set to "*" string only, whichever remote EIR Cluster it comes from, the call can be accepted.

The value "#" stands for "no EIR cluster" and can be used to deactivate the routing.

The specification of an element list, of type EC (list of identifications of EIR Clusters) or RU (Rule) or MR (Master Rule), is also accepted. The name of the list must always be included between apostrophe characters and must correspond to a list already present at the time of the setting-up of the routing.

The parameter is made visible and is only configured if the connection is of type CtoV or CtoC.

CDI: | Called number of the incoming call
00 | from 1 up to 20 characters '0' - '9', *, ?, #, 'List'

It enables the user to specify which number being called satisfies the routing.

If the field is set to the "#" string, then no called number must be present in the incoming call to satisfy the routing.

If the field is set to the "*" string, any called number will satisfy the routing.
The '*' (asterisk) character can also be used at the beginning or at the end of a sequence of digits with the meaning of "any digit and any number of digits" (E.g.: "123*" or "*321").

The '*' (asterisk) character can appear only once and at the beginning or the end of a sequence of digits only. For example the following expressions are not allowed: "0123*23" and "*23*"

If the field is set to the "?" string, then the routing is satisfied by any called number made up of only one digit.
The '?' (question mark) character can also be used in a sequence of numbers with the meaning of "any digit" (E.g.: "?654" or "1234???"). One or more '?' (question mark) characters can be used in a sequence of digits along with the '*' (asterisk) character (E.g.: "*2??35?" or "15??74*").

The specification of an element list, of type IN (list of ISDN numbers) or RU (Rule), or MR (Master Rule), is also accepted. The name of the list must always be included between apostrophe characters and must correspond to a list already present at the time of the setting-up of the routing.

SDI: | Called Sub-address of the incoming call
* | from 1 up to 20 characters '0' - '9', 'a' - 'z', 'A' - 'Z', *, ?, #, 'List'

It enables the user to specify which sub-address being called is acceptable for the routing.

If the filed is set to "#" string, then no called sub-address must be present in the incoming call in order to satisfy the routing.

If the field is set to the "*" string, any called sub-address will satisfy the routing.
The '*' (asterisk) character can also be used at the beginning or at the end of a sequence of digits with the meaning of "any digit/letter and any number of digits/letters" (E.g.: "1AAA3*" or "*bc321").

The '*' (asterisk) character can appear only once and at the beginning or the end of a sequence of digits/letters only. For example the following expressions are not allowed: "0ab3*23" and "*2cdf3*"

If the field is set to the "?" string, then the routing is satisfied by any called sub-address made up of only one digit/letter.
The '?' (question mark) character can also be used in a sequence of digits/letters with the meaning of "any digit or any letters" (E.g.: "?6AA54" or "ABC1234???"). One or more '?' (question mark) characters can be used in a sequence of digits/letters along with the '*' (asterisk) character (E.g.: "*A2??3B5?" or "1A5??7C4*").

The specification of an element list, of type IN (list of ISDN numbers) or IS (list of ISDN sub-addresses) or RU (Rule), or MR (Master Rule), is also accepted. The name of the list must always be included between apostrophe characters and must correspond to a list already present at the time of the setting-up of the routing.

CGI: | Calling address of the incoming call
* | from 1 up to 20 characters '0' - '9', *, ?, #, 'List'

It enables the user to specify which calling address satisfies the routing.

If the field is set to the "#" string, then no calling number must be present in the incoming call to satisfy the routing.

If the field is set to the "*" string, any calling number will satisfy the routing.
The '*' (asterisk) character can also be used at the beginning or at the end of a sequence of digits with the meaning of "any digit and any number of digits" (E.g.: "123*" or "*321").

The '*' (asterisk) character can appear only once and at the beginning or the end of a sequence of digits only. For example the following expressions are not allowed: "0123*23" and "*23*"

If the field is set to the "?" string, then the routing is satisfied by any calling number made up of only one digit.
The '?' (question mark) character can also be used in a sequence of numbers with the meaning of "any digit" (E.g.: "?654" or "1234???"). One or more '?' (question mark) characters can be used in a sequence of digits along with the '*' (asterisk) character (E.g.: "*2??35?" or "15??74*").

The specification of an element list, of type IN (list of ISDN numbers) or RU (Rule), or MR (Master Rule), is also accepted. The name of the list must always be included between apostrophe characters and must correspond to a list already present at the time of the setting-up of the routing.

SGI: | Calling sub-address of the incoming call
* | from 1 up to 20 characters '0' - '9', *, ?, #, 'List'

It enables user to specify which calling sub-address satisfies the routing.

If the filed is set to "#" string, then no calling sub-address must be present in the incoming call in order to satisfy the routing.

If the field is set to the "*" string, any calling sub-address will satisfy the routing.
The '*' (asterisk) character can also be used at the beginning or at the end of a sequence of digits with the meaning of "any digit/letter and any number of digits/letters" (E.g.: "1AAA3*" or "*bc321").

The '*' (asterisk) character can appear only once and at the beginning or the end of a sequence of digits/letters only. For example the following expressions are not allowed: "0ab3*23" and "*2cdf3*"

If the field is set to the "?" string, then the routing is satisfied by any calling sub-address made up of only one digit/letter.
The '?' (question mark) character can also be used in a sequence of digits/letters with the meaning of "any digit or any letters" (E.g.: "?6AA54" or "ABC1234???"). One or more '?' (question mark) characters can be used in a sequence of digits/letters along with the '*' (asterisk) character (E.g.: "*A2??3B5?" or "1A5??7C4*").

The specification of an element list, of type IN (list of ISDN numbers) or IS (list of ISDN sub-addresses) or RU (Rule), or MR (Master Rule), is also accepted. The name of the list must always be included between apostrophe characters and must correspond to a list already present at the time of the setting-up of the routing.

POO: | Port or exit group of the call (Only for TYPE:TR/CtoV/DATA/Clus)
NONE | 0-999, #, NONE, G1 - G32

It establishes the port or the group of ports from where the call which has satisfied the routing, must come out.

If a port number is indicated, it must correspond to a port of type EBQ931 or EPQ931 which is active inside the system.

The value "NONE" or the string "#", stands for "no port and no group of ports" and can be used to refuse unwanted calls via this routing.

If the identifier of an EIR group is indicated, it must correspond with a group among those configured in the table of EIR groups.

The parameter is made visible and can be configured only if the connection is of type TR, CtoV, DATA or Clus.

DS: | Identification of the remote EIR of the destination of the call (Only for TYPE: VtoC/CtoC)
# | from 1 up to 8 characters '0' - '9', 'a' - 'z', 'A' - 'Z', '_' (underlined), #

It establishes the remote EIR cluster to where the call which originated from the routing must now be forwarded.

The value "#" serves to deactivate the routing since it takes on the meaning of "no remote EIR cluster".

The parameter is visualized and can be configured only if the connection is of type VtoC or CtoC.

CDO: | Called address of the outgoing call
* | from 1 up to 20 characters '0' - '9', *, #, 'macro'

It enables to specify the called address of the outgoing call.

If the filed is set to "#" string, then the called address of the outgoing call will be left empty.

If the filed is set to "*" string, then the called address of the incoming call, is transferred without modifications in the outgoing call.

If the field is set to a sequence of characters, the called address of the incoming call is completely replaced in the outgoing call, with the values specified in "CDO:".

In contrast to the parameter CDI: described above, the '?' (question mark) character cannot be used in the field "CDO:", and the '*' (asterisk) character can only appear on its own.

The specification of peculiar expressions, called macro-instructions is also allowed. They must always be included between apostrophe characters and can contain the neither '*' (asterisk) character or '#' (pound) character.

A macro-instruction can only contain:

  • decimal digits '0' - '9';
  • names of input caller's address and sub-address fields: 'CGI' and 'SGI';
  • names of input called's address fields and sub-address fields: 'CDI' and 'SDI';
  • the '.' (dot) character, which is used as a separator;
  • the sequences ".3xx", ".Lxx" and ".Rxx", the meaning of which is explained as follows:
Sequence | Operative meaning
yyy.Sxx | take the characters of field "yyy" starting from position "xx".
yyy.Lxx | take up to "xx" characters of field "yyy", starting from the leftmost.
yyy.Rxx | take up to "xx" characters of field "yyy", staring from the rightmost.

The following table contains examples of macro-instructions and the explanation of their operative meaning in the composition of the called address field by the outgoing call:

Configuration sequence | Operative meaning of the macro-instruction
CDO:'SGI' | The called address field of the outgoing call will contain the same value as is contained in the field for the called sub-address of the incoming call.
CDO:1023'SGI' | The called address field of the outgoing call will contain the numerical sequence "1023" followed by the content of the called sub-address of the incoming call.
CDO:1023'SGI.S02' | The called address field of the outgoing call will contain the numerical sequence "1023" followed by the content of the called sub-address of the incoming call, starting from the 2nd character (.S02).
CDO:1023'SGI.R02' | The called address field of the outgoing call will contain the numerical sequence "1023" followed by at most two characters taken from the content of the called sub-address of the incoming call, starting from the right most (.R02).

In the eventuality that from the application of the macro-instruction, the resulting "CDO:" is longer than the maximum allowed value (i.e. 20 characters), the obtained sequence will be truncated.

If the macro-instruction has a syntax error it is refused by the configuration procedure with an appropriate error message.

If on the other hand the macro-instruction, although grammatically correct, contains instructions which do not make sense or cannot be applied, it will be ignored.

SDO: | Called sub-address of the outgoing call
* | from 1 up to 20 characters '0' - '9', 'a' - 'z', 'A' - 'Z', '_' (underline), *, #, 'macro'.

It enables the user to specify the called sub-address by the outgoing call.

If the filed is set to "#" string, then the called sub-address of the outgoing call will be left empty.

If the filed is set to "*" string, then the called sub-address of the incoming call, is transferred without modifications in the outgoing call.

If the field is set to a sequence of characters, the called sub-address of the incoming call is completely replaced in the outgoing call, with the values specified in "SDO:".

In contrast to the parameter SDI: described above, the '?' (question mark) character cannot be used in the field "SDO:", and the '*' (asterisk) character can only appear on its own.

The specification of peculiar expressions, called macro-instructions is also allowed. They must always be included between apostrophe characters and can contain the neither '*' (asterisk) character or '#' (pound) character.

A macro-instruction can only contain:

  • numeric or alphabetical characters or the '_' (underline) character;
  • the names of the input caller's address and sub-address fields: 'CGI' and 'SGI';
  • the names of the input called's address and sub-address fields: 'CDI' and 'SDI';
  • the '.' (dot) character, which is used as a separator;
  • the sequences ".3xx", ".Lxx" and ".Rxx", the meaning of which is explained as follows:
Sequence | Operative meaning
yyy.Sxx | take the characters of field "yyy" starting from position "xx".
yyy.Lxx | take up to "xx" characters of field "yyy", starting from the leftmost.
yyy.Rxx | take up to "xx" characters of field "yyy", staring from the rightmost.

The following table contains examples of macro-instructions and an explanation of their operative meaning in the composition of the called sub-address field of the outgoing call:

Configuration sequence | Operative meaning of the macro-instruction
SDO:'SGI' | The called sub-address field of the outgoing call will contain the same value as is contained in the field for the called sub-address of the incoming call.
SDO:AA23'SGI' | The called sub-address field of the outgoing call will contain the numerical sequence "AA23" followed by the content of the called sub-address of the incoming call.
SDO:102AA3'SGI.S02' | The called sub-address field of the outgoing call will contain the numerical sequence "102AA3" followed by the content of the called sub-address of the incoming call, starting from the 2nd character (.S02).
SDO:CC1023'SGI.R02' | The called sub-address field of the outgoing call will contain the numerical sequence "CC1023" followed by at most two characters taken from the content of the called sub-address of the incoming call, starting from the right most (.R02).

In the eventuality that from the application of the macro-instruction, the resulting "SDO:" is longer than the maximum allowed value (i.e. 20 characters), the obtained sequence will be truncated.

If the macro-instruction has a syntax error it is refused by the configuration procedure with an appropriate error message.

If on the other hand the macro-instruction, although grammatically correct, contains instructions which do not make sense or cannot be applied, it will be ignored.

CGO: | Calling address of the outgoing call
* | from 1 up to 20 characters '0' - '9', *, #, ##, 'macro'

It enables the user to specify the calling address of the outgoing call.

If the filed is set to "#" string, then the calling address of the outgoing call will be left empty.

If the filed is set to "##" string, then the calling address of the outgoing call will be left empty and the "presentation restricted" feature will be set.

If the filed is set to "*" string, then the calling address of the incoming call, is transferred without modifications in the outgoing call.

If the field is set to a sequence of characters, the calling address of the incoming call is completely replaced in the outgoing call, with the values specified in "CGO:".

In contrast to the parameter CGI: described above, the '?' (question mark) character cannot be used in the field "CGO:", and the '*' (asterisk) character can only appear on its own.

The specification of peculiar expressions, called macro-instructions is also allowed. They must always be included between apostrophe characters and can contain the neither '*' (asterisk) character or '#' (pound) character.

Composition rules and meaning are the same explained for the CDO: parameter.

SGO: | Calling sub-address of the outgoing call
* | from 1 up to 20 characters '0' - '9', 'a' - 'z', 'A' - 'Z', '_' (underline), *, #, 'macro'

Allows user to specify the calling sub-address of the outgoing call.

If the filed is set to "#" string, then the calling sub-address of the outgoing call will be left empty.

If the filed is set to "*" string, then the calling sub-address of the incoming call, is transferred without modifications in the outgoing call.

If the field is set to a sequence of characters, the calling sub-address of the incoming call is completely replaced in the outgoing call, with the values specified in "SGO:".

In contrast to the parameter SGI: described above, the '?' (question mark) character cannot be used in the field "SGO:", and the '*' (asterisk) character can only appear on its own.

The specification of peculiar expressions, called macro-instructions is also allowed. They must always be included between apostrophe characters and can contain the neither '*' (asterisk) character or '#' (pound) character.

Composition rules and meaning are the same explained for the SDO: parameter.

TI1: - TI5: | Time band of validity of the routing
See text | ggg-hh1mm1 -hh1 mm1, #

These parameters allow the user to specify up to 5 time bands for which the EIR routing can be used.

The time bands must be indicated in the following form:

ggg-hh1:mm1-hh2:mm2

where:

"ggg"
is the indication of the day/s of the week in which the routing can be utilized and can assume the following values:

Symbol | Meaning
M-F | The routing is valid from Monday to Friday;
SAT | The routing is only valid on Saturdays;
SUN | The routing is only valid on Sundays;
ALL | The routing valid on any day of the week Monday-Sunday.
"hh1:mm1"
is the indication of the beginning of the hourly interval of the validity of the routing for the indicated day/s;
"hh1" indicates the hour and can take on values between 00 and 23;
"mm1" indicates the minutes and can take on values between 00 and 59;
"hh2:mm2"
is the indication of the end of the hourly interval of the validity of the routing for the indicated day/s;
"hh2" indicates the hour and can take on values between 00 and 23;
"mm2" indicates the minutes and can take on values between 00 and 59.

The default value of "TI1:" is "ALL-00:00-23:59" that corresponds with retaining the routing valid on any day of the week (ALL) throughout the day (from 00.00 to 23.59).

The string "#" reported in correspondence with the parameters from "T12:" to "T15:" indicates that such intervals are disabled.

To disable an interval set its value to "#".

SP: | Speed of the compressed voice (only for TYPE:VtoC/CtoV)
4800 | 4800, 6400, 7200, 8000, 9600, 10400, 12800, 16000 (in Kbit/sec.)

It enables the user to set the speed of the compressed voice (in Kbits/sec.).

The parameter is made visible and can be configured only if the connection is of type VtoC or CtoV.

VOL: | Volume of the exit signal (only for TYPE:VtoC/CtoV)
8 (= 0 db) | 1 - 15

It enables the user to set the exit signal volume.

The parameter is made visible and can be configured only if the connection is of type VtoC or CtoV.

LVOL: | Local volume of the exit signal (only for TYPE:VtoC/CtoV)
8 (= 0 db) | 1 - 15

It enables the user to set the exit signal local volume.

The parameter is made visible and can be configured only if the connection is of type VtoC or CtoV.

SC: | Indication of the suppression of silent periods (only for TYPE:VtoC/CtoV)
NO | NO, YES

It enables the user to activate the suppression of silent periods on the connection obtained with the routing under consideration.

The parameter is made visible and can be configured only if the connection is of type VtoC or CtoV.

ID: | Identification of the cluster canal (only for TYPE:Clus)
# | from 1 to 8 alphanumeric characters '0' - '9', 'a' - 'z', 'A' - 'Z', '_' (underlined), #

It enables the setting-up of the identifier of the EIR cluster to be used for the connection.

The parameter is made visible and can be configured only if the connection is of type Clus.

The value "#", utilized with the meaning of "no EIR cluster", is used to deactivate the routing.

DT: | Disconnection time-out (only for TYPE:Clus)
10 | 1 - 900 (in seconds)

It enables the setting-up of a time-out (in sec.) for disconnections caused by inactivity on the connection which has been obtained with the routing under consideration.

The parameter is made visible and can be configured only if the connection is of type Clus.

MC: | Maximum number of connections on B channel (only for TYPE:Clus)
1 | 1 - 32

It enables the setting-up of the maximum number of connections on B channel, which can be opened up simultaneously by utilizing the routing under consideration.

In brackets is also given the maximum number of connections on B channel, which can be opened altogether on EIR cluster, the name of which is indicated in the ID: field of the routing.

This value is also made visible in the table of the EIR cluster identifiers, where it is possible to set up for it the value corresponding to the desired amount.

The parameter is made visible and can be configured only if the connection is of type Clus.

Configuration of EIR groups top

The table of the EIR groups can hold up to 32 definitions, indexed starting from 1 up to 31.

The table of EIR groups is not automatically maintained with consecutive indices and can contain "empty" places. Vacancies are assigned when a new entry is going to be created.

The table of the EIR groups can be modified during the operation of Abilis CPX without the need to make it restart. The modifications carried out in the table are made active immediately with the command INIT ER.

All commands for the manipulation of the EIR groups are described in the EIR Groups section of the chapter Commands relating to the Enhanced ISDN Router. The commands available are as follows:

A EG
C EG
D EG
S EG

Example of a view of all the EIR groups, shown values are sample values:

[15:46:31] ABILIS_CPX: D EG

ID: SC: R: |P1  P2  P3  P4  |P5  P6  P7  P8  |P9  P10 P11 P12 |P13 P14 P15 P16
-----------|----------------|----------------|----------------|---------------
1   R   NOR|280 281 .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------
2   R   NOR|282 283 .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------
5   P   LNA|.   .   .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------

Detail of the Parameters of the EIR groups

ID: | Identification of the EIR group.
no value | from 1 to 31

It establishes the EIR group identification index, that is used in the EIR routings to reference a group in POI: and POO: parameters.

The index of the EIR group must be in the range [1 - 31] and is also utilized as a reference for operations of insertion, modification and cancellation.

The table of EIR groups is not automatically maintained with consecutive indices and can contain "empty" places.

Every action of cancellation does not result in a reordering of all the indices following the one being referred to; by consequence, the identification corresponding to the EIR group which has been removed, remains disused.

SC: | Scanning ports method
R | R, P

It establishes the algorithm with which the ports listed in the EIR group are scanned.

The value "R" stands for "Round-Robin" algorithm and it indicates that the scanning of the ports occurs in a circular manner, ensuring that all of them are fairly utilized.

The value "P", stands for "Priority" algorithm and it is used to indicate that the ports are scanned starting from the first to the last.

R: | Try subsequent ports rule
NOR | LNA, NOR

It establishes the rule with which the Enhanced ISDN router will try the connection on the next port listed in the group, in the case that the connection on the previous port fails.

The value "LNA" stands for "Link Not Accessible" and it indicates that the group search continues ONLY after internal disconnection causes.

The value "NOR", stands for "Normal behavior" and it indicates that the group scanning proceeds when the disconnection cause is one of the following:

  • all internal causes (the same as "LNA" case);
  • Q931_CS_NONRES_USER cause;
  • all causes of class 2 (resource unavailable, e.g. "No circuit/channel available"), class 5 (invalid message, e.g. "Invalid call reference value") and class 6 (protocol error, e.g. "Recovery on timer expiring")
  • when the connection did NOT reach the "Alerting" state (or the later state - "Connected").
For additional explanations about disconnection causes see ISDN disconnection codes section.
P1: - P16: | Port of the group
NONE | 1 - 999, NONE (represented with '.' (dot) character)

They establish the possible destination ports of the EIR connection (which can only be of type EBQ931 or EPQ931).

The value "NONE", that is represented with the '.' (dot) character, stands for "no port" can be used to deactivate the single port of the EIR group.

If a port number is indicated, it must correspond with a port of type EBQ931 or EPQ931, which is configured and active inside the system.

Identifiers of remote EIR clusters top

The table of the identifiers of remote EIR clusters is automatically compiled and maintained up-to-date by the configuration procedures of Abilis CPX. Information are obtained on the base of the values configured in the Enhanced ISDN Router (EIR) port, and in the table of EIR routings.

Only one parameter can be modified by the user and it refers to the maximum number of connections on channel B that can be opened altogether on the EIR Cluster under consideration (MaxConn:).

All commands for the manipulation of the table of the identifiers of remote EIR clusters are described in the EIR Cluster Identifiers section of the Commands relating to the Enhanced ISDN Router chapter. The commands available are as follows:

D EID
S EID

Example of a view of the table of identifiers of remote EIR clusters:

[18:41:46] ABILIS_CPX: D EID

+-----------+----------+-----------+--------+
| Id:      | IntRef: | MaxConn: | Used: |
+-----------+----------+-----------+--------+
| CLUS_1   |  1 [01] |    32    |   1   |
| CLUS_2   |  2 [02] |     1    |   2   |
+-----------+----------+-----------+--------+

Detail of the parameters of the identifier of remote EIR clusters

Id: | Name assigned to the EIR Cluster
no value | from 1 to 8 alphanumeric characters

Reports the mnemonic identification which has been associated with the EIR Cluster at the moment of its configuration in the table of the EIR Routings or in the Enhanced ISDN Router port (EIR).

This parameter cannot be modified.

IntRef: | Internal numerical identification assigned by the system to the EIR Cluster
no value | from 1 to 233

This is the numerical identifier that is automatically assigned by the system to the remote EIR Cluster.

The numerical identification is reported both in decimal and hexadecimal format.

This numerical index is used only inside the system and cannot be used by the user in any way to make a reference to the remote EIR Cluster. For any operation, the user must use the mnemonic reported in the Id: parameter.

This parameter has only an informative meaning and cannot be modified.

MaxConn: | Maximum number of connections on channel B which can be opened on the EIR Cluster
32 | 0 - 32

This parameter enables the planning-out of the maximum number of connections on channel B that can be activated on the EIR Cluster under consideration.

The value of this parameter is used toghether with a similar parameter (MC:) that is available in Clus routings of the table of EIR routings.

Used: | Counting of references to the identification
no value | 1 - 233

This field shows the number of references to that identifier of remote EIR cluster, i.e. the total number of times that it is present in the configuration of the EIR port and/or in the table of the EIR routings.

This parameter has only an informative meaning and cannot be modified.


TDM switches configuration

Revised for CPX 4.1.0.
Configuration of TDM switches

Configuration of EIR connections
Configuration of EIR groups
Identifiers of remote EIR clusters

TDM switches configuration top

The table of TDM switches can store up to 64 entries, indexed starting from 0 up to 63.

The entry priority index sets the switch verification order and must be sequential.

The priority index for TDM switches is also utilized as a reference for operations of insertion, modification and deletion.

In the table of TDM switches, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT TDM.

Commands for handling the table of TDM switches are described in the TDM switches section of the chapter Commands relating to the Enhanced ISDN Router. The available commands are the following:

A TDM
C TDM
D TDM
M TDM
S TDM

Here it follows an example of the TDM switch visualization. All values are only examples.

[18:14:08] ABILIS_CPX: D TDM

---+--------+---------+-------+-----+------------------------------------------
PR:|SERVICE:|MODE:    |VSP-ID:|PO:  |CH:
---+--------+---------+-------+-----+------------------------------------------
0   sQ931    OUTGOING      -   NONE  NONE
1   sQ931    BIDIR         -     80  1-2
2   sQ931    BIDIR         -     80  NONE
3   VSP      -             3   NONE  NONE
4   VSP      -            32   NONE  NONE
5   VSP      -             1     96  1-31

Detail of the TDM switch parameters

PR: | TDM switch priority: the highest priority is 0
no value | from 0 up to 63

This is the TDM switch entry priority. The priority value sets the verification order of the TDM switches table entries: starting from the highest (0) and proceeding to the end of the table (at maximum up to 63).

The priority index is also used by the adding, modifying, deleting commands to refer to a given TDM switch.

TDM switches table is automatically updated every time it is modified, so that priority sequential order is kept and no "free places" are left into the table.

SERVICE: | Type of service associated to the TDM switch
Unused | Unused, VSP, sQ931, Q931

It sets the type of service associated to the TDM switch.

Value | Meaning
Unused | It stands for "no service". It is the default value associated by the command A TDM.
VSP | It stands for Virtual Synchronous Port service.
sQ931 | It stands for simulated Q931 service.
Q931 | It stands for Q931 service.
MODE: | Type of channel(s) used by the service.(Only for SERVICE:sQ931/Q931)
BIDIR | BIDIR, INCOMING, OUTGOING

It sets the type of channel(s) used by the service sQ931 or by the service Q931, which the TDM switch refers to:

Value | Meaning
BIDIR | Bidirectional channels
INCOMING | Incoming channels
OUTGOING | Outgoing channels

This parameter can be changed only when the SERVICE: parameter is set to "Q931" or "sQ931" value.

VSP-ID: | Identifiers associated to the VSP service (Only for SERVICE:VSP)
NONE | NONE, 1 - 32

It sets the identifier associated to the Virtual Synchronous Port (VSP) service, which the TDM switch refers to.

This parameter can be changed only when the SERVICE: parameter is set to "VSP" value.

PO: | ISDN/EBISDN/EPISDN port which the TDM switch refers to TDM
NONE | NONE, 0 - 999

It specifies the port which the TDM switch refers to. The specified value must correspond to a configured port of ISDN, EBISDN or EPISDN type.

CH: | Channels used by the service which the TDM switch refers to.
NONE | NONE, 1 - 31 (more than one values can be joined by using ',' (comma), and/or '-' (minus))

It specifies the channel or a group of channels used by the service, which the TDM switch refers to.

Intervals of values are allowed by using the ',' (comma) character and/or the '-' (minus) character.
For example the value: "CH:1-3,5-8,20-22", indicates that channels from 1 to 3, 5 to 8, 20 to 22 are in use.

For VSP services type only contiguous intervals are allowed.
For example it is allowed to set "CH:5-20", while it is not allowed the following "CH:5-10,12-20".

If the port specified in the parameter PO: is a Basic Rate port, then the interval allowed will be [1 - 2].


The ISDN level 1 ports (ISDN - EBISDN - EPISDN)

Configuration of the ISDN level 1 ports (ISDN - EBISDN - EPISDN)
Statistics of the ISDN level 1 ports (ISDN - EBISDN - EPISDN)
SNMP traps generated for the ISDN ports
SNMP traps generated for the EBISDN ports
SNMP traps generated for the EPISDN ports

Configuration of the ISDN level 1 ports (ISDN - EBISDN - EPISDN) top

The ISDN Basic Rate configuration

The ISDN Basic Rate port for the "single port" board is labelled, within the Abilis CPX, by the abbreviation "ISDN" and it is provided with the parameters described in this chapter.

The following example shows how to display the ISDN Basic Rate port parameters. Shown values are the default ones.

[18:42:32] ABILIS_CPX: D P PO:17
PO:17  ------------------------------------------------------------------------
ISDN   LOG:NO      frame:2100    rxbuf:14     txbuf:1

To activate any change made on the ISDN Basic Rate port parameters, it is needed to restart the system. This feature is highlighted by the fact that parameters names are showed by low case characters. Changes made on the parameter LOG: are immediately active.

The ISDN Basic Rate configuration for EBIB board

The ISDN Basic Rate ports for the EBIB board are labelled, within the Abilis CPX, by the abbreviation "EBISDN" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of two EBISDN ports: the first one is a "NT" type, the second a "TE".

[18:42:32] ABILIS_CPX: D P PO:81

PO:81  ------------------------------------------------------------------------
EBISDN LOG:NO      side:NT       BUS:SHORT

[18:42:32] ABILIS_CPX: D P PO:82

PO:82  ------------------------------------------------------------------------
EBISDN LOG:DS      side:TE

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on low case parameters it is enough to execute the initialization command INIT PO:. Changes made on the parameter LOG: are immediately active.

The ISDN Primary Rate configuration for EPIB board

The ISDN Primary Rate ports for the EPIB board are labelled, within the Abilis CPX, by the abbreviation "EPISDN" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of the EPISDN port.

[18:42:32] ABILIS_CPX: D P PO:96

PO:96  ------------------------------------------------------------------------
EPISDN LOG:DS      side:NT       BUS:SHORT
       service:E1                E1-FRAMING:CRC4

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on low case parameters it is enough to execute the initialization command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the ISDN level 1 ports (ISDN - EBISDN - EPISDN)

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

FRAME: | Maximum frame length (Only in ISDN ports)
2100 | 128 - 2100 (in bytes)

It sets the maximum frame length (without Flags and CRC).

RXBUF: | Number of receiving buffers (Only in ISDN ports)
14 | 1 - 50

It sets the number of buffer to be used for receiving DATA frames.

TXBUF: | Number of transmission buffers (Only in ISDN ports)
1 | 1 - 50

It sets the number of buffer to be used for transmitting DATA frames.

SIDE: | Port type (Only in EBISDN and EPISDN ports)
TE | TE, NT

It sets the port type and then the driver behaviour.

This parameter is related with the eventual upper level EBLAPD/EPLAPD port. If those values have been set differently, the Validation procedure will force the parameter "SIDE:" of the EBISDN port to have the same value as the parameter SIDE: of the EBLAPD/EPLAPD port referred.

BUS: | S0 bus type in us (Only in EBISDN and EPISDN ports if SIDE:NT)
SHORT | SHORT, EXT

It sets the S0 bus type in use. The parameter is shown and configurable only if the port type is "NT".

The value "SHORT" means the bus length is shorter than 200 meters, the "EXT" one, instead, refers to length shorter than 1 km.

SERVICE: | Service type (Only in EPISDN ports)
E1-ISDN |

It sets the type of service.

E1-FRAMING: | ????????????(Only in EPISDN ports)

??????????????????????????.

Statistics of the ISDN level 1 ports (ISDN - EBISDN - EPISDN) top

Statistics of the ISDN Basic Rate ports

How to check the state and statistics of the ISDN Basic Rate ports by the command D S.

[18:42:32] ABILIS_CPX: D S PO:17

PO:17  ------------------------------------------------------------------------
ISDN   STATE:F7-READY  SLIPS:0

Extended statistics are available for ISDN Basic Rate ports too. Here is an example on how to check them using the command D SE:

[18:42:32] ABILIS_CPX: D SE PO:17

PO:17  ------------------------------------------------------------------------
ISDN   --- Cleared 001:04:53:04 ago, on 08/05/2000 at 13:06:34 ----------------
       Level 1    SLIPS:0
       ------------------------------------------------------------------------
       D channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |41072      |41002      |FRM        |10060      |9939       |
       LONG       |0          |0          |LOST       |0          |           |
       ------------------------------------------------------------------------
       B1 channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------
       B2 channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EBISDN ports

How to check the state and statistics of the EBISDN ports, "NT" type and then "TE", by the command D S.

[18:42:32] ABILIS_CPX: D S PO:81

PO:81  ------------------------------------------------------------------------
EBISDN STATE:G3-READY

[18:42:32] ABILIS_CPX: D S PO:82

PO:82  ------------------------------------------------------------------------
EBISDN STATE:F7-READY  SLIPS:0

Extended statistics are available for EBISDN ports too. Here is an example on how to check them using the command D SE:

ABILIS_CPX: D SE PO:81

PO:81  ------------------------------------------------------------------------
EBISDN --- Cleared 027:06:42:31 ago, on 14/04/2000 at 11:07:28 ----------------
       Level 1    SLIPS:1
       ------------------------------------------------------------------------
       D channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |1001814    |990287     |FRM        |242149     |242342     |
       LONG       |0          |0          |LOST       |0          |           |
       ------------------------------------------------------------------------
       B1 channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------
       B2 channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EPISDN ports

How to check statistics of the EPISDN ports through the command D S.

[18:42:32] ABILIS_CPX: D S PO:96

PO:96  ------------------------------------------------------------------------
EPISDN STATE:PRI-DOWN  SLIPS:0

Extended statistics are available for EPISDN ports too. Here is an example on how to check them using the command D SE:

[18:42:32] ABILIS_CPX: D SE PO:96

PO:96  ------------------------------------------------------------------------
EPISDN --- Cleared 000:05:58:15 ago, on 11/05/2000 at 12:01:29 ----------------
       Level 1    SLIPS:0
       ------------------------------------------------------------------------
       D channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM        |0          |0          |
       LONG       |0          |0          |LOST       |0          |           |
       ------------------------------------------------------------------------
       B channel summary
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

The last example shows that the execution of the command D SE will display a summary table of the 30 B channels extended statistics.

it is possible to show the extended statistics of each B channel, as the following example demonstrates:

[18:42:32] ABILIS_CPX: D SE PO:96 BCHAN:5

PO:96  ------------------------------------------------------------------------
EPISDN Level 1    SLIPS:0
       ------------------------------------------------------------------------
       D channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM        |0          |0          |
       LONG       |0          |0          |LOST       |0          |           |
       ------------------------------------------------------------------------
       B5  channel
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       DATA-CHR   |0          |0          |FRM-D      |0          |0          |
       FRM-C      |0          |0          |FRM-V      |0          |0          |
       LONG-D     |0          |0          |LONG-C     |0          |0          |
       LONG-V     |0          |0          |LOST-D     |0          |           |
       LOST-C     |0          |           |LOST-V     |0          |           |
       ------------------------------------------------------------------------

Even in this case statistics related to the D channel are displayed.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the statistics of the ISDN level 1 ports (ISDN - EBISDN - EPISDN)

STATE: | Current state of the ISDN LEVEL 1 PORT driver
 | DOWN, F7-READY, HALTED, FAILED, F3-INACT, F3-INACT2, F3-INACT3, F4-DOWN, F5-DOWN, F6-DOWN, F8-DOWN, G1-DEACTIVATED, G2-PENDING_ACTIVATION, G2-LOST_FRAMING, G3-READY, G3-ACTIVATED_BLOCKED, G4-PENDING_DEACTIVATION, G4-WAIT_DEACTIVATION, ERR

It shows the actual state of the ISDN driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
ISDN | DOWN F3-INACT F3-INACT2 F3-INACT3 F4-DOWN F5-DOWN F6-DOWN F8-DOWN | The ISDN driver is not active and it is not able to work | dn
 | F7-READY or G3-READY | Port is active | RD
 | HALTED | The ISDN driver is halted due to a fatal error | HL
 | FAILED | The ISDN driver is blocked because of the initialization procedure failure | FL
 | ERR | Software error. Contact the Abilis assistance. | NA
EBISDN | DOWN F3-INACT F3-INACT2 F3-INACT3 F4-DOWN F5-DOWN F6-DOWN F8-DOWN G1-DEACTIVATED G2-PENDING-ACTIVATION G2-LOST-FRAMING G3-ACTIVATED-BLOCKED G4-PENDING-DEACTIVATION G4-WAIT-DEACTIVATION | The ISDN driver is not active and it is not able to work | dn
 | F7-READY or G3-READY | Port is active | RD
 | HALTED | The ISDN driver is halted due to a fatal error | HL
 | FAILED | The ISDN driver is blocked because the initialization procedure failed | FL
 | ERR | Software error. Contact the Abilis assistance. | NA
EPISDN | PRI-DOWN | The port is not active and it is not able to restart | dn
 | PRI-UP | Port is active | UP
 | ERR | Software error. Contact Abilis assistance. | NA

SLIPS: | Number of "slips" detected in the Level 1
 | 0 - 4.294.967.295

This counter shows the number of "slips" detected in the Level 1.

Detail of the extended statistics of the ISDN level 1 ports (ISDN - EBISDN - EPISDN)

SLIPS: These statistics are the same shown in basic command and already explained
RX-OVR: | Number of "overrun" occurred in the communication board
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time an "overrun" in the communication board occurs.

TX-UND: | Number of "underrun" occurred in the communication board
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time an "underrun" in the communication board occurs.

BAD-FCS: | Number of received frames with bad FCS field
 | 0 - 4.294.967.295

The counter BAD-FCS (INPUT) is incremented every time a frame with bad FCS is received.

ABORT: | Number of aborted received frames or aborted during the transmission
 | 0 - 4.294.967.295

The counter ABORT (INPUT) is incremented every time an aborted frame is received. Similarly the ABORT (OUTPUT) one is incremented every time a transmission "abort" occurs.

DATA-CHR: | Number of DATA characters received/sent
 | 0 - 4.294.967.295

The counter DATA-CHR (INPUT) is incremented every time the port receives a frame, while the counter DATA-CHR (OUTPUT) every time a frame is sent.

FRM: | Number of received/sent frames
 | 0 - 4.294.967.295

The counter FRM (INPUT) is incremented every time the port receives a frame, while the counter FRM (OUTPUT) every time a frame is sent.

LONG: | Number of too long received frames
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time a received frame is too long, while the counter LONG (OUTPUT) every time a too long frame is received from the upper level driver.

LOST: | Number of frames sent and lost
 | 0 - 4.294.967.295

The counter LOST (INPUT) is incremented every time a sent frame get lost.

FRM-D: | Number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter FRM-D (INPUT) is incremented every time a DATA frame is received. The counter FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

FRM-C: | Number of received/sent Link-Check frames
 | 0 - 4.294.967.295

The counter FRM-C (INPUT) is incremented every time a Link-Check frame is received. The counter FRM-C (OUTPUT) is incremented every time a Link-Check frame is sent.

FRM-V: | Number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

LONG-D: | Number of too long DATA frames received/sent
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time the DATA frame received by the lower level is too long. The counter LONG-D (OUTPUT) is incremented if the upper level port requests to send a DATA frame, whose length is bigger than the allowed maximum value.

LONG-C: | Number of too long Link-Check frames received/sent
 | 0 - 4.294.967.295

The counter LONG-C (INPUT) is incremented every time a Link-Check frame received is too long. The counter LONG-C (OUTPUT) is incremented if the upper level port request to send a Link-Check frame, whose length is bigger than the allowed maximum value.

LONG-V: | Number of too long VOICE frame received/sent
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time a VOICE frame received is too long. The counter LONG-V (OUTPUT) is incremented if the upper level port request to send a VOICE frame, whose length is bigger than the allowed maximum value.

LOST-D: | Number of DATA frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-D (INPUT) is incremented every time a sent DATA frame get lost.

LOST-C: | Number of Link-Check frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-C (INPUT) is incremented every time a sent Link-Check frame get lost.

LOST-V: | Number of VOICE frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-V (INPUT) is incremented every time a sent VOICE frame get lost.

SNMP traps generated for the ISDN ports top

Specific code of the Trap | Trap mnemonic | SNMP variables shown in the trap | Description
6 | cxTrapIsdnBriDown | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ISDN port driver leaves the READY state and reaches one of the "DOWN" states.
7 | cxTrapIsdnBriReady | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ISDN port driver leaves one of the "DOWN" states and reaches a "READY" one.

Detail of the SNMP variables shown in the ISDN port traps

cxPortIndex | ISDN port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the ISDN port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case ISDN) and the description eventually associated to it.

cxIsdnDiagState | Current state if the ISDN port driver which the trap refers to
 | down(0), f7-ready(1), halted(2), failed(3), f3-inact(4), f3-inact2(5), f3-inact3(6), f4-down(7), f5-down(8), f6-down(9), f8-down(10)

This variable shows the current state of the ISDN port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the ISDN driver
down(0) | DOWN
f7-ready(1) | F7-READY
halted(2) | HALTED
failed(3) | FAILED
f3-inact(4) | F3-INACT
f3-inact2(5) | F3-INACT2
f3-inact3(6) | F3-INACT3
f4-down(7) | F4-DOWN
f5-down(8) | F5-DOWN
f6-down(9) | F6-DOWN
f8-down(10) | F8-DOWN

cxIsdnDiagSlips | Number of "slips" detected in Level 1
 | 0 - 4.294.967.295

This variable shows the number of "slips" detected in Level 1.

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as "days:hours:minutes:seconds".

SNMP traps generated for the EBISDN ports top

Specific code of the Trap | Trap mnemonic | SNMP variables shown in the trap | Description
6 | cxTrapIsdnBriDown | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the EBISDN port driver leaves the READY state and reaches one of the "DOWN" states
7 | cxTrapIsdnBriReady | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ISDN port driver leaves one of the "DOWN" states and reaches a "READY" one

Detail of the SNMP variables shown in the EBISDN port traps

cxPortIndex | EBISDN port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the EBISDN port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case EBISDN) and the description eventually associated to it.

cxIsdnDiagState | Current state if the EBISDN port driver which the trap refers to
 | down(0), f7-ready(1), halted(2), failed(3), f3-inact(4), f3-inact2(5), f3-inact3(6), f4-down(7), f5-down(8), f6-down(9), f8-down(10), g1-deactivated(11), g2-pending-activation(12), g2-lost-framing(13), g3-ready(14), g3-activated-blocked(15), g4-pending-deactivation(16), g4-wait-deactivation(17)

This variable shows the current state of the EBISDN port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the EBISDN driver
down(0) | DOWN
f7-ready(1) | F7-READY
halted(2) | HALTED
failed(3) | FAILED
f3-inact(4) | F3-INACT
f3-inact2(5) | F3-INACT2
f3-inact3(6) | F3-INACT3
f4-down(7) | F4-DOWN
f5-down(8) | F5-DOWN
f6-down(9) | F6-DOWN
f8-down(10) | F8-DOWN
g1-deactivated(11) | G1-DEACTIVATED
g2-pending-activation(12) | G2-PENDING-ACTIVATION
g2-lost-framing(13) | G2-LOST-FRAMING
g3-ready(14) | G3-READY
g3-activated-blocked(15) | G3-ACTIVATED-BLOCKED
g4-pending-deactivation(16) | G4-PENDING-DEACTIVATION
g4-wait-deactivation(17) | G4-WAIT-DEACTIVATION

cxIsdnDiagSlips | Number of "slips" detected in Level 1
 | 0 - 4.294.967.295

This variable shows the number of "slips" detected in Level 1. This parameter is meaningful only if the port type is "TE".

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

SNMP traps generated for the EPISDN ports top

Specific code of the Trap | Trap mnemonic | SNMP variables shown in the trap | Description
6 | cxTrapIsdnPriDown | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the EPISDN port driver leaves the PRI-UP state and reaches the PRI-DOWN one
7 | cxTrapIsdnPriUp | cxPortIndex, cxPortType, cxIsdnDiagState, cxIsdnDiagSlips, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the EPISDN port driver leaves the PRI-DOWN state and reaches the PRI-UP one

Detail of the SNMP variables shown in the EPISDN port traps

cxPortIndex | EPISDN port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the EPISDN port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case EPISDN) and the description eventually associated to it.

cxIsdnDiagState | Current state if the EPISDN port driver which the trap refers to
 | pri-up(18), pri-down(19)

This variable shows the current state of the EPISDN port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the EBISDN driver
pri-up(18) | PRI-UP
pri-down(19) | PRI-DOWN

cxIsdnDiagSlips | Number of "slips" detected in Level 1
 | 0 - 4.294.967.295

This variable shows the number of "slips" detected in Level 1. This parameter is meaningful only if the port type is "TE".

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence in the format day:hours:minutes:seconds.


The level 2 ISDN ports (LAPD - EBLAPD - EPLAPD)

Configuration of the level 2 ISDN ports (LAPD - EBLAPD - EPLAPD)
Statistics of the level 2 ISDN ports (LAPD - EBLAPD - EPLAPD)
SNMP Traps generated for the ISDN Basic Rate LAPD
SNMP Traps generated for the EBLAPD ports
SNMP Traps generated for the EPLAPD ports

Configuration of the level 2 ISDN ports (LAPD - EBLAPD - EPLAPD) top

Configuration of the ISDN Basic Rate LAPD ports

The LAPD port type for ISDN Basic Rate is labelled, within the Abilis CPX, by the abbreviation "LAPD" and it is provided with the parameters described in this chapter.

The following example shows how to display the LAPD port parameters. Shown values are the default ones.

[18:21:53] ABILIS_CPX: D P PO:117
PO:117 ------------------------------------------------------------------------
LAPD   LOG:NO      lowpo:17      LINE:MP
       Q931:YES    Q931TEI:AUTO  X25:NO       X25TEI:10
       X25K:7      X25T200:1     X25T203:10   X25N200:3    x25n201:260

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Configuration of the EBLAPD ports

The LAPD Basic Rate ports for the EBIB board are labelled, within the Abilis CPX, by the abbreviation "EBLAPD" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of the EBLAPD ports. Shown values are the default ones.

[18:21:53] ABILIS_CPX: D P PO:180 .
PO:180 ------------------------------------------------------------------------
EBLAPD LOG:NO      lowpo:80      side:NT      line:MP
       Q931:YES    Q931TEI:AUTO  X25:NO       X25TEI:10
       X25K:7      X25T200:1     X25T203:10   X25N200:3    x25n201:260

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Configuration of the EPLAPD ports

The LAPD Primary Rate ports for the EPIB board are labelled, within the Abilis CPX, by the abbreviation "EPLAPD" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of the EPLAPD ports. Shown values are the default ones.

[18:21:53] ABILIS_CPX: D P PO:196
PO:196 ------------------------------------------------------------------------
EPLAPD LOG:DS      lowpo:96      side:NT
       Q931:YES    Q931TEI:0     X25:NO       X25TEI:10
       X25K:7      X25T200:1     X25T203:10   X25N200:3    x25n201:260

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the level 2 ISDN ports (LAPD - EBLAPD - EPLAPD)

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the lower level port; it can only be an ISDN Basic Rate port type.

The value "NONE" isolates the LAPD port from the lower level ports.

LINE: | Line type
MP | MP, PP

It sets the line type: "MP" stands for multi-point, while "PP" point to point.

This parameter is related with the same eventual parameter of the higher level Q931/EBQ931 ports. If those values have been set differently, the Validation procedure will force the parameter "LINE:" of the LAPD port to have the same value as the parameter LINE: of the Q931/EBQ931 ports referred.

SIDE: | Port type
NT | TE, NT

It sets the port type and then the driver behaviour.

This parameter is related with the eventual upper level EBQ931/EPQ931 port. If those values have been set differently, the Validation procedure will force the parameter "SIDE:" of the EBLAPD/EPLAPD port to have the same value as the parameter SIDE: of the EBQ931/EPQ931 port referred.

This parameter is also related with the same parameter of the lower level EBISDN/EPISDN port. If those values have been set differently, the Validation procedure will force the parameter SIDE: of the EBISDN/EPISDN port to have the same value as the parameter "SIDE:" of the EBLAPD/EPLAPD referred port.

Q931: | Sapi Q.931 activation
YES | NO, YES

This parameter activates the Sapi Q.931, needed to use the B channels.

Q931TEI: | TEI assignation to the Sapi 0 (Q931)
AUTO | 0 - 63, AUTO

It assigns the TEI to Sapi 0 (Q931). If it is set to "AUTO" the assignation is automatic.

X25: | Sapi X.25 activation
YES | NO, YES

This parameter activates the Sapi X.25, needed to use the service "X25 over D channel".

X25TEI: | TEI assignation to the Sapi X.25
10 | 0 - 63

It assigns the TEI to Sapi X.25.

X25K: | Maximum size of the frame window for Sapi X.25
7 | 1 - 7

It sets the maximum size of the frame window for Sapi X.25.

X25T200: | Time interval between two consecutive SABME or DM frame type transmissions and timeout for Sapi X.25
1 | 1 - 10 (in seconds )

It sets the minimum time interval between two consecutive transmissions of SABME or DM frame type and timeout for Sapi X.25.

X25T203: | Maximum "idle" time of the Sapi X.25
10 | 1 - 60 (in seconds)

It sets the maximum "idle" time interval of the Sapi X.25.

X25N200: | Sapi X.25 maximum number of retransmissions
3 | 1 - 30

It sets the maximum number of retransmissions for the Sapi X.25.

X25N201: | Maximum number of octets stored, for the Sapi X.25, by the informative field
260 | 260 - 2052

It sets the maximum number of octets stored, for the Sapi X.25, by the informative field.

Statistics of the level 2 ISDN ports (LAPD - EBLAPD - EPLAPD) top

Statistics of the ISDN Basic rate LAPD ports

How to check the state and statistics of the LAPD ports by the command D S.

[18:21:53] ABILIS_CPX: D S PO:117
PO:117 ------------------------------------------------------------------------
LAPD   - Sapi ------- TEI -- STATE --------------------------------------------
         16 (X.25)      0    00-INACTIVE
         0  (Q.931)   255    01-IDLE
       ------------------------------------------------------------------------

Extended statistics are available for LAPD ports too. Here is an example on how to check them using the command D SE:

[18:21:53] ABILIS_CPX: D SE PO:117
PO:117 ------------------------------------------------------------------------
LAPD   --- Cleared 000:00:01:21 ago, on 11/05/2000 at 18:23:29 ----------------
       Sapi 16 (X.25)   TEI:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------
       Sapi 0  (Q.931)  TEI:ALL
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The last example shows that the execution of the command D SE will display a summary table of the extended statistics of TEIs used on Sapi 16 and 0.

it is possible to show the extended statistics of each TEI, as the following example demonstrates:

[18:21:53] ABILIS_CPX: D SE PO:117 TEI:0
PO:117 ------------------------------------------------------------------------
LAPD   --- Cleared 000:00:02:16 ago, on 11/05/2000 at 18:23:29 ----------------
       Sapi 16 (X.25)  TEI:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The value specified by the parameter "TEI:" must be in the interval 0 - 126. Digiting "TEI:A", all the TEIs will be shown.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EBLAPD ports

How to check the state and statistics of the EBLAPD ports by the command D S.

[18:21:53] ABILIS_CPX: D S PO:180 .
PO:180 ------------------------------------------------------------------------
EBLAPD - Sapi ------- TEI -- STATE --------------------------------------------
         16 (X.25 )    10    00-INACTIVE
         0  (Q.931)    64    07-CONNECTED
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
         0  (Q.931)   255    01-IDLE
       ------------------------------------------------------------------------

Extended statistics are available for EBLAPD ports too. Here is an example on how to check them using the command D SE:

[18:21:53] ABILIS_CPX: D SE PO:18O .
PO:180 ------------------------------------------------------------------------
EBLAPD --- Cleared 027:07:27:50 ago, on 14/04/2000 at 11:07:23 ----------------
       Sapi 16 (X.25)  TEI:10
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------
       Sapi 0  (Q.931)  TEI:ALL
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |9644       |4589       |
       UI         |0          |0          |RR         |239072     |244126     |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The last example shows that the execution of the command D SE will display a summary table of the extended statistics of TEIs used on Sapi X.25 and Q931.

it is possible to show the extended statistics of each TEI, as the following example demonstrates:

[18:21:53] ABILIS_CPX: D SE PO:180 TEI:10
PO:180 ------------------------------------------------------------------------
EBLAPD --- Cleared 027:07:28:38 ago, on 14/04/2000 at 11:07:24 ----------------
       Sapi 16 (X.25)  TEI:10
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The value specified by the parameter "TEI:" must be in the interval 0 - 126. Digiting "TEI:A", all the TEIs will be shown.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EPLAPD ports

How to check the state and statistics of the EPLAPD ports through the command D S.

[18:21:53] ABILIS_CPX: D S PO:196
PO:196 ------------------------------------------------------------------------
EPLAPD - Sapi ------- TEI -- STATE --------------------------------------------
         16 (X.25 )    10    00-INACTIVE
         0  (Q.931)     0    05-CONNECTING
       ------------------------------------------------------------------------

Extended statistics are available for EPLAPD ports too. Here is an example on how to check them using the command D SE:

[18:21:53] ABILIS_CPX: D SE PO:196
PO:196 ------------------------------------------------------------------------
EPLAPD --- Cleared 000:00:00:58 ago, on 11/05/2000 at 18:44:01 ----------------
       Sapi 16 (X.25)  TEI:10
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------
       Sapi 0  (Q.931)  TEI:ALL
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |32         |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |32         |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The last example shows that the execution of the command D SE will display a summary table of the extended statistics of TEIs used on Sapi X.25 and Q931.

it is possible to show the extended statistics of each TEI, as the following example demonstrates:

[18:21:53] ABILIS_CPX: D SE PO:182 TEI:10
PO:182 --- Cleared 004:22:41:13 ago, at 21/05/1999 11:36:43 -------------------
EPLAPD Sapi 16 (X.25)  TEI:10
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T200-DN    |           |0          |T200-UP    |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       UI         |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SABME      |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       DM         |0          |0          |N200-OVER  |           |0          |
       SHORT      |0          |           |LONG       |0          |           |
       UNK-SAPI   |0          |           |BAD-FRM    |0          |           |
       ------------------------------------------------------------------------

The value specified by the parameter "TEI:" must be in the interval [0 - 126]. Digiting "TEI:A", all the TEIs will be shown.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of state fields and statistics of the LAPD ports

Sapi: | Actual Sapi
 | 0 (Q931) or 16 (X.25) or ALL

It shows the actual Sapi which state information refers to.

TEI: | TEI currently assigned
 | 0 - 126

It shows the TEI currently assigned to the Sapi.

STATE: | Current state of Sapi Q931 and Sapi X.25 of the LAPD driver
 | 00-INACTIVE, 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING, 07-CONNECTED, 08-CONNECTED, ERR

It shows the actual state of Sapi Q931 and Sapi X.25:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
LAPD (Sapi Q931 and Sapi X.25) | 00-INACTIVE | Sapi is not active | in | in |
 | 01-IDLE | TEI is not assigned | dn | dn |
 | 04-DISCONNECTED | TEI is assigned, the connection is not open
 | 05-CONNECTING | Waiting for connection to be ready
 | 06-DISCONNECTING | Waiting for connection to get closed
 | 07-CONNECTED | Connection is up | UP |  |
 | 08-CONNECTED |  |  |  |
 | ERR | Software error. Contact Abilis assistance. | NA | NA |
EBLAPD (Sapi Q931 and Sapi X.25) | 00-INACTIVE | Sapi is not active | in | in |
 | 01-IDLE | TEI is not assigned | dn | dn |
 | 04-DISCONNECTED | TEI is assigned, the connection is not open
 | 05-CONNECTING | Waiting for connection to be open
 | 06-DISCONNECTING | Waiting for connection to get closed
 | 07-CONNECTED | Connection is up | UP |  |
 | 08-CONNECTED |  |  |  |
 | ERR | Software error. Contact Abilis assistance. | NA | NA |
EPLABD (Sapi Q931 and Sapi X.25) | 00-INACTIVE | Sapi is not active | in
 | 01-IDLE | TEI is not assigned | dn
 | 04-DISCONNECTED | TEI is assigned, the connection is not open
 | 05-CONNECTING | Waiting for connection to be open
 | 06-DISCONNECTING | Waiting for connection to get closed
 | 07-CONNECTED | Connection is up | UP
 | 08-CONNECTED
 | ERR | Software error. Contact Abilis assistance. | NA

Detail of the extended statistics of LAPD ports

T200-DN: | Number of times that "T200:" ran over while the port is in its "DISCONNECTED" state
 | 0 - 4.294.967.295

The counter T200-DN (OUTPUT) is incremented every time the Abilis CPX doesn't receive, within the time interval set by the parameter "T200:", the acknowledge of frame sent while the driver is in its "DISCONNECTED" state.

T200-UP: | Number of times that "T200:" ran over while the port is in the "CONNECTED" state
 | 0 - 4.294.967.295

The counter T200-UP (OUTPUT) is incremented every time the Abilis CPX does not receive, within the time interval set in the parameter "T200:", the acknowledge of frame sent while the driver is in the "CONNECTED" state.

REP: | Number of times that a repeated frame is sent/received
 | 0 - 4.294.967.295

The counter REP (INPUT) is incremented every time the Abilis CPX receives a repeated frame, while the counter REP (OUTPUT) every time the Abilis CPX sends again a frame.

INFO: | Number of INFO frames received/sent
 | 0 - 4.294.967.295

The counter INFO (INPUT) is incremented every time the Abilis CPX receives an INFO frame. The counter INFO (OUTPUT) is incremented every time an INFO frame is sent.

UI: | Number of UI frames received/sent
 | 0 - 4.294.967.295

The counter UI (INPUT) is incremented every time a UI frame is received, while the counter UI (OUTPUT) every time a UI frame is sent.

RR: | Number of RR frames received/sent
 | 0 - 4.294.967.295

The counter RR (INPUT) is incremented every time a RR frame is received, while the counter RR (OUTPUT) every time a RR frame is sent.

RNR: | Number of RNR frames received/sent
 | 0 - 4.294.967.295

The counter RNR (INPUT) is incremented every time a RNR frame is received, while the counter RNR (OUTPUT) every time a RNR frame is sent.

REJ: | Number of REJ frames received/sent
 | 0 - 4.294.967.295

The counter REJ (INPUT) is incremented every time a REJ frame is received, while the counter REJ (OUTPUT) every time a REJ frame is sent.

FRMR: | FRMR frames received/sent
 | 0 - 4.294.967.295

The counter FRMR (INPUT) is incremented every time Abilis CPX receives a FRMR frame, while the counter FRMR (OUTPUT) every time a FRMR frame is sent.

SABME: | Number of SABME frames received/sent
 | 0 - 4.294.967.295

The counter SABME (INPUT) is incremented every time Abilis CPX receives a SABME frame, while the counter SABME (OUTPUT) every time a SABME frame is sent.

UA: | Number of UA frames received/sent
 | 0 - 4.294.967.295

The counter UA (INPUT) is incremented every time a UA frame is received, while the counter UA (OUTPUT) every time a UA frame is sent.

DISC: | Number of DISC frames received/sent
 | 0 - 4.294.967.295

The counter DISC (INPUT) is incremented every time a DISC frame is received, while the counter DISC (OUTPUT) every time a DISC frame is sent.

DM: | Number of DM frames received/sent
 | 0 - 4.294.967.295

The counter DM (INPUT) is incremented every time a DM frame is received, while the counter DM (OUTPUT) every time a DM frame is sent.

N200-OVER: | Number of times the maximum retransmission number has been reached
 | 0 - 4.294.967.295

The counter N2-OVR (OUTPUT) is incremented every time that the value set in the parameter X25N200: is reached.

SHORT: | Number of too short frames received
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the port receives a frame, whose size is smaller than the fixed minimum value.

LONG: | Number of too long frames received
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time the port receives a frame, whose size is bigger than the fixed maximum value.

UNK-SAPI: | Number of frames received with correct TEI but unknown Sapi
 | 0 - 4.294.967.295

The counter UNK-SAPI is incremented every time a frame is received with correct TEI but unknown Sapi.

BAD-FRM: | Number of frames received with a control field unknown
 | 0 - 4.294.967.295

The counter BAD-FRM is incremented every time a frame is received with Control field unknown.

SNMP Traps generated for the ISDN Basic Rate LAPD top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
16 | cxTrapLapdBriQ931Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a LAPD port reaches the 00-INACTIVE state
17 | cxTrapLapdBriQ931Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a LAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
18 | cxTrapLapdBriQ931Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a LAPD port reaches the 07-CONNECTED or 08-CONNECTED state
19 | cxTrapLapdBriX25Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25 of a LAPD port reaches the 00-INACTIVE state
20 | cxTrapLapdBriX25Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a LAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
21 | cxTrapLapdBriX25Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a LAPD port reaches the 07-CONNECTED or 08-CONNECTED state

Detail of the SNMP variables shown in the LAPD port traps

cxPortIndex | LAPD port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the LAPD port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case LAPD) and the description eventually associated to it.

cxLapdDiagSapiIndex | Identifier of the Sapi which the trap refers to
 | 0 (Q931) o 16 (X.25)

This parameter shows the Sapi identifier which the traps refers to.

cxLapdDiagSapiState | Current state of the Sapi Q931 or Sapi X.25 which the trap refers to
 | inactive_00(0), idle_01(1), disconnected_04(4), connecting_05(5), disconnecting_06(6), connected_07(7), connected_08(8)

This variable shows the current state of the Sapi Q931or Sapi X.25 which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the EBISDN driver
inactive_00(0) | 00-INACTIVE
idle_01(1) | 01-IDLE
disconnected_04(4) | 04-DISCONNECTED
connecting_05(5) | 05-CONNECTING
disconnecting_06(6) | 06-DISCONNECTING
connected_07(7) | 07-CONNECTED
connected_08(8) | 08-CONNECTED

cxLapdDiagSapiTei | Identifier of the TEI currently assigned to the Sapi which the trap refers to
 | 1 - 126

It shows the identifier of the TEI currently assigned to the Sapi which the trap refers to.

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

SNMP Traps generated for the EBLAPD ports top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
16 | cxTrapLapdBriQ931Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of the EBLAPD port reaches the 00-INACTIVE state
17 | cxTrapLapdBriQ931Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of the EBLAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
18 | cxTrapLapdBriQ931Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of the EBLAPD port reaches the 07-CONNECTED or 08-CONNECTED state
19 | cxTrapLapdBriX25Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25 of a EBLAPD port reaches the 00-INACTIVE state
20 | cxTrapLapdBriX25Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a EBLAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
21 | cxTrapLapdBriX25Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a EBLAPD port reaches the 07-CONNECTED or 08-CONNECTED state

Detail of the SNMP variables shown in the EBLAPD port traps

cxPortIndex | EBLAPD port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port index which the SNMP trap refers to.

cxPortType | Type and description of the EBLAPD port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case EBLAPD) and the description eventually associated to it.

cxLapdDiagSapiIndex | Sapi identifier which the trap refers to
 | 0 (Q931) or 16 (X.25)

This parameter shows the Sapi identifier which the traps refers to.

cxLapdDiagSapiState | Sapi Q931 or Sapi X.25 current state which the trap refers to
 | inactive_00(0), idle_01(1), disconnected_04(4), connecting_05(5), disconnecting_06(6), connected_07(7), connected_08(8)

This variable shows the current state of the Sapi Q931or Sapi X.25 which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the Sapi Q931/X.25
inactive_00(0) | 00-INACTIVE
idle_01(1) | 01-IDLE
disconnected_04(4) | 04-DISCONNECTED
connecting_05(5) | 05-CONNECTING
disconnecting_06(6) | 06-DISCONNECTING
connected_07(7) | 07-CONNECTED
connected_08(8) | 08-CONNECTED

cxLapdDiagSapiTei | Identifier of the TEI currently assigned to the Sapi which the trap refers to
 | 1 - 126

It shows the identifier of the TEI currently assigned to the Sapi which the trap refers to.

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

SNMP Traps generated for the EPLAPD ports top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
16 | cxTrapLapdPriQ931Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a EPLAPD port reaches the 00-INACTIVE state
17 | cxTrapLapdPriQ931Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a EPLAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
18 | cxTrapLapdPriQ931Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi Q931 of a EPLAPD port reaches the 07-CONNECTED or 08-CONNECTED state
19 | cxTrapLapdPriX25Inactive | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25 of a EPLAPD port reaches the 00-INACTIVE state
20 | cxTrapLapdPriX25Down | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a EPLAPD port reaches one of the "down" states: 01-IDLE, 04-DISCONNECTED, 05-CONNECTING, 06-DISCONNECTING
21 | cxTrapLapdPriX25Up | cxPortIndex, cxPortType, cxLapdDiagSapiIndex, cxLapdDiagSapiState, cxLapdDiagSapiTei, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Sapi X.25of a EPLAPD port reaches the 07-CONNECTED or 08-CONNECTED state

Detail of the SNMP variables shown in the EPLAPD port traps

cxPortIndex | EPLAPD port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the EPLAPD port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case EPLAPD) and the description eventually associated to it.

cxLapdDiagSapiIndex | Identifier of the Sapi which the trap refers to
 | 0 (Q931) or 16 (X.25)

This parameter shows the Sapi identifier which the traps refers to.

cxLapdDiagSapiState | Current state of the Sapi Q931 or Sapi X.25 which the trap refers to
 | inactive_00(0), idle_01(1), disconnected_04(4), connecting_05(5), disconnecting_06(6), connected_07(7), connected_08(8)

This variable shows the current state of the Sapi Q931or Sapi X.25 of the EPLAPD port which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the Sapi Q931/X.25
inactive_00(0) | 00-INACTIVE
idle_01(1) | 01-IDLE
disconnected_04(4) | 04-DISCONNECTED
connecting_05(5) | 05-CONNECTING
disconnecting_06(6) | 06-DISCONNECTING
connected_07(7) | 07-CONNECTED
connected_08(8) | 08-CONNECTED

cxLapdDiagSapiTei | Identifier of the TEI currently assigned to the Sapi which the trap refers
 | 1 - 126

It shows the identifier of the TEI currently assigned to the Sapi which the trap refers to.

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually reported in the format days:hours:minutes:seconds


The level 3 ISDN ports (Q931 - ExQ931)

The level 3 ISDN ports (Q931 - EBQ931 - EPQ931)

Configuration of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931)
Statistics of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931)

Configuration of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931) top

Configuration of the Q931 ports

The Q931Basic Rate port is labelled, within the Abilis CPX, by the acronym "Q931" and it is provided with the parameters described in this chapter.

The following example shows how to display parameters of two Q931 ports: the first one for multi-point line, the second one for a point to point line. Shown values are the default ones.

[11:00:07] ABILIS_CPX: D P PO:Q931

PO:217 ------------------------------------------------------------------------
Q931   lowpo:NONE  TYPE:USER     LINE:MP  DIALT:5   T301:180
       NUM:*                     ORCD:0

PO:218 ------------------------------------------------------------------------
Q931   lowpo:NONE  TYPE:USER     LINE:PP  DIALT:5   scrst:YES  T301:180
       NUM:*                     ORCD:0

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on "high case" parameters it is enough to execute the initialisation command INIT PO:.

Configuration of the EBQ931 ports

The Q931 Basic Rate ports for the EBIB board are labelled, within the Abilis CPX, by the acronym "EBQ931" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of two Q931 ports: the first one is a "NT" (multi point line) port type, the second a "TE" (point to point line). Shown values are the default ones.

[11:08:33] ABILIS_CPX: D P PO:EBQ931

PO:280 ------------------------------------------------------------------------
EBQ931 lowpo:180   TYPE:USER     side:NT  line:MP  |-- From TDM switch table --
       DIALT:5                   T301:180          |B1:BIDIR
       NUM:*                                       |B2:BIDIR

PO:281 ------------------------------------------------------------------------
EBQ931 lowpo:NONE  TYPE:USER     side:TE  LINE:PP   DIALT:5   scrst:YES
       T301:180    NUM:*                            ORCD:0

The example shows that for the EBQ931 "NT" type ports, it is displayed a summary of information stored in the TDM switch table related to B1 and B2 channels of the port.

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:.

Configuration of the EPQ931 ports

The Q931 Basic Rate ports for the EPIB board are labelled, within the Abilis CPX, by the acronym "EPQ931" and they are provided with the parameters described in this chapter.

The following example shows how to display parameters of two EPQ931 ports: the first one is a "NT" (multi point line) port type, the second a "TE" (point to point line). Shown values are the default ones.

[12:11:25] ABILIS_CPX: D P PO:EPQ931

PO:296 ------------------------------------------------------------------------
EPQ931 lowpo:196   TYPE:USER    |----------- From TDM switch table ------------
       side:NT     DIALT:5      |IN: #
       scrst:YES   T301:180     |BID:1-31
       NUM:*                    |OUT:#

PO:297 ------------------------------------------------------------------------
EPQ931 lowpo:NONE  TYPE:USER     side:TE  DIALT:5   scrst:YES  T301:180
       NUM:*                     ORCD:0

The example shows that for the EPQ931 "NT" type ports, it is displayed a summary of information stored in the TDM switch table related to B1 and B2 channels of the port.

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:.

Detail of the level 3 ISDN ports parameters (Q931 - EBQ931 - EPQ931)

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the lower level port; it can only be an LAPD/EBLAPD/EPLAPD port type.

The value "NONE" isolates the Q931/EBQ931/EPQ931 port from the lower level ports.

TYPE: | Port type
USER | USER, NETWORK

This parameter sets how the port behaves when a connection is going to be open.

The port connected to the network is defined NETWORK port; the one connected to the user equipment USER port.

LINE: | Line type (Only in Q931 and EBQ931 ports)
MP | MP, PP

It sets the line type: "MP" stands for multi-point, while "PP" point to point.

This parameter is related with the same eventual parameter of the lower level LAPD/EBLAPD port. If those values have been set differently, the Validation procedure will force the parameter LINE: of the LAPD/EBLAPD port to have the same value as parameter "LINE:" of the Q931 referred port.

SIDE: | Port type (Only in EBQ931 and EPQ931 ports)
TE | TE, NT

It sets the port type so also the driver behaviour.

This parameter is related with the same parameter of the eventual lower level EBLAPD/EPLAPD port. If those values have been set differently, the Validation procedure will force the parameter SIDE: of the EBLAPD/EPLAPD port to have the same value as parameter "SIDE:" of the EPQ931 referred port.

DIALT: | Dialling timeout
5 | 1 - 15

Timeout to wait for the automatic number completion. This timeout is required because the Abilis CPX does not know when the number is complete.

This parameter affects both incoming and outgoing call in absence of SENDING COMPLETE infromation element.

SCRST: | Activation of the RESTART signal, if a given event occurs (Only if LINE:PP)
YES | NO, YES, EXT

It activates the RESTART functionality only if particular conditions occur.

Value | Meaning
NO | The functionality is disabled: the RESTART signal is never sent
YES | The RESTART signal is sent only at Abilis CPX start-up
EXT | The RESTART signal is sent at Abilis CPX start-up and every time the lower level (2) opens a connection after disconnecting.

This parameter is shown and configurable only if the line type is PP (point to point).

T301: | Time interval between the ALERT signal and connection establishment
180 | 60 - 180 (in seconds)

It sets the time interval to be waited between the ALERT signal and connection establishment.

NUM: | ISDN number of the port
* | from 1 up to 20 numerical digits, *

It sets the ISDN number of the port; it will be used to forward the outgoing calls.

The character "*" stands for "any number", that is upper level port driver, i.e. MLM, can make calls with any calling address.

ORCD: | Maximum number of digits used for the incoming calls with "open numbering"
0 | 0- 20

It sets the maximum number of digits used for the incoming calls with "open numbering", for example:

  • User number: 376399xxx, the ORCD has to be set to 9

  • User number: 261xxxx (formally 02 61xxxx), the ORCD has to be set to 7

  • etc..

warning! Calls income from the net without "zero", so that the user called by "02 610001" will receive an incoming call from "2610001".

Statistics of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931) top

Statistics of the Q931 ports

How to check the state and statistics of the Q931 ports through the command D S.

[11:04:56] ABILIS_CPX: D S PO:217

PO:217 ------------------------------------------------------------------------
Q931   CH: STATE:               CG: [SCG:]              CD: [SCD:]
       ------------------------------------------------------------------------
        2  0A-CONNECTED-FROM    376397925               0587640526
                                CPISDN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |25         |2          |SUCC-CALL  |33         |44         |
       TIME-CALL  |4546       |2745       |
       ------------------------------------------------------------------------

Extended statistics are available for Q931 ports too. Here is an example on how to check them using the command D SE:

[11:04:56] ABILIS_CPX: D SE PO:217

PO:217 ------------------------------------------------------------------------
Q931   --- Cleared 000:00:02:19 ago, on 15/05/2000 at 17:18:00 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EBQ931 ports

How to check the state and statistics of the EBQ931 ports through the command D S.

[12:09:15] ABILIS_CPX: D S PO:280 .

PO:280 ------------------------------------------------------------------------
EBQ931 CH: STATE:               CG: [SCG:]              CD: [SCD:]
       ------------------------------------------------------------------------
                    *** B1 and B2 channels are disconnected ***
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |7          |13         |SUCC-CALL  |19         |44         |
       TIME-CALL  |2717       |5004       |
       ------------------------------------------------------------------------

Extended statistics are available for EBQ931 ports too. Here is an example on how to check them using the command D SE:

[12:09:15] ABILIS_CPX: D SE PO:280 .

PO:280 ------------------------------------------------------------------------
EBQ931 --- Cleared 003:05:50:20 ago, on 12/05/2000 at 12:13:25 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |7          |13         |SUCC-CALL  |19         |44         |
       TIME-CALL  |2717       |5004       |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Statistics of the EPQ931 ports

How to check the state and statistics of the EPQ931 ports through the command D S.

[12:26:04] ABILIS_CPX: D S PO:296 .

PO:296 ------------------------------------------------------------------------
EPQ931 CH: STATE:               CG: [SCG:]              CD: [SCD:]
       ------------------------------------------------------------------------
                      ***  All channels disconnected ***
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |1          |
       TIME-CALL  |0          |0          |
       ------------------------------------------------------------------------

Extended statistics are available for EPQ931 ports too. Here is an example on how to check them using the command D SE:

[12:26:04] ABILIS_CPX: D SE PO:296

PO:285 --- Cleared 004:23:09:43 ago, at 21/05/1999 11:36:41 -------------------
EPQ931 -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931)

CH: | B channel identifier
 | 1, 2

Identifier of the Q931 channel, whose state is not the 00-DISCONNECTED. If all the channels are in the state 00-DISCONNECTED, the following message will be shown: "***B1 and B2 channels are disconnected ***".

STATE: | Current state of the B channel
 | DISCONNECTING, DISCONNECTED, REM-ALERT, LOC-ALERT, DIALLING, DIALLED, CALLING, CALLED, CALL-ABORT, CONNECTED, RESTARTING, RESTARTED, ERR

It shows the current state of the B channels:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
Q931 EBQ931 EPQ931 (B Channels) | DISCONNECTED | Connection on the B channel is closed |  |  | D
 | DISCONNECTING | The driver is closing the connection |  |  | d
 | CALL-ABORT | The call is aborted and driver is closing the connection |  |
 | REM-ALERT | Connection has been accepted; the counterpart is in its ALERTING state |  |  | a
 | LOC-ALERT | The connection has been accepted from the counterpart, the driver is in the ALERTING state |  |
 | DIALLING | The driver has requested to open a connection on the B channel |  |  | c
 | CALLING | The driver has requested to open a connection on the B channel |  |
 | DIALLED | The driver has received a connection request on the B channel |  |  | o
 | CALLED | The driver has received a connection request on the B channel |  |
 | CONNECTED-TO | The connection is active because of an outgoing call |  |  | C
 | CONNECTED-FROM | The connection is active because of an incoming call |  |
 | RESTARTING | The driver has requested the B channel to be initialised |  |  | r
 | RESTARTED | The driver has received a initialization request of the B channel |  |
 | ERR | Software error. Contact the Abilis assistance. |  |  | #

CG: | Calling address
 | from 0 up to 20 digits 0..9

It shows the calling number.

SCG: | Calling sub-address
 | from 0 up to 6 digits 0..9

It shows the calling sub-address.

CD: | Called address
 | from 0 up to 20 digits 0..9

It shows the called number.

SCD: | Called sub-address
 | from 0 up to 6 digits 0..9

It shows the called sub-address.

FAIL-CALL: | Number of incoming/outgoing calls failed over all the channels
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) shows the number of failed incoming calls over all channels, while the FAIL-CALL (OUTPUT) shows the failed outgoing ones.

SUCC-CALL: | Number of incoming/outgoing calls successful over all the channels
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) shows the number of successful incoming calls over all channels, while the SUCC-CALL (OUTPUT) shows the successful outgoing ones.

TIME-CALL: | Duration of the incoming/outgoing calls over al the channels
 | 0 - 4.294.967.295

The counter TIME-CALL (INPUT) shows the overall duration of the connection due to incoming calls on all the channels, while the TIME-CALL (OUTPUT) shows the overall duration of the connection due to outgoing calls.

Detail of the extended statistics of the level 3 ISDN ports (Q931 - EBQ931 - EPQ931)

FAIL-CALL: These statistics are the same shown in basic command and already explained
SUCC-CALL:
TIME-CALL:


The simulation ports of level 3 ISDN (sQ931)

Configuration of the sQ931 ports
Statistics of the Sq931 ports

Configuration of the sQ931 ports top

The Q931 Primary Rate port, for the EPIB board, is labelled, within the Abilis CPX, by the acronym "EPQ931" and it is provided with the parameters described in this chapter.

The following example shows how to display parameters of sQ931 ports.

[14:24:47] ABILIS_CPX: D P PO:SQ931

PO:380 ------------------------------------------------------------------------
sQ931  LOG:DS      lowpo:96    TYPE:USER     NRTY1:15   DELAY1:30   DELAY2:5

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on "high case" parameters it is enough to execute the initialisation command INIT PO:.

Detail of the sQ931 port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the lower level port; it can only be an EPISDN or EBISDN port type.

The value "NONE" isolates the sQ931 port from the lower level ports.

TYPE: | Port type
USER | USER, NETWORK

This parameter sets how the port behaves during the connection establishment.

The port connected to the network is defined NETWORK port; the one connected to the user equipment USER port.

NRTY1: | Number of retries (attempts) during phase n.1
15 | 1 - 255

It sets the number of retries during phase n.1.

DELAY1: | Delay between two consecutive retries in phase n.1
30 | 15 - 255 (in seconds)

It sets the delay between two consecutive retries in phase n.1

DELAY2: | Delay between two consecutive retries in phase n.2
5 | 1 - 255 (in minutes)

It sets the delay between two consecutive retries in phase n.2

Statistics of the sQ931 ports top

How to check the state and statistics of the sQ931 ports through the command D S.

[12:26:04] ABILIS_CPX: D S PO:380 .

PO:380 ------------------------------------------------------------------------
sQ931  CH: STATE:               CG: [SCG:]              CD: [SCD:]
       ------------------------------------------------------------------------
                           ***  All channels disconnected ***
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |
       ------------------------------------------------------------------------

Extended statistics are also available for Q931 ports. Here is an example on how to check them using the command D SE:

[14:37:07] ABILIS_CPX: D SE PO:380

PO:380 ------------------------------------------------------------------------
sQ931  --- Cleared 000:01:50:38 ago, on 23/06/2000 at 12:47:34 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state field and statistics of the sQ931 ports

CH: | Identifier of the B channel
 | 1 - 31

Identifier of the sQ931 channel, whose state is not the 00-DISCONNECTED. If the channel state would not be 00-DISCONNECTED, the following message will be displayed "*** All channels disconnected ***".

STATE: | Current state of the sQ931 channel
 | 01-CALLING, 02-DIALLING, 03-CALLING, 04-REM-ALERT, 06-CALLED, 07-LOC-ALERT, 08-CALLED, 09-CALLED, 0A-CONNECTED, 0B-DISCONNECTING, 0C-DISCONNECTING, 13-DISCONNECTING, 16-CALL-ABORT, 19-DIALLED, 3D-RESTARTING, 3E-RESTARTED, 63-CALLED

The sQ931 port driver can be in one of the following states:

  • 01-CALLING:
    The driver has requested to open a connection on the B channel.

  • 02-DIALLING:
    The driver has requested to open a connection on the B channel.

  • 03-CALLING:
    The driver has requested to open a connection on the B channel.

  • 04-REM-ALERT:
    Connection has been accepted: the counter-part is in the ALERTING state.

  • 06-CALLED:
    The driver has received a request of connection on the B channel.

  • 07-LOC-ALERT:

  • 08-CALLED:
    The driver has received a request of connection on the B channel.

  • 09-CALLED:
    The driver has received a request of connection on the B channel.

  • 0A-CONNECTED TO:
    Connection on the B channel is active owing to an outgoing call.

  • 0A-CONNECTED FROM: Connection on the B channel is active owing to an incoming call.

  • 0B-DISCONNECTING:
    The driver is closing the connection.

  • 0C-DISCONNECTING:
    The driver is closing the connection.

  • 13-DISCONNECTING:
    The driver is closing the connection.

  • 16-CALL-ABORT:

  • 19-DIALLED:

  • 3D-RESTARTING:
    The driver has requested the initialisation of the B channel.

  • 3E-RESTARTED:
    The driver has received a request to initialise the B channel.

  • 63-CALLED:
    The driver has received a request of connection on the B channel.

CG: | Calling address
 | from 0 up to 16, digits: 0..9

It shows the calling address.

SCG: | Calling sub-address
 | from 0 up to 8, digits: 0..9

It shows the calling sub-address.

CD: | Called address
 | from 0 up to 16, digits: 0..9

It shows the called address.

SCD: | Called sub-address
 | from 0 up to 8 digits: 0..9

It shows the called sub-address.

FAIL-CALL: | Number of incoming/outgoing calls failed on all the channels
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) shows the number of failed incoming calls on all the channels, while the FAIL-CALL (OUTPUT) the number of the failed outgoing calls.

SUCC-CALL: | Number of incoming/outgoing calls successful on all the channels
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) shows the number of successful incoming calls on all the channels, while the SUCC-CALL (OUTPUT) the number of the successful outgoing calls.

TIME-CALL: | Duration of connections due to incoming/outgoing calls on all the channels
 | 0 - 4.294.967.295

The counter TIME-CALL (INPUT) shows the overall duration of connections due to the incoming calls on all the channels, while the TIME-CALL (OUTPUT) the duration of the ones generated by the outgoing calls.

Detail of the extended statistics of the sQ931 ports

FAIL-CALL: These statistics are the same shown in basic command and already explained
SUCC-CALL:
TIME-CALL:


The Accounting Agent Port (ACNT)

Configuration of the Accounting Agent Port (ACNT)
Statistics of the Accounting Agent Port (ACNT)

The Accounting Agent port of the Abilis CPX is responsible of transmitting, through a TCP/IP network, accounting information to a remote host where a software application, named "Accounting Collector" provides data collecting, reports generating and presenting to the end user.

Accounting Agent Port (ACNT)

Relevant accounting information usually include:

  • call duration
  • date and time of call end
  • input port
  • output port
  • call direction (input or output)
  • type of call (compressed voice, data, cluster, transparent)
  • called number
  • calling number

The Accounting Agent Port (ACNT) offers two types of services:

SIMPLE accounting
In SIMPLE accounting, events are sent from Abilis CPX to the Collector at the same time they occur, the Collector will print the event on a window and saves it into the selected file. If the TCP session is not opened the event is lost. There could be a buffer to temporary store events.
SIMPLE accounting can supply events to more Collectors simultaneously.
TRANSACTION accounting
In TRANSACTION accounting events are stored in an internal database that can be either in RAM or on the HD. When the transaction has to take place, events are transferred to the Collector that, after writing them on disk, sends acknowledge for deletion in Abilis CPX. The transaction procedure ensure that no events are lost (except when the Abilis CPX database becomes full), and no events are duplicated.
TRANSACTION account can deal with a unique Collector ONLY, the counterpart identity must be checked based on IP address (first level check), and with an addition message exchange. This is mandatory not only for security, but mainly for database consistency.

Configuration of the Accounting Agent Port (ACNT) top

The port, which carries out the Accounting functionalities within the Abilis CPX, is named "ACNT" and it has the parameters described in this section.

The following example shows how to display the ACNT port parameters. Shown values are the default ones.

[11:16:42] ABILIS_CPX: D P PO:ACNT

PO:908 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
ACNT   ------------------------------------------------------------------------
       lowpo:901   TYPE:USER    locport:2060     tcpses:3
       COLL-IP:#                                 COLL-CRYPT:AUTO  COLL-KEY:DFT
       EXTRA-IP-LIST:*                          EXTRA-CRYPT:AUTO EXTRA-KEY:DFT
       FILTER:ALL

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on TYPE: parameter is immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the ACNT port parameters

lowpo: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX port of the lower level. It can be only a TCP port type.

The value "NONE" isolates the ACNT port.

TYPE: | Port type
USER | USER

This parameter is used for setting how the port has to behave if data compression is active.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The ACNT port can be only USER.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

locport: | Identifier of the TCP local port
2060 | 0 - 65535

It sets the TCP local port used by the accounting driver. The IP port number assigned by default for the ACNT service is 2060.

tcpses: | Number of TCP sessions

It sets the number of TCP sessions reserved to the ACNT port.

COLL-IP: | Main Collector IP address
# | see table, #

This parameter sets the IP address of the remote station collecting the Accounting data.

The allowed values are showed in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not actually supported.

The character '#' stands for "no IP address" and can be used to prevent the Accounting information exchanged with any data Collector.

COLL-CRYPT: | Cryptography activation modality
AUTO | AUTO, YES

This parameter set the activation modality for the cryptography procedure of Accounting information exchanged between the ACNT port, in the Abilis CPX, and the application for Accounting data collection.

If the parameter is set to "AUTO": the cryptography usage is negotiated between the Agent and the data Collector.
If the parameter is set to "YES": the cryptography usage is mandatory.

COLL-KEY: | Index of the cryptographic key used
DFT | DFT, 1 - 63

It selects the key to be used for data cryptography. User can choose if using the default key ("COLL-KEY:DFT") or one already defined in the Table of Cryptography Keys. In this case, the user has to specify a numeric value [1-63] corresponding to the key index in the table.

If the numeric value specified is meaningless, that is no key corresponds to it, the parameter content will be displayed into square brackets; for example "COLL-KEY:[5]", means that in the cryptographic keys table, there is no key whose index is "5".

EXTRA-IP-LIST: | List of IP addresses of additional stations for Accounting data collection
* | NONE, 'listname', *

It defines a list of additional stations for Accounting data collection.

The value "NONE", stands for "no list" and means that no list is defined for additional stations.

The value "*" stands for "any additional station with any IP address".

The name of the list of the IP addresses of the allowed additional stations must be string of up to 20 characters in the range [0..9, a..z, A..Z, _], written between peakes. It must correspond to the name of a list of IP addresses or the name of a list of IP addresses ranges or the name of a Rule list or the name of a Master Rule list. The referenced list must already be defined in the Elements Lists service.

EXTRA-CRYPT: | Cryptography activation modality
AUTO | AUTO, YES

This parameter set the activation modality for the cryptography procedure of Accounting information exchanged between the ACNT port, in the Abilis CPX, and the additional applications for Accounting data collection included in the list defined by EXTRA-IP-LIST: parameter.

If the parameter is set to "AUTO": the cryptography usage is negotiated between the Agent and the data Collector.
If the parameter is set to "YES": the cryptography usage is mandatory.

EXTRA-KEY: | Index of the cryptographic key used
DFT | DFT, 1 - 63

It selects the key to be used for cryptography of information exchanged between the ACNT port, in the Abilis CPX, and the additional applications for Accounting data collection. User can choose if using the default key ("EXTRA-KEY:DFT") or one already defined in the Table of Cryptography Keys. In this case, the user has to specify a numeric value [1-63] correspondent to the key index in the table.

If the numeric value specified is meaningless, that is no key corresponds to it, the parameter content will be displayed into square brackets; for example "EXTRA-KEY:[5]", means that in the cryptographic keys table, there is no key whose index is "5".

FILTER: | Call records filtering at origin
ALL | ALL, CONNECTED, FAILED

This parameter defines a filter to be applied on the Accounting information to be collected.

Filter value | Description
ALL | any acconting event is collected
CONNECTED | only information related to successful connections are collected
FAILED | only information related to failed connections are collected

Statistics of the Accounting Agent Port (ACNT) top

The following example shows how to display state and statistics of the ACNT port through the command D S:

[11:16:42] ABILIS_CPX: D S PO:ACNT

PO:908 ------------------------------------------------------------------------
ACNT   STATE:READY
       Ch State     Mode     Crypt LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  LISTEN                   000.000.000.000-2060
       2  LISTEN                   000.000.000.000-2060
       3  LISTEN                   000.000.000.000-2060
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       CHAR       |          0|          0|MSG        |           |          0|
       ------------------------------------------------------------------------

The following example shows how to display extended statistics of the ACNT port through the command D SE:

[18:02:36] ABILIS_CPX: D SE PO:ACNT

PO:908 ------------------------------------------------------------------------
ACNT   --- Cleared 000:05:43:08 ago, on 30/03/2004 at 12:24:31 ----------------
       Ch State     Mode     Crypt LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  LISTEN                   000.000.000.000-2060
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       CHAR       |          0|          0|MSG        |           |          0|
       ------------------------------------------------------------------------
       2  LISTEN                   000.000.000.000-2060
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       CHAR       |          0|          0|MSG        |           |          0|
       ------------------------------------------------------------------------
       3  LISTEN                   000.000.000.000-2060
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       CHAR       |          0|          0|MSG        |           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of state fields and statistics of the ACNT port

STATE: | Current state of the ACNT port driver
 | INACTIVE, READY, DOWN, ERR

The parameter shows the Current state of the ACNT port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Debug Log | LCD Display
ACNT | INACTIVE | ... |  |  | in
 | READY | ... |  |  | RD
 | DOWN | ... |  |  | dn
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

FAIL-CALL: | Total number of failed calls over all sessions
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) is incremented every time a connection request is received, but the attempt fails.

The counter FAIL-CALL (OUTPUT) is incremented every time a connection request is sent, but the attempt fails.

SUCC-CALL: | Total number of successful calls over all sessions
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) is incremented every time a connection request is received and the connection is established.

The counter SUCC-CALL (OUTPUT) is incremented every time a connection request is sent and the connection is established.

CHAR: | Total number of sent/received characters during all sessions
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a character is received. The counter CHAR (OUTPUT) is incremented every time a character is sent.

MSG: | Total number of sent/received messages during all sessions
 | 0 - 4.294.967.295

The counter MSG (INPUT) is incremented every time a message is received. The counter MSG (OUTPUT) is incremented every time a message is sent.

Detail of state fields and statistics of the ACNT connection

CH: | Channel identifier
 | 0 - tcpses:

The parameter shows the number of the channel (or connection) on the ACNT port. The maximum number of available channels on the ACNT port is given by the value of the parameter tcpses:, when the system is activated.

State: | Connection state
 | see below

It shows the current state of the connection:

States | Description
CLOSED | Connection is closed.
LISTEN | Session is active and waiting to receive the connection request.
CALLED | Connection is getting opened, the session received the connection requested, but it didn't send the acknowledgement.
CALLING | Connection is getting opened, the session sent the connection request and it is waiting for the acknowledgement.
CONN-TO | Connection is active, the session received the connection request and sent the acknowledgement.
CONN-FROM | Connection is active, the session sent the connection request and received the acknowledgement.
CLEARING | Connection is getting cleared, the session sent a clear request and it is waiting for the acknowledgement.
CLEARED | Connection is getting cleared, the session received a clear request and it didn't send the acknowledgement.
DOWN | Connection is down.
ERR | Software error. Contact Abilis assistance.

Mode: | Current mode of data exchange
 | UNKNOWN, SIMPLE, TRANSACT

It shows the current mode for exchanging accounting data on the connection. The allowed values are:

Data exchange mode | Meaning
UNKNOWN | Unknown mode
SIMPLE | Simplified mode
TRANSACT | Transactional mode

Crypt: | Eventual use of data cryptography
 | NO, YES

It shows whether data exchanged on the current connection are encrypted.

The value "NO" stands for data are not encrypted, the "YES" one, means the opposite.

LocAdd: | Local IP address used by the connection
 | 0 - 255.255.255.255

It shows the IP local Address used by the connection, only its state is neither LISTEN or DOWN.

LocPort: | Number of the local IP port used by the connection
 | 0 - 65.535

It shows the number of the local IP port used by the connection, only its state is neither LISTEN or DOWN.

RemAdd: | Remote IP address used by the connection
 | 0 - 255.255.255.255

It shows the remote IP address used by the connection, only its state is neither LISTEN or DOWN.

RemPort: | Number of the remote IP port used by the connection
 | 0 - 65.535

It shows the IP remote port used by the connection, only its state is neither LISTEN or DOWN.

FAIL-CALL: | Number of failed calls on the connection
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) is incremented every time a connection request is received, but the attempt fails.

The counter FAIL-CALL (OUTPUT) is incremented every time a connection request is sent, but the attempt fails.

SUCC-CALL: | Number of successful calls on the connection
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) is incremented every time a connection request is received and the connection is established.

The counter SUCC-CALL (OUTPUT) is incremented every time a connection request is sent and the connection is established.

CHAR: | Number of sent/received characters on the connection
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a character is received. The counter CHAR (OUTPUT) is incremented every time a character is sent.

MSG: | Number of sent/received messages on the connection
 | 0 - 4.294.967.295

The counter MSG (INPUT) is incremented every time a message is received. The counter MSG (OUTPUT) is incremented every time a message is sent.


Fxs/Fxo VOICE connections

Configuration of Fxs/Fxo VOICE connections
Configuration of Fxs/Fxo VOICE groups
Configuration of Data ports for Fxs/Fxo VOICE connections

Configuration of Fxs/Fxo VOICE connections top

The table of Fxs/Fxo VOICE routings can hold up to 64 definitions, indexed starting from 0 up to 63.

The table of Fxs/Fxo VOICE routings is not automatically maintained with consecutive indices and can contain "empty" places. Vacancies are assigned when a new entry is going to be created.

The table of Fxs/Fxo VOICE routings can be modified while the Abilis CPX is working without needing to restart it. Changes made in the table are immediately active by executing the command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

Commands for handling Fxs/Fxo VOICE routings are described in the Fxs/Fxo VOICE routings section of the chapter Commands relating to the Analogue VOICE Router.

The available commands are the following:

A VR
C VR
D VR
S VR

In the following example are displayed all the entries of the table of Fxs/Fxo VOICE routings. Displayed values are only samples.

[18:14:08] ABILIS_CPX: D VR

ID:  NUM:  NUMO:  GROUP:   POO:
---------------------------------
0    1     *           #    501
1    2     *           #    501
2    160   *           #     60
3    162   *           #     62
4    163   *           #     63
5    161   *           #     61
6    0000  *           #   NONE

info Abilis CPX makes possible also to set Fxs/Fxo VOICE connections by using Data connections in the intermediate routings.

Detail of the Fxs/Fxo VOICE connection parameters

ID: | Fxs/Fxo VOICE routing identifier
no value | from 0 up to 63

It represent the index of the Fxs/Fxo VOICE routing identifier and it sets the verifying sequence of entries for each incoming call. The verifying procedure starts from the routing identified by 0 and proceeds until it finds the proper routing for that call or it reaches the end of the table.

The table of Fxs/Fxo VOICE routings can store up to 64 entries, therefore the routing identifier value must be in the interval [0 - 63]. The table is NOT automatically maintained with consecutive indexes, then Fxs/Fxo VOICE routing definitions may not have sequential identifiers.

The index is also used by the adding, modifying, deleting commands to refer to a given entry.

NUM: | Called telephone number
0000 | from 1 up to 4 digits, #

Called telephone number to be routed.

The string "#" stands for "no telephone number" and it can be used to deactivate the routing without deleting it.

NUMO: | Outgoing telephone number
* | from 1 up to 4 digits, *

It allows to set a telephone number to be placed in the outgoing call, instead of the one present in the incoming call (NUM: parameter).

The string "*" stands for "the same telephone number" and it is used when the number present in the incoming call (NUM: parameter) does not have to be changed.

GROUP: | Destination group of the connection
# | 1 - 15, #, NONE

It sets the index of the Fxs/Fxo VOICE destination group of the connection.

The values "NONE" and "#" stand for "no group". They are used either when it is defined only one destination port for the Fxs/Fxo VOICE connection or to deactivate the routing without deleting it.

warning! By setting the parameter GROUP: to a value belonging to the interval [1-15], the parameter POO:, related to the destination port of the Fxs/Fxo VOICE connection, becomes meaningless and it is automatically set to "NONE".

POO: | Destination port of the VOICE connection
none | 1 - 999, #, none

It sets the destination port of the Fxs/Fxo VOICE connection.

The values "NONE" and "#" stand for "no port". They are used either when in the parameter GROUP: it is defined a destination Fxs/Fxo VOICE group for the connection or to deactivate the routing without deleting it.

warning! By setting the parameter GROUP: to a value belonging to the interval [1-15], the parameter POO:, related to the destination port of the Fxs/Fxo VOICE connection, becomes meaningless and it is automatically set to "NONE".

Configuration of Fxs/Fxo VOICE groups top

The table of Fxs/Fxo VOICE groups can hold up to 15 definitions, indexed starting from 1 up to 15.

The table of Fxs/Fxo VOICE groups is not automatically maintained with consecutive indices and can contain "empty" places. Vacancies are assigned when a new entry is going to be created.

The table of Fxs/Fxo VOICE groups can be modified while the Abilis CPX is working without needing to restart it. Changes made in the table are immediately active by executing the command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

Commands for handling the Fxs/Fxo VOICE groups are described in the Fxs/Fxo VOICE groups section of the chapter Commands relating to the Analogue VOICE Router. The available commands are the following:

A VG
C VG
D VG
S VG

In the following example are displayed all the entries defined in the table of Fxs/Fxo VOICE groups. Shown values are only samples.

[18:14:08] ABILIS_CPX: D VG

ID          |1   2   3   4   5  |6  7  8  9  10 |11 12 13 14 15 |16 17 18 19 20
------------|-------------------|---------------|---------------|--------------
1  VS:R VPx:|60  61  62  63  .  |.  .  .  .  .  |.  .  .  .  .  |.  .  .  .  .
   DS:R DPx:|1   2   .   .      |               |               |
------------|-------------------|---------------|---------------|--------------
3  VS:R VPx:|.   .   .   .   .  |.  .  .  .  .  |.  .  .  .  .  |.  .  .  .  .
   DS:R DPx:|.   .   .   .      |               |               |
------------|-------------------|---------------|---------------|--------------

Detail of the Fxs/Fxo VOICE group parameters

ID: | Fxs/Fxo VOICE group identifier
no value | from 1 up to 15

It represent the index of the Fxs/Fxo VOICE group identifier. It is used in the parameter GROUP: of Fxs/Fxo VOICE routings.

The index is also used by the adding, modifying, deleting commands to refer to a given Fxs/Fxo VOICE group.

The table of Fxs/Fxo VOICE groups can store up to 15 entries, therefore the identifier value must be in the interval [1 - 15]. The table is NOT automatically maintained with consecutive indexes, then Fxs/Fxo VOICE group definitions may not have sequential identifiers.

VP1: - VP20: | Destination VOICE ports of the Fxs/Fxo VOICE connection
NONE | 0 - 999, NONE ( (represented with '.' (dot) character )

They set the destination VOICE ports of the Fxs/Fxo VOICE connection. The port value must be in the range [0 - 999] and must correspond to a VOICE port currently configured and active.

Value "NONE" and the string "#" stand for "no port". They are represented with '.' (dot) character and they can be used to deactivate a destination port.

VS: | Scanning procedure of the VOICE ports
R | R, P

It allows to select the algorithm with which the Analogue VOICE Router will scan the list of VOICE ports configured in the group.

The value "R" stands for "Round-Robin algorithm" and it means that all ports are scanned in a circular way: i.e. all of them are equally used.

The value "P" stands for "Priority algorithm" and it means that all the ports are scanned starting from the first one to the last one.

DP1: - DP4: | Destination data ports of the Fxs/Fxo VOICE connection
NONE | 0 - 999, NONE ( (represented with '.' (dot) character )

They set the destination data ports of the Fxs/Fxo VOICE connection. The port value must be in the range [0 - 999] and must correspond to a MLM port currently configured and active.

Value "NONE" and the string "#" stand for "no port". They are represented with '.' (dot) character and they can be used to deactivate a destination port.

DS: | Scanning procedure of the data ports
R | R, P

It allows to select the algorithm with which the Analogue VOICE Router will scan the list of data ports (i.e. ports of MLM type) configured in the group.

The value "R" stands for "Round-Robin algorithm" and it means that all ports are scanned in a circular way: i.e. all of them are equally used.

The value "P" stands for "Priority algorithm" and it means that all the ports are scanned starting from the first one to the last one.

Configuration of Data ports for Fxs/Fxo VOICE connections top

The table of Data ports for Fxs/Fxo VOICE connections can hold up to 32 entries, indexed starting form 0 up to 31.

The table of Data ports for Fxs/Fxo VOICE connections is not automatically maintained with consecutive indices and can contain "empty" places. Vacancies are assigned when a new entry is going to be created.

The table of Data ports for Fxs/Fxo VOICE connections can be modified while the Abilis CPX is working without needing to restart it. Changes made in the table are immediately active by executing the command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

Commands for handling Data ports for Fxs/Fxo VOICE connections are described in the Data ports for Fxs/Fxo VOICE connections section of the chapter Commands relating to the Analogue VOICE Router. The available commands are the following:

A VD
C VD
D VD
S VD

In the following example are displayed some Data ports for Fxs/Fxo VOICE connections entries. Shown values are only samples.

[18:14:08] ABILIS_CPX: D VD

ID:   PO:   MXBW:    CURBW:
-----------------------------------
0     501    NOMAX        0
1     502    64000    15600
3    NONE    NOMAX        -

Detail of the Data port for Fxs/Fxo VOICE connections

ID: | Data port identifier
no value | from 0 up to 31

It represent the index of the entry and it sets the verifying sequence of the table of Data ports for Fxs/Fxo VOICE connections, for each incoming call.

The verifying procedure starts from the entry identified by 0 and proceeds until it finds the proper definition for that call or it reaches the end of the table.

The index is also used by the adding, modifying, deleting commands to refer to a given Data ports for Fxs/Fxo VOICE connections.

The table of Data ports for Fxs/Fxo VOICE connections can store up to 32 entries, therefore the identifier value must be in the interval [0 - 31]. The table is NOT automatically maintained with consecutive indexes, then Data port for Fxs/Fxo VOICE connections definitions may not have sequential identifiers.

PO: | Data port number
NONE | 0 - 999, NONE

It sets the CPX port number corresponding to the Data port for the incoming call. The port value must be in the range [0 - 999] and must correspond to a MLM port currently configured and active.

The value "NONE" stands for "no port" and it can be used to deactivate an entry without deleting it.

MXBW: | Maximum bandwidth available for Voice traffic
NOMAX | 0 - 2048000, NOMAX

It sets the maximum bandwidth that is available for the Voice traffic.

If it is set to "NOMAX", the available bandwidth will be as much as the physical resources can give.

CURBW: | Bandwidth currently used by the Voice traffic
- | 0 - 2048000

It shows the bandwidth that is currently used by the Fxs/Fxo VOICE connections active on the port specified by PO: field.

The value "-" means that the present entry is not currently in use for Fxs/Fxo VOICE connections and it has to be initialized by executing the command INIT VR.

The parameter has informative meaning only and cannot be modified.


The ports Fxs/Fxo (VOICE)

Configuration of the voice ports
Statistics of the VOICE ports

Configuration of the VOICE ports top

The VOICE port is labelled within the Abilis CPX by the acronym "VOICE" and it is provided with the parameters described in the following section:

The following example shows how to display parameters of VOICE ports. Shown value are only examples.

[18:38:04] ABILIS_CPX: D P PO:60

PO:60  ------------------------------------------------------------------------
VOICE  SP:6400  ( 7800)       VOL:8     LVOL:8      SC:NO      UDT:15
       ACNUM:#     DIALT:5    int:FXS   CNG:AUTO    EC:YES     PF:YES
       LOOP:NO     TT:NO      TRON:10   TROFF:25    THON:3     THOFF:1

If the parameter INT: is set to "FXO" the visualization will be:

[18:38:04] ABILIS_CPX: D P PO:60

PO:60  ------------------------------------------------------------------------
VOICE  SP:6400  ( 7800)       VOL:8     LVOL:8      SC:NO      UDT:15
       ACNUM:#     DIALT:5    int:FXO   CNG:AUTO    EC:YES     PF:YES
       LOOP:NO     TT:NO      TRON:10   TROFF:25    THON:3     THOFF:1
       ------------------------------ FXO only --------------------------------
       DISC:BUSY
       SDT:30      SFIL:1     CTDT:5    CTFIL:1     BREP:3     BFIL:1
       TSMIN:5     TSMAX:25   TST:2     SSMIN:5     SSMAX:25   SST:2

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:.

Detail of the VOICE port parameters

SP: | Rate of the compressed speech
6400 | 4800, 6400, 7200, 8000, 9600, 10400, 12800, 16000

This parameter is sued to set the rate of the compressed speech.

VOL: | Volume of the output signal (8 = 0db)
8 | 0 - 15

It sets the volume of the output signal.

LVOL: | Local volume of the output signal (8 = 0db)
8 | 0 - 15

It sets the local volume of the output signal.

SC: | Activation of the "Silence Compression" function
NO | NO, YES

It activates/deactivates the "Silence Compression" function.

When silence compression is active it is possible to enable the disconnection by silence in DISC: parameter.

UDT: | Timeout of the unconditioned disconnection
15 | FORCETOZERO (= 0), 1 - 60 (minutes)

It sets the timeout of the unconditioned disconnection.

If its value is higher than zero, the counter will start when the connection leaves the "DISCONNECTED" state for reaching the "CONNECTED" one. One the counter ran over, it will be closed. To force the disconnecting interval to zero, it is not allowed to use the digit "0", but the string "FORCETOZERO"; only in this case the timeout will be ignored.

ACNUM: | Telephone number for the auto-connection procedure
# | from 1 up to 4 numerical digits, #

This parameter is used to specify the telephone number for activating the auto-connection procedure.

The value "#", standing for "no number", means that no auto-connection procedure will be executed.

DIALT: | Dialling Timeout
5 | 1 - 60 (seconds)

It sets the dialling timeout.

INT: | Type of the analogue interface installed
NONE | FXS, FXO, E&M, NONE

This parameter is used to select the type of the analogue interface installed.

CNG: | Activation of the "Comfort Noise" generator
AUTO | NO, ALWAYS, AUTO

It activates/deactivates the "Comfort Noise Generator".

EC: | "Echo canceller" enabling
YES | NO, YES

It is used to activates/deactivates the "Echo canceller".

PF: | Activation of the "Post filter"
YES | NO, YES

It activates/deactivates the "Post filter".

LOOP: | Type of "Loopback test"
NO | CODER, PCM, NO

It selects the type of "Loopback test".

TT: | Activation of the "Tone test"
NO | NO, YES

It activates/deactivates the type of "Tone Test".

TRON: | Duration of the RING-ON generation interval (Only if INT:FXS)
8 | 1 - 20 (in 100 milliseconds)

It sets the duration of the RING-ON generation interval.

The parameter is meaningful only if INT: is set to "FXS".

TROFF: | Duration of the RING-OFF generation interval (Only if INT:FXS)
8 | 1 - 20 (in 100 milliseconds)

It sets the duration of the RING-OFF generation interval.

The parameter is meaningful only if INT: is set to "FXS".

THON: | Minimal duration of the time interval for detecting the ON-HOOK signal (Only if INT:FXS)
10 | 1 - 20 (in 100 milliseconds)

It sets the minimal duration of the time interval for detecting the ON-HOOK signal.

The parameter is meaningful only if INT: is set to "FXS".

THOFF: | Minimal duration of the time interval for detecting the OFF-HOOK (Only if INT:FXS)
10 | 1 - 20 (in 100 milliseconds)

It sets the minimal duration of the time interval for detecting the OFF-HOOK signal.

The parameter is meaningful only if INT: is set to "FXS".

DISC: | Sources of the disconnection signal (Only if INT:FXO)
NO | NO, SILENCE, BUSY, TONE, ALL

It selects the sources of the disconnection signal.

Value | Meaning
NO | Disconnection signal is never detected
SILENCE | Disconnection depends on the duration of the simultaneous silence interval on both channels. Requires SC:YES.
BUSY | Disconnection depends on the duration of the busy signal detected
TONE | Disconnection depends on the duration of the tone signal detected
ALL | Disconnection depends on the silence (if SC:YES), the busy and tone signal

The parameter is meaningful only if INT: is set to "FXO".

SDT: | Time interval of silence detection (Only if INT:FXO)
30 | 1 - 90 (in seconds)

Duration of the silence, simultaneous on both channels, for identifying the disconnection.

Disconnection by silence requires SC:YES.

The parameter is meaningful only if INT: is set to "FXO".

SFIL: | Stability time interval for silence detection (Only if INT:FXO)
1 | 1 - 10 (in samples)

It sets the time interval needed to detect the silence state. The signal state, in order to be considered valid, has to be constant during the specified time interval.

The parameter is meaningful only if INT: is set to "FXO".

CTDT: | Time interval needed to detect the steady tone for disconnection (Only if INT:FXO)
2 | 1 -20 (in seconds)

Number of sequences valid and sequential which identify the disconnection signal.

The parameter is meaningful only if INT: is set to "FXO".

CTFIL: | Stability time interval needed to detect the steady tone for disconnecting (Only if INT:FXO)
1 | 0 - 10 (in samples)

It sets the time interval needed to detect the state of the steady tone. The signal state, in order to be considered valid, has to be constant during the specified time interval.

The parameter is meaningful only if INT: is set to "FXO".

BREP: | Number of consecutive repetitions of the busy tone for disconnecting (Only if INT:FXO)
3 | 1 - 20 (Tone/No-tone)

Number of sequences valid and consecutive which identify the disconnection signal.

The parameter is meaningful only if INT: is set to "FXO".

BFIL: | Stability time interval needed to detect the busy tone (Only if INT:FXO)
1 | 0 - 10 (in samples)

It sets the time interval needed to detect the state of the busy tone. The signal state, in order to be considered valid, has to be constant during the specified time interval.

The parameter is meaningful only if INT: is set to "FXO".

TSMIN: | Minimal duration of the "tone" of the busy signal (Only if INT:FXO)
5 | 1 - 253 (in samples)

If the duration of the "Tone" section in the busy signal is smaller than the set one, the detecting procedure of this signal will be repeated.

The parameter is meaningful only if INT: is set to "FXO".

TSMAX: | Maximal duration of the "tone" of the busy signal (Only if INT:FXO)
25 | 3 - 255 (in samples)

If the duration of the "Tone" section in the busy signal is bigger than the set one, the detecting procedure of this signal will be repeated.

The parameter is meaningful only if INT: is set to "FXO".

TST: | Tolerance interval of the "Tone" in the busy signal (Only if INT:FXO)
2 | 2 - 255 (in samples)

If the "tone" duration in the busy signal is not the same as the set value, the detecting procedure of this signal will be repeated.

The parameter is meaningful only if INT: is set to "FXO".

SSMIN: | Minimal duration of the "No-Tone" of the busy signal (Only if INT:FXO)
5 | 1 - 253 (in samples)

If the duration of the "No-Tone" section in the busy signal is smaller than the set one, the detecting procedure of this signal will be repeated.

The parameter is meaningful only if INT: is set to "FXO".

SSMAX: | Maximal duration of the "No-Tone" of the busy signal (Only if INT:FXO)
25 | 3 - 255 (in samples)

If the duration of the "No-Tone" section in the busy signal is bigger than the set one, the detecting procedure of this signal will be repeated.

The parameter is meaningful only if INT: is set to "FXO".

SST: | Tolerance interval of the "No-Tone" in the busy signal (Only if INT:FXO)
2 | 2 - 255 (in samples)

If the "No-Tone" duration in the busy signal is not the same as the set value, the detecting procedure of this signal will be repeated

The parameter is meaningful only if INT: is set to "FXO".

Statistics of the VOICE ports top

How to check state and statistics of the VOICE ports by the command D S.

[18:38:04] ABILIS_CPX: D S PO:60

PO:60  ------------------------------------------------------------------------
VOICE  STATE:DISCONNECTED       HOOK:ON-HOOK            RING:OFF
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |LOST-FRAME |0          |           |
       UDT-DISC   |0          |0          |           |           |           |
       SIL-DISC   |           |0          |TONE-DISC  |           |0          |
       BUSY-DISC  |           |0          |
       ------------------------------------------------------------------------

Extended statistics are not available for VOICE ports. The command D SE execution will display again the not extended statistics by the following format:

[18:38:04] ABILIS_CPX: D SE PO:60

PO:60  ------------------------------------------------------------------------
VOICE  --- Cleared 000:03:37:20 ago, at 25/05/1999 07:12:49 -------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |0          |0          |SUCC-CALL  |0          |0          |
       TIME-CALL  |0          |0          |LOST-FRAME |0          |           |
       UDT-DISC   |0          |0          |           |           |           |
       SIL-DISC   |           |0          |TONE-DISC  |           |0          |
       BUSY-DISC  |           |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the VOICE ports

STATE: | Current state of the VOICE driver
 | DISCONNECTED, DIALLING, CALLING, ALERTING, BUSY, CALLED, RINGING, DISCONNECTING, CONNECTED, FAILED-DWNL, FAILED-INIT, FAILED-RUN, ERR

It shows the current state of the VOICE port driver:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
VOICE | DISCONNECTED | Connection is going to be closed |  |  | D
 | DIALLING | Connection is getting established |  |  | l
 | CALLING | Connection is getting established |  |  | o
 | ALERTING | Connection is getting established |  |  | a
 | BUSY | The dialled number is busy |  |  | b
 | CALLED | Connection is getting established |  |  | o
 | RINGING | Connection is getting established |  |  | r
 | DISCONNECTING | Connection is going to be closed |  |  | d
 | CONNECTED | Connection is active |  |  | C
 | FAILED-DWNL | The port is not active owing to a failure of the software loading procedure |  |  | #
 | FAILED-INIT | The port is not active owing to a failure of the initialization procedure |  |
 | FAILED-RUN | Port is not active |  |
 | ERR | Software error, contact the Abilis assistance |  |

HOOK: | Current state of the ON-HOOK/OFF-HOOK
 | ON-HOOK, OFF-HOOK

It shows the current state of the ON-HOOK/OFF-HOOK.

RING: | Current state of the Ring signal
 | OFF, ON

It shows the current state of the Ring signal:

OFF: the Ring signal is not present.

ON: the Ring signal is present.

FAIL-CALL: | Overall number of incoming/outgoing failed calls
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) is incremented every time an incoming call fails, while the FAIL-CALL (OUTPUT) every time an outgoing call fails.

SUCC-CALL: | Overall number of incoming/outgoing successful calls
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) is incremented every time an incoming call succeeds, while the SUCC-CALL (OUTPUT) every time an outgoing call succeeds.

TIME-CALL: | Overall duration (in seconds) of connections generated by the incoming/outgoing calls
 | 0 - 4.294.967.295

The counter TIME-CALL (INPUT) represents the overall duration of connections generated by incoming calls, while the counter TIME-CALL (OUTPUT) the overall duration of connections generated by outgoing calls.

LOST-FRAME: | Number of lost voice frames during the transfer between two connected analog voice ports.
 | 0 - 4.294.967.295

If the analog voice port is in CONNECTED state, the Analog Voice Router has to deliver the valid voice frame into such port. If the Voice Router isn't able to provide such voice frame (the frames are not properly delivered from the other side of the connection), this counter is increased and port has to used blind voice frame.

UDT-DISC: | Number of times that the timeout "UDT:" ran over
 | 0 - 4.294.967.295

The counter UDT-DISC is incremented every time the timeout UDT: runs over.

SIL-DISC: | Number of times that the timeout "SDT:" ran over (Only if INT:FXO)
 | 0 - 4.294.967.295

The counter SILENCE-DISC is incremented every time the timeout SDT: runs over

The parameter is meaningful only if INT: is set to "FXO".

TONE-DISC: | Number of times that the timeout "CTDT:" ran over (Only if INT:FXO)
 | 0 - 4.294.967.295

The counter TONE-DISC is incremented every time the timeout CTDT: runs over

The parameter is meaningful only if INT: is set to "FXO".

BUSY-DISC: | Number of that the "BUSY" signal was detected and connection dropped
 | 0 - 4.294.967.295

The counter BUSY-DISC represents the number of time that a connection was closed by detection of the BUSY signal.

The BUSY signal is detected according to the configurations of BREP, BFIL, TSMIN, TSMAX, TST, SSMIN, SSMAX, SST parameters.

The parameter is meaningful only if INT: is set to "FXO".


The Control Port (CP)

Access levels to the Control Port (CP)
Configuration of the Control Port (CP)
Statistics of the Control Port (CP)
How to connect to the Control Port (CP)

It is possible through the Control Port to access configuration and supervising functions.

The Control Port is not a physic port, that is there is no connector, but it is a "virtual" port of the Abilis CPX. It is possible to send commands and get answers, to configure and supervise the Abilis CPX.

Access levels to the Control Port (CP) top

it is possible to log in to the Control Port by using three different privilege levels, each of them has got a set of allowed operations and it is provided with a set of suitable commands:

  • User login level (USER): it is possible to execute only some operations for supervising the Abilis CPX working mode, executing "USER" not allowed commands will cause the message "COMMAND NOT ALLOWED FOR USER LOGIN LEVEL" to be displayed.
  • Administrator login level (ADMINISTRATOR): user is allowed, with some restrictions, to execute all the operations for configuring and supervising the Abilis CPX; execution of "ADMINISTRATOR" not allowed commands is refused and the message "COMMAND NOT ALLOWED FOR ADMINISTRATOR LOGIN LEVEL" is displayed.
  • Super-User login level (SUPERUSER): user is able to completely manage the system; execution of any configuration or supervision commands is possible.

It is possible to access the different levels through the proper passwords: if no password is configured, User will access directly the level which provides more privileges.

Once the CP has been accessed, it is possible to check or modify the privilege level by using the command LOGIN, described in section Access commands to the system of General and system commands document.

Here is an example on how to access the Control Port through the TELNET port, with USER privileges:

[192.168.0.60] TELNETS>00-CP
COM

CPX system release 4.1.0 - build 1129
Wednesday 27/03/2002 18:31:04 (GMT+1.00)
Login:USER
Password:*********
Logged as USER

[11:32:37] ABILIS_CPX:

As the previous example shows, the User is asked to specify the requested access level (USER, ADMINISTRATOR or SUPERUSER) and then to insert the correspondent password.

If the password is wrong, it will be asked again. After the third wrong try the connection will be cleared.

[192.168.0.60] TELNETS>00-CP
COM

CPX system release 4.1.0 - build 1129
Wednesday 27/03/2002 18:31:04 (GMT+1.00)
Login:USER
Password:*****

INVALID PASSWORD

Password:********

INVALID PASSWORD

Password:*******

CLR F0 AE

[192.168.0.60] TELNETS>

Configuration of the Control Port (CP) top

The Control Port is identified by the mnemonic "CP", correspondent to the Abilis CPX port "0" and it is provided with the parameters described in this section.

Here is an example on how to display the Control Port parameters. Shown values are the default ones.

[11:47:16] ABILIS_CPX: D P PO:0

PO:0   - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
CP     ------------------------------------------------------------------------
       PI:ABILIS_CPX:          bsvc:3                  ps:128
       PWD-U:                  PWD-A:                  PWD-S:
       X29A:02010102010302040006050C010D000E000F011008111812121302
       X29B:020100020003000402050006000700080009000A000C000D000E000F001500

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary changes made on upper case parameters are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Details of the Control Port (CP) parameters

PI: | Prompt of CP command interpreter
ABILIS_CPX: | from 0 up to 16 ASCII characters [33..126]

This parameter set the command interpreter prompt of the Control Port.

Information about current local time "[hh:mm:ss]" always precedes the user defined prompt.

It is possible to use from 0 up to 16 ASCII characters [33..126], spaces are not allowed. No differences between low and high case characters are made.

To remove the port identifier, the prompt parameter has to be set to "S P PO:0 PI:".

BSVC: | Number of sessions
3 | 3 - 8

It sets the maximum number of connections that can be opened at the same time with the Control Port.

PS: | Packet size
128 | 16, 32, 64, 128, 256, 512, 1024, 2048 (bytes)

It sets the maximum size (in bytes) of packets to be sent or received.

PWD-U: | Access Password to the CP of the USER level
no value | from 0 up to 16 ASCII characters [33..126]

It sets the access password to the CP of the USER level.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made

Once it is configured, the new password will be saved on the Abilis CPX disk, in a encrypted way, using the command SAVE CONF.

Every time the user wants to connect to the Control Port, he is asked to specify the requested access level (USER, ADMINISTRATOR or SUPERUSER) and then to insert the correspondent password. If the password is wrong, it will be asked again. After the third wrong try the connection will be cleared.

To delete the password, this parameter has to be set to "S P PO:0 PWD-U:".

This parameter can me modified at the privilege levels Administrator/Super-User.

PWD-A: | Access Password to the CP of the ADMINISTRATOR level
no value | from 0 up to 16 ASCII characters [33..126]

It sets the access password to the CP of the ADMINISTRATOR level.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made

Once it is configured, the new password will be saved on the Abilis CPX disk, in a encrypted way, using the command SAVE CONF.

Every time the user wants to connect to the Control Port, he is asked to specify the requested access level (USER, ADMINISTRATOR or SUPERUSER) and then to insert the correspondent password. If the password is wrong, it will be asked again. After the third wrong try the connection will be cleared.

To delete the password, this parameter has to be set to "S P PO:0 PWD-AU:".

This parameter can me modified at the privilege levels Administrator/Super-User.

PWD-S: | Access Password to the CP of the SUPER-USER level
no value | from 0 up to 16 ASCII characters [33..126]

It sets the access password to the CP of the SUPER-USER level.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made

Once it is configured, the new password will be saved on the Abilis CPX disk, in a encrypted way, using the command SAVE CONF.

Every time the user wants to connect to the Control Port, he is asked to specify the requested access level (USER, ADMINISTRATOR or SUPERUSER) and then to insert the correspondent password. If the password is wrong, it will be asked again. After the third wrong try the connection will be cleared.

To delete the password, this parameter has to be set to "S P PO:0 PWD-S:".

This parameter can me modified at the privilege level Super-User.

X29A: | X29 String to be sent before reach the "COMMAND-MODE"
See example | from 0 up to 64 hexadecimal digits

This parameter represents the content of the X29 packet that has to the Control Port has to send to the PAD port every time it activates the exchange command procedure COMMAND-MODE.

It means the content of this parameter will be used when:

  • the session established with the Control Port leaves the READY state and reaches the CONNECTED one;
  • the Control Port terminates the procedure of file transferring using the XMODEM protocol and goes back to the command exchanged mode COMMAND-MODE.

The string configured in the parameter "X29A:" will be send into a packet with Q-bit set to 1.

To delete the X29 string and to not send it, the parameter must have no value: "S P PO:0 X29A:".

X29B: | X29 String to be sent on exiting the "COMMAND MODE"
See example | from 0 up to 64 hexadecimal digits

This parameter represents the content of the X29 packet that has to the Control Port has to send to the PAD port every time it activates the procedures of file transferring using the XMODEM protocol.

The string configured in the parameter "X29B:" will be send into a packet with Q-bit set to 1.

To delete the X29 string and to not send it, the parameter must have no value: "S P PO:0 X29B:".

Statistics of the Control Port (CP) top

Example on how to show state and statistics of the Control Port through the command D S:

[11:32:37] ABILIS_CPX: D S PO:0
PO:0   ------------------------------------------------------------------------
CP     STATE:UP
       Ses  State       AccessLevel    Action
       ------------------------------------------------------------------------
       1    CONNECTED   SUPERUSER      COMMAND-MODE
       2    READY
       3    READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         64|          4|CHAR       |       3798|         21|
       ------------------------------------------------------------------------

The Control Port has no extended statistics, so that the execution of the command D SE will display again the not extended statistics by the format:

[11:32:37] ABILIS_CPX: D SE PO:0
PO:0   ------------------------------------------------------------------------
CP     --- Cleared 001:01:38:54 ago, on 25/03/2002 at 08:34:47 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         64|          4|CHAR       |       3798|         21|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the Control Port (CP)

STATE: | Current state of the Control Port
 | UP, ERR

It shows the current state of the Control Port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
CP | UP | The port is active. This is a virtual port, so it is always active. |  |  | UP
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

SEG: | Number of data segments sent/received
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time data are received by the Control Port. The counter SEG (OUTPUT) is incremented every time data are sent by the Control Port.

Segments are calculated by dividing the number of bytes per 64.

CHAR: | Number of characters sent/received
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time data are received by the Control Port. The counter CHAR (OUTPUT) is incremented every time data are sent by the Control Port.

Details of the sessions state fields of the Control Port (CP)

Ses: | Session of the Control Port
 | 3 - 8

Session of the CP. The number of connections that can be opened at the same time with the Control Port is set by the BSVC: parameter.

State: | Current state of the Control Port
 | DOWN, READY, CALLED, CALLING, CONNECTED, REST, RESETTING, CLEARED, CLEARING, ERR

It shows the current state of each connection.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
CP (Sessions) | DOWN | Session is not ready to open a new connection |  |  |
 | READY | Session is ready to open an eventual connection |  |  |
 | CALLED | Session is opening the connection |  |  |
 | CALLING |  |  |  |
 | CONNECTED | Session is connected |  |  |
 | RESET | Session is resetting the connection |  |  |
 | RESETTING |  |  |  |
 | CLEARED | Session is clearing the connection |  |  |
 | CLEARING |  |  |  |
 | ERR | Software error. Contact Abilis assistance. |  |  |

AccessLevel: | Session access level currently in use
 | USER, ADMINISTRATOR, SUPERUSER

It shows the session privilege level actually in use, only if the session is in its state CONNECTED.

Driver | Access Level | Description
 |  |  | CP (Sessions) | USER | User is actually connected using a USER privilege level
ADMINISTRATOR | User is actually connected using a ADMINISTRATOR privilege level
SUPERUSER | User is actually connected using a SUPER-USER privilege level

Action: | Operative current state of the session
 | LOGIN-PHASE, COMMAND-MODE, SENDING-FILE, SENDING-TRACE, RECEIVING-FILE, UPDATING-SYSTEM

Current operative state of the CP session, only if the session is in its state CONNECTED.

Driver | Operative states | Description
 |  |  | CP (Sessions) | LOGIN-PHASE | Session is connected and Login/password request procedure is in act
COMMAND-MODE | Session is connected and data are exchanged (COMMAND-MODE)
SENDING-FILE | On the actual session, files are sent to a remote destination
SENDING-TRACE | On the actual session, the events trace is sent to a remote destination
RECEIVING-FILE | A file is received from a remote destination
UPDATING-SYSTEM | System updating is received from a remote destination

How to connect to the Control Port (CP) top

There are several ways to connect to the Control Port:

  • through the asynchronous serial port of the Abilis CPX
  • through the SVC X.25 channel and asynchronous remote PAD
  • through the SVC X.25 channel and DTE X.25 remote
  • through a TCP/IP network using TELNET/SSH protocols

Connecting through the PAD configuration port

Connecting through the PAD configuration port

Figure 1. Connecting through the PAD configuration port.

In this case the asynchronous terminal is connected to the male DB-25 plug, placed on the back of the Abilis CPX.

The terminal must be set to 9600 bit/sec, 8 data bit, 1 stop bit, no parity check and no flow control. After switching on the terminal, press the key <Enter> to get the PAD local port prompt, digit 00-CP and the command interpreter of the local CPX Control Port will appear.

It is also possible to connect to a remote CPX Control Port through a local CPX.

When the connection to the CP is established, all the needed commands can be sent, the answer will be displayed on the video.

Instead of the asynchronous terminal it is always possible to use a personal computer provided with a emulation program TTY or VT100 or similar.

warning! Abilis CPX asynchronous interface is a DTE type, the suitable connecting cable must be chosen.

Connecting through a SVC X.25 channel and asynchronous remote PAD

Connecting to the CP through the SVC X.25 channel, from a remote PAD

Figure 2. Connecting to the CP through the SVC X.25 channel, from a remote PAD.

In this case the asynchronous terminal connected to a PAD must be provided with a terminal emulation program such as TTY or VT100 (or similar).

The terminal makes a call to the Abilis CPX address, inserting in the User data the string "CP".

Abilis CPX receives the call, open the connection to the Control Port, and send back to the terminal a packet containing the prompt (for example ABILIS_CPX:); from this moment terminal and CP can communicate.

Procedure for making a X.25 call depends on the PAD type, however here is an example of the mostly used:

PAD_PROMPT:12345678DCP                  It calls the 12345678 NUA with user data RP
ACP:COM                                 Call has been accepted.
PAD_PROMPT:C 12345678DCP                It calls the 12345678 NUA with user data RP.
PAD:COM                                 Call has been accepted.
PAD_PROMPT:12345678-CP                  It calls the 12345678 NUA with user data RP.
COM

Refer to PAD instructions for the procedure to use.

The connection to the Control Port via the SVC channel requires the routing table to have, at least, one routing whose destination is "0". Into the default table there are two routings able to connect to the CP: the first one containing the "RP" user data, the second one with the called address "00".

By modifying the routings according to the instructions described in the section Configuration of SVC routing of chapter SVC routing, it is possible to change the CP accessing rules, or simply to remove the routing, whose destination port is "0", in such a way to avoid any remote connection to it.

If routings, with destination port "0", have been removed, there two possibilities to recover the access to the Control Port:

  • add locally a routing to the port "0", through an asynchronous connection or the off-line configurator;
  • load the default configuration: all the already executed configuration will be lost.

PAD and the Control Port must communicate through packets, that is every command sent by the terminal has to be contained in a single X.25 packet, otherwise the Control Port won't accept it. That's why it is really important that PAD is configured to send packet only after receiving the character <CR> (carriage return).

Here there is an example of PAD parameter configuration; the obligatory ones are highlighted:

01:001 02:001 03:002 04:000 05:001 06:005 07:000 08:000 09:000 10:000 11:015 12:001 13:004
14:000 15:001 16:008 17:024 18:002

Instead of the asynchronous terminal it is always possible to use a personal computer provided with a emulation program TTY or VT100 or similar.

warning! Connection to the Control Port requires a SVC channel.
If Abilis CPX is only using PVC channels, it is better to add at least one SVC channel.
If the Abilis is only using SVC channels, it is better to add a new SVC channel. If all the SVC channels are busy it is not possible to connect to the Control Port.

Connecting through a SVC X.25 channel and remote DTE X.25.

Connecting to the CP via X.25 SVC, from a remote DTE X.25

Figure 3. Connecting to the CP via X.25 SVC, from a remote DTE X.25.

In this case the X.25 DTE connected to the network must be provided with X.25 adapter and a terminal emulation program such as TTY or VT100 (or similar).

The X.25 DTE makes a call to the Abilis CPX address, inserting in the User data, starting from the 5th byte, the string "CP".

Abilis CPX receives the call, open the connection to the Control Port, and send back to the X.25 DTE a packet containing the prompt (for example ABILIS_CPX:); from this moment DTE and CP can communicate.

X.25 DTE and the Control Port must communicate through packets, that is every command sent by the DTE has to be contained in a single X.25 packet, otherwise the Control Port won't accept the command.

Discussions about routings of the previous examples are still valid.

The Control Port needs at least one routing to be reached: the default routing table has got a routing for connection to the Control Port ("CP" user data of the call).

Connecting through a TCP/IP network using TELNET/SSH protocols

In this case it is possible to use a personal computer provided with a TELNET (or SSH) Client program such as Windows 2000 Telnet Client (or similar).

The TELNET (or SSH) Client application makes a TCP/IP call to the Abilis CPX IP address.

The TELNET (or SSH) Server of the Abilis CPX receives the call, establishes the TCP connection and sends back the TELNET (or SSH) Server prompt (for example TELNETS>).

From this moment the TELNET (or SSH) Server of the Abilis CPX and the remote TELNET (or SSH) Client application are interconnected.

[192.168.0.60] TELNETS>

To open the connection to the Control Port, the user must enter the proper Called address and User data values to the TELENET (or SSH) application prompt.

The TELNET (or SSH) makes a call to the Control Port, that sends back the packet containing the configured prompt (for example ABILIS_CPX:).

[192.168.0.60] TELNETS>00-CP
COM

CPX system release 4.1.0 - build 1129
Wednesday 27/03/2002 18:31:04 (GMT+1.00)
Logged as SUPERUSER

[18:13:50] ABILIS_CPX:

To cut short the connection phase the user can activate the Auto-Connection procedure on the TELNET (or SSH) Server of the Abilis CPX, setting the AC: parameter to YES. The CDO: and the UDO: parameters of the TELNET (or SSH) port must be also set respectively to the proper Called address and User data values.

Acordingly to the features of the Auto-Connection procedure, once the TELNET (or SSH) Server of the Abilis CPX will receive the TCP/IP call from the TELNET (or SSH) Client application, it will atomatically call the Control Port, establishing the connection.

COM

CPX system release 4.1.0 - build 1129
Wednesday 27/03/2002 18:31:04 (GMT+1.00)
Logged as SUPERUSER

[18:28:22] ABILIS_CPX:

Discussions about routings of the previous examples are still valid.

The Control Port needs at least one routing to be reached: the default routing table has got a routing for connection to the Control Port ("CP" user data of the call).


The serial asynchronous ports (PAD)

Configuration of the pad ports
Statistics of the PAD ports
SNMP traps generated for the pad ports
Commands of the pad port

The Abilis CPX uses the communication serial asynchronous ports to convert data flows of "Start-Stop" type into X.25 packets and viceversa (PAD = Packet Assembly Disassembly), according to the CCITT X3-X28-X29.

Configuration of the PAD ports top

The asynchronous serial port is labelled within the Abilis CPX by the acronym "PAD", it is provided with the parameters described in this section.

Here is an example of the PAD port parameters. All of them are DEFAULT values.

[18:42:32] ABILIS_CPX: D P PO:21

PO:21  ------------------------------------------------------------------------
PAD    01:001 02:001 03:002 04:000 05:001 06:005 07:000 08:000 09:000 10:000
       11:014 12:001 13:004 14:000 15:001 16:008 17:024 18:002 19:002 20:000
       21:000 22:000
       LOG:NO     TYPE:USER  MCAU:NO    ps:128   FS:128      vc:BSVC  AC:NO
       PI:CPX/021:           SP:9600    LE:8     PT:NONE     ST:1     HF:NO
       CD:YES     FDCD:500   FCTS:500   CO:NO    CODLY:0     DTRDN:0
       DW:100     CLRX29:NO  CQ:YES     FC:
       X29:

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

The command PAR PO: is also available for the PAD ports: it shows the current value of the CCITT parameters:

[18:42:32] ABILIS_CPX: PAR PO:21

PO:21  ------------------------------------------------------------------------
PAD    01:001 02:001 03:002 04:000 05:001 06:005 07:000 08:000 09:000 10:000
       11:014 12:001 13:004 14:000 15:001 16:008 17:024 18:002 19:002 20:000
       21:000 22:000

Detail of the PAD port parameters

01: | Parameter X3 01: PAD recall
1 | 0, 1, 32 - 126

Refer to CCITT X3-X28-X29 recommendations.

02: | Parameter X3 02: Echo
1 | 0, 1

Refer to CCITT X3-X28-X29 recommendations.

03: | Parameter X3 03: Data forwarding charcter(s)
2 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

04: | Parameter X3 04: Idle timer delay
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

05: | Parameter X3 05: Ancillary device (DTE flow control)
1 | 0 - 2

Refer to CCITT X3-X28-X29 recommendations.

06: | Parameter X3 06: PAD service and command signals
5 | 0, 1, 4, 5

Refer to CCITT X3-X28-X29 recommendations.

07: | Parameter X3 07: Operation of PAD on receipt of Break signal from DTE
0 | 0 - 31

Refer to CCITT X3-X28-X29 recommendations.

08: | Parameter X3 08: Discard output
0 | 0, 1

Refer to CCITT X3-X28-X29 recommendations.

09: | Parameter X3 09: Padding after carriage return (CR)
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

10: | Parameter X3 10: Line Folding
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

11: | Parameter X3 11: Binary speed of DTE
14 | 0 - 25

Refer to CCITT X3-X28-X29 recommendations.

12: | Parameter X3 12: PAD flow control
1 | 0, 1

Refer to CCITT X3-X28-X29 recommendations.

13: | Parameter X3 13: Line feed (LF) insertion after carriage return (CR)
4 | 0 - 7

Refer to CCITT X3-X28-X29 recommendations.

14: | Parameter X3 14: Line feed (LF) padding
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

15: | Parameter X3 15: Editing
1 | 0, 1

Refer to CCITT X3-X28-X29 recommendations.

16: | Parameter X3 16: Character delete
8 | 0 - 127

Refer to CCITT X3-X28-X29 recommendations.

17: | Parameter X3 17: Line delete
24 | 0 - 127

Refer to CCITT X3-X28-X29 recommendations.

18: | Parameter X3 18: Line display
2 | 0 - 127

Refer to CCITT X3-X28-X29 recommendations.

19: | Parameter X3 19: Editing PAD service signals
2 | 0 - 2, 8, 32 - 126

Refer to CCITT X3-X28-X29 recommendations.

20: | Parameter X3 20: Echo mask
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

21: | Parameter X3 21: Parity treatment
0 | 0 - 2

Refer to CCITT X3-X28-X29 recommendations.

22: | Parameter X3 22: Page wait
0 | 0 - 255

Refer to CCITT X3-X28-X29 recommendations.

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

TYPE: | Port type
USER | USER

This parameter sets how the port behaves if data compression is activated.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user device USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The PAD can be only a USER port.

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PS: | Maximum packet size (bytes)
128 | 16, 32, 64, 128, 256, 512, 1024, 2048

It sets the maximum packet size.

FS: | Number of character to "accumulate" before transmission
128 | from 1 up to PS

Number of character to "accumulate" in a buffer before transmission.

VC: | Logical channel type
BSVC | BSVC, PVC

It selects the connection type.

notice! BSVC= bidirectional switched, PVC = bidirectional permanent.

AC: | Auto-connection mode
NO | NO, DCD, DATA

It selects the auto-connection mode.

Value | Meaning
NO | No auto- connection procedure is applied
DCD | This auto-connection procedure automatically generates a called whenever the driver reaches the "UP" state by leaving the "DOWN" one
DATA | This auto-connection procedure automatically generates a called when the first character is received

PI: | Port identifier
CPX/021 | 16 alphanumeric characters

it is possible to insert any alphanumeric character without distinction between low and high case.

Space are not allowed, in spite of them the character "_" (under score) may be used.

To delete the port identifier this parameter has to be left without value:

S P PO:xxx PI:

where "xxx" stands for the PAD port identifier.

SP: | Port speed
9600 | 110, 1345, 300, 1200, 400, 75, 150, 1800, 200, 100, 50, 75/1200, 2400, 4800, 9600, 19200, 48000, 56000, 64000, 7200, 14400, 28800, 33400, 38400, 57600, 115200

It selects the PAD port speed.

LE: | Character length (bits)
8 | 5, 6, 7, 8 bits

It selects the character length (bits).

PT: | Parity type
NONE | NONE, EVEN, ODD, MARK, SPACE

It select the parity type.

Value | Meaning
NONE | No parity
EVEN | Even parity
ODD | Odd parity
MARK | Parity bit is always set to 1
SPACE | Parity bit is always set to 0

ST: | Number of stop bits
1 | 1, 2

It sets the number of stop bits.

HF: | Hardware flow control
NO | NO, RTS, CTS, BOTH

It sets the type of hardware flow control.

Value | Meaning
NO | The signal RTS is always "UP" and the CTS one is ignored
RTS | The signal RTS is used for controlling the flow of data received by the PAD and the CTS one is ignored
CTS | The signal CTS is used for controlling the flow of data received by the DTE and the RTS one is always "UP"
BOTH | The signal RTS is used for controlling the flow of data received by the PAD, while the CTS one to control the flow of data received by the DTE.

CD: | Controlling signal DCD
NO | NO, YES, MODEM

It selects the control type of the signal DCD.

FDCD: | Time interval of stability of the DCD signal
500 | 0 - 65535 milliseconds

It sets the time interval needed to detect the state of the DCD signal. It is checked every CPU tick (55 milliseconds c.a.) and, in order to avoid detection of useless fluctuations, it is considered valid only if it is constant during the time interval defined in the parameter.

FCTS: | Time interval of stability of the CTS signal
500 | 0 - 65535 milliseconds

It sets the time interval needed to detect the state of the CTS signal. It is checked every CPU tick (55 milliseconds c.a.) and, in order to avoid detection of useless fluctuations, it is considered valid only if it is constant during the time interval defined in this parameter.

CO: | Connect indication mode
NO | NO, YES, MODEM

It sets the "connect indication" mode.

Value | Meaning
NO | "Connect indication" is not handled. DTR is always "UP" and the RTS signal is handled conventionally.
YES "Connect indication" is handled basing on the call type:
  • incoming call: the PAD activates the DTR signal and waits, for the time interval specified in the parameter CODLY:, the signal DCD to be "UP". If the signal DCD goes "UP" within the specified time interval, the session will be "CONNECTED", otherwise the call will be refused and the session will go back to the "READY" state
  • outgoing calls: when the session reaches the "CONNECTED" state, the signal DTR is set to "UP", while the signal DCD behaves according to the "CD:" parameter value
MODEM | "MODEM disconnection" procedure is applied. Connection is teared down if no session is activated within a given time interval. In this case the signal DTR is kept "DOWN" as long as the value of the parameter DRTDN:

CODLY: | Waiting interval of the signal DCD UP (Only if CO:YES)
100 | 0 - 65535 milliseconds

Waiting interval of the signal DCD "UP" in case of CO: "YES".

DTRDN: | Time interval of the signal DTR "DOWN" (Only if CO:MODEM)
100 | 0 - 65535 milliseconds

If CO: is set to "MODEM", the signal DTR will be kept "DOWN" for the time interval specified in this parameter.

DW: | Time interval to be waited before sending a CLEAR request when the DCD signal is "DOWN"
100 | 0 - 65535 milliseconds

It sets the time interval to be waited before sending a CLEAR request when the DCD signal is "DOWN"

CLRX29: | Sending of CLR_X29, instead of CLR_REQ, when the DCD signal is "DOWN"
YES | NO, YES

It enables sending of CLR_X29, instead of CLR_REQ, when the DCD signal is "DOWN"

CQ: | Control whether the Q-BIT is set to 1
YES | NO,

It checks whether the Q-BIT is set to 1.

If the parameter is set to "NO" the PAD will discard all the packets whose Q-BIT is 1, otherwise the PAD will manage them, as, for example, the X29 strings.

FC: | Additional characters
none | from 0 up to 15 hexadecimals

String of additional characters.

To delete the string, this parameter has to be let without value:

S P PO:xxx FC:

where "xxx" stands for the PAD port identifier.

It is strictly related with the settings of the CCITT X3-X28-X29 recommendation for the parameter X3 03.

X29: | String X29 to send when the session reaches the "CONNECTED" state
none | from 0 up to 64 hexadecimals

It selects the X29 string to send when the session reaches the "CONNECTED" state.

To delete the string, this parameter has to be let without value: S P PO:xxx X29:, where "xxx" stands for the PAD port identifier.

Statistics of the PAD ports top

How to check the state and statistics of the PAD ports by the command D S.

[18:42:32] ABILIS_CPX: D S PO:21

PO:21  ------------------------------------------------------------------------
PAD    STATE:DOWN                          L1:DOWN
       DTR:UP            DCD:DOWN          RTS:DOWN          CTS:DOWN
       RXOVR:0           LOST-I:0          PARITY:0          FRAMING:0
       FIFO:UNKNOWN      TXSIZE:1          RXSIZE:1
       ------------------------------------------------------------------------
       UART:16450        TXTRIGGER:0       RXTRIGGER:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |0          |0          |
       CALL       |0          |0          |
       ------------------------------------------------------------------------

The PAD ports have not extended statistics so that the execution of the command D SE will display again the not extended statistics by the following format:

[18:42:32] ABILIS_CPX: D SE PO:21

PO:21  ------------------------------------------------------------------------
PAD    --- Cleared 000:03:13:30 ago, on 12/05/2000 at 12:21:27 ----------------
       RXOVR:0           LOST-I:0          PARITY:0          FRAMING:0
       FIFO:UNKNOWN      TXSIZE:1          RXSIZE:1
       ------------------------------------------------------------------------
       UART:16450        TXTRIGGER:0       RXTRIGGER:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |0          |0          |
       CALL       |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the PAD ports

STATE: | Current state of the driver PAD
 | HALTED, CLOSED, DOWN, CALLED, READY, CALLING, CONNECTED-DT, CONNECTED-CM, CLEARING, ERR

It shows the current state of the PAD port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Event Log | Display LCD
PAD | HALTED | Port is not working |  |  |
 | CLOSED | Starting state of the PAD port |  |  |
 | DOWN | Prot is not active |  |  |
 | CALLED | The port made a call |  |  |
 | READY | Port is active |  |  |
 | CALLING | The port received a call |  |  |
 | CONNECTED-DT | Session is connected and data are exchanged |  |  |
 | CONNECTED-CM | Session is connected and commands are exchanged |  |  |
 | CLEARING | Session clearing |  |  |
 | ERR | Software error. Contact Abilis assistance. |  |  |

L1: | Current state of the 1st asynchronous driver
 | DOWN, UP, HALTED, ERR

It shows the current state of the 1st asynchronous level of the PAD port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
Level 1 asynchronous | DOWN | Level 1 asynchronous is not active | dn
 | UP | Level 1 asynchronous is active | UP
 | HALTED | Level 1 asynchronous is halted | HT
 | ERR | Software error. Contact the Abilis assistance. | NA

DTR: | Current state of the signal DTR
 | DOWN, UP, N/A

It reports the current state of the signal DTR.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (Signal DTR) | DOWN | The signal DTR is not active | 0 | dn | 0
 | UP | The signal DTR is active | 1 | UP | 1
 | N/A | The signal state is not available | 2 | NA | 2

DCD: | Current state of the signal DCD
 | DOWN, UP, N/A

It reports the current state of the signal DCD.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (Signal DCD) | DOWN | The signal DCD is not active | 0 | dn | 0
 | UP | The signal DCD is active | 1 | UP | 1
 | N/A | The signal state is not available | 2 | NA | 2

RTS: | Current state of the signal RTS
 | DOWN, UP, N/A

It reports the current state of the signal RTS.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (Signal RTS) | DOWN | The signal RTS is not active |  |  |
 | UP | The signal RTS is active |  |  |
 | N/A | The signal state is not available |  |  |

CTS: | Current state of the signal CTS
 | DOWN, UP, N/A

It reports the current state of the signal CTS.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (Signal CTS) | DOWN | The signal CTS is not active |  |  |
 | UP | The signal CTS is active |  |  |
 | N/A | The signal state is not available |  |  |

RXOVR: | Number of "overrun" occurred in the communication board
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time the communication board reports an "overrun" for the received data.

warning! High values, but especially growing, of this counter could mean a hardware problem of the Abilis CPX or most probably that the communication speed is too high.

NOBUF: | Number of times the condition "no buffer" occurred
 | 0 - 4.294.967.295

The counter NOBUF is incremented every time the condition "NO BUFFER" occurs.

PARITY: | Number of "parity errors" detected in the incoming data
 | 0 - 4.294.967.295

The counter PARITY is incremented every time a "parity error" is detected in the incoming data.

FRAMING: | Number of "framing errors" detected in the incoming data
 | 0 - 4.294.967.295

The counter FRAMING is incremented every time a "framing error" is detected in the incoming data.

FIFO: | State of level 1 FIFO
 | UNKNOWN, NOTVALID, USED

It shows the current state of the Uart FIFO.

TXSIZE: | Size of the transmitting FIFO
 | 0 - 65.535

The parameter TXSIZE shows the size of the transmitting FIFO.

RXSIZE: | Size of the receiving FIFO
 | 0 - 65.535

The parameter RXSIZE shows the size of the Uart receiving FIFO.

UART: | UART installed
 | NOTINST, 8250, 16450, 16550, 16550A, 16650, 16750

It shows the UART type installed.

TXTRIGGER: | TX trigger level
 | 0 - 255

The parameter TXTRIGGER shows the trigger transmitting level of the UART.

RXTRIGGER: | RX trigger level
 | 0 - 255

The parameter RXTRIGGER shows the trigger receiving level of the UART.

SEG: | Number of received/sent segments
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time data are received by the PAD port. The counter SEG (OUTPUT) is incremented every time data are sent.

Segments are obtained dividing by 64 the number of bytes.

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time data are received by the PAD port. The counter CHAR (OUTPUT) is incremented every time data are sent.

CALL: | Number of received/made calls
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time the PAD port received a call. The counter CALL (OUTPUT) is incremented every time a call is made.

SNMP traps generated for the PAD ports top

The Abilis CPX Agent sends traps corresponding to the most significative state changes of the asynchronous Level 1 of the PAD ports.

Trap own code | Trap mnemonic | SNMP variables referred in the trap | Description
29 | cxTrapPadL1Down | cxPortIndex, cxPortType, cxPadDiagPadState, cxPadDiagAsyncState, cxPadDiagDCD, cxPadDiagDTR, sysUpTime | This kind of trap is generated by the Agent of Abilis CPX, every time the asynchronous Level 1 of a PAD port reaches the DOWN state
30 | cxTrapPadL1Up | cxPortIndex, cxPortType, cxPadDiagPadState, cxPadDiagAsyncState, cxPadDiagDCD, cxPadDiagDTR, sysUpTime | This kind of trap is generated by the Agent of Abilis CPX, every time the asynchronous Level 1 of a PAD port reaches the UP state

Detail of the SNMP variables shown in the PAD port traps

cxPortIndex | PAD port which the SNMP trap refers to
0 - 999 |

This variable gives the number of the CPX port which the SNMP trap refers to.

cxPortType | Type and description of the SYNC port which the trap refers to
 | type - description

This variable shows the port type (in this case PAD) which the trap refers to, and the description that the user could associate to it.

cxPadDiagPadState | Current of the PAD port which the trap refers to
 | halted(0), closed(1), down(2), called(3), ready(4), calling(5), connected-DT(6), connected-CM(7), clearing(8)

This variable shows current state of the PAD port driver which the trap refers to. In the following table is shown the relation among the state values shown in the SNMP variable and the ones shown by the command D S.

Value of the SNMP variable | Corresponding state of the PAD port
halted(0) | HALTED
closed(1) | CLOSED
down(2) | DOWN
called(3) | CALLED
ready(4) | READY
calling(5) | CALLING
connected-DT(6) | CONNECTED-DT
connected-CM(7) | CONNECTED-CM
clearing(8) | CLEARING

cxPadDiagAsyncState | Current state of the asynchronous Level 1 of the PAD port which the trap refers to
 | down(0), up(1), halted(2)

This variable shows current state of the Level 1 asynchronous of the PAD port which the trap refers to. In the following table is shown the relation among the state values shown in the SNMP variable and the ones shown by the command D S.

Value of the SNMP variable | Correspondent state of the PAD port Level 1
down(0) | DOWN
up(1) | UP
halted(2) | HALTED

cxPadDiagDCD | Current state of the signal DCD of the PAD port which the trap refers to
 | down(0), up(1), not-available(2)

This variable shows current state of the signal DCD of the PAD port which the trap refers to. In the following table is shown the relation among the state values shown in the SNMP variable and the ones shown by the command D S.

Value of the SNMP variable | Correspondent state of the signal DCD
down(0) | DOWN
up(1) | UP
not-available(2) | N/A

cxPadDiagDTR | Current state of the signal DTR of the PAD port which the trap refers to
 | down(0), up(1), not-available(2)

This variable shows current state of the signal DTR of the PAD port which the trap refers to. In the following table is shown the relation among the state values shown in the SNMP variable and the ones shown by the command D S.

Value of the SNMP variable | Correspondent state of the signal DTR
down(0) | DOWN
up(1) | UP
not-available(2) | N/A

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cents of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

Commands of the port PAD top

A command interpreter is active in the PAD port, every time the session is "READY" or "CONNECTED-CM".

If session is its state "CONNECT-DT", that is it is exchanging data, it will be possible to reach the "CONNECTED-CM" state, by pressing the combination <Ctrl+P>, as consequence of this action the command interpreter prompt of the PAD port, set in the parameter PI:, will be shown.

If the combination above mentioned will be pressed again, the session will leave the "CONNECTED-CM" state and go back to the "CONNECTED-DT" and the following message will be displayed "RETURNED TO DATA TRANSFER".

Hers is a list, in alphabetical order, of the allowed commands for the PAD port command interpreter.

Command | Description | Notes
BREAK | Equivalent to the BREAK signal | Actually not implemented
CLR | It sends a CLEAR | Only if state is CONNECTED-CM
PAR? | Current values of the CCITT parameters |
RESET | It sends a RESET | Only if state is CONNECTED-CM
RPAR? | Current values of the remote CCITT parameters | Only if state is CONNECTED-CM
RSET | It sets the values of the remote CCITT parameters | Only if state is CONNECTED-CM
RSET? | It sets and shows values of the remote CCITT parameters | Only if state is CONNECTED-CM
SET | It sets the values of the CCITT parameters |
SET? | It sets and shows values of the CCITT parameters |

Detail of the PAD port commands

BREAK | Break signal
 | BREAK

This command is not implemented in the actual version of the Abilis CPX. If it is executed, the following message will be shown: "BREAK COMMAND NOT IMPLEMENTED YET (use Break signal)".

CLR | Send CLEAR
 | CLR

If session is connected and exchanging commands, this command will close the current connection, causing a Clear Request packet to be sent.

If session is not in the state "CONNECTED-CM" the following message will be shown "CLR ERR - NOT LINKED".

PAR | Display CCITT parameters
 | PAR? [par]

It shows the actual value of the CCITT parameters of the PAD port, only if the session state is READY or CONNECTED-CM.

If not parameter is added, the command will shown all the parameters by the format "parameter:value", otherwise only the requested parameter will be displayed.

RESET | Send RESET
 | RESET

If session is connected and exchanging commands, this command send a Reset Indication packet.

RPAR | Display CCITT remote parameters
 | RPAR? [par]

If session is connected and exchanging commands, this command will display the current values of the CCITT parameters of the remote PAD port.

If not parameter is added, the command will shown all the parameters by the format "parameter:value", otherwise only the requested parameter will be displayed.

If session is not in the state "CONNECTED-CM" the following message will be shown "CLR ERR - NOT LINKED".

RSET | Set CCITT parameters
 | RSET par:val

If session is connected and exchanging commands, this command will set the current values of the CCITT parameters of the remote PAD port, by the format "parameter:value".

RSET? | Set and display CCITT parameters
 | RSET par:val

If session is connected and exchanging commands, this command will set the current values of the CCITT parameters of the remote PAD port, by the format "parameter:value", and then display them.

SET | Set CCITT parameters
 | SET par:val

This command set the current values of the CCITT parameters of the PAD port, by the format "parameter:value".

SET? | Set and display CCITT parameters
 | SET par:val

This command set the current values of the CCITT parameters of the PAD port, by the format "parameter:value", and then shows them.


The synchronous ports (SYNC)

Configuration of the synchronous ports
Statistics of the synchronous ports
SNMP Traps generated for the SYNC ports

Synchronous ports are the communication ports of the Abilis boards HSCB, ESB and ESB2.

The SYNC supplies the following services:

Data, received from the upper level ports, are online transmitted as HDLC frames, including either the beginning/ending frame flags and the CRC, to which is applied the "zero bit stuffing" procedure, as expected by the standard HDLC protocol.

Data, online received, are directed to the upper level ports. The beginning/ending frame flags and the CRC are, as usually, controlled and the "stuffing" zero bit is removed. Only those frames which pass the controls are sent to upper level ports.

Configuration of the synchronous ports top

The synchronous port is referred by the "SYNC" abbreviation and it has all the parameters described in this chapter.

Here is an example of the SYNC port parameters.

[18:17:22] ABILIS_CPX: D P PO:1

PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V24     CLK:EXT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialization command INIT PO:. The changes made on the LOG: parameter are immediately active.

Details of the SYNC ports parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

INT: | Electric interface
V24 | V24, V35, X21

On a running CPX it specifies which interface module has been installed on the communication board, which is automatically detected at system startup.

In the Off-line configurator it just specifies the "expected" interface or the interface detected the last time the system ran.

V24 is equivalent to EIA RS232 and CCITT V24/V28 interfaces.

CLK: | Synchronism type
EXT | EXT, INT, PCLK, SYM

It sets the synchronism signal (clock) source, which is going to be used for data transmitting and receiving.

The ESB boards have less options than the HSCB ones.

This parameter has also relationship with the line coding type, configured in the parameter CODING:. The following table shows the available combinations between both parameters:

HSCB board

CODING value: | CLK value: | Source:
NRZ, NRZI, MAN, FM0, FM1 | EXT | Tx and Rx clock must be supplied from the outside
NRZ, NRZI, MAN, FM0, FM1 | INT | Tx and Rx clock are generated inside the board and supplied to the outside
NRZ, NRZI | SYM | Tx clock is generated inside the board and be supplied to the outside; Rx clock must be provided by external signal
MAN, FM0, FM1 | PCLK | 625 kbit/sec Tx and Rx clock are generated inside the board

ESB board

CODING value: | CLK value: | Source:
NRZ, NRZI | EXT | Tx and Rx clock must be supplied from the outside
NRZ, NRZI | INT | Tx and Rx clock are generated inside the board and supplied to the outside
NRZ, NRZI | SYM | Tx clock is generated inside the board and supplied to the outside; Rx clock must be provided by external signal
SP: | Speed
2400 | from 2400 up to 2048000 bit/sec.

It sets the internal clock frequency. Refer to the parameter CLK: for its real use.

Binary coding, configurable in the parameter CODING:, also influences the speed. The following table shows the range of "SP" allowed values, according to the parameter "CODING:":

CODING value: | SP value:
NRZ, NRZI | 2400 - 2500000 bit/sec
MAN, FM0, FM1 | 2400 - 156250 bit/sec

Important: if the speed is less than 19.200 bit/sec, SP value should be the same as the real speed, even in case of tx/rx external synchronism (CLK:EXT).

CODING: | Binary coding type
NRZ | NRZ, NRZI, MAN, FM0, FM1

It allows to choose the desired binary coding.

The value "MAN" means the Manchester coding has been chosen, but it requires a suitable interface with a Manchester coder.

This parameter has relationship either with speed (parameter SP:) and the synchronism type (parameter CLK:). The following table shows the allowed combinations of the parameters:

CODING value: | SP value: | CLK value:
NRZ, NRZI | 2400 - 2048000 bit/sec | EXT, INT, SIM
MAN, FM0, FM1 | 2400 - 156250 bit/sec | EXT, INT, PCLK

IDLE: | Way of managing the "Idle" state
FLAG | FLAG, MARK, AUTO

It allows to select how to manage the "Idle" state.

FDCD: | Time interval of the DCD signal stability
500 | 0 - 65535 milliseconds

It sets the time interval necessary to detect the DCD signal state. It is checked every CPU tick (55 milliseconds c.a.) and, in order to avoid detection of useless fluctuations, it is considered valid only if constant during the time interval defined by the parameter.

FCTS: | Time interval of the CTS signal stability
500 | 0 - 65535 (in milliseconds)

It sets the time interval necessary to detect the CTS signal state. It is checked every CPU tick (55 milliseconds c.a.) and, in order to avoid detection of useless fluctuations, it is considered valid only if constant during the time interval defined by the parameter.

MODE: | Half/Full duplex operating mode.
FULL | FULL, HDTE, HDCE

It sets the transmission/receiving mode.

Value | Meaning
FULL | Full duplex mode, the signal RTS is always active.
HDTE | Half duplex-DTE mode, the signal RTS is activated only when each frame has to be sent. The level 1 driver waits the CTS signal to start sending data.
HDCE | Half duplex-DCE, where, once the CTS is received, the RTS one must be activated after the time interval, defined RTSDLY is elapsed..

The parameter "MODE:" is used only to properly check the RTS signal. Actually, Level 1 driver is always able to work in Full duplex mode.

RTSDLY: | Activation delay of the RTS signal (HALF-DCE mode)
0 | 0 - 255

It sets the activation delay of the RTS signal in case of Half duplex-DCE operating mode.

CD: | Checking activation of the signal DCD
NO | NO, YES

It allows to check the signal DCD.

If it is set to "NO", the Level 1 state is "UP".

If it is set to "YES", the Level 1 state is directly depending on the signal DCD state.

FRAME: | Maximum frame length (except Flags and CRC).
2100 | 128 - 2100 bytes

It sets the maximum frame length, excluding Flags and CRC.

D-RXBUF: | Number of receiving buffers
14 | 1 - 255

It sets the number of receiving buffers in use.

DMA-RXBUF: | Number of dma receive buffers.
1 | 1 - 255

It sets the number of dma receive buffers in use.

DMA-TXBUF: | Number of transmission buffers
1 | 1 - 255

It sets the number of transmission buffers in use.

MPX: | VOICE/DATA multiplexing activation.
NO | NO, YES

It allows to activate the VOICE/DATA multiplexing.

Statistics of the synchronous ports top

Example of how to check the state and statistics of SYNC ports through the command D S.

[18:17:22] ABILIS_CPX: D S PO:1

PO:1   ------------------------------------------------------------------------
SYNC   STATE:UP          SP:19200          XTAL:X1-1,8MHz   CARD:ESB
       DTR:UP            DCD:UP            RTS:UP           CTS:UP
       ------------------------------------------------------------------------
       FIFO:USED         TXSIZE:2          RXSIZE:10
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |1364250    |1364138    |FRM        |227367     |227368     |
       CHR-D      |7          |15         |FRM-D      |2          |5          |
       CHR-V      |0          |0          |FRM-V      |0          |0          |
       CHR-C      |1364243    |1364123    |FRM-C      |227365     |227363     |
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       SHORT      |0          |0          |OTHERS     |0          |           |
       LONG-D     |0          |0          |LOST-D     |0          |           |
       LONG-C     |0          |0          |LOST-C     |16         |           |
       LONG-V     |0          |0          |LOST-V     |0          |           |
       CTS-TOUT   |0          |           |
       ------------------------------------------------------------------------

The SYNC ports have no extended statistics, so the execution of the command D SE will show again the not extended statistics in the following format:

[18:17:22] ABILIS_CPX: D SE PO:1

PO:1   ------------------------------------------------------------------------
SYNC   --- Cleared 003:21:49:21 ago, on 12/05/2000 at 12:11:40 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |1364442    |1364330    |FRM        |227399     |227400     |
       CHR-D      |7          |15         |FRM-D      |2          |5          |
       CHR-V      |0          |0          |FRM-V      |0          |0          |
       CHR-C      |1364435    |1364315    |FRM-C      |227397     |227395     |
       RX-OVR     |0          |           |TX-UND     |           |0          |
       BAD-FCS    |0          |           |ABORT      |0          |0          |
       SHORT      |0          |0          |OTHERS     |0          |           |
       LONG-D     |0          |0          |LOST-D     |0          |           |
       LONG-C     |0          |0          |LOST-C     |16         |           |
       LONG-V     |0          |0          |LOST-V     |0          |           |
       CTS-TOUT   |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows either the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and SYNC ports statistics

STATE: | Current state of Level 1 driver
 | DOWN, UP, HALTED

It reports the current state of the SYNC Level 1 driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC | DOWN | The port is not active | dn
 | UP | Level 1 is active | UP
 | HALTED | The port is not working | HT
 | ERR | Software error. Contact Abilis service. | NA
SP: | Exact speed

It reports the exact speed in use.
This is required because not all the values configured in SP: parameter can be precisely generated as internal clock, some rounding is applied and the exact speed is shown here.

XTAL: | Xtal oscillator used to generate internal clocks

It reports the xtal oscillator used to generate internal clocks, for informational purpose only.

CARD: | Card to which the port belongs
 | HSCB, ESB, ESB2

It reports the card to which the port belongs.
The distinction between HSCB and ESB/ESB2 is due to the configuration, while the distinction between ESB and ESB2 depends on the card actually detected by the driver.

DTR: | Current state of the signal DTR
 | DOWN, UP, N/A

It reports the current state of the signal DTR.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (DTR signal) | DOWN | The signal DTR is not active | 0 | dn | 0
 | UP | The signal DTR is active | 1 | UP | 1
 | N/A | The signal state is not available. | 2 | NA | 2
DCD: | Current state of the signal DCD
 | DOWN, UP, N/A

It reports the current state of the signal DCD.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (DCD signal) | DOWN | The signal DCD is not active | 0 | dn | 0
 | UP | The signal DCD is active | 1 | UP | 1
 | N/A | The signal state is not available. | 2 | NA | 2
RTS: | Current state of the signal RTS
 | DOWN, UP, N/A

It reports the current state of the signal RTS.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (RTS signal) | DOWN | The signal RTS is not active |  |  |
 | UP | The signal RTS is active |  |  |
 | N/A | The signal state is not available. |  |  |
CTS: | Current state of the signal CTS
 | DOWN, UP, N/A

It reports the current state of the signal CTS.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
SYNC (CTS signal) | DOWN | The signal CTS is not active |  |  |
 | UP | The signal CTS is active |  |  |
 | N/A | The signal state is not available. |  |  |
FIFO: | State of Level 1 FIFO
 | UNKNOWN, NOTVALID, USED

FIFO state can be one among the followings:

  • UNKNOWN: FIFO has not been identified.

  • NOTVALID: FIFO is not in a valid state.

  • USED: FIFO has been correctly identified and it is in use.

TXSIZE: | Size of the transmitting FIFO
 | HSCB:4096, ESB/ESB2:0-255

The counter TXSIZE reports the size of the transmitting FIFO.

For HSCB it shows the bytes actually available in the on-board transmit fifo, however because of hw contrain just one frame can be placed there.

For ESB and ESB2 it shows the number of frames of frame length that can be stored in the dma transmit buffer.
It is important to note that the default value 2 is the optimum for voice/dat/link-check priority control, while higher value are better for throughput improvement.
Also note that value 0 is used for a special mode required by SDLC driver and when upper port is SDLC this value can't be changed.

RXSIZE: | Size of the receiving FIFO
 | HSCB:4096, ESB/ESB2:1-255

The counter RXSIZE reports the size of the receiving FIFO.

For HSCB it shows the bytes actually available in the on-board receive fifo that can buffer up to 10 frames or up to RXSIZE bytes, whichever is reached first.

For ESB and ESB2 it shows the number of frames of frame length that can be stored in the dma receive buffer. It is important to note that the receive buffering is optimised on 128 chuncks leading to a more effective buffering, example:
RXSIZE=10, FRAME=2100 -> up to 10 frames 2100 bytes long, or up to 164 frames 128 bytes long.

CHR: | Number of received/sent characters.
 | 0 - 4.294.967.295

The counter CHR (INPUT) is incremented every time a frame is received. The counter CHR (OUTPUT) is incremented every time a frame is sent.

FRM: | Number of received/sent frame.
 | 0 - 4.294.967.295

The counter FRM (INPUT) is incremented every time a frame is received. The counter FRM (OUTPUT) is incremented every time a frame is sent.

CHR-D: | Number of received/sent DATA characters
 | 0 - 4.294.967.295

The counter CHR-D (INPUT) is incremented every time a DATA frame is received. The counter CHR-D (OUTPUT) is incremented every time a DATA frame is sent.

CHR-C: | Number of received/sent Link-Check characters
 | 0 - 4.294.967.295

The counter CHR-C (INPUT) is incremented every time a Link-Check frame is received. The counter CHR-C (OUTPUT) is incremented every time a Link-Check frame is sent.

CHR-V: | Number of received/sent VOICE characters
 | 0 - 4.294.967.295

The counter CHR-V (INPUT) is incremented every time a VOICE frame is received. The counter CHR-V (OUTPUT) is incremented every time a VOICE frame is sent.

FRM-D: | Number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter FRM-D (INPUT) is incremented every time a DATA frame is received. The counter FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

FRM-C: | Number of received/sent Link-Check frames
 | 0 - 4.294.967.295

The counter FRM-C (INPUT) is incremented every time a Link-Check frame is received. The counter FRM-C (OUTPUT) is incremented every time a Link-Check frame is sent.

FRM-V: | Number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

RX-OVR: | Number of "overrun" occurred in the communication board.
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time the communication board reports an "overrun" due to the received data.

warning! High values, especially if growing, of this counter could mean either hardware problems of the Abilis CPX or, most probably, communication speed too high.

TX-UND: | Number of "underrun" occurred in the communication board.
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time the communication board reports an "underrun" due to the sent DATA.

warning! High value, especially if growing, of this counter could mean either hardware problems of the Abilis CPX or, most probably, communication speed too high.

BAD-FCS: | Number of received frames with wrong FCS
 | 0 - 4.294.967.295

The counter FCS-I is incremented every time the FCS (or CRC) control of a received frame is unsuccessful.

warning! High values, especially if growing, of this counter could mean a bad quality of the transmission line, corrupting the received data. A bad quality turns into a performance lowering and into possible breaks out of the link.

ABORT: | Number of aborted received frames or aborted during the transmission.
 | 0 - 4.294.967.295

The counter ABORT (INPUT) is incremented every time an "abort" event occurs while a frame is received. The counter ABORT (OUTPUT) is incremented every time an "abort" event occurs while a frame is going to be sent.

warning! High values, especially if growing, of this counter could mean a bad quality of the transmission line, corrupting the received data. A bad quality turns into a performance lowering and into possible breaks out of the link.

SHORT: | Number of too short frames received
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the length of a received frame is smaller than the minimum size (2 bytes without CRC). The counter SHORT (OUTPUT) is incremented if the length of the frame received by upper level is smaller than the minimum size (2 bytes except the CRC).

OTHERS: | Number of unknown events occurred
 | 0 - 4.294.967.295

The counter OTHER is incremented every time other events, not classifiable in the already mentioned, occur.

LONG-D: | Number of too long DATA frames received/sent
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time the DATA frame received by the lower level is too long. The counter LON-D (OUTPUT) is incremented if the DATA frame received by the upper level is too long.

LONG-C: | Number of too long Link-Check frames received/sent
 | 0 - 4.294.967.295

The counter LONG-C (INPUT) is incremented every time the Link-Check frame received by the lower level is too long. The counter LONG-C (OUTPUT) is incremented if the Link-Check frame received by the upper level is too long.

LONG-V: | Number of too long VOICE frame received/sent
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time the VOICE frame received by the lower level is too long. The counter LONG-V (OUTPUT) is incremented if the VOICE frame received by the upper level is too long.

LOST-D: | Number of DATA frames sent and lost
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time a DATA frame is discarded because there are no available receiving buffers.

LOST-C: | Number of Link-Check frames sent and lost
 | 0 - 4.294.967.295

The counter LONG-C (INPUT) is incremented every time a Link-Check frame is discarded because there are no available receiving buffers.

LOST-V: | Number of VOICE frames sent and lost
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time a VOICE frame is discarded because there are no available receiving buffers.

CTS-TOUT: | Number of times the CTS time-out has expired.
 | 0 - 4.294.967.295

The counter CTS-TOUT is incremented every time the CTS time-out expires.

SNMP traps generated for the SYNC ports top

The Abilis CPX Agent sends traps corresponding to the meaningful state changes of the synchronous Level 1.

Trap own code | Trap mnemonic | SNMP variables referred in the trap | Description
29 | cxTrapSyncDown | cxPortIndex, cxPortType, cxSyncDiagState, cxSyncDiagDCD, cxSyncDiagDTR, sysUpTime | This kind of trap is generated by the Agent of Abilis CPX, every time the synchronous Level 1 reaches the DOWN state.
30 | cxTrapSyncUp | cxPortIndex, cxPortType, cxSyncDiagState, cxSyncDiagDCD, cxSyncDiagDTR, sysUpTime | This kind of trap is generated by the Agent of Abilis CPX, every time the synchronous Level 1 reaches the UP state.

Details of the SNMP variables used by SYNC ports

cxPortIndex | SYNC port which the SNMP trap refers to
 | 0 - 999

This variable gives the number of the CPX port which the SNMP trap refers to.

cxPortType | Type and description of the SYNC port which the trap refers to
 | type - description

This variable shows either the port type (in this case SYNC) which the trap refers to, and the description the user could associate to it.

cxSyncDiagState | Level 1 state current of the SYNC port which the trap refers to
 | down(0), up(1), halted(2)

This variable shows the current state of the synchronous Level 1 of the SYNC port which the trap refers to. In the following table is shown the relationship among the state values shown in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Corresponding state of the PAD port Level 1
down(0) | DOWN
up(1) | UP
halted(2) | HALTED

cxSyncDiagDCD | Signal DCD current state of the SYNC port which the trap refers to
 | down(0), up(1), not-available(2)

This variable shows the current state of the SYNC port signal DCD which the trap refers to. In the following table is shown the relationship among the state values stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Corresponding state of the signal DCD
down(0) | DOWN
up(1) | UP
not-available(2) | N/A
cxSyncDiagDTR | Signal DTR current state of the SYNC port which the trap refers to
 | down(0), up(1), not-available(2)

This variable shows the current state of the SYNC port signal DTR which the trap refers to. In the following table is shown the relationship among the state values stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Corresponding state of the signal DTR
down(0) | DOWN
up(1) | UP
not-available(2) | N/A
sysUpTime | Elapsed time since the system started owing to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cents of second) since the system start caused by the event occurrence, which has also generated the SNMP traps. This value is usually stored as days:hours:minutes:seconds.


X.25 level 3 ports

The X.25 level 2 ports (LAPB)

Configuration of the LAPB ports
Statistics of the LAPB ports
SNMP traps generated for the LAPB

The X.25 level 2 communication ports provide the Link Level services to the Network Level X25 ports.

Configuration of the LAPB ports top

The X.25 level 2 port is labelled in the Abilis CPX by the "LAPB" abbreviation and it is provided with the parameters described in the following section.
Here is an example of the LAPB port parameters, all of them are DEFAULT values.

[18:42:32] ABILIS_CPX: D P PO:201 .

PO:201 ------------------------------------------------------------------------
LAPB   LOG:NO       lowpo:1      lapb:DTE       FW:7
       T1:3000      T2:0         T3:0           N1:144       N2:10

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Details of the LAPB ports parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL,+E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log.
S | Recording of the driver state changes and/or the meaningful events in System Log.
A | Periodic detection of possible alarms. The detected alarms can be displayed with the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display of the front panel.
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option.
T | Generation by the SNMP Agent of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events.

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log;
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" e "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

let's suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";

let's suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

Warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

LOWPO: | Identifier of the Abilis CPX lower level port.
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port, which can only be a SYNC, MLM, ML or PLINKE port type.

The value "NONE" is used to isolate the LAPB port

LAPB: | Level 2 DTE/DCE behaviour
DTE | DTE, DCE

It allows to choose the level 2 behaviour between DTE and DCE.

Info The ports of the two devices that faces each other, that is the two ports connected through the line, must be configured complementary. It means that connection will work only if one is DCE and the other is DTE.

Network ports are usually set as DCE therefore user devices ports have to be set as DTE. As a result, Abilis CPX ports connected to a public network will be set as DTE while those connected to a user device will be set to DCE.

This parameter allows to establish a logical link between level 2 DCE and DTE: signal position on the interface connector is modified only changing the interface modules of the proper port and, if necessary, the link cable.

So, remember to implement the physical adaptation using interface modules and, if necessary, suitable cable.

FW: | Frame window size
7 | from 1 up to 7

It sets the size of the Level 2 window.

It must match the value set for the port at the other side of the line.

Usually it is set to 7.

T1: | Timeout for level 2 frames acknowledge
3000 | 200 - 30000 (in milliseconds)

It sets the maximum time to wait between sending a frame and receiving its acknowledge.

T2: | Transmission delay of acknowledge
0 | 0 - 5000 (in milliseconds)

It sets the time to wait for sending the acknowledge frame.

This value is in relationship with the one defined in the parameter T1: through following the rule: T2 < T1/2.

T3: | Polling interval
9000 | 600 - 60000 (in milliseconds)

It sets the time interval for sending connection maintenance frames.

This value is related to the one set in the parameter T1: through the following rule: T3 > T1*2.

N1: | Maximum LAPB frame size
144 | 144 - 2100 bytes

It sets the maximum LAPB frame size.

N2: | Counter of frame repetitions
10 | from 1 up to 99

It sets the maximum number of transmission attempts of level 2 frames before closing the link.

If it runs over, the link is closed and subsequently a new connection attempt occurs.

Statistics of the LAPB ports top

How to check the state and statistics of the LAPB ports by the command D S.

[18:42:32] ABILIS_CPX: D S PO:201 .

PO:201 ------------------------------------------------------------------------
LAPB   STATE:CONNECTED
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |0          | T1-DN     |           |0          |
       REJ        |1          |0          | FRMR      |0          |0          |
       N2-OVER    |           |0          | N1-OVER   |0          |           |
       INFO       |2414       |2419       | BADF      |0          |           |
       UNK-ADD    |0          |           |
       ------------------------------------------------------------------------

Extended statistics are available for LAPB ports too. Here is an example on how to check them using the command D SE :

[18:42:32] ABILIS_CPX: D SE PO:201 .

PO:201 ------------------------------------------------------------------------
LAPB   --- Cleared 027:07:02:55 ago, on 14/04/2000 at 11:07:27 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |0          | T1-DN     |           |0          |
       REP        |0          |0          | INFO      |2414       |2419       |
       RR         |1456       |1688       | RNR       |0          |0          |
       REJ        |1          |0          | FRMR      |0          |0          |
       SABM       |1          |0          | UA        |0          |1          |
       DISC       |0          |0          | RD        |0          |0          |
       DM         |0          |0          | BADF      |0          |           |
       N2-OVER    |           |0          | N1-OVER   |0          |           |
       SHORT      |0          |           | UNK-ADD   |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last statistics clear (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds") computed from the current date/time.

Details of the state fields and statistics of the LAPB ports

STATE: | Current state of the LAPB driver
 | DOWN, DISCONNECTING, FRMR, CONNECTING, CONNECTED, WAITING

This is the current state of the LAPB driver.

Driver | States | Meaning | Values shown in
 |  |  | System Log | Events Log | LCD Display
LAPB | DOWN | Port is not active. | down
 | DISCONNECTING | Waiting for disconnecting. The port sent a DISC frame and it is waiting to receive an UA or DM frame.
 | FRMR | FRMR has been sent. | frmr
 | CONNECTING | Waiting for level 2 connection. The port sent a SABM frame and it is waiting to receive an UA frame. | cg
 | CONNECTED | LAPB is active. The port sent a SABM frame and received an UA frame, or vice versa. | CONN
 | WAITING | The LAPB port is blocked | wait
 | ERR | Software error. Please contact the Abilis assistance. | NA

T1-UP: | Number of times that "T1:" ran over while the port is in the "CONNECTED" state
 | 0 - 4.294.967.295

The counter T1-UP (OUTPUT) is incremented every time the Abilis CPX does not receive, within the time interval set in the parameter T1:, the acknowledge of INFO frame sent while the driver is in the CONNECTED state

Warning! High values, but especially growing, of this counter could mean a bad quality of the transmission line. However they indicate errors in the received data. A bad quality turns into a performance lowering and possible breaks down of the connection.

T1-DN: | Number of times that "T1:" ran over while the port is in the connecting/disconnecting phase
 | 0 - 4.294.967.295

The counter T1-DN (OUTPUT) is incremented every time the Abilis CPX does not receive, within the time interval set in the parameter T1:, the acknowledge of frame sent while the driver is in the connecting/disconnecting phase.

Warning! Since LAPB tries indefinitely to contact the counterpart, this statistic may increase just because the counterpart is switched off. However if you are sure that counterpart should be reachable, increasing value definitely indicates that the LAPB connection cannot be established indicating a line fault or DTE/DCE wrong configuration.

REJ: | Number of REJ frames received/sent
 | 0 - 4.294.967.295

The counter REJ (INPUT) is incremented every time a REJ frame is received, while the counter REJ (OUTPUT) every time a REJ is sent.

Warning! High values, but especially growing, of this counter could mean a bad quality of the transmission line. However they indicate errors in data received by the counterpart which in turn are data transmitted by the local LAPB. A bad quality turns into a performance lowering and possible breaks down of the connection.

FRMR: | Number of FRMR frames received/sent
 | 0 - 4.294.967.295

The counter FRMR (INPUT) is incremented every time Abilis CPX receives a FRMR frame, while the counter FRMR (OUTPUT) every time a FRMR frame is sent.

Warning! FRMR should always be 0 as they signal protocol violations. Every FRMR is always followed by a complete link reset with all X25 channels forcedly closed.

N2-OVER: | Number of times the maximum retransmission number has been reached
 | 0 - 4.294.967.295

The counter N2-OVR (OUTPUT) is incremented every time the maximum retransmission number, set in the parameter N2: has been reached.

N1-OVER: | Number of too long frames received
 | 0 - 4.294.967.295

The counter N1-OVER (INPUT) is incremented every time the port receives a frame, whose size is bigger than the one set in the parameter N1:.

INFO: | Number of INFO frames received/sent
 | 0 - 4.294.967.295

The counter INFO (INPUT) is incremented every time the Abilis CPX receives an INFO frame. The counter INFO (OUTPUT) is incremented every time an INFO frame is sent.

BADF: | Number of unknown frames type received
 | 0 - 4.294.967.295

The counter BADF (INPUT) is incremented every time the Abilis CPX receives a frame, whose type is unknown.

UNK-ADD: | Number of received frames with unknown address
 | 0 - 4.294.967.295

The counter UNK_ADD (INPUT) is incremented every time the Abilis CPX receives a frame, whose address is unknown.

Details of the extended statistics fields of the LAPB ports

T1_UP: These statistics are the same shown in basic command and already explained
T1_DN:
REJ:
FRMR:
N2_OVER:
N1_OVER:
INFO:
BADF:
UNK_ADD:

REP: | Number of times a repeated frame is received/sent.
 | 0 - 4.294.967.295

The counter REP (INPUT) is incremented every time the Abilis CPX receives a repeated frame.

The counter REP (OUTPUT) every time the Abilis CPX repeats the transmission of already sent frames.

RR: | Number of RR frames received/sent
 | 0 - 4.294.967.295

The counter RR (INPUT) is incremented every time a RR frame is received, while the counter RR (OUTPUT) every time a RR frame is sent.

RNR: | Number of RNR frames received/sent
 | 0 - 4.294.967.295

The counter RNR (INPUT) is incremented every time a RNR frame is received, while the counter RNR (OUTPUT) every time a RNR frame is sent.

SABM: | Number of SABM frames received/sent
 | 0 - 4.294.967.295

The counter SABM (INPUT) is incremented every time a SABM frame is received, while the counter SABM (OUTPUT) every time a SABM frame is sent.

UA: | Number of UA frames received/sent
 | 0 - 4.294.967.295

The counter UA (INPUT) is incremented every time a UA frame is received, while the counter UA (OUTPUT) every time a UA frame is sent.

DISC: | Number of DISC frames received/sent
 | 0 - 4.294.967.295

The counter DISC (INPUT) is incremented every time a DISC frame is received, while the counter DISC (OUTPUT) every time a DISC frame is sent.

RD: | Number of RD frames received/sent
 | 0 - 4.294.967.295

The counter RD (INPUT) is incremented every time a RD frame is received, while the counter RD (OUTPUT) every time a RD frame is sent.

DM: | Number of DM frames received/sent
 | 0 - 4.294.967.295

The counter DM (INPUT) is incremented every time a DM frame is received, while the counter DM (OUTPUT) every time a DM frame is sent.

SHORT: | Number of too short frames received
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the port receives a frame, whose size is smaller than the fixed minimum value.

SNMP traps generated for the LAPB top

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
22 | cxTrapLapbDown | cxPortIndex, cxPortType, cxLapbDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the LAPB port driver leaves the CONNECTED state.
23 | cxTrapLapbConnected | cxPortIndex, cxPortType, cxLapbDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the LAPB port driver reaches the CONNECTED state.

Details of the SNMP variables shown in the LAPB port traps

cxPortIndex | X25 port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the LAPB port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case LAPB) and the description eventually associated to it.

cxLapbDiagState | Current state of the X25 port to which the trap refers
 | down(0), connecting(1), disconnecting(2), connected(3), frmr(4), waiting(5)

This variable shows the current state of the LAPB port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Corresponding state in LAPB driver
down(0) | DOWN
connecting(1) | CONNECTING
disconnecting(2) | DISCONNECTING
connected(3) | CONNECTED
frmr(4) | FRMR
waiting(5) | WAITING

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.


The X.25 level 3 ports

The X.25 level 3 ports (X25)

Configuration of the X25 ports
Statistics of the X25 ports
SNMP traps generated for the X25 ports

The X25 ports provide communication services regarding the level 3 of the X.25 protocol.

Configuration of the X25 ports top

The X.25 port is labeled in the Abilis CPX by the "X25" abbreviation and it is provided with the parameters described in the following section.

Here is an example of the X25 port parameters. The shown values are only examples.

[18:38:04] ABILIS_CPX: D P PO:301

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:2     ps:128
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DTE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Details of the X25 ports parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port, which can only be a LAPB or LAPD, EBLAPD or EPLAPD port type.

The value "NONE" is used to isolate the X25 port.

TYPE: | Port type
USER | NETWORK, USER

This parameter sets how the port behaves if data compression is activated.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user device USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

Wrong configuration of this parameter will cause connection to close as soon as data is exchanged. If the error is detected by the user equipment it closes the connection and provides its own X25 diagnostic code, if the error is detected by Abilis CPX it closes the connection providing one of the following diagnostic codes:

  • F0,C2 : Error in the expansion phase

  • F0,C3 : Format of the compressed data not valid

  • F0,AA: Compression protocol not compatible

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

MCAU: | Cause code modification in CLEAR packets sent
NO | NO, YES

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PW: | Default size of the packet window
2 | from 1 up to 7

It sets the default size of the Level 3 window.

It must match the value set for the port at the other side of the line.

warning! Abilis CPX supports packet window negotiation as for X25 recommendation.

PS: | X25 packet size
128 | 16, 32, 64, 128, 256, 512, 1024, 2048

It sets the maximum size (in bytes) of the packets to be sent/received.

warning! Abilis CPX does not support packet size negotiation.

X25: | DTE/DCE behaviour of level 3
DTE | DTE, DCE

It allows to choose the level 3 behaviour between DTE and DCE.

warning! The ports of the two devices that face each other, that is the two ports connected through the line, must be configured complementary. It means that connection will work only if one is DCE and the other is DTE.

Network ports are usually set as DCE therefore user devices ports have to be set as DTE. As a result, Abilis CPX ports connected to a public network will be set as DTE while those connected to a user device will be set to DCE.

The difference between level 3 DTE and DCE consists in the way they manage the logical channels:

  • DTE makes the outgoing calls starting from the higher logical channel, while DCE from the lower;

  • DTE makes calls on OSVC channels and receives them on the ISVC ones;

  • DCE makes calls on ISVC channels and receives them on the OSVC ones:

  • Both make and receive calls on BSVC channels.

fpvc: | Number of the first permanent logical channel
1 | from 1 up to 255

It sets the number of the first permanent logical channel (PVC).

If ISVC: is set to 0, this parameter is meaningless.

fisvc: | Number of the first incoming switched logical channel
1 | from 1 up to 4095

It sets the number of the first ISVC logical channel in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

If ISVC: is set to 0, this parameter is meaningless.

fbsvc: | Number of the first bidirectional switched logical channel
1 | from 1 up to 4095

It sets the number of the first BSVC logical channel in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

If BSVC: is set to 0, this parameter is meaningless.

fosvc: | Number of the first outgoing switched logical channel
11 | from 1 up to 4095

It reports the number of the first OSVC logical channel in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

If OSVC: is set to 0, this parameter is meaningless.

PVC: | Number of permanent logical channels
0 | from 0 up to 255

It sets the number of permanent logical channels (PVC) in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

A wrong setting of this parameter could prevent the activation of PVC connections and the ability of making and receiving calls.

Value 0 means that no PVC is configured.

warning! Permanent channels numbering ALWAYS starts from 1 and it is SEQUENTIAL.

If, for instance, PVC channels 4 and 5 have to be used, while the 1,2,3 ones shall not, then the parameter PVC: has to be set to 5 and in the PVC connection table only the channels 4 and 5 have to be configured.

ISVC: | Number of incoming switched logical channels
0 | from 0 up to 255

It reports the number of ISVC logical channels in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

Value 0 means that no ISVC are configured.

BSVC: | Number of bidirectional switched logical channels
10 | from 0 up to 255

It reports the number of BSVC logical channels in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

Value 0 means that no BSVC are configured.

OSVC: | Number of outgoing switched logical channels
0 | from 0 up to 255

It reports the number of OSVC logical channels in the X.25 connection.

If the port is connected to an X25 network, the value to set is specified in the network provider subscription.

If the port is connected to a user device, the value of the parameter has to match the device configuration.

If this parameter is wrongly set, no calls could be received or made.

Value 0 means that no OSVC are configured.

T20: | Timeout for Restart acknowledge
30 | 0 - 1024 ( in seconds)

Maximum time to wait for receiving a Restart Confirmation after sending a Restart Request.

If it elapses the Restart Request is repeated indefinitely.

T21: | Timeout for Call acknowledge
30 | 0 - 1024 ( in seconds)

Maximum time to wait for receiving a Call Connect or Clear Request, after sending a Call Request.

If it elapses a Clear Request packet is sent with cause and diagnostic 13,31.

T22: | Timeout for Reset acknowledge
30 | 0 - 1024 ( in seconds)

Maximum time to wait for receiving a Reset Confirmation after sending a Reset Request.

If it elapses the behaviour is different for PVC and SVC channels:

  • in PVC, Reset Request is repeated indefinitely.

  • In SVC, Reset Request is repeated up to N3 times, after which a Clear Request packet is sent with cause and diagnostic 13,31.

T23: | Timeout for Clear acknowledge
30 | 0 - 1024 ( in seconds)

Maximum time to wait for receiving a Clear Confirmation after sending a Clear Request.

If it elapses the Clear Request is repeated up to N3 times, after which the call clearing is considered complete.

N3: | Maximum number of packet repetitions
3 | 1 - 99

It sets how many times Clear Request and Reset Request (SVC) can be repeated before reporting an error.

Statistics of the X25 ports top

How to check the state and statistics of the X25 ports by the command D S.

[18:38:04] ABILIS_CPX: D S PO:301

PO:301 ------------------------------------------------------------------------
X25    STATE:READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |0          |0          |
       PCK        |0          |0          |
       ------------------------------------------------------------------------

Extended statistics are also available for X25 ports. Here is an example on how to check them using the command D SE:

[18:38:04] ABILIS_CPX: D SE PO:301

PO:301 ------------------------------------------------------------------------
X25    --- Cleared 003:23:51:21 ago, on 12/05/2000 at 12:11:28 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RES-REQ    |0          |1          |RES-CON    |1          |0          |
       CAL-REQ    |0          |0          |CAL-CON    |0          |0          |
       CLR-REQ    |0          |0          |CLR-CON    |0          |0          |
       RST-REQ    |0          |0          |RST-CON    |0          |0          |
       INT-REQ    |0          |0          |INT-CON    |0          |0          |
       PCK        |0          |0          |SEG        |0          |0          |
       CHAR       |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       BAD-PCK    |0          |           |T20-OVR    |           |0          |
       T21-OVR    |           |0          |T22-OVR    |           |0          |
       T23-OVR    |           |0          |N3-OVR     |           |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows either the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Details of the state fields and X25 ports statistics

STATE: | Current state of the X25 driver
 | DOWN, RESTARTING, RESTARTED, READY, ERR

This is the current state of the X25 driver.

Driver type | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | LCD Display
X25 | DOWN | Port is not active. | down
 | RESTARTING | Waiting level 3 initialisation. The port sent a RESTART Request packet and waits to receive the RESTART Confirmation one. | rstg
 | RESTARTED | Waiting level 3 initialisation. The port received a RESTART Request packet and it is waiting to send a RESTART Confirmation packet. | rstd
 | READY | Level 3 is in the READY state | RDY
 | ERR | Software error. Please contact the Abilis assistance. | NA
SEG: | Number of data segments sent/received.
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the X25 port receives data, while the counter SEG (OUTPUT) every time data are sent.

Segments are calculated on a per packet basis as 64 bytes units; if a packet length is not exactly multiple of 64 bytes, the excess is counted as 1 segment.

CHAR: | Number of characters received/sent per X25 PDU (PDU: Payload Data Units).
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time the X25 port receives data, while the counter CHAR (OUTPUT) every time data are sent.

PCK: | Number of data packet received/sent
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time the X25 port receives data packets, while the counter PCK (OUTPUT) every time it sends them.

Details of the extended statistics fields of the X25 ports

RES-REQ: | Number of RESTART Request received/sent
 | 0 - 4.294.967.295

The counter RES-REQ (INPUT) is incremented every time a RESTART Request is received, while the counter RES-REQ (OUTPUT) every time a RESTART Request is sent.

RES-CON: | Number of RESTART Confirmation received/sent
 | 0 - 4.294.967.295

The counter RES-CON (INPUT) is incremented every time a RESTART Confirmation is received, while the counter RES-CON (OUTPUT) every time RESTART Confirmation is sent.

CAL-REQ: | Number of Call Request received/sent
 | 0 - 4.294.967.295

The counter CAL-REQ (INPUT) is incremented every time a Call Request is received, while the counter CAL-REQ (OUTPUT) every time a Call Request is sent.

CAL-CON: | Number of Call Connect received/sent
 | 0 - 4.294.967.295

The counter CAL-CON (INPUT) is incremented every time a Call Connect is received, while the counter CAL-CON (OUTPUT) every time a Call Connect is sent.

CLR-REQ: | Number of Clear Request received/sent
 | 0 - 4.294.967.295

The counter CLR-REQ (INPUT) is incremented every time a Clear Request is received, while the counter CLR-REQ (OUTPUT) every time a Clear Request is sent.

CLR-CON: | Number of Clear Confirmation received/sent
 | 0 - 4.294.967.295

The counter CLR-CON (INPUT) is incremented every time a Clear Confirmation is received, while the counter CLR-CON (OUTPUT) every time a Clear Confirmation is sent.

RST-REQ: | Number of Reset Request received/sent
 | 0 - 4.294.967.295

The counter RST-REQ (INPUT) is incremented every time a Reset Request is received, while the counter RST-REQ (OUTPUT) every time a Reset Request is sent.

RST-CON: | Number of Reset Confirmation received/sent
 | 0 - 4.294.967.295

The counter RST-CON (INPUT) is incremented every time a Reset Confirmation is received, while the counter RST-CON (OUTPUT) every time a Reset Confirmation is sent.

INT-REQ: | Number of INTERRUPT Request received/sent
 | 0 - 4.294.967.295

The counter INT-REQ (INPUT) is incremented every time a INTERRUPT Request is received, while the counter INT-REQ (OUTPUT) every time a INTERRUPT Request is sent.

INT-CON: | Number of INTERRUPT Confirmation received/sent
 | 0 - 4.294.967.295

The counter INT-CON (INPUT) is incremented every time a INTERRUPT Confirmation is received, while the counter INT-CON (OUTPUT) every time a INTERRUPT Confirmation is sent.

PCK: | Number of data packets received/sent
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time the X25 port receives data packets, while the counter PCK (OUTPUT) every time it sends them.

SEG: | Number of data segments received/sent
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the X25 port receives data, while the counter SEG (OUTPUT) every time data are sent.

Segments are calculated on a per packet basis as 64 bytes units; if a packet length is not exactly multiple of 64 bytes, the excess is counted as 1 segment.

CHAR: | Number of characters received/sent per X25 PDU (PDU: Payload Data Units).
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time the X25 port receives data, while the counter CHAR (OUTPUT) every time data are sent.

RR: | Number of RR received/sent
 | 0 - 4.294.967.295

The counter RR (INPUT) is incremented every time a RR packet is received, while the counter RR (OUTPUT) every time a RR is sent.

RNR: | Number of RNR received/sent
 | 0 - 4.294.967.295

The counter RNR (INPUT) is incremented every time a RNR packet is received, while the counter RNR (OUTPUT) every time a RNR is sent.

REJ: | Number of REJ received/sent
 | 0 - 4.294.967.295

The counter REJ (INPUT) is incremented every time a REJ packet is received, while the counter REJ (OUTPUT) every time a REJ is sent.

BAD-PCK: | Number of unknown packets received
 | 0 - 4.294.967.295

The counter BAD-PCK (INPUT) is incremented every time any unknown packet is received.

T20-OVR: | RESTART timeout
 | 0 - 4.294.967.295

The counter T20-OVR (OUTPUT) is incremented every time the timeout configured in the parameter T20: occurs.

T21-OVR: | CALL timeout
 | 0 - 4.294.967.295

The counter T21-OVR (OUTPUT) is incremented every time the timeout configured in the parameter T21: occurs.

T22-OVR: | RESET timeout
 | 0 - 4.294.967.295

The counter T22-OVR (OUTPUT) is incremented every time the timeout configured in the parameter T22: occurs.

T23-OVR: | CLEAR timeout
 | 0 - 4.294.967.295

The counter T23-OVR (OUTPUT) is incremented every time the timeout configured in the parameter T23: occurs.

N3-OVR: | Number of times the maximum retransmission number has been reached
 | 0 - 4.294.967.295

The counter N3-OVR (OUTPUT) is incremented every time the maximum retransmission number, set in the parameter N3: has been reached.

SNMP traps generated for the X25 ports top

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
31 | cxTrapX25Down | cxPortIndex, cxPortType, cxX25DiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the X25 port driver leaves the READY state.
32 | cxTrapX25Ready | cxPortIndex, cxPortType, cxX25DiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the X25 port driver reaches the READY state.

Details of the SNMP variables shown in the X25 port traps

cxPortIndex | X25 port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the X25 port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case X25) and the description eventually associated to it.

CxX25DiagState | Current state if the X25 port driver which the trap refers to
 | down(0), restarting(1), restarted(2), ready(3)

This variable shows the current state of the X25 port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

SNMP variable value | Corresponding state of the X25 port
down(0) | DOWN
restarting(1) | RESTARTING
restarted(2) | RESTARTED
ready(3) | READY
sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.


The SDLC (SDLC) ports

Configuration of the SDLC ports
Statistics of the SDLC ports
SNMP traps generated for the SDLC ports

The communication ports SDLC are used within the Abilis CPX for converting SDLC frames into QLLC ones and vice versa, according to the IBM specifications.

Configuration of the SDLC port top

The SDLC port is provided with the parameters described in this section.

Here is an example on how to display the SDLC port parameters. The shown values are the default ones.

[15:43:20] ABILIS_CPX: D P PO:321

PO:321 ------------------------------------------------------------------------
SDLC   lowpo:NONE  TYPE:USER     MCAU:NO   ps:2048   pvc:0     bsvc:0
       role:SEC    MAXOUT:7      T1:3000   T2:3000   T5:0      N2:7

If parameter PVC: and/or BSVC: are set to a value bigger than zero, the display will be the following (in the example BSVC:2):

[15:43:20] ABILIS_CPX: D P PO:321

PO:321 ------------------------------------------------------------------------
SDLC   lowpo:NONE  TYPE:USER     MCAU:NO   ps:2048   pvc:0     bsvc:2
       role:SEC    MAXOUT:7      T1:3000   T2:3000   T5:0      N2:7
       PU:0   add:01   PROT:QLLC  n1:2100  GEN:YES    SLOWPOLL:15   LOG:DS
              AC:NO    RTY:INC    TB:6     NRTY:NOMAX

       PU:1   add:02   PROT:QLLC  n1:2100  GEN:YES    SLOWPOLL:15   LOG:NO
              AC:NO    RTY:INC    TB:6     NRTY:NOMAX

If parameter ROLE: is set to "PRI" the visualization will be:

[15:43:20] ABILIS_CPX: D P PO:321

PO:321 ------------------------------------------------------------------------
SDLC   lowpo:NONE  TYPE:USER     MCAU:NO   ps:2048   pvc:0     bsvc:2
       role:PRI    MAXOUT:7      T1:3000   T2:3000   T5:0      N2:7
       QTINFO:*
       PU:0   add:01   PROT:QLLC  n1:2100  GEN:YES    SLOWPOLL:15   LOG:DS
              AC:NO    RTY:INC    TB:6     NRTY:NOMAX               QTCHK:NO
              QXID:TR

       PU:1   add:02   PROT:QLLC  n1:2100  GEN:YES    SLOWPOLL:15   LOG:NO
              AC:NO    RTY:INC    TB:6     NRTY:NOMAX               QTCHK:NO
              QXID:TR

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on low case parameters it is enough to execute the initialisation command INIT PO:. Changes made on the parameter LOG:, of each Physical Unit, are immediately active.

Detail of the SDLC port parameters

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be a SYNC or PLINKE. port.

Value "NONE" isolates the SDLC port from the lower level ones.

TYPE: | Port type
USER | NETWORK, USER

This parameter is used for setting how the port has to behave if data compression is active.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

A configuration error of this parameter will cause the virtual channel to be teared down as soon as data are transmitted. If the user equipment detects the error, it will generate the X25 diagnostic code, while if the Abilis CPX will detect the error, it will tear down the virtual channel using the diagnostic codes F0,C2 (Expansion error) or F0,C3 (Compressed data format not valid) or F0,AA (Compression protocol not compatible).

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PS: | Maximum packet size (bytes)
2048 | 16, 32, 64, 128, 256, 512, 1024, 2048

It sets the maximum size (bytes) of packets to be sent or received.

PVC: | Number of permanent connections
0 | 0 - 16

It sets the number of PVC connections.

BSVC: | Number of bidirectional switched connections
0 | 0 - 16

It sets the number of BSVC connections.

ROLE: | Port role
SEC | SEC, PRI

It sets the port role: Master or Slave.

Value | Meaning
PRI | The Master port controls the connection establishment and polls all the PU configured
SEC | The slave port can only send data after being polled by a SDLC station

MAXOUT: | Maximum number of unacknowledged frames
7 | 1 - 7

It sets the maximum number of frames to be sent without receiving their acknowledgement.

This value is common to all the PU configured.

T1: | Longest idle interval in NRM mode
3000 | 100 - 65535 (milliseconds)

It sets the longest time interval for waiting a polling response in NRM mode (Normal Response Mode).

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

T2: | Longest idle interval in NDM mode
3000 | 100 - 65535 (milliseconds)

It sets the longest time interval for waiting a polling response in NDM mode (Normal Disconnect Mode).

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

T5: | Polling interval
0 | 100 - 65535 (milliseconds)

It sets the time interval between sending a polling frame and its successive ones.

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

N2: | Maximum number of frame repetitions
7 | 0 - 99

It sets the maximum number of consecutive retransmission of the same frame.

QTINFO: | Informative string for the QLLC TEST frames (Only if ROLE:PRI)
* | *, from 1 up to 10 hexadecimal digits

It sets the informative string accepted in the QLLC TEST frames. The value "*" (asterisk) stands for "any string", allowing to accept QLLC TEST frames with any value of the informative strings.

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

Detail of the parameter of the Physical Units SDLC

PU: | Identifier of the Physical Unit
NONE | 0 - 15

It sets the identifier of the PU SDLC.

ADD: | Address of the Physical Unit
0x00 | 0x00 - 0xFE

It sets the address of the PU SDLC.

The value "0x00" is used to disable the PU, in this way it is not activated by the SDLC port.

PROT: | Conversion protocol type
QLLC | QLLC, QLLC2, QSYNC

It sets the conversion protocol type to apply.

N1: | Maximum length of the SDLC frame (Flags and CRC not included)
2100 | 128 - 2100 bytes

It sets the maximum length of the SDLC frame (Flags and CRC not included).

GEN: | DISC/DM frame generation
YES | NO, YES

It enables the generation of DISC/QDICS or DM/QDM frames.

If the parameter is set to "NO", the driver never generates this kind of frame, but it is only received from outside and managed.

SLOWPOLL: | Polling interval for the auto-connection procedure
15 | 1 - 255 (in seconds)

It sets the waiting interval between a connection attempt and its successive one.

This parameter is used by the auto-connection procedure only if the parameter AC: is set to "TEST" or "XID" or "SDLC" or "POLL".

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

AC: | Auto-connection mode
NO | NO, DCD; TEST, XID, SNRM, POLL

It selects the auto-connection mode.

Value | Meaning
NO | No auto-connection procedure is applied
DCD | This auto-connection procedure automatically generates a called whenever the driver leaves the "DOWN" state and reaches the "UP" one. If the call is unsuccessful the port will repeat the call as many times as the value of the parameter RTY:.
TEST XID SNRM POLL | The "autoconnection" procedure is applied as in the "DCD" case, however there are some differences, depending on the port role: - Master: before call generation an unnumbered frame specified (TEST or XID or SNRM or POLL) is sent. If no the acknowledgement frame is not received within the time interval specified in the parameter T2:, the port will wait until the time interval, specified in the parameter SLOWPOLL:, elapses and then start again the procedure. - Slave: before call generation the port has to receive an unnumbered specified frame (TEST or XID or SNRM or POLL).

RTY: | Calls repetition mode
INC | LIN, INC

It allows to select the calls repetition mode.

Value | Meaning
LIN | The time interval to wait, between a call attempt and the successive one, is fixed and configurable through the parameter TB:
INC | The time interval to wait, between a call attempt and the successive one, is doubled at every attempt starting from the value defined in the parameter TB:

TB: | Time interval between calls repetitions
6 | 6 - 255 seconds

It defines the smallest time interval to be waited between a call attempt and its successive one.

NRTY: | Maximum number of call repetitions
0 | 0 - 65534, NOMAX

It specifies the maximum number of call repetitions:

Value | Description
0 | No call is made
NOMAX | Calls are repeated indefinitely
1 - 65534 | Calls are repeated as many times as the configured value

QTCHK: | Activation of the control function of the QLLC TEST frames (Only if ROLE:PRI)
NO | NO, YES

It activates the control function of the QLLC TEST frames.

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

QXID: | Response string for the QLLC XID frames (Only if ROLE:PRI)
TR | from 1 up to 15 hexadecimal digits, TR

It sets a sequence of hexadecimal characters to send in the QLLC XID.

  • If the parameter is set to "TR"...

  • If the parameter contains a sequence of hexadecimal characters, it will be set in the XID frame sent.

This parameter is meaningful only for Master ports, therefore when the parameter ROLE: is set to "PRI".

Statistics of the SDLC ports top

How to check state and statistics of the SDLC ports through the command D S.

[15:43:20] ABILIS_CPX: D S PO:322 .

PO:322 ------------------------------------------------------------------------
SDLC   STATE:N/A
       ------------------------- SDLC PU diagnostics --------------------------
       Pu0 Pu1 Pu2 Pu3 Pu4 Pu5 Pu6 Pu7 Pu8 Pu9 Pu10 Pu11 Pu12 Pu13 Pu14 Pu15
        00  00  00  00  00  00  00  00  00  00   00   00   00   00   00   00
         F   F   F   F   F   F   F   F   F   F    F    F    F    F    F    F
       ------------------------------------------------------------------------
       (QLLC: 0=Down; 1=Ready; 2,3,5=Connected; 7=Calling; 8=Delay; 9=Stopped)
       (PU  : 2=Disconnected(NDM); 3=Connecting; 5=Connected(NRM); F=N/A)
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T3-EXP     |           |0          |UNK-ADD    |0          |           |
       SHORT      |0          |0          |
       ------------------------------------------------------------------------

Extended statistics are available for SDLC ports, here is an example of the command D SE execution:

[15:43:20] ABILIS_CPX: D SE PO:321 .

PO:321 ------------------------------------------------------------------------
SDLC   --- Cleared 004:22:08:51 ago, at 21/05/1999 11:36:46 -------------------
       Pu:0     Add:01                    LAST-UNN-FRAMES IN:00  OUT:00
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       UNK-FRM    |0          |0          |T2-EXP     |0          |           |
       T1-EXP     |           |0          |N2-OVR     |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       CHAR       |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SNRM       |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       RD         |0          |0          |DM         |0          |0          |
       TEST       |0          |0          |XID        |0          |0          |
       ------------------------------------------------------------------------
       Pu:1     Add:02                    LAST-UNN-FRAMES IN:00  OUT:00
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       UNK-FRM    |0          |0          |T2-EXP     |0          |           |
       T1-EXP     |           |0          |N2-OVR     |           |0          |
       REP        |0          |0          |INFO       |0          |0          |
       CHAR       |0          |0          |RR         |0          |0          |
       RNR        |0          |0          |REJ        |0          |0          |
       FRMR       |0          |0          |SNRM       |0          |0          |
       UA         |0          |0          |DISC       |0          |0          |
       RD         |0          |0          |DM         |0          |0          |
       TEST       |0          |0          |XID        |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the SDLC ports

Current state of the SDLC driver
N/A

The SDLC port state is not available, that's why the value "N/A" will be always shown.

T3-EXP: | Number of times the "T3" polling timeout ran over
 | 0 - 4.294.967.295

The counter "T3" is incremented every time the "T3" polling timeout, expected for Slave stations in case of NRM, runs over.

UNK-ADD: | Number of received frames with unknown address
 | 0 - 4.294.967.295

The counter UNK-ADD is incremented every time a frame, whose address is unknown, is received.

SHORT: | Number of too short frames received
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the SDLC driver receives too short frames. The counter SHORT (OUTPUT) is incremented every time the SDLC driver receives, from the upper level, frames too short.

Detail of the state fields of the Physical Unit SDLC

PuXX: | Identifier of the PU SDLC
 | Pu0, Pu1, Pu2, …, Pu15

Identifier of the PU SDLC.

YY: | Address of the PU SDLC
 | 0x00 - 0xFE

Address of the PU SDLC.

The value "0x00" is used to disable the PU. A PU is active only if its address is not 0x00.

Z: | Current state of the PU SDLC
 | 0, 1, 2, 3, 5, 7, 8, 9, F

It shows the numeric value correspondent to the current state of the Physical Unit:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
SDLC (Physical Unit) | 0 | The QLLC is in the DOWN state, it cannot receive or make calls | dn | dn |
 | 1 | The QLLC is in the READY state, it can receive or make calls
 | 2 | The QLLC is in the CONNECTED state, the PU in the DISCONNECTED one (Normal Disconnect Mode)
 | 3 | The QLLC is in the CONNECTED state, the PU in the CONNECTING one
 | 7 | The QLLC is in the CALLING state
 | 8 | The QLLC is in the DELAY state, it can receive calls
 | 9 | The QLLC is in the STOPPED state, it can receive calls | st | st |
 | 5 | The QLLC is in the CONNECTED state, the PU in the CONNECTED one | CN | CN |
 | F | It identifies a not active, not available PU | NA | NA |

Detail of the extended statistics of the Physical Unit SDLC

Pu: | Identifier of the Physical Unit SDLC
 | 0 - 15

Identifier of the Physical Unit SDLC.

Add: | Address of the Physical Unit SDLC
 | 0x00 - 0xFE

Address of the Physical Unit SDLC.

The value "0x00" is used to disable the PU. A PU is active only if its address is not 0x00.

LAST-UNN-FRAMES: | Control field of the last unnumbered frame received/sent
 | 0x00 - 0xFF

The field LAST-UNN-FRAMES IN shows the content of the control field of the last unnumbered frame received, while the LAST-UNN-FRAMES OUT shows the one of the last unnumbered frame sent.

UNK-FRM: | Number of received frames with unknown address
 | 0 - 4.294.967.295

The counter UNK-FRM is incremented every time a frame, whit address unknown, is received.

T2-EXP: | Number of times that "T2:" timeout ran over
 | 0 - 4.294.967.295

The counter T2-EXP (INPUT) is incremented every time the timeout, configured in the parameter T2:, run over.

T1-EXP: | Number of times that "T1:" timeout ran over
 | 0 - 4.294.967.295

The counter T1-EXP (INPUT) is incremented every time the timeout, configured in the parameter T1:, run over.

N2-OVR: | Number of times the maximum retransmission number has been reached
 | 0 - 4.294.967.295

The counter N2-OVR (OUTPUT) is incremented every time the maximum number of retransmission, set in the parameter N2:, is reached.

REP: | Number of repeated frame sent/received
 | 0 - 4.294.967.295

The counter REP (INPUT) is incremented every time the Abilis CPX receives a repeated frame, while the counter REP (OUTPUT) every time a sent frame is repeated.

INFO: | Number of INFO frames received/sent
 | 0 - 4.294.967.295

The counter INFO (INPUT) is incremented every time an INFO frame is received. The counter INFO (OUTPUT) is incremented every time an INFO frame is sent.

CHAR: | Number of characters received/sent
 | 0 - 4.294.967.295

The counter INFO (INPUT) is incremented every time an INFO frame is received. The counter INFO (OUTPUT) is incremented every time an INFO frame is sent.

RR: | Number of RR frames received/sent
 | 0 - 4.294.967.295

The counter RR (INPUT) is incremented every time a RR frame is received, while the counter RR (OUTPUT) every time a RR frame is sent.

RNR: | Number of RNR frames received/sent
 | 0 - 4.294.967.295

The counter RNR (INPUT) is incremented every time a RNR frame is received, while the counter RNR (OUTPUT) every time a RNR frame is sent.

REJ: | Number of REJ frames received/sent
 | 0 - 4.294.967.295

The counter REJ (INPUT) is incremented every time a REJ frame is received, while the counter REJ (OUTPUT) every time a REJ frame is sent.

FRMR: | Number of FRMR frames received/sent
 | 0 - 4.294.967.295

The counter FRMR (INPUT) is incremented every time Abilis CPX receives a FRMR frame, while the counter FRMR (OUTPUT) every time a FRMR frame is sent.

SNRM: | SNRM frames received/sent
 | 0 - 4.294.967.295

The counter SNRM (INPUT) is incremented every a SNRM frame is received, while the counter SNRM (OUTPUT) every time a SNRM frame is sent.

UA: | Number of UA frames received/sent
 | 0 - 4.294.967.295

The counter UA (INPUT) is incremented every time a UA frame is received, while the counter UA (OUTPUT) every time a UA frame is sent.

DISC: | Number of DISC frames received/sent
 | 0 - 4.294.967.295

The counter DISC (INPUT) is incremented every time a DISC frame is received, while the counter DISC (OUTPUT) every time a DISC frame is sent.

RD: | Number of RD frames received/sent
 | 0 - 4.294.967.295

The counter RD (INPUT) is incremented every time a RD frame is received, while the counter RD (OUTPUT) every time a RD frame is sent.

DM: | Number of DM frames received/sent
 | 0 - 4.294.967.295

The counter DM (INPUT) is incremented every time a DM frame is received, while the counter DM (OUTPUT) every time a DM frame is sent.

TEST: | Number of TEST frames received/sent
 | 0 - 4.294.967.295

The counter TEST (INPUT) is incremented every time a TEST frame is received, while the counter TEST (OUTPUT) every time a TEST frame is sent.

XID: | Number of XID frames received/sent
 | 0 - 4.294.967.295

The counter XID (INPUT) is incremented every time a XID frame is received, while the counter XID (OUTPUT) every time a XID frame is sent.

SNMP traps generated for the SDLC ports top

The SNMP Agent of the Abilis CPX sends traps in correspondence of meaningful state changes relating to the Physical Unit of the SDLC ports.

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
24 | cxTrapSdlcPuDown | cxPortIndex, cxPortType, cxSdlcDiagPuIndex, cxSdlcDiagPuAddr, cxSdlcDiagPuState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Physical Unit SDLC reaches the DOWN state
25 | cxTrapSdlcPuStopped | cxPortIndex, cxPortType, cxSdlcDiagPuIndex, cxSdlcDiagPuAddr, cxSdlcDiagPuState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Physical Unit SDLC reaches the STOPPED state
26 | cxTrapSdlcPuConnectedNRM | cxPortIndex, cxPortType, cxSdlcDiagPuIndex, cxSdlcDiagPuAddr, cxSdlcDiagPuState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the Physical Unit SDLC reaches the CONNECTED state (Normal Response Mode)

Detail of the SNMP variables shown in the SDLC port traps

cxPortIndex | SDLC port which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the SDLC port, which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case SDLC) and the description eventually associated to it.

cxSdlcDiagPuIndex | PU identifier of the SDLC port which the trap refers to
 | 0 - 15

PU identifier of the SDLC port which the trap refers to.

cxSdlcDiagPuAddr | PU address of the SDLC port which the trap refers to
 | 0x00 - 0xFE

PU address of the SDLC port which the trap refers to.

cxSdlcDiagPuState | PU current state of the HDLCT port which the trap refers to
 | qllcDown(0), qllcReday(1), qllcConnected-PuDisconnected(2), qllcConnected-PuConnecting(3), qllcConnected-PuConnectedNRM(5), qllcCalling(7), qllcDelay(8), qllcStopped(9), not-available(15)

This variable shows the current state of Physical Unit SDLC which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the PU SDLC
qllcDown(0) | 0
qllcReday(1) | 1
qllcConnected-PuDisconnected(2) | 2
qllcConnected-PuConnecting(3) | 3
qllcConnected-PuConnectedNRM(5) | 5
qllcCalling(7) | 7
qllcDelay(8) | 8
qllcStopped(9) | 9
not-available(15) | F

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


The ports HDLC Transparent (HDLCT)

Configuration of the HDLCT ports
Statistics of the HDLCT ports
SNMP traps generated HDLCT ports

The HDLCT ports provide a simple service of HDLC frames "transparent transport" to their destination, they do not manage any acknowledgement procedure. It means, for a correct use of this service, proper transmission timeouts have to be set.

Configuration of the HDLCT ports top

The HDLC transparent port is labelled within the Abilis CPX with the acronym "HDLCT" and it is provided with the parameters described in this section.

Here is an example on how to display the HDLCT port parameters. Shown values are the default ones.

[15:03:33] ABILIS_CPX: D P PO:341 .

PO:341 ------------------------------------------------------------------------
HDLCT  LOG:ALL     lowpo:1     TYPE:USER     MCAU:NO   ps:2048     vc:BSVC
       n1:2100     AC:NO       RTY:INC       TB:6      NRTY:1      DT:0
       rxbuf:1     txbuf:14

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on low case parameters it is enough to execute the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the HDLCT port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port.

The value "NONE" isolates the HDCLT port from the lower level ones.

TYPE: | Port type
USER | USER

The port connected to the network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The HDLCT port can be only USER.

MCAU: | Cause code modification in CLEAR packets sent
NO | NO, YES

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PS: | Packet size (bytes)
2048 | 16, 32, 64, 128, 256, 512, 1024, 2048

It sets the maximum size (bytes) of packets to be sent or received.

VC: | Type of logical channel
BSVC | BSVC, PVC

It sets the connection type: BSVC=bidirectional switched, PVC= bidirectional permanent.

N1: | Maximum HDLCT frame size (CRC not included)
2100 | 128 - 2100 bytes

It sets the maximum size (bytes) of HDLCT frames to be sent or received, CRC is not included.

AC: | Autoconnection mode
NO | NO, DCD, DATA

It sets how the port behaves during the connection set up.

Value | Description
NO | No "autoconnection" procedure is enabled and the connection is established only because of requests calls
DCD | The "autoconnection" procedure is used: the HDLCT driver, whenever it reaches the READY state, will start to set up the connection
DATA | The "autoconnection" procedure is used: the HDLCT driver will start to set up the connection, only if a frame is received

RTY: | Calls repetition mode
INC | LIN, INC

It allows to select the calls repetition mode.

Value | Description
LIN | The time interval to wait, between a call attempt and the successive one, is fixed and configurable through the parameter TB:
INC | The time interval to wait, between a call attempt and the successive one, is doubled to every attempt starting from the value defined in the parameter TB:

If the connection type is PVC (that is parameter VC: set to "PVC") the value of the parameter "RTY:" is ignored.

TB: | Time interval between calls repetitions
6 | 6 - 255 seconds

It defines the smallest time interval to be waited between a call attempt and its successive one.

If the connection type is PVC (that is parameter VC: set to "PVC") the value of the parameter "RTY:" is ignored.

NRTY: | Maximum number of call repetitions
0 | 0 - 65534, NOMAX
Value | Description
0 | No call is made
AUTO | Calls are repeated indefinitely
1 - 65534 | Calls are repeated as many times as the configured value

If the connection type is PVC (that is parameter VC: set to "PVC") the value of the parameter "RTY:" is ignored.

DT: | Disconnection Timeout
0 | 0 - 255 minutes

Every time the HDLCT driver is in its "CONNECTED" state and no frames are exchanged from both directions for longer than this parameter value, connection will teared down with codes F0,D0 and the driver will reach the "READY" state.

If the connection type is PVC (that is parameter VC: set to "PVC") the value of the parameter "RTY:" is ignored.

RXBUF: | Number of receiving buffers
1 | 1 - 255

It sets the number of receiving buffers.

TXBUF: | Number of transmission buffers
14 | 1 - 255

It sets the number of transmission buffers.

Statistics of the HDLCT ports top

How to check state and statistics of the HDLCT ports by the command D S.

[15:03:33] ABILIS_CPX: D S PO:341 .

PO:341 ------------------------------------------------------------------------
HDLCT  STATE:READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |FRAME      |0          |0          |
       CHAR       |0          |0          |
       ------------------------------------------------------------------------

Extended statistics are not available for HDLCT ports. The command D SE execution will display again the not extended statistics by the following format:

[15:03:33] ABILIS_CPX: D SE PO:341

PO:341 ------------------------------------------------------------------------
HDLCT  --- Cleared 000:00:01:38 ago, on 01/01/1997 at 01:50:31 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |FRAME      |0          |0          |
       CHAR       |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of state parameters and statistics of the HDLCT ports

STATE: | Current state of the driver HDLCT
 | DOWN, READY, READY-DELAYED, STOPPED, CALLING, CONNECTED, CLEARING, ERR
Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
HDLCT | DOWN | Port is active | DN
 | READY | Port is active, but the Level 2 is not connected | RD
 | READY-DELAY | Waiting for level 2 connecting. A SABM frame has been sent and the driver is waiting to receive an UA frame
 | STOPPED | Port is blocked | ST
 | CALLING | Waiting for disconnecting; a DISC frame has been sent and the driver is waiting to receive a DM or UA frame | CL
 | CONNECTED | Level 2 is active; a SABM frame has been sent and an UA one was received or the SABM was received and the UA one sent | CN
 | CLEARING | A FRMR frame has been sent | CR
 | ERR | Software error. Contact Abilis assistance. | NA

SEG: | Number of data segments received/sent
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the HDLCT port receives data, while the counter SEG (OUTPUT) every time data are sent.

Segments are calculated on a per packet basis as 64 bytes units.

FRAME: | Number of frames received/sent
 | 0 - 4.294.967.295

The counter FRAME (INPUT) is incremented every time the HDLCT port receives one frame, while the counter FRAME (OUTPUT) every time a frame is sent.

CHAR: | Number of characters received/sent
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time the HDLCT port receives data, while the counter CHAR (OUTPUT) every time data are sent.

SNMP traps generated for the HDLCT ports top

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
33 | cxTrapHdlctDown | cxPortIndex, cxPortType, cxHdlctDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the HDLCT port leaves the READY or READY-DELAY or CALLING or CONNECTED or CLEARING state and reaches one of the following states: DOWN or STOPPED
34 | cxTrapHdlctUp | cxPortIndex, cxPortType, cxHdlctDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the HDLCT port leaves one of the following states: DOWN or STOPPED and reaches the READY or READY-DELAY or CALLING or CONNECTED or CLEARING state

Detail of the SNMP variables shown in the HDLCT port traps

cxPortIndex | HDLCT port which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the HDLCT port, which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case HDLCT) and the description eventually associated to it.

cxHdlctDiagState | Current state of the HDLCT port driver which the trap refers to
down(0), ready(1), ready-delay(2), stopped(3), calling(4), connected(5), clearing(6) |

This variable shows the current state of the HDLCT port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the HDLCT driver
down(0) | DOWN
ready(1) | READY
ready-delay(2) | READY-DELAY
stopped(3) | STOPPED
calling(4) | CALLING
connecteded(5) | CONNECTED
clearing(6) | CLEARING

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


The Frame Relay (FR) ports

Configuration of the fr port
Statistics of the FR ports
SNMP traps generated for the fr ports
SNMP traps generated for the DLCIs of the FR ports

Configuration of the FR port top

The Frame Relay ports are labelled within the Abilis CPX by the acronym "FR" and they are provided with the parameters described in this section.

Here is an example on how to display the FR port parameters. Shown values are the default ones:

[15:03:33] ABILIS_CPX: D P PO:101 .

PO:101 ------------------------------------------------------------------------
FR     LOG:DS      lowpo:1     SIDE:USER-UNI     header:2  pvc:1   STD:ANSI
       LMI:NO      LMIBAL:NO   AR:64000
       T391:10     T392:15     N391:6            N392:3    N393:4

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialization command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the FR port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be a SYNC or MLM port.

Value "NONE" isolates the FR port.

SIDE: | FR port behaviour
USER-UNI | USER-UNI, NETWORK-UNI

It sets how the FR port behaves.

If the parameter is set to "USER-UNI", the port will behave as user side of the User-to-Network (UNI) connection.

If the parameter is set to "NETWORK-UNI", the port will behave as network side of the User-to-Network (UNI) connection.

HEADER: | Header length
2 | 2 - 4 in bytes

It sets the header size (bytes) whose value must match the one of the connected device.

Changes of the header will modify the DLCI valid values:

Header length | DLCI valid values
2 bytes | 16 - 991
3 bytes | 1024 - 63487
4 bytes | 131072 - 8126463

PVC: | Number of permanent channels
1 | 0 - 64

This parameter set the number of permanent channels (PVC), therefor the DLCIs, that the FR port allows to use at the same time.

AR: | Access rate
64000 | 19200 - 2500000 in bits/sec

It has to be set depending on the real line rate. Only right value can cause the proper reaction to congestion signaling, jointly with parameters CIR, BC, BE, CC, SC configured in MLM ports.

LMI: | Activation of LMI procedure (Local Management Interface)
NO | NO, YES

The procedure LMI allows, within limits, monitoring connection state through message exchange over the DLCI 0.

This procedure can be "monodirectional/unbalanced" or "bidirectional/balanced".

In the LMI unbalanced procedure the user side (USER-UNI) queries the network one (NETWORK_UNI) through periodic messages of Status-Enquiry/Link-Integrity[ [1]] and Status-Enquiry/Full-Status [[2]], more exactly every N391 requests of LINK INTEGRITY it sends a FULL STATUS request.

In the LMI balanced procedure ENQUIRY messages are sent from both equipments and both of them must answer by messages of Status/Link-Integrity[ [3]] and Status/Full-Status[ [4]].

LMIBAL: | Activation of the LMI balanced procedure (Local Management Interface)
NO | NO, YES

This parameter is valid only if the procedure LMI is active.

If it is set to "NO", in spite of the "bidirectional/balanced" procedure, the "monodirectional/unbalanced" on will be used.

STD: | Standard protocol selection
ANSI | ANSI, CCITT

This parameter is valid only if the procedure LMI is active.

It selects the standard protocol between ANSI Annex-D and ITU/CCITT X.36.

T391: | Delay between sending a Status-Enquiry/Link-Integrity message and its next one
10 | 5 - 30 (in seconds)

This parameter is valid only if the procedure LMI is active.

T392: | Timeout for receiving the Status-Enquiry messages.
15 | 5 - 30 (in seconds)

This parameter is valid only if the procedure LMI is active.

It sets the maximum time interval for waiting, after receiving a Status-Enquiry message, the next one in order to not consider it as an error.

This parameter is meaningful in the following cases: NETWORK.UNIUSER-UNI and LMIBAL:YES.

N391: | Number of Status-Enquiry-Link-Integrity after which a Status-Enquiry/Full-Status message is sent
6 | 1 - 255

This parameter is valid only if the procedure LMI is active.

N392: | Maximum number of errors during the LMI procedure
3 | 1 - 10

This parameter is valid only if the procedure LMI is active.

Jointly with the parameter N393, it sets the error threshold above which the link reaches the error state (LMI-DOWN).

N393: | Number of events monitored during the LMI procedure
4 | 1 - 10

This parameter is valid only if the procedure LMI is active.

It sets the number of events to be controlled: on them it is based the number of errors set in the parameter N392.

If over N393 events there are N392 or more errors, the link reaches the error state (LMI-DOWN).

Statistics of the FR ports top

How to check the state and statistics of the FR ports by the command D S.

[15:03:33] ABILIS_CPX: D S PO:101 .

PO:101 ------------------------------------------------------------------------
FR     STATE:LMI-UP
       DLCI     State     Cong       MaxThr CurMaxThr  5sec-Thr-Out 5sec-Thr-In
                                  StepConst   MaxThr%  5min-Thr-Out 5min-Thr-In
                                       Step      Cir%  MaxFrame-Out MaxFrame-In
       ------------------------------------------------------------------------
       16       ACT       NO          64000     64000            40          40
                                        N/A      100%            40          40
                                        N/A       N/A            10          10
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---
       FRAMES     |786        |778        |LMI-POLL   |84         |0          |
       NO-DLCI    |0          |           |LMI-F-POLL |19         |0          |
       LONG       |0          |0          |LMI-NOANS  |0          |           |
       SHORT      |0          |0          |LMI-BAD    |0          |           |
       CLLM       |0          |0          |N392_U_OVR |0          |           |
       BAD-CLLM   |0          |           |N392_N_OVR |0          |           |
       T392-EXP   |0          |           |
       ------------------------------------------------------------------------

Extended statistics are available for FR ports too. Here is an example on how to check them using the command D SE:

[15:03:33] ABILIS_CPX: D SE PO:101 .

PO:101 ------------------------------------------------------------------------
FR     --- Cleared 000:00:17:36 ago, on 01/01/1997 at 17:49:36 ----------------
       DLCI:16
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHAR       |21         |5566       |FRM-D      |4          |4          |
       LONG-D     |0          |           |FRM-V      |0          |0          |
       LONG-V     |0          |           |FRM-C      |701        |693        |
       LONG-C     |0          |           |BECN       |0          |           |
       LOST-D     |0          |           |BECN-THR   |0          |           |
       LOST-V     |0          |           |FECN       |0          |           |
       LOST-C     |6          |           |FECN-THR   |0          |           |
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FRAMES     |812        |804        |LMI-POLL   |87         |0          |
       NO-DLCI    |0          |           |LMI-F-POLL |20         |0          |
       LONG       |0          |0          |LMI-NOANS  |0          |           |
       SHORT      |0          |0          |LMI-BAD    |0          |           |
       CLLM       |0          |0          |N392_U_OVR |0          |           |
       BAD-CLLM   |0          |           |N392_N_OVR |0          |           |
       T392-EXP   |0          |           |
       ------------------------------------------------------------------------

As the following example shows, through the command D SE, it is also possible to display the extended statistics of the single DLCI.

[15:03:33] ABILIS_CPX: D SE PO:101 DLCI:16

PO:101 --- Cleared 000:00:18:11 ago, on 01/01/1997 at 17:49:36 ----------------
       DLCI:16
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHAR       |21         |5758       |FRM-D      |4          |4          |
       LONG-D     |0          |           |FRM-V      |0          |0          |
       LONG-V     |0          |           |FRM-C      |725        |717        |
       LONG-C     |0          |           |BECN       |0          |
       LOST-D     |0          |           |BECN-THR   |0          |           |
       LOST-V     |0          |           |FECN       |0          |           |
       LOST-C     |6          |           |FECN-THR   |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of FR ports

STATE: | FR driver current state
 | DOWN, LMI-DOWN, LMI-UP, BLIND, ERR

It shows the FR driver current state.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
FR | DOWN | The FR port is not active due to errors signaled by the "lower port" | dn
 | LMI-DOWN | The Fr port is not active due to LMI procedure errors | L-dn
 | LMI-UP | The FR port is active WITH LMI procedure | L-UP
 | BLIND | The FR port is active WITHOUT LMI procedure | BLND
 | ERR | Software error. Contact Abilis assistance. | NA

FRAMES: | Number of received/sent frames
 | 0 - 4.294.967.295

The counter FRAMES shows the number of received (INPUT) and sent (OUTPUT) frames.

NO-DLCI: | Number of received frames with an unknown DLCI
 | 0 - 4.294.967.295

The counter NO-DLCI (INPUT) shows the number of received frames with an unknown DLCI identifier.

LONG: | Number of too long received/sent frames
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time the received frame is longer than the allowed value. The counter LONG (OUTPUT) is incremented if the upper level port, i.e. MLM, requests to send a frame, whose length is bigger than the allowed maximum value.

In the actual implementation the value of this counter has always to be "0", however if a different value is going to be set, please contact the technical support.

SHORT: | Number of too short received/sent frames
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the received frame is shorter than the minimum value. The counter SHORT (OUTPUT) is incremented if the upper level port, i.e. MLM, requests to send a frame, whose length is smaller than the allowed minimum value.

In the actual implementation the value of this counter has always to be "0", however if a different value is going to be set, please contact the technical support.

LMI-POLL: | Number of LMI polling frames sent and received
 | 0 - 4.294.967.295

The counter LMI-POLL shows the number of LMI (Local Management Interface) request messages of link state (LINK INTEGRITY) received (INPUT) and sent (OUTPUT).

LMI-F-POLL: | Number of LMI polling frames sent and received
 | 0 - 4.294.967.295

The counter LMI-F-POLL shows the number of LMI (Local Management Interface) request messages of complete state (FULL STATUS) received (INPUT) and sent (OUTPUT).

LMI-NOANS | Number of unanswered LMI polling messages
 | 0 - 4.294.967.295

The counter LMI-NOANS (INPUT) shows the number of answers missing to LMI (Local Management Interface) messages of STATUS ENQUIRY sent.

LMI-BAD: | Number of LMI invalid frames received
 | 0 - 4.294.967.295

The counter LMI-BAD (INPUT) shows the number of LMI (Local Management Interface) invalid messages received.

N392-U-OVR: | Number of times the N392 parameter value has been reached (USER SIDE)
 | 0 - 4.294.967.295

The counter N392-U-OVR (INPUT) shows how many times, on the user connection side, the value of the error counter N392 has been reached.

N392-N-OVR: | Number of times the N392 parameter value has been reached (NETWORK SIDE)
 | 0 - 4.294.967.295

The counter N392-N-OVR (INPUT) shows how many times, on the network connection side, the value of the error counter N392 has been reached.

CLLM: | Number of received/sent CLLM frames
 | 0 - 4.294.967.295

The counter CLLM shows the number of CLLM (Consolidated Link Layer Management) messages received (INPUT) and (OUTPUT) sent.

BAD_CLLM: | Number of CLLM invalid frames received
 | 0 - 4.294.967.295

The counter BAD-CLLM (INPUT) shows the number of invalid CLLM (Consolidated Link Layer Management) messages received.

T392-EXP: | Number of times the T932 time-out ran over
 | 0 - 4.294.967.295

The counter T932-EXP (INPUT) shows how many times the time-out, configured in the parameter "T932:", run over.

Detail of the state fields and statistics of FR DLCIs

DLCI: | DLCI identifier
 | 16 - 991, 1024 - 63487, 131072 - 8126463

DLCI identifier.

STATE: | DLCI current state
 | DOWN, LMI-DOWN, IDLE, NP, ACT, ACT-NEW, INACT, INACT-NEW, BLIND, REMOVED, ERR

It shows the DLCI current state.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
FR (DLCI) | N/U | The DLCI correspondent to this identifier is not in use | nu | nu |
 | DOWN | The DLCI is not active because the lower level port is not "UP" | dn | dn |
 | LMI-DOWN | The DLCI is not active because the LMI procedure shut down the link
 | IDLE | DLCI idle state due to the "refresh" procedure. IT lasts few seconds | id | id |
 | NP | The DLCI correspondent to this identifier is not present | np | np |
 | ACT | DLCI is active | AC | AC |
 | ACT-NEW | DLCI is active, it has been configured a short time ago
 | INACT | DLCI is inactive | in | in |
 | INACT-NEW | DLCI is inactive, it has been configured a short time ago
 | BLIND | DLCI is active, but the LMI procedure is not in use | BL | BL |
 | REMOVED | The DLCI has been just removed | rm | rm |
 | ERR | Software error. Contact Abilis assistance. | NA | NA |

CONG: | Current congestion level
 | NO, NORMAL, MINIMUM, MEDIUM, HIGH, SEVERE, UNKNOWN

It shows the current congestion level detected:

Value | Meaning
NO | NO congestion detected. CIR can exceed.
NORMAL | Normal congestion level detected. CIR has to be limited
MINIMUM | Minimum congestion level detected
MEDIUM | Medium congestion level detected
HIGH | High congestion level detected
SEVERE | Severe congestion level detected
UNKNOWN | System is not able to estimate the current congestion level

StepConst | Value of the constant for the congestion level estimation
 | 1..65535, N/A
Step | Interval for the congestion level estimation
 | 1..65535, N/A
MaxThr | Maximum throughput (bit/sec)
 | 0 - 4.294.967.295

It is, in bit/sec, the maximum throughput reachable according to the configuration.

It is mathematically obtained as CIR + BE/tc, where tc stands for the measuring interval (BC/CIR).

In other words, MaxThr = CIR ( 1 + BE/BC ).

CurMaxThr | Current maximum throughput (bit/sec)
 | 0 - 4.294.967.295

It is, in bit/sec, the maximum throughput reachable according to the current congestion level.

MaxThr% | Percentage ratio between the maximum throughput and the current maximum throughput
 | 0 - 100

It is the percentage ratio between the parameters value CurMaxThr and MaxThr.

Cir% | Percentage ratio between the maximum throughput and the parameter CIR
 | 0-9999, N/A

It is the percentage ratio between the parameters value CurMaxThr and CIR.

Values, smaller than 100%, mean the network is not providing the guaranteed service (CIR) and if it goes on, it means that, owing to a bad configuration, the quality of the FR network is less than the established threshold.

5sec-Thr-Out | Output throughput during the last 5 seconds
 | 0 - 4.294.967.295

It shows, in bit/sec, the output throughput during the last 5 seconds.

5sec-Thr-In | Input throughput during the last 5 seconds
 | 0 - 4.294.967.295

It shows, in bit/sec, the input throughput during the last 5 seconds.

5min-Thr-Out | Output throughput during the last 5 minutes
 | 0 - 4.294.967.295

It shows, in bit/sec, the output throughput during the last 5 minutes.

5min-Thr-In | Input throughput during the last 5 minutes
 | 0 - 4.294.967.295

It shows, in bit/sec, the input throughput during the last 5 minutes.

MaxFrame-Out | Longest frame sent
 | 0 - 2100 (in bytes)

It shows the length of the longest frame sent.

MaxFrame-In | Longest frame received
 | 0 - 2100 (in bytes)

It shows the length of the longest frame received.

Detail of the state fields and extended statistics of the FR DLCIs

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR shows the number of received/sent characters.

FRM-D: | Number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter FRM-D shows the number of received/sent DATA frames.

FRM-C: | Number of received/sent Link-Check frames
 | 0 - 4.294.967.295

The counter FRM-C shows the number of received/sent Link-Check frames.

FRM-V: | Number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter FRM-V shows the number of received/sent VOICE frames.

LONG-D: | Number of too long DATA frames received/sent
 | 0 - 4.294.967.295

The counter LONG-D shows the number of too long DATA frames received (INPUT) and sent (OUTPUT).

LONG-C: | Number of too long Link-Check frames received/sent
 | 0 - 4.294.967.295

The counter LONG-C shows the number of too long Link-Check frames received (INPUT) and sent (OUTPUT).

LONG-V: | Number of too long VOICE frames received/sent
 | 0 - 4.294.967.295

The counter LONG-V shows the number of too long VOICE frames received (INPUT) and sent (OUTPUT).

LOST-D: | Number of lost DATA frames
 | 0 - 4.294.967.295

The counter LOST-D shows the number of lost DATA frames.

LOST-C: | Number of lost Link-Check frames
 | 0 - 4.294.967.295

The counter LOST-C shows the number of lost Link-check frames.

LOST-V: | Number of lost VOICE frames
 | 0 - 4.294.967.295

The counter LOST-VC shows the number of lost VOICE frames.

BECN: | Number of frames with backward explicit congestion notification
 | 0 - 4.294.967.295

The counter BECN (INPUT) shows the number of frames with backward explicit congestion notification.

BECN-THR: | Number of times the BECN frames threshold has been reached
 | 0 - 4.294.967.295

The counter BECN-THR (INPUT) shows how many times the BECN frames threshold has been reached.

FECN: | Number of frames with forward explicit congestion notification
 | 0 - 4.294.967.295

The counter FECN (INPUT) shows the number of frames with forward explicit congestion notification.

FECN-THR: | Number of times the FECN frames threshold has been reached
 | 0 - 4.294.967.295

The counter FECN-THR (INPUT) shows how many times the FECN frames threshold has been reached.

SNMP traps generated for the FR ports top

Trap own code | Trap Mnemonic | SNMP variables shown in the trap | Description
37 | cxTrapFrDown | cxPortIndex, cxPortType, cxFrDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the FR port driver leaves the UP state and reaches one of the states: DOWN or TXDISABLED or HALTED or FAILED or NEGOTIATING
38 | cxTrapFrUp | cxPortIndex, cxPortType, cxFrDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the FR port driver leaves one of the states: DOWN or TXDISABLED or HALTED or FAILED or NEGOTIATING and reaches the UP state

Detail of SNMP variables shown in the FR port traps

cxPortIndex | FR port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the FR port which the trap refers to
 | 0 - 4.294.967.295

This variable shows either the port type which the trap refers to (in this case FR) and the description eventually associated to it.

cxFrDiagState | Current state if the FR port driver which the trap refers to
 | down(0), lmi-down(1), lmi-up(2), blind(3)

This variable shows the current state of the FR port driver which the trap refers to. The following table shows the correspondence among the state value stored in the SNMP variable and the ones obtained executing the command D S.

SNMP variable value | Correspondent state of the FR port driver
down(0) | DOWN
lmi-down(1) | LMI-DOWN
lmi-up(2) | LMI-UP
blind(3) | BLIND

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

SNMP traps generated for DLCIs of FR ports top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
47 | cxTrapFrDlciDown | cxPortIndex, cxPortType, cxFrDiagDlciNum, cxFrDiagDlciState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR port reaches one of the states: DOWN or LMI-DOWN
48 | cxTrapFrDlciActive | cxPortIndex, cxPortType, cxFrDiagDlciNum, cxFrDiagDlciState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR port reaches one of the states: ACTIVE or ACTIVE-NEW
49 | cxTrapFrDlciBlind | cxPortIndex, cxPortType, cxFrDiagDlciNum, cxFrDiagDlciState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR port reaches the state: BLIND
50 | cxTrapFrDlciInactive | cxPortIndex, cxPortType, cxFrDiagDlciNum, cxFrDiagDlciState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR port reaches one of the states: INACTIVE or INACTIVE-NEW
51 | cxTrapFrDlciNotPresent | cxPortIndex, cxPortType, cxFrDiagDlciNum, cxFrDiagDlciState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR port reaches the state: NOT-PRESENT
52 | cxTrapFrDlciRemoved | cxPortIndex, cxPortType, cxFrDiagDlciNum, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a DLCI of a FR is removed

Detail of the SNMP variables shown in traps of DLCIs FR ports

cxPortIndex | FR port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the FR port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case FR) and the description eventually associated to it.

cxFrDiagDlciNum | DLCI number
 | 16 - 991, 1024 - 63487, 131072 - 8126463

This variable shows the DLCI identifier of the FR port which the trap refers to.

cxFrDiagDlciState | DLCI current state
 | not-used(0), down(1), lmi-down(2), idle(3), np(4), act(5), act-new(6), inact(7), inact-new(8), blind(9), removed(10)

This variable shows the current state of the DLCI which the trap refers to. The following table shows the correspondence among the state value stored in the SNMP variable and the ones obtained executing the command D S.

SNMP variable value | Correspondent DLCI state
not-used(0) | N/U
down(1) | DOWN
lmi-down(2) | LMI-DOWN
idle(3) | IDLE
np(4) | NP
act(5) | ACT
act-new(6) | ACT-NEW
inact(7) | INACT
inact-new(8) | INACT-NEW
blind(9) | BLIND
removed(10) | REMOVED

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown in SNMP consoles as days:hours:minutes:seconds.

[1] Status-Enquiry/Link-Integrity: this message is used whether the link is working.

[2] Status-Enquiry/Full-Status: this message is used to query the other equipment the current state of all DLCIs it knows and at the same time it performs the same functionalities of Status-Enquiry/Link-Integrity messages.

[3] Status/Link-Integrity: it is used as answer to a Status-Enquiry/Link-Integrity only for checking whether the link is working.

[4] Status/Full-Status: this message is used for communicating to the other equipment the current state of all the known DLCIs and at the same time it performs the same functionalities of Status-Enquiry/Link-Integrity messages. If no DLCI is in the message, it means it is not configured.


The Multi Link Manager ports (MLM)

Revised for CPX 4.1.0.
Terminology
Goal
Configuration of the MLM ports
Statistics of the MLM ports
SNMP traps generated for the MLM port

Terminology top

P-LINK
It stands for Permanent link and defines a permanent connection toward the remote device.
It also defines a kind of "logical" interface in the CPX that several drivers can emulate.
S-LINK
It stands for Switched link and defines a switched connection toward the remote device. A switched connection is established only upon request. It also defines the kind of "logical" interface offered in the CPX by EIR and Q931 drivers.
Link-check
It is a MLM/ML procedure used to detect end-to-end link (or emulated p-link) real functioning, regardless of the lower protocol layers states.
It consists of periodical link-check frames exchange.
Dial-on-Demand
It is a feature that allows to establish Switched connections as soon as there are data to send.
Short-Hold-Mode
This feature makes Switched connections appear as permanent ones: connection is automatically established as soon as there are data to send and automatically closed after a configurable inactivity time.
The procedure is transparent for the applications, that is sessions are not aware of connections/disconnections.
True link backup
When MLM is configured with both P-LINK and S-LINK lower ports, it will use P-LINK whenever the end-to-end P-LINK connection is functioning and will use S-LINK only in case of P-LINK failure.
The True link backup name is justified by the use of an end-to-end protocol that verifies P-LINK integrity (the previously described Link-Check), extending the lower protocol layers diagnostics which are often imprecise, moreover the P-LINK is continuosly monitored so that when the failure ends P-LINK will be automatically reused and S-LINK connection closed. If timeouts are properly set the applications will not notice the link changes.

Goal top

Multi-Link Manager (MLM) basic concepts.

The MLM driver is a very versatile driver. Originally devised as an intermediate layer to offer switched services for ISDN B-Channels to drivers and protocols that can support only permanent connections, has become an "always present" adaptation driver which provides many extra functions like Dial-on-Demand, Short-Hold-Mode, and true link backup.

MLM driver is the "gate" to:

  • Switched ISDN B-channels
  • Permanent ISDN B-channels
  • Virtual Synchronous Port (VSP) in E1/T1 links
  • Frame relay PVCs
  • Backups of any sort of permanent links, including frame-relay PVCs and IP tunnels
  • Voice and data multiplexing via Abilis MPX protocol

Within CPX the MLM appears to upper drivers as a single P-LINK port while it is able to use two lower ports of P-LINK and S-LINK types.

Configuration of the MLM ports top

The Multi-Link Manager port is referred in the Abilis CPX by the "MLM" abbreviation, it has all the parameters described in the following section.

The layout of the MLM port parameters changes considerably according to the used P-Link and S-Link port types.

Here are some examples of the MLM port parameters.

MLM over SYNC.

[18:42:32] ABILIS_CPX: D P PO:MLM

PO:501 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:1
       SLINK:NONE

MLM over FRAME-RELAY.

PO:502 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:102   DLCI:16       CC:YES                  SC:4
       CIR:19200                 BC:19200                BE:0
       SLINK:NONE

MLM over PLINK-E.

PO:503 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:701
       SLINK:NONE

MLM over ISDN (over permanent B-Channel).

PO:504 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:17    BCHAN:B2
       SLINK:NONE

MLM over EIR (PLINK).

PO:505 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:200   VSP-ID:10
       SLINK:NONE

MLM over EIR (SLINK).

PO:506 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:NONE
       SLINK:200
       RTY:LIN     NRTY:5        TB:3     DDT:220        VDT:10
       CGI:777                   SGI:*
       CDI:*                     SDI:*
       CGO:#                     SGO:#
       CDO:123                   SDO:#

MLM over FRAME-RELAY and EIR.

PO:507 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:102   DLCI:16       CC:YES                  SC:4
       CIR:19200                 BC:19200                BE:0
       SLINK:200
       RTY:LIN     NRTY:5        TB:3     DDT:220        VDT:10
       CGI:777                   SGI:*
       CDI:*                     SDI:*
       CGO:#                     SGO:#
       CDO:123                   SDO:#

MLM over NO LINKS.

PO:508 ------------------------------------------------------------------------
MLM    LOG:NO      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:NONE
       SLINK:NONE

By the previous example, it is possible to underline that:

  • the shown values for the port "501" appear for P-Link port of SYNC type;

  • the shown values for the port "502" appear for P-Link port of FR type;

  • the shown values for the port "503" appear for P-Link port of PLINKE type;

  • the shown values for the port "504" appear for P-Link port of ISDN type;

  • the shown values for the port "505" appear for P-Link port of EIR (PLINK) type;

  • the shown values for the port "506" appear for S-Link port of EIR (SLINK) type;

  • the shown values for the port "507" appear for P-Link port of FR type and S-Link port of EIR (SLINK) type;

  • the shown values for the port "508" are the default ones.

All the changes made on the MLM port parameters can be immediately activated through the initialization command INIT PO: (this property is underlined by uppercase characters in their name), however it has to be noted that a possible active connection on the S-Link channel is closed with 80 90 80 8A code. The MLM port will immediately be ready for a new communication, without affecting the upper level driver.

The changes made on the parameter LOG: are immediately active.

Details of the MLM ports parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

MPX: | Activation of the Abilis MPX protocol
YES | NO, YES, EXT

It makes possible to activate the multiplexing of DATA, "Link-Check", VOICE frames type.

Value | Meaning
NO | Abilis MPX multiplexing is not active. MLM is running in "transparent" mode over the P-LINK interface, as if it would not be there.
YES | Abilis MPX multiplexing is active only for the data protocols LAPB and LINK-FR.
EXT | Abilis MPX multiplexing is active for ANY data protocol.

warning! The activation of the Abilis MPX multiplexing protocol, a proprietary protocol, requires that the counterpart is running MPX as well. It is also necessary that the MPX value is identical for the counterparts.

LC: | Activation of the Abilis MPX Link-check protocol
YES | NO, YES

It enables/disables the use of the "Link-Check" protocol, and consequently the transmission of "Link-check" frames.

The link-check protocol is automatically disabled when MPX:NO.

Most of the application have benefits from the Link-check protocol, however there are cases where the generated traffic is not desired while the voice/data multiplexing is still required, as in the cases of VoIP applications with dial-up accesses.

It is also important to note that with LC:NO the "true link backup" is disabled.

Value | Meaning
NO | Link-Check protocol is not active.
YES | Link-Check protocol is not active.

T1: | Link-Check "probes" Timeout
1000 | 200-3000 (in milliseconds)

Maximum time to wait for a Link-Check "probe" acknowledge. If this time elapses without receiving the acknowledge the "probe" is immediately repeated, as a result "not acknowldged probes" are repeated every T1: milliseconds.

T3: | Time interval between transmission of Link-Check "probes" when link is functioning
3000 | 600-9000 (in milliseconds)

This is the time interval between a correctly sent and acknowledged Link-Check "probe" and the next one to send while the link is regularly working (e.g. P-LINK state is READY). It has relationships with the parameter T1: and it has to satisfy the simple rule: T3 > T1 * 2.

N2: | Maximum number of Link-Check "probes" retransmission
3 | 1 - 99

Sets the maximum number of Link-Check "probes" retransmission.

If this counter runs over, it means "N2" Link-Check "probes" have been sent without receiving any acknowledge, the P-Link or S-Link channel is declared out of service.

In the case it occurs on the P-Link channel, the communication will be activated on the S-Link channel, providing that it is properly configured.

In the case it occurs with the S-Link channel, the connection is closed with the code 80 90 80 8B; if it happens three times consecutively the port will be placed in the "STOPPED2" state, without being able to receive or make further calls.

To recover from the error it is necessary to execute the INIT PO: command.

If alarm detection was enabled, i.e. if LOG is set with the "A" option, it is also possible to recover from the error with the ALARM RESET command or using the analogous menu available on the LCD display of the front panel.

If the communication cannot go on any longer either on P-Link or S-Link, the upper level driver will be advised of the error and point out a "Level 1 Down".

CIPHER: | Enable and select cryptography
NO | NO, DATA, VOICE, ALL

It enables and selects the cryptography to be applied on the frames passing through the port. Cryptography can be selectively applied to the different traffic types (VOICE and DATA):

Value | Meaning
NO | No cryptography is applied.
DATA | Cryptography is applied only on DATA traffic type.
VOICE | Cryptography is applied only on VOICE traffic type.
ALL | Cryptography is always in use, whatever is the traffic data type.
CRKEY: | Index of the key used for the cryptography
DFT | DFT, 1 - 63

It selects the key to be used for cryptography operations.

Users can choose either the default key supplied by the system ("CRKEY:DFT"), or one of the keys defined in the cryptography keys table, in which case the numeric value (from 1 to 63) corresponding to the desired CRKEY has to be specified.

If the configured value refers to a missing CRKEY it will be shown inside square brackets, e.g. "CRKEY:[5]" means that the key number 5 is not present in the table.

If the parameter CIPHER: is set to "NO", the value of CRKEY: is useless.

PLINK: | Identifier of the Abilis CPX port of P-Link level
NONE | 1 - 999, NONE

It defines the P-Link port of the lower level, which can only be SYNC, FR, ISDN, PLINKE or EIR type.

If no P-Link port is required, the value "NONE" must be set.

BCHAN: | Identifier of the channel B to use (only if the P-Link is an ISDN port type)
B1 | B1, B2

The parameter appears and can be modified only if the port referred by the parameter PLINK: is an ISDN Basic Rate port type, i.e. the service provided by "only data" ISDN adaptors.

It defines the channel to be used on the lower level ISDN port.

DLCI: | Identifier of the DLCI to use (only if the P-Link is a FR port type)
NONE | 16-991, 1024-63487, 131072-8126463, NONE

The parameter appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It defines the identifier of the DLCI to use the lower lever FR port.

The value "NONE" means "no DLCI" and it disables the connection with the lower level FR port.

The validity of allowed values intervals for the DLCI identifier depends on the length of the header Frame-Relay in use:

Value | Meaning
NO | No cryptography is applied.
DATA | Cryptography is applied only on DATA traffic type.
VOICE | Cryptography is applied only on VOICE traffic type.
ALL | Cryptography is always in use, whatever is the traffic data type.
CC: | Activation of the congestion control
YES | NO, YES

The parameter appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It makes possible to apply or to not apply the throughput reduction as reaction to congestion notifications.

warning! Not obeying to congestion notification may cause severe malfunctioning, therefore we strongly reccommend to always use CC:YES. Ignoring congestion notification may be needed for some testing activities, certainly not during the regular work.

SC: | Value of the constant "step count", used in congestion control (only if the P-Link is a FR port type)
4 | 1 - 50

The parameter appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It sets how many consecutive frames with BECN=1 have to be received for reducing the throughput, according to the rule fixed by ANSI T1.618 annex A §2.1.1.

Value 4 suits the most frequent situations, however the right value can be evaluated by using the Calculator.

CIR: | Value of "Committed Information Rate" (only if the P-Link is a FR port type)
0 | 0, 4800 - 2500000 in bit/sec

The parameter appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It defines the value of "Committed Information Rate", i.e. the throughput the frame-relay network has to guarantee in normal working conditions. This throughput is measured in the time interval TC (Time Committed) given by the following formula: TC=BC/CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BC: | Value of "Burst Committed" (only if the P-Link port is a FR port type)
0 | 0, 2400 - 5000000 in bits

The parameter appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It defines the "Burst Committed", i.e. the number of bits the network can accept, during the time interval TC, to guarantee the CIR.

If the network is congested, it sends a signal (BECN or FECN) that require the user to progressively reduce his throughput to values smaller than CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BE: | Value of "Burst Excess" (only if the P-Link is a FR port type)
0 | 0 - 5000000 in bits

The appears and can be modified only if the port referred by the parameter PLINK: is a FR port type.

It defines the "Burst Excess", i.e. the number of bits in excess that the network can manage, during the time interval TC, if there is availability of exceeding resources. The "exceeding throughput" is evaluated by using the following formula ThExcess=BE*TC.

When the network does not have resources in excess sends a signal (BECN or FECN) that engages the user to immediately limit the throughput to the value of the CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

VSP-ID: | Service identifier (only if the P-Link is a EIR port type)
NONE | NONE, 1 - 32

This parameter indicates which Virtual Synchronous Port (VSP) of those defined in the TDM table the MLM must use.

SLINK: | Identifier of the Abilis CPX port of S-Link level
NONE | 1 - 999, NONE

It defines the S-Link port of lower level, it can be of EIR or Q931 type.

If the S-Link port is not desired, the parameter has to be set to "NONE".

RTY: | Calls repetition rule on failures
INC | LIN, INC, US

It allows to select the calls repetition rule on the S-Link channel following an unsuccessful call, and if the attempts are exhausted the S-Link channel is placed in STOPPED1 state.

If the switched connection is established the attempts counter is reset (connection was established!), however if "link-checks" are active a "second level verification" is executed and if it fails the connection is classified as "link-check failure". Three consecitive "link-check failures" forces the S-Link channel in STOPPED2 state preventing any further outgoing or incoming call!

Warning! The behaviour upon exhausted attempts is slightly different when RTY:US, see below or details.

Value | Calls repetition rules
LIN The time interval between a call attempt and the next one is fixed and configurable through the parameter TB:.
INC | The time interval between a call attempt and the next one, is doubled at every attempt, starting with the value defined in the parameter TB:.
US The abbreviation "US" stands for "unattended site".
In this case the S-Link channel driver activates the following procedure until success:
  1. the driver executes a number of tries equal to the value of the parameter NRTY: every TB: seconds, or until three consecutive "link-check" errors occour;
  2. the driver makes 8 calls every 15 minutes;
  3. the driver makes 4 calls every 1 hour;
  4. the driver makes 9 calls every 2 hours;
  5. the driver makes 8 calls every 6 hours;
  6. the driver is placed in the state STOPPED1 or STOPPED2 caused by the last error;
This procedure allows an "automatic recovery" from critical situations within three days from the first failure occurrence, afterwards a maintenance intervention is required.

It is important to emphasize that points 2,3,4,5,6 of the procedure do not distinguish between failure's reason (connection not established or connection established with "link-check" error) until the last attempt is reached and the last failure reason is used to set the final state (STOPPED1 or STOPPED2).
NRTY: | Maximum number of call repetitions
5 | 0 - 65534, NOMAX

It specifies the maximum number of call repetitions for the S-Link channel when the connection cannot be established. Once attempts are exhausted the S-Link chennel is place in STOPPED1 state.

Warning! If the channel is established BUT the "link-check protocol" detects link-check failure for three times consecutively the port is placed in STOPPED2 state regardless the NRTY counter.

Info The behaviour upon exhausted attempts is slightly different when RTY:US.

Value | Meaning
0 | Outgoing calls are disabled.
1-65534 | Calls are repeated as many times as the value.
NOMAX | Calls are repeated indefinitely. For "RTY:INC" the time interval of calls after the 65535th will not increase further, keeping the interval TB: * 65535 seconds. For "RTY:US" the actual behaviour is identical to RTY:LIN because the condition that starts the "unattended site retries" will not be reached.
TB: | Time base interval between calls repetitions
3 | 3 - 255 (in seconds)

It defines the "base" time interval that the retry procedure set in RTY: uses to calculate the delay between a call attempt that fails and the next one.

DDT: | Data disconnect timeout
220 | from 10 up to 65535 (in seconds)

After "DDT:" seconds from the last sent or received "data" frame the S-LINK connection will be closed, unless "voice" frames still need the connection.

Warning! The disconnection actually occur when both DDT: and VDT: expire.

VDT: | Voice disconnection timeout
10 | from 5 up to 900 (in seconds)

After "VDT:" seconds from the last sent or received "voice" frame the S-LINK connection will be closed, unless "data" frames still need the connection.

Warning! The disconnection actually occur when both DDT: and VDT: expire.

CGI: | Calling address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

It sets up the calling address, that the incoming call must contain.

The character "*" means "any number".

SGI: | Calling sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

It sets up the calling sub-address, that the incoming call must contain.

The character "*" means "any character".

CDI: | Called address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

It sets up the called address, that the incoming call must contain.

The character "*" means "any number".

SDI: | Called sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

It sets up the called sub-address, that the incoming call must contain.

The character "*" means "any character".

CGO: | Calling address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

It sets up the calling number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling address.

SGO: | Calling sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

It sets up the calling sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling sub-address.

CDO: | Called address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

It sets up the called number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called address.

SDO: | Called sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

It sets up the called sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called sub-address.

Statistics of the MLM ports top

Example of how to check the state and statistics of MLM ports by the command D S

[18:42:32] ABILIS_CPX: D S PO:501

PO:501 ------------------------------------------------------------------------
MLM    +--------+--- Global ----+------- P-Link -------+------- S-Link -------+
       | STATE: |    READY      |        READY         |   LINK-NOT-PRESENT   |
       +--------+---------------+----------------------+----------------------+
       PLINK-DN1:1            PLINK-DN2:1
       SLINK-ST1:0            SLINK-ST2:0            TIME-CUR-CALL:0
       RTY:0       DDT:0      VDT:0       USRTY:0    TDEL:0        TREM:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|           |           |           |
       V-NO-CRKEY |          0|          0|D-NO-CRKEY |          0|          0|
       V-BAD-CIPH |          0|           |D-BAD-CIPH |          0|           |
       ------------------------------------------------------------------------

The MLM ports have not extended statistics, that's why the execution of the command D SE will show again the not extended ones in the following format:

[18:42:32] ABILIS_CPX: D SE PO:501

PO:501 ------------------------------------------------------------------------
MLM    --- Cleared 028:00:15:01 ago, on 14/04/2000 at 11:05:34 ----------------
       PLINK-DN1:1            PLINK-DN2:1
       SLINK-ST1:0            SLINK-ST2:0            TIME-CUR-CALL:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|           |           |           |
       V-NO-CRKEY |          0|          0|D-NO-CRKEY |          0|          0|
       V-BAD-CIPH |          0|           |D-BAD-CIPH |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows both the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the MLM state fields and statistics

Global STATE: | Global current state
 | READY, DOWN, ERR

It reports the global current state, as seen by the upper port (e.g. IPRTR, LPAB, etc ...):

Driver | States | Meaning
 |  |  | MLM (Global) | READY | MLM is READY and usable.
DOWN | MLM is DOWN.
ERR | Software error. Contact Abilis service.
P-Link STATE: | P-Link channel current state
 | READY, LINK-NOT-PRESENT, DOWN1, DOWN2, ERR

It reports the P-Link channel current state:

Driver | States | Meaning | Values reported into:
 |  |  | System Log | Events Log | LCD display
MLM (P-Link) | READY | The P-Link is ready and usable. | RD
 | LINK-NOT-PRESENT | The value configured in PLINK: does not refer to a valid or running port. | ln
 | LINK-ERROR | The port configured in PLINK: is a valid and running port, however there are problems with other parameters. E.g. when MLM uses a frame relay port and it tries to use a DLCI already used, require an unacceptable CIR, etc... | le
 | DOWN1 | P-Link channel is down because of a DOWN state in the lower protocol driver, as in the case of SYNC port with CD:YES and current DCD state is DOWN. | d1
 | DOWN2 | P-Link channel is down because the "link-check protocol" detected a failure, while the state in the lower protocol driver is "UP". | d2
 | ERR | Software error. Contact Abilis service. | NA
S-Link STATE: | S-Link channel current state
 | READY, READY-DELAY, CALLING, CALLED, CONNECTED TO, CONNECTED FROM, CLEARING, CLEARED, LINK-NOT-PRESENT, STOPPED1, STOPPED2, US-DELAY, ERR

It reports the S-Link channel current state:

Driver | States | Meaning | Values reported into in:
 |  |  | System Log | Events Log | LCD Display
MLM (S-Link) | READY | The S-Link is ready and usable. | RD
 | READY-DELAY | The S-Link channel is ready to receive a call but not to place it. It is executing a delay because of a previous call attempt failure.
 | CALLING | A call is outgoing. Waiting for call acceptance or call refusal.
 | CALLED | A call is incoming. Waiting to accept/refuse the call.
 | CLEARING | A call disconnection has been generated from the local MLM. Waiting for completion of the disconnection procedure.
 | CLEARED | A disconnection request has been received. Waiting to complete the disconnection procedure.
 | US-DELAY | The S-Link channel is in the "unattended site" procedure and it is executing the delay before the next attempt. It can appear only if RTY:US.
 | CONNECTED-TO | it is connected as a result of one outgoing call. | CN
 | CONNECTED-FROM | it is connected as a result of one incoming call. | CN
 | LINK-NOT-PRESENT | The value configured in SLINK: does not refer to a valid or running port. | ln
 | STOPPED1 | The S-Link channel exhausted the call retry attempts that was configured through RTY: and NRTY: parameters. Further outgoing calls are not possible while incoming calls can be accepted. This error condition can be reset with the INIT PO: command or, if alarm is active, with either the ALARM RESET command or the analogous menu available on the LCD display of the front panel. | s1
 | STOPPED2 | The "link-check protocol" detected three consecutive failures on either incoming or outgoing calls. Both outgoing and incoming calls are not anymore possible. This error condition can be reset with the INIT PO: command or, if alarm is active, with either the ALARM RESET command or the analogous menu available on the LCD display of the front panel. | s2
 | ERR | Software error. Contact Abilis service. | NA
PLINK-DN1: | Number of times that P-Link channel reached the DOWN1 state
 | 0 - 4.294.967.295

The counter PLINK-DN1 reports the number of times the P-Link channel reached the DOWN1 state.

PLINK-DN2: | Number of times that P-Link channel reached the DOWN2 state
 | 0 - 4.294.967.295

The counter PLINK-DN2 reports the number of times the P-Link channel reached the DOWN2 state.

SLINK-ST1: | Number of times that S-Link channel reached then STOPPED1 state
 | 0 - 4.294.967.295

The counter SLINK-ST1 reports the number of times that S-Link channel reached the STOPPED1 state.

SLINK-ST2: | Number of times that S-Link channel reached the STOPPED2 state
 | 0 - 4.294.967.295

The counter SLINK-ST2 reports the number of times that S-Link channel reached the STOPPED2 state.

TIME-CUR-CALL: | Duration of the current connection
 | 0 - 4.294.967.295

The counter TIME-CUR-CALL reports the overall duration of the current connection.

RTY: | Number of reattempt of the current call
 | 0 - NRTY

The counter RTY reports the number of reattempt of the current call, as used by RTY:LIN/INC/US procedures.

DDT: | Number of seconds to go for the channel disconnecion by "DATA frames inactivity".
 | 60 - 65535 (in seconds)

The counter DDT shows how many seconds to go for the channel disconnecion by "DATA frames inactivity".

The channel will be actually disconnected when both DDT: and VDT: values will reach 0.

VDT: | Number of seconds to go for the channel disconnecion by "VOICE frames inactivity".
 | 1 - 900 (in seconds)

The counter VDT shows how many seconds to go for the channel disconnecion by "VOICE frames inactivity".

The channel will be actually disconnected when both DDT: and VDT: values will reach 0.

USRTY: | Number of reattempt in modality "Unattended Site"
 | 0 - 65.535

The counter USRTY reports the number of reattempt in modality "Unattended Site" (parameter RTY:US).

TDEL: | S-Link channel: seconds elapsed since entering the READY-DELAY state
 | 0 - 65.535 (in seconds)

The counter TDEL reports the seconds elapsed since the S-Link channel entered the READY-DELAY state.

TREM: | S-Link channel: seconds to go to move from READY-DELAY to READY state
 | 0 - TDEL (in seconds)

The counter TREM reports the seconds to go before the S-Link channel leaves the current READY-DELAY state and enters the READY one.

FAIL-CALL | Number of incoming/outgoing calls failed
 | 0 - 4.294.967.295

The counter FAIL-CALL (INPUT) reports the number of incoming calls failed.
The counter FAIL-CALL (OUTPUT) reports the number of outgoing calls failed.

SUCC-CALL | Number of incoming/outgoing calls successful
 | 0 - 4.294.967.295

The counter SUCC-CALL (INPUT) reports the overall number of incoming call successful.
The counter SUCC-CALL (OUTPUT)reports the overall number of outgoing calls successful.

TIME-CALL | Duration of connections caused by incoming/outgoing calls
 | 0 - 4.294.967.295

The counter TIME-CALL (INPUT) reports the overall duration of those connections caused by incoming calls.
The counter TIME-CALL (OUTPUT) reports the overall duration of those connections caused by outgoing calls.

V-NO-CRKEY | Number of VOICE frames discarded because of missing CRKEY.
 | 0 - 4.294.967.295

The counter V-NO-CRKEY (INPUT) is incremented every time a VOICE frame is received, but it is not decryptable because the index of the cryptographic key, set in the parameter CRKEY:, refers to a non-existent cipher key.

The counter V-NO-CRKEY (OUTPUT) is incremented every time a VOICE frame is received from the upper level, but it is not encryptable because the index of the cryptographic key, set in the parameter CRKEY:, refers to a non-existent cipher key.

V-BAD-CIPH | Number of discarded VOICE frames because of decryption failure
 | 0 - 4.294.967.295

The counter V-BAD-CIPH (INPUT) is incremented every time a received VOICE frame must be discarded because the decryption failed. This can be caused by:

  • frame content corruption occourred along the path from the source to the destination;
  • the cryptographic key, used by the source for the encryption, is unlike the one set in the parameter CRKEY:, used for the decryption.
D-NO-CRKEY | Number of DATA frames discarded because of missing CRKEY.
 | 0 - 4.294.967.295

The counter D-NO-CRKEY (INPUT) is incremented every time a DATA frame is received, but it is not decryptable because the index of the cryptographic key, set in the parameter CRKEY:, refers to a non-existent cipher key.

The counter D-NO-CRKEY (OUTPUT) is incremented every time a DATA frame is received from the upper level, but it is not encryptable because the index of the cryptographic key, set in the parameter CRKEY:, refers to a non-existent cipher key.

D-BAD-CIPH | Number of discarded DATA frames because of decryption failure
 | 0 - 4.294.967.295

The counter D-BAD-CIPH (INPUT) is incremented every time a received DATA frame must be discarded because the decryption failed. This can be caused by:

  • frame content corruption occourred along the path from the source to the destination;
  • the cryptographic key, used by the source for the encryption, is unlike the one set in the parameter CRKEY:, used for the decryption.

SNMP traps generated for the MLM port top

The SNMP Agent of Abilis CPX is able to generate traps owing to meaningful state changes pertinent either to P-Link or S-Link channel of the MLM.

SNMP traps generated for the P-Link channel of the MLM

The traps listed below are generated when the "T" option is set in the LOG: parameter.

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
1 | cxTrapPLinkDown | cxPortIndex, cxPortType, cxMlmDiagPLinkState, cxMlmDiagSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the P-Link channel of the MLM goes into the DOWN1 state or DOWN2 state.
2 | cxTrapPLinkReady | cxPortIndex, cxPortType, cxMlmDiagPLinkState, cxMlmDiagSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the P-Link channel of the MLM leaves the DOWN1 state or DOWN2 state.

SNMP traps generated for the S-Link channel of the MLM

The traps listed below are generated when the "T" option is set in the LOG: parameter.

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
3 | cxTrapSLinkStopped | cxPortIndex, cxPortType, cxMlmDiagPLinkState, cxMlmDiagSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the S-Link channel of the MLM goes into the STOPPED1 state or STOPPED2 state.
4 | cxTrapSLinkReady | cxPortIndex, cxPortType, cxMlmDiagPLinkState, cxMlmDiagSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the S-Link channel of the MLM leaves the STOPPED1 state or STOPPED2 state.
5 | cxTrapSLinkUSStart | cxPortIndex, cxPortType, cxMlmDiagPLinkState, cxMlmDiagSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the repetition calls procedure, specified in the parameter RTY:, if set to the value "US", starts on the S-Link channel of the MLM port.

Details of the SNMP variables reported in the MLM traps

cxPortIndex | FR port, which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the MLM port, which the trap refers to
 | type - description

This variable reports either the port type which the trap refers to (in this case it will be MLM) and the description that eventually the user can give to the CPX port.

cxMlmDiagPLinkState | P-Link channel current state
 | ready(0), link-not-present(1), link-error(2), down1(3), down2(4)

This variable reports the current state of the P-Link channel, which the trap refers to. The following table shows the relationship between the state values, referred by the SNMP variables, and the states carried out by executing the command D S.

SNMP variable value | P-Link channel corresponding state
ready(0) | READY
link-not-present(1) | LINK-NOT-RESENT
link-error(2) | LINK-ERROR
down1(3) | DOWN1
down2(4) | DOWN2
cxMlmDiagSLinkState | S-Link channel current state
 | ready(0), ready-delay(1), calling(2), called(3), connected(4), clearing(5), cleared(6), link-not-present(7), stopped1(8), stopped2(9), us-delay(10)

This variable reports the current state of the S-Link channel, which the trap refers to. The following table shows the relationship between the state values, referred by the SNMP variables, and the states carried out by executing the command D S.

Value of the SNMP variable | Corresponding state of the S-Link channel
ready(0) | READY
ready-delay(1) | READY-DELAY
calling(2) | CALLING
called(3) | CALLED
connected(4) | CONNECTED
clearing(5) | CLEARING
cleared(6) | CLEARED
link-not-present(7) | LINK-NOT-PRESENT
stopped1(8) | STOPPED1
stopped2(9) | STOPPED2
us-delay(10) | US-DELAY
sysUpTime | Elapsed time since the system has been started by the occurred event
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable reports the elapsed time (in cents of second) since the occurred event, which has generated the SNMP, started the system. This value is usually shown by using the format days:hours:minutes:seconds.


The Multi Link ports (ML)

Terminology
Goal
Configuration of the ML ports
Statistics of the ML ports
SNMP traps generated for the ML ports

Terminology top

P-LINK
It stands for "Permanent link" and defines a permanent connection toward the remote device.
It also defines a kind of "logical" interface in the CPX that several drivers can emulate.
S-LINK
It stands for "Switched link" and defines a switched connection toward the remote device. A switched connection is established only upon request. It also defines the kind of "logical" interface offered in the CPX by EIR and Q931 drivers.
Link-check
It is a ML/ML procedure used to detect end-to-end link (or emulated p-link) real functioning, regardless of the lower protocol layers states.
It consists of periodical "link-check frames" exchange.
Bandwidth-on-Demand (uses Dial-on-Demand, Short-Hold-mode and True link backup. see MLM)
It is a feature that allows to open a new S-LINK channel when ML detects that the current throughput is too high for the current bandwidth. To detect this situation, ML has several parameters that indicate when a new channel must be open. A similar rule is used also when there is the possibility to close an S-LINK channel because of no more needed.

Goal top

Multi-Link (ML) basic concepts.

The ML driver is a very versatile driver. It is used as an intermediate layer to offer switched services for ISDN B-Channels to drivers and protocols that can support only permanent connections. It provides many extra functions like Bandwidth-on-Demand.

ML driver is the "gate" to:

  • Switched ISDN B-channels
  • Permanent ISDN B-channels
  • Virtual Synchronous Port (VSP) in E1/T1 links
  • Frame relay PVCs
  • Backups of any sort of permanent links, including frame-relay PVCs and IP tunnels
  • Voice and data multiplexing via Abilis MPX protocol

Within CPX the ML appears to upper drivers as a single P-LINK port while it is able to use several lower ports of P-LINK and S-LINK types.

Configuration of the ML ports top

The Multi-Link port is referred in the Abilis CPX by the "ML" abbreviation, it has all the parameters described in the following section.

The layout of the ML port parameters changes considerably according to the used P-Link and S-Link port types.

Here are some examples of the ML port parameters.

ML default .

[18:42:32] ABILIS_CPX: D P PO:ML

ML over EIR.

PO:521 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:200      Chan:0                    CHAN-LIMIT:0
                      CGI:*                     SGI:*
                      CDI:*                     SDI:*
       CDOMAXCONN:2   CGO:#                     SGO:#
       CDONRTY:5      CDO:#                     SDO:#
       ------------------------------------------------------------------------
                         *** NO PLINKs CONFIGURED ***

ML over EIR.

PO:521 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:200      Chan:0                    CHAN-LIMIT:0
                      CGI:*                     SGI:*
                      CDI:*                     SDI:*
       CDOMAXCONN:2   CGO:#                     SGO:#
       CDONRTY:5      CDO:#                     SDO:#
       ------------------------------------------------------------------------
                         *** NO PLINKs CONFIGURED ***

ML over SYNC.

PO:523 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:NONE
       ------------------------------------------------------------------------
       Pl:1   ST:RUNNING   LOWPO:1     SPEED:64000

ML over FRAME-RELAY.

PO:524 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:NONE
       ------------------------------------------------------------------------
       Pl:1   ST:RUNNING   LOWPO:102   SPEED:64000    DLCI:NONE
              CIR:0        BC:0        BE:0           SC:4         CC:YES

ML over FRAME-RELAY and EIR.

PO:528 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:200      Chan:0                    CHAN-LIMIT:0
                      CGI:*                     SGI:*
                      CDI:*                     SDI:*
       CDOMAXCONN:2   CGO:#                     SGO:#
       CDONRTY:5      CDO:#                     SDO:#
       ------------------------------------------------------------------------
       Pl:1   ST:RUNNING   LOWPO:102   SPEED:64000    DLCI:NONE
              CIR:0        BC:0        BE:0           SC:4         CC:YES

ML over EIR.

PO:529 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:200      Chan:0                    CHAN-LIMIT:0
                      CGI:*                     SGI:*
                      CDI:*                     SDI:*
       CDOMAXCONN:2   CGO:#                     SGO:#
       CDONRTY:5      CDO:#                     SDO:#
       ------------------------------------------------------------------------
                         *** NO PLINKs CONFIGURED ***

ML over NO LINKS.

PO:530 ------------------------------------------------------------------------
ML     LOG:DS        CRYPT:NO        CRKEY:DFT      T1:1000  T3:3000   N2:3
       ROLE:MASTER   MAXBW:2400      MINDATABW:0             DDT:60    VDT:30
       NORM-TH:50    FAST-TH:75      NORM-TIME:60   FAST-TIME:10
       Drx-pool:30   DRX-TOUT:3000   Vrx-pool:10    Vtx-pool:10   VTX-TOUT:500
       ------------------------------------------------------------------------
       SLINK:NONE
       ------------------------------------------------------------------------
                         *** NO PLINKs CONFIGURED ***

By the previous example, it is possible to underline that:

  • the shown values for the port "521" appear for S-Link port of EIR type;

  • the shown values for the port "522" appear for S-Link port of EIR type using a CDO list;

  • the shown values for the port "523" appear for P-Link port of SYNC type;

  • the shown values for the port "524" appear for P-Link port of FR type;

  • the shown values for the port "528" are for an example of common configuration.

  • the shown values for the port "529" are the default ones.

  • the shown values for the port "530" is ML with no lower ports.

All the changes made on the ML port parameters can be immediately activated through the initialization command INIT PO: (this property is underlined by uppercase characters in their name), however it has to be noted that a possible active connection on the S-Link channel is closed with 80 90 80 8A code. The ML port will immediately be ready for a new communication, without affecting the upper level driver.

Warning! ML has another feature that allows the complete restart of the port, the command R PO: which allows ML to reload ALL the parameters in configuration, including those that otherwise would need a system restart.
As a result, LINK resources that were added or removed will be respectively activated or definitly deleted, limits on maximum SLINK channels changed to reflect the new values, and also buffers sizes updated.
All these operation are carried out without affecting the upper level driver, which will be "unaware" of the ML restart, unless the new configuration contains a mistake that prevent the communication.

Warning! Following the restart command R PO: all the active connections on the S-Link channel are closed with 80 90 80 8A code, however ML is immediately available for new connections.

Info Parameters that can be activated with the R PO: command can be identified by the initial character in UPPERCASE and subsequent ones in LOWERCASE, e.g. Vrx-pool:, Chan:, ...

The changes made on the parameter LOG: are immediately active.

Details of the ML ports parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

CRYPT: | Enable and select cryptography
NO | NO, DATA, VOICE, ALL

It enables and selects the cryptography to be applied on the frames passing through the port. Cryptography can be selectively applied to the different traffic types (VOICE and DATA):

Value | Meaning
NO | No cryptography is applied.
DATA | Cryptography is applied only on DATA traffic type.
VOICE | Cryptography is applied only on VOICE traffic type.
ALL | Cryptography is always in use, whatever is the traffic data type.
CRKEY: | Index of the key used for the cryptography
DFT | DFT, 1 - 63

It selects the key to be used for cryptography operations.

Users can choose either the default key supplied by the system ("CRKEY:DFT"), or one of the keys defined in the cryptography keys table, in which case the numeric value (from 1 to 63) corresponding to the desired CRKEY has to be specified.

If the configured value refers to a missing CRKEY it will be shown inside square brackets, e.g. "CRKEY:[5]" means that the key number 5 is not present in the table.

If the parameter CRYPT: is set to NO, the value of "CRKEY:" is useless.

T1: | Link-Check "probes" Timeout
1000 | 200-3000 (in milliseconds)

Maximum time to wait for a Link-Check "probe" acknowledge. If this time elapses without receiving the acknowledge the "probe" is immediately repeated, as a result "not acknowldged probes" are repeated every T1 milliseconds.

T3: | Time interval between transmission of Link-Check "probes" when link is functioning
3000 | 600-9000 (in milliseconds)

This is the time interval between a correctly sent and acknowledged Link-Check "probe" and the next one to send while the link is regularly working (e.g. P-LINK state is READY). It has relationships with the parameter T1: and it has to satisfy the simple rule: T3 > T1 * 2.

N2: | Maximum number of Link-Check "probes" retransmission
3 | 1 - 99

Sets the maximum number of Link-Check "probes" retransmission.

If this counter runs over, it means "N2" Link-Check "probes" have been sent without receiving any acknowledge, the P-Link or S-Link channel is declared out of service.

In the case it occurs on the P-Link channel, the communication will be activated on the S-Link channel, providing that it is properly configured.

In the case it occurs with the S-Link channel, the connection is closed with the code 80 90 80 8B; if it happens three times consecutively the port will be placed in the "STOPPED2" state, without being able to receive or make further calls.

To recover from the error it is necessary to execute the INIT PO: command.

If alarm detection was enabled, i.e. if LOG is set with the "A" option, it is also possible to recover from the error with the ALARM RESET command or using the analogous menu available on the LCD display of the front panel.

If the communication cannot go on any longer either on P-Link or S-Link, the upper level driver will be advised of the error and point out a "Level 1 Down".

ROLE: | ML role
MASTER | MASTER, SLAVE

This parameter indicates the role of the ML. When ML is configured as a MASTER, it has the complete control on all its lower links. It can decide to open or close them following its throughput rules. When ML is configured al SLAVE, it has a reduced set of controls. It can only open one single S-LINK only when strictly needed.

MLs connected together cannot have the same role. In this case will be both automatically set to SLAVE.

MAXBW: | Maximum bandwidth
2400 | 2400-99999999 (bps)

It is the maximum bandwidth allowed to accross over ML links. If the bandwidth that is going on ML connection is higher that maximum, ML will no open other S-LINK.

MINDATABW: | Minimum bandwidth for DATA
0 | 0-99999999 (bps)

it is the minumum bandwidth that must be left for DATA.

If MINDATABW is not set to 0, one link will be always open: will be opened a PLINK if at least one PLINK is configured and CONNECTED. Will be opened a S-LINK if no P-LINKS are configured or set to DOWN and at least there is a S-LINK present.

DDT: | Time-out for extra Slinks shutdown for DATA
60 | from 10 up to 1000 (in seconds)

DDT is the time that ML uses to analyze the DATA throughput on the LINKs. When ML considers that for DDT seconds current throughput could be managed also without one SLINK, it starts the DATA procedure to close the SLINK.

Warning! ML closes the SLINK only when both DATA and VOICE procedures to close SLINK were started.

When the SLINK is closed, ML waits at least other DDT seconds before checking again for SLINK closure. This procedure is used by ML if at least one SLINK is open. See Bandwidth On Demand documentation for more deatails about rules used for DATA stream to detect when SLINK can be closed by ML.

VDT: | Time-out for extra Slinks shutdown for VOICE
30 | from 10 up to 1000 (in seconds)

VDT is the time that ML uses to analyze the VOICE throughput on the LINKs. When ML considers that for VDT seconds current throughput could be managed also without one SLINK, it starts the VOICE procedure to close the SLINK.

Warning! ML closes the SLINK only when both DATA and VOICE procedures to close SLINK were started.

When the SLINK is closed, ML waits at least other VDT seconds before checking again for SLINK closure. This procedure is used by ML if at least one SLINK is open. See Bandwidth On Demand documentation for more deatails about rules used for VOICE stream to detect when SLINK can be closed by ML.

NORM-TH: | Threshold for NORMAL opening of additional SLinks
50 | 0 - 100 (%)

This parameter indicates the threshold for opening an S-LINK after a certain amount of time. When the current throughput is higher than normal threshold, ML analises this situation for NORM-TIME: seconds. If after this period, threshold percentage is still higher than NORM-TH, then a new SLINK will be opened (if present and ready to be opened).

The percentage is not calculated using the total bandwidth of the currently opened links: it is calculated using the total bandwidth of the currently opened links LESS the REAL bandwidth used by voice frames.

FAST-TH: | Threshold for FAST opening of additional SLinks
75 | 0 - 100 (%)

It follows the same rules of NORM-TH:. The difference is that the period of time to wait before opening the link is indicated by FAST-TIME:

NORM-TIME: | Time-out for NORMAL opening of additional SLinks
60 | 10-1000 (seconds)

This is the period that ML has to analyze before opening an additional S-LINK channel when current data throughput is higher than NORM-TH:

FAST-TIME: | Time-out for FAST opening of additional SLinks
10 | 5-100 (seconds)

This is the period that ML has to analyze before opening an additional S-LINK channel when current data throughput is higher than FAST-TH:

Drx-pool: | Rx pool size for DATA frame
30 | 1-255 (KBytes)

This is the amount of DATA frames (in Kbytes) that ML can handle when receiving from remote ML.

DRX-TOUT: | Rx time out for DATA frame
3000 | 50-10000 (msec)

This parameter indicate when DATA frames hold in ML pool (DRX-POOL:) must be considered in time-out and then directly forwarded to higher layer. This situation could happen when previous frame was not yet arrived and ML was waiting for it before submitting next datagram to higher layer.

Vrx-pool: | Rx pool size for VOICE frame
10 | 1-255 (KBytes)

This is the amount of VOICE frames (in Kbytes) that ML can handle when receiving from remote ML.

Vtx-pool: | Tx pool size for VOICE frame
10 | 1-255 (KBytes)

This is the amount of VOICE frames (in Kbytes) that ML can handle when sending them remote ML. This is needed because could happen that several voice frames cannot be sent to a specific LINK because of, for example, this link went down. In this case, ML cannot stop the voice frame stream because other voice frames probably were sent on other working LINKs, so, only VOICE that cannot be temporally sent are stored into this pool.

VTX-TOUT: | Tx time out for VOICE frame
500 | 100-3000 (msec)

This time-out is used when several voice frames are present in VOICE pool (see VTX-POOL:) and they were hold more than VTX-TOUT. This method is to avoid that once VOICE frames can be sent (because for example another link were opened), they are not too old for the remote side.

SLINK: | Identifier of the Abilis CPX port of S-Link level
200 | 1 - 999, NONE

It defines the S-Link port of lower level, it can be of EIR or Q931 type.

If the S-Link port is not desired, the parameter has to be set to "NONE".

Chan: | Number of S-Link configured
0 | 0-32

This parameter indicates how many SLINK channels are managed by ML.

This doesn't mean that can be always opened CHAN SLINKs. Also CHAN-LIMIT: must be considered.

CHAN-LIMIT: | Maximum number of openend S-Link
0 | 0-CHAN:

Specify the maximum number of SLINK channels that can be opened by ML.

CDOMAXCONN: | Output called address maximum number of connections
2 | 0-32

This parameter indicates how many SLINK channels can be opened using CDO number.

If ML needs to open a new SLINK (due to throughput, see NORM-TH: and FAST-TH:) and the number of SLINK opened using CDO: is the same of CDOMAXCONN, then no more SLINK will be opened, even if present in configuration.

CDONRTY: | Maximum number of call repetitions
5 | 0 - 65534, NOMAX

It specifies the maximum number of call repetitions for the S-Link channel when the connection cannot be established. Once attempts are exhausted the S-Link chennel is place in STOPPED1 state.

Warning! If the channel is established BUT the "link-check protocol" detects link-check failure for three times consecutively the port is placed in STOPPED2 state regardless the NRTY counter.

Value | Meaning
0 | Outgoing calls are disabled.
1-65534 | Calls are repeated as many times as the value.
NOMAX | Calls are repeated indefinitely.
CGI: | Calling address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

It sets up the calling address, that the incoming call must contain.

The character "*" means "any number".

SGI: | Calling sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

It sets up the calling sub-address, that the incoming call must contain.

The character "*" means "any character".

CDI: | Called address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

It sets up the called address, that the incoming call must contain.

The character "*" means "any number".

SDI: | Called sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

It sets up the called sub-address, that the incoming call must contain.

The character "*" means "any character".

CGO: | Calling address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

It sets up the calling number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling address.

SGO: | Calling sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

It sets up the calling sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling sub-address.

CDO: | Called address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

It sets up the called number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called address.

SDO: | Called sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

It sets up the called sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called sub-address.

Pl: | P-Link port identifier
1 | 1-32

It identifies the PLINK configured in ML list. Can be considered as an index and it is used to access PLINK parameters.

ST: | P-Link port state
DELETED | NEW, DELETED, RUNNING

Status of the PLINK configuration.

NEW: PLINK is added in ML configuration, but it is not yet operative (ML needs to be restarted).

DELETED: PLINK is removed from ML configuration, but it is yet present into ML resources, even if no more used (ML needs to be restarted to completely remove it from memory).

RUNNING: PLINK is present in configuration and working. This is the only status where ML can send/receive datagrams on this P-LINK.

LOWPO: | Identifier of the Abilis CPX port of P-Link level
NONE | 1 - 999, NONE

It defines the P-Link port of the lower level, which can only be SYNC, FR, ISDN, PLINKE or EIR type.

If no P-Link port is required, the value "NONE" must be set.

SPEED: | Line speed
64000 | (Kbit/sec)

This is the maximum bandwidth on the P-LINK. This field is very important because it is used when calculating throughput percentage (see NORM-TH: and FAST-TH:).

BCHAN: | Identifier of the channel B to use (only if the P-Link is an ISDN port type)
B1 | B1, B2

The parameter appears and can be modified only if the port referred by the parameter LOWPO: is an ISDN Basic Rate port type, i.e. the service provided by "only data" ISDN adaptors.

It defines the channel to be used on the lower level ISDN port.

DLCI: | Identifier of the DLCI to use (only if the P-Link is a FR port type)
NONE | 16-991, 1024-63487, 131072-8126463, NONE

The parameter appears and can be modified only if the PLINK referred is a FR port type.

It defines the identifier of the DLCI to use the lower lever FR port.

The value "NONE" means "no DLCI" and it disables the connection with the lower level FR port.

The validity of allowed values intervals for the DLCI identifier depends on the length of the header Frame-Relay in use:

Value | Meaning
NO | No cryptography is applied.
DATA | Cryptography is applied only on DATA traffic type.
VOICE | Cryptography is applied only on VOICE traffic type.
ALL | Cryptography is always in use, whatever is the traffic data type.
CC: | Activation of the congestion control
YES | NO, YES

The parameter appears and can be modified only if the port referred by the parameter PL: is a FR port type.

It makes possible to apply or to not apply the throughput reduction as reaction to congestion notifications.

warning! Not obeying to congestion notification may cause severe malfunctioning, therefore we strongly reccommend to always use CC:YES. Ignoring congestion notification may be needed for some testing activities, certainly not during the regular work.

SC: | Value of the constant "step count", used in congestion control (only if the P-Link is a FR port type)
4 | 1 - 50

The parameter appears and can be modified only if the port referred by the parameter PL: is a FR port type.

It sets how many consecutive frames with BECN=1 have to be received for reducing the throughput, according to the rule fixed by ANSI T1.618 annex A §2.1.1.

Value 4 suits the most frequent situations, however the right value can be evaluated by using the Calculator.

CIR: | Value of "Committed Information Rate" (only if the P-Link is a FR port type)
0 | 0, 4800 - 2500000 in bit/sec

The parameter appears and can be modified only if the port referred by the parameter PL: is a FR port type.

It defines the value of "Committed Information Rate", i.e. the throughput the frame-relay network has to guarantee in normal working conditions. This throughput is measured in the time interval TC (Time Committed) given by the following formula: TC=BC/CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BC: | Value of "Burst Committed" (only if the P-Link port is a FR port type)
0 | 0, 2400 - 5000000 in bits

The parameter appears and can be modified only if the port referred by the parameter PL: is a FR port type.

It defines the "Burst Committed", i.e. the number of bits the network can accept, during the time interval TC, to guarantee the CIR.

If the network is congested, it sends a signal (BECN or FECN) that require the user to progressively reduce his throughput to values smaller than CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BE: | Value of "Burst Excess" (only if the P-Link is a FR port type)
0 | 0 - 5000000 in bits

The appears and can be modified only if the port referred by the parameter PL: is a FR port type.

It defines the "Burst Excess", i.e. the number of bits in excess that the network can manage, during the time interval TC, if there is availability of exceeding resources. The "exceeding throughput" is evaluated by using the following formula ThExcess=BE*TC.

When the network does not have resources in excess sends a signal (BECN or FECN) that engages the user to immediately limit the throughput to the value of the CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

VSP-ID: | Service identifier (only if the P-Link is a EIR port type)
NONE | NONE, 1 - 32

This parameter indicates which Virtual Synchronous Port (VSP) of those defined in the TDM table the ML must use.

Statistics of the ML ports top

Example of how to check the state and statistics of ML ports by the command D S

[17:09:33] ABILIS_CPX: D S PO:521

PO:521 ------------------------------------------------------------------------
ML     STATE:DOWN  PLINKs:ALL-DOWN   CHANs:STOPPED1 ROLE-Cur/Conf:MASTER/MASTER
                   Max-BW:0          Cur-BW:0              N-DOWN:1
       - Data: ---------|-------INPUT-------|-------OUTPUT------|-Thresholds--|
              Avail-BW: |0                  |0                  |             |
       NORM-Throughput: |         0/  0/ 50 |         0/  0/ 50 |0            |
       FAST-Throughput: |         0/  0/ 75 |         0/  0/ 75 |0            |
       - Voice: ------------------------------------|---INPUT----|--OUTPUT----|
       CHANs:0          BW:0            Throughput: | 0          | 0          |
       ------------------------------------------------------------------------
       PL:1    ST:CONNECTED  DN1:0                     DN2:0
       ------------------------------------------------------------------------
       MAX-RTY:0           CUR-RTY:0           DDT:18     VDT:30
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|CUR-CALL   |          0|          0|
       ------------------------------------------------------------------------

[17:09:36] ABILIS_CPX:

Example of how to check the extended statistics of ML ports by the command D SE

[17:10:47] ABILIS_CPX: d se po:521

PO:521 ------------------------------------------------------------------------
ML     --- Cleared 000:00:01:55 ago, on 03/04/2002 at 17:09:00 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|FRM        |          0|          0|
       CHR-D      |          0|          0|FRM-D      |          0|          0|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       LOST-D     |          0|           |BAD-FRM    |          0|          0|
       LOST-V     |          0|          0|CRYPTO-ERR |          0|          0|
       D-TOUT     |          0|           |D-OUT-SEQ  |          0|           |
       D-MISSING  |          0|           |D-RESYNC   |          0|           |
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|CUR-CALL   |          0|          0|
       ------------------------------------------------------------------------
       ------------------------------------------------------------------------
       PR CDO                  ST   SUCC-CALL  FAIL-CALL  TIME-CALL  CUR-CALL
       ------------------------------------------------------------------------
       1  12345                GOOD 3          2          10         500

[17:10:55] ABILIS_CPX:

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows both the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the ML state fields and statistics

STATE: | Current state of the ML driver
 | DOWN, READY, ERR

It shoes the current state of the ML port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
ML | DOWN | Both PLINKs and CHANs states are DOWN |  |  | DN
 | READY | Port is active |  |  | RD
 | ERR | Software error, contact Abilis assistance. |  |  | NA

PLINKs: | Status of PLINKs.
 | ALL-DOWN, ALL_READY, SOME-READY, ERR

Indicates the global PLINK status. The information is the result of all the PLINKs configured in ML.

Value | Meaning
ALL-DOWN | All the PLINKs in ML are in DOWN state.
ALL-READY | All the PLINKs in ML are in DOWN state.
SOME-READY | At least one PLINK in ML is in READY state, the remaining PLINKs are DOWN.
ERR | Software error, contact Abilis assistance.
CHANs: | Status of SLINKs.
 | STOPPED1, READY, ERR

Indicates the status of SLINK channels.

Value | Meaning
STOPPED1 | ML cannot make other outgoing calls on SLINK due to errors.
READY | ML can attempt to open a SLINK.
ERR | Software error, contact Abilis assistance.
ROLE: | Current/configured ML role.
 | SLAVE - MASTER

Indicates the current ML ROLE and the value in the ROLE set in configuration. This information is useful because when both MLs are set as MASTER, they are automatically forced to SLAVE. In this way will be detected soon that a configuration error occurs.

MAX-BW: | Max bandwidth.
 | 0-99999999 (bps)

Indicates the maximum bandwidth that ML could reach if ALL its LINKs were open. In order to have more bandwidth will be necessary to increase the number of LINKS.

CUR-BW: | Current bandwidth.
 | 0-99999999 (bps)

Indicates the current bandwidth available in ML. This information is calculated making a sum of the bandwith of all the LINKS currently open.

N-DOWN: | Counter of DOWN states.
 | 0 - 4.294.967.295

This statistic indicates how many times the ML state went DOWN. The DOWN state is reached when ALL PLINKs configured are DOWN and when SLINKs cannot be opened.

Avail-BW: | Available DATA bandwidth.
 | 0 - 4.294.967.295

Indicates the available bandwidth for DATA throughput. It is calculated making the difference between the Cur-BW and the sum of the theoretical throughput of all the VOICE frames (BW:).

NORM-Throuhput: | Normal throughput informations.

This table row indicates several things. 3 columns are present: the first and the second column contain the information about current data throughput and thresholds percentage. The first field has the current throughput of DATA frames. Throughput is calculated making an average of the DATA throughput on the last NORM-TIME seconds and the available bandwidth (Avail-BW). The second field is the percentage of the DATA throughput previously described. This percentage is calculated on the available data bandwidth. The third field contains the configured normal threshold NORM-TH. In the third column there is the threshold information: it indicates how many time the percentage calculated on data throughput was greated than normal threshold configured NORM-TH.

FAST-Throuhput: | Fast throughput informations.

This row contains similar informations to NORM-Throuhput. The difference is that throughput is calculated on last FAST-TM seconds, and the percentage threshold is FAST-TH.

CHANs: | Number of voice channels currently opened.
 | 0 - 239

Indicates the number of voice channels that are currently opened by upper layer. ML detects the number of opened channels analizing the informations present in voice frames.

BW: | Theoretical throughput of voice frames.
 | 0 - 4.294.967.295

A distinction must be done about theoretical and real throughput. To calculate real throughput, ML analyses every second the amount of BITs sent/received on VOICE frames. About theoretical throughput, it is the result of the sum of the bandwidth declared by upper layer when opening VOICE channel.

Throughput: | Real VOICE frames throughput
 | 0 - 4.294.967.295

To calculate real throughput, ML analyses every second the amount of BITs sent/received on VOICE frames. The result will be a value expressed in bits per seconds..

PL: | PLink indicator.
 | 1 - 32

It indicates for which PLINK the informations on this row are referred to.

ST: | Status of the PLINK.
 | CONNECTED

Indicates the current status of the PLINK.

DN1: | DOWN1 counter.
 | 0 - 4.294.967.295

Indicates how many times this PLINK went in DOWN1 state.

DN2: | DOWN2 counter.
 | 0 - 4.294.967.295

Indicates how many times this PLINK went in DOWN2 state.

MAX-RTY: | MAX SLINK retries.
 | 0 - RTY

It indicates the RTY parameter set in ML configuration. In this way will be made a fast comparison with current retries (CUR-RTY).

CUR-RTY: | Current SLINK retries.
 | 0 - RTY

It indicates the current number of retries attempted by ML in order to open a SLINK.

DDT: | DATA Disconnection time.
 | 0 - DDT

This parameter indicates the time elapsed when ML has started to analyse throughput of DATA frames. For more informations see DDT:

VDT: | VOICE Disconnection time.
 | 0 - VDT

This parameter indicates the time elapsed when ML has started to analyse throughput of VOICE channels. For more informations see VDT:

FAIL-CALL: | Unsuccessfull SLINK calls.
 | 0 - 4.294.967.295

Indicates the number of times the ML tried to open a SLINK but it cannot.

SUCC-CALL: | Successfull SLINK calls.
 | 0 - 4.294.967.295

Indicates the number of times that ML opened a SLINK successfully.

TIME-CALL: | SLINK connection counter.
 | 0 - 4.294.967.295 (seconds)

Indicates the sum of seconds that every SLINK was connected from REBOOT or from ML RESTART (or when statistics were cleared). This statistic make a distinction about incoming and outgoing calls and takes care also of the SLINK currently connected.

CUR-CALL: | Current SLINK open connection counter.
 | 0 - 4.294.967.295 (seconds)

Indicates the sum of seconds of the current opened SLINKs.

CHR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHR (INPUT) is incremented every time a frame is received. The counter CHR (OUTPUT) is incremented every time a frame is sent.

FRM: | Number of received/sent frame
 | 0 - 4.294.967.295

The counter FRM (INPUT) is incremented every time a frame is received. The counter FRM (OUTPUT) is incremented every time a frame is sent.

CHR-D: | Number of received/sent DATA characters
 | 0 - 4.294.967.295

The counter CHR-D (INPUT) is incremented every time a DATA frame is received. The counter CHR-D (OUTPUT) is incremented every time a DATA frame is sent.

CHR-C: | Number of received/sent Link-Check characters
 | 0 - 4.294.967.295

The counter CHR-C (INPUT) is incremented every time a Link-Check frame is received. The counter CHR-C (OUTPUT) is incremented every time a Link-Check frame is sent.

CHR-V: | Number of received/sent VOICE characters
 | 0 - 4.294.967.295

The counter CHR-V (INPUT) is incremented every time a VOICE frame is received. The counter CHR-V (OUTPUT) is incremented every time a VOICE frame is sent.

FRM-D: | Number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter FRM-D (INPUT) is incremented every time a DATA frame is received. The counter FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

FRM-C: | Number of received/sent Link-Check frames
 | 0 - 4.294.967.295

The counter FRM-C (INPUT) is incremented every time a Link-Check frame is received. The counter FRM-C (OUTPUT) is incremented every time a Link-Check frame is sent.

FRM-V: | Number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

LOST-D: | Number of DATA frames sent and lost
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time a DATA frame is discarded because there are no available receiving buffers.

BAD-FRM: | Number of frames received in a bad format
 | 0 - 4.294.967.295

Number of frames received in a bad format.

LOST-V: | Number of VOICE frames sent and lost.
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time a VOICE frame is discarded because there are no available receiving buffers.

CRYPTO-ERR: | Cipher error.
 | 0 - 4.294.967.295

Input: Number of received frames discarded due to bad ciphering or missing cipher key.

Output: Number of sending frames discarded due to missing cipher key.

D-TOUT: | DATA frames time-out
 | 0 - 4.294.967.295

Is used to indicate how many times the receiver DATA buffer gone in time-out due to missing DATA frame.

D-OUT-SEQ: | Out of sequence DATA frames.
 | 0 - 4.294.967.295

Number of out-of-sequence DATA frames received.

D-MISSING: | Missing data frames.
 | 0 - 4.294.967.295

Number of datagram lost due to re-sequence of DATA frames.

D-RESYNC: | Resync request.
 | 0 - 4.294.967.295

Number of resincronisation requests.

PR: | CDO number priority list identifier.
 | 0 - 4.294.967.295

Indicates the priority of this CDO number. Lower is the number, higher is the priority.

CDO: | Called address of the outgoing call.
 | from 1 up to 20 numerical characters [0- 9], #

Indicates the called number of the outgoing call.

ST: | Status of CDO number.
 | STOP, GOOD, ERR

Indicate the status of CDO number. If GOOD, this number can be used for outgoing calls. If STOP, this number will no more used for calling until an INIT or a RESTART of ML port.

Value | Meaning
STOP | ML will use no more this number for calling until an INIT or a RESTART.
READY | This CDO number can be used by ML for outgoing calls.
ERR | Software error, contact Abilis assistance.
SUCC-CALL: | Successfull SLINK calls.
 | 0 - 4.294.967.295

Indicates the number of times that ML opened a SLINK successfully.

FAIL-CALL: | Unsuccessfull SLINK calls.
 | 0 - 4.294.967.295

Indicates the number of times the ML tried to open a SLINK with this CDO number, but it cannot.

TIME-CALL: | SLINK connection counter.
 | 0 - 4.294.967.295 (seconds)

Indicates the sum of seconds that this CDO number used by a SLINK establish a connection from REBOOT or from ML RESTART (or when statistics were cleared). This statistic indicates only outgoing calls and takes care also of the SLINK currently connected.

CUR-CALL: | Current SLINK open connection counter.
 | 0 - 4.294.967.295 (seconds)

Indicates the sum of seconds of the current opened SLINKs by CDO number.

SNMP traps generated for the ML port top

The SNMP Agent of Abilis CPX is able to generate traps owing to meaningful state changes pertinent either to P-Link or S-Link channels of the ML.

SNMP traps generated for global state changes pertinent to all P-Link channels of the ML port

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for ML ports.

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
53 | cxTrapMlAllPLinksDown | cxPortIndex, cxPortType, cxMlDiagGlobalPLinkState, cxMlDiagGlobalSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that all P-Links of a ML port currently running are in DOWN state.
54 | cxTrapMlAllPLinksReady | cxPortIndex, cxPortType, cxMlDiagGlobalPLinkState, cxMlDiagGlobalSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that all P-Links of a ML port currently running are in READY state.
55 | cxTrapMlSomePLinksReady | cxPortIndex, cxPortType, cxMlDiagGlobalPLinkState, cxMlDiagGlobalSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that some P-Links of a ML port currently running are in READY state.

SNMP traps generated for global state changes pertinent to all S-Link channels of the ML port

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for ML ports.

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
56 | cxTrapMlSLinksStopped1 | cxPortIndex, cxPortType, cxMlDiagGlobalPLinkState, cxMlDiagGlobalSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that all S-Links of a ML port currently running are in STOPPED1 state.
57 | cxTrapMlSLinksReady | cxPortIndex, cxPortType, cxMlDiagGlobalPLinkState, cxMlDiagGlobalSLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that all S-Links of a ML port currently running are in READY state.

SNMP traps generated for a single P-Link channel of the ML port

The traps listed below are generated only when the "T+E" options are set in the LOG: parameter, i.e. it is required an extension of the basic SNMP traps generation functionality.

Trap own code | Mnemonic of the trap | SNMP variables reported in the trap | Description
58 | cxTrapMlPLinkDown | cxPortIndex, cxPortType, cxMlDiagPLinkIndex, cxMlDiagPLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that a single P-Link of a ML port currently running is in DOWN state.
59 | cxTrapMlPLinkUp | cxPortIndex, cxPortType, cxMlDiagPLinkIndex, cxMlDiagPLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time it recognizes that a single P-Link of a ML port currently running is in UP state.

Details of the SNMP variables reported in the ML traps

cxPortIndex | FR port, which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the ML port, which the trap refers to
 | type - description

This variable reports either the port type which the trap refers to (in this case it will be ML) and the description that eventually the user can give to the CPX port.

cxMlDiagGlobalPLinkState | Global P-Link channels state
 | all-down(0), all-ready(1), some-ready(2)

This variable reports the current value of the global P-Link channels state.

SNMP variable value | Corresponding Global P-Link channels state
all-down(0) | ALL-DOWN
all-ready(1) | ALL-READY
some-ready(2) | SOME-READY
cxMlDiagGlobalSLinkState | Global S-Link channels state
 | stopped1(0), ready(1)

This variable reports the current value of the global S-Link channels state.

SNMP variable value | Corresponding Global S-Link channels state
stopped1(0) | STOPPED1
ready(1) | READY
cxMlDiagPLinkIndex | P-Link channel indentifier
 | 1 - 32

This variable reports the P-Link channel identifier for which the trap is generated.

cxMlDiagPLinkState | P-Link channel state
 | none(0), link-np(1), link-err(2), down1(3), down2(4), ready(5), listening(6), called(7), calling(8), connected(9), clearing(10), cleared(11), undefined(12)

This variable reports the current state of the P-Link channel, which the trap refers to. The following table shows the relationship between the state values, referred by the SNMP variables, and the states carried out by executing the command D S.

SNMP variable value | Corresponding P-Link channel state
none(0) | NONE
link-np(1) | LINK-NP
link-err(2) | LINK-ERR
down1(3) | DOWN1
down2(4) | DOWN2
ready(5) | READY
listening(6) | LISTENING
called(7) | CALLED
calling(8) | CALLING
connected(9) | CONNECTED, CONN-TO, CONN-FROM
clearing(10) | CLEARING
cleared(11) | CLEARED
undefined(12) | UNDEFINED
sysUpTime | Elapsed time since the system has been started by the occurred event
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable reports the elapsed time (in cents of second) since the occurred event, which has generated the SNMP, started the system. This value is usually shown by using the format days:hours:minutes:seconds.


Point-to-Point Protocol (PPP) port

Revised for CPX 4.3.0.
PPP-specific terminology
PPP protocol overview
PPP port configuration
PPP port statistics and diagnostics
SNMP traps generated for the PPP ports
PPP port debug commands

PPP-specific terminology top

Host
Host is a computer or other device at the end of a link.
Point-to-Point
The point-to-point link is a connection between two hosts only (called peers in this case). For example, direct cable connection is a Point-to-Point connection, unlike Ethernet.
LCP
Protocol, determining basic capabilities of a PPP link
NCP
Protocol, determining options specific for a certain upper layer protocol (e.g. IP or IPX)

PPP protocol overview top

The Point-to-Point Protocol (PPP), specified in RFC 1661, provides a standard method for transporting multi-protocol datagrams over point-to-point links.

PPP is designed for simple links that transport packets between two peers. These links provide full-duplex simultaneous bi-directional operation, and are assumed to deliver packets in order. It is intended that PPP provide a common solution for easy connection of a wide variety of hosts, bridges and routers.

PPP is not a single protocol, but consists of several partly dependent protocols, of which LCP, IPCP and authentication protocols are of the most importance.

Link Control Protocol

The Link Control Protocol (LCP) is the base of PPP, negotiating basic link parameters such as timeouts, retries and authentication. It is build as the finite state automaton, having 10 states and driven by such events as link up/down, incoming packets and timeouts.

IP Control Protocol

The IP Control Protocol (IPCP) is an example of a Network Control Protocol (NCP), and is responsible for transporting IP traffic over a PPP link. Like LCP, it has the form of a finite state automaton, though a bit simplified. It negotiates IP addresses, DNS addresses and IP compression.

Authentication protocols

This PPP implementation makes use of one of the following protocols: PAP (Password Authentication Protocol), CHAP (Challenge-Handshake Authentication Protocol) and MS-CHAP (Microsoft CHAP) versions 1 and 2.

PAP is a simple plain-text protocol, requiring user to send username and password and server to respond with appropriate response. Due to its simplicity it is the most widespread protocol, but it is not very secure because of password transmitted in plain text form.

CHAP is more advanced protocol. Here client does not send password in plain form, but rather sends a value, derived from username, password and some data received from server. The process of calculating this value ("hashing") is such that it does not allow reconstructing password from it, thus making interception inefficient. However, it still requires both server and user to store password in plain text form, thus being vulnerable to theft attacks.

Microsoft has developed its own version of CHAP, solving this problem. There are two versions of MS-CHAP: version 1 and version 2. the latter being the most secure. Both are supported by current version.

For more information, consult the following documents:

  • RFC 1661 "The Point-to-Point Protocol (PPP)"
  • RFC 1662 "PPP in HDLC-like Framing"
  • RFC 1570 "PPP LCP Extensions"
  • RFC 1332 "The PPP Internet Protocol Control Protocol (IPCP)"
  • RFC 1877 "PPP Internet Protocol Control Protocol Extensions for Name Server Addresses"
  • RFC 1144 "Compressing TCP/IP Headers for Low-Speed Serial Links"
  • RFC 1334 "PPP Authentication Protocols"
  • RFC 1994 "PPP Challenge Handshake Authentication Protocol (CHAP)"
  • RFC 2433 "Microsoft PPP CHAP Extensions"
  • RFC 2759 "Microsoft PPP CHAP Extensions, Version 2"

PPP port configuration top

The PPP port is provided with the parameters described in this section.

The layout of the PPP port parameters changes considerably according to the used lower layer port type.

PPP over SYNC.

[13:51:12] ABILIS_CPX: D P PO:541 .
PO:541 ------------------------------------------------------------------------
PPP    LOG:DS           LOWPO:1
       - Tcp-MSS/Lcp/IpCp -----------------------------------------------------
       TCP-MSS-CLAMP:YES  TCP-MSS-VALUE:1414
       maxmru:1500        DNS:NO
       - Authentication -------------------------------------------------------
       USERNAME:myuserid                          LOCAL:CHAP
       PASSWORD:********************************
       SERVNAME:                                  REMOTE:CHAP
       REPEAT:0

PPP over FRAME-RELAY.

[13:51:12] ABILIS_CPX: D P PO:541 .
PO:541 ------------------------------------------------------------------------
PPP    LOG:DS           LOWPO:101        DLCI:16
       CIR:19200        BC:19200         BE:0             SC:4      CC:YES
       - Tcp-MSS/Lcp/IpCp -----------------------------------------------------
       TCP-MSS-CLAMP:YES  TCP-MSS-VALUE:1414
       maxmru:1500        DNS:NO
       - Authentication -------------------------------------------------------
       USERNAME:myuserid                          LOCAL:CHAP
       PASSWORD:********************************
       SERVNAME:                                  REMOTE:CHAP
       REPEAT:0

PPP over ISDN.

[13:51:12] ABILIS_CPX: D P PO:541 .
PO:541 ------------------------------------------------------------------------
PPP    LOG:DS           LOWPO:17      BCHAN:B2
       - Tcp-MSS/Lcp/IpCp -----------------------------------------------------
       TCP-MSS-CLAMP:YES  TCP-MSS-VALUE:1414
       maxmru:1500        DNS:NO
       - Authentication -------------------------------------------------------
       USERNAME:myuserid                          LOCAL:CHAP
       PASSWORD:********************************
       SERVNAME:                                  REMOTE:CHAP
       REPEAT:0

PPP over EIR (S-LINK).

[13:51:12] ABILIS_CPX: D P PO:541 .
PO:541 ------------------------------------------------------------------------
PPP    LOG:DS           LOWPO:200     VSPID:NONE   DT-IN:300     DT-OUT:300
       - Dial-in --------------------------------------------------------------
       DIAL-IN:YES   CGI:*                     SGI:*
                     CDI:*                     SDI:*
       - Dial-out -------------------------------------------------------------
       DIAL-OUT:YES  RTY:LIN     NRTY:5      NRTY2:3      NRTY3:3      TB:3
                     CGO:#                     SGO:#
                     CDO:#                     SDO:#
       - Tcp-MSS/Lcp/IpCp -----------------------------------------------------
       TCP-MSS-CLAMP:YES  TCP-MSS-VALUE:1414
       maxmru:1500        DNS:NO
       - Authentication -------------------------------------------------------
       USERNAME:myuserid                          LOCAL:CHAP
       PASSWORD:********************************
       SERVNAME:                                  REMOTE:CHAP
       REPEAT:0

PPP over EIR (P-LINK).

[13:51:12] ABILIS_CPX: D P PO:541 .
PO:541 ------------------------------------------------------------------------
PPP    LOG:DS           LOWPO:200     VSPID:1
       - Tcp-MSS/Lcp/IpCp -----------------------------------------------------
       TCP-MSS-CLAMP:YES  TCP-MSS-VALUE:1414
       maxmru:1500        DNS:NO
       - Authentication -------------------------------------------------------
       USERNAME:myuserid                          LOCAL:CHAP
       PASSWORD:********************************
       SERVNAME:                                  REMOTE:CHAP
       REPEAT:0

To activate changes made on the low case parameters it is needed to restart the system, on the contrary for the high case ones, it is enough to execute the initialization command INIT PO:.

Detail of the PPP port parameters

LOWPO: | Identifier of the lower level Abilis CPX port
NONE | 1 - 999, NONE

Sets the lower level port; it can be any P-LINK or an S-LINK port.

The value "NONE" makes the PPP port unusable.

BCHAN: | Identifier of the channel B to use
B1 | B1, B2

The parameter appears and can be modified only if the lower port is an ISDN Basic Rate port type, i.e. the service provided by "only data" ISDN adaptors.

Defines the channel to be used on the lower level ISDN port.

DLCI: | Identifier of the DLCI to use
NONE | 16-991, 1024-63487, 131072-8126463, NONE

The parameter appears and can be modified only if the lower port is a FR port type.

Defines the identifier of the DLCI to use the lower lever FR port.

The value "NONE" means "no DLCI" and it disables the connection with the lower level FR port.

The validity of allowed values intervals for the DLCI identifier depends on the length of the header Frame-Relay in use:

Value | Meaning
NO | No cryptography is applied.
DATA | Cryptography is applied only on DATA traffic type.
VOICE | Cryptography is applied only on VOICE traffic type.
ALL | Cryptography is always in use, whatever is the traffic data type.
CC: | Activation of the congestion control
YES | NO, YES

The parameter appears and can be modified only if the lower port is a FR port type.

Makes possible to apply or to not apply the throughput reduction as reaction to congestion notifications.

warning! Not obeying to congestion notification may cause severe malfunctioning, therefore we strongly recommend to always use CC:YES. Ignoring congestion notification may be needed for some testing activities, certainly not during the regular work.

SC: | Value of the "step count" for Congestion Control
4 | 1 - 50

The parameter appears and can be modified only if the lower port is a FR port type.

Sets how many consecutive frames with BECN=1 have to be received for reducing the throughput, according to the rule fixed by ANSI T1.618 annex A §2.1.1.

Value 4 suits the most frequent situations, however the right value can be evaluated by using the Calculator.

CIR: | Value of "Committed Information Rate"
0 | 0, 4800 - 2500000 in bit/sec

The parameter appears and can be modified only if the lower port is a FR port type.

Defines the value of "Committed Information Rate", i.e. the throughput the frame-relay network has to guarantee in normal working conditions. This throughput is measured in the time interval TC (Time Committed) given by the following formula: TC=BC/CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BC: | Value of "Burst Committed"
0 | 0, 2400 - 5000000 in bits

The parameter appears and can be modified only if the lower port is a FR port type.

Defines the "Burst Committed", i.e. the number of bits the network can accept, during the time interval TC, to guarantee the CIR.

If the network is congested, it sends a signal (BECN or FECN) that require the user to progressively reduce his throughput to values smaller than CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

BE: | Value of "Burst Excess"
0 | 0 - 5000000 in bits

The appears and can be modified only if the lower port is a FR port type.

Defines the "Burst Excess", i.e. the number of bits in excess that the network can manage, during the time interval TC, if there is availability of exceeding resources. The "exceeding throughput" is evaluated by using the following formula ThExcess=BE*TC.

When the network does not have resources in excess sends a signal (BECN or FECN) that engages the user to immediately limit the throughput to the value of the CIR.

The set up value must correspond to that one established by contract with the operator of the frame-relay network.

VSP-ID: | Service Identifier
NONE | NONE, 1 - 32

The parameter appears and can be modified only if the lower port is a EIR port type.

This parameter indicates which Virtual Synchronous Port (VSP) of those defined in the TDM table the PPP must use.

DT-IN: | Disconnect timer on incoming call
300 | numeric

The parameter appears and can be modified only if the lower port is any S-LINK, e.g. EIR port type with VSPID=NONE.

This parameter specifies inactivity timer for incoming calls, i.e if this PPP is called from outside and link is idle for this time, connection will be terminated.
Note that in this case only incoming packets are counted - packets coming from us to the client are not counted as activity.

DT-OUT: | Disconnect timer on outgoing call
300 | numeric

The parameter appears and can be modified only if the lower port is any S_LINK, e.g. EIR port type with VSPID=NONE.

This parameter specifies inactivity timer for outgoing calls, i.e if this PPP itself called a remote host and link is idle for this time, connection will be terminated.

Note that in this case only outgoing packets are counted - packets coming from the server are not counted as activity.

DIAL-IN: | Incoming call allowance
YES | NO, YES

Determines if this PPP will answer incoming calls, i.e. serve as a Dial-Up Server.
Usually only one of DIAL-IN and DIAL-OUT should be set.

CGI: | Calling address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

Sets up the calling address, that the incoming call must contain.

The character "*" means "any number".

SGI: | Calling sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

Sets up the calling sub-address, that the incoming call must contain.

The character "*" means "any character".

CDI: | Called address of the incoming call
* | from 1 up to 20 numerical characters [0- 9], *

Sets up the called address, that the incoming call must contain.

The character "*" means "any number".

SDI: | Called sub-address of the incoming call
* | from 1 up to 20 alphanumerical [0- 9, a - z, A- Z], *

Sets up the called sub-address, that the incoming call must contain.

The character "*" means "any character".

DIAL-OUT: | Outgoing call allowance
YES | NO, YES

Determines if this PPP is allowed to make outgoing calls, e.g. call an ISP.
Usually only one of DIAL-IN and DIAL-OUT should be set.

RTY: | Calls repetition rule on failures
INC | LIN, INC, US

Allows to select the calls repetition rule on the S-Link channel following an unsuccessful call, and if the attempts are exhausted the S-Link channel is placed in STOPPED1 state.

If the switched connection is established the attempts counter is reset (connection was established!), however if "link-checks" are active a "second level verification" is executed and if it fails the connection is classified as "link-check failure". Three consecutives "link-check failures" forces the S-Link channel in STOPPED2 state preventing any further outgoing or incoming call!

Warning! The behaviour upon exhausted attempts is slightly different when RTY:US, see below or details.

Value | Calls repetition rules
LIN The time interval between a call attempt and the next one is fixed and configurable through the parameter TB:.
INC | The time interval between a call attempt and the next one, is doubled at every attempt, starting with the value defined in the parameter TB:.
US The abbreviation "US" stands for "unattended site".
In this case the S-Link channel driver activates the following procedure until success:
  1. the driver executes a number of tries equal to the value of the parameter NRTY: every TB: seconds, or until three consecutive "link-check" errors occur;
  2. the driver makes 8 calls every 15 minutes;
  3. the driver makes 4 calls every 1 hour;
  4. the driver makes 9 calls every 2 hours;
  5. the driver makes 8 calls every 6 hours;
  6. the driver is placed in the state STOPPED1 or STOPPED2 caused by the last error;
This procedure allows an "automatic recovery" from critical situations within three days from the first failure occurrence, afterwards a maintenance intervention is required.

It is important to emphasize that points 2,3,4,5,6 of the procedure do not distinguish between failure's reason (connection not established or connection established with "link-check" error) until the last attempt is reached and the last failure reason is used to set the final state (STOPPED1 or STOPPED2).
NRTY: | Maximum number of CALL repetitions
5 | 0 - 65534, NOMAX

Specifies the maximum number of call repetitions for the S-Link channel when the connection cannot be established due to CALL command failure.
Once attempts are exhausted the port is placed in STOPPED1 state.

Info The behaviour upon exhausted attempts is slightly different when RTY:US.

Value | Meaning
0 | Outgoing calls are disabled.
1-65534 | Calls are repeated as many times as the value.
NOMAX | Calls are repeated indefinitely. For "RTY:INC" the time interval of calls after the 65535th will not increase further, keeping the interval TB: * 65535 seconds. For "RTY:US" the actual behaviour is identical to RTY:LIN because the condition that starts the "unattended site retries" will not be reached.
NRTY2: |
3 | 0 - 65534, NOMAX

Specifies the maximum number of call repetitions for the S-Link channel when the connection cannot be established due to negotiation timeout.
Once attempts are exhausted the port is placed in STOPPED2 state.

NRTY3: |
3 | 0 - 65534, NOMAX

Specifies the maximum number of call repetitions for the S-Link channel when the connection cannot be established due to negotiation failure (e.g. authentication error).
Once attempts are exhausted the port is placed in STOPPED3 state.

TB: | Time base interval between calls repetitions
3 | 3 - 255 (in seconds)

Defines the "base" time interval that the retry procedure set in RTY: uses to calculate the delay between a call attempt that fails and the next one.

CGO: | Calling address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

Sets up the calling number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling address.

SGO: | Calling sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

Sets up the calling sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the calling sub-address.

CDO: | Called address of the outgoing call
# | from 1 up to 20 numerical characters [0- 9], #

Sets up the called number of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called address.

SDO: | Called sub-address of the outgoing call
# | from 1 up to 6 alphanumerical [0- 9, a - z, A- Z], #

Sets up the called sub-address of the outgoing call.

The character "#" means "no number", if it is set, the outgoing call will not contain the called sub-address.

TCP-MSS-CLAMP: | Whether to perform TCP MSS clamping
NO | NO, YES

If set, forces PPP to change value of Maximum Segment Size in all TCP packets to one equal or lower than set with TCP-MSS-VALUE: option to avoid certain problems with PPP over Ethernet "black hole". Also can be used to reduce link latency at the cost of some bandwidth loss.

TCP-MSS-VALUE: | Maximal TCP MSS value to allow
1414 | 496-1452

Specifies maximal allowed value for TCP Maximum Segment Size option.

This option is only visible if MSS clamping is allowed via TCP-MSS-CLAMP: parameter.

MAXMRU: | Maximal value of MRU accepted
1500 | 1500 - 65535, NONE

Specifies the maximal value of MRU (Maximal Receive Unit) to be negotiated.
One can try increasing this value to improve performance slightly

Changes to this value cannot be applied without CPX restart.

DNS: | DNS addresses negotiation
NO | NO, RETRIEVE, PROVIDE

Specifies negotiation of DNS addresses with a remote host.

Value | Meaning
NO | No DNS address negotiation is performed.
PROVIDE | PPP can provide DNS addresses (if specified in corresponding IP Port) to a remote host. This is a common setting to be used on a Dial-Up Server.
RETRIEVE | PPP requests DNS addresses from a remote host. This is a typical setting while accessing an ISP.
USERNAME: | Login UserName
no value | up to 32 characters

Specifies UserName to authenticate to a remote peer.
Need not be set when operating as a Dial-Up Server.

PASSWORD: | Login Password
no value | up to 32 characters

Specifies Password to authenticate to a remote peer.
Need not be set when operating as a Dial-Up Server.

SERVNAME: | CHAP Server name
no value | up to 32 characters

Specifies this Server name to be sent along with CHAP Challenge.
Only needed for Dial-Up servers authorizing complicated clients with CHAP, usually can be left empty

LOCAL: | As-Client Authentication allowed
CHAP | NONE, any combination of PAP,CHAP,MSCHAP1,MSCHAP2

Specifies authentication protocols usable in Client mode, i.e if remote requires us to authenticate.

REMOTE: | As-Server Authentication allowed
CHAP | NONE, any combination of PAP,CHAP,MSCHAP1,MSCHAP2

Specifies authentication protocols usable in Server mode, i.e we'll require the remote to authenticate using one of these protocols.
Preference order is from most to least secure: MSCHAP2, MSCHAP1, CHAP, PAP.

REPEAT: | CHAP Repeating authentication
NONE | 1 - 999, NONE

Specifies how often, if ever, should CHAP require re-authentication while already connected, in seconds.
This parameter is intended to use when REMOTE:parameterr contains any CHAP protocol.

PPP port statistics and diagnostics top

[15:18:04] CPX-INTERNET:D S PO:541

PO:541 ------------------------------------------------------------------------
PPP    STATE:DOWN                LCP-PH:DEAD           IPCP-PH:DEAD
       LINK:READY                LCP-ST:STARTING       IPCP-ST:STARTING
       LOCAL-IP:000.000.000.000  REMOTE-IP:000.000.000.000
       ST1:0       ST2:0       ST3:0       TIME_CUR_CALL:0
       RTY:0       DT:0        USRTY:0     TDEL:0      TREM:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|           |           |           |
       AUTH-FAIL  |          0|          0|CHR        |          0|          0|
       PCK        |          0|          0|PCK-SYS    |          0|          0|
       DROPPED    |          0|           |LOST       |          0|           |
       ------------------------------------------------------------------------

[15:18:04] CPX-INTERNET:D SE PO:541

PO:541 ------------------------------------------------------------------------
PPP    --- Cleared 000:00:00:11 ago, on 03/09/2002 at 15:17:53 ----------------
       ST1:0       ST2:0       ST3:0       TIME_CUR_CALL:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       FAIL-CALL  |          0|          0|SUCC-CALL  |          0|          0|
       TIME-CALL  |          0|          0|           |           |           |
       AUTH-FAIL  |          0|          0|CHR        |          0|          0|
       PCK        |          0|          0|PCK-SYS    |          0|          0|
       DROPPED    |          0|           |LOST       |          0|           |
       ------------------------------------------------------------------------

STATE: | General PPP state
 | UP, DOWN, DELAYING, STOPPED1, STOPPED2, STOPPED3

States | Meaning
UP | PPP is either already connected or ready to connect.
DOWN | Lower layer not connected.
DELAYING | Temporarily unable to call due to delay after unsuccessful attempt. Incoming calls are accepted.
STOPPED1 | Unable to call due to call failure limit exceeded. Incoming calls are accepted.
STOPPED2 | Unable to call due to negotiation timeout limit exceeded. Incoming calls are accepted.
STOPPED3 | Unable to call due tonegotiationn failure limit exceeded. Incoming calls are accepted.
LINK: | Link state
 | NOTPRESENT, DOWN, READY, LISTENING, CONNECTED, CALLING, CALLED, CLEARING, CLEARED

Specifes state of a lower layer link.

States | Meaning
NOTPRESENT | Port specified by LOWPO: is not present or inactive.
DOWN | Link is down due to some lower layer problems.
READY | Link is ready to connect/listen.
LISTENING | Link is listening for an incoming call.
CONNECTED | Link is connected and ready to transmit data.
CALLING | Link is actively calling the remote host.
CALLED | Link is processing an incoming call.
CLEARING | Link is actively terminating existing connection.
CLEARED | Link was terminated from remote.
LCP-PH: | LCP Protocol phase
 | DEAD, ESTABLISHING, AUTHENTICATING, NETWORK, TERMINATING

Current LCP Protocol phase, Consult RFC 1661 for details

States | Meaning
DEAD | LCP is inactive.
ESTABLISHING | LCP is negotiating link parameters.
AUTHENTICATING | Authentication protocol is running.
NETWORK | LCP is ready to transmit upper layer traffic, NCPs can start.
TERMINATING | LCP is terminating a connection. Over P-LINK LCP never goes to DEAD state, remaining in this one.
LCP-ST: |
 | STARTING, STOPPED, STOPPING, REQSENT, ACKRCVD, ACKSENT, OPENED

Current LCP state

States | Meaning
STARTING | Waiting for lower link to go UP.
STOPPED | Work finished, waiting for lower link to go DOWN.
STOPPING | Terminate-Request sent.
REQSENT | Configure-Request sent.
ACKRCVD | Configure-Request sent and Configure-Ack received, but no Configure-Request received.
ACKSENT | Configure-Request sent, Configure-Request received and Configure-Ack sent, but no Configure-Ack received.
OPENED | Negotiation complete.
IPCP-PH: |
 | DEAD, ESTABLISHING, NETWORK, TERMINATING

Current IPCP phase. For description, see LCP-PH:

IPCP-ST: | IPCP state
 | STARTING, STOPPED, STOPPING, REQSENT, ACKRCVD, ACKSENT, OPENED

Current IPCP state. For description, see LCP-ST:

LOCAL-IP: | Local IP address
0.0.0.0 | xxx.xxx.xxx.xxx

IP address of this machine, corresponding to this IP port.
The value is set either if preset in IP port configuration, or retrieved from remote host.

REMOTE-IP: | Remote IP address
0.0.0.0 | xxx.xxx.xxx.xxx

IP address of machine on the other end of a link.
The value is set either if preset in IP port configuration, or provided by the remote host (which overrides preset value).

ST1: | STOPPED1 Count
 | numeric

Determines how much times PPP went into STOPPED1 state

ST2: | STOPPED2 Count
 | numeric

Determines how much times PPP went into STOPPED2 state

ST3: | STOPPED3 Count
 | numeric

Determines how much times PPP went into STOPPED3 state

TIME_CUR_CALL: | Current call time duration
 | numeric

Specifies how long is the current connection taking time.

RTY: | STOPPED counter
 | numeric

Specifies how much times call was unsuccessful. When it reaches NRTY: value, and RTY: parameter is not US, PPP will go into STOPPEDx state. IfRTY: is US, additional, retries will be indicated by USRTY stat.

USRTY: | STOPPED counter for RTY=US
 | numeric

Specifies how much times call was unsuccessful, after reaching NRTY: value. When it reaches 25, PPP will go into STOPPEDx state.
Valid only for RTY==US setting.

DT: | Inactivity timer
 | numeric

Specifies time for which PPP was inactive. When it reaches the DT-IN: or DT-OUT: value PPP will close the link.

TDEL: | Current delay between calls
 | numeric

Specifies how much PPP delays after ununsuccessfulAL before trying again.

TREM: | Delay remaining
 | numeric

If STATE=DELAYING, specifies delay remaining before new CALL can be tried

SUCC-CALL: | Successful CALLs
 | numeric

Specifies number of successful outgoing CALLs

FAIL-CALL: | Failed CALLS
 | numeric

Specifies number of failed outgoing CALLs

TIME-CALL: | Total connection time
 | numeric

Total time when PPP was connected

AUTH-FAIL: | Authentication failed
 | numeric

Total number of authentication failures

CHR: | Characters in/out
 | numeric

Total number of bytes received/sent

PCK: |
 | numeric

Total number of packets received/sent

PCK-SYS: |
 | numeric

Total number of system (LCP, IPCP and authentication) packets received/sent

DROPPED: |
 | numeric

Number of packets dropped due to unknown protocol or incorrect order. Small numbers (about 1-2 per connection) do not indicate any malfunction

LOST: |
 | numeric

Total number of packets lost due to queue overflow

SNMP traps generated for the PPP ports top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
60 | cxTrapPppDown | cxPortIndex, cxPortType, cxPppDiagPppState, cxPppDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the PPP port driver goes in to the "Down" states set.
61 | cxTrapPppUp | cxPortIndex, cxPortType, cxPppDiagPppState, cxPppDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the PPP port driver exits the "Down" states set.
62 | cxTrapPppStopped | cxPortIndex, cxPortType, cxPppDiagPppState, cxPppDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the PPP port driver goes in to the "Stopped" states set.
63 | cxTrapPppReady | cxPortIndex, cxPortType, cxPppDiagPppState, cxPppDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the PPP port driver exits the "Stopped" states set.

Detail of SNMP variables shown in the PPP port traps

cxPortIndex | ETH port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the PPP port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case PPP) and the description eventually associated to it.

cxPppDiagPppState | General PPP state
 | stopped1(0), stopped2(1), stopped3(2), delaying(3), down(4), up(5)

This variable stores the general PPP state value when the trap is generated (See STATE:).

SNMP variable value | Corresponding General PPP state
stopped1(0) | STOPPED1
stopped2(1) | STOPPED2
stopped3(2) | STOPPED3
delaying(3) | DELAYING
down(4) | DOWN
up(5) | UP
cxPppDiagLinkState | Link state
 | not_present(0), down(1), ready(2), listening(3), calling(4), called(5), clearing(6), cleared(7), connected(8)

This variable stores the lower link state value when the trap is generated (See LINK:).

SNMP variable value | Corresponding Link state
not_present(0) | NOTPRESENT
down(1) | DOWN
ready(2) | READY
listening(3) | LISTENING
calling(4) | CALLING
called(5) | CALLED
clearing(6) | CLEARING
cleared(7) | CLEARED
connected(8) | CONNECTED
sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.

PPP port DEBUG commands top

LSN 0: Debug commands help
PO:541 ------------------------------------------------------------------------
PPP    BufferLength:207    Date/Time:30/08/2002 15:17:11 TraceTime:<NotRunning>

LSN 1: PPP information
LSN 2: IP information
LSN 3: Negotiated options
LSN 4: LCP/IPCP/Link states
LSN 5: Four above combined
LSN 10: CALL log (20 to clear)
LSN 11: PPP Negotiation log (21 to clear)
LSN 1: PPP information
PPP Not Connected, State=UP
STOPPED1 Counter: 0 (NRTY=5)
STOPPED2 Counter: 0 / 3
STOPPED3 Counter: 0 / 3

Time Connected: 00:00:47
Authentication: Local: NONE, Remote: NONE
Idle: 00:00:47 (DT=00:05:00 as server)
LSN 2: IP information
Not Connected
                 CONFIGURED
Local IP:      192.168.002.002
Remote IP:     000.000.000.000
Primary DNS:   000.000.000.000
Secondary DNS: 000.000.000.000
MRU:           1500
MTU:           1500

                 CONFIGURED         NEGOTIATED
Local IP:      192.168.002.003    192.168.002.003
Remote IP:     000.000.000.000    192.168.002.005
Primary DNS:   000.000.000.000    000.000.000.000
Secondary DNS: 000.000.000.000    000.000.000.000
MRU:           1500               1500
MTU:           1500               1492
LSN 3: Negotiated options
Not Connected
Local parameters:
MRU=1500  MagicNumber=0x30D61E2E  AuthProto=CHAP  PFC=YES  ACFC=YES  VJ=NO
Remote parameters:
MRU=1500  MagicNumber=0x00000000  AuthProto=NONE  PFC=NO  ACFC=NO  VJ=NO
Will accept negotiation: PAP
Will require negotiation: CHAP

Local parameters:
MRU=1500  MagicNumber=0x30D61E2E  AuthProto=CHAP  PFC=YES  ACFC=YES  VJ=NO
Remote parameters:
MRU=1492  MagicNumber=0x7D9C661A  AuthProto=NONE  PFC=YES  ACFC=YES  VJ=NO
LSN 4: LCP/IPCP/Link states
Not Connected
Link State: CONNECTED
LCP Phase: TERMINATING, State: STOPPED
IPCP Phase: DEAD, State: STARTING

Link State: CONNECTED
LCP Phase: NETWORK, State: OPENED
IPCP Phase: NETWORK, State: OPENED
LSN 5: Shows info for LSN 2, 3 and 4 in one call
LSN 10: CALL log
30.08.02 15:16:38  Listening
30.08.02 15:25:11  Accepting
30.08.02 15:25:11  Accepting - succeeded
30.08.02 15:29:35  Hanging up with cause 0x81-0x90 - 0xF0-0xA3
30.08.02 15:29:35  Hanging up - succeeded
30.08.02 15:29:35  ----------------
LSN 11: PPP negotiation log
30.08.02 15:29:35  LCP: Unsupported/unallowed CHAP method requested: 0x05
30.08.02 15:29:35  ----------------


The PPP over Ethernet Client (POECLI) port

PPP over Ethernet Client (POECLI) port

POECLI port configuration
POECLI port statistics and diagnostics

The Point-to-Point Protocol (PPP) is the most widely used protocol for connecting hosts over the peer-to-peer connection, such as modem or ISDN link or a direct cable connection. It supports transmitting multi-protocol datagrams over a single link, along with such features as authentication, link quality monitoring and flexible set of options which can be negotiated between two connecting hosts.

The PPP over Ethernet (PPPoE) protocol allows hosts inside an Ethernet-based network to access external hosts via PPP through the bridge host (Access Concentrator). It is most often used to access an xDSL line from inside the network, the DSL or cable modem playing the role the AC

Thus, for successful connection two physical parts are required: client PPPoE module (on every host wishing to use PPPoE) and one or more Access Concentrators. They are presented in a CPX by two modules: POECLI for client part, described in this document, and POEAC as a server part.

This PPPoE Client implementation supports several upper-layer PPP's per single POECLI module. However, you will have to install a distinct POECLI module per each Ethernet interface through which the connection is desired. Also note, that POECLI and POEAC modules cannot share the same Ethernet interface on the same CPX.

For more information, consult the following documents:

  • RFC 2516: A Method for Transmitting PPP Over Ethernet (PPPoE)
  • RFC 1661: The Point-to-Point Protocol (PPP)

POECLI port configuration top

The PPP over Ethernet Client port is labelled within the Abilis CPX with the acronym "POECLI" and it is provided with the parameters described in this section.

Here is an example on how to display the POECLI port parameters. Shown values are only examples.

[13:51:12] ABILIS_CPX: D P PO:970 .
PO:970 ------------------------------------------------------------------------
POECLI LOG:NO         LOWPO:55        max-ses:4      ABORT:NEVER
       INIT-TOUT:1    INIT-RTY:4      SREQ-TOUT:20   SREQ-RTY:4

To activate changes made on the low case parameters it is needed to restart the system, on the contrary for the high case ones, it is enough to execute the initialization command INIT PO:.

Detail of the POECLI port parameters

LOWPO: | Identifier of the lower level Abilis CPX port
NONE | 1 - 999, NONE

Sets the lower level port; it can only be an ETH or ETH100 port.

The value "NONE" makes the PPPoE port unusable.

MAX-SES: | Number of sessions a module can support
4 | 1 - 255

Sets the number of PPPoE sessions the module can support. There can't be more than this amount of upper layer PPP modules connecting at once. Changing this parameter requires CPX restart.

ABORT: | Active Discovery abort policy
ALWAYS | NEVER, NOOTHER, ALWAYS

Determines the behavior in case a PADO packet specifying an error condition was received:

Value | Meaning
NEVER | PADO packets indicating an error are ignored
NOOTHER | Negotiation terminates if no other PADO packets received until timeout. This may be the preferred policy for networks with several Access Concentrators
ALWAYS | Error PADO packets cause immediate termination. This may be the preferred policy for networks with a single Access Concentrator
INIT-TOUT: | Active Discovery Initiation timeout
5 | 1 - 65535

Sets the timeout between resending of PADI packets, in case no answer was received.

INIT-RTY: | Active Discovery Initiation retries
4 | 1 - 65535

Sets the maximal number of PADI packets sent during initiation phase. If none of them were answered, connection terminates.

SREQ-TOUT: | Active Discovery Request timeout
20 | 1 - 65535

Sets the timeout between resending of PADS packets, in case no answer was received.

SREQ-RTY: | Active Discovery Session Request retries
4 | 1 - 65535

Sets the maximal number of PADR packets sent during initiation phase. If none of them were answered, PADI packets are being sent again.

POECLI port statistics and diagnostics top

POECLI stat/diag output contain several parts:

  • General POECLI diagnostics (first line)
  • Diagnostic for each session (both open and closed ones)
  • Statistics for each link - not yet present
  • Overall POECLI statistics
[18:45:45] ABILIS_CPX: D S PO:970 .

PO:970 ------------------------------------------------------------------------
POECLI STATE:READY     CUR-SES:1      MAX-SES:2
       ------------------------------------------------------------------------
       SES: STATE:        AC-MAC:             CONN-TIME:  SES-ID:
            SERVICE-NAME:                     AC-NAME:
       ------------------------------------------------------------------------
       0    CONNECTED     00-40-F4-0A-C6-EB   5           1
            EBIB                              CPX
       ------------------------------------------------------------------------
       1    DISCONNECTED  00-00-00-00-00-00   0           0
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC-CALL  |           |          0|FAIL_CALL  |           |          0|
       CHAR-DATA  |          0|          0|CHAR-SYS   |          0|          0|
       PCK-DATA   |          0|          0|PCK-SYS    |          0|          0|
       LOST-DATA  |          0|           |DROP-SYS   |          0|           |
       ------------------------------------------------------------------------

[18:45:45] ABILIS_CPX: D S PO:970 .

PO:970 ------------------------------------------------------------------------
POECLI --- Cleared 000:00:00:35 ago, on 03/09/2002 at 18:45:10 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC-CALL  |           |          0|FAIL_CALL  |           |          0|
       CHAR-DATA  |          0|          0|CHAR-SYS   |          0|          0|
       PCK-DATA   |          0|          0|PCK-SYS    |          0|          0|
       LOST-DATA  |          0|           |DROP-SYS   |          0|           |
       ------------------------------------------------------------------------

Detail of the POECLI port diagnostics

STATE: | POECLI port state
 | DOWN, READY

Current port state.

Value | Meaning
DOWN | Lower ETH layer is not present or inoperable, POECLI stopped.
READY | POECLI is up and running.
CUR-SES: | Number of open sessions
 | 0-255

Total number of sessions currently active

Detail of the POECLI session diagnostics

SES: | Session number
 | 0-255

Session number in internal table.

STATE: | Session state
 | DOWN, PADISENT, PADRSENT, OPEN

Current session state.

Value | Meaning
DOWN | Session is closed.
PADISENT | Session is opening: PADI packet sent, PADO not yet received.
PADRSENT | Session is opening: PADR packet sent, PADS not yet received.
OPEN | Session is open and transferring data.
AC-MAC: | Remote MAC address
 | 0-255

MAC address of remote Access Concentrator. If session is DOWN, will show last valid value.

CONN-TIME: | Time connected
 | DWORD

Shows time since session was connected.

SES-ID: | Session ID
 | 0-65535

Shows PPPoE Session ID as assigned by Access Concentrator.

SERVICE-NAME: | Session Service name

Shows Service Name to which connection occured. This can either the exact name specified in upper layer PPP or, if it was blank, service name given by AC.

AC-NAME: | Remote AC name

Shows Access Concentrator Name to which connection occured.

Detail of the POECLI port statistics

SUCC-CALL: | Successful connects to remote AC
 | 0-65535

Number of successful attempts to establish a connection to Access Concentrator(s).

FAIL-CALL: | Failed connects to remote AC
 | 0-65535

Number of failed attempts to establish a connection to Access Concentrator(s).

CHAR-DATA: Total data bytes received/sent

Total number of data bytes received from (sent to) hosts in LAN, including all framing.
Data means all PPP traffic, including PPP system packets. This is the same as bytes sent/received to external links.

CHAR-SYS: Total system bytes received/sent

Total number of system bytes received from (sent to) hosts in LAN, including all framing.
System means PPPoE system packets only.

PCK-DATA: Data packets received/sent

Number of data packets received from (sent to) hosts in LAN.
Data means all PPP traffic, including PPP system packets. This is the same as packets sent/received to external links.

PCK-SYS: System packets received/sent

Number of system packets received from (sent to) hosts in LAN.
System means PPPoE system packets only.

LOST-DATA: Data packets lost

Number of data packets lost due to internal queues overflow.

LOST-DATA: | Data packets lost
 | 0-255

Number of data packets lost because there were no RECV pending from PPP.

DROP-SYS: | System packets dropped
 | 0-255

Number of system packets, which were discarded because they were of unexpected type or specified a nonexisting session ID


The PPP over Ethernet Access Concentrator (POEAC) port

PPP over Ethernet Access Concentrator (POEAC) port

POEAC port configuration
POEAC port statistics and diagnostics

The Point-to-Point Protocol (PPP) is the most widely used protocol for connecting hosts over the peer-to-peer connection, such as modem or ISDN link or a direct cable connection. It supports transmitting multi-protocol datagrams over a single link, along with such features as authentication, link quality monitoring and flexible set of options which can be negotiated between two connecting hosts.

The PPP over Ethernet (PPPoE) protocol allows hosts inside an Ethernet-based network to access external hosts via PPP through the bridge host (Access Concentrator). It is most often used to access an xDSL line from inside the network, the DSL or cable modem playing the role of the AC.

Thus, for successful connection two physical parts are required: client PPPoE module (on every host wishing to use PPPoE) and one or more Access Concentrators. They are presented in a CPX by two modules: POECLI for client part, and POEAC as a server part, described in this document.

This PPPoE Access Concentrator implementation supports several outgoing links per single POEAC module. However, you will have to install a distinct POEAC module per each Ethernet interface through which the connection is desired. Also note, that POECLI and POEAC modules cannot share the same Ethernet interface on the same CPX.

For more information, consult the following documents:

  • RFC 2516: A Method for Transmitting PPP Over Ethernet (PPPoE)
  • RFC 1661: The Point-to-Point Protocol (PPP)

POEAC port configuration top

The PPP over Ethernet Access Concentrator port is labelled within the Abilis CPX with the acronym "POEAC" and it is provided with the parameters described in this section.

Unlike most other modules, POEAC has two parameters blocks: common parameters and link parameters. Links are numbered from 1 to 32 and have two special parameters, among with ones common for physical layers.

Here is an example on how to display the POEAC port parameters. Shown values are only examples.

[14:21:06] ABILIS_CPX: D P PO:980 .

PO:980 ------------------------------------------------------------------------
POEAC  LOG:DS         LOWPO:57        max-ses:1      ses-rxbuf:32
       TCP-MSS-CLAMP:YES              TCP-MSS-VALUE:1452
       ACNAME:CPX
       ------------------------------------------------------------------------
       Lnk:1  ST:RUNNING  LOWPO:2
              SERVICENAME:HSCB
       Lnk:2  ST:RUNNING  LOWPO:200   VSP-ID:NONE
              SERVICENAME:EBIB
              DT:300      RTY:LIN     NRTY:5      TB:10
              CGO:#                     SGO:#
              CDO:111                   SDO:#

To activate changes made on the lowercase parameters it is needed to restart the system, for the uppercase ones, it is enough to execute the initialization command INIT PO:.

Detail of the POEAC port parameters

LOWPO: | Identifier of the lower level Abilis CPX port
NONE | 1 - 999, NONE

Sets the lower level port; it can only be an ETH or ETH100 port.

The value "NONE" makes the PPPoE port unusable.

MAX-SES: | Number of sessions a module can support
4 | 1 - 255

Sets the number of PPPoE sessions the module can support. There can't be more than this amount of external sessions connecting at once. Changing this parameter requires CPX restart.

SES-RXBUF: | Number of packets in single session queue
32 | 1 - 255

Sets the number of PPPoE packets received from client a module can hold while sending other packets to remote PPP. Changing this parameter requires CPX restart.

TCP-MSS-CLAMP: | Whether to perform TCP MSS clamping
NO | NO, YES

If set, forces POEAC to change value of Maximum Segment Size in all TCP packets to one equal or lower than set with TCP-MSS-VALUE: option to avoid certain problems with PPP over Ethernet "black hole". Also can be used to reduce link latency at the cost of some bandwidth loss.

TCP-MSS-VALUE: | Maximal TCP MSS value to allow
1414 | 496-1452

Specifies maximal allowed value for TCP Maximum Segment Size option.

This option is only visible if MSS clamping is allowed via TCP-MSS-CLAMP: parameter.

ACNAME: | Access Concentrator name
(empty) | Any string up to 64 symbols

The name of the Access Concentrator is sent along with responses from hosts. Intellectual PPPoE clients can rely on this to choose a certain AC from several available. This parameter can be left blank in case there is only one AC in the network for each service-name requested.

ST: | Link state
NEW | NEW, RUNNING, DELETED

Determines the current state of the link.

Value | Meaning
NEW | Link has just been created and is not yet used by POEAC.
RUNNING | Link has been initialized and is used by POEAC.
DELETED | Link has just been deleted and is already not used by POEAC.
SERVICENAME: | Link service name
(empty) | Any string up to 64 characters

Name under which this link can be requested from the client. If the client specifies a certain ServiceName, Server answers only if it has link with tha exactly name. If Client specifies no name, it means any line is acceptable.

POEAC port statistics and diagnostics top

POEAC stat/diag output contain several parts:

  • General POEAC diagnostics (first line)
  • Diagnostic for each session (both open and closed ones)
  • Statistics for each link - not yet present
  • Overall POEAC statistics
[15:29:13] ABILIS_CPX: D S PO:980

PO:980 ------------------------------------------------------------------------
POEAC  STATE:READY     CUR-SES:1      MAX-SES:2
       ------------------------------------------------------------------------
       STATE:        CLI-MAC:           LNK:        SES-ID:  CONN-TIME:
       SERVICE-NAME:
       ------------------------------------------------------------------------
       OPEN          52-54-4C-04-9F-2D  2           1        11
       EBIB
       ------------------------------------------------------------------------
       DOWN          00-00-00-00-00-00  0           2        0
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC-CALL  |           |          0|FAIL-CALL  |           |          0|
       CHAR-DATA  |          0|          0|CHAR-SYS   |          0|          0|
       PCK-DATA   |          0|          0|PCK-SYS    |          0|          0|
       LOST-DATA  |          0|           |
       ------------------------------------------------------------------------

[15:29:13] ABILIS_CPX: D SE PO:980

PO:980 ------------------------------------------------------------------------
POEAC  --- Cleared 000:00:00:49 ago, on 03/09/2002 at 15:28:24 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC-CALL  |           |          0|FAIL-CALL  |           |          0|
       CHAR-DATA  |          0|          0|CHAR-SYS   |          0|          0|
       PCK-DATA   |          0|          0|PCK-SYS    |          0|          0|
       LOST-DATA  |          0|           |
       ------------------------------------------------------------------------

Detail of the POEAC port diagnostics

STATE: | POEAC port state
 | DOWN, READY

Current port state.

Value | Meaning
DOWN | Lower ETH layer is not present or inoperable, POEAC stopped.
READY | POEAC is up and running.
CUR-SES: | Number of currently open sessions
 | 0-255

Total number of sessions currently active

Detail of the POEAC session diagnostics

STATE: | Session state
 | DOWN, PADISENT, PADRSENT, OPEN

Current session state.

Value | Meaning
DOWN | Session is closed.
PADRRCVD | PADR was received, call to lower layer in progress, PADS not yet sent.
OPEN | Session is open and transferring data.
CLI-MAC: | Remote MAC address
 | 0-255

MAC address of remote client. If session is DOWN, will show last valid value.

LNK: | Link number
 | 0-255

Shows number of link used by the session.

SES-ID: | Session ID
 | 0-65535

Shows PPPoE Session ID assigned for this session.

CONN-TIME: | Time connected
 | DWORD

Shows time since session was connected.

SERVICE-NAME: | Session Service name
 | 0-255

Shows Service Name to which connection occured.

Detail of the POEAC port statistics

SUCC-CALL: | Successful connects to this AC
 | 0-255

Number of successful connection establishments with this Access Concentrator.
Each time a new session was started.

FAIL-CALL: | Failed connects to this AC
 | 0-255

Total number of attempts a connection was tried but failed.
The reason could be failed call to lower layer.

CHAR-DATA: Total data bytes received/sent

Total number of data bytes received from (sent to) hosts in LAN, including all framing.
Data means all PPP traffic, including PPP system packets. This is the same as bytes sent/received to external links.

CHAR-SYS: Total system bytes received/sent

Total number of system bytes received from (sent to) hosts in LAN, including all framing.
System means PPPoE system packets only.

PCK-DATA: Data packets received/sent

Number of data packets received from (sent to) hosts in LAN.
Data means all PPP traffic, including PPP system packets. This is the same as packets sent/received to external links.

PCK-SYS: System packets received/sent

Number of system packets received from (sent to) hosts in LAN.
System means PPPoE system packets only.

LOST-DATA: Data packets lost

Number of data packets lost due to internal queues overflow.


Ethernet (ETH) ports

The Ethernet (ETH) ports

Configuration of the Ethernet (ETH) ports
State and e statistics of the Ethernet (ETH) ports
SNMP Traps generated for the Ethernet (ETH) ports

The ETH ports represent the Ethernet (10 Mbit/sec ) adapters drivers for TP and Thin Coax wiring. They provide transmission and receiving services of frames over LAN, in other words they deal with the physical layer management and Media Access Control (MAC): collisions, retransmissions, MAC address filtering.

The ETH driver supports IP, ARP, RARP protocols.

Configuration of the Ethernet (ETH) ports top

The Ethernet port is labelled within the Abilis CPx with the acronym "ETH" and it is provided with the parameters described in this section.

Here is an example on how to display the ETH port parameters. Shown values are the default ones.

[15:03:33] ABILIS_CPX: D P PO:ETH

PO:56  - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
ETH    ------------------------------------------------------------------------
       LOG:NO      ip-rxbuf:25   arp-rxbuf:5

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:.
Changes made on the parameter LOG: are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the ETH port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ip-rxbuf: | Number of receive buffers for IP
25 | 1 - 255

It sets the number of receive buffers for IP.

arp-rxbuf: | Number of receive buffers for ARP
5 | 1 - 255

It sets the number of receive buffers for ARP.

State and statistics of the Ethernet (ETH) ports top

How to check state and statistics of the ETH ports by the command D S.

[18:58:20] ABILIS_CPX: D S PO:ETH

PO:55  ------------------------------------------------------------------------
ETH    STATE:READY          MAC-ADDR:00-40-33-55-AE-8B
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |          0|          0|CHAR       |          0|          0|
       BROADCAST  |          0|          0|MULTICAST  |          0|          0|
       NOBUF      |          0|           |LOST-IP    |          0|           |
       LOST-ARP   |          0|           |LOST-RARP  |          0|           |
                  |           |           |N-COLL     |           |          0|
       FCS        |          0|           |L-COLL     |           |          0|
       RX-OVR     |          0|           |E-COLL     |           |          0|
       TX-UND     |           |          0|DEFERRED   |           |          0|
       CARR       |          0|           |ALIGN      |          0|           |
       CARD-RESET |          0|           |SHORT      |          0|          0|
       SQE-ERR    |          0|           |
       ------------------------------------------------------------------------

How to display extended statistics of the ETH ports by the command D SE.

[18:58:33] ABILIS_CPX: D SE PO:ETH

PO:55  ------------------------------------------------------------------------
ETH    --- Cleared 000:00:00:22 ago, on 21/07/2004 at 18:58:13 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |          0|          0|CHAR       |          0|          0|
       BROADCAST  |          0|          0|MULTICAST  |          0|          0|
       NOBUF      |          0|           |LOST-IP    |          0|           |
       LOST-ARP   |          0|           |LOST-RARP  |          0|           |
                  |           |           |N-COLL     |           |          0|
       FCS        |          0|           |L-COLL     |           |          0|
       RX-OVR     |          0|           |E-COLL     |           |          0|
       TX-UND     |           |          0|DEFERRED   |           |          0|
       CARR       |          0|           |ALIGN      |          0|           |
       CARD-RESET |          0|           |SHORT      |          0|          0|
       SQE-ERR    |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the ETH ports

STATE: | Current state of the ETH port driver
 | DOWN, READY, TXDISABLED, HALTED, FAILED, ERR

It shows the current state of the ETH port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
ETH | DOWN | Port is not active | DN
 | READY | Port is active | RD
 | TXDISABLED | The transmission has been disabled due to a fatal error | TD
 | HALTED | Port halted because of a fatal error | HL
 | FAILED | Port is not working because of an initialization error | FL
 | ERR | Software error. Contact Abilis assistance. | NA

MAC-ADDR: | MAC address of the driver Ethernet
 | 6 hexadecimals digits separated by "-" (minus)

This parameter shows the MAC (Media Access Control) address used by the Ethernet port driver.
MAC addresses are usually made of a sequence of 6 octets (48bits) and they are displayed as a sequence of 6 hexadecimals digits separated by the character "-" (minus).

SUCC: | Number of frames successfully received
 | 0 - 4.294.967.295

The counter SUCC (INPUT/OUTPUT) shows the number of frames successfully received/sent.

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT/OUTPUT) shows the number of characters received/sent.

BROADCAST: | Number of "broadcast" frames received/sent
 | 0 - 4.294.967.295

The counter BROADCAST (INPUT/OUTPUT) is incremented every time a "broadcast" frame is received/sent.

The "broadcast" frames are sent to all the LAN Ethernet stations.

MULTICAST: | Number of "multicast" frames received/sent
 | 0 - 4.294.967.295

The counter MULTICAST (INPUT/OUTPUT) is incremented every time a "multicast" frame is received/sent.

The "multicast" frames are sent to a group of the LAN Ethernet stations.

NOBUF: | Number of frames discarded because of the unavailability of receiving buffer
 | 0 - 4.294.967.295

The counter NOBUF (INPUT) is incremented every time a frame is discarded because of the unavailability of receiving buffers.

High values of this parameter compared to the overall data exchanged could mean that the Abilis system is overloaded, so that it is convenient to contact the seller and consider to upgrade it.

LOST-IP: | Number of received frames discarded because of the unavailability of IP buffers
 | 0 - 4.294.967.295

The counter LOST-IP (INPUT) is incremented every time a received frames is discarded because of the unavailability of IP buffers.

LOST-ARP: | Number of received frames discarded because of the unavailability of ARP buffers
 | 0 - 4.294.967.295

The counter LOST-ARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of ARP buffers.

LOST-RARP: | Number of received frames discarded because of the unavailability of RARP buffers
 | 0 - 4.294.967.295

The counter LOST-RARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of RARP buffers.

N-COLL: | Number of "normal" collisions
 | 0 - 4.294.967.295

The counter N-COLL (OUTPUT) is incremented every time a "normal collision" occurs.

Collisions, in a Ethernet network, are an absolutely normal occurrence, but if their number grows up to the overall amount of data exchanged, then it should be considered the network segmentation, for example through a SWITCH.

LANs highly congested present a high number of "extended collisions" (E-COLL).

L-COLL: | Number of "late" collisions
 | 0 - 4.294.967.295

The counter L-COLL (OUTPUT) is incremented every time a "late collision" occurs.

Significative values of this parameter could mean:

  • hardware failures of one or more LAN stations;
  • wrong configuration of the modality half/full duplex in one or more LAN stations;
  • the LAN is too wide, segmentation has to be considered. The collision domain of a 10Mbit/sec LAN is estimated about 2,5km.
E-COLL: | Number of "extended" collisions
 | 0 - 4.294.967.295

The counter E-COLL (OUTPUT) is incremented every time an "extended collision" occurs.

If the number of collisions grows up to the overall amount of data exchanged, then it should be considered the network segmentation, for example through a SWITCH.

FCS: | Number of received frames with a wrong FCS
 | 0 - 4.294.967.295

The counter FCS (INPUT) is incremented every time the FCS (or CRC) check procedure, of each frame, fails.

warning! High values, especially if growing, of this counter could mean a bad quality of the transmission line, corrupting the received data; it surely points out errors into the received data. A bad quality turns into a performance lowering and into possible breaks out of the link.

RX-OVR: | Number of "overrun" occurred during reception
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time the communication board reports an "overrun" due to the received data. It occurs whenever the Ethernet driver, due to an excessive payload within the Abilis CPX, is not fast enough to take data from the communication board. Up to now, no Abilis CPX application gave such "overrun" problems, however if the value of this counter get more and more significative compared to the amount of data exchanged, it should be convenient to contact the seller and consider the Abilis CPX upgrade.

However, if high numbers of FCS are also detected, then it is more probable that the "overload" is caused by the excessive number of errors on the transmission line, which, as consequence, should be repaired.

TX-UND: | Number of "underrun" occurred during transmission
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time the communication board reports an "underrun" due to the sent DATA. In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

DEFERRED: | Number of deferred frames
 | 0 - 4.294.967.295

The counter DEFERRED (OUTPUT) is incremented every time a frame transmission is deferred.

This counter does not highlight particular problems.

CARR: | Number of "carrier loss" in TP links
 | 0 - 4.294.967.295

The counter CARR (INPUT) shows the number of "carrier loss" in TP links.

it is normal that this counter increments every time the TP link is missing. Growing values, not due to intentional disconnections, could mean:

  • bad quality of the transmission line;
  • the HUB, which the Abilis is connected to, doesn't work properly.
ALIGN: | Number of "align error"
 | 0 - 4.294.967.295

The counter ALIGN (INPUT) shows the number of received frames with an align error.

Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

CARD-RESET: | Number of "hardware restart" of the board
 | 0 - 4.294.967.295

The counter HW-RST (INPUT) is incremented every time the board is reinitialised during the normal working mode of the system.

Too high values of this parameters, especially if growing, could mean an imminent failure of the board.

SHORT: | Number of too short frames
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the length of the received Ethernet frame is shorter than 64 bytes. Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

The counter SHORT (OUTPUT) is incremented every time the "higher level port", such as IPLAN, requests to send a frame whose length is shorter than 64 bytes.

In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

SQE-ERR: | Number of "squelch error"
 | 0 - 4.294.967.295

The counter SQ-ERR shows the number of "squelch errors" for AUI connections. But the AUI interface is not supported by the used adapter, so this parameter is meaningless.

SNMP traps generated for the Ethernet (ETH) ports top

The SNMP Agent of Abilis CPX is able to generate traps owing to meaningful state changes pertinent to the ETH ports.

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for ETH ports.

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
39 | cxTrapEthDown | cxPortIndex, cxPortType, cxEthDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ETH port driver leaves the READY state and reaches one of the following states: DOWN, TXDISABLED, HALTED, FAILED
40 | cxTrapEthReady | cxPortIndex, cxPortType, cxEthDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ETH port driver leaves one of the following states: DOWN, TXDISABLED, HALTED, FAILED and reaches the READY state

Detail of SNMP variables shown in the ETH port traps

cxPortIndex | ETH port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the ETH port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case ETH) and the description eventually associated to it.

cxEthDiagState | Current state if the Ethernet port driver which the trap refers to
 | down(0), ready(1), txDisabled(2), halted(3), failed(4)

This variable shows the current state of the ETH port driver which the trap refers to.
The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the ETH driver
down(0) | DOWN
ready(1) | READY
txDisabled(2) | TXDISABLED
halted(3) | HALTED
failed(4) | FAILED

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format "days:hours:minutes:seconds".


The Fast Ethernet (ETH100) ports

Configuration of the Fast Ethernet (ETH100) ports
State and statistics of the Fast Ethernet (ETH100) ports
SNMP traps generated for the Fast Ethernet (ETH100) ports

The ETH100 ports represent the Fast Ethernet (10/100 Mbit/sec ) adapters drivers for TP wiring. They provide transmission and receiving services of frames over LAN, in other words they deal with the physical layer management and Media Access Control (MAC): collisions, retransmissions, MAC address filtering.

The Fast Ethernet driver supports IP, ARP protocols.

In the default configuration the ETH100 drivers automatically adjust speed, and if possible even the half/full duplex mode, to the one of the HUB port which it is connected to. However it is possible to force using only a fixed mode. This procedure could be necessary if some incompatibilities could arise during the "negotiation".

It is important to highlight that for a correct working of 10Mbit/sec links it is enough to use an UTP3 cable, while for 100Mbit/sec links, even if shorts (ten cms) it is needed to use the UTP5 cable or better.

Configuration of Fast Ethernet (ETH100) top

The Fast Ethernet port is labelled within the Abilis CPX with the acronym "ETH100" and it is provided with the parameters described in this section.

Here is an example on how to display the ETH100 port parameters. Shown values are the default ones.

[15:03:33] ABILIS_CPX: D P PO:ETH100

PO:58  - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
ETH100 ------------------------------------------------------------------------
       LOG:NO            MODE:AUTO         DUPLEX:HALF   TPPOL:AUTO
       dma-rxbuf:25      dma-txbuf:25      ip-rxbuf:25   arp-rxbuf:5
       pppoed-rxbuf:5    pppoes-rxbuf:25   ieee-rxbuf:25

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:.
Changes made on the parameter LOG: are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the ETH100 port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

MODE: | Speed selection and negotiation
AUTO | AUTO, 10TP, 100TX

It sets the link speed or the negotiation ("AUTO") mode.

Negotiation is made according to the Nways protocol, however if the counterpart does not support that protocol, adjusting is carried out trying alternatively the use of 10TP and 100TX. The faster will be choose.

warning! The Nways protocol negotiates also the half/full duplex more, adjustment obtained by attempt, always uses the "HALF" duplex mode.

DUPLEX: | Transmission mode
HALF | HALF, FULL

It sets the transmission mode: "HALF" correspond to alternating bidirectional; "FULL" to simultaneous bidirectional.

Connections to HUBs always require the "HALF" mode, while the ones to SWITCHs (depending on the SWITCH itself) could accept the "FULL" mode.

This parameter is meaningful only if MODE: is set to "10TP" or "100TX"; while it is meaningless if MODE: is set to "AUTO".

TPPOL: | Polarity setting of signals in the TP cable
AUTO | AUTO, NORMAL, REVERSE

It sets the Fast Ethernet board to the real polarity of signals in the TP cable.

For a correct installation the polarity will always be normal, however it is possible to correct a wiring error via software.

The value "AUTO" activates the automatic recognition; while with values "NORMAL" and "REVERSE" the adjustments forced manually.

dma-rxbuf: | Number of receive buffers for DMA
25 | 1 - 255

It sets the number of receive buffers for DMA.

dma-txbuf: | Number of transmit buffers for DMA
1 | 1 - 255

It sets the number of transmit buffers for DMA.

ip-rxbuf: | Number of receive buffers for IP
25 | 1 - 255

It sets the number of receive buffers for IP.

arp-rxbuf: | Number of receive buffers for ARP
25 | 1 - 255

It sets the number of receive buffers for ARP.

pppoed-rxbuf: | Number of receive buffers for PPPOE Discovery protocol
25 | 1 - 255

It sets the number of receive buffers for PPPOE Discovery protocol.

pppoes-rxbuf: | Number of receive buffers for PPPOE Session protocol
25 | 1 - 255

It sets the number of receive buffers for PPPOE Session protocol.

ieee-rxbuf: | Number of receive buffers for IEEE Bridge
25 | 1 - 255

It sets the number of receive buffers for IEEE Bridge.

State and statistics of the Fast Ethernet (ETH100) ports top

How to check state and statistics of the ETH100 ports by the command D S.

[16:05:04] ABILIS_CPX: D S PO:ETH100

PO:58  ------------------------------------------------------------------------
ETH100 STATE:READY          MAC-ADDR:00-80-48-CD-05-7B   CARD:FL100TX
       MODE:AUT-100TX       DUPLEX:AUT-HALF              TPPOL:AUT-NORMAL
       IEEE-FILTER:OFF
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |      16320|        571|CHAR       |    1522126|      35033|
       BROADCAST  |      18100|         61|MULTICAST  |          0|          0|
       NOBUF      |         41|           |LOST-IP    |          0|           |
       LOST-ARP   |          0|           |LOST-RARP  |          0|           |
                  |           |           |N-COLL     |           |          7|
       FCS        |          0|           |L-COLL     |          0|          0|
       RX-OVR     |          0|           |E-COLL     |           |          0|
       TX-UND     |           |          0|DEFERRED   |           |         37|
       CARR       |          0|           |ALIGN      |          0|           |
       TBE        |         41|        632|SHORT      |          0|          0|
       QED        |           |          0|LONG       |          0|          0|
       WDG-TOUT   |          0|           |RUNT       |          0|           |
       JBR-TOUT   |          0|           |HB-FAIL    |          0|           |
       GPT-TOUT   |          0|           |NEG-FAIL   |          0|           |
       BUS-ERR    |          0|           |LINK-FAIL  |          3|           |
       DSC-ERR    |          0|           |FILT-FAIL  |          0|           |
       MII-ERR    |          0|           |CARD-RESET |          2|           |
       ------------------------------------------------------------------------

How to display extended statistics of the ETH100 ports by the command D SE.

[16:15:38] ABILIS_CPX: D SE PO:ETH100

PO:58  ------------------------------------------------------------------------
ETH100 --- Cleared 000:03:57:43 ago, on 22/07/2004 at 12:19:16 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |      16320|        571|CHAR       |    1522126|      35033|
       BROADCAST  |      18100|         61|MULTICAST  |          0|          0|
       NOBUF      |         41|           |LOST-IP    |          0|           |
       LOST-ARP   |          0|           |LOST-RARP  |          0|           |
                  |           |           |N-COLL     |           |          7|
       FCS        |          0|           |L-COLL     |          0|          0|
       RX-OVR     |          0|           |E-COLL     |           |          0|
       TX-UND     |           |          0|DEFERRED   |           |         37|
       CARR       |          0|           |ALIGN      |          0|           |
       TBE        |         41|        632|SHORT      |          0|          0|
       QED        |           |          0|LONG       |          0|          0|
       WDG-TOUT   |          0|           |RUNT       |          0|           |
       JBR-TOUT   |          0|           |HB-FAIL    |          0|           |
       GPT-TOUT   |          0|           |NEG-FAIL   |          0|           |
       BUS-ERR    |          0|           |LINK-FAIL  |          3|           |
       DSC-ERR    |          0|           |FILT-FAIL  |          0|           |
       MII-ERR    |          0|           |CARD-RESET |          2|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the ETH100 ports

STATE: | Current state of the ETH100 port driver
 | DOWN, READY, TXDISABLED, HALTED, FAILED, NEGOTIATING, ERR

It shows the current state of the ETH100 port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
ETH100 | DOWN | Port is not active | DN
 | READY | Port is active | RD
 | TXDISABLED | The transmission has been disabled due to a fatal error | TD
 | HALTED | Port halted because of a fatal error | HL
 | FAILED | Port is not working because of an initialisation error | FL
 | NEGOTIATING | Port is negotiating | NG
 | ERR | Software error. Contact Abilis assistance. | NA

MAC-ADDR: | MAC address of the driver ETHERNET
 | 6 hexadecimals spaced by ":" (colon)

The parameter MAC-ADDR: shows the MAC (Media Access Control) address used by the ETH100 port driver. MAC addresses are usually made of a sequence of 6 octets (48bits) and they are displayed as a sequence of 6 hexadecimals separated by the character ":" (colon).

CARD: | Fast Ethernet board type
 | FL100TX, FL100TX/WOL

It shows the Fast Ethernet board type in use.

MODE: | Speed mode currently in use
 | UNKNOWN, 10TP, 100TX

The prefix "AUT-" means that the speed mode, currently used, is the result of the negotiation procedure.

The prefix "FIX-" means that the speed mode, currently used, was selected manually.

The value UNKNOWN means that the negotiation procedure is active but no valid signal has been yet detected, owing to, for example, the link absence.

DUPLEX: | Transmission mode in use
 | UNKNOWN, HALF, FULL

The prefix "AUT-" means that the transmission mode, currently used, is the result of the negotiation procedure.

The prefix "FIX-" means that the transmission mode, currently used, was selected manually.

The value UNKNOWN means that the negotiation procedure is active but no valid signal has been yet detected, owing to, for example, the link absence.

TPPOL: | Polarity in use
 | UNKNOWN, NORMAL, REVERSE

The prefix "AUT-" means that the polarity, currently used, has been adjusted automatically.

The prefix "FIX-" means that the polarity, currently used, was selected manually.

The value UNKNOWN means that the negotiation procedure is active but no valid signal has been yet detected, owing to, for example, the link absence.

In case of negotiated speed or manually set to 100TX, the polarity will be always displayed as UNKNOWN because it cannot be determinated.

IEEE-FILTER

.

SUCC: | Number of frames successfully received
 | 0 - 4.294.967.295

The counter SUCC (INPUT/OUTPUT) shows the number of frames successfully received/sent.

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT/OUTPUT) shows the number of characters received/sent.

BROADCAST: | Number of "broadcast" frames received/sent
 | 0 - 4.294.967.295

The counter BROADCAST (INPUT/OUTPUT) is incremented every time a "broadcast" frame is received/sent.

The "broadcast" frames are sent to all the LAN Ethernet stations.

MULTICAST: | Number of "multicast" frames received/sent
 | 0 - 4.294.967.295

The counter MULTICAST (INPUT/OUTPUT) is incremented every time a "multicast" frame is received/sent.

The "multicast" frames are sent to a group of the LAN Ethernet stations.

NOBUF: | Number of frames discarded because of the unavailability of receiving buffer
 | 0 - 4.294.967.295

The counter NOBUF (INPUT) is incremented every time a frame is discarded because of the unavailability of receiving buffers.

High values of this parameter compared to the overall data exchanged could mean that the Abilis system is overloaded, so that it is convenient to contact the seller and consider to upgrade it.

LOST-IP: | Number of received frames discarded because of the unavailability of IP buffers
 | 0 - 4.294.967.295

The counter LOST-IP (INPUT) is incremented every time a received frames is discarded because of the unavailability of IP buffers.

LOST-ARP: | Number of received frames discarded because of the unavailability of ARP buffers
 | 0 - 4.294.967.295

The counter LOST-ARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of ARP buffers.

LOST-RARP: | Number of received frames discarded because of the unavailability of RARP buffers
 | 0 - 4.294.967.295

The counter LOST-RARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of RARP buffers.

N-COLL: | Number of "normal" collisions
 | 0 - 4.294.967.295

The counter N-COLL (OUTPUT) is incremented every time a "normal collision" occurs.

Collisions, in a Ethernet network, are an absolutely normal occurrence, but if their number grows up to the overall amount of data exchanged, then it should be considered the network segmentation, for example through a SWITCH.

LANs highly congested present a high number of "extended collisions" (E-COLL).

L-COLL: | Number of "late" collisions
 | 0 - 4.294.967.295

The counter L-COLL (OUTPUT) is incremented every time a "late collision" occurs, while a frame is sent or received.

Significative values of this parameter could mean:

  • hardware failures of one or more LAN stations;

  • wrong configuration of the modality half/full duplex in one or more LAN stations;

  • the LAN is too wide, segmentation has to be considered. The LAN collision domain is estimated about 2,5km for a 10Mbut/sec LAN while 250m for a 100Mbit/sec one.

E-COLL: | Number of "extended" collisions
 | 0 - 4.294.967.295

The counter E-COLL (OUTPUT) is incremented every time that 16 consecutive collisions for the same frame occur.

If the number of collisions grows up to the overall amount of data exchanged, then it should be considered the network segmentation, for example through a SWITCH.

FCS: | Number of received frames with a wrong FCS
 | 0 - 4.294.967.295

The counter FCS (INPUT) is incremented every time the FCS (or CRC) check procedure, of each frame, fails.

warning! High values, especially if growing, of this counter could mean a bad quality of the transmission line, corrupting the received data; it surely points out errors into the received data. A bad quality turns into a performance lowering and into possible breaks out of the link.

RX-OVR: | Number of "overrun" occurred during reception
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time the communication board reports an "overrun" due to the received data. It occurs whenever the Ethernet driver, due to an excessive payload within the Abilis CPX, is not fast enough to take data from the communication board. Up to now, no Abilis CPX application gave such "overrun" problems, however if the value of this counter get more and more significative compared to the amount of data exchanged, it should be convenient to contact the seller and consider the Abilis CPX upgrade.

However, if high numbers of FCS are also detected, then it is more probable that the "overload" is caused by the excessive number of errors on the transmission line, which, as consequence, should be repaired.

TX-UND: | Number of "underrun" occurred during transmission
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time the communication board reports an "underrun" due to the sent DATA. In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

DEFERRED: | Number of deferred frames
 | 0 - 4.294.967.295

The counter DEFERRED (OUTPUT) is incremented every time a frame transmission is deferred.

This counter does not highlight particular problems.

CARR: | Number of "carrier loss" in TP links
 | 0 - 4.294.967.295

The counter CARR (INPUT) shows the number of "carrier loss" in TP links.

it is normal that this counter increments every time the TP link is missing. Growing values, not due to intentional disconnections, could mean:

  • bad quality of the transmission line;

  • the HUB, which the Abilis is connected to, doesn't work properly.

ALIGN: | Number of "align error"
 | 0 - 4.294.967.295

The counter ALIGN (INPUT) shows the number of received frames with an align error.

Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

TBE: | Number of times buffers have been completely emptied
 | 0 - 4.294.967.295

Only internal use

QED: | Number of times frames have been queued
 | 0 - 4.294.967.295

Only internal use.

SHORT: | Number of too short frames
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the length of the received Ethernet frame is shorter than 64 bytes. Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

The counter SHORT (OUTPUT) is incremented every time the "higher level port", such as IPLAN, requests to send a frame whose length is shorter than 64 bytes.

In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

LONG: | Number of too long frames
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time the length of the received Ethernet frame is longer than 1518 bytes. Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

The counter LONG (OUTPUT) is incremented every time the "higher level port", such as IPLAN, requests to send a frame whose length is longer than 1518 bytes.

In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

WDG-TOUT: | Number of "watchdog-timeouts"
 | 0 - 4.294.967.295

The counter WDG-TOUT (INPUT) shows the number of "watchdog-timeout" events.

The Fast Ethernet has its own "watchdog timer", which checks the frame receiving timings. If the frame receiving time is bigger that the allowed value, generally due to transmission errors, the "watchdog timer" will end the reception and signal this event to the driver.

Significative values could stand, most probably, for a bad transmission line quality, but they could also represent faults of the fast-ethernet adapter.

RUNT: | Number of "RUNT" frames
 | 0 - 4.294.967.295

The counter RUNT (INPUT) is incremented every time while a frame is received, a collision, inside the homonymous window (i.e. within the first 512 bytes), is detected.

The above mentioned frame is discarded.

JBR-TOUT: | Number of "jabber-timeouts"
 | 0 - 4.294.967.295

The counter JBR-TOUT (INPUT) shows the number of "jabber-timeout" events.

The "jobber timeout" is an embedded protection of the board to avoid that its transmission problem could halt all the LAN. Particularly if the frame transmission requires a too long time (for example for sending more than 2048 bytes), The transmitter is forcedly deactivated and the event is signalled to the driver which increments the counter JBR-TOUT.

A significative value of this parameter, especially if growing, could represent a faulty board, please contact the technical support.

HB-FAIL: | Number of "heartbeat-fails"
 | 0 - 4.294.967.295

This parameter is only valid for 10TP links.

This counter shows the number of "heartbeat-fails", that is the bad recognition of the "link pulses" of the 10TP links.

Non-zero values, especially if growing, could stand, most probably, for a bad transmission line quality, but they could also represent faults of the fast-ethernet board or of the HUB port.

GPT-TOUT: | Number of "general purpose timer timeout"
 | 0 - 4.294.967.295

The counter GPT-TOUT (INPUT) shows the number of "general purpose timer timeout" events occurred.

Only internal use.

NEG-FAIL: | Number of negotiation failures
 | 0 - 4.294.967.295

The counter NEG-FAIL (INPUT) shows the number of negotiation failures.

BUS-ERR: | Number of errors detected on the PCI bus
 | 0 - 4.294.967.295

The counter BUS-ERR (INPUT) shows the number of errors detected on the PCI bus.

A significative value of this parameter, especially if growing, could represent a CPX hardware problem, please contact the technical support.

LINK-FAIL: | Number of "link failures"
 | 0 - 4.294.967.295

The counter LINK-FAIL (INPUT) shows the number of "link failure" events occurred.

it is normal that this counter increments every time the TP link is missing. Growing values, not due to intentional disconnections, could mean:

  • bad quality of the transmission line;

  • the HUB, which the Abilis is connected to, doesn't work properly.

DSC-ERR: | Number of "descriptor errors"
 | 0 - 4.294.967.295

The counter DSC-ERR (INPUT) shows the number of "descriptor errors" occurred.

Only internal use.

FILT-FAIL: | Number of "filtering failures"
 | 0 - 4.294.967.295

The counter FILT-FAIL (INPUT) shows the number of "filtering failure" events.

Only internal use.

MII-ERR: | Number of "MII errors"
 | 0 - 4.294.967.295

The counter MII-ERR shows the number of "MII errors" occurred, that is physical errors detected on the MII interface.

Only internal use.

CARD-RESET: | Number of times that the board has been reinitialised
 | 0 - 4.294.967.295

Actually not in use.

SNMP traps generated for the Fast Ethernet (ETH100) ports top

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
41 | cxTrapEth100Down | cxPortIndex, cxPortType, cxEth100DiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ETH100 port driver leaves the READY state and reaches one of the following states: DOWN, TXDISABLED, HALTED, FAILED or NEGOTIATING
42 | cxTrapEth100Ready | cxPortIndex, cxPortType, cxEth100DiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the ETH100 port driver leaves one of the following states: DOWN, TXDISABLED, HALTED, FAILED or NEGOTIATING and reaches the READY state

Detail of the SNMP variables shown in the ETH100 port traps

cxPortIndex | Fast Ethernet port which the SNMP trap refers to
 | 0 - 999

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the Fast Ethernet port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case ETH100) and the description eventually associated to it.

cxEth100DiagState | Current state of the Fast Ethernet port driver which the trap refers to
 | down(0), ready(1), txDisabled(2), halted(3), failed(4), negotiating(5)

This variable shows the current state of the ETH100 port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the ETH100 driver
down(0) | DOWN
ready(1) | READY
txDisabled(2) | TXDISABLED
halted(3) | HALTED
failed(4) | FAILED
negotiating(5) | NEGOTIATING

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


The Token Ring (TR) ports

Configuration of the token ring ports
State and statistics of the token ring ports
SNMP traps generated for the TR ports

The TR ports represent the drivers of the Token Ring (IEEE 802.5) adapters, providing serivces of frames transmission and reception on Token Ring LAN types. They manage the physical layer and the Media Access Control (MAC) one, according to the standard IEEE 802.5.

The TR driver supports the IP, ARP, RARP protocols.

Configuration of the Token Ring ports top

The Token Ring port is labeled within the Abilis CPx with the acronym "TR" and it is provided with the parameters described in this section.

Here is an example on how to display the TR port parameters. Shown values are the default ones.

[18:22:37] ABILIS_CPX: D P PO:57

PO:57  ------------------------------------------------------------------------
TR     LOG:NO      AUTOSENSE:YES  highspeed:16M  DUPLEX:AUTO
       rxbuf:25    txbuf:25

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:. Changes made on the parameter LOG: are immediately active.

Detail of the TR port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

AUTOSENSE: | Enabling the negotiation function
YES | NO, YES

It activates the negotiation procedure to detect and automatically configure the working characteristics.

HIGHSPEED: | Activation of the highest transmission speed
16M | 4M, 16M

It allows the selection of the highest transmission speed.

DUPLEX: | Enabling the full-duplex mode
AUTO | NO, AUTO

It selects the full-duplex transmission mode. By setting this parameter to "NO" the full-duplex mode is disabled a priori. If it is set to "AUTO", the full-duplex transmission mode is automatically managed by the driver.

RXBUF: | Number of receiving buffers
25 | 1 - 255

It sets the number of receiving buffers.

TXBUF: | Number of transmission buffers
25 | 1 - 255

It sets the number of transmission buffers.

State and statistics of the Token Ring ports top

How to check state and statistics of the TR ports by the command D S.

[18:22:37] ABILIS_CPX: D S PO:57

PO:58  ------------------------------------------------------------------------
ETH100 STATE:READY          MAC-ADDR:00:80:48:B3:07:6C
       MODE:AUT-16Mbps      DUPLEX:AUT-HALF
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |9043       |142        |CHAR       |871740     |8535       |
       BROADCAST  |8920       |2          |MULTICAST  |0          |0          |
       NOBUF      |0          |           |LOST-IP    |0          |           |
       LOST-ARP   |0          |           |LOST-RARP  |0          |           |
       FCS        |0          |           |RX-OVR     |0          |           |
       ALIGN      |0          |           |TX-UND     |           |0          |
       TBE        |0          |0          |SHORT      |0          |0          |
       QED        |0          |0          |LONG       |0          |0          |
       NEG-FAIL   |0          |           |BUS-ERR    |0          |           |
       LINK-FAIL  |0          |           |DSC-ERR    |0          |           |
       FILT-FAIL  |0          |           |CARD-RESET |0          |           |
       ------------------------------------------------------------------------

Extended statistics are not available for TR ports. The command D SE execution will display again the not extended statistics by the following format:

[18:22:37] ABILIS_CPX: D SE PO:55

PO:57  ------------------------------------------------------------------------
TR     --- Cleared 021:07:37:12 ago, on 14/04/2000 at 11:22:52 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SUCC       |9043       |142        |CHAR       |871740     |8535       |
       BROADCAST  |8920       |2          |MULTICAST  |0          |0          |
       NOBUF      |0          |           |LOST-IP    |0          |           |
       LOST-ARP   |0          |           |LOST-RARP  |0          |           |
       FCS        |0          |           |RX-OVR     |0          |           |
       ALIGN      |0          |           |TX-UND     |           |0          |
       TBE        |0          |0          |SHORT      |0          |0          |
       QED        |0          |0          |LONG       |0          |0          |
       NEG-FAIL   |0          |           |BUS-ERR    |0          |           |
       LINK-FAIL  |0          |           |DSC-ERR    |0          |           |
       FILT-FAIL  |0          |           |CARD-RESET |0          |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the Token Ring ports

STATE: | Current state of the TR port driver
 | HWRESET, SWRESET, TXRESET, INITIALISING, INITILISED, OPENING, OPEN, CLOSING, CLOSED, DOWN, READY, HALTED, FAILED, ERR

It shows the current state of the TR port driver:

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
TR | HWRESET |  | HR
 | SWRESET |  | SR
 | TXRESET |  | TR
 | INITIALISING |  | IG
 | INITIALISED |  | ID
 | OPENING |  | OG
 | OPEN |  | ON
 | CLOSING |  | CG
 | CLOSED |  | CD
 | DOWN | Port is not active | DN
 | READY | Port is active | RD
 | HALTED | Port is halted owing to a fatal error | HD
 | FAILED | Port is halted owing to an initialisation error | FD
 | ERR | Software error, contact the Abilis assistance | NA

MAC-ADDR: | MAC address of the TR driver
 | 6 hexadecimal digits spaced by the character ":" (colon)

The parameter MAC-ADDR: shows the MAC (Media Access Control) address used by the TR port driver.

warning! MAC addresses are usually made of a sequence of 6 octets (48bits) and they are displayed as a sequence of 6 hexadecimals spaced by the character ":" (colon).

MODE: | Speed mode currently in use
 | UNKNOWN, 4Mbps, 16Mbps

The prefix "AUT-" means that the speed mode, currently used, is the result of the negotiation procedure.

The prefix "FIX-" means that the speed mode, currently used, was selected manually.

The value UNKNOWN means that the negotiation procedure is active but no valid signal has been yet detected, owing to, for example, the link absence.

DUPLEX: | Transmission mode in use
 | UNKNOWN, HALF, FULL

The prefix "AUT-" means that the transmission mode, currently used, is the result of the negotiation procedure.

The prefix "FIX-" means that the transmission mode, currently used, was selected manually.

The value UNKNOWN means that the negotiation procedure is active but no valid signal has been yet detected, owing to, for example, the link absence.

SUCC: | Number of frames successfully received/sent
 | 0 - 4.294.967.295

The counter SUCC (INPUT/PUTPUT) shows the number of frames successfully received/sent.

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT/PUTPUT) shows the number of characters received/sent

BROADCAST: | Number of "broadcast" frames received/sent
 | 0 - 4.294.967.295

The counter BROADCAST (INPUT/OUTPUT) is incremented every time a "broadcast" frame is received/sent.

warning! The "broadcast" frames are sent to all the LAN stations.

MULTICAST: | Number of "multicast" frames received/sent
 | 0 - 4.294.967.295

The counter MULTICAST (INPUT/OUTPUT) is incremented every time a "multicast" frame is received/sent.

warning! The "multicast" frames are sent to a group of the LAN stations.

NOBUF: | Number of frames discarded because of the unavailability of receiving buffers
 | 0 - 4.294.967.295

The counter NOBUF (INPUT) is incremented every time a frame is discarded because of the unavailability of receiving buffers.

warning! Hihg values of this parameter compared to the overall data exchanged could mean that the Abilis system is overloaded, so that it is convenient to contact the seller and consider to upgrade it.

LOST-IP: | Number of received frames discarded because of the unavailability of IP buffers
 | 0 - 4.294.967.295

The counter LOST-IP (INPUT) is incremented every time a received frames is discarded because of the unavailability of IP buffers.

LOST-ARP: | Number of received frames discarded because of the unavailability of ARP buffers
 | 0 - 4.294.967.295

The counter LOST-ARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of ARP buffers.

LOST-RARP: | Number of received frames discarded because of the unavailability of RARP buffers
 | 0 - 4.294.967.295

The counter LOST-RARP (INPUT) is incremented every time a received frames is discarded because of the unavailability of RARP buffers.

FCS: | Number of received frames with a wrong FCS
 | 0 - 4.294.967.295

The counter FCS (INPUT) is incremented every time the FCS (or CRC) check procedure, of each frame, fails

warning! High values, especially if growing, of this counter could mean a bad quality of the transmission line, corrupting the received data; it surely points out erros into the received data. A bad quality turns into a performance lowering and into possible breaks out of the link.

RX-OVR: | Number of "overrun" occurred during reception
 | 0 - 4.294.967.295

The counter RX-OVR (INPUT) is incremented every time the communication board reports an "overrun" due to the received data.

It occurs whenever the Token Ring driver, due to an excessive payload within the Abilis CPX, is not fast enough to take data from the communication board.

Up to now, no Abilis CPX application gave such "overrun" problems, however if the value of this counter get more and more significative compared to the amount of data exchanged, it should be convenient to contact the seller and consider the Abilis CPX upgrade.

However, if high numbers of FCS are also detected, then it is more probable that the "overload" is caused by the excessive number of errors on the transmission line, which, as consequence, should be repaired.

TX-UND: | Number of "underrun" occurred during transmission
 | 0 - 4.294.967.295

The counter TX-UND (OUTPUT) is incremented every time the communication board reports an "underrun" due to the sent DATA. In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support

ALIGN: | Number of "align error"
 | 0 - 4.294.967.295

The counter ALIGN (INPUT) shows the number of received frames with an align error.

Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

TBE: | Number of times that the buffers have been completely emptied
 | 0 - 4.294.967.295

Only internal use.

QED: | Number of times that the frames have been queued
 | 0 - 4.294.967.295

Only internal use.

SHORT: | Number of too short frames
 | 0 - 4.294.967.295

The counter SHORT (INPUT) is incremented every time the length of the received frame is shorter than the minimum value. Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

The counter SHORT (OUTPUT) is incremented every time the "higher level port", such as IPLAN, requests to send a frame whose length is shorter than the minimum value.

In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support

LONG: | Number of too long frames
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time the length of the received frame is longer than the maximum value. Non-zero values could stand for problems in LAN station, or for a bad transmission line quality.

The counter LONG (OUTPUT) is incremented every time the "higher level port", such as IPLAN, requests to send a frame whose length is longer than maximum value.

In the actual implementation this counter has to always be zero, however if other values would be displayed, please contact the technical support.

NEG-FAIL: | Number of "negotiation failures"
 | 0 - 4.294.967.295

The counter NEG-FAIL (INPUT) shows the number of negotiation failures

LINK-FAIL: | Numero di "link failures"
 | 0 - 4.294.967.295

The counter LINK-FAIL (INPUT) shows the number of "link failure" events occurred.

warning! Growing values, not due to intentional disconnections, could mean a bad quality of the transmission line.

FILT-FAIL: | Number of "filtering failures"
 | 0 - 4.294.967.295

The counter FILT-FAIL (INPUT) shows the number of "filtering failure" events.

Only internal use.

BUS-ERR: | Number of errors detected on the PCI bus
 | 0 - 4.294.967.295

The counter BUS-ERR (INPUT) shows the number of errors detected on the PCI bus.

warning! A significative value of this parameter, especially if growing, could represent a CPX hardware problem, please contact the technical support.

DSC-ERR: | Number of "descriptor errors"
 | 0 - 4.294.967.295

The counter DSC-ERR (INPUT) shows the number of "descriptor errors" occurred.

Only internal use.

CARD-RESET: | Number of times that the board has been reinitialised ("hardware restart")
 | 0 - 4.294.967.295

The counter HW-RST (INPUT) is incremented every time the board is reinitialised during the normal working mode of the system.

warning! A significative value of this parameter, especially if growing, could represent an imminent failure of the board.

SNMP traps generated for the TR ports top

The Abilis CPX Agent sends traps corresponding to the most significative state changes of the TR ports.

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
43 | cxTrapTrDown | cxPortIndex, cxPortType, cxTrDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the TR port driver leaves the OPEN state
44 | cxTrapTrOpen | cxPortIndex, cxPortType, cxTrDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the TR port driver reaches the OPEN state

Detail of the SNMP variables shown in the TR port traps

cxPortIndex | TR port which the SNMP trap refers to
0 - 999 |

This variable shows the CPX port number which the SNMP trap refers to.

cxPortType | Type and description of the TR port which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case TR ) and the description eventually associated to it.

cxTrDiagState | Current state of the TR port driver which the trap refers to
 | hwReset(0), swReset(1), txReset(2), initialising(3), initialised(4), opening(5), open(6), closing(7), closed(8), down(9), ready(10), halted(11), failed(12)

This variable shows the current state of the TR port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the TR driver
hwReset(0) | HWRESET
swReset(1) | SWRESET
txReset(2) | TXRESET
initilising(3) | INITIALISING
initialised(4) | INITIALISED
opening(5) | OPENING
open(6) | OPEN
closing(7) | CLOSING
closed(8) | CLOSED
down(9) | DOWN
ready(10) | READY
halted(11) | HALTED
failed(12) | FAILED

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


IP ports for LAN (IPLAN)

Configuration of the IP ports for LAN
State and statistics of the IPLAN ports
SNMP TRAPS generated for IPLAN ports

Communication ports IP for LAN have been introduced, within the Abilis CPX, for offering to the IP router (IPRTR) all the transmission and reception services of IP datagrams over LAN Ethernet or Token Ring. It is also provided the IP addresses resolutions service towards the Ethernet addresses through ARP (Address Resolution Protocol) and RARP (Reverse Address Resolution Protocol) protocols (RFC 826).

In order to have an efficient management of the addresses resolution service, the IPLAN port has got a table, called ARP cache, where the couples <IP address, Ethernet address> already resolved are stored. In such way the overall address resolution process will not be activated for each incoming datagram.

Each element added to the ARP cache has a cache presence time, set by the parameter CACHETIMER:, after which it is removed. This procedure is needed in order to follow, within a reasonable time, the changes of the couples <IP address, Ethernet address> occurring, for example, when a station changes its adapter or IP address.

Each IPLAN port uses a ETH or ETH100 or TR lower layer port and provides its own services to a LAN IP port of the router IP.

Configuration of the IPLAN ports top

The IP port for LAN is labelled within the Abilis CPX with the acronym "IPLAN" and it is provided with the parameters described in this section.

Here is an example on how to display the IPLAN port parameters. Shown values are the default ones.

[18:45:45] ABILIS_CPX: D P PO:IPLAN

PO:158 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
IPLAN  ------------------------------------------------------------------------
       LOG:NO      lowpo:NONE  arpcache:200   CACHETIMER:120
       rxbuf:4     txbuf:14

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialisation command INIT PO:.
Changes made on the parameter LOG: are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the IPLAN port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Identifier of the Abilis CPX lower level port
NONE | 1- 999, NONE

It sets the Abilis CPX lower level port. It can only be a ETH or ETH100 or TR port.

The value "NONE" isolates the IPLAN port from the lower level ones.

arpcache: | Maximum number of the elements of the cache ARP
50 | 50 - 1000

It sets the maximum number of couples <IP address, Ethernet address> that can be stored in the ARP cache.
If the table get full the oldest element are deleted.

The default value is enough to efficiently manage LANs with hundreds of stations, however if the statistics ARP-CACHE-ITEMS frequently shows values close to the value set in arpcache: parameter, it is reasonable to increase the parameter value.

CACHETIMER: | Living time of each element in the ARP cache
120 | 15 - 65535 seconds

It sets how long (at maximum) each couple <IP address, Ethernet address> can stay into the ARP cache, before it get deleted.

The default values represents a good trade off between efficiency and reaction time, eventual changes of this parameter have to be done very carefully.

warning! Executing the command INIT PO:, all the table elements are immediately deleted.

rxbuf: | Number of receiving buffers
4 | 1 - 50

It sets the number of receiving buffers.

txbuf: | Number of transmission buffers
14 | 1 - 50

It sets the number of transmission buffers.

State and statistics of the IPLAN ports top

Example on how to show state and statistics of IPLAN ports through the command D S:

[18:45:45] ABILIS_CPX: D S PO:IPLAN

PO:158 ------------------------------------------------------------------------
IPLAN  STATE:LINKREADY       ARP-CACHE-ITEMS:1
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       DG         |      70363|      11249|CHAR       |   10249776|    2105391|
       LONG       |          0|          0|SHORT      |           |          0|
       LOST       |           |          0|ARP-REQ    |         96|        103|
       ARP-RESP   |        103|         96|ARP-R-TOUT |           |          0|
       ------------------------------------------------------------------------

Example on how to show extended statistics of IPLAN ports through the command D SE:

[18:45:45] ABILIS_CPX: D SE PO:IPLAN

PO:158 ------------------------------------------------------------------------
IPLAN  --- Cleared 003:18:22:39 ago, on 16/07/2004 at 16:32:04 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       DG         |      70402|      11276|CHAR       |   10253564|    2107473|
       LONG       |          0|          0|SHORT      |           |          0|
       LOST       |           |          0|ARP-REQ    |         96|        103|
       ARP-RESP   |        103|         96|ARP-R-TOUT |           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the IPLAN ports

STATE: | Current state of the IPLAN port
 | LINKDOWN, LINKREADY, LINKNOTPRESENT, HALTED, FAILED, ERR

It shows the current state of the IPLAN port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
IPLAN | LINKDOWN | The Abilis CPX lower level port is not active | LD
 | LINKREADY | The Abilis CPX lower level port is active | LR
 | LINKNOTPRESENT | The Abilis CPX lower level port is not present or not working | LN
 | HALTED | The port is not working because of a fatal error | HL
 | FAILED | The port is not working because of an initialisation error | FL
 | ERR | Software error, contact Abilis assistance | NA

ARP-CACHE-ITEMS: | Number of items currently stored into the ARP cache
 | 0 - 65.535

The counter ARP-CACHE-ITEMS shows the number of couples <IP address, Ethernet address> currently sorted into the ARP cache.

DG: | Number of IP datagrams sent/received
 | 0 - 4.294.967.295

The counter DG (INPUT) is incremented every time an IP datagram is received from the lower level port and its Checksum is correct, while the counter DG (OUTPUT) every time a datagram is sent to the lower level port, without errors.

CHAR: | Number of characters received/sent
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time the IPLAN port receives correct datagrams from the lower level port, while the counter CHAR (OUTPUT) every time data are sent.

LONG: | Number of too long datagrams
 | 0 - 4.294.967.295

The counter LONG (INPUT) is incremented every time the datagram length received from the lower level port exceeds the maximum size (1500 bytes).

The counter LONG (OUTPUT) is incremented every time the higher level port requests the transmission of a datagram whose length exceeds the maximum size (1500 bytes).

In the actual implementation these counters has always to display zero. If different values are shown, please contact the technical support.

SHORT: | Number of too short datagrams received from the higher level
 | 0 - 4.294.967.295

The counter SHORT (OUTPUT) is incremented every time the higher level port requests the transmission of a datagram whose length is less than 20 bytes.

In the actual implementation these counters has always to display zero. If different values are shown, please contact the technical support.

LOST: | Number of IP datagrams sent but lost
 | 0 - 4.294.967.295

The counter LOST (OUTPUT) is incremented every time the IPLAN driver was not able to send a datagram to the LAN.

This could only happen, in the actual implementation, if the resolution of an IP Address to an Ethernet one is not successful:

  • the couple <IP address, Ethernet address> is not present in the ARP cache;
  • destination station is not present or not connected;
  • CPX is not connected to the LAN;
  • LAN is too congested;
  • worst quality of the transmission line.

If one of the above mentioned situations will occur while the couple <IP address, Ethernet address> is present in the table, the error will be detected only after its removal, that is with a maximum delay of CACHETIMER: seconds.

ARP-REQ: | Number of ARP requests sent/received
 | 0 - 4.294.967.295

The counter ARP-REQ (INPUT) is incremented every time an ARP request frame is received, while the ARP-ERQ (OUTPUT) one every time it is sent.

ARP-RESP: | Number of ARP responses sent/received
 | 0 - 4.294.967.295

The counter ARP-RSP (INPUT) is incremented every time an ARP response frame is received, while the ARP-RSP (OUTPUT) one every time it is sent.

ARP-R-TOUT: | Number of ARP requests sent, but not responded
 | 0 - 4.294.967.295

The counter ARP-REQ-TOUT is incremented every time the IPLAN driver sends an ARP requests but it does not received the relative response within one second.

SNMP traps generated for the IPLAN ports top

The SNMP Agent of Abilis CPX is able to generate traps owing to meaningful state changes pertinent to the IPLAN port driver.

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for IPLAN ports.

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
45 | cxTrapIpLanDown | cxPortIndex, cxPortType, cxIpLanDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the IPLAN port driver leaves the LINK-READY state and reaches one of the following states: LINK-DOWN, LINK-NOT-PRESENT, HALTED or FAILED
46 | cxTrapIpLanReady | cxPortIndex, cxPortType, cxIpLanDiagState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the IPLAN port driver reaches the LINK-READY state after leaving one of the following states: LINK-DOWN, LINK-NOT-PRESENT, HALTED or FAILED

Detail of the SNMP variables shown in the IPLAN port traps

cxPortIndex | IPLAN port which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the IPLAN port, which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case IPLAN) and the description eventually associated to it.

cxIpLanDiagState | Current state of the IPLAN port driver which the trap refers to
 | linkDown(0), linkReady(1), linkNotPresent(2), halted(3), failed(4)

This variable shows the current state of the IPLAN port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the IPLAN driver
linkDown(0) | LINK-DOWN
linkReady(1) | LINK-READY
linkNotPresent(2) | LINK-NOT-PRESENT
halted(3) | HALTED
failed(4) | FAILED

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


The Telnet port (TELNET)

Configuration of the TELNET port
Statistics of the TELNET port
Commands of the TELNET port

The TELNET port is used within the Abilis CPX to implement the homonymous applicative program.

Generally the telnet is a program of family TCP/IP based on the protocol of transport Connection-Oriented TCP/IP and it allows the User to request a (login) to an other computer. The opening of a session is obtainable specifying IP address of the computer wished to be approached as "virtual terminal", or digiting a mnemonic previously associated to IP destination address of the remote system.

It is possible to distinguish between TELNET processes of type "Client", that accept the login request and provide the connection establishment with the remote unit, and TELNET processes of type "Server" that host on the remote system and provide the login service to the request processes of the TELNET Clients.

The TELNET port of Abilis CPX uses the transport service of Connection-Oriented type offered by the TCP port and the services of IP Router port. It allows, by default, the connection with the Control port and therefore it can access the configuration and supervision functions provided by it.

Configuration of the TELNET port top

The TELNET port is labelled within the Abilis CPX by the acronym "TELNET" and it is provided with the parameters described in the present section.

The following example shows how to display parameters of TELNET ports. Shown value are the default ones.

[14:58:28] ABILIS_CPX: D P PO:TELNET

PO:905 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
TELNET ------------------------------------------------------------------------
       lowpo:901   TYPE:USER  MCAU:NO  ps:128  locport:23     KEEPALIVE:NO
       --Server----------------------------------------------------------------
       PSER:TelnetS>          AC:YES               DT:15
       PWD:                   CDO:00               UDO:CP            ser:3
       IPSRC:*                IPSRCLIST:#
       --Client----------------------------------------------------------------
       PCLI:TelnetC>          CDI:*                UDI:*             cli:3

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on TYPE: and MCAU: parameters are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the TELNET port parameters

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be an TCP port.

Value "NONE" isolates the TELNET port.

TYPE: | Port type
USER | USER

This parameter is used for setting how the port has to behave if data compression is active.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The TELNET port can be only USER.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

PS: | Maximum packet size
128 | 16, 32, 64, 128, 256, 512, 1024, 2048 (bytes)

It sets the maximum packet size (in bytes).

LOCPORT: | Identifier of the IP local port used
23 | 23

It sets the local IP port used by the TELNET port. The IP number assigned by default to the TELNET process (according to recommendations) is 23.

This parameter has got only informative value and cannot be modified.

KEEPALIVE: | Activation and setting of the "Keep-Alive" time-out
NO | NO, 15 - 65535 (seconds)

It activates and set the value of the "Keep-Alive" time-out.

The "Keep-Alive" procedure, by sending the homonymous packets, keeps on the TCP connection even if data are not exchanged. The parameter set the idle time interval (in seconds) which precedes the activation of such procedure.

If the parameter is set to NO, the procedure is not active.

If its value belongs to the interval [15-65535], the procedure will be activated only when the correspondent time-out will run-over.

PSER: | Identifier of the TELNET Server
TELNETS> | from 0 up to 16 ASCII characters [33..126]

This parameter set the prompt of the commands interpreter of the Server TELNET port.

The local IP address, expressed in Dotted Decimal Notation and in square brackets (e.g. [xxx.xxx.xxx.xxx] ), always precedes the prompt defined by the user.

It is possible to use string from 0 up to 16 ASCII characters characters in the range [33..126], spaces are not allowed.

For deleting the TELNET Server identifier this parameter has to be left without value: "S P PO:xxx PSER:", where "xxx" stands for the TELNET port identifier.

AC: | Activation of the Autoconnection mode for the TELNET server
YES | NO, YES

It selects the autoconnection mode for the TELNET Server.

The default value is "YES". In this way the TELNET Server automatically generates a connection request, using information configured in parameters CDO: and UDO:, whenever it receives a login request from a Client TELNET process.

DT: | Idleness disconnection time-out
15 | 0 - 255 (minutes)

Idle time interval after which the connection is closed (in minutes).

PWD: | TELNET Server authentication password
YES | from 0 up to 16 ASCII characters [33..126]

It sets the TELNET Server password, which is asked at the connection.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made.

Once it is set the new password will be, encryptly, saved on disk through the command "SAVE CONF".

Every time the user wants to access the TELNET Server, he will need to insert the password.

For deleting the password this parameter has to be left without value: "S P PO:xxx PWD:", where "xxx" is the TELNET port identifier.

CDO: | Called address of the TELNET Server outgoing call
00 | from 1 up to 15 characters [0 - 9, #]

It sets the called address field of the TELNET Server outgoing call. The default value, jointly with the parameter AC: set to "YES", allows to connect to the Control port.

UDO: | User data filed of the TELNET Server outgoing call
CP | from 1 up to 12 characters [0 - 9, a - z, A - Z, #]

It sets the User data field [1] of the TELNET Server outgoing call. The default value, jointly with the parameter AC: set to "YES", allows to connect to the Control port.

SER: | Number of TELNET Server processes
3 | 0 - 10

Number of Server processes predisposed on the TELNET port.

IPSRC: | Accepted source IP address for incoming requests
* | see table, *

The parameter configures the IP address of enabled source TELNET Client system.

The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The character '*' means "any IP source address" and allows any User to query the Server.

IPSRCLIST: | List of accepted source IP addresses for incoming requests
# | ListName, #

The parameter configures a list of IP addresses of enabled TELNET Client systems.

It must be set to the name of an IP or IR or RU or MR list. The referenced list must already be defined in the Elements Lists service.

The value '#' stands for "no list".

PCLI: | Identifier of the TELNET Client
TELNETC> | from 0 up to 16 ASCII characters [33..126]

This parameter set the prompt of the commands interpreter of the Client TELNET port.

The local IP address, expressed in Dotted Decimal Notation and in square brackets (e.g. [xxx.xxx.xxx.xxx] ), always precedes the prompt defined by the user.

It is possible to use string from 0 up to 16 ASCII characters characters in the range [33..126], spaces are not allowed.

For deleting the TELNET Client identifier this parameter has to be left without value: "S P PO:xxx PCLI:", where "xxx" is the TELNET port identifier.

CDI: | Called address of the TELNET Client incoming call
* | from 1 up to 15 characters [0 - 9, *]

It sets the called address field of the TELNET Client incoming call.

UDI: | User data filed of the TELNET Client incoming call
* | from 1 up to 12 characters [0 - 9, a - z, A - Z, *]

It sets the User data field of the TELNET Client incoming call.

CLI: | Number of TELNET Client processes
3 | 0 - 10

Number of Client processes predisposed on the TELNET port

Statistics of the TELNET port top

Example on how to show state and statistics of the TELNET port through the command D S:

[18:22:40] ABILIS_CPX: D S PO:TELNET

PO:905 ------------------------------------------------------------------------
TELNET STATE:READY
       CH TYPE X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  CLNT READY     READY
       2  CLNT READY     READY
       3  CLNT READY     READY
       4  SERV READY     LISTEN    000.000.000.000-23
       5  SERV CONNECTED CONNECTED 192.168.000.060-23    192.168.000.002-1517
       6  SERV READY     LISTEN    000.000.000.000-23
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         57|          8|CHAR       |       3168|        177|
       PCK        |         34|          8|CALL       |          0|          2|
       RESET      |          0|          0|
       ------------------------------------------------------------------------

Example on how to show extended statistics of the TELNET port through the command D SE:

[18:22:40] ABILIS_CPX: D SE PO:TELNET

PO:905 ------------------------------------------------------------------------
TELNET --- Cleared 000:00:53:11 ago, on 24/03/2004 at 14:42:56 ----------------
       CH TYPE X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       2  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       3  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       4  SERV READY     LISTEN    000.000.000.000-23
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       5  SERV CONNECTED CONNECTED 192.168.000.060-23    192.168.000.002-1517
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         57|          8|CHAR       |       3168|        177|
       PCK        |         34|          8|CALL       |          0|          1|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       6  SERV READY     LISTEN    000.000.000.000-23
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         53|          7|CHAR       |       3015|        163|
       PCK        |         31|          7|CALL       |          0|          1|
       RESET      |          0|          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the TELNET port

STATE: | Current state of the TELNET port
 | READY, DOWN, ERR

It shows the current state of the the TELNET port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
TELNET | READY | ... |  |  | RD
 | DOWN | ... |  |  | DN
 | ERR | Software error, contact the Abilis assistance |  |  | NA

CH | Channel identifier
 | 0 - (SER: + CLI:)

It shows the number of channel on the TELNET port. The maximum number of the available channels is given by the number of Server processes (configuration parameter SER:) summed to the number of Client ones (configuration parameter CLI:).

TYPE | Process type
 | SERV, CLNT

It shows the type of the process active on the channel: the abbreviation "SERV" identifies the Server process, the one "CLNT" the Client process.

X25-State | Connection state
 | READY, LISTEN, CALLING, CONNECTED, CLEARING, CLEARED, ERR

It shows the current state of the connection, towards the Connection Oriented Router.

States | Meaning
READY | Session is ready to send the connection request
LISTEN | Session is ready to receive the connection request
CALLED | Session is establishing the connection
CALLING
CONNECTED | Session is connected
CLEARED | Session is disconnecting
CLEARING
ERR | Software error, contact the Abilis assistance

TCP-State | Connection state towards the TCP port
 | DOWN, READY, LISTEN, CALLING, CONNECTED, CLEARING, CLEARED, ERR

It shows the current state of the connection, towards the TCP port.

States | Meaning
DOWN | The parameter LOWPO: is set to NONE or the driver is not able to connect to the TCP lower level port
READY | Connection is closed
LISTEN | Connection is active and it is waiting to receive/send connection requests
CALLED | Connection is going to be established
CALLING
CONNECTED | Connection is active
CLEARING | Connection is going to be closed
CLEARED
ERR | Software error, contact the Abilis assistance

LocAdd | IP local address used by the connection
 | 0 - 255.255.255.255

It shows the IP local address used by the connection, whose state has not to be READY.

LocPort | IP local port used by the connection
 | 0 - 65.535

It shows the IP local port used by the connection, whose state has not to be READY.

RemAdd | IP remote address used by the connection
 | 0 - 255.255.255.255

It shows the IP remote address used by the connection, whose state has not to be READY.

RemPort | IP remote port used by the connection
 | 0 - 65.535

It shows the IP remote port used by the connection, whose state has not to be READY.

SEG | Overall number of segments received/sent in all the sessions
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a packet is received, while the counter SEG (OUTPUT) every time a packet is sent.

CHAR | Overall number of characters received/sent in all the sessions
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a packet is received, while the counter CHAR (OUTPUT) every time a packet is sent.

PCK | Overall number of packets received/sent in all the sessions
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a packet is received, while the counter PCK (OUTPUT) every time a packet is sent.

CALL | Overall number of calls sent/received in all the sessions
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time a connection request is received, while the counter CALL (OUTPUT) every time a connection request is sent.

RESET | Overall number of resets sent/received in all the sessions
 | 0 - 4.294.967.295

The counter RESET (INPUT) is incremented every time a Reset is received, while the counter RESET (OUTPUT) every time a Reset is sent.

Detail of the extended statistics of the TELNET port

SEG | Number of segments received/sent by the session
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a packet is received, while the counter SEG (OUTPUT) every time a packet is sent by the session.

CHAR | Number of characters received/sent by the session
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a packet is received, while the counter CHAR (OUTPUT) every time a packet is sent by the session.

PCK | Number of packets received/sent by the session
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a packet is received, while the counter PCK (OUTPUT) every time a packet is sent by the session.

CALL | Number of calls sent/received by the session
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time a connection request is received, while the counter CALL (OUTPUT) every time a connection request is sent by the session.

RESET | Number of resets sent/received by the session
 | 0 - 4.294.967.295

The counter RESET (INPUT) is incremented every time a Reset is received, while the counter RESET (OUTPUT) every time a Reset is sent by the session.

Commands of the TELNET port top

While the TELNET Server process is running, the User can access the TELNET port commands pressing the button combination <Ctrl+P>.

As a consequence of this action, the prompt of the TELNET Server, configured in the parameter PSER:, will be displayed.

The user can leave the command exchange procedure and start the data exchange one through pressing again the button combination <Ctrl+P>.

The following table shows the list of the available commands for the command interpreter of the TELNET port:

Command | Description | Notes
OPEN | It requests to open a connection with a TELNET Server process hosting on the remote equipment identified by the specified IP | Only TELNET Client
CLOSE | It requests the session to be closed |
CLR | It requests the session to be closed |

Detail of the TELNET port commands

OPEN | Open connection
 | OPEN xxx.xxx.xxx.xxx

This command, available only on TELNET Client processes, allows the User to open a connection with the TELNET Server process, hosting on the remote equipment identified by the specified IP.

CLOSE | Close connection

It requests the session to be closed.

CLR | Close connection
 | CLR

It requests the session to be closed.

[1] The parameter "UDO:" always refers to the user data, starting from the 5th byte. If the settings of the parameter "UDO:" need the user data, they will be set starting from the 5th byte and in the missing position (from 1st to 4th) the sequence "01000000" will be added.


The Secure Shell port (SSH)

Configuration of SSH port
Statistics of SSH port

The Secure Shell (SSH) port is used within the Abilis CPX to implement the homonymous applicative program.

SSH port configuration top

The Secure Shell port is identified by the mnemonic "SSH" and is provided with the parameters described in this section.

Here are examples on how to display the SSH port parameters. Dispalyed values are the default ones.

[16:04:54] ABILIS_CPX: D P PO:SSH

PO:906 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
SSH    ------------------------------------------------------------------------
       lowpo:901   TYPE:USER  MCAU:NO  ps:128  tcpport:22     KEEPALIVE:NO
       WDIR:C:\APP\SSH\
       --Server----------------------------------------------------------------
       PSER:SSHS>             AC:YES               DT:15
       PWD:                   CDO:00               UDO:CP            ser:3
       IPSRC:*                IPSRCLIST:#                            MAXAUTH:6
       KEYLEN:768             KEYREGENT:60         HOSTKEYLEN:1024
       S-CIPHERS:DES,3DES                  S-AUTH:PWD
       --Client----------------------------------------------------------------
       PCLI:SSHC>             CDI:*                UDI:*             cli:3
       DFT-CIPHER:3DES        MAXPROMPT:3
       C-CIPHERS:DES,3DES                  C-AUTH:PWD

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on TYPE: and MCAU: parameters are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the SSH port parameters

lowpo: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be an TCP port.

Value "NONE" isolates the SSH port.

TYPE: | Port type
USER | USER

This parameter is used for setting how the port has to behave if data compression is active.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The SSH port can be only USER.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

ps: | Maximum length of COR packet size
128 | 16, 32, 64, 128, 256, 512, 1024, 2048 (bytes)

Maximum length of COR packet size (in bytes).

tcpport: | Identifier of the IP local port used
22 | 23

It sets the local IP port used by the SSH port. The IP number assigned by default to the SSH process (according to recommendations) is 22.

This parameter has got only informative value and cannot be modified.

KEEPALIVE: | Activation and setting of the "Keep-Alive" time-out
NO | NO, 15 - 65535 (seconds)

It activates and set the value of the "Keep-Alive" time-out.

The "Keep-Alive" procedure, by sending the homonymous packets, keeps on the TCP connection even if data are not exchanged. The parameter set the idle time interval (in seconds) which precedes the activation of such procedure.

If the parameter is set to NO, the procedure is not active.

If its value belongs to the interval [15-65535], the procedure will be activated only when the correspondent time-out will run-over.

WDIR: | Directory where HOST and SERVER keys are stored.
C:\APP\SSH\ | from 0 up to 128 ASCII extended characters [32..255]

It selects the directory where HOST and SERVER keys are stored.

This parameter must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the backslash ('\') character. Accepted values are strings of up to 128 ASCII extended characters in the range [32..255]. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\"). The case of the entered string is preserved.

PSER: | Identifier of the SSH Server
SSHS> | from 0 up to 16 ASCII characters [33..126]

This parameter set the prompt of the commands interpreter of the SSH Server port.

The local IP address, expressed in Dotted Decimal Notation and in square brackets (e.g. [xxx.xxx.xxx.xxx] ), always precedes the prompt defined by the user.

It is possible to use string from 0 up to 16 ASCII characters characters in the range [33..126], spaces are not allowed.

For deleting the SSH Server identifier this parameter has to be left without value: "S P PO:xxx PSER:", where "xxx" stands for the SSH port identifier.

AC: | Activation of the Autoconnection mode for the SSH Server
YES | NO, YES

It selects the autoconnection mode for the SSH Server.

The default value is "YES". In this way the SSH Server automatically generates a connection request, using information configured in parameters CDO: and UDO:, whenever it receives a login request from a Client SSH Server.

DT: | Inactivity disconnect time-out
15 | 0..255 (min.)

This parameter selects the idle time interval after which the connection is closed (in minutes).

PWD: | SSH Server authentication password
YES | from 0 up to 16 ASCII characters [33..126]

It sets the SSH Server password, which is asked at the connection.

It is possible to use from 0 up to 16 ASCII characters in the range [33..126], spaces are not allowed. No differences between low and high case characters are made.

Once it is set the new password will be, encryptly, saved on disk through the command "SAVE CONF".

Every time the user wants to access the SSH Server, he will need to insert the password.

For deleting the password this parameter has to be left without value: "S P PO:xxx PWD:", where "xxx" is the SSH port identifier.

CDO: | Called NUA for outgoing X25BSVC call
00 | from 1 up to 15 characters [0 - 9, #]

It sets the called address field of the SSH Server outgoing call. The default value, jointly with the parameter AC: set to "YES", allows to connect to the Control Port.

UDO: | User data for outgoing X25BSVC call
CP | from 1 up to 12 characters [0 - 9, a - z, A - Z, #]

It sets the User data field [1] of the SSH Server outgoing call. The default value, jointly with the parameter AC: set to "YES", allows to connect to the Control Port.

ser: | Maximum number of servers
3 | 0..10

This parameter selects the number of SSH Server processes predisposed on the SSH port.

IPSRC: | Accepted source IP address for incoming requests
* | see table, *

The parameter configures the IP address of enabled source SSH Client system.

The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The value '*' means "any Ip address" and it is used to enable SSH requests received from any SSH Client.

IPSRCLIST: | List of accepted source IP addresses for incoming requests
# | ListName, #

The parameter configures a list of IP addresses of enabled SSH Client systems.

It must be set to the name of an IP or IR or RU or MR list. The referenced list must already be defined in the Elements Lists service.

The value '#' stands for "no list".

KEYLEN: | Server key length
768 | 512, 768, 1024 (bits)

This parameter selects the SSH Server RSA key length (in bits).

KEYREGENT: | Server RSA key regeneration time
60 | 30..65535 (min.)

This parameter selects the SSH Server RSA key regeneration time (in minutes).

HOSTKEYLEN: | Host key length
1024 | 512, 768, 1024 (bits)

This parameter selects the host RSA key length (in bits).

MAXAUTH: | Maximum number of authentication attempts
6 | 1..10

This parameter selects the maximum number of authentication attempts for a SSH Client.

S-CIPHERS: | Supported cryptography algorithms
DES,3DES | ALL, IDEA, DES, 3DES, BF (values can be joined using "," operator)

This parameter selects the cryptography algorithms that are supported by the SSH Server.

It can be set to "ALL", i.e. all ciphers, or it can be a combination of the following available ciphers:

Cipher Type | Description
IDEA | IDEA in CFB mode
DES | DES in CBC mode
3DES | Triple-DES in CBC mode
BF | Blowfish

S-AUTH: | Supported authentication method
PWD | NONE, PWD

This parameter selects the authentication method that is supported by the SSH Server.

Authentication methods | Description
NONE | No Authentication
PWD | Password Authentication

PCLI: | Identifier of the SSH Client
SSHC> | from 0 up to 16 ASCII characters [33..126]

This parameter set the prompt of the commands interpreter of the SSH Client port.

The local IP address, expressed in Dotted Decimal Notation and in square brackets (e.g. [xxx.xxx.xxx.xxx] ), always precedes the prompt defined by the user.

It is possible to use string from 0 up to 16 ASCII characters characters in the range [33..126], spaces are not allowed.

For deleting the SSH Client identifier this parameter has to be left without value: "S P PO:xxx PCLI:", where "xxx" is the SSH port identifier.

CDI: | Called NUA to match incoming X25BSVC call
* | from 1 up to 15 characters [0 - 9, *]

It sets the called address field of the SSH Client incoming call.

UDI: | User data to match incoming X25BSVC call
* | from 1 up to 12 characters [0 - 9, a - z, A - Z, *]

It sets the User data field of the SSH Client incoming call.

cli: | Maximum number of clients
3 | 0..10

This parameter selects the maximum number of SSH Clients processes predisposed on the SSH port.

DFT-CIPHER: | Client cryptography algorithm
3DES | IDEA, DES, 3DES, BF, AUTO

This parameter selects the default cipher type of SSH Client.

It can be one of the following available ciphers:

Cipher Type | Description
IDEA | IDEA in CFB mode
DES | DES in CBC mode
3DES | Triple-DES in CBC mode
BF | Blowfish

If it is set to "AUTO" value, the SSH Client will try to select the cryptography algorithm automatically.

MAXPROMPT: | Maximum number of password prompts
3 | 1..10

This parameter selects the maximum number of unsuccessful inputs of password for the SSH client.

C-CIPHERS: | Supported cryptography algorithms
DES,3DES | ALL, IDEA, DES, 3DES, BF (values can be joined using "," operator)

This parameter selects the cryptography algorithms that are supported by the SSH Client.

It can be set to "ALL", i.e. all ciphers, or it can be a combination of the following available ciphers:

Cipher Type | Description
IDEA | IDEA in CFB mode
DES | DES in CBC mode
3DES | Triple-DES in CBC mode
BF | Blowfish

C-AUTH: | Supported authentication methods
PWD | NONE, PWD

This parameter selects the authentication method that is supported by the SSH Client.

Authentication methods | Description
NONE | No Authentication
PWD | Password Authentication

SSH port statistics top

Example on how to show state and statistics of the SSH port through the command D S:

[10:56:27] ABILIS_CPX: D S PO:SSH

PO:906 ------------------------------------------------------------------------
SSH    STATE:READY
       CH TYPE X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  CLNT READY     READY
       2  CLNT READY     READY
       3  CLNT READY     READY
       4  SERV READY     LISTENING 000.000.000.000-22
       5  SERV READY     LISTENING 000.000.000.000-22
       6  SERV CONNECTED CONNECTED 192.168.000.060-22    192.168.000.002-1662
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         66|          0|CHAR       |       4103|         23|
       PCK        |         34|          0|CALL       |          0|          1|
       RESET      |          0|          0|
       ------------------------------------------------------------------------

Example on how to show extended statistics of the SSH port through the command D SE:

[10:56:30] ABILIS_CPX: D SE PO:SSH

PO:906 ------------------------------------------------------------------------
SSH    --- Cleared 000:00:06:50 ago, on 24/03/2004 at 17:10:39 ----------------
       CH TYPE X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       1  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       2  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       3  CLNT READY     READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       4  SERV READY     LISTENING 000.000.000.000-22
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       5  SERV READY     LISTENING 000.000.000.000-22
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|CALL       |          0|          0|
       RESET      |          0|          0|
       ------------------------------------------------------------------------
       6  SERV CONNECTED CONNECTED 192.168.000.060-22    192.168.000.002-1662
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |         66|          0|CHAR       |       4103|         23|
       PCK        |         34|          0|CALL       |          0|          1|
       RESET      |          0|          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the SSH port

STATE: | Current state of the SSH port
 | READY, DOWN, ERR

It shows the current state of the the SSH port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
SSH | READY | ... |  |  | RD
 | DOWN | ... |  |  | DN
 | ERR | Software error, contact the Abilis assistance |  |  | NA

CH | Channel identifier
 | 0 - (ser: + cli:)

It shows the number of channel on the SSH port. The maximum number of the available channels is given by the number of Server processes (configuration parameter ser:) summed to the number of Client ones (configuration parameter cli:).

TYPE | Process type
 | SERV, CLNT

It shows the type of the process active on the channel: the abbreviation "SERV" identifies the Server process, the one "CLNT" the Client process.

X25-State | Connection state
 | READY, LISTEN, CALLING, CONNECTED, CLEARING, CLEARED, ERR

It shows the current state of the connection, towards the Connection Oriented Router.

States | Meaning
READY | Session is ready to send the connection request
LISTEN | Session is ready to receive the connection request
CALLED | Session is establishing the connection
CALLING
CONNECTED | Session is connected
CLEARED | Session is disconnecting
CLEARING
ERR | Software error, contact the Abilis assistance

TCP-State | Connection state towards the TCP port
 | DOWN, READY, LISTEN, CALLING, CONNECTED, CLEARING, CLEARED, ERR

It shows the current state of the connection, towards the TCP port.

States | Meaning
DOWN | The parameter LOWPO: is set to NONE or the driver is not able to connect to the TCP lower level port
READY | Connection is closed
LISTEN | Connection is active and it is waiting to receive/send connection requests
CALLED | Connection is going to be established
CALLING
CONNECTED | Connection is active
CLEARING | Connection is going to be closed
CLEARED
ERR | Software error, contact the Abilis assistance

LocAdd | IP local address used by the connection
 | 0 - 255.255.255.255

It shows the IP local address used by the connection, whose state has not to be READY.

LocPort | IP local port used by the connection
 | 0 - 65.535

It shows the IP local port used by the connection, whose state has not to be READY.

RemAdd | IP remote address used by the connection
 | 0 - 255.255.255.255

It shows the IP remote address used by the connection, whose state has not to be READY.

RemPort | IP remote port used by the connection
 | 0 - 65.535

It shows the IP remote port used by the connection, whose state has not to be READY.

SEG | Overall number of segments received/sent in all the sessions
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a packet is received, while the counter SEG (OUTPUT) every time a packet is sent.

CHAR | Overall number of characters received/sent in all the sessions
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a packet is received, while the counter CHAR (OUTPUT) every time a packet is sent.

PCK | Overall number of packets received/sent in all the sessions
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a packet is received, while the counter PCK (OUTPUT) every time a packet is sent.

CALL | Overall number of calls sent/received in all the sessions
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time a connection request is received, while the counter CALL (OUTPUT) every time a connection request is sent.

RESET | Overall number of resets sent/received in all the sessions
 | 0 - 4.294.967.295

The counter RESET (INPUT) is incremented every time a Reset is received, while the counter RESET (OUTPUT) every time a Reset is sent.

Detail of the extended statistics of the SSH port

SEG | Number of segments received/sent by the session
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a packet is received, while the counter SEG (OUTPUT) every time a packet is sent by the session.

CHAR | Number of characters received/sent by the session
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a packet is received, while the counter CHAR (OUTPUT) every time a packet is sent by the session.

PCK | Number of packets received/sent by the session
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a packet is received, while the counter PCK (OUTPUT) every time a packet is sent by the session.

CALL | Number of calls sent/received by the session
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time a connection request is received, while the counter CALL (OUTPUT) every time a connection request is sent by the session.

RESET | Number of resets sent/received by the session
 | 0 - 4.294.967.295

The counter RESET (INPUT) is incremented every time a Reset is received, while the counter RESET (OUTPUT) every time a Reset is sent by the session.

[1] The parameter "UDO:" always refers to the user data, starting from the 5th byte. If the settings of the parameter "UDO:" need the user data, they will be set starting from the 5th byte and in the missing position (from 1st to 4th) the sequence "01000000" will be added.


The Domain Name System Port (DNS)

Terminology

Configuration of the DNS port
Statistics of the DNS port

The Domain Name System (DNS) protocol of TCP/IP networks identifies network stations through a symbolic name associated to the IP address.

When active, the Abilis CPX DNS port behaves as a DNS Resolver for all the local services and, if activated, as a DNS Relay too. The DNS Relay feature allows the system to appear as a DNS server to other IP stations while it simply forwards the requests to real DNS servers, and their responses are forwarded back to the original requesters.

The DNS port of the Abilis CPX uses the Connection Less transport service, provided by the UDP protocol, to query one or two DNS servers referred as primary and secondary.

Terminology top

Acting as resolver
When the Abilis CPX DNS Resolver has to deal with an address, it first makes a query to the primary DNS Server. If, after 500 milliseconds, it doesn't get any response, it forwards the same query to both servers and if, after 1 second, no response is received another request to both servers is sent. This procedure is also repeated if no response is received after 2 seconds. If the DNS Resolver doesn't get any answer, after 4 second it terminates the procedure. If the parameter RTY: is set to a value higher than 1, the procedure will be repeated as many times as its value. The delay (in seconds) between two following blocks of queries can be set through the parameter DELAY:.
Acting as relay
When CPX acts as DNS relay it actually acts as an "intermediate" between the requester and the real DNS servers.
Why it is needed?
This method is absolutely needed when the CPX is used in a LAN as a router with NAT+PAT with a dial-up PPP connection. In this situation the address of DNS servers may not be known in advance because they are discovered at PPP connection establishment, and therefore they cannot be configured in the stations: the address of CPX is configured instead, which in turn will forward the request to the DNS servers addresses obtained by PPP. The method can also be used to simplify the configuration of the lan stations: lans are configured with the same address for both "default gateway" and "DNS server", CPX will forward the requests to the configured DNS which may be easily changed by CPX administrator in any moment, and for all the stations.
DNS relay service "listens" for incoming requests on the local UDP port 53, and behaves as explained below:
  • listen for requests on local UDP port 53
  • receives a DNS request from DNS client
  • validates the request (only formally correct ones are processed)
  • relays the request to a real DNS server (PRIMARY or SECONDARY)
  • receives, from the real DNS server, the response for this request
  • sends the response to the DNS requester (also called DNS client)

In addition DNS relay can:
  • Check the IP address of a requester (source IP in the request packet) against a list of allowed ones and discard those not allowed.
  • Process several simultaneous requests from the same or different users.
  • Load balance between PRIMARY and SECONDARY DNS servers.
  • Validate incoming packets (requests from clients and responses from servers) against formal errors.

Configuration of the DNS port top

The Domain Name System Protocol port is labelled within the Abilis CPX with the acronym "DNS" and it is provided with the parameters described in this section.

Here is an example on how to display the DNS port parameters. Shown values are the default ones.

[11:32:37] ABILIS_CPX: D P PO:DNS

PO:910 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
DNS    ------------------------------------------------------------------------
       LOG:NO         lowpo:902    ACT:YES   RELAY:NO
       locport:53     SRCADD:R-ID (192.168.000.060)
       PRIMARY:#                SECONDARY:#
       - Resolver -------------------------------------------------------------
       DELAY:5        RTY:1
       - Relay ----------------------------------------------------------------
       RELAY-TOUT:10  IPSRC:*                IPSRCLIST:#

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the DNS port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Lower CPX port number
NONE | NONE, 1 - 999

It sets the lower CPX port number. Only UDP are accepted.

Value "NONE" isolate the DNS port.

ACT: | Runtime activation/deactivation
NO | NO, YES

This parameter allows to run-time activate/deactive DNS functionalities.
When it is set to "NO", DNS port is running but its functionalities are disabled.
When it is set to "YES", DNS port is running and its functionalities are enabled.

RELAY: | Activation/deactivation of DNS relay feature.
NO | NO, YES

This parameter activate/deactivate DNS relay feature for DNS port. DNS relay allows to relay external DNS requests of DNS clients from CPX to DNS server.

locport: | DNS-relay listening UDP port
53 | 53

This parameter sets the UDP port on which the DNS relay will receive client's requests. As specified in RFC-1700 and RFC-1035, the only possible value is 53.

SRCADD: | Source IP address for outgoing requests
R-ID | R-ID, OUT-IPP, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

It sets the IP address to be set in every outgoing DNS requests.

The "R-ID" value makes possible to use the Router-ID IP address.

The "OUT-IPP" value makes possible to use the IP address of the IP port through which the request is sent.

The specification of an IP address, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is also allowed. D and E class of IP addresses are not supported.

PRIMARY: | IP address of the primary DNS Server
# | #, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter sets the IP address of the primary DNS server, which the Abilis CPX port refers to for name resolution.

The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The value "#" means "none primary DNS Server".

SECONDARY: | IP address of the secondary DNS Server
# | #, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter sets the IP address of the secondary DNS server, which the Abilis CPX port refers to for name resolution.

The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The value "#" means "none secondary DNS Server".

DELAY: | Time that resolvers waits for server's responses
5 | 1..15 sec.

This parameter sets the maximum time (in seconds) to wait for receiving a response from the DNS server (Resolver only).

RTY: | Number of attempts to perform DNS request
1 | 1..10

This parameter sets how many times a request has to be sent to the DNS server if the DNS Resolver doesn't get any response in the expected time interval fixed in the DELAY: parameter (Resolver only).

RELAY-TOUT: | Timeout waiting server response for relayed requests
5 | 5..60 sec.

This parameter sets the time of life (in seconds) for a record in DNS relay table (Relay only).
The record in the DNS relay table is used to forward back to the client the response from the PRIMARY: or SECONDARY: server, therefore if the time elapses and record is deleted further "late answers" cannot be passed back to the client.

IPSRC: | Client IP address from which the requests are accepted
* | *, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter selects the IP address of the client from which the requests will be accepted (Relay only).
In conjunction with IPSRCLIST:, it allows to selectively grant/deny the service to stations by looking at their IP address, actually the source IP address of the requests.

If it is equal to "*", requests are accepted from any IP address. This value also makes IPSRCLIST: parameter irrelevant.

If it is equal to a specific IP address, only requests from that address are accepted. However, if an IP list is specified in IPSRCLIST:, those IP addresses will be accepted too.
The allowed IP addresses are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Requests coming from DNS Client, whose IP address doesn't match neither the value configured in this parameter nor satisfies the list configured in IPSRCLIST: parameter, are discarded.

IPSRCLIST: | List of additional client IP addresses from which the requests are accepted
# | ListName, #

The parameter sets the list of DNS Client systems enabled to use the DNS relay service.

The name of the list must be string of up to 20 characters in the range [0..9, a..z, A..Z, _]. It must correspond to the name of a list of IP addresses or the name of a list of IP addresses ranges or the name of a Rule list or the name of a Master Rule list. The referenced list must already be defined in the Elements Lists service.

The value "#" means "no list".

Requests coming from DNS Clients, whose IP address doesn't satisfy neither the list configured in this parameter nor matches the value configured in IPSRC: parameter, are discarded.

Statistics of the DNS port top

The following example shows how to display state and statistics of the DNS port through the command D S:

[11:32:37] ABILIS_CPX: D S PO:DNS
PO:910 ------------------------------------------------------------------------
DNS    RESOLVER-STATE:READY
       RELAY-STATE:READY     CUR:0        PEAK:0        MAX:0
       - Resolver -------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       PRI-QUERIES|           |          0|SEC-QUERIES|           |          0|
       PRI-RES    |          0|           |SEC-RES    |          0|           |
       PRI-UNK    |          0|           |SEC-UNK    |          0|           |
       PRI-RTY-OVR|          0|           |SEC-RTY-OVR|          0|           |
       PRI-TOUT   |          0|           |SEC-TOUT   |          0|           |
       PRI-ERRORS |          0|           |SEC-ERRORS |          0|           |
       ------------------------------------------------------------------------
       - Relay ----------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQ-TOTAL  |          0|           |PRI-REQ-RSP|          0|          0|
       REQ-SUCC   |          0|           |SEC-REQ-RSP|          0|          0|
       REQ-BAD    |          0|           |PRI-NOMATCH|          0|           |
       OVERFLOW   |          0|           |SEC-NOMATCH|          0|           |
       DROP-ACCESS|          0|           |RSP-BAD    |          0|           |
       ------------------------------------------------------------------------

The following example shows how to display extended statistics of the DNS port through the command D SE:

[16:14:55] ABILIS_CPX: D SE PO:DNS

PO:910 ------------------------------------------------------------------------
DNS    --- Cleared 000:01:20:58 ago, on 11/05/2004 at 14:56:24 ----------------
       - Resolver -------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       PRI-QUERIES|           |          0|SEC-QUERIES|           |          0|
       PRI-RES    |          0|           |SEC-RES    |          0|           |
       PRI-UNK    |          0|           |SEC-UNK    |          0|           |
       PRI-RTY-OVR|          0|           |SEC-RTY-OVR|          0|           |
       PRI-TOUT   |          0|           |SEC-TOUT   |          0|           |
       PRI-ERRORS |          0|           |SEC-ERRORS |          0|           |
       ------------------------------------------------------------------------
       - Relay ----------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQ-TOTAL  |          0|           |PRI-REQ-RSP|          0|          0|
       REQ-SUCC   |          0|           |SEC-REQ-RSP|          0|          0|
       REQ-BAD    |          0|           |PRI-NOMATCH|          0|           |
       OVERFLOW   |          0|           |SEC-NOMATCH|          0|           |
       DROP-ACCESS|          0|           |RSP-BAD    |          0|           |
       ------------------------------------------------------------------------

If DNS relay feature is not active, i.e. RELAY: parameter is set to "NO", the "Relay" section of the statistics will not appear.

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of state fields and statistics of the DNS port

RESOLVER-STATE: | Current state of the resolver service
 | INACTIVE, DOWN, READY, ERR

It shows the actual state of the resolver service.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
DNS | INACTIVE | Driver is not active because ACT: parameter is set to "NO". | IN
 | DOWN | Driver is not active because not connected to the lower level UDP port, or the LOWPO: parameter is set to "NONE". | DN
 | READY | Driver is successfully connected to the UDP port and properly working | RD
 | ERR | Software Error. Contact the Abilis assistance. | NA

RELAY-STATE: | Current state of the relay service
 | INACTIVE, DOWN, READY, ERR

It shows the actual state of the relay service.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
DNS | INACTIVE | State set when the parameter RELAY: is set to "NO" or when the parameter ACT: is set to "NO". | NA
 | DOWN | Driver is not active because not connected to the lower level UDP port, or the parameter LOWPO: is set to "NONE" | DN
 | READY | Driver is successfully connected to the UDP port and properly working | RD
 | ERR | Software Error. Contact the Abilis assistance | NA

CUR: | Number of records currently occupied with pending requests.
0 | 0 - 20000

It counts all the records that contains a request "waiting for server response", not yet timed out.

PEAK: | Maximum number of simultaneously pending records ever reached.
0 | 0 - 20000

This value shows the maximal use of the table, that is the maximum number of records that were simultaneously waiting for response, not yet timed out.

MAX: | Maximum number of simultaneously pending requests.
500 | 0 - 20000

This is actually the number of records that the table can host. The value 500 is the size provided in Abilis CPX and cannot be changed by the user. The value has been determined in excess, however if you exeperience frequent "table full" please contact Abilis helpdesk to get the workaround.

PRI-QUERIES | Number of queries sent to the primary DNS server
 | 0 - 4.294.967.295

The counter PRI-QUERIES (OUTPUT) shows the overall number of queries sent to the primary DNS Server.

PRI-RES | Number of responses received from the primary DNS server
 | 0 - 4.294.967.295

The counter PRI-RES (INPUT) shows the overall number of response received from the primary DNS Server.

PRI-UNK | Number of negative responses received from the primary DNS Server
 | 0 - 4.294.967.295

The counter PRI-UNK (INPUT) shows the overall number of negative responses ("Unknown Host") received from the primary DNS Server.

PRI-RTY-OVR | Number of retransmission to the primary DNS server overruns
 | 0 - 4.294.967.295

The counter PRI-RTY-OVR (INPUT) shows how many times the maximum number, configured in the parameter RTY:, of retransmission to the primary DNS Server ran over.

PRI-TOUT | Number of times the time-out of response from the primary DNS server ran over
 | 0 - 4.294.967.295

The counter PRI-TOUT (INPUT) is incremented every time the time-out, configured in the parameter DELAY:, of responses from the primary DNS Server ran over.

PRI-ERRORS | Number of bad frames received from the primary DNS server
 | 0 - 4.294.967.295

The counter PRI-ERRORS (INPUT) shows the number of invalid frames received from the primary DNS Server.

SEC-QUERIES | Number of queries sent to the secondary DNS server

The counter SEC-QUERIES (OUTPUT) shows the overall number of queries sent to the secondary DNS Server.

SEC-RES | Number of response received from the secondary DNS server
 | 0 - 4.294.967.295

The counter SEC-RES (INPUT) shows the overall number of responses received from the secondary DNS Server.

SEC-UNK | Number of negative responses received from the secondary DNS Server
 | 0 - 4.294.967.295

The counter SEC-UNK (INPUT) shows the overall number of negative responses ("Unknown Host") received from the secondary DNS Server.

SEC-RTY-OVR | Number of retransmission to the secondary DNS server overruns
 | 0 - 4.294.967.295

The counter SEC-RTY-OVR (INPUT) shows how many times the maximum number, configured in the parameter RTY:, of retransmission to the secondary DNS Server ran over.

SEC-TOUT | Number of times the time-out of response from the secondary DNS server ran over
 | 0 - 4.294.967.295

The counter SEC-TOUT (INPUT) is incremented every time the time-out, configured in the parameter DELAY:, of responses from the secondary DNS Server ran over.

SEC-ERRORS | Number of bad frames received from the secondary DNS server
 | 0 - 4.294.967.295

The counter SEC-ERRORS (INPUT) shows the number of invalid frames received from the secondary DNS Server.

REQ-TOTAL | Total number of all the client's requests that arrived to DNS relay.
 | 0 - 4.294.967.295

It counts all the requests arrived from clients, regardless whether they are later processed or discarded.

REQ-SUCC | Total number of client's DNS requests that were processed successfully.
 | 0 - 4.294.967.295

Incremented for every client's request that actually got an answer. It mean that:

  • DNS relay received the client's request
  • DNS relay forwarded the request
  • DNS relay received the response from the DNS server
  • The response is sent back to the client
OVERFLOW | Total number of DNS requests received from clients but was not processed because the DNS relay table was overflow.
 | 0 - 4.294.967.295

This counter is incremented for every client's request that passed all the checks (access validation, formal checks, etc), but could not occupy a record because the table was full, and therefore it had to be discarded.

PRI-NOMATCH | Number of responses from primary DNS for which a matching request was not found in the table.
 | 0 - 4.294.967.295

A record in the table for a response could not found when:

  • DNS relay has not received a matching request for this response.
  • A record for this response was in the table but it became out of date and was used for other request.

The precise distinction between timeout and missing record is not perfomed because it is an imprecise information: timed out records can be left or deleted depending on needs.

SEC-NOMATCH | Number of responses from secondary DNS for which a matching request was not found in the table.
 | 0 - 4.294.967.295

A record in the table for a response could not found when:

  • DNS relay has not received a matching request for this response.
  • A record for this response was in the table but it became out of date and was used for other request.

The precise distinction between timeout and missing record is not perfomed because it is an imprecise information: timed out records can be left or deleted depending on needs.

DROP-ACCESS | Total number of DNS requests received and discarded because not allowed.
 | 0 - 4.294.967.295

The counter DROP-ACCESS shows the number of DNS requests received from the clients but not processed because requester (the author of this DNS request) is not allowed. The not-allowed requester is a client whose IP address is not present in IPSRC and IPSRCLIST parameters configuration.

REQ-BAD | Number of client's requests that was malformed or contained severe formal errors.
 | 0 - 4.294.967.295

Incremented for every client's request that, after having passed the "source IP access validation", was detected as malformed, or with error in the content, or any other serious formal error.

RSP-BAD | Number of responses that had to be discarded because they had formal errors that prevented further processing.
 | 0 - 4.294.967.295

This counter incremented in cases when:

  • The source port of a response's UDP packet is not equal DNS (53) port.
  • A matching request for this respons did not find in the table and the IP source address of a response's UDP packet is not equal IP address of primary DNS Server and not equal IP address of secondary DNS Server.
  • other formal errors.
PRI-REQ-RSP | Number of requests and responses exchanged with primary DNS.
 | 0 - 4.294.967.295

The counter PRI-REQ-RSP (INPUT) is incremented every time that DNS receives a response from the primary DNS Server.

The counter PRI-REQ-RSP (OUTPUT) is incremented every time that DNS sends a request to the primary DNS Server.

SEC-REQ-RSP | Number of requests and responses exchanged with secondary DNS.
 | 0 - 4.294.967.295

The counter SEC-REQ-RSP (INPUT) is incremented every time that DNS receives a response from the secondary DNS server.

The counter SEC-REQ-RSP (OUTPUT) is incremented every time that DNS sends a request to the secondary DNS server.


The Simple Network Time Protocol (SNTP) port

Revised for CPX 4.1.0.
Configuration of the SNTP port
Statistics of the SNTP ports
SNMP TRAPS generated for the SNTP ports

The SNTP port is used within the Abilis CPX to implement the homonymous synchronization protocol for TCP/IP networks.

The Simple Network Time Protocol (SNTP) is an adaptation of the Network Time Protocol (NTP) used to synchronize computer clocks in the Internet.

The NTP, specified in RFC-1305, is used to synchronize computer clocks in the global Internet. It provides comprehensive mechanisms to access national time and frequency dissemination services, organizes the time-synchronization subnet and adjust the local clock in each participating subnet peer.

In most places of the Internet of today, NTP provides accuracies of 1-50 ms, depending on the characteristics of the synchronization source and network paths.

The SNTP protocol can be used when the ultimate performance of the full NTP implementation is not needed or justified. It allows the automatic management of clock synchronization of any equipment by recovering information about date and current time from one or more SNTP server stations available in the Internet.

The SNTP has got a client/server implementation. The Abilis CPX SNTP port, by using the Connection-Less transport service provided by the UDP protocol, is able to:

  • behave as SNTP Client, that is to synchronize the internal Abilis clock with data provided by a SNTP Server available in the Internet;
  • behave as SNTP Server, that is to provide the clock synchronization to any requesting SNTP Client.

Configuration of the SNTP port top

The SNTP port is labelled within the Abilis CPX with the acronym "SNTP" and it is provided with the parameters described in this section.

Here is an example on how to show the SNTP port parameters. Shown values are only examples:

[18:17:18] ABILIS_CPX: D P PO:SNTP

PO:909 - Udp_protocol_entry_point ---------------------------------------------
SNTP   LOG:NO       lowpo:902    udpport:123
       --Server----------------------------------------------------------------
       SERVACT:NO   IPSRC:*                IPSRCLIST:#
       --Client----------------------------------------------------------------
       CLIACT:YES   SNTPHOST:192.168.000.253  SRCADD:R-ID (192.168.000.207)
                    POLLP:60     NRTY:3       TBW:30     TBD:30

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:.

Changes made on the parameter LOG: are immediately active.

Detail of the SNTP port parameter

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be an UDP port.

Value "NONE" isolates the SNTP port.

UDPPORT: | Identifier of the used UDP port
123 | 123

It sets the local UDP port that is used by the SNTP port. According to recommendations, the UDP port number assigned to both NTP and SNTP protocols is 123, which should be used in both the Source Port and Destination Port fields in the UDP datagram header.

This parameter has got only informative value and cannot be modified.

SERVACT: | SNTP Server activation
NO | NO, YES

It activates/deactivates the SNTP Server functionality above mentioned. If the parameter is set to "NO", even if the SNTP port is configured and active, it won't carry out the Server function.

When the Client process of the SNTP port is not activated (CLIACT: set to "NO"), the Server process will operate as a primary reference source of synchronization. I.e. it will provide the clock synchronization, using the uncalibrated local Abilis CPX clock and without external means of synchronization.

When the Client process of the SNTP port is also activated (CLIACT: set to "YES"), the Server process will operate as a secondary reference source of synchronization. I.e. it will provide the clock synchronization, retrived by the Client process, to any requesting SNTP Client.

IPSRC: | IP address of the SNTP Client enabled to query the Server process of Abilis CPX
* | *, see table

The parameter sets the IP address of the SNTP Client enabled to query the Server process of Abilis CPX. Allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Synchronization requests coming from SNTP Client, whose IP address doesn't match either the value configured in this parameter or the list of values configured in IPSRCLIST: parameter, are discarded by the Server process of Abilis CPX.

The character '*' stands for "any IP source address": any SNTP Client can query the Server process of Abilis CPX.

IPSRCLIST: | List of SNTP Clients enabled to query the Server process of Abilis CPX
# | ListName, #

The parameter sets the list of SNTP Client systems enabled to query the Server process of Abilis CPX.

The accepted types of element list are: IP addresses (IP), rangess of IP addresses (IR), Rules (RU), Master Rules (MR).

Synchronization requests coming from SNTP Client, whose IP address doesn't match either the list of values configured in this parameter or the value configured in IPSRC: parameter, are discarded by the Server process of Abilis CPX.

The value '#' means "no list".

CLIACT: | SNTP Client activation
NO | NO, YES

It activates/deactivates the SNTP Client functionality above mentioned. If the parameter is set to "NO", even if the SNTP port is configured and active, it won't carry out the Client function.

When the Server process of the SNTP port is also activated (SERVACT: set to "YES"), the Client process activation/deactivation effects the Server process operational mode.
If the Client process is not active the Server process operates as a primary reference source of synchronization; if the Client process is active the Server process operates as a secondary reference source of synchronization.

SNTPHOST: | IP address of the SNTP Server host
* | see table, #

It sets the IP address of the SNTP Server host to which the Client process of the Abilis CPX will send its synchronization requests. The allowed values are:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The character '#' stands for "no IP address": it can be used to disable the SNTP Client of Abilis CPX even if the parameter CLIACT: is set to "YES".

SRCADD: | Source IP address for Client requests
R-ID | R-ID, OUT-IPP, see table

It sets the IP address to be set in outgoing Client synchronization requests.

The "R-ID" value makes possible to use the Router-ID IP address.

The "OUT-IPP" value makes possible to use the IP address of the IP port through which the request is sent.

The specification of an IP address, in Dotted Decimal Notation, is also allowed. The available values of IP address are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

D and E class of IP addresses are not, at the moment, supported.

POLLP: | Synchronization interval
60 | 1 - 65535 (minutes)

It sets the time interval (in minutes) after which has to start the synchronization procedure of the SNTP Client of Abilis CPX toward the SNTP Sever whose IP address is set in the parameter SNTPHOST:.

NRTY: | Maximum number of repetition for each synchronization attempt
3 | 0 - 255

It sets how many times the synchronization request can be repeated, once this value is over taken the request will be considered failed. According to the SNTP protocol, a single synchronization request can fail because of several reasons: missing answer from the queried Sever, bad format/bad content of the received synchronization message.

TBW: | Time interval to be waited for getting an answer to the synchronization request
30 | 1 - 65535 (in seconds)

The parameter sets the time interval (in seconds) after which, if no answer from the SNTP Serve is received, the request, sent by the SNTP Client of the Abilis CPX, will be considered failed.

TBD: | Time interval between two successive synchronization requests
30 | 1 - 65535 (in seconds)

This parameter sets the time interval (in seconds) between a failed synchronization request and its successive one. If the request, sent by the Client process of the Abilis CPX, has not be responded, the next one can be send only after "TBD:" seconds. As consequence, in case of no answer, the overall time interval between one request and its successive one will be obtained from the sum of "TBD:" and TBW: paramter's values.

Statistics of the SNTP ports top

How to check state and statistics of the SNTP ports by the command D S.

[18:17:22] ABILIS_CPX: D S PO:909 .

PO:909 ------------------------------------------------------------------------
SNTP   Local Clock Synchronized: External Clock Reference 192.168.000.253
       Clock last synchronized on 09/04/2002 at 16:57:58 Delta:-1 sec.
       Server-State:INACTIVE
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SER-PCK    |          0|          0|SER-BADPCK |          0|           |
       SER-BADSRC |          0|           |
       ------------------------------------------------------------------------
       Client-State:READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CLI-PCK    |         94|         94|CLI-BADPCK |          0|           |
       CLI-BADSRC |          0|           |CLI-TOUT   |          0|           |
       SUCC-SYNC  |         94|           |FAIL-SYNC  |          0|           |
       ------------------------------------------------------------------------

The string "Local Clock Synchronized" means that the internal clock of the Abilis CPX is correctly synchronized.

The eventual message "Local Clock Unsynchronised" means that the synchronization is not guaranteed.

On the same row, it is also shown whether the internal clock of Abilis CPX has been synchronized using an external clock source (through the SNTP Client process): "External Clock Reference 192.168.000.253" or using an internal clock source (SNTP Sever process) "Internal Clock Reference".

If the Server, whose address is set in the parameter SNTPHOST: is, for any reason, not reachable the following message will be shown: "Unavailable Clock Reference".

Information "Clock last synchronized on 09/04/2002 at 16:57:58 Delta:-1 sec." shows date, time of the last successful synchronization and the difference, in seconds, between date and time of the internal clock with the ones received from the queried SNTP Server.

If this information won't be available the following message will be shown: "Clock last synchronization unavailable".

For a more detailed description of these counters, please refer to the next section.

The SNTP ports have extended statistics and they can be displayed through the execution of the command D SE, shown values are the same to the ones obtained by the D S execution:

[18:17:22] ABILIS_CPX: D SE PO:909 .

PO:909 ------------------------------------------------------------------------
SNTP   --- Cleared 003:20:39:33 ago, on 05/04/2002 at 20:51:19 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SER-PCK    |          0|          0|SER-BADPCK |          0|           |
       SER-BADSRC |          0|           |
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CLI-PCK    |         94|         94|CLI-BADPCK |          0|           |
       CLI-BADSRC |          0|           |CLI-TOUT   |          0|           |
       SUCC-SYNC  |         94|           |FAIL-SYNC  |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the SNTP ports

Server-State: | Current state of the Server process of the SNTP port
 | INACTIVE, ACTIVE, READY, DISCONNECTING, HALTED, ERR

It shows the current state of the SNTP Server process.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
SNTP | INACTIVE | The configuration parameter SERVACT: is set to "NO" so that the driver is active, but it is not working. By setting the parameter to "YES" and executing the command INIT PO: on this port, it will be possible to activate the driver. |  |  | IN
 | DOWN | The configuration parameter SERVACT: is set to "YES"; but the driver is not connected to the UDP port or the parameter LOWPO: is set to "NONE" |  |  | DN
 | READY | The configuration parameter SERVACT: is set to "YES"; the driver is successfully connected to the port and working |  |  | RD
 | DISCONNECTING | The driver is disconnecting from the UDP port |  |  | DG
 | HALTED | Owing to an error the driver is halted |  |  | HL
 | ERR | Software error. Contact Abilis assistance. |  |  | NA

SER-PCK: | Number of packets sent/received by the SNTP Server
 | 0 - 4.294.967.295

The counter SER-PCK (INPUT) is incremented every time the Server receives a SNTP synchronization request, while the counter SER-PCK (OUTPUT) every time it sends a SNTP response frame to a received synchronization request.

SER-BADPCK: | Number of not valid packets received by the SNTP Server
 | 0 - 4.294.967.295

The counter SER-BADPCK (INPUT) is incremented every time the SNTP Server receives a frame whose content or format is not valid.

SER-BADSRC: | Number of packets received by the SNTP Server from a not enabled SNTP Client
 | 0 - 4.294.967.295

The counter SER-BADSRC (INPUT) is incremented every time the Server receives a SNTP synchronization request from a SNTP Client with an IP address either not matching the one set in the parameter IPSRC: or not contained in the list of SNTP Clients set in the parameter IPSRCLIST:.

Client-State: | Current state of the Client process of the SNTP port
 | INACTIVE, ACTIVE, READY, DISCONNECTING, HALTED, ERR

It shows the current state of the Client process of the SNTP port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
SNTP | INACTIVE | The configuration parameter CLIACT: is set to "NO" so that the driver is active, but it is not working. By setting the parameter to "YES" and executing the command INIT PO: on this port, it will be possible to activate the driver |  |  | IN
 | DOWN | The configuration parameter CLIACT: is set to "YES"; but the driver is not connected to the UDP port or the parameter LOWPO: is set to "NONE" |  |  | DN
 | READY | The configuration parameter CLIACT: is set to "YES"; the driver is successfully connected to the port and working |  |  | RD
 | DISCONNECTING | The driver is disconnecting from the UDP port |  |  | DG
 | HALTED | Owing to an error the driver is halted |  |  | HL
 | ERR | Software error. Contact Abilis assistance. |  |  | NA

CLI-PCK: | Number of packets sent/received from the SNTP Client
 | 0 - 4.294.967.295

The counter CLI-PCK (INPUT) is incremented every time the Client receives a SNTP response frame to a sent synchronization request, while the counter CLI-PCK (OUTPUT) every time it sends a SNTP synchronization request frame.

CLI-BADPCK: | Number of not valid packets received by the SNTP Client
 | 0 - 4.294.967.295

The counter CLI-BADPCK (INPUT) is incremented every time the SNTP Client receives a response SNTP frame whose content or format is not valid.

CLI-BADSRC: | Number of packets received with a IP address not valid
 | 0 - 4.294.967.295

The counter CLI-BADSRC (INPUT) is increments every time the SNTP Client receives a SNTP response frame with a IP address different from the one of the configured Server (parameter SNTPHOST:).

CLI-TOUT: | Number of times the time out TBW: ran over
 | 0 - 4.294.967.295

The counter CLI-TOUT (INPUT) is incremented every time the Client, after sending a synchronization request, doesn't receive the response within the time interval set in the parameter TBW:.

SUCC-SYNC: | Number of successful synchronizations
 | 0 - 4.294.967.295

The counter SUCC-SYNC (INPUT) is incremented every time a synchronization is successfully completed.

FAIL-SYNC: | Number of failed synchronizations
 | 0 - 4.294.967.295

The counter FAIL-SYNC (INPUT) is incremented every time a synchronization fails. According to the SNTP protocol, a single synchronization request can fail because of several reasons: missing answer from the queried Sever, bad format/bad content of the received synchronization message.

SNMP traps generated for the SNTP ports top

The traps listed below are generated when the "T" option is set in the LOG: parameter.

Trap own code | Trap mnemonic | SNMP variables shown in the trap | Description
35 | cxTrapSntpUnsynchronised | cxSntpDiagServIpAddr, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the SNTP Client doesn't get synchronized for 24 hours.
36 | cxTrapSntpSynchronised | cxSntpDiagServIpAddr, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the SNTP Client leaves the un-synchronized condition, signalled by the cxTrapSntpUnsynchronised trap.

Detail of the SNMP variables shown in the SNTP port traps

cxSntpDiagServIpAddr | IP address of the SNTP Server host
 | (see parameter SNTPHOST:)

This variable shows the IP address of the SNTP Server host to which the SNTP Client process of Abilis CPX sends its synchronization requests.

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


The Simple Network Management Protocol (SNMP) Port

Revised for CPX 4.1.0.
Configuration of the SNMP port
Statistics of the SNMP port

The SNMP port is used in the Abilis CPX unit to implement the homonym TCP/IP network management protocol.

The Simple Network Management Protocol (SNMP) uses the Connection Less transport service provided by the UDP protocol and makes possible the automatic management of some devices by one or more supervisor platforms.

The working principle of the SNMP lies in the exchange of configuration information, statistics, alarms, etc, among suitable devices for network supervision, called SNMP Manager, and processes called SNMP Agent, placed in the devices to be controlled.

The SNMP protocol is like a client/server system: the controlling station (manager) polls, by suitable commands, the server processes (agents), which are the elements to be controlled. They latter answer to the SNMP Manager by back messages.

The protocol also allows the Agent processes to send unsolicited messages, called Traps, to the Manager ones for pointing out particular events such as alarms, exceptions, etc.

An important feature of the SNMP protocol is the MIB (Management Information Base), which contains the description of the configuration/statistics "objects" available in the SNMP Agents and their availability of being controlled by SNMP Managers.

The Abilis CPX SNMP port implements a SNMP Agent process, according to the SNMP Vers.1 (SNMPv1) protocol standard. This makes possible to achieve supervision functions of the Abilis CPX from SNMP Manager made by any producer.

In the implementation, which this manual refers to, the MIBs of the following rules are available:

  • RFC1213: Management Information Base for Network Management of TCP/IP-based internets: MIB-II. (RFC1213-MIB)

  • RFC1354: IP Forwarding Table MIB. (RFC1354-MIB)

  • RFC1612: DNS Resolver MIB Extensions. (DNS-RESOLVER-MIB)

  • RFC1643: Definitions of Managed Objects for the Ethernet-like Interface Types. (EtherLike-MIB)

  • RFC1724: RIP Version 2 MIB Extension. (RIPv2-MIB)

  • RFC1748: IEEE 802.5 MIB using SMIv2. (TOKENRING-MIB)

The Abilis proprietary MIB, ABILIS-CPX-MIB, adds to the above list for a more powerful management of the CPX unit.

Configuration of the SNMP port top

The SNMP Agent port is labelled in the Abilis CPX by the "SNMP" abbreviation and it is provided with the parameters described in the following section.

Here is an example of the SNMP port parameters. All of them are DEFAULT values.

[15:43:20] ABILIS_CPX: D P PO:904

PO:904 - SnmpV1_Agent ---------------------------------------------------------
SNMP   lowpo:902   ACT:YES      locport:161    fifo:5
       COMMUNITY:public
       IPSRC:*                        IPSRCLIST:#
       TRAP:YES    AUTHTRAP:NO        TRAPREP:10
       TRAPDEST:192.168.000.002       TRAPSRC:R-ID (062.110.059.130)

To activate any change made on the lowercase parameters, the system has to be started again, on the contrary for the uppercase parameters it is enough to submit the initialization command INIT PO:.

Details of the SNMP port parameters

lowpo: | Identification of the lower level Abilis CPX port
NONE | 1 - 999, NONE

Sets up the lower level CPX port, it can be only an UDP type port.

If the value is set to "NONE" the SNMP port is isolated.

ACT: | Activation of the SNMP functionalities
NO | NO, YES

It enables the above mentioned functionalities to be actually activated. If the parameter is set to "NO", although the port is configured and active, it won't carry out any function in the system.

locport: | Identification of the local IP port in use
161 | 161

Sets the local IP port to be used by the SNMP one. The number of the IP port reserved for the SNMP process Agent type is 161.

The parameter is only informative and its value cannot be modified.

fifo: | Receiving FIFO size
5 | 1 - 50

Sets the number of available buffers in the receiving FIFO of the SNMP port. If the queue will be full, the SNMP port won't receive anymore and further datagrams will be discarded by the lower UDP port.

COMMUNITY: | Keyword used for the authenticating procedure
public | from 1 to 32 alphanumeric characters

By this parameter it is possible to set the keyword used by the authenticating procedure of those SNMP management systems able to query the SNMP Agent of the Abilis CPX. Only those, which have the same value of the "Community Name" as the local SNMP port, are allowed to supervise.

The authenticating procedure, as expected by SNMPv1 protocol, simply checks if the content of the "Community Name" in the query frames received is the same as the "COMMUNITY:" of the local port.

If it doesn't match, the query frames are rejected and, if the parameter AUTHTRAP: is set to "YES", a wrong authentication message is sent to the system, whose IP is configured in the parameter TRAPDEST:.

IPSRC: | IP address of the permitted SNMP management station
* | see table, *

This parameter makes possible to set the IP address of the SNMP source management from which the SNMP Agent of the Abilis CPX can receive requests.

The allowable values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

At the moment, D and E IP class addresses are not supported.

The character '*', in this case, means 'any IP source address' and it makes every SNMP management system able to query the local agent.

IPSRCLIST: | IP addresses list of the permitted SNMP management stations
# | ListName, #

The parameter makes possible to set a IP addresses list of the SNMP management systems able to query the SNMP Agent of the Abilis CPX.

The shown name of the list must be the same as the one previously defined in the table of the elements lists. The allowed types of lists are: IP addresses (IP); groups of IP addresses (IR); lists of "Rules" (RU); lists of "Master Rules" (MR).

The value '#' is used with the meaning of "no list".

TRAP: | Activating the generation of informative asynchronous signalling
NO | NO, YES

This parameter makes possible to activate the generation, by the SNMP port, of informative asynchronous signaling (called "trap") to the SNMP Manager, whose IP address must be declared in the TRAPDEST: parameter.

The traps generated by the SNMP port are, of course, provided by the SNMPv1 protocol, in addition, another set is defined according to the own MIB of Abilis CPX.

If the parameter is set to "NO", the generation is disabled.

If it is set to "YES", the SNMP port will send informative asynchronous signaling to that system whose IP address is declared in the TRAPDEST: parameter, if and only if this one contains a valid IP address.

AUTHTRAP: | Activating the generation of the wrong authentication signalling
NO | NO, YES

The parameter makes the SNMP port able to generate informative signalling if it receives requests from not authorized SNMP Manager processes.

The authentication of those management systems, which can query the SNMP Agent of the Abilis CPX, is made by comparing the value of the parameter COMMUNITY: against the content of field "Community Name" contained in the query.

If the parameter is set to "NO", the generation of wrong authentication traps is disabled.

If it is set to "YES", the SNMP port will send traps to the system whose IP address is configured in the parameter TRAPDEST: but only if it contains a valid IP address and the parameter TRAP: is set to "YES" too.

TRAPREP: | Time interval between repetitions of the same trap
10 | NO, 1 - 255 ( in minutes)

This parameter sets the time interval which has to pass before sending again the same trap.

Important signals, such as alarms, out of service states, etc. are indeed repeated by the SNMP Agent of the Abilis CPX each "TRAPREP" minutes for all the time they are set. In this way it is possible to avoid such situations where, for any reason, the SNMP Manager devices could not get the trap.

If the value is set to "NO" traps will not be repeated.

TRAPDEST: | IP address of the management station which is recipient for the traps
# | see table, #, ListName

This parameter makes possible to set the IP address, or a list of IP addresses, of the management system to which must be sent the informative asynchronous signalling generated by the SNMP Agent of the Abilis CPX.

If the manager device, where traps have to be sent to, is only one, the available values of IP address are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

D and E class of IP addresses are not, at the moment, supported.

The character '#' is used to not send any trap regardless if the parameter TRAP: is set to "YES".

If it is needed to send traps to more than one manager device, the list of their IP addresses must be set in the parameter. The name of this list must be specified in between apexes and it has to be already declared into the elements list.

The allowed types of lists are: IP addresses (IP); groups of IP addresses (IR).

TRAPSRC: | Source IP address for traps
R-ID | R-ID, OUT-IPP, see table

It allows to define the source IP address to be used for outgoing traps.

The "R-ID" value makes possible to use the Router-ID IP address.

The "OUT-IPP" value makes possible to use the IP address of the IP port used by the outgoing trap.

The specification of an IP address, in Dotted Decimal Notation, is also allowed. The available values of IP address are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

D and E class of IP addresses are not, at the moment, supported.

Statistics of the SNMP port top

Example of how to check the status and the statistics of the SNMP port by the command D S.

[15:43:20] ABILIS_CPX: D S PO:904 .

PO:904 ------------------------------------------------------------------------
SNMP   STATE:READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       PCK        |     23330 |     23415 |GET-REQ    |     23308 |         0 |
       GET-NEXT   |        14 |         0 |SET-REQ    |         0 |         0 |
       GET-RESP   |         0 |     23308 |TRAP       |         0 |        93 |
       ------------------------------------------------------------------------

Extended statistics are even available for the SNMP ports. The following example shows how to check the extended statistics of the SNMP port, by using the command D SE:

[15:43:20] ABILIS_CPX: D SE PO:904 .

PO:904 ------------------------------------------------------------------------
SNMP   --- Cleared 040:21:05:21 ago, on 15/02/2002 at 17:45:00 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       PCK        |     23330 |     23415 |GET-REQ    |     23308 |         0 |
       GET-NEXT   |        14 |         0 |SET-REQ    |         0 |         0 |
       GET-RESP   |         0 |     23308 |TRAP       |         0 |        93 |
       BAD-VER    |         0 |           |BAD-COM-N  |         8 |           |
       BAD-COM-U  |         0 |           |ASN-ERR    |         0 |           |
       TOO-BIG    |         0 |         0 |NO-NAME    |        14 |         0 |
       BAD-VAL    |         0 |         0 |RONLY      |         0 |           |
       GEN_ERR    |         0 |         0 |REQ_VAR    |     93136 |           |
       SET_VAR    |         0 |           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows both the time elapsed since the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution recovered from the current date/time set (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics

STATE: | Actual value of the SNMP port driver
 | INACTIVE, ACTIVE, READY, DISCONNECTING, HALTED

It shows the actual state of the driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
SNMP | INACTIVE | The configuration parameter ACT: is set to "NO", therefore the driver is active, but idle. By setting the value of the parameter to "YES" and executing the command INIT PO:, actually the driver will be operating. |  |  | IN
 | DOWN | The configuration parameter ACT: is set to "YES", but the driver is not connected with the port UDP or the parameter LOWPO: is set to NONE. |  |  | DN
 | READY | The configuration parameter ACT: is set to "YES", the driver is successfully connected with the port UDP and it is able to manage its functions. |  |  | RD
 | DISCONNECTING | The driver is going to be disconnected by the port UDP. |  |  | DG
 | HALTED | Owing to an error the driver is halted |  |  | HL
 | ERR | Software error. Please contact the ABILIS assistance. |  |  | NA
PCK: | Number of sent/received packets
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a SNMP frame is received. Similarly the counter PCK (OUTPUT) every time a SNMP frame is sent.

GET-REQ: | Number of GetRequest frames received
 | 0 - 4.294.967.295

The counter GET-REQ (INPUT) is incremented every time a query frame of GetRequest type is received.

GET-NEXT: | Number of GetNext frames received
 | 0 - 4.294.967.295

The counter GET-NEXT (INPUT) is incremented every time a query frame of GetNext type is received.

SET-REQ: | Number of SetRequest frames received
 | 0 - 4.294.967.295

The counter SET-REQ (INPUT) is incremented every time a query frame of SetRequest type is received.

GET-RESP: | Number of GetResponse frames sent
 | 0 - 4.294.967.295

The counter GET-RESP (OUTPUT) is incremented every time a response frame of GetResponse type is sent.

TRAP: | Number of asynchronous messages (Traps) sent
 | 0 - 4.294.967.295

The counter TRAP (OUTPUT) is incremented every time an informative asynchronous message (Traps) is sent.

Details of the extended statistics fields

PCK: These statistics are the same shown in basic command and already explained
GET-REQ:
GET-NEXT:
SET-REQ:
GET-RESP:
TRAP:

BAD-VER: | Number of messages with a bad Version field
 | 0 - 4.294.967.295

The counter BAD-VER (INPUT) is incremented every time a query frame, whose "Version" field is different from SNMPv1, is received. it is wasted owing to the protocol incompatibility.

BAD-COM-N: | Number of messages with a bad Community Name field
 | 0 - 4.294.967.295

The counter BAD-COM-N (INPUT) is incremented every time a query frame, whose "Community Name" field is different from the one configured in the parameter COMMUNITY:, is received.

BAD-COM-U: | Number of messages with an inadequate "Community Name" field
 | 0 - 4.294.967.295

The counter BAD-COM-U (INPUT) is incremented every time a query frame, whose "Community Name" field is not suitable for the command, is received.

ASN-ERR: | Number of wrongly coded messages received
 | 0 - 4.294.967.295

The SNMP protocol requires the content of the frames to be coded according to the rules fixed by ASN1-BER (Abstract Syntax Notation 1 - Basic Encoding Rules). The counter ASN-ERR (INPUT) is incremented every time the content of the received frame does not match the standard; the frame is deleted.

TOO-BIG: | Number of messages with "TooBig" error code generated
 | 0 - 4.294.967.295

The SNMP protocol expects that, if a frame bigger than 1500 bytes is asked to be generated, the SNMP Agent should reply to this request with a message, whose error code is "TooBig". The counter TOO-BIG (OUTPUT) is incremented every time, the above mentioned message is generated.

NO-NAME: | Number of messages with "NoSuchName" error code generated
 | 0 - 4.294.967.295

The counter NO-NAME (OUTPUT) is incremented every time a response frame, whose error code is "NoSuchName", is generated. Such a code means that the received request asked for a parameter or a configuration variable that is unknown or inaccessible by the SNMP Agent. The SNMP protocol version 1 expects the same error message, instead of using the "ReadOnly" error code, to be generated even if the received frames ask to set the value of a "read only" variable.

BAD-VAL: | Number of messages with "BadValue" error code generated
 | 0 - 4.294.967.295

The counter BAD-VAL (OUTPUT) is incremented every time a response frame, whose error code is "BadValue", is generated. Such code means that the received request asked the Agent to set a parameter or a configuration variable to a not allowed value.

RONLY: | Number of messages with "ReadOnly" error code generated
 | 0 - 4.294.967.295

The counter BAD-VAL (OUTPUT) is incremented every time a response frame, whose error code is "BadValue", is generated. Such code means that the received request asked the Agent to set a parameter or a "read only" configuration variable.

GEN-ERR: | Number of messages with "GenErr" error code generated
 | 0 - 4.294.967.295

The counter GEN-ERR (OUTPUT) is incremented every time a response frame, whose error code is not referable to the already defined ones, is generated.

REQ-VAR: | Number of all the variables which have been asked for their value
 | 0 - 4.294.967.295

The counter REQ-VAR (INPUT) reports the number of all the variables or parameters which the Agent received a "READ" request for (GetRequest o GetNext).

SET-VAR: | Number of all the variables asked to be set
 | 0 - 4.294.967.295

The counter SET-VAR (INPUT) reports the number of all the variables or parameters which the Agent received a "WRITE" request for (SetRequest).


The Traffic Analyzer Port (TRFA)

Configuration of the Traffic Analyzer Port (TRFA)
Statistics of the Traffic Analyzer Port (TRFA)

Http pages for IP traffic analisys (TRFA)

Http pages for IP traffic analisys (TRFA)

The Traffic Analyzer (TRFA) port accumulates and shows a traffic for one or more IP interfaces. It provides the following features:

  • show a common traffic for all interfaces;
  • show a common traffic for each interface;
  • show traffic is separated by IP address
  • show traffic is separated by applications (FTP, TELNET, etc.);
  • show traffic is separated by IP address and an application;
  • show traffic the above in the defined time ranges;
  • show traffic statistics on an internal HTTP server.

Configuration of the Traffic Analyzer Port (TRFA) top

The Traffic Analyzer ports is identified by the mnemonic "TRFA" and it is provided with the parameters described in this section.

Here are examples on how to display the TRFA port parameters. Displayed values are the default ones:

[11:47:16] ABILIS_CPX: D P PO:TRFA

PO:916 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
TRFA   ------------------------------------------------------------------------
       LOG:DS        ACT:NO        max-addresses:100    max-png:5      BAK:YES
       WDIR:C:\APP\TRFA\

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the TRFA port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ACT: | Runtime activation/deactivation of TRFA
NO | NO, YES

This parameter allows to run-time activate/deactive TRFA functionalities.

When it is set to "NO", the port is running but saving traffic information is disabled.

When it is set to "YES", the port is running and the TRFA driver performs its activities, i.e. saving traffic information is enabled.

max-addresses: | Maximum number of pair IPP + IP address in the address table
1000 | 2..65535

This parameter defines the maximum number of pair "IP port,IP address" in the TRFA address table.

The actual size of the internal database, as well as other relevant parameters, must are calculated by the driver using the present parameter, the TRFA-MODE: parameter and the IP-RESERVE: parameter.

max-png: | Maximum number of PNG shell objects
5 | 1..20

This parameter defines the maximum number of PNG shell objects. This objects will be used creating PNG files for TRFA's HTML information page.

warning! If you have a lot of interfaces with active TRFA and TRFA's HTML information page is created too slowly, then increase this value. Each PNG shell object gets about 400K memory.

BAK: | Back-up file creation enable/disable
YES | NO, YES

This parameter activates the creation of a back-up copy of data files.

When it is set to "YES", the before replacing a ".DAT" file the TRFA driver makes a backup copy in a file with ".BAK" extension.

When it is set to "NO", the ".DAT" file is not backed-up.

WDIR: | Directory where traffic data files are stored.
C:\APP\TRFA\ | from 1 up to 128 ASCII extended characters [32..255]

This parameter defines the location of the directory where traffic data files are stored. It cannot be empty. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the backslash ('\'). The maximum accepted working directory string length is 128 characters. Case is preserved and spaces are allowed, but strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\").

Statistics of the Traffic Analyzer Port (TRFA) top

Example on how to show state and statistics of the TRFA port through the command D S:

[11:10:58] ABILIS_CPX: D S PO:TRFA

PO:916 ------------------------------------------------------------------------
TRFA   STATE:ACTIVE    ACTIVE-STATE:NORMAL    BACKUP-STATE:NORMAL    EVENT: 82
       ------------------------------------------------------------------------
       ---ARRAY---|---PERC----|----CUR----|---PEAK----|----MAX----|----OVR----|
       ACTIVE     |          0|          0|          0|        100|          0|
       BACKUP     |          0|          0|          0|        100|          0|
       ------------------------------------------------------------------------
       - Send/Receive statistics ----------------------------------------------
       -----------|---TOTAL---|---SUCC----|---FAIL----|---INACT---|-OVERFLOW--|
       REQUESTS   |         64|         64|          0|          0|          0|
       ------------------------------------------------------------------------

Example on how to show extended statistics of the TRFA port through the command D SE:

[11:11:13] ABILIS_CPX: D SE PO:TRFA

PO:916 ------------------------------------------------------------------------
TRFA   --- Cleared 000:00:00:45 ago, on 25/03/2004 at 17:38:12 ----------------
       -----------|---TOTAL---|---SUCC----|---FAIL----|---INACT---|-OVERFLOW--|
       REQUESTS   |        129|        129|          0|          0|          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the TRFA port (TRFA)

STATE:ACTIVE NORMAL NORMAL EVENT:247
STATE: | Current state of the TRFA port
 | INACTIVE, DOWN, ACTIVE, ERR

It shows the current state of the TRFA port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
TRFA | INACTIVE | The parameter ACT: is set to "NO". |  |  | in
 | DOWN | The parameter ACT: is set to "YES", but TRFA service does not work correctly. |  |  | dn
 | ACTIVE | The parameter ACT: is set to "YES". |  |  | RD
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

ACTIVE-STATE: | Current status of the active address array
 | NORMAL, WARNING, DANGER, OVERFLOW, ERR

It shows the current status of the active address array.

States | Description
NORMAL | Active address array is loaded less than 60%.
WARNING | Active address array is loaded less than 75% but more than 60%.
DANGER | Active address array is loaded less than 100% but more than 75%.
OVERFLOW | Active address array is loaded on 100%.
ERR | Software error. Contact Abilis CPX assistance.

BACKUP-STATE: | Current status of the active traffic array
 | NORMAL, WARNING, DANGER, OVERFLOW, ERR

It shows the current status of the active traffic array.

States | Description
NORMAL | Active traffic array is loaded less than 60%.
WARNING | Active traffic array is loaded less than 75% but more than 60%.
DANGER | Active traffic array is loaded less than 100% but more than 75%.
OVERFLOW | Active traffic array is loaded on 100%.
ERR | Software error. Contact Abilis CPX assistance.

EVENT: | Number of seconds to reach next event
 | 0 - 4.294.967.295

It shows the number of seconds to reach next event.

ARRAY | Address/Traffic array
 | ACTIVE, BACKUP

Identify the array to which the information are pertinent.

PERC | Percentage of use the active address/backup array
 | 0 - 100

It shows the percentage of use the active address/backup array.

CUR | Currently record saved in the active address/backup array
 | 0 - 4.294.967.295

It shows the currently record saved in the active address/backup array.

PEAK | Maximum number of simultaneously record in the active address/backup array
 | 0 - 4.294.967.295

It shows the maximum number of simultaneously record in the active address/backup array.

MAX | Actual size of the active address/backup array
 | 0 - 4.294.967.295

It shows the actual size of the active address/backup array.

OVR | Number of requests that were discarded because active address/backup array is overflow
 | 0 - 4.294.967.295

It shows the number of requests that were discarded because active address/backup array is overflow.

TOTAL | Total number of requests
 | 0 - 4.294.967.295

It shows the total number of received requests.

SUCC | Number of requests that were successfully executed
 | 0 - 4.294.967.295

It shows the number of requests for which the traffic tracing was successfully executed.

FAIL | Number of requests that were not satisfied
 | 0 - 4.294.967.295

It shows the number of requests tfor which the traffic tracing was unsuccessful.

INACT | Number of requests for which the traffic tracing was not activated
 | 0 - 4.294.967.295

It shows the number of requests for which the traffic tracing was not activated.

OVERFLOW | Number of failures due to an address overflow
 | 0 - 4.294.967.295

It shows the number of failures due to an address overflow.


The HyperText Transfer Protocol (HTTP) port

Configuration of the HyperText Transfer Protocol (HTTP) port

Configuration of the HyperText Transfer Protocol (HTTP) port
Statistics of the HyperText Transfer Protocol (HTTP) port

Configuration of HTTP Virtual Root Paths
Configuration of HTTP Virtual Path's Access Rights

Http user manual
<<<<<<< mod_http.htm Http pages for traffic analisys (TRFA)

======= Http pages for IP traffic analisys (TRFA)

>>>>>>> 1.14

The HTTP port is sued by the Abilis CPX to implement the homonymous protocol.

Generally the HyperText Transfer Protocol (HTTP) is an applicative layer protocol and belongs to the TCP/IP family. It transfers hyper textual information and it uses the transport service of Connection Oriented type, provided by the protocol TCP/IP.

...

Configuration of the HyperText Transfer Protocol (HTTP) port top

The HTTP port implements the HyperText Transfer Protocol and it is labelled within the Abilis CPX with the acronym "HTTP". it is provided with the parameters described in this section.

Here is an example on how to display the HTTP port parameters. Shown values are the default ones.

[18:45:45] ABILIS_CPX: D P PO:HTTP

PO:915 ------------------------------------------------------------------------
HTTP   lowpo:901   ACT:NO   locport:80     sesnum:12        COOKIE-TOUT:1440
       IPSRC:*                             IPSRCLIST:#
       WDIR:C:\APP\HTTP\
       START-PAGE:SYS (/sys/cpx.htm)

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialization command INIT PO:.

Details of the parameters of the HTTP port

LOWPO: | Identifier of the lower TCP port
901 | 1 - 999, NONE

It sets the Abilis CPX lower layer port. It can be a TCP port only.

The value "NONE" isolates the HTTP port.

ACT: | Run time activation/deactivation flag
NO | NO, YES

This parameter allows to run-time activate/deativate the HTTP protocol functionalities above mentioned. If the parameter is set to "NO", even if the HTTP port is configured and active, it won't provided any service.

locport: | Identifier of the IP local port used
80 | 80

It sets the IP local port used by the HTTP one. Recommendations reserve the number 80 for the HTTP service.

This is an informative parameter and its value cannot be changed.

sesnum: | Maximum number of HTTP sessions
12 | 0..255

It sets the maximum number of sessions on the HTTP port.

COOKIE-TOUT: | Cookie time-out
1440 | 5..65535 min.

It sets the cookie time-out in minutes.

IPSRC: | IP address of the enabled source
* | see table, *

This parameter configures the IP address of the enabled source of incoming requests.

The allowed values are showed by the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP address of class D and E are not actually supported.

The character '*' means "any IP source address".

IPSRCLIST: | List of the IP addresses of the enabled sources
# | ListName, #

This parameter configures a list of the enabled sources of incoming requests.

A string of maximum 20 characters in the range [0..9, a..z, A..Z, _] is accepted. The configured name must correspond to the name of a list of IP addresses or the name of a list of IP addresses ranges or the name of a Rule list or the name of a Master Rule list. The referenced list must already be defined in the Elements Lists service.

The character '#' means "no list".

WDIR: | Directory where temporary files are saved
C:\APP\HTTP\ | see below

This parameter selects the directory where temporary files are saved. It cannot be empty. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. The maximum accepted working directory string length is 128 characters. Case is preserved and spaces are allowed, but strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\").

START-PAGE: | Start page
SYS (/sys/cpx.htm) | ListName, #

This parameter selects the HTTP start page. The user can select between the "SYS" value, i.e. the default system start page corresponding to the "/sys/cpx.htm", and a specific file, whose name must be specified with the related URL (Uniform Resource Identifier)(E.g.: "/default.htm" or "/root/home.htm" ). The maximum accepted start page string length is 128 characters. Case is preserved and spaces are allowed, but strings holding spaces must be written between quotation marks (E.g.: "/My url/index.htm").

Statistics of the HyperText Transfer Protocol (HTTP) port top

Example on how to show state and statistics of the HTTP port through the command D S:

[18:45:45] ABILIS_CPX: D S PO:HTTP

PO:915 ------------------------------------------------------------------------
HTTP   STATE:READY     MAX-CONN:12
       ------------------------------------------------------------------------
       CH  State       LocAdd-LocPort         RemAdd-RemPort
       ------------------------------------------------------------------------
       0   LISTENING   000.000.000.000-80
       1   LISTENING   000.000.000.000-80
       2   LISTENING   000.000.000.000-80
       3   LISTENING   000.000.000.000-80
       4   LISTENING   000.000.000.000-80
       5   LISTENING   000.000.000.000-80
       6   LISTENING   000.000.000.000-80
       7   LISTENING   000.000.000.000-80
       8   LISTENING   000.000.000.000-80
       9   LISTENING   000.000.000.000-80
       10  LISTENING   000.000.000.000-80
       11  LISTENING   000.000.000.000-80
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|REQ        |          0|           |
       REQ-GET    |          0|           |REQ-POST   |          0|           |
       REQ-PUT    |          0|           |
       ------------------------------------------------------------------------

Example on how to show extended statistics of the HTTP port through the command D SE:

[11:32:37] ABILIS_CPX: D SE PO:HTTP

PO:915 ------------------------------------------------------------------------
HTTP   --- Cleared 000:00:00:00 ago, on 15/03/2004 at 17:46:44 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|REQ        |          0|           |
       REQ-GET    |          0|           |REQ-POST   |          0|           |
       REQ-PUT    |          0|           |
       ------------------------------------------------------------------------
       CH:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|REQ        |          0|           |
       REQ-GET    |          0|           |REQ-POST   |          0|           |
       REQ-PUT    |          0|           |
       ------------------------------------------------------------------------
       CH:1
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|REQ        |          0|           |
       REQ-GET    |          0|           |REQ-POST   |          0|           |
       REQ-PUT    |          0|           |
       ------------------------------------------------------------------------
       CH:2
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|REQ        |          0|           |
       REQ-GET    |          0|           |REQ-POST   |          0|           |
       REQ-PUT    |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the HTTP port

STATE: | Current state of the HTTP port
 | INACTIVE, DOWN, READY, ERR

It shows the current state of the HTTP port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
HTTP | INACTIVE | The run time activation flag ACT: is set to "NO". |  |  | IN
 | DOWN | The run time activation flag ACT: is set to "YES", but Listen(s) to lower TCP port fail. |  |  | DN
 | READY | The run time activation flag ACT: is set to "YES", and HTTP is connected to lower TCP port. |  |  | RD
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

MAX-CONN: | Current maximum number of connections
 | 0..255

It shows the current maximum number of HTTP connections.

CHR | Number of characters sent/received by the port
 | 0 - 4.294.967.295

The counter CHR (INPUT) is incremented every time data are received by the port. The counter CHR (OUTPUT) is incremented every time data are sent by the port.

REQ | Number of requests received by the port
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a requests is received by the port.

REQ-GET | Number of GET requests received by the port
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a GET requests is received by the port.

REQ-POST | Number of GET requests received by the port
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a POST requests is received by the port.

REQ-PUT | Number of GET requests received by the port
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a PUT requests is received by the port.

Details of the state fields and statistics of the HTTP connections

CH | Connection identifier
 | 0..255

It is the connection identifier.

State | Connection state
 | CLOSED, LISTENING, CALLED, CALLING, CONNECTED, READY, CLEARING, CLEARED, DESTRUCTING, DOWN, READY, ERR

It shows tha current state of the HTTP connection.

LocAdd-LocPort | Local IP address and Local port
 | 000.000.000.000..255.255.255.255 - 1..65535

It show the local IP address, in Dotted Decimal Notation, and the local TCP/IP port.

RemAdd-RemPort | Remote IP address and Remote port
 | 000.000.000.000..255.255.255.255 - 1..65535

It show the remote IP address, in Dotted Decimal Notation, and the remote TCP/IP port.

CHR | Number of characters sent/received by the single connection
 | 0 - 4.294.967.295

The counter CHR (INPUT) is incremented every time data are received by the single connection. The counter CHR (OUTPUT) is incremented every time data are sent by the single connection.

REQ | Number of requests received by the single connection
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a requests is received by the single connection.

REQ-GET | Number of GET requests received by the single connection
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a GET requests is received by the single connection.

REQ-POST | Number of GET requests received by the single connection
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a POST requests is received by the single connection.

REQ-PUT | Number of GET requests received by the single connection
 | 0 - 4.294.967.295

The counter REQ (INPUT) is incremented every time a PUT requests is received by the single connection.


The File Transfer Protocol (FTP) port

Terminology
Summary of supported features
FTP server port configuration
FTP server virtual root paths table
Common user authentication service
FTP server virtual paths access control
FTP server port statistics
FTP server port debug information
Long file names

The following list gives general design goals for File Transfer Protocol (FTP) port of Abilis CPX:

  • to promote sharing of files (computer programs and/or data).
  • to encourage indirect or implicit (via programs) use of remote computers.
  • to shield a user from variations in file storage systems among hosts.
  • to transfer data reliably and efficiently.

FTP, though usable directly by a user at a terminal, is designed mainly for use by programs.

Terminology top

Control connection
A TCP connection between Server and Client for the exchange of command and replies. It is always open during the FTP session, one can say it IS the FTP session.
Data connection
A TCP connection between Server and Client (or two Servers) for the purpose of data transfer, which can be a file listing, file, or a part of file. Modes allowing transferring several files upon one data connection are not supported.
Data type
  • ASCII - intended primarily for the transfer of text files. Data are in the standard 8-bit NVT-ASCII representation, with <CR><LF> specifying the end-of-line sequence.
  • EBCDIC - intended efficient transfer between hosts which use EBCDIC for their internal character representation. Not supported by CPX FTP.
  • IMAGE - also referred as Binary. The data is sent as contiguous bits packed into 8-bit bytes, and stored the same way. If both systems have 8-bit bytes (as it is practically always), this means transferring data without any changes.
  • LOCAL - intended for transfer between systems having identical but non-standard byte size. Not supported by CPX FTP.
Data structure
  • FILE - no internal file structuring is present.
  • RECORD - file is made of sequential records. Not supported by CPX FTP.
  • PAGE - file is made up of independent indexed pages. Not supported by CPX FTP
Transmission mode
  • STREAM - Data is transmitted as a stream of bytes. EOF is indicated by closing the data connection.
  • BLOCK - File is transmitted as a series of data blocks preceded by one or more header bytes. Not supported by CPX FTP.
  • COMPRESSED - Data is sent compressed by a RLE-like algorithm. Not supported by CPX FTP.
Active mode
Data connection is opened by FTP Server to Client, using either default port value or value explicitly specified by client (using the PORT command)
Passive mode
Data connection is opened by FTP Client to Server, using port value returned by server in reply to PASV command
User
A person or a process on behalf of a person wishing to obtain file transfer service. The human user may interact directly with a server-FTP process, but use of a user-FTP process is preferred since the protocol design is weighted towards automata.

Summary of supported features top

  • Active and passive data connections
  • ASCII and BINARY data types only
  • No file structuring
  • Stream mode only
  • Restarting data transfer
  • FTP-over-SSL operation (not yet implemented)
  • Supported commands (in the order listed by RFC 959): USER/PASS, CWD/CDUP, REIN, QUIT, PORT, PASV, TYPE, RETR, STOR/STOU, APPE, RNFR/RNTO, ABOR, DELE, MKD/RMD, PWD, LIST, SYST, STAT, HELP, NOOP
  • Unsupported commands:
    ACCT (no accounting system available on CPX)
    SMNT (no mountable file systems)
    ALLO (no disk space preallocation available)
    SITE (no CPX-specific options yet defined)

FTP server port configuration top

The FTP-server port is labeled within the Abilis CPX with the acronym "FTP" and it is provided with the parameters described in this section.

Here is an example on how to show the FTP-server port parameters. Shown values are the default ones (command "d p po:ftp"):

[15:02:45] ABILIS_CPX:d p po:ftp
PO:914 ------------------------------------------------------------------------
FTP    LOG:NO        lowpo:901     ACT:YES          max-cli:4
       c-port:21     d-port:20     c-sslport:990    d-sslport:989
       IPSRC:*                     IPSRCLIST:#
       SEND-TOUT:30      DT:300    REJ-1024:YES     SAME-IP:YES  SYSDRIVES:NO
       MAX-PWD-FAIL:4              DELAY-PWD-FAIL:5
       MAX-IP-SES:NOMAX            MAX-USER-SES:2
       ANONYMOUS-USER:DENY         REGISTERED-USER:PERMIT

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialization command INIT PO:.

You can get on-line help about the FTP server parameters by executing command: "s p po:ftp ?"

[16:40:31] ABILIS_CPX:s p po:ftp ?

FTP port parameters:

LOG:       State changes log and alarm generation [NO, D, S, A, L, T, ALL] [+E]
           (D: Debug Log; S: System Log; A: Alarm view; L: Local audible alarm;
           T: SNMP traps; +E: Extended Log of state changes, see ref. manual)
LOWPO:     Lower CPX port [0..999, NONE]
ACT:       Operation activation [NO, YES]
MAX-CLI:   Number of FTP clients [1-255]
C-PORT:    TCP port for incoming control connections [21]
D-PORT:    TCP port for outgoing data connections [20]
C-SSLPORT: TCP port for incoming SSL control connections [990]
D-SSLPORT: TCP port for outgoing SSL data connections [20]
IPSRC:     Incoming requests: accepted source IP address
           [*, 1-126.x.x.x, 128-223.x.x.x]
IPSRCLIST: Incoming requests: name of the IP/IR/RU/MR list for source IP
           address acceptance [#, 0..9, a..z, A..Z, _]
SEND-TOUT: Send time-out [30..3600 sec.]
DT:        Inactivity time-out [30..3600 sec.]
REJ-1024:  Refuse active data connections to client's ports lower then 1024
           [NO, YES]
SAME-IP:   Limit data commection to the same IP of the control connection
           [NO, YES]
SYSDRIVES: Allow creating a /sysdrive/ virtual directory with <drive> subdirs
           [NO, YES]
MAX-PWD-FAIL:    Maximum number of password attempts [1-255]
DELAY-PWD-FAIL:  Delay after failed PASS command [1-255 sec.]
MAX-IP-SES:      Limits number of simultaneous CONTROL connections that can be
                 established from a client's IP address [NOMAX, 1..255]
MAX-USER-SES:    Limits number of simultaneous CONTROL connections that a user
                 can establish from the SAME IP with the SAME USER login
                 [NOMAX, 1..255]
ANONYMOUS-USER:  Permit/deny anonymous log-in [DENY, PERMIT]
REGISTERED-USER: Permit/deny log-in of registered users [DENY, PERMIT]

Datails of FTP server port configuration parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Lower CPX port number
NONE | NONE, 1 - 999

Lower CPX port number.

Only TCP ports are accepted..

The device management procedures COULD use this value for recursions, for example to perform a parameter check for a full drivers stack, always starting from the TOP.

ACT: | Runtime activation/deactivation of the FTP server port.
NO | NO, YES

NO: The port is configured, active, but it does not accept connections. The driver is not listening.
When changing from YES to NO the FTP-server cancels all the pending listens.

YES: The port is configured, active, and it accepts connections. It is listening. When changing from NO to YES the FTP server begins to listen.

max-cli: | Number of FTP clients that the module can support at once.
4 | 1 - 255

Control connections exceeding this value will be rejected. Note that for every client TWO tcp sessions are needed. This value cannot be changed without CPX restart.

c-port: | FTP control connection TCP port.
21 | 21

Specifies TCP port on which FTP waits for incoming connections. It is the "well known" port 21, which is currently not changeable.

d-port: | FTP data connection TCP port.
20 | 20

Specifies TCP port on which FTP makes outgoing data connections. It is the "well known" port 20, which is currently not changeable

c-sslport: | FTP control SSL connection TCP port.
990 | 990

Specifies TCP port on which FTP waits for incoming SSL connections. It is the "well known" port 990, which is currently not changeable.

Now it is not supported.

d-sslport: | FTP data connection TCP port.
989 | 989

Specifies TCP port on which FTP makes outgoing SSL data connections. It is the "well known" port 989, which is currently not changeable.

Now it is not supported.

IPSRC: | Allowed client's IP address.
* | *, DDN see table below

Specifies which client's IP address is allowed to access FTP server.

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | * | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

The default value is *, means "any ip", so that every client IP is allowed.
In the case that one needs to restrict the access, he has to set in IPSRC the ip address of a client which must always have access, e.g. the IP address of the administrator console, and add further IPs using IPSRCLIST.

This method guarantee that even in case of misconfiguration in the list referenced by IPSRCLIST, at least one client, e.g. the one of the system administrator, still have access to FTP server.

IPSRCLIST: | List of additional allowed client's IP addresses
# | list name (0..9, a..z, A..Z), #

Specifies additional client's IP address allowed to access FTP server. Default value is #, means "no list used", in which case the FTP server driver will not query the list service.

The shown name of the list must be the same as the one previously defined in the table of the elements lists. The allowed types of lists are: IP addresses (IP); groups of IP addresses (IR); lists of "Rules" (RU); lists of "Master Rules" (MR).

The value '#' is used with the meaning of "no list".

If IPSRC equal to *, the driver skips the query to the list service since "any IP" is already accepted through IPSRC.

SEND-TOUT: | Send timeout for control and data connections.
30 | 30-3600

Specifies sending inactivity timeout for control and data connections. Upon timeout, a connection will be forced to close: if file transfer is in progress, then data connection is to be closed, else control connection is closed and session terminates.

DT: | Inactivity timeout for the session.
300 | 30-3600

Specifies inactivity timeout for control and data connections. Traffic on either control or data connection resets the timer.
The timeout is restarted, i.e. reset, at every in/out transfer on either of the two sessions (control and data). It means that timeout expires when BOTH sessions exceeded the inactivity time.

Upon timeout control connection will be forcedly closed, as well as data connection if opened.

REJ-1024: | Limitation of the data connections to client's ports lower than 1024.
YES | NO, YES

Refuse active data connections to client's ports lower than 1024 (client source port specified in PORT command < 1024). If this parameter is set, data ports lower than 1024 will not be accepted, protecting from a "Bounce Attack".

MAX-PWD-FAIL: | Maximal number of password attempts.
4 | 1-255

Specifies maximal number of password attempts, after which a session will be disconnected, to lower the efficiency of possible brute-force attack

DELAY-PWD-FAIL: | Delay after failed PASS command.
5 | 1-255

Delay appears after each failed PASS command, to lower the efficiency of possible brute-force attack

SAME-IP: | Limitation of establishment of DATA connection to the same IP of the CONTROL connection
YES | NO, YES

If this parameter is set, the FTP server allows to establish a DATA connection only to an IP address identical to that of the CONTROL connection. This enforces the protections when there is not need to establish the data connection to a third machine, which is the most common use we will make of the FTP server.

Valid for both active and passive modes.

SYSDRIVES: | Allow creating a /sysdrive/ virtual root path with <drive> subdirs.
NO | NO, YES

If this parameter is set, additional virtual root path "/sysdrive/" is created, having all system drives as its subdirectories.

MAX-IP-SES: | Limits number of simultaneous CONTROL connections that can be established from a client's IP address.
NOMAX | NOMAX, 1 - 255

This parameter defines how many CONTROL connections can be established from the SAME IP address. If this parameter is set to NOMAX, number of CONTROL connections is not limited by this restriction and displayed/configured as NOMAX

MAX-USER-SES: | Limits number of simultaneous CONTROL connections that a user can establish from the SAME IP with the SAME USER login
2 | NOMAX, 1 - 255

This parameter defines how many CONTROL connections can be established with the SAME USER-id from the SAME IP address. If this parameter is set to NOMAX, number of CONTROL connections is not limited by this restriction and displayed/configured as NOMAX.

ANONYMOUS-USER: | Permit/deny anonymous log-in
DENY | DENY, PERMIT

Enables/Disables the acceptance of anonymous log-in

REGISTERED-USER: | Permit/deny log-in of registered users (not anonymous).
PERMIT | DENY, PERMIT

Enables/Disables the acceptance of registered users log-in.

FTP server virtual root paths table top

The Virtual root paths table allows to store up to 64 records.

Virtual paths can be individually added/set/displayed/cleared with the command:

A/S/D/C FTP PATH:<virtual path> [PHYS-PATH:<physical path>]

The whole table can be shown with the "d ftp path" command:

An example of the output is shown below

[10:01:53] ABILIS_CPX:d ftp path

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

Virtual root path table record structure

PATH: | Virtual root path
empty | up to 32 characters (see also long file names)

Specifies virtual root path for a directory on disk, in UNIX notation starting and ending with a slash ("/").
Virtual path "/" cannot be accepted because "/" does never refer to physical path, it is only the "container" of virtual paths.

E.g. "/Common/" or "/usr/"

PHYS-PATH: | Physical path.
empty | up to 128 characters (see also long file names)

Specifies real path on disks of a directory, in DOS notation starting with a drive letter and ending with a backslash ("\"). E.g. C:\, A:\, C:\USR\TEST\.

By default the root path table contains the following entries:

Virtual root path | Real path
/usr/ | c:\usr\
/usr2/ | d:\usr\
/pub/ | c:\usr\pub\
/pub2/ | d:\usr\pub\

The use of c:\usr is defined in the documents describing the boot manager which has security reasons as well as system integrity. The directory d:\usr will be used in the same way.

Again for system integrity the FTP server applies the following restrictions:

  • do not allow operations, for any user, in the C:\ directory different from listing and file retrieval. The whole system integrity may be compromised by writing in the C:\ directory
  • virtual root paths without access rights defined has a default "DENY ALL"
  • virtual root path /sysdrives/, created with SYSDRIVES set to YES, and if access rights are not explicitly defined for it, has a default "DENY ALL".

Moreover:

  • If the virtual root path references a disk directory which is not present, the virtual path will not appear in the listing to the user.
  • The table is kept sorted by PATH.
  • Virtual path "/" cannot be specified because "/" does never refer to physical path, it is only the "container" of virtual root paths.

Also you can show specified record by using "d ftp path:<virtual path>"command:

An example of the output is shown below

[19:52:40] ABILIS_CPX:d ftp path:/leo-private/

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /leo-private/
PHYS-PATH:    c:\usr\leo\leo-private\
------------------------------------------------------------------------------

User authentication service top

The service of user authentication is provided through a centralized "archive" where users are defined as well as the services to which they have access and some service-related parameters.

The centralized "User service" provides the authentication for the following services:

  • PPP
  • FTP
  • HTTP
  • CP

The RAS table that was present up to version 4.3.x has been replaces by the USER service, available through the Commands relating to Users Access Control table". Issuing any of the obsolete RAS command will produce the following warning message:

RAS SERVICE IS DEPRECATED. USE USERs ACCESS CONTROL SERVICE

The User service has a user "admin" that cannot be deleted. This user can be enabled only with a "non empty" password.

For the FTP service the HOMEDIR parameter will be managed exactly as required by FTP:

The syntax of the commands is:

a/c/s user:<user> [optional parameters]
d user[:<user>|a]
d usere[:<user>|a]

Display USERs table summary: "d user"

[15:45:19] ABILIS_CPX:d user

USER:                             PASSWORD:  ENABLED: PPP: FTP: HTTP: CP:
-------------------------------------------------------------------------------
Leo                                          YES      YES  YES  YES   YES
Konstantin                        *********  YES      NO   YES  YES   NO

Display a selected entry of the USERs table: "d user:<user>"

[15:45:19] ABILIS_CPX:d user:Leo

Parameter    |Value
-------------------------------------------------------------------------------
USER:         Leo
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     chap
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:
FTP-PROT:     PLAIN
HTTP:         YES
CP:           YES
CP-LEVEL:     USER

Display all entries of the USERs table: "d user:a"

[15:45:19] ABILIS_CPX:d user:a
Parameter    |Value
-------------------------------------------------------------------------------
USER:         Leo
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     chap
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:
FTP-PROT:     PLAIN
HTTP:         YES
CP:           YES
CP-LEVEL:     USER
-------------------------------------------------------------------------------
USER:         Konstantin
PASSWORD:     *********
ENABLED:      YES
FTP:          YES
FTP-HOMEDIR:  /user/konstt/
FTP-PROT:     PLAIN,SSL
HTTP:         YES
-------------------------------------------------------------------------------

If section (PPP/FTP/HTTP/CP) is disabled (set to NO) it is not displayed.

The "extended" version of the command will display also the sections set to NO.
The extended command is "d usere:<user> | all"

[15:45:19] ABILIS_CPX:d usere:Konstantin

Parameter    |Value
-------------------------------------------------------------------------------
USER:         Konstantin
PASSWORD:     *********
ENABLED:      YES
PPP:          NO
PPP-AUTH:     chap
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:  /user/konstt/
FTP-PROT:     PLAIN,SSL
HTTP:         YES
CP:           NO
CP-LEVEL:     USER
-------------------------------------------------------------------------------

Common user information

USER: | User name.
empty | up to 32 of '0'-'9', 'A'-'Z', 'a'-'z', '_', ':' characters

User name. The strings 'A' and 'ALL' are reserved for the system and cannot be used for user name value.

PASSWORD: | User password.
empty | up to 32 of '0'-'9', 'A'-'Z', 'a'-'z', '_', ':' characters

User password.

ENABLED: | User enable/disable flag..
YES | NO, YES

User enable/disable flag.

FTP specific user information

FTP: | FTP service enable/disable flag
NO | NO, YES

FTP service enable/disable flag. If it is set to NO (disabled) it is not displayed.

FTP-HOMEDIR: | Starting virtual path (home) for the user
empty | up to 128 characters (see also long file names)

Specifies home virtual path for a user. i.e. /user/konstt/ or /system/admin/.

When the user logs-in the FTP server will put the user in this virtual path, which becomes the current path.
This is not a "root" path for the user, so if user issues PWD command he will get that current path is "HOMEDIR", and not "/"
If HOMEDIR is empty the FTP driver must assume HOMEDIR=/.

If FTP flag is set to NO (disabled) FTP-HOMEDIR is not displayed.

FTP-PROT: | The user is accepted only if he is using one of the protocols specified here.
PLAIN and SSL | PLAIN or/and SSL

FTP server can be accessed using the PLAIN unchyphered protocol or using SSL encryption. With this parameter it is possible to limit the acceptance of the user to a specific protocol.

If FTP flag is set to NO (disabled) FTP-PROT is not displayed.

FTP server virtual paths access control table top

After a user is authenticated the next requirement is to gain/deny access to portions of the ftp site, this is obtained through some access control system. it is complication can very a lot, depending on specific requirements and on the underlying operating system and file system.

For controlling access to FTP (and other) resources CPX has a control system based on:

  • User authenticated (see user authentication service)
  • Virtual path (see virtual root paths table)
  • Users and rights for that virtual path
  • By default a right is denied

It is realized as "common service". The "access control service" has by default some authorizations, but they can be changed/removed by the user:

PATH | USER | FILE | DIR | RECUR | PROT
/pub/ | anonymous | r--- | l--- | yes | plain,ssl
/pub2/ | anonymous | r--- | l--- | yes | plain,ssl
/sysdrives/ | admin | rwdn | lcdn | yes | plain,ssl
/usr/ | admin | rwdn | lcdn | yes | plain,ssl
/usr2/ | admin | rwdn | lcdn | yes | plain,ssl

Access rights for a specific virtual path can be individually added/set/displayed/cleared with the commands described in this section.

The rights are split in "file rights" and "directory rights" and are configured/viewed with two different parameters: FILE : and DIR :.

The value of these parameters are configurable in a way comparable to the CX32_LOG parameter, that is each right correspond to a character and a "+" or "-" sign is used to specify respectively "granted" or "denied". The syntax is:

   FILE:[+|-R][+|-W][+|-D][+|-N]     DIR:[+|-L][+|-C][+|-D][+|-N]

  • The "+" sets granted right.
  • The "-" sets denied right.
  • If + or - is not specified, the value "+" is assumed, so it may be omitted.
  • Not specified right is left unchanged
  • The FILE: and DIR: values do not care of the characters' position
  • The FILE: and DIR: values are case insensitive

As a result the commands variants below are equivalent:

S FTP RIGHTS PATH:/ USER:test FILE:+R+W+D+N
S FTP RIGHTS PATH:/ USER:test FILE:rwdn
S FTP RIGHTS PATH:/ USER:test FILE:NdwR

S FTP RIGHTS PATH:/ USER:test FILE:+D-N
S FTP RIGHTS PATH:/ USER:test FILE:D-N
S FTP RIGHTS PATH:/ USER:test FILE:-ND

Add path, add path and a user, add user to an existing path

Add the path only.

a ftp rights path:<virtual path>  |  id:<id>

Add path and user: the path does not exist yet
If this is too much complicated we can avoid this add "path and user" case.
a ftp rights path:<virtual path>|id:<id> [user:<user> file:<file rights> dir:<dir rights> recur:yes|no mode:plain,ssl]

Add user: the path already exists.

a ftp rights path:<virtual path>|id:<id> [user:<user> file:<file rights> dir:<dir rights> recur:yes|no mode:plain,ssl]

Set rights and the other parameters for an already existent user.

a ftp rights path:<virtual path>|id:<id> user:<user>[file:<file rights> dir:<dir rights> recur:yes|no mode:plain,ssl]

Delete an existing user. If the user is the last one the path is not deleted.

c ftp rights path:<virtual path> | id:<id> user:<user>

Display paths and users.

Display rights summary

d ftp rights

An example of the output is shown below

[09:56:29] ABILIS_CPX:d ftp rights

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

Display rights for a specific path

d ftp rights path:<virtual path> | id:<id>

An example of the output is shown below

[19:52:40] ABILIS_CPX:d ftp rights path:/usr/pub (or id:1)

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /usr/pub/
       anonymous                        r---  l---  YES    PLAIN
------------------------------------------------------------------------------

Display rights that a user has on all paths. The paths for which the user is not defined are skipped.

d ftp rights user:<user>

An example of the output is shown below

[19:52:40] ABILIS_CPX:d ftp rights user:leo

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
 10 /usr/leo/
       leo                              rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
 50 /usr/konstantin/
       leo                              ----  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
 51 /usr/konstantin/123/
       leo                              ----  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

Virtual paths access control table record structure.

ID: | ID assigned to this entry and referenced by the user rights table records.
0 | 0, 1-128

Specifies the ID of the virtual path for which this user right apply

PATH: | Virtual path for which one or more user rights are specified in the user rights table
empty | up to 128 characters (see also long file names)

Specifies the Virtual Path for which one or more user rights are specified in the user rights table, e.g. "/Common/" or "/usr/konstt/".

USER: | User to which the rights belongs.
empty | up to 32 of '0'-'9', 'A'-'Z', 'a'-'z', '_', ':' characters

Specifies the user for whom rights are specified.

See also user authentication service.

FILE: | Access to the file operations
r--- | see table

Specifies rights that are granted to the USER for file operations for virtual PATH.

DIR: | Access to the directory operations
l--- | see table

Specifies rights that are granted to the USER for the directory operations for virtual PATH.

RECUR: | This user's right is propagated to all the subdirectories, until one is found with "explicit" rights
YES | YES, NO

Specifies whether this right has to be extended to all the subdirectories, until one is found with an explicit rights definition

PROT: | Validity of this right can be made valid/invalid for a specific connection protocol.
PLAIN and SSL | PLAIN or/and SSL

Specifies for which connection modes (PLAIN, SSL or both) this record is applicable.

The description of FILE: and DIR: parameters values

FILE: |  |  |  | DIR:
R | W | D | N | L | C | D | N
Read | Write | Delete | Rename | List | Create | Delete | Rename

FTP server port statistics top

At these snapshots you can see CPX screens with statistics of FTP-server port after executing command D S: "d s po:ftp"

-without active FTP-connections:
[15:38:27] ABILIS_CPX:d s po:ftp

PO:967 ------------------------------------------------------------------------
FTP    STATE:ACTIVE            MAX-CLI:4
       -- Clients --------|--TOT CUR---|--TOT PEAK--|--SSL CUR---|--SSL PEAK--|
       CONNECTED          |           0|           0|           0|           0|
       LOGGED             |           0|            |           0|            |
       DATA-SESSION       |           0|           0|           0|           0|
       ------------------------------------------------------------------------
       -- Sessions states -----------------------------------------------------
       SES C-STATE C-REM                 C-LOC                 USER
           D-STATE D-REM                 D-LOC
       ------------------------------------------------------------------------
                             *** NO FTP SESSIONs ***
       -- Ports statistics ----------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CTRL-CHR   |          0|          0|CTRL-PCK   |          0|          0|
       DATA-CHR   |          0|          0|DATA-PCK   |          0|          0|
       COMMAND    |          0|           |REPLY      |           |          0|
       ------------------------------------------------------------------------
-with two active FTP-connections:
[15:58:20] ABILIS_CPX:d s po:ftp

PO:967 ------------------------------------------------------------------------
FTP    STATE:ACTIVE            MAX-CLI:4
       -- Clients --------|--TOT CUR---|--TOT PEAK--|--SSL CUR---|--SSL PEAK--|
       CONNECTED          |           2|           2|           0|           0|
       LOGGED             |           2|            |           0|            |
       DATA-SESSION       |           0|           0|           0|           0|
       ------------------------------------------------------------------------
       -- Sessions states -----------------------------------------------------
       SES C-STATE C-REM                 C-LOC                 USER
           D-STATE D-REM                 D-LOC
       ------------------------------------------------------------------------
         1 LOGGED  192.168.006.004:1066  192.168.006.010:21    admin
           READY   000.000.000.000:0     000.000.000.000:0
         2 LOGGED  192.168.006.005:1614  192.168.006.010:21    admin
           READY   000.000.000.000:0     000.000.000.000:0
       -- Ports statistics ----------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CTRL-CHR   |        241|        870|CTRL-PCK   |         22|         27|
       DATA-CHR   |          0|        187|DATA-PCK   |          0|          3|
       COMMAND    |         22|           |REPLY      |           |         27|
       ------------------------------------------------------------------------

At this snapshot you can see CPX screen with statistics of FTP-server port after executing command D SE: "d se po:ftp".

[11:16:07] ABILIS_CPX:d se po:ftp

PO:967 ------------------------------------------------------------------------
FTP    --- Cleared 000:00:04:38 ago, on 30/12/2002 at 11:12:46 ----------------
       SES C-STATE C-REM                 C-LOC                 USER
           D-STATE D-REM                 D-LOC
       ------------------------------------------------------------------------
         4 LOGGED  192.168.000.002:1201  192.168.000.060:21    anonymous
           READY   000.000.000.000:0     000.000.000.000:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CTRL-CHR   |         90|        271|CTRL-PCK   |          7|          8|
       DATA-CHR   |          0|          0|DATA-PCK   |          0|          0|
       COMMAND    |          7|           |REPLY      |           |          8|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

FTP server port statistics fields detailed

STATE: | FTP-server port state
 | see table below

Possible states of the FTP server port.

State | Description
INIT | FTP server port is in the init state
INACTIVE | FTP server port is "ready" to work, but the ACT: parameter is set to "NO"
ACTIVE | FTP server port is fully ready to work

MAX-CLI: | Number of FTP client that FTP server can serve
 | 1-255

It showns how many client can be served simultaneously, for each of them the FTP server has reserved one session for COMMANDs and one for DATA. This counter does not make distinction between "plain" and "ssl" sessions.

It is equal to max-cli parameter.

Clients' statistics.

CONNECTED: | Number of FTP control sessions which are connected
 | 0 - 255

CONNECTED TOT CUR shows the number of FTP control session which are currently connected, including those not logged-in. This counter does not make distinction between "plain" and "ssl" sessions. It also correspond to the number of clients currently connected.
CONNECTED TOT PEAK shows the peak value of FTP control sessions that went connected at the same time, including those not logged-in. This counter is actually the maximum value ever reached by "CONNECTED TOT CUR".
CONNECTED SSL CUR shows number of SSL FTP control sessions which are connected.
As for "CONNECTED TOT CUR" but limited to SSL sessions.
CONNECTED SSL PEAK shows maximum number of SSL FTP control sessions that went connected simultaneously.
As for "CONNECTED TOT PEAK" but limited to SSL sessions.

LOGGED: | Number of FTP control sessions which are connected and logged-in
 | 0 - 255

LOGGED TOT CUR shows the number of FTP control sessions which are currently connected and for which already successfully executed the log-in. This counter does not make distinction between "plain" and "ssl" sessions. It also correspond to the number of clients currently connected and logged-in.
LOGGED SSL CUR shows number of SSL FTP control sessions which are connected and logged-in.
As for "LOGGED TOT CUR" but limited to SSL sessions.

DATA-SESSION: | Number of FTP data sessions which are currently established
 | 0 - 255

DATA-SESSION TOT CUR shows the number of FTP data sessions which are currently established and on which the data transfer is proceeding or going to start. This counter does not make distinction between "plain" and "ssl" sessions.
It also correspond to the number of clients currently sending or receiving with the FTP server.
DATA-SESSION TOT PEAK shows maximum number of FTP-DATA sessions that were established simultaneously.
It shows the peak value of FTP data sessions that were established at the same time. This counter is actually the maximum value ever reached by "DATA-SESSION TOT CUR".
DATA-SESSION SSL CUR shows the number of SSL FTP data sessions which are currently established.
As for "DATA-SESSION TOT CUR" but limited to SSL sessions.
DATA-SESSION SSL PEAK shows maximum number of SSL FTP data sessions that were established simultaneously.
As for "DATA-SESSION SSL PEAK" but limited to SSL sessions.

Sessions states

SESS: | Identifier of FTP session
 | 1 - 255

Unique identifier of established FTP session.

C-STATE: | State of FTP server control connection
 | see table below

Possible states of the FTP server port control connection:

State | Description
STOPPED | FTP session is stopped. ACT parameter is set to "NO".
READY | FTP session is ready to work.
CONN | FTP session is in connection state and waits USER command (user name)
WAITPWD | FTP session waits PASS command (password)
LOGGED | FTP user is logged in state and fully ready to work

C-REM: | IP address and TCP port on the remote FTP client
 | see table

IP address and TCP port of the control connection on the remote FTP client.

C-LOC: | IP address and TCP port of the control connection on the local FTP server
 | see table

IP address and TCP port of the control connection on the local FTP server.
Ftp server may have been reached with any of the IP addresses of the CPX. The value of TCP port is c-port, currently fixed to the standard value 21.

D-STATE: | State of FTP server data connection
 | see table below

Possible states of the FTP server port data connection:

State | Description
READY | Data connection is free and ready to work.
LIST | Data connection sends list of the directory (full format). LIST command processing.
NLIST | Data connection sends list of the directory (short format). NLST command processing.
STOR | Data connection receives file from FTP client. STOR command processing.
STOU | Data connection receives file from FTP client and stores it to the unique file on the server. STOU command processing.
APPE | Data connection receives file from FTP client and appends it to the existent file on the server. APPE command processing.
RETR | Data connection sends file to the client. RETR command processing.
PASVL | Data listens TCP port to establish of passive TCP connection from remote side. PASV command processing

D-REM: | IP address and TCP port on the remote FTP client, or on another FTP server
 | see table

IP address and TCP port of the data connection on the remote FTP client, or on another FTP server.

It is equal to 0.0.0.0:0 if data connection is in READY state (if data connection not established).

D-LOC: | IP address of the data connection on the local FTP server
 | see table

IP address of the data connection on the local FTP server.

Ftp server "data" may have been opened in PASV mode with any of the IP addresses of the CPX, or the FTP server may have called the client from any of the router's addresses.
Usually data connections are accepted/opened with a local IP address equal to that FTP-client established the control connection.

It is equal to 0.0.0.0:0 if data connection is in READY state (if data connection not established).

USER: | User name of the established FTP client
 | up to 32 characters, ftp, anonymous

User name of the established FTP client. Can be "anonymous" or "ftp" if anonymous clients are allowed. (ANONYMOUS-USER parameter is set to PERMIT), e.g. "konstantin", "leo", "ftp".

See also user authentication service.

Ports statistics

CTRL-CHR: | Number of received/sent characters by FTP control session(s)
 | 0 - 4294967295

Total number of characters received (INPUT) or sent (OUTPUT) by FTP control session(s).

DATA-CHR: | Number of received/sent characters by FTP data session(s)
 | 0 - 4294967295

Total number of characters received (INPUT) or sent (OUTPUT) by FTP data session(s).

CTRL-PCK: | Number of received/sent packets by FTP control session
 | 0 - 4294967295

Total number of packets received (INPUT) or sent (OUTPUT) by FTP control session(s).

DATA-PCK: | Number of received/sent packets by FTP data session
 | 0 - 4294967295

Total number of packets received (INPUT) or sent (OUTPUT) by FTP data session(s).

COMMAND: | Number of valid FTP commands which were received by FTP control session(s)
 | 0 - 4294967295

Total number of valid FTP commands which were received by FTP control session(s) from the FTP client(s).

REPLY: | Number of FTP replies which were by FTP control session(s)
 | 0 - 4294967295

Total number of FTP replies which were sent by FTP control session(s) to the FTP client(s)

Range of IP addresses / TCP port statistic parameter.
CP Layout | Variable name | Range | Description
IP:PORT e.g..192.168.000.002:1201 | IP | 0.0.0.0, 1.0.0.0 - 126.255.255.255, 128.0.0.0 - 223.255.255.255 | IP address
 | PORT | 0-65535 | TCP port

Class D and class E addresses are not supported.

FTP server port debug information top

You can get help information about FTP debug by executing "debug po:ftp" or "debug po:ftp lsn:0"commands.

At next snapshot you can see CPX screen with debug information of FTP-server port after executing command "debug po:ftp"

[16:02:14] ABILIS_CPX:debug po:ftp

PO:967 ------------------------------------------------------------------------
FTP BufferLength:254 Date/Time:06/01/2003 16:02:39 TraceTime:<NotRunning>

DEBUG PO:<FTP>
LSN:0 - This help
LSN:1 - Complete debug
LSN:2 - Statistics
LSN:3 - Session log
LSN:3 CMD:CLR - Clear session log
LSN:3 CMD:SES:x - Shows events only for session "x"

You can get statistic of FTP server by executing "debug po:ftp lsn:2"command.

At next snapshot you can see CPX screen with FTP server port statistic after executing command "debug po:ftp lsn:2"

[16:10:40] ABILIS_CPX:debug po:ftp lsn:2

PO:967 ------------------------------------------------------------------------
FTP    BufferLength:1123   Date/Time:06/01/2003 16:10:53 TraceTime:<NotRunning>

------------------------------------------------------------------------
STATE:ACTIVE              MAX-CLI:4
------------------------------------------------------------------------
Cumulative PLAIN and SSL
------------------------------------------------------------------------
CUR-CLI-CONNECTED:0     CUR-CLI-DATA:0    CUR-CLI-LOGGED:0
PEAK-CLI-CONNECTED:2    PEAK-CLI-DATA:0
------------------------------------------------------------------------
SSL specific
------------------------------------------------------------------------
SSL-CUR-CLI-CONNECTED:0     SSL-CUR-CLI-DATA:0    SSL-CUR-CLI-LOGGED:0
SSL-PEAK-CLI-CONNECTED:0    SSL-PEAK-CLI-DATA:0
------------------------------------------------------------------------
--CONTROL--+---INPUT---+--OUTPUT---+----DATA---+---INPUT---+--OUTPUT---|
CHR        |       247 |       883 |CHR        |         0 |       187 |
PCK        |        23 |        28 |PCK        |         0 |         3 |
COMMAND    |        23 |           |
REPLY      |           |        28 |
------------------------------------------------------------------------

For getting information of FTP server log buffer you can execute "debug po:ftp lsn:3"command.

At next snapshot you can see CPX screen with FTP server port statistic after executing command "debug po:ftp lsn:3"

[16:07:58] ABILIS_CPX:debug po:ftp lsn:3

PO:967 ------------------------------------------------------------------------
FTP    BufferLength:3743   Date/Time:06/01/2003 16:07:58 TraceTime:<NotRunning>

------------------------------------------------------------------------
06.01 15:57:10 [1] Reply:220 Server ready
06.01 15:57:10 [1] Ctrl connection open:192.168.6.4:1066
06.01 15:57:10 [1] Command:USER admin
06.01 15:57:10 [1] Reply:331 Password required for admin
06.01 15:57:10 [1] Command:PASS admin
06.01 15:57:10 [1] Reply:230 User "admin" logged in
06.01 15:57:10 [1] User "admin" logged in. Home dir:"/"
06.01 15:57:10 [1] Command:SYST
06.01 15:57:10 [1] Reply:215 CPX Generation: 1
06.01 15:57:10 [1] Command:PWD
06.01 15:57:10 [1] Reply:257 "/" is current directory
06.01 15:57:10 [1] Command:TYPE A
06.01 15:57:10 [1] Reply:250 Type set to ASCII
06.01 15:57:10 [1] Command:PORT 192,168,6,4,4,43
06.01 15:57:10 [1] PORT command successful:192.168.6.4:1067
06.01 15:57:10 [1] Reply:200 Port command successful
06.01 15:57:10 [1] Command:LIST
06.01 15:57:10 [1] DATA open ACTIV L:192.168.6.10:20 R:192.168.6.4:1067
06.01 15:57:10 [1] Reply:150 Opening data connection for directory list
06.01 15:57:10 [1] Reply:226 Transfer complete
06.01 15:57:10 [1] Transfer complete. 65 bytes was sent
06.01 15:57:12 [1] Command:CWD sysdrives
06.01 15:57:12 [1] Reply:250 Command successful. "/sysdrives/" is current direct
ory
06.01 15:57:12 [1] Current directory:"/sysdrives/"
06.01 15:57:12 [1] Command:PORT 192,168,6,4,4,44
06.01 15:57:12 [1] PORT command successful:192.168.6.4:1068
06.01 15:57:12 [1] Reply:200 Port command successful
06.01 15:57:12 [1] Command:LIST
06.01 15:57:12 [1] DATA open ACTIV L:192.168.6.10:20 R:192.168.6.4:1068
06.01 15:57:12 [1] Reply:150 Opening data connection for directory list
06.01 15:57:12 [1] Reply:226 Transfer complete
06.01 15:57:12 [1] Transfer complete. 57 bytes was sent
06.01 15:57:14 [1] Command:CDUP
06.01 15:57:14 [1] Reply:250 Command successful. "/" is current directory
06.01 15:57:14 [1] Current directory:"/"
06.01 15:57:14 [1] Command:PWD
06.01 15:57:14 [1] Reply:257 "/" is current directory
06.01 15:57:21 [1] Command:telnet 192.168.6.10
06.01 15:57:21 [1] Reply:500 Command telnet is unknown
06.01 15:57:21 [1] Command telnet is unknown
06.01 15:57:38 [1] Command:CWD sysdrives
06.01 15:57:38 [1] Reply:250 Command successful. "/sysdrives/" is current direct
ory
06.01 15:57:38 [1] Current directory:"/sysdrives/"
06.01 16:00:30 [2] Reply:220 Server ready
06.01 16:00:30 [2] Ctrl connection open:192.168.6.5:1614
06.01 16:00:30 [2] Command:USER admin
06.01 16:00:30 [2] Reply:331 Password required for admin
06.01 16:00:30 [2] Command:PASS admin
06.01 16:00:30 [2] Reply:230 User "admin" logged in
06.01 16:00:30 [2] User "admin" logged in. Home dir:"/"
06.01 16:00:30 [2] Command:SYST
06.01 16:00:30 [2] Reply:215 CPX Generation: 1
06.01 16:00:30 [2] Command:PWD
06.01 16:00:30 [2] Reply:257 "/" is current directory
06.01 16:00:30 [2] Command:TYPE A
06.01 16:00:30 [2] Reply:250 Type set to ASCII
06.01 16:00:30 [2] Command:PORT 192,168,6,5,6,79
06.01 16:00:30 [2] PORT command successful:192.168.6.5:1615
06.01 16:00:30 [2] Reply:200 Port command successful
06.01 16:00:30 [2] Command:LIST
06.01 16:00:30 [2] DATA open ACTIV L:192.168.6.10:20 R:192.168.6.5:1615
06.01 16:00:30 [2] Reply:150 Opening data connection for directory list
06.01 16:00:30 [2] Reply:226 Transfer complete
06.01 16:00:30 [2] Transfer complete. 65 bytes was sent
06.01 16:02:15 [2] Command:QUIT
06.01 16:02:15 [2] Reply:221 Goodbye
06.01 16:02:15 [2] Ctrl connection close
06.01 16:02:38 [1] Inactive time-out expired
06.01 16:02:38 [1] Ctrl connection close

For getting complete debug information of FTP server (statistics and log buffer) you can execute "debug po:ftp lsn:2"command.

Also you can clear debug information from log buffer by executing "debug po:ftp lsn:3 cmd:clr"command.

For showing debug events only for FTP session x you can execute "debug po:ftp lsn:3 cmd:ses:x"command, where x specifies identifier of interesting FTP session.

Long file names top

Long file names may consist of any combination of letters, digits, or character values greater than 127 (0x7E).

In particular, the following special characters are ALSO allowed:

Character | ASCII Hex. value
$ | 0x24
% | 0x25
' | 0x26
- | 0x2D
_ | 0x5F
@ | 0x40
~ | 0x7E
` | 0x60
! | 0x21
( | 0x28
) | 0x29
{ | 0x7B
} | 0x7D
^ | 0x5E
# | 0x23
& | 0x26
. | 0x2E
+ | 0x2B
, | 0x2C
; | 0x3B
= | 0x2D
[ | 0x5B
] | 0x5D

Also embedded spaces within file names are allowed, while leading and trailing spaces are ignored.

The following characters are NOT allowed:

Character | ASCII Hex. value
\ | 0x5C
/ | 0x2F
: | 0x3A
* | 0x2A
? | 0x3F
" | 0x22
< | 0x3C
> | 0x3E
| | 0x7C


The Network Address Translator port (NAT)

Network Address Translation (NAT) problems
Terminology
Types of address translation

Configuration of the NAT port
Statistics of the NAT port

Configuration of NAT Aliases

Supported protocols/applications
Configuration examples

The IP addresses inside a stub domain can be duplicated by another stub domain, for instance a single Class A address could be used in several stub domains. This situation very frequently happens when the domains are not administered by the same authority, as in the case of independent enterprises networks.

As long as the domains are isolated there are not problems, but as soon as they need to be interconnected the addresses overlapping would prevent it. Here is where Network Address Translation (NAT) plays its role: installing a Network Address Translator at each exit point between a stub domain and the backbone, or between stub domains, allows translations of addresses so that each stub domain can "see" valid addresses.

Network Address Translation (NAT) problems top

Unfortunately Network Address Translation (NAT) is not for free. Because of the way some protocol/application behaves it may introduce compatibility problems, not always solved.

The problem: some protocols/applications places IP addresses, and/or TCP/UDP ports, in the payload of the packets, at the same "level" of the application data.
As a result, when the Network Address Translator changes the IP addresses or the TCP/UDP port of a datagram, it results in a misalignment between the new values in IP/TCP/UDP headers and the content of the packet, which carries the same information BUT at application level.

To successfuly apply Network Address Translation (NAT) it is therefore necessary to proceed with a further modification of the packet payload, so that it correspond the current values in the IP/TCP/UDP headers.
Unfortunately there is not a "good-for-all" method and each protocol/application must be identified and processed properly.

The List of protocols/applications supported by NAT section gives the exact view of the well known application/protocols that require a special handling and that are either supported or not supported by Abilis CPX Network Address Translator port.
Those not mentioned should be able to work without troubles.

Terminology top

Inside. The set of networks there are subject of translation, usually "private" networks.

Outside. All other networks, usually "public" addresses located on the Internet.

Inside local IP address. The IP address was assigned to a host on the inside network. The address may or may not be a valid outside address (usually on Internet), but in the second case it may actually belong to another organization to which it will impossible to connect, even with NAT. In the table of NAT Aliases this term called as NET:.

Inside global IP address. The IP address of an inside host as it appears to the outside networks. If, as usual, the outside network is the Internet, the address must be one of the "public" addresses that the ISPs have assigned to user's router for those connections. In the table of NAT Aliases this term called as ANET:.

Processed IP packet. It mean in this packet was changed a source or destination address in some cases a source or destination port was changed too.

Ignored IP packet. It mean that this packet was not changed.

Types of address translation top

Static Address Translation. The user can establish a one-to-one mapping between the inside local and global addresses, which happens when the number (netmask) of inside local and global addresses are identical.

Dynamic Source Address Translation. The user can establish dynamic mapping between the inside and global addresses, which happens when the number (netmask) of inside local and global addresses are different.

Port Address Translation (PAT). The user can conserve addresses in the global address pool by allowing source ports in TCP connections or UDP conversations to be translated. Different local addresses will be mapped to the same global address, with port translation providing the necessary uniqueness for TCP/UDP and other tricks providing uniqueness for ICMP.

This mode is indifferently called "PAT" or "NAT+PAT" and works only with TCP/UDP/ICMP protocols.

Extended filtering in PAT mode. The purpose of this feature is to allow a selective activation of the PAT translation based on the destination TCP/UDP port and on the IP protocol, with the result that network managers can empower their control of the network by:

  • Granting access only to some service, e.g. web and ftp.

  • Blocking access only to specific services, e.g. realaudio / realvideo servers

  • Precisely distinguishing inbound connections from outbound ones

  • Allowing internal users to access ANY service on the Internet while outside users may access only a restricted set

Destination port mapping. This behaviour is very useful in many situations, the most frequents are:

  • The user has just one public IP address and on the internal LAN there are more computers on several IP addresses running different services that must be reached from outside, e.g. one runs FTP, another HTTP, another SMTP.

  • The user has just one public IP address and on the internal LAN there are more computers on several IP addresses running the same service with different contents, e.g. a commercial web, a technical web, a restricted access web.

For more information see Configuration examples section.

Configuration of the NAT port top

The NAT port is referred by the "NAT" abbreviation and it has all the parameters described in this chapter.

Here is an example of the NAT port parameters.

[18:18:41] ABILIS_CPX: D P PO:NAT

PO:911 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
NAT    ------------------------------------------------------------------------
       LOG:DS          ACT:NO           dimtable:1000   TOUT:60
       - PAT mode timeouts ----------------------------------------------------
       TCP-CONN:3      TCP-CLOSING:180  TCP-CLOSED:1    TCP-RST:YES
       ICMP:30         UDP:3            DNS:30          SNTP:30
       FRAG-ID:30      FRAG-PTR:30      SNMP-ALG:NO

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
The changes made on the LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Details of the NAT port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ACT: | NAT runtime activation/deactivation
NO | NO, YES

This parameter is used to activate/deactivate the Network Address Translation runtime.

When it is set to "NO", NAT processing is disabled. The IP router will ignore any NAT references.

When it is set to "YES", NAT processing is enabled. The IP router will requests NAT processing whenever a packet arrives from either an INSIDE or an OUTSIDE interface.

warning! Unclassified interfaces, i.e. those interfaces that don't belong neither to the inside scope nor to the outside (NAT: field of IP port configuration is set to "NO"), are ignored.

When the Network Address Translation is active, packets will be forwarded only in the following cases:

  • Between unclassified interfaces (NAT: field of IP port configuration is set to "NO")
  • Between classified interfaces (NAT: field of IP port configuration is set to "INSIDE" or NAT: field of IP port configuration is set to "OUTSIDE") but only if a translation really took place.

When NAT is active, packets will not be forwarded between a classified and an unclassified interface.

DIMTABLE: | Maximum number of simultaneously active translations
1000 | 100 - 10000

It specifies how many translations can be created at the same time.

In the case that the translation table gets full, further requests will be ignored and the packets dropped. In this conditions the statistic counter OVERFLOW: will be increased for each dropped packet.

TOUT: | Time-out for IP links - non PAT mode
60 | 1 - 65535 min

This value sets the timeout of static and dynamic translations, i.e. those created without the PAT mode.
If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table.

TCP-CONN: | Time of storage for TCP link in connecting state.
3 | 1-65534 min

This value sets the timeout for TCP link in connecting state. It is a main state of TCP connection when it has set. If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. For more information about states of TCP connection see RFC 793. That value has used in PAT state of NAT only.

TCP-CLOSING: | Time of storage for TCP link in closing state.
180 | 1-240 sec

This value sets the timeout for TCP link in closing state. It is a state of TCP connection when one point of link waiting for a connection termination request acknowledgment from another. For more information about states of TCP connection see RFC 793. This value has used in PAT state of NAT only.

TCP-CLOSED: | Time of storage for TCP link in closed state.
1 | 1-240 sec

This value sets the timeout for TCP link in closed state. It represents no connection state at all (i.e a connection closed from both sides). For more information about states of TCP connection see RFC 793. This value has used in PAT state of NAT only.

TCP-RST: | Send RESET for expired link
YES | NO, YES

For packets other than SYN when link is not available NAT send datagram with set RST-bit to the host that sent this datagram. It initiates a new connection establishing. For more information about states of TCP connection see RFC 793. This value has used in PAT state of NAT only.

ICMP: | Time of storage for ICMP links
30 | 1-240 sec

This value sets the timeout for ICMP links. If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. This value has used in PAT state of NAT only.

UDP: | Time of storage for UDP links
3 | 1-65534 min

This value sets the timeout for UDP links. If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. This value has used in PAT state of NAT only.

DNS: | Time of storage for DNS links
30 | 1-240 sec

This value sets the timeout for DNS links. This links are created in process of DNS packets translating. (DNS packet is UDP packet has had a source port or a destination port equal 53.) If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. This value has used in PAT state of NAT only.

SNTP: | Time of storage for SNTP links
30 | 1-240 sec

This value sets the timeout for SNTP links. This links are created in process of SNTP packets translating. (SNTP packet is UDP packet has had a source port or a destination port equal 123.) If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. This value has used in PAT state of NAT only.

FRAG-ID: | Time of storage for FRAG-ID links
30 | 1-240 sec

This value sets the timeout for FRAGMENT ID links. This links are created in process of IP fragments translating. If the translation is not used for the specified time (i.e. no packets need it), it times out and it has removed by the translation table. This value has used in PAT state of NAT only.

FRAG-PTR: | Time of storage for FRAG-PTR links
30 | 1-240 sec

This value sets the timeout for FRAGMENT PTR links. This value has used in PAT state of NAT only.

SNMP-ALG: | Enable/disable SNMP Application Level Gateway
NO | NO, YES

This parameter is used to enable/disable SNMP Application Level Gateway.

Statistics of the NAT port top

Example on how to show state and statistics of the Control Port through the command D S:

[15:00:45] ABILIS_CPX:d s po:911

PO:911 ------------------------------------------------------------------------
NAT    STATE:READY     CUR-TRANSLATIONS:0           MAX-TRANSLATIONS:1000
       ------------------------------------------------------------------------
       REQ:529         SUCCESS:0           IGNORED:529         ERROR:0
       OVERFLOW:0                          TCP-RST:0
       -----------|--IN SRC---|--IN DST---|--OUT SRC--|--OUT DST--|
       ICMP       |0          |0          |0          |0          |
       TCP        |0          |0          |0          |0          |
       UDP        |0          |0          |0          |0          |
       OTHERS     |0          |0          |0          |0          |
       ------------------------------------------------------------------------
       FTP        |0          |0          |0          |0          |
       DNS        |0          |0          |0          |0          |
       OTHERS     |0          |0          |0          |0          |
       ------------------------------------------------------------------------
       FRAG-ID:0                   FRAG-POINTER:0
       FRAG-UNRESOLVED:0           FRAG-HEADER-FOUND:0
       ------------------------------------------------------------------------

NAT port statistics fields detailed top

CUR-TRANSLATIONS: | Number of translations is currently active.
 | 0 - 65534

There are a number of records in NAT dynamic table have used for translation now.

MAX-TRANSLATIONS: | Limit to possible simultaneous translations
 | 1 - 65534

Limit to possible simultaneous translations. There is a size of NAT dynamic table.

REQ: | Requests total.
 | 0 - 4294967295

There are a number of translation requests, which NAT has received after start (or NAT port statistics has cleared).

SUCCESS: | Successful requests.
 | 0 - 4294967295

The number of requests have processed successful (i.e a source or destination address in this IP packet was changed. Or was changed an IP address in packet's body, for example when a packet has a DNS massage in its body).

IGNORED: | Ignored requests.
 | 0 - 4294967295

The number of ignored requests (i.e an IP packet has not changed) because a match have not found.

ERROR: | Unsuccessful requests.
 | 0 - 4294967295

The number of requests have not processed successful independently of error's reason.

OVERFLOW: | Table overflow.
 | 0 - 4294967295

The number of requests have not processed successful because the table is overflow.

TCP-RST: | TCP resets sent.
 | 0 - 4294967295

The number of sent TCP reset packets. The TCP RST packets may be sent only when TCP-RST parameter of NAT is equal YES.

ICMP: | The number of processed ICMP packets.
 | 0 - 4294967295

The number of processed ICMP packets. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

TCP: | The number of processed TCP packets.
 | 0 - 4294967295

The number of processed TCP packets. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

UDP: | The number of processed UDP packets.
 | 0 - 4294967295

The number of processed UDP packets. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

OTHERS: | The number of processed packets other types.
 | 0 - 4294967295

The number of processed packets other (not ICMP/UDP/TCP) types. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

FTP: | The number of processed FTP packets.
 | 0 - 4294967295

The number of processed FTP packets. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

DNS: | The number of processed DNS packets.
 | 0 - 4294967295

The number of processed DNS packets. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

OTHERS: | The number of processed packets other types.
 | 0 - 4294967295

The number of processed packets other (not FTP/DNS) types. Each kinds of translation: Incoming Source, Incoming Destination, Outbound Source, Outbound Destination is counted separately.

FRAG-ID: | The number of processed FRAGMENT ID packets.
 | 0 - 4294967295

The number of processed FRAGMENT ID packets.

FRAG-POINTER: | The number of processed FRAGMENT POINTER packets.
 | 0 - 4294967295

The number of processed FRAGMENT POINTER packets.

FRAG-UNRESOLVED: | The number of unprocessed fragment packets.
 | 0 - 4294967295

The number of unprocessed fragments of IP packets because a fragment not resolved.

FRAG-HEADER-FOUND: | The number of processed fragments of IP packets.
 | 0 - 4294967295

There are a number of processed fragments of IP packets.

Supported protocols/applications top

Terminology

Regular protocol/application
It is a protocol/application that works correctly even if IP addresses and/or TCP/UDP ports are translated. They do not require a specific treatment.
Special protocol/application
It is a protocol/application that requires further specific treatment of the packets payload after the IP addresses and/or TCP/UDP ports translation.
Supported protocol/application.
It is special a protocol/application that CPX NAT can successfully manage.
Unsupported protocol/application.
It is a protocol/application that CPX NAT cannot manage correctly, in the sense that it can only translate IP addresses and/or TCP/UDP port but it cannot modify the packet payload.

Well known regular protocols

  • HTTP
  • HTTPS
  • TFTP
  • TELNET
  • Any application that does NOT carry the IP addresses to be translated in the packet payload
  • Any application that does NOT carry the IP addresses and/or TCP/UDP ports to be translated in the packet payload

Supported protocols/applications

Below is a list of well known special protocols/applications which are supported by CPX NAT.

  • ICMP (used by "ping" and "traceroute" utilities)
  • FTP on port 21 (PORT and PASV commands)
  • DNS on port 53 ("A" and "PTR" queries)

Unsupported protocols/applications

Below is a list of well known special protocols/applications which cannot work with any NAT implementation, because the information in the payload is ciphered, and therefore NATs cannot modify them!

  • IPsec and IKE
  • Kerberos 4
  • Kerberos 5
  • X Windowing System

Below is a list of well known special protocols/applications which are not supported by the current CPX NAT implementation.

  • NetBIOS over TCP/IP
  • Progressive Networks' RealAudio
  • NetMeeting
  • NetMeeting Directory (Internet Locator Server)
  • H.323
  • PPTP


The Dynamic Host Configuration Protocol Port (DHCP)

Terminology
Goal

Configuration of the DHCP port
Statistics of the DHCP port

Configuration of DHCP Server tables
DHCP bindings table

Table of types of hardware addresses

The Dynamic Host Configuration Protocol (DHCP) provides configuration parameters to Internet hosts. DHCP consists of two components: a protocol for delivering host-specific configuration parameters from a DHCP server to a host and a mechanism for allocation of network addresses to hosts.

DHCP is built on a client/server model, where designated DHCP server hosts allocate network addresses and deliver configuration parameters to dynamically configured hosts. Throughout the remainder of this document, the term "server" refers to a host providing initialization parameters through DHCP, and the term "client" refers to a host requesting initialization parameters from a DHCP server.

A host should not act as a DHCP server unless explicitly configured to do so by a system administrator. The diversity of hardware and protocol implementations in the Internet would preclude reliable operation if random hosts were allowed to respond to DHCP requests.
For example, IP requires the setting of many parameters within the protocol implementation software. Because IP can be used on many dissimilar kinds of network hardware, values for those parameters cannot be guessed or assumed to have correct defaults. Also, distributed address allocation schemes depend on a polling/defense mechanism for discovery of addresses that are already in use. IP hosts may not always be able to defend their network addresses, so that such a distributed address allocation scheme cannot be guaranteed to avoid allocation of duplicate network addresses.

DHCP supports three mechanisms for IP address allocation:

  • In automatic allocation, DHCP assigns a permanent IP address to a client.
  • In dynamic allocation, DHCP assigns an IP address to a client for a limited period of time (or until the client explicitly relinquishes the address).
  • In manual allocation, a client's IP address is assigned by the network administrator, and DHCP is used simply to convey the assigned address to the client.

A particular network will use one or more of these mechanisms, depending on the policies of the network administrator.

Dynamic allocation is the only one of the three mechanisms that allows automatic reuse of an address that is no longer needed by the client to which it was assigned. Thus, dynamic allocation is particularly useful for assigning an address to a client that will be connected to the network only temporarily or for sharing a limited pool of IP addresses among a group of clients that do not need permanent IP addresses. Dynamic allocation may also be a good choice for assigning an IP address to a new client being permanently connected to a network where IP addresses are sufficiently scarce that it is important to reclaim them when old clients are retired.

Manual allocation allows DHCP to be used to eliminate the error-prone process of manually configuring hosts with IP addresses in environments where (for whatever reasons) it is desirable to manage IP address assignment outside of the DHCP mechanisms.

Terminology top

DHCP client
A DHCP client is an Internet host using DHCP to obtain configuration parameters such as a network address.
DHCP server
A DHCP server is an Internet host that returns configuration parameters to DHCP clients.
BOOTP relay agent
A BOOTP relay agent or relay agent is an Internet host or router that passes DHCP messages between DHCP clients and DHCP servers. DHCP is designed to use the same relay agent behavior as specified in the BOOTP protocol specification.
Binding
A binding is a collection of configuration parameters, including at least an IP address, associated with or "bound to" a DHCP client. Bindings are managed by DHCP servers.

Goal top

The following list gives general design goals for DHCP.

  • DHCP should be a mechanism rather than a policy. DHCP must allow local system administrators control over configurationparameters where desired; e.g., local system administrators should be able to enforce local policies concerning allocation and access to local resources where desired.
  • Clients should require no manual configuration. Each client should be able to discover appropriate local configuration parameters without user intervention and incorporate those parameters into its own configuration.
  • Networks should require no manual configuration for individual clients. Under normal circumstances, the network manager should not have to enter any per-client configuration parameters.
  • DHCP should not require a server on each subnet. To allow for scale and economy, DHCP must work across routers or through the intervention of BOOTP relay agents.
  • A DHCP client must be prepared to receive multiple responses to a request for configuration parameters. Some installations may include multiple, overlapping DHCP servers to enhance reliability and increase performance.
  • DHCP must coexist with statically configured, non-participating hosts and with existing network protocol implementations.
  • DHCP must interoperate with the BOOTP relay agent behavior as described by RFC 951 and by RFC 1542.
  • DHCP must provide service to existing BOOTP clients.

The following list gives design goals specific to the transmission of the network layer parameters. DHCP must:

  • Guarantee that any specific network address will not be in use by more than one DHCP client at a time,
  • Retain DHCP client configuration across DHCP client reboot. A DHCP client should, whenever possible, be assigned the same configuration parameters (e.g., network address) in response to each request,
  • Retain DHCP client configuration across server reboots, and, whenever possible, a DHCP client should be assigned the same configuration parameters despite restarts of the DHCP mechanism,
  • Allow automated assignment of configuration parameters to new clients to avoid hand configuration for new clients,
  • Support fixed or permanent allocation of configuration parameters to specific clients.

Configuration of the DHCP port top

The Dynamic Host Configuration Protocol port is labelled within the Abilis CPX with the acronym "DHCP" and it is provided with the parameters described in this section.

Here is an example on how to display the DHCP port parameters. Shown values are the default ones.

[11:56:24] ABILIS_CPX: D P PO:DHCP

PO:912 ------------------------------------------------------------------------
DHCP   LOG:DS          lowpo:902    ACT:NO            srvport:67   cliport:68
       msg-len:1472    mode:RELAY   MAX-HOPS:4        SRV:#
       LOCIPADD:R-ID (192.168.000.060)
       WDIR:C:\APP\DHCP\

The parameters set changes on the base of the type of the DHCP port behaviour, i.e. on the base of the current value of the mode: parameter. By default it is set to "RELAY".

Here is an example of DHCP port parameters, when the mode: parameter is set to "SERVER"

[11:56:24] ABILIS_CPX: D P PO:DHCP

PO:912 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
DHCP   ------------------------------------------------------------------------
       LOG:DS          lowpo:902    ACT:NO            srvport:67   cliport:68
       msg-len:1472    mode:SERVER  max-clients:300   ICMPCHK:NO
       MAC-FILTER:YES  MAC-LIST:#                     MAC-RULE:DENY
       WDIR:C:\APP\DHCP\

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the DHCP port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

lowpo: | Lower CPX port number
NONE | NONE, 1 - 999

It sets the lower CPX port number. Only UDP are accepted.

ACT: | Runtime activation/deactivation
NO | NO, YES

This parameter allows to run-time activate/deactive DHCP functionalities.

When it is set to "NO", DHCP processing is disabled. The port is running but messages processing is disabled.
For BOOTP relay agent mode, it means that any received packet is discarded; for DHCP server mode any received packet is discarded but "leases timers" are not stopped.

When it is set to "YES", DHCP processing is enabled. The port is running and forwarding is enabled.

srvport: | DHCP server port number
67 | 67

This is a read-only parameter, it shows the DHCP Server port number, that is currently fixed to 67.

cliport: | DHCP Client port number
68 | 68

This is a read-only parameter, it shows the DHCP Client port number, that is currently fixed to 68.

msg-len: | Maximum length of a DHCP messages
1472 | 548 - 2048 (bytes)

This parameter specifies specifies the maximum length of a DHCP messages (in bytes), which is actually the UDP payload.

mode: | Working mode of DHCP port driver
SERVER | SERVER, RELAY

This parameter specifies the mode of DHCP port working.

When it is set to "SERVER", the port behaves as DHCP server.

When it is set to "RELAY", the port behaves as BOOTP relay agent.

MAX-HOPS: | Maximum DHCP relay agent hops
4 | 1 - 16

This parameter specifies the maximum number of DHCP relay agent hops, i.e. the maximum acceptable value for "hops" field in received BOOTREQUEST messages. Higher values causes the discard of the request, which in any case occours for "hops" field value greater then 16. Note that the "hops" field value is increased by each relay agent at forwarding time.

This parameter is available only when the port behaves as BOOTP relay agent, i.e. mode: is set to "RELAY".

SRV: | DHCP Server to which requests must be forwarded
# | #, ListName, 1-126.x.x.x, 128-223.x.x.x

This parameter specifies the DHCP Server to which requests must be forwarded. It can be set to an IP address, in Dotted Decimal Notation, or the the name of an IP list.

The value "#", stands for "no DHCP Server" and it means that the request cannot be forwarded and must be discarded.

Acceptable IP adresses are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The name of the IP list must be a string of up to 20 characters in the range [0..9, a..z, A..Z, _] and it must correspond to the name of a list already defined in the Elements Lists service.

This parameter is available only when the port behaves as BOOTP relay agent, i.e. mode: is set to "RELAY".

LOCIPADD: | Source IP address used for the requests relayed to DHCP Server(s)
R-ID | R-ID, OUT-IPP, 1-126.x.x.x, 128-223.x.x.x

This parameter specifies the IP address that DHCP relay agent will use as "source address" in the requests relayed to the server(s).

In multiple interface systems, like a router is, it is necessary to have the possibility of choosing which of the IP addresses assigned to the system have to be used. These "system addresses" are the IP addresses of each interface and the R-ID (i.e an IP address elected as router identifier).

When the parameter is set to "R-ID", the router identifier will be used.

When the parameter is set to "OUT-IPP", the IP addresses of the interface from which the data is forwarded will be used.

An IP address in dotted decimal notaticon can also be set. Acceptable IP adresses are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

This parameter is available only when the port behaves as BOOTP relay agent, i.e. mode: is set to "RELAY".

max-clients: | Maximum number of supported DHCP clients
300 | 100 - 1000

This parameter specifies the maximum number of supported DHCP clients. It actually determines the size of the binding database on disk and in memory. It is important that changes to this value do not cause inconsistencies in the database.
If the new size is greater then the previous one, please check the amount of available memory and disk space.
If the new size is lower then the previous one, you should take into consideration that some information will be discarded. Anyway only discardable bindings will be discarded, all the others will be preserved.

This parameter is available only when the port behaves as DHCP server, i.e. mode: is set to "SERVER".

ICMPCHK: | ICMP check for incoming requests activation
NO | NO, YES

This parameter enables ICMP checking of IP address.

When it is set to "NO", ICMP checking is disabled.

When it is set to "YES", ICMP checking is enabled. Before the server sends the DHCPOFFER message it sends two (with 500 msec and 1500 msec timeouts) ICMP ping requests to check the IP address which was allocated. If both timeouts expire, then the server will send the DHCP offer message, otherwise it will mark this IP address as abandoned and will not send response.

This parameter is available only when the port behaves as DHCP server, i.e. mode: is set to "SERVER".

MAC-FILTER: | Enable/disable the selection of serviceable clients based on their MAC address
NO | YES, NO

This parameter enables/disables the selection of serviceable clients based on their MAC address.

When it is set to "NO", MAC filtering is disabled. i.e. requests from any MAC address is served.

When it is set to "YES", MAC filtering is enabled. When DHCP receives an incoming request and before processing it, the DHCP verifies that the sender's MAC address is allowed by using MAC-LIST: and MAC-RULE: parameters current setting.

This parameter is available only when the port behaves as DHCP server, i.e. mode: is set to "SERVER".

MAC-LIST: | MAC addresses filtering list
# | #, ListName

This parameter allow to select a list of MAC addresses that must be used for the selection of serviceable clients based on their MAC address.

The name of the selected list must be a string of up to 20 characters in the range [0..9, a..z, A..Z, _]; it must be the name of a MAC or a RU or a MR list already defined in the Elements Lists.

The value '#', stands for "no MAC addresses list" and if the MAC-RULE: parameter is currently set to "PERMIT", the result is that any request is ignored, because, by default, every MAC is denied and there is no list specifying permitted MAC addresses.

This parameter is available only when the port behaves as DHCP server, i.e. mode: is set to "SERVER", and when the MAC-FILTER: parameter is set to "YES".

MAC-RULE: | MAC addresses filtering type
DENY | DENY, PERMIT

This parameter selects how to use the MAC addresses filtering list defined in MAC-LIST:.

When it is set to "DENY", MAC addresses specified in the list MAC-LIST: are denied only; all the others are permitted.

When it is set to "PERMIT", MAC addresses specified in the list MAC-LIST: are permitted only; all the others are denied.

This parameter is available only when the port behaves as DHCP server, i.e. mode: is set to "SERVER", and when the MAC-FILTER: parameter is set to "YES".

WDIR: | Directory where DHCP.BND file is located
C:\APP\DHCP\ | from 1 up to 128 ASCII extended characters [32..255]

This parameter selects the directory where DHCP.BND file is saved. It cannot be empty. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. The maximum accepted working directory string length is 128 characters. Case is preserved and spaces are allowed, but strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\").

Statistics of the DHCP port top

Example on how to show state and statistics of the DHCP port through the command D S:

[11:40:35] ABILIS_CPX: D S PO:DHCP

PO:912 ------------------------------------------------------------------------
DHCP   MODE:RELAY     STATE:INACT
       ------------------------------------------------------------------------
       Server mode
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQUESTS   |          0|           |RESPONSES  |           |          0|
       CHAR       |          0|          0|PCK        |          0|          0|
       LONG       |          0|          0|BAD-FORMAT |          0|           |
       UNK-IPP    |          0|           |           |           |           |
       DISCOVER   |          0|           |OFFER      |           |          0|
       REQUEST    |          0|           |ACK        |           |          0|
       DECLINE    |          0|           |NAK        |           |          0|
       RELEASE    |          0|           |           |           |           |
       INFORM     |          0|           |
       ------------------------------------------------------------------------
       Relay mode
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQUESTS   |          0|          0|RESPONSES  |          0|          0|
       HOP-EXCEED |          0|           |BAD-GW     |          0|           |
       ------------------------------------------------------------------------

Example on how to show extended statistics of the DHCP port through the command D SE:

[17:12:45] ABILIS_CPX: D SE PO:DHCP

PO:912 ------------------------------------------------------------------------
DHCP   --- Cleared 000:00:07:09 ago, on 02/04/2004 at 17:05:39 ----------------
       ------------------------------------------------------------------------
       Server mode
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQUESTS   |          0|           |RESPONSES  |           |          0|
       CHAR       |          0|          0|PCK        |          0|          0|
       LONG       |          0|          0|BAD-FORMAT |          0|           |
       UNK-IPP    |          0|           |           |           |           |
       DISCOVER   |          0|           |OFFER      |           |          0|
       REQUEST    |          0|           |ACK        |           |          0|
       DECLINE    |          0|           |NAK        |           |          0|
       RELEASE    |          0|           |           |           |           |
       INFORM     |          0|           |
       ------------------------------------------------------------------------
       Relay mode
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       REQUESTS   |          0|          0|RESPONSES  |          0|          0|
       HOP-EXCEED |          0|           |BAD-GW     |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the DHCP port

MODE: | Current behaviour of the DHCP port
 | SERVER, RELAY

It shows the current behaviour of the DHCP port driver.

When it is set to "SERVER", the port behaves as DHCP server.

When it is set to "RELAY", the port behaves as BOOTP relay agent.

STATE: | Current state of DHCP port driver
 | DOWN, INACT, STOP, ACTIVE, ERR

It shows the current state of the DHCP port driver.

Driver | States | Description | Values shown in:
System Log | Events Log | Display LCD
DHCP | DOWN | State set when registration to lower UDP port fail. | dn
INACT DHCP port is running, but the ACT: parameter is set to "NO".
All the incoming requests/responses will be silently dropped at their arrival, without requiring CPU time for their verification. 		in
STOP Server mode only. The driver is fully ready to work but it cannot create/write the bindings file "DHCP.BND". Possible causes:
  • the file is corrupted;
  • the disk is corrupted;
  • the disk is write protected.
Try to remove the cause of stopped state and execute the INIT PO: command. 		st
ACTIVE | The driver is fully ready to work: no errors with UDP service and ACT: parameter is set to "YES". | RD
ERR | Software error. Contact Abilis CPX assistance. | NA

Server mode - REQUESTS | Total number of packets sent from DHCP client to DHCP server
 | 0 - 4294967295

It shows the total number of packets sent from DHCP client to DHCP server.

Server mode - RESPONSES | Total number of packets sent from DHCP server to DHCP client
 | 0 - 4294967295

It shows the total number of packets sent from DHCP server to DHCP client.

Server mode - CHAR | Number of received and sent characters
 | 0 - 4294967295

It shows the total number of received (INPUT) and sent (OUTPUT) characters. UDP interface overhead excluded.

Server mode - PCK | Number of received and sent packets
 | 0 - 4294967295

It shows the total number of received (INPUT) and sent (OUTPUT) packets.

Server mode - LONG | Number of lost too long received incoming and not sent outgoing DHCP packets
 | 0 - 4294967295

It shows the total number of lost received (INPUT) and number of not sent (OUTPUT) DHCP packets which are too long for the configured msg-len value from configuration.

Actually no packets are sent with too long length.

Server mode - BAD-FORMAT | Number of lost received DHCP packets with bad format
 | 0 - 4294967295

It shows the total number of lost recieved DHCP packets with bad format.

Server mode - UNK-IPP | Number received packets with "unkwon" IP interface
 | 0 - 4294967295

It shows the total number of received packets with "unkwon" IP interface (IP port). This situation can occour only for software bugs.

Server mode - DISCOVER | Number of received DHCPDISCOVER packets
 | 0 - 4294967295

It shows the number of received DHCPDISCOVER packets from the DHCP client.

Server mode - OFFER | Number of sent DHCPOFFER packets
 | 0 - 4294967295

It shows the number of sent DHCPOFFER packets to the DHCP client.

Server mode - REQUEST | Number of received DHCPREQUEST packets
 | 0 - 4294967295

It shows the number of received DHCPDISCOVER packets from the DHCP client.

Server mode - ACK | Number of sent DHCPACK packets
 | 0 - 4294967295

It shows the number of sent DHCPACK packets to the DHCP client.

Server mode - DECLINE | Number of received DHCPDECLINE packets
 | 0 - 4294967295

It shows the number of received DHCPDECLINE packets from the DHCP client.

Server mode - NAK | Number of sent DHCPNAK packets
 | 0 - 4294967295

It shows the number of sent DHCPNAK packets to the DHCP client.

Server mode - RELEASE | Number of received DHCPRELEASE packets
 | 0 - 4294967295

It shows the number of received DHCPRELEASE packets from the DHCP client.

Server mode - INFORM | Number of received DHCPINFORM packets
 | 0 - 4294967295

It shows the number of received DHCPINFORM packets from the DHCP client. Actually this type of packet is not handled.

Relay mode - REQUESTS | Number of requests received from client and relayed to the servers
 | 0 - 4294967295

It shows the total number of good incoming requests received from client which are suitable for relaying (INPUT) and the total number of requests actually relayed to the servers (OUTPUT). In the case of multiple servers the counter is increased for each of them.

Relay mode - RESPONSES | Number of responses received from server(s) and relayed to the client
 | 0 - 4294967295

It shows the total number of good incoming responses received from server(s) which are suitable for relaying to the client (INPUT) and the total number of responses actually relayed to the client (OUTPUT).

Relay mode - HOP-EXCEED | Number of discarded requests with exceeded "hops number" value in the packet
 | 0 - 4294967295

Number of discarded requests because the "hops number" value in the DHCP packet exceeded the threshold.
Incremented for client's request that was already relayed by several agents and their count, present in 'hops' field of the recived packet, exceeds the threshold configured in MAX-HOPS.

Relay mode - BAD-GW | Number of discarded responses for "not matching" gateway address
 | 0 - 4294967295

It shows the total number of discarded responses for "not matching" gateway address ('giaddr' field in DHCP packet).
Incremented for every server's response packet whose 'giaddr' field value does not match any address of the router's interfaces.

DHCP bindings table top

A bindings table is the memory data base which stores bindings allocated for DHCP clients.

A binding record includes the information about allocated IP address, start time and end time of lease, profile which is currently used by a DHCP client and some other information.

The Table of DHCP bindings is used in server mode only.

It is stored in the "DHCP.BND" file in the location defined by the WDIR: parameter, that is by default the "C:\APP\DHCP\" directory, and it allows storage of up to max-clients: bindings, one per each record.
Every one minute the DHCP server checks the bindings table in the memory and, if the table was changed since the last time it was updated, the DHCP server saves all bindings to the file.

During Abilis CPX DHCP port start-up the DHCP driver tries to read the bindings table from the disk.
If the DHCP server finds the bindings file, it check wheter the file is can be updated, making a write operation try.
If the writing attempt is successful the DHCP server goes to the ACTIVE state.
If writing attempt fails the DHCP server goes to the STOP state; it writes a warning message into the System Log (i.e. "W: DHCP STOPPED") and it doesn't load the bindings "DHCP.BND" file content.
If the DHCP server doesn't find the bindings file, it tries to create it. If it is not possible the server goes to the STOP state and it writes a warning message into the System Log (i.e. "W: DHCP STOPPED").

If the server is in the STOP state you must check the disk (remove protection, etc.), try to remove the cause of stopped state and execute the INIT PO: command. The server will retry to check and load the binding file.

After loading the bindings from the "DHCP.BND" file, the DHCP server checks the bindings according to the current configuration of the DHCP driver and binding record that don't conform to the current configuration will be marked as "not valid" and they will not be used by the DHCP server.

The DHCP server makes the next checks of the loading bindings and marks the binding as "invalid" in all the following cases:

  • The subnet record which is coressponding to the IP address from the binding is not found in the subnets table.
  • The profile identifier from the binding is not found in the the profiles table.

If the binding is static (i.e. allocated from the hosts):

  • The host record with the IP and MAC addresses which are corresponding to the IP and MAC addresses from the loading binding is not found in the hosts table.
  • The IP address from the binding is found in one of the pools of the subnet record (i.e. if the corresponding subnet record was found).

if the binding is dynamic (i.e. allocated from the pools):

  • The host record with the IP and MAC addresses which are corresponding to the IP and MAC adresses from the loading binding is found in the hosts table;
  • The IP address from the binding is not found in one of the pools of the subnet record (i.e. if the corresponding subnet record was found);

warning! Be careful when you change the configuration parameters.

Commands for handling Table of DHCP bindings are described in the DHCP bindings section of the document Commands relating to DHCP.

The available commands are the following:

C DHCP BIND
D DHCP BIND
D DHCP BINDE

In the following example are displayed all the entries of the table of Table of DHCP bindings. Displayed values are samples.

[19:07:12] ABILIS_CPX: D DHCP BIND

------------------+----------------+------+-----------------+------------------
MAC:              |IP              |PROF: |Last request(GMT)|Expiry on(GMT)
------------------+----------------+------+-----------------+------------------
11-11-23-11-11-11  192.168.000.123    128  20/12/2002 10:10  29/12/2002 10:10
11-11-23-11-11-11  010.010.010.005     21  20/12/2002 10:16  21/11/2002 10:16 E
11-11-23-11-11-15  192.168.000.150   NONE  20/12/2002 10:20  23/12/2002 10:10
11-11-23-11-11-12  192.168.000.124      5  20/12/2002 10:30  21/11/2002 10:30 E
11-11-23-11-11-12  192.168.000.124      5  20/12/2002 10:40  23/12/2002 10:10

In the following example are displayed all the entries of the table of Table of DHCP bindings in extended format. Displayed values are samples.

[19:07:12] ABILIS_CPX: D DHCP BINDE

----+-----+-------------------+-----------------+-------+----------------------
 O: | ST: | MAC:              | IP:             | PROF: | Last request(GMT)
                                                        | Expiry on(GMT)
----+-----+-------------------+-----------------+-------+----------------------
 H    EXP   11-11-23-11-11-11   192.168.000.123     128   21/12/2002 10:10:10
                                                          21/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    ACT   11-11-23-11-11-11   010.010.010.005     128   21/12/2002 10:10:10
                                                          29/12/2002 12:10:00
-------------------------------------------------------------------------------
 H    REL   11-11-23-11-11-15   192.168.000.150     128   21/12/2002 10:10:10
                                                          24/12/2002 11:10:10
-------------------------------------------------------------------------------
 H    ABD   11-11-23-11-11-30   000.000.000.000      10   21/12/2002 10:10:10
                                                          23/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    ACT   11-11-23-11-11-12   192.168.000.124    NONE   21/12/2002 10:10:10
                                                          25/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    EXP   11-11-23-11-11-18   192.168.000.100       5   21/12/2002 10:10:10
                                                          21/12/2002 11:10:10
-------------------------------------------------------------------------------

Binding records can also be cleared, however this action is very dangerous and it should carefully evaluated by the user.

The current user interface allows the clear all the records currently present in the database in memory and/or to clear a specific record by specifying the IP address binded to the client. In both cases the user confirmation is requested before the command execution.

Here there are few samples of bindings clear commands:

[15:00:45] ABILIS_CPX: C DHCP BIND IP:A

YOU ARE GOING TO DELETE THE WHOLE CONTENT OF THE DHCP BINDINGS DATA BASE IN MEMORY.
DO YOU WANT TO PROCEES (Y/N)? Y

COMMAND EXECUTED

[15:00:45] ABILIS_CPX: C DHCP BIND IP:192.168.0.60

YOU ARE GOING TO DELETE THE SPECIFIED DHCP BINDING ENTRY FROM THE DATA BASE IN MEMORY.
DO YOU WANT TO PROCEES (Y/N)? Y

COMMAND EXECUTED

Details of Binding record's parameters

O: | Origin of the binding
 | H, P, ?

Specifies the origin of the binding:

  • H: IP address was allocated from hosts table (static allocation).
  • P: IP address was allocated from IP pools of one of subntes from subnets table.
  • ?: The origin is unknown.
ST: | State of the binding
 | see below

Specifies state of the binding at current time.

State | Description
REL | Released: DHCP client released IP address and cancelling remaining lease.
ACT | Active: Value of expiry time greate than current time and bind is not abandoned or released.
EXP | Expiried: Value of expiry time less than current time.
ABD | Abandoned: DHCP client indicated to server that network address is already in use.
UNK | Unknown state. Error.

MAC: | Binded MAC address of client
 | 00:00:00:00:00:00-FF:FF:FF:FF:FF:FF

Specifies the binded MAC address of the DHCP client.

IP: | IP address binded to the client
 | 1.0.0.0-126.255.255.255 128.0.0.0-223.255.255.255

Specify the IP address assigned to the DHCP client with the MAC address.

PROF: | DHCP profile identifier
 | NONE, 1-128

Specifies the identifier of DHCP profile from profiles table used at binding time.

Last request: | GMT Date and time value when the lease was assigned/renewed last time
 | dd/mm/yyyy hh:mm:ss

Specifies the GMT date and time value when the lease was assigned/renewed the last time.

Expiry on: | GMT Date and time value when the lease will expire
 | dd/mm/yyyy hh:mm:ss

Specifies the GMT date and time value when the lease will expire.

Table of types of hardware addresses top

Number | Hardware type
1 | Ethernet (10Mb)
2 | Experimental Ethernet (3Mb)
3 | Amateur Radio AX.25
4 | Proteon ProNET Token Ring
5 | Chaos
6 | IEEE 802 Networks
7 | ARCNET
8 | Hyperchannel
9 | Lanstar
10 | Autonet Short Address
11 | LocalTalk
12 | LocalNet (IBM PCNet or SYTEK LocalNET)
13 | Ultra link
14 | SMDS
15 | Frame Relay
16 | Asynchronous Transmission Mode (ATM)
17 | HDLC
18 | Fibre Channel
19 | Asynchronous Transmission Mode (ATM)
20 | Serial Line
21 | Asynchronous Transmission Mode (ATM)
22 | MIL-STD-188-220
23 | Metricom
24 | IEEE 1394.1995
25 | MAPOS

warning! NOTE: Current version of DHCP server supports only 1 and 6 types.


The ports X.25 session tunnelling protocol (XTP)

Configuration of the XTP port
Statistics of the XTP ports

The XTP ports are used within the Abilis CPX in order to implement the proprietary protocol "X.25 session tunnelling protocol", that allows the transport of X.25 sessions over TCP/IP connections.

The transport of the X.25 sessions on TCP connections is carried out by the driver of XTP port, through which a one-to-one correspondence is established between sessions of the Connection Oriented Router and TCP sessions, that means that a TCP session transports only one X.25 session.

The relation between the X.25 sessions and TCP connections are realized without the definition of predefined correspondences between the NUA X.25 and the IP addresses: the TCP connections are only established whenever the Connection Oriented Router receives a connection request.

The IP address of TCP connection is supplied by the Connection Oriented Router to XTP port during the phase of connection establishment, according to the appropriated information in the routing SVC.

The main good point of this strategy resides in the flexibility and the dinamicity of routings: in fact the information present in SVC routing are run-time modifiable and they do not need to restart the system.

Consequently the system is potentially able to reach any number of wished IP destinations: as an example with a single port of type XTP it is possible to manage up to 255 bidirectional switched sessions, addressing them towards as many different IP destinations.

The advantages of the proprietary protocol used by Abilis CPX are:

  • information about control of flow are estimated by the protocol X.25 (RR, RNR), they are not forwarded along the IP path;

  • the activities of buffering and management of the transmission window, provided by the TCP/IP protocol, are not influenced, neither penalized by the X.25 protocol ones.

A disadvantage could be the strategy for opening the chosen TCP/IP connection, because the time needed for detecting an eventual failure could even be longer than the standard one allowed by the X.25 protocol (usually 30 seconds). It turns into difficulty for offering a service of alternative routing from the Connection Oriented Router. The same considerations may be carried out for unexpected TCP/IP disconnections. However such mishaps can be over taken through a right setting of the proper time-outs.

In the Abilis CPX version, which this manual refers to, the PVC connections are not currently supported, but the protocol can be extended, without limits, in further implementations.

Here are some examples of SVC routings used to transport X.25 sessions over TCP/IP connections.

EXAMPLE N.1

PR:3   POI:301    CGI:*               CDI:888             UDI:*
NEXT:N POO:907    CGO:*               CDO:*               UDO:*
       COMP:NO                        FFO:*
                                      IPDEST:192.168.000.253

This routing allows to route calls coming from the X25 301 port (field POI:), with the features defined by the parameters CGI:, CDI: and UDI:, to the XTP 907 port (field POO:) opening a TCP/IP connection, whose IP destination is 192.168.000.253 (field IPDEST:).

EXAMPLE N.2

PR:1   POI:910    CGI:*               CDI:*               UDI:*
NEXT:N POO:302    CGO: 56565656       CDO: 123456768      UDO:*
       COMP:NO                        FFO:*
       IPSRC:*

This routing allows all the calls, coming from the port XTP 910 (field POI:) and having ANY IP address source (field IPDEST:), to be routed to the X25 302 port (field POO: ) opening a X.25 connection with the call information configured in the fields CGO:, CDO:, UDO: and FFO:.

EXAMPLE N.3

PR:5   POI:910    CGI:*               CDI:'XtpCdi'        UDI:'XtpUdf'
NEXT:N POO:911    CGO:*               CDO:*               UDO:*
       COMP:NO                        FFO:*
       IPSRC:'IpList'                 IPDEST:192.168.000.253

This routing allows all the calls, coming from the port XTP 910 (field POI:) and having ANY calling address (field CGI:), called address belonging to the "XtpCdi" list of NUA X.25 (field CDI:), user data belonging to the "XtpUdf" list of X.25 user data (field UDI:), IP source address in the "IpList" list of IP addresses (field IPSRC:), are forwarded to the XTP 911 port and a new connection, whose IP destination is 192.168.000.253 (field IPDEST:), is opened.

Configuration of the XTP port top

The port which implements the transport of X.25 sessions over TCP/IP connections is labelled within the Abilis CPX by the acronym "XTP" and it is provided with the following parameters.

The following example shows how to display parameters of XTP ports. Shown value are the default ones.

[18:38:04] ABILIS_CPX: D P PO:910

PO:910 ------------------------------------------------------------------------
XTP    lowpo:901      TYPE:USER     MCAU:NO   locport:2050   remport:2050
       bsvc:10        KEEPALIVE:30
       IPSRC:*                      IPSRCLIST:#

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialisation command INIT PO:.

Detail of the XTP port parameter

LOWPO: | Identifier of the Abilis CPX lower level port
NONE | 1 - 999, NONE

It sets the Abilis CPX lower level port. It can only be a TCP port.

Value "NONE" isolates the XTP port.

TYPE: | Port type
USER | USER

This parameter is used for setting how the port has to behave if data compression is active.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user equipment USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The XTP port can be only USER.

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), either for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialisation commands.

LOCPORT: | Identifier of the IP local port used
2050 | 2050

It sets the local IP port used by the XTP port. The IP number assigned by default to the XTP process is 2050.

This parameter has got only informative value and cannot be modified.

REMPORT: | Identifier of the IP remote port used
2050 | 2050

It sets the remote IP port used by the XTP port. The IP number assigned by default to the XTP process is 2050.

This parameter has got only informative value and cannot be modified.

BSVC: | Number of BSVC sessions
10 | 0 - 255

It sets the number of BSVC sessions managed by the XTP port. As above-mentioned, each XTP port can manage up to 255 BSVC sessions, addressing them towards as many different IP destinations.

KEEPALIVE: | Activation and setting of the "Keep-Alive time-out"
30 | NO, 15 - 65535 (seconds)

It activates and set the value of the "Keep-Alive time-out".

The "Keep-Alive" procedure, by sending the homonymous packets, keeps on the TCP connection even if data are not exchanged. The parameter set the idle time interval (seconds) which precedes the activation of such procedure.

If the parameter is set to NO, the procedure is not active.

If its value belongs to the interval [15-65535], the procedure will be activated only when the correspondent time-out will run-over.

IPSRC: | IP address of the enabled source
* | see table, *

The parameter configures the IP address of enabled source.

The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The character '*' means "any IP source address".

IPSRCLIST: | List of the IP addresses of enabled sources
# | ListName, #

The parameter configures an IP address list of enabled TELNET Client systems.

The List name must match a previously configured list in the Item list table. the allowed type lists are: IP addresses (IP), "Rule" lists (RU), "Master Rule" lists (MR).

The value '#' stands for "no list".

Statistics of the XTP ports top

How to check state and statistics of the XTP ports through the command D S.

[18:38:04] ABILIS_CPX: D S PO:907 .

PO:907 ------------------------------------------------------------------------
XTP    CH X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       0  READY     LISTENING
       1  CONN TO   CONNECTED 192.168.000.070-35481 192.168.000.253-2050
       2  READY     LISTENING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |2322       |38137      |CHAR       |4108       |2287657    |
       PCK        |2322       |20430      |CALL       |55         |0          |
       RESET      |0          |0          |
       ------------------------------------------------------------------------

The XTP ports have extended statistics and they can be displayed through the execution of the command D SE.

[18:38:04] ABILIS_CPX: D SE PO:907 .

PO:907 --- Cleared 004:03:42:20 ago, at 21/05/1999 11:38:23 -------------------
XTP    CH X25-State TCP-State LocAdd-LocPort        RemAdd-RemPort
       ------------------------------------------------------------------------
       0  READY     LISTENING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |297        |4888       |CHAR       |433        |294438     |
       PCK        |297        |2607       |CALL       |6          |0          |
       RESET      |0          |0          |
       ------------------------------------------------------------------------
       1  READY     LISTENING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |73         |1134       |CHAR       |165        |67417      |
       PCK        |73         |617        |CALL       |6          |0          |
       RESET      |0          |0          |
       ------------------------------------------------------------------------
       2  READY     LISTENING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |237        |3898       |CHAR       |354        |234901     |
       PCK        |237        |2078       |CALL       |6          |0          |
       RESET      |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the XTP ports

CH: | Channel identifier
 | 0 - BSVC:

It shows the number of the channel on the XTP port. The maximum number of channels is given, at the system start, by the value of the parameter BSVC:.

X25-State: | Connection state
 | READY, LISTENING, CALLING, CALLED, CONN TO, CONN FROM, CLEARING, CLEARED, RESETTING, RESET, ERR

It shows the current state of the connection, towards the Connection Oriented Router.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
XTP (X25 Session) | READY | The session is closed |  |  |
 | LISTENING | Session is ready to receive/send the connection request |  |  |
 | CALLING | Connection is getting established, the session sent a connection request and it is waiting for acknowledgement |  |  |
 | CALLED | Connection is getting established, the session received, but not yet acknowledged, a connection request |  |  |
 | CONN TO | Connection is active, the session received a connection request and sent its acknowledgement |  |  |
 | CONN FROM | Connection is active, the session sent a connection request and received its acknowledgement |  |  |
 | CLEARING | Connection is going to be closed, the session sent a disconnection request and it is waiting for acknowledgement |  |  |
 | CLEARED | Connection is going to be closed, the session received, but not yet acknowledged, a disconnection request |  |  |
 | RESETTING | Connection is managing a Reset. The session sent a Reset request and it is waiting for acknowledgement |  |  |
 | RESET | Connection is managing a Reset. The session received, but not yet acknowledged, a Reset request |  |  |
 | ERR | Software error, contact the Abilis assistance |  |  |

TCP-State: | Connection state towards the TCP port
 | DOWN, READY, LISTENING, CALLED, CALLING, CONNECTED, CLEARING, CLEARED, RESETTING, RESET, ERR

It shows the current state of the connection, towards the TCP port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
XTP (TCP connection) | DOWN | The parameter "LOWPO:" is set to NONE or the driver is not able to connect to the TCP lower level port |  |  |
 | READY | Connection is closed |  |  |
 | LISTENING | Connection is active and it is waiting to receive/send connection requests |  |  |
 | CALLED | Connection is going to be established |  |  |
 | CALLING |  |  |  |
 | CONNECTED | Connection is active |  |  |
 | CLEARING | Connection is going to be closed |  |  |
 | CLEARED |  |  |  |
 | RESETTING | Connection is managing a Reset request |  |  |
 | RESET |  |  |  |
 | ERR | Software error, contact the Abilis assistance |  |  |

LocAdd: | IP local address used by the connection
 | 0 - 255.255.255.255

It shows the IP local address used by the connection, whose state has not to be READY-LISTENING.

LocPort: | IP local port used by the connection
 | 0 - 65.535

It shows the IP local port used by the connection, whose state has not to be READY-LISTENING.

RemAdd: | IP remote address used by the connection
 | 0 - 255.255.255.255

It shows the IP remote address used by the connection, whose state has not to be READY-LISTENING.

RemPort: | IP remote port used by the connection
 | 0 - 65.535

It shows the IP remote port used by the connection, whose state has not to be READY-LISTENING.

SEG: | Overall number of segments received/sent in all the sessions
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time a packet is received, while the counter SEG (OUTPUT) every time a packet is sent.

CHAR: | Overall number of characters received/sent in all the sessions
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time a packet is received, while the counter CHAR (OUTPUT) every time a packet is sent.

PCK: | Overall number of packets received/sent in all the sessions
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a packet is received, while the counter PCK (OUTPUT) every time a packet is sent

CALL: | Overall number of calls sent/received in all the sessions
 | 0 - 4.294.967.295

The counter CALL (INPUT) is incremented every time a connection request is received, while the counter CALL (OUTPUT) every time a connection request is sent

RESET: | Overall number of resets sent/received in all the sessions
 | 0 - 4.294.967.295

The counter RESET (INPUT) is incremented every time a Reset is received, while the counter RESET (OUTPUT) every time a Reset is sent

Detail of the extended statistics of the XTP ports

CH: These statistics are the same shown in basic command and already explained
X25-State:
TCP-State:
LocAdd:
LocPort:
RemAdd:
RemPort:
SEG:
CHAR:
PCK:
CALL:
RESET:


PLINK Emulation over UDP (PLINKE)

Operating modes of PLINKE driver

Configuration of the PLINKE ports
Statistics of the PLINKE ports

PLINKE stands for Permanent Link Emulation. As the name suggest, PLINKE port is used to provide the P-Link service, i.e. the service provided by Synchronous (SYNC) ports, to the upper layer port while using an IP network for the actual packet transport.
The upper layer port of a PLINKE is the Multi Link Manager (MLM) port.

PLINKE uses the IP/UDP protocol, which is provided in the Abilis CPX by the UDP port.

Typical applications of this service are:

  • Clustering of several CPXs through a LAN interface, to increase capacity or availability of data and voice services.
  • Layer 2 oer IP tunneling
  • IP over IP tunnelling
  • Data and Voice over IP

PLINKE is optimised for the Abilis Data and Voice Multiplexing (MPX protocol), which provides very good results for tunneling Voice over IP and Voice over the Internet.

Operating modes of PLINKE driver top

The PLINKE driver of Abilis CPX works in four operating modes:

Standard mode
  • A full clustering of several CPX will require a consistent number of PLINKE ports on each CPX: one for each "peer" CPX.
  • Prioritization of DATA/VOICE/LINK-CHECK is not performed. If the LAN is not heavily loaded there will not be problems of voice degradation.
  • Usage of PLINKE over WANs MUST be avoided, especially for voice transmission. The main problem is that PLINKE doesn't implement the Real-Time Transport Protocol (RTP).
  • Local and remote peer PLINKE must match for MPX: parameter configuration.
  • Problems when at least one IP port is "behind" a NAT (or firewall) or is used a xDSL connection (and so a dynamic IP address is used).
  • The remote PLINKE port must be configured in the same mode also (i.e. MODE:STD).
Extended mode
  • Extended version of the PLINKE port can encapsulate several VOICE frames to the one VOICE datagram.
  • Extended version of PLINKE over WANs MAY be used, because extended version of drivers has mechanism of sequencing incoming DATA and VOICE frames (similar to Real-Time Transport Protocol (RTP)).
  • Problems when at least one IP port is "behind" a NAT (or firewall) or is used a xDSL connection (and so a dynamic IP address is used).
  • The remote PLINKE port must be configured in the same mode also (i.e. MODE:EXT).
Extended SERVER and Extended CLIENT modes
  • PLINKE port can encapsulate several VOICE frames to the one VOICE datagram (like in the EXTENDED mode).
  • PLINKE over WANs MAY be used, because extended version of drivers has mechanism of sequencing incoming DATA and VOICE frames (similar to Real-Time Transport Protocol (RTP)).
  • No problems when one IP port is "behind" a NAT (or firewall) or is used a xDSL connection (and so a dynamic IP address is used).
    The SERVER will not send any datagrams until it knows which is the address to send data. Once he knows it, the SERVER will be able to send data to its remote peer (CLIENT).
    To do this, the CLIENT will add in its datagram the local information of IP address and port.
    When the SERVER receives the datagram from the CLIENT, it will check the header of the datagram (IP ADDR and PORT fields) with the expected information. If they are right, SERVER will use the address of the IP/UDP header received. This because the IP/UDP header contains the real information on the remote peer.
    When the SERVER doesn't receive data from remote for a certain amount of time, the IP/UDP information previously gained are resetted. This because remote side could be down.
  • The SERVER peer channel works only with a CLIENT peer channel and vice versa.
  • PLINKE peer channel behind the NAT (or firewall) must be configured in the CLIENT mode.

Configuration of the PLINKE port top

PLINKE ports are identified by the mnemonic "PLINKE" and are provided with the parameters described in this section.

Here is an example on how to display PLINKE ports parameters. It shows default configuration of four PLINKE ports, one for every operative mode.

[15:02:45] ABILIS_CPX:D P PO:PLINKE

PO:401 ------------------------------------------------------------------------
PLINKE LOWPO:902     MODE:STD          D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10
                     LOCPORT:2101                     REMPORT:2100
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)  REMIPADD:#

PO:402 ------------------------------------------------------------------------
PLINKE LOWPO:902     MODE:EXT          D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:SINGLE   LOCPORT:2102                     REMPORT:2100
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)  REMIPADD:#

PO:403 ------------------------------------------------------------------------
PLINKE LOWPO:902     MODE:EXT-SERVER   D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:SINGLE   LOCPORT:2103                     REMPORT:2100
       CLI-ID:#
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)

PO:404 ------------------------------------------------------------------------
PLINKE LOWPO:902     MODE:EXT-CLIENT   D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:SINGLE   LOCPORT:2104                     REMPORT:2100
       ID:R-ID (192.168.000.060)
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)  REMIPADD:#

In case of Extended mode, Extended SERVER and Extended CLIENT modes, an additional set of parameters are shown when the PATH: is set to "DOUBLE".

Double path's default parameters values are shown in the sample below:

[16:57:08] ABILIS_CPX:S P PO:402,403,404 PATH:DOUBLE

COMMAND EXECUTED

[16:57:19] ABILIS_CPX:D P PO:402,403,404

PO:402 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
PLINKE ------------------------------------------------------------------------
       LOWPO:902     MODE:EXT          D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:DOUBLE   LOCPORT:2102                     REMPORT:2100
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)  REMIPADD:#
       OUT-IPP2:AUTO
       LOCIPADD2:R-ID (192.168.000.060) REMIPADD2:#

PO:403 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
PLINKE ------------------------------------------------------------------------
       LOWPO:902     MODE:EXT-SERVER   D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:DOUBLE   LOCPORT:2103                     REMPORT:2100
       CLI-ID:#
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)
       OUT-IPP2:AUTO
       LOCIPADD2:R-ID (192.168.000.060)

PO:404 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
PLINKE ------------------------------------------------------------------------
       LOWPO:902     MODE:EXT-CLIENT   D-TOS:NONE   V-TOS:DELAY   C-TOS:DELAY
       MPX:NO        RS-BUF:10         D-TOUT:3000  V-TOUT:100
       PATH:DOUBLE   LOCPORT:2104                     REMPORT:2100
       ID:R-ID (192.168.000.060)
       OUT-IPP:AUTO
       LOCIPADD:R-ID (192.168.000.060)  REMIPADD:#
       OUT-IPP2:AUTO
       LOCIPADD2:R-ID (192.168.000.060) REMIPADD2:#

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

All PLINKE parameters are displayed by upper case characters, this means that changes made on these parameters are immediately active and it is not needed to restart the system.

Details of the PLINKE port parameters

LOWPO: | Lower CPX port
Default value | 0..999, NONE

It sets the Abilis CPX lower layer port. It can only be an UDP port.

Value "NONE" isolates the PLINKE port.

MODE: | Operating mode
Default value | STD, EXT, EXT-SERVER, EXT-CLIENT

It sets the port working mode.

Token | Working Mode
STD | Standard mode. Driver works only with the remote side in the standard mode.
EXT | Extended mode. Driver works only with the remote side in the extended mode.
EXT-SERVER | Extended-server mode. Driver works only with the remote side in the extended-client mode.
EXT-CLIENT | Extended-client mode. Driver works only with the remote side in the extended-server mode.

D-TOS: | DATA frames Type Of Service
Default value | NONE, COST, REL, THR, DELAY

This parameter specifies the Type Of Service assigned to DATA frames.

V-TOS: | VOICE frames Type Of Service
Default value | NONE, COST, REL, THR, DELAY

This parameter specifies the Type Of Service assigned to VOICE frames.

C-TOS: | LINK-CHECK frames Type Of Service
Default value | NONE, COST, REL, THR, DELAY

This parameter specifies the Type Of Service assigned to LINK-CHECK frames.

MPX: | Abilis MPX protocol activation
Default value | NO, YES

It allows to activate the VOICE/DATA multiplexing, as per ABILIS MPX protocol.

If set to "NO", multiplexing is disabled; if the PLINKE port receives LINK-CHECK or VOICE frames type, it will discard them because they cannot be forwarded.

RS-BUF: | Size of receive buffer for out-of-sequence frames
Default value | 1..100 Kbytes

For the extended modes only, it sets the size (in Kbytes) of the buffer where the received frames are "parked" during the re-sequentialisation process.

The default value is optimal when the PLINKE is used only for VOICE services

The maximum value, 100 Kbytes, is strongly suggested when PLINKE is used for data or for voice/data traffic.

D-TOUT: | Time limit for out-of-sequence DATA frames parking (Only for MODE:EXT/EXT-SERVER/EXT-CLIENT)
Default value | 0..10000 msec

The IP networks do not guarantee that packets are received in the same order that they are sent, therefore a re-sequentialisation procedure must be adopted. Unfortunately packets may also never arrive, e.g. because they were lost, therefore it is necessary to have a time limit to prevent deadlocks.

Packets which arrive "too late" will be discarded and counted as "OUT-SEQ - DATA IN"

When 0 is used, only "in sequence" packets are accepted: the re-sequentialisation procedure will never wait for "out of order" packets, but it guarantees that packets deliver to upper layer are in the correct order, although with "holes".

V-TOUT: | Time limit for out-of-sequence VOICE frames parking (Only for MODE:EXT/EXT-SERVER/EXT-CLIENT)
Default value | 0..500 msec

The IP networks do not guarantee that packets are received in the same order that they are sent, therefore a re-sequentialisation procedure must be adopted. Unfortunately packets may also never arrive, e.g. because they were lost, therefore it is necessary to have a time limit to prevent deadlocks.

Packets which arrive "too late" will be discarded and counted as "OUT-SEQ - VOICE IN"

When 0 is used, only "in sequence" packets are accepted: the re-sequentialisation procedure will never wait for "out of order" packets, but it guarantees that packets deliver to upper layer are in the correct order, although with "holes".

PATH: | Single/double path variant activationn (Only for MODE:EXT/EXT-SERVER/EXT-CLIENT)
Default value | SINGLE, DOUBLE

This parameters allows the Single/Double PATH variant selection. It allows to activate the sending/receiving VOICE/DATA/LINK-CHECK datagrams by two paths in EXT/EXT-SERVER/EXT-CLIENT modes.

Token | Working Mode
SINGLE | SINGLE-PATH variant is used.
DOUBLE | DOUBLE-PATH variant is used.

LOCPORT: | Local UDP port number for incoming/outgoing UDP packets
Default value | 1..65535

It sets the local UDP port used by the PLINKE port to "listen" for incoming packets.

It is not possible that two or more UDP services "listen" on the same port and IP address, which is of course valid for PLINKE ports too. User must set different values for each configured port.

The VALIDATE command can be used to verify that such duplications are really not present.

This port is used as source in sent packets and must be present as destination in the received packets.

REMPORT: | Remote UDP port number for incoming/outgoing UDP packets
Default value | 1..65535

It sets UDP port on which the remote PLINKE can be reached.

This port is used as destination in sent packets and must be present as source in the received packets

ID: | Identification IP address sent by the Client to the Server (Only for MODE:EXT-CLIENT)
Default value | R-ID, 1-126.x.x.x, 128-223.x.x.x

This is a "static" IP address of the client that client sends to the ext-server for identification.

The EXT-CLIENT mode uses this parameter plus LOCPORT: to identify itself to the server.

Possible values are swhoewn in the table below:

Value | Meaning
R-ID(xxx.xxx.xxx.xxx) | Router-ID as reported by IPRTR
1.0.0.0 - 126.255.255.255 128.0.0.0 - 223.255.255.255 | Any valid unicast IP address

CLI-ID: | Client identification IP address (Only for MODE:EXT-SERVER)
Default value | #, 1-126.x.x.x, 128-223.x.x.x

This is a "static" IP address of the client that ext-server uses as client identification.

The EXT-SERVER uses this parameter plus REMPORT: to match the client identification.

Possible values are swhoewn in the table below:

Value | Meaning
# | CLI-ID IP not set. Since identifier of the client is not, none clients can connect
1.0.0.0 - 126.255.255.255 128.0.0.0 - 223.255.255.255 | Any valid unicast IP address

OUT-IPP: | Output IP interface
Default value | AUTO, 0..63

It sets the output IP interface.

If this parameter is set to "AUTO", the UDP packets will be routed through IP routter routing table.
If an IP port value is defined, the UDP packets will be forced to be sent out from the specified IP interface.

GW: | Gateway (Only for OUT-IPP: not equal to "AUTO")
Default value | #, 1-126.x.x.x, 128-223.x.x.x

It is the IP address of the Gateway to be used when OUT-IPP: is not equal to "AUTO".
When OUT-IPP: is not equal to "AUTO" the driver must set the GW field of the UDP packet equal to 0.

Allowed values are shown into the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

LOCIPADD: | Local IP address for incoming/outgoing UDP pakets
Default value | R-ID, OUT-IPP, 1-126.x.x.x, 128-223.x.x.x

It specifies which of the router's IP address the PLINKE will use as:

  • valid IP address destination of the received packets
  • source IP address in the transmitted packets

The "R-ID" value means: use "router-id". Note that the display of the parameters will show, between round brackets, the current router-id value.

The "OUT-IPP" value means: use the IP address of the IP port through which the packet is sent out. There can be several situations where this option is useful, but there is one where it is mandatory: when using dialup PPP connections with dynamic assignment of the IP address.

Valid IP addresses, out of the addresses of the IP ports, that can be set are shwon in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "legal" IP addresses are those of the IP ports (IPADD: in IP port configuration) plus the router-id.

This address is used as source in sent packets and must be present as destination in the received packets

REMIPADD: | Remote IP address for incoming/outgoing UDP packets (Only for MODE:STD/EXT/EXT-CLIENT)
Default value | #, 1-126.x.x.x, 128-223.x.x.x

It sets the remote IP address.

The "#" value correspond to a "not configured" remote IP, that is a remote PLINKE to connect to is not configured.

The others allowed values are shown into the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

This address is used as destination in sent packets and must be present as source in the received packets

OUT-IPP2: | Second output IP interface (Only for PATHS:DOUBLE)
Default value | AUTO, 0..63

It sets the output IP interface for the second path.

If this parameter is set to "AUTO", the UDP packets will be routed through IP routter routing table.
If an IP port value is defined, the UDP packets will be forced to be sent out from the specified IP interface.

GW2: | Second gateway (Only for PATHS:DOUBLE and OUT-IPP2: not equal to "AUTO")
Default value | #, 1-126.x.x.x, 128-223.x.x.x

It is the IP address of the Gateway to be used when OUT-IPP2: is not equal to "AUTO".
When OUT-IPP2: is not equal to "AUTO" the driver must set the GW field of the UDP packet equal to 0.

Allowed values are shown into the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

LOCIPADD2: | Second IP address that the Local PlinkE will use as "source address" for the path 2 (Only for PATHS:DOUBLE)
Default value | R-ID, OUT-IPP, 1-126.x.x.x, 128-223.x.x.x

It specifies which of the router's IP address the PLINKE will use as:

  • valid IP address destination of the received packets
  • source IP address in the transmitted packets
for the path 2.

The "R-ID" value means: use "router-id". Note that the display of the parameters will show, between round brackets, the current router-id value.

The "OUT-IPP" value means: use the IP address of the IP port through which the packet is sent out. There can be several situations where this option is useful, but there is one where it is mandatory: when using dialup PPP connections with dynamic assignment of the IP address.

Valid IP addresses, out of the addresses of the IP ports, that can be set are shwon in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Warning!

The "legal" IP addresses are those of the IP ports (IPADD: in IP port configuration) plus the router-id.

This address is used as source in sent packets and must be present as destination in the received packets

REMIPADD2: | IP address of the Remote PlinkE for the path 2 (Only for MODE:STD/EXT/EXT-CLIENT and PATHS:DOUBLE)
Default value | #, 1-126.x.x.x, 128-223.x.x.x

It sets the remote IP address for the path 2.

The "#" value correspond to a "not configured" remote IP, that is a remote PLINKE to connect to is not configured.

The others allowed values are shown into the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

This address is used as destination in sent packets and must be present as source in the received packets

Statistics of the PLINKE ports top

Example on how to show state and statistics of a PLINKE port through the command D S:

[15:02:53] ABILIS_CPX: D S PO:403 .
PO:403 ------------------------------------------------------------------------
PLINKE STATE:DOWN          MODE:EXT-SERVER                 PATHS:DOUBLE
       PATHSTATE:DOWN      CUR-REM:-/-                     TOUT:0
       PATHSTATE2:DOWN     CUR-REM2:-/-                    TOUT2:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|FRM        |          0|          0|
       IP-CHR     |          0|          0|IP-FRM     |          0|          0|
       BAD-SRC    |          0|           |NO-SERV    |          0|           |
       CLI-TOUT   |          0|           |CLI-REMAP  |          0|           |
       -----------|--DATA IN--|-VOICE-IN--|-CHECK IN--|-----------------------|
       MISSING    |          0|          0|          0|
       NOBUF      |          0|          0|          0|
       ------------------------------------------------------------------------
       -- Time arrival variation of voice frames after reordering (msec.) -----
       ------------------------------------------------------------------------
            0- 20 |          0 (   0% )   |   151-200 |          0 (   0% )   |
           21- 50 |          0 (   0% )   |   201-300 |          0 (   0% )   |
           51-100 |          0 (   0% )   |   301-600 |          0 (   0% )   |
          101-150 |          0 (   0% )   |   601-xxx |          0 (   0% )   |
       ------------------------------------------------------------------------

The following example shows how to display extended statistics of a PLINKE port through the command D SE:

[16:30:05] ABILIS_CPX: D SE PO:403 .

PO:403 ------------------------------------------------------------------------
PLINKE --- Cleared 000:00:01:09 ago, on 19/07/2004 at 16:28:58 ----------------
       ------------------------------------------------------------------------
       Tunnel payload
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|FRM        |          0|          0|
       CHR-D      |          0|          0|FRM-D      |          0|          0|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       ------------------------------------------------------------------------
       IP level counters (actual IP traffic)
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       IP-CHR     |          0|          0|IP-FRM     |          0|          0|
       IP-CHR-D   |          0|          0|IP-FRM-D   |          0|          0|
       IP-CHR-V   |          0|          0|IP-FRM-V   |          0|          0|
       IP-CHR-C   |          0|          0|IP-FRM-C   |          0|          0|
       ------------------------------------------------------------------------
       Errors
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       BAD-SRC    |          0|           |NO-SERV    |          0|           |
       ------------------------------------------------------------------------
       Special counters for extended mode
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CLI-TOUT   |          0|           |CLI-REMAP  |          0|           |
       V-CHR-NOPT |          0|          0|D-FRM-ENC  |          0|          0|
       V-CHR-OPT  |          0|          0|V-FRM-ENC  |          0|          0|
       V-SAVED%   |          0|          0|C-FRM-ENC  |          0|          0|
       V-FRM-OPT  |          0|          0|           |           |           |
       -----------|--DATA IN--|-VOICE-IN--|-CHECK IN--|-----------------------|
       MISSING    |          0|          0|          0|
       TOUT       |          0|          0|          0|
       NOBUF      |          0|          0|          0|
       OUT-SEQ    |          0|          0|          0|
       REORDERED  |          0|          0|          0|
       BAD-FORM   |          0|          0|           |
       RESYNC     |          0|          0|          0|
       ------------------------------------------------------------------------
       -- Time arrival variation of voice frames after reordering (msec.) -----
       ------------------------------------------------------------------------
            0- 20 |          0 (   0% )   |   151-200 |          0 (   0% )   |
           21- 50 |          0 (   0% )   |   201-300 |          0 (   0% )   |
           51-100 |          0 (   0% )   |   301-600 |          0 (   0% )   |
          101-150 |          0 (   0% )   |   601-xxx |          0 (   0% )   |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the PLINKE ports

STATE: | Current overall state of the PLINKE paths
 | READY, DOWN, ONE-READY

It shows the current overall state of the PLINKE paths. This state is a result of PATHSTATE: and PATHSTATE2:.

State | Meaning | Values shown in:
 |  | System Log | Debug Log | Display LCD
DOWN | None of the path is working | not used | not used | DN
READY | All the configured paths (1 or 2) are working | not used | not used | RD
ONE-READY | Only one of the configured paths (1 or 2) are working | not used | not used | OR
ERR | Software error, contact Abilis assistance. | not used | not used | NA

MODE: | Current working mode of PLINKE driver
 | STD, EXT, EXT-SERVER, EXT-CLIENT

It shows the current working mode of PLINKE driver:

Token | Working Mode
STD | Standard mode.
EXT | Extended mode.
EXT-SERVER | Extended-server mode.
EXT-CLIENT | Extended-client mode.

PATHS: | Current state of Double-path variant
 | SINGLE, DOUBLE

It shows the current state of Double-path variant.

The "SINGLE" value means that Double-path variant is not active and statistics fields related to second path will not displayed in this case. The "DOUBLE" value means Double-path variant is activated.

PATHSTATE: | Current state of the path #1
 | READY, DOWN, READY-W, N/U

It shows the current state of the path #1:

Value | Meanning
READY | Registration to UDP successful. For EXT-SERVER CLI-IP must also be known and not timed out.
DOWN | Registration to UDP failed. For EXT-SERVER also when CLI-IP is not known yet.
READY-W | Path is active, but activity time-out occurred. Resets to READY state as soon as a new frame is received from client, or falls to DOWN after a frame was sent out to CLIENT during READY-W and no frames back arrived with 15 seconds. Only for Extended-server mode.
N/U | The path is unused. Because of the current implementation this can occur only for path #2.

CUR-REM: | Path #1 real client's remote IP address and port (Only for MODE:EXT-SERVER)
 | see below

This field display real client's remote IP address and UDP port, used to send datagrams to the extended-client for path #1.

The IP adress range is shwon in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

The UDP port value range is [1..65535].

TOUT: | Seconds remaining to path #1 map timeout (Only for MODE:EXT-SERVER)
 | 0-65355

This counter shows the amount of seconds remaining to path #1 map timeout.

PATHSTATE2: | Current state of the path #2 (Only for MODE:EXT-SERVER and PATH:DOUBLE)

It shows the current state of the path #2:

Value | Meanning
READY | Registration to UDP successful. For EXT-SERVER CLI-IP must also be known and not timed out.
DOWN | Registration to UDP failed. For EXT-SERVER also when CLI-IP is not known yet.
READY-W | Path is active, but activity time-out occurred. Resets to READY state as soon as a new frame is received from client, or falls to DOWN after a frame was sent out to CLIENT during READY-W and no frames back arrived with 15 seconds. Only for Extended-server mode.
N/U | The path is unused.

CUR-REM2: | Path #2 real client's remote IP address and port (Only for MODE:EXT-SERVER and PATH:DOUBLE)

This field display real client's remote IP address and UDP port, used to send datagrams to the extended-client for path #2.

The IP adress range is shwon in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

The UDP port value range is [1..65535].

TOUT2: | Seconds remaining to path #2 map timeout (Only for MODE:EXT-SERVER and PATH:DOUBLE)

This counter shows the amount of seconds remaining to path #2 map timeout.

CHR: | Number of received/sent characters from/to UDP
 | 0 - 4.294.967.295

The counter CHR (INPUT) is incremented every time a frame is received. The counter CHR (OUTPUT) is incremented every time a frame is sent.

CHR-D: | Number of received/sent DATA characters from/to UDP
 | 0 - 4.294.967.295

The counter CHR-D (INPUT) is incremented every time a DATA frame is received. The counter CHR-D (OUTPUT) is incremented every time a DATA frame is sent.

CHR-V: | Number of received/sent VOICE characters
 | 0 - 4.294.967.295

The counter CHR-V (INPUT) is incremented every time a VOICE frame is received. The counter CHR-V (OUTPUT) is incremented every time a VOICE frame is sent.

CHR-C: | Number of received/sent LINK-CHECK characters from/to UDP
 | 0 - 4.294.967.295

The counter CHR-C (INPUT) is incremented every time a LINK-CHECK frame is received. The counter CHR-C (OUTPUT) is incremented every time a LINK-CHECK frame is sent.

FRM: | Number of received/sent frame from/to UDP
 | 0 - 4.294.967.295

The counter FRM (INPUT) is incremented every time a frame is received. The counter FRM (OUTPUT) is incremented every time a frame is sent.

FRM-D: | Number of received/sent DATA frames from/to UDP
 | 0 - 4.294.967.295

The counter FRM-D (INPUT) is incremented every time a DATA frame is received. The counter FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

FRM-V: | Number of received/sent VOICE frames from/to UDP
 | 0 - 4.294.967.295

The counter FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

FRM-C: | Number of received/sent LINK-CHECK frames from/to UDP
 | 0 - 4.294.967.295

The counter FRM-C (INPUT) is incremented every time a LINK-CHECK frame is received. The counter FRM-C (OUTPUT) is incremented every time a LINK-CHECK frame is sent.

IP-CHR | Total number of incoming/outgoing IP characters
 | 0 - 4.294.967.295

The counter IP-CHR (INPUT) is incremented every time a frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.
The counter IP-CHR (OUTPUT) is incremented every time a frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.

IP-CHR-D | Total number of incoming/outgoing DATA characters
 | 0 - 4.294.967.295

The counter IP-CHR-D (INPUT) is incremented every time a DATA frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.
The counter IP-CHR-D (OUTPUT) is incremented every time a DATA frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.

IP-CHR-V | Total number of incoming/outgoing VOICE characters
 | 0 - 4.294.967.295

The counter IP-CHR-V (INPUT) is incremented every time a VOICE frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.
The counter IP-CHR-V (OUTPUT) is incremented every time a VOICE frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.

IP-CHR-C | Total number of incoming/outgoing LINK-CHECK characters
 | 0 - 4.294.967.295

The counter IP-CHR-C (INPUT) is incremented every time a LINK-CHECK frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.
The counter IP-CHR-C (OUTPUT) is incremented every time a LINK-CHEK frame is received from UDP. The actual IP count is computed by adding the IP/UDP overhead (28 bytes) for each frame.

IP-FRM | Total number of incoming frames from UDP
 | 0 - 4.294.967.295

The counter IP-FRM (INPUT) is incremented every time a frame is received. The counter IP-FRM (OUTPUT) is incremented every time a frame is sent.

IP-FRM-D | Total number of received/sent DATA frames
 | 0 - 4.294.967.295

The counter IP-FRM-D (INPUT) is incremented every time a DATA frame is received. The counter IP-FRM-D (OUTPUT) is incremented every time a DATA frame is sent.

IP-FRM-V | Total number of received/sent VOICE frames
 | 0 - 4.294.967.295

The counter IP-FRM-V (INPUT) is incremented every time a VOICE frame is received. The counter IP-FRM-V (OUTPUT) is incremented every time a VOICE frame is sent.

IP-FRM-C | Total number of received/sent LINK-CHECK frames
 | 0 - 4.294.967.295

The counter IP-FRM-C (INPUT) is incremented every time a LINK-CHECK frame is received. The counter IP-FRM-C (OUTPUT) is incremented every time a LINK-CHECK frame is sent.

LONG-D: | Number of too long DATA frames received/sent
 | 0 - 4.294.967.295

The counter LONG-D (INPUT) is incremented every time the DATA frame received by the lower level is too long. The counter LONG-D (OUTPUT) is incremented if the DATA frame received by the upper layer is too long.

LONG-V: | Number of too long VOICE frames received/sent
 | 0 - 4.294.967.295

The counter LONG-V (INPUT) is incremented every time the VOICE frame received by the lower level is too long. The counter LONG-V (OUTPUT) is incremented if the VOICE frame received by the upper layer is too long.

LONG-C: | Number of too long LINK-CHECK frames received/sent
 | 0 - 4.294.967.295

The counter LONG-C (INPUT) is incremented every time the LINK-CHECK frame received by the lower level is too long. The counter LONG-C (OUTPUT) is incremented if the LINK-CHECK frame received by the upper layer is too long.

LOST-D: | Number of DATA frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-D (INPUT) is incremented every time a DATA frame is discarded because there are no available receiving buffers.

LOST-V: | Number of VOICE frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-V (INPUT) is incremented every time a VOICE frame is discarded because there are no available receiving buffers.

LOST-C: | Number of LINK-CHECK frames sent and lost
 | 0 - 4.294.967.295

The counter LOST-C (INPUT) is incremented every time a LINK-CHECK frame is discarded because there are no available receiving buffers.

BAD-SRC: | Number of received frames with bad IP address or wrong UDP source port
 | 0 - 4.294.967.295

The counter BAD-SRC (INPUT) is incremented every time a frame is received with bad remote IP address or wrong UDP source port (if remote IP address and UDP source port from received UDP datagram don't match remote IP address and remote UDP port from config).

NO-SERV: | Number of frames discarded owing to service unavailability
 | 0 - 4.294.967.295

If the parameter MPX: is set to "YES", VOICE, DATA and LINK-CHECK multiplexing service is enabled.

If the parameter MPX: is set to "NO", only DATA multiplexing service is enabled.

The counter NO-SERV (INPUT) is incremented every time the received frame has format corresponding to the disabled type of the service.

CLI-TOUT | Number of downs of client side, detected on server side
 | 0 - 4.294.967.295

This counter shows the umber of downs of client side, detected on server side.

CLI-REMAP | Number of immediate IP address/UDP port remapping during a valid map
 | 0 - 4.294.967.295

If the SERVER knows a real remote IP address and UDP port of the CLIENT, it is in the valid map state. If the SERVER receives a valid datagram with the remote IP address and UDP port which one don't correspond to the previous values, the counter CLI-REMAP will be incremented.

V-CHR-NOPT |
 | 0 - 4.294.967.295

.

D-FRM-ENC | Number of incoming/outgoing encapsulated DATA frames from/to UDP
 | 0 - 4.294.967.295

Number of received/sent frames containing more than one DATA frame. The counter D-FRM-ENC is incremented every time a frame, containing more than one DATA encapsulated frames, is received (INPUT) or sent (OUTPUT).

V-CHR-OPT |
 | 0 - 4.294.967.295

.

V-FRM-ENC | Number of incoming/outgoing encapsulated VOICE frames from/to UDP
 | 0 - 4.294.967.295

Number of received/sent frames containing more than one VOICE frame. The counter V-FRM-ENC is incremented every time a frame, containing more than one VOICE encapsulated frames, is received (INPUT) or sent (OUTPUT).

V-SAVED% |
 | 0 - 4.294.967.295

.

C-FRM-ENC |
 | 0 - 4.294.967.295

.

V-FRM-OPT | Number of frames received/sent that carry more than one VOICE channel
 | 0 - 4.294.967.295

Number of VOICE frames received/sent that carry more than one encapsulated VOICE frames. The counter V-FRM-OPT is incremented every time a frame, containing more than one VOICE encapsulated frames, is received (INPUT) or sent (OUTPUT).

MISSING | Number of missing DATA/VOICE/LINK-CHECK frames when time-out expired
 | 0 - 4.294.967.295

Number of missing DATA/VOICE/LINK-CHECK frames when time-outs V-TOUT: (for the VOICE frames) and D-TOUT: (for the DATA frames) are expired (see also OUT-SEQ and REORDERED statistics).

TOUT | Number of lost DATA/VOICE/LINK-CHECK frames
 | 0 - 4.294.967.295

Number of lost DATA/VOICE/LINK-CHECK frames. Time-outs V-TOUT: (for the VOICE frames) and D-TOUT: (for the DATA frames) are expired and queued DATA or VOICE frames must be sent to the upper layer but a sequence number of the first ready frame is not expected in sequence (some frames was missed).

NOBUF | Number of extended lost DATA/VOICE/LINK-CHECK frames in the extended working mode
 | 0 - 4.294.967.295

This counter shows the number of DATA/VOICE/LINK-CHECK frames lost during the extended working mode. Receiving buffer could be full or the frame out of sequence.

OUT-SEQ | Number of OUT-OF-SEQ DATA/VOICE/LINK-CHECK frames received after time-out
 | 0 - 4.294.967.295

This counter shows the number of DATA/VOICE/LINK-CHECK frames received after time-outs V-TOUT: (for the VOICE frames) and D-TOUT: (for the DATA frames) are expired (see also REORDERED statistics).

REORDERED | Number of DATA/VOICE/LINK-CHECK frames out of sequence before time-out expired
 | 0 - 4.294.967.295

Number of DATA/VOICE/LINK-CHECK frames out of sequence before time-outs V-TOUT: (for the VOICE frames) and D-TOUT: (for the DATA frames) are expired (see also OUT-SEQ statistics).

BAD-FORM | Number of incoming encapsulated DATA/VOICE frames with bad structure
 | 0 - 4.294.967.295

The counter BAD-FORM is incremented every time a frame, containing more than one DATA or VOICE frames, is received with a bad format.

RESYNC | Number of resync DATA/VOICE/LINK-CHECK requests
 | 0 - 4.294.967.295

The number of resync requests from remote peer. Remote peer restarted with the re-synchronization of the sequence number of the DATA or VOICE or LINK-CHECK frames. The sequence number of the DATA/VOICE/LINK-CHECK packet made a very large jump. Normally sequence numbers are incremented at one every time a frame is sent by remote peer.

0- 20 | Number of frames received in time delay of 0-20 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
21- 50 | Number of frames received in time delay of 21-50 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
51-100 | Number of frames received in time delay of 51-100 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
101-150 | Number of frames received in time delay of 101-150 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
151-200 | Number of frames received in time delay of 151-200 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
201-300 | Number of frames received in time delay of 201-300 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
301-600 | Number of frames received in time delay of 301-6000 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)
601-xxx | Number of frames received in time delay > then 601 milliseconds
 | 0 - 4.294.967.295 (0 - 100%)


The SIMULATOR (SIM) ports

The SIMULATOR ports (SIM)

Configuration of the Sim ports
Statistics of the simulator ports

The SIMULATOR ports are virtual ports used within Abilis CPX in order to generate data traffic. A SIMULATOR port can be considered like a data traffic source with an high throughput at the Connection Oriented Router level.

Beyond supplying data generation, the SIMULATOR port can moreover carry out a comparison between data transmitted and received ones, in order to detect eventual errors. At the end, it provides a segmentation and packets concatenation control, carried out through the use of the M-bit (in case of ports that have different packet size).

The main scope for which the SIMULATOR ports have been introduced is to carry out "stress tests" in order to estimate performances and reliability of Abilis CPX.

As an example, they could be used for one of the following scopes:

  • To generate a bidirectional data flow at very high frequency between X25 ports on the number of wished logical channels;

  • To generate a bidirectional data flow at very high frequency between PAD ports in order to carry out verifications on the performances and the mechanism of flow control;

  • To generate a bidirectional data flow pseudo-casual in order to carry out a control on the compression adapter;

  • To generate a bidirectional data flow at very high frequency in order to test efficiency and reliability of external but compatible equipment with Abilis CPX.

The simpler use of the SIMULATOR ports is to generate traffic on two X25 ports, externally connected by modem or a "null-modem" cable. The SIMULATOR port is configured to activate a prefixed equal number of bidirectional SVC channels, subdivided in equal parts in "calling" channels and "called" channels.

Calls generated by the "calling" channels on the SIMULATOR ports are re-directed by the Connection Oriented Router through the X25 ports again on the same SIMULATOR port, where they are accepted from the "called" channels. Once the connection is established data exchange can start:

Connections between different SIM ports can be also established on same Abilis CPX or different Abilis CPX: it is sufficient to configure the necessary number of channels BSVC, the number of calls to generate and to use on both ports the same configuration for the parameters regarding the type of data generated, the packet size to send and to receive, the eventual control of sequences concatenated by the M-bit.

Configuration of the SIMULATOR port top

The SIMULATOR port is labelled within the Abilis CPX with the acronym "SIM" and it is provided with the parameters described in this section.

Here is an example on how to show the SIM port parameters. Shown values are the default ones.

[15:43:20] ABILIS_CPX: D P PO:920

PO:920 ------------------------------------------------------------------------
SIM    TYPE:USER     MCAU:NO   ps:2048  bsvc:10   CALL:0
       DATA:HEX      CMP:NO    DLY:0    DT:0      MCHK:YES
       IPADD:000.000.000.000   IPFRM:128
       IPMIN:001.001.001.001   IPMAX:001.001.001.001
       THRPUT:65535  BURST:NO  TXBURST:500

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialization command INIT PO:.

Detail of the SIMULATOR port parameters

TYPE: | Port type
USER | USER

This parameter sets how the port behaves if data compression is activated.

The port connected to the X.25 network is defined NETWORK port; the one connected to the user device USER port.

The NETWORK port sends compressed data and expands the received ones; the USER port compresses the received data and sends the expanded ones.

The SIM can be only a USER port.

MCAU: | Cause code modification in CLEAR packets sent
NO | YES, NO

It affects only X.25 communications.

If MCAU is set to NO, Abilis CPX transports, without any changes, the cause and diagnostic code of the CLEAR packets; it also uses the F0 cause code and the suitable diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, Abilis CPX forces the cause code of the CLEAR packet sent to the value 00 (DTE originated), for the external CLEAR and the internal ones.

warning! The changes made on this parameter are immediately activated, without the need of initialization.

PS: | Maximum packet size (bytes)
2048 | 16, 32, 64, 128, 256, 512, 1024, 2048

It sets the maximum size of packet to be sent and received. If frame longer than the fixed value is received, the connection will be closed with the code F1:A0.

BSVC: | Number of BSVC connections
0 | 0 - 254

This parameter set the number of BSVC channels configured.

CALL: | Number of calls to be placed
0 | 0 - BSVC

It sets the number of calls to be placed. This value can be modified while the Abilis CPX is working without the need to restart it. To activate the new value it is needed to execute the command INIT PO:. Current calls will be terminate with codes F1:A5 and successively the new specified number of calls will be placed.

DATA: | Data type sent/received
RND | NO, RND, ALPHA, HEX, IP

It sets the type of data generate by the SIM port.

Value | Meaning
NO | No data are generated, once the connection is established
RND | Random sequences of characters (length set in the parameter PS:) are generated
ALPHA | Sequences of always the same alphanumeric characters (high case letters from 'A' to 'Z' and digits from '0' to '9') and fixed length (parameter PS:) are generated
HEX | Sequences of always the same hexadecimal digits (from 0x00 to 0xFF) and fixed length (parameter PS:) are generated
IP | Generation of IP frame datagram (length set in the parameter PS:)

CMP: | Comparison between data sent and received
 | NO, YES

Activation of comparison between data sent and received.

If the comparison is not successful the connection will be closed with the codes F1:A3.

DLY: | Delay between a call and its successive one
0 | 0 - 255 seconds

It sets the time delay between a call and its successive one.

Value "0" stands for "no delay" between the calls.

DT: | Disconnection Time-out
0 | 0 - 65535 seconds

It sets how long a connection can be up, after this time interval it will be teared down.

Value "0" stands for indefinite period, that is connection is never teared down.

This time-out is the same for all the connections.

Connection are teared down, after the time-out elapses, with codes F1:A4.

MCHK: | M-bit control
YES | NO, YES

It permits to activate the control on the sequences of the packets linked by M-bit.

If a too long sequence of the packets linked by M-bit is received, connection are teared down with codes F1:A4.

If a too short sequence of the packets linked by M-bit is received, connection are teared down with codes F1:A2.

IPADD: | SIM port IP address
0.0.0.0 | 0 - 255.255.255.255

It sets the SIM port IP address.

IPMIN: | Lowest IP address to generate
1.1.1.1 | 0 - 255.255.255.255

It sets the lowest IP address to generate.

IPMAX: | Highest IP address to generate
1.1.1.1 | 0 - 255.255.255.255

It sets the highest IP address to generate.

IPFRM: | Maximum length (in bytes) of the IP frame
128 | 20 - 155

It sets the maximum length (in bytes) of the IP frame to manage.

THRPUT: | Requested throughput for each channel
65535 | 1 - 65535 packets per second

It sets the traffic throughput ( packets per second) to generate on each channel. If the requested throughput exceeds the actual transmission capacity, the effective throughput will be the maximum value actually allowed.

BURST: | Burst activation
NO | NO, YES

It activates the burst generation on channels.

If it is set to "NO", traffic is homogeneously generated during the whole connection.

If the parameter is set to "YES", traffic generation will be maximally concentrated on the time interval specified by the parameter TXBURST: and it will be suspended in order to not exceed the requested throughput (parameter BURST:).

TXBURST: | BURST duration
500 | 100 - 65535 (in milliseconds)

It sets the burst duration. This parameter is used only if the parameter BURST: is set to "YES".

Statistics of the simulator ports top

How to check the state and statistics of the SIM ports by the command D S.

[15:43:20] ABILIS_CPX: D S PO:920

PO:920 STATE:UP
SIM    -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |0          |0          |
       PCK        |0          |0          |PPS        |0          |0          |
       CPS        |0          |0          |
       ------------------------------------------------------------------------

The PLINKE ports has not extended statistics so that the execution of the command D SE will display again the not extended statistics by the following format:

[15:43:20] ABILIS_CPX: D SE PO:920

PO:920 --- Cleared 000:05:01:38 ago, at 20/05/1999 18:20:45 -------------------
SIM    -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |0          |0          |CHAR       |0          |0          |
       PCK        |0          |0          |PPS        |0          |0          |
       CPS        |0          |0          |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date, time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of the state fields and statistics of the SIMULATOR ports

STATE: | Current state of the SIM ports
 | UP

It shows the current state of the SIM port driver.

Driver | States | Meaning | Value shown in:
 |  |  | System Log | Debug Log | Display LCD
SIM | UP | The port is active. By being a virtual port, it is always active |  |  | UP

SEG: | Number of received/sent segments
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the SIM port receives data. The counter SEG (OUTPUT) is incremented every time data are sent.

Segments are obtained dividing the number of bytes by 64.

CHAR: | Number of received/sent characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time data are received by the SIM port. The counter CHAR (OUTPUT) is incremented every time data are sent.

PCK: | Number of received/sent packets
 | 0 - 4.294.967.295

The counter PCK (INPUT) is incremented every time a data packet is received by the SIM port. The counter PCK (OUTPUT) is incremented every time a data packet is sent.

PPS: | Number of packets received/sent per second
 | 0 - 4.294.967.295

The counter PPS (INPUT) shows the number of packets received during the last 5 seconds of activity. The counter PPS (OUTPUT) shows the number of packets sent during the last 5 seconds of activity.

The shown value is an integer: it is always rounded down.

CPS: | Number of characters received/sent per second
 | 0 - 4.294.967.295

The counter CPS (INPUT) shows the number of characters received during the last 5 seconds of activity. The counter CPS (OUTPUT) shows the number of characters during the last 5 seconds of activity.

The shown value is an integer: it is always rounded down.


The DUMMY ports

Configuration of the DUMMY ports
Statistics of the DUMMY ports

The DUMMY ports are virtual ports, used within the Abilis CPX to transfer data from a given communication port to another one.

All the received by a given port data are transmitted without changes or losses to the other port.

The DUMMY port behaves like a real communication port; it is able to open bidirectional switched connections and to make communicate ports with different packet size.

In the following figure two logical channels VC1 and VC2 are represented. They are connected to each other (through a "null-modem" cable or DTE-DCE connection) as if they belong to two different ports.

two logical channels VC1 and VC2

Configuration of the DUMMY ports top

The DUMMY port has got the configuration parameter described in this section.

Here is an example on how to display the DUMMY port parameters. Shown values are the default ones.

[11:32:37] ABILIS_CPX: D P PO:DUMMY

PO:910 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
DUMMY  ------------------------------------------------------------------------
       TYPE:USER     MCAU:NO   ps:2048  bsvc:0

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the DUMMY port parameters

TYPE: | Port type
USER | NETWORK, USER

This parameter set how the port has to behave if data compression is active.

it is needed to refer as NETWORK the port connected to the X25 network and as USER the one connected to the user equipment.

The NETWORK port sends compressed data and expands the received ones, the USER port compresses the received data and transmits the expanded ones.

Any configuration error of this parameter will cause the virtual channel to be cleared in the same moment data are transmitted.

If the user equipment detects the error, it will generate the X25 diagnostics code, while if the Abilis CPX will detect it, it will close the virtual channel using the diagnostics and cause codes F0,C2 (expansion error), or F0,C3 (Compressed data format not valid), or F0,AA (Compression protocol not compatible).

MCAU: | Modifies of the cause code of the CLEAR packets sent
NO | YES, NO

If MCAU is set to NO, the Abilis CPX will accurately transmit the diagnostic and cause codes of the CLEAR packets and it will use the F0 code and the proper diagnostic one for all the CLEAR packets internally generated.

If MCAU is set to YES, the Abilis CPX will force to the value 00 (DTE originated) the cause code of all the CLEAR packets sent, whether they are internal or external.

warning! Changes made on this parameter are immediately active.

PS: | Maximum packet size (in bytes)
2048 | 16, 32, 64, 128, 256, 512, 1024, 2048 (in bytes)

It sets the maximum size of packets to be sent or received.

BSVC: | Number of bidirectional switched connections
0 | 0 - 254

The parameter set the number of bidirectional switched channels configured.

Statistics of the DUMMY ports top

The following example shows how to display state and statistics of DUMMY ports through the command D S:

[17:55:06] ABILIS_CPX: D S PO:dummy

PO:921 ------------------------------------------------------------------------
DUMMY  STATE:UP
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       ------------------------------------------------------------------------

The following example shows how to display extended statistics of DUMMY ports through the command D SE:

[17:55:06] ABILIS_CPX: D SE PO:dummy

PO:921 ------------------------------------------------------------------------
DUMMY  --- Cleared 000:00:06:55 ago, on 12/05/2004 at 17:49:21 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Detail of the state field and statistics of the DUMMY ports

STATE: | Current state of the DUMMY port
 | UP

It shows the actual state of the DUMMY port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Events Log | Display LCD
DUMMY | UP | Port is active. Being a virtual port, the DUMMY port is always active |  |  | UP

SEG: | Number of sent/received segments
 | 0 - 4.294.967.295

The counter SEG (INPUT) is incremented every time the DUMMY port receives data. Similarly the SEG (OUTPUT) one every time data are sent.

Segments are obtained by dividing the number of bytes by 64.

CHAR: | Number of sent/received characters
 | 0 - 4.294.967.295

The counter CHAR (INPUT) is incremented every time the DUMMY port receives characters. Similarly the CHAR (OUTPUT) one every time characters are sent.


The Secure Socket Layer Port (SSL)

Terminology

Configuration of the Secure Socket Layer Port (SSL)
Statistics of the Secure Socket Layer Port (SSL)

The Secure Sockets Layer (SSL) protocol is a security protocol that provides privacy over the Internet.
It is designed to provide privacy between client/server applications.

SSL requires a reliable transport protocol (e.g.TCP) for data transmission and reception.
The advantage of the SSL Protocol is that it is application protocol independent. A "higher level" application protocol (e.g. HTTP, FTP, TELNET, etc.) can layer on top of the SSL protocol transparently.
The SSL Protocol can negotiate an encryption algorithm and session key as well as authenticate a server before the application protocol transmits or receives its first byte of data.
All of the application protocol data is transmitted encrypted, ensuring privacy.

The SSL protocol provides "channel security" which has three basic properties:

  • The channel is private. Encryption is used for all messages after a simple handshake is used to define a secret key.
  • The channel is authenticated. The server endpoint of the conversation is always authenticated, while the client endpoint is optionally authenticated.
  • The channel is reliable. The message transport includes a message integrity check (using a MAC).

Terminology top

Application Protocol
An application protocol is a protocol that normally layers directly on top of TCP/IP. For example: HTTP, TELNET, FTP, and SMTP.
Authentication
Authentication is the ability of one entity to determine the identity of another entity. Identity is defined by this document to mean the binding between a public key and a name and the implicit ownership of the corresponding private key.
Bulk Cipher
This term is used to describe a cryptographic technique with certain performance properties. Bulk ciphers are used when large quantities of data are to be encrypted/decrypted in a timely manner. Examples include RC2, RC4, and IDEA.
Client
In this document client refers to the application entity that is initiates a connection to a server.
CLIENT-READ-KEY
The session key that the client uses to initialize the client read cipher. This key has the same value as the SERVER-WRITE-KEY.
CLIENT-WRITE-KEY
The session key that the client uses to initialize the client write cipher. This key has the same value as the SERVER-WRITE-KEY.
MASTER-KEY
The master key that the client and server use for all session keys generation. The CLIENT-READ-KEY, CLIENT-WRITE-KEY, SERVER-WRITE-KEY and SERVER-WRITE-KEY are generated from the MASTER-KEY.
MD2
MD2 is a hashing function that converts an arbitrarily long data stream into a digest of fixed size. This function predates MD5, which is viewed as a more robust hash function.
MD5
MD5 is a hashing function that converts an arbitrarily long data stream into a digest of fixed size. The function has certain properties that make it useful for security, the most important of which is it is inability to be reversed.
Nonce
A randomly generated value used to defeat "playback" attacks. One party randomly generates a nonce and sends it to the other party. The receiver encrypts it using the agreed upon secret key and returns it to the sender. Because the nonce was randomly generated by the sender this defeats playback attacks because the replayer can't know in advance the nonce the sender will generate. The receiver denies connections that do not have the correctly encrypted nonce.
Non-repudiable Information Exchange
When two entities exchange information it is sometimes valuable to have a record of the communication that is non-repudiable. Neither party can then deny that the information exchange occurred. Version 2 of the SSL protocol does not support Non-repudiable information exchange.
Public Key Encryption
Public key encryption is a technique that leverages asymmetric ciphers. A public key system consists of two keys: a public key and a private key. Messages encrypted with the public key can only be decrypted with the associated private key. Conversely, messages encrypted with the private key can only be decrypted with the public key. Public key encryption tends to be extremely compute intensive and so is not suitable as a bulk cipher.
Privacy
Privacy is the ability of two entities to communicate without fear of eavesdropping. Privacy is often implemented by encrypting the communications stream between the two entities.
RC2, RC4
Proprietary bulk ciphers invented by RSA. RC2 is block cipher and RC4 is a stream cipher.
Server
The server is the application entity that responds to requests for connections from clients. The server is passive, waiting for requests from clients.
Session cipher
A session cipher is a bulk cipher that is capable of encrypting or decrypting arbitrarily large amounts of data. Session ciphers are used primarily for performance reasons. The session ciphers used by this protocol are symmetric. Symmetric ciphers have the property of using a single key for encryption and decryption.
Session identifier
A session identifier is a random value generated by a client that identifies itself to a particular server. The session identifier can be thought of as a handle that both parties use to access a recorded secret key (in our case a session key). If both parties remember the session identifier then the implication is that the secret key is already known and need not be negotiated.
Session key
The key to the session cipher. In SSL there are four keys that are called session keys: CLIENT-READ-KEY, CLIENT-WRITE-KEY, SERVER-READ-KEY, and SERVER-WRITE-KEY.
SERVER-READ-KEY
The session key that the server uses to initialize the server read cipher. This key has the same value as the CLIENT-WRITE-KEY.
SERVER-WRITE-KEY
The session key that the server uses to initialize the server write cipher. This key has the same value as the CLIENT-READ-KEY.
Symmetric Cipher
A symmetric cipher has the property that the same key can be used for decryption and encryption. An asymmetric cipher does not have this behavior. Some examples of symmetric ciphers: IDEA, RC2, RC4.
SSL 2.0
Secure Sockets Layer (SSL) protocol version 2.0.
SSL 3.0
Secure Sockets Layer (SSL) protocol version 3.0.
TLS
Transport Layer Security (TLS) protocol.

Configuration of the Secure Socket Layer Port (SSL) top

The Secure Socket Layer (SSL) ports is identified by the mnemonic "SSL" and it is provided with the parameters described in this section.

Here are examples on how to display the SSL port parameters. Displayed values are the defaults ones:

[11:47:16] ABILIS_CPX: D P PO:SSL

PO:917 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
SSL    ------------------------------------------------------------------------
       LOG:NO        ACT:NO            max-cli:0           max-srv:4
       mpxs:2048     SEND-TOUT:20      CACH-TOUT:300       AUTH-CLI:NO
       PWDKEY-CLI:DFT                  PWDKEY-SRV:DFT
       CERT-PATH:SYS (C:\1506\)

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the SSL port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ACT: | Runtime activation/deactivation of SSL
NO | NO, YES

This parameter allows to run-time activate/deactive SSL functionalities.

When it is set to "YES:", the port is configured, active, and the SSL driver performs its activities.

When it is set to "NO", the port is configured, active, but the SSL driver does not execute any action.

max-cli: | Number of SSL clients
0 | 0..100

This parameter sets the number of SSL clients.

max-srv: | Number of SSL servers
4 | 0..100

This parameter sets the number of SSL servers.

mxps: | Maximum length of SSL packet
2048 | 2048..4096 (bytes)

This parameter sets the maximum length of SSL packet (in bytes).

SEND-TOUT: | Send time-out for SSL handshake protocol
20 | 10..600 (sec.)

This parameter specifies sending inactivity time-out for SSL handshake protocol (in seconds). On time-out expiration, a SSL connection will be forced to close.

CACH-TOUT: | SSL Session cache time out
300 | 60..7200 (sec.)

This parameter specifies how long a used SSL session will be cached (in seconds).

AUTH-CLI: | Enable/disable authentication of SSL client
NO | NO, YES

This parameter enables/disables the authentication of SSL client.
When it is set to "YES", the SSL server authenticates SSL client by sending certificate message request.

PWDKEY-CLI: | Password for decoding encrypted private RSA key file of SSL client
DFT | from 4 up to 64 ASCII extended characters [32..255], DFT

This parameter sets the password for decoding encrypted private RSA key file of SSL client.

Accepted values are strings from 4 up to 64 ASCII extended characters in the range [33..255]. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "may key"). The case of the entered string is preserved.

The "DFT" value corresponds to select to decode default key files provided by Abilis.

PWDKEY-SRV: | Password for decoding encrypted private RSA key file of SSL server
DFT | from 4 up to 64 ASCII extended characters [32..255], DFT

This parameter sets the password for decoding encrypted private RSA key file of SSL server.

Accepted values are strings from 4 up to 64 ASCII extended characters in the range [33..255]. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "may key"). The case of the entered string is preserved.

The "DFT" value corresponds to select to decode default key files provided by Abilis.

CERT-PATH: | Directory where SSL certificate and key files are stored
SYS | from 1 up to 128 ASCII extended characters [32..255], SYS

This parameter selects the directory where SSL certificate and key files are stored.

The "SYS" value corresponds to select the current system working directory.

Alternatively the user can enters the physical full path of another directory in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Accepted values are strings of up to 128 ASCII extended characters in the range [32..255]. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\"). The case of the entered string is preserved.

Statistics of the Secure Socket Layer Port (SSL) top

Example on how to show state and statistics of the SSL port through the command D S:

[11:10:58] ABILIS_CPX: D S PO:SSL

PO:917 ------------------------------------------------------------------------
SSL    STATE:INACTIVE         MAX-SRV:4               MAX-CLI:0
       ------------------------------------------------------------------------
       -----------------------+---CHAN----+-CHAN-EST--+-CHAN-PEAK-+-SESS-CACH-|
       SERVER                 |0          |0          |0          |0          |
       CLIENT                 |0          |0          |0          |0          |
       ------------------------------------------------------------------------
       -----------------------+--HNDSHK---+-HNDSHK-OK-+----HIT----+--SESS-TO--|
       SERVER                 |0          |0          |0          |0          |
       CLIENT                 |0          |0          |0          |0          |
       ------------------------------------------------------------------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|PCK        |          0|          0|
       LONG       |          0|          0|BAD        |          0|           |
       ------------------------------------------------------------------------
       - Channels -------------------------------------------------------------
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |CH |MODE|    STATE    |  CHAR-IN  |  PCK-IN   | CHAR-OUT  |  PCK-OUT  |
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |  1|SRV |INACT        |          0|          0|          0|          0|
       |  2|SRV |INACT        |          0|          0|          0|          0|
       |  3|SRV |INACT        |          0|          0|          0|          0|
       |  4|SRV |INACT        |          0|          0|          0|          0|
       +---+----+-------------+-----------*-----------+-----------+-----------+

Example on how to show extended statistics of the SSL port through the command D SE:

[11:11:13] ABILIS_CPX: D SE PO:SSL

PO:917 ------------------------------------------------------------------------
SSL    --- Cleared 000:01:17:37 ago, on 25/03/2004 at 09:54:16 ----------------
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |CH |MODE|    STATE    |  CHAR-IN  |  PCK-IN   | CHAR-OUT  |  PCK-OUT  |
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |  1|SRV |INACT        |          0|          0|          0|          0|
       |  2|SRV |INACT        |          0|          0|          0|          0|
       |  3|SRV |INACT        |          0|          0|          0|          0|
       |  4|SRV |INACT        |          0|          0|          0|          0|
       +---+----+-------------+-----------*-----------+-----------+-----------+

It also possible to inspect extended statistics of the single SSL channel, by executing the command "D SE PO:xxx CH:yyy", where "xxx" is the SSSL port number and the "yyy" is a value in the range [1..100] corresponding to the channel identifier.

[11:13:55] ABILIS_CPX: D SE PO:917 CH:3

PO:917 ------------------------------------------------------------------------
SSL    --- Cleared 000:01:21:03 ago, on 25/03/2004 at 09:54:15 ----------------
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |CH |MODE|    STATE    |  CHAR-IN  |  PCK-IN   | CHAR-OUT  |  PCK-OUT  |
       +---+----+-------------+-----------+-----------+-----------+-----------+
       |  3|SRV |INACT        |          0|          0|          0|          0|
       +---+----+-------------+-----------*-----------+-----------+-----------+

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Details of the state fields and statistics of the SSL port

STATE: | Current state of the SSL port
 | INACTIVE, ACTIVE, ERR

It shows the current state of the SSL port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
SSL | INACTIVE | SSL port is running, but the ACT: parameter is set to "NO". |  |  | dn
 | ACTIVE | SSL port is fully ready to work. |  |  | RD
 | ERR | Software error. Contact Abilis CPX assistance. |  |  | NA

MAX-SRV: | Maximum number of SSL server channels
 | 0 - 100

It shows how many SSL server channels can be served simultaneously, that is given by the number configured in the max-srv: parameter.

MAX-CLI: | Maximum number of SSL client channels
 | 0 - 100

It shows how many SSL client channels can be served simultaneously, that is given by the number configured in the max-cli: parameter.

CHAN | Number of SSL server/client channels which are connected
 | 0 - 4.294.967.295

It shows the number of SSL server/client channels which are currently connected, even not established.

CHAN-EST | Number of connected and established SSL server/client channels
 | 0 - 4.294.967.295

It shows the number of SSL server/client channels which are currently connected, AND established.

CHAN-PEAK | Maximum number of SSL server/client channels that went connected simultaneously
 | 0 - 4.294.967.295

It shows the peak value of SSL server/client channels that went connected at the same time, including those not established. This counter is currently the maximum value ever reached by CHAN counter.

SESS-CACH | Number of SSL server/client sessions currently cached
 | 0 - 4.294.967.295

It shows number of SSL server/client sessions currently cached after using.

HNDSHK | Total number of new SSL server/client connections
 | 0 - 4.294.967.295

The SERVER counter is incremented every time any SSL server channel receives first SSL handshake protocol packet from peer client.

The CLIENT counter is incremented every time any SSL client channel initiates SSL handshake protocol.

HNDSHK-OK | Total number of SSL successful server/client connections
 | 0 - 4.294.967.295

The SERVER counter is incremented every time any SSL server channel receives first SSL handshake protocol packet from peer client and SSL session is successfully established.

The CLIENT counter is incremented every time any SSL client channel initiates SSL handshake protocol and SSL session is successfully established.

HIT | Total number of reused SSL server/client sessions
 | 0 - 4.294.967.295

The SERVER counter is incremented every time any SSL server channel reuses SSL session from cache.

The CLIENT counter is incremented every time any SSL client channel reuses SSL session from cache.

SESS-TO | Total number of time-out expired cached server/client sessions
 | 0 - 4.294.967.295

The SERVER counter is incremented every time when time-out of cached server session is expired and session is removed from cache.

The CLIENT counter is incremented every time when time-out of cached client session is expired and session is removed from cache.

CHR | Total number of characters received/sent by all SSL channels from/to TCP
 | 0 - 4.294.967.295

The INPUT counter is incremented every time any SSL channel receives a packet from TCP.

The OUTPUT counter is incremented every time any SSL channel sends a packet to TCP.

PCK | Total Number of packets received/sent by all SSL channels from/to TCP
 | 0 - 4.294.967.295

The INPUT counter is incremented every time any SSL channel receives a packet from TCP.

The OUTPUT counter is incremented every time any SSL channel sends a packet to TCP.

LONG | Total number of incoming/outgoing SSL packets too long
 | 0 - 4.294.967.295

The INPUT counter is incremented every time any SSL channel receives a too long packet from TCP.

The OUPUT counter is incremented every time any SSL channel tries to send a too long packet to TCP.

BAD | Total number of incoming/outgoing SSL packets which have bad format
 | 0 - 4.294.967.295

The INPUT counter is incremented every time any SSL channel receives a packet with bad format.

Details of the state fields and statistics of the SSL channel

CH | SSL channel identifier
 | 0 - (max-cli: + max-srv:)

It represents the channel identifier. The maximum number of the available channels is given by the number of SSL Server processes (configuration parameter max-srv:) summed to the number of SSL Client ones (configuration parameter max-cli:).

MODE | SSL channel working mode
 | SRV, CLI

It shows the type of the process active on the channel: the "SRV" abbreviation identifies the SSL Server process, while the "CLI" abbreviation identifies the SSL Client process.

STATE | SSL channel working state
 | see table below

It shows the current state of the SSL channel.

States | Description
DOWN | SSL channel is in down state.
INACT | SSL channel is in inactive state. ACT parameter is set to "NO".
STOPPED | SSL channel is stopped. Only SERVER channels can be in this state. It means that SSL server X509 certificate and/or private RSA key file are bad, not loaded or private key is not corresponded public key from X509 certificate.
READY | SSL channel is ready to work.
CLOSING | SSL channel is in a closing state.
W-S-HELLO | SSL client channel is in a handshake protocol state. Channel awaits SERVER-HELLO message from SSL server.
W-S-VERIFY | SSL client channel is in a handshake protocol state. Channel awaits SERVER-VERIFY message from SSL server.
W-S-FINISHED | SSL client channel is in a handshake protocol state. Channel awaits SERVER-FINISHED or REQUEST-CERTIFICATE messages from SSL server.
W-C-HELLO | SSL server channel is in a handshake protocol state. Channel awaits CLIENT-HELLO message from SSL client.
W-C-M-KEY | SSL server channel is in a handshake protocol state. Channel awaits CLIENT-MASTER-KEY message from SSL client.
W-C-CERT | SSL server channel is in a handshake protocol state. Channel awaits CLIENT-CERTIFICATE message from SSL client.
W-C-FINISHED | SSL server channel is in a handshake protocol state. Channel awaits CLIENT-FINISHED message from SSL client.
ESTABLISHED | SSL connection is established.

CHAR-IN | Number of characters received by SSL channel from TCP, since the SSL connection was started
 | 0 - 4.294.967.295

The CHAR-IN counter is incremented every time a packet is received from TCP.

PCK-IN | Number of SSL packets received by SSL channel from TCP, since the SSL connection was started
 | 0 - 4.294.967.295

The PCK-IN counter is incremented every time a packet is received from TCP.

CHAR-OUT | Number of characters sent by SSL channel to TCP, since the SSL connection was started
 | 0 - 4.294.967.295

The CHAR-OUT counter is incremented every time a packet is sent to TCP.

PCK-OUT | Number of SSL packets sent by SSL channel to TCP, since the SSL connection was started
 | 0 - 4.294.967.295

The PCK-OUT counter is incremented every time a packet is sent to TCP.


The IEEE BRIDGE port

Configuration of the BRIDGE port
Statistics of the BRIDGE port
SNMP TRAPS generated for BRIDGE ports

BRIDGE is a module that introduces bridging functionalities in Abilis CPX. In this version it allows bridging of IEEE 802.3 frames only and only between pre-configured MAC addresses (future versions may allow bridging of any Ethernet types as well as other LAN frames (e.g. 802.5). Furthermore MAC addresses self-learning and spanning tree protocol could be added.

The main goal of the Abilis CPX BRIDGE driver is to provide a quick and reliable solution for customers with simple network topology, typically a star topology, who need to transport SNA 802.2/802.3 traffic through an IP backbone, with an alternative method to the much more complicated DLSw.

The Abilis CPX BRIDGE driver is however not limited to an IP backbone, it may use ANY backbone protocol supported in Abilis CPX through the ML/MLM drivers.
Three formats of the bridged packets can be selected:

  1. Abilis proprietary with a low overhead fragmentation technique
  2. ANSI, as per T1.618a
  3. ANSI with fragmentation, as per T1.618a

Bridging is not a complete replacement for DLSw, but under some circumstances it can fully satisfy user needs:

  1. The traffic is only LAN-to-LAN (in cpx limited to Ethernet 802.3 LANs)
  2. The traffic, considering the acknowledgments overhead, remains "reasonably small". This has an impact on performances but also on "costs" if the transport network is paid by the volume of exchanged data.
  3. The transport network is reliable (small packet loss) and offers low delays, usually smaller than SNA IEEE 802.2 protocol timeouts.
  4. The topology of the SNA connections is of star type, i.e. from branch offices to central site. Although mesh topology is still possible, the deployment of large configurations will be cumbersome and error prone because of the huge amount of links that will be configured and the possibility of loops in the paths.

Configuration of the BRIDGE port top

The BRIDGE port is labelled within the Abilis CPX with the acronym "BRIDGE" and it is provided with the parameters described in this section.

Here is an example on how to show the BRIDGE parameters. Shown values are examples.

[15:42:35] ABILIS_CPX:D P PO:BRIDGE

PO:170 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
BRIDGE ------------------------------------------------------------------------
       LOG:ALL+E     ACT:YES    LOWPO:58           MODE:STAR    LAN-PROT:IEEE
       L-MAC:*                                     M-MAC:#
       SAP:*                                       RXPADREMOVE:YES
       - Links ----------------------------------------------------------------
       Lnk:1   ST:RUNNING   LOWPO:NONE       ENC:ABILIS     FRAGSIZE:800
               RXQUEUE:10   TXQUEUE:30
               R-MAC:
       ------------------------------------------------------------------------
       Lnk:3   ST:RUNNING   LOWPO:503        ENC:ABILIS     FRAGSIZE:800
               RXQUEUE:10   TXQUEUE:30
               R-MAC:
       ------------------------------------------------------------------------
       Lnk:4   ST:NEW       LOWPO:504        ENC:ABILIS     FRAGSIZE:800
               RXQUEUE:10   TXQUEUE:30
               R-MAC: 00-40-F4-0A-AF-35  00-C0-CA-14-3D-8E  02-01-01-01-01-04
                      02-01-01-01-01-FF
       ------------------------------------------------------------------------

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on high case parameters it is enough to execute the initialization command INIT PO:xxx, where "xxx" is the BRIDGE port number.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed and/or restarted.

There is also the possibility to restart the port. Restarting a port means to reinitialize it like at start-up.
When a port is restarted, ALL the parameters are reloaded. In order to restart the BRIDGE port, the command is R PO:xxx, where "xxx" is the BRIDGE port number.

Detail of the BRIDGE port parameter

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

ACT: | BRIDGE activation
NO | NO, YES

It activates the BRIDGE functionalities above mentioned. If the parameter is set to "NO", even if the BRIDGE port is configured and active, it won't carry out any functionality within the system.

LOWPO: | Identifier of the Abilis CPX lower ETH100 port
NONE | NONE, TYPE-XXX

It sets the Abilis CPX lower level port. It can only be an ETH100 port.

Value "NONE" isolates the BRIDGE port from CPX lower ethernet-100 port.

MODE: | Behaviour of frames exchange among LAN and Links
STAR | STAR, MESH

Indicates which is the behaviour used by BRIDGE upon receiving frames:

  • STAR: BRIDGE port works in "star" mode, that is data traffic can take place only between LAN and LinkS, and not between LINK and LINK.
    Broadcasts received from a link are sent only to the LAN, while broadcasts received from LAN are "copied" to all the links.
  • MESH: BRIDGE port works in "mesh" mode, that is data traffic can take place between LAN and LinkS, and also between LINK and LINK.
    Broadcasts received from LAN are "copied" to all the links, as in "star" mode, but broadcasts received from a link are sent to the LAN and to all the other LINKS.
LAN-PROT: | Bridging protocol frames
IEEE | IEEE

Selects if bridging is allowed only for IEEE frames or for ALL Ethernet frames types.
Currently BRIDGE allows traffic on only IEEE frames.

L-MAC: | Local MAC addresses accepted
* | #, *, ListName

It is used as a filter to determine which frames can be accepted from ETH100 port.

  • * BRIDGE accepts frames from ETH100 from ANY source MAC addresses.
  • # BRIDGE doesn't accept any frame because no list is configured.
  • listname BRIDGE accepts frames from ETH100 only if the source MAC address is present in the <listname> list of MAC addresses. BRIDGE increment a counter for frames that are discarded because of this filter (L-MAC-DENY).
M-MAC: | Multicast MAC addresses
# | #, ListName

This list is used to indicate to ETH100 which multicast can be received by BRIDGE.

  • # BRIDGE doesn't accept any MULTICAST frame because list is not configured.
  • listname BRIDGE accepts MULTICAST frames from ETH100 only if the source MAC address is present in the <listname> list of MULTICAST MAC addresses.
SAP: | Filter on SAP
* | #, *, 00..FF, 'ListName'

This is a filter in order to allow specific SAP value. Filter as applied for both source and destination SAP.

  • * BRIDGE accepts frames with ANY SAP value.
  • # BRIDGE doesn't accept any frame because no SAP list nor SAP value is configured.
  • value BRIDGE accept only frames with SAP <value> configured.
  • listname BRIDGE accepts frames only if the SAP is present in the <listname> list of SAP values.
RXPADREMOVE: | Remove padding in frames received from LAN
* | NO, YES

This parameter allow to activate/deactivate padding removal in frames received from LAN.

Lnk: | Link identifier
 | 1 - 256

It identifies the LINK where the parameters refers to.

ST: | Link State
DELETED | NEW, DELETED, RUNNING

Status of the LINK configuration.

NEW: LINK is added in BRIDGE configuration, but it is not yet operative (BRIDGE needs to be restarted).

DELETED: LINK is removed from BRIDGE configuration, but it is still present into BRIDGE port, even if no more used (BRIDGE needs to be restarted to completely remove it from memory).

RUNNING: LINK is present in configuration and working. This is the only status where BRIDGE can send/receive datagrams on this LINK.

LOWPO: | Lower link port
NONE | NONE, TYPE-XXX

Identifier of the lower Abilis CPX port used by the link.
It defines the Link port of the lower level, which can only be MLM or ML type.
If no Link port is required, the value "NONE" must be set.

ENC: | Encapsulation method
ABILIS | ABILIS, ANSI, ANSI-FRAG

Indicates the type of encapsulation performed on the LINK port.

  • ABILIS Abilis proprietary protocol is used, which have fragmentation capabilities always active.
  • ANSI Ethernet frame is encapsulated according to ANSI T1.617a annex F,
  • ANSI-FRAG Ethernet frame is encapsulated according to ANSI T1.617a annex F, multiprotocol encapsulation over frame relay, with fragmentation specified in chapter F.5.3, without the T.618 address.
FRAGSIZE: | Maximum length of fragments
800 | 32 - 1518

Defines the length of the sent fragment, for those encapsulations that provide fragmentation. The parameter regulates only "sent frames", while BRIDGE must always be ready to receive fragments of any size.

RXQUEUE: | Receive queue size
10 - 255 | 10

Defines the size, in kbytes, of the receive queue of the link.
Frames received from the link and destined to the lan are "parked" in this queue.
Frame received from the link and destined to another link (MESH mode) are directly put into the link TX queue, without transiting through the link rx buffers.

TXQUEUE: | Transmit queue size
10 - 255 | 30

Defines the size, in kbytes, of the transmit queue of the link.
Frames destined to the link are "parked" in this queue, regardless is they are received from LAN or from another LINK.

R-MAC: | Remote MAC address
<empty> | 00-00-00-00-00-00 - FF-FF-FF-FF-FF-FF

List of remote MACs present to the other side of the link.
This information is very important because is used to indicate to ETH100 port which MAC addresses are allowed to be received.

Statistics of the BRIDGE port top

Example on how to show state and statistics of BRIDGE ports through the command D S:

[12:35:43] ABILIS_CPX: D S PO:BRIDGE

PO:170 ------------------------------------------------------------------------
BRIDGE STATE:READY               LINKs:SOME-READY          DOWN:0
       ------------------------------------------------------------------------
       Lan:1     ST:READY        DOWN:0
       Lnk:1     ST:DOWN1        DOWN:0
       Lnk:2     ST:DOWN1        DOWN:0
       Lnk:3     ST:READY        DOWN:0
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|FRM        |          0|          0|
       ERROR      |          0|          0|
       ------------------------------------------------------------------------

Example on how to show extended statistics of BRIDGE ports through the command D SE:

[14:22:12] ABILIS_CPX: D SE PO:BRIDGE

PO:170 ------------------------------------------------------------------------
BRIDGE --- Cleared 000:00:00:00 ago, on 20/07/2004 at 14:22:17 ----------------
       - Lan   1 -|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|          0|FRM        |          0|          0|
       LONG       |          0|           |SHORT      |          0|           |
       L-MAC-DENY |          0|           |R-MAC-DENY |          0|           |
       SAP-DENY   |          0|           |NODEST     |          0|           |
       - Lnk   1 -|-----------|-----------|-----------|-----------|-----------|
       CHR        |          0|          0|FRM        |          0|          0|
       LONG       |          0|           |SHORT      |          0|           |
       L-MAC-DENY |          0|           |R-MAC-DENY |          0|           |
       SAP-DENY   |          0|           |NODEST     |          0|           |
       NOBUF      |          0|          0|BAD-FMT    |          0|           |
       BAD-FRAG   |          0|           |
       - Lnk   2 -|-----------|-----------|-----------|-----------|-----------|
       CHR        |          0|          0|FRM        |          0|          0|
       LONG       |          0|           |SHORT      |          0|           |
       L-MAC-DENY |          0|           |R-MAC-DENY |          0|           |
       SAP-DENY   |          0|           |NODEST     |          0|           |
       NOBUF      |          0|          0|BAD-FMT    |          0|           |
       BAD-FRAG   |          0|           |
       - Lnk   3 -|-----------|-----------|-----------|-----------|-----------|
       CHR        |          0|          0|FRM        |          0|          0|
       LONG       |          0|           |SHORT      |          0|           |
       L-MAC-DENY |          0|           |R-MAC-DENY |          0|           |
       SAP-DENY   |          0|           |NODEST     |          0|           |
       NOBUF      |          0|          0|BAD-FMT    |          0|           |
       BAD-FRAG   |          0|           |
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the time interval elapsesed from the last reset of statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Detail of statistics of BRIDGE ports

STATE: | Current state of the BRIDGE port
 | DOWN, READY, ERR

It shows the current state of the BRIDGE port.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
BRIDGE | DOWN | The BRIDGE port driver is down. | dn
 | READY | The BRIDGE port driver is ready. | RD
 | ERR | Software error, contact Abilis assistance | NA

LINKs: | Current global state of links of BRIDGE port
 | ALL-DOWN, ALL-READY, SOME-READY, NO-LINKS

Indicates the current global state of links of BRIDGE port drvers.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
BRIDGE Links | ALL-DOWN | All links of the BRIDGE port driver are down. | dn
 | ALL-READY | All links of the BRIDGE port driver are ready. | rd
 | SOME-READY | Some links of the BRIDGE port driver are ready. | RD
 | NO-LINKs | No links are avaiable for the BRIDGE port driver. | np
 | ERR | Software error, contact Abilis assistance | NA

DOWN: | Number of times that BRIDGE went into DOWN state
 | 0 - 4294967295

This counter shows the total number of times that BRIDGE went into DOWN state from a READY state.

Lan: | LAN identifier
 | 1 - 256

Identifier used to specify to which LAN of the BRIDGE port driver, diagnostic informations refer to.

ST: | Current LAN state
 | NONE, LINK-NP, LINK-ERR, DOWN1, READY, UNDEFINED

Indicates th current sate of a specific LAN of the BRIDGE port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
BRIDGE Lan | NONE | Link doesn't exists. | dn
 | LINK-NP | Down state: unable to establish the connection. | np
 | LINK-ERR | Down state: unable to establish the connection. | dn
 | DOWN1 | Down state: lower layer is DOWN. | DN
 | READY | Channel is ready. | RD
 | UNDEFINED | State undefined. | dn
 | ERR | Software error, contact Abilis assistance | NA

DOWN: | Number of times that a LAN went into DOWN1 state
 | 0 - 4294967295

This counter shows the total number of times that a LAN of the BRIDGE port driver went into DOWN1 state.

Lnk: | Link identifier
 | 1 - 256

Identifier used to specify to which Link of the BRIDGE port driver, diagnostic informations refer to.

ST: | Current Link state
 | NONE, LINK-NP, LINK-ERR, DOWN1, READY, UNDEFINED

Indicates th current sate of a specific Link of the BRIDGE port driver.

Driver | States | Meaning | Values shown in:
 |  |  | System Log | Debug Log | Display LCD
BRIDGE Link | NONE | Link doesn't exists. | dn
 | LINK-NP | Down state: unable to establish the connection. | np
 | LINK-ERR | Down state: unable to establish the connection. | dn
 | DOWN1 | Down state: lower layer is DOWN. | DN
 | READY | Channel is ready. | RD
 | UNDEFINED | State undefined. | dn
 | ERR | Software error, contact Abilis assistance | NA

DOWN: | Number of times that a Link went into DOWN1 state
 | 0 - 4294967295

This counter shows the total number of times that a Link of the BRIDGE port driver went into DOWN1 state.

CHR: | Number of received/sent characters
 | 0 - 4294967295

The counter CHR (INPUT) is incremented every time a frame is received from every LAN and Link.
The counter CHR (OUTPUT) is incremented every time a frame is sent to every LAN and Link.
This counter is the sum of the CHR specific statistics of LAN and of the CHR specific statistics of Link present into BRIDGE.
The counter is incremented for every frame by the amount of characters present into it.

FRM: | Number of received/sent frame
 | 0 - 4294967295

The counter FRM (INPUT) is incremented every time a frame is received from every LAN and Link.
The counter FRM (OUTPUT) is incremented every time a frame is sent to every LAN and Link.
This counter is the sum of the FRM specific statistics of LAN and of the FRM specific statistics of Link present into BRIDGE.

ERROR: | Number of errors received/sent
 | 0 - 4294967295

This counter has a sum of all the errors counted into specific statistics for LAN and Link.

Detail of statistics of LAN of BRIDGE ports

CHR | Number of received/sent characters
 | 0 - 4294967295

The counter CHR (INPUT) is incremented every time a frame is received from the specific LAN.
The counter CHR (OUTPUT) is incremented every time a frame is sent to the specific LAN.
The counter is incremented for every frame by the amount of characters present into it.

FRM | Number of received/sent frames
 | 0 - 4294967295

The counter FRM (INPUT) is incremented every time a frame is received from the specific LAN.
The counter FRM (OUTPUT) is incremented every time a frame is sent to the specific LAN.

LONG | Number of frames received and lost due to length
 | 0 - 4294967295

This counter is incremented for every frame received and lost due to length greater than allowed size.

SHORT | Number of frames received and lost due to length
 | 0 - 4294967295

This counter is incremented for every frame received and lost due to length smalled than minimum size required to analyse the frame.

L-MAC-DENY | Number of frames discarded to LOCAL MAC filter
 | 0 - 4294967295

This counter is incremented for every frame received from ETH100 port with a MAC address not present (for more details see L-MAC:).

R-MAC-DENY | Number of frames LOST due to MAC filtering
 | 0 - 4294967295

This counter is incremented for every frame received from a LAN and its source MAC address is not present into R-MAC: list.
This is a filter used to avoid traffic possible only in a single direction.

SAP-DENY | Number of frames LOST due to SAP filter
 | 0 - 4294967295

This counter is incremented every time a frame received from LAN contains a SAP value that is not allowed to be received due to SAP filter (for more details see SAP:).

NODEST | Number of frames LOST due to a MAC address destination unknown
 | 0 - 4294967295

This counter is incremented every time a frame is received from LAN and BRIDGE has no information about where to send that frame.

Detail of statistics of Link of BRIDGE ports

CHR | Number of received/sent characters
 | 0 - 4294967295

The counter CHR (INPUT) is incremented every time a frame is received from the specific Link.
The counter CHR (OUTPUT) is incremented every time a frame is sent to the specific Link.
The counter is incremented for every frame by the amount of characters present into it.

FRM | Number of received/sent frames
 | 0 - 4294967295

The counter FRM (INPUT) is incremented every time a frame is received from the specific Link.
The counter FRM (OUTPUT) is incremented every time a frame is sent to the specific Link.

LONG | Number of frames received and lost due to length
 | 0 - 4294967295

This counter is incremented for every frame received and lost due to length greater than allowed size.

SHORT | Number of frames received and lost due to length
 | 0 - 4294967295

This counter is incremented for every frame received and lost due to length smalled than minimum size required to analyse the frame.

L-MAC-DENY | Number of frames discarded to LOCAL MAC filter
 | 0 - 4294967295

This counter is incremented for every frame received from ETH100 port with a MAC address not present (for more details see L-MAC:).

R-MAC-DENY | Number of frames LOST due to MAC filtering
 | 0 - 4294967295

This counter is incremented for every frame received from a Link and its source MAC address is not present into R-MAC: list.
This is a filter used to avoid traffic possible only in a single direction.

SAP-DENY | Number of frames LOST due to SAP filter
 | 0 - 4294967295

This counter is incremented every time a frame received from Link contains a SAP value that is not allowed to be received due to SAP filter (for more details see SAP:).

NODEST | Number of frames LOST due to a MAC address destination unknown
 | 0 - 4294967295

This counter is incremented every time a frame is received from Link and BRIDGE has no information about where to send that frame.

NOBUF: | Frames lost due to a receiving/sending queue full
 | 0 - 4294967295

This counter is incremented every time the use of queues is required and no space is available to store frames.
The counter NOBUF (INPUT) is incremented every time a frame is received from a Link and receiving queue is full.
The counter NOBUF (OUTPUT) is incremented every time a frame is sent to a Link and sending queue is full.

BAD-FMT: | Frames lost due to a frame bad format
 | 0 - 4294967295

This counter is incremented every time the frame format is different from expected.
It could be due also to a misconfiguration of ENC protocols between 2 links.

BAD-FRAG: | Error during fragmentation/reassemply phase
 | 0 - 4294967295

The counter BAD-FRAG (INPUT) is incremented every time there is a missing fragment when reassembly whole datagram.
The counter BAD-FRAG (OUTPUT) is incremented every time is needed a frame fragmentation and ENC: parameter doesn't allow it.

SNMP TRAPS generated for BRIDGE ports top

The SNMP Agent of Abilis CPX is able to generate traps owing to meaningful state changes pertinent either to the BRIDGE port itself and to LANs and to Links of the BRIDGE port driver.

SNMP traps generated for global state changes pertinent to all Links of the BRIDGE port

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for BRIDGE ports.

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
66 | cxTrapBdgDown | cxPortIndex, cxPortType, cxBdgDiagState, cxBdgDiagLinksState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the BRIDGE port currently running goes to DOWN state.
67 | cxTrapBdgReady | cxPortIndex, cxPortType, cxBdgDiagState, cxBdgDiagLinksState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the BRIDGE port currently running goes to READY state.
68 | cxTrapBdgAllLinksDown | cxPortIndex, cxPortType, cxBdgDiagState, cxBdgDiagLinksState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time all links of the BRIDGE port currently running are in DOWN state.

SNMP traps generated for state changes pertinent to LANs of the BRIDGE port

The traps listed below are generated when at least the "T" options are set in the LOG: parameter, corresponding to the basic SNMP traps generation functionality provided for BRIDGE ports.

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
69 | cxTrapBdgLanDown | cxPortIndex, cxPortType, cxBdgDiagLanIndex, cxBdgDiagLanState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the LAN of the BRIDGE port currently running goes to DOWN state.
70 | cxTrapBdgLanReady | cxPortIndex, cxPortType, cxBdgDiagLanIndex, cxBdgDiagLanState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time the LAN of the BRIDGE port currently running goes to READY state.

SNMP traps generated for a single Link of the BRIDGE port

The traps listed below are generated only when the "T+E" options are set in the LOG: parameter, i.e. it is required an extension of the basic SNMP traps generation functionality.

Trap own code | Mnemonic of the trap | SNMP variables shown in the trap | Description
71 | cxTrapBdgLinkDown | cxPortIndex, cxPortType, cxBdgDiagLinkIndex, cxBdgDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a LINK of the BRIDGE port currently running goes to DOWN state.
72 | cxTrapBdgLinkReady | cxPortIndex, cxPortType, cxBdgDiagLinkIndex, cxBdgDiagLinkState, sysUpTime | The SNMP Agent of the Abilis CPX generates this kind of trap every time a LINK of the BRIDGE port currently running goes to READY state.

Detail of the SNMP variables shown in the BRIDGE port traps

cxPortIndex | BRIDGE port which the SNMP trap refers to
 | 0 - 999

This variable stores the CPX port number, which the SNMP trap refers to.

cxPortType | Type and description of the BRIDGE port, which the trap refers to
 | type - description

This variable shows either the port type which the trap refers to (in this case BRIDGE) and the description eventually associated to it.

cxBdgDiagState | Current state of the BRIDGE port driver, which the trap refers to
 | down(0), ready(1)

This variable shows the current state of the BRIDGE port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the BRIDGE driver
down(0) | DOWN
ready(1) | READY

cxBdgDiagLinksState | Current global state for Links of BRIDGE port driver, which the trap refers to
 | all_down(0), some_ready(1), all_ready(2), no_links(3)

This variable shows the current global state for Links of BRIDGE port driver which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the BRIDGE driver
all_down(0) | ALL-DOWN
some_ready(1) | SOME-READY
all_ready(2) | ALL-READY
no_links(3) | NO-LINKs

cxBdgDiagLanIndex | Index of the BRIDGE port LAN, which the trap refers to
 | 1 - 256

This variable shows the index of the BRIDGE port LAN which the trap refers to.

cxBdgDiagLanState | Current state of the BRIDGE port LAN, which the trap refers to
 | none(0), link_not_present(1), link_error(2), down1(3), ready(4), undefined(5)

This variable shows the current state of the LAN of the BRIDGE port, which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the LAN
none(0) | NONE
link_not_present(1) | LINK-NP
link_error(2) | LINK-ERR
down1(3) | DOWN1
ready(4) | READY
undefined(5) | UNDEFINED

cxBdgDiagLinkIndex | Index of the BRIDGE port LINK, which the trap refers to
 | 1 - 256

This variable shows the index of the BRIDGE port LINK which the trap refers to.

cxBdgDiagLinkState | Current state of the BRIDGE port LINK, which the trap refers to
 | none(0), link_not_present(1), link_error(2), down1(3), ready(4), undefined(5)

This variable shows the current state of the Link of the BRIDGE port, which the trap refers to. The following table shows the relationship among the state value stored in the SNMP variable and the ones obtained executing the command D S.

Value of the SNMP variable | Correspondent state of the Link
none(0) | NONE
link_not_present(1) | LINK-NP
link_error(2) | LINK-ERR
down1(3) | DOWN1
ready(4) | READY
undefined(5) | UNDEFINED

sysUpTime | Elapsed time from the system start to the event occurrence
 | 0 - 4.294.967.295 or "ddd:hh:mm:ss"

This variable stores the elapsed time (in cent of second) from the system start to the SNMP trap event occurrence.

This value is usually shown by the format days:hours:minutes:seconds.


Synchronous Adapters

HSCB Gold
"Piggy-back" interface modules
HSCB Silver
ESB
Adapting cables for HSCB Gold/Silver and ESB

Other adapters

HSCB Gold adapter top

The HSCB Gold adapter provides all of the following services:

  • 2 synchronous ports (up to 2,5Mbit/sec)
  • 2 housings for the RS232/V24, V35, X21, MAN/V11 piggy back interface modules
  • 1 socket for the data compressor processor
  • 2 sockets for 30 pin SIMM RAM for the data compressor
  • ISA bus

In each Abilis CPX it is possible to plug in only one HSCB Gold adapter.

Hscb gold
Figure 6. HSCB Gold adapter.

Table 2. HSCB Gold, jumper JP1.
chassis not connected with interface signal ground | op
chassis connected with interface signal ground | CL

Table 3. HSCB Gold, jumpers JP2 e JP5.
number of HSCB | JP2 |  |  | Base address | JP5
 | 4 | 2 | 1 |  | 2 | 1
HSCB #0 | op | op | op | disabled adapter | op | op
HSCB #1 | op | op | CL | 0xE000 ('486) | CL | op
HSCB #2 | op | CL | op | 0xD000 (Pentium) | op | CL
HSCB #3 | op | CL | CL | 0xC000 | CL | CL
HSCB #4 | CL | op | op |
HSCB #5 | CL | op | CL
HSCB #6 | CL | CL | op
HSCB #7 | CL | CL | CL

The JP4 jumpers block selects the IRQ level used by the communication chip (ESCC).

For selecting the given IRQ level, install the jumper in the proper position (a-b).

In the newest version of this adapter the "c " line has been removed to avoid mistakes.

The JP3 jumper block makes possible to direct an IRQ level from the ESCC to the DCP, by changing the proper jumper position from the b-c to the a-b one. Actually the DCP driver doesn't use the IRQ signal, so jumpers must be kept in the position b-c. In the newest models, jumpers have been replaced by welded wires

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

"Piggy-back" interface modules for HSCB and ESB

Each port can support the requested interface module: V24, V35, X2, MAN-V11.

Piggyback interface modules for HSCB
Figure 7. HSCB, modules V24, V35, X21 and Manchester/V11.

Depending on the chosen interface and DCE/DTE modality, it is needed to use the suitable cable, as the following table shows.

Table 4. Cable codes.
DTE V24 | DTE V35 | DTE X21 | DCE V24 | DCE V35 | DCE X21 | MAN/V11
000124 | 000135 | 000121 | 000224 | 000235 | 000221 | ---

User must insert or extract very carefully the interface modules, without forcing excessively.
Modules have two different size connectors, user must pay attention to insert them in the proper sockets.

If the module is wrongly inserted, the module itself and the adapter will be damaged.

HSCB Silver adapter top

The HSCB Silver adapter provides all of the following services:

  • 2 synchronous ports (up to 2,5Mbit/sec)
  • 2 housings for the RS232/V24, V35, X21, MAN/V11 piggy back interface modules
  • In each Abilis CPX it is possible to plug in up to7 HSCB Silver adapter plus 1 HSCB Gold, or 8 HSCB Silver.
  • ISA bus

HSCB Silver
Figure 8. HSCB Silver adapter.

Table 9. HSCB Silver, jumper JP1.
chassis not connected with interface signal ground | op
chassis connected with interface signal ground | CL

Table 10. HSCB Silver, jumpers JP2 and JP5
number of HSCB | JP2 |  |  | Base address | JP5
 | 4 | 2 | 1 |  | 2 | 1
HSCB #1 | op | op | op | disabled adapter | op | op
HSCB #2 | op | op | CL | 0xE000 ('486) | CL | op
HSCB #3 | op | CL | op | 0xD000 (Pentium) | op | CL
HSCB #4 | op | CL | CL | 0xC000 | CL | CL
HSCB #5 | CL | op | op |
HSCB #6 | CL | op | CL
HSCB #7 | CL | CL | op
HSCB #8 | CL | CL | CL

The JP4 jumpers block selects the IRQ level used by the communication chip (ESCC).

For selecting the given IRQ level, install the jumper in the proper position (a-b).

In the newest version of this adapter the "c" line has been removed to avoid errors.

The HSCB Silver adapter makes possible to select the IRQ12 (10 jumpers instead of 9), which is not present in the HSCB Gold one. However some old models are lacking (9 jumpers as the HSCB Gold one). The user is asked to check the presence of the IRQ12, by counting the number of present jumpers.

The HSCB Silver adapter uses the same interface modules and cables as HSCB gold.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

ESB adapter top

The ESB adapter provides all of the following services:

  • 4 synchronous ports (up to 2,5Mbit/sec, up to 10Mbit/sec if the "high speed" interface is requested)
  • 4 slots for the RS232/V24, V35, X21, piggy back interface modules
  • PCI bus

Being a PCI adapter, no jumpers/switches configuration is needed.

ESB
Figure 9. ESB adapter.

ESB2 adapter top

The ESB2 adapter provides all of the following services:

  • 4 synchronous ports (up to 2,5Mbit/sec, up to 10Mbit/sec if the "high speed" interface is requested)
  • 4 slots for the RS232/V24, V35, V11, X21, E1/G.703 piggy back interface modules
  • PCI bus

Being a PCI adapter, no jumpers/switches configuration is needed.

ESB
Figure 10. ESB2 adapter.

Adapting cables for HSCB e ESB top

V24, V35, X21 e MAN/V11 cables schemes are described in the section Connection cables.


Start-up configuration recovery

Start-up configuration recovery on MfIde equipped systems
Start-up configuration recovery on Front Panel equipped systems

Installation

The purpose of this procedure is to create a copy of configuration and Log files on floppy disk and/or to copy configuration files from floppy disk to Abilis CPX HD/CF.

Similar commands are available ether through the Control Port command-line interface (CONFLOG BACKUP and CONFLOG RESTORE) or through the Abilis CPX frontal panel, when the system is running.

NoFloppyBasedSystem The procedure is available on HD/CF based system only.

Start-up configuration recovery on MfIde equipped systems top

The procedure is activated keeping pressed the Up key during Abilis CPX system start-up (for a description of the LCD display and of function keys (Up, Down, Right, Left and OK), see The front panel of MfIde equipped systems).

The following messages are displayed:

Abilis CPX
ConfLog Utility
CONFLOG BACKUP ?
N=<Left> Y=<OK>

To start configuration and Log files backup, press OK key.

Pressing Left key it is possible to go to the next step of the procedure, i.e. configuration files restore.

CONFLOG RESTORE?
N=<Left> Y=<OK>

To start configuration files restore, press OK key.

Pressing Left key it is possible to end the procedure:

Extract last
inserted disk
<OK> to Run
<Left> to Reboot

Press Ok key to proceed with Abilis CPX software initialization.
Press Left key to restart Abilis CPX system.
Press Up key to execute the configuration recovery procedure from the beginning once again.

Configuration and Log files backup

Once the OK key is pressed, the request to insert a floppy disk in drive A: will be shown:

Insert FLP disk
and press <OK>

When ready, press OK key. The messages "CONFLOG BACKUP", "IN PROGRESS..." will be shown and Abilis CPX will copy current configuration and Log files (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG and CPX.XCP) to the floppy disk.

During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
These messages are of the following form:

CONFLOG BACKUP
FFFFFFFF ...
CONFLOG BACKUP
FFFFFFFF done
CONFLOG BACKUP
FFFFFFFF E-nn

Where:

  • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG or CPX.XCP);
  • ... signals that the operation is still in progress;
  • done signals that the operation was successfully ended;
  • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.

If the operation is successful, the messages "CONFLOG BACKUP", "EXECUTED" are shown; otherwise the messages "CONFLOG BACKUP", "ENDED WITH ERROR" will be displayed.

After the configuration and Log files backup phase completion, the next step of the procedure, i.e. configuration files restore phase is initiated:

CONFLOG RESTORE?
N=<Left> Y=<OK>

Configuration and Log files restore

Once the OK key is pressed, the request to insert a floppy disk in drive A: will be shown:

Insert FLP disk
and press <OK>

When ready, press OK key. The messages "CONFLOG RESTORE", "IN PROGRESS..." will be shown and Abilis CPX will copy configuration files (DRIVERS.CFG and DRIVERS.BCK) from the floppy disk to the HD/CF.

During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
These messages are of the following form:

CONFLOG RESTORE
FFFFFFFF ...
CONFLOG RESTORE
FFFFFFFF done
CONFLOG RESTORE
FFFFFFFF E-nn

Where:

  • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG or DRIVERS.BCK);
  • ... signals that the operation is still in progress;
  • done signals that the operation was successfully ended;
  • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.

If the operation is successful, the messages "CONFLOG RESTORE", "EXECUTED" are shown; otherwise the messages "CONFLOG RESTORE", "ENDED WITH ERROR" will be displayed.

After the configuration files restore phase completion, it possible either to make the Abilis CPX system start-up to proceed; or to make the system to be restarted; or to re-execute the procedure from the beginning.

Start-up configuration recovery on Front Panel equipped systems top

The procedure is activated keeping pressed the Select key during Abilis CPX system start-up (for a description of the LCD display and of function keys (Select and OK), see The front panel).

The following messages are displayed:

Abilis CPX
ConfLog Utility
CONFLOG BACKUP ?
N=<Select>Y=<OK>

To start configuration and Log files backup, press OK key.

Pressing Select key, it is possible to go to the next step of the procedure, i.e. configuration files restore.

CONFLOG RESTORE?
N=<Select>Y=<OK>

To start configuration files restore, press OK key.

Pressing Select key, it is possible to end the procedure:

Extract last
inserted disk
<OK>=Run
<Select>=Reboot

Press OK key, to proceed with Abilis CPX software initialization.
Press Select key, to restart Abilis CPX system.
Press OK and while keeping it pressed, press Select key too, to execute the configuration recovery procedure from the beginning once again.

Configuration and Log files backup

Press OK key, the request to insert a floppy disk in drive A: will be shown:

Insert FLP disk
and press <OK>

When ready, press OK key. The messages "CONFLOG BACKUP", "IN PROGRESS..." will be shown and Abilis CPX will copy current configuration and Log files (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG and CPX.XCP) to the floppy disk.

During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
These messages are of the following form:

CONFLOG BACKUP
FFFFFFFF ...
CONFLOG BACKUP
FFFFFFFF done
CONFLOG BACKUP
FFFFFFFF E-nn

Where:

  • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG or CPX.XCP);
  • ... signals that the operation is still in progress;
  • done signals that the operation was successfully ended;
  • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.

If the operation is successful, the messages "CONFLOG BACKUP", "EXECUTED" are shown; otherwise the messages "CONFLOG BACKUP", "ENDED WITH ERROR" will be displayed.

After the configuration and Log files backup phase completion, the next step of the procedure, i.e. configuration files restore phase is initiated:

CONFLOG RESTORE?
N=<Select>Y=<OK>

Configuration and Log files restore

Press OK key, the request to insert a floppy disk in drive A: will be shown:

Insert FLP disk
and press <OK>

When ready, press OK key. The messages "CONFLOG RESTORE", "IN PROGRESS..." will be shown and Abilis CPX will copy configuration files (DRIVERS.CFG and DRIVERS.BCK) from the floppy disk to the HD/CF.

During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
These messages are of the following form:

CONFLOG RESTORE
FFFFFFFF ...
CONFLOG RESTORE
FFFFFFFF done
CONFLOG RESTORE
FFFFFFFF E-nn

Where:

  • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG or DRIVERS.BCK);
  • ... signals that the operation is still in progress;
  • done signals that the operation was successfully ended;
  • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.

If the operation is successful, the messages "CONFLOG RESTORE", "EXECUTED" are shown; otherwise the messages "CONFLOG RESTORE", "ENDED WITH ERROR" will be displayed.

After the configuration files restore phase completion, it possible either to make the Abilis CPX system start-up to proceed; or to make the system to be restarted; or to execute the procedure from the beginning once again.


The front panel of MfIde equipped systems

Commands of the front panel
Use of the LCD display and function keys (Up, Down, Right, Left and OK)
Menus that are available on LCD display

System supervision

Commands of the front panel top

The Abilis CPX frontal panel lodges a floppy disk drive, a power switch and an MfIde2 equipment.

The MfIde2 is equipped of one LCD display, five push buttons, four leds, a Compact Flash and one Chip Card reader/writer.

The LCD Display and the indicators give information about the Abilis CPX working mode, while the push buttons provide some utility functions described.

Cpx front panel

Figure 1. Front panel.

Power - (Power switch)
If pressing the Power switch the leds do not light on, control that the power cable is working and connecting the Abilis CPX to the current tap. The user should also check whether the tap supplies the required voltage (220V). If, after executing all the previous verifications, the Abilis CPX didn't switch on, please contact the assistance.

LED 1, 2, 3, 4 - (Power and Abilis CPX works indicators)
All leds are switched on, immediately after Abilis CPX has been started through switch Power. If, after pressing the Power switch, the leds are not switched on, control that the power cable is working and connecting the Abilis CPX to the current tap. The user should also check whether the tap supplies the required voltage (220V). If, after executing all the previous verifications, the Abilis CPX didn't switch on, please contact the assistance.
The green LED 4 lightens every second, when the Abilis CPX starts to working, after the software loading phase.

Up, Down, Right, Left - (Menu selection)
Every time the button Up, is pressed, the display will show the previous menu. By pressing it a lot of times, all the menus will be shown in a cyclic way.
Every time the button Down, is pressed, the display will show the next menu. By pressing it a lot of times, all the menus will be shown in a cyclic way.
Every time the button Right, is pressed, the display will show the sub-menu.
Every time the button Left, is pressed, the display will go back to the menu.
Refer to section Use of the display and function keys (Up, Down, Right, Left and OK), for a more detailed description.

OK - (Confirmation key)
Pressing key OK it is possible to access information about the menu currently showed on the LCD display. Moreover for those menus, that requires a confirmation, by pressing the OK key, an affirmative answer will be given to the request showed on the LCD display. Refer to section Use of the display and function keys (Up, Down, Right, Left and OK), for a more detailed description.

Liquid Crystals Display.
The LCD is able to visualize two lines of sixteen alphanumeric characters. In order to allow an easy read is necessary that the environment is sufficiently illuminated. If the display is not clearly legible, it is necessary to change the observation angle, moving in horizontal and/or vertical sense.

Compact Flash.
On CF based systems, for a correct Abilis CPX working mode it is mandatory that the Compact Flash, containing the Abilis CPX software, is inserted.
Moreover it cannot be inserted/extracted while the power is on, otherwise its content will be definitively damaged. Be sure to have switched off the system before inserting/extracting the Compact Flash.

Floppy disk drive.
On Floppy based systems, for a correct Abilis CPX working mode it is mandatory that the disk, containing the Abilis CPX software, is inserted.
The inserted disk must be NOT WRITE PROTECTED, contrary Abilis CPX will start regularly, but it won't be possible to save either new configuration or log files.
The floppy disk is not write protected if the write enable "window" is closed. The floppy disk is write protected if it is opened.
On HD/CF based systems, the floppy disk can be used for configuration and Log files backup/restore operations. Refer to section System updating and restarting for more details about these features.

Use of the display and function keys (Up, Down, Right, Left and OK).

At the Abilis CPX start, the display visualizes the Messages Menu which shows on the first row the product name, on the second the software version currently in use.

The use of Up, Down, Right, Left and OK push buttons is the following:

  • Press Down: move to the next menu
  • Press Up: move to the previous menu
  • Press Right: enter the sub-menu
  • Press Left: leave the sub-menu
  • Press OK: positive answer the question that appear on the LCD.

The picture shows how to scroll the menus.

How to use the Select key for Menu chooses.

Figure 2. How to use the Down and Up keys for Menu choice.

Pressing the Right key it is possible to access sub-menus.

The picture shows how to enter and leave a sub-menu, as well as how to scroll the sub-menu.

How to use the Select and OK key for managing menus and submenus.

Figure 3. How to use the Up, Down, Right and Left keys for managing menus and sub-menus.

Menus that are available on LCD display

Messages Menu - Abilis CPX version and system messages.
The first row of the Messages Menu visualizes the system name, while the second shows informative messages about the system working mode. For example, after resources activation, during which it is visualized the software version, the message "START SYSTEM" will be shown to signal that Abilis CPX from that moment is regularly working:

The informative messages are displayed if, on the display, the Messages Menu is active. If one of the following menus is active, only eventual messages of errors or alarms will be displayed.Every time an informative message or an alarm is shown, pressing the OK key is possible to visualize again name and version of the product.

State Menu of the link level ports
This menu allows displaying the status of the link level ports. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • SSSS is the current state;
  • TTTTT is the port type.

If no Link ports are running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the protocol ports
This menu allows displaying the status of the protocol ports. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • SSSS is the current state;
  • TTTTT is the port type.

If no protocol ports are running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the VOICE ports
This menu allows displaying the status of the VOICE ports. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about twenty ports:

Where:

  • xx-xx is a port number's interval of up to four VOICE ports;
  • SSSSSSSS is the current state of the VOICE ports.

If no VOICE ports are running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the ISDN PRIMARY channels
This menu allows displaying the state of ports and ISDN primary rate channels. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown.
Each ISDN PRI port requires two pages, in the first one Level 1, Level 2 states and "Slips" are shown, in the second is shown each B-channel state.
First page:

Where:

  • Pxxx is the port number, L1L1 is the Level 1 state (EPISDN);
  • L2L2 L2L2 is the Level 2 state (EPLAPD Sapi0 and Sapi16);
  • SLIPS: xxxxxxxxxx is the number of slips detected.

Pressing the Right key, the second page will be shown:

Where:

  • "-" means that the channel 0 and the 16th are not used;
  • S is the state of each channel from the 1st one to the 15th and from 17th to the 31st one (EPQ931).

Pressing the Down key the next port will be shown.

If no ISDN-PRI (EPQ931) ports are running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the ISDN BASIC RATE channels.
This menu allows displaying the state of ISDN Basic Rate channels. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown.
Each page shows information about 4 pair of channels:

Where:

  • xxx-yyy is the considered port interval;
  • b1b2 is the current state of the pair of channels for each port.

If no ISDN-BRI (Q931/EBQ931) ports are running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Menu of compression statistics
This menu allows displaying the compression statistics of the protocol ports. Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • S:±yy is the segment compression rate;
  • B:±yy is the compression rate in bytes.

If no protocol ports type is running, the following message will be shown:

Press the Left key to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Menu of System Utilities
This menu can execute operations related to system management, such as enabling/disabling the acoustic signal, system restart or saving the Events Log (Debug Log), or the current configuration. Pressing Right key the user accesses the first page of the menu, pressing the Down key all the other pages are visualized in a cyclic way.

Enabling/disabling the acoustic alarm signal:

The purpose of this utility command is the same of the SOUND DISABLE and SOUND ENABLE commands that are available through the Control Port command-line interface.

If the signal is already enabled, the following message will be shown:

  • To accept, press OK key. The message "SOUND DISABLED" will be shown.
  • Pressing Right key, the message "ENABLE SOUND?" will be shown.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.

If the signal is already disabled, the following message will be shown:

  • To accept, press OK key. The message "SOUND ENABLED" will be shown.
  • Pressing Right key, the message "DISABLE SOUND?" will be shown.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

System restart:

The purpose of this utility command is the same of the RESTART SYSTEM command that is available through the Control Port command-line interface.

The following message will be displayed:

  • To accept, press OK key.
    Before initiating the restart procedure, the system checks whether the configuration that is currently running was changed but not saved:
    • if the configuration wasn't saved, the system doesn't restart. Instead the the configuration saving procedure reported in the section Saving the current configuration is started;
    • if the configuration wasn't changed or was already been saved, The messages "**ATTENTION! **", "RESTART SYSTEM" will be shown and Abilis CPX will initiate the system restart sequence.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Saving the Events Log (Debug Log):

The purpose of this utility command is the same of the SAVE DEBUG command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK key. The message "SAVING LOG DEBUG" will be shown and Abilis CPX will start to save on disk the Events Log (Debug Log). If the operation is successful, the message "DEBUG LOG SAVED" will be shown, otherwise "DEBUG NOT SAVED".
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Saving the current configuration:

The purpose of this utility command is the same of the SAVE CONF command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK key. The messages "SAVE CONF", "IN PROGRESS..." will be shown and Abilis CPX will save the current configuration on disk, in DRIVERS.CFG file. If the operation is successful, the messages "SAVE CONF", "EXECUTED" are shown, otherwise one of the following messages will be displayed:
    • "SAVE CONF", "FAIL phase": indicating the phase during which the saving failed ("VALIDATE", "WRITE ERR");
    • "SAVE CONF", "FAIL E.xx": indicating a fatal error occurred, "xx" is an hexadecimal value.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Creating a backup copy of the current configuration:

The purpose of this utility command is the same of the SAVE CONF BACKUP command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK key. The messages "SAVE CONF BCK", "IN PROGRESS..." will be shown and Abilis CPX will create a backup copy of the current configuration on disk, in DRIVERS.BCK file. If the operation is successful, the messages "SAVE CONF BCK", "EXECUTED" are shown, otherwise one of the following messages will be displayed:
    • "SAVE CONF BCK", "FAIL phase": indicating the phase during which the saving failed ("WRITE ERR");
    • "SAVE CONF BCK", "FAIL E.xx": indicating a fatal error occurred, "xx" is an hexadecimal value.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Creating copy of configuration and Log files on floppy disk:

The purpose of this utility command is the same of the CONFLOG BACKUP command available through the Control Port command-line interface.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The following message is displayed:

  • To accept, press OK key. The messages "CONFLOG BACKUP", "IN PROGRESS..." will be shown and Abilis CPX will copy current configuration and Log files (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG and CPX.XCP) to the floppy disk. If the operation is successful, the messages "CONFLOG BACKUP", "EXECUTED" are shown, otherwise the messages "CONFLOG BACKUP", "ENDED WITH ERROR" will be displayed.
    During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
    These messages are of the following form:

    Where:

    • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG, DRIVERS.BCK, DHCP.BND, CPX.LOG, CPX.DBG or CPX.XCP);
    • ... signals that the operation is still in progress;
    • done signals that the operation was successfully ended;
    • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Copying configuration files from floppy disk:

The purpose of this utility command is the same of the CONFLOG RESTORE command available through the Control Port command-line interface.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The following message is displayed:

  • To accept, press OK key. The messages "CONFLOG RESTORE", "IN PROGRESS..." will be shown and Abilis CPX will copy configuration files (DRIVERS.CFG and DRIVERS.BCK) from the floppy disk to the current version directory. If the operation is successful, the messages "CONFLOG RESTORE", "EXECUTED" are shown, otherwise the messages "CONFLOG RESTORE", "ENDED WITH ERROR" will be displayed.
    During the configuration and Log files copying procedure, a message is shown informing the user about the file that is going to be copied and about the result of the operation.
    These messages are of the following form:

    Where:

    • FFFFFFFF is the name of the file that is going to be processed (DRIVERS.CFG or DRIVERS.BCK);
    • ... signals that the operation is still in progress;
    • done signals that the operation was successfully ended;
    • E-nn signals that an error occurred on the file that is going to be processed, "nn" is a decimal value.
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Formatting floppy disk:

The purpose of this utility command is the same of the SYS FLPFORMAT command available through the Control Port command-line interface.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The following message is displayed:

  • To accept, press OK key. The messages "INSERT FLP DISK", "AND PRESS OK" will be shown inviting the User to insert in the floppy disk drive the floppy disk to be formatted.
    Once the disk is inserted, press OK key. The messages "FLP DISK FORMAT", "IN PROGRESS..." will signal that the formatting is started.
    If the operation is successful, the messages "FLP DISK FORMAT", "EXECUTED" are shown; otherwise the messages "FLP DISK FORMAT", "FAIL E:nn" will be displayed, to signal that an error occurred ("nn" is a decimal value).
  • Press Left key to go back to the Utility Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Menu of alarms displaying
The purpose of this menu is the same of the ALARM VIEW command available through the Control Port command-line interface.
It displays a list of those ports where an alarm event occurred. Being the alarm condition checked every 30 seconds, it is possible that 30 seconds could pass from the moment the port starts to correctly work again and to the one when the alarm event ends.

  • Pressing the Right key, it is possible to access the first page of the menu, pressing successively the Down key all the other eventual pages will be shown in a cyclic way. Each page shows information about two ports:

    Where:

    • Pxxx is the port number;
    • TTTTT is the port type.
    • SSSS is the current state; if SSSS is "----" it means the considered port is not in a alarm condition.

    If there are no ports in alarm condition, the following message will be shown:

  • Press Left key to go back to the main Menu.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Do not forget that this menu shows only those ports, whose parameter "LOG:" is set to "A", i.e. the periodic alarm event condition detection is requested.

Menu of alarms management
This menu allows working on those ports, which are in an alarm condition not recoverable automatically but only manually. The most frequent cases are the SDLC, HDLCT and MLM/Slink ports in their STOPPED state: because of the error type they have to be manually reset. In such cases, if the ports parameter "LOG:" is set to "A", those ports will be contained in the "alarm list" and they can be reset from the Menu of alarms management.
The result is the same as the ALARM RESET command is executed through the control port and the command INIT PO: is sent to all the alarmed ports.

  • To accept, press OK key. The messages "ALARM RESET", "EXECUTED" will be shown and alarms will be reset.
  • Press Down key to move to the next Menu.
  • Press Up key to move to the previous Menu.


The front panel

Commands of the front panel
Using display and function keys (Select and OK)
Menus that are available on LCD display

System supervision

Commands of the front panel top

The Abilis CPX frontal panel lodges a LCD display, a floppy disk drive, a power switch, two push buttons and three leds.

The LCD Display and the indicators give information about the Abilis CPX working mode, while the push buttons provide some utility functions described.

Cpx front panel
Figure 1. Front panel.

Power - (Power switch)
If pressing the Power switch the green led does not light on, control that the power cable is working and connecting the Abilis CPX to the current tap. The user should also check whether the tap supplies the required voltage (220V). If, after executing all the previous verifications, the Abilis CPX didn't switch on, please contact the assistance.

On - (Green LED: Power indicator)
The green led starts to light on, immediately after Abilis CPX has been started through switch Power. If, after pressing the Power switch, the green led does not light on, control that the power cable is working and connecting the Abilis CPX to the current tap. The user should also check whether the tap supplies the required voltage (220V). If, after executing all the previous verifications, the Abilis CPX didn't switch on, please contact the assistance.

1 - (Yellow LED 1. It indicates the Abilis CPX works)
The yellow LED 1 lightens every second, when the Abilis CPX starts to working, after loading the software. The yellow LED 1 flashes with higher frequency while the software is loading; it can slow down during disk access operation. If both yellow LED 1 and yellow LED 2 do not flash simultaneously, it means that Abilis CPX is blocked and it is necessary to switch off and then restart it.

2 - (Yellow LED 2. It indicates the Abilis CPX works)
The yellow Led 2 lightens every (c.a) second, when the Abilis CPX starts working, after loading the software. The yellow Led 2 do not flash (always lightened or off), while the software is loading; it can slow down during disk access operation. If both yellow LED 1 and yellow LED 2 do not flash simultaneously, it means that Abilis CPX is blocked and is necessary to switch off and then restart it.

Select - (Confirmation for menu selection)
Every time the button Select, is pressed, the display will show the next menu. By pressing it a lot of times, all the menus will be shown in a cyclic way.
Refer to section Using the display and function keys (Select and OK), for a more detailed description.

OK - (Confirmation key)
Pressing key OK it is possible to access information about the menu currently showed on the LCD display. Moreover for those menus, that requires a confirmation, by holding pressed the OK keys for an extended time, an affirmative answer will be given to the request showed on the LCD display.
Refer to section Using the display and function keys (Select and OK), for a more detailed description.

Liquid Crystals Display.
The LCD is able to visualize two lines of sixteen alphanumeric characters. In order to allow an easy read is necessary that the environment is sufficiently illuminated. If the display is not clearly legible, it is necessary to change the observation angle, moving in horizontal and/or vertical sense.

Floppy disk drive.
For a correct Abilis CPX working mode it is mandatory that the disk, containing the Abilis CPX software, is inserted.
The inserted disk must be NOT WRITE PROTECTED, contrary Abilis CPX will start regularly, but it won't be possible to save either new configuration or log files.
The floppy disk is not write protected if the write enable "window" is closed. The floppy disk is write protected if it is opened. The disk, containing the Abilis CPX software, must always be inserted, in the floppy disks drive, with the WRITE PROTECTION disabled.

Use of the display and function keys (Select and OK).

At the Abilis CPX start, the display visualizes the Messages Menu which shows on the first row the product name, on the second the software version currently in use.

The use of Select and OK push buttons is the following:

  • Press and rapidly release Select: move to the next menu
  • Press Select and keep pressed for at least 2 seconds: move to the previous menu
  • Press and rapidly release OK: enter the sub-menu
  • Press OK and keep pressed for at least 2 seconds: leave the sub-menu
  • Press OK and while keeping it pressed, press Select too: positive answer the question that appear on the LCD.

The picture shows how to scroll the menus.

How to use the Select key for Menu chooses.
Figure 2. How to use the Select key for Menu choice.

Pressing the OK key it is possible to access sub-menus.

The picture shows how to enter and leave a sub-menu, as well as the use of Select button to scroll within the sub-menu.

How to use the Select and OK key for managing menus and submenus.
Figure 3. How to use the Select and OK key for managing menus and sub-menus.

Menus that are available on LCD display

Messages Menu - Abilis CPX version and system messages.
The first row of the Messages Menu visualizes the system name, while the second shows informative messages about the system working mode. For example, after resources activation, during which it is visualized the software version, the message "START SYSTEM" will be shown to signal that Abilis CPX from that moment is regularly working:

The informative messages are displayed if, on the display, the Messages Menu is active. If one of the following menus is active, only eventual messages of errors or alarms will be displayed.Every time an informative message or an alarm is shown, pressing the OK key is possible to visualize again name and version of the product.

State Menu of the link level ports
This menu allows displaying the status of the link level ports. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • SSSS is the current state;
  • TTTTT is the port type.

If no Link ports are running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the protocol ports
This menu allows displaying the status of the protocol ports. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • SSSS is the current state;
  • TTTTT is the port type.

If no protocol ports are running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the VOICE ports
This menu allows displaying the status of the VOICE ports. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about twenty ports:

Where:

  • xx-xx is a port number's interval of up to four VOICE ports;
  • SSSSSSSS is the current state of the VOICE ports.

If no VOICE ports are running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the ISDN PRIMARY channels
This menu allows displaying the state of ports and ISDN primary rate channels. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each ISDN PRI port requires two pages, in the first one Level 1, Level 2 states and "Slips" are shown, in the second is shown each B channel state.
First page:

Where:

  • Pxxx is the port number, L1L1 is the Level 1 state (EPISDN);
  • L2L2 L2L2 is the Level 2 state (EPLAPD Sapi0 and Sapi16);
  • SLIPS: xxxxxxxxxx is the number of slips detected.

Pressing the Select key, the second page will be shown:

Where:

  • "-" means that the channel 0 and the 16th are not used;
  • S is the state of each channel from the 1st one to the 15th and from 17th to the 31st one (EPQ931).

Pressing the Select key the next port will be shown.

If no ISDN-PRI (EPQ931) ports are running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

State Menu of the ISDN BASIC RATE channels.
This menu allows displaying the state of ISDN Basic Rate channels. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about 4 pair of channels:

Where:

  • xxx-yyy is the considered port interval;
  • b1b2 is the current state of the pair of channels for each port.

If no ISDN-BRI (Q931/EBQ931) ports are running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Menu of compression statistics
This menu allows displaying the compression statistics of the protocol ports. Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Only the active and correctly "RUNNING" ports are shown. Each page shows information about two ports:

Where:

  • Pxxx is the port number;
  • S:±yy is the segment compression rate;
  • B:±yy is the compression rate in bytes.

If no protocol ports type is running, the following message will be shown:

Press the OK for at least 2 seconds to go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Menu of System utilities
This menu can execute operations related to system management, such as enabling/disabling the acoustic signal, system restart or saving the Events Log (Debug Log), or the current configuration. Pressing OK key the user accesses the first page of the menu, pressing the Select key all the other pages are visualized in a cyclic way.

Enabling/disabling the acoustic alarm signal:

The purpose of this utility command is the same of the SOUND DISABLE and SOUND ENABLE commands that are available through the Control Port command-line interface.

If the signal is already enabled, the following message will be shown:

  • To accept, press OK and while keeping it pressed, press Select too. The message "SOUND DISABLED" will be shown.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

If the signal is already disabled, the following message will be shown:

  • To accept, press OK and while keeping it pressed, press Select too. The message "SOUND ENABLED" will be shown.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

System restart:

The purpose of this utility command is the same of the RESTART SYSTEM command that is available through the Control Port command-line interface.

The following message will be displayed:

  • To accept, press OK and while keeping it pressed, press Select too. Before initiating the restart procedure, the system checks whether the configuration that is currently running was changed but not saved:
    • if the configuration wasn't saved, the system doesn't restart. Instead the the configuration saving procedure reported in the section Saving the current configuration is started;
    • if the configuration wasn't changed or was already been saved, The messages "**ATTENTION! **", "RESTART SYSTEM" will be shown and Abilis CPX will initiate the system restart sequence.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

Saving the Events Log (Debug Log):

The purpose of this utility command is the same of the SAVE DEBUG command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK and while keeping it pressed, press Select too. The message "SAVING LOG DEBUG" will be shown and Abilis CPX will start to save on disk the Events Log (Debug Log). If the operation is successful, the message "DEBUG LOG SAVED" will be shown; otherwise "DEBUG NOT SAVED".
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

Saving the current configuration:

The purpose of this utility command is the same of the SAVE CONF command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK and while keeping it pressed, press Select too. The messages "SAVE CONF", "IN PROGRESS..." will be shown and Abilis CPX will save the current configuration on disk, in DRIVERS.CFG file. If the operation is successful, the messages "SAVE CONF", "EXECUTED" are shown, otherwise one of the following messages will be displayed:
    • "SAVE CONF", "FAIL phase": indicating the phase during which the saving failed ("VALIDATE", "WRITE ERR");
    • "SAVE CONF", "FAIL E.xx": indicating a fatal error occurred, "xx" is an hexadecimal value.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

Creating a backup copy of the current configuration:

The purpose of this utility command is the same of the SAVE CONF BACKUP command that is available through the Control Port command-line interface.

The following message is displayed:

  • To accept, press OK and while keeping it pressed, press Select too. The messages "SAVE CONF BCK", "IN PROGRESS..." will be shown and Abilis CPX will create a backup copy of the current configuration on disk, in DRIVERS.BCK file. If the operation is successful, the messages "SAVE CONF BCK", "EXECUTED" are shown, otherwise one of the following messages will be displayed:
    • "SAVE CONF BCK", "FAIL phase": indicating the phase during which the saving failed ("WRITE ERR");
    • "SAVE CONF BCK", "FAIL E.xx": indicating a fatal error occurred, "xx" is an hexadecimal value.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.

Menu of alarms displaying
The purpose of this menu is the same of the ALARM VIEW command available through the Control Port command-line interface.
It displays a list of those ports where an alarm event occurred. Being the alarm condition checked every 30 seconds, it is possible that 30 seconds could pass from the moment the port starts to correctly work again and to the one when the alarm event ends.

  • Pressing the OK key, it is possible to access the first page of the menu, pressing successively the Select key all the other eventual pages will be shown in a cyclic way. Each page shows information about two ports:

    Where:

    • Pxxx is the port number;
    • TTTTT is the port type.
    • SSSS is the current state; if SSSS is "----" it means the considered port is not in a alarm condition.

    If there are no ports in alarm condition, the following message will be shown:

  • Pressing the OK key, it will go back to the main Menu.

Maintaining the display on a page, every second the state of the port(s) shown on that page is refreshed.

Do not forget that this menu shows only those ports, whose parameter "LOG:" is set to "A", i.e. the periodic alarm event condition detection is requested.

Menu of alarms management
This menu allows working on those ports, which are in an alarm condition not recoverable automatically but only manually. The most frequent cases are the SDLC, HDLCT and MLM/Slink ports in their STOPPED state: because of the error type they have to be manually reset. In such cases, if the ports parameter "LOG:" is set to "A", those ports will be contained in the "alarm list" and they can be reset from the Menu of alarms management.
The result is the same as the ALARM RESET command is executed through the control port and the command INIT PO: is sent to all the alarmed ports.

  • To accept, press OK and while keeping it pressed, press Select too. The messages "ALARM RESET", "EXECUTED" will be shown and alarms will be reset.
  • Press OK for at least 2 seconds to go back to the Utility Menu.
  • Press Select to move to the next Menu.


DHCP Hosts, DHCP Profiles and DHCP Subnets Tables

Configuration of DHCP Hosts
Configuration of DHCP Profiles
Configuration of DHCP Subnets

Configuration of DHCP Hosts top

The DHCP Hosts table can hold up to 500 definitions, indexed from 1 up to 500 hosts bindings.

The table of DHCP Hosts can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

Commands for handling DHCP Hosts are described in the DHCP Hosts section of the document Commands relating to DHCP.

The available commands are the following:

A DHCP HOST MAC:val
A DHCP HOST:val
C DHCP HOST MAC:val
C DHCP HOST:val
D DHCP HOST [MAC:val]
D DHCP HOST:val
S DHCP HOST:val

In the following example are displayed all the entries of the table of DHCP Hosts.

[11:38:42] ABILIS_CPX: D DHCP HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  1   00-00-00-00-00-01  001.001.001.001  LAN
  3   00-00-00-00-00-30  001.001.001.003  1
  4   00-00-00-00-00-02  000.000.000.000  LAN
 10   00-00-00-00-00-01  001.001.001.010  2

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of DHCP host's parameters

HOST: | Host identifier
no default | 1..500

It is the host definition identifier. The identifier is a numeric value in the range [1..500] that is assigned by the system to the DHCP host definition when it is added the first time. It can be used for clearing/displaying and setting operations to reference the host definition.

MAC: | MAC address of client
00:00:00:00:00:00 | 00:00:00:00:00:00-FF:FF:FF:FF:FF:FF

This parameter specifies the MAC address of the client to which assign IP address, when the request arrives from the subnet valid for this IP address.

IP: | IP address
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the IP address to assgined to requests coming from the subnet valid for this IP and MAC of request is equal to MAC value from this host record.

If the IP address is equal to 0.0.0.0 (unasigned) and MAC of request is equal to MAC: value from this host record DHCP server will use Profile from this host record and IP address will be assigned from subnet pools (POOL5:..POOL5:).

PROF: | DHCP Profile identifier
LAN | LAN, 1..128

This parameter specifies the identifier of DHCP Profile identifier from the table of DHCP Profiles to be used if MAC of request is equal to MAC of this record.

If profile is set to "LAN", DHCP will use the subnet profile or even none in the case that the subnet have not a valid profile configured.
If profile is ste to a value in the range [1..128], DHCP will use the specified one. If the profile doesn't exist DHCP will not use any profile.

Configuration of DHCP Profiles top

The DHCP Profiles table can hold up to 129 definitions, indexed from 0 up to 128.

The first definition, i.e. the profile identified by the index equal to zero, is a default profile that is always present within the table and that cannot be deleted by the user. Instead the user can arbitrarily add/delete the definitions from the index 1 to 128.

The table of DHCP Profiles can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

Commands for handling DHCP Profiles are described in the DHCP Profiles section of the document Commands relating to DHCP.

The available commands are the following:

A DHCP PROF:val
C DHCP PROF:val
D DHCP PROF
D DHCP PROF:val
S DHCP PROF:val

In the following example are displayed all the entries of the table of DHCP Profiles. As it can be seen, this command shows synthetically the current content of the table of DHCP Profiles. Displayed values are only samples.

[18:35:50] ABILIS_CPX: D DHCP PROF

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

PROF: |NAME:
-------------------------------------------------------------------------------
  0    Default_profile
  5    This_is_the_name_of_profile_5

The following sample shows how to display all definitions in details:

[15:00:45] ABILIS_CPX: D DHCP PROF:A

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
PROF:          0
NAME:          Default_profile
-------------------------------------------------------------------------------
PROF:          5
NAME:          This_is_the_name_of_profile_5
GW1:           192.168.000.253
TIME:          001.001.001.001
-------------------------------------------------------------------------------

Because every DHCP profile entry has several parameters, to keep the visualization as short as possible, the command doesn't display information about parameters set to their default values. Such information is displayed only if the parameters are set to not default values.

The following sample shows how to display a single definition:

[15:00:45] ABILIS_CPX: D DHCP PROF:5

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
PROF:          5
NAME:          This_is_the_name_of_profile_5
GW1:           192.168.000.253
TIME:          001.001.001.001
-------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of DHCP profile's parameters

PROF: | DHCP profile identifier
empty | 0..128

This parameter specifies the identifier of the profile.

NAME: | DHCP profile name
empty | from 0 up to 32 ASCII printable characters

This parameter specifies the name of the profile.

TTL: | IP time-to-live
0 | 0, 1..255

This parameter specifies the default time-to-live that the client should use on outgoing datagrams.

The value "0" means "not present".

KEEPALIVE: | TCP keepalive interval
0 | 0, 15..65535 sec.

This parameter specifies the interval (in seconds) that the client should wait before sending a keepalive message on a TCP connection.

The value "0" means "not present".

NB-SCOPE-ID: | Netbios scope identifier
empty | from 0 up to 32 ASCII printable characters

This parameter specifies the NetBIOS over TCP/IP scope parameter for the client as specified in RFC1001/1002.

NB-NODE-TYPE: | Netbios node type
UNK | UNK, B, P, M, H

This parameter allows NetBIOS over TCP/IP clients which are configurable to be configured as described in RFC1001/1002.
The value is specified as follows:

Value | Node Type
UNK | Undefined
B | B-node
P | P-node
M | M-node
H | H-node

DOMAIN: | IP domain name
empty | from 0 up to 32 ASCII printable characters

This parameter specifies the domain name that client should use when resolving hostnames via the Domain Name System.

GW1: | First gateway
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the first gateway IP address.

GW2: | Second (backup) gateway
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the second (backup) gateway IP address.

GW3: | Third (backup) gateway
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the third (backup) gateway IP address.

DNS1: | Primary Domain Name server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Primary Domain Name Server IP address.

DNS2: | Secondary Domain Name server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Secondary Domain Name Server IP address.

SMTP: | Simple Mail Transport Protocol (SMTP) server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Simple Mail Transport Protocol (SMTP) server IP address.

POP3: | Post Office Protocol (POP3) server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Post Office Protocol (POP3) server IP address.

NNTP: | Network News Transport Protocol (NNTP) server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Network News Transport Protocol (NNTP) server IP address.

WWW: | World Wide Web (WWW) server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the World Wide Web (WWW) server IP address.

FINGER: | Finger server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Finger server IP address.

IRC: | Internet Relay Chat server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the Internet Relay Chat server IP address.

NTP: | NTP/SNTP server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the NTP/SNTP server IP address.

TIME: | TIME server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the TIME server (RFC868) IP address.

WINS1: | First WINS server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the first WINS server IP address.

WINS2: | Second WINS server
0.0.0.0 | 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255

This parameter specifies the second WINS server IP address.

Configuration of DHCP Subnets top

The DHCP Subnets table can hold up to 128 definitions.

The table of DHCP Subnets can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

Commands for handling DHCP Subnets are described in the DHCP Subnets section of the document Commands relating to DHCP.

The available commands are the following:

A DHCP LAN NET:val
A DHCP LAN:val
C DHCP LAN NET:val
C DHCP LAN:val
D DHCP LAN
D DHCP LAN:val
S DHCP LAN NET:val
S DHCP LAN:val

In the following example are displayed all the entries of the table of DHCP Subnets in a synthetic format.

[15:00:45] ABILIS_CPX: D DHCP LAN

LAN: |NET:            |MASK:
-------------------------------------------------------------------------------
  1   192.000.123.000  255.255.255.000
  5   192.168.000.000  255.255.255.000

The following sample shows how to display a single definition:

[15:00:45] ABILIS_CPX: D DHCP LAN:5

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
LAN:           5
NAME:          The name of this subnet is LOCAL-LAN
NET:           192.168.0.0/24
MASK:          255.255.255.0
POOL1:         192.168.0.10:192.168.0.254
DEF-LEASE:     36000
MAX-LEASE:     36000
PROF:          5 (Local lan 192.168.0.0/24)

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of DHCP subnet's parameters

LAN: | DHCP subnet identifier
empty | 1..128

This parameter specifies the subnet record numeric identifier.

NAME: | Name of DHCP subnet
empty | [from 0 up to 32 ASCII printable characters

This parameter specifies the name of the subnet.

NET: | Network address
0.0.0.0 | 0.0.0.0 1.0.0.0-126.255.255.255 128.0.0.0-223.255.255.255

This parameter specifies the network IP address of the DHCP subnet.

MASK: | Network mask
0.0.0.0 | 0.0.0.0 128.0.0.0-255.255.255.252

This parameter specifies the mask related to the network (NET:) of the DHCP subnet.

POOL1: | First IP pool
0.0.0.0 | see below

This parameter specifies the first IP pool of addresses.

A single IP address value, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is accepted; or two IP addresses, in Dotted Decimal Notation, separated by ':' (colon) can be set (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100 ).

POOL2: | Second IP pool
0.0.0.0 | see below

This parameter specifies the second IP pool of addresses.

A single IP address value, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is accepted; or two IP addresses, in Dotted Decimal Notation, separated by ':' (colon) can be set (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100 ).

POOL3: | Third IP pool
0.0.0.0 | see below

This parameter specifies the third IP pool of addresses.

A single IP address value, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is accepted; or two IP addresses, in Dotted Decimal Notation, separated by ':' (colon) can be set (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100 ).

POOL4: | Fourth IP pool
0.0.0.0 | see below

This parameter specifies the fourth IP pool of addresses.

A single IP address value, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is accepted; or two IP addresses, in Dotted Decimal Notation, separated by ':' (colon) can be set (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100 ).

POOL5: | Fifth IP pool
0.0.0.0 | see below

This parameter specifies the fifth IP pool of addresses.

A single IP address value, in Dotted Decimal Notation, in the range [1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255] is accepted; or two IP addresses, in Dotted Decimal Notation, separated by ':' (colon) can be set (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100 ).

DEF-LEASE: | Default lease time of the IP address
36000 | 60..1000000 sec.

This parameter specifies the default lease time of the IP address in seconds. This value will be assigned to the client if client doesn't request IP lease.

MAX-LEASE: | Maximum lease time of the IP address
36000 | 60..1000000 sec.

This parameter specifies the maximum value of lease time of the IP address in seconds. This value will be assigned to the client if client requests IP lease more than one.

Maximum lease time of the IP address must be equal or greater than DEF-LEASE: value.

PROF: | DHCP Profile identifier
0 | NONE, 1..128

This parameter specifies the identifier of DHCP Profile from the table of DHCP Hosts to be used when assigning an IP from the pool, or for static hosts belonging to this subnet has Profile Id equal to NONE.


FTP Virtual Root Paths and Virtual Path's Access Rights Tables

Configuration of FTP Virtual Root Paths
Configuration of FTP Virtual Path's Access Rights

Configuration of FTP Virtual Root Paths top

The table of FTP Virtual Root Paths can hold up to 64 definitions.

FTP Virtual Root Path definitions are kept alphabetically sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of FTP Virtual Root Paths can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the FTP port number.

Commands for handling FTP Virtual Root Paths are described in the FTP Virtual Root Paths table section of the document Commands relating to FTP.

The available commands are the following:

A FTP PATH:
C FTP PATH:
D FTP PATH
D FTP PATH:
S FTP PATH:

In the following example are displayed all the entries of the table of FTP Virtual Root Paths. Displayed values are the default one.

[16:32:16] ABILIS_CPX: D FTP PATH

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of FTP virtual root path's parameters

PATH: | Virtual root path
no value | up to 32 characters (see also long file names)

Specifies virtual root path for a directory on disk, in UNIX notation starting and ending with a slash ("/") (E.g.: "/Common/" or "/usr/").

Maximum 32 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "/My dir/").

There is no difference between lowercase and uppercase characters. For example the strings "/APPDIR/" and "/appdir/" are equivalent. However, when an entry is created, the case is preserved.

info The virtual root path "/sysdrives/" cannot be defined because it is reserved to the system.
Virtual path "/" cannot be accepted because "/" does never refer to physical path, it is only the "container" of virtual paths.

PHYS-PATH: | Physical path
empty | from 0 up to 128 characters (see also long file names)

Specifies real path on disks of a directory. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with a backslash ("\") (E.g.: "C:\", "A:\", "C:\USR\TEST\").

Maximum 128 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\USR\My dir\").

There is no difference between lowercase and uppercase characters. For example the strings "C:\APP\MYDIR\" and "c:\app\mydir\" are equivalent. However, when an entry is created, the case is preserved.

Configuration of FTP Virtual Path's Access Rights top

The table of FTP Virtual Path's Access Rights can hold up to 128 path definitions and up to 300 user definitions.

FTP Virtual Path's Access Rights entries are identified by an index in the range [1 - 128].

Path and user definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries. Likewise entries deletion will cause a table rearrangement on the base of the currently defined entries.

Special attention must be paid in deleting a path definition, in fact deleting a path causes also the deletion of all user entries that are eventually defined for it.

Changes made on the table of FTP Virtual Path's Access Rights are immediately active, they do not require any initialization command to be operative.

Commands for handling FTP Virtual Path's Access Rights are described in the FTP Virtual Path's Access Rights table section of the document Commands relating to FTP.

The available commands are the following:

A FTP RIGHTS ID:
A FTP RIGHTS PATH:
C FTP RIGHTS ID:
C FTP RIGHTS PATH:
D FTP RIGHTS
D FTP RIGHTS ID:
D FTP RIGHTS PATH:
D FTP RIGHTS USER:
F FTP RIGHTS PATH:
S FTP RIGHTS ID:
S FTP RIGHTS PATH:

In the following example are displayed all the entries of the table of FTP Virtual Path's Access Rights. Displayed values are the default ones.

[16:33:25] ABILIS_CPX: D FTP RIGHTS

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

Here there is a sample about how to see all virtual paths for which a cartain user is defined:

[17:04:03] ABILIS_CPX: D FTP RIGHTS USER:admin

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Detail of FTP Virtual Path's Access Right entry's parameters

ID: | Virtual path identifier
no value | 1 - 128

Specifies the identifier assigned to the virtual path definition when it was added to the FTP Virtual Path's Access Rights.

FTP Virtual Path's Access Rights entries are are kept alphabetically sorted, then the identifiers are not neccessary displayed in sequential order by the D FTP RIGHTS command.

The assigned identifier can be used by the user to simply the entry manipulation in addition, deletion setting and diaplying operations.

PATH: | Virtual path value
no value | up to 128 characters (see also long file names)

Specifies virtual path, in UNIX notation starting and ending with a slash ("/") (E.g.: "/Common/" or "/usr/konstt/").

Maximum 128 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "/user dir/My dir/").

There is no difference between lowercase and uppercase characters. For example the following strings "/user dir/my dir/", "/USER DIR/MY DIR/", "/User Dir/My Dir/" are equivalent. However, when an entry is created, the case is preserved.

USER: | User name
no value | up to 32 ASCII characters [33..126]

Specifies the name of the user for which access rights are specified.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

FILE: | Rigths for file operations
r--- | +/-R, +/-W, +/-D, +/-N

Specifies rights that are granted to the USER: for file operations on the virtual PATH:.

Rights can be added putting the plus character ("+") before the corresponding letter (E.g.: "+R+W").
Rights can be removed putting the minus character ("-") before the corresponding letter (E.g.: "-D").
In the case that the sign is omitted before the letter, the plus one is assumed.

Value | Meanning | Description
R | Read | Files reading right.
W | Write | Files writing right.
D | Delete | Files deleting right.
N | reName | Files renaming right.

DIR: | Rigths for directory operations
l--- | +/- L,C,D,N

Specifies rights that are granted to the USER: for directory operations on the virtual PATH:.

Rights can be added putting the plus character ("+") before the corresponding letter (E.g.: "+L").
Rights can be removed putting the minus character ("-") before the corresponding letter (E.g.: "-D-C").
In the case that the sign is omitted before the letter, the plus one is assumed.

Value | Meanning | Description
L | List | Directories listing right.
C | Create | Directories creating right.
D | Delete | Directory deleting right.
N | reName | Directory renaming right.

RECUR: | Recursive rights propagation
YES | YES, NO

This parameter specifies whether this right has to be extended to all the sub-directories of the virtual PATH:, until one is found with an explicit rights definition.

PROT: | Connection protocol
PLAIN,SSL | PLAIN, SSL

This parameter specifies which connection protocol (PLAIN, SSL or both) is applicable to thi entry.

Values can be joined using the comma (",") character.

Long file names

Long file names may consist of any combination of letters, digits, or character values greater than 127 (0x7E). In particular, the following special characters are ALSO allowed:

Character | ASCII Hex. value
$ | 0x24
% | 0x25
' | 0x26
- | 0x2D
_ | 0x5F
@ | 0x40
~ | 0x7E
` | 0x60
! | 0x21
( | 0x28
) | 0x29
{ | 0x7B
} | 0x7D
^ | 0x5E
# | 0x23
& | 0x26
. | 0x2E
+ | 0x2B
, | 0x2C
; | 0x3B
= | 0x2D
[ | 0x5B
] | 0x5D

Also embedded spaces within file names are allowed, while leading and trailing spaces are ignored.

The following characters are NOT allowed:

Character | ASCII Hex. value
\ | 0x5C
/ | 0x2F
: | 0x3A
* | 0x2A
? | 0x3F
" | 0x22
< | 0x3C
> | 0x3E
| | 0x7C


HTTP Virtual Root Paths and Virtual Path's Access Rights Tables

Configuration of HTTP Virtual Root Paths
Configuration of HTTP Virtual Path's Access Rights

Configuration of HTTP Virtual Root Paths top

The table of HTTP Virtual Root Paths can hold up to 64 definitions.

HTTP Virtual Root Path definitions are kept alphabetically sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of HTTP Virtual Root Paths can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the HTTP port number.

Commands for handling HTTP Virtual Root Paths are described in the HTTP Virtual Root Paths table section of the document Commands relating to HTTP.

The available commands are the following:

A HTTP PATH:
C HTTP PATH:
D HTTP PATH
D HTTP PATH:
S HTTP PATH:

In the following example are displayed all the entries of the table of HTTP Virtual Root Paths. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /leo/
PHYS-PATH:    c:\usr\pub\
------------------------------------------------------------------------------
PATH:         /test/
PHYS-PATH:
------------------------------------------------------------------------------
PATH:         /trfafiles/
PHYS-PATH:    c:\app\trfa\
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of HTTP virtual root path's parameters

PATH: | Virtual root path
no value | up to 32 characters (see also long file names)

Specifies virtual root path for a directory on disk, in UNIX notation starting and ending with a slash ("/") (E.g.: "/Common/" or "/usr/").

Maximum 32 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "/My dir/").

There is no difference between lowercase and uppercase characters. For example the strings "/APPDIR/" and "/appdir/" are equivalent. However, when an entry is created, the case is preserved.

info The virtual root path "/sys/" cannot be defined because it is reserved to the system.
Virtual path "/" cannot be accepted because "/" does never refer to physical path, it is only the "container" of virtual paths.

PHYS-PATH: | Physical path
empty | from 0 up to 128 characters (see also long file names)

Specifies real path on disks of a directory. It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with a backslash ("\") (E.g.: "C:\", "A:\", "C:\USR\TEST\").

Maximum 128 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\USR\My dir\").

There is no difference between lowercase and uppercase characters. For example the strings "C:\APP\MYDIR\" and "c:\app\mydir\" are equivalent. However, when an entry is created, the case is preserved.

Configuration of HTTP Virtual Path's Access Rights top

The table of HTTP Virtual Path's Access Rights can hold up to 128 path definitions and up to 300 user definitions.

HTTP Virtual Path's Access Rights entries are identified by an index in the range [1 - 128].

Path and user definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries. Likewise entries deletion will cause a table rearrangement on the base of the currently defined entries.

Special attention must be paid in deleting a path definition, in fact deleting a path causes also the deletion of all user entries that are eventually defined for it.

Changes made on the table of HTTP Virtual Path's Access Rights are immediately active, they do not require any initialization command to be operative.

Commands for handling HTTP Virtual Path's Access Rights are described in the HTTP Virtual Path's Access Rights table section of the document Commands relating to HTTP.

The available commands are the following:

A HTTP RIGHTS ID:
A HTTP RIGHTS PATH:
C HTTP RIGHTS ID:
C HTTP RIGHTS PATH:
D HTTP RIGHTS
D HTTP RIGHTS ID:
D HTTP RIGHTS PATH:
D HTTP RIGHTS USER:
F HTTP RIGHTS PATH:
S HTTP RIGHTS ID:
S HTTP RIGHTS PATH:

In the following example are displayed all the entries of the table of HTTP Virtual Path's Access Rights. Displayed values are the default ones.

[16:33:25] ABILIS_CPX: D HTTP RIGHTS

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /sys/
       admin                            r---  l---  YES    PLAIN,SSL
       anonymous                        r---  ----  NO     PLAIN,SSL
------------------------------------------------------------------------------

Here there is a sample about how to see all virtual paths for which a cartain user is defined:

[17:04:03] ABILIS_CPX: D HTTP RIGHTS USER:anonymous

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /sys/
       anonymous                        r---  ----  NO     PLAIN,SSL
------------------------------------------------------------------------------
  2 /test/
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /test_2/
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Detail of HTTP Virtual Path's Access Right entry's parameters

ID: | Virtual path identifier
no value | 1 - 128

Specifies the identifier assigned to the virtual path definition when it was added to the HTTP Virtual Path's Access Rights.

HTTP Virtual Path's Access Rights entries are are kept alphabetically sorted, then the identifiers are not neccessary displayed in sequential order by the D HTTP RIGHTS command.

The assigned identifier can be used by the user to simply the entry manipulation in addition, deletion setting and diaplying operations.

PATH: | Virtual path value
no value | up to 128 characters (see also long file names)

Specifies virtual path, in UNIX notation starting and ending with a slash ("/") (E.g.: "/Common/" or "/usr/konstt/").

Maximum 128 characters are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "/user dir/My dir/").

There is no difference between lowercase and uppercase characters. For example the following strings "/user dir/my dir/", "/USER DIR/MY DIR/", "/User Dir/My Dir/" are equivalent. However, when an entry is created, the case is preserved.

USER: | User name
no value | up to 32 ASCII characters [33..126]

Specifies the name of the user for which access rights are specified.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

FILE: | Rigths for file operations
r--- | +/-R, +/-W, +/-D, +/-N

Specifies rights that are granted to the USER: for file operations on the virtual PATH:.

Rights can be added putting the plus character ("+") before the corresponding letter (E.g.: "+R+W").
Rights can be removed putting the minus character ("-") before the corresponding letter (E.g.: "-D").
In the case that the sign is omitted before the letter, the plus one is assumed.

Value | Meanning | Description
R | Read | Files reading right.
W | Write | Files writing right.
D | Delete | Files deleting right.
N | reName | Files renaming right.

DIR: | Rigths for directory operations
l--- | +/- L,C,D,N

Specifies rights that are granted to the USER: for directory operations on the virtual PATH:.

Rights can be added putting the plus character ("+") before the corresponding letter (E.g.: "+L").
Rights can be removed putting the minus character ("-") before the corresponding letter (E.g.: "-D-C").
In the case that the sign is omitted before the letter, the plus one is assumed.

Value | Meanning | Description
L | List | Directories listing right.
C | Create | Directories creating right.
D | Delete | Directory deleting right.
N | reName | Directory renaming right.

RECUR: | Recursive rights propagation
YES | YES, NO

This parameter specifies whether this right has to be extended to all the sub-directories of the virtual PATH:, until one is found with an explicit rights definition.

PROT: | Connection protocol
PLAIN,SSL | PLAIN, SSL

This parameter specifies which connection protocol (PLAIN, SSL or both) is applicable to thi entry.

Values can be joined using the comma (",") character.

Long file names

Long file names may consist of any combination of letters, digits, or character values greater than 127 (0x7E). In particular, the following special characters are ALSO allowed:

Character | ASCII Hex. value
$ | 0x24
% | 0x25
' | 0x26
- | 0x2D
_ | 0x5F
@ | 0x40
~ | 0x7E
` | 0x60
! | 0x21
( | 0x28
) | 0x29
{ | 0x7B
} | 0x7D
^ | 0x5E
# | 0x23
& | 0x26
. | 0x2E
+ | 0x2B
, | 0x2C
; | 0x3B
= | 0x2D
[ | 0x5B
] | 0x5D

Also embedded spaces within file names are allowed, while leading and trailing spaces are ignored.

The following characters are NOT allowed:

Character | ASCII Hex. value
\ | 0x5C
/ | 0x2F
: | 0x3A
* | 0x2A
? | 0x3F
" | 0x22
< | 0x3C
> | 0x3E
| | 0x7C


NAT Aliases

Configuration of NAT Aliases

NAT configuration examples

Configuration of NAT Aliases top

The table of NAT Aliases can store up to 255 entries, indexed starting from 0 up to 254.

The entry priority index sets the entries verification order and must be sequential.

The priority index for NAT Aliases is also utilized as a reference for operations of insertion, modification and deletion.

In the table of NAT Aliases, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT NAT or by executing the initialization command INIT PO:, where "xxx" is the NAT port number.

Commands for handling the table of NAT Aliases are described in the Configuration of NAT Alias entries section of the document Commands relating to NAT.

The available commands are the following:

A NAT
C NAT
D NAT
M NAT
S NAT

Here it follows an example of the NAT Aliases visualization. All values are only examples.

[18:14:08] ABILIS_CPX: D NAT

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                  SIPP: DIPP: PAT:
               PROT:                  DPO:                   ADPO:
------------------------------------------------------------------------------
0   IN    DST  002.002.002.002/32     005.005.005.005/32     10    *     NO
------------------------------------------------------------------------------
1   OUT   DST  005.005.005.005/32     002.002.002.002/32     *     *     NO
------------------------------------------------------------------------------
2   IN    DST  002.002.002.003/32     005.005.005.006/32     10    *     NO
------------------------------------------------------------------------------
3   OUT   DST  005.005.005.006/32     002.002.002.003/32     *     *     NO
------------------------------------------------------------------------------
4   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               ICMP
------------------------------------------------------------------------------
5   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               TCP                    *
------------------------------------------------------------------------------
6   IN    DST  000.000.000.000/32     000.000.000.000/32     *     *     YES
               UDP                    *                      *
------------------------------------------------------------------------------

As it is possible to note from the previous example, this command desn't display information about parameters whose values are the default ones. They will be only displayed if their values have been changed from the default ones. In such way, the description of single entry is simply contained in one row.

Single entry displaying:

[12:41:53] ABILIS_CPX: D NAT PR:4

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                  SIPP: DIPP: PAT:
               PROT:                  DPO:                   ADPO:
------------------------------------------------------------------------------
4   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               ICMP
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

Detail of the NAT Alias entry's parameters

PR: | NAT alias entry priority (The 0 priority is the highest)
none | from 0 up to 254

It is the entry priority. The priority index sets NAT alias entries looking order.

The NAT alias entry priority index is also use by the adding, modifying and deleting commands for referring to it.

Priority indexes, every time an entry is added or deleted, in the list are automatically kept in sequential order.

The verifying procedure is executed for each entry when NAT has had an IP datagram which must be translated, i.e. if an entry in NAT dynamic table for this IP datagram has not found.

It starts from the entry with priority 0 and continues until the suitable one will be found or the list will end.

SIDE: | Side of translation
IN | IN, OUT

It sets the side of translation. The "IN" value stands for "inside"; "OUT" value stands for "outside".

A NAT alias entry is used only when the side of the translation for incoming IP datagram is equal to the side of the translation for this record.

The side of translation for incoming IP datagrams is defined in NAT: field of IP port configuration.

ADD: | Address translation type
SRC | SRC, DST

It sets the type of translation. The "SRC" value stands for "source IP address"; "DST" value stands for "destination IP address".

A NAT alias entry can be used to translate the source IP address of the IP datagram or to translate the destination IP address of the IP datagram.

In the case that both source and destination IP adresses have to be translated, two entries have to be defined in the table of NAT Aliases.

For more information about address translation see the section NAT configuration examples.

NET: | Network IP address and mask
000.000.000.000/32 | see below

It sets the network IP address and mask values used to match with the address of the IP datagram to be translated.

Allowed values for the network IP address are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Allowed values for the network mask are [0 - 32]. Only values that contain a contiguous sequence of bits set to 1 are accepted. Moreover doing the "logical And" between the network IP address value and the related mask value, the result should be the network IP address itself.

This filed can also be set to the name of an IP addresses list or to the name of an IP addresses ranges list betweek peaks (E.g.: 'ListName'). The referenced list must already be defined in the Elements Lists service.

For more information about address translation see the section NAT configuration examples.

ANET: | Alias network IP address and mask
000.000.000.000/32 | see below

It sets the network IP address and mask values to be used to replace the original address of the IP datagram.

Allowed values for the alias network IP address are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Allowed values for the alieas network related mask are [0 - 32]. Only values that contain a contiguous sequence of bits set to 1 are accepted. Moreover doing the "logical And" between the alias network IP address value and the related mask value, the result should be the alias network IP address itself.

This field can also be set to "OUT-IPP" value, in this case the original address of the IP datagram will be replaced with the IP address of the IP port from which it will be forwarded, i.e. the IP address set in IPADD: field of IP port configuration.

For more information about address translation see the section NAT configuration examples.

SIPP: | Source IP port
* | 0..63, *, NONE

It sets the IP port from which the IP datargram has to be received in order to match the entry.

The value "*", that stands for "any IP port", allows the translation to be independent of the IP port from which the datagram has been received.

The value "NONE", that stands for "no IP port", can be used to temporary disable a certain entry without deleting it.

DIPP: | Destination IP port
* | 0..63,*, NONE

It sets the IP port from which the translated IP datagram has to be forwarded in order to match the entry.

The value "*", that stands for "any IP port", allows the translation to be independent of the IP port from which the datagram has to be forwarded.

The value "NONE", that stands for "no IP port", makes the entry to mach only with IP datagram with internal detination.

PAT: | Port address translation activation/deactivation.
NO | NO, YES

It allows to enable/disable the Port Address Translation (PAT) mode for this record.

When this parameter is set to "YES", the PAT mode is enabled and the additional parameters PROT:, DPO: and ADPO: can be configured.

PROT: | Allowed IP protocols
* | ICMP, TCP, UDP, *, NONE

It sets the IP protocols values that make the IP datagram to match with this entry.

Values "ICMP", "TCP" and "UDP" can be joined using the comma (",") character. This parameter can be set only when the Port Address Translation (PAT) mode is enabled, i.e. when the PAT: field is set to "YES".

DPO: | Allowed destination TCP/UDP ports.
* | see below

It sets the destination TCP/UDP port(s) values that make the IP datagram to match with this entry.

It can be set to a single port, using the corresponding mnemonic or a decimal value in the range [1..65535].

It can be set to a range of ports, using two port values separated by colon (":") character.

It can also be set to the name of a TCP/UDP ports list or to the name of a Rule list or to the name of a Master rule list between primes (E.g.: 'ListName'). The referenced list must already be defined in the Elements Lists service.

By last the value "*", that stands for "any port" can be used to make the translation to be independent of the destination TCP/UDP port.

Here there are examples of accepted values: "22" or "SSH" or "1:1024" or "*" or "'List'".

This parameter can be set only when the Port Address Translation (PAT) mode is enabled, i.e. when the PAT: field is set to "YES", and when TCP/UDP protocols are selected in PROT: field.

ADPO: | Alias destination TCP/UDP ports.
* | 1 - 65535, *

It sets the alias destination TCP/UDP port(s) values that has to be set in the IP datagram matching with this entry.

It can be set to a single port, using the corresponding mnemonic or a decimal value in the range [1..65535].

The value "*", that stands for "any port" can be used to leave the TCP/UDP port of the IP datagram unchanged.

This parameter can be set only when the Port Address Translation (PAT) mode is enabled, i.e. when the PAT: field is set to "YES"; when TCP/UDP protocols are selected in PROT: field and when the ADD: field is equal to "DST".


Configuration of OSPF Tables

Configuration of OSPF Areas
Configuration of OSPF External Routes
Configuration of OSPF Hosts
Configuration of OSPF Neighbours
Configuration of OSPF Ranges
Configuration of OSPF Virtual links

Configuration examples.

Structure's parameters of OSPF port

Configuration of OSPF Areas top

The table of OSPF Areas can hold up to 16 definitions.

OSPF Area definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF Areas can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF Areas are described in the OSPF Areas section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF AREA:
C OSPF AREA:
D OSPF AREA
D OSPF AREA:
S OSPF AREA:

In the following example are displayed all the entries of the table of OSPF Areas. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF AREA

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
010.000.000.000     NO         NO          65535
020.000.000.000     NO         NO             20
--------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF Area's parameters

AREA: | Area ID
0.0.0.0 | 0.0.0.0 - 255.255.255.255

This is a 32-bit number that identifies the area. The Area ID of 0.0.0.0 is reserved for the backbone. If the area represents a subnetted network, the IP network number of the subnetted network may be used for the Area ID.

AUTTYPE: | Authentication type
NO | NO, SIMPLE, CRYPTO

Each area can be configured for a separate type of authentication.
All OSPF protocol exchanges are authenticated. The OSPF packet header includes an authentication type field and 64-bits of data for use by the appropriate authentication scheme (determined by the type field). The authentication type is configurable on a per-area basis. Additional authentication data is configurable on a per-interface basis.

For example, if an area uses a simple password scheme for authentication, a separate password may be configured for each network contained in the area.

The current list of authentication types is described below:

Value | Meanning | Description
NO | No authentication | Use of this authentication type means that routing exchanges in the area are not authenticated. The 64-bit field in the OSPF header can contain anything; it is not examined on packet reception.
SIMPLE | Simple password authentication | Using this authentication type, a 64-bit field is configured on a per-network basis. All packets sent on a particular network must have this configured value in their OSPF header 64-bit authentication field. This essentially serves as a "clear" 64-bit password.
CRYPTO | Cryptographic authentication | Using this authentication type, a shared secret key is configured in all routers attached to a common network/subnet. For each OSPF protocol packet, the key is used to generate/verify a "message digest" that is appended to the end of the OSPF packet. The message digest is a one-way function of the OSPF protocol packet and the secret key. Since the secret key is never sent over the network in the clear, protection is provided against passive attacks. The algorithm's used to generate and verify the message digest are specified implicitly by the secret key. This specification completely defines the use of OSPF Cryptographic authentication when the MD5 algorithm is used.

STUB: | External route capability flag
NO | NO, YES

Whether AS external advertisements will be flooded into/throughout the area. If AS external advertisements are excluded from the area, the area is called a "stub". Internal to stub areas, routing to external destinations will be based solely on a default summary route. The backbone cannot be configured as a stub area. Also, virtual links cannot be configured through stub areas.

  • NO: This area is not stub area.
  • YES: This area is stub area.
DEFCOST: | Stub default cost
65535 | 1 - 65535

If the area has been configured as a stub area, and the router itself is an area border router, then the Stub Default Cost indicates the cost of the default summary link that the router should advertise into the area.

Configuration of OSPF External Routes top

The table of OSPF External Routes contains filtering rules for routes which are external to the OSPF domain that could be imported into the OSPF domain.
Is is used only when this router is declared as ASBR, i.e. the OSPF_ASBR: parameter is set to "YES".

The table is used as describe below:

  1. An empty table is a "accept by default" table.
  2. A table with only "ignore" records is still a "accept by default" table.
  3. A table with at least one "accept" record for a protocol becomes a "ignore by default" for that protocol.

In the case 1) the filtering is possible only "by protocol" through the parameters of the OSPF ports: OSPF_LOCAL, OSPF_STATIC and OSPF_RIP.

In the case 2) it is possible to explicitely ignore routes.

In case 3) all the routes for the protocol having at least one "accept" record are ignored, except those explicitely accepted.

The table of OSPF External Routes can hold up to 256 definitions.

OSPF External route definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF External Routes can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF External Routes are described in the OSPF External Routes section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF EXTERNAL:
C OSPF EXTERNAL:
D OSPF EXTERNAL
D OSPF EXTERNAL:
S OSPF EXTERNAL:

In the following example are displayed all the entries of the table of OSPF External Routes. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF EXTERNAL

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-----------------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:  TYPE:
-----------------------------------------------------
192.168.006.002/32   RIP     ACCEPT          5     1
192.168.006.000/24   LOCAL   IGNORE          1     1
010.000.000.000/8    ANY     ACCEPT         10     1
000.000.000.000/0    ANY     ACCEPT          *     1
-----------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF External route's parameters

EXTERNAL: | External IP network
no value | see below

It specifies the external IP network that can be imported (or not) into OSPF port.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The network address "0.0.0.0" is valid only for mask value "0".

PROT: | Routing protocol filter
ANY | ANY, LOCAL, STATIC, RIP

This parameter defines a routing protocol for which this filter will be applied.

  • ANY: All routing protocols
  • LOCAL: Local routes
  • STATIC: Static routes
  • RIP: RIP routes
ACTION: | Accept/Ignore flag
ACCEPT | ACCEPT, IGNORE

This parameter indicates if the selected network EXTERNAL: can be accepted or ignored by OSPF port.

  • IGNORE: Do not distribute this IP addresses into OSPF.
  • ACCEPT: Distribute this IP addresses into OSPF.

This means that all the routing present into IP Routings table that matches with EXTERNAL: will be imported into OSPF table in case that ACTION: is set to "ACCEPT" (and then will be used also specified metric METRIC:), and will be not imported in case that it is set to "IGNORE".

METRIC: | Metric used for redistribute this route
* | 0 - 16, *

This parameter sets the metric value that will be used for redistribution routes, of LOCAL:, STATIC: or RIP: type, imported from the IP Routings table into OSPF.

The value "*" stands for "use default metric", i.e. indicates to use the metric specified for the related protocol type PROT:, in OSPF port configuration.

TYPE: | Type of external route
1 | 1, 2

This parameter sets the type of External route.

Configuration of OSPF Hosts top

The table of OSPF Hosts collects information about "hosts", i.e. users (servers, workstations, etc.) directly connected to router.

The table of OSPF Hosts can hold up to 100 definitions.

OSPF Host definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF Hosts can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF Hosts are described in the OSPF Hosts section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF HOST:
C OSPF HOST:
D OSPF HOST
D OSPF HOST:
S OSPF HOST:

In the following example are displayed all the entries of the table of OSPF Hosts. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

---------------------------------------
HOST:            AREA:            COST:
---------------------------------------
010.000.000.001  010.000.000.000  65535
192.168.006.010  010.000.000.000     25
---------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF Host's parameters

HOST: | Host's IP address
no value | see below

This parameter sets the host's IP address, in Dotted Decimal Notation.

Valid IP addresses are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Host routes are advertised in router links advertisements as stub networks with mask 0xFFFFFFFF. They indicate either router interfaces to point-to-point networks, looped router interfaces, or IP hosts that are directly connected to the router (e.g., via a SLIP line).

AREA: | Owner's ID
0 | 0.0.0.0 - 255.255.255.255

This is a 32-bit number (Area ID) that identifies the owner area.

COST: | Cost of a route to the host
65535 | 1 - 65535

This parameter sets the cost of sending a packet to the host, in terms of the link state metric. However, since the host probably has only a single connection to the Internet, the actual configured cost in many cases is not important (i.e. it will have no effect on routing).

Configuration of OSPF Neighbours top

The table of OSPF Neighbours collects information about router's neighbors, i.e. routers that have interfaces to a common network. On multi-access networks (BMA), neighbors are dynamically discovered by OSPF's Hello Protocol. But for all other types of networks (NBMA, PP, UPP, PMP) neighbors must be configured.

The table of OSPF Neighbours can hold up to 100 definitions.

OSPF Neighbour definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF Neighbours can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF Neighbours are described in the OSPF Neighbours section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF NEIGH:
C OSPF NEIGH:
D OSPF NEIGH
D OSPF NEIGH:
S OSPF NEIGH:

In the following example are displayed all the entries of the table of OSPF Neighbours. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF NEIGH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

----------------------------------------------------------------
NEIGH:           IPP:   PRIO:   POLL:    COST:
----------------------------------------------------------------
010.000.000.001  NONE       0      10        0
192.168.006.011     1       0      13        0
----------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF Neighbour's parameters

NEIGH: | IP address
0.0.0.0 | 0.0.0.0, | 1.0.0.0 - 126.255.255.255, | 128.0.0.0 - 223.255.255.255

Thi is the neighbour's IP address.

IP addresses of class D and E are not actually supported.

This table contains the list of all other routers attached to the non-broadcast network. Each router is listed by its IP interface address on the network. Also, for each router listed, that router's eligibility to become Designated Router must be defined. When an interface to a non-broadcast network comes up, the router sends Hello Packets only to those neighbors eligible to become Designated Router, until the identity of the Designated Router is discovered.

IPP: | IP port number
NONE | NONE, 0 - 63

Each neighbor links with one OSPF interface only. This parameter defines the number of the IP port taht links with OSPF interface.

PRIO: | Neighbor's priority
0 | 0 - 255

Neighbor's priority.

POLL: | Neighbour's poll interval
10 | 1 - 65535

If a neighboring router has become inactive (Hello Packets have not been seen for Router Dead Interval seconds), it may still be necessary to send Hello Packets to the dead neighbour. These Hello Packets will be sent at the reduced rate Poll Interval, which should be much larger than Hello Interval. Sample value for a PDN X.25 network: 2 minutes (120 seconds).

COST: | Neighbour's cost
0 | 0 - 65535

Neighbor's cost.

Configuration of OSPF Ranges top

The table of OSPF Ranges holds information about ares's ranges. Routing information is condensed at area boundaries. External to the area, at most a single route is advertised (via a summary link advertisement) for each address range. The route is advertised if and only if the address range's Status is set to Advertise. Unadvertised ranges allow the existence of certain networks to be intentionally hidden from other areas.

The table of OSPF Ranges can hold up to 100 definitions.

OSPF Range definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF Ranges can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF Ranges are described in the OSPF Ranges section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF RANGE:
C OSPF RANGE:
D OSPF RANGE
D OSPF RANGE:
S OSPF RANGE:

In the following example are displayed all the entries of the table of OSPF Ranges. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF RANGE

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

---------------------------------------------------------
AREA:               RANGE:                ADV:
---------------------------------------------------------
000.000.000.000     192.168.006.000/24    NO
010.000.000.000     001.002.003.004/32    YES
---------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF Range's parameters

AREA: | Owner's ID
0.0.0.0 | 0.0.0.0 - 255.255.255.255

This is a 32-bit number (Area ID) that identifies the owner area.

RANGE: | Range address and mask
0.0.0.0 | [0.0.0.0, 1-126.x.x.x, 128-223.x.x.x]

This parameter corresponds to the range IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

Networks and hosts are assigned to an area depending on whether their addresses fall into one of the area's defining address ranges. Routers are viewed as belonging to multiple areas, depending on their attached networks' area membership.

ADV: | Advertise flag
YES | NO, YES

Routing information is condensed at area boundaries. External to the area, at most a single route is advertised (via a summary link advertisement) for each address range. The route is advertised if and only if the address range's Status is set to Advertise. Unadvertised ranges allow the existence of certain networks to be intentionally hidden from other areas. Status is set to Advertise (1) by default.

As an example, suppose an IP subnetted network is to be its own OSPF area. The area would be configured as a single address range, whose IP address is the address of the subnetted network, and whose mask is the natural class A, B, or C address mask.

A single route would be advertised external to the area, describing the entire subnetted network.

  • NO: Do not advertise.
  • YES: Advertise.

Configuration of OSPF Virtual links top

The table of OSPF Virtual links holds information about Virtual Links.
It is possible to define areas in such a way that the backbone area (0.0.0.0) is no longer contiguous. In this case the system administrator must restore backbone area connectivity by configuring virtual links.

Virtual links can be configured between any two backbone routers that have an interface to a common non-backbone area. Virtual links belong to the backbone area.

The protocol treats two routers joined by a virtual link as if they were connected by an unnumbered point-to-point network. On the graph of the backbone area, two such routers are joined by arcs whose costs are the intra-area distances between the two routers.

The routing protocol traffic that flows along the virtual link uses intra-area routing only.

The table of OSPF Virtual links can hold up to 16 definitions.

OSPF Virtual link definitions are kept sorted. News definition are added in the correct position of the table on the base of the currently defined entries. Likewise the entry deletion will cause the table to be rearranged.

The table of OSPF Virtual links can be modified while the Abilis CPX is working without needing to restart it. Changes made on the table can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

Commands for handling OSPF Virtual links are described in the OSPF Virtual Links section of the document Commands relating to OSPF Tables. The available commands are the following:

A OSPF VL REM-RID:
C OSPF VL REM-RID:
D OSPF VL
D OSPF VL REM-RID:
S OSPF VL REM-RID:

In the following example are displayed all the entries of the table of OSPF Virtual links. Displayed values are only samples.

[16:32:16] ABILIS_CPX: D OSPF VL

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
REM-RID:         AREA:           HELLO: RXMT: TRDEL: DEAD:  PWD:         KEYID:
                                                            MD5KEY:
-------------------------------------------------------------------------------
002.000.000.000  010.000.000.000     12     5      1    60                    0

020.001.001.001  000.000.000.000     10     5      1    60                    0

-------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

Detail of OSPF Virtual link's parameters

REM-RID: | Remote router ID
0.0.0.0 | 0.0.0.0 - 255.255.255.255

The Router ID of a remote router that is located in other end of VL.

AREA: | Owners area ID
0.0.0.1 | 0.0.0.1 - 255.255.255.255

Area ID of area that is used as transit area for this Virtual Link.

HELLO: | Hello interval
10 | 1 - 120 secs

The length of time, in seconds, between the Hello Packets that the router sends on the other point of VL. This value is advertised in the router's Hello Packets. It must be the same for both routers attached to a VL. The smaller the Hello Interval, the faster topological changes will be detected, but more OSPF routing protocol traffic will ensue.

RXMT: | Retransmission interval
5 | 1 - 150 secs

The number of seconds between link state advertisement retransmissions, for adjacencies belonging to this VL.

TRDEL: | Transmit delay interval
1 | 1 - 30 secs

The estimated number of seconds it takes to transmit a Link State Update Packet over this VL.

DEAD: | Dead interval
60 | 1 - 1200 secs

After ceasing to hear a router's Hello Packets, the number of seconds before its neighbor declare the router down. This is also advertised in the router's Hello Packets in their Router Dead Interval field. This value again must be the same for both routers attached to a VL.

PWD: | Authentication password
empty | From 0 up to 8 ASCII characters [33.127]

This parameter allows to set the Authentication password. Strings of up to 8 ASCII characters in the range [33..126] are accepted. Spaces are not allowed. The case of the entered password is preserved.

Cheracter string is contain a value of a password.

KEYID: | Key ID
0 | 0 - 255

This field identifies the algorithm and secret key used to create the message digest appended to the OSPF packet. Key Identifiers (Key ID) must be set equal at the two ends of the VL.

MD5KEY: | MD5 secret key
empty | From 0 up to 16 ASCII characters [33..126]

This parameter allows to set the MD5 secret key. Strings of up to 16 ASCII characters in the range [33..126] are accepted. Spaces are not allowed. The case of the entered key is preserved.

A shared secret key is configured in all routers attached to a common network/subnet. For each OSPF protocol packet, the key is used to generate/verify a "message digest" that is appended to the end of the OSPF packet. The message digest is a one-way function of the OSPF protocol packet and the secret key. Since the secret key is never sent over the network in the clear, protection is provided against passive attacks.

The algorithm's used to generate and verify the message digest are specified implicitly by the secret key. This specification completely defines the use of OSPF Cryptographic authentication when the MD5 algorithm is used.


IPsec policies, IPsec SAs tables

Revised for CPX 4.8.0.
Policy table of the IPsec port
Security Associations (SA) table of the IPsec port

Configuration examples (CPX-to-CPX)
Configuration examples (CPX-to-Win2k/XP)

Policy table of the IPsec port top

This table is used only in MANUAL mode of IPsec port.

The table of IPsec policies can store up to 128 entries, indexed starting from 0 up to 127.

In the table of IPsec policies, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT PO:xxx, where "xxx" is the IPsec port number.

Commands for handling IPsec Policies are described in the IPsec policy table section of the document Commands relating to IPsec.

The available commands are the following:

A IPSEC POLICY:
C IPSEC POLICY:
D IPSEC POLICY:
D IPSEC POLICY
S IPSEC POLICY:

Here is an example of the IPsec policy table:

[21:28:23] CPX_1:D IPsec POLICY
-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_1-to-CPX_2                   192.168.001.000/24 *
         OUT  0       IPSEC               192.168.003.000/24 *
-------------------------------------------------------------------------------
1        CPX_2-to-CPX_1                   192.168.003.000/24 *
         IN   1       IPSEC               192.168.001.000/24 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------

Here is an example of the single IPsec policy table record 0:

[00:15:04] ABILIS_CPX:D IPsec POLICY:0

Parameter:   |Value:
------------------------------------------------------------------------------
POLICY:       0
NAME:         CPX_1-to-CPX_2
DIR:          OUT
BUNDLE:       0
RULE:         IPSEC
NET-SRC:      192.168.002.001/32
NET-DST:      192.168.002.002/32
PORT-SRC:     *
PORT-DST:     *
------------------------------------------------------------------------------

Details of the IPsec policy table parameters

POLICY: | Policy record identifier
no default | 0-127

It is the policy record identifier. The identifier is a numeric value that is assigned by the system to the IPsec policy record when it is added the first time. It can be used for clearing/displaying and setting operations to reference the policy record.

NAME: | Name for the policy record
empty | from 0 up to 32 ASCII printable characters. Spaces are not allowed. Case is preserved.

Specifies name for the current policy record.

DIR: | Direction for this policy record
OUT | IN, OUT

Specifies direction for this policy record.

OUT: Outbound direction.
IN: Inbound direction.

BUNDLE: | Number of SA bundle
NONE | NONE, 0-127

Specifies number of SA bundle group associated with this policy record.

Value NONE means "not defined". For the IPSEC rule, group number must be present in SA table

RULE: | Rule for this policy record
IPSEC | BYPASS, DROP, IPSEC

Specifies rule for this policy record.

BYPASS: IP packet will be bypassed by IPsec driver. Outbound direction only.
DROP: IP packet will be dropped by IPsec driver. Outbound direction only.
IPSEC: IP packet will be processed by IPsec.

NET-SRC: | Source subnet address and mask
0.0.0.0/0 | net: 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255 mask: 0-32

Specifies network address and mask of the source subnet/host in Slash Notation [x.x.x.x/yy].

NET-DST: | Destination subnet address and mask
0.0.0.0/0 | net: 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255 mask: 0-32

Specifies network address and mask of the destination subnet/host in Slash Notation [x.x.x.x/yy].

PORT-SRC: | Source port of the upper protocol
* | 1-65535

Specifies source port of the upper protocol (TCP, UDP).

PORT-DST: | Destination port of the upper protocol
* | 1-65535

Specifies destination port of the upper protocol (TCP, UDP).

Security Associations (SA) table of the IPsec port top

This table is used only in MANUAL mode of IPsec port.

The table of IPsec Security Associations can store up to 128 entries, indexed starting from 0 up to 127.

In the table of IPsec Security Associations, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT PO:xxx, where "xxx" is the IPsec port number.

Commands for handling Security Associations are described in the IPsec Security Associations table section of the document Commands relating to IPsec.

The available commands are the following:

A IPSEC SA:
C IPSEC SA:
D IPSEC SA:
D IPSEC SA
S IPSEC SA:

Here is an example of the IPsec SA table. SA bundle: ESP protocol with MD5 authentication and 3DES encryption, AH protocol with SHA-1 authentication:

[21:25:43] CPX_1:D IPsec SA

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2_ESP   00000200       192.168.002.001 ESP   MD5      3DES
     OUT  0       YES     1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_2_AH    00000201       192.168.002.001 AH    SHA
     OUT  0       NO      1      AUTO    192.168.002.002       *******
-------------------------------------------------------------------------------
2    CPX_2-to-CPX_1_AH    00000401       192.168.002.002 AH    SHA
     IN   1       NO      1      AUTO    192.168.002.001       *******
-------------------------------------------------------------------------------
3    CPX_2-to-CPX_1_ESP   00000400       192.168.002.002 ESP   MD5      3DES
     IN   1       YES     1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------

Here is an example of the IPsec SA table record 0 (single SA). ESP protocol without authentication and IDEA encryption:

[00:12:22] ABILIS_CPX:D IPsec SA:0

Parameter:   |Value:
------------------------------------------------------------------------------
SA:           0
NAME:         CPX_1-to-CPX_2_ESP
SPI:          00010ABC
DIR:          OUT
BUNDLE:       0
SRC-IP:       192.168.002.001
DST-IP:       192.168.002.002
PROT:         ESP
AUTH:         NONE
CIPHER:       IDEA
ENCKEY:       ********
TUNNEL:       NO
IPP:          1
SIDE:         AUTO
------------------------------------------------------------------------------

Details of the IPsec SA table parameters

SA: | Security Association record identifier
no default | 0-127

It is the Security Association record identifier. The identifier is a numeric value that is assigned by the system to the IPsec Security Association record when it is added the first time. It can be used for clearing/displaying and setting operations to reference the policy record.

NAME: | Name of the Security Association record
empty | from 0 up to 32 ASCII printable characters. Spaces are not allowed. Case is preserved.

Specifies name of the current Security Association record.

SPI: | Security Parameter Index (SPI).
NONE | 0x100-0xFFFFFFFF

Specifies Specifies Security Parameter Index (SPI) for this Security Association record.

Each SA must have unique value of SPI within the table.

DIR: | Direction for this Security Association record
OUT | IN, OUT

Specifies direction for this Security Association record.

OUT: Outbound direction.
IN: Inbound direction.

BUNDLE: | Number of SA bundle group
NONE | NONE, 0-127

Specifies number of Security Association bundle group.

Value NONE means "not defined". All SAs which have identical group number will be grouped to the one bundle with the same number. Group cannot have SAs with different directions

SRC-IP: | Source IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

Specifies source IP address for the this Security Association record.

DST-IP: | Destination IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

Specifies destination IP address for the this Security Association record.

PROT: | IPsec protocol.
AH | AH, ESP

Specifies IPsec protocol for this Security Association record.

AH: IPsec Authentication Header protocol
ESP: IPsec Encapsulating Security Payload protocol.

AUTH: | Authentication method for the AH or ESP protocols.
NONE | NONE, MD5, SHA

Specifies authentication method for the AH or ESP protocols for this Security Association record.

NONE: No authentication. MD5: Message Digest Algorithm MD5.
SHA: Message Digest Algorithm SHA-1.

CIPHER: | Encryption algorithm for the ESP protocol.
NONE | NONE, DES, 3DES, IDEA, CAST, BLOWFISH, AES128, AES192, AES256

Specifies encryption algorithm for ESP protocol for this Security Association record.

NONE: No encryption. DES: DES encryption algorithm in CBC mode.
3DES: Triple DES encryption algorithm in CBC mode.
IDEA: IDEA encryption algorithm in CBC mode.
CAST: CAST encryption algorithm in CBC mode.
BLOWFISH: BLOWFISH encryption algorithm in CBC mode.
AES128: AES encryption algorithm in CBC mode with 128 bits key length.
AES192: AES encryption algorithm in CBC mode with 192 bits key length.
AES256: AES encryption algorithm in CBC mode with 256 bits key length.

AUTHKEY: | Manual authentication key for the AH or ESP protocols.
empty | ASCII printable string. Case is preserved. Spaces are allowed. For MD5 authentication key: exactly 16 characters are required. For SHA authentication key: exactly 20 characters are required.

Specifies manual authentication key for the AH or ESP protocols for this Security Association record.

ENCKEY: | Manual encryption key for the ESP protocol.
empty | ASCII printable string. Case is preserved. Spaces are allowed. For DES encryption key: exactly 8 characters are required. For IDEA, CAST, BLOWFISH and AES128 encryption key: exactly 16 characters are required. For 3DES and AES192 encryption key: exactly 24 characters are required. For AES256 encryption key: exactly 32 characters are required.

Specifies manual encryption key for the ESP protocol for this Security Association record.

TUNNEL: | Tunnel mode flag.
NO | NO, YES

Specifies tunnel mode for this Security Association record.

NO: Tunnel mode is disabled. Security Association in transport mode.
YES: Tunnel mode is enabled. Security Association in tunnel mode.

IPP: | Tunnel IP port.
# | #, 0-63

Specifies IPP used for this record. This information is used to associate current SA record with an IP port

SIDE: | NAT side type of tunnel.
AUTO | NONE, INSIDE, OUTSIDE, AUTO

Specifies NAT side type of tunnel (when available).


IKE hosts, IKE clients, IKE PSK tables

Revised for CPX 4.8.0.
Host connection table of the IKE port
Client connection table of the IKE port
Pre-shared key (PSK) table of the IKE port

Configuration examples (CPX-to-CPX)
Configuration examples (CPX-to-Win2k/XP)

Host connection table of the IKE port top

The table of IKE hosts can store up to 32 entries, indexed starting from 0 up to 31.

In the table of IKE hosts, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT PO:xxx, where "xxx" is the IKE port number.

Commands for handling IKE hosts are described in the IKE host table section of the document Commands relating to IKE.

The available commands are the following:

A IKE HOST:
C IKE HOST:
D IKE HOST:
D IKE HOST
S IKE HOST:

Here is an example of the IKE host table:

[21:30:22] ABILIS_CPX:D IKE HOST

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
1     CPX_1-to-CPX_3                   192.168.002.001      1       3
      IDEA      PSK   SHA   MODP1536   *                    AUTO    3600
      IP              192.168.002.001
      FQDN                             www.antek.it
-------------------------------------------------------------------------------

Here is an example of the single IKE host connection 0:

[11:18:29] ABILIS_CPX:D IKE HOST:0

Parameter:   |Value:
------------------------------------------------------------------------------
HOST:         0
NAME:         CPX_1-to-CPX_2
LOC-IP:       192.168.002.001
REM-IP:       192.168.002.002
CIPHER:       3DES
AUTH:         PSK
HASH:         MD5
DH:           MODP1024
KEY-TRIES:    3
LIFE-TIME:    3600
ID-TYPE:      IP
IP:           192.168.002.001
PEER-ID-TYPE: IP
PEER-IP:      192.168.002.002
IPP:          0
SIDE:         AUTO
------------------------------------------------------------------------------

Details of the IKE host table parameters

HOST: | Host connection identifier
no default | 0-31

It is the host connection identifier. The identifier is a numeric value that is assigned by the system to the IKE host connection when it is added the first time. It can be used for clearing/displaying and setting operations to reference the host connection.

NAME: | Name of the host connection
empty | from 0 up to 32 ASCII printable characters. Spaces are not allowed. Case is preserved.

Specifies name of the current host connection.

LOC-IP: | Local IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x, 0-63

Specifies local IP address for the this host connection.

0-63: IP port. The IKE driver uses specified IP Port to get information about local IP address to use.
0.0.0.0, 1-126.x.x.x, 128-223.x.x.x: IP address. The driver uses specified value as local IP address.

REM-IP: | Remote IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x, *, 1- 64

*: Any IP address. The IKE driver accepts all remote IP addresses (only for responder).
1-64: IP list. The IKE driver accepts only remote IP addresses present into specified list (only for responder).
0.0.0.0, 1-126.x.x.x, 128-223.x.x.x: IP address. The IKE driver uses specified value as remote IP address.

CIPHER: | Encryption algorithm for the ISAKMP/OAKLEY negotiation (ISAKMP SA).
NONE | NONE, DES, 3DES, IDEA, CAST, BLOWFISH, AES128, AES192, AES256

Specifies encryption algorithm for Encryption algorithm for the ISAKMP/OAKLEY negotiation (ISAKMP SA) for this host connection.

NONE: No algorithms. DES: DES encryption algorithm in CBC mode.
3DES: Triple DES encryption algorithm in CBC mode.
IDEA: IDEA encryption algorithm in CBC mode.
CAST: CAST encryption algorithm in CBC mode.
BLOWFISH: BLOWFISH encryption algorithm in CBC mode.
AES128: AES encryption algorithm in CBC mode with 128 bits key length.
AES192: AES encryption algorithm in CBC mode with 192 bits key length.
AES256: AES encryption algorithm in CBC mode with 256 bits key length.

AUTH: | Authentication method for the ISAKMP/OAKLEY negotiation (ISAKMP SA).
PSK | PSK

Specifies authentication method for the ISAKMP/OAKLEY negotiation (ISAKMP SA) for this host connection.

PSK: Message Digest Algorithm SHA-1.

HASH: | Hash algorithm for the ISAKMP/OAKLEY negotiation (ISAKMP SA).
MD5 | MD5, SHA

Specifies authentication method for the ISAKMP/OAKLEY negotiation (ISAKMP SA) for this host connection.

MD5: Message Digest Algorithm MD5.
SHA: Message Digest Algorithm SHA-1.

DH: | Diffi-Hellman group for the ISAKMP/OAKLEY negotiation (ISAKMP SA).
MODP1024 | MODP768, MODP1024, MODP1536

Specifies Diffi-Hellman group for the ISAKMP/OAKLEY negotiation (ISAKMP SA) for this host connection.

MODP768: 768 Diffi-Hellman group.
MODP1024: 1024 Diffi-Hellman group.
MODP1536: 1536 Diffi-Hellman group

ID-TYPE: | Type of local host ID.
AUTO | AUTO, IP, FQDN, USER-FQDN

Specifies type of local host ID for this host connection.

AUTO: Local ID will be set automatically in run-time as local IP address.
IP: Local ID is local IP address.
FQDN: Local ID is fully-qualified domain name (FQDN), e.g. www.antek.it.
USER-FQDN: Local ID is fully-qualified user domain name (FQDN), e.g. konstt@antek.it.

IP: | Specifies local host ID as IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

Specifies local host ID as IP address.

This value is used only if ID-TYPE parameter is set to IP.

FQDN: | Specifies local host ID as FQDN or USER-FQDN.
empty | FQDN: From 0 up to 64 characters, range: ['0'..'9', 'A'..'Z', 'a'..'z', '-', '.']. USER-FQDN must be an ASCII printable user name string, where spaces are not allowed, plus a '@' character and a FQDN string. Case is not preserved.

Specifies local host ID as as FQDN or USER-FQDN.

This value is used only if ID-TYPE parameter is set to FQDN or USER-FQDN.

PEER-ID-TYPE: | Type of peer host ID.
AUTO | AUTO, IP, FQDN, USER-FQDN

Specifies type of peer host ID for this host connection.

AUTO: Peer ID will be set automatically in run-time as remote IP address.
IP: Peer ID is remote IP address.
FQDN: Peer ID is fully-qualified domain name (FQDN), e.g. www.antek.it.
USER-FQDN: Peer ID is fully-qualified user domain name (FQDN), e.g. konstt@antek.it.

PEER-IP: | Specifies peer host ID as IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

Specifies peer host ID as IP address.

This value is used only if PEER-ID-TYPE parameter is set to IP.

PEER-FQDN: | Specifies peer host ID as FQDN or USER-FQDN.
empty | FQDN: From 0 up to 64 characters, range: ['0'..'9', 'A'..'Z', 'a'..'z', '-', '.']. USER-FQDN must be an ASCII printable user name string, where spaces are not allowed, plus a '@' character and a FQDN string. Case is not preserved.

Specifies peer host ID as as FQDN or USER-FQDN.

This value is used only if PEER-ID-TYPE parameter is set to FQDN or USER-FQDN.

IPP: | Tunnel IP port.
# | #, 0-63

Specifies IP port used for this host connection.

SIDE: | NAT side type of tunnel.
AUTO | NONE, INSIDE, OUTSIDE, AUTO

Specifies NAT side type of tunnel (when available).

KEY-TRIES: | Number of ISAKMP SA rekeying.
3 | INFINITE, 1-100

Specifies how many times IKE should try to negotiate an ISAKMP SA, either for the first time or for rekeying.

LIFE-TIME: | Life time of ISAKMP SA.
3600 | 900-28800

Specifies how long IKE will propose that an ISAKMP SA be allowed to live.

Client connection table of the IKE port top

The table of IKE clients can store up to 64 entries, indexed starting from 0 up to 63.

In the table of IKE clients, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT PO:xxx, where "xxx" is the IKE port number.

Commands for handling IKE hosts are described in the IKE client table section of the document Commands relating to IKE.

The available commands are the following:

A IKE CLI:
C IKE CLI:
D IKE CLI:
D IKE CLI
S IKE CLI:

Here is an example of the IKE client connection table:

[21:25:43] CPX_1:D IKE CLI

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_3                   1        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.004.000/24
-------------------------------------------------------------------------------

Here is an example of the IKE client table record 0:

[14:22:45] ABILIS_CPX:D IKE CLI:0

- Not Saved (SAVE CONF) -------------------------------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
CLI:          0
NAME:         CPX_1-to-CPX_2
HOST-ID:      0
RULE:         IPSEC
PASSIVE:      YES
PERMANENT:    YES
TUNNEL:       YES
ESP:          YES
ESP-CIPHER:   3DES
ESP-AUTH:     MD5
AH:           NO
AH-AUTH:      MD5
LIFE-TIME:    28800
PFS:          YES
NET-SRC:      192.168.001.000/24
NET-DST:      192.168.003.000/24
------------------------------------------------------------------------------

Details of the IKE client table parameters

CLI: | Client connection identifier
no default | 0-63

It is the client connection identifier. The identifier is a numeric value that is assigned by the system to the IKE client connection when it is added the first time. It can be used for clearing/displaying and setting operations to reference the client connection.

NAME: | Name of the client connection
empty | from 0 up to 32 ASCII printable characters. Spaces are not allowed. Case is preserved.

Specifies name of the current client connection.

HOST-ID: | Identifier of host connection
NONE | NONE, 0-31

Specifies identifier of IKE host connection associated with this client connection.

Value NONE means "not defined". For the client connection with IPSEC rule, this parameter must not be NONE. The host connection with HOST-ID identifier must be present in the host connection table

RULE: | Rule for this client connection
IPSEC | BYPASS, DROP, IPSEC

Specifies rule for this client connection.

BYPASS: IP packet will be bypassed by IPsec driver.
DROP: IP packet will be dropped by IPsec driver.
IPSEC: IP packet will be processed by IPsec.

PASSIVE: | Initiate mode of IKE negotiation
YES | NO, YES

Specifies initiate mode of IKE negotiation.

NO: Negotiation can be started as initiator (by IPsec driver request or if this connection is PERMANENT) and as responder.
YES: Client connection is passive (IPsec server). Negotiation can be started as responder only.

This parameter takes effect only for client connections with IPSEC rule.

PERMANENT: | Initiate mode of IKE negotiation
YES | NO, YES

Specifies initiate mode of IKE negotiation.

NO: Initiation of this connection never starts automatically.
YES: After start of the IKE driver or after INIT PO:IKE command, (re-)negotiation of this connection is started automatically as initiator. Negotiated connection is saved into the IKE.CNS file.

This parameter takes effect only for client connections with IPSEC rule.

TUNNEL: | Tunnel mode flag.
NO | NO, YES

Specifies tunnel mode for this client connection.

NO: Tunnel mode is disabled. Transport mode.
YES: Tunnel mode is enabled.

AH: | Enable/disable AH IKE protocol.
NO | NO, YES

Enable/disable AH IKE protocol for this client connection.

NO: IPsec protocol AH is disable.
YES: IPsec protocol AH is enable.

This parameter takes effect only for client connections with IPSEC rule.

AH-AUTH: | Authentication method for the AH protocol.
MD5 | MD5, SHA

Specifies authentication method for the AH protocol for this client connection.

MD5: Message Digest Algorithm MD5.
SHA: Message Digest Algorithm SHA-1.

This parameter takes effect only for client connections with IPSEC rule.

ESP: | Enable/disable ESP IKE protocol.
YES | NO, YES

Enable/disable ESP IKE protocol for this client connection.

NO: IPsec protocol ESP is disable.
YES: IPsec protocol ESP is enable.

This parameter takes effect only for client connections with IPSEC rule.

ESP-AUTH: | Authentication method for the ESP protocol.
MD5 | NONE, MD5, SHA

Specifies authentication method for the ESP protocol for this client connection.

NONE: No authentication.
MD5: Message Digest Algorithm MD5.
SHA: Message Digest Algorithm SHA-1.

This parameter takes effect only for client connections with IPSEC rule.

ESP-CIPHER: | Encryption algorithm for the ESP protocol.
3DES | NONE, DES, 3DES, IDEA, CAST, BLOWFISH, AES128, AES192, AES256

Specifies encryption algorithm for ESP protocol for this client connection.

NONE: No encryption. DES: DES encryption algorithm in CBC mode.
3DES: Triple DES encryption algorithm in CBC mode.
IDEA: IDEA encryption algorithm in CBC mode.
CAST: CAST encryption algorithm in CBC mode.
BLOWFISH: BLOWFISH encryption algorithm in CBC mode.
AES128: AES encryption algorithm in CBC mode with 128 bits key length.
AES192: AES encryption algorithm in CBC mode with 192 bits key length.
AES256: AES encryption algorithm in CBC mode with 256 bits key length.

This parameter takes effect only for client connections with IPSEC rule.

LIFE-TIME: | Life time of IPsec SAs which are associated with current client connection.
28800 | 14400-86400

Specifies how long IKE will propose that an IPsec SA be allowed to live.

This parameter takes effect only for client connections with IPSEC rule.

PFS: | Enable/disable Perfect Forward Secrecy (PFS).
YES | NO, YES

Enable/disable PFS for IPsec SA negotiation for this client connection.

NO: PFS is disable.
YES: PFS is enable.

This parameter takes effect only for client connections with IPSEC rule.

NET-SRC: | Source subnet address and mask.
0.0.0.0/0 | net: 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255 mask: 0-32

Specifies network address and mask of the source subnet/host in Slash Notation [x.x.x.x/yy].

NET-DST: | Destination subnet address and mask.
0.0.0.0/0 | net: 0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255 mask: 0-32

Specifies network address and mask of the destination subnet/host in Slash Notation [x.x.x.x/yy].

Pre-shared key (PSK) table of the IKE port top

The table of IKE psk can store up to 64 entries, indexed starting from 0 up to 63.

In the table of IKE psk, configurations may be added, modified, deleted while the Abilis CPX is working, without needing to restart it. Changes made in the table are immediately actives by executing the command INIT PO:xxx, where "xxx" is the IKE port number.

Commands for handling IKE psk are described in the IKE psk table section of the document Commands relating to IKE.

The available commands are the following:

A IKE PSK:
C IKE PSK:
D IKE PSK:
D IKE PSK
S IKE PSK:

Here is an example of the IKE PSK table:

[21:25:43] ABILIS_CPX:D IKE PSK

- Not Saved (SAVE CONF) -------------------------------------------------------

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.001
1    ******** ANONYMOUS
2    ******** FQDN                      konstt

Here is an example of the IKE PSK table record 0:

[15:57:03] ABILIS_CPX:D IKE PSK:2

- Not Saved (SAVE CONF) -------------------------------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PSK:          2
KEY:          ********
ID-TYPE:      FQDN
FQDN:         konstt
------------------------------------------------------------------------------

Details of the IKE PSK table parameters

PSK: | PSK record identifier
no default | 0-63

It is the PSK record identifier. The identifier is a numeric value that is assigned by the system to the IKE PSK record when it is added the first time. It can be used for clearing/displaying and setting operations to reference the PSK record.

ID-TYPE: | Type of peer host ID.
UNDEF | UNDEF, IP, FQDN, USER-FQDN, ANONYMOUS

Specifies type of peer host ID for this PSK record.

UNDEF: "not assigned".
IP: ID is peer IP address.
FQDN: Peer ID is fully-qualified domain name (FQDN), e.g. www.antek.it.
USER-FQDN: Peer ID is fully-qualified user domain name (FQDN), e.g. konstt@antek.it.
ANONYMOUS: Used to keep PSK for anonymous peer's.

IP: | Specifies peer host ID as IP address.
0.0.0.0 | 0.0.0.0, 1-126.x.x.x, 128-223.x.x.x

Specifies peer host ID as IP address.

This value is used only if ID-TYPE parameter is set to IP.

FQDN: | Specifies peer host ID as FQDN or USER-FQDN.
empty | FQDN: From 0 up to 64 characters, range: ['0'..'9', 'A'..'Z', 'a'..'z', '-', '.']. USER-FQDN must be an ASCII printable user name string, where spaces are not allowed, plus a '@' character and a FQDN string. Case is not preserved.

Specifies peer host ID as as FQDN or USER-FQDN.

This value is used only if ID-TYPE parameter is set to FQDN or USER-FQDN.

KEY: | Specifies value of the pre-shared key.
empty | From 0 up to 64 ASCII printable characters. Case is preserved. Spaces are allowed. Strings holding spaces must be written between quotation marks (E.g.: "my key").

Specifies value of the pre-shared key.


PVC connections

Configuration of PVC connections
Configuration examples
EXAMPLE N.1
EXAMPLE N.2

About SVC and PVC

Configuration of PVC connections top

In Abilis CPX, PVC connections represent a permanent links between two logical channels of two communication ports; they also define the compression protocols to be used.

The main functions provided by the PVC connections are:

  • Setting a connection identifier;
  • Choosing source port and source logical channel;
  • Choosing destination port and destination logical channel;
  • Choosing compression protocol to be used.

The PVC connections table is initially empty: it has to be configured if on the two communications ports are present PVC channels to be connected.

PVC connections activation is dynamic, so that any add, delete or change can be activated by using the commands C C and R PVC.

All the commands for PVC connections management are described in the section PVC connections of the chapter Commands relating to the Connection Oriented Router.

The following commands are available:

A PVC
C PVC
D PVC
S PVC
R PVC

Here is an example of the command D PVC execution. Values shown for connections from 1 to 3 are interesting examples for displaying some features of the PVC connections, values of the connection 4 are the default ones of the command A PVC:

  • Both ports can be source and/or destination. Setting order is not important.
  • PVC channels of the two ports can be "crossed".
  • Connection just set are not yet active: ST:2.
  • Not valid connections (POI:1 SESI:1 is already in use) are marked and "frozen": ST:1.
[18:14:08] ABILIS_CPX: D PVC

- Not Saved (SAVE CONF) -------------------------------------------------------

ID:0   ST:2  POI:301   SESI:1     PWI:7   COMP:MBIT
             POO:302   SESO:1     PWO:7

ID:1   ST:2  POI:302   SESI:3     PWI:1   COMP:MBIT
             POO:301   SESO:2     PWO:1

ID:2   ST:1  POI:301   SESI:1     PWI:2   COMP:NO
             POO:302   SESO:4     PWO:2

ID:3   ST:2  POI:302   SESI:2     PWI:6   COMP:NO
             POO:301   SESO:3     PWO:5

ID:4   ST:2  POI:NONE  SESI:NONE  PWI:2   COMP:NO
             POO:NONE  SESO:NONE  PWO:2

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Detail of the PVC connection parameters

ID: | Identifier of the PVC connection
no value | from 0 to 63

The identifier sets the activation sequence of the PVC connections. Adding, modifying and deleting commands also use it as reference to the PVC connection.

PVC channels activation starts from the lowest identifier until it reaches the last. As consequence, if there are two PVC connections wrongly using the same port and logical channel, then the one with the lowest identifier will be activated (ST:3), the other will be set as "not valid PVC connection" (ST:1).

Identifiers, in the PVC connection table, are kept in sequential order; when an identifier is added or deleted, the table is re-sorted.

Notice! PVC connections inserted or modified can be activated without restarting the Abilis CPX, by using the commands C C and R PVC.

ST: | PVC connection state
2 | 0, 1, 2, 3

It is the current state of the PVC connection. Default value is the connection state when it is added by using the command A PVC.

The meaning of the states is the following:

State | Meaning
0 | Undefined state.
1 | PVC connection is not valid. Probable errors and/or parameters conflicts.
2 | PVC connection has been set but not activated. IT will be activated on the next Abilis restart, or by executing the command R PVC. Even if the configuration is syntactically correct, eventual errors and/or conflicts in parameters will be detected only during its activating.
3 | PVC connection is active.
POI: | Source port of the PVC connection
NONE | 1 - 999, NONE

It sets the source port of the PVC connection.

The value "NONE" stands for "no port", it can be used to deactivate the connection without deleting it.

Distinction between source/destination port is meaningless for the PVC connection configuration, it is used only for distinguish the parameters "logical channel (SESI: e SESO:)" and "packet window (PWI: e PWO:)" relating to each port.

POO: | Destination port of the PVC connection
NONE | 1 - 999, NONE

It sets the destination port of the PVC connection.

The value "NONE" stands for "no port", it can be used to deactivate the connection without deleting it.

Distinction between source/destination port is meaningless for the PVC connection configuration, it is used only for distinguish the parameters "logical channel (SESI: e SESO:)" and "packet window (PWI: e PWO:)" relating to each port.

SESI: | Logical channel number of the source port
NONE | 1 - 255, NONE

It sets which logical channel of the source port is going to be used in the PVC connection.

The value "NONE" stands for "no logical channel", it can be used to deactivate the connection without deleting it.

The logical channel specified must be a PVC valid one, otherwise the connection will be set as "PVC connection not valid" (ST:1).

SESO: | Logical channel number of the destination port
NONE | 1 - 255, NONE

It sets which logical channel of the destination port is going to be used in the PVC connection.

The value "NONE" stands for "no logical channel", it can be used to deactivate the connection without deleting it.

The logical channel specified must be a PVC valid one, otherwise the connection will be set as "PVC connection not valid" (ST:1).

PWI: | Packet window to be used for SESI:
2 | from 1 to 7

It specifies which packet window is used for the logical channel specified in SESI: of the port specified in POI:.

Parameter is meaningful only for X25 ports type. If the input port is modified to a not X25 port type, the packet window is automatically set to 1.

PWO: | Packet window to be used for SESO:
2 | from 1 to 7

It specifies which packet window is used for the logical channel specified in SESO: of the port specified in POO:.

Parameter is meaningful only for X25 ports type. If the input port is modified to a not X25 port type, the packet window is automatically set to 1.

COMP: | Compression protocol to be used
NO | NO, QLLC, MBIT

It sets the compression protocol to use on data exchanging, once the PVC connections is established.

Value | Meaning
NO | No compression protocol is associated to the PVC connection; data "pass transparent through" the Abilis CPX. It has to be used for PVC connections set on system different from the Abilis CPX, or for connections that don't have to be compressed.
QLLC | To the PVC connection is associated the QLLC compression protocol
MBIT | To the PVC connection is associated the MBIT compression protocol

it is necessary that both parts of the same PVC connection set this parameter to the same value.

MBIT protocol has a system able to detect the protocol used by the counterpart. If they are not the same, Abilis CPX closes the PVC connection and generates a X25 RESET with F0,40 cause codes. However in internal diagnostics the RESET will be generated with F0,AA cause codes (Compression protocol not compatible).

QLLC doesn't have this system, so the error may not be immediately detected, causing the DTE to generate a RESET owing to not valid data.

it is also possible the Abilis detects the error before the DTE. Abilis will close the PVC connection and generate a X25 RESET with F0,40 cause codes. However in the internal diagnostics the RESET will be generated with F0,C2 cause codes (expansion error) or F0,C3 (Format of data compressed not valid).

Configuration examples top

Here are some examples, useful to distinguish the above-mentioned functions:

EXAMPLE N.1

ID:0   ST:3  POI:301   SESI:1     PWI:7   COMP:NO
             POO:302   SESO:1     PWO:7

ID: | represents the PVC connection identifier to be used by the PVC connections management commands.
ST: | represents the current status of the connection.
POI: and SESI: | represent source port and logical channel.
PWI: | represents the packet window to be used for the source logical channel.
POO: and SESO: | represent destination port and logical channel.
PWO: | represents the packet window to be used for the destination logical channel.
COMP: | compression protocol to be used. In the example, no compression protocol is used.

Abilis CPX is instructed to set a permanent connection between logical channel "1" of port "301" and logical channel "1" of port "302", without using any compression protocol, independently of what the parameters communications ports are set to.

Changes made on the PVC connections can be activated without restarting the Abilis CPX, by using the commands C C and R PVC.

EXAMPLE N.2

ID:0   ST:3  POI:301   SESI:4     PWI:7   COMP:MBIT
             POO:302   SESO:5     PWO:7

In this example, Abilis CPX is instructed to set a permanent connection between logical channel "4" of port "301" and logical channel "5" of port "302", using the MBIT compression protocol and packet window "7", independently of what the parameters communications ports are set to.


SVC routings

Configuration of SVC routings
Configuration examples
EXAMPLE N.1
EXAMPLE N.2
EXAMPLE N.3
EXAMPLE N.4

About SVC and PVC

Configuration of SVC routings top

In the SVC routings table are stored the information needed to identify the incoming call and to route it to the wished port. Moreover every SVC routing contains data of the outgoing call and information on the compression protocol to be used.

The functions realized through SVC routing are:

  • setting the priority order of routings verification;
  • identifying the incoming call;
  • setting the destination port;
  • if necessary, to modify the data call (gateway function);
  • choosing the compression protocol to use.

If the call, selected by the routing, fails to reach its destination, it is possible to repeat the routing search procedure.

The functionality of alternative routing must be expected by the routing previously used.

The SVC routings table contains by default four routings: two routings for being able itself to connect to the Control Port and two routings in order to allow the calls "to pass" the Abilis CPX in transparent way.

Routings can be added, modified, deleted while the Abilis CPX works, without needing to restart it.

Calls, incoming after the changes, will use the new table, while those in course will remain active with the previous parameters values, until their closing.

All the commands for the SVC routings management are described in the section SVC Routing of the chapter Commands relating to the Connection Oriented Router.

The available commands are the following:

A R
C R
D R
D RE
M R
S R

Example of displaying all the SVC routings:

[18:14:08] ABILIS_CPX: D R

- Not Saved (SAVE CONF) -------------------------------------------------------

---+----+----+----+---------------+---------------+------------+--------------
PR |COMP|POI |POO |CDI            |CDO            |UDI         |UDO
   |NEXT|         |CGI            |CGO            |PIDI        |PIDO
   |              |IPSRC          |IPDEST         |FFO
------------------------------------------------------------------------------
0   NO   *    0    *               *               CP           *
    NO             *               *               *            *
                                                   *
------------------------------------------------------------------------------
1   NO   301  302  *               *               *            *
    NO             *               *               *            *
                                                   *
------------------------------------------------------------------------------
2   NO   302  301  *               *               *            *
    NO             *               *               *            *
                                                   *
------------------------------------------------------------------------------
3   NO   907  NONE 007             *               *            *
    NO             *               *               *            *
                   'ipsrc_list'                    *
------------------------------------------------------------------------------
4   NO   NONE 907  *               007             *            *
    NO             *               *               *            *
                                   192.168.000.007 *
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Example of displaying, using an extended format, of all the SVC routings:

[18:14:08] ABILIS_CPX: D RE

PR:0   POI:*    POO:0    COMP:NO
NEXT:N CGI:*               CDI:*               UDI:CP           PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:1   POI:301  POO:302  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:2   POI:302  POO:301  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:3   POI:907   POO:*    COMP:NO   IPSRC:'ipsrc_list'
NEXT:N CGI:*               CDI:007             UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:4   POI:*    POO:907   COMP:NO                         IPDEST:192.168.000.007
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:007             UDO:*            PIDO:*
       FFO:*

Example of displaying, in an extended format, a single routing. Values are examples of a particular SVC routing that allows receiving/placing X.25 calls from/to TCP/IP using XTP port type.

[18:14:08] ABILIS_CPX: D RE PR:3

PR:3   POI:907   POO:907   COMP:NO   IPSRC:'ipsrc_list'   IPDEST:192.168.000.007
NEXT:N CGI:*               CDI:007             UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

The optional parameter IPSRC: is also shown. It can be configured only if the input port (POI: ) type is XTP.

The optional parameter IPDEST: is shown, it can only be configured if the output port (POO:) type is XTP.

For more detailed information about management of X.25 traffic over TCP/IP refer to the section The X.25 ports, session tunnelling protocol (XTP).

Detail of the SVC routing parameters

PR: | Routing priority (Priority 0 is the highest)
no value | from 0 up to 99

The routing priority index sets the routing verification order for each incoming call.

The verification starts from the routing with priority 0 and continues until a routing is found matching the incoming call or the end of the table is reached.

The routing priority index is also used like reference for the operations of insertion, modification and deleting.

The SVC routings table is automatically maintained with consecutive indexes of priority, that is without "empty" places. Therefore every action of deleting or insertion makes the system to reorder all the indexes succeeding the referred one.

If an incoming call does not match any routing, the Abilis CPX will refuse the call with the codes F0,A0 (Customer not Configured. No routing matches the call).

POI: | Input port of the call
NONE | 0 - 999, *, NONE

It sets the port from wich the call has to come-in for matching the routing. The number must correspond to an active port inside the system.

The value "NONE", that indicates "no port", can be used for deactivating the routing without cancelling it.

The value "*" is used in order to specify "any port". It is usually used for routings accessing the Control Port.

POO: | Output port of the call
NONE | 0 - 999, NONE

It sets the output port to which the call that matched the routing will be routed.

The number must correspond to an active port inside the system.

The value "NONE" indicates "no port" and can be used in order to refuse, through this routing, undesired calls.

CGI: | CALLING address of the incoming call
* | from 1 up to 15 decimal digits 0 - 9, *, #, ?, 'ListName'

It sets the calling address that satisfies the routing.

If "CGI:" contains only the character "*", any calling address satisfies the routing.

The character "*" can be used at the beginning or at the end of a sequence of digits with the meaning of "any digit or character and any number of digits and characters" (E.g.: "*123" or "321*").

If "CGI:" contains only the character "#", no calling address must be present in the incoming call in order to satisfy the routing.

If "CGI:" contains only the character "?", any calling address made of only one digit satisfies the routing. The character "?" can be used in a sequence of digits with the meaning of "any digit" (E.g.: "f?654f" or "1234???").

As it has already pointed out previously, one or more characters "?" can be used in a sequence of digits together with the character "*". As an example it is allowed the following value: "*2??35".

Keep in mind that the character "*" can only appear at the beginning or at the end of a sequence; it is not allowed to write: "0123*23". Moreover the character "*" can only appear once in a given sequence of digits. As an example this writing is not allowed: "*23*".

The name of an element list is also accepted, for checking the calling address of the incoming call in a set of defined X.25 NUAs. The accepted types of list are: list of X.25 NUA (XN) or Rule (RU) type or Rule Master (MR) type. The name of the element list must always be indicated between apexes and must correspond to an element list already existing when the routing has be configured.

CDI: | CALLED address of the incoming call
00 | from 1 up to 15 decimal digits 0 - 9, *, #, ?, 'ListName'

It sets the called address that satisfies the routing.

If "CDI:" contains only the character "*";, any called address satisfies the routing.

The character "*" can be used at the beginning or at the end of a sequence of digits with the meaning of "any digit or character and any number of digits and characters" (E.g.: "*123" or "321*").

If "CDI:" contains only the character "#", no called address must be present in the incoming call in order to satisfy the routing.

If "CDI:" contains only the character "?", any called address made of only one digit satisfies the routing. The character "?" can be used in a sequence of digits with the meaning of "any digit" (E.g.: "?654" or "1234???").

As it has already pointed out previously, one or more characters "?" can be used in a sequence of digits together with the character "*". As an example it is allowed the following value: "*2??35".

Keep in mind that the character "*" can only appear at the beginning or at the end of a sequence; it is not allowed to write: "0123*23". Moreover the character "*" can only appear once in a given sequence of digits. As an example this writing is not allowed: "*23*".

The name of an element list is also accepted, for checking the called address of the incoming call in a set of defined X.25 NUAs. The accepted types of list are: list of X.25 NUA (XN) or Rule (RU) type or Rule Master (MR) type. The name of the element list must always be indicated between apexes and must correspond to an element list already existing when the routing has be configured.

UDI: | USER DATA of the incoming call
* | from 1 up to 12 alphanumerical characters 0 - 9, a - z, A - Z, *, #, ?, 'ListName'

It sets the user data that satisfies the routing.

If "UDI:" contains only the character "*", any content of the user data satisfies the routing.

If "UDI:" contains only the character "#", the user data field of the incoming call must be empty in order to satisfy the routing.

If "UDI:" contains only the character "?", any use data field made of a single digit satisfies the routing.

The character "?" can be used like a sequence of characters with the meaning of "every character" (E.g.: "f?654f" or "1234???").

As it has already pointed out previously, one or more characters "?" can be used in a sequence of digits together with the character "*" (E.g.: "*2??ab").

Keep in mind that the character "*" can only appear at the beginning or at the end of a sequence; it is not allowed to write: "ABCD*23". Moreover the character "*" can only appear once in a given sequence of digits. As an example this writing is not allowed: "*ABC*".

The name of an element list is also accepted, for checking the called address of the incoming call in a set of defined X.25 UDFs. The accepted types of list are: list of X.25 User Data Fields (XU) or Rule (RU) type or Rule Master (MR) type. The name of the element list must always be indicated between apexes and must correspond to an element list already existing when the routing has be configured.

warning! The X.25 protocol defines the possibility of inserting in the call packet 16 bytes for user data (Facility FAST-SELECT not subscribed), however the first four bytes are normally used in order to identify the DTE-DTE protocols and the remaining 12 are normally used for all the other scopes.
Parameter PIDI: always refers to the first four bytes.

Parameter UDI: always refers to the user data, starting from the fifth byte.

PIDI: | PID of the incoming call
* | 4 hexadecimal digits, *, #

It sets the first four bytes of the user data that satisfies the routing.

If "PIDO:" contains only the character "*", the PID field of the incoming call is passed without changes to the outgoing call.

If "PIDO:" contains only the character "#", the PID field of the incoming call is not passed to the outgoing one.

If "PIDO:" contains some values, the first four bytes of the user data field of the outgoing call will be set to them.

The character "?" can't be used and the character "*" can be used only alone.

warning! The X.25 protocol defines the possibility of inserting in the call packet 16 bytes for user data (Facility FAST-SELECT not subscribed), however the first four bytes are normally used in order to identify the DTE-DTE protocols and the remaining 12 are normally used for all the other scopes.
Parameter PIDI: always refers to the first four bytes.

Parameter UDI: always refers to the user data, starting from the fifth byte.

CGO: | CALLING address of the outgoing call
* | from 1 up to 15 decimal digits 0 - 9, *, #

It sets the calling address of the outgoing call.

If "CGO:" contains only the character "*", the calling address of the incoming call is passed to the outgoing one without changes.

If "CGO:" contains only the character "#", the calling address of the incoming call is not passed to the outgoing one.

If "CGO:" contains some values, the calling address of the outgoing call will be set to them.
Unlike the parameter "CGI:", for the parameter "CGO:" the character "?" can't be used and the character "*" can be used only alone.

CDO: | CALLED address of the outgoing call
* | from 1 up to 15 decimal digits 0 - 9, *, #

It sets the called address of the outgoing call.

If "CDO:" contains only the character "*", the called address of the incoming call is passed to the outgoing one without changes.

If "CDO:" contains only the character "#", the called address of the incoming call is not passed to the outgoing one.

If "CDO:" contains some values, the calling address of the outgoing call will be set to them.
Unlike the parameter "CDI:", for the parameter "CDO:" the character "?" can't be used and the character "*" can be used only alone.

UDO: | USER DATA of the outgoing call
* | from 1 up to 12 alphanumerical characters 0 - 9, a - z, A - Z, *, #

It sets the user data field of the outgoing call.

If "UDO:" contains only the character "*", the user data field of the incoming call is passed without changes to the outgoing call.

If "UDO:" contains only the character "#", the user data field of the incoming call is not passed to the outgoing one.

If "UDO:" contains some values, the user data field of the outgoing call will be set to them.

Unlike the parameter "UDI:", for the parameter "UDO:" the character "?" can't be used and the character "*" can be used only alone.

warning! The X.25 protocol defines the possibility of inserting in the call packet 16 bytes for user data (Facility FAST-SELECT not subscribed), however the first four bytes are normally used in order to identify the DTE-DTE protocols and the remaining 12 are normally used for all the other scopes.
Parameter PIDO: always refers to the first four bytes. Parameter UDO: always refers to the user data, starting from the fifth byte.

PIDO: | PID of the outgoing call
* | 4 hexadecimal digits, *, #

It sets the first four bytes of the user data field of the outgoing call.

If "PIDO:" contains only the character "*", the PID field of the incoming call is passed without changes to the outgoing call.

If "PIDO:" contains only the character "#", the PID field of the incoming call is not passed to the outgoing one.

If "PIDO:" contains some values, the first four bytes of the user data field of the outgoing call will be set to them.

The character "?" can't be used and the character "*" can be used only alone.

warning! The X.25 protocol defines the possibility of inserting in the call packet 16 bytes for user data (Facility FAST-SELECT not subscribed), however the first four bytes are normally used in order to identify the DTE-DTE protocols and the remaining 12 are normally used for all the other scopes.
Parameter PIDO: always refers to the first four bytes. Parameter UDO: always refers to the user data, starting from the fifth byte.

FFO: | FACILITY field of the outgoing call
* | from 1 up to 15 hexadecimal digits, *, #

It sets the content of the Facility field of the outgoing call.

If "FFO:" contains only the character "*", the Facility field of the incoming call is passed without changes to the outgoing call.

If "FFO:" contains only the character "#", the Facility field of the incoming call is not passed to the outgoing one.

If "FFO:" contains some values, the user data field of the outgoing call will be set to them.

For the parameter "FFO:" the character "?" can't be used and the character "*" can be used only alone

info Every hexadecimal digit is made of two character defined in the intervals [0 - 9] and [A - F].

IF an odd number of characters, or more than 30 characters, or a not valid character is inserted, the following message will be shown: "INVALID VALUE".

Here is an example of FFO in order to signal the demand for taxation to the called one: "S R PR:i FFO:0101", in the outgoing call the Facility field will contain the hexadecimals 01 and 01.

COMP: | Compression protocol to use
NO | NO, QLLC, MBIT

It sets the compression protocol to use on data exchanging, once the connections is established.

Value | Meaning
NO | No compression protocol is associated to the routing, i.e. data go through the Abilis CPX in a transparent way. It has to be used for connecting users unprovided with Abilis CPX, or for connection, whose compression is not needed.
QLLC | The QLLC compression protocol is associated to the routing.
MBIT | The MBIT compression protocol is associated to the routing.

It is indispensable that this parameter setting coincides with the one of the same parameter of the counterpart, obviously for the routing interested in the connection establishing. Protocol MBIT has a system of acknowledgment of the protocol used from the counterpart and if the protocols do not coincide the call is cleared from Abilis CPX with the F0,AA cause codes (Compression protocol of not compatible). Protocol QLLC does not have this system, therefore it is possible that the protocol error is not immediately detected, so that the connection could be closed either from the DTE user because of not valid data or from the Abilis CPX with the codes F0,C2 (Error of expansion) or F0,C3 (Data compressed format not valid)

NEXT: | Enabling the alternative routing research
N (NO) | N (NO), Y (YES)

It sets up the possibility to search of an alternative routing in the SVC routings table if the call, placed by this routing, fails.

The search of the alternative routing proceeds starting from the routing, whose priority is successive to that one previously used, and it is always based on the data present in the incoming call.

If a new routing is satisfied by the call, a new attempt of connection is carried out using the information configured in such routing.

If also this connection fails, the ulterior search of an alternative routing depends on the value of parameter "NEXT:" of the last routing used.

The procedure of alternative routing can proceed like indicated until (at maximum) 16 call tries with different routings are done.

Usually, every time that the incoming call matches one of the routing present in the table, in the Events Log the priority value of the satisfied routing is saved (e.g.: "Routing Match PR:i").

The recording is carried out whether the call is successful or not.

In the case of alternative routing search procedure the user will be able to detect in the Events Log all the tries made, before the call have been successful or before the definitive failure of the connection.

IPSRC: | IP source address of the incoming call (Only if POI: is a XTP port type)
* | see table, *, 'ListName'

It sets the source IP address of the incoming call received from the POO: port of XTP type.

The IP address of the incoming call is compared with the one stored in the "IPSRC:" routing parameter. Only those incoming call, whose IP source address matches the this parameter are accepted. The other calls are refused with codes F0,A0 (Customer not Configured. No routing matches the call).

The allowed values are summarized in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP address of class D and E are not currently supported.

The value 0.0.0.0 is shown with the character "*" and it means "any IP address". The calls, incoming from any IP source, are accepted.

The name of an element list is also accepted, for checking source IP address of the incoming call in a set of defined IP adresses. The accepted types of list are: IP list (IP), list of IP interval addresses (IR), Rule (RU) type or Rule Master (MR) type. The name of the element list must always be indicated between apexes and must correspond to list already existing when the routing has be configured.

The parameter is shown, it can only be configured if the output port (POO:) type is XTP.

For more detailed information about management of X.25 traffic over TCP/IP refer to the section The X.25 ports, session tunnelling protocol (XTP).

IPDEST: | IP destination address (Only if POI: is a XTP port type)
# | see table, #

It sets the IP destination address that will be placed in the call routed to the POO: port of XTP type.

The allowed values are summarized in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP address of class D and E are not currently supported.

The value 0.0.0.0 is shown with the character "#" and it means "no IP address". It can be used for disabling the routing. Every call is refused with the codes F0,A0 (Customer not Configured. No routing matches the call).

The parameter is shown, it can only be configured if the output port (POO:) type is XTP.

For more detailed information about management of X.25 traffic over TCP/IP refer to the section The X.25 ports, session tunnelling protocol (XTP).

Configuration examples top

The following examples will try to explain the differences between the above-mentioned functionalities.

warning! To facilitate the understanding of the examples we use the "extended" display of the routing table, the one obtainable with D RE command.

EXAMPLE N.1

PR:0   POI:*    POO:0    COMP:NO
NEXT:N CGI:*               CDI:00              UDI:CP           PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:0 represents the priority of routing verification.

For each incoming call the SVC routings table is checked starting from the routing with priority "0", the highest, until finding a routing that matches the incoming call. If all the table is checked, but no matches are found, the incoming call is rejected with codes of cause and diagnostic F0,A0 (Customer not Configured. No routing matches the call).

POI:, CGI:, CDI: and UDI: represent the values that must, at the same time, be present in the incoming call, so that the routing matches it, that is:

  • it can come in from any port (POI:*);
  • it can have any calling address (CGI:*);
  • it can have any called address (CDI:*);
  • it MUST have in the data user field only the sequence of ASCII characters "CP" (UDI:CP) [1].

POO:, CGO:, CDO:, UDO: and FFO: represent the outgoing port and data contained in the outgoing call, that is:

  • it is routed to port "0" (POO:0);
  • it keeps the calling address (CGO:*);
  • it keeps the called address (CDO:*);
  • it keeps the user data (UDO:* and PIDO:*)[2];
  • it keeps the "facility field" (FFO:*).

COMP: contains information about the compression protocol to be used.

NEXT: this parameter enables the alternative routing searching in the eventuality that the call using the present routing fails.

In the example this functionality is disabled. (NEXT:N).

A call, whatever is its incoming port, is routed to the Control Port (POO:0), only if its user data field contains the sequence of ASCII characters "CP".

The example shows a really important routing: it is possible to access the Control Port from any remote equipment that can place SVC calls towards the Abilis CPX.

warning! If in the SVC routings table there isn't at least one routing to the Control Port "0", it won't be possible to access the mentioned port through a SVC channel.

The same result is obtained if the incoming call matches a routing, whit higher priority and different port destination.

The next example will show that every incoming call matches the routing "0", so that the routing "1" will be never examined.

PR:0   POI:*    POO:301  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:1   POI:*    POO:0    COMP:NO
NEXT:N CGI:*               CDI:00              UDI:CP           PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

To restore the access to the Control Port, it will be needed to add locally, by using the off-line configurator, the requested routing.

EXAMPLE N.2

PR:1   POI:301  POO:302  COMP:MBIT
NEXT:N CGI:56565656        CDI:12345678        UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

In order to match this routing, a call:

  • must have the "301" (POI:301) port as incoming port;
  • must have such calling address "56565656" (CGI:56565656);
  • must have such called address "12345678" (CDI:12345678);
  • the user data field can have any content (UDI:* and PIDI:*) [1];
  • routes the call to the port "302" (POO:302);
  • it keeps the calling address (CGO:*);
  • it keeps the called address (CDO:*);
  • it keeps the user data (UDO:* and PIDO:*)[2];
  • it keeps the "facility field" data (FFO:*);
  • it ACTIVATEs the MBIT compression type (COMP:MBIT);
  • no alternative routing will be searched in case call failure (NEXT:N).

Often, calls between two corresponding DTE happen in both directions, that is both can demand the opening of the logical channel.

In this case the appropriated presence of a routing is necessary also for the opposite direction.

The following example shows a routing that could correspond to the one already described.

PR:2   POI:302  POO:301  COMP:MBIT
NEXT:N CGI:12345678        CDI:56565656        UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

In order to match this routing, a call:

  • must have the "302" (POI:302) port as incoming port;
  • must have such calling address "12345678" (CGI:12345678);
  • must have such called address "56565656" (CDI:56565656);
  • the user data field can have any content (UDI:* and PIDI:*) [1];
  • routes the call to the port "301" (POO:301);
  • it keeps the calling address (CGO:*);
  • it keeps the called address (CDO:*);
  • it keeps the user data (UDO:* and PIDO:*)[2];
  • it keeps the "facility field" data (FFO:*);
  • it ACTIVATEs the MBIT compression type (COMP:MBIT);
  • no alternative routing will be searched in case call failure (NEXT:N).

EXAMPLE N.3

This example shows how the Abilis CPX manages the calling data, this is an alternative method to the previous one in order to establish which call must be compressed and the proper protocol.

Figure 1. Using the calling data.
SVC compressed/uncompressed example

Routing in the calling Abilis CPX:

PR:3   POI:301  POO:302  COMP:MBIT
NEXT:N CGI:*               CDI:87654321        UDI:*            PIDI:*
       CGO:*               CDO:8765432199      UDO:*            PIDO:*
       FFO:*

Routings in the receiving Abilis CPX:

PR:2   POI:302  POO:301  COMP:MBIT
NEXT:N CGI:*               CDI:8765432199      UDI:*            PIDI:*
       CGO:*               CDO:87654321        UDO:*            PIDO:*
       FFO:*

PR:3   POI:302  POO:301  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

In such way, the calls, received by the X.25 network, keep their original calling data (what they have before being processed by the Abilis CPX), while it is possible to recognize the "compressed call" through the sub-address "99" added to the called address.

Calls to the 87654321 address without the sub-address "99" are transparently sent by the routing "3" (COMP:NO).

EXAMPLE N.4

This example shows what the Abilis CPX, in the fields CGI:, CDI:, UDI:, CGO:, CDO:, UDO:, means for:

  • the character "*": "every digit or character or every number of digits or characters";
  • the character "?": "every digit or character";
  • the character "#" no digit or character;
PR:2   POI:302  POO:301  COMP:NO
NEXT:N CGI:*8              CDI:15*             UDI:#            PIDI:#
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

In order to match this routing, a call:

  • must have the "302" (POI:302) port as incoming port;
  • must have its calling address made of any sequence of digits, but ending by "8" (CGI:*8);
  • must have its called address made of any sequence of digits, but starting by "8 (CDI:15*);
  • must have the user data field MANDATORY empty (UDI:# and PIDI:#) [1];
  • routes the call to the port "301" (POO:301);
  • keeps the calling address (CGO:*);
  • keeps the called address (CDO:*);
  • it keeps the user data (UDO:* and PIDO:*)[2];
  • keeps the "facility field" data (FFO:*);
  • don't activate any compression (COMP:NO);
  • no alternative routing will be searched in case call failure (NEXT:N).
PR:3   POI:301  POO:302  COMP:NO
NEXT:N CGI:#               CDI:????            UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:#            PIDO:#
       FFO:#

In order to match this routing, a call:

  • must have the "301" (POI:301) port as incoming port;
  • must have its calling MANDATORY empty (CGI:#);
  • must have its called address made of any four digits sequence (CDI:????);
  • the user data field can have any content (UDI:* and PIDI:*) [1];
  • routes the call to the port "302" (POO:302);
  • keeps the calling address (CGO:*);
  • keeps the called address (CDO:*);
  • do not have any user data (UDO:# and PIDO:#) [2];
  • don't carry the "facility field" data (FFO:#);
  • don't activate any compression (COMP:NO);
  • no alternative routing will be searched in case call failure (NEXT:N).

[1] The parameter UDI: always refers to user data starting from the 5th byte. The parameter PIDI: always refers to the first four bytes.

[2] The parameter UDO: always refers to user data starting from the 5th byte. The parameter PIDO: always refers to the first four bytes.


RIP External Routes

RIP External Routes filter table

RIP External Routes filter table top

The table of RIP External Routes contains information about filtering rules for routes which are external to the RIP domain and that could be imported into the RIP domain.
This table is used only when this router is declared as ASBR (ASBR:YES).

The table of RIP External Routes is used as follow:

  1. An empty table is a "default accept" table.
  2. A table with only "ignore" records is still a "default accept" table.
  3. A table with at least one "accept" record for a protocol becomes a "default ignore" for that protocol.

In case 1) the filtering is possible only "by protocol" through the parameters LOCAL:, STATIC: and OSPF:.

In case 2) it is possible to explicitely ignore routes.

In case 3) all the routes for the protocol having at least one "accept" record are ignored, except those explicitely accepted.

The table of RIP External Routes can store up to 256 entries.

Records are kept contiguous and sorted by their external IP network (EXTERNAL:) value (i.e. kept sorted by Network address and Network mask values: longer mask first; lower Network address first) and by their Routing protocol filter (PROT:) value.

Two or more entries for the same external IP network (EXTERNAL:) cannot have the same Routing protocol filter (PROT:) value.

Commands for managing the table of RIP External Routes are described in the section Commands related to RIP External Routes. The following commands are available:

A RIP EXTERNAL:
C RIP EXTERNAL:
D RIP EXTERNAL
D RIP EXTERNAL:
S RIP EXTERNAL:

Here is an example of the D RIP EXTERNAL command execution. Displayed values are only examples.

[16:54:38] ABILIS_CPX: D RIP EXTERNAL

----------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:
----------------------------------------------
192.168.006.002/32   OSPF    ACCEPT          5
192.168.006.000/24   LOCAL   IGNORE          1
010.000.000.000/8    ANY     ACCEPT         10
000.000.000.000/0    ANY     ACCEPT          *
----------------------------------------------

Changes made on the table of RIP External Routes are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command.

Detail of the RIP External Routes filter parameters

EXTERNAL: | External IP network
no value | see below

It specifies the external IP network that can be imported (or not) into RIP port.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The network address "0.0.0.0" is valid only for mask value "0".

PROT: | Routing protocol filter
ANY | ANY, LOCAL, STATIC, OSPF

This parameter defines a routing protocol for which this filter will be applied.

  • ANY: All routing protocols
  • LOCAL: Local routes
  • STATIC: Static routes
  • OSPF: OSPF routes
ACTION: | Accept/Ignore flag
ACCEPT | ACCEPT, IGNORE

This parameter indicates if the selected network EXTERNAL: can be accepted or ignored by RIP port.

  • IGNORE: Do not distribute this IP addresses into RIP.
  • ACCEPT: Distribute this IP addresses into RIP.

This means that all the routing present into IP Routings table that matches with EXTERNAL: will be imported into RIP table in case that ACTION: is set to "ACCEPT" (and then will be used also specified metric METRIC:), and will be not imported in case that it is set to "IGNORE".

METRIC: | Metric used for redistribute this route.
* | 0 - 16, *

This parameter sets the metric value that will be used for redistribution routes, of LOCAL:, STATIC: or OSPF: type, imported from the IP Routings table into RIP.

The value "*" stands for "use default metric", i.e. indicates to use the metric specified for the related protocol type PROT:, in RIP port configuration.


Wireless to G.703 routings

Configuration of Wireless to G.703 routings

Configuration of Wireless to G.703 routings top

The table of Wireless to G.703 routings can hold up to 4 definitions, indexed starting from 0 up to 3.

The table of Wireless to G.703 routings is not automatically maintained with consecutive indices and can contain "empty" places. Vacancies are assigned when a new entry is going to be created.

The table of Wireless to G.703 routings can be modified while the Abilis CPX is working, but but modifications are not immediately active, to be activated they need the system to be restarted.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Commands for handling Wireless to G.703 routings are described in the Wireless to G.703 routings section of the Commands relating to the Wireless to G.703 Bridge document.

The available commands are the following:

A WGB
C WGB
D WGB
S WGB

In the following example are displayed all the entries of the table of Wireless to G.703 routings. Displayed values are only samples.

[18:14:08] ABILIS_CPX: D WGB

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

ID:  SRCPORT:  SRCCHAN:  DSTPORT:  DSTCHAN:
---------------------------------------------
0          30         0       600         0
3        NONE         0      NONE         0

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Detail of the Wireless to G.703 routing parameters

ID: | Identifier of the Wireless to G.703 routing
no value | from 0 to 3

It represent the index of the Wireless to G.703 routing identifier and it sets the verifying sequence of entries for each incoming call. The verifying procedure starts from the routing identified by 0 and proceeds until it finds the proper routing for that call or it reaches the end of the table.
The table of Wireless to G.703 routings can store up to 4 entries, therefore the routing identifier value must be in the interval [0 - 3]. The table is NOT automatically maintained with consecutive indexes, then Wireless to G.703 routing definitions may not have sequential identifiers.

The index is also used by the adding, modifying, deleting commands to refer to a given entry.

SRCPORT: | Identifier of the source port
NONE | 0..999, NONE

It is the source port. The selected port must be a WL or a G703 valid one.

The value "NONE" stands for "no port", it can be used to deactivate the routing without deleting it.

Distinction between source/destination port is meaningless for the Wireless to G.703 routing configuration; it is used only for distinguish the parameters relating to each port.

SRCCHAN: | Identifier of the source channel
0 | 0..255

It is the source channel.

Distinction between source/destination port is meaningless for the Wireless to G.703 routing configuration; it is used only for distinguish the parameters relating to each port.

DSTPORT: | Identifier of the destination port
NONE | 0..999, NONE

It is the destination port. The selected port must be a WL or a G703 valid one.

The value "NONE" stands for "no port", it can be used to deactivate the routing without deleting it.

Distinction between source/destination port is meaningless for the Wireless to G.703 routing configuration; it is used only for distinguish the parameters relating to each port.

DSTCHAN: | Identifier of the destination channel
0 | 0..255

It is the destination channel.

Distinction between source/destination port is meaningless for the Wireless to G.703 routing configuration; it is used only for distinguish the parameters relating to each port.


OSPF configuration examples

Deploying OSPF
Planning the Autonomous System
Planning each area
Planning each network

Example 1: The OSPF configuration for PP network (single area).
Example 2: The OSPF configuration for NBMA network (single area).
Example 3: The OSPF configuration for PMP network (single area).
Example 4: The OSPF configuration for a common case (single area).
Example 5: The OSPF configuration for multiple areas. Area Border router (ABR).
Example 6: Restore Backbone connectivity and Virtual Links.
Example 7: Summarize inter-area routes and area address ranges.
Example 8: Stub area configuration.
Example 9: Hosts.
Example 10: Routes redistribution into OSPF. Autonomous System Boundary Router (ASBR).

The Open Shortest Path First (OSPF) Version 2 port

Deploying OSPF top

Deploying OSPF requires careful planning and configuration at four levels:

  • The Autonomous System
  • The Area(s)
  • The Network(s)
  • The Host(s)

Planning the Autonomous System

For the OSPF autonomous system (AS), you need to:

  • Designate the backbone area.
  • Identify autonomous system boundary routers (ASBRs).
  • Subdivide the OSPF AS into areas that can be easily summarized by using summary routes. (if need)
  • Assign area IDs.
  • Identify virtual links. (if need)
  • Identify area border routers (ABRs). (if need)
  • Identify stub areas. (if need)

The Figure 1 shows a sample map of an Anonymous System. Router 5 have EGP connection to other Anonymous System. Is it an ASBR.

Example of an Autonomous System

Figure 1: Example of an Autonomous System

The Figure 2 shows a sample OSPF area configuration.
The first area consists of networks N1-N4, along with their attached routers RT1-RT4.
The second area consists of networks N6-N8, along with their attached routers RT7, RT8, RT10 and RT11.
The third area consists of networks N9-N11 and Host, along with their attached routers RT9, RT11 and RT12.

Example of an Autonomous System with areas

Figure 2: Example of an Autonomous System with areas

In Figure 2, Routers RT1, RT2, RT5, RT6, RT8, RT9 and RT12 are internal routers.
Routers RT3, RT4, RT7, RT10 and RT11 are area border routers.
Finally, as before, Router RT5 is AS boundary router.

Router RT11 is a backbone router because it belongs to two areas. In order to make the backbone connected, a virtual link has been configured between Routers R10 and R11. Again, Routers RT3, RT4, RT7, RT10 and RT11 are area border routers. As Routers RT3 and RT4 did above, they have condensed the routing information of their attached areas for distribution via the backbone.

The backbone enables the exchange of summary information between area border routers. Every area border router hears the area summaries from all other area border routers. It then forms a picture of the distance to all networks outside of its area by examining the collected advertisements, and adding in the backbone distance to each advertising router.

Note that a failure of the line between Routers RT6 and RT10 will cause the backbone to become disconnected. Configuring a virtual link between Routers RT7 and RT10 will give the backbone more connectivity and more resistance to such failures. Also, a virtual link between RT7 and RT10 would allow a much shorter path between the third area (containing N9) and the router RT7, which is advertising a good route to external network N12.

Planning each area

For each router, you need to:

  • Define the areas to which the router is connected.
  • If the area is a stub area, define the area as a stub area.
  • If the router is an ABR, optionally configure the ranges that summarize the IP networks within the area.
  • If the router is an ABR that uses a virtual link, define the virtual interface.
  • If the router is an ASBR, enable ASBR and configure optional external route filters.

Planning each network

For each IP address for each router interface that uses OSPF, you need to:

  • Enable OSPF on the interface.
  • Configure the interface for the appropriate area ID.
  • Configure the interface for the appropriate router priority.
  • Configure the interface for the appropriate link cost.
  • Configure the interface for the appropriate password.
  • Configure the interface for the appropriate network type.
  • If the interface is a single-adapter Frame Relay (or X.25 or ATM) interface, configure the nonbroadcast multiple access (NBMA) neighbors.

The OSPF configuration for PP network (single area) top

Figure 3

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[03:46:13] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO

Step 2. Configure OSPF area for both routers.

[00:30:23] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on both routers must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 3. Configure IP port for use with OSPF protocol.

Screen layout for RT1

[00:41:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:192.168.6.10
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.010                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:PP     OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT2

[00:41:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:192.168.6.11
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.011                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:PP     OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Allow to use this IP port with OSPF protocol. For this set RP parameter equal OSPF.
Configure ID of OSPF area (OAREA field) and type of network (ONETTYPE field).

Step 4. Configure the other end of Point-to-Point connection.

You must set for each neighbor the next parameters:

  • IP address of neighbor (field NEIGH)
  • Number of IP interface for this neighbor (field IP)

Other fields are not used for this type of network and their any values will be ignored.

Screen layout for RT1

[00:41:45] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.011     1       0      30        0
----------------------------------------------------------------

Screen layout for RT2

[00:41:45] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.010     1       0      30        0
----------------------------------------------------------------

Step 5. Save configuration and restart OSPF port.

The OSPF configuration for NBMA network (single area). top

Non broadcast multiaccess network

Figure 4

In this example RT1 and RT2 have priority more then 0, it means They can be eligibled to Designated Router (DR) or Backup DR (BDR) for this network. RT3 has priority equal 0 he cannot be DR(BDR).

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[03:46:13] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO

Step 2. Configure OSPF area for all routers.

[00:30:23] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
--------------------------------------------------------
Area configuration on all routers must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 3. Configure IP port for use with OSPF protocol.

Screen layout for RT1

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.010                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:10     OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT2

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.011                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:10     OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT3

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.012                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Allow to use this IP port with OSPF protocol (set RP parameter equal OSPF).
Configure ID of OSPF area (OAREA field) and type of network (ONETTYPE field).

Step 4. Configure neighbors for each router.

You must set for each neighbor the next parameters:

  • IP address of neighbor (field NEIGH)
  • Number of IP interface for this neighbor (field IP)
  • Neighbor's priority (field PRIO)
  • Time interval between Hello packets that are sent to a neighbor that has DOWN state.(field POLL)
Field COST is not used for this type of network.

Screen layout for RT1

[04:20:16] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.011     1      10      40        0
192.168.006.012     1       0      40        0
----------------------------------------------------------------

Screen layout for RT2

[04:20:16] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.010     1      10      40        0
192.168.006.012     1       0      40        0
----------------------------------------------------------------

Screen layout for RT3

[04:20:16] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
     *** NO OSPF NEIGHBORs DEFINED ***

Step 5. Save configuration and restart OSPF port.

The OSPF configuration for PMP network (single area). top

Physiscal toplogy of network.

Point-to-Multipoint network (physical)

Figure 5
Logical toplogy of network.

Point-to-Multipoint network (logical)

Figure 6

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[03:46:13] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO

Step 2. Configure OSPF area for all routers.

[00:30:23] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on all routers must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 3. Configure IP port for use with OSPF protocol.

Screen layout for RT1

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.010                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:PMP    OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT2

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.011                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:PMP    OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT3

[03:53:41] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.012                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:PMP    OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Allow to use this IP port with OSPF protocol (set RP parameter equal OSPF)
Configure Area ID (OAREA field) and type of network (ONETTYPE field).

Step 4. Configure neighbors for each router.

You must set for each neighbor the next parameters:

  • IP address of neighbor (field NEIGH)
  • Number of IP interface for this neighbor (field IP)
  • Note. If cost of this link (COST field) is equal 0 (default value) will be used cost of interface (fiels OCOST). But you can set a special cost for any neighbor. In this case to use neighbor's COST field (to see neighbor's configuration for RT1, RT3).

Other fields are not used for this type of network and their any values will be ignored.

Screen layout for RT1

[00:41:45] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.011     1       0      30        10
192.168.006.012     1       0      30        0
----------------------------------------------------------------

Screen layout for RT2

[00:41:45] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.010     1       0      30        0
192.168.006.012     1       0      30        0
----------------------------------------------------------------

Screen layout for RT3

[00:41:45] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
192.168.006.010     1       0      30        11
192.168.006.011     1       0      30        21
----------------------------------------------------------------

Step 5. Save configuration and restart OSPF port.

Note. For Point-to-Multipoint you can use different logical topologies, combine links between as you need. In this case you can reduce OSPF network traffic.
Some variants you can see below.

Logical topology of PMP network (variants)

Figure 7

The OSPF configuration for a common case (single area). top

Mixed network configuration

Figure 8

In this example you can see how to configure a router with many interfaces (will show configuration for RT1).

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[03:46:13] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO

Step 2. Configure OSPF area for all routers.

[00:30:23] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on all routers must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 3. Configure IP port for use with OSPF protocol.

Screen layout for RT1. Interface Ip-1

[15:56:53] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.001                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:000.000.000.000     ONETTYPE:NBMA   OPRIO:10     OCOST:3
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Interface Ip-2

[15:58:04] ABILIS_CPX:d p res:ip-2

RES:Ip-2 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-2
       IPADD:172.016.001.001                         BRD:NET
       MASK:255.255.000.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:000.000.000.000     ONETTYPE:PMP    OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Interface Ip-3

[15:59:35] ABILIS_CPX:d p res:ip-3

RES:Ip-3 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-3
       IPADD:010.000.000.001                         BRD:NET
       MASK:255.000.000.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:000.000.000.000     ONETTYPE:PP     OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Step 4. Neighbor's configuration for RT1.

[16:01:31] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
010.000.000.002     3       0      40        0
172.016.001.002     2       0      40       13
172.016.001.003     2       0      40        0
192.168.006.011     1      10      40        0
192.168.006.012     1       0      40        0
----------------------------------------------------------------

Step 5. Save configuration and restart OSPF port.

The OSPF configuration for multiple areas. ABR. top

Area Border Router configuration

Figure 9

In this example you can see how to configure a router that is connected to many areas. This router is called Area Border Router (ABR).

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[04:39:14] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO

Step 2. Configure OSPF area for this routers.

[04:42:19] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
000.000.000.000     NO         NO          65535
001.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on all routers that are located in one area must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 3. Configure IP port for use with OSPF protocol.

Screen layout for RT1. Interface Ip-1

[04:39:21] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:192.168.006.010                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:10     OCOST:3
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for RT1. Interface Ip-2

[04:39:28] ABILIS_CPX:d p res:ip-2

RES:Ip-2 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
ACT    OPSTATE:UP
       LANRES:Eth100-2
       IPADD:172.016.001.001                         BRD:NET
       MASK:255.255.000.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:000.000.000.000     ONETTYPE:PP     OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Step 4. Configure neighbors for this router.

[04:43:27] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
010.000.000.002     2       0      40        0
192.168.006.011     1       0      40        0
----------------------------------------------------------------

Step 5. Save configuration and restart OSPF port.

Restore Backbone connectivity and Virtual Links. top

Figure 10

In this example you can see how to configure a virtual link between routers RT1 and RT2.
The first will show a configuration process for RT1 the second a configuration process for RT2.

Router 1 (RT1). Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[11:12:26] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO
Step 2. Set router ID.
[11:15:14] ABILIS_CPX: d p res:iprtr

RES:Iprtr ---------------------------------------------------------------------
       DESCR:IP_Router_general_properties
       - General --------------------------------------------------------------
       LOG:NO                 R-ID:001.000.000.000          NAT:NO
       maxroute:500           DFTTTL:64              ps:2048
       DEF-LOCAL-AD:0     DEF-STATIC-AD:1     DEF-OSPF-AD:110   DEF-RIP-AD:120
       - IP Access List -------------------------------------------------------
       ACL:NO                 ACLBYPASS:#
       COS:DISABLED           COSDFT:NORMAL
       COSBALANCE:NO          NORMRATE:50            LOWRATE:50
       - IP Trace -------------------------------------------------------------
       tracerec:100
       - Ppp-Dns --------------------------------------------------------------
       PPP-DNS-PRI:000.000.000.000  PPP-DNS-SEC:000.000.000.000

Step 3. Configure OSPF areas for this router.

[11:15:20] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
002.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on all routers that are located in one area must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 4. Configure IP ports for use with OSPF protocol.

Screen layout for interface Ip-1

[11:16:36] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:172.016.001.001                         BRD:NET
       MASK:255.255.000.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:002.000.000.000     ONETTYPE:NBMA   OPRIO:0      OCOST:3
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for interface Ip-2

[11:19:10] ABILIS_CPX:d p res:ip-2

RES:Ip-2 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-2
       IPADD:192.168.006.010                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:0      OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Step 5. Configure neighbors for this router.

[11:20:08] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
172.016.001.002     1      10      40        0
192.168.006.011     2      10      40        0
----------------------------------------------------------------

Step 6. Configure virtual links for this router.

[11:37:54] ABILIS_CPX:d ospf VL

-------------------------------------------------------------------------------
REM-RID:         AREA:           HELLO: RXMT: TRDEL: DEAD:  PWD:         KEYID:
                                                            MD5KEY:
-------------------------------------------------------------------------------
002.000.000.000  001.000.000.000     10     5      2    60                    0

-------------------------------------------------------------------------------

Step 7. Save configuration and restart OSPF port.

Router 2 (RT2). Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

[11:28:50] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:NO
Step 2. Set router ID.
[11:28:56] ABILIS_CPX:d p res:iprtr

RES:Iprtr ---------------------------------------------------------------------
       DESCR:IP_Router_general_properties
       - General --------------------------------------------------------------
       LOG:NO                 R-ID:002.000.000.000          NAT:NO
       maxroute:500           DFTTTL:64              ps:2048
       DEF-LOCAL-AD:0     DEF-STATIC-AD:1     DEF-OSPF-AD:110   DEF-RIP-AD:120
       - IP Access List -------------------------------------------------------
       ACL:NO                 ACLBYPASS:#
       COS:DISABLED           COSDFT:NORMAL
       COSBALANCE:NO          NORMRATE:50            LOWRATE:50
       - IP Trace -------------------------------------------------------------
       tracerec:100
       - Ppp-Dns --------------------------------------------------------------
       PPP-DNS-PRI:000.000.000.000  PPP-DNS-SEC:000.000.000.000

Step 3. Configure OSPF areas for router.

[11:29:39] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
000.000.000.000     NO         NO          65535
001.000.000.000     NO         NO          65535
--------------------------------------------------------

Area configuration on all routers that are located in one area must be equal. If we have different values for AUTYPE or STUB parameters then connecton between this routers will be not established.

Step 4. Configure IP ports for use with OSPF protocol.

Screen layout for interface Ip-1

[11:30:12] ABILIS_CPX:d p res:ip-1

RES:Ip-1 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-1
       IPADD:010.000.000.001                         BRD:NET
       MASK:255.000.000.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:000.000.000.000     ONETTYPE:PP     OPRIO:0      OCOST:3
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Screen layout for interface Ip-2

[11:30:41] ABILIS_CPX:d p res:ip-2

RES:Ip-2 - IP over LAN (LAN) --------------------------------------------------
       DESCR:
NEW    OPSTATE:UP
       LANRES:Eth100-2
       IPADD:192.168.006.011                         BRD:NET
       MASK:255.255.255.000   MTU:1500               OUTBUF:50
       NAT:NO                 SRCV:NO                FAIRQUEUE:YES
       REDIS:YES              HIDE:NO                RP:OSPF
       SPEEDLIMIT:NO
       - OSPF section ---------------------------------------------------------
       OAREA:001.000.000.000     ONETTYPE:NBMA   OPRIO:10     OCOST:1
       ORXMT:5      OTRDEL:1     OHELLO:10       ODEAD:60     omax-nei:5

Step 5. Configure neighbors for this router.

[11:31:12] ABILIS_CPX:d ospf neigh

----------------------------------------------------------------
NEIGH:           IP:    PRIO:   POLL:    COST:
----------------------------------------------------------------
010.000.000.002     1      10      40        0
192.168.006.010     2       0      40        0
----------------------------------------------------------------

Step 6. Configure virtual links for this router.

[11:36:43] ABILIS_CPX:d ospf  VL

-------------------------------------------------------------------------------
REM-RID:         AREA:           HELLO: RXMT: TRDEL: DEAD:  PWD:         KEYID:
                                                            MD5KEY:
-------------------------------------------------------------------------------
001.000.000.000  001.000.000.000     10     5      2    60                    0

-------------------------------------------------------------------------------

Step 7. Save configuration and restart OSPF port.

Summarize inter-area routes and area address ranges. top

Area address ranges

Figure 11

Route summarization is the consolidation of advertised addresses. This feature causes a single summary route to be advertised to other areas by an ABR. In OSPF, an ABR will advertise networks in one area into another area. If the network numbers in an area are assigned in a way such that they are contiguous, you can configure the ABR to advertise a summary route that covers all the indivindual networks within the area that fall into the specified range.

There we will not show configuration procedure for all components are needed for OSPF (IP ports, OSPF port, neighbors, etc.) You can see it in any previous example.

Call you attention to OSPF areas configuration and address ranges configuration

OSPF areas' configuration for this router.

[13:48:52] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         NO          65535
002.000.000.000     NO         NO          65535
--------------------------------------------------------

OSPF address range configuration for this router.

[13:48:56] ABILIS_CPX:d ospf range

---------------------------------------------------------
AREA:               RANGE:                ADV:
---------------------------------------------------------
001.000.000.000     192.168.000.000/16    YES
---------------------------------------------------------

Stub area configuration. top

AS with stub area

Figure 12

Stub areas are areas into which information on external routes is not sent. Instead, there is a default external route generated by the area border router, into the stub area for destination outside the autonomous system. The cost of a default route depends on value of DEFCOST filed.

There we will not show configuration procedure for all components are needed for OSPF (IP ports, OSPF port, neighbors, etc.) You can see it in any previous example.

Call you attention to OSPF areas configuration.

OSPF areas' configuration for this router.

[12:24:44] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.000.000.000     NO         YES            15
002.000.000.000     NO         NO          65535
--------------------------------------------------------

Hosts. top

Figure 13

Hosts there are computers directly connected to a router.

There we will not show configuration procedure for all components are needed for OSPF (IP ports, OSPF port, neighbors, etc.) You can see it in any previous example.

Call you attention to OSPF host configuration.

OSPF areas' configuration for this router.

[15:22:21] ABILIS_CPX:d ospf area

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
192.168.006.000     NO         NO          65535
--------------------------------------------------------

OSPF hosts' configuration for this router.

[15:19:35] ABILIS_CPX:d ospf host

---------------------------------------
HOST:            AREA:            COST:
---------------------------------------
192.168.006.011  192.168.006.000     10
---------------------------------------
192.168.006.012  192.168.006.000      7
---------------------------------------

Routes redistribution into OSPF. ASBR. top

Figure 14

The normally situation is when we have used more as one routing protocols in our networks. It can be static routing, RIP, OSPF or any other IGP protocol.
For a correct work such networks we must have the possible to redistribute routes from one routing protocol to any other. It means that routes were detected through RIP or static protocols must be known in OSPF Autonomous System and routes were detected through OSPF protocol must be known on all routes that use RIP protocol.

CPX allow to redistribute OSPF routes into common routes' table and redistribute local, static, RIP routes from common routes' table to OSPF AS.

Steps and screen layouts for a configuration procedure.

Step 1. Configure and activate OSPF port.

Select types of route thhat we want to redistribute into OSPF. If need you can set a separate cost (metric) for each type of routes. In Other case will be used default metric (DEF_METRIC field).

[[16:14:50] ABILIS_CPX:d p res:ospf

RES:Ospf ----------------------------------------------------------------------
       DESCR:Open_Shortest_Path_First_Routing_Protocol
       LOG:DS       ACT:YES       max-lsa:200      max-routes:500
       RFC1583COMP:YES            ASBR:YES
       - ASBR section ---------------------------------------------------------
       LOCAL:YES           STATIC:YES           RIP:YES
       LOCAL-METRIC:*      STATIC-METRIC:3      RIP-METRIC:*
       DEF-METRIC:1

Step 2. If need, Define address ranges for routes that will be redistributed into OSPF AS.

You can define a separate metric for each address range. In other case will be used the metric that was defined for this type of route in OSPF port configuration (fields LOCAL-METRIC,STATIC-METRIC,RIP-METRIC).

[16:22:32] ABILIS_CPX:d ospf external

-----------------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:  TYPE:
-----------------------------------------------------
192.168.006.011/32   STATIC  IGNORE        255      1
192.168.006.000/24   ANY     ACCEPT          2      1
010.000.000.000/8    RIP     ACCEPT        255      1
-----------------------------------------------------


IPsec port configuration example. CPX to CPX.

Revised for CPX 4.8.0.
Manual mode
Transport (host-to-host)
Tunnel (gateway-to-gateway)
IKE mode
Transport (host-to-host)
Tunnel (gateway-to-gateway)
Tunnel (gateway-to-2 gateways)
Tunnel (gateway-to-2 anonymous gateways)
Tunnel (gateway-to-1 gateway + 1 anonymous gateway)

Manual mode top

MODE parameter of the IPsec driver must be set to the MANUAL mode for both CPXs.

[21:14:29] CPX_1:d p po:ipsec

PO:920
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:MANUAL  mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR

[21:14:29] CPX_2:d p po:ipsec

PO:920
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:MANUAL  mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR
IKE port should be deactivated for both CPXs (set ACT parameter to the NO):

[21:14:32] CPX_1:d p po:ike

PO:921 ------------------------------------------------------------------------
IKE    LOG:DS       lowpo:902       ACT:NO       mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:YES     NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20

[21:14:32] CPX_2:d p po:ike

PO:921 ------------------------------------------------------------------------
IKE    LOG:DS       lowpo:902       ACT:NO>       mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:YES     NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20

Manual mode. Transport (host-to-host) top

Figure 1. Host-to-host layout.

There are two CPXs. Each CPX has IP interface:

CPX 1 (host) has IP interface 0 with 192.168.2.1 IP address.
CPX 2 (host) has IP interface 0 with 192.168.2.2 IP address.

CPX 1.

Policy table:
[21:28:23] CPX_1:d ipsec policy

-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_1-to-CPX_2                   192.168.002.001/32 *
         OUT  0       IPSEC               192.168.002.002/32 *
-------------------------------------------------------------------------------
1        CPX_2-to-CPX_1                   192.168.002.002/32 *
         IN   1       IPSEC               192.168.002.001/32 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------

CPX 2.

Policy table:
[21:28:23] CPX_2:d ipsec policy

-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_2-to-CPX_1                   192.168.002.002/32 *
         OUT  0       IPSEC               192.168.002.001/32 *
-------------------------------------------------------------------------------
1        CPX_1-to-CPX_2                   192.168.002.001/32 *
         IN   1       IPSEC               192.168.002.002/32 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------

Example 1.

  • IPsec: ESP protocol with MD5 authentication and 3DES encryption.

CPX 1.

SA table:
[21:25:43] CPX_1:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2       00000200       192.168.002.001 ESP   MD5      3DES
     OUT  0       NO      1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_2-to-CPX_1       00000400       192.168.002.002 ESP   MD5      3DES
     IN   1       NO      1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------

CPX 2.

SA table:
[21:25:43] CPX_2:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1       00000400       192.168.002.002 ESP   MD5      3DES
     OUT  0       NO      1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_2       00000200       192.168.002.001 ESP   MD5      3DES
     IN   1       NO      1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
Notes:
  • TUNNEL fields of all SA records must be set to the NO for both CPXs.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of OUT SA for CPX_1 and corresponding fields of IN SA for CPX_2 must be identical.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of IN SA for CPX_1 and corresponding fields of OUT SA for CPX_2 must be identical.
  • SPI field of OUT SA for CPX_1 and corresponding field of IN SA for CPX_2 must be identical (0x200) and and vice versa (0x400).

Example 2.

  • IPsec: SA bundle: ESP protocol with MD5 authentication and 3DES encryption, AH protocol with SHA-1 authentication.

CPX 1.

SA table:
[21:25:43] CPX_1:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2_ESP   00000200       192.168.002.001 ESP   MD5      3DES
     OUT  0       NO      1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_2_AH    00000201       192.168.002.001 AH    SHA
     OUT  0       NO      1      AUTO    192.168.002.002       *******
-------------------------------------------------------------------------------
2    CPX_2-to-CPX_1_AH    00000401       192.168.002.002 AH    SHA
     IN   1       NO      1      AUTO    192.168.002.001       *******
-------------------------------------------------------------------------------
3    CPX_2-to-CPX_1_ESP   00000400       192.168.002.002 ESP   MD5      3DES
     IN   1       NO      1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------

CPX 2.

SA table:
[21:25:43] CPX_2:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1_ESP   00000400       192.168.002.001 ESP   MD5      3DES
     OUT  0       NO      1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_2-to-CPX_1_AH    00000401       192.168.002.001 AH    SHA
     OUT  0       NO      1      AUTO    192.168.002.002       *******
-------------------------------------------------------------------------------
2    CPX_1-to-CPX_2_AH    00000201       192.168.002.002 AH    SHA
     IN   1       NO      1      AUTO    192.168.002.001       *******
-------------------------------------------------------------------------------
3    CPX_1-to-CPX_2_ESP   00000200       192.168.002.002 ESP   MD5      3DES
     IN   1       NO      1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------
Notes:
  • TUNNEL fields of all SA records must be set to the NO for both CPXs.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of OUT AH SA for CPX_1 and corresponding fields of IN AH SA for CPX_2 must be identical.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of OUT ESP SA for CPX_1 and corresponding fields of IN ESP SA for CPX_2 must be identical.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of IN AH SA for CPX_1 and corresponding fields of OUT AH SA for CPX_2 must be identical.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of IN ESP SA for CPX_1 and corresponding fields of OUT ESP SA for CPX_2 must be identical.
  • SPI field of OUT AH SA for CPX_1 and corresponding field of IN AH SA for CPX_2 must be identical (0x201) and and vice versa (0x401).
  • SPI field of OUT ESP SA for CPX_1 and corresponding field of IN ESP SA for CPX_2 must be identical (0x200) and and vice versa (0x400).

Manual mode. Tunnel (gateway-to-gateway). top

Figure 2. IPsec gateway-to-gateway network layout.

There are two CPXs. Each CPX has two IP interfaces:

CPX 1 (gateway) has IP interface 0 with 192.168.1.1 IP address and IP interface 1 with 192.168.2.1 IP address.
CPX 2 (gateway) has IP interface 0 with 192.168.3.1 IP address and IP interface 1 with 192.168.2.2 IP address.

Example 1.

  • IPsec: ESP protocol with MD5 authentication and 3DES encryption.

CPX 1.

Policy table:
[21:28:23] CPX_1:d ipsec policy

-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_1-to-CPX_2                   192.168.001.000/24 *
         OUT  0       IPSEC               192.168.003.000/24 *
-------------------------------------------------------------------------------
1        CPX_2-to-CPX_1                   192.168.003.000/24 *
         IN   1       IPSEC               192.168.001.000/24 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------
SA table:
[21:25:43] CPX_1:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2       00000200       192.168.002.001 ESP   MD5      3DES
     OUT  0       YES     1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_2-to-CPX_1       00000400       192.168.002.002 ESP   MD5      3DES
     IN   1       YES     1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------

CPX 2.

Policy table:
[21:28:23] CPX_2:d ipsec policy

-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_2-to-CPX_1                   192.168.003.000/24 *
         OUT  0       IPSEC               192.168.001.000/24 *
-------------------------------------------------------------------------------
1        CPX_1-to-CPX_2                   192.168.001.000/24 *
         IN   1       IPSEC               192.168.003.000/24 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------
SA table:
[21:25:43] CPX_2:d ipsec sa

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1       00000400       192.168.002.002 ESP   MD5      3DES
     OUT  0       YES     1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_2       00000200       192.168.002.001 ESP   MD5      3DES
     IN   1       YES     1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
Notes:
  • TUNNEL fields of all SA records must be set to the YES for both CPXs.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of OUT SA for CPX_1 and corresponding fields of IN SA for CPX_2 must be identical.
  • AUTH, AUTHKEY, CIPHER and ENCKEY fields of IN SA for CPX_1 and corresponding fields of OUT SA for CPX_2 must be identical.
  • SPI field of OUT SA for CPX_1 and corresponding field of IN SA for CPX_2 must be identical (0x200) and and vice versa (0x400).

IKE mode top

MODE parameter of the IPsec driver must be set to the IKE mode for both CPXs.

[21:14:29] CPX_1:d p po:ipsec

PO:920
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:IKE     mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR

[21:14:29] CPX_2:d p po:ipsec

PO:920
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:IKE     mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR
IKE port must be activated for both CPXs (set ACT parameter to the YES):

[21:14:32] CPX_1:d p po:ike

PO:921 ------------------------------------------------------------------------
IKE    LOG:DS       lowpo:902       ACT:YES       mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:YES     NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20

[21:14:32] CPX_2:d p po:ike

PO:921 ------------------------------------------------------------------------
IKE    LOG:DS       lowpo:902       ACT:YES       mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:YES     NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20

IKE mode. Transport (host-to-host) top

Network layout is the same as on Figure 1.

Example 1.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: ESP protocol with SHA-1 authentication and DES encryption.
  • PFS: disabled.
Only CPX 1 can begin to negotiate IPsec connection. CPX 2 is in the PASSIVE mode.

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         NO
     YES  DES         SHA             NO       YES          192.168.002.001/32
     NO               MD5                      NO           192.168.002.002/32
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.2

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   192.168.002.002      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.001      AUTO    3600
      IP              192.168.002.002
      IP              192.168.002.001
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         NO
     YES  DES         SHA             YES      YES          192.168.002.002/32
     NO               MD5                      NO           192.168.002.001/32
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.1

Example 2.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: SA bundle: ESP protocol with SHA-1 authentication and IDEA encryption, AH protocol with SHA-1 authentication.
  • PFS: enabled.
Both CPX 1 and CPX 2 can begin to negotiate IPsec connection.

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  IDEA        SHA             NO       YES          192.168.002.001/32
     YES              SHA                      NO           192.168.002.002/32
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.2

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   192.168.002.002      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.001      AUTO    3600
      IP              192.168.002.002
      IP              192.168.002.001
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         YES
     YES  IDEA        SHA             NO       YES          192.168.002.002/32
     YES              SHA                      NO           192.168.002.001/32
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.1

IKE mode. Tunnel (gateway-to-gateway). top

Network layout is the same as on Figure 2.

Example 1.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: ESP protocol with SHA-1 authentication and DES encryption.
  • PFS: disabled.
Only CPX 1 can begin to negotiate IPsec connection. CPX 2 is in the PASSIVE mode.

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         NO
     YES  DES         SHA             NO       YES          192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.2

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   192.168.002.002      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.001      AUTO    3600
      IP              192.168.002.002
      IP              192.168.002.001
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         NO
     YES  DES         SHA             YES      YES          192.168.003.000/24
     NO               MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.1

Example 2.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: SA bundle: ESP protocol with SHA-1 authentication and IDEA encryption, AH protocol with SHA-1 authentication.
  • PFS: enabled.
Both CPX 1 and CPX 2 can begin to negotiate IPsec connection.

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  IDEA        SHA             NO       YES          192.168.001.000/24
     YES              SHA                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.2

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   192.168.002.002      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.001      AUTO    3600
      IP              192.168.002.002
      IP              192.168.002.001
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         YES
     YES  IDEA        SHA             NO       YES          192.168.003.000/24
     YES              SHA                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.1

IKE mode. Tunnel (gateway-to-2 gateways). top

Figure 3. Gateway-to-2 gateways layout.

There are three CPXs. Each CPX has two IP interfaces:

CPX 1 (gateway) has IP interface 0 with 192.168.1.1 IP address and IP interface 1 with public 83.149.0.35 IP address.
CPX 2 (gateway) has IP interface 0 with 192.168.3.1 IP address and IP interface 1 with public 213.206.129.60 IP address.
CPX 3 (gateway) has IP interface 0 with 192.168.4.1 IP address and IP interface 1 with public 212.171.210.147 IP address.

There are two IPsec tunnels: CPX 1-to-CPX 2 and CPX 1-to-CPX 3.

Example 1.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: SA bundle: ESP protocol with MD5 authentication and 3DES encryption, AH protocol with MD5 authentication.
  • PFS: enabled for the CPX 1-to-CPX 2 tunnel and disabled for the CPX 1-to-CPX 3 one.
Only CPX 2 and CPX 3 can begin to negotiate IPsec connection. CPX 1 is in PASSIVE mode (IPsec server).

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   083.149.000.035      1       3
      3DES      PSK   MD5   MODP1024   213.206.129.060      AUTO    3600
      IP              083.149.000.035
      IP              213.206.129.060
-------------------------------------------------------------------------------
1     CPX_1-to-CPX_3                   083.149.000.035      0       3
      3DES      PSK   MD5   MODP1024   212.171.210.147      AUTO    3600
      IP              083.149.000.035
      IP              212.171.210.147
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     YES              MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_3                   1        IPSEC        28800         NO
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     YES              MD5                      YES          192.168.004.000/24
-------------------------------------------------------------------------------
2    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        213.206.129.060
1    ******** IP        212.171.210.147

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   213.206.129.060      1       3
      3DES      PSK   MD5   MODP1024   083.149.000.035      AUTO    3600
      IP              213.206.129.060
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         YES
     YES  3DES        MD5             NO       YES          192.168.003.000/24
     YES              MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

CPX 3.

IKE host connections table:
[21:30:22] CPX_3:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_3-to-CPX_1                   212.171.210.147      1       3
      3DES      PSK   MD5   MODP1024   083.149.000.035      AUTO    3600
      IP              212.171.210.147
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_3:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_3-to-CPX_1                   0        IPSEC        28800         NO
     YES  3DES        MD5             NO       YES          192.168.004.000/24
     YES              MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_3:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

IKE mode. Tunnel (gateway-to-2 anonymous gateways). top

Figure 4. Gateway-to-2 anonymous gateways layout.

There are three CPXs. Each CPX has two IP interfaces:

CPX 1 (gateway) has IP interface 0 with 192.168.1.1 IP address and IP interface 1 with public 83.149.0.35 IP address.
CPX 2 (gateway) has IP interface 0 with 192.168.3.1 IP address and IP interface 1 with dynamic IP address.
CPX 3 (gateway) has IP interface 0 with 192.168.4.1 IP address and IP interface 1 with dynamic IP address.

There are two IPsec tunnels: CPX 1-to-CPX 2 and CPX 1-to-CPX 3.

Example 1.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: ESP protocol with MD5 authentication and 3DES encryption.
  • PFS: enabled for both tunnels.
Only CPX 2 and CPX 3 can begin to negotiate IPsec connection. CPX 1 is in PASSIVE mode (IPsec server).

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   083.149.000.035      1       3
      3DES      PSK   MD5   MODP1024   *                    AUTO    3600
      IP              083.149.000.035
      FQDN                             konstt
-------------------------------------------------------------------------------
1     CPX_1-to-CPX_3                   083.149.000.035      1       3
      3DES      PSK   MD5   MODP1024   *                    AUTO    3600
      IP              083.149.000.035
      FQDN                             castagna
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_3                   1        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.004.000/24
-------------------------------------------------------------------------------
2    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** ANONYMOUS

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   0                    1       3
      3DES      PSK   MD5   MODP1024   083.149.000.035      AUTO    3600
      FQDN                             konstt
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         YES
     YES  3DES        MD5             NO       YES          192.168.003.000/24
     NO               MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

CPX 3.

IKE host connections table:
[21:30:22] CPX_3:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_3-to-CPX_1                   0                    1       3
      3DES      PSK   MD5   MODP1024   083.149.000.035      AUTO    3600
      FQDN                             castagna
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_3:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_3-to-CPX_1                   0        IPSEC        28800         YES
     YES  3DES        MD5             NO       YES          192.168.004.000/24
     NO               MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_3:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

IKE mode. Tunnel (gateway-to-1 gateway + 1 anonymous gateway). top

Figure 5. Gateway-to-1 gateway + 1 anonymous gateway layout.

There are three CPXs. Each CPX has two IP interfaces:

CPX 1 (gateway) has IP interface 0 with 192.168.1.1 IP address and IP interface 1 with public 83.149.0.35 IP address.
CPX 2 (gateway) has IP interface 0 with 192.168.3.1 IP address and IP interface 1 public with 213.206.129.60 IP address.
CPX 3 (gateway) has IP interface 0 with 192.168.4.1 IP address and public IP interface 1 with dynamic IP address.

There are two IPsec tunnels: CPX 1-to-CPX 2 and CPX 1-to-CPX 3.

Example 1.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption for CPX 1-to-CPX 2 tunnel, 1536 DH group, PSK authentication, SHA-1 hash and IDEA encryption CPX 1-to-CPX 3 tunnel.
  • IPsec: ESP protocol with MD5 authentication and 3DES encryption.
  • PFS: enabled for both tunnels.
Only CPX 2 and CPX 3 can begin to negotiate IPsec connection. CPX 1 is in PASSIVE mode (IPsec server).

CPX 1.

IKE host connections table:
[21:30:22] CPX_1:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   083.149.000.035      1       3
      3DES      PSK   MD5   MODP1024   213.206.129.060      AUTO    3600
      IP              083.149.000.035
      IP              213.206.129.060
-------------------------------------------------------------------------------
1     CPX_1-to-CPX_3                   083.149.000.035      1       3
      IDEA      PSK   SHA   MODP1536   *                    AUTO    3600
      IP              083.149.000.035
      FQDN                             castagna
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_1:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_3                   1        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.004.000/24
-------------------------------------------------------------------------------
2    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** ANONYMOUS
1    ******** IP        213.206.129.060

CPX 2.

IKE host connections table:
[21:30:22] CPX_2:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_2-to-CPX_1                   213.206.129.060      1       3
      3DES      PSK   MD5   MODP1024   083.149.000.035      AUTO    3600
      IP              213.206.129.060
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_2:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_2-to-CPX_1                   0        IPSEC        28800         YES
     YES  3DES        MD5             NO       YES          192.168.003.000/24
     NO               MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_2:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

CPX 3.

IKE host connections table:
[21:30:22] CPX_3:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_3-to-CPX_1                   0                    1       3
      IDEA      PSK   SHA   MODP1536   083.149.000.035      AUTO    3600
      FQDN                             castagna
      IP              083.149.000.035
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX_3:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_3-to-CPX_1                   0        IPSEC        28800         YES
     YES  3DES        MD5             NO       YES          192.168.004.000/24
     NO               MD5                      YES          192.168.001.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:.
[21:30:19] CPX_3:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        083.149.000.035

print this page


IPsec port configuration example. CPX to Win2000/XP.

Manual mode
IKE mode
Transport (host-to-host)
Transport (host-to-2 anonymous hosts)
Tunnel (gateway-to-gateway)

Manual mode top

Manual mode is not supported by Windows2000/XP.

IKE mode top

MODE parameter of the IPsec driver must be set to the IKE mode.

[21:14:29] CPX:d p po:ipsec

PO:920
IPSEC  ------------------------------------------------------------------------
       LOG:DS         ACT:YES    MODE:IKE     mxps:2048   IN-CHK:YES  TTL:0
       ECN:FORBIDDEN  DF:CLEAR
IKE port must be activated (set ACT parameter to the YES):

[21:14:32] CPX:d p po:ike

PO:921 ------------------------------------------------------------------------
IKE    LOG:DS       lowpo:902       ACT:YES       mxps:2048   NRTY:3    TB:10
       WDIR:C:\APP\IKE\
       NATT:NO      NATT-N-IKE:YES  NATT-PF:YES  NATT-KA:20
For all examples set win2k/XP autentication method to pre-shared key (PSK):

Figures 1, 2. Win2k/XP PSK method settings.

IKE mode. Transport (host-to-host) top

Figure 3. Host-to-host layout.

CPX (host) has IP interface 0 with 192.168.2.1 IP address.
Win2k/XP (host) has IP interface with 192.168.2.2 IP address.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: ESP protocol with SHA-1 authentication and DES encryption.
  • PFS: disabled.
CPX can begin to negotiate IPsec connection.

CPX.

IKE host connections table:
[21:30:22] CPX:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX-to-Win2k/XP                  192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX-to-Win2k/XP                  0        IPSEC        28800         NO
     YES  DES         SHA             NO       NO           192.168.002.001/32
     NO               MD5                      NO           192.168.002.002/32
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       YES          000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX_1:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.2

Win2k/XP.

Reset tunnel settings:

Figure 4. Win2k/XP tunnel settings: transport.

Set IP filter properties:

Figure 5. Win2k/XP transport IP filter.

Set ISAKMP settings:

Figures 6-8. Win2k/XP ISAKMP settings: MD5, 3DES, DH-1024 (Medium 2).

Set IPSec settings:

Figures 9-11. Win2k/XP IPsec settings: ESP (DES, SHA-1), PFS is disabled.

IKE mode. Transport (host-to-2 anonymous hosts) top

Figure 12. Host-to-2 anonymous hosts layout.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: SA bundle: ESP protocol with SHA-1 authentication and 3DES encryption, AH protocol with MD5 authentication.
  • PFS: enabled.
CPX is in the PASSIVE mode (IPsec server).

CPX.

IKE host connections table:
[21:30:22] CPX:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX-to-Win2k/XP_1                192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   *                    AUTO    3600
      IP              192.168.002.001
      FQDN                             konstt
-------------------------------------------------------------------------------
1     CPX-to-Win2k/XP_2                192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   *                    AUTO    3600
      IP              192.168.002.001
      FQDN                             castagna
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX-to-Win2k/XP_1                0        IPSEC        28800         YES
     YES  3DES        SHA             YES      NO           192.168.002.001/32
     YES              MD5                      NO           192.168.002.002/32
-------------------------------------------------------------------------------
1    CPX-to-Win2k/XP_2                1        IPSEC        28800         YES
     YES  3DES        SHA             YES      NO           192.168.002.001/32
     YES              MD5                      NO           192.168.002.002/32
-------------------------------------------------------------------------------
2    Drop                             NONE     DROP         28800         NO
     NO   DES         SHA             NO       NO           000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table (both anonymous client will share the same PSK):
[21:30:19] CPX:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** ANONYMOUS

Win2k/XP 1, 2.

Set IP filter properties:

Figure 13. Win2k/XP transport IP filter.

Set IPSec settings:

Figures 14, 15. Win2k/XP IPsec settings: ESP (3DES, SHA-1) + AH (MD5), PFS is enabled.

IKE mode. Tunnel (gateway-to-gateway). top

Figure 16. gateway-to-gateway layout.

  • ISAKMP: 1024 DH group, PSK authentication, MD5 hash and 3DES encryption.
  • IPsec: ESP protocol with MD5 authentication and DES encryption.
  • PFS: enabled.
CPX can begin to negotiate IPsec connection.

CPX.

IKE host connections table:
[21:30:22] CPX:d ike host

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX-to-Win2k/XP                  083.149.000.035      1       3
      3DES      PSK   MD5   MODP1024   213.206.129.060      AUTO    3600
      IP              083.149.000.035
      IP              213.206.129.060
-------------------------------------------------------------------------------
IKE client connections table:
[21:30:58] CPX:d ike cli

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX-to-Win2k/XP                  0        IPSEC        28800         YES
     YES  DES         MD5             NO       NO           192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    Drop                             NONE     DROP         28800         YES
     NO   DES         SHA             NO       NO           000.000.000.000/0
     NO               MD5                      NO           000.000.000.000/0
-------------------------------------------------------------------------------
IKE PSK table:
[21:30:19] CPX:d ike psk

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        213.206.129.060

Win2k/XP.

For tunnel mode you should add two IP filter records (inbound and outbound): For each filter records set tunnel settings (tunnel's endpoints):

"outbound" policy:

"inbound" policy:

Figure 17, 18. Win2k/XP tunnel settings: tunnels.

For each filter records set IP filter properties:

"outbound" policy:

"inbound" policy:

Figure 19, 20. Win2k/XP tunnel IP filters.

print this page


Calculator for Frame Relay

This calculator is used to calculate the StepCountConst configuration parameter of CPX.

Choose value from pull-down selectors or just type in the field.

Terminology

StepCountConst

This value depends on the Frame Relay line parameters AR, CIR, Bc, Be, EETD and FSize. It expresses the maximum number of frames present on the path from the local user to the remote user and vice versa at the same moment.

AR (Access Rate)

Port related parameter.
Expressed in bits per second.

CIR (Committed Information Rate)

DLCI related parameter.
Expressed in bits per second.

Bc (Committed Burst Size)

DLCI related parameter.
Expressed in bits (per Tc).

Be (Excess Burst Size)

DLCI related parameter.
Expressed in bits (per Tc).

Tc (Measurement interval)

Time interval calculated as Bc/CIR.
Expressed in seconds.

EETD (End to End Transit Delay)

Time interval that starts when the first bit of transmitted frame crosses the local interface, and ends when the last bit of the same frame crosses the remote interface. This value depends on the frame size.
Expressed in milliseconds.

FSize (Frame Size)

The size of the longest frame expected to send on this DLCI.
Expressed in bytes.

Last update: August 2, 1999


Using HTTP for showing TRFA statistics

Overview
Parameters of request
Filters
Possible combinations report parameters

Http user manual

<<<<<<< mod_http_trfa.htm HyperText Tranfer Protocol port (HTTP)
Traffic analyzer port (TRFA)
======= Http port (HTTP)

>>>>>>> 1.3

Overview top

As you know TRFA port allows to save and analyze traffic for one or more IP interfaces. HTTP port gives friendly interface for working with TRFA information. You can get access to this feature through /sys/trfa.htm page. If you cannot get access to this page make sure that access rights were set correctly. Please see HTTP Port user manual for information how to set access rights.

Parameters of request top

Period selection.

This parameter is allow to define which time period will be used as report base.
  • Current year
  • Archive information. There are three previous years and current year.
    Note! Archive information will be available only you have already run TRFA port on previous time. On the other words sometime you will see only value for current year. It is normally and means that TRFA have not information about previous time.

If you select current year than you can define report period more exactly. Each period has minimal time interval.
There are

  • For Year minimal period is one day.
  • For Month minimal period is two hours.
  • For Week minimal period is 30 minutes (half hour).
  • For Day minimal period is five minutes.

Window display.

This parameter is used for detection where will be selected period begun.

  • Sliding It means that the end of selected period will be started at the current moment minus length of period. For example if Day period was selected and it is 22 hours now You will see report from 22 hour of previous day to now.
  • Beginning It means that will be used "official" start of selected period. For example It is 00:00 for a day.

Display information as.

This parameter detects an output view of report.

  • Picture In this case traffic information will be represented as picture.
  • Table In this case traffic information will be represented as table.

Note! You can always switch current type of display information for prepared report. For changing picture view to table view simple to click by picture or select "Switch to PICTURE view" link on page with table otherwise.

Report type.

This parameter defines will or will not be grouped output information.

Units.

This parameter defines size of kilobytes that will be user for report. You can use as value equal 1000 bytes as 1024 bytes in depend on you preferences.

Multiplier.

This parameter defines unit that will be used for showing traffic information. You can select or bits per second (Bits/Sec) or bytes per second (Bytes/Sec).

Filters top

You can filter traffic information for selected period by

  • IPP In this case will be showed traffic information for selected IPPs only.
  • IP addresses In this case will be showed traffic information for selected IP addresses (or intervals of IP addresses) only.
  • Protocols In this case will be showed traffic information for selected protocols only.

Note! Information about filter parameters will be displayed on the top of report page.
For example:

Filter parameters |
IPP: | 0, 1, 2
Protocols: | ICMP, All TCP
IP address: | 062.094.170.067 : 062.110.059.140
 | 064.223.179.109

Possible combinations report parameters top

Report type | IPP filter | Protocol filter | Display information as | Result
Individuals | All IPP | All protocols | Picture/Table | Report where traffic information will be grouped by IPP (i.e each table/graph will contain traffic information for one IPP and all protocols).
Sums | All IPP | All protocols | Picture | Report on the picture view where traffic information grouped as by IPP as by Protocols (i.e. one picture only).
Sums | All IPP | All protocols | Table | Table where traffic information will be grouped by IPP (i.e each table row will contain traffic information for one IPP and all protocols on table or picture view).
Individuals | All IPP | A few protocols | Picture/Table | Error. It is not valid combination. We can use multiple protocol report only for one IPP.
Sums | All IPP | A few protocols | Picture/Table | Report where traffic information on each picture will be grouped by IPP (i.e. each picture/table row will contain traffic information for one Protocol and all IPPs).
Individuals | A few IPPs | A few protocols | Picture/Table | Error. It is not valid combination. We can use multiple protocol report only for one IPP.
Sums | A few IPPs | A few protocols | Picture/Table | Report where traffic information on each picture will be grouped by IPP (i.e. each picture/table row will contain traffic information for one Protocol and all selected IPPs).
Individuals | One IPP | A few protocols | Picture/Table | Report where on each picture/table row will contain traffic information for selected IPP and one seleted Protocol.
Sums | One IPP | A few protocols | Picture/Table | Report where traffic information on each picture will be grouped by IPP (i.e. each picture/table row will contain traffic information for one Protocol and all selected IPPs).


HTTP user manual

Introduction
Virtual paths
URL processing
HTTP root directory
Default page
Access rights
Typical access problems and their solutions
HTTP site deploying

Http pages for IP traffic analysis (TRFA)

<<<<<<< mod_http_man.htm HyperText Tranfer Protocol port (HTTP)

======= Http port (HTTP)

>>>>>>> 1.3

Introduction top

<<<<<<< mod_http_man.htm

Before using HTTP port of CPX you should decide about the next issues: =======

HTTP port can be used for representation service or user information on comfortable view. Before using HTTP port get answers for the next question:

>>>>>>> 1.3
    <<<<<<< mod_http_man.htm
  • Which kind of information you intend to offer (CPX built-in, disk files access, TRFA report)
    • =======
  • Which kinds of information will you server represent (CPX built-in, disk files access, TRFA report)?
    • >>>>>>> 1.3
  • Where will you site be located on?
  • Whether you need user identification and individual access rights
  • Whether you need anonymous access
  • How many simultaneous users you expect to serve
<<<<<<< mod_http_man.htm Having decided on the the above issue you'll avoid errors in the site deploying. Follow next instruction to create your site easyly and quickly. =======

This information is allowed you to avoid errors for site deploying. Follow our instructions you will create you site easy and quickly. >>>>>>> 1.3

Virtual paths top

<<<<<<< mod_http_man.htm

In CPX, files or built-in pages are all accessible under the so called Virtual paths. There are system virtual paths, which are not under user control, and there are virtual root paths which are user configurable.

Currently /sys/ is the system virtual path under which all built-in pages and system related files are published, for example /sys/trfa/trfa_info.html is the built-in page to access the traffic analysis service. Actually /sys/ correspond to the CPX working directory on disk (e.g. C:\4-7-0\). Only two special pages exists under the / path, they are login.htm and logout.htm, for ... login/logout purposes.

Virtual root paths are user configurable, and they allow to publish any local disk directory with a name immediately following the FQDN or the IP address. They are called "virtual root paths" because it is possible to specify only the the first name after the FQDN or the IP address, child directories will be automatically published with their name on disk. Note that since /sys/ is a reserved system virtual paths, it is not possible to configure /sys/ in the Virtual root paths table.

The whole name after the FQDN or the IP address is the complete virtual path. Either virtual root path or virtual path can be used to apply access rights, as shown in Access rights section.

Examples:

http://www.mysite.com/files/subdir1/index.hml
www.mysite.com is the FQDN
/files/ is the virtual root path
/files/subdir1/ is the virtual path
index.html is the document name

http://192.168.0.1/files/subdir1/index.hml
192.168.0.1 is the IP address
/files/ is the virtual root path
/files/subdir1/ is the virtual path
index.html is the document name
=======

Usually Virtual directories are used for hide real directory structure of disk from HTTP users. Moreover this feature allows to set flexible access rights for each directory. When you type URL on the address bar of you internet browser you always use virtual directories instead real. HTTP port will translate virtual directories to real itself. >>>>>>> 1.3

<<<<<<< mod_http_man.htm

warning A special case exists when the user wants to map a disk directory as the site root /, in which case the / is a virtual root path. If disk directory published as / contains a subdirectory with a name which is also configured as a virtual root path or is a system virtual path, the last take precedence. Similarly the system pages /login.htm and /logout.htm take precedence to files with the same names eventually present in the disk directory mapped to /.

URL processing top

Any HTTP requests from a browser comes with the requested URL specified, here we describe how the URL is parsed and processed by the CPX HTTP port:

  • CPX HTTP port does not offer virtual servers service, therefore the FQDN or the IP address are first removed from URL and the remaining is separated in virtual path and file name.
    For example:
    =======

    How HTTP port translates requested URL:

    >>>>>>> 1.3
      <<<<<<< mod_http_man.htm
    • http://www.mysite.com/default.htm will be parsed into virtual path=/ and file name=default.htm.
    • http://192.168.0.1/main_dir/sub_dir1/a_page.html will be parsed into virtual path=/main_dir/sub_dir1 and file name=a_page.html.
    At this time HTTP does not know yet if file name is intended for a regular file or a subdirectory.
  • First of all HTTP checks if the virtual path is either /login.htm or /logout.htm. These pages are pages which have top priorities and overrides any other virtual system or root paths. If the URL is not for these priviledged pages, the story goes on ...
  • HTTP port checks if the virtual path correspond to a system virtual path, or if it can satisfy a record in the virtual root path table.
    • If virtual path corresponds to a system virtual path, the appropriate system action is performed
    • If virtual path satisfy a virtual root path record, the disk directory specified in the record will be accessed in the attempt to retrieve the file/directory specified in file name.
  • If requested file/directory does not exists:
    • =======
  • HTTP port try do separate requested URL by directory and file names. For example for case when URL equal http:/mysite/default.htm It will be parsed to "/" and "default.htm".
  • If filename is absent then HTTP port: >>>>>>> 1.3
      <<<<<<< mod_http_man.htm
    • For site root ("/") HTTP will try to load the start-page
    • For any other virtual path HTTP will try to find directory default page. It is "default.htm" now.
    • If this files cannot be found then HTTP suppose that user try to list a directory content.
    =======
  • For HTTP root directory "/" will try to load default page
  • For any other directory will try to find directory default page. It is "default.htm" now.
  • If this file cannot be found then HTTP suppose that user try to list a directory content.
  • HTTP port tries to find directory name into virtual path table. If such virtual path is present then virtual path on URL will be replaced by phys-path for this record.
    • >>>>>>> 1.3
  • If virtual path for this directory not present HTTP port try to parse directory name on subdirectories and find the first of them on virtual path table. For example: directory that have been detected from URL is "/usr/admin/". Virtual path for "/usr/admin/" is not present on virtual paths table then directory name will be split on "/usr/" and /admin" and port will try to find "/usr/" on virtual path table.
  • If previous search was unsuccessful then directory name will be split on "/" and "usr/admin/" HTTP port will try to find record for HTTP root directory ("/") into virtual path table.
  • If path for HTTP root have not found then error 404 (file not found) will be returned.

    • For example let real disk directory structure has view:

    C:\APP
C:\APP\HTTP
C:\APP\SMNP
C:\MY
C:\MY\TEMP
C:\ROOT

    To use virtual directories we can allow access to these directories in view more comfortable for user.

    [16:32:16] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /
PHYS-PATH:    c:\root\
PATH:         /http/
PHYS-PATH:    c:\app\http\
PATH:         /snmp/
PHYS-PATH:    c:\app\snmp\
PATH:         /temp/
PHYS-PATH:    c:\my\temp\

    Then if URL has view:

    • http://mysite/default.htm then HTTP server will try to find c:\root\default.htm file and send it to you.
    • http://mysite/http/mypage.htm then HTTP server will try to find c:\app\htt\mypage.htm
    • http://mysite/snmp/version1/main.page As you can see /snmp/version1/ does not present on virtual paths table and in this case HTTP server replace only a part of requested path (i.e. virtual directory will be used as parent directory for a real) c:\app\snmp\version1\main.page

    HTTP root directory top

    Each WEB site usually have root directory. When you type http://my_site/ on the address bar your internet browser it means that you try to receive access to files into root directory of you site.

    Two steps must be executed for creating root directory:

    • Create physical directory
    • Map virtual directory "/" to this physical directory

    Below is represented view of HTTP virtual paths table with configured root directory.

    [16:32:16] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /
PHYS-PATH:    c:\app\http\

    Note: You site will function and if you do not create HTTP root directory. You do not need on it for example if you planning to use you HTTP server for representing CPX built-in information only.

    Default page top

    It will be useful to detect which page will user see if he does not select anyone. For example there is situation when user types link to root directory of you site http://my_site/. CPX HTTP port allows to setup this page through START-PAGE parameter.

    You can use this possibility regardless of was or was not defined root directory for you site. As you know we can set any value for this parameter.
    Note! If you use default page different from SYS (/sys/cpx.htm) to be sure that you have virtual path for this page otherwise HTTP port could not show you default page.

    For example: Let's set value of START-PAGE parameter equal "/usr/default.htm"

    [18:45:45] ABILIS_CPX: D P PO:HTTP

PO:915 ------------------------------------------------------------------------
HTTP   lowpo:901   ACT:NO   locport:80     sesnum:12        COOKIE-TOUT:1440
       IPSRC:*                             IPSRCLIST:#
       WDIR:C:\APP\HTTP\
       START-PAGE:/usr/default.htm

    Then right HTTP virtual path table will have view:

    [16:32:16] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    c:\app\http\

    Access rights top

    HTTP server realizes access rights management on base user's rights. It means that all requests are executed with some user's rights. We will separate two different situations:

    • Authorized request
    • Anonymous request

    Authorized request is request executed by user that has gone through authorization procedure. During authorization procedure user must insert his username and password on the special system page. This page has URL http://you_site/login.htm You do not need any additional operations (for example create virtual directory or set user access rights) for access to this page. It is allow always and for all user. If registration procedure finished successful:

    • Such user is present on user's table
    • This user has rights to use HTTP port
    • Password is valid

    then HTTP port tries to save cookie with user's registration information.

    Note! Cookie must be allowed on you Internet browser otherwise HTTP port cannot detect user for the next HTTP request.

    Lifetime of cookie is restricted. It means that If you executed you last request for this user more time ago than restricted time you will need to repeat authorization procedure.

    After then you have added virtual paths for you HTTP site you need to set access rights for this paths. HTTP port is allow to set the next rights for each virtual path for each user:
    • For files: read, write, delete, rename
    • For directory: list directory content, create, delete, rename
    • Grant/Deny access to subdirectories
    • Grant/Deny access in depend of HTTP session secure parameters PLAIN/SSL

    Note! You must remember two important things:

    • HTTP port does not set any access rights for new paths by default. It means that you will not have an access to this path if access rights will not be added by hand.
    • In order to avoid problems with not authorized access to you site to be very careful when you work with access rights.

    Typical access problems and theirs solutions top

    Description | Reason | Solution
You cannot get access to any files for some virtual path | Access rights for this virtual path are not set. | Set access rights
You cannot get access to subdirectory located on this virtual path | Value of RECUR parameter for this virtual path is NO | Set RECUR parameter to Yes
Access rights for this virtual path are set but you still cannot get access to files | 1. To be sure that current user has rights to use HTTP port. See command F USER 2. To be sure that current user has rights to load files. | 1. Enable HTTP for current user 2. Enable files reading right for this user
You have added virtual path for some user's home directory (for example /leo/ ) and set some access rights for this path. You have also added "home.htm" page to this directory. When you type http://my_site/leo/home.htm you see this page successfully. However when you type http://my_site/leo you see "Access forbidden" page. How can you avoid this message ? | 1. If you can grant access to some user to see content of this directory than make sure that this user has necessary rights. 2. Add default page for this directory. | 1. Enable directory listing right for this user. 2. Default page for any directory has name "default.htm". You can rename "home.htm" to "default.htm" and this page will be automatic showed on http://my_site/leo request.

    HTTP site deploying top

    Description on base configuration

    • HTTP port is installed.
    • CPX disk contains logical drive C:
    • Physical directory C:\USR contains two user's directory C:\USR\LEO and C:\USER\DEN
    • HTTP port will be allowed as for anonymous access as for two registered users Leo and Den
    • Anonymous user will have rights to see HTTP port default page and user's default pages. Registered users will have rights to see content of personal directories.

    Step 1. Check directory structure

    [[11:07:48] ABILIS_CPX:sys dir c:\usr\

Directory listing of c:\usr\

.                                                 DIR    02/09/2003   14:54:52
..                                                DIR    02/09/2003   14:54:52
PUB                                               DIR    02/09/2003   14:54:52
DEN                                               DIR    17/02/2004   03:03:56
LEO                                               DIR    07/08/2004   11:04:50

Found 5 directories, 0 files.
Total 501 MB, Used 418 MB, Free 83 MB.

[11:07:57] ABILIS_CPX:

    Step 2. Check HTTP port parameters.

    Will be sure that HTTP port is enabled and ran (ACT:YES).
    [10:40:23] ABILIS_CPX:d p po:915

PO:915 ------------------------------------------------------------------------
HTTP   lowpo:901   ACT:YES  locport:80     sesnum:12        COOKIE-TOUT:5
       IPSRC:*                             IPSRCLIST:#
       WDIR:C:\APP\HTTP\
       START-PAGE:SYS (/sys/cpx.htm)
PO:901 ------------------------------------------------------------------------
TCP    sesnum:27   tcpwin:2048

    Step 3. Add HTTP users.

    Will be sure that added users have right to use HTTP port.
    [10:47:37] ABILIS_CPX:d user

- Not Saved (SAVE CONF) -------------------------------------------------------

USER:                             PASSWORD:  ENABLED: PPP: FTP: HTTP:
------------------------------------------------------------------------------
admin                             *********  YES      YES  YES  YES
den                               *********  YES      NO   NO   YES
leo                               *********  YES      NO   NO   YES

    Step 4. Add virtual paths for site root directory and users home directories.

    [11:29:43] ABILIS_CPX:d http path

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /
PHYS-PATH:    C:\
------------------------------------------------------------------------------
PATH:         /den/
PHYS-PATH:    C:\USR\DEN\
------------------------------------------------------------------------------
PATH:         /leo/
PHYS-PATH:    C:\USR\LEO\
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\usr\pub\
------------------------------------------------------------------------------

    Step 5. Set access rights.

    [11:29:38] ABILIS_CPX:d http rights

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  3 /
       anonymous                        r---  l---  NO     PLAIN,SSL
------------------------------------------------------------------------------
  5 /den/
       anonymous                        r---  ----  YES    PLAIN,SSL
       den                              r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /leo/
       anonymous                        r---  ----  YES    PLAIN,SSL
       leo                              r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub/
       anonymous                        r---  l---  NO     PLAIN,SSL
------------------------------------------------------------------------------
  1 /sys/
       admin                            r---  l---  YES    PLAIN,SSL
       anonymous                        r---  ----  NO     PLAIN,SSL
------------------------------------------------------------------------------

    Step 6. Add default pages into user home directories.

    Create and add user's default page. Place this pages to user's home directory. Note: You can use FTP port for it. Information about FTP port configuration see on FTP manual.
    [11:16:44] ABILIS_CPX:sys dir C:\USR\LEO\

Directory listing of C:\USR\LEO\

.                                                 DIR    07/08/2004   11:04:50
..                                                DIR    07/08/2004   11:04:50
default.htm                                       4990   06/07/2004   01:05:24

Found 2 directories, 1 files.
Total 501 MB, Used 418 MB, Free 83 MB.

    [11:23:04] ABILIS_CPX:sys dir C:\USR\DEN\

Directory listing of C:\USR\DEN\

.                                                 DIR    17/02/2004   03:03:56
..                                                DIR    17/02/2004   03:03:56
default.htm                                       4990   06/07/2004   01:05:24

Found 2 directories, 1 files.
Total 501 MB, Used 418 MB, Free 83 MB.

    Step 7. Check HTTP configuration

    • Check CPX home page
      • Type http://my_site and make sure that you see site home page.
    • Check anonymous access to users home pages
      • Type http://my_site/leo and make sure that you see Leo's home page.
      • Type http://my_site/den and make sure that you see Den's home page.
    • Try to login as LEO or as DEN. Make sure that you can still see site and user's home pages.
    • Make sure that you can see you home directory. For it:
      • Rename C:\USR\LEO\default.htm file to readme.htm
      • Login as LEO
      • Type http://my_site/leo
      • Make sure that you see list of files on Loe's home directory
      • Login as some other user. For example DEN.
      • Type http://my_site/leo again
      • Make sure that you see Forbidden access page


The Archive Port (ARC)

Terminology

Configuration of the Archive Port (ARC)
Statistics of the Archive Port (ARC)

The Archive port is responsible for creating a structured files archive starting from a set of files.

The generated archive organization is time-based, i.e. files are grouped in a set of separated directories on the base of the date and time of their creation. Directories and sub-directories are hierarchically organized in a tree starting from the archive root.

Below there is an example of a source archive:

D:\SrcArchive\
|__ File#1 (dated 2004_03_10, 10:22:37)
|__ File#2 (dated 2004_03_10, 11:22:01)
|__ File#3 (dated 2004_03_10, 11:23:40)
|__ File#4 (dated 2004_03_12, 00:45:15)
|__ File#5 (dated 2004_03_13, 18:30:00)
...
|__ File#N (dated 2004_03_31, 19:51:23)

The figure below shows how the generated archive organization:

E:\DstArchive\
|_2004_03                          (Year_Month directory)
        |_10                       (Day directory)
        |   |_10                   (Hour directory)
        |   |  |_ File#1
        |   |_11
        |      |_ File#2
        |      |_ File#3
        |_12
        |   |_00
        |      |_ File#4
        |
        |_13
        |   |_18
        |      |_ File#5
        ...
        |_31
            |_19
               |_ File#N

Terminology top

Archiving
It is the procedure that moves all files from the archive source directory (SRCPATH:) to the archive destination directory (DSTPATH:).
This operation is periodically executed for every activated session (USE:YES) on the base of the ARC-INT: parameter value.
Archive purging
It is the procedure that deletes old archived file from the archive destination directory (DSTPATH:), in order to avoid archive saturation and to create free space for more recent files archiving.
This operation is periodically executed for every activated session (USE:YES) on the base of the PURGE-INT: parameter value on those files that are older then the PURGE-AGE: parameter value.
ZIP packing
It is the procedure that compress archived files found in the archive destination directory (DSTPATH:) in to one or more ZIP packed file.
This operation is periodically executed for every activated session (USE:YES) on the base of the PACK-INT: parameter value.
HD Sentinel
Is is a process responsible for checking the run out of the space available for every hard disk used by the Archive port and sessions.
When the process is activated (INTERVAL:) the current amount of free space of any disks is evaluated and, if the amount of free space of a disk reaches the minimum value defined by the MIN-FREE-SPACE: parameter, then a "purging procedure" is activated on this disk. The procedure will delete the oldes archived file from the disk in order to create the minimum amount of space defined by the MIN-FINAL-SPACE: parameter.
Historical logging
Relevant information related to the ARC port driver actions, errors and any other interesting events are stored in a textual file named "ARC.LOG" and usually located in "C:\LOG\ARC\" directory.
Here it is a sample of the content of the historical log file:
[11:13:51] ABILIS_CPX: DEBUG PO:980 LSN:5

PO:980 ------------------------------------------------------------------------
ARC    BufferLength:432    Date/Time:08/04/2004 11:28:24 TraceTime:<NotRunning>

***** Archive History Log file - Created at Thursday, 08/04/2004 11:25:12 *****

[08/04/2004 11:26:03] PO:980 History process activated.
[08/04/2004 11:26:03] PO:980 Ses:00 Activated.
[08/04/2004 11:26:04] PO:980 Ses:31 Activated.
[08/04/2004 11:26:04] PO:980 Initialization completed.
[08/04/2004 11:26:09] PO:980 Ses:31 Source path directory not valid.
[08/04/2004 11:27:03] PO:980 Ses:00 Source path directory not valid.
The historical logging activation/deactivation as well as the "ARC.LOG" file location and maximum size can be selected by the user through the HISTORY:, history-size: and history-path: parameters.

Configuration of the Archive Port (ARC) top

The Archive port is identified by the mnemonic "ARC" and it is provided with the parameters described in this section.

Here are examples on how to display the ARC port parameters. Displayed values are samples:

[11:47:16] ABILIS_CPX: D P PO:ARC

PO:980 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
ARC    ------------------------------------------------------------------------
       LOG:NO      ACT:NO   MAX-SES:1    HISTORY:YES  history-size:AUTO
       history-path:C:\LOG\ARC\
       - Hd Sentinel ----------------------------------------------------------
       INTERVAL:10   MIN-FREE-SPACE:2    MIN-FINAL-SPACE:4
       - ZIP Packing ----------------------------------------------------------
       PACK-INT:60
       - Archiving sessions ---------------------------------------------------
       SES:0  USE:NO   DESCR:
              SRCPATH:
              DSTPATH:
              ARC-INT:60    PURGE-INT:1    PURGE-TIME:00:00:00  PURGE-AGE:15
              PACK-SIZE:10240
       ------------------------------------------------------------------------

To activate changes made on the parameters displayed by low case characters, it is needed to restart the system; on the contrary for activating changes made on upper case parameters it is enough to execute the initialization command INIT PO:.
Changes made on LOG: parameter are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

Detail of the ARC port parameters

LOG: | Events logging activation and generation of alarm signals
DS | NO, D, S, A, L, T, ALL, +E

Usually this parameter makes possible to activate/deactivate logging functionalities of meaningful events of the port as well as the detection and signalling of alarms in case of critical events.

The following table shows the available options and the related functionalities usable by the parameter:

Option | Meaning
D | Recording of the driver state changes and/or the meaningful events in Debug Log
S | Recording of the driver state changes and/or the meaningful events in the System Log
A | Periodic detection of possible alarms. The detected alarms can be displayed the command ALARM VIEW or by the analogous command available on the UTILITY of the LCD display on the front panel
L | On alarm detection, acoustic signal generation plus a message on the LCD display. This function depends on activation of alarms detection by the "A" option
T | Generation by the Agent SNMP of Abilis CPX of SNMP traps corresponding to any change of the driver state and/or occurring of meaningful events

Beside the already described options the following values are also allowed:

Option | Meaning
NO | It means that all the logging functionalities, alarms detection and generation, above mentioned, are disabled.
ALL | It means that all the logging functionalities, alarms detection and generation, above mentioned, are enabled.
+E | This option added to one or more of the previous ones, extends its (their) set of meaningful events. The value "ALL+E" activates all the options and extends the set of meaningful events. The value "NO+E" is meaningless so it is ignored.

Options can be combined together.

Some examples:

  • setting "LOG:DS+E", activates the extended logging functions for Events Log and System Log
  • setting "LOG:STA", activates the extended logging functions for System Log, SNMP traps generation and periodic detection of alarm states;

By using the characters "+" and "-" as prefix of one or more options is possible to add or delete one or more functionalities without setting from the scratch the value of the parameters.

Some examples:

  • Suppose the current value of the parameter is "LOG:DSTA", by setting "LOG:-A", the periodic detection of eventual alarm states is removed, leaving unchanged all the remaining options; in such way the final value of the parameter will be "LOG:DST";
  • Suppose the current value of the parameter is "LOG:ST", by setting "LOG:+DA", the logging function of the events on the Events Log and the periodic alarm detection are added to the already activated options; in such way the final value of the parameter will be "LOG:DSTA".

warning! The changes made on this parameter are immediately activated, without the need of initialization commands.

In the following sample, messages registered in the System Log by the ARC port are displayed:

[11:22:54] ABILIS_CPX: D L

Current Local Time: Thursday 08/04/2004 11:23:00 (GMT+2.00)

08/04/2004 11:21:26 WARM START
08/04/2004 11:21:53 --- NEW RUN ----
08/04/2004 11:21:53 I: SYSTEM RESET
08/04/2004 11:21:56 W: HSCB 001 NI
08/04/2004 11:21:57 W: EB EPIC CONF
08/04/2004 11:21:57 W: EB EPIC NI
08/04/2004 11:22:00 W: C02
08/04/2004 11:22:03 SYSTEM STARTED
08/04/2004 11:22:03 CONF:ACCEPTED
08/04/2004 11:22:03 CONF:BACKUP
08/04/2004 11:22:03 AUTO SAVE CONF
08/04/2004 11:22:03 I:p21  PAD:dn.01
08/04/2004 11:22:03 I:p201 LAPB:cg
08/04/2004 11:22:03 I:p202 LAPB:cg
08/04/2004 11:22:03 I:p301 X25:down
08/04/2004 11:22:03 I:p302 X25:down
08/04/2004 11:22:03 I:p980 ARC:RD
08/04/2004 11:22:03 I:p980 SES:0  RD
08/04/2004 11:22:03 I:p980 SES:31 RD
08/04/2004 11:22:03 I:p997 MLM:ln.RD
08/04/2004 11:22:03 I:p998 LAPB:cg
08/04/2004 11:22:03 I:p999 X25:down
08/04/2004 11:22:04 AUTO SAVE OK

In the following sample, messages registered in the Debug Log by the ARC port are displayed:

[11:26:42] ABILIS_CPX: D LDM

Current Local Time: Thursday 08/04/2004 11:26:47 (GMT+2.00)

Date   Time   Po  Ses   Event and Parameters
------ ------ --- ----- ------------------------------------------------------
080404 112608  21     0 PortDiag PAD:dn DCD:dn DTR:UP
080404 112608 201     0 PortDiag LAPB:cg
080404 112608 202     0 PortDiag LAPB:cg
080404 112608 301     0 PortDiag X25:down
080404 112608 302     0 PortDiag X25:down
080404 112608 980     0 PortDiag ARC:ACTIVE
080404 112608 980     0 PortDiag ARC SES:0  ST:ACTIVE
080404 112608 980     0 PortDiag ARC SES:31 ST:ACTIVE
080404 112608 997     0 PortDiag MLM PLink:ln SLink:RD ATN:
080404 112608 998     0 PortDiag LAPB:cg
080404 112608 999     0 PortDiag X25:down
080404 112637 905     6 CallRx CG:                CD:00
              PID:01000000 UD:CP           FF:
080404 112637 905     6 Routing Match PR:0
080404 112637   0     1 CallTx CG:                CD:00
              PID:01000000 UD:CP           FF:
080404 112637   0     1 CallConnRx LSN:01 CG:                CD:00
              PID:01000000 UD:CP           FF:
080404 112637 905     6 CallConnTx LSN:01 CG:                CD:
              PID:         UD:             FF:

ACT: | Runtime activation/deactivation of ARC
NO | NO, YES

This parameter allows to run-time activate/deactivate ARC functionalities.

When it is set to "YES:", the port is configured, active, and the ARC driver performs its activities.

When it is set to "NO", the port is configured, active, but the ARC driver does not execute any action.

MAX-SES: | Number of ARC clients
1 | 1..32

This parameter sets the maximum number of ARC sessions to be supported by the ARC port.

Changes made on this parameter are immediately active, but they don't need the system to be restarted. The new number of ARC sessions can be activated by the execution of the initialization command INIT PO:xxx, where "xxx" is the ARC port number.

HISTORY: | Historical logging activation/deactivation
YES | NO, YES

This parameter activate/deactivate the generation of an historical log file.

Historical log file is a plain textual file, named "ARC.LOG", where relevant information related to the ARC port driver actions are stored.

If the parameter is set to "NO", the registration of interesting events into the history log file is disabled.

If the parameter is set to "YES", registration of interesting events into the history log file is enabled and the "ARC.LOG" file is created by the ARC port driver in the location specified by the history-path: parameter.

The maximum size of the "ARC.LOG" file is selected by the history-size: parameter.

history-size: | Historical log file size
AUTO | AUTO, 1%..99%, 100K..65535K

This parameter sets the maximum size of the historical log file "ARC.LOG" created by the ARC port driver during its execution.

The user can select the historical log file size by one of the following ways:

Value | Description
AUTO | By specifying this value, the ARC port driver will use the 5% of the disk size for the "ARC.LOG" file.
1%..99% | By specifying a numeric value in the range [1..99] followed by a '%' character, the ARC port driver will use the selected percentage of the disk size.
100K..65535K | By specifying a numeric value in the range [100..65535] followed by a 'K' character, the ARC port driver will use exactly the selected amount of space on the disk. If the specified value is greater then the disk size, the driver will use the 99% of the disk size.

The historical log file "ARC.LOG" created by the ARC port driver in the location specified by the history-path: parameter.

This parameter is used only if the HISTORY: is set to "YES".

history-path: | Historical log location.
C:\LOG\ARC | From 0 up to 128 ASCII extended characters [32..255]

This parameter selects the location where the historical log file "ARC.LOG" must be created by the ARC port driver.

It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Strings of up to 128 ASCII extended characters in the range [32..255] are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\"). The case of the entered path is preserved.

If the directory doesn't exists, the driver will create it. If the parameter is left empty, the Historical log will not be generated by the ARC port driver.

This parameter is used only if the HISTORY: is set to "YES".

INTERVAL: | Disk space check interval
10 | 1..65535 sec.

This parameter specify the activation interval (in seconds) for the HD checking process, named "Hd Sentinel".

When the "Hd Sentinel" process is activated the current amount of free space of any disks present in the system and currently used by one of the ARC port sessions is evaluated. If the amount of free space of a disk in use by ARC port sessions reaches the minimum free space value, defined by the MIN-FREE-SPACE: parameter, then a "purging procedure" is activated on this disk. In order to free at least the amount of space defined by the MIN-FINAL-SPACE: parameter, the process will delete oldest files from the archiving session destination path directory ( DSTPATH: parameter).

MIN-FREE-SPACE: | Minimum free space on disk
2 | 1..65535 MB

This parameter sets the minimum amount of space (in Mega bytes) that must be left free on the archive disk. When activated, he "Hd Sentinel" process of the ARC driver will use this threshold in order to check whether a "purging procedure" has to be activated or not to increase the amount of free space on the disk.

This parameter must be minor or equal to MIN-FINAL-SPACE: parameter value.

MIN-FINAL-SPACE: | Minimum space that must result free on disk
4 | 1..65535 MB

This parameter sets the minimum amount of space (in Mega bytes) that must result free on disk after the "purging procedure" executed by the "Hd Sentinel" process.

This parameter must be greater or equal to MIN-FREE-SPACE: parameter value.

PACK-INT: | Packing interval
60 | 1..65535 min.

This parameter sets the ZIP-packing execution interval (in seconds). The "ZIP-packing" process of the ARC driver will be periodically activated in order to compress the files archived since it was activated the last time in to one or more ZIP packed file.

Detail of the ARC port session parameters

SES: | Session identifier
0 | [0..(MAX-SES: - 1)]

This parameter is the ARC port session identifier. Its range is limited by the value configured in the MAX-SES: parameter.

The session identifier can be used for session specific parameters setting.

USE: | Enable/disable archiving session
NO | NO, YES

This parameter enable/disable the activation of the present session. When it is set to "NO", the ARC driver doesn't perform any action for this session. When it is set to "YES", archiving, purging and packing procedure are executed on this section on the base of related session specific parameters setting.

Archiving sessions can be activated run-time, without restarting the system, by the execution of the initialization command INIT PO:xxx, where "xxx" is the ARC port number.

DESCR: | Session description
empty | From 0 up to 80 ASCII characters [32..126]

This parameter allow to assign to a session a brief description. Accepted description values must be string of up to 80 ASCII characters in the range [32..126]. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g. "My archiving session n. 1"). The case of the entered description is preserved.

SRCPATH: | Source archive location
empty | From 0 up to 128 ASCII extended characters [32..255]

This parameter select the location of the archiving source directory.

It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Strings of up to 128 ASCII extended characters in the range [32..255] are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\"). The case of the entered path is preserved.

DSTPATH: | Destination archive location
empty | From 0 up to 128 ASCII extended characters [32..255]

This parameter select the location of the archiving destination directory.

It must be a physical full path in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Strings of up to 128 ASCII extended characters in the range [32..255] are accepted. Spaces are allowed and strings holding spaces must be written between quotation marks (E.g.: "C:\My dir\"). The case of the entered path is preserved.

ARC-INT: | Archiving interval
60 | 1..65535 sec.

It is the interval (in seconds) at which the "archiving" process is activated on this session.

PURGE-INT: | Archive purging interval
1 | 1..365 day

This parameter sets the interval (in days) at which the "archive purging" procedure is activated on this session.

PURGE-TIME: | Time of the day at which archive purging starts
00:00:00 | hh:mm:ss

This parameter sets the time of the day at which "archive purging" procedure must be executed on this session. By default the "archive purging" procedure is activated at midnight.

  • 'hh' is the hour of the day, in the range [0..23];
  • 'mm' is the minute of the hour, in the range [0..59];
  • 'ss' is the second of the minute, in the range [0..59];

Hour, minutes and seconds values must be separated by ':' character without spaces.

PURGE-AGE: | Minimum age of the files to be purged
15 | 1..365 day

This parameter sets minimum age of the files that can be deleted by the "archive purging" procedure (in day).

PACK-SIZE: | Size of the ZIP packed archive
10240 | 100..102400 KB

This parameter select the maximum size (in Kilo bytes) of the ZIP packed file to be created for this session when the "ZIP-packing" process of the ARC driver is activated.

Statistics of the Archive Port (ARC) top

Example on how to show state and statistics of the ARC port through the command D S:

[11:10:58] ABILIS_CPX: D S PO:ARC

PO:980 ------------------------------------------------------------------------
ARC    STATE:INACTIVE   CUR-MAX-SES:3     HISTORY:ON
       - Hd Sentinel ----------------------------------------------------------
       STATE:DELAYING  (Next activation at 2004/03/30 12:25:52)
       - ZIP Packing ----------------------------------------------------------
       STATE:DELAYING  (Next activation at 2004/03/30 13:25:42)
       ------------------------------------------------------------------------
       Ses State    Arc       NextActivation      Purge     NextActivation
       ------------------------------------------------------------------------
       0   ACTIVE   DELAYING  2004/03/30 12:26:42 DELAYING  2004/03/31 00:00:00
       1   INACTIVE SUSPENDED                     SUSPENDED
       2   ACTIVE   DELAYING  2004/03/30 12:26:42 DELAYING  2004/03/31 00:00:00
       ------------------------------------------------------------------------

Example on how to show extended statistics of the ARC port through the command D SE:

[11:11:13] ABILIS_CPX: D SE PO:ARC

PO:980 ------------------------------------------------------------------------
ARC    --- Cleared 000:00:01:44 ago, on 30/03/2004 at 12:25:03 ----------------
       - Hd Sentinel ----------------------------------------------------------
       -- Disk --|---PURGE---|--MIN SPACE (Kbytes)--|--CUR SPACE (Kbytes)--|
       C:        |          0|                  5632|                  5632|
       D:        |          0|               2494912|               2494912|
       - ZIP Packing ----------------------------------------------------------
       |----DONE---|----ZIP----|----NEW----|----UPD----|-FAILURES-|-MAX TIME--|
       |          0|          1|          1|          0|         0|          0|
       - Archiving sessions ---------------------------------------------------
       - Ses 0  -|----DONE----|---TIME----|---FILES---|-MAX TIME--|-MAX FILES-|
       Archive   |          43|          4|        389|          2|        183|
       Purge     |           0|          0|          0|          0|          0|
       Purge-Hd-S|           0|          0|          0|          0|          0|
       ZIP-Pack  |           1|         11|        183|         11|        183|
       - Ses 1  -|----DONE----|---TIME----|---FILES---|-MAX TIME--|-MAX FILES-|
       Archive   |           0|          0|          0|          0|          0|
       Purge     |           0|          0|          0|          0|          0|
       Purge-Hd-S|           0|          0|          0|          0|          0|
       ZIP-Pack  |           0|          0|          0|          0|          0|
       - Ses 2  -|----DONE----|---TIME----|---FILES---|-MAX TIME--|-MAX FILES-|
       Archive   |          60|         71|        886|         36|        108|
       Purge     |           0|          0|          0|          0|          0|
       Purge-Hd-S|           0|          0|          0|          0|          0|
       ZIP-Pack  |           2|         55|        598|         30|        299|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows the elapsed time from the last reset of the statistics (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day/month/year" and "hours:minutes:seconds").

Extended statistics related to monitored HDs can be cleared only using a specific command, i.e. C S PO:xxx HD:yyy, where "xxx" is the ARC port number and "yyy" is a drive letter in the range [C..Z] that identifies the disk.

Details of the state fields and statistics of the ARC port

STATE: | Current state of the ARC port
 | INIT, INACTIVE, ACTIVE, ERR

It shows the current state of the ARC port driver.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
ARC | INIT | The ARC port driver is in the initialization phase. | in | INIT | in
 | INACTIVE | The ACT: parameter is set to "NO". | dn | INACTIVE | dn
 | ACTIVE | The ACT: parameter is set to "YES". | RD | ACTIVE | RD
 | ERR | Software error. Contact Abilis CPX assistance. | NA | ERR | NA

The ARC port state changes are reported in the System Log and in the Events Log only when the "DS" options are set in the LOG: parameter.

CUR-MAX-SES: | Current number of sessions
 | 1 - 32

It is the current number of ARC sessions.

HISTORY: | Current number of sessions
 | OFF, ON

It is the current state of the historical logging functionality.
If it is equal to "OFF", the registration of interesting events into the history log file is disabled.
If it is equal to "ON", registration of interesting events into the history log file is enabled.

Hd Sentinel - STATE: | Current number of sessions
 | see below

It is the current state of the ARC "Hd Sentinel" process.

States | Description
SUSPENDED | The ACT: parameter is set to "NO". The ARC "Hd Sentinel" process is suspended.
DELAYING | The ACT: parameter is set to "YES". The ARC "Hd Sentinel" process is waiting for the expiration of the time-out set in INTERVAL: parameter.
CHECKING | The ACT: parameter is set to "YES". The ARC "Hd Sentinel" process is ready and it is checking whether the minimum free size threshold is reached or not on one of the HDs in use by the ARC sessions.
PURGING | The ACT: parameter is set to "YES". The ARC "Hd Sentinel" process is ready and it is executing the purging procedure on one of the HDs in use by the ARC sessions.
ERR | Software error. Contact Abilis CPX assistance.

ZIP Packing - STATE: | Current number of sessions
 | see below

It is the current number of the ARC "ZIP Packing" process.

States | Description
SUSPENDED | The ACT: parameter is set to "NO". The ARC "ZIP Packing" process is suspended.
DELAYING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is waiting for the expiration of the time-out set in PACK-INT: parameter.
READY | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is ready.
G-WAITING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is ready to perform its actions, but it is waiting on a general semaphore that guarantees that packing procedure is activated only one session in the same time.
WAITING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is ready to the performing its actions, but it is waiting in a session's destination path protection semaphore.
CHECKING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is checking whether there are any files to be packed for a certain session.
PACKING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is packing files for a certain session.
PACK-DELAYING | The ACT: parameter is set to "YES". The ARC "ZIP Packing" process is delaying between one packing try and the next. Between one session and the next the "ZIP Packing" process waits 1 min.
ERR | Software error. Contact Abilis CPX assistance.

Details of the state fields and statistics of the ARC port session

Ses | Session identifier
 | 0 - 31

It is the session identifier.

State | Current ARC session state
 | see below

It is the current state of the ARC session.

Driver | States | Description | Values shown in:
 |  |  | System Log | Events Log | Display LCD
ARC (session) | INIT | The session is in the initialization state. | in | INIT | in
 | INACTIVE | The ACT: and/or the USE: parameters are set to "NO". | dn | INACTIVE | dn
 | ACTIVE | The ACT: and the USE: parameters are set to "YES". | RD | ACTIVE | RD
 | ERR | Software error. Contact Abilis CPX assistance. | NA | ERR | NA

The ARC port session's state changes are reported in the System Log and in the Events Log only when the "DS+E" options are set in the LOG: parameter, i.e. it is required an extension of the basic logging functionality.

Arc | Current state of the session archiving process
 | see below

It is the current state of the session "archiving" process.

States | Description
SUSPENDED | The USE: parameter is set to "NO". The session "archiving" process is suspended.
DELAYING | The USE: parameter is set to "YES". The session "archiving" process is waiting for the ARC-INT: time-out expiration.
WAITING | The USE: parameter is set to "YES". The session "archiving" process is ready to the performing its actions, but it is waiting on destination path protection semaphore.
ARCHIVING | The USE: parameter is set to "YES". The session "archiving" process is ready and the archiving oprations are in progress.
G-WAITING | The USE: parameter is set to "YES". The session "archiving" process is ready to the performing its actions, but it is waiting on a global semaphore that guaratees that only one session "archiving" process is executed in the same time.
ERR | Software error. Contact Abilis CPX assistance.

Arc - NextActivation | Date and time of the archiving process next activation
 | YYYY/MM/DD hh:mm:ss

This parameter informs about the date and time of the next activation of the "archiving" process on this session.

The information is displayed only when the "archiving" process is in the DELAYING state.

Purge | Current state of the archive purging process
 | see below

It is the current state of the session "archive purging" process.

States | Description
SUSPENDED | The USE: parameter is set to "NO". The session "archive purging" process is suspended.
DELAYING | The USE: parameter is set to "YES". The session "archive purging" process is waiting for the PURGE-INT: time-out expiration.
WAITING | The USE: parameter is set to "YES". The session "archive purging" process is ready to the performing its actions, but it is waiting on destination path protection semaphore.
PURGING | The USE: parameter is set to "YES". The session "archive purging" process is ready and the archive purging operations are in progress.
G-WAITING | The USE: parameter is set to "YES". The session "archive purging" process is ready to the performing its actions, but it is on a general semaphore that guarateens that only one session "archive purging" process is executed in the same time.
ERR | Software error. Contact Abilis CPX assistance.

Purge - NextActivation | Date and time of the "archive purging" process next activation
 | YYYY/MM/DD hh:mm:ss

This parameter informs about the date and time of the next activation of the "archive purging" process on this session.

The information is displayed only when the "archive purging" process is in the DELAYING state.

Details of extended statistics of the ARC port

Disk | Monitored disk drive letter
 | C..Z

This is the letter corresponding to the monitored disk drive.
While information related to the disk capacity are reported for all HDs of the system, the "purging" procedure is activated by the "HD Sentinel" process only onm those disks that are used by an ARC port session.

PURGE | Number of time that the purging procedure was executed on the disk
 | 0 - 4.294.967.295

This is the number of time that the "purging" procedure was activated by the "HD Sentinel" on the disk.

MIN SPACE (Kbytes) | Minimum free space on the disk
 | 0 - 4.294.967.295

It shows the minimum free space found (in Kilo bytes) on the disk.

CUR SPACE (Kbytes) | Current free space on the disk
 | 0 - 4.294.967.295

It shows the amount of space (in Kilo bytes) that is currently available on the disk.

DONE | Number of times that the ZIP Packing process was activated
 | 0 - 4.294.967.295

This counter shows the number of times that the ZIP Packing process was activated.

ZIP | Number of times that the ZIP Packing procedure was executed
 | 0 - 4.294.967.295

This counter shows the number of times that the ZIP Packing procedure was executed.

NEW | Number of created new ZIP files
 | 0 - 4.294.967.295

This counter shows the number of times that the "ZIP Packing" procedure created a new ZIP file.

UPD | Number of updated ZIP files
 | 0 - 4.294.967.295

This counter shows the number of times that the "ZIP Packing" procedure updated an existing ZIP file.

FAILURES | Number of failures creating a new ZIP file or updating an existing ZIP file
 | 0 - 4.294.967.295

This counter shows the number of times that the "ZIP Packing" procedure fail creating a new ZIP file or updating an existing ZIP file.

MAX TIME | Maximum time elapsed executing the "ZIP Packing" procedure
 | 0 - 4.294.967.295 sec.

Maximum time (in seconds) elapsed for the execution of the "ZIP Packing" procedure.

Details of extended statistics of the ARC port session

Ses | Session identifier
 | 0 - 31

It is the session identifier.

DONE | Number of time that the specified action was executed on this session
 | 0 - 4.294.967.295

The "Archive" counter is incremented each time the "archiving" procedure is executed on this session.

The "Purge" counter is incremented each time the "archive purging" procedure is executed on this session.

The "Purge-Hd-S" counter is incremented each time the "HD Sentinel" executes a supplementary "purging" procedure is executed on this session.

The "ZIP-Pack" counter is incremented each time the "ZIP Packing" procedure is executed on this session.

TIME | Total time elapsed for the specified action
 | 0 - 4.294.967.295 sec.

The "Archive" counter is incremented each time the "archiving" procedure is executed on this session.

The "Purge" counter is incremented each time the "archive purging" procedure is executed on this session.

The "Purge-Hd-S" counter is incremented each time the "HD Sentinel" executes a supplementary "purging" procedure is executed on this session.

The "ZIP-Pack" counter is incremented each time the "ZIP Packing" procedure is executed on this session.

FILES | Total number of files deleted/created by the specified action
 | 0 - 4.294.967.295

The "Archive" counter is incremented each time the "archiving" procedure is executed on this session.

The "Purge" counter is incremented each time the "archive purging" procedure is executed on this session.

The "Purge-Hd-S" counter is incremented each time the "HD Sentinel" executes a supplementary "purging" procedure is executed on this session.

The "ZIP-Pack" counter is incremented each time the "ZIP Packing" procedure is executed on this session.

MAX TIME | Maximum time elapsed for a single execution of the specified action
 | 0 - 4.294.967.295 sec.

The "Archive" counter is incremented each time the "archiving" procedure is executed on this session; it shows the maximum time (in seconds) elapsed for a single "archiving" procedure execution.

The "Purge" counter is incremented each time the "archive purging" procedure is executed on this session; it shows the maximum time (in seconds) elapsed for a single "archive purging" procedure execution.

The "Purge-Hd-S" counter is incremented each time the "HD Sentinel" executes a supplementary "purging" procedure is executed on this session; it shows the maximum time (in seconds) elapsed by the "HD Sentinel" in a single "purging" procedure execution.

The "ZIP-Pack" counter is incremented each time the "ZIP Packing" procedure is executed on this session; it shows the maximum time (in seconds) elapsed for a single "packing" procedure execution.

MAX FILES | Maximum number of files deleted/created by a single execution of the specified action
 | 0 - 4.294.967.295

The "Archive" counter is incremented each time the "archiving" procedure is executed on this session; it shows the maximum number of files deleted by a single "archiving" procedure execution.

The "Purge" counter is incremented each time the "archive purging" procedure is executed on this session; it shows the maximum number of files deleted by a single "archive purging" procedure execution.

The "Purge-Hd-S" counter is incremented each time the "HD Sentinel" executes a supplementary "purging" procedure is executed on this session; it shows the maximum number of files deleted by the "HD Sentinel" in a single "purging" procedure execution.

The "ZIP-Pack" counter is incremented each time the "ZIP Packing" procedure is executed on this session; it shows the maximum number of files packed by a single "packing" procedure execution.


NavBar Cpx Man 4.7.x English

Home page of the site


Cables

Connection cables

V.24 for HSCB/ESB
V.35 for HSCB/ESB
X21 for HSCB/ESB
MAN/V11 per HSCB
Asynchronous DB25
Asynchronous DB9
Cable to connect ISDN S0 "data only" adapter to Telco T0 NT
Cable to connect ISDN S0 EBIB to Telco T0 NT
Cable to connect ISDN T0 EBIB to PABX S0 TE
Cable to connect ISDN S2m EPIB to Telco NT termination.
Cable to connect ISDN T2m EPIB to PABX TE S2m.
Analogue voice FXS ed FXO
Ethernet 10BaseT e 100BaseTX
RJ-45 and RJ-11 pinout

Table 1. V.24 cables for HSCB/ESB.
V24 DTE (00124) |  |  |  |  | V24 DCE(00224)
Cable end plugged into CPX socket DB15 male |  |  | DB25 male |  | Cable end plugged into CPX socket DB15 male |  |  | DB25 female
1 | (shield) | -------- | 1 | (shield) | 1 | (shield) | -------- | 1 | (shield)
2 | TXD | -->---- | 2 | TXD | 2 | TXD | -->---- | 3 | RXD
3 | RXD | ----<-- | 3 | RXD | 3 | RXD | ----<-- | 2 | TXD
4 | RTS | -->---- | 4 | RTS | 4 | RTS | -->---- | 5 | CTS
5 | CTS | ----<-- | 5 | CTS | 5 | CTS | ----<-- | 4 | RTS
6 | DSR | ----<-- | 6 | DSR | 6 + 8 | DSR DCD | ---<--- | 20 | DTR
7 | SG | -------- | 7 | SG
8 | DCD | ----<-- | 8 | DCD | 7 | SG | -------- | 7 | SG
9 | TXC | ----<-- | 15 | TXC | 11 | DTE Clk | -->---- | 15 + 17 | TXC RXC
10 | RXC | ----<-- | 17 | RXC
12 | DTR | -->---- | 20 | DTR | 12 | DTR | -->---- | 6 + 8 | DSR DCD
13 | RI | ----<-- | 22 | RI
11 | DTE Clk | ----<-- | 24 | DTE Clk |

Table 2. V.35 cables for HSCB/ESB.
V35 DTE(00135) |  |  |  |  | V35 DCE(00235)
Cable end plugged into CPX socket DB15 male |  |  | M male |  | Cable end plugged into CPX socket DB15 male |  |  | M female
1 | (shield/SG) | -------- | A + B | (shield/SG) | 1 | (shield/SG) | -------- | A + B | (shield/SG)
2 | TXD + | -->---- | P | TXD + | 2 | TXD + | -->---- | R | RXD +
3 | RXD + | ----<-- | R | RXD + | 3 | RXD + | ----<-- | P | TXD +
4 | TXC + | ----<-- | Y | TXC + | 6 | DTE Clk + | -->---- | Y + V | TXC + RXC +
5 | RXC + | ----<-- | V | RXC +
6 | DTE Clk + | -->---- | U | DTE Clk + | 7 | DTR | -->---- | E + F | DSR DCD
7 | DTR | -->---- | H | DTR
8 | CTS | ----<-- | D | CTS | 8 | CTS | ----<-- | C | RTS
9 | TXD - | -->---- | S | TXD - | 9 | TXD - | -->---- | T | RXD -
10 | RXD - | ----<-- | T | RXD - | 10 | RXD - | ----<-- | S | TXD -
11 | TXC - | ----<-- | AA | TXC - | 13 | DTE Clk - | -->---- | AA + X | TXC + RXC +
12 | RXC - | ----<-- | X | RXC -
13 | DTE Clk - | -->---- | W | DTE Clk - | 14 | RTS | -->---- | D | CTS
14 | RTS | -->---- | C | RTS | 15 | DCD | ----<-- | H | DTR
15 | DCD | ----<-- | E | DCD |

Table 3. X21 adaptor cables for HSCB/ESB.
X21 DTE(00121) |  |  |  |  | X21 DCE(00221)
Cable end plugged into CPX socket DB15 male |  |  | DB15 male |  | Cable end plugged into CPX socket DB15 male |  |  | DB15 female
1 | (shield/SG) | -------- | 1 | (shield/SG) | 1 | (shield/SG) | -------- | 1 | (shield/SG)
2 | TXD + | -->---- | 2 | TXD + | 2 | TXD + | -->---- | 4 | RXD +
3 | C + | -->---- | 3 | C + | 3 | C + | -->---- | 5 | I +
4 | RXD + | ----<-- | 4 | RXD + | 4 | RXD + | ----<-- | 2 | TXD +
5 | I + | ----<-- | 5 | I + | 5 | I + | ----<-- | 3 | C +
6 | ST + | ----<-- | 6 | ST + | 6 + 7 | ST + DTE Clk + | -->---- | 6 | ST +
9 | TXD - | -->---- | 9 | TXD +
10 | C - | -->---- | 10 | C - | 9 | TXD - | -->---- | 11 | RXD -
11 | RXD - | ----<-- | 11 | RXD - | 10 | C - | -->---- | 12 | I -
12 | I - | ----<-- | 12 | I - | 11 | RXD - | ----<-- | 9 | TXD -
13 | ST - | ----<-- | 13 | ST - | 12 | I - | ----<-- | 10 | C -
 |  |  |  |  | 13+14 | ST - DTE Clk - | -->---- | 13 | ST -

Table 4. MAN/V11 adaptor cables for HSCB.
MAN V11(---)
Cable end plugged into CPX socket DB15 male |  |  | Free wires
1 | (shield/SG) | -------- |
2 | TXD + | -->---- |
4 | RXD + | ----<-- |
9 | TXD - | -->---- |
11 | RXD - | ----<-- |

Table 5. Asynchronous connection cables (DB25).
Asynchronous RS232/V24 CPX-Null-Modem 25-25 |  |  |  |  | Asynchronous RS232/V24 CPX-Modem 25-25
Cable end plugged into CPX socket DB25 female |  |  | DB25 female |  | Cable end plugged into CPX socket DB25 female |  |  | DB25 male
Shield | 1 sh | ---- | 1 sh | Shield | Shield | 1 sh | ---- | 1 sh | Shield
TxD | 2 | ->-- | 3 | RxD | TxD | 2 | ->-- | 2 | TxD
RxD | 3 | --<- | 2 | TxD | RxD | 3 | --<- | 3 | RxD
RTS | 4 | ->-- | 5 | CTS | RTS | 4 | ->-- | 4 | RTS
CTS | 5 | --<- | 4 | RTS | CTS | 5 | --<- | 5 | CTS
SG | 7 | ---- | 7 | SG | DSR | 6 | --<- | 6 | DSR
DCD | 8 | --<- | 20 | DTR | SG | 7 | ---- | 7 | SG
DTR | 20 | ->-- | 8 | DCD | DCD | 8 | --<- | 8 | DCD
 |  |  |  |  | DTR | 20 | ->-- | 20 | DTR

Table 6. Asynchronous connection cables (DB9).
Asynchronous RS232/V24 Null-Modem 9-25 |  |  |  |  | Asynchronous RS232/V24 Null-Modem 9-9
Cable end plugged into CPX socket DB9 female |  |  | DB25 female |  | Cable end plugged into CPX socket DB9 female |  |  | DB9 female
DCD | 1 | ---<-- | 20 | DTR | DCD | 1 | ---<-- | 4 | DTR
RxD | 2 | ---<-- | 2 | TxD | RxD | 2 | ---<-- | 3 | TxD
TxD | 3 | -->--- | 3 | RxD | TxD | 3 | -->--- | 2 | RxD
DTR | 4 | -->--- | 8 | DCD | DTR | 4 | -->--- | 1 | DCD
SG | 5 | ------- | 7 | SG | SG | 5 | ------- | 5 | SG
RTS | 7 | -->--- | 5 | CTS | RTS | 7 | -->--- | 8 | CTS
CTS | 8 | ---<-- | 4 | RTS | CTS | 8 | ---<-- | 7 | RTS

Table 7. Connection cable between ISDN S0 "data only" adaptors, and Telecom T0 NT.
S0 TE "data only" - T0 NT
Cable end plugged into CPX (TE) socket RJ45 male |  |  | Cable end plugged into NT socket RJ45 male
 | 1 |  | 1 | Psink3 +
 | 2 |  | 2 | Psink3 -
TXD + | 3 | -->---- | 3 | RXD +
RXD + | 4 | ----<-- | 4 | TXD +
RXD - | 5 | ----<-- | 5 | TXD -
TXD - | 6 | -->---- | 6 | RXD -
 | 7 |  | 7 | Psource2 -
 | 8 |  | 8 | Psource2 +

Table 8. Connection cable between ISDN S0 EBIB adaptors and Telecom T0 NT (crossed).
S0 EBIB - T0 NT
Cable end plugged into CPX (EBIB) socket RJ45 male |  |  | Cable end plugged into NT RJ45 male
 | 1 |  | 1 | Psink3 +
 | 2 |  | 2 | Psink3 -
RXD + | 3 | ----<-- | 4 | TXD +
TXD + | 4 | -->---- | 3 | RXD +
TXD - | 5 | -->---- | 6 | RXD -
RXD - | 6 | ----<-- | 5 | TXD -
 | 7 |  | 7 | Psource2 -
 | 8 |  | 8 | Psource2 +

Table 9. Connection cable between ISDN T0 EBIB adaptors and PABX S0 TE.
T0 EBIB - S0 TE (PABX)
Cable end plugged into CPX (EBIB) socket RJ45 male |  |  | Cable end plugged into TE RJ45 female
 | 1 |  | 1 |
 | 2 |  | 2 |
RXD+ | 3 | ----<-- | 3 | TXD+
TXD+ | 4 | -->---- | 4 | RXD+
TXD- | 5 | -->---- | 5 | RXD-
RXD- | 6 | ----<-- | 6 | TXD-
 | 7 |  | 7 |
 | 8 |  | 8 |

Table 10. Connection cable between ISDN S2m EPIB adaptors and Telecom terminal.
S2m EPIB - T2m TelecomTerminal
Cable end plugged into CPX (EBIB) socket RJ45 male |  |  | Free wires
 | 1 |  |
 | 2 |  |
RXD+ | 3 | ----<-- |
TXD+ | 4 | -->---- |
TXD- | 5 | -->---- |
RXD- | 6 | ----<-- |
 | 7 |  |
 | 8 |  |

Table 11. Connection cable between ISDN T2m EPIB adaptors and PABX TE S2m.
T2m EPIB - S2m TE (PABX)
Cable end plugged into CPX (EBIB) socket RJ45 male |  |  | Free wires
 | 1 |  |
 | 2 |  |
RXD+ | 3 | ----<-- |
TXD+ | 4 | -->---- |
TXD- | 5 | -->---- |
RXD- | 6 | ----<-- |
 | 7 |  |
 | 8 |  |

Table 12. FXS ed FXO connection cables.
FXS - Telephone |  |  |  |  | FXO - PABX
Cable end plugged into CPX socket RJ45 male |  |  | Cable end plugged into telephone RJ11 male |  | Cable end plugged into CPX socket RJ45 male |  |  | Cable end plugged into PABX socket RJ11 male
 | 1 |  |  |  |  | 1 |  |  |
 | 2 |  | 1 |  |  | 2 |  | 1 |
 | 3 |  | 2 |  |  | 3 |  | 2 |
Tip | 4 | -------- | 3 | Tip | Tip | 4 | -------- | 3 | Tip
Ring | 5 | -------- | 4 | Ring | Ring | 5 | -------- | 4 | Ring
 | 6 |  | 5 |  |  | 6 |  | 5 |
 | 7 |  | 6 |  |  | 7 |  | 6 |
 | 8 |  |  |  |  | 8 |  |  |

Table 13. Connection cable for ethernet 10BaseT and 100BaseTX.
TP CPX - TP HUB
Cable end plugged into CPX socket RJ45 male |  |  | Cable end plugged into HUB socket RJ45 male
TXD + | 1 | -->---- | 1 | RXD +
TXD - | 2 | -->---- | 2 | RXD -
RXD + | 3 | ----<-- | 3 | TXD +
 | 4 |  | 4 |
 | 5 |  | 5 |
RXD - | 6 | ----<-- | 6 | TXD -
 | 7 |  | 7 |
 | 8 |  | 8 |

Figure 1. Female connectors RJ-45 ed RJ-11.
Rj45-Rj11 connectors


ISDN disconnection codes

ITU codes
Abilis CPX private codes

ISDN disconnection codes recommended by ITU (formerly CCITT) top

The messages I-ClrRx and I-ClrTx found in the event log show a "cause" field which corresponds to what has been specified by the ITU in Recommendations Q.931 e Q.850.

The complete format, which includes some optional values, is described in Table 1. Full format for ITU "cause" element. The most frequent format is reported in Table 2. Most frequent format for the ITU "cause" element.

For a complete description of all the options, refer to recommendation ITU Q.850.

NOTE

Recommendation Q.931 enumerates the bytes starting from the 3rd, because the entire information element relating to "cause" contains two other bytes at the beginning, which specify the element itself, "cause", and the total length.

Since these values do not influence the content of the "cause" field and vice versa, they are not registered and are not taken into consideration for the interpretation which follows.

Table 1. Full format for ITU "cause" element.
Bit # |  |  |  |  |  |  |  | Byte #, (NOTE 3)
8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | Q.931 | Q.763
0/1 ext. | Coding standard |  | 0 Spare | Location |  |  |  | 3 | 1
1 ext. | Recommendation (NOTE 1) (NOTE 2) |  |  |  |  |  |  | 3a* |
1 ext. | Cause value |  |  |  |  |  |  | 4 | 2
Diagnostic(s) (if any) |  |  |  |  |  |  |  | 5* | 3*

NOTES

  1. If the default applies for the Recommendation field, the byte including this field shall be omitted. The Recommendation field is not supported by the ISUP. The default interpretation for ISUP is Q.763. Optional bytes are marked with asterisks (*).

  2. In EURO-Isdn networks, and in particular in basic rate accesses (BRI), byte 3a (Recommendation), is absent, while the diagnostic field is only present for certain disconnectioins.

  3. To simplify, the format for the ISDN disconnection "cause" element most frequently encountered, is the one shown in the table following.

Table 2. Most frequent format for the ITU "cause" element.
Bit # |  |  |  |  |  |  |  | Byte #
8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | Q.931
1 | Coding standard |  | 0 Spare | Location |  |  |  | 3
1 | Cause value |  |  |  |  |  |  | 4
Diagnostic(s) (if any) |  |  |  |  |  |  |  | 5*

Table 3. ITU "coding standard" field.
Bits | 7 | 6 |
 | 0 | 0 | CCITT standardized coding, as described below
 | 0 | 1 | ISO/IEC standard (see NOTE)
 | 1 | 0 | National standard (see NOTE)
 | 1 | 1 | Standard specific to identified location (see NOTE)

NOTE - These other coding standards should be used only when the desired cause value cannot be represented with the CCITT-standardized coding.

Table 4. ITU "location" field.
Bits | 4 | 3 | 2 | 1 | Location | Brief description
 | 0 | 0 | 0 | 0 | user (U) | Originated by user equipment, i.e phone.
 | 0 | 0 | 0 | 1 | private network serving the local user (LPN) | Generated by a private networking device, e.g. a PABX, on the side which is directly connected to the receiving device.
 | 0 | 0 | 1 | 0 | public network serving the local user (LN) | Generated by the public network, e.g. a Telco, on the side which is directly connected to the receiving device.
 | 0 | 0 | 1 | 1 | transit network (TN) | Generated somewhere in an intermediate network on which the call is transiting.
 | 0 | 1 | 0 | 0 | public network serving the remote user (RLN) | Generated by the public network, e.g. a Telco, on the remote side respect to the receiving device.
 | 0 | 1 | 0 | 1 | private network serving the remote user (RPN) | Generated by a private networking device, e.g. a PABX, on the remote side respect to the receiving device.
 | 0 | 1 | 1 | 1 | international network (INTL) | Generated somewhere in the international network.
 | 1 | 0 | 1 | 0 | network beyond interworking point (BI) | Generated by a non-ISDN network interconnected to the ISDN network.
 |  |  |  |  | All other values are reserved. |

NOTE - The actual meaning of locations is deeply explained in ITU recommendations, however the table above introduces a brief description.

The "cause" values are subdivided in two parts: class and value.

The names of the classes are listed following, however, each "cause" is uniquely identifiable even without looking up the classes.

Table 5. Classes of cause values, bits 7-5-4 of the ITU-T "cause value" field.
Bits | 7 | 6 | 5 | Location
 | 0 | 0 | 0 | normal event
 | 0 | 0 | 1 | normal event
 | 0 | 1 | 0 | resource unavailable
 | 0 | 1 | 1 | service or option not available
 | 1 | 0 | 0 | service or option not implemented
 | 1 | 0 | 1 | invalid message (e.g. parameter out of range)
 | 1 | 1 | 0 | protocol error (e.g. unknown message
 | 1 | 1 | 1 | Interworking

Table 6. ITU-T "cause value" field.
Cause value |  |  |  | ITU definition as per Q.850 recommendation.
Class | Value | No.(dec) | No.(*) (hex) |
000 | 0001 | 1 | 01 (81) | Unallocated (unassigned) number. This cause indicates that the called party cannot be reached because, although the called party number is in a valid format, it is not currently allocated (assigned).
000 | 0010 | 2 | 02 (82) | No route to specified transit network (national use). This cause indicates that the equipment sending this cause has received a request to route the call through a particular transit network which it does not recognize. The equipment sending this cause does not recognize the transit network either because the transit network does not exist or because that particular transit network, while it does exist, does not serve the equipment which is sending this cause. This cause is supported on a network-dependent basis.
000 | 0011 | 3 | 03 (83) | No route to destination. This cause indicates that the called party cannot be reached because the network through which the call has been routed does not serve the destination desired. This cause is supported on a network-dependent basis.
000 | 0100 | 4 | 04 (84) | Send special information tone. This cause indicates that the called party cannot be reached for reasons that are of a long term nature and that the special information tone should be returned to the calling party.
000 | 0101 | 5 | 05 (85) | Misdialled trunk prefix (national use). This cause indicates the erroneous inclusion of a trunk prefix in the number of the called party.
000 | 0110 | 6 | 06 (86) | Channel unacceptable. This cause indicates that the channel most recently identified is not acceptable to the sending entity for use in this call.
000 | 0111 | 7 | 07 (87) | Call awarded and being delivered in an established channel. This cause indicates that the user has been awarded the incoming call, and that the incoming call is being connected to a channel already established to that user for similar calls (e.g. packet-mode X.25 virtual calls).
000 | 1000 | 8 | 08 (88) | Preemption. This cause indicates that the call is being preempted.
000 | 1001 | 9 | 09 (89) | Preemption - circuit reserved for reuse. This cause indicates that the call is being preempted and the circuit is reserved for reuse by the preempting exchange.
001 | 0000 | 16 | 10 (90) | Normal call clearing. This cause indicates that the call is being cleared because one of the users involved in the call has requested that the call be cleared. Under normal situations, the source of this cause is not the network.
001 | 0001 | 17 | 11 (91) | User busy. This cause is used to indicate that the called party is unable to accept another call because the user busy condition has been encountered. This cause value may be generated by the called user or by the network. In the case of user determine user busy, it is noted that the user equipment is compatible with the call.
001 | 0010 | 18 | 12 (92) | No user responding. This cause is used when a called party does not respond to a call establishment message with either an alerting or connect indication within the prescribed period of time allocated.
001 | 0011 | 19 | 13 (93) | No answer from user (user alerted). This cause is used when the called party has been alerted but does not respond with a connect indication within a prescribed period of time. NOTE - This cause is not necessarily generated by Q.931 procedures but may be generated by internal network timers.
001 | 0100 | 20 | 14 (94) | Subscriber absent. This cause value is used when a mobile station has logged off, radio contact is not obtained with a mobile station or if a personal telecommunication user is temporarily not addressable at any user-network interface.
001 | 0101 | 21 | 15 (95) | Call rejected. This cause indicates that the equipment sending this cause does not wish to accept this call, although it could have accepted the call because the equipment sending this cause is neither busy nor incompatible. This cause may also be generated by the network, indicating that the call was cleared due to a supplementary service constraint. The diagnostic field may contain additional information about the supplementary service and reason for rejection.
001 | 0110 | 22 | 16 (96) | Number changed. This cause is returned to a calling party when the called party number indicated by the calling party is no longer assigned. The new called party number may optionally be included in the diagnostic field. If a network does not support this cause value, cause No. 1, unallocated (unassigned) number shall be used.
001 | 1010 | 26 | 1A (9A) | Non-selected user clearing. This cause indicates that the user has not been awarded the incoming call.
001 | 1011 | 27 | 1B (9B) | Destination out of order. This cause indicates that the destination indicated by the user cannot be reached because the interface to the destination is not functioning correctly. The term "not functioning correctly" indicates that a signalling message was unable to be delivered to the remote party; e.g. a physical layer or data link layer failure at the remote party, or user equipment off-line.
001 | 1100 | 28 | 1C (9C) | Invalid number format (address incomplete). This cause indicates that the called party cannot be reached because the called party number is not in a valid format or is not complete. NOTE - This condition may be determined immediately after reception of an ST signal or on time-out after the last received digit.
001 | 1101 | 29 | 1D (9D) | Facility rejected. This cause is returned when a supplementary service requested by the user cannot be provided by the network.
001 | 1110 | 30 | 1E (9E) | Response to STATUS ENQUIRY. This cause is included in the STATUS message when the reason for generating the STATUS message was the prior receipt of a STATUS ENQUIRY message.
001 | 1111 | 31 | 1F (9F) | Normal, unspecified. This cause is used to report a normal event only when no other cause in the normal class applies.
010 | 0010 | 34 | 22 (A2) | No circuit/channel available. This cause indicates that there is no appropriate circuit/channel presently available to handle the call.
010 | 0110 | 38 | 26 (A6) | Network out of order. This cause indicates that the network is not functioning correctly and that the condition is likely to last a relatively long period of time; i.e. immediately re-attempting the call is not likely to be successful.
010 | 0111 | 39 | 27 (A7) | Permanent frame mode connection out-of-service. This cause is included in a STATUS message to indicate that a permanently established frame mode connection is out-of-service (e.g. due to equipment or section failure) (see Annex A/Q.933).
010 | 1000 | 40 | 28 (A8) | Permanent frame mode connection operational. This cause is included in a STATUS message to indicate that a permanently established frame mode connection is operational and capable of carrying user information (see Annex A/Q.933).
010 | 1001 | 41 | 29 (A9) | Temporary failure. This cause indicates that the network is not functioning correctly and that the condition is not likely to last a long period of time; i.e. the user may wish to try another call attempt almost immediately.
010 | 1010 | 42 | 2A (AA) | Switching equipment congestion. This cause indicates that the switching equipment generating this cause is experiencing a period of high traffic.
010 | 1011 | 43 | 2B (AB) | Access information discarded. This cause indicates that the network could not deliver access information to the remote user as requested, i.e. user-to-user information, low layer compatibility, high layer compatibility, or sub-address, as indicated in the diagnostic. It is noted that the particular type of access information discarded is optionally included in the diagnostic.
010 | 1100 | 44 | 2C (AC) | Requested circuit/channel not available. This cause is returned when the circuit or channel indicated by the requesting entity cannot be provided by the other side of the interface.
010 | 1110 | 46 | 2E (AE) | Precedence call blocked. This cause indicates that there are no preemptable circuits or that the called user is busy with a call of equal or higher preemptable level.
010 | 1111 | 47 | 2F (AF) | Resource unavailable, unspecified. This cause is used to report a resource unavailable event only when no other cause in the resource unavailable class applies.
011 | 0001 | 49 | 31 (B1) | Quality of Service not available. This cause is used to report that the requested Quality of Service, as defined in Recommendation X.213, cannot be provided (e.g. throughput or transit delay cannot be supported).
011 | 0010 | 50 | 32 (B2) | Requested facility not subscribed. This cause indicates that the user has requested a supplementary service which is implemented by the equipment which generated this cause, but which the user is not authorized to use.
011 | 0101 | 53 | 35 (B5) | Outgoing calls barred within CUG. This cause indicates that although the calling party is a member of the CUG for the outgoing CUG call, outgoing calls are not allowed for this member of the CUG.
011 | 0111 | 55 | 37 (B7) | Incoming calls barred within CUG. This cause indicates that although the called party is a member of the CUG for the incoming CUG call, incoming calls are not allowed to this member of the CUG.
011 | 1001 | 57 | 39 (B9) | Bearer capability not authorized. This cause indicates that the user has requested a bearer capability which is implemented by the equipment which generated this cause but which the user is not authorized to use.
011 | 1010 | 58 | 3A (BA) | Bearer capability not presently available. This cause indicates that the user has requested a bearer capability which is implemented by the equipment which generated this cause but which is not available at this time.
011 | 1110 | 62 | 3E (BE) | Inconsistency in designated outgoing access information and subscriber class. This cause indicates that there is an inconsistency in the designated outgoing access information and subscriber class.
011 | 1111 | 63 | 3F (BF) | Service or option not available, unspecified. This cause is used to report a service or option not available event only when no other cause in the service or option not available class applies.
100 | 0001 | 65 | 41 (C1) | Bearer capability not implemented. This cause indicates that the equipment sending this cause does not support the bearer capability requested.
100 | 0010 | 66 | 42 (C2) | Channel type not implemented. This cause indicates that the equipment sending this cause does not support the channel type requested.
100 | 0101 | 69 | 45 (C5) | Requested facility not implemented. This cause indicates that the equipment sending this cause does not support the requested supplementary service.
100 | 0110 | 70 | 46 (C6) | Only restricted digital information bearer capability is available (national use). This cause indicates that the calling party has requested an unrestricted bearer service but that the equipment sending this cause only supports the restricted version of the requested bearer capability.
100 | 1111 | 79 | 4F (CF) | Service or option not implemented, unspecified. This cause is used to report a service or option not implemented event only when no other cause in the service or option not implemented class applies.
101 | 0001 | 81 | 51 (D1) | Invalid call reference value. This cause indicates that the equipment sending this cause has received a message with a call reference which is not currently in use on the user-network interface.
101 | 0010 | 82 | 52 (D2) | Identified channel does not exist. This cause indicates that the equipment sending this cause has received a request to use a channel not activated on the interface for a call. For example, if a user has subscribed to those channels on a primary rate interface numbered from 1 to 12 and the user equipment or the network attempts to use channels 13 through 23, this cause is generated.
101 | 0011 | 83 | 53 (D3) | A suspended call exists, but this call identity does not. This cause indicates that a call resume has been attempted with a call identity which differs from that in use for any presently suspended call(s).
101 | 0100 | 84 | 54 (D4) | Call identity in use. This cause indicates that the network has received a call suspended request containing a call identity (including the null call identity) which is already in use for a suspended call within the domain of interfaces over which the call might be resumed.
101 | 0101 | 85 | 55 (D5) | No call suspended. This cause indicates that the network has received a call resume request containing a call identity information element which presently does not indicate any suspended call within the domain of interfaces over which calls may be resumed.
101 | 0110 | 86 | 56 (D6) | Call having the requested call identity has been cleared. This cause indicates that the network has received a call resume request containing a call identity information element indicating a suspended call that has in the meantime been cleared while suspended (either by network timeout or by the remote user).
101 | 0111 | 87 | 57 (D7) | User not member of CUG. This cause indicates that the called user for the incoming CUG call is not a member of the specified CUG or that the calling user is an ordinary subscriber calling a CUG subscriber.
101 | 1000 | 88 | 58 (D8) | Incompatible destination. This cause indicates that the equipment sending this cause has received a request to establish a call which has low layer compatibility, high layer compatibility, or other compatibility attributes (e.g. data rate) which cannot be accommodated.
101 | 1010 | 90 | 5A (DA) | Non-existent CUG. This cause indicates that the specified CUG does not exist.
101 | 1011 | 91 | 5B (DB) | Invalid transit network selection (national use). This cause indicates that a transit network identification was received which is of an incorrect format as defined in Annex C/Q.931.
101 | 1111 | 95 | 5F (DF) | Invalid message, unspecified. This cause is used to report an invalid message event only when no other cause in the invalid message class applies.
110 | 0000 | 96 | 60 (E0) | Mandatory information element is missing. This cause indicates that the equipment sending this cause has received a message which is missing an information element which must be present in the message before that message can be processed.
110 | 0001 | 97 | 61 (E1) | Message type non-existent or not implemented. This cause indicates that the equipment sending this cause has received a message with a message type which it does not recognize either because this is a message not defined or is defined but not implemented by the equipment sending this cause.
110 | 0010 | 98 | 62 (E2) | Message not compatible with call state or message type non-existent or not implemented. This cause indicates that the equipment sending this cause has received a message such that the procedures do not indicate that this is a permissible message to receive while in the call state, or a STATUS message was received indicating an incompatible call state.
110 | 0011 | 99 | 63 (E3) | Information element/parameter non-existent or not implemented. This cause indicates that the equipment sending this cause has received a message which includes information element(s)/parameter(s) not recognized because the information element identifier(s)/parameter name(s) are not defined or are defined but not implemented by the equipment sending the cause. This cause indicates that the information element(s)/parameter(s) were discarded. However, the information element is not required to be present in the message in order for the equipment sending the cause to process the message.
110 | 0100 | 100 | 64 (E4) | Invalid information element contents. This cause indicates that the equipment sending this cause has received an information element which it has implemented; however, one or more fields in the information element are coded in such a way which has not been implemented by the equipment sending this cause.
110 | 0101 | 101 | 65 (E5) | Message not compatible with call state. This cause indicates that a message has been received which is incompatible with the call state.
110 | 0110 | 102 | 66 (E6) | Recovery on timer expiry. This cause indicates that a procedure has been initiated by the expiry of a timer in association with error-handling procedures.
110 | 0111 | 103 | 67 (E7) | Parameter non-existent or not implemented - passed on (national use). This cause indicates that the equipment sending this cause has received a message which includes parameters not recognized because the parameters are not defined or are defined but not implemented by the equipment sending the cause. The cause indicates that the parameter(s) were ignored. In addition, if the equipment sending this cause is an intermediate point, then this cause indicates that the parameter(s) were passed on unchanged.
110 | 1110 | 110 | 6E (EE) | Message with unrecognized parameter discarded. This cause indicates that the equipment sending this cause has discarded a received message which includes a parameter that is not recognized.
110 | 1111 | 111 | 6F (EF) | Protocol error, unspecified. This cause is used to report a protocol error event only when no other cause in the protocol error class applies.
111 | 1111 | 127 | 7F (FF) | Interworking, unspecified. This cause indicates that there has been interworking with a network which does not provide causes for actions it takes. Thus, the precise cause for a message which is being sent cannot be ascertained.

(*) The hexadecimal value in brackets is the value which also includes the most significant bit with the value "1", that normally present, with the purpose is to simplify decoding.

For example, the code "I-ClrRx cause:80 92" is defined as: "CCITT coding", "User location", "Normal event", "No user responding".

Abilis CPX private ISDN disconnection codes top

In "I-ClrRx" and "I-ClrTx" messages it is sometimes possibile for codes to be reported which are not codified by ITU, or are codified as "specific for the specified location: user".

These are specific codes used by CPX to indicate particular events.

Codes starting with FF as the first byte, report local problems, i.e. they are not messages sent or received by the network.

Codes starting with 80 as the first byte, are codes specific to CPX, sent or received by the network. It should be noted that these "private" codes might not be transported to their destination by ISDN, exactly as happens with the Italian Telecom network.

Cause | Description
FF A0 | The calling number ("CGO" in the MLM driver) specified in the call cannot be associated with any ISDN line ("NUM" in the Q931 driver).
FF A3 | The "cause" field is absent.
FF A5 | Level 1 of ISDN is inactive.
FF A6 | Level 2 of ISDN in inactive, or failed to activate.
FF B3 | No "B" channels were available.
80 80 | Closure caused by SHM feature of the MLM driver.
80 8A | Closure caused by "INIT" command issued to the MLM driver.
80 8B | Closure caused by an error discovered by the MPX protocol in the MLM driver, usually a failure in link-check frame exchange.
80 8C | Closure caused by the restoration of READY state in the P-LINK& interface of the MLM diriver.


Messages

Messages generated by the VALIDATE command
Messages in the System Log
Messages in the Events Log
Messages on the front panel display

Messages generated by the VALIDATE command top

Table 1. Notifications of errors which are followed by the failure of the configuration validation.
Message | Meaning
ERROR: PO:XXX error getting "par" | The validate procedure failed to get the parameter "par" of the port XXX. This is a sw problem that must be reported to Abilis technical assistance.
ERROR: PO:XXX error setting "par" | The validate procedure failed to the set the parameter "par" parameter of port XXX. This is a sw problem that must be reported to Abilis technical assistance.
ERROR: PO:XXX recursion on the same port | The "LOWPO" parameter of port XXX has the same value as the port itself.
ERROR: PO:XXX reached maximal recursion number | Maximum number of recursions reached (15). The whole ports stack is greater than 15, which possibly means a ports recursion problem.
ERROR: PO:XXX invalid "LOWPO" = YYY type | The port XXX has been set with a LOWPO YYY which type is unacceptable (e.g. LAPB has an X25 as lowpo).
ERROR: PO:XXX "LOWPO" = YYY not present or inactive | The port XXX has been set with a LOWPO YYY which is not configured or not active.
ERROR: PO:XXX "LOWPO" = YYY crossed setting | The port XXX has been set with a LOWPO YYY which is already in use elsewhere.
ERROR: PO:XXX invalid "par" = YYY value | The parameter "par" of the port XXX is set to an invalid value.
ERROR: PO:XXX conflicting setting between "par1" = YYY and "par2" = ZZZ | The parameter "par1" of the port XXX is set to the YYY value that is in conflict with the ZZZ value that is set in the "par2" parameter.
ERROR: PO:XXX "PLINK" = YYY not present or inactive | The port XXX has been set with a PLINK YYY which is not configured or not active.
ERROR: PO:XXX invalid "PLINK" = YYY type | The port XXX has been set with a PLINK YYY which type is unacceptable (e.g. MLM has an X25 as plink).
ERROR: PO:XXX "PLINK" = YYY crossed setting | The port XXX has been set with a PLINK YYY which is already in use elsewhere.
ERROR: PO:XXX PLINK = YYY type conflicts with the upper port = ZZZ type | The port XXX has been set with a PLINK YYY which type conflicts with the type of the upper port, i.e. the port ZZZ. The type of the PLINK YYY and port ZZZ, linked through the port XXX, are incompatible.
ERROR: PO:XXX "SLINK" = YYY not present or inactive | The port XXX has been set with a PLINK YYY which is not configured or not active.
ERROR: PO:XXX invalid "SLINK" = YYY type | The port XXX has been set with an SLINK YYY which type is unacceptable (e.g. MLM has a SYNC as plink).
ERROR: PO:XXX and PO:YYY "BCHAN" = ZZ crossed setting | Ports XXX and YYY have the same value for the BCHAN: parameter, i.e. the BCHAN: required by the port XXX is already in use by the port YYY.
ERROR: PO:XXX and PO:YYY "DLCI" = ZZZZ crossed setting | Ports XXX and YYY have the same value for the DLCI: parameter, i.e. the DLCI: required by the port XXX is already in use by the port YYY.
ERROR: PO:XXX and PO:YYY "LOCPORT" = ZZZ crossed setting | Ports XXX and YYY have the same value for the LOCPORT parameter, i.e. the LOCPORT required by the port XXX is already in use by the port YYY.
ERROR: ML LINK:XX error getting "par" | The validate procedure failed to get the parameter "par" of the LINK XX of the ML port. This is a sw problem that must be reported to Abilis technical assistance.
ERROR: IPP:YYY error getting "par" | The validate procedure failed to get the parameter "par" of the IP port YYY. This is a sw problem that must be reported to Abilis technical assistance.
ERROR: IPP:YYY invalid "LOWPO" = ZZZ type | The IP port YYY has been set with a LOWPO equal to ZZZ, whose type is unacceptable (e.g. an X25). Valid types for the lower port of an IP port are SYNC, LAPB, MLM, ML, PPP, IPLAN.
ERROR: IPP:YYY "LOWPO" = ZZZ not present or inactive | The IP port YYY has been set with a LOWPO equal to ZZZ, which is not configured or not active.
ERROR: IPP:YYY invalid "LOWPO" = ZZZ crossed setting | The IP port YYY has been set with a LOWPO equal to ZZZ, which is already in use elsewhere.
ERROR: PO:XXX "SERVICE" conflicts with use of CH:16 in TDM PR:YY | The type of service set in SERVICE: parameter of the EPISDN port XXX doesn't allow the usage of channel 16 and this is in conflict with the value set in the CH: parameter of the TDM switch whose priority is YY.
ERROR: crossed setting between EIR and VOICE ROUTER on PLXX = YY | The PLINK YYY is simultaneously requested for use by the Fxs/Fxo VOICE Router and the Enhanced ISDN Router, a condition which is not possible.
ERROR: PO:XXX ZZZZ and CARD:YYY conflicting settings | The values of the interrupt or of the address or of the ports configured in the XXX port of type ZZZZ are in conflict with those configured in the card YYY.
ERROR: EBIB card can't be activated with EPIB or BEP cards | The EBIB card cannot be activated at the same time as the EPIB and BEP cards. In fact the installation of EBIB system in the Abilis CPX is alternative to the EPIB/EXP/BEP one.
ERROR: CARD:XXX Error getting configuration | The validate procedure failed to the get configuration parameter(s) for the card XXX (e.g. CARD:HSCB-1).
ERROR: CARD:XXX Error setting configuration | The validate procedure failed to the set configuration parameter(s) for the card XXX (e.g. CARD:HSCB-1).
ERROR: CARD:XXX PO:YYY not present or not active | The card XXX requires that port YYY is active while it is not. At the moment this is required by HSCB cards only, in fact they needs SYNC ports to be active.
ERROR: CARD:XXX and CARD:YYY conflicting settings | Cards XXX and YYY have a conflict on interrupt and/or on the address and they cannot be activated simultaneously.

Table 2. Informative messages which do not cause the configuration validation to fail.
Messagge | Meaning
WARNING: PO:XXX changed "par" from YYY to ZZZ | The value of "par" parameter of the port XXX has been changed from YYY to ZZZ.
WARNING: PO:XXX changed "par1" from YYY to ZZZ because PO:TTT "par2" = WWW | The value of "par1" parameter of the port XXX has been changed from YYY to ZZZ, because the "par2" parameter of the port TTT is set to WWW value.
WARNING: PO:XXX changed "par" from YYY to ZZZ because PO:TTT is RRR | The value of "par" parameter of the port XXX has been changed from YYY to ZZZ, because the port TTT is of RRR type.
WARNING: PO:XXX changed "LOWPO" from YYY to NONE, because PO:XXX not used | The value of "LOWPO:" parameter of port XXX has been changed from YYY to NONE, because port XXX is not referenced by any port of protocol level.
WARNING: PO:XXX changed "PLINK" from YYY to NONE, because PO:XXX not used | The value of "PLINK:" parameter of port XXX has been changed from YYY to NONE, because port XXX is not referenced by any port of protocol level.
WARNING: PO:XXX changed "SLINK" from YYY to NONE, because PO:XXX not used | The value of "SLINK:" parameter of port XXX has been changed from YYY to NONE, because port XXX is not referenced by any port of protocol level.
WARNING: PO:XXX changed "par" from ZZZ to NONE, because PO:YYY invalid type | The value of "par" parameter of port XXX has been changed from ZZZ to NONE, because port YYY is of unacceptable type with respect to the type of port XXX.
WARNING: PO:XXX changed "par1" from YYY to NONE, because PO:WWW invalid "par2" = ZZZ type | The value of "par1" parameter of port XXX has been changed from YYY to NONE, because the parameter "par2" of port WWW is of an unacceptable type ZZZ.
WARNING: PO:XXX changed "MPX" from YES to EXT, because upper IPP:YYY "IFTYPE:" is LINK | The value of "MPX:" parameter of the port XXX has beeen changed, because the XXX port is used by an IP port YYY whose IFTYPE: parameter is set to "LINK".
WARNING: PO:XXX changed "MPX" from YES to EXT, because upper IPP:YYY "FRAG" = ABILIS | The value of "MPX:" parameter of the port XXX has beeen changed, because the XXX port is used by an IP port YYY whose FRAG: parameter is set to "ABILIS".
WARNING: PO:XXX changed "par" from YYY to WWW, because PLINK:ZZZ is PLINKE | The value of the "par" parameter of the port XXX has been changed from YYY to WWW, because the referenced P-Link port is of PLINKE type.
WARNING: PO:XXX changed "par" from YYY to WWW, because upper port type is TTT | The value of the "par" parameter of the port XXX has been changed from YYY to WWW, because the upper port type is TTT.
WARNING: PO:XXX changed "par" from YYY to WWW, because EIR is present | The value of "par" parameter of port XXX has been changed from YYY to WWW, because of the presence of the Enhanced ISDN Router.
WARNING: PO:XXX changed "YYY" from ZZZ to WWW, because EIR is not present | The value of "YYY" parameter of port XXX has been changed from ZZZ to WWW, because of the absence of the Enhanced ISDN Router.
WARNING: PO:XXX changed EPQ931, EBQ931 and sQ931 ports list | The list of EPQ931, EBQ931 and sQ931 ports in the Enhanced ISDN Router port XXX has been updated.
WARNING: PO:XXX no EPQ931, EBQ931 and sQ931 ports configured | The list of EPQ931, EBQ931 and sQ931 ports in the Enhanced ISDN Router port XXX is empty.
WARNING: PO:XXX changed list of EPISDN and EBISDN ports for clock recovery | The list of EPISDN and EBISDN ports for clock recovery in the Enhanced ISDN Master port XXX has been updated.
WARNING: BEP card requires EPIB card activation | In order to activate the BEP card the EPIB card must be activated too.

Messages in the System Log top

Table 3. Types of messages of the System Log.
Type of message | Meaning
Unclassified | Indications of general events.
E: | Indications of severe errors which require the reset of Abilis CPX. All the sessions are closed and Abilis CPX automatically restarts. Note that an exception is generated and saved in the Exceptions Log for a possible use by Abilis engineers.
W: | Indications of not critical errors that could be caused by some malfunction. The reason must be carefully identified, but the system will continue to function.
I: | Informative indications. Registration of events of particular interest that occour in the regular system operation.

Table 4. Generic messages.
Message | Meaning
--- NEW RUN --- | Indicates the start-up of the system: the software has been loaded and the initialisation phase is in progress.
SYSTEM STARTED | The initialisation phases of the system is complete and then system is active.
RESTART SYSTEM | Request for system restart submitted by the user through the RESTART SYSTEM command issued to the command interpreter of the Control Port or executed from the the frontal panel.
WARM START | Request for unconditional system restart submitted by the user through the WARM START command issued to the command interpreter of the Control Port.
AUTO WARM START | Automatic restart of Abilis CPX caused by an error. Note that an exception is generated and saved in the Exceptions Log for a possible use by Abilis engineers.
PNP REBOOT | Automatic restart of Abilis CPX caused by the PNP/PCI manager.
CONF:ACCEPTED | The main configuration, that was previously saved, has been checked and accepted as valid because the system was able to successfuly start with it. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:REFUSED | The main configuration, that was previously saved, has been checked but not accepted as valid because in the previous attempt the system was NOT able to successfuly start with it. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:RESTORE | The backup configuration is being restored as the main one. This may occour when the main configuration cannot be loaded (e.g. because the file is corrupted) or it was just refused (CONF:REFUSED). Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:RESTORE ERR | The restoring of the backup configuration failed because of an error. If neither the main nor the backup configuration can be loaded, the system will continue to reboot indefinitely. If it happens, it is necessary to repair the diskette or replace it with a second copy. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:BACKUP | The main configuration has been backed up. Usually it occours after a CONF:ACCEPTED event. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:BACKUP ERR | The process of backing up the main configuration failed because of an error. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:MISSING CFG | The main configuration is not present on the diskette or it is not accessible. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:MISSING BCK | The backup configuration is not present on the diskette or it is not accessible. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:CORRUPTED | The content of the main configuration is corrupted or not valid. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:LOAD BCK | Abilis CPX is loading the backup configuration in place of the main configuration. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
CONF:INVALID BCK | The content of the backup configuration is corrupted or not valid. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
AUTO SAVE CONF | Abilis CPX has initiated the automatic saving of the current configuration as the main configuration. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
AUTO SAVE ABORT | The automatic saving of the current configuration has been aborted because of an error. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
AUTO SAVE FAIL | The automatic saving of the current configuration failed because of an error. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
AUTO SAVE OK | The automatic saving of the current configuration was successful. Main configuration is stored in DRIVERS.CFG, backup configuration in DRIVERS.BCK.
ALARM RESET | The command to recovery alarm conditions has been issued.
TRACE ACTIVATED | The function for tracing internal events has been automatically activated at the system start-up.
TRACE NOT ACTIVE | It was not possible to activate the tracing of internal events at the system start-up.
SAVING DEBUG LOG | Saving of the Events Log (Debug Log) in progress.
DEBUG LOG SAVED | Saving of the Events Log (Debug Log) carried out successfully.
DEBUG LOG ERROR | Saving of the Events Log (Debug Log) not carried out because of an error.
DEBUG LOG EMPTY | Saving of the Events Log (Debug Log) not carried out because it was empty
MEMORY SUMMARY: TOT:xxxxxxxxxx FREE:yyyyyyyyyy HU:zzzzzzzzzz HLFB:wwwwwwwwww HLUB:tttttttttt | Informative message about the state of the system memory, values are expressed in byteS. This message indicates a possible internal error, please report the error to the Abilis CPX help-desk. TOT: total memory; FREE: available memory; HU: memory used; HLFB: size of the biggest block of contiguos memory currently available; HLUB: size of the biggest block of contiguos memory currently in use.

Table5. Messages relating to the ports.
Messagge | Meaning
E: Axx yy zzz | xx represents the hexadecimal value of the driver's return code of the zzz port. yy represents the hexadecimal code of the command that caused the error. The following table lists the possible values of xx and yy, and their meaning. The usage of these information is intended for Abilis engineers only.
W: Axx yy zzz | xx represents the hexadecimal value of the driver's return of the zzz port. yy represents the hexadecimal code of the command which caused the warning. The following table lists the possible values of xx and yy, and their meaning. The usage of these information is intended for Abilis engineers only.
W: Nxx yy zzz | xx represents the hexadecimal value of the driver's return code of the zzz port. yy represents the hexadecimal code of the command which has caused the warning. The following table lists the possible values of xx and yy, and their meaning. The usage of these information is intended for Abilis engineers only.
W: L94 xxxx LSN:yy P:zzz | Warning about an internal error. Report the message to the Abilis CPX helpdesk.

xx | Meaning | yy | Command
01 | Invalid buffer length | 01 | MLM only: voice pseudo call
03 | Invalid command | 02 | MLM only: voice pseudo hangup
08 | Invalid local session number or invalid state | 10 | Call
09 | No virtual circuits available | 11 | Listen
0A | Session closed | 12 | Hangup
0B | Command cancelled | 14 | Send
11 | No local session numbers available | 15 | Receive
12 | Unsuccessful call | 35 | Cancel Listen
16 | Circuit in use (PVC) | 60 | Diagnostic
18 | Session reset | 62 | Statistics
19 | Alerting | 64 | Maintenance
20 | Progressing | 65 | Debug
22 | Too many outstanding commands | 66 | Voice
23 | Bad port number | 68 | Test
80 | Destination not found | 69 | Disconnection indication
90 | Level 1 not ready | 6A | Connnection indication
9E | Bad Number | 6B | Alert
A0 | Link level not ready | 6C | Proceeding
B0 | Packet level not ready | 6D | Tone
D0 | Requested service is not available | 6E | Progress
E0 | Global Submit Service not active | 70 | Get Event
F0 | The driver failed to start | 71 | Put Event
FF | Command not completed | 72 | EIR

Table 6. Messages relating to the data compressor.
Message | Meaning
E: C01 | Error allocating the compression/expansion buffers.
W: C02 | Less than 2 dictionaries. No compression available.
W: C03 dd | Insufficient system memory. Only "dd" dictionaries available.
W: C04 D:xx R:yy | The initialisation of the disctionay number "xx" failed. The return code is "yy".
W: C05 | The compression/expansion service has been reinitialised.

Table 7. Error and warning messages relating to the cards.
Message | Meaning
W: HSCB xxx NI | The HSCB card number xxx failed to initialise
W: EB AC autorst ACBM:xx FAILED ACBM:xx AC:yy,zz | EBIB card: auto-reset of the audio compressors module number xx because one or both channels didn't complete the initialisation sequence. The ACBM number xx failed to complete the initialisation, the AC channel yy was reset first and AC channel zz last.
W: EB AC autorst ACBM:xx MALFUNC ACBM:xx AC:yy,zz | EBIB card: auto-reset of the audio compressors module number xx because one or both channels got malfunctioning after working regularly. The ACBM number xx went malfunctioning, the AC channel yy was reset first and AC channel zz last.
W: EB EPIC NF | EBIB/BEP card (master): EPIC not found. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EB EPIC NI | EBIB/BEP card (master): EPIC not initialised. EPIC is the core component of the card, the TDM switching matrix. This error means that the card is defective, or the interrupt line is misconfigured, or there is a conflict with other cards.
W: EB EPIC CONF | EBIB/BEP card (master): failure configuring the EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC CMr | EBIB/BEP card (master): failure when resetting the EPIC control memory. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC CFI | EBIB/BEP card (master): failure during EPIC CFI interface setup. The CFI interface is the PCM/IOM2 interface toward the BRI and PRI lines This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC DMr | EBIB/BEP card (master): failure of the procedure that resets the EPIC data memory. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC ACT | EBIB/BEP card (master): error activating EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC PWR | EBIB/BEP card (master): error powering up EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EB IDEC NF | EBIB card: IDEC not found. IDEC is the D-channels handler for 4 BRI interfaces. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EB ESCC8 NF | EBIB card: ESCC8 not found. ESCC8 is the handler for 8 B-channels. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EB QUAT INIT | EBIB card: the QUAT-S initialisation failed. QUAT-S is the layer 1 handler for 4 BRI interfaces. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EB QUAT PRG | EBIB card: the QUAT-S programming failed. This error means that the card is defective, or there is a conflict with other cards. On very early versions of EBIB cards this error can seldomly appear at system startup on regularly working cards too, if it happens just reboot again
W: EP AC autorst ACBM:xx FAILED ACBM:xx AC:yy,zz | EPIB card: auto-reset of the audio compressors module number xx because one or both channels didn't complete the initialisation sequence. The ACBM number xx failed to complete the initialisation, the AC channel yy was reset first and AC channel zz last.
W: EP AC autorst ACBM:xx MALFUNC ACBM:xx AC:yy,zz | EPIB card: auto-reset of the audio compressors module number xx because one or both channels got malfunctioning after working regularly. The ACBM number xx went malfunctioning, the AC channel yy was reset first and AC channel zz last.
W: EB EPIC NF | EPIB card (master): EPIC not found. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EP EPIC NI | EPIB card (master): EPIC not initialised. EPIC is the core component of the card, the TDM switching matrix. This error means that the card is defective, or the interrupt line is misconfigured, or there is a conflict with other cards.
W: EP EPIC CONF | EPIB card (master): failure configuring the EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EP EPIC CMr | EPIB card (master): failure when resetting the EPIC control memory. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC DMr | EPIB card (master): failure of the procedure that resets the EPIC data memory. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC ACT | EPIB card (master): error activating EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EB EPIC PWR | EBIB/BEP card (master): error powering up EPIC. This error means that the card is defective or there is a conflict with other cards.
W: EP FALC NF | EPIB card: FALC not found This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.
W: EP ESCC8 NF | EPIB card: ESCC8 not found. ESCC8 is the handler for 8 B-channels. This error means that the card is not present, or not configured correctly, or defective, or there is a conflict with other cards.

Table 8. Messages relating to the files on the diskette
Message | Meaning
E: RTF xx | Error "xx" during the initialisation of the file system. Report the error to the Abilis CPX helpdesk.
E: MISSING ssss | Missing some file necessary to the Enhanced ISDN router or the Analog voice router. Where "ssss" is an achronym corresponding to the file which the message refers to, the possible values are: FDSP = file FDSP.BIN BUSY = file BUSYTONE.BIN DIAL = file READTONE.BIN RING = file RINGTONE.BIN Report the error to the Abilis CPX helpdesk.
W: F03 xx | Error "xx" in the format of the above listed files. This error usually means that the diskette is damaged, if you are sure that it is not the case peport the error to the Abilis CPX helpdesk.
E: F06 xx | Error "xx" in the Events Log (Debug Log) file (CPX.DBG). Report the error to the Abilis CPX helpdesk.

Table 9. Warning and error messages relating to the PNP/PCI manager.
Message | Meaning
W: PNP FAIL | The initialisation of the PNP service failed. Report the error to the Abilis CPX helpdesk.
W: PNP_R FAIL | The updating of the PNP service failed. Report the error to the Abilis CPX helpdesk.
W: PCISRV FAIL | The initialisation of the PCI service failed. Report the error to the Abilis CPX helpdesk.
W: PCI MANY CARDS | The maximum limit of 32 PCI cards which the system can support, has been reached. Report the error to the Abilis CPX helpdesk.
E: PCI WRONG CHS | The chip set present on the mother board is incompatible with CPX software. Report the error to the Abilis CPX helpdesk.
W: PCI UNKN CHS | The chip set present on the mother board is not in the list of the known ones. Report the error to the Abilis CPX helpdesk.

Table 10. Warning and error messages that must be reported to the Abilis CPX helpdesk.
Message | Meaning
E: WDG ERROR | Severe error of the hardware watchdog, probably due to hardware defect.
W: IPRT OVERFLOW The table of the dynamic IP routing went full and some new routing (e.g learned by RIP) could not be inserted.
It is possible to increase the routing table size by increasing the value of maxroute parameter in the IPRTR port.
E: OS EXIT Severe error at operating system level.
It is often caused by defective or extremely low amount of system RAM. If the problem persist after replacing or increasing the amount the system RAM, contact Abilis CPX technical assistance.
E: HNDL xx | Severe internal software error.
E: Bxx yy The configuration file passed correcteness checks, however further inner checks detected a missing or incompatible configuration block.
This message is caused by a software bug, please report the error to Abilis CPX helpdesk providing the DRIVERS.CFG file and the version number and date.
E: D00 xxxx
E: D01 xxxx
E: D02 xxxx
E: D03 xxxx
E: Gxx yyyy
E: GSxx
E: Lxx yyyy
E: Mxx
E: Mxx yy
E: Mxx yyyy
E: Nxx yy zzz ww
E: Pxx
E: Sxx
E: Txx
E: Xxx
 Severe software errors, please contact Abilis CPX helpdesk.
W: PVC:xx INVPTR | Software error relating to PVC with ID:xx, which is now malfunctioning.
W: ACNT ddddd
   STA: ddddd
   LSN: ddddd
   MOD: ddddd
   DRC: ddddd
   COD: ddddd 		Warning message specific to ACNT module.
W: EIR MXPC The EIR reached the maximum number of calls pending in the "establishing" phases, that is calling/alerting phases
It is possible to increase the limit by increasing the value of parameter mxpc in the EIR port.
W: EIR ReleaseID | Warning message specific to EIR (Enhanced ISDN Router).
W: EIR GetIDByPort | Warning message specific to EIR (Enhanced ISDN Router).
W: EIR IP:   ddddd
       ID:   ddddd
       InID: ddddd
       IDEx: XXXX
       IIDE: XXXX
       IDEx: XXXX
       IIDE: XXXX
ddddd, ddddd ->
ddddd, ddddd
ddddd, ddddd ->
ddddd, ddddd
 Warning message specific to EIR (Enhanced ISDN Router).
W: EIR IP:   ddddd
       ID:   ddddd
       InID: ddddd
       Ex:   XXXX
       IEx:  XXXX
       CoTy: XXXX
       Cpx:  ddddd
       ICpx: ddddd
       Cpx:  ddddd
       OCpx: ddddd
ddddd, ddddd ->
ddddd, ddddd
ddddd, ddddd ->
ddddd, ddddd
 Warning message specific to EIR (Enhanced ISDN Router).
W: EIR Handle
   Ebib: xxxxx
   Hand: YY 		Warning message specific to EIR (Enhanced ISDN Router).
W:HeapCorrupt XX A corruption of system memory has been detected.
The error can be caused by a software bug or by defective system RAM memory.
W:HeapEmpty XX System memory cannot be inspected.
The error can be caused by a software bug or by defective system RAM memory.
W:HeapChkFail XX The check of system memory could not be completed because it is probably corrupted.
The error can be caused by a software bug or by defective system RAM memory.
W:HeapReg Err 01 Markers of a software module cannot be written in the system memory.
The error can be caused by a software bug or by defective system RAM memory.

Table 11. Informative messages of the System Log. Tabella 4. Messaggi informativi del Log di Sistema.
Message | Meaning
I: WDSTART | The watchdog has noticed a timeout during the departure phase. [Il watchdog ha rilevato un timeout durante la fase di partenza.
I: WDLIVE1 | The watchdog has noticed a timeout on the primary LIVE during the operative phase. [Il watchdog ha rilevato un timeout sul LIVE principale durante la fase di funzionamento.
I: WDLIVE2 | The watchdog has noticed a timeout on the secondary LIVE during the operative phase. In the current version, the secondary LIVE is linked to the primary LIVE, therefore the presence of this signal indicates that on the watchdog card a bridge is missing. Il watchdog ha rilevato un timeout sul LIVE secondario durante la fase di funzionamento. Nella versione corrente il LIVE secondario e' collegato al LIVE primario, pertanto la presenza di questa segnalazione indica che sulla scheda watchdog manca un ponticello.
I:DSTt to STDt 1 | The system has alerted to the necesssity of effecting the transition from "official" to "solar" time; as a result, the values for local date and time will be updated on the basis of the current time zone. [Il sistema ha rilevato la neccessita' di effettuare la trasizione da Orario Legale ad Orario Solare, i valori di data ed ora locali verranno di conseguenza aggiornati in base al Fuso Orario correntemente configurato.
I:DSTt to STDt 2 | The system has effected the transition from Official Time to Solar Time. [Il sistema ha effettuato la trasizione da Orario Legale ad Orario Solare.
I:STDt to DSTt 1 | The system has alerted to the necessity of effecting the transition from "Solar" to "Officical" time; as a result, the values for local date and time will be updated on the basis of the current time zone. [Il sistema ha rilevato la neccessita' di effettuare la trasizione da Orario Solare ad Orario Legale, i valori di data ed ora locali verranno di conseguenza aggiornati in base al Fuso Orario correntemente configurato.
I:STDt to DSTt 2 | The system has effected the transition from Solar Time to Official Time. [ Il sistema ha effettuato la trasizione da Orario Solare ad Orario Legale.
I:TIME UPD >1min I:+-xxxxxx sec | This message indicates that the process of synchronizing the system clock has alerted to a time difference of greater than one minute, between the local clock and the synchronization Server. Where "+-xxxxxx" indicates the exact value in seconds of the time of the time difference encountered. [Questo messaggio segnala che la procedura di sincronizzazione del clock di sistema ha rilevato uno sfasamento superiore ad un minuto del clock locale rispetto a quello del Server di sincronizzazione. Dove "+-xxxxxx" indica l'esatto valore in secondi dello sfasamento riscontrato.
I:pxxx SYN:SS.zt (*) | Message of the status of the synchronous ports (SYNC): [Messaggio di stato delle porte sincrone (SYNC): xxx= number of the SYNC port which the message refers to; [xxx = numero della porta SYNC cui il messaggio si riferisce; SS = status of the SYNC driver; [SS = stato del driver SYNC: + = status of the DTR signal. [+ = stato del segnale DTR z = status of the DCD signal; [z = stato del segnale DCD
I:pxxx EPI:SSSS (*) | Message of the status of the ISDN Primary Rate ports (EPISDN): [Messaggio di stato delle porte ISDN Primary Rate (EPISDN): xxx = number of the EPISDN port which the message refers to; [xxx = numero della porta EPISDN cui il messaggio si riferisce; SSSS = status of the EPISDN driver. [SSSS = stato del driver EPISDN
I:pxxx EBI:SSSS (*) | Message of the status of the ISDN Basic Rate ports (EBISDN/ISDN): [Messaggio di stato delle porte ISDN Basic Rate (EBISDN/ISDN): XXX = number of the EBISDN/ISDN port which the message refers to; [xxx = numero della porta EBISDN/ISDN cui il messaggio si riferisce; SSSS= status of the EBISDN/ISDN driver. [SSSS = stato del driver EBISDN/ISDN
I:pxxx ETH:SS (*) | Message of the status of the ETH ports: [Messaggio di stato delle porte ETH: xxx = number of the ETH port which the message refers to; [xxx = numero della porta ETH cui il messaggio si riferisce; SS = status of the ETH driver. [SS = stato del driver ETH
I:pxxx ETH100:SS (*) | Message of the status of the ETH100 ports: [ Messaggio di stato delle porte ETH100: xxx = number of the ETH100 port which the message refers to; [xxx = numero della porta ETH100 cui il messaggio si riferisce; SS = status of the ETH100 driver. [SS = stato del driver ETH100.
I:pxxx TR:SS (*) | Message of the status of the TR ports: [Messaggio di stato delle porte TR: xxx = number of the TR port which the message refers to; [xxx = numero della porta TR cui il messaggio si riferisce; SS = status of the TR driver. [SS = stato del driver TR
I:pxxx FR:SSSS (*) | Message of the status of the FR ports: [Messaggio di stato delle porte FR: xxx = number of the FR port which the message relates to; [xxx = numero della porta FR cui il messaggio si riferisce; SSSS = status of the FR driver; [SSSS = stato del driver FR
I:pxxx yyyyyyy SS (*) | Message of the status of the single DLCI of the FR ports: [Messaggio di stato del singolo DLCI delle porte FR: xxx = number of the FR port which the message refers to; [xxx = numero della porta FR cui il messaggio si riferisce; yyyyyyy = number of the DLCI which the message refers to; [yyyyyyy = numero del DLCI cui il messaggio si riferisce; SS = status of the DLCI [SS = stato del DLCI
I:pxxx EPL:SQ.SX (*) | Message of the status of the LAPD Primary Rate ports (EPLABD): [Messaggio di stato delle porte LAPD Primary Rate (EPLABD): xxx = number of the EPLABD port which the message refers to; [xxx = numero della porta EPLABD cui il messaggio si riferisce; SQ = status of the Sapi Q931; [SQ = stato del Sapi Q931; SX = status of the Sapi X25. [SX = stato del Sapi X25.
I:pxxx EBL:SQ.SX (*) | Message of the status of the LAPD Basic Rate ports (EBLABD), of type TE: [Messaggio di stato delle porte LAPD Basic Rate (EBLABD), di tipo TE: xxx = number of the EBLABD port which the message refers to; [xxx = numero della porta EBLABD cui il messaggio si riferisce; SQ = status of the Sapi Q931; [ SQ = stato del Sapi Q931; SX = status of the Sapi X25 [SX = stato del Sapi X25
I:pxxx EBL:--.SX a | Message of the status of the LAPD Basic Rate ports (EBLABD), of type NT: [ Messaggio di stato delle porte LAPD Basic Rate (EBLABD), di tipo NT: xxx = number of the EBLABD port which the message refers to [xxx = numero della porta EBLABD cui il messaggio si riferisce; SX = status of the Sapi X25. [SX = stato del Sapi X25.
I:pxxx LAPB:SSSS (*) | Message of the state of the LAPB ports: [Messaggio di stato delle porte LAPB: xxx = number of the LAPB port which the message refers to; [xxx = numero della porta LAPB cui il messaggio si riferisce; SSSS = status of the LAPB driver. [SSSS = state of the driver LAPB
I:pxxx IPLAN:SS (*) | Message of the status of the IPLAN ports: [Messaggio di stato delle porte IPLAN: xxx = number of the IPLAN port which the message refers to; [xxx = numero della porta IPLAN cui il messaggio si riferisce; SS = status of the IPLAN driver. [SS = stato del driver IPLAN
I:pxxx MLM:PL.SL (*) | Message of the status of the MLM ports: [Messaggio di stato delle porte MLM: xxx = number of the MLM port which the message refers to; [xxx = numero della porta MLM cui il messaggio si riferisce; PL = status of the P-Link; [PL = stato del P-Link SL = status of the S-Link; [SL = stato del S-Link;
I:pxxx X25:SSSS (*) | Message of the status of the X25 ports: [Messaggio di stato delle porte X25: xxx = number of the X25 port which the message refers to; [xxx = numero della porta X25 cui il messaggio si riferisce; SSSS = status of the X25 driver; [SSSS = stato del driver X25;
I:pxxx HDLCT:SS (*) | Message of the status of the HDLCT ports: [ Messaggio di stato delle porte HDLCT: xxx = number of HDLCT port which the message refers to; [xxx = numero della porta HDLCT cui il messaggio si riferisce; SS = status of the HDLCT driver ; [SS = stato del driver HDLCT.
I:pxxx AD:YY SSSS (*) | Message of the status of the Physical Units of the SDLC ports: [Messaggio di stato delle Physical Unit delle porte SDLC: xxx = number of the SDLC port which the number refers to; [xxx = numero della porta SDLC cui il messaggio si riferisce; YY = address of the Physical Unit which the message refers to; [YY = indirizzo della Physical Unit cui il messaggio si riferisce; SSSS = status of the Physical Unit; [SSSS = stato della Physical Unit;
I:pxxx PAD:SS.zt (*) | Message of the status of the PAD ports: [Messaggio di stato delle porte PAD: xxx = number of the PAD port which the message refers to; [xxx = numero della porta PAD cui il messaggio si riferisce; SS = status of asynchronous Level 1; [SS = stato del Livello 1 asincrono; z = status of the DCD signal; z = stato del segnale DCD t = status of the DTR signal. t = stato del segnale DTR
I:CP DTR SS pxxx | This message notifies the implementation on the synchronous (SYNC) ports of the command for setting up the status of the DTR signal{?) [Questo messaggio segnala l'esecuzione sulle porte sincrone (SYNC) del commando di impostazione dello stato del segnale DTR: SS = status of the DTR signal which has been set up; the possible values are: UP = UP, DN = DOWN, PL = PULSE; [SS = stato del segnale DTR impostato; i valori posssibili sono: UP = UP, DN = DOWN, PL = PULSE; xxx = number of the SYNC port where the command has been sent. [xxx = numero della porta SYNC cui il commando e' stato inviato.
I:SDLC xxx QTEST | This message signals the receipt by an SDLC port, of a QLLC TEST notification(?) for activating the control procedure of the DTR signal: [Questo messaggio segnala la ricezione da parte di una porta SDLC di una trama QLLC TEST di attivazione della procedura di controllo del segnale DTR: xxx = number of the SDLC port which the message refers to. [ xxx = numero della porta SDLC cui il messaggio si riferisce.
I:pxxx DTR SS | This message signals the receipt by a synchronous port (SYNC) of the command for setting up the status of the DTR signal (?) [Questo messaggio segnala la ricezione da parte di una porta sincrona (SYNC) del comando di impostazione dello stato del segnale DTR. xxx = number of the SYNC port which the message refers to. [xxx = numero della porta SYNC cui il messaggio si riferisce. SS = status of the DTR signal which has been set up; the possible values are: UP = UP, DN = DOWN, PL = PULSE. [SS = stato del segnale DTR impostato; i valori posibili sono: UP = UP, DN = DOWN, PL = PULSE.
I: EB IDEC fxx | EBIB card: this message signals the number of quadruple control units of channel D (IDEC) which are highlighted(?) and functioning (xx). [Scheda EBIB: questo messaggio segnala il numero di controllori quadrupli di canale D (IDEC) rilevati e funzionanti (xx).
I: EB ESCC8 fxx | EBIB card: this message signals the number of octuple controllers of channel B (ESCC8) which are highlighted and functioning (xx). [Scheda EBIB: questo messaggio segnala il numero di controllori ottupli di canale B (ESCC8) rilevati e funzionanti (xx).
I: EB AC fxx ryy | EBIB card: this message signals the number of voice compressors the presence of which has been highlighted (xx), and how many of them are functioning (yy). [Scheda EBIB: questo messaggio segnala il numero di compressori voce di cui e' stata rilevata la presenza (xx) e quanti di essi sono funzionanti (yy).
I: EB AC restart | EBIB card: a restart of the voice compressors has been carried out. [Scheda EBIB: e' stato eseguito un restart dei compressori voce.
I: EP FALC fxx | EPIB card: this message signals the number of single controllers of channel D (FALC) which are highlighted and functioning (xx). [Scheda EPIB: questo messaggio segnala il numero di controllori singoli di canale D (FALC) rilevati e funzionanti (xx).
I: EP ESCC8 fxx | EPIB card: this message signals the number of octuple controllers of channel B (ESCC8) which are highlighted and functioning (xx). [Scheda EPIB: questo messaggio segnala il numero di controllori ottupli di canale B (ESCC8) rilevati e funzionanti (xx).
I: EP AC fxx ryy | EPIB card: this message signals the number of voice compressors, the presence of which has been highlighted (xx), and how many of them are functioning (yy) .[ Scheda EPIB: questo messaggio segnala il numero di compressori voce di cui e' stata rilevata la presenza (xx) e quanti di essi sono funzionanti (yy).
I: EP AC restart | EPIB card: a restart of the voice compressors has been carried out. Scheda EPIB: e' stato eseguito un restart dei compressori voce.
Note: (*) The status of the ports is checked at intervals of about half a second, therefore changes in status of less than a second are not highlighted by Abilis CPX, and consequently are not registered in the log of the system. Note: (*) Lo stato delle porte viene controllato ad intervalli di circa mezzo secondo, pertanto i cambiamenti di stato inferiori al secondo non vengono rilevati da Abilis CPX e di conseguenza non vengono registrati nel log di sistema.

Messages in the events log top

Table 12. List of the diagnostic messages in the Log of Events.
Message | Description of the event
PortDiag SYNC:ss DCD:dd DTR:rr | Information on the status of the SYNC driver. [Informazioni sullo stato del driver SYNC. Where [Dove: ss = status of the SYNC driver stato del driver SYNC; dd = state of the DCD signal stato del segnale DCD; rr = status of the DTR signal stato del segnale DTR.
PortDiag EPISDN:ss | Information on the status of the driver of the ISDN Primary Rate (EPISDN) cards. [Informazioni sullo stato del driver delle schede ISDN Primary Rate (EPISDN). Where: ss = status of the EPISDN driver. [Dove: ss = stato del driver EPISDN
PortDiag EBISDN:ss | Information on the state of the driver of the ISDN Basic Rate (EBISDN/ISDN) cards. [Informazioni sullo stato del driver delle schede ISDN Basic Rate (EBISDN/ISDN). Where : ss = [Dove: ss = status of the EBISDN/ISDN driver. stato del driver EBISDN/ISDN.
PortDiag ETH:ss | Information on the status of the ETH driver. [Informazioni sullo stato del driver ETH. Where ss: = [Dove: ss = status of the ETH driver. del driver ETH.
PortDiag ETH100:ss | Information on the status of the ETH100 driver.. [Informazioni sullo stato del driver ETH100. Where: ss = [Dove: ss = status of the ETH100 driver. del driver ETH100.
Port Diag TR:ss | Information on the status of the TR driver. [Informazioni sullo stato del driver TR. Where: ss = [Dove: ss = status of the TR driver. del driver TR.
PortDiag LAPB:ssss | Information on the status of the LAPB driver. [.Informazioni sullo stato del driver LAPB. Where: ss = [Dove: ss = status of the LAPB driver. del driver LAPB.
PortDiag EPLAPD Q931:sq X25:sx | Information on the status of the LAPD Primary Rate (EPLAPD) driver. [Informazioni sullo stato del driver LAPD Primary Rate (EPLAPD). Where: sq = [Dove: sq = status of the Sapi Q931; del Sapi Q931; sx = [sx = status of the Sapi X25 . del Sapi X25.
PortDiag EBLAPD Q931:sq X25:sx | Information on the status of the LAPD Basic Rate (EBLAPD/LAPD) driver, of type TE. [Informazioni sullo stato del driver LAPD Basic Rate (EBLAPD/LAPD), di tipo TE. Where: sq = [Dove: sq = status of the Sapi Q931; del Sapi Q931; sx = [sx = status of the Sapi X25. del Sapi X25.
PortDiag EBLAPD Q931:-- X25:sx | Information on the status of the LAPD Basic Rate (EBLAPD/LAPD) driver, of type NT. [Informazioni sullo stato del driver LAPD Basic Rate (EBLAPD/LAPD), di tipo NT. Where: sx = [Dove: sx = state of the Sapi X25. del Sapi X25.
PortDiag IPLAN:ss | Information on the status of the IPLAN driver. [ Informazioni sullo stato del driver IPLAN. Where: ss = [Dove: ss = status of the IPLAN driver. del driver IPLAN.
PortDiag FR:ssss | Information on the status of the FR driver. [Informazioni sullo stato del driver FR. Where: ssss = [Dove: ssss = status of the FR driver. del driver FR.
PortDiag FR DLCI:xxxxxxx ST:ss | Information on the status of the DLCIs of the FR driver. [Informazioni sullo stato dei DLCI del driver FR. Where: xxxxxxxx = number of the DLCI, ss = [Dove: xxxxxxx = numero del DLCI, ss = status of the DLCI. del DLCI.
PortDiag X25:ssss | Information on the status of the X25 driver. [Informazioni sullo stato del driver X25. Where: ssss = [Dove: ssss = state of the X25 driver. del driver X25.
PortDiag SDLC PU:dd ADD:xx ST:y | Information on the status of the Physical Unit of the SDLC driver. [Informazioni sullo stato delle Physical Unit del driver SDLC. Where: dd = index of the Physical Unit, xx = address of the Physical Unit, y = [Dove: dd = indice della Physical Unit, xx = indirizzo della Physical Unit, y = status of the Physical Unit. della Physical Unit.
PortDiag PAD:ss DCD:dd DTR:rr | Inform,ation on the status of the PAD driver. [Informazioni sullo stato del driver PAD. Where: ss = [Dove: ss = status of asynchronous level 1; del livello 1 asincrono; dd = [dd = status of the DCD signal; del segnale DCD; r r = [rr = status of the DTR signal. del segnale DTR.
PortDiag HDLCT:ss | Information on the status of the HDLCT driver. [Informazioni sullo stato del driver HDLCT. Where: ss = [Dove: ss = status of the HDLCT driver. del driver HDLCT.
PortDiag MLM PLink:sl SLink:ss ATN:aaa | Information on the status of the MLM driver. [Informazioni sullo stato del driver MLM. Where: sl = [Dove: sl = status of the P-Link; del P-Link; ss [ss = status of the S-Link; del S-Link; aaa = status of ATTENTION of the S-Link. [aaa = stato di ATTENTION del S-Link.
PortDiag SLink started retries in ATN | Information on the status of the S-Link of the MLM driver (status of ATTENTION). [Informazioni sullo stato del S-Link del driver MLM (stato di ATTENTION).
PortDiag Slink exited from ATN | Information on the status of the S-Link of the MLM driver (status of ATTENTION of the S-Link). [Informazioni sullo stato del S-Link del driver MLM (stato di ATTENTION del S-Link).
PortDiag SLink started Unattended Site retries (US) | The MLM port has initiated the calling procedure specified by the RTY configuration parameter. [La porta MLM ha iniziato la procedura di chiamata specificata dal parametro di configurazione RTY:.
Table 13. Events relating to the Connection-Orientated Router in the Log of Events. Tabella 6. Eventi relativi ai Connection Oriented Router nel Log degli Eventi.
Event | Description of the event
CallRx CG:s1 CD:s2 PID:s3 UD:s4 FF:s5 | Call request received. [Call request ricevuta. Where: sl = caller's address; s2 = address called, s3 = "PID" field of the call, s4 = User's Data field, s5 = Facility field. [Dove: s1 = indirizzo chiamante; s2 = indirizzo chiamato, s3 = campo "PID" della chiamata, s4 = campo Dati Utente, s5 = campo Facility.
CallTx CG:s1 CD:s2 PID:s3 UD:s4 FF:s5 | Call request sent [Call request inviata. Where: s1 = caller's address; s2 address called, s3 = "PID" field of the call, s4 = User's Data field, s5 = Facility field. [Dove: s1 = indirizzo chiamante; s2 = indirizzo chiamato, s3 = campo "PID" della chiamata, s4 = campo Dati Utente, s5 = campo Facility.
CallConnRx LSN:yy CG:s1 CD:s2 PID:s3 UD:s4 FF:s5 | Call connect received. [Call connect ricevuta. Where: yy = "Local Session number" received by the driver, s1 = caller's address; s2 = address called, s3 = "PID" field of the call, s4 = User's Data field, s5 = Facility field. [Dove: yy = "Local Session Number" ricevuto dal driver, s1 = indirizzo chiamante; s2 = indirizzo chiamato, s3 = campo "PID" della chiamata, s4 = campo Dati Utente, s5 = campo Facility.
CallConnTx LSN:yy CG:s1 CD:s2 PID:s3 UD:s4 FF:s5 | Call connect sent. [Call connect inviata. Where: yy = "Local Session Number" received by the Driver, s1 = caller's address; s2 = address called, s3 = "PID" field of the call, s4 = User's Data field, s5 = Facility field. [Dove: yy = "Local Session Number" ricevuto dal driver, s1 = indirizzo chiamante; s2 = indirizzo chiamato, s3 = campo "PID" della chiamata, s4 = campo Dati Utente, s5 = campo Facility.
ClrRx cc:dd LSN:yy | Clear request received. [Clear request ricevuta. Where: cc:dd = cause and diagnostics codes; yy = "Local Session Number. [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
ClrTx cc:dd LSN:yy | Clear request sent. [Clear request inviata. Where cc:dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
ClrConfRx cc:dd LSN:yy | Clear confirmation received. [Clear confirmation ricevuta. Where: cc:dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
ClrConfTx cc:dd LSN:yy | Clear confirmation sent(3). [Clear confirmation inviata (3). Where cc:dd = cause and diagnostic codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
RstRx cc:dd LSN:yy | Reset indication received. [Reset indication ricevuta. Where: cc:dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
RstTx cc:dd LSN:yy | Reset indication sent. [Reset indication inviata. Where: cc:dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
RstConfRx LSN:yy | Reset confirmation received. [Reset confirmation ricevuta. Where: yy = "Local Session Number". [Dove: yy = "Local Session Number".
RstConfTx | Reset confirmation sent(3). Reset confirmation inviata (3).
IntRx | Interrupt received. [Interrupt ricevuto.
IntTx | Interrupt sent. [Interrupt inviato.
IntConfRx | Interrupt confirmation received. [Interrupt confirmation ricevuta.
IntConfTx | Interrupt confirmation sent (3). [Interrupt confirmation inviata (3).
PvcOpenRx LSN:yy | Open request received on PVC(2) (5), [Open request ricevuto su PVC (2) (5) . Where: yy = "Local Session Number". [Dove: yy = "Local Session Number".
PvcOpenTx LSN:yy PW:zz | Open request sent on PVC(5). [Open request inviato su PVC (5) . On the X25 line a package of RESET is sent, with cause F0 and diagnostic 00. At the interior of Abilis CPX the PVC has been activated. [Sulla linea X25 viene inviato un pacchetto di RESET con causa F0 e diagnostica 00. All'interno di Abilis CPX il PVC e' stato attivato. Where: yy = Local Session Number, zz = package window. [Dove: yy = "Local Session Number", zz = finestra di pacchetto.
PvcOpenConfRx LSN:yy | Open confirmation received on PVC(5). [Open confirmation ricevuto su PVC (5) . Request to activate Pvc Open Tx has been accepted, the RESET F0,00 has been sent. [ La richiesta di attivazione Pvc OpenTx e' stata accettata, il RESET F0,00 e' stato inviato. Where: yy = Local Session Number". [Dove: yy = "Local Session Number".
PvcOpenConfTx LSN:yy | Open confrirmation sent on PVC(2) (5). [Open confirmation inviato su PVC (2) (5) . Where: yy = "Local Session Number". [Dove: yy = "Local Session Number".
PvcCloseRx cc:dd LSN:yy | Close request received on PVC(5). [Close request ricevuto su PVC (5) . The PVC has been deactivated by the X25 driver owing to an error. A RESET F0,40 or a RESTART has been sent along the line. To reactivate the PVC a new Pvc Open Tx will be sent. [Il PVC e' stato disattivato dal driver X25 a causa di un errore. Sulla linea e' stato inviato un RESET F0,40 o un RESTART. Per riattivare il PVC verre' inviata una nuova PvcOpenTx. Where: cc: dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
PvcCloseTx cc:dd LSN:yy | Close request sent on PVC(5) . [Close request inviato su PVC (5) . On the X25 line a RESET package is sent with cause F0 and diagnostic 40. At the interior of the Abilis CPX the PVC has been deactivated. [Sulla linea X25 viene inviato un pacchetto di RESET con causa F0 e diagnostica 40. All'interno di Abilis CPX il PVC e' stato disattivato. Where: cc:dd = cause and diagnostics codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
PvcCloseConfRx cc:dd LSN:yy | Close confirmation received on PVC(5). [Close confirmation ricevuto su PVC (5) . The request to deactivate Pvc Close Tx has ben accepted, the RESET F0,40 has ben sent. [La richiesta di disattivazione PvcCloseTx e' stata accettata, il RESET F0,40 e' stato inviato. Where: cc: dd = cause and diagnostic codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
PvcCloseConfTx cc:dd LSN:yy | Close confirmation sent on PVC(3) (5). [Close confirmation inviato su PVC (3) (5) . Indication that the PvcCloseRx has been received and accepted by Abilis CPX [Indicazione che il PvcCloseRx e' stato ricevuto ed accettato da Abilis CPX. Where: cc:dd = cause and diagnostic codes; yy = "Local Session Number". [Dove: cc:dd = codici di causa e diagnostica; yy = "Local Session Number".
Level x DOWN | Signal of unavailability of levels 1,2 or 3. [Segnalazione di indisponibilita' dei livelli 1, 2 o 3. Where: x = level which the message refers to. [Dove: x = livello cui il messaggio si riferisce.
PidRx LSN:yy COMP:zzzz | Identification received, of the type of compression protocol. [Ricevuto identificativo del tipo di protocollo di compressione. Where: yy = "Local Session Number", zzzz = compression protocol ("MBIT", "MBITB" or "QLLC"). [Dove: yy = "Local Session Number"; zzzz = protocollo di compressione ( "MBIT", "MBITB" o "QLLC").
PidTx LSN:yy COMP:zzzz | Identification transmitted, of the type of compression protocol. [Trasmesso identificativo del tipo del protocollo di compressione. Where: yy = "Local Session Number", zzzz = compression protocol ("MBIT", "MBITB" or "QLLC"). [Dove: yy = "Local Session Number"; zzzz = protocollo di compressione ( "MBIT", "MBITB" o "QLLC").
BadPidRx LSN:yy | Identification received, of invalid compression protocol. [Ricevuto identificativo del protocollo di compressione non valido. Where: yy = "Local Session Number". [Dove: yy = "Local Session Number".
Routing Match PR:yy | Adequate routeing identified. [ Individuato il routing SVC adeguato. Where: yy = priority of the routeing. [Dove: yy = priorita' del routing.
Unsuccessful Routing PR:yy xx:xx, search next | The SVC routeing cannot be utilised successfully, so another route is being sought. [Il routing SVC indicato non puo' essere utilizzato con successo, si procede alla ricerca di un' altro routing. Where: yy = priority of the routeing; cc:dd = cause and diagnostic codes. [Dove: yy = priorita' del routing; cc:dd = codici di causa e diagnostica.
Routing Fail PR:yy, search next | The call effected with the SVC routeing indicated, has not been successful, so another route is being sought. [La chiamata effettuata con il routing SVC indicato non ha avuto successo, si procede alla ricerca di un' altro routing. Where: yy = priority of the routeing. [Dove: yy = priorita' del routing.
CompErr RC:zzzz | Compression error (1) [ Errore di compressione (1). Where: zzzz = error code, to be reported to the Abilis CPX Helpdesk. [Dove: zzzz = codice dell'errore, da riportare all'assistenza Abilis CPX.
ExpErr RC:zzzz | De-compression error. (1) [Errrore di de-compressione (1). Where: zzzz = error code, to be reported to the Abilis CPX helpdesk. [Dove: zzzz = codice dell'errore, da riportare all'assistenza Abilis CPX.
InvLenCM:xxLN:yy | Length not valid for the data transmitted or received. [Lunghezza non valida per i dati trasmessi o ricevuti. Where: xx = command code sent to the driver; yy = length of the buffer data. Report the error to the Abilis CPX Helpdesk. [Dove: xx = codice del comando inviato al driver; yy = lunghezza del buffer dati. Riportare l'errore all'assistenza Abilis CPX.
SwErr CM:xx RC:zz LSN:yy INFO:ww | Internal error [Errore interno. Where: xx = command code sent to the driver; zz = return code received by the driver; yy = "Local Session Number", ww = information field sent to/received by the driver. [Dove: xx = codice del comando inviato al driver; zz = codice di ritorno ricevuto dal driver; yy = "Local Session Number"; ww = campo informativo inviato/ricevuto al/dal driver. Report the error to the Abilis CPX Helpdesk [Riportare l'errore all'assistenza Abilis CPX.
RetCode CM:xx RC:zz | Return code not predicted in that situation(4). [Codice di ritorno non previsto in quella situazione (4). Where: xx = command code sent to the driver; zz = return code received by the driver. [Dove: xx = codice del comando inviato al driver; zz = codice di ritorno ricevuto dal driver. Report the error to the Abilis CPX Helpdesk. [Riportare l'errore all'assistenza Abilis CPX.
Notes: (1) The code has no meaning for the user, it is intended for Abilis technicians to resolve eventual problems. (2) In reality this event will never occur. (3) Then confirmations of Clear, Reset and Interrupt are carried out automatically by the Drivers. (4) The "command codes" are "yy" values reported in "Errors signalled by the drivers". The reference to Open and Close on PVC is only valid for the internal structure of Abilis CPX, as the real activity is described in the table which follows. Note: (1) Il codice non ha significato per l'utente, serve ai tecnici Abilis per la soluzione di eventuali problemi. (2) In realta' questo evento non potra' mai verificarsi. (3) Le conferme di Clear, Reset e Interrupt sono gestite automaticamente dai driver. (4) I "command codes" sono i valori "yy" riportati in "Errori segnalati dai driver". I "return codes" sono i valori "xx" riportati in "Errori segnalati dai driver". (5) Il riferimento a Open e Close su PVC e' valido solamente per la struttura interna di Abilis CPX, il comportamento reale viene descritto nella tabella successiva. Table 14. Events relating to the Multi-Link Managers in the Log of Events. Tabella 7. Eventi relativi ai Multi-Link Manager nel Log degli Eventi.
Event | Description of event
I-CallRx POI:xxx LSN:yy CD:s1 CG:s3 SCD:s2 SCG:s4 | Call request received. [Call request ricevuta. Where: xxx = CPX input port; yy = "Local Session Number", s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = sub-address of the caller.(?) Dove: xxx = porta CPX di input; yy = "Local Session Number"; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante.(?)
I-CallTx POI:xxx CD:s1 CG:s2 SCD:s3 SCG:s4 MPX:s5 | Call request sent. [Call request inviata. Where: xxx = CPX input port; s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = sub-address of the caller(?) ; s5 = value of the "MPX" field. [Dove: xxx = porta CPX di input; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante(?); s5 = valore del campo "MPX".
I-CallConnRx POI:xxx LSN:yy | Call connect received. [Call connect ricevuta. Where: xxx = CPX input port; yy = "Local Session Number" [Dove: xxx = porta CPX di input; yy = "Local Session Number".
I-CallConnTx POI:xxx LSN:yy MPX:s1 | Call connect sent. [Call connect inviata. Where: xxx = CPX input port; yy = "Local Session Number", Dove: xxx = porta CPX di input; yy = "Local Session Number" ; s1 = valore del campo "MPX".
I-ClrRx POI:xxx LSN:yy CODE:s1 | Clear request received. [Clear request ricevuta Where: xxx = CPX input port; yy = "Local Session Number", s1 = "Cause" field. [Dove: xxx = porta CPX di input; yy = "Local Session Number"; s1 = campo "Cause".
I-ClrTx POI:xxx LSN:yy CODE:s1 | Clear request sent. [Clear request inviata. Where: xxx = CPX input port; yy = "Local Session Number", s1 = "Cause" field. [Dove: xxx = porta CPX di input; yy = "Local Session Number"; s1 = campo "Cause".
I-ClrConfRx POI:xxx LSN:yy CODE:s1 | Clear confirm received. [Clear confirm ricevuta. Where: xxx = CPX input port; yy = "Local Session Number", s1 = "Cause" field. [Dove: xxx = porta CPX di input; yy = "Local Session Number"; s1 = campo "Cause".
I-ClrConfTx POI:xxx LSN:yy CODE:s1 | Clear confirm sent. [Clear confirm inviata. Where: xxx = CPX input port; yy = "Local Session Number", s1 = "Cause" field [Dove: xxx = porta CPX di input; yy = "Local Session Number"; s1 = campo "Cause".
Table 15. Events relevant to the Enhanced ISDN Router in Events Log. Tabella 8. Eventi relativi all'Enhanced ISDN Router nel Log degli Eventi.
Event | Description of the event
E-CallRx ID:xxx BC:yyy CD:s1 CG:s2 SCD:s3 SCG:s4 | Call request received. [ricevuta. Where: xxx = identification of the connection; yyyy = "Bearer Capability" field, and can be "Speech" or "Udi" or "Rdi" or "3.1 kHz Audio" or "Udi_Ta" or "Video"; s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = caller's sub-address(?).Dove: xxx = identificativo della connessione; yyyy = campo "Bearer Capability" e pu??sere "Speech" o "Udi" o "Rdi" o "3.1 kHz Audio" o "Udi_Ta" o "Video"; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante.(?)
E-CallRx ID:xxx VSP-ID:yy | Call request received [Call request ricevuta. Where: xxx = identification of the connection; yy = identification of the VSP. [Dove: xxx = identificativo della connessione; yy = identificativo del VSP.
E-CallTx ID:xxx BC:yyy TY:zzz CD:s1 CG:s2 SCD:s3 SCG:s4 MPX:s5 | Call request sent. [ Call request inviata. Where: xxx = identification of the connection; yyyy = "Bearer Capability" field and can be "Speech" or "Udi" or "Rdi" or "3.1 kHz Audio" or "Udi_Ta" or "Video"; zzz = type of connection, and can be "TR" or "VtoC" or "CtoV" or "CtoC" or "DATA" or "Clus"; s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = caller's sub-address;(?) s5 = value of "MPX" field. [Dove: xxx = identificativo della connessione; yyyy = campo "Bearer Capability" e pu??sere "Speech" o "Udi" o "Rdi" o "3.1 kHz Audio" o "Udi_Ta" o "Video"; zzz = tipo della connessione e pu??sere "TR" o "VtoC" o "CtoV" o "CtoC" o "DATA" o "Clus"; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante;(?)- s5 = valore del campo "MPX".
E-CallFailRx ID:xxx CODE:yy | Call fail received. [Call fail ricevuta. Where: xxx = identification of the conncection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
E-CallFailTx ID:xxx CODE:yy | Call fail sent. [Call fail inviata. Where: xxx = identification of the connection; yy = "Cause" field. Dove: xxx = identificativo della connessione; yy = campo "Cause".
E-AlertRx ID:xxx | Alert received. [ricevuto. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
E-AlertTx ID:xxx | Alert sent. [inviato. Where : xxx = identification of the connection [Dove: xxx = identificativo della connessione.
E-ConnRx ID:xxx | Call connect received. [ ricevuta. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
E-ConnTx CH:xxx MPX:yy | Call connect sent. [inviata. Where: xxx = identification of the connection; yy = value of the "MPX" field. Dove: xxx = identificativo della connessione; yy = valore del campo "MPX".
E-DiscRx ID:xxx CODE:yy | Disc request received. [ricevuta. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
E-DiscTx ID:xxx CODE:yy | Disc request sent. [inviata. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
E-DiscConfRx ID:xxx | Disc confirm received. [ricevuta. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
E-DiscConfTx ID:xxx | Disc confirm sent. [inviata. Where: xxx = identification of the connection [Dove: xxx = identificativo della connessione.
E-CallCancelledRx ID:xxx | Call cancel received. [ricevuta. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
E-CancelCallTx ID:xxx CODE:yy | Call cancel sent. [inviata. Where: xxx = identification of the connection; yy = "Cause" field.Dove: xxx = identificativo della connessione; yy = campo "Cause".
E-Routing Match ID:xxx PR:yy | Appropriate routeing identified. [Identifcato il routing appropriato. Where: xxx = identification of the connection; yy = priority of the routeing. [Dove: xxx = identificativo della connessione; yy = priorit?el routing.
E-Without Routing ID:xxx | The search for the routeing has been unsuccessful. [La ricerca del routing ?allita. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
E-Routing Fail ID:xxx PR:yy | The routeing used has been unsuccessful. [Il routing utilizzato non ha avuto successo. Where: xxx = identification of the connection; yy = priority of the routeing. [Dove: xxx = identificativo della connessione; yy = priorit?el routing.
E-Routing Fail ID:xxx PR:yy, search next | The routeing used has been unsuccessful, so another route is being sought. Il routing utilizzato non ha avuto successo, si procede alla ricerca di un altro routing. Where" xxx = identification of the connection; yy = priority of the routeing. Dove: xxx = identificativo della connessione; yy = priorit?el routing.
Ec-CallRx ID:xxx BC:yyy CD:s1 CG:s2 SCD:s3 SCG:s4 | Cluster: Call request received. [Cluster: Call request ricevuta. Where: xxx = identification of the connection; yyyy = "Bearer Capability" field and can be "Speech" or "Udi" or "Rdi" or "3.1 kHz Audio" or "Udi_Ta" or "Video"; s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = caller's sub-address.(?) Dove: xxx = identificativo della connessione; yyyy = campo "Bearer Capability" e puo' essere "Speech" o "Udi" o "Rdi" o "3.1 kHz Audio" o "Udi_Ta" o "Video"; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante.(?)
Ec-CallTx ID:xxx BC:yyy TY:zzz CD:s1 CG:s2 SCD:s3 SCG:s4 MPX:s5 | Cluster: Call request sent. [inviata. Where xxx = ientification of the connection; yyyy = "Bearer Capability" field and can be "Speech" or "Udi" or "Rdi" or "3.1 kHz Audio" or ""Udi_Ta" or "Video"; zzz = type of connection and can be "TR" or "VtoC" or "CtoV" or "CtoC" or "DATA" or "Clus"; s1 = address called; s2 = caller's address; s3 = sub-address called; s4 = caller's sub-address(?); s5 = value of "MPX" field. [Dove: xxx = identificativo della connessione; yyyy = campo "Bearer Capability" e puo' essere "Speech" o "Udi" o "Rdi" o "3.1 kHz Audio" o "Udi_Ta" o "Video"; zzz = tipo della connessione e puo' essere "TR" o "VtoC" o "CtoV" o "CtoC"o "DATA" o "Clus"; s1 = indirizzo chiamato; s2 = indirizzo chiamante; s3 = sub-indirizzo chiamato; s4 = sub-indirizzo chiamante(?); s5 = valore del campo "MPX".
Ec-CallFailRx ID:xxx CODE:yy | Cluster: Call fail received. [ ricevuta. Where: xxx = identiifcation of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Ec-CallFailTx ID:xxx CODE:yy | Cluster: Call fail sent. [inviata. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Ec-AlertRx ID:xxx | Cluster: Alert received. [ricevuto. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
Ec-AlertTx ID:xxx | Cluster: Alert sent. [inviato. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
Ec-ConnRx ID:xxx | Cluster: Call connect received. [ricevuta. Where: xxx = identiifcation of the connection. [Dove: xxx = identificativo della connessione.
Ec-ConnTx ID:xxx MPX:yy | Cluster: Call connect sent. [inviata. Where: xxx = identification of the connection; yy = "MPX" field. [Dove: xxx = identificativo della connessione; yy = campo "MPX".
Ec-DiscRx ID:xxx CODE:yy | Cluster: Disc request received. [ricevuta. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Ec-DiscTx ID:xxx CODE:yy | Cluster: Disc request sent. [inviata. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Ec-DiscConfRx ID:xxx | Cluster: Disc confirm received. [ricevuta. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
Ec-DiscConfTx ID:xxx | Cluster: Disc confirm sent. [inviata. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
Ec-CallCancelledRx ID:xxx | Cluster: Call cancel received. [ricevuta. Where: xxx = iddentification of the connection. [Dove: xxx = identificativo della connessione.
Ec-CancelCallTx ID:xxx CODE:yy | Cluster: Call cancel sent. [inviata. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Ec-Routing Match ID:xxx PR:yy | Cluster: appropriate routeing identified. [Cluster: identificato il routing appropriato. Where: xxx = identification of the connection; yy = priority of the routeing. [Dove: xxx = identificativo della connessione; yy = priorita' del routing.
Ec-Without Routing ID:xxx | Cluster: the search for the routeing has been unsuccessful. [Cluster: la ricerca del routing e' fallita. Where: xxx = identification of the connection. Dove: xxx = identificativo della connessione.
Ec-Routing Fail ID:xxx PR:yy | Cluster: The routeing used has been unsuccessful. [Cluster: il routing utilizzato non ha avuto successo. Where: xxx = identification of the connection; yy = priority of the routeing. [Dove: xxx = identificativo della connessione; yy = priorita' del routing.
Ec-Routing Fail ID:xxx PR:yy, search next | Cluster: the routeing utilised has not been successful, so another route is being sought. [Cluster: il routing utilizzato non ha avuto successo, si procede alla ricerca di un altro routing. Where: xxx = identification of the connection; yy = priority of the routeing. [Dove: xxx = identificativo della connessione; yy = priorita' del routing.
Ec-Without Cluster Routing ID:xxx | Cluster: the appropriate routeing does not exist. [Cluster: il routing appropriato non esiste. Where: xxx = identification of the connection. [Dove: xxx = identificativo della connessione.
Ec-PlxFailure ID:xxx CODE:yy | Cluster: the VtoC or CtoC call with ID:xxx has failed owing to a problem on the PLINK destination port. [Cluster: La chiamata VtoC o CtoC con ID:xxx e' fallita a causa di un problema sulla porta PLINK di destinazione. Where: xxx = identification of the connection; yy = "Cause" field. [Dove: xxx = identificativo della connessione; yy = campo "Cause".
Eir-MXPC exceeded | The maximum number of "anticipated" connections has been exceeded, i.e. connections which have not yet achieved the "CONNECTED" status. If necessary, increase the "MPX" parameter in the EIR port. [Superato il numero massimo di connessioni "pendenti", connessioni che non hanno ancora raggiunto lo stato "CONNECTED". Se necessario aumentare il parametro "MXPC" nella porta EIR.

Messages on the front panel display top

Lcd messages
Figure 1. Use of the keys and the display LCD.

Table 16. Messages of the status of the ports shown on the LCD display.
Messagge | Description
Pxxx SSSS TTTT | Generic message of the status relating to the majority of the drivers. [Messaggio generico di stato relativo alla maggioranza dei driver. Where: xxx = port which the message refers to; SSSS = status of the driver; TTTT = type of driver. [Dove: xxx = porta cui si riferisce il messaggio; SSSS = stato del driver; TTTT = tipo del driver.
Pxxx SSyz SYNC | Message of the status relating to the SYNC driver. [Messaggio di stato relativo al driver SYNC. Where: xxx = SYNC port which the message refers to; SS = status of the SYNC driver; y = status of the DCD signal; z = status of the DTR signal. [Dove: xxx = porta SYNC cui si riferisci il messaggio; SS = stato del driver SYNC; y = stato del segnale DCD; z = stato del segnale DTR.
Pxxx YYZZ EPLAPB | Message of the status relating to the ISDN Primary Rate driver (EPLAPB). [Messagio di stato relativo al driver ISDN Primary Rate (EPLAPB). Where: xxx = EPLAPB port which the message refers to; yy = status of the Sapi Q931; ZZ = status of the Sapi X25. [Dove: xxx = porta EPLAPB cui il messaggio si riferisce; YY = stato del Sapi Q931; ZZ = stato del Sapi X25.
Pxxx YYZZ MLM | Message of the status relating to the MLM driver. [Messagio di stato relativo al driver MLM. Where: xxx = MLM port which the message refers to; yy = status of the P-Link; ZZ = status of the S-Link. [Dove: xxx = porta MLM cui il messaggio si riferisce; YY = stato del P-Link; ZZ = stato del S-Link.
Pxxx YYZZ SNTP | Message of the status relating to the MLM driver. [Messagio di stato relativo al driver MLM. Where: xxx = SNTP port which the message refers to; yy = status of the Server; ZZ = status of the client. [Dove: xxx = porta SNTP cui il messaggio si riferisce; YY = stato del Server; ZZ = stato del Client.
Pxxx SSyz PAD | Message of the status relating to the PAD driver. [Messaggio di stato relativo al driver PAD. Where: xxx = PAD port which the message refers to; SS = status of asynchronous level 1; y = status of the DCD signal; z = status of the DTR signal. [Dove: xxx = porta PAD cui si riferisci il messaggio; SS = stato del livello 1 asincrono; y = stato del segnale DCD; z = stato del segnale DTR.
Table 17. Alarm messages of the ports, as shown on the LCD display. Tabella 10. Messaggi di allarme delle porte visualizzati sul display LCD.
Message | Description
Pxxx LAPB WT | Alarm on the LAPB "xxx" port. Driver in WAITING status. [Allarme sulla porta LAPB "xxx": driver in stato WAITING.
Pxxx IPRTR X25WT | Alarm on the IPRTR "xxx" port. One or more IP ports in status X25-WAITING (only for IP ports of type X25BSVC). [Allarme sulla porta IPRTR "xxx": una o piu' porte IP in stato X25-WAITING (solo per porte IP di tipo X25BSVC).
Pxxx SDLC PU ST | Alarm on the SDLC "xxx" port. One or more Physical Units in the status STOPPED (only BSVC channels). [Allarme sulla porta SDLC "xxx": una o piu' Physical Unit in stato STOPPED (solo canali BSVC).
Pxxx HDLCT ST | Alarm on HDLCT "xxx" port. Driver in STOPPED status (only for BSVC channnels). [Allarme sulla porta HDLCT "xxx": driver in stato STOPPED (solo per canali BSVC).
Pxxx MLM XX YYYY | Alarm on MLM "xxx" port. Where XX is the status of the P-Link and YYYY is the status of the S-Link. [Allarme sulla porta MLM "xxx": Dove XX e' lo stato del P-Link e YYYY e' lo stato del S-Link.


X.25 disconnection codes

ITU X.25 codes
Abilis internal X.25 codes

ITU (formerly CCITT) X.25 codes top

Table 1. ITU X.25 cause codes
Cause ( Hex ) | Meaning
 | CAUSES OF DISCONNECTION
00 | CLR DTE - Originating from DTE
01 | CLR OCC - Called address busy
03 | CLR INV - Request for facility not valid
05 | CLR NC - Network congestion
09 | CLR DER - Called address out of order
0B | CLR NA - Access not allowed
0D | CLR NP - Inexistent called address
11 | CLR RPE - Error in X.25 procedure at the remote end
13 | CLR ERR - Error in X.25 procedure at the local end
15 | RPOA out of service
19 | CLR RC -The called address does not accept taxation on its charge
21 | Incompatible destination
29 | "Fast Select" option not available for the called address
39 | Ship missing (only for mobile marine services)
 | RESET CAUSES
00 | RES DTE - Originating from DTE
01 | RES DOWN - Remote DTE out of service (only PVC)
03 | RES RPE - Remote DTE caus an X.25 procedure error
05 | RES ERR - Local DTE cause an X.25 procedure error
07 | RES NC - Network congestion
09 | RES UP - Remote DTE operative (only PVC)
0F | RES UP - Network resumes service (only PVC)
11 | Incompatible destination
1D | RES DOWN - Network out of service (only PVC)
 | RESTART CAUSES
00 | Originating from DTE
01 | Local procedure error
D7 | Network operational

Table 2. ITU X.25 diagnostic codes
Diag. ( Hex ) | Meaning
00 | No additional information
01 | P(S) not valid
02 | P(R) not valid
10 | INVALID packet
11 | Type of packet not valid for rl state
12 | Type of packet not valid for r2 state
13 | Type of packet not valid for r3 state
14 | Type of packet not valid for p1 state
15 | Type of packet not valid for p2 state
16 | Type of packet not valid for p3 state
17 | Type of packet not valid for p4 state
18 | Type of packet not valid for p5 state
19 | Type of packet not valid for p6 state
1A | Type of packet not valid for p7 state
1B | Type of packet not valid for d1 state
1C | Type of packet not valid for d2 state
1D | Type of packet not valid for d3 state
20 | PACKET DISALLOWED
21 | packet disallowed: unidentified packet
22 | packet disallowed: call request received on OSVC
23 | packet disallowed: type of packet not valid for PVC
24 | packet disallowed: packet for an unassigned logical channel
25 | packet disallowed: Reject not allowed
26 | packet disallowed: packet too short
27 | packet disallowed: packet too long
28 | packet disallowed: GFI (General Format Identifier) not valid
29 | packet disallowed: restart with GFI different from zero
2A | packet disallowed: type of packet not compatible with the registered facility
2B | packet disallowed: interrupt confirmation not authorised
2C | packet disallowed: interrupt not authorised
2D | packet disallowed: reject not authorised
30 | TIMER EXPIRED
31 | Timer expired: for call request
32 | Timer expired: for clear indication
33 | Timer expired: for reset indication
34 | Timer expired: for restart indication
40 | CALL SET-UP PROBLEMS
41 | Call-setup problems: facility or registration code not permitted
42 | Call-setup problems: parameter of the facility not permitted
43 | Call-setup problems: called address not valid
44 | Call-setup problems: caller's address
45 | Call-setup problems: length of facility or registration not valid
46 | Call-setup problems: incoming calls barred
47 | Call-setup problems: no logical channel available
48 | Call-setup problems: call collision
49 | Call-setup problems: facility request duplicated
4A | Call-setup problems: length of the address different to zero
4B | Call-setup problems: length of the facility different to zero
4C | Call-setup problems: facility was not supplied when expected
4D | Call-setup problems: format of the facility specified by DTE not compatible with CCITT
50 | VARIOUS
51 | Various: incorrect cause code generated by DTE
52 | Various: byte not aligned
53 | Various: Q-bit setting meaningless
70 | INTERNATIONAL PROBLEMS
71 | International problems: problems of the remote network
72 | International problems: problems of protocol at international level
73 | International problems: international link not in service
74 | International problems: international link busy
75 | International problems: problem of the facility on the transit network
76 | International problems: problem of the facility on the destination network
77 | International problems: problems on the international routings
78 | International problems: temporary routing problems
79 | International problems: the DNIC being called is not recognized
7A | International problems: maintenance in progress

Abilis CPX internal codes top

At the startup of Abilis CPX all the sessions are initialised with the code FO, BO, visible by the D_C and D_CE commands, subsequently the code of the last disconnection will be indicated.

The internal disconnection codes caused by errors in the X.25 procedure, have as cause and diagnostic the values provided by CCITT.

Internal disconnection codes which are not caused by errors in the X.25 procedure, have FO as the cause (see also the parameter MCAU in the port parameters) and the appropriate value for the error identification.

Some of these diagnostic codes are of considerable importance to the installer and the user of Abilis CPX, while others are important for technical assistance of the retailer and the producer.

Table 3. Abilis CPX internal codes
Cause ( hex ) | Diag. ( hex ) | Meaning
F0 | 90 | IP Router: no IP port has been recognized.
F0 | 91 | IP Router: IP port busy.
F0 | 92 | IP Router: closure caused by an INIT command of the IP port.
F0 | 93 | IP Router: closure due to inactivity time-out - only for BSVC.
F0 | 94 | TCP: closure due to expiry of the time-out, the number of retransmissions of the segment has reached the limit.
F0 | 95 | TCP: closure due to a reset.
F0 | 96 | TELNET: sessions of the TCP port exhausted.
F0 | 97 | TELNET: The fields received for address calling and address being called differ from the ones configured. The connection is refused.
F0 | 98 | TCP: Retries exceeded.
F0 | 99 | TCP: Call refused.
F0 | 9A | XTP: Error in protocol.
F0 | 9B | XTP: Call collision in one session.
F0 | A0 | No routing is satisfactory for the call.
F0 | A1 | Sessions on the destination port exhausted.
F0 | A2 | Closure following a RESTART SYSTEM or the command C C PO:x SES.y.
F0 | A3 | Cause and detection not available in the "CLEAR" or "RESET" packets received.
F0 | A4 | Dictionaries exhausted: impossible to activate a compressed logical channel.
F0 | A5 | The destination port is out of service (OSI LEVEL 1).
F0 | A6 | The destination port is out of service (OSI LEVEL 2).
F0 | A7 | X25: the destination port is out of service (OSI LEVEL 3).
F0 | A8 | The destination port does not exist. In the routing there is a POO that either does not exist or could not be used in order to prevent an undesired call loopback.
F0 | A9 | Call collision in one session
F0 | AA | Compression protocol not compatible.
F0 | AC | SVC: unexpected internal code.
F0 | AD | PVC: unexpected internal code
F0 | AE | Access password to the control port not valid.
F0 | B0 | Value assigned at the system startup.
F0 | B1 | Obsolete.
F0 | B2 | Obsolete.
F0 | B3 | Channels exhausted.
F0 | B4 | Impossible to carry out compression between two USER ports or two NETWORK ports.
F0 | B5 | Maximum number of attempts to connect with alternative routings, has been reached.
F0 | BE | Obsolete.
F0 | BF | Obsolete.
F0 | C0 | Generic software error during the compression or expansion phases.
F0 | C1 | Error in the compression phase.
F0 | C2 | Error in the expansion phase.
F0 | C3 | Format of the compressed data not valid.
F0 | C4 | Obsolete.
F0 | C5 | Obsolete.
F0 | C6 | HDLCT: disconnection as consequence of a ;RESET occurred between the two HDLCT ports.
F0 | C7 | An internal error caused the compression module to be reinitialised
F0 | C8 | Internal code not provided for the commands SEND/RECEIVE.
F0 | C9 | QLLC, MBIT, MBITB compressions: disconnection as consequence of a RESET received on the compressed channel.
F0 | CA | Obsolete.
F0 | CB | Obsolete.
F0 | CC | Obsolete.
F0 | CD | Obsolete.
F0 | CE | Obsolete.
F0 | CF | Obsolete.
F0 | D0 | Regular disconnection caused by the SHM feature.
F0 | D1 | SDLC, HDLCT: ;the received frame is too long (greater than N1)
F0 | D2 | Obsolete
F0 | D3 | SDLC/QLLC: ;received a too long sequence of X25 packets with M-bit= 1 (greater than N1-2).
F0 | D4 | SDLC: the PU being addressed is already in use.
F0 | D5 | SDLC: the PU being addressed is not configured or does not exist.
F0 | D6 | SDLC: the PU has received an X.25 reset packet while in an "ACTIVE" state (state 5, NRM) and forced the closure.
F0 | D7 | SDLC: the secondary PU has not received polling for a period longer than "INACT".
F0 | D8 | SDLC: the primary PU, in an "ACTIVE" state, has exceeded frame retransmission attempts.
F0 | D9 | SDLC: the secondary PU has sent an FRMR frame.
F0 | DA | SDLC: the primary PU has received an FRMR frame.
F0 | DB | SDLC/QLLC: the PU has received an invalid X.25/QLLC sequence.
F0 | E0 | Obsolete.
F0 | E1 | Obsolete.
F0 | E2 | Obsolete.
F1 | A0 | Simulator: closure caused by the receipt of a packet longer than MXPS.
F1 | A1 | Simulator: closure caused by the receipt of a too long M-bit sequence.
F1 | A2 | Simulator: closure caused by the receipt of a too short M-bit sequence.
F1 | A3 | Simulator: closure due to an error noted in the comparison between the frames sent and received.
F1 | A4 | Simulator: regular closure due to expiry of the configured time out.
F1 | A5 | Simulator: generic regular closure.


Commands relating to the Connection Oriented Router

SVC Routing
PVC Connections
COR Connections

Other commands

SVC Routing top

A R | Add Routing (Administrator)
 | A R PR:xx [par:val]

It adds a new routing with "PR:xx" priority and, eventually, it sets the indicated parameters to the specified values.

There can be up to 100 routing definitions in the SVC routing table, therefore the priority value indicated must be in the interval [0 - 99].

If a routing with "PR:xx" priority already exists in the table and a new routing with the same priority is going to be added, then the new one's priority will be incremented by one (PR:xx+1).

If the new "PR:xx" value is higher than the maximum value already existing, then new routing priority will be the maximum one incremented by one.

If the table is full and a new routing is going to be added, then an error message will be displayed "ROUTING TABLE IS FULL, COMMAND NOT EXECUTED"

Changes made on the SVC routing table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C R | Clear Routing (Administrator)
 | C R PR:xx

It remove from the table that routing, whose priority is "PR:xx". Priority value must be in the interval [0 - 99]. Routings, whose priority is higher than the deleted one, are decremented by one, so that the table is still contiguous.

If the indicated priority does not match an already existing routing, the following message will be displayed "ROUTING NOT PRESENT".

Changes made on the SVC routing table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D R | Display Routing (User)
 | D R D R PR:xx

It shortly displays the SVC routing table. This short description will not display information about parameters whose values are the default ones. They will be only displayed if their values have been changed from the default ones. In such way, the description of single routing is simply contained in a row.

Here is an example of the information shown by the command execution:

[15:19:51] ABILIS_CPX: D R

- Not Saved (SAVE CONF) -------------------------------------------------------

---+----+----+----+---------------+---------------+------------+--------------
PR |COMP|POI |POO |CDI            |CDO            |UDI         |UDO
   |NEXT|         |CGI            |CGO            |PIDI        |PIDO
   |              |IPSRC          |IPDEST         |FFO
------------------------------------------------------------------------------
0   NO   *    0    *01             *               CP           *
------------------------------------------------------------------------------
1   NO   *    0    *               *               CP           *
------------------------------------------------------------------------------
2   NO   301  302  *               *               *            *
------------------------------------------------------------------------------
3   NO   302  301  *               *               *            *
------------------------------------------------------------------------------
4   NO   920  900  *               920             *            *
    NO             920001          *               *            *
------------------------------------------------------------------------------
5   NO   921  900  *               921             *            *
    NO             921001          *               *            *
------------------------------------------------------------------------------
6   NO   907  907  999             23760272        *            *
    NO             *               *               *            01000000
                   *               192.168.000.253 *
------------------------------------------------------------------------------
7   NO   907  907  999             *               *            *
    NO             *               *               *            01000000
                   *               192.168.000.252 *
------------------------------------------------------------------------------
8   NO   900  921  921             *               *            *
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the priority will be omitted, the execution of this command will display all the routings currently present in the table.

Trough specifying a priority value, the command will show the routing identified by the priority "xx".

Priority value must be in the interval [0 - 99]. If the priority does not match any routing priority in the table, the message "ROUTING NOT PRESENT" will be displayed.

If the routing table is empty, the following message is generated: "ROUTING TABLE IS EMPTY".

For a better description of the information displayed, please refer to Configuration of SVC routings section.

D RE | Display Routing in extended format (User)
 | D RE D RE PR:xx

It shows information about the SVC routing table by an extended format.

Here is an example of the information displayed as a result of the command execution:

[15:19:51] ABILIS_CPX: D RE

- Not Saved (SAVE CONF) -------------------------------------------------------

PR:0   POI:*    POO:0    COMP:NO
NEXT:N CGI:*               CDI:*01             UDI:CP           PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:1   POI:*    POO:0    COMP:NO
NEXT:N CGI:*               CDI:*               UDI:CP           PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:2   POI:301  POO:302  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:3   POI:302  POO:301  COMP:NO
NEXT:N CGI:*               CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

PR:4   POI:920  POO:900  COMP:NO
NEXT:N CGI:920001          CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:920             UDO:*            PIDO:*
       FFO:*

PR:5   POI:921  POO:900  COMP:NO
NEXT:N CGI:921001          CDI:*               UDI:*            PIDI:*
       CGO:*               CDO:921             UDO:*            PIDO:*
       FFO:*

PR:6   POI:907  POO:907  COMP:NO   IPSRC:*               IPDEST:192.168.000.253
NEXT:N CGI:*               CDI:999             UDI:*            PIDI:*
       CGO:*               CDO:23760272        UDO:*            PIDO:01000000
       FFO:*

PR:7   POI:907  POO:907  COMP:NO   IPSRC:*               IPDEST:192.168.000.252
NEXT:N CGI:*               CDI:999             UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:01000000
       FFO:*

PR:8   POI:900  POO:921  COMP:NO
NEXT:N CGI:*               CDI:921             UDI:*            PIDI:*
       CGO:*               CDO:*               UDO:*            PIDO:*
       FFO:*

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the priority will be omitted, the execution of this command will display all the routings currently present in the table.

Trough specifying a priority value, the command will show the routing identified by the priority "xx".

Priority value must be in the interval [0 - 99]. If the priority does not match any routing priority in the table, the message "ROUTING NOT PRESENT" will be displayed.

If the routing table is empty, the following message is generated: "ROUTING TABLE IS EMPTY".

For a better description of the information displayed, please refer to Configuration of SVC routings section.

M R | Move Routing (Administrator)
 | M R PR:xx PR:yy

It changes the routing priority value "xx" to "yy". Therefore the routing position, inside the table, will be changed and the whole table will be sorted again to guarantee its contiguity.

Priority value must be in the interval [0 - 99]. If the priority does not match any routing priority in the table, the message "ROUTING NOT PRESENT" will be displayed.

If the routing table is empty, the following message is generated: "ROUTING TABLE IS EMPTY".

Changes made on the SVC routing table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

S R | Set Routing (Administrator)
 | S R PR:xx par:val [par:val]

It sets to new values the parameters of the routing specified by "PR:xx".

Priority value must be in the interval [0 - 99]. If the priority does not match without any routing priority in the table, the message "ROUTING NOT PRESENT" will be displayed.

If the routing table is empty, the following message is generated: "ROUTING TABLE IS EMPTY".

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the SVC routing table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

PVC Connections top

A PVC | Add PVC (Administrator)
 | A PVC ID:xx [par:val]

It adds a new PVC connection definition with the identifiers "ID:xx". It sets the parameters to their values (if specified).

The not specified parameters are automatically set to the default values. PVC table can store up to 64 connection definitions. The identifier value must be in the interval [0 - 63]. "If ID:xx" already exists in the table, the "ID:" of the connection, that is going to be added, will be incremented by one (ID:xx+1).

If the new "ID:xx" value is higher than the maximum value already existing, then new connection ID will be the maximum one incremented by one.

If the table is full and a new connection is going to be added, then an error message will be displayed "PVC TABLE IS FULL, COMMAND NOT EXECUTED".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C PVC | Clear PVC (Administrator)
 | C PVC ID:xx

It removes from the table the PVC connection specified by "ID:xx".

The identifier value must be in the interval [0 - 63]. If the ID does not match any PVC connection in the table, the message "PVC NOT PRESENT" will be displayed.

If the PVC table is empty, the message "PVC TABLE IS EMPTY" will be displayed.

PVC connections whose "ID:" is higher than the removed one, will be decremented by one. In such way the table is still contiguous.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D PVC | Display PVC (User)
 | D PVC D PVC ID:xx

It shows the PVC connection table.

Here is an example of this command execution:

[16:36:33] ABILIS_CPX: D PVC

- Not Saved (SAVE CONF) -------------------------------------------------------

ID:0   ST:2  POI:301   SESI:1     PWI:2   COMP:NO
             POO:302   SESO:1     PWO:2

ID:1   ST:2  POI:302   SESI:2     PWI:2   COMP:MBIT
             POO:301   SESO:2     PWO:2

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the connection "ID:" is omitted, the command will show all the definitions currently present in the table.

If an "ID:" is specified, then the command will show the connection requested. The identifier value must be in the interval [0 - 63]. If the "ID:" does not match any PVC connection in the table, the message "PVC NOT PRESENT" will be displayed.

If the PVC table is empty, the message "PVC TABLE IS EMPTY" will be displayed.

To have more detailed information about the PVC connections, please refer to Configuration of PVC connections section.

S PVC | Set PVC (Administrator)
 | S PVC ID:xx par:val [par:val]

It sets to new values the parameters of the PVC connection specified by "ID:xx".

The identifier value must be in the interval [0 - 63]. If the ID does not match any PVC connection in the table, the message "PVC NOT PRESENT" will be displayed.

If the PVC table is empty, the message "PVC TABLE IS EMPTY" will be displayed.

In order to activating the new configuration, whatever parameter has been changed, it is NOT needed to restart the Abilis CPX, it is requested only to execute the command C C or R PVC.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is wrong or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

R PVC | Restart PVC (User)
 | R PVC ID:xx

It executes the re-activation of the PVC connection identified by "ID:xx". The identifier value must be in the interval [0 - 63]. If the "ID:" does not match any PVC connection in the table, the message "PVC NOT PRESENT" will be displayed.

If the connection is in the ST:3 state (connection active), the following message will be displayed: "SESSION ALREADY CONNECTED"; if it is in any other state but ST:3 the message "COMMAND EXECUTED" will be shown.

The message "COMMAND EXECUTED" does not guarantee the PVC connection to be actually activated. In fact eventual errors and/or conflicts are detected only in subsequent procedures.

It is reccommended to use the command D PVC to verify the PVC connection state.

COR Connections top

C C | Clear Connection (Administrator)
 | C C PO:xxx SES:yyy

Clear the "SES:yyy" session relating to the "PO:xxx" port. The specified port value must be in the interval [0 - 999], the session value in [1 - 255].

If the session, when the command is going to be executed, is really connected, the following message will be shown: "COMMAND EXECUTED"; if it is not connected this message will he shown: "SESSION NOT CONNECTED".

If the specified session is SVC, then X.25 Clear Request packets, with cause and diagnostic codes F0,A2, will be sent to both communication sessions.

If the session is defined in a PVC connection, this last one will be closed and subsequently opened again. The event "PvcCloseTx" (with cause and diagnostic codes F0,A2) followed by the "PvcOpenTx" will be recorded in the Events Log (Debug Log), for both PVC connection sessions.

If the "SES:yyy" identifier is not in the allowed interval of session defined for that port, the error message "SESSION NOT PRESENT" will be displayed.

The reopening of the PVC connection is carried out reading the parameters from the PVC table, as a result eventual changes are immediately activated.

If during the activation any error and/or parameter conflict occurs, the PVC connection won't be activated and its new state will be ST:1 (i.e. PVC connection not valid).

To activate it again, it is needed to fix the error and execute the command R PVC.

The event "PvcCloseTx" always generates a X.25 Reset packet with cause and diagnostic codes F0,40, without concern what the codes recorded in the Events Log (Debug Log) are.

In the same way the event "PvcOpenTx" always generates a X.25 Reset packet with cause and diagnostic codes F0,00.

D C | Display Connections (User)
 | D C PO:A D C PO:xxx [SES:yyy]

It shows the communication sessions state for the specified port(s), if working (running).

By specifying "D C PO:A", the sessions of all the ports actually working will be displayed.

If it is specified only the port number and the session is omitted, this command will show all the communication sessions for the "PO:xxx" port. Port number must be in the interval [0 - 999].

If the requested port is not present or not working, an error message will be displayed: "PORT NOT PRESENT OR NOT RUNNING".

If the port is not linked (served by) to the Connection Oriented Router, the command will shown this error message: "COMMAND NOT ALLOWED FOR THAT PORT".

By specifying a session value, which has to be in the interval [1 - 255], the command will show only the information relating to the communication session requested.

If the requested session is not present, the following error message will be displayed: "SESSION NOT PRESENT".

To have more detailed description of the shown information, please refer to the supervision functionalities section.

D CE | Display Connections in extended format (User)
 | D CE PO:A D CE PO:xxx [SES:yyy]

It shows the communication sessions state for the specified, if working (running), port(s). Information is displayed by an extended format.

By specifying "D CE PO:A", the sessions of all the ports actually working will be displayed.

If it is specified only the port number and the session is omitted, this command will show all the communication sessions for the "PO:xxx" port. Port number must be in the interval [0 - 999].

If the requested port is not present or not working, an error message will be displayed: "PORT NOT PRESENT OR NOT RUNNING".

If the port is not linked (served by) to the Connection Oriented Router, the command will shown this error message: "COMMAND NOT ALLOWED FOR THAT PORT".

By specifying a session value, which has to be in the interval [1 - 255], the command will show only the information relating to the communication session requested.

If the requested session is not present, the following error message will be displayed: "SESSION NOT PRESENT".

To have more detailed description of the shown information, please refer to the supervision functionalities section.

C CODE | Clear Codes (Administrator)
 | C CODE PO:xxx

It sets the cause and diagnostic codes to the default value (F0,B0) for all the sessions of the specified port (if it is working).
Port number must be in the interval [0 - 999].

If command execution is successful the message "COMMAND EXECUTED" will be displayed.

This command works only on "RUNNING" ports; if they are not in such state an error message, "PORT NOT PRESENT OR NOT RUNNING", will be displayed.

Moreover, the ports, that the command can be executed on, have to be linked the Connection Oriented Router, otherwise the following message will be displayed: "COMMAND NOT ALLOWED FOR THAT PORT".


Commands relating to Cryptography keys

Other commands

A CRKEY | Add Cryptography key (Administrator)
 | A CRKEY:xx VAL:val [DESC:val]

This command adds a new key in the Table of Cryptography Keys.

There can be up to 64 definitions in the table (indexed from 0 to 63). The zero index position is always dedicated to the default cryptography key, automatically provided by the system. The default key can be used whenever the user does not need to define his own private key. Consequently the user defined indexes must be within the interval [1 - 63].

The value of the cryptography keys is set through the obligatory parameter VAL:, which is a strings, made of 8 up to 32 ASCII characters in the range [33..126], spaces are not allowed.
Through the optional parameter DESC:, is also possible to associate descriptions to the cryptography keys for supporting the configuration activities, which is a strings, made of 0 up to 64 ASCII characters in the range [33..126], spaces are not allowed.

warning! If a cryptography key, whose index is "CRKEY:xx", already exists in the table, an error message will be display: "CRYPTOGRAPHY KEY ALREADY EXISTS".

If the table is full and a new key is going to be added, the following error message will be shown: "CRKEY TABLE IS FULL, COMMAND NOT EXECUTED".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C CRKEY | Clear Cryptography key (Administrator)
 | C CRKEY:xx

This command deletes, if present, a cryptography key from the Table of Cryptography Keys.

The index of the cryptography key specified must be in the interval [1 - 63]. The default key, provided by the system, always occupies the zero index position and it cannot be delete by the User.

Warning! If the specified cryptography key is not present in the table, the following error message will be shown: "CRYPTOGRAPHY KEY NOT PRESENT".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D CRKEY | Display Cryptography key (User)
 | D CRKEY D CRKEY:xx

This command shows the content of the Table of Cryptography Keys.

Cryptography keys are stored in memory and saved on disk in a coded way. Once the value of the cryptography key is set, it cannot be shown anymore, so when the table has to be displayed, the key will be masked by a string of eight '*' (asterisk) characters, aside from the actual key length.

If the cryptography key index is omitted, the command shows the key well defined. Entries defined in the Table of Cryptography Keys might not have sequential identifiers, such that the not shown values represent available place in the table.

Here is an example of the command "D CRKEY" execution.

[17:57:29] ABILIS_CPX: D CRKEY

- Not Saved (SAVE CONF) -------------------------------------------------------

CRKEY:  VAL:      DESC:
------------------------------------------------------------------------------
0       ********  Default_encryption/decryption_key
3       ********  Test_cypher_key_1
10      ********  Test_cypher_key_2

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the cryptography key index is specified, the command will display only information about the asked key. The cryptography key specified index must be within the interval [0 - 63].

Here is an example of the command "D CRKEY:3" execution.

[17:57:29] ABILIS_CPX: D CRKEY:3

CRKEY:  VAL:      DESC:
------------------------------------------------------------------------------
3       ********  Test_cypher_key_1

warning! If the specified cryptography key is not defined, the following error message will be shown: "CRYPTOGRAPHY KEY NOT PRESENT".

S CRKEY | Set Cryptography key (Administrator)
 | S CRKEY:xx par:val [par:val]

It sets the value (VAL:) or the description (DESC:) of the specified cryptography key, of course if it is present in the table.

The index of the cryptography key specified must be within the interval [1 - 63]. The default key, provided by the system, always occupies the zero index position: its value and description are fixed and they cannot be modified.

warning! If the key is not defined, the following error message "CRYPTOGRAPHY KEY NOT PRESENT" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.


Commands relating to DHCP

DHCP information summary
DHCP Hosts
DHCP Profiles
DHCP Subnets
DHCP bindings

Other commands

DHCP information summary top

D DHCP | Display DHCP information summary (User)
 | D DHCP

This command shows the current state of the DHCP driver and a summary of the most important DHCP configuration information.

[18:56:27] ABILIS_CPX: D DHCP

DHCP summary:

Service:  INACT  (state of the DHCP driver [DOWN, ACTIVE, INACT])
Subnets:     0   (number of configured subnets [0..128])
Profiles:    1   (number of configured profiles [1..128])
Hosts:       0   (number of hosts configured for static leases [0..500])
Leases:      0   (current number of leases in the Db in memory [100..1000])

Because the service state and the number of leases are available on running Abilis CPX only, in off-line configurator these information will be omitted.

DHCP Hosts top

A DHCP HOST | Add DHCP host by MAC address (Administrator)
 | A DHCP HOST MAC:val [par:val]

This command allows to add a DHPC host definition by the specification of the host's MAC address value. The MAC address value must be in the range [00-00-00-00-00-01..FF-FF-FF-FF-FF-FF].

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

DHCP host configurations don't have consecutive indexes. The new definition will be added in the first position of the table that is currently available and a correspondent numeric identifier will be assigned to the DHCP host.

[12:17:19] ABILIS_CPX: D DHCP HOST

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  1   00-00-00-01-01-01  001.001.001.001  1
  2   00-00-00-21-02-12  001.001.001.002  2
  3   10-10-10-21-02-12  001.001.001.003  3
 10   10-10-10-11-01-11  001.001.001.010  10

[12:17:36] ABILIS_CPX: A DHCP HOST MAC:0-0-0-0-0-2

COMMAND EXECUTED

[12:17:40] ABILIS_CPX: D DHCP HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  1   00-00-00-01-01-01  001.001.001.001  1
  2   00-00-00-21-02-12  001.001.001.002  2
  3   10-10-10-21-02-12  001.001.001.003  3
  4   00-00-00-00-00-02  000.000.000.000  LAN
 10   10-10-10-11-01-11  001.001.001.010  10

As can be seen from the previous example, the new record wasn't added at the end of the table but it was inserted in the position '4', that was the first free one.

If the DHCP Hosts Table is full, i.e. no free record is currently available, the message "DHCP HOSTs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

A DHCP HOST: | Add DHCP host by identifier (Administrator)
 | A DHCP HOST MAC:val [par:val]

This command allows to add a DHPC host definition by the specification of the host's identifier. The specification of the host's MAC address value is also required by the command.

The host identifier must be a numeric value in the range [1..500].

The MAC address value must be in the range [00-00-00-00-00-01..FF-FF-FF-FF-FF-FF].

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

[12:17:42] ABILIS_CPX: A DHCP HOST:5  MAC:2-1-3-1-2-2 PROF:5

COMMAND EXECUTED

DHCP host configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a DHCP host already present in the table the message "DHCP HOST ALREADY EXISTS" will be shown.

If the DHCP Hosts Table is full, i.e. no free record is currently available, the message "DHCP HOSTs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

C DHCP HOST | Clear DHCP host by MAC address (Administrator)
 | C DHCP HOST MAC:val

This command allows to delete from the DHCP Hosts Table all the entries whose MAC address is set to the specified value. The MAC address value must be in the range [00-00-00-00-00-01..FF-FF-FF-FF-FF-FF].

If no entry is found for the specified MAC address, the message "DHCP HOST NOT PRESENT" will be shown.

If the DHCP Hosts Table is currently empty, the message "DHCP HOSTs TABLE IS EMPTY" will be shown.

DHCP host's definition are not kept contiguous in the table, then any deleted entry leaves a free space in the table that will be reused at next DHCP host's definition addition.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

C DHCP HOST: | Clear DHCP host by identifier (Administrator)
 | C DHCP HOST:xxx

This command allows to delete the DHCP host definition corresponding to the specified identifier.

The host identifier must be a numeric value in the range [1..500].

If no entry is found in the specified position of the table, the message "DHCP HOST NOT PRESENT" will be shown.

If the DHCP Hosts Table is currently empty, the message "DHCP HOSTs TABLE IS EMPTY" will be shown.

DHCP host's definition are not kept contiguous in the table, then any deleted entry leaves a free space in the table that will be reused at next DHCP host's definition addition.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

D DHCP HOST | Display DHCP Hosts Table (User)
 | D DHCP HOST [MAC:]

This command displays configured DHCP Hosts.

Here is an example of the information shown by the command execution:

[11:38:42] ABILIS_CPX: D DHCP HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  1   00-00-00-00-00-01  001.001.001.001  LAN
  3   00-00-00-00-00-30  001.001.001.003  1
  4   00-00-00-00-00-02  000.000.000.000  LAN
 10   00-00-00-00-00-01  001.001.001.010  2

The parameter "MAC:" allows to display a sub-set of the currently configured DHCP Hosts by specifying a MAC address value in the range [00-00-00-00-00-01..FF-FF-FF-FF-FF-FF].

[11:41:06] ABILIS_CPX: D DHCP HOST MAC:0-0-0-0-0-1

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  1   00-00-00-00-00-01  001.001.001.001  LAN
 10   00-00-00-00-00-01  001.001.001.010  2

If no DHPC host is currently defined the message "*** NO DHCP HOSTs DEFINED ***" will be displayed.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the displayed information, please refer to the Configuration of DHCP Hosts section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

D DHCP HOST: | Display DHCP host (User)
 | D DHCP HOST:xxx D DHCP HOST:A

This command displays a DHCP host configuration.

The host identifier must be a numeric value in the range [1..500].

Here is an example of the information shown by the command execution:

[11:26:34] ABILIS_CPX: D DHCP HOST:3

HOST:|MAC:              |IP:             |PROF:
-------------------------------------------------------------------------------
  3   00-00-00-00-00-03  001.001.001.003  1

By specifying "HOST:A", the command will display all configured DHCP Hosts.

If no DHPC host is currently defined the message "*** NO DHCP HOSTs DEFINED ***" will be displayed.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the displayed information, please refer to the Configuration of DHCP Hosts section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

S DHCP HOST: | Set DHCP host by identifier (Administrator)
 | S DHCP HOST:xxx par:val [par:val]

This command sets all the indicated parameters of the requested DHCP host entry to the specified values.

The host identifier must be a numeric value in the range [1..500].

If no entry is found in the specified position of the table, the message "DHCP HOST NOT PRESENT" will be shown.

If the DHCP Hosts Table is currently empty, the message "DHCP HOSTs TABLE IS EMPTY" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other,starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the DHCP Hosts Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the DHCP host's definition parameters, please refer to the Configuration of DHCP Hosts section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

DHCP Profiles top

A DHCP PROF: | Add DHCP profile (Administrator)
 | A DHCP PROF:xxx [par:val]

This command allows to add a new DHCP profile defintion to the DHCP Profiles Table.

The profile identifier must be a numeric value in the range [1..128].

DHCP profile configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a DHCP profile already present in the table the message "DHCP PROFILE ALREADY EXISTS" will be shown.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

[18:33:39] ABILIS_CPX: A DHCP PROF:5 NAME:This_is_the_name_of_profile_5

COMMADN EXECUTED

[18:35:50] ABILIS_CPX: D DHCP PROF

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

PROF: |NAME:
-------------------------------------------------------------------------------
  0    Default_profile
  5    This_is_the_name_of_profile_5

If the DHCP Profiles Table is full, i.e. no free record is currently available, the message "DHCP PROFILEs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the DHCP Profiles Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

C DHCP PROF: | Clear DHCP profile (Administrator)
 | C DHCP PROF:xxx[,yyy,...]

This command remove the specified entries from the DHCP profile table.

The profile identifier must be a numeric value in the range [1..128]. More values can be specified separating them with the ',' (comma) characters without spaces.

If no entry is found in the specified position of the table, the message "DHCP PROFILE NOT PRESENT" will be shown.

The default profile, i.e. the one with index 0 cannot be deleted.

[18:33:42] ABILIS_CPX: C DHCP PROF:0

DEFAULT DHCP PROFILE CANNOT BE DELETED

DHCP profile definitions are not kept contiguous in the table, then any deleted entry leaves a free space in the table that will be reused at next DHCP profile definition addition.

Changes made on the DHCP Profiles Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

D DHCP PROF | Display DHCP profile summary (User)
 | D DHCP PROF

This command shows synthetically the current content of the DHCP Profiles Table. Only NAME: parameter is displayed for every entry of the table.

Here is an example of the information shown by the command execution:

[18:35:50] ABILIS_CPX: D DHCP PROF

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

PROF: |NAME:
-------------------------------------------------------------------------------
  0    Default_profile
  5    This_is_the_name_of_profile_5

Changes made on the DHCP Profiles Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

D DHCP PROF: | Display DHCP profile details (User)
 | D DHCP PROF:xxx[,yyy,...]

This command displays DHCP profile configuration(s) in an extended format.

The profile identifier must be a numeric value in the range [0..128]. More values can be specified separating them with the ',' (comma) characters without spaces.

If no entry is found in the specified position of the table, the message "DHCP PROFILE NOT PRESENT" will be shown.

Because every DHCP profile entry has several parameters, to keep the visualization as short as possible, the command doesn't display information about parameters set to their default values. Such information is displayed only if the parameters are set to not default values.

Here is an example of the information shown by the command execution:

[15:00:45] ABILIS_CPX: D DHCP PROF:5

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
PROF:          5
NAME:          This_is_the_name_of_profile_5
GW1:           192.168.000.253
TIME:          001.001.001.001
-------------------------------------------------------------------------------

By specifying "PROF:A", the command will display all configured DHCP Profiles.

[15:00:45] ABILIS_CPX: D DHCP PROF:A

Parameter     |Value
-------------------------------------------------------------------------------
PROF:          0
NAME:          Default_profile
-------------------------------------------------------------------------------
PROF:          1
NAME:
-------------------------------------------------------------------------------
PROF:          5
NAME:          This_is_the_name_of_profile_5
GW1:           192.168.000.253
TIME:          001.001.001.001
-------------------------------------------------------------------------------

Changes made on the DHCP Profiles Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the displayed information, please refer to the Configuration of DHCP Profiles section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

S DHCP PROF: | Set DHCP profile (Administrator)

This command sets all the indicated parameters of the requested DHCP profile entries to the specified values.

The profile identifier must be a numeric value in the range [0..128]. More values can be specified separating them with the ',' (comma) characters without spaces.

If no entry is found in the specified position of the table, the message "DHCP PROFILE NOT PRESENT" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other,starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the DHCP Profiles Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the DHCP profile's parameters, please refer to the Configuration of DHCP Profiles section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

DHCP Subnets top

A DHCP LAN | Add DHCP subnet by Network address/mask (Administrator)
 | A DHCP LAN NET:val [MASK:val] [par:val]

This command allows to add a new DHCP subnet definition by the specification of the Network address and mask values.

The Network address must be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The Network mask must be a value that contains sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one. It can be expressed either together with the Network address value, by a decimal value preceded by the '/' character, or it can be expressed in Dotted Decimal Notation, using the "MASK:" parameter. In this last case the valid range is [0.0.0.0, 128.0.0.0-255.255.255.252].

Doing the "logical AND" between Network address and mask values, the result should be the Network address value itself; if not the message "INVALID VALUE" will be shown and the new definition addition will be refused.

The subnet identified by Network address and mask values must be unique among all subnets records currently configured.
If the value already exist in the table, the message "DHCP SUBNET ALREADY EXIST" will be shown.

Here are two examples of the syntaxes accepted by the command for Network address and mask values specifications:

[14:49:09] ABILIS_CPX: A DHCP LAN NET:192.0.123.0/24

COMMAND EXECUTED

[14:52:13] ABILIS_CPX: A DHCP LAN NET:192.168.0.0 MASK:255.255.255.0

COMMAND EXECUTED

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

DHCP subnet configurations don't have consecutive indexes. The new definition will be added in the first position of the table that is currently available and a correspondent numeric identifier will be assigned to the DHCP subnet.

[15:27:47] ABILIS_CPX: D DHCP LAN

LAN: |NET:            |MASK:
-------------------------------------------------------------------------------
  2   192.000.123.000  255.255.255.000
  3   192.168.000.000  255.255.255.000
  4   001.001.001.001  255.255.255.255

[15:27:49] ABILIS_CPX: A DHCP LAN NET:1.1.1.2/32

COMMAND EXECUTED

[15:27:54] ABILIS_CPX: D DHCP LAN

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

LAN: |NET:            |MASK:
-------------------------------------------------------------------------------
  1   001.001.001.002  255.255.255.255
  2   192.000.123.000  255.255.255.000
  3   192.168.000.000  255.255.255.000
  4   001.001.001.001  255.255.255.255

As can be seen from the previous example, the new record wasn't added at the end of the table but it was inserted in the position '1', that was the first free one.

If the DHCP Subnets Table is full, i.e. no free record is currently available, the message "DHCP SUBNETs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

A DHCP LAN: | Add DHCP subnet by identifier (Administrator)
 | A DHCP LAN:xxx [par:val]

This command allows to add a DHPC subnet definition by the specification of the subnet's identifier.

The subnet identifier must be a numeric value in the range [1..128].

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

[12:17:42] ABILIS_CPX: A DHCP LAN:10 NAME:MyLan

COMMAND EXECUTED

DHCP subnet configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a DHCP subnet already present in the table the message "DHCP SUBNET ALREADY EXISTS" will be shown.

If the DHCP Subnets Table is full, i.e. no free record is currently available, the message "DHCP SUBNETs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

C DHCP LAN | Clear DHCP subnet by Network address/mask (Administrator)
 | C DHCP LAN NET: [MASK:]

This command allows to delete the DHCP subnet definition by specifying the corresponding Network address and mask values.

The Network address must be expressed in Dotted Decimal Notation. The Network mask can be expressed either together with the Network address value, by a decimal value preceded by the '/' character, or it can be expressed in Dotted Decimal Notation, using the "MASK:" parameter.

Each DHCP subnet is unambiguously identified by its Network address and mask values. If no entry is found for the specified Network address and mask values, the message "DHCP SUBNET NOT PRESENT" will be shown.

If the DHCP Subnets Table is currently empty, the message "DHCP SUBNETs TABLE IS EMPTY" will be shown.

DHCP subnet's definition are not kept contiguous in the table, then any deleted entry leaves a free space in the table that will be reused at next DHCP subnet's definition addition.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

C DHCP LAN: | Clear DHCP subnet by identifier (Administrator)
 | C DHCP LAN:xxx[,yyy,...]

This command allows to delete the DHCP subnet definition(s) corresponding to the specified identifier(s).

The subnet identifier must be a numeric value in the range [1..128]. More values can be specified separating them with the ',' (comma) characters without spaces.

If no entry is found in the specified position of the table, the message "DHCP SUBNET NOT PRESENT" will be shown.

If the DHCP Subnets Table is currently empty, the message "DHCP SUBNETs TABLE IS EMPTY" will be shown.

DHCP subnet's definition are not kept contiguous in the table, then any deleted entry leaves a free space in the table that will be reused at next DHCP subnet's definition addition.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

D DHCP LAN | Display DHCP Subnets Table summary (User)
 | D DHCP LAN [NET: [MASK:]]

This command shows synthetically the current content of the DHCP Subnets Table. Only NET: and MASK: parameters are displayed for every entry of the table.

Here is an example of the information shown by the command execution:

[15:00:45] ABILIS_CPX: D DHCP LAN

LAN: |NET:            |MASK:
-------------------------------------------------------------------------------
  1   192.000.123.000  255.255.255.000
  5   192.168.000.000  255.255.255.000

Each DHCP subnet is unambiguously identified by its Network address and mask values. By specifying a couple of values of Network address and mask, the corresponding entry is shown.
If no entry is found for the specified Network address and mask values, the message "DHCP SUBNET NOT PRESENT" will be shown.

If no DHPC subnet is currently defined the message "*** NO DHCP SUBNETs DEFINED ***" will be displayed.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the displayed information, please refer to the Configuration of DHCP Subnets section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

D DHCP LAN: | Display DHCP subnet (User)
 | D DHCP LAN:xxx[,yyy,...] D DHCP LAN:A

This command displays DHCP subnet configuration(s) in an extended format.

The subnet identifier must be a numeric value in the range [1..128]. More values can be specified separating them with the ',' (comma) characters without spaces.

If no entry is found in the specified position of the table, the message "DHCP SUBNET NOT PRESENT" will be shown.

Because every DHCP subnet entry has several parameters, to keep the visualization as short as possible, the command doesn't display information about parameters set to their default values. Such information is displayed only if the parameters are set to not default values.

Here is an example of the information shown by the command execution:

[15:00:45] ABILIS_CPX: D DHCP LAN:5

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
LAN:           5
NAME:          The name of this subnet is LOCAL-LAN
NET:           192.168.0.0/24
MASK:          255.255.255.0
POOL1:         192.168.0.10:192.168.0.254
DEF-LEASE:     36000
MAX-LEASE:     36000
PROF:          5 (Local lan 192.168.0.0/24)

By specifying "LAN:A", the command will display all configured DHCP subnets.

[15:00:45] ABILIS_CPX: D DHCP LAN:A

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter     |Value
-------------------------------------------------------------------------------
LAN:           1
NAME:          This is LAN in San Petersburg
NET:           192.0.123.0/24
MASK:          255.255.255.0
POOL1:         192.0.123.10:192.0..123.254
DEF-LEASE:     36000
MAX-LEASE:     36000
-------------------------------------------------------------------------------
LAN:           2
NAME:
NET:           001.001.001.002/32
MASK:          255.255.255.255
-------------------------------------------------------------------------------
LAN:           5
NAME:          The name of this subnet is LOCAL-LAN
NET:           192.168.0.0/24
MASK:          255.255.255.0
POOL1:         192.168.0.10:192.168.0.254
DEF-LEASE:     36000
MAX-LEASE:     36000
PROF:          5 (Local lan 192.168.0.0/24)
-------------------------------------------------------------------------------
LAN:           10
NAME:          MyLan
-------------------------------------------------------------------------------

If the DHCP Subnets Table is currently empty, the message "DHCP SUBNETs TABLE IS EMPTY" will be shown.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the displayed information, please refer to the Configuration of DHCP Subnets section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

S DHCP LAN | Set DHCP subnet by Network address/mask (Administrator)
 | S DHCP LAN NET:val [MASK:val] par:val [par:val]

This command sets all the indicated parameters of the requested DHCP subnet entry to the specified values.

The DHCP subnet definition is specified by Network address and mask values.

The Network address must be expressed in Dotted Decimal Notation. The Network mask can be expressed either together with the Network address value, by a decimal value preceded by the '/' character, or it can be expressed in Dotted Decimal Notation, using the "MASK:" parameter.

Each DHCP subnet is unambiguously identified by its Network address and mask values. If no entry is found for the specified Network address and mask values, the message "DHCP SUBNET NOT PRESENT" will be shown.

If the DHCP Subnets Table is currently empty, the message "DHCP SUBNETs TABLE IS EMPTY" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other,starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the DHCP subnet's parameters, please refer to the Configuration of DHCP Subnets section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

S DHCP LAN: | Set DHCP subnet by identifier (Administrator)
 | S DHCP LAN NET:val [MASK:val] par:val [par:val]

This command sets all the indicated parameters of the requested DHCP subnet entry to the specified values.

The subnet identifier must be a numeric value in the range [1..128].

If no entry is found in the specified position of the table, the message "DHCP SUBNET NOT PRESENT" will be shown.

If the DHCP Subnets Table is currently empty, the message "DHCP SUBNETs TABLE IS EMPTY" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other,starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the DHCP Subnets Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the DHCP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

For a more detailed description of the DHCP subnet's parameters, please refer to the Configuration of DHCP Subnets section of DHCP Hosts, DHCP Profiles and DHCP Subnets Tables.

DHCP bindings top

C DHCP BIND | Clear DHCP binding (Administrator)
 | C DHCP BIND IP:val C DHCP BIND IP:A

This command allows to remove a DHCP binding entry from the DHCP bindings table identified by the specified IP address.

The IP address must be expressed in Dotted Decimal Notation

By specifying "IP:A", the command will delete all the entries that are currently present in the DHCP bindings table.

[19:19:52] ABILIS_CPX: C DHCP BIND IP:A

YOU ARE GOING TO DELETE THE WHOLE CONTENT OF THE DHCP BINDINGS DB IN MEMORY.
DO YOU WANT TO PROCEED (Y/N)? Y

COMMAND EXECUTED

D DHCP BIND | Display DHCP bindings summary (User)
 | D DHCP BIND [IP:val] [PROF:val]

This command displays DHCP binding(s) in a synthetic format.

[19:07:12] ABILIS_CPX: D DHCP BIND

------------------+----------------+------+-----------------+------------------
MAC:              |IP              |PROF: |Last request(GMT)|Expiry on(GMT)
------------------+----------------+------+-----------------+------------------
11-11-23-11-11-11  192.168.000.123    128  20/12/2002 10:10  29/12/2002 10:10
11-11-23-11-11-11  010.010.010.005     21  20/12/2002 10:16  21/11/2002 10:16 E
11-11-23-11-11-15  192.168.000.150   NONE  20/12/2002 10:20  23/12/2002 10:10
11-11-23-11-11-12  192.168.000.124      5  20/12/2002 10:30  21/11/2002 10:30 E
11-11-23-11-11-12  192.168.000.124      5  20/12/2002 10:40  23/12/2002 10:10

By the "IP:" parameter, it is possible to display all the entries that match the specified value. The "IP:" parameter can be a single IP address or two IP addresses separated by ':'(colon) (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100). IP address(es) must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

By the "PROF:" parameter, it is possible to display all the entries that match the specified value. The "PROF:" parameter must be a numeric identifier in the range [0..128].

If no DHPC binding is currently defined the message "*** NO DHCP BINDINGs DEFINED ***" will be displayed.

For a more detailed description of the DHCP binding's parameters, please refer to the DHCP bindings table section of Dynamic Host Configuration Protocol (DHCP).

D DHCP BINDE | Display DHCP bindings details (User)
 | D DHCP BINDE [par:val] [par:val]

This command displays DHCP binding(s) in an extended format.

[19:07:12] ABILIS_CPX: D DHCP BINDE

----+-----+-------------------+-----------------+-------+----------------------
 O: | ST: | MAC:              | IP:             | PROF: | Last request(GMT)
                                                        | Expiry on(GMT)
----+-----+-------------------+-----------------+-------+----------------------
 H    EXP   11-11-23-11-11-11   192.168.000.123     128   21/12/2002 10:10:10
                                                          21/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    ACT   11-11-23-11-11-11   010.010.010.005     128   21/12/2002 10:10:10
                                                          29/12/2002 12:10:00
-------------------------------------------------------------------------------
 H    REL   11-11-23-11-11-15   192.168.000.150     128   21/12/2002 10:10:10
                                                          24/12/2002 11:10:10
-------------------------------------------------------------------------------
 H    ABD   11-11-23-11-11-30   000.000.000.000      10   21/12/2002 10:10:10
                                                          23/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    ACT   11-11-23-11-11-12   192.168.000.124    NONE   21/12/2002 10:10:10
                                                          25/12/2002 11:10:10
-------------------------------------------------------------------------------
 P    EXP   11-11-23-11-11-18   192.168.000.100       5   21/12/2002 10:10:10
                                                          21/12/2002 11:10:10
-------------------------------------------------------------------------------

By the "O:" parameter, it is possible to display all the entries identified by the specified origin. Allowed values for the origin of the binding are 'H' and 'P'.

By the "ST:" parameter, it is possible to display all the entries that are currently in the specified state. Allowed values for the state of the binding are 'REL', 'ACT', 'EXP' and 'AB'.

By the "IP:" parameter, it is possible to display all the entries that match the specified value. The "IP:" parameter can be a single IP address or two IP addresses separated by ':'(colon) (E.g.: 150.200.192.192 or 192.168.0.0:192.168.0.100). IP address(es) must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

By the "PROF:" parameter, it is possible to display all the entries that match the specified value. The "PROF:" parameter must be a numeric identifier in the range [0..128].

If no DHPC binding is currently defined the message "*** NO DHCP BINDINGs DEFINED ***" will be displayed.

For a more detailed description of the DHCP binding's parameters, please refer to the DHCP bindings table section of Dynamic Host Configuration Protocol (DHCP).


Commands relating to the Enhanced ISDN Router

Revised for CPX 4.1.0.
EIR Routings
EIR Groups
EIR Cluster Identifiers
TDM switches
EIR connections
Initialization commands

Other commands

EIR Routing top

A ER | Add Enhanced ISDN Routing (Administrator)
 | A ER PR:xx [par:val]

It adds a new EIR (Enhanced ISDN Router) routing with PR:xx priority and eventually sets the indicated parameters to the specified values. Not specified parameters are set to default values.

EIR routings table can store up to 100 routing definitions, so the priority value must be in the interval [0 - 99].

If a routing with "PR:xx" is already present in the table, it will get "PR:xx+1" priority.

If "PR:xx" is higher than the maximum (highest) priority currently present in the table, new EIR routing priority will be the (maximum) highest incremented by one.

If the EIR routings table is full and a new routing is asked to be added, an error message is generated: "EIR ROUTING TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the EIR routings table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

C ER | Clear Enhanced ISDN Routing (Administrator)
 | C ER PR:xx

It deletes an EIR (Enhanced ISDN Router) routing from the homonymous table. Priority value must be in the interval [0 - 99].

Priority of remaining routings, if higher than the removed one, is decremented because of table contiguity.

If the specified routing is not present in the table, the message "EIR ROUTING NOT PRESENT" is generated. If the table is empty, then "EIR ROUTING TABLE IS EMPTY" will be displayed.

Changes made on the EIR routings table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

D ER | Display Enhanced ISDN Routing (User)
 | D ER D ER PR:xx

It shows the EIR (Enhanced ISDN Router) routings table. Information is shown in a short format.

This short representation will not display information about parameters set to their default values. Such information is displayed only if the parameters are set to not default values. In this way representation of one EIR routing is usually contained in a row.

If priority is omitted, the command will show all the routings correctly present in the table. Here is an example of the command execution:

[18:56:10] ABILIS CPX: D ER

---+----+---------+--------+--------+--------------------+--------------------
PR |TYPE|NEXT     |POI/SR  |POO/DS  |CDI                 |CDO
   |    |ID-DT-MC/SP-VOL-LVOL-SC    |CGI                 |CGO
   |    |                           |SDI                 |SDO
   |    |                           |SGI                 |SGO
   |    |TI1 .. TI5
------------------------------------------------------------------------------
0   DATA NO        G2       200      *                    *
------------------------------------------------------------------------------
1   TR   NO        G1       G2       *                    *
------------------------------------------------------------------------------
2   TR   NO        G2       G1       *                    *
------------------------------------------------------------------------------
3   CtoC NO        CLUS_1   CLUS_2   00                   *
------------------------------------------------------------------------------

By specifying a priority value, the command will show the routing identified by specified priority. Priority value must be in the interval [0 - 99]. If the specified priority does not match any routing present in the table, the message "EIR ROUTING NOT PRESENT" is generated.

If the EIR routings table is empty, the following message will be displayed "EIR ROUTING TABLE IS EMPTY".

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Configuration of EIR Connections section.

D ERE | Display Enhanced ISDN Routing in extended format (User)
 | D ERE D ER PR:xx

It shows the EIR (Enhanced ISDN Router) routings table. Information is displayed in an extended format.

If priority is omitted, the command will show all the routings correctly present in the table. Here is an example of the command execution:

[18:56:10] ABILIS CPX: D ERE

PR:0   TYPE:DATA POI:G2      CDI:*                    SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:200     CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:1   TYPE:TR   POI:G1      CDI:*                    SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:G2      CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:2   TYPE:TR   POI:G2      CDI:*                    SDI:*
NEXT:N                       CGI:*                    SGI:*
                 POO:G1      CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#
------------------------------------------------------------------------------
PR:3   TYPE:CtoC SR:CLUS_1   CDI:00                   SDI:*
NEXT:N                       CGI:*                    SGI:*
                 DS:CLUS_2   CDO:*                    SDO:*
                             CGO:*                    SGO:*
       TI1:ALL,00:00-23:59                TI2:#  TI3:#  TI4:#  TI5:#

By specifying a priority value, the command will show the routing identified by specified priority. Priority value must be in the interval [0 - 99]. If the specified priority does not match any routing present in the table, the message "EIR ROUTING NOT PRESENT" is generated.

If the EIR routings table is empty, the following message will be displayed "EIR ROUTING TABLE IS EMPTY".

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Configuration of EIR Connections section.

M ER | Move Enhanced ISDN Routing (Administrator)
 | M ER PR:xx PR:yy

It changes the EIR (Enhanced ISDN Router) routing priority from the value "PR:xx" to the "PR:yy" one.

By consequence its position inside the EIR routings table will be changed. Other definitions present in the table are re-sorted because of table contiguity.

Priority value must be in the interval [0 - 99]. If the specified priority does not match any routing present in the table, the message "EIR ROUTING NOT PRESENT" is generated.

If the routing table is empty, the following message will be displayed "EIR ROUTING TABLE IS EMPTY".

Changes made on the EIR routings table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

S ER | Set Enhanced ISDN Routing
 | S ER PR:xx par:val [par:val]

It sets parameters of the EIR (Enhanced ISDN Router) routing identified by "PR:xx" to their new values.

Priority value must be in the interval [0 - 99]. If the specified priority does not match any routing present in the table, the message "EIR ROUTING NOT PRESENT" is generated.

If the routing table is empty, the following message will be displayed "EIR ROUTING TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other,starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the EIR routings table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

EIR Groups top

A EG | Add Enhanced ISDN group (Administrator)
 | A EG ID:xx [par:val]

It adds a new EIR (Enhanced ISDN Router) group identified by "ID:xx" and it sets the parameters, eventually indicated, to the specified values. Not specified parameters are set to default values.

EIR groups table can store up to 31 definitions, so the identifiers specified must be in the interval [1 - 31].

If an EIR group, whose ID is already present in the table, is going to be added, an error message will be displayed "EIR GROUP ALREADY EXISTS".

If the EIR groups table is full and a new group is asked to be added, an error message is generated: "EIR GROUP TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the EIR groups table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

C EG | Clear Enhanced ISDN group (Administrator)
 | C EG ID:xx

It deletes the EIR (Enhanced ISDN Router) group identified by "ID:xx", if present.

EIR groups table can store up to 31 definitions, so the identifiers specified must be in the interval [1 - 31].

Identifiers of remaining EIR groups, if higher than the removed one, will not decremented because of table contiguity. The deleted definition frees a place in the table that won't be displayed by the execution of the command D EG.

If the specified entry is not present in the table, the error message "EIR GROUP NOT PRESENT" will be generated.

If the EIR groups table is empty, the following message will be displayed "EIR GROUP TABLE IS EMPTY".

Changes made on the EIR groups table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

D EG | Display Enhanced ISDN group (User)
 | D EG D EG ID:xx

It shows the EIR (Enhanced ISDN Router) groups table.

If the group identifier is omitted, the command will show all the EIR groups correctly present in the table. Groups definitions may not have sequential identifiers, that is the not shown values are free places in the table. Here is an example of the command execution:

[15:46:31] ABILIS_CPX: D EG

ID: SC: R: |P1  P2  P3  P4  |P5  P6  P7  P8  |P9  P10 P11 P12 |P13 P14 P15 P16
-----------|----------------|----------------|----------------|---------------
1   R   NOR|280 281 .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------
2   R   NOR|282 283 .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------
5   P   LNA|.   .   .   .   |.   .   .   .   |.   .   .   .   |.   .   .   .
-----------|----------------|----------------|----------------|---------------

By specifying a group identifier, the command will show the requested group only, of course if it is present in the table. The specified identifier must be in the interval [1 - 31].

If the requested EIR group is not present in the table, an error message is generated: "EIR GROUP NOT PRESENT".

If the EIR groups table is empty, the following message will be displayed "EIR GROUP TABLE IS EMPTY".

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Configuration of EIR groupssection.

S EG | Set Enhanced ISDN group (Administrator)
 | S EG ID:xx par:val [par:val]

It sets parameters of the EIR group identified by "ID:xx" to their new values. Identifier value must be in the interval [0 - 31].

If the requested EIR group is not present in the table, an error message is generated: "EIR GROUP NOT PRESENT".

If the EIR groups table is empty, the following message will be displayed "EIR GROUP TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the EIR groups table are not immediately active. For activating them, it is needed to execute the initialization command INIT ER

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

EIR Cluster identifiers top

D EID | Display remote Enhanced ISDN Router identifiers (Administrator)
 | D EID

It shows the EIR (Enhanced ISDN Router) cluster identifiers table.

Here is an example of the command execution:

[18:41:46] ABILIS_CPX: D EID

+----------+---------+----------+-------+
| Id:      | IntRef: | MaxConn: | Used: |
+----------+---------+----------+-------+
| CLUS_1   |  1 [01] |    32    |   1   |
| CLUS_2   |  2 [02] |     1    |   2   |
+----------+---------+----------+-------+

EIR Cluster identifier table can store up to 233 definitions (from 1 to 233). Definitions may not be sequential, that is the not shown values represent free places in the table.

If the table is empty, the message "EID TABLE IS EMPTY" is generated.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Identifiers of remote EIR clusters section.

S EID | Set remote Enhanced ISDN Router identifiers (Administrator)
 | S EID ID:name MAXCONN:xx

It makes possible to set the parameter "MAXCONN:" associated to the specified (Enhanced ISDN Router) cluster identifier. This parameter indicates the maximum number of connections on B channels, that can be opened on that (Enhanced ISDN Router) cluster. The "MAXCONN:" value must be in the range [0 -32].

If the table does not contain any entry identifier by the mnemonic "ID:name", the following message will be shown: "EIR IDENTIFIER NOT PRESENT".

If the table is empty, the message "EID TABLE IS EMPTY" is generated.

Changes made on the EIR cluster identifiers table are immediately active. it is not needed to execute any initialization command.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

TDM switches top

A TDM | Add TDM switch (Administrator)
 | A TDM PR:xx [par:val]

It adds a new definition of TDM switch with priority "PR:xx" and it can eventually set the indicated parameters to the specified values. Not specified parameters are set to their default values.

The TDM switches table can store up to 64 definitions, therefore the specified priority value must be in the interval [0 - 63].

The TDM switches table is automatically maintained with consecutive indexes of priority, that is without "empty" places. Therefore every action of deleting or insertion makes the system to reorder all the indexes succeeding the referred one.

If a TDM switch, whose "PR:xx" is already present in the table, its priority will be increased by one, i.e. it will be "PR:xx+1".

If "PR:xx" is higher than the maximum priority currently present in the table, new definition will get the maximum value incremented by one.

If the TDM switches table is full and a new definition is going to be added, the following message will be generated: "TDM SWITCH TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the TDM switches table are not immediately active. For activating them, it is needed to execute the initialization command INIT TDM.

C TDM | Clear TDM switch (Administrator)
 | C TDM PR:xx

It deletes from the TDM switches table the definition identified by "PR:xx" Priority value must be in the interval [0 - 63].

Priority of remaining switch, if higher than the removed one, is decremented because of table contiguity.

If the specified entry is not present in the TDM switches table, the message "TDM SWITCH ENTRY NOT PRESENT" will be shown.

If the table is empty the following message will be generated: "TDM SWITCH TABLE IS EMPTY".

Changes made on the TDM switches table are not immediately active. For activating them, it is needed to execute the initialization command INIT TDM.

D TDM | Display TDM switch (User)
 | D TDM D TDM PR:xx

It shows the current content of the TDM switches table.

If the priority value is omitted, the command will show all the definitions currently present in the table. Here is an example of the command execution:

[16:36:20] ABILIS_CPX: D TDM

---+--------+---------+-------+-----+------------------------------------------
PR:|SERVICE:|MODE:    |VSP-ID:|PO:  |CH:
---+--------+---------+-------+-----+------------------------------------------
0   sQ931    OUTGOING      -   NONE  NONE
1   sQ931    BIDIR         -     80  1-2
2   sQ931    BIDIR         -     80  NONE
3   VSP      -             3   NONE  NONE
4   VSP      -            32   NONE  NONE
5   VSP      -             1     96  1-31

By specifying a priority, the command will only show the TDM switch requested. Priority value must be in the interval [0 - 63].

If the specified switch TDM is not present in the table, the message "TDM SWITCH ENTRY NOT PRESENT" will be shown.

If the table is empty the following message will be generated: "TDM SWITCH TABLE IS EMPTY".

For a more detailed description of the displayed information, please refer to the TDM switches configuration section.

M TDM | Move TDM switch (Administrator)
 | M TDM PR:xx PR:yy

It changes TDM switch priority from the value "PR:xx" to "PR:yy", consequently also it is position inside the table changes and other definitions are sorted again because of table contiguity. Priority values must be in the interval [0 - 63].

If the specified switch TDM is not present in the table, the message "TDM SWITCH ENTRY NOT PRESENT" will be shown.

If the table is empty the following message will be generated: "TDM SWITCH TABLE IS EMPTY".

Changes made on the TDM switches table are not immediately active. For activating them, it is needed to execute the initialization command INIT TDM.

S TDM | Set TDM switch (Administrator)
 | S TDM PR:xx par:val [par:val]

It sets the parameters of the specified TDM switch to their new values. Priority value must be in the interval [0 - 63].

If the specified switch TDM is not present in the table, the message "TDM SWITCH ENTRY NOT PRESENT" will be shown.

If the table is empty the following message will be generated: "TDM SWITCH TABLE IS EMPTY".

Changes made on the TDM switches table are not immediately active. For activating them, it is needed to execute the initialization command INIT TDM.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the TDM switches table are not immediately active. For activating them, it is needed to execute the initialization command INIT TDM.

EIR connections top

C EC | Clear Enhanced ISDN connection (Administrator)
 | C EC ID:xxx

It forces to clear the EIR connection identified by "ID:xxx". The connection identifier must be in the range [0 - 255].

If the requested EIR connection is not present, the error message "EIR CONNECTION NOT PRESENT" will be shown.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

D EC | Display Enhanced ISDN connection (User)
 | D EC

It shows currently present EIR (Enhanced ISDN Router) connections. Information is displayed in a short format.

Here is an example of the command execution:

[14:40:11] ABILIS_CPX: D EC

ID  Type Input    Output   PR   State   Cgi (Calling Input) Cdo (Called Output)
--- ---- -------- -------- -- --------- ------------------- -------------------
125 TR   291      283      22 CONNECTED                     376390774
181 TR   290      280      19 CONNECTED 381650866           376397398
196 TR   290      282      19 CALLING   444687062           376397398

If no EIR connection is running, the message "NO EIR CONNECTIONS" is generated.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Vision of EIR connections status section.

D ECE | Display Enhanced ISDN connection in extended format (User)
 | D ECE

It shows currently running EIR (Enhanced ISDN Router) connections. Information is displayed in an extended format.

Here is an example of the command execution:

[14:40:11] ABILIS_CPX: D ECE

ID:125 TYPE:TR    POI:291  GPI:#   POO:283  GPO:#   PR:22  ST:CONNECTED
      CGI:                     CGO:
      SGI:                     SGO:
      CDI:376390774            CDO:376390774
      SDI:                     SDO:

ID:181 TYPE:TR    POI:290  GPI:#   POO:280  GPO:#   PR:19  ST:CONNECTED
      CGI:381650866            CGO:381650866
      SGI:                     SGO:
      CDI:376397398            CDO:376397398
      SDI:                     SDO:

ID:197 TYPE:TR    POI:290  GPI:#   POO:282  GPO:#   PR:20  ST:CALLING
      CGI:3486508535           CGO:3486508535
      SGI:                     SGO:
      CDI:376396548            CDO:376396548
      SDI:                     SDO:

If no EIR connection is running, the message "NO EIR CONNECTIONS" is generated.

If the Abilis CPX version, currently in use, does not support EIR services, the following message will be shown "EIR SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Vision of EIR connections status section.

Initialization commands top

INIT ER | Init Enhanced ISDN Routing (User)
 | INIT ER

It refreshes the EIR routings table and EIR groups table, according to the changes made on the definitions.

If the command is successful, the message "COMMAND EXECUTED" will be shown.

If the EIR services are not supported by Abilis CPX version currently in use, the following message will be shown "EIR SERVICE NOT PRESENT".

INIT TDM | Init TDM switches table (User)
 | INIT TDM

It refreshes TDM switches table, according to the changes made on the definitions.

If the command is successful, the message "COMMAND EXECUTED" will be shown.

If the EIR services are not supported by Abilis CPX version currently in use, the following message will be shown "EIR SERVICE NOT PRESENT".

INIT EIR | Init Enhanced ISDN Router (User)
 | INIT EIR

It reinitializes the EIR Router. This procedure is not immediate; usually it can take some minutes to be executed.

If the command is successful, the message "COMMAND EXECUTED" will be shown.

Here is an example of the command execution:

[17:48:12] ABILIS_CPX: INIT EIR

INIT EIR IN PROGRESS, THIS MAY TAKES FEW MINUTES...

COMMAND EXECUTED

If the EIR services are not supported by Abilis CPX version currently in use, the following message will be shown "EIR SERVICE NOT PRESENT".

R EBIB | Restart EBIB card (User)
 | R EBIB

It reinitializes all the VOICE compression modules on the EBIB board.

If the command is successful, the message "RESTART EBIB EXECUTED" will be shown.

warning! This command works on the file present in the disk. If the disk is not present or a reading errors occur, the following message will be displayed "ERROR LOADING FILE 'xxxx', RESTART EBIB NOT EXECUTED", where "xxxx" stands for the file that is needed for correct running of the EBIB board.

If the EIR services are not supported by Abilis CPX version currently in use, the following message will be shown "EIR SERVICE NOT PRESENT".

R EPIB | Restart EPIB card (User)
 | R EPIB

It reinitializes all the VOICE compression modules on the EPIB board.

If the command is successful, the message "RESTART EPIB EXECUTED" will be shown.

warning! This command works on the file present in the disk. If the disk is not present or a reading errors occur, the following message will be displayed "ERROR LOADING FILE 'xxxx', RESTART EPIB NOT EXECUTED", where "xxxx" stands for the needed file for correct running of the EPIB board.

If the EIR services are not supported by Abilis CPX version currently in use, the following message will be shown "EIR SERVICE NOT PRESENT".


Commands relating to FTP

FTP Virtual Root Paths table
FTP Virtual Path's Access Rights table

Other commands

FTP Virtual Root Paths top

A FTP PATH: | Add FTP Virtual Root Path entry (Administrator)
 | A FTP PATH:val [par:val]

This command allows to add a new FTP Virtual Root Path definition.

The "PATH:" value must be a strings of up to 32 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

info The virtual root path "/sysdrives/" cannot be defined because it is reserved to the system.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

FTP Virtual Root Path definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

If an entry with the same path value is already defined, the message "FTP VIRTUAL ROOT PATH ALREADY EXISTS" will be shown.

Paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table. However, when an entry is created, the case is preserved.

[15:48:44] ABILIS_CPX: D FTP PATH

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

[15:48:49] ABILIS_CPX: A FTP PATH:/my_path/

COMMAND EXECUTED

[15:49:04] ABILIS_CPX: D FTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

If the FTP Virtual Root Paths Table is full, i.e. no free record is currently available, the message "FTP VIRTUAL ROOT PATHs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the FTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the FTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Root Paths Service, the following message will be shown "FTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

C FTP PATH: | Clear FTP Virtual Root Path (Administrator)
 | C FTP PATH:val

This command allows to delete an entry from the FTP Virtual Root Paths Table.

If no entry is found for the specified path, the message "FTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table.

If the table is currently empty, the message "FTP VIRTUAL ROOT PATHs TABLE IS EMPTY" will be shown.

FTP Virtual Root Path definitions are kept contiguous and alphabetically sorted, then the deletion will cause the table to be rearranged.

Changes made on the FTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the FTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Root Paths Service, the following message will be shown "FTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

D FTP PATH | Display FTP Virtual Root Paths table (User)
 | D FTP PATH

This command displays all configured FTP Virtual Root Paths.

Here is an example of the information shown by the command execution:

[15:49:04] ABILIS_CPX: D FTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If no FTP Virtual Root Path is currently defined the message "*** NO FTP VIRTUAL ROOT PATHs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of FTP Virtual Root Paths table.

If the Abilis CPX version, currently in use, does not support FTP Virtual Root Paths Service, the following message will be shown "FTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

D FTP PATH: | Display FTP Virtual Root Path (User)
 | D FTP PATH:val

This command displays the specified entry of the FTP Virtual Root Paths Table.

If no entry is found for the specified path, the message "FTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table.

Here is an example of the information shown by the command execution:

[15:49:04] ABILIS_CPX: D FTP PATH:/my_path/

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If no FTP Virtual Root Path is currently defined the message "*** NO FTP VIRTUAL ROOT PATHs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of FTP Virtual Root Paths table.

If the Abilis CPX version, currently in use, does not support FTP Virtual Root Paths Service, the following message will be shown "FTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

S FTP PATH: | Set FTP Virtual Root Path (Administrator)
 | S FTP PATH:val par:val [par:val]

This command sets all the indicated parameters of the requested entry of the FTP Virtual Root Paths Table to the specified values.

If no entry is found for the specified path, the message "FTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same virtual root path in the table.

If the table is currently empty, the message "FTP VIRTUAL ROOT PATHs TABLE IS EMPTY" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

As it can be seen from the following example, also the path value itself can be changed using the present command:

[10:41:35] ABILIS_CPX: A FTP PATH:/aaa/

COMMAND EXECUTED

[10:41:41] ABILIS_CPX: S FTP PATH:/aaa/ PATH:/bbb/

COMMAND EXECUTED

info The virtual root path "/sysdrives/" value cannot be set because it is reserved to the system.

Because definitions are kept alphabetically sorted by the "PATH:" value, the modifications of the path will cause a table rearrangement on the base of the currently defined entries.

For a detailed description of the FTP Virtual Root Path entry's parameters, please refer to Configuration of FTP Virtual Root Paths table.

Changes made on the FTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the FTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Root Paths Service, the following message will be shown "FTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

FTP Virtual Path's Access Rights table top

A FTP RIGHTS ID: | Add user rights to FTP Virtual Path's Access Rights entry (Administrator)
 | A FTP RIGHTS ID:val USER:val [par:val]

This command adds a new user to the specified path of the FTP Virtual Path's Access Rights Table that is identified by "ID:xxx". The FTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

The same "USER:" cannot be defined more then once for the same FTP Virtual Path's Access Rights entry. If the specified user already exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY ALREADY EXISTS".

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

A FTP RIGHTS PATH: | Add FTP Virtual Path's Access Rights entry (Administrator)
 | A FTP RIGHTS PATH:val A FTP RIGHTS PATH:val USER:val [par:val]

This command adds a new path entry to the FTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
There is no difference between lowercase and uppercase characters. However, when an entry is created, the case is preserved.

When a new path entry is added to the FTP Virtual Path's Access Rights Table, the system provide to assign to it a numeric identifiers that can be used for further operations on the entry. FTP Virtual Path's Access Rights identifiers are values in the range [1 - 128].

FTP Virtual Path's Access Rights Table's definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

If an entry with the same path value is already defined, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY ALREADY EXISTS" will be shown.

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the user "USER:" parameter is specified, the command adds a new user to the specified path of the FTP Virtual Path's Access Rights Table, if it is present. If the specified path isn't present the command provides to add it.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

The same "USER:" cannot be defined more then once for the same FTP Virtual Path's Access Rights entry. If the specified user already exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY ALREADY EXISTS".

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

C FTP RIGHTS ID: | Clear user rights from FTP Virtual Path's Access Rights entry (Administrator)
 | C FTP RIGHTS ID:val USER:val

This command deletes a user from the specified path of the FTP Virtual Path's Access Rights Table that is identified by "ID:xxx". The FTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY NOT PRESENT".

User definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

C FTP RIGHTS PATH: | Clear FTP Virtual Path's Access Rights entry (Administrator)
 | C FTP RIGHTS PATH:val C FTP RIGHTS PATH:val USER:val

This command deletes a path entry from the FTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
There is no difference between lowercase and uppercase characters.

If the specified path doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

Path definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

While deleting the path definition, the command deletes also all user entries that are eventually defined for that path.

[11:56:55] ABILIS_CPX: D FTP RIGHTS

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  6 /ccc/
       aaa                              r---  l---  YES    PLAIN,SSL
       aaa_bbb                          r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

[11:57:02] ABILIS_CPX: C FTP RIGHTS PATH:/ccc/

THE SELECTED FTP VIRTUAL PATH'S RIGHTS ENTRY AND ALL RELATED USERs
WILL BE DELETED.
PROCEED (N/Y)? Y

COMMAND EXECUTED

[11:57:12] ABILIS_CPX: D FTP RIGHTS

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

If the user "USER:" parameter is specified, the command deletes only the specified user from the selected path of the FTP Virtual Path's Access Rights Table, if it is present.

If the specified path doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY NOT PRESENT".

User definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D FTP RIGHTS | Display FTP Virtual Path's Access Rights Table (User)
 | D FTP RIGHTS

It displays the FTP Virtual Path's Access Rights Table content.

Here is an example of the information shown by the command execution:

[11:57:12] ABILIS_CPX: D FTP RIGHTS

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /sys/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  ----  NO     PLAIN,SSL
------------------------------------------------------------------------------
  2 /test/
       user                             r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If no entry is currently defined the message "*** NO FTP VIRTUAL PATH'S RIGHTs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of FTP Virtual Path's Access Rights Table.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D FTP RIGHTS ID: | Display FTP Virtual Path's Access Rights entry (User)
 | D FTP RIGHTS ID:val

The command displays the selected entry of the FTP Virtual Path's Access Rights Table.

The FTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D FTP RIGHTS PATH: | Display FTP Virtual Path's Access Rights entry (User)
 | D FTP RIGHTS PATH:val

The command displays the selected entry of the FTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the specified path doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Here is an example of the information shown by the command execution:

[12:33:18] ABILIS_CPX: D FTP RIGHTS PATH:/pub/

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to Configuration of FTP Virtual Path's Access Rights Table.

D FTP RIGHTS USER: | Display FTP Virtual Path's Access Rights user's entry (User)
 | D FTP RIGHTS USER:val

The command displays the selected entries of the FTP Virtual Path's Access Rights Table for which the specified user is defined.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY NOT PRESENT".

Here is an example of the information shown by the command execution:

[12:33:30] ABILIS_CPX: D FTP RIGHTS USER:admin

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to Configuration of FTP Virtual Path's Access Rights Table.

F FTP RIGHTS PATH: | Find FTP Virtual Path's Access Rights entry (Administrator)
 | F FTP RIGHTS PATH:val USER:val PROT:val

It verifies access rights of a certain user "USER:val" for the the specified path "PATH:val" in the FTP Virtual Path's Access Rights for the selected FTP access protocol "PROT:val".

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The comparison is not case-sensitive. For example, the string "string" and "STRING" would both reference the same path and/or user in the table.

Here is an example of the information shown by the command execution:

[12:39:28] ABILIS_CPX: F FTP RIGHTS PATH:/pub/my_user/ USER:anonymous PROT:plain

SUCCESSFUL FTP ACCESS CONTROL SEARCH:
 FILE rights: r---, DIR rights: l---, matching table entry:

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

S FTP RIGHTS ID: | Set FTP Virtual Path's Access Rights entry (Administrator)
 | S FTP RIGHTS ID:VAL USER:val par:val [par:val]

The command sets parameters of the selected user entry of the FTP Virtual Path's Access Rights Table.

The FTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY NOT PRESENT".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of the FTP Virtual Path's Access Rights entry's parameters, please refer to Configuration of FTP Virtual Path's Access Rights Table.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

S FTP RIGHTS PATH: | Set FTP Virtual Path's Access Rights entry (Administrator)
 | S FTP RIGHTS PATH:val USER:val par:val [par:val]

The command sets parameters of the selected user entry of the FTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the specified path doesn't correspond to an already existing entry, the message "FTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "FTP USER'S RIGHTS ENTRY NOT PRESENT".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of the FTP Virtual Path's Access Rights entry's parameters, please refer to Configuration of FTP Virtual Path's Access Rights Table.

Changes made on the FTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support FTP Virtual Path's Access Rights Service, the following message will be shown "FTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".


Commands relating to HTTP

HTTP Virtual Root Paths table
HTTP Virtual Path's Access Rights table

Other commands

HTTP Virtual Root Paths top

A HTTP PATH: | Add HTTP Virtual Root Path entry (Administrator)
 | A HTTP PATH:val [par:val]

This command allows to add a new HTTP Virtual Root Path definition.

The "PATH:" value must be a strings of up to 32 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

info The virtual root path "/sys/" cannot be defined because it is reserved to the system.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

HTTP Virtual Root Path definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

If an entry with the same path value is already defined, the message "HTTP VIRTUAL ROOT PATH ALREADY EXISTS" will be shown.

Paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table. However, when an entry is created, the case is preserved.

[15:48:44] ABILIS_CPX: D HTTP PATH

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

[15:48:49] ABILIS_CPX: A HTTP PATH:/my_path/

COMMAND EXECUTED

[15:49:04] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

If the HTTP Virtual Root Paths Table is full, i.e. no free record is currently available, the message "HTTP VIRTUAL ROOT PATHs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the HTTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the HTTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Root Paths Service, the following message will be shown "HTTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

C HTTP PATH: | Clear HTTP Virtual Root Path (Administrator)
 | C HTTP PATH:val

This command allows to delete an entry from the HTTP Virtual Root Paths Table.

If no entry is found for the specified path, the message "HTTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table.

If the table is currently empty, the message "HTTP VIRTUAL ROOT PATHs TABLE IS EMPTY" will be shown.

HTTP Virtual Root Path definitions are kept contiguous and alphabetically sorted, then the deletion will cause the table to be rearranged.

Changes made on the HTTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the HTTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Root Paths Service, the following message will be shown "HTTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

D HTTP PATH | Display HTTP Virtual Root Paths table (User)
 | D HTTP PATH

This command displays all configured HTTP Virtual Root Paths.

Here is an example of the information shown by the command execution:

[15:49:04] ABILIS_CPX: D HTTP PATH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------
PATH:         /pub/
PHYS-PATH:    C:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /pub2/
PHYS-PATH:    D:\USR\PUB\
------------------------------------------------------------------------------
PATH:         /usr/
PHYS-PATH:    C:\USR\
------------------------------------------------------------------------------
PATH:         /usr2/
PHYS-PATH:    D:\USR\
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If no HTTP Virtual Root Path is currently defined the message "*** NO HTTP VIRTUAL ROOT PATHs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of HTTP Virtual Root Paths table.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Root Paths Service, the following message will be shown "HTTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

D HTTP PATH: | Display HTTP Virtual Root Path (User)
 | D HTTP PATH:val

This command displays the specified entry of the HTTP Virtual Root Paths Table.

If no entry is found for the specified path, the message "HTTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same path in the table.

Here is an example of the information shown by the command execution:

[15:49:04] ABILIS_CPX: D HTTP PATH:/my_path/

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
PATH:         /my_path/
PHYS-PATH:
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If no HTTP Virtual Root Path is currently defined the message "*** NO HTTP VIRTUAL ROOT PATHs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of HTTP Virtual Root Paths table.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Root Paths Service, the following message will be shown "HTTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

S HTTP PATH: | Set HTTP Virtual Root Path (Administrator)
 | S HTTP PATH:val par:val [par:val]

This command sets all the indicated parameters of the requested entry of the HTTP Virtual Root Paths Table to the specified values.

If no entry is found for the specified path, the message "HTTP VIRTUAL ROOT PATH NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "Name" and "NAME" would both reference the same virtual root path in the table.

If the table is currently empty, the message "HTTP VIRTUAL ROOT PATHs TABLE IS EMPTY" will be shown.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

As it can be seen from the following example, also the path value itself can be changed using the present command:

[10:41:35] ABILIS_CPX: A HTTP PATH:/aaa/

COMMAND EXECUTED

[10:41:41] ABILIS_CPX: S HTTP PATH:/aaa/ PATH:/bbb/

COMMAND EXECUTED

info The virtual root path "/sys/" value cannot be set because it is reserved to the system.

Because definitions are kept alphabetically sorted by the "PATH:" value, the modifications of the path will cause a table rearrangement on the base of the currently defined entries.

For a detailed description of the HTTP Virtual Root Path entry's parameters, please refer to Configuration of HTTP Virtual Root Paths table.

Changes made on the HTTP Virtual Root Paths Table are NOT immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the HTTP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT PO:xxx command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Root Paths Service, the following message will be shown "HTTP VIRTUAL ROOT PATHs SERVICE NOT PRESENT".

HTTP Virtual Path's Access Rights table top

A HTTP RIGHTS ID: | Add user rights to HTTP Virtual Path's Access Rights entry (Administrator)
 | A HTTP RIGHTS ID:val USER:val [par:val]

This command adds a new user to the specified path of the HTTP Virtual Path's Access Rights Table that is identified by "ID:xxx". The HTTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

The same "USER:" cannot be defined more then once for the same HTTP Virtual Path's Access Rights entry. If the specified user already exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY ALREADY EXISTS".

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

A HTTP RIGHTS PATH: | Add HTTP Virtual Path's Access Rights entry (Administrator)
 | A HTTP RIGHTS PATH:val A HTTP RIGHTS PATH:val USER:val [par:val]

This command adds a new path entry to the HTTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
There is no difference between lowercase and uppercase characters. However, when an entry is created, the case is preserved.

When a new path entry is added to the HTTP Virtual Path's Access Rights Table, the system provide to assign to it a numeric identifiers that can be used for further operations on the entry. HTTP Virtual Path's Access Rights identifiers are values in the range [1 - 128].

HTTP Virtual Path's Access Rights Table's definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

If an entry with the same path value is already defined, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY ALREADY EXISTS" will be shown.

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the user "USER:" parameter is specified, the command adds a new user to the specified path of the HTTP Virtual Path's Access Rights Table, if it is present. If the specified path isn't present the command provides to add it.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent. However, when an entry is created, the case is preserved.

User definitions are kept alphabetically sorted. The new definition will be added in the correct position of the table on the base of the currently defined entries.

The same "USER:" cannot be defined more then once for the same HTTP Virtual Path's Access Rights entry. If the specified user already exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY ALREADY EXISTS".

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

While adding the new definition, the command sets also the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

C HTTP RIGHTS ID: | Clear user rights from HTTP Virtual Path's Access Rights entry (Administrator)
 | C HTTP RIGHTS ID:val USER:val

This command deletes a user from the specified path of the HTTP Virtual Path's Access Rights Table that is identified by "ID:xxx". The HTTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY NOT PRESENT".

User definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

C HTTP RIGHTS PATH: | Clear HTTP Virtual Path's Access Rights entry (Administrator)
 | C HTTP RIGHTS PATH:val C HTTP RIGHTS PATH:val USER:val

This command deletes a path entry from the HTTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
There is no difference between lowercase and uppercase characters.

If the specified path doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

Path definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

While deleting the path definition, the command deletes also all user entries that are eventually defined for that path.

[11:56:55] ABILIS_CPX: D HTTP RIGHTS

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  6 /ccc/
       aaa                              r---  l---  YES    PLAIN,SSL
       aaa_bbb                          r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

[11:57:02] ABILIS_CPX: C HTTP RIGHTS PATH:/ccc/

THE SELECTED HTTP VIRTUAL PATH'S RIGHTS ENTRY AND ALL RELATED USERs
WILL BE DELETED.
PROCEED (N/Y)? Y

COMMAND EXECUTED

[11:57:12] ABILIS_CPX: D HTTP RIGHTS

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

If the user "USER:" parameter is specified, the command deletes only the specified user from the selected path of the HTTP Virtual Path's Access Rights Table, if it is present.

If the specified path doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY NOT PRESENT".

User definitions are kept alphabetically sorted. The definition deletion will cause a table rearrangement on the base of the currently defined entries.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D HTTP RIGHTS | Display HTTP Virtual Path's Access Rights Table (User)
 | D HTTP RIGHTS

It displays the HTTP Virtual Path's Access Rights Table content.

Here is an example of the information shown by the command execution:

[11:57:12] ABILIS_CPX: D HTTP RIGHTS

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /sys/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  ----  NO     PLAIN,SSL
------------------------------------------------------------------------------
  2 /test/
       user                             r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If no entry is currently defined the message "*** NO HTTP VIRTUAL PATH'S RIGHTs DEFINED ***" will be displayed.

For a more detailed description of the displayed information, please refer to Configuration of HTTP Virtual Path's Access Rights Table.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D HTTP RIGHTS ID: | Display HTTP Virtual Path's Access Rights entry (User)
 | D HTTP RIGHTS ID:val

The command displays the selected entry of the HTTP Virtual Path's Access Rights Table.

The HTTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

D HTTP RIGHTS PATH: | Display HTTP Virtual Path's Access Rights entry (User)
 | D HTTP RIGHTS PATH:val

The command displays the selected entry of the HTTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the specified path doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Here is an example of the information shown by the command execution:

[12:33:18] ABILIS_CPX: D HTTP RIGHTS PATH:/pub/

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to Configuration of HTTP Virtual Path's Access Rights Table.

D HTTP RIGHTS USER: | Display HTTP Virtual Path's Access Rights user's entry (User)
 | D HTTP RIGHTS USER:val

The command displays the selected entries of the HTTP Virtual Path's Access Rights Table for which the specified user is defined.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY NOT PRESENT".

Here is an example of the information shown by the command execution:

[12:33:30] ABILIS_CPX: D HTTP RIGHTS USER:admin

- Not Saved (SAVE CONF) -------------------------------------------------------

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  2 /pub2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  3 /sysdrives/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  4 /usr/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------
  5 /usr2/
       admin                            rwdn  lcdn  YES    PLAIN,SSL
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to Configuration of HTTP Virtual Path's Access Rights Table.

F HTTP RIGHTS PATH: | Find HTTP Virtual Path's Access Rights entry (Administrator)
 | F HTTP RIGHTS PATH:val USER:val PROT:val

It verifies access rights of a certain user "USER:val" for the the specified path "PATH:val" in the HTTP Virtual Path's Access Rights for the selected HTTP access protocol "PROT:val".

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The comparison is not case-sensitive. For example, the string "string" and "STRING" would both reference the same path and/or user in the table.

Here is an example of the information shown by the command execution:

[12:39:28] ABILIS_CPX: F HTTP RIGHTS PATH:/pub/my_user/ USER:anonymous PROT:plain

SUCCESSFUL HTTP ACCESS CONTROL SEARCH:
 FILE rights: r---, DIR rights: l---, matching table entry:

------------------------------------------------------------------------------
ID: PATH:
       USER:                            FILE: DIR:  RECUR: PROT:
------------------------------------------------------------------------------
  1 /pub/
       anonymous                        r---  l---  YES    PLAIN,SSL
------------------------------------------------------------------------------

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

S HTTP RIGHTS ID: | Set HTTP Virtual Path's Access Rights entry (Administrator)
 | S HTTP RIGHTS ID:VAL USER:val par:val [par:val]

The command sets parameters of the selected user entry of the HTTP Virtual Path's Access Rights Table.

The HTTP Virtual Path's Access Rights entry identifier must be a value in the range [1 - 128].

If the specified identifiers doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY NOT PRESENT".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of the HTTP Virtual Path's Access Rights entry's parameters, please refer to Configuration of HTTP Virtual Path's Access Rights Table.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".

S HTTP RIGHTS PATH: | Set HTTP Virtual Path's Access Rights entry (Administrator)
 | S HTTP RIGHTS PATH:val USER:val par:val [par:val]

The command sets parameters of the selected user entry of the HTTP Virtual Path's Access Rights Table.

Valid "PATH:" parameter values are strings of up to 128 characters, initiating and terminating with '/' (slash) character. Strings holding spaces must be written between quotation marks (E.g.: "/My path/").
The paths comparison is not case-sensitive. For example, the name "PathName" and "pathNAME" would both reference the same path in the table.

If the specified path doesn't correspond to an already existing entry, the message "HTTP VIRTUAL PATH'S RIGHTS ENTRY NOT PRESENT" will be shown.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed.

The user names comparison is not case-sensitive. For example, the name "UserName" and "userNAME" would both reference the same user in the table.

If the specified user doesn't exists in the table, the following message is generated "HTTP USER'S RIGHTS ENTRY NOT PRESENT".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of the HTTP Virtual Path's Access Rights entry's parameters, please refer to Configuration of HTTP Virtual Path's Access Rights Table.

Changes made on the HTTP Virtual Path's Access Rights Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support HTTP Virtual Path's Access Rights Service, the following message will be shown "HTTP VIRTUAL PATH'S RIGHTS SERVICE NOT PRESENT".


Commands relating to the IKE

Revised for CPX 4.8.0.
IKE host connections table
IKE client connections table
IKE pre-shared keys (PSK) table

Other commands

IKE host connections table top

A IKE HOST: | Add host connection (Administrator)
 | A IKE HOST:xx [par:val]

It adds a new entry to the host connections table in the "ID:xx" position. The command can also set eventually indicated parameters to the specified values.

The host connections table can store up to 32 entries, therefore the host connection identifier value must be in the interval [0 - 31].

IKE host connection configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a IKE host connection already present in the table the message "IKE HOST CONNECTION ALREADY EXISTS" will be shown

If the host connections table is full and a new host connection is asked to be added, an error message is generated: "IKE HOST CONNECTIONS TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the host connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:A IKE HOST:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IKE HOST:7 CIPHER:3DES

COMMAND EXECUTED

C IKE HOST: | Clear host connection (Administrator)
 | C IKE HOST:xxx

It deletes the specified entry from the host connections table. The host connection identifier must be in the interval [0 - 31].

If the requested entry is not present in the table, the following error message will be displayed: "IKE HOST CONNECTION NOT PRESENT".

If the host connections table is empty, the following message will be shown "IKE HOST CONNECTIONS TABLE IS EMPTY".

Changes made on the host connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:C IKE HOST:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:C IKE HOST:10

IKE HOST CONNECTION NOT PRESENT

D IKE HOST: | Display host connection (User)
 | D IKE HOST D IKE HOST:xx

It shows the host connections table.

If the identifier is omitted, the command will show all host connections currently set.

Here is an example of the command execution:

[21:28:23] ABILIS_CPX:D IKE HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
HOST: NAME:                            LOC-IP:              IPP:    KEY-TRIES:
      CIPHER:   AUTH: HASH: DH:        REM-IP:              SIDE:   LIFE-TIME:
      ID-TYPE:        IP:              FQDN:
      PEER-ID-TYPE:   PEER-IP:         PEER-FQDN:
-------------------------------------------------------------------------------
0     CPX_1-to-CPX_2                   192.168.002.001      1       3
      3DES      PSK   MD5   MODP1024   192.168.002.002      AUTO    3600
      IP              192.168.002.001
      IP              192.168.002.002
-------------------------------------------------------------------------------
1     CPX_1-to-CPX_3                   192.168.002.001      1       3
      IDEA      PSK   SHA   MODP1536   *                    AUTO    3600
      IP              192.168.002.001
      FQDN                             www.antek.it
-------------------------------------------------------------------------------

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the host connections table is empty, the following message will be shown "*** NO IKE HOST CONNECTIONS DEFINED ***".

By specifying the host connection identifier, the command will show only the requested host connection.

[00:15:04] ABILIS_CPX:D IKE HOST:0

Parameter:   |Value:
------------------------------------------------------------------------------
HOST:         0
NAME:         CPX_1-to-CPX_2
LOC-IP:       192.168.002.001
REM-IP:       192.168.002.002
CIPHER:       3DES
AUTH:         PSK
HASH:         MD5
DH:           MODP1024
KEY-TRIES:    3
LIFE-TIME:    3600
ID-TYPE:      IP
IP:           192.168.002.001
PEER-ID-TYPE: IP
PEER-IP:      192.168.002.002
IPP:          0
SIDE:         AUTO
------------------------------------------------------------------------------

The identifier must be in the interval [0 - 31]. If the requested entry is not present in the table, the following error message will be displayed: "IKE HOST CONNECTION NOT PRESENT".

For a more detailed description of the shown information, refer the Host connections table of the IKE port section.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

S IKE HOST: | Set host connection (Administrator)
 | S IKE HOST:xx par:val [par:val]

It sets parameters of the specified host connection to their new values.

The specified host connection identifier value must be in the interval [0 - 31]. If the requested entry is not present in the table, the following error message will be displayed: "IKE HOST CONNECTION NOT PRESENT".

If the host connections table is empty, the following message will be shown "IKE HOST CONNECTIONS TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the host connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Example:
[10:32:14] ABILIS_CPX:S IKE HOST:7 AUTH:PSK

COMMAND EXECUTED

IKE client connections table top

A IKE CLI: | Add client connection (Administrator)
 | A IKE CLI:xx [par:val]

It adds a new entry to the client connections table in the "ID:xx" position. The command can also set eventually indicated parameters to the specified values.

The client connections table can store up to 64 entries, therefore the client connection identifier value must be in the interval [0 - 63].

IKE client connection configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a IKE client connection already present in the table the message "IKE CLIENT CONNECTION ALREADY EXISTS" will be shown

If the client connections table is full and a client connection is asked to be added, an error message is generated: "IKE CLIENT CONNECTIONS TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the client connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:A IKE CLI:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IKE CLI:7 PFS:YES

COMMAND EXECUTED

C IKE CLI: | Clear client connection (Administrator)
 | C IKE CLI:xx

It deletes the specified entry from the client connections table. The client connection identifier must be in the interval [0 - 63].

If the requested entry is not present in the table, the following error message will be displayed: "IKE CLIENT CONNECTION NOT PRESENT".

If the client connections table is empty, the following message will be shown "IKE CLIENT CONNECTIONS TABLE IS EMPTY".

Changes made on the client connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:C IKE CLI:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:C IKE CLI:10

IKE CLIENT CONNECTION NOT PRESENT

D IKE CLI: | Display client connection (User)
 | D IKE CLI D IKE CLI:xx

It shows the client connections table.

If the identifier is omitted, the command will show all client connections currently set.

Here is an example of the command execution:

[21:28:23] ABILIS_CPX:D IKE CLI

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
CLI: NAME:                            HOST-ID: RULE:        LIFE-TIME:    PFS:
     ESP: ESP-CIPHER: ESP-AUTH:       PASSIVE: PERMANENT:   NET-SRC:
     AH:              AH-AUTH:                 TUNNEL:      NET-DST:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2                   0        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.003.000/24
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_3                   1        IPSEC        28800         YES
     YES  3DES        MD5             YES      YES          192.168.001.000/24
     NO               MD5                      YES          192.168.004.000/24
-------------------------------------------------------------------------------

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the client connections table is empty, the following message will be shown "*** NO IKE CLIENT CONNECTIONS DEFINED ***".

By specifying the client connection identifier, the command will show only the requested client connection.

[00:15:04] ABILIS_CPX:D IKE CLI:0

Parameter:   |Value:
------------------------------------------------------------------------------
CLI:          0
NAME:         CPX_1-to-CPX_2
HOST-ID:      0
RULE:         IPSEC
PASSIVE:      YES
PERMANENT:    YES
TUNNEL:       YES
ESP:          YES
ESP-CIPHER:   3DES
ESP-AUTH:     MD5
AH:           NO
AH-AUTH:      MD5
LIFE-TIME:    28800
PFS:          YES
NET-SRC:      192.168.001.000/24
NET-DST:      192.168.003.000/24
------------------------------------------------------------------------------

The identifier must be in the interval [0 - 63]. If the requested entry is not present in the table, the following error message will be displayed: "IKE CLIENT CONNECTION NOT PRESENT".

For a more detailed description of the shown information, refer the Client connections table of the IKE port section.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

S IKE CLI: | Set client connection (Administrator)
 | S IKE CLI:xx par:val [par:val]

It sets parameters of the specified client connection to their new values.

The specified client connection identifier value must be in the interval [0 - 63]. If the requested entry is not present in the table, the following error message will be displayed: "IKE CLIENT CONNECTION NOT PRESENT".

If the client connections table is empty, the following message will be shown "IKE CLIENT CONNECTIONS TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the client connections table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Example:
[10:32:14] ABILIS_CPX:S IKE CLI:7 ESP-AUTH:SAH

COMMAND EXECUTED

IKE pre-shared keys (PSK) table top

A IKE PSK: | Add preshared key (Administrator)
 | A IKE PSK:xx [par:val]

It adds a new entry to the preshared keys table in the "ID:xx" position. The command can also set eventually indicated parameters to the specified values.

The preshared keys table can store up to 64 entries, therefore the preshared key identifier value must be in the interval [0 - 63].

IKE preshared key configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a IKE preshared key already present in the table the message "IKE PRESHARED KEY ALREADY EXISTS" will be shown

If the preshared keys table is full and a preshared key is asked to be added, an error message is generated: "IKE PRESHARED KEY TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the preshared keys table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:A IKE PSK:2

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IKE PSK:7 ID-TYPE:IP

COMMAND EXECUTED

C IKE PSK: | Clear preshared key (Administrator)
 | C IKE PSK:xxx

It deletes the specified entry from the preshared keys table. The preshared key identifier must be in the interval [0 - 63].

If the requested entry is not present in the table, the following error message will be displayed: "IKE PRESHARED KEY NOT PRESENT".

If the preshared keys table is empty, the following message will be shown "IKE PRESHARED KEYS TABLE IS EMPTY".

Changes made on the preshared keys table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:C IKE PSK:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:C IKE PSK:10

IKE PRESHARED KEY NOT PRESENT

D IKE PSK: | Display preshared key (User)
 | D IKE PSK D IKE PSK:xx

It shows the preshared keys table.

If the identifier is omitted, the command will show all client connections currently set.

Here is an example of the command execution:

[21:28:23] ABILIS_CPX:D IKE PSK

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
PSK: KEY:     ID-TYPE:  IP:             FQDN:
-------------------------------------------------------------------------------
0    ******** IP        192.168.002.001
1    ******** ANONYMOUS
2    ******** FQDN                      konstt
-------------------------------------------------------------------------------

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the client connections table is empty, the following message will be shown "*** NO IKE PRESHARED KEYS DEFINED ***".

By specifying the preshared key identifier, the command will show only the requested preshared key.

[00:15:04] ABILIS_CPX:D IKE PSK:2

Parameter:   |Value:
------------------------------------------------------------------------------
PSK:          2
KEY:          ********
ID-TYPE:      FQDN
FQDN:         konstt
------------------------------------------------------------------------------

The identifier must be in the interval [0 - 63]. If the requested entry is not present in the table, the following error message will be displayed: "IKE PRESHARED KEY NOT PRESENT".

For a more detailed description of the shown information, refer the Pre-shared key (PSK) table of the IKE port section.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

S IKE PSK: | Set preshared key (Administrator)
 | S IKE PSK:xx par:val [par:val]

It sets parameters of the specified preshared key to their new values.

The specified preshared key identifier value must be in the interval [0 - 63]. If the requested entry is not present in the table, the following error message will be displayed: "IKE PRESHARED KEY NOT PRESENT".

If the preshared keys table is empty, the following message will be shown "IKE PRESHARED KEYS TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the preshared keys table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IKE port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IKE service, the following message will be shown "IKE SERVICE NOT PRESENT".

Example:
[10:32:14] ABILIS_CPX:S IKE PSK:7 KEY:1234567890

COMMAND EXECUTED


Commands relating to IP Router

IP ports
IP routings
Saved static IP routings
IP source routings
IP Routing administrative distances

IP access list

State commands and statistics
Initialization commands

Other commands

IP Ports top

A IPP | Add IP port (Administrator)
 | A IPP:xx [par:val]

It adds a new IP port definition, identified by "IPP:xx". It also set the parameters to the values eventually specified. The not specified parameters are set to default values.

IP table can store up to 64 definitions, therefore the IP port identifier must be in the interval [0 - 63].

Definitions may not have consecutive identifiers, therefore new definition can have any identifier value less than the maximum (63).

If a port, whose "IPP:xx" is already used in the table, is going to be added, the following error message is generated: "IP PORT ALREADY EXISTS".

If the IP table is full and a new definition is asked to be added, an error message is generate: "IP PORT TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the IP ports table are not immediately active. For their activation, it is needed to execute the initialization command INIT IPP, that refreshes all IP Ports parameters and purges queues, or the command INIT IPP:xxx, that refreshes the specified IP port parameters only.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

C IPP | Clear IP port (Administrator)
 | C IPP:xx

It removes the requested IP port from the IP port table.

IP port identifiers must be in the interval [0 - 63]. If no port matches the identifier, the following error message is displayed "IP PORT NOT PRESENT".

If the IP port table is empty, the message "IP PORT TABLE IS EMPTY" is generated.

Ports, whose IPP is higher than the removed one, are not decremented because of contiguity. The removed definition frees a place in the table, which won't be displayed by the command D IPP execution.

Changes made on the IP ports table are not immediately active. For their activation, it is needed to execute the initialization command INIT IPP, that refreshes all IP Ports parameters and purges queues, or the command INIT IPP:xxx, that refreshes the specified IP port parameters only.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

D IPP | Display IP port (User)
 | D IPP D IPP:xx

It shows the IP port table.

By omitting the IP port identifier, the command will show all the ports currently defined.

Here is an example of the command execution:

[16:44:11] ABILIS_CPX: D IPP

IPRTR (PO:900) parameters:  R-ID:AUTO (192.168.000.213)

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

IPP:0  - Lan_ip_port ----------------------------------------------------------
ACT    IPADD:192.168.000.213                       MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LAN            REDIS:YES             RP:RIP
       BRD:NET               LOWPO:158   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - RIP section ----------------------------------------------------------
       RIPSEND:RIP2B    RIPRECV:BOTH     RIPNU:YES    RIPMETRIC:1
       - TRFA section ---------------------------------------------------------
       TRFA:YES  trfa-mode:FULL      ip-reserve:AUTO  TRFA-IPADD:LOCAL

IPP:1  - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
NEW    ------------------------------------------------------------------------
       IPADD:000.000.000.000 NEIGH:000.000.000.000 MTU:1500       FRAG:NO
       MASK :255.255.255.255 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NONE
       ENC:RAW-IP            LOWPO:NONE  HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - TRFA section ---------------------------------------------------------
       TRFA:NO

IPP:5  - test_line ------------------------------------------------------------
ACT    IPADD:000.000.000.000 NEIGH:000.000.000.000 MTU:1500       FRAG:NO
       MASK :255.255.255.000 NAT:OUTSIDE SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NONE
       ENC:RAW-IP            LOWPO:3     HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - TRFA section ---------------------------------------------------------
       TRFA:YES  trfa-mode:FULL      ip-reserve:AUTO  TRFA-IPADD:LOCAL

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

By specifying IP port identifier, the command will show the definition of the requested port. IP port identifier must be in the interval [0 - 63]. If does not exist any port with that identifier, an error message is generated: "IP PORT NOT PRESENT".

Here is an example of the execution of the command "D IPP:1", displayed values are the default ones:

[16:44:11] ABILIS_CPX: D IPP:1

IPP:1  - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
NEW    ------------------------------------------------------------------------
       IPADD:000.000.000.000 NEIGH:000.000.000.000 MTU:1500       FRAG:NO
       MASK :255.255.255.255 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LINK           REDIS:YES             RP:NONE
       ENC:RAW-IP            LOWPO:NONE  HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - TRFA section ---------------------------------------------------------
       TRFA:NO

The "Not Saved (SAVE CONF)" message is displayed every time the IP port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the IP port configuration is modified but not refreshed with the initialization command.

If the IP port table is empty, the following message is generated: "IP PORT TABLE IS EMPTY". Definitions may not have consecutive identifiers, that's why the not shown IPP values correspond to free places in the table.

In conclusion, as it is possible to notice from the previous examples, for those IP ports, which have been assigned a description, the command will display in the first row the informative string set by the User through the command A D.

S IPP | Set IP port (Administrator)
 | S IPP:xx par:val [par:val]

It sets the parameters to their new values for the specified port.

IP port identifiers must be in the interval [0 - 63]. If no port matches the identifier, the following error message is displayed "IP PORT NOT PRESENT".

If the IP port table is empty, the message "IP PORT TABLE IS EMPTY" is generated.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the IP ports table are not immediately active. For their activation, it is needed to execute the initialization command INIT IPP, that refreshes all IP Ports parameters and purges queues, or the command INIT IPP:xxx, that refreshes the specified IP port parameters only.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

IP routings top

A IPR | Add IP routing (Administrator)
 | A IPR NET:x.x.x.x/yy [par:val] [-FD] A IPR NET:x.x.x.x MASK:y.y.y.y [par:val] [-FD]

It adds a new IP routing definition and it sets any other parameters that is eventually indicated to the specified values. The not specified parameters are set to their default values.

The destination network address and the related mask can be specified either using the Slash Notation (e.g. NET:x.x.x.x/yy) or using the Dotted Decimal Notation for both the network address and the related mask (e.g. NET:x.x.x.x MASK:y.y.y.y).

Allowed values for the destination network address must be in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255].

When Slash Notation is used, valid values for the network mask mast be in the range [0-32]; while values in the range [0.0.0.0 - 255.255.255.255] are accepted in Dotted Decimal Notation.

Doing the "logical AND" between destination network address and the mask values, the result should be the destination network address itself; if not the message "INVALID STATIC NETWORK" will be shown and the new definition addition will be refused.

This command can be only used to add static IP routings to the table.

Once added, an IP routing is unambiguously identified by the destination network address and the related mask. If an IP routing with the same destination network address and mask values of the specified one is already present in the table, an error message will be displayed "STATIC ROUTING IS ALREADY PRESENT".

The "-FD" option can be optionally specified to force routing duplication, i.e. the addition of two routings with the same destination network and mask, but with different destination IP port. E.g.:

Destination routes and conditional source routes:
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|B|P|S|H|     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|AD:|
| | | | |                    |   SRNET:/SRMASK:   |                 |    |   |
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|*|S| | | 001.001.001.001/32 | 255.255.255.255    |                 |D  1|  1|
| |S| | | 001.001.001.001/32 | 255.255.255.255    |                 |NONE|  1|
+-+-+-+-+--------------------+--------------------+-----------------+----+---+

If the table is full and a new IP routing is going to be added, the following error message will be displayed: "IP ROUTING TABLE OVERFLOW COMMAND NOT EXECUTED".

Changes made on the IP routings table are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C IPR | Clear IP routing (Administrator)
 | C IPR NET:x.x.x.x [par:val]

It deletes from the table the IP routing identified by the specified destination network "NET:x.x.x.x", expressed in Dotted Decimal Notation.

Allowed values for the destination network address must be in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255].

This command can be only used to remove static IP routings from the table.

Once added, an IP routing is unambiguously identified by the destination network address and the related mask. If one or more IP routings with the same destination network address of the specified one are present in the table, the user should specify one or more additional parameters in order to allow the unambiguous identification of the definition. Otherwise the result of the command will be the following:

[16:12:05] ABILIS_CPX: C IPR NET:1.1.1.1

 +-----+--------------------+-----------------+-----------------+----+
 |HIDE:|        NET:        |      MASK:      |        GW:      |IPP:|
 +-----+--------------------+-----------------+-----------------+----+
 |  NO | 001.001.001.001/32 | 255.255.255.255 | 000.000.000.000 |D  1|
 |  NO | 001.001.001.001/32 | 255.255.255.255 | 000.000.000.000 |NONE|
 +-----+--------------------+-----------------+-----------------+----+

More routing match. Please specify additional parameters.

On the contrary, if no entry is found for the specified parameter's values, the message "STATIC ROUTING NOT FOUND" will be generated.

Changes made on the IP routings table are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D IPR | Display IP routing (User)
 | D IPR [filter:value]

It shows the IP routing table.

In absence of additional parameters, the command will show all the routings.
Here is an example of the command "D IPR" execution:

[11:18:14] ABILIS_CPX: D IPR

- Not Saved (SAVE CONF) -------------------------------------------------------

[16:41:28] CPX_TRFA_213:d ipr

Unconditional source routes:
+-------+--------------------+--------------------+-----------------+----+---+
|       |     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|   |
|       |                    |   SRNET:/SRMASK:   |                 |    |   |
+-------+--------------------+--------------------+-----------------+----+---+
|       | 002.002.000.000/16 | 255.255.000.000    |                 |    |   |
|       |                    | 005.005.005.005/32 |                 |D  2|   |
|       |                    | 005.005.005.005/32 |                 |D  1|   |
+-------+--------------------+--------------------+-----------------+----+---+

Destination routes and conditional source routes:
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|B|P|S|H|     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|AD:|
| | | | |                    |   SRNET:/SRMASK:   |                 |    |   |
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|*|S| | | 001.001.001.001/32 | 255.255.255.255    |                 |D  1|  1|
| |S| | | 001.001.001.001/32 | 255.255.255.255    |                 |NONE|  1|
| | | | |                    | 005.005.005.005/32 |                 |NONE|   |
|*|S| | | 001.005.005.005/32 | 255.255.255.255    |                 |NONE|  1|
|*|S| |*| 002.002.002.002/32 | 255.255.255.255    |                 |  10|  1|
| |S| | | 002.002.002.002/32 | 255.255.255.255    |                 |NONE|  1|
|*|S| | | 002.002.002.003/32 | 255.255.255.255    |                 |  10|  1|
|*|S| |*| 005.005.005.005/32 | 255.255.255.255    |                 |   5|  1|
|*|S| | | 005.005.005.006/32 | 255.255.255.255    |                 |   6|  1|
|*|S| | | 009.009.009.009/32 | 255.255.255.255    |                 |NONE|  1|
|*|S| | | 010.000.000.001/32 | 255.255.255.255    |                 |   5|  5|
|*|S| | | 032.032.032.032/32 | 255.255.255.255    |                 |  32|  1|
|*|S| | | 192.168.000.005/32 | 255.255.255.255    |                 |  15|  1|
|*|R| | | 192.168.000.060/32 | 255.255.255.255    | 192.168.000.060 |   0|120|
|*|C| | | 192.168.000.213/32 | 255.255.255.255    |                 |R-ID|  0|
|*|C| | | 192.168.010.001/32 | 255.255.255.255    |                 |  30|  0|
|*|C| | | 192.168.031.213/32 | 255.255.255.255    |                 |  31|  0|
|*|C| | | 212.025.018.178/32 | 255.255.255.255    |                 |  30|  0|
|*|C| | | 006.006.006.000/24 | 255.255.255.000    |                 |D 63|  0|
|*|C| | | 192.168.000.000/24 | 255.255.255.000    |                 |   0|  0|
|*|R| | | 192.168.001.000/24 | 255.255.255.000    | 192.168.000.060 |   0|120|
|*|S| | | 192.168.006.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
|*|S| | | 192.168.008.000/24 | 255.255.255.000    | 192.168.000.251 |   0|  1|
|*|C| | | 002.002.000.000/16 | 255.255.000.000    |                 |  40|  0|
| |S| | | 002.002.000.000/16 | 255.255.000.000    |                 |  40|  1|
| | | | |                    | 005.005.005.005/32 |                 |   0|   |
| | | | |                    | 005.005.005.005/32 |                 |NONE|   |
|*|S| | | 010.000.000.000/16 | 255.255.000.000    | 192.168.000.253 |   0|  1|
+-+-+-+-+--------------------+--------------------+-----------------+----+---+

It is possible to use additional parameters for filtering the selection of the routing to be displayed. Then only those routings that match the requests will be displayed.
Here is an example of the command "D IPR NET:192.168.000.000" execution:

[17:35:12] CPX_TRFA_213: D IPR NET:192.168.000.000

- Not Saved (SAVE CONF) -------------------------------------------------------

Unconditional source routes:
+-------+--------------------+--------------------+-----------------+----+---+
|       |     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|   |
|       |                    |   SRNET:/SRMASK:   |                 |    |   |
+-------+--------------------+--------------------+-----------------+----+---+

Destination routes and conditional source routes:
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|B|P|S|H|     NET:/MASK:     |      MASK: or      |       GW:       |IPP:|AD:|
| | | | |                    |   SRNET:/SRMASK:   |                 |    |   |
+-+-+-+-+--------------------+--------------------+-----------------+----+---+
|*|C| | | 192.168.000.000/24 | 255.255.255.000    |                 |   0|  0|
+-+-+-+-+--------------------+--------------------+-----------------+----+---+

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Here is a brief description of the optional parameters allowed by the command:

Parameter | Description
P: | Routing provenience [C(connected), S (static), O, R ( obtained form the RIP/OSPF routing algorithm)]; it can be used for displaying IP routings by their source.
H: | It sets if the static routing (can) has to be invisible to other routers during RIP/OSPF refreshing [NO, YES]; it can be used for displaying IP routings by the same feature.
NET: | IP address of the destination network (in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255]) or destination network address and mask (in the range [0-32]) in Slash Notation; it can be used for displaying IP routings with the same destination network.
MASK: | Mask associated to the destination network, expressed in Dotted Decimal Notation (in the range [0.0.0.0 - 255.255.255.255]); it can be used for displaying IP routings characterized by a certain mask.
SRNET: | IP address of the source routing network (in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255]) or source routing network address and mask (in the range [0-32]) in Slash Notation; it can be used for displaying IP routings with the same source routing network.
SRMASK: | Source routing network mask, expressed in Dotted Decimal Notation (in the range [0.0.0.0 - 255.255.255.255]); it can be used for displaying IP routings characterized by a certain source routing network mask.
GW: | IP address of the destination Gateway in Dotted Decimal Notation (in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255]); it can be used for displaying IP routings characterized by a certain destination Gateway.
IPP: | Destination IP port [0 - 63]; it can be used for displaying IP routings characterized by a given IP port.
UN: | Unconditional source routing [NO, YES]; it can be used for displaying unconditional source routes only.

For a more detailed description of shown information, please refer to the IP routings section.

S IPR | Set IP routing (Administrator)
 | S IPR NET:x.x.x.x [par:val]

It sets one or more parameters to their new values, in the IP routing identified by the specified destination network "NET:x.x.x.x", expressed in Dotted Decimal Notation.

Allowed values for the destination network address must be in the range [0.0.0.0, 1.0.0.0-126.255.255.255, 128.0.0.0-223.255.255.255].

This command can be only used to modify static IP routing definitions in the table.

Once added, an IP routing is unambiguously identified by the destination network address and the related mask. If one or more IP routings with the same destination network address of the specified one are present in the table, the user should specify one or more additional parameters in order to allow the unambiguous identification of the definition. Otherwise the result of the command result will be the following:

[16:12:05] ABILIS_CPX: S IPR NET:1.1.1.1

 +-----+--------------------+-----------------+-----------------+----+
 |HIDE:|        NET:        |      MASK:      |        GW:      |IPP:|
 +-----+--------------------+-----------------+-----------------+----+
 |  NO | 001.001.001.001/32 | 255.255.255.255 | 000.000.000.000 |D  1|
 |  NO | 001.001.001.001/32 | 255.255.255.255 | 000.000.000.000 |NONE|
 +-----+--------------------+-----------------+-----------------+----+

More routing match. Please specify additional parameters.

On the contrary, if no entry is found for the specified parameter's values, the message "STATIC ROUTING NOT FOUND" will be generated.

The parameter's list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the IP routings table are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Saved static IP routings top

A IPRS A SIPR | Add saved static IP routing (Available only in off-line Configurator)
 | A IPRS ID:xxx [par:val] A SIPR ID:xxx [par:val]

It adds new saved static IP routing. The command can only be executed for adding static IP routing by off-line configurator.

The table of saved static IP routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If a new IP routing, whose "ID:xxx" identifier is already present in the table, is going to be added, an error message will be display "STATIC IP ROUTING ALREADY EXISTS".

If the table is full and a new IP routing is going to be added, the following error message will be displayed: "STATIC IP ROUTING TABLE OVERFLOW, COMMAND NOT EXECUTED".

Optional parameters can be set together with the routing addition. The not specified parameters are set to their default values.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C IPRS C SIPR | Clear saved static IP Routing (Available only in off-line Configurator)
 | C IPRS ID:xxx C SIPR ID:xxx

It removes a static IP routing from the saved ones table. The command can only be executed for deleting static IP routing by off-line configurator.

The table of saved static IP routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If the requested IP routing is not present in the table, the error message "STATIC IP ROUTING NOT PRESENT" will be generated. If the table of saved static IP routings is empty, the following message will be displayed: "STATIC IP ROUTING TABLE IS EMPTY".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D IPRS D SIPR | Display saved static IP routing (User)
 | D IPRS [ID:xxx] D SIPR [ID:xxx]

It shows saved static IP routings.

Here is an example of the command execution:

[17:22:35] ABILIS_CPX: D SIPR

+-----+-------+-----------------+-----------------+-----------------+------+
| ID: | HIDE: |      NET:       |      MASK:      |       GW:       | IPP: |
+-----+-------+-----------------+-----------------+-----------------+------+
|   0 |  YES  | 002.002.002.002 | 255.255.255.255 | 000.000.000.000 |   10 |
|   1 |  NO   | 002.002.002.003 | 255.255.255.255 | 000.000.000.000 |   10 |
|   2 |  YES  | 005.005.005.005 | 255.255.255.255 | 000.000.000.000 |    5 |
|   3 |  NO   | 005.005.005.006 | 255.255.255.255 | 000.000.000.000 |    6 |
|   4 |  NO   | 010.000.000.001 | 255.255.255.255 | 000.000.000.000 |    5 |
|   5 |  NO   | 032.032.032.032 | 255.255.255.255 | 000.000.000.000 |   32 |
|   6 |  NO   | 192.168.006.000 | 255.255.255.000 | 192.168.000.251 |    0 |
|   7 |  NO   | 192.168.008.000 | 255.255.255.000 | 192.168.000.251 |    0 |
|   8 |  NO   | 002.002.000.000 | 255.255.000.000 | 000.000.000.000 |   40 |
|   9 |  NO   | 010.000.000.000 | 255.255.000.000 | 192.168.000.253 |    0 |
|  10 |  NO   | 000.000.000.000 | 000.000.000.000 | 192.168.000.232 |    0 |
+-----+-------+-----------------+-----------------+-----------------+------+

By specifying the routing identifier, the command will display only the requested routing, of course if it is present in the table.

The table of saved static IP routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If no static IP routing exists with that identifier, the message "STATIC IP ROUTING NOT PRESENT" will be displayed.

If the table of saved static IP routings is empty, the following message will be displayed: "STATIC IP ROUTING TABLE IS EMPTY".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

For a more detailed description of shown information, please refer to the Saved static IP routings section.

S IPRS S SIPR | Set saved static IP routing (Available only in off-line Configurator)
 | S IPRS ID:xx par:val [par:val] S SIPR ID:xx par:val [par:val]

It sets the parameters of the specified saved static IP routing to their new values. The command can only be executed for setting static IP routing by off-line configurator.

The table of saved static IP routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If no static IP routing exists with that identifier, the message "STATIC IP ROUTING NOT PRESENT" will be displayed.

If the table of saved static IP routings is empty, the following message will be displayed: "STATIC IP ROUTING TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

IP source routings top

A IPSR | Add IP source routing (Available only in off-line Configurator)
 | A IPSR ID:xxx [par:val]

It adds new IP source routing. The command can only be executed by off-line configurator.

The table of IP source routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If a new IP routing, whose "ID:xxx" identifier is already present in the table, is going to be added, an error message will be display "IP SOURCE ROUTING ALREADY EXISTS".

If the table is full and a new IP routing is going to be added, the following error message will be displayed: "IP SOURCE ROUTING TABLE OVERFLOW, COMMAND NOT EXECUTED".

Optional parameters can be set together with the routing addition. The not specified parameters are set to their default values.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C IPSR | Clear IP source routing (Available only in off-line Configurator)
 | C IPSR ID:xxx

It removes an existing IP source routing from the related table. The command can only be executed by off-line configurator.

The table of IP source routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If the requested IP routing is not present in the table, the error message "IP SOURCE ROUTING NOT PRESENT" will be generated. If the table of IP source routings is empty, the following message will be displayed: "IP SOURCE ROUTING TABLE IS EMPTY".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D IPSR | Display IP source routing (User)
 | D IPSR [ID:xxx]

It shows IP source routings.

Here is an example of the command execution:

[11:02:59] ABILIS_CPX: D IPSR

+-----+--------------------+--------------------+-----------------+------+----+
| ID: |     NET:/MASK:     |   SRNET:/SRMASK:   |        GW:      | IPP: | UN:|
+-----+--------------------+--------------------+-----------------+------+----+
|   0 | 001.001.001.001/32 | 005.005.005.005/32 | 000.000.000.000 | NONE | NO |
|   1 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    0 | NO |
|   2 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 | NONE | NO |
|   3 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    2 | YES|
|   4 | 002.002.000.000/16 | 005.005.005.005/32 | 000.000.000.000 |    1 | YES|
+-----+--------------------+--------------------+-----------------+------+----+

By specifying the routing identifier, the command will display only the requested routing, of course if it is present in the table.

The table of IP source routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If no IP source routing exists with that identifier, the message "IP SOURCE ROUTING NOT PRESENT" will be displayed.

If the table of IP source routings is empty, the following message will be displayed: "*** NO SOURCE ROUTINGs DEFINED ***".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

For a more detailed description of shown information, please refer to the IP source routings section.

S IPSR | Set IP source routing (Available only in off-line Configurator)
 | S IPSR ID:xxx par:val [par:val]

It sets the parameters of the specified IP source routing to their new values. The command can only be executed for setting IP source routing parameter by off-line configurator.

The table of IP source routings can store up to 255 routings, therefore the identifier of the specified routing must be in the interval [0 - 254].

If no IP source routing exists with that identifier, the message "IP SOURCE ROUTING NOT PRESENT" will be displayed.

If the table of IP source routings is empty, the following message will be displayed: "IP SOURCE ROUTING TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

IP Routing administrative distances top

A IPAD | Add IP Routing Administrative distance (Administrator)
 | A IPAD NET:x.x.x.x/yy PROT:val [par:val]

This command adds a new entry to the IP Routing Administrative distance table and it sets additional parameters that are eventually specified.

The "NET:" parameter value must consist in a network address plus the related network mask, in Slash Notation.
Valid network addresses must be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network address and mask values, the result should be the network address value itself.

The "PROT:" parameter value must correspond to a routing protocol value in the range [NONE, LOCAL, STATIC, OSPF, RIP].

Every entry in the IP Routing Administrative Distances table is unambiguously identified by its "NET:" and "PROT:" parameters values.
If the indicated entry matches an already existing entry, the following message will be displayed "IP ROUTING ADMINISTRATIVE DISTANCE ALREADY PRESENT".

If the table is full, i.e. no free record is currently available, the message "IP ROUTING ADMINISTRATIVE DISTANCEs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the IP Routing Administrative distance table are NOT immediately active, they can be activated by executing the initialization command INIT IPAD.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

If the Abilis CPX version, currently in use, does not support IP Routing Administrative Distances services, the following message will be shown "IP ROUTING ADMINISTRATIVE DISTANCE SERVICE NOT PRESENT".

C IPAD | Clear IP Routing Administrative distance (Administrator)
 | C IPAD NET:x.x.x.x/yy PROT:val

This command deletes the specified entry from the IP Routing Administrative distance table, if it is present.

Every entry in the IP Routing Administrative Distances table is unambiguously identified by its "NET:" and "PROT:" parameters values. If the specified entry is not present the message "IP ROUTING ADMINISTRATIVE DISTANCE NOT PRESENT" will be displayed.

The "NET:" parameter value must consist in a network address plus the related network mask, in Slash Notation.
Valid network addresses must be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between Network address and mask values, the result should be the network address value itself.

The "PROT:" parameter value must correspond to a routing protocol value in the range [NONE, LOCAL, STATIC, OSPF, RIP].

If the table is empty, the following message is generated: "IP ROUTING ADMINISTRATIVE DISTANCEs TABLE IS EMPTY".

Changes made on the IP Routing Administrative distance table are NOT immediately active, they can be activated by executing the initialization command INIT IPAD.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

If the Abilis CPX version, currently in use, does not support IP Routing Administrative Distances services, the following message will be shown "IP ROUTING ADMINISTRATIVE DISTANCE SERVICE NOT PRESENT".

D IPAD | Display IP Routing Administrative distances (Administrator)
 | D IPAD D IPAD NET:x.x.x.x/yy PROT:val

This command displays configured IP Routing Administrative distance's entries.

Here is an example of the information shown by the command execution:

[10:49:13] ABILIS_CPX: D IPAD

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

+--------------------+----------+-----------+--------+
|        NET:        |   PROT:  | DISTANCE: |  IPP:  |
+--------------------+----------+-----------+--------+
| 001.001.001.001/32 |  NONE    |       255 |        |
| 001.001.001.001/32 |  STATIC  |         1 |     *  |
| 002.002.002.002/32 |  STATIC  |         2 |  NONE  |
| 002.002.002.002/32 |  OSPF    |       255 |        |
| 002.002.002.002/32 |  RIP     |       255 |        |
| 192.168.006.002/32 |  STATIC  |         1 |     0  |
+--------------------+----------+-----------+--------+

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command INIT IPAD.

If no entry is currently defined the message "*** NO IP ROUTING ADMINISTRATIVE DISTANCEs DEFINED ***" will be displayed.

The "NET:" and the "PROT:" parameters allows to display the specified entry of the table, if it is present.

[16:54:38] ABILIS_CPX: D IPAD NET:192.168.006.002/32 PROT:STATIC

+--------------------+----------+-----------+--------+
|        NET:        |   PROT:  | DISTANCE: |  IPP:  |
+--------------------+----------+-----------+--------+
| 192.168.006.002/32 |  STATIC  |         1 |     0  |
+--------------------+----------+-----------+--------+

The "NET:" parameter value must consist in a network address plus the related network mask, in Slash Notation.
Valid network addresses must be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

The "PROT:" parameter value must correspond to a routing protocol value in the range [NONE, LOCAL, STATIC, OSPF, RIP].

Every entry in the IP Routing Administrative Distances table is unambiguously identified by its "NET:" and "PROT:" parameters values. If the specified entry is not present the message "IP ROUTING ADMINISTRATIVE DISTANCE NOT PRESENT" will be displayed.

If the Abilis CPX version, currently in use, does not support IP Routing Administrative Distances services, the following message will be shown "IP ROUTING ADMINISTRATIVE DISTANCE SERVICE NOT PRESENT".

For a more detailed description of the displayed information, please refer to the Administrative distance table section of IP routings.

S IPAD | Set IP Routing Administrative distance (Administrator)
 | S IPAD NET:x.x.x.x/yy PROT:val par:val [par:val]

This command sets parameters of the selected entry of the IP Routing Administrative Distances table.

Every entry in the IP Routing Administrative Distances table is unambiguously identified by its "NET:" and "PROT:" parameters values. If the specified entry is not present the message "IP ROUTING ADMINISTRATIVE DISTANCE NOT PRESENT" will be displayed.

The "NET:" parameter value must consist in a network address plus the related network mask, in Slash Notation.
Valid network addresses must be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid mask values must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between Network address and mask values, the result should be the network address value itself.

The "PROT:" parameter value must correspond to a routing protocol value in the range [NONE, LOCAL, STATIC, OSPF, RIP].

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a more detailed description of IP Routing Administrative distance entry's parameters, please refer to the Administrative distance table section of IP routings.

Changes made on the IP Routing Administrative distance table are NOT immediately active, they can be activated by executing the initialization command INIT IPAD.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the initialization command.

If the Abilis CPX version, currently in use, does not support IP Routing Administrative Distances services, the following message will be shown "IP ROUTING ADMINISTRATIVE DISTANCE SERVICE NOT PRESENT".

IP access list top

A IPACL | Add IP Access List (Administrator)
 | A IPACL PR:xxx TYPE:val SA:val DA:val PROT:val [SPO:val DPO:val] [par:val] A IPACL PR:xx TYPE:val SA:val DA:val PROT:val [PO:val] [par:val]

It adds a new filter to the IP access list, with priority "PR:xxx" and it sets the requested parameters to the specified values. The not specified parameters are set to their default values.

It is possible, by typing "A IPACL PR: ?", to have a complete list of syntax and allowed options of the command. For example:

[12:04:05] ABILIS_CPX: A IPACL PR: ?

IP Access List parameters:

TYPE:      Access list type [DENY, PERMIT]                          <Mandatory>
SA:        Source Ip Addresses Range:                               <Mandatory>
           a single Ip address [1.0.0.0-126.255.255.255, 128.0.0.0-
           223.255.255.255] or two Ip addresses separated by ':' (colon) or "*"
           (Any Ip address) or the name of an IP/IR/RU/MR list between primes.
           (Es.: 150.200.192.192 or 192.168.0.0:192.168.0.100 or * or 'List')
DA:        Destination Ip Addresses Range:                          <Mandatory>
           a single Ip address [1.0.0.0-126.255.255.255, 128.0.0.0-
           223.255.255.255] or two Ip addresses separated by ':' (colon) or "*"
           (Any Ip address) or the name of an IP/IR/RU/MR list between primes.
           (Es.: 150.200.192.192 or 192.168.0.0:192.168.0.100 or * or 'List')
PROT:      Internet Protocol:                                       <Mandatory>
           Internet protocol mnemonic or decimal value [1..254] or "*" (Any
           Internet protocol) or "tcpudp" or the name of an IPT/RU/MR list
           between primes. (Es.: icmp or 1 or * or tcpudp or 'List)
PO:        Source or destination Ports Range:      <Mandatory for PROT:TCP/UDP>
           a single port mnemonic or decimal value [1..65535] or two port
           values separated by ':' (colon) or "*" (Any port) or the name of a
           TUP/RU/MR list between primes. (Es.: 23 or SSH or 1:1200 or 'List')
SPO:       Source Ports Range:                     <Mandatory for PROT:TCP/UDP>
           a single port mnemonic or decimal value [1..65535] or two port
           values separated by ':' (colon) or "*" (Any port) or the name of a
           TUP/RU/MR list between primes. (Es.: 23 or SSH or 1:1200 or 'List')
DPO:       Destination Ports Range:                <Mandatory for PROT:TCP/UDP>
           a single port mnemonic or decimal value [1..65535] or two port
           values separated by ':' (colon) or "*" (Any port) or the name of a
           TUP/RU/MR list between primes. (Es.: 23 or SSH or 1:1200 or 'List')
TOS:       Type of Service [D, T, R, C, N or *]                      <Optional>
           (D= Min. Delay; T= Max. Throughput; R= Max. Reliability; C= Min.
           Monetary Cost; N= None; *= ignore.)
SIPP:      Source Ip port [0..63, INT, *]                            <Optional>
DIPP:      Destination Ip port [0..63, INT, *]                       <Optional>
IPCOS:     Ip Class of Service [DFT, HIGH, NORMAL, LOW or D, H, N, L]<Optional>
CRDIR:     Encryption/decryption direction [NONE, ENCRYPT, DECRYPT]  <Optional>
CRKEY:     Encryption/decryption key index [DFT, 1..63]              <Optional>

As it can be seen from the previous example, the command required a large set of mandatory parameters, that must be specified in the definition of new IP access filter:

Parameter Description
TYPE: Type of the filter [DENY, PERMIT].
SA: Source IP address. It may be expressed as:
- a single value, using the Dotted Decimal Notation (E.g.: 150.200.192.192);
- an interval, by separating the two IP addresses with ':' (colon) character (E.g.: 192.168.0.0:192.168.0.100);
- the name of an Elements List of type IP or IR or RU or MR, written between primes (E.g.: 'My_List');
- the "*" (asterisk) string, that stands for "any IP address".
DA: Destination IP address. It may be expressed as:
- a single value, using the Dotted Decimal Notation (E.g.: 150.200.192.192);
- an interval, by separating the two IP addresses with ':' (colon) character (E.g.: 192.168.0.0:192.168.0.100);
- the name of an Elements List of type IP or IR or RU or MR, written between primes (E.g.: 'My_List');
- the "*" (asterisk) string, that stands for "any IP address".
PROT: Internet Protocol. It may be expressed as:
- mnemonic or numeric identifier [1 - 254] of an Internet Protocol (E.g.: tcp or 6);
- the name of an Elements List of type IPT or RU or MR, written between primes (E.g.: 'My_List');
- the "tcpudp" string, that stands for "tcp and/or udp protocols".
- the "*" (asterisk) string, that stands for "any Internet protocol".

If the Internet Protocol is set to "tcp(6)" or "udp(17)" or to the "tcpudp" string, the command requires also to specify the correspondent values of the source and destination TCP/UDP ports:

Parameter Description
SPO: Source port. It may be expressed as:
- mnemonic or numeric identifier [1 - 65535] of a TCP/UDP port (E.g.: telnet or 23);
- an interval, by separating the two TCP/UDP ports value with ':' (colon) character (E.g. 23:161 or telnet:snmp);
- the name of an Elements List of type TUP or RU or MR, written between primes (E.g.: 'My_List');
- the "*" (asterisk) string, that stands for "any TCP/UDP port".
DPO: Destination port. It may be expressed as:
- mnemonic or numeric identifier [1 - 65535] of a TCP/UDP port (E.g.: telnet or 23);
- an interval, by separating the two TCP/UDP ports value with ':' (colon) character (E.g. 23:161 or telnet:snmp);
- the name of an Elements List of type TUP or RU or MR, written between primes (E.g.: 'My_List');
- the "*" (asterisk) string, that stands for "any TCP/UDP port".

In alternative to the parameters "SPO:" and "DPO:" it is possible to use only one parameter, "PO:", that will be used to filter both source port and destination port:

Parameter Description
PO: Source port or destination port. It may be expressed as:
- mnemonic or numeric identifier [1 - 65535] of a TCP/UDP port (E.g.: telnet or 23);
- an interval, by separating the two TCP/UDP ports value with ':' (colon) character (E.g. 23:161 or telnet:snmp);
- the name of an Elements List of type TUP or RU or MR, written between primes (E.g.: 'My_List');
- the "*" (asterisk) string, that stands for "any TCP/UDP port".

These are, on the other hand, the optional parameters allowed by the command:

Parameter | Description
TOS: | Type of Service [D, T, R, C, N or *] (D= Min. Delay; T= Max. Throughput; R= Max. Reliability; C= Min. Monetary Cost; N= None; *= ignore.)
SIPP: | Source IP port [0..63, INT, *]
DIPP: | Destination Ip port [0..63, INT, *]
IPCOS: | IP class of service associated to the access list [DFT, HIGH (or H), NORMAL (or N), LOW (or L)].
CRDIR: | Direction of cryptography [NONE, ENCRYPT, DECRYPT].
CRKEY: | Index of the cryptography key [DFT, 1..63].

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate, no definition will be added to the table, if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) values to be set and others.

IP access list can store up to 256 filter definition, therefore the priority value specified must be in the interval [0 - 255].

If a filter, whose priority is "PR:xxx" is already present in the table, the new filter will occupy the "xxx" entry, while the old one priority will be increased by one.

If "PR:xxx" is higher than the maximum value already present in the table, the new filter will get the maximum value plus one.

If the IP access list is full and a new filter is tried to add, the message "IP ACCESS LIST TABLE IS FULL, COMMAND NOT EXECUTED" will be displayed.

Changes made on the IP access list are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C IPACL | Clear IP Access List (Administrator)
 | C IPACL PR:xx

It deletes the specified definition, if present in the IP access list. The priority value must be in the interval [0 - 255].

The priority of those filters, whose "PR:xxx" is higher that the deleted one, is decremented by one, because of table contiguity.

If the requested filter is not in the table, the following message will be displayed: "IP ACCESS LIST NOT PRESENT".

Changes made on the IP access list are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D IPACL | Display IP Access List
 | D IPACL D IPACL PR:xx

It shows the current content of the IP access list.

By omitting the priority, the command will show all the filters currently in the table.

Here is an example of command "D IPACL" execution:

[18:14:08] ABILIS_CPX: D IPACL

IPRTR (PO:900) parameters:  ACL:NO        ACLBYPASS:#
                            COS:DISABLED  COSDFT:NORMAL

- Not Saved (SAVE CONF) -------------------------------------------------------

Tot-IPACL-Number:4

-------------------------------------------------------------------------------
PR: TYPE:  SA:                               DA:
    IPCOS: PROT:                  SPO:/PO:               DPO:
    TOS:   SIPP:  DIPP:  CRDIR:   CRKEY:
-------------------------------------------------------------------------------
0   PERMIT 001.001.001.001                   002.002.002.002
    DFT    tcp                    telnet(23)
-------------------------------------------------------------------------------
1   DENY   001.001.001.001                   002.002.002.002
           ospf
-------------------------------------------------------------------------------
2   PERMIT 001.001.001.001                   002.002.002.002
    LOW    udp                    snmp(161)              *
    *      *      INT    NONE
-------------------------------------------------------------------------------
3   PERMIT *                                 *
    LOW    *                      *
    *      *      *      ENCRYPT  DFT
-------------------------------------------------------------------------------

The command desn't display information about parameters whose values are the default ones. They will be only displayed if their values have been changed from the default ones. In such way, the description of single entry is simply contained in two rows.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the IP access list is empty the message "*** NO IP ACCESS LISTS DEFINED ***" will be displayed.

By specifying a priority value, the command shows only the definition identified by the "PR:xxx" priority. The priority value must be in the interval [0 - 255].

If specified priority doesn't match any existing filter in the table, the following message will be displayed: "IP ACCESS LIST NOT PRESENT".

For a more detailed description of the information displayed, refer to the Configuration of the IP access list section.

F IPACL | Find IP Access List (User)
 | F IPACL [STD] SrcAddr DstAddr SrcIpp [DstIpp] F IPACL EXT SrcAddr DstAddr Protocol SrcPort DstPort SrcIpp [DstIpp]

It makes possible to verify how the IP datagram, whose characteristics are specified in the command, will be managed depending on the current content of the IP access list.

[14:21:47] ABILIS_CPX: F IPACL ?

F IPACL [STD] SrcAddr DstAddr TOS     Standard Ip forwarding test using IPACL
              SrcIpp [DstIpp]

F IPACL EXT SrcAddr DstAddr TOS       Extended Ip forwarding test using IPACL
            Protocol SrcPort DstPort
            SrcIpp [DstIpp]

SrcAddr           Source Ip Address [1.0.0.0-126.255.255.255, 128.0.0.0-
                  223.255.255.255].                                <Mandatory>
DstAddr           Destination Ip Address [1.0.0.0-126.255.255.255,
                  128.0.0.0-223.255.255.255].                      <Mandatory>
TOS               Type Of Service [NONE or N, COST or C, REL or R, THR or T,
                  DELAY or D]                                      <Mandatory>
Protocol          Internet protocol mnemonic or decimal value [1..254]
                  (Es.: TCP or 6).        <Mandatory for Extended search only>
SrcPort           Source port mnemonic or decimal value [1..65535]
                  (Es.: FTP or 21).     <Mandatory for TCP/UDP protocol only>
DstPort           Destination port mnemonic or decimal value [1..65535]
                  (Es.: TELNET or 23).   <Mandatory for TCP/UDP protocol only>
SrcIpp            Source Ip port [INT, 0..63]
                                                                   <Mandatory>
DstIpp            Destination Ip port [INT, 0..63]
                                                                    <Optional>

The command has two different ways of searching in the IP access list:

  • "Standard" searching mode: the search is made by verifying the source and destination IP address fields, the Type Of Service and source IP port value; optionally it can make a verification on the destination IP port;
  • "Extended" searching mode: the search is made by verifying the source and destination IP address, the Type Of Service, Internet protocol, source and destination ports (required only for TCP and UDP protocols); optionally it can make a verification on the destination IP port;

The following table lists mandatory and optional parameters:

Parameter | Description | Note
SrcAddr | Source IP address [1.0.0.0 - 126.255.255.255, 128.0.0.0 - 223.255.255.255]. | Mandatory for both "Standard" and "Extended" search.
DstAddr | Destination IP address [1.0.0.0 - 126.255.255.255, 128.0.0.0 - 223.255.255.255]. | Mandatory for both "Standard" and "Extended" search.
TOS | Type Of Service [NONE or N, COST or C, REL or R, THR or T, DELAY or D] | Mandatory for both "Standard" and "Extended" search.
SrcIpp | Source IP port [INT, 1 - 63]. | Mandatory for both "Standard" and "Extended" search.
Protocol | Internet protocol mnemonic or decimal value [1 - 254]. | Mandatory for "Extended" search.
SrcPort | Source TCP/UDP port mnemonic or decimal value [1 - 65535]. | Mandatory for "Extended" search, but required for TCP and UDP protocols only.
DstPort | Destination TCP/UDP port mnemonic or decimal value [1 - 65535]. | Mandatory for "Extended" search, but required for TCP and UDP protocols only.
DstIpp | Destination IP port [INT, 1 - 63]. | Optional for both "Standard" and "Extended" search.

Here are some examples of command executions with different results: all of them are pertinent to the following IP access list content:

[15:10:57] ABILIS_CPX: D IPACL

IPRTR (PO:900) parameters:  ACL:NO        ACLBYPASS:#
                            COS:DISABLED  COSDFT:NORMAL

Tot-IPACL-Number:2

-------------------------------------------------------------------------------
PR: TYPE:  SA:                               DA:
    IPCOS: PROT:                  SPO:/PO:               DPO:
    TOS:   SIPP:  DIPP:  CRDIR:   CRKEY:
-------------------------------------------------------------------------------
0   PERMIT *                                 *
    LOW    *                      *
    *      INT    *      NONE
-------------------------------------------------------------------------------
1   DENY   *                                 002.002.002.002
           *                      *
    *      1      *      NONE
-------------------------------------------------------------------------------

EXAMPLE 1: "Standard" search, entered information matches PR:0 filer, which permits IP forwarding:

[19:10:16] ABILIS_CPX: F IPACL 1.1.1.1 1.1.1.2 NONE INT

STANDARD SEARCH RESULT:

MATCH FOUND WITH IPACL PR:0

IP FORWARDING IS PERMITTED:
- IP CLASS OF SERVICE: LOW
- ENCRYPTION/DECRYTPTION DIRECTION: NONE

EXAMPLE 2: "Standard" search, entered information doesn't match any filer, then the IP forwarding is permitted:

[19:10:27] ABILIS_CPX: F IPACL 1.1.1.1 1.1.1.2 NONE 1

STANDARD SEARCH RESULT:

NO MATCH FOUND

IP FORWARDING IS PERMITTED:
- IP CLASS OF SERVICE: NORMAL (COSDFT)
- ENCRYPTION/DECRYTPTION DIRECTION: NONE

EXAMPLE 3: "Extended" search, current IP access list content denies IP forwarding for the specified values:

[15:00:38] ABILIS_CPX: F IPACL EXT 1.1.1.1 2.2.2.2 COST tcp 1024 2000 1

IP FORWARDING IS NOT PERMITTED

EXAMPLE 4: "Extended" search, entered information matches PR:0 filer, which permits IP forwarding:

[15:12:38] ABILIS_CPX: F IPACL EXT 1.1.1.1 2.2.2.2 COST tcp 1024 2000 INT

EXTENDED SEARCH RESULT:

MATCH FOUND WITH IPACL PR:0

IP FORWARDING IS PERMITTED:
- IP CLASS OF SERVICE: LOW
- ENCRYPTION/DECRYTPTION DIRECTION: NONE

If the IP access list is empty, the message: "IP ACCESS LIST TABLE EMPTY" is generated.

M IPACL | Move IP Access list (Administrator)
 | M IPACL PR:xxx PR:yyy

It changes the filter priority value from "PR:xxx" to "PR:yyy". Consequently also its position inside the IP access list will change.

The other definitions are sorted again because of table contiguity.

Priority value must be in the interval [0 - 255]. If the requested filter is not in the table, the following message will be displayed: "IP ACCESS LIST NOT PRESENT".

Changes made on the IP access list are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

S IPACL | Set IP Access list (Administrator)
 | S IPACL PR:xxx par:val [par:val]

It sets the values of the specified filter. Priority value must be in the interval [0 - 255]. If specified priority doesn't match any existing filter in the table, the following message will be displayed: "IP ACCESS LIST NOT PRESENT".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

Changes made on the IP access list are immediately active, they do not need any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

State commands and statistics top

C S IPP | Clear Status IP port (Administrator)
 | C S IPP

It clears the statistics counters of all currently running IP ports.

warning! This command generates events neither in the System Log or in the Events Log; it is up to the User to refer statistics to the proper time interval. it is important to remember that statistics are always cleared at each Abilis CPX start.

If the IP Router is not present, the command will generate an error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "PO:xxx" stands for the IPRTR port identifier.

D S IPP | Display Status IP port (User)
 | D S IPP D S IPP:A D S IPP:xxx

It shows state information about the currently running IP ports.

By specifying the an IP port identifier, the command will display state information of the requested IP port only, of course if it is present and currently running. The identifier must be in the interval [0 - 63].

By specifying the "IPP:A" value or omitting an IP port identifier, the command will display state information of all IP ports.

Here is an example of "D S IPP" command execution:

[18:52:00] ABILIS_CPX: D S IPP

PO:900 ------------------------------------------------------------------------
IPRTR  IPP:0  - Lan_IP_port ---------------------------------------------------
              IFTYPE:LAN                     LOWPO:158    STATE:LINKREADY
       IPP:5  - test_line -----------------------------------------------------
              IFTYPE:LINK     ENC:RAW-IP     LOWPO:3      STATE:LINKREADY
       IPP:6  -----------------------------------------------------------------
              IFTYPE:LINK     ENC:RAW-IP     LOWPO:4      STATE:LINKREADY
       IPP:10 -----------------------------------------------------------------
              IFTYPE:X25BSVC  CDI:920                     STATE:X25CONNECTED
                              CDO:NO
       IPP:15 -----------------------------------------------------------------
              IFTYPE:VIRTUAL                 P-IPP:0      STATE:LINKREADY
       IPP:20 -----------------------------------------------------------------
              IFTYPE:VIRTUAL                 P-IPP:0      STATE:LINKREADY
       IPP:30 -----------------------------------------------------------------
              IFTYPE:PPP      ENC:NONE       LOWPO:541    STATE:LINKREADY
       IPP:31 -----------------------------------------------------------------
              IFTYPE:PPP      ENC:NONE       LOWPO:542    STATE:LINKREADY
       IPP:32 - test-remote ---------------------------------------------------
              IFTYPE:LINK     ENC:RAW-IP     LOWPO:751    STATE:LINKREADY

The last example points out that, if an IP port has its own description, the command will show on the first row the informative string set by the User using the command A D IPP:xxx.

If the IP Router is not present, the command will generate an error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "PO:xxx" stands for the IPRTR port identifier.

D SE IPP | Display Statistics Extended IP port (User)
 | D SE IPP D SE IPP:A D SE IPP:xxx

It shows, in extended format, state information and statistics of IP running port.

By specifying the an IP port identifier, the command will display information of the requested IP port only, of course if it is present and currently running. The identifier must be in the interval [0 - 63].

By specifying the "IPP:A" value or omitting an IP port identifier, the command will display state information of all IP ports.

Here is an example of "D SE IPP" command execution:

[18:52:03] ABILIS_CPX: D SE IPP

PO:900 ------------------------------------------------------------------------
IPRTR  --- Cleared 000:01:23:50 ago, on 16/03/2004 at 17:52:55 ----------------
       IPP:0  - Lan_Ip_Port ---------------------------------------------------
       IFTYPE:LAN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |     615355|     904607|
       DG         |       5222|       2895|ICMP       |          1|          0|
       TCP        |       1873|       2892|UDP        |       3348|          3|
       BRD        |          0|           |CAL        |          0|          0|
       RST        |          0|           |LONG       |          0|          0|
       SHORT      |          0|           |LOST-LOOP  |           |          0|
       LOST-BUF   |           |          0|LOST-OTH   |           |          0|
       B-VER      |          0|           |B-ICMP     |          0|           |
       B-LEN      |          0|           |NO-ROUTE   |          0|           |
       B-FCS      |          0|           |UNK-PROT   |          0|           |
       TTL-EXP    |           |          0|LOST-INC-DG|          0|           |
       LOST-ACC   |          0|           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          0|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------
       IPP:5  - test_line -----------------------------------------------------
       IFTYPE:LINK     ENC:RAW-IP
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |   10905000|   10611000|
       DG         |      10905|      10611|ICMP       |          0|          0|
       TCP        |          0|          0|UDP        |          0|          0|
       BRD        |          0|           |CAL        |          0|          0|
       RST        |          0|           |LONG       |          0|          0|
       SHORT      |          0|           |LOST-LOOP  |           |          0|
       LOST-BUF   |           |          0|LOST-OTH   |           |          0|
       B-VER      |          0|           |B-ICMP     |          0|           |
       B-LEN      |          0|           |NO-ROUTE   |          0|           |
       B-FCS      |          0|           |UNK-PROT   |          0|           |
       TTL-EXP    |           |          0|LOST-INC-DG|          0|           |
       LOST-ACC   |          0|           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          0|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------
       IPP:10 -----------------------------------------------------------------
       IFTYPE:X25BSVC
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |  174630288|     425456|CHAR       | 2324458408|   26591000|
       DG         |   10914393|      26591|ICMP       |          0|          0|
       TCP        |          0|          0|UDP        |          0|          0|
       BRD        |          0|           |CAL        |          1|          0|
       RST        |          0|           |LONG       |          0|          0|
       SHORT      |          0|           |LOST-LOOP  |           |          0|
       LOST-BUF   |           |          0|LOST-OTH   |           |          0|
       B-VER      |          0|           |B-ICMP     |          0|           |
       B-LEN      |          0|           |NO-ROUTE   |          0|           |
       B-FCS      |          0|           |UNK-PROT   |          0|           |
       TTL-EXP    |           |          0|LOST-INC-DG|          0|           |
       LOST-ACC   |          0|           |B-FR-HDR   |          0|           |
       SLARP-FRM  |          0|          0|SLARP-CHAR |          0|          0|
       SLARP-KEEP |          0|          0|SLARP-DOWN |          0|           |
       IPP-DOWN   |          0|           |SP-LIM-OVFL|           |          0|
       ------------------------------------------------------------------------
       IPP:15 -----------------------------------------------------------------
       IFTYPE:VIRTUAL  on P-IPP:0
       ------------------------------------------------------------------------

The last example points out that, if an IP port has its own description, the command will show on the first row the informative string set by the User using the command A D IPP:xxx.

If the IP Router is not present, the command will generate an error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "PO:xxx" stands for the IPRTR port identifier.

C IPS | Clear IP Router Statistics (Administrator)
 | C IPS

It clears the statistics of the IP Router (IPRTR port).

warning! This command generates events neither in the System Log or in the Events Log; it is up to the User to refer statistics to the proper time interval. it is important to remember that statistics are always cleared at each Abilis CPX start.

If the IP Router is not present, or not active, the command will generate an error message: "IP SERVICE NOT PRESENT".

D IPS | Display IP Router Statistics (User)
 | D IPS

It shows the statistics of the IP Router, if it is running.

If the IP Router is not present or not active, the command will generate an error message: "IP SERVICE NOT PRESENT".

The following example shows the extended statistics of the IP Router:

[17:19:47] ABILIS_CPX: D IPS

PO:900 ------------------------------------------------------------------------
IPRTR  STATE:READY
       ROUTINGs TABLE Diagnostics
       -----------|---State---|-Current%--|--Current--|---Peak----|----Max----|
       ROUTINGS   |NORMAL     |          4|         20|         20|        500|
       ------------------------------------------------------------------------
       --- Cleared 000:01:28:58 ago, on 16/03/2004 at 17:52:54 ----------------
       ROUTER Statistics
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       DGM        |   11622652|       3376|HDR-ERR    |          0|           |
       ADDR-ERR   |          0|           |FRW-DGM    |           |   11617048|
       UNK-PROT   |          0|           |DISCARDS   |          0|          0|
       LOCAL-DGM  |       7988|           |NO-ROUT    |           |          8|
       REAS-TOUT  |          0|           |REAS-REQD  |          0|           |
       REAS-OK    |          0|           |REAS-FAIL  |          0|           |
       FRAG-OK    |           |          0|FRAG-FAIL  |           |          0|
       FRAG-CREATE|           |          0|ROUT-DISC  |          0|           |
       ------------------------------------------------------------------------
       ICMP Statistics
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       MSG        |          1|          4|ERR        |          0|           |
       DEST-UNREAC|          1|          4|T-EXCEED   |          0|          0|
       PARM-PROB  |          0|          0|SRC-QUENCH |          0|          0|
       REDIRECT   |          0|          0|ECHO       |          0|          0|
       ECHO-REP   |          0|          0|TSTAMP     |          0|          0|
       TSTAMP-REP |          0|          0|ADMASK     |          0|          0|
       ADMASK-REP |          0|          0|
       ------------------------------------------------------------------------

For a more detailed description of the information displayed, refer to The IP Router port (IPRTR) section.

Initialization Commands top

INIT IPAD | IP Routing administrative distances (User)
 | INIT IPAD

It reinitializes the table of IP Routing administrative distances, updating eventual parameters that might have been changed.

If the command is successful the message "COMMAND EXECUTED" is generated, otherwise the one "COMMAND FAILED".

INIT IPP | Init IP Ports (User)
 | INIT IPP

It reinitializes all IP ports, updating eventual parameters that might have been changed, and purges queues.

All IP ports parameters are run-time changeable; changes do not need the system to be restarted, but they are activated by executing this command.

If the command is successful the message "COMMAND EXECUTED" is generated, otherwise the one "COMMAND FAILED".

INIT IPP:xxx | Init IP Port (User)
 | INIT IPP:xxx

It reinitializes the specified IP port, updating eventual parameters that might have been changed. IP port identifiers must be in the interval [0 - 63].

All IP ports parameters are run-time changeable; changes do not need the system to be restarted, but they are activated by executing this command.

If the command is successful the message "COMMAND EXECUTED" is generated, otherwise the one "COMMAND FAILED".

INIT IPR | Init IP Router
 | INIT IPR

It reinitializes the IP Router: all the static and connected IP routings are deleted from the IP routings table, subsequently the static IP routings are reloaded from the table of the saved static IP routings.

At the same time, IP routings, calculated by the RIP routing algorithm, will get ready to be updated and the request procedure, from the router to the other ones of the network, is activated.

If the command is successful the message "COMMAND EXECUTED" is generated. If the IP router is not present an error message is generated: "PORT NOT PRESENT OR INACTIVE".


Commands relating to the IPsec

Revised for CPX 4.8.0.
IPsec policy table
IPsec Security Associations table

Other commands

IPsec policy table top

A IPSEC POLICY: | Add policy (Administrator)
 | A IPSEC POLICY:xxx [par:val]

It adds a new entry to the policy table in the "ID:xxx" position. The command can also set eventually indicated parameters to the specified values.

The policy table can store up to 128 entries, therefore the policy identifier value must be in the interval [0 - 127].

IPsec policy configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a IPsec policy already present in the table the message "IPSEC SECURITY POLICY ALREADY EXISTS" will be shown

If the policy table is full and a new policy is asked to be added, an error message is generated: "IPSEC SECURITY POLICIES TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the policy table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:A IPSEC POLICY:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IPSEC POLICY:7 DIR:IN

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IPSEC POLICY:2 RULE:IPSEC

COMMAND EXECUTED

C IPSEC POLICY: | Clear policy (Administrator)
 | C IPSEC POLICY:xxx

It deletes the specified entry from the policy table. The policy identifier must be in the interval [0 - 127].

If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY POLICY NOT PRESENT".

If the policy table is empty, the following message will be shown "IPSEC SECURITY POLICIES TABLE IS EMPTY".

Changes made on the policy table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:C IPSEC POLICY:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:C IPSEC POLICY:10

IPSEC SECURITY POLICY NOT PRESENT

D IPSEC POLICY: | Display policy (User)
 | D IPSEC POLICY D IPSEC POLICY:xxx

It shows the policy table.

If the identifier is omitted, the command will show all policies currently set.

Here is an example of the command execution:

[21:28:23] ABILIS_CPX:D IPSEC POLICY

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
POLICY:  NAME:                            NET-SRC:           PORT-SRC:
         DIR: BUNDLE: RULE:               NET-DST:           PORT-DST:
-------------------------------------------------------------------------------
0        CPX_1-to-CPX_2                   192.168.001.000/24 *
         OUT  0       IPSEC               192.168.003.000/24 *
-------------------------------------------------------------------------------
1        CPX_2-to-CPX_1                   192.168.003.000/24 *
         IN   1       IPSEC               192.168.001.000/24 *
-------------------------------------------------------------------------------
2        Drop policy                      000.000.000.000/0  *
         OUT  NONE    DROP                000.000.000.000/0  *
-------------------------------------------------------------------------------

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the policy table is empty, the following message will be shown "*** NO IPSEC SECURITY POLICIES DEFINED ***".

By specifying the policy identifier, the command will show only the requested policy.

[00:15:04] ABILIS_CPX:D IPSEC POLICY:0

Parameter:   |Value:
------------------------------------------------------------------------------
POLICY:       0
NAME:         CPX_1-to-CPX_2
DIR:          OUT
BUNDLE:       0
RULE:         IPSEC
NET-SRC:      192.168.002.001/32
NET-DST:      192.168.002.002/32
PORT-SRC:     *
PORT-DST:     *
------------------------------------------------------------------------------

The identifier must be in the interval [0 - 127]. If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY POLICY NOT PRESENT".

For a more detailed description of the shown information, refer the Policy table of the IPsec port section.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

S IPSEC POLICY: | Set policy (Administrator)
 | S IPSEC POLICY:xxx par:val [par:val]

It sets parameters of the specified policy to their new values.

The specified policy identifier value must be in the interval [0 - 127]. If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY POLICY NOT PRESENT".

If the policy table is empty, the following message will be shown "IPSEC SECURITY POLICIES TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the policy table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Example:
[10:32:14] ABILIS_CPX:S IPSEC POLICY:7 DIR:OUT RULE:DROP

COMMAND EXECUTED

IPsec Security Associations table top

A IPSEC SA: | Add Security Association (Administrator)
 | A IPSEC SA:xxx [par:val]

It adds a new entry to the Security Associations table in the "ID:xxx" position. The command can also set eventually indicated parameters to the specified values.

The Security Associations table can store up to 128 entries, therefore the Security Association identifier value must be in the interval [0 - 127].

IPsec Security Association configurations don't require consecutive indexes. A new definition can be added in any position of the table that is currently free. If the specified index corresponds to a IPsec Security Association already present in the table the message "IPSEC SECURITY ASSOCIATION ALREADY EXISTS" will be shown

If the Security Associations table is full and a new security association is asked to be added, an error message is generated: "IPSEC SECURITY ASSOCIATIONS TABLE IS FULL, COMMAND NOT EXECUTED".

Changes made on the Security Associations table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:A IPSEC SA:0

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IPSEC SA:7 DIR:IN

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:A IPSEC SA:2 PROT:ESP

COMMAND EXECUTED

C IPSEC SA: | Clear Security Association (Administrator)
 | C IPSEC SA:xxx

It deletes the specified entry from the Security Associations table. The Security Association identifier must be in the interval [0 - 127].

If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY ASSOCIATION NOT PRESENT".

If the Security Associations table is empty, the following message will be shown "IPSEC SECURITY ASSOCIATIONS TABLE IS EMPTY".

Changes made on the Security Associations table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Examples:
[10:32:14] ABILIS_CPX:C IPSEC SA:10

COMMAND EXECUTED

[10:32:14] ABILIS_CPX:C IPSEC SA:10

IPSEC SECURITY ASSOCIATION NOT PRESENT

D IPSEC SA: | Display Security Association (User)
 | D IPSEC SA D IPSEC SA:xxx

It shows the Security Associations table.

If the identifier is omitted, the command will show all Security Associations currently set.

Here is an example of the command execution:

[21:28:23] ABILIS_CPX:D IPSEC SA

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
SA:  NAME:                SPI:           SRC-IP:         PROT: AUTH:    CIPHER:
     DIR: BUNDLE: TUNNEL: IPP:   SIDE:   DST-IP:               AUTHKEY: ENCKEY:
-------------------------------------------------------------------------------
0    CPX_1-to-CPX_2_ESP   00000200       192.168.002.001 ESP   MD5      3DES
     OUT  0       YES     1      AUTO    192.168.002.002       *******  *******
-------------------------------------------------------------------------------
1    CPX_1-to-CPX_2_AH    00000201       192.168.002.001 AH    SHA
     OUT  0       NO      1      AUTO    192.168.002.002       *******
-------------------------------------------------------------------------------
2    CPX_2-to-CPX_1_AH    00000401       192.168.002.002 AH    SHA
     IN   1       NO      1      AUTO    192.168.002.001       *******
-------------------------------------------------------------------------------
3    CPX_2-to-CPX_1_ESP   00000400       192.168.002.002 ESP   MD5      3DES
     IN   1       YES     1      AUTO    192.168.002.001       *******  *******
-------------------------------------------------------------------------------

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Security Associations table is empty, the following message will be shown "*** NO IPSEC SECURITY ASSOCIATIONS DEFINED ***".

By specifying the Security Association identifier, the command will show only the requested Security Association.

[00:15:04] ABILIS_CPX:D IPSEC SA:0

Parameter:   |Value:
------------------------------------------------------------------------------
SA:           0
NAME:         CPX_1-to-CPX_2_ESP
SPI:          00010ABC
DIR:          OUT
BUNDLE:       0
SRC-IP:       192.168.002.001
DST-IP:       192.168.002.002
PROT:         ESP
AUTH:         NONE
CIPHER:       IDEA
ENCKEY:       ********
TUNNEL:       NO
IPP:          1
SIDE:         AUTO
------------------------------------------------------------------------------

The identifier must be in the interval [0 - 127]. If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY ASSOCIATION NOT PRESENT".

For a more detailed description of the shown information, refer the Security Associations table of the IPsec port section.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

S IPSEC SA: | Set Security Association (Administrator)
 | S IPSEC SA:xxx par:val [par:val]

It sets parameters of the specified Security Association to their new values.

The specified Security Association identifier value must be in the interval [0 - 127]. If the requested entry is not present in the table, the following error message will be displayed: "IPSEC SECURITY ASSOSIATION NOT PRESENT".

If the Security Associations table is empty, the following message will be shown "IPSEC SECURITY ASSOCIATIONS TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the Security Associations table are not immediately active. They can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the IPSEC port number.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support IPsec service, the following message will be shown "IPSEC SERVICE NOT PRESENT".

Example:
[10:32:14] ABILIS_CPX:S IPSEC SA:10 DIR:OUT PROT:AH

COMMAND EXECUTED


Commands relating to the Elements Lists

Lists handling
Elements handling

Other commands

Lists handling top

LIST CREATE | Create list (Administrator)
 | LIST CREATE Name Type [Description]

This command creates a new list, identified by "Name" and "Type". It can eventually set a list description to the specified "Description" value.

The parameter "Name" is the name the User wants to assign to the List. Names of the lists can be string with maximum length of 20 characters (alphabetical, numerical, "_" underscore). String cannot start with a numerical character and the terms "A", "And", "Or", "Not" are not allowed.

Name completely identifies the list within the system. Two or more lists with the same "Name" cannot be defined. There is no difference between low case and uppercase characters.

For example the following strings "FirstList", "FIRSTLIST", "firstlist" are equivalent. If a list with the selected name already exists in the system, the message "LIST ALREADY EXISTS" will be displayed.

"Type" parameter is the type the User wants to assign the list; it can be chosen among the following mnemonics:

Mnemonic | List type
IN | List of ISDN numbers
IS | List of ISDN sub-addresses
EC | List of EIR Cluster identifiers
XN | List of X25 NUA
XU | List of X25 User Data Field
IP | List of IP addresses
IR | List of IP group addresses
DN | List of Dialling numbers
CP | List of CPX ports
TUP | List of TCP and UDP ports ranges
IPT | List of Internet protocols
MAC | List of MAC addresses
SAP | List of SAP values
RU | List of Rules
MR | List of Master Rules

For more detailed description of lists types, refer to the Elements Lists section.

The optional parameter "Description" let User to give description to the list. it is a string of ASCII characters, without spaces, whose maximum length is 71 characters. Description can be omitted while creating a list, it can eventually be set later on through the command LIST DESCRIPTION.

Lists table can store up to 64 definitions. When a list is created, it gets a new numeric identifier (1 - 64) that can be used instead of "Name", in some commands.

The command inserts list definition into the first free place available in lists table. Because of free places in the table, numeric identifiers can be not sequential.

If the list table is full, the error message "LIST TABLE IS FULL" is shown.

The "Not Saved (SAVE CONF)" message is displayed every time Lists table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

LIST DELETE | Delete list (Administrator)
 | LIST DELETE Name

This command deletes the list, identified by "Name" in the Elements List.

The parameter "Name" is the list name the User wants to delete. List is checked to be present by searching its identifier. There is no difference between low case and uppercase characters, so strings like "FirstList", "FIRSTLIST", "firstlist" are equivalent.

If the requested list is not present, the message "LIST NOT PRESENT" is displayed. If the table is empty, the error message "LIST TABLE IS EMPTY" will be shown.

List definitions in the table are not contiguous. The deleted definition frees one place that can be used for creating a new list.

User must be careful in list deleting, because all the elements defined in it will be also deleted. Moreover only those list, not referenced by any routing, can be deleted.

If the list to be deleted is still referenced by any routing, the following error message will be displayed: "LIST ALREADY IN USE; CANNOT BE DELETED". It won't be deleted.

The "Not Saved (SAVE CONF)" message is displayed every time Lists table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

LIST DESCRIPTION | Set list description (Administrator)
 | LIST DESCRIPTION Name Description

This command makes possible to set and/ or modify the description of the list identified by "Name", already present in the lists of elements.

The parameter "Name" is the list name the User wants to work on. List is checked to be present by searching its identifier. There is no difference between low case and uppercase characters, so strings like "FirstList", "FIRSTLIST", "firstlist" are equivalent.

If the requested list is not present, the message "LIST NOT PRESENT" is displayed.

The parameter "Description" is the description the User wants to give to the list. It is a string of ASCII characters, without spaces, whose maximum length is 71 characters.

The "Not Saved (SAVE CONF)" message is displayed every time Lists definitions are modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

LIST RENAME | Set list name (Administrator)
 | LIST RENAME OldName NewName

This command changes the Name of a CPX list, already present in the table, from "OldName" to "NewName".

The parameter "OldName" is the list name the User wants to work on. List is checked to be present by searching its identifier. There is no difference between low case and uppercase characters, so strings like "FirstList", "FIRSTLIST", "firstlist" are equivalent.

If the requested list is not present, the message "LIST NOT PRESENT" is displayed.

The parameter "NewName" is the name the User wants to assign to the List. Names of the lists can be string with maximum length of 20 characters (alphabetical, numerical, "_" underscore). String cannot start with a numerical character and the terms "A", "And", "Or", "Not" are not allowed.

Name completely identifies the list within the system. Two or more lists with the same "Name" cannot be defined. There is no difference between low case and uppercase characters.

If a list with the selected name already exists in the system, the message "LIST ALREADY EXISTS" will be displayed.

The "Not Saved (SAVE CONF)" message is displayed every time Lists definitions are modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

Elements handling top

A LIST | Add item to list (Administrator)
 | A LIST:Name Item1 [Item2 …]

It adds one or more elements to the list.

The parameter "Name" can be either the name of the list the User wants to work on, or the numeric identifier, assigned by the system, when the list was created.

If the requested list is not present, the message "LIST NOT PRESENT" is displayed.

"Item1" is the element to be added. For more detailed description of types and values of elements, refer to the Elements Lists section.

If an element, equal to the specified one, is already present in the list, the following message will be shown: "ITEM 'item' ALREADY EXISTS", where 'item' is the value that was going to be added.

Usually it is possible to add more than one element at the same time, by separating them with a space character in the command row.

For "RU" and "MR" list types, this is not possible because the can hold only one element. If "RU" or "MR" list is not empty, the message "LIST IS FULL: THIS LIST CAN HOLD ONLY ONE ITEM".

For other list types, the maximum number of elements that can be added at the same time, is given by their maximum size: 2000 definitions.

Elements table is contiguous and sorted by increasing values of identifier of the list which the elements belong to.

If the elements table is full, the error message "ITEM TABLE IS FULL" is shown.

The "Not Saved (SAVE CONF)" message is displayed every time a list is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

C LIST | Clear item from list (Administrator)
 | C LIST:Name Item1 [Item2 …]

It clears one or more elements from list.

The parameter "Name" can be either the name of the list the User wants to work on, or the numeric identifier, assigned by the system, when the list was created. "Item1" is the element to be deleted. If the requested list is not present, the message "LIST NOT PRESENT" is displayed.

Usually it is obligatory to specify the element ("Itemxx") to delete. The "RU" and "MR" list types are an exception:, they can only hold one element, so in this case it is allowed to omit the value of the element to delete.

Searching the specified value, by considering lower case and upper case characters, make verifying the element presence.

If the requested element is not found then the error message is generated: "ITEM NOT PRESENT".

If the specified list is empty, the error message "LIST IS EMPTY" will be shown.

Elements table is kept contiguous and sorted using optimization searching criteria. Therefore the command will delete the requested definition and will sort the table again.

The "Not Saved (SAVE CONF)" message is displayed every time a list is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

D LIST | Display lists (User)
 | D LIST D LIST:Name D LIST:A

It shows lists table.

By specifying the parameter "Name", the command will show the correspondent list and its elements; "Name" is either the list name, assigned by the User, or the numeric identifier, assigned by the system, list creation.

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D LIST

List-Number:8   Items-Number:20    Used-Resources:468    Free-Resources:20012

Id Name                 Type Description                         Ref First Numb
-------------------------------------------------------------------------------
 2 Disabled             IN   Temporary_disabled_callers          0   4     1
 3 Far                  IN   Allowed_callers_from_different_...  0   5     3
 6 Local                IN   Allowed_callers_from_local_area     0   15    5
 7 Special              IS   Special_servicee_validation         0   0     0
 8 Callers              RU   Full_allowed_callers                0   20    1
 1 D_Numbers            DN   Dialling_numbers                    0   1     3
 5 IpServices           TUP                                      0   11    4
 4 IpProtocol           IPT                                      0   8     3
-------------------------------------------------------------------------------
IN:ISDN Numbers,         IS:ISDN Sub Addresses,   EC:EIR Clusters,
XN:X25 NUAs,             XU:X25 UDFs,             IP:IP Addresses,
IR:IP Addresses Ranges,  RU:Rules,                MR:Master Rules,
DN:Dialling Numbers,     CP:CPX Ports,            TUP:TCP and UDP ports ranges,
IPT:Internet Protocols,  MAC:MAC addresses.       SAP:SAP values,
-------------------------------------------------------------------------------

The previous example points out that the lists are sorted by type (according to the order shown in the legend at the bottom of the table) and, at a parity of type, by alphabetical order. The numeric index, that precedes the name, is the identifier automatically assigned by the system to the list during its creation.

Lists table can store up to 64 definitions. Identifiers of the elements lists can be not sequential, so the not shown values correspond to free places in the table.

If the lists table is empty, the message "NO LIST DEFINED" is generated.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

Here is an example of single list visualization:

[18:14:08] ABILIS_CPX: D LIST:Local

LIST:Local - IN, Allowed_callers_from_local_area
     0038*                   0038123123123           0376396967
     064556                  123456

By specifying the "A" value, the command will show all the configured lists and their elements.

The following example shows an example of visualization of all the lists:

[18:14:08] ABILIS_CPX: D LIST:A

LIST:Disabled - IN, Temporary_disabled_callers
     0376399495

LIST:Far - IN, Allowed_callers_from_different_areas
     0376*                   03383223124             0338959456

LIST:Local - IN, Allowed_callers_from_local_area
     0038*                   0038123123123           0376396967
     0644556                 123456

LIST:Special - IS, Special_servicee_validation

LIST:Callers - RU, Full_allowed_callers
     Local.OR.Far.AND.NOT.Disabled

LIST:D_Numbers - DN, Dialling_numbers
     Order  DialingNumber         MaxConn  Nrty
     1      0376366128            2        NOMAX
     2      5557893               2        NOMAX
     3      3383223444            2        5

LIST:IpServices - TUP,
     ssh(22)        telnet(23)     snmp(161)      rip(520)

LIST:IpProtocol - IPT,
     tcp            udp            ospf

The "Not Saved (SAVE CONF)" message is displayed every time lists are modified but modifications are not saved with the SAVE CONF command.

For a more detailed description of the shown information, refer to the Elements Lists section.

D ITEM | Display Items (User)
 | D ITEM

It shows the elements table.

Lists table can store up to 2000 definitions (indexed from 1 to 2000).

Elements identifiers are sequential and they run only into the system, so they can't be used by the user in no one of the list manipulation commands.

If the elements table is empty, the message "NO ITEMS DEFINED" is generated.

If the Abilis CPX version, currently in use, does not support List services, the following message will be shown "LIST SERVICE NOT PRESENT".

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D ITEM

Item List Type  Value
-------------------------------------------------------------------------------
   1    1   DN  1      0376366128            2        NOMAX
   2    1   DN  2      5557893               2        NOMAX
   3    1   DN  3      3383223444            2        5
   4    2   IN  0376399495
   5    3   IN  0376*
   6    3   IN  03383223124
   7    3   IN  0338959456
   8    4  IPT  tcp
   9    4  IPT  udp
  10    4  IPT  ospf
  11    5  TUP  ssh(22)
  12    5  TUP  telnet(23)
  13    5  TUP  snmp(161)
  14    5  TUP  rip(520)
  15    6   IN  0038*
  16    6   IN  0038123123123
  17    6   IN  0376396967
  18    6   IN  0644556
  19    6   IN  123456
  20    8   RU  Local.OR.Far.AND.NOT.Disabled
-------------------------------------------------------------------------------
IN:ISDN Numbers,         IS:ISDN Sub Addresses,   EC:EIR Clusters,
XN:X25 NUAs,             XU:X25 UDFs,             IP:IP Addresses,
IR:IP Addresses Ranges,  RU:Rules,                MR:Master Rules,
DN:Dialling Numbers,     CP:CPX Ports,            TUP:TCP and UDP ports ranges,
IPT:Internet Protocols.
-------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time lists are modified but modifications are not saved with the SAVE CONF command.

For a more detailed description of the shown information, refer to the Elements Lists section.

F LIST | Find item in a list (User)
 | F LIST:Name Item [Type]

It is used to find the requested element of the specified type in a given list.

The parameter "Name" is the name list where the search has to be made.

The parameter "Item" is the element to search.

The parameter "Type" specifies the element type and it is obligatory only for "RU" lists type.

Here are some examples of the command execution:

[18:57:52] ABILIS_CPX: D LIST:CellFam

LIST:CellFam - IN, Numeri_da_chiamare_via_Omnitel
     12*                     110*                    144*
     166*                    176*                    0328*
     0330*                   0333*                   0338*
     0339*                   0360*                   0368*
     1412*

[18:57:37] ABILIS_CPX: F LIST:1 5678

ITEM '5678' NOT FOUND OR BAD ITEM TYPE 'IN'

[18:59:23] ABILIS_CPX: F LIST:1 12345

THE ITEM IS PRESENT

The examples show that the elements, containing wildcards ('*', '?'), are also considered in searching operations. In fact the number "12345", is considered to belong to the list, because it is possible to find in it the element "12*".


Command language

Introduction
Login levels of the Control Port
Commands
Help online
Configuration validating
Complete list of commands in alphabetical order

Commands relating to the Elements List
Commands relating to the Cryptography keys
Commands relating to Users Access Control table

Commands relating to the Connection Oriented Router

Commands relating to the IP Router
Commands relating to the RIP External routes
Commands relating to the OSPF Areas/External routes/Hosts/Neighbours/Ranges/Virtual links

Commands relating to the Enhanced ISDN Router
Commands relating to the Analogue Voice Router

Commands relating to the Wireless to G.703 Bridge

Commands relating to NAT table
Commands relating to DHCP bindings/hosts/profiles/subnets
Commands relating to FTP virtual root paths/virtual paths access control
Commands relating to HTTP virtual root paths/virtual paths access control

Commands relating to IPSEC table
Commands relating to IKE table

Commands relating to ports and boards
General and System commands

Introduction top

Abilis CPX configuration and supervision are made through the Control Port: after opening the connection, it is possible to send commands and get answers. This paragraph describes the main rules that set up the command language of the Control Port commands interpreter.

Login levels of the Control Port top

it is possible to log in to the Control Port by using three different privilege levels, each of them has got a set of allowed operations:

  • User login level (USER): it is possible to execute only some supervision operations; execution of commands not allowed for the user login level will cause the message "COMMAND NOT ALLOWED FOR USER LOGIN LEVEL" to be displayed.
  • Administrator login level (ADMINISTRATOR): user is allowed, with some restrictions, to execute all the configuration and supervision commands; execution of commands not allowed for the administrator login level will cause the message "COMMAND NOT ALLOWED FOR ADMINISTRATOR LOGIN LEVEL" to be displayed.
  • Super-User login level (SUPERUSER): user is able to completely manage the system; execution of any configuration or supervision command is possible.

The following paragraphs will show the login level that can execute the commands provided by the Control Port commands interpreter.

Commands top

A command is represented by a series of characters, ending with <CR> (carriage return), sent to Abilis CPX.
The answer is a series of characters sent by Abilis CPX, which contains the requested information; every answer is ended by a line containing the prompt of the Control Port commands interpreter.

In the following examples the highlighted characters are sent to Abilis CPX, the others are sent by Abilis CPX.

[11:33:39] ABILIS_CPX: D P PO:1 <CR>

PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V35     CLK:INT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       E1-FRAMING:CRC4         HAUL:SHORT
       CH:0-31
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

[11:33:39] ABILIS_CPX: S P PO:1 SP:19200 <CR>

COMMAND EXECUTED

[11:33:39] ABILIS_CPX: S P PO:1 FRAME:4000 <CR>

PO:1 INVALID VALUE 'FRAME:4000'

Commands are divided into the following groups:

Group | Group ID | Action | Minimum privilege level required
Add commands | A | Add configurations to the tables. | Administrator
Reconfiguration commands | BOOT | Activate default configurations. | Administrator
Clear/delete commands | C | Delete configurations from the tables and clear the statistics. | Administrator
Copy commands | COPY | Copy among homogeneous configurations. | Administrator
Display commands | D | Display tables configurations and statistics. | User
Search commands | F | Search configurations in tables. | User
Re-initialization commands | INIT | Components re-initialization owing to configuration changes. | User
Elements list managing commands | LIST | Elements list management. | Administrator
Move commands | M | Change position of configuration within the tables. | Administrator
Restart commands | R | Activate inactive components. | User
Set up commands | S | Set up the tables configurations. | Administrator/Super-User
System commands | (see further) | System general management or activation of special functions. | (see further)

Excluding the system commands, each command executes its action on objects.

Objects are divided into the following classes:

Object class | Class ID | Action
Active resources (ports, boards) | ACT | Access tables of the active boards and ports.
COR Connections | C and CE | Access state of Connection Oriented Router (COR) communication sessions.
Board parameters | CARD | Access board parameters.
Cause and diagnostic code | CODE | Access cause and diagnostic codes of communication sessions.
Encryption/Decryption keys | CRKEY | Access table of cryptographic keys.
CPU load percentages | CPU | Display current CPU load percentages.
Ports description | D and DE | Display information about IP, link and protocol ports.
DHCP bindings | DHCP BIND | Allow to manage DHCP bindings management.
DHCP hosts | DHCP HOST | Access table of DHCP hosts.
DHCP subnets | DHCP LAN | Access table of DHCP subnets.
DHCP profiles | DHCP PROF | Access table of DHCP profiles.
EIR connections | EC and ECE | Access table of EIR connection in progress.
EIR groups | EG | Access table of EIR groups.
EIR Cluster identifiers | EID | Access table of EIR Cluster identifiers.
EIR routing | ER and ERE | Access table of EIR routing.
FTP Virtual Root Paths | FTP PATH | Acess table of FTP Virtual root paths.
FTP Virtual Path's Access Rights | FTP RIGHTS | Acess table of FTP Virtual Path's Access Rights.
General parameters of the system | G | Access table of general parameters of the system.
HTTP Virtual Root Paths | HTTP PATH | Acess table of HTTP Virtual root paths.
HTTP Virtual Path's Access Rights | HTTP RIGHTS | Acess table of HTTP Virtual Path's Access Rights.
System information | I | Display information about the system and files on floppy disk.
Inactive resources (ports, boards) | INACT | Access tables of the inactive boards and ports.
IP access list | IPACL | Access the IP access list.
IP Routing administrative distance | IPAD | Access the table of IP Routing administrative distancies.
IP ports | IPP | Access table of IP ports.
Dynamic IP routing | IPR | Access table of IP routings.
Static IP routing | IPRS or SIPR | Access table of the Saved static IP routings.
IP Source routing | IPSR | Access table of the IP source routings.
IP statistics | IPS | Display IP statistics.
Elements of the list | ITEM | Access table of Elements lists.
System Log | L | Access System Log.
Events Log on disk | LDD | Access Events Log saved on disk.
Events Log in memory | LDM | Access Events Log stored in the memory.
Exceptions Log | LE | Access Exceptions Log saved on disk.
Elements lists | LIST | Access table of Elements lists.
NAT Alias entries | NAT | Access table of NAT Alias entries.
OSPF Areas | OSPF AREA | Acess table of OSPF Areas.
OSPF External routes | OSPF EXTERNAL | Acess table of OSPF External routes.
OSPF Hosts | OSPF HOST | Acess table of OSPF Hosts.
OSPF Neigbours | OSPF NEIGH | Acess table of OSPF Neighbours.
OSPF Ranges | OSPF RANGE | Acess table of OSPF Ranges.
OSPF Virtual Links | OSPF VL | Acess table of OSPF Virtual links.
IPSEC Policies | OSPF POLICY | Acess table of IPSEC Policies.
IPSEC Security Associations | IPSEC SA | Acess table of IPSEC Security Associations.
IKE Hosts | IKE HOST | Acess table of IKE Hosts.
IKE Clients | IKE CLI | Acess table of IKE Clients.
IKE Preshared Keys | IKE PSK | Acess table of IKE PSK.
Port parameters | P | Access port parameters.
PCI boards | PCIDEV | Display information about system PCI boards.
PVC connections | PVC | Access table of PVC connections.
SVC routing | R and RE | Access table of SVC routing.
RIP External routes | RIP EXTERNAL | Acess table of RIP External Routes.
Working resources (ports) | RUN | Access table of working ports.
States | S and SE | Access state of the communication ports.
Compression statistics | SC | Access compression statistics.
Time | T and TE | Access local date and time of system.
TDM assignations | TDM | Access table of TDM assignations.
Connections among ports | TREE | Display the current state of the connection among the protocol and link ports.
Tone Trace | TT | Activate/deactivate the Tone Trace.
USER entry | USER | Access the Users Access Control table.
VOICE connections | VC | Access table of Fxs/Fxo VOICE connections in progress.
Software version in use | VER | Display software version currently working on the system.
Data ports for VOICE | VD | Access table of data ports for VOICE.
VOICE groups | VG | Access the VOICE groups table.
VOICE routing | VR | Access the VOICE routing table.
WG Bridge routing | WGB | Access the Wireless to G.703 Bridge Routings table.

Excluding the system commands, the others observe the following simple rule for setting the command:

<group ID>_< class ID>_[parameter:value]_..._[parameter:value]

where "_" stands for space character.

Each class can accept all the commands groups or only a part of them; a detailed list in given later on. Regarding parameters and the allowed values for each coupling group/class, it is necessary refer to the proper section, which deal with them.

System commands do not follow the rules above mentioned. The consequences, those commands could have on system operating mode, suggested to ask for their extended digitation, in such way, to reduce to the minimum the chances to send them by mistake.

System commands are, in alphabetic order, the following:

Command | Action | Minimum privilege level required
ALARM RESET | Activate the recovery procedure of those errors which generated the alarm. | User
ALARM VIEW | Show ports that are in error conditions. | User
CALL PO: | Set up a connection on the specified port. | User
CLOSE | Tear down the connection with the Control Port. | User
CONFLOG BACKUP | Allow to backup configuration and log files to the floppy disk (Available only on HD/CF based systems). | Administrator
CONFLOG RESTORE | Allow to restore configuration files from the floppy disk (Available only on HD/CF based systems). | Administrator
DEBUG BM | Display the content of Boot Manager configuration file (Available only on HD/CF based systems). | Administrator
DEBUG CPXRUN | Display the content of CPX runs configuration file (Available only on HD/CF based systems). | Administrator
DEBUG FILE | Display statistics information about system files. | Administrator
DEBUG IRQ | Display statistics information about interrupts. | Administrator
DEBUG MEM | Display statistics information about memory. | Administrator
DEBUG PO: | Display debugging information about the ports. | Administrator
DEBUG TASK | Display statistics information about the tasks. | Administrator
DEBUG WDGMEM | Display statistics information saved in case of system critical situation detected by the Watchdog. | Administrator
DISC PO: | Open a connection previously activated on the specified port. | User
EXIT | Quit execution of the off-line configuration program. | User
FILE COPY | Allow to make a copy of a file (Available only on HD/CF based systems). | Administrator
FILE DELETE | Allow to delete a file (Available only on HD/CF based systems). | Administrator
FILE GET | Activate file transferring from CPX to remote destinations through the XModem protocol. | Administrator
FILE PUT | Activate file transferring from remote destinations to CPX through the XModem protocol. | Administrator
IPTRACE ACT | Activate TCP/IP events tracing. | Administrator
IPTRACE CLEAR | Clear the content of the TCP/IP events trace. | Administrator
IPTRACE DISPLAY | Display the content of the TCP/IP events trace. | Administrator
IPTRACE INACT | Deactivate TCP/IP events tracing. | Administrator
IPTRACE START | Start the TCP/IP events trace. | Administrator
IPTRACE STOP | Stop events tracing. | Administrator
LOGIN | Display current login privilege level. | User
LOGIN ADMINISTRATOR | Make possible the user to access the Administrator login level. | User
LOGIN SUPERUSER | Make possible the user to access the Super-User login level. | User
LOGIN USER | Make possible the user to access the User login level. | User
LOGOUT | Close the current configuration session and ask for a new log-in. | User
PAR PO: | Display parameters currently used by the PAD port specified. | User
PING | Ping the IP address specified. | User
QUIT | Quit execution of the off-line configuration program. | User
RESTART SYSTEM | System closet connections eventually on, and restarts. | Administrator
SAVE CONF | Save current configuration on disk. | Administrator
SAVE CONF BACKUP | Make a backup of the configurations currently saved on disk. | Administrator
SAVE CONF TEST | Save current configuration on disk as test configuration. | Administrator
SAVE DEBUG | Save Events Log on disk. | Administrator
SOUND DISABLE | Disable acoustic signal generation in case of alarm situations. | User
SOUND ENABLE | Enable acoustic signal generation in case of alarm situations. | User
START L | Activate System Log real-time displaying. | Administrator
START LDM | Activate Events Log real-time displaying. | Administrator
SYS COMPACT | Directory re-compating operation. (Available only on HD/CF based systems). | Administrator
SYS COMPACTR | Directory re-compating operation, recursive. (Available only on HD/CF based systems). | Administrator
SYS DELETE PACKAGE | Delete a package file (Available only on HD/CF based systems). | Administrator
SYS DELETE VERSION | Delete a version directory (Available only on HD/CF based systems). | Administrator
SYS DIR | List the content of a directory (Available only on HD/CF based systems). | Administrator
SYS DISK CHK | Check HD/CF integrity (Available only on HD/CF based systems). | Administrator
SYS DISK FORMAT | Drive format operation (Available only on HD/CF based systems). | Administrator
SYS DISK INFO | Display HD/CF information (Available only on HD/CF based systems). | Administrator
SYS DISK LABEL | Drive label setting (Available only on HD/CF based systems). | Administrator
SYS DISK PARTITION ADD | Add HD/CF partition(s) (Available only on HD/CF based systems). | Administrator
SYS DISK PARTITION INFO | Display HD/CF partition(s) information (Available only on HD/CF based systems). | Administrator
SYS DISK PARTITION RESET | Reset HD/CF partition(s) (Available only on HD/CF based systems). | Administrator
SYS DISPLAY BOOT | Display current Boot Manager configuration (Available only on HD/CF based systems). | Administrator
SYS DISPLAY BOOT LOG | Display current Boot Manager log file (Available only on HD/CF based systems). | Administrator
SYS DISPLAY PACKAGES | Display available package files (Available only on HD/CF based systems). | Administrator
SYS DISPLAY VERSIONS | Display available versions (Available only on HD/CF based systems). | Administrator
SYS FLPFORMAT | Floppy disk format (Available only on HD/CF based systems). | Administrator
SYS SET BOOT VERSION | Set the next version to be loaded (Available only on HD/CF based systems). | Administrator
SYS UPDATE | Update system software. | Administrator
TRACE ACT | Activate internal events tracing. | Administrator
TRACE CLEAR | Clear the content of the internal events trace currently saved. | Administrator
TRACE DISPLAY | Display the content of the internal events trace currently saved. | Administrator
TRACE DISPLAY EXTENDED | Display, in extended format, the content of the internal events trace currently saved. | Administrator
TRACE GET | Transfer internal events trace, currently saved, from CPX to remote destination through the XModem protocol. | Administrator
TRACE INACT | Deactivate internal events tracing. | Administrator
TRACE PARAM | Display parameters of the trace functions currently active. | Administrator
TRACE PARAM SAVE | Save current values of trace functions parameters. | Administrator
TRACE PARAM SET | Set up saved values of parameters of trace functions. | Administrator
TRACE START | Start internal events trace. | Administrator
TRACE STOP | Stop internal events trace. | Administrator
TRACERT | Trace an IP racket path towards a specified address. | User
VALIDATE | Execute configuration validating. | User
WARM START | System immediately restarts. | Administrator

Help online top

For all commands, either if they are system commands or not, a contextual online help function is available. By typing the "?" character, all the information, needed to correctly compose the commands, are displayed.

As already mentioned, the help function is contextual, this means the help message displayed depends on the "?" character position in the command line. If, for example, only the "?" character is digitated, a list of key words that can be placed at the beginning of the command row is displayed. A brief description of them is also given:

[11:33:39] ABILIS_CPX: ?

ALARM          Alarm operations
A              Add operations
BOOT           Boot operations
C              Clear operations
CALL           Open a Connection
CLOSE          Close current CP session
CONFLOG        Configuration and log files backup/restore
COPY           Copy port configuration
D              Display operations
DEBUG          Debug operations
DISC           Close a Connection
F              Find operations
FILE           File copy/delete/get/put operations
INIT           Init operations
IPTRACE        TCP/IP Trace operations
LIST           Lists operations
LOGIN          Log-in operations
LOGOUT         Log-out operations
M              Move operations
PAR            Active Parameter operations
PING           Ping command
RESTART        System Restart operations
R              Restart operations
S              Set operations
SAVE           Save operations
SOUND          Sound disable/enable operations
START          Start real-time logging operations
SYS            System operations
TRACE          Trace operations
TRACERT        Trace route command
VALIDATE       Current configuration validation
WARM           System warm start operations

Inserting the "?" character in a more advanced position in the command line, only those key words and their description, allowed by the command language to be place in that position and after on, will be displayed.

For example, if "?" is digitated after the key word "ALARM", a list of all the key words, allowed to be placed after "ALARM", is displayed:

[10:07:11] ABILIS_CPX: ALARM ?

VIEW           Alarm view
RESET          Alarm reset

The following example shows how it is possible, through digitation "?" in successively different positions, to have a complete description of setting the "Add" SVC routing command:

[11:36:27] ABILIS_CPX: A ?

CRKEY:         Encryption/Decryption key identifier [1..63]
D              IP and/or CPX ports description
DHCP           DHCP profile/subnet/host
EG             EIR Group
ER             EIR Routing
FTP            FTP Virtual root paths/path's access Rights
HTTP           HTTP Virtual root paths/path's access Rights
IPACL          IP Access List
IPAD           IP Routing Administrative Distance
IPP:           IP Port identifier [0..63]
IPR            IP Routing
LIST:          CPX list name
NAT            NAT alias entry
OSPF           OSPF area/range/neigh/host/external route
PVC            PVC Connection
R              SVC Routing
RIP            RIP external route
TDM            TDM Switch
USER:          User name. Max. 32 ASCII characters.
VD             VOICE Data port
VG             VOICE Group
VR             VOICE Routing
WGB            WG Bridge Routing

[11:36:31] ABILIS_CPX: A R ?

PR:            SVC Routing priority [0..99]

[11:36:31] ABILIS_CPX: A R PR: ?

SVC Routing parameters:

POI:       Input port [0..999, *, NONE]
CGI:       Input calling address [0..9, *, #, ?, 'list']
CDI:       Input called address [0..9, *, #, ?, 'list']
UDI:       Input user data field [0..9, a..z, A..Z, *, #, ?, 'list']
PIDI:      Input PID [Hexadecimal, *, #]
POO:       Output port [0..999, *, #, NONE]
CGO:       Output calling address [0..9, *, #]
CDO:       Output called address [0..9, *, #]
UDO:       Output user data field [0..9, a..z, A..Z, *, #]
PIDO:      Output PID [Hexadecimal, *, #]
FFO:       Output Facility field [Hexadecimal, *, #]
COMP:      Compression protocol [NO, MBIT, QLLC]
NEXT:      Alternative routing indication [N or NO, Y or YES]
IPDEST:    Destination Ip Address [0-126.x.x.x, 128.x.x.x-223.x.x.x, #]
IPSRC:     Source Ip Address [0-126.x.x.x, 128.x.x.x-223.x.x.x, *, 'list']

[11:36:31] ABILIS_CPX: A R PR:1 POI:301 POO:302

COMMAND EXECUTED

warning! The "?" character has to be separated by one or more spaces from the previous word.

Configuration validating top

Configuration validating has been introduced to ensure correct Abilis CPX configurations.

By validation it is meant the explicit execution of a series of congruence controls made by Abilis CPX on all the configuration information.

Base controls on the type and the interval of values, allowed by the configuration parameters, are implicitly carried out by configuration commands, however exists a series of verifications that cannot be executed during the normal routine of configuration. That's why is available a procedure that activates a set of deepened and more complete controls. Particularly, configuration parameters of cards and boards are subject to validation.

The output of the validating procedure can be positive without demanding modifications to the configuration, or it is possible that the validation detects some incongruency or imprecision in the configuration.

If the validation detects imprecision that it can directly correct, the outcome of the command is however positive. But in such case, the procedure expects the displaying of informative messages which signal the changes, made on the configuration during the validation, to the User.

If the validation detects serious incongruencies, in the configuration, that cannot automatically be corrected, the outcome of the command is negative. In such case the procedure expects the displaying of error messages for signalling the detected errors to the User.

A command for the explicit execution of the validating procedure exists; moreover configuration commands implicitly execute configuration validating before saving it on disk. The commands, which execute this procedure, are:

Command | Description
VALIDATE | Validation of current configuration, without saving.
SAVE CONF | Saving, by previous validation, the current configuration.
SAVE CONF TEST | Saving, by previous validation, the current configuration (for testing it).
D TREE | Displaying, by previous validation, the current connections state among protocol and Link ports.

Here are some examples about the execution of implicit and explicit validation.

Example N.1

The following example shows a successful explicit validation; the procedure required some changes in the configuration (changing parameters values owing to other parameters values either of the same port or different ports connected to it; or caused by incongruency with the port

[11:36:31] ABILIS_CPX: VALIDATE

VALIDATION IN PROGRESS ...
PO:201 changed "N1" from 144 to 528 because PO:301 "PS" = 512
PO:1 changed "FRAME" from 144 to 528 because PO:201 "N1" = 528
PO:1 changed "CODING" from NRZI to NRZ because PO:201 is LAPB
VALIDATION SUCCESSFULLY EXECUTED

The procedure has modified the value of the parameter "N1:" of port 201 since it is in relation with parameter "PS:" of port 301 connected to it.

The procedure has modified the value of parameter "FRAME:" of port 1 since it is in relation with the parameter "N1:" of port 201 connected to it.

The procedure has modified the value of parameter "CODING:" of port 1 since it is in relation with the type of port 201 connected to it.

Example N.2

The following example shows an explicit validation failed because of some, particularly serious, errors detected in the configuration (inconsistent setting of two parameters of the same port, incongruency between the parameter and the port type, sharing resources among two or more ports):

[11:36:31] ABILIS_CPX: VALIDATE

VALIDATION IN PROGRESS ...
ERROR: PO:1 conflicting setting between "CODING" = NRZ and "CLK" = PCLK
ERROR: PO:302 invalid "LOWPO" = 321 type
ERROR: PO:321 "LOWPO" = 1 crossed setting
VALIDATION FAILED

The procedure has detected a conflict between the value assigned to the parameter "CODING:" and the one given to "CLK:" of port 1.

The procedure has detected the type of port 321, connected to port 302 through the parameter "LOWPO:", to be not valid.

The procedure has detected that the parameter "LOWPO:" of port 321 has been assigned to a number of port already in use.

Example N.3

The following example shows an unsuccessful configuration saving because the implicit validation procedure, that has been executed, failed:

[11:36:31] ABILIS_CPX: SAVE CONF

VALIDATION IN PROGRESS ...
ERROR: PO:1 conflicting setting between "CODING" = NRZ and "CLK" = PCLK
ERROR: PO:302 invalid "LOWPO" = 321 type
ERROR: PO:321 "LOWPO" = 1 crossed setting
PO:202 changed "LOWPO" from 2 to NONE because PO:202 not used
VALIDATION FAILED

SAVE NOT EXECUTED

The saving procedure of current configuration has implicitly executed the validating configuration.

The validation procedure has detected, in the current configuration, some errors not recoverable: it failed.

The saving procedure has not been executed.

Example N.4

The following example shows a saving procedure of configuration for testing it. It is successful, even if the implicit validation procedure, executed by it, has detected some configuration incongruency:

[11:36:31] ABILIS_CPX: SAVE CONF TEST

VALIDATION IN PROGRESS ...
PO:1 changed "FRAME" from 144 to 2100 because PO:321 is SDLC
PO:1 changed "L1RXBUF" from 14 to 10 because PO:321 is SDLC
PO:201 changed "LOWPO" from 1 to NONE because PO:201 not used
VALIDATION SUCCESSFULLY EXECUTED

SAVE TEST EXECUTED

The saving procedure of configuration for testing has implicitly executed a validation of configuration.

The validation has detected recoverable incongruency in the current configuration, it made the needed changes and it was successful.

The saving procedure of configuration for test aim has been executed.

Complete list of commands in alphabetical order top

ALARM RESET
ALARM VIEW
A CRKEY:
A D
A DHCP HOST
A DHCP HOST:
A DHCP LAN
A DHCP LAN:
A DHCP PROF:
A EG
A ER
A FTP PATH:
A FTP RIGHTS ID:
A FTP RIGHTS PATH:
A IPACL
A IPAD
A IPP:
A IPR
A IPRS
A LIST:
A NAT
A OSPF AREA:
A OSPF EXTERNAL:
A OSPF HOST:
A OSPF NEIGH:
A OSPF RANGE:
A OSPF VL REM-RID:
A PVC
A R
A RIP EXTERNAL:
A SIPR
A TDM
A USER:
A VD
A VG
A VR
BOOT CARD:
C C
C CODE
C CRKEY:
C D
C DHCP BIND
C DHCP HOST
C DHCP HOST:
C DHCP LAN
C DHCP LAN:
C DHCP PROF:
C EC
C EG
C ER
C FTP PATH:
C FTP RIGHTS ID:
C FTP RIGHTS PATH:
C IPACL
C IPAD
C IPP:
C IPR
C IPRS
C IPS
C L
C LDM
C LE
C LIST:
C NAT
C OSPF AREA:
C OSPF EXTERNAL:
C OSPF HOST:
C OSPF NEIGH:
C OSPF RANGE:
C OSPF VL REM-RID:
C PVC
C R
C RIP EXTERNAL:
C SIPR
C S
C SC
C S IPP
C TDM
C TT
C USER:
C VC
C VD
C VG
C VR
CALL PO:
CLOSE
CONFLOG BACKUP
CONFLOG RESTORE
COPY PO:
D ACT
D C
D CARD
D CE
D CRKEY
D CRKEY:
D D
D DE
D DHCP
D DHCP BIND
D DHCP BINDE
D DHCP HOST
D DHCP HOST:
D DHCP LAN
D DHCP LAN:
D DHCP PROF
D DHCP PROF:
D EC
D ECE
D EG
D EID
D ER
D ERE
D FTP PATH
D FTP PATH:
D FTP RIGHTS
D FTP RIGHTS ID:
D FTP RIGHTS PATH:
D FTP RIGHTS USER:
D G
D I
D INACT
D IPACL
D IPAD
D IPP
D IPP:
D IPR
D IPRS
D IPS
D ITEM
D L
D LDD
D LDM
D LE
D LIST
D LIST:
D NAT
D OSPF AREA
D OSPF AREA:
D OSPF EXTERNAL
D OSPF EXTERNAL:
D OSPF HOST
D OSPF HOST:
D OSPF NEIGH
D OSPF NEIGH:
D OSPF RANGE
D OSPF RANGE:
D OSPF VL
D OSPF VL REM-RID:
D P
D PCIDEV
D PVC
D R
D RE
D RIP EXTERNAL
D RIP EXTERNAL:
D RUN
D S
D SC
D SE
D SIPR
D S IPP
D SE IPP
D T
D TDM
D TE
D TREE
D TT
D USER
D USER:
D USERE
D USERE:
D VC
D VD
D VER
D VG
D VR
DEBUG BM
DEBUG CPXRUN
DEBUG FILE
DEBUG IRQ
DEBUG MEM
DEBUG PO:
DEBUG TASK
DEBUG WDGMEM
DISC PO:
EXIT
F FTP RIGHTS PATH:
F IPACL
F LIST:
F USER
FILE COPY
FILE DELETE
FILE GET
FILE PUT
INIT EIR
INIT ER
INIT IPP
INIT IPR
INIT NAT
INIT PO:
INIT TDM
INIT VR
IPTRACE ACT
IPTRACE CLEAR
IPTRACE DISPLAY
IPTRACE INACT
IPTRACE START
IPTRACE STOP
LIST CREATE
LIST DELETE
LIST DESCRIPTION
LIST RENAME
LOGIN
LOGOUT
M ER
M IPACL
M NAT
M R
M TDM
PAR PO:
PING
QUIT
RESTART SYSTEM
R ACB
R EBIB
R EPIB
R PO:
R PVC
S ACT
S CARD:
S CRKEY:
S D
S DHCP HOST:
S DHCP LAN
S DHCP LAN:
S DHCP PROF:
S EG
S EID
S ER
S FTP PATH:
S FTP RIGHTS ID:
S FTP RIGHTS PATH:
S G
S INACT
S IPACL
S IPAD
S IPP:
S IPR
S IPRS
S NAT
S OSPF AREA:
S OSPF EXTERNAL:
S OSPF HOST:
S OSPF NEIGH:
S OSPF RANGE:
S OSPF VL REM-RID:
S P
S PVC
S R
S RIP EXTERNAL:
S S
S SIPR
S T
S TDM
S TT
S USER:
S VD
S VG
S VR
SAVE CONF
SAVE CONF BACKUP
SAVE CONF TEST
SAVE DEBUG
SOUND DISABLE
SOUND ENABLE
START L
START LDM
SYS DELETE PACKAGE
SYS DELETE VERSION
SYS DIR
SYS DISPLAY BOOT
SYS DISPLAY BOOT LOG
SYS DISPLAY PACKAGES
SYS DISPLAY VERSIONS
SYS DISK CHK
SYS DISK INFO
SYS FLPFORMAT
SYS SET BOOT VERSION
SYS UPDATE
TRACE ACT
TRACE CLEAR
TRACE DISPLAY
TRACE DISPLAY EXTENDED
TRACE GET
TRACE DELETE
TRACE INACT
TRACE PARAM
TRACE PARAM SAVE
TRACE PARAM SET
TRACE SAVE
TRACE START
TRACE STOP
TRACERT
VALIDATE
WARM START


Commands relating to NAT

Configuration of NAT Alias entries
Initialization commands

Other commands

Configuration of NAT Alias entries top

A NAT | Add NAT Alias entry (Administrator)
 | A NAT PR:xxx [par:val]

This command adds a new entry in the Table of NAT Alias with "PR:xxx" priority and, eventually, it sets the indicated parameters to the specified values.

There can be up to 255 entries in the Table of NAT Alias, therefore the priority value indicated must be in the interval [0 - 254].

If a entry with "PR:xxx" priority already exists in the table and a new entry with the same priority is going to be added, then the old one's priority will be incremented by one (PR:xxx+1).

If the new "PR:xxx" value is higher than the maximum value already existing, then new entry priority will be the maximum one incremented by one.

If the table is full and a new entry is going to be added, then an error message will be displayed "NAT TABLE IS FULL, COMMAND NOT EXECUTED"

Changes made on the Table of NAT Alias are not immediately active. They can be activated by executing the command INIT NAT or by executing the initialization command INIT PO:xxx, where "xxx" is the NAT port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".

C NAT | Clear NAT Alias entry (Administrator)
 | C NAT PR:xxx

This command removes from the Table of NAT Alias the entry, whose priority is "PR:xxx". Priority value must be in the interval [0 - 254]. Entries, whose priority is higher than the deleted one, are decremented by one, so that the table is still contiguous.

If the indicated priority does not match an already existing entry, the following message will be displayed "NAT TABLE ENTRY NOT PRESENT".

If the table is empty, the following message is generated: "NAT TABLE IS EMPTY".

Changes made on the Table of NAT Alias are not immediately active. They can be activated by executing the command INIT NAT or by executing the initialization command INIT PO:xxx, where "xxx" is the NAT port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".

D NAT | Display NAT Alias entry (User)
 | D NAT D NAT PR:xxx

This command shows the content of the Table of NAT Alias. It desn't display information about parameters whose values are the default ones. They will be only displayed if their values have been changed from the default ones. In such way, the description of single entry is simply contained in one row.

If the priority is omitted, all defined entries are displayed:

[18:14:08] ABILIS_CPX: D NAT

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                  SIPP: DIPP: PAT:
               PROT:                  DPO:                   ADPO:
------------------------------------------------------------------------------
0   IN    DST  002.002.002.002/32     005.005.005.005/32     10    *     NO
------------------------------------------------------------------------------
1   OUT   DST  005.005.005.005/32     002.002.002.002/32     *     *     NO
------------------------------------------------------------------------------
2   IN    DST  002.002.002.003/32     005.005.005.006/32     10    *     NO
------------------------------------------------------------------------------
3   OUT   DST  005.005.005.006/32     002.002.002.003/32     *     *     NO
------------------------------------------------------------------------------
4   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               ICMP
------------------------------------------------------------------------------
5   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               TCP                    *
------------------------------------------------------------------------------
6   IN    DST  000.000.000.000/32     000.000.000.000/32     *     *     YES
               UDP                    *                      *
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

If the table is empty, the message "*** NO NAT ALIAS ENTRIES CONFIGURED ***" is displayed.

Trough specifying a priority value, the command will show the entry identified by the priority "PR:xxx".

[12:41:53] ABILIS_CPX: D NAT PR:4

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                  SIPP: DIPP: PAT:
               PROT:                  DPO:                   ADPO:
------------------------------------------------------------------------------
4   IN    SRC  000.000.000.000/32     000.000.000.000/32     *     *     YES
               ICMP
------------------------------------------------------------------------------

Priority value must be in the interval [0 - 254]. If the priority does not match any entry priority in the table, the message "NAT TABLE ENTRY NOT PRESENT" will be displayed.

For a detailed description of the information displayed, please refer to Configuration of NAT Aliases section of NAT Aliases document.

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".

M NAT | Move NAT Alias entry (Administrator)
 | M NAT PR:xxx PR:yyy

It changes the NAT Alias entry priority value "PR:xxx" to "PR:yyy". Therefore the entry position, inside the table, will be changed and the whole table will be sorted again to guarantee its contiguity.

Priority values must be in the interval [0 - 254]. If the priority does not match any entry priority in the table, the message "NAT TABLE ENTRY NOT PRESENT" will be displayed.

If the table is empty, the following message is generated: "NAT TABLE IS EMPTY".

Changes made on the Table of NAT Alias are not immediately active. They can be activated by executing the command INIT NAT or by executing the initialization command INIT PO:xxx, where "xxx" is the NAT port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".

S NAT | Set NAT Alias entry (Administrator)
 | S NAT PR:xxx par:val [par:val]

It sets to new values the parameters of the NAT Alias entry specified by "PR:xxx".

Priority value must be in the interval [0 - 254]. If the priority does not match any entry priority in the table, the message "NAT TABLE ENTRY NOT PRESENT" will be displayed.

If the table is empty, the following message is generated: "NAT TABLE IS EMPTY".

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of NAT Alias entry parameters, please refer to to Configuration of NAT Aliases section of NAT Aliases document.

Changes made on the Table of NAT Alias are not immediately active. They can be activated by executing the command INIT NAT or by executing the initialization command INIT PO:xxx, where "xxx" is the NAT port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT NAT command or the INIT PO: command.

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".

Initialization commands top

INIT NAT | Init NAT Alias table (User)
 | INIT NAT

It refreshes the NAT static table updating eventual parameters that might have been changed by the user acting on Table of NAT Alias and clears the NAT dynamic table content.

For a detailed description of NAT services, please refer to NAT port section.

If the command is successful the message "COMMAND EXECUTED" is generated, otherwise the one "COMMAND FAILED".

If the Abilis CPX version, currently in use, does not support NAT services, the following message will be shown "NAT SERVICE NOT PRESENT".


Commands relating to OSPF Tables

OSPF Areas
OSPF External routes
OSPF Hosts
OSPF Neighbours
OSPF Ranges
OSPF Virtual Links

Other commands

OSPF Areas top

A OSPF AREA: | Add OSPF Area (Administrator)
 | A OSPF AREA:x.x.x.x [par:val]

This command adds a new entry to the OSPF Areas table, identified by the specified ID. The command also sets the eventually indicated optional parameters to the specified values.

Valid Area IDs are values in the range [0.0.0.0 - 255.255.255.255] and must be expressed in Dotted Decimal Notation.

The ID value unambiguously identifies an entry in the system. Two or more entries with the same ID value cannot be present in the same time in the table. If the indicated value matches an already existing entry, the following message will be displayed "OSPF AREA ALREADY EXISTS".

If the table is full, i.e. no free record is currently available, the message "OSPF AREAs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF AREA: | Clear OSPF Area (Administrator)
 | C OSPF AREA:x.x.x.x

This command deletes an entry from the OSPF Areas table, identified by the specified ID.

Valid Area IDs are values in the range [0.0.0.0 - 255.255.255.255] and must be expressed in Dotted Decimal Notation.

The ID value unambiguously identifies an entry in the system. Two or more entries with the same ID value cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF AREA NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF AREAs TABLE IS EMPTY" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF AREA | Display OSPF Areas (User)
 | D OSPF AREA

This command shows all currently defined OSPF ares.

Here it is a sample of the command execution:

[19:40:25] ABILIS_CPX: D OSPF AREA

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

--------------------------------------------------------
AREA:               AUTTYPE:   STUB:    DEFCOST:
--------------------------------------------------------
001.001.000.002     SIMPLE     YES             1
001.001.001.001     CRYPTO     NO          65535
001.001.001.002     SIMPLE     YES         65535
002.001.001.001     NO         NO          65535
--------------------------------------------------------

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF AREAs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Areas table's entry parameters, please refer to the Configuration of OSPF Areas section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF AREA: | Display OSPF Area (User)
 | D OSPF AREA:x.x.x.x

This command display the OSPF area entry identified by the specified ID.

Valid Area IDs are values in the range [0.0.0.0 - 255.255.255.255] and must be expressed in Dotted Decimal Notation.

The ID value unambiguously identifies an entry in the system. Two or more entries with the same ID value cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF AREA NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF AREAs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Areas table's entry parameters, please refer to the Configuration of OSPF Areas section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

S OSPF AREA: | Set OSPF Area (Administrator)
 | S OSPF AREA:x.x.x.x par:val [par:val]

This command sets to new values the parameters of the OSPF Area, identified by the specified ID.

Valid Area IDs are values in the range [0.0.0.0 - 255.255.255.255] and must be expressed in Dotted Decimal Notation.

The ID value unambiguously identifies an entry in the system. Two or more entries with the same ID value cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF AREA NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF AREAs TABLE IS EMPTY" will be shown.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of OSPF Areas table's entry parameters, please refer to the Configuration of OSPF Areas section.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

OSPF External routes top

A OSPF EXTERNAL: | Add OSPF External route (Administrator)
 | A OSPF EXTERNAL:x.x.x.x/yy PROT:val ACTION:val [METRIC:val]

It adds a new entry to the Table of OSPF External Routes, identified by the specified mandatory parameters. The command also sets the eventually indicated optional parameters to the specified values.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The "ACTION:val" parameter represents the action associated to this entry and must correspond to a value in the range [IGNORE, ACCEPT].

The IP external network, the protocol and the action values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated values match an already existing entry, the following message will be displayed "OSPF EXTERNAL ROUTE ALREADY PRESENT".

If the table is full, i.e. no free record is currently available, the message "OSPF EXTERNAL ROUTEs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF EXTERNAL: | Clear OSPF External route (Administrator)
 | C OSPF EXTERNAL:x.x.x.x/yy PROT:val

It deletes an OSPF External route entry, identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match any already existing entry, the following message will be displayed "OSPF EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the following message is generated: "OSPF EXTERNAL ROUTEs TABLE IS EMPTY".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF EXTERNAL | Display OSPF External routes table (User)
 | D OSPF EXTERNAL

This command shows the content of the Table of OSPF External Routes.

Here is an example of the information shown by the command:

[16:54:38] ABILIS_CPX: D OSPF EXTERNAL

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-----------------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:  TYPE:
-----------------------------------------------------
192.168.006.002/32   RIP     ACCEPT          5     1
192.168.006.000/24   LOCAL   IGNORE          1     1
010.000.000.000/8    ANY     ACCEPT         10     1
000.000.000.000/0    ANY     ACCEPT          *     1
-----------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the table is empty, the message "*** NO OSPF EXTERNAL ROUTEs DEFINED ***" will be displayed.

For a detailed description of OSPF External Routes table's entry parameters, please refer to the Configuration of OSPF External Routes section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF EXTERNAL: | Display OSPF External route (User)
 | D OSPF EXTERNAL:x.x.x.x/yy PROT:val

It displays a specific OSPF External route entry, identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

[15:22:05] ABILIS_CPX: D OSPF EXTERNAL:192.168.006.000/24 PROT:LOCAL

-----------------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:  TYPE:
-----------------------------------------------------
192.168.006.000/24   LOCAL   IGNORE          1     1
-----------------------------------------------------

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match any already existing entry, the following message will be displayed "OSPF EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the message "*** NO OSPF EXTERNAL ROUTEs DEFINED ***" will be displayed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF External Routes table's entry parameters, please refer to the Configuration of OSPF External Routes section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

S OSPF EXTERNAL: | Set OSPF External route (Administrator)
 | S OSPF EXTERNAL:x.x.x.x/yy PROT:val par:val [par:val]

It sets to new values the parameters of the OSPF External route entry, identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match any already existing entry, the following message will be displayed "OSPF EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the following message is generated: "OSPF EXTERNAL ROUTEs TABLE IS EMPTY".

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of OSPF External Routes table's entry parameters, please refer to the Configuration of OSPF External Routes section.

Changes made on the table of OSPF External Routes are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

OSPF Hosts top

A OSPF HOST: | Add OSPF Host (Administrator)
 | A OSPF HOST:x.x.x.x AREA:val [par:val]

This command adds a new host definition to the OSPF Hosts table, identified by the specified IP address and Area ID. The command also sets the eventually indicated optional parameters to the specified values.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255]. The specified OSPF area must be already defined in the OSPF Areas table, otherwise the "OSPF AREA NOT PRESENT" error message is displayed and the command refused.

The host IP address unambiguously identifies an entry in the system. Two or more entries with the same IP address cannot be present in the same time in the table. If the indicated value matches an already existing entry, the following message will be displayed "OSPF HOST ALREADY EXISTS".

If the table is full, i.e. no free record is currently available, the message "OSPF HOSTs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF HOST: | Clear OSPF Host (Administrator)
 | C OSPF HOST:x.x.x.x

This command deletes an entry from the OSPF Hosts table, identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The host IP address unambiguously identifies an entry in the system. If the indicated value does not match any already existing entry, the following message will be displayed "OSPF HOST NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF HOSTs TABLE IS EMPTY" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF HOST | Display OSPF Hosts (User)
 | D OSPF HOST

This command shows the content of the Table of OSPF Hosts.

Here is an example of the information shown by the command:

[16:54:38] ABILIS_CPX: D OSPF HOST

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

---------------------------------------
HOST:            AREA:            COST:
---------------------------------------
001.001.001.001  001.001.001.001  65535
001.001.001.002  001.001.001.001  65535
002.001.001.001  002.000.000.000  65535
---------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the table is empty, the message "*** NO OSPF HOSTs DEFINED ***" will be displayed.

For a detailed description of OSPF Hosts table's entry parameters, please refer to the Configuration of OSPF Hosts section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF HOST: | Display OSPF Host (User)
 | D OSPF HOST:x.x.x.x

It displays a specific OSPF host entry, identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The host IP address unambiguously identifies an entry in the system. If the indicated value does not match any already existing entry, the following message will be displayed "OSPF HOST NOT PRESENT".

If the table is empty, the message "*** NO OSPF HOSTs DEFINED ***" will be displayed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Hosts table's entry parameters, please refer to the Configuration of OSPF Hosts section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

S OSPF HOST: | Set OSPF Host (Administrator)
 | S OSPF HOST:x.x.x.x par:val [par:val]

This command sets to new values the parameters of the OSPF Host, identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The host IP address unambiguously identifies an entry in the system. If the indicated value does not match any already existing entry, the following message will be displayed "OSPF HOST NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF HOSTs TABLE IS EMPTY" will be shown.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of OSPF Hosts table's entry parameters, please refer to the Configuration of OSPF Hosts section.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

OSPF Neighbours top

A OSPF NEIGH: | Add OSPF Neighbour (Administrator)
 | A OSPF NEIGH:x.x.x.x [par:val]

This command adds a new entry to the OSPF Neighbours table, identified by the specified IP address. The command also sets the eventually indicated optional parameters to the specified values.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The neighbour IP address unambiguously identifies an entry in the system. Two or more entries with the same IP address cannot be present in the same time in the table. If the indicated value matches an already existing entry, the following message will be displayed "OSPF NEIGHBOUR ALREADY EXISTS".

If the table is full, i.e. no free record is currently available, the message "OSPF NEIGHBOURs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF NEIGH: | Clear OSPF Neighbour (Administrator)
 | C OSPF NEIGH:x.x.x.x

This command deletes an entry from the OSPF Neighbours table, identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The neighbour IP address unambiguously identifies an entry in the system. Two or more entries with the same IP address cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF NEIGHBOUR NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF NEIGHBOURs TABLE IS EMPTY" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF NEIGH | Display OSPF Neighbours (User)
 | D OSPF NEIGH

This command shows all currently defined OSPF neighbours.

Here it is a sample of the command execution:

[19:40:25] ABILIS_CPX: D OSPF NEIGH

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

----------------------------------------------------------------
NEIGH:           IPP:   PRIO:   POLL:    COST:
----------------------------------------------------------------
001.001.001.001  NONE     255       1        0
001.001.002.001     1       0      10        0
002.001.002.000  NONE       0      10      255
----------------------------------------------------------------

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF NEIGHBOURs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Neighbours table's entry parameters, please refer to the Configuration of OSPF Neighbours section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF NEIGH: | Display OSPF Neighbour (User)
 | D OSPF NEIGH:x.x.x.x

This command display the OSPF neighbour entry identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The neighbour IP address unambiguously identifies an entry in the system. Two or more entries with the same IP address cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF NEIGHBOUR NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF NEIGHBOURs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Neighbours table's entry parameters, please refer to the Configuration of OSPF Neighbours section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

S OSPF NEIGH: | Set OSPF Neighbour (Administrator)
 | S OSPF NEIGH:x.x.x.x par:val [par:val]

This command sets to new values the parameters of the OSPF Neighbour, identified by the specified IP address.

Valid IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The neighbour IP address unambiguously identifies an entry in the system. Two or more entries with the same IP address cannot be present in the same time in the table. If the indicated value does not match any existing entry, the following message will be displayed "OSPF NEIGHBOUR NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF NEIGHBOURs TABLE IS EMPTY" will be shown.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of OSPF Neighbours table's entry parameters, please refer to the Configuration of OSPF Neighbours section.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

OSPF Ranges top

A OSPF RANGE: | Add OSPF Range (Administrator)
 | A OSPF RANGE:x.x.x.x/yy AREA:val [ADV:val]

This command defines a new OSPF range, identified by the specified mandatory parameters. The command also sets the eventually indicated optional parameters to the specified values.

The "RANGE:" parameter corresponds to network IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255]. The specified OSPF area must be already defined in the OSPF Areas table, otherwise the "OSPF AREA NOT PRESENT" error message is displayed and the command refused.

The range and the Area ID values unambiguously identify an entry in the system. Two or more entries with the same range value and the same Area ID cannot be present in the same time in the table. If the indicated values match an already existing entry, the following message will be displayed "OSPF RANGE ALREADY EXISTS".

If the table is full, i.e. no free record is currently available, the message "OSPF RANGEs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

Changes made on the table of OSPF Ranges are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF RANGE: | Clear OSPF Range (Administrator)
 | C OSPF RANGE:x.x.x.x/yy AREA:val

This command deletes an OSPF range, identified by the specified mandatory parameters.

The "RANGE:" parameter corresponds to network IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "AREA:" parameter represents an OSPF Area ID expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The range and the Area ID values unambiguously identify an entry in the system. Two or more entries with the same range value and the same Area ID cannot be present in the same time in the table. If the indicated values don't match any already existing entry, the following message will be displayed "OSPF RANGE NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF RANGEs TABLE IS EMPTY" will be shown.

Changes made on the table of OSPF Ranges are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF RANGE | Display OSPF Ranges (User)
 | D OSPF RANGE

This command displays all configured OSPF ranges.

Here it is a sample of the command execution:

[18:51:44] ABILIS_CPX: D OSPF RANGE

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

---------------------------------------------------------
AREA:               RANGE:                ADV:
---------------------------------------------------------
001.001.001.001     001.001.001.001/32    YES
                    001.002.002.002/32    NO
---------------------------------------------------------
002.001.001.001     002.001.001.002/32    YES
---------------------------------------------------------

As it can bee seen from the previous example, OSPF ranges are grouped and sorted on the base of their Area ID.

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF RANGEs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Ranges table's entry parameters, please refer to the Configuration of OSPF Ranges section.

D OSPF RANGE: | Display OSPF Range (User)
 | D OSPF RANGE:x.x.x.x/yy AREA:val

This command displays a specific OSPF range, identified by the specified mandatory parameters.

The "RANGE:" parameter corresponds to network IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "AREA:" parameter represents an OSPF Area ID expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The range and the Area ID values unambiguously identify an entry in the system. Two or more entries with the same range value and the same Area ID cannot be present in the same time in the table. If the indicated values don't match any already existing entry, the following message will be displayed "OSPF RANGE NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF RANGEs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

For a detailed description of OSPF Ranges table's entry parameters, please refer to the Configuration of OSPF Ranges section.

S OSPF RANGE: | Set OSPF Range (Administrator)
 | S OSPF RANGE:x.x.x.x par:val [par:val]

This command sets to new values the parameters of the OSPF Range entry, identified by the specified mandatory parameters.

The "RANGE:" parameter corresponds to network IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "AREA:" parameter represents an OSPF Area ID expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The range and the Area ID values unambiguously identify an entry in the system. Two or more entries with the same range value and the same Area ID cannot be present in the same time in the table. If the indicated values don't match any already existing entry, the following message will be displayed "OSPF RANGE NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF RANGEs DEFINED ***" will be shown.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the table of OSPF Ranges are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

For a detailed description of OSPF Ranges table's entry parameters, please refer to the Configuration of OSPF Ranges section.

OSPF Virtual Links top

C OSPF VL REM-RID:
D OSPF VL
D OSPF VL REM-RID:
S OSPF VL REM-RID:
A OSPF VL REM-RID: | Add OSPF Virtual Link (Administrator)
 | A OSPF VL REM-RID:x.x.x.x AREA:val [par:val]

This command adds a new entry to the OSPF Virtual Links table, identified by the specified Remote Router ID and and Area ID. The command also sets the eventually indicated optional parameters to the specified values.

Valid Remote Router ID must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255]. The specified OSPF area must be already defined in the OSPF Areas table, otherwise the "OSPF AREA NOT PRESENT" error message is displayed and the command refused.

The OSPF Virtual Link definition requires also that the Backbone area is already defined in the OSPF Areas table, otherwise the "OSPF BACKBONE AREA (0.0.0.0) NOT PRESENT. OSPF VIRTUAL LINK CANNOT BE ADDED" error message is displayed and the command refused.

The couple Remote Router ID and Area ID unambiguously identifies an entry in the system. Two or more entries with the same Remote Router ID and Area ID cannot be present in the same time in the table. If the indicated values match an already existing entry, the following message will be displayed "OSPF VIRTUAL LINK ALREADY EXISTS".

If the table is full, i.e. no free record is currently available, the message "OSPF VIRTUAL LINKs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

C OSPF VL REM-RID: | Clear OSPF Virtual Link (Administrator)
 | C OSPF VL REM-RID:x.x.x.x AREA:val

This command deletes an entry from the OSPF Virtual Links table, identified by the specified Remote Router ID and Area ID.

Valid Remote Router ID must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The couple Remote Router ID and Area ID unambiguously identifies an entry in the system. Two or more entries with the same Remote Router ID and Area ID cannot be present in the same time in the table. If the indicated values does not match any existing entry, the following message will be displayed "OSPF VIRTUAL LINK NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF VIRTUAL LINKs TABLE IS EMPTY" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF VL | Display OSPF Virtual Links (User)
 | D OSPF VL

This command shows all currently defined OSPF Virtual Links.

Here it is a sample of the command execution:

[19:40:25] ABILIS_CPX: D OSPF VL

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

-------------------------------------------------------------------------------
REM-RID:         AREA:           HELLO: RXMT: TRDEL: DEAD:  PWD:         KEYID:
                                                            MD5KEY:
-------------------------------------------------------------------------------
001.001.001.001  001.001.001.001     10     5      1    60                    0

001.001.001.002  001.001.001.001     10     5      1    60                    0

-------------------------------------------------------------------------------

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF VIRTUAL LINKs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Virtual links table's entry parameters, please refer to the Configuration of OSPF Virtual links section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

D OSPF VL REM-RID: | Display OSPF Virtual Link (User)
 | D OSPF VL REM-RID:x.x.x.x AREA:val

This command display the OSPF Virtual Link entry, identified by the specified Remote Router ID and Aarea ID.

Valid Remote Router ID must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The couple Remote Router ID and Area ID unambiguously identifies an entry in the system. Two or more entries with the same Remote Router ID and Area ID cannot be present in the same time in the table. If the indicated values does not match any existing entry, the following message will be displayed "OSPF VIRTUAL LINK NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "*** NO OSPF VIRTUAL LINKs DEFINED ***" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

For a detailed description of OSPF Virtual links table's entry parameters, please refer to the Configuration of OSPF Virtual links section.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".

S OSPF VL REM-RID: | Set OSPF Virtual Link (Administrator)
 | S OSPF VL REM-RID:x.x.x.x AREA:val par:val [par:val]

This command sets to new values the parameters of the Virtual Link entry, identified by the specified Remote Router ID and Aarea ID.

Valid Remote Router ID must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

The "AREA:" parameter represents an OSPF Area ID, expressed in Dotted Decimal Notation [0.0.0.0 - 255.255.255.255].

The couple Remote Router ID and Area ID unambiguously identifies an entry in the system. Two or more entries with the same Remote Router ID and Area ID cannot be present in the same time in the table. If the indicated values does not match any existing entry, the following message will be displayed "OSPF VIRTUAL LINK NOT PRESENT".

If the table is empty, i.e. no record is currently available, the message "OSPF VIRTUAL LINKs TABLE IS EMPTY" will be shown.

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of OSPF Virtual links table's entry parameters, please refer to the Configuration of OSPF Virtual links section.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the OSPF port number.

If the Abilis CPX version, currently in use, does not support OSPF services, the following message will be shown "OSPF SERVICE NOT PRESENT".


Commands relating to ports and boards

Ports configuration
Boards configuration
Status commands and statistics of the ports
Initialization/activation/deactivation commands
Information notes about the ports

Other commands

Ports configuration top

D P | Display Port Parameters (User)
 | D P PO:A D P PO:type D P PO:xxx[,yyy,...] D P PO:xxx [.]

This command shows configuration parameters of one or more active CPX ports. The following table summarizes the allowed command syntaxes:

D P PO:A | Display parameter(s) of all the active ports currently configured.
D P PO:type | Display parameter(s) of all the active ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
D P PO:xxx[,yyy,...] | Display parameter(s) of all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.
D P PO:xxx [.] | Display parameter(s) of the specified port [0 - 999]. If there is a lower active port that is linked to the requested one, then the command will also display its parameters and so on recursively. The recursive visualization is not executed if the '.' (dot) character is added at the end of the command row.

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR INACTIVE", where "xxx" is the identifier of the requested port.

Configuration parameters are displayed using lower case and upper case characters. This kind of visualization is used to point out that configuration parameters are grouped into two sets:

  • parameters that can be activated only by restarting the system; they are identified by lower case characters;
  • parameter that can be activated by executing the initialization command INIT PO:xxx; they are identified by upper case characters.

Here there are some examples of the command output:

EXAMPLE 1: recursive visualization:

[10:38:10] ABILIS_CPX: D P PO:301

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:2     ps:128
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3
PO:201 ------------------------------------------------------------------------
LAPB   LOG:DS      lowpo:1     lapb:DCE      FW:7
       T1:3000     T2:0        T3:9000       N1:144      N2:10
PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V35     CLK:INT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       E1-FRAMING:CRC4         HAUL:SHORT
       CH:0-31
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

EXAMPLE 2: recursive visualization avoided by the addition of the '.' (dot) character the end of the command line:

[10:38:12] ABILIS_CPX: D P PO:301 .

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

EXAMPLE 3: visualization of a set of ports of the same type:

[10:39:21] ABILIS_CPX: D P PO:X25

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:302 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:202   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

EXAMPLE 4: visualization of a set of ports, by specifying the list:

[10:39:44] ABILIS_CPX: D P PO:301,201,1

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:2     ps:128
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:201 ------------------------------------------------------------------------
LAPB   LOG:DS      lowpo:1     lapb:DCE      FW:7
       T1:3000     T2:0        T3:9000       N1:144      N2:10

PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V35     CLK:INT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       E1-FRAMING:CRC4         HAUL:SHORT
       CH:0-31
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

S P | Set Port Parameters (Administrator/Super-User)
 | S P PO:A par:val [par:val] S P PO:type par:val [par:val] S P PO:xxx[,yyy,...] par:val [par:val]

This command sets one or more configuration parameters of one or more active CPX ports. The following table summarizes the allowed command syntaxes:

S P PO:A par:val [par:val] | Set the specified parameter(s) value of all the active ports currently configured.
S P PO:type par:val [par:val] | Set the specified parameter(s) value of all the active ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
S P PO:xxx[,yyy,...] par:val [par:val] | Set the specified parameter(s) value of all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR INACTIVE", where "xxx" is the identifier of the requested port.

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value; the other ones will not be changed.

Here there are some examples of the command execution:

EXAMPLE 1: setting the same parameter for all the active ports: an error message is generated for that ports for which the specified parameter is not provided:

[11:13:42] ABILIS_CPX: S P PO:A LOG:NO

PO:0 BAD PARAMETER 'LOG:NO'

PO:100 BAD PARAMETER 'LOG:NO'

PO:200 BAD PARAMETER 'LOG:NO'

PO:901 BAD PARAMETER 'LOG:NO'

PO:902 BAD PARAMETER 'LOG:NO'

PO:903 BAD PARAMETER 'LOG:NO'

PO:904 BAD PARAMETER 'LOG:NO'

PO:905 BAD PARAMETER 'LOG:NO'

PO:906 BAD PARAMETER 'LOG:NO'

PO:910 BAD PARAMETER 'LOG:NO'

COMMAND EXECUTED

EXAMPLE 2: setting the same parameter for all the active ports of a certain type: an error message is generated for that ports for which the specified parameter is not available (in the example: EBISDN ports for which the side: parameter is set to "TE"):

[11:16:34] ABILIS_CPX: D P PO:EBISDN

PO:80  ------------------------------------------------------------------------
EBISDN LOG:NO      side:NT       BUS:SHORT

PO:81  ------------------------------------------------------------------------
EBISDN LOG:NO      side:NT       BUS:SHORT

PO:82  ------------------------------------------------------------------------
EBISDN LOG:NO      side:TE

PO:83  ------------------------------------------------------------------------
EBISDN LOG:NO      side:TE

[11:16:41] ABILIS_CPX: S P PO:EBISDN BUS:SHORT

PO:82 BAD PARAMETER 'BUS:SHORT'

PO:83 BAD PARAMETER 'BUS:SHORT'

COMMAND EXECUTED

EXAMPLE 3: setting one or more parameters whose range is related to the current value of same other parameters: in the example it can be seen that the setting PVC:, FISVC:, ISVC:, FBSVC:, BSVC:, FOSVC:, OSVC: parameters of an X25 port must be done very carefully. In fact X.25 normative requires an increasing enumeration of the VC channels, that's why Abilis CPX checks whether the assignation of logical channels matches the requirements.
Suppose that the current setting is the following:

[11:48:00] ABILIS_CPX: D P PO:308

PO:308 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:NONE  TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:6       fosvc:26    x25:DTE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

The following command generates an error message that singal a conflicting situation:

[12:08:17] ABILIS_CPX: S P PO:308 ISVC:10 FBSVC:16

PO:308 CONFLICTING VALUE 'ISVC:10'

In fact the command row is evaluated starting from the leftmost element; because "FBSVC:" current value is 6, writing "ISVC:10" as first element will cause a conflict. This error can be avoided if, before setting "ISVC:10", "FBSVC:" value is changed:

[12:08:26] ABILIS_CPX: S P PO:308 FBSVC:16 ISVC:10

COMMAND EXECUTED

In this way the new "ISVC:" value won't be incompatible anymore.

EXAMPLE 4: How to know wheter the port configuration was modified or not?

Suppose that the current setting of the FTP port is the following:

[10:57:34] ABILIS_CPX: D P PO:FTP

PO:914 ------------------------------------------------------------------------
FTP    LOG:NO        lowpo:901     ACT:YES          max-cli:4
       c-port:21     d-port:20
       IPSRC:*                     IPSRCLIST:#
       SEND-TOUT:30      DT:300    REJ-1024:YES     SAME-IP:YES  SYSDRIVES:YES
       MAX-PWD-FAIL:4              DELAY-PWD-FAIL:5
       MAX-IP-SES:NOMAX            MAX-USER-SES:NOMAX
       ANONYMOUS-USER:DENY         REGISTERED-USER:PERMIT

The "Not Saved (SAVE CONF)" message is displayed every time the port configuration is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the port configuration is modified but not refreshed with the INIT PO: command.

The FTP port parameters display will be the one reported in the following example:

[10:57:51] ABILIS_CPX: S P PO:FTP SEND-TOUT:100

COMMAND EXECUTED

[10:58:08] ABILIS_CPX: D P PO:FTP

PO:914 - Not Saved (SAVE CONF), Not Refreshed (INIT) --------------------------
FTP    ------------------------------------------------------------------------
       LOG:NO        lowpo:901     ACT:YES          max-cli:4
       c-port:21     d-port:20
       IPSRC:*                     IPSRCLIST:#
       SEND-TOUT:100     DT:300    REJ-1024:YES     SAME-IP:YES  SYSDRIVES:YES
       MAX-PWD-FAIL:4              DELAY-PWD-FAIL:5
       MAX-IP-SES:NOMAX            MAX-USER-SES:NOMAX
       ANONYMOUS-USER:DENY         REGISTERED-USER:PERMIT

After the SAVE CONF command execution, the "Not Saved (SAVE CONF)" message dissapears:

[11:04:11] ABILIS_CPX: SAVE CONF

VALIDATION IN PROGRESS ...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[11:04:14] ABILIS_CPX: D P PO:FTP

PO:914 - Not Refreshed (INIT) -------------------------------------------------
FTP    ------------------------------------------------------------------------
       LOG:NO        lowpo:901     ACT:YES          max-cli:4
       c-port:21     d-port:20
       IPSRC:*                     IPSRCLIST:#
       SEND-TOUT:100     DT:300    REJ-1024:YES     SAME-IP:YES  SYSDRIVES:YES
       MAX-PWD-FAIL:4              DELAY-PWD-FAIL:5
       MAX-IP-SES:NOMAX            MAX-USER-SES:NOMAX
       ANONYMOUS-USER:DENY         REGISTERED-USER:PERMIT

After the INIT PO: command execution, the "Not Refreshed (INIT)" message dissapears:

[11:09:10] ABILIS_CPX: INIT PO:FTP

COMMAND EXECUTED

[11:10:40] ABILIS_CPX: D P PO:FTP

PO:914 ------------------------------------------------------------------------
FTP    LOG:NO        lowpo:901     ACT:YES          max-cli:4
       c-port:21     d-port:20
       IPSRC:*                     IPSRCLIST:#
       SEND-TOUT:100     DT:300    REJ-1024:YES     SAME-IP:YES  SYSDRIVES:YES
       MAX-PWD-FAIL:4              DELAY-PWD-FAIL:5
       MAX-IP-SES:NOMAX            MAX-USER-SES:NOMAX
       ANONYMOUS-USER:DENY         REGISTERED-USER:PERMIT

warning! To activate changes made on the parameters displayed by upper case characters, it is enough to execute the initialization command INIT PO:. On the contrary for activating changes made on parameters displayed by low case characters, it is needed to restart the system.

COPY | Copy Port Parameters (Administrator)
 | COPY PO:xxx TO PO:yyy

It sets the "PO:yyy" port configuration parameters to the same values of the "PO:xxx" port ones. Both port values must be in the interval [0 - 999] and they must correspond to currently active ports.

PAR | Display CCITT parameters active values (User)
 | PAR PO:xxx

It displays the values of CCITT parameters currently active on the specified PAD port. The specified port value must be in the range [0 - 999] and must correspond to currently active and running port.

[14:29:13] ABILIS_CPX: PAR PO:21

PO:21  ------------------------------------------------------------------------
PAD    01:001 02:001 03:002 04:000 05:001 06:005 07:000 08:000 09:000 10:000
       11:014 12:001 13:004 14:000 15:001 16:008 17:024 18:002 19:002 20:000
       21:000 22:000

This command works on PAD port type only; otherwise the message "COMMAND NOT ALLOWED FOR THAT PORT" will be shown.

In the case that the specified port is not currently running, the following error message is generated: "PORT NOT PRESENT OR NOT RUNNING".

Boards configuration top

BOOT CARD | Boot Card (Administrator/Super-User)
 | BOOT CARD:type-nnn

It sets configuration parameters of the specified board to its default values.

Boards identifier ust be indicated in the form: "type-nnn", where:

"type"
has to be one of the card's mnemonics that are allowed by the system (e.g. ETH100, ESB and so on);
"nnn"
must be a digit in the interval [1 - 255].

If the command is successful the message "COMMAND EXECUTED" is generated.

If the specified board is not currently configured or active the following message will be shown: "CARD NOT PRESENT OR INACTIVE".

D CARD | Display active/inactive cards (User)
 | D CARD

It displays configured boards and an overview of related configuration.

[11:49:13] ABILIS_CPX: D CARD

-------------------------------- Active Cards: --------------------------------
Card-Numb      Port(s)                                       SlotId  Addr  Irq
-------------------------------------------------------------------------------
ESB-1            1,  2,  3,  4  . . . . . . . . . . . . . . .     8   PCI   10
ESB-2            5,  6,  7,  8  . . . . . . . . . . . . . . .    10   PCI   12
ASY-1           21  . . . . . . . . . . . . . . . . . . . . .     -   3F8    4
ETH100-1        58  . . . . . . . . . . . . . . . . . . . . .     9   PCI    7
EBIB-1         100,  80..95   . . . . . . . . . . . . . . . .     -  CE00   11

------------------------------- Inactive Cards: -------------------------------
Card-Numb      Port(s)                                       SlotId  Addr  Irq
-------------------------------------------------------------------------------
HSCB-1           1,  2  . . . . . . . . . . . . . . . . . . .     -  D000    7
HSCB-2           3,  4  . . . . . . . . . . . . . . . . . . .     -  D000    5
HSCB-3           5,  6  . . . . . . . . . . . . . . . . . . .     -  D000   10
HSCB-4           7,  8  . . . . . . . . . . . . . . . . . . .     -  D000   11
HSCB-5           9, 10  . . . . . . . . . . . . . . . . . . .     -  D000   14
HSCB-6          11, 12  . . . . . . . . . . . . . . . . . . .     -  D000   15
HSCB-7          13, 14  . . . . . . . . . . . . . . . . . . .     -  D000    3
HSCB-8          15, 16  . . . . . . . . . . . . . . . . . . .     -  D000   12
ESB-3            9, 10, 11, 12  . . . . . . . . . . . . . . .  NONE   PCI    ?
ESB-4           13, 14, 15, 16  . . . . . . . . . . . . . . .  NONE   PCI    ?
ISDN-1          17  . . . . . . . . . . . . . . . . . . . . .     -   390   11
ISDN-2          18  . . . . . . . . . . . . . . . . . . . . .     -   398   10
ISDN-3          19  . . . . . . . . . . . . . . . . . . . . .     -   3A0    5
ASY-2           22  . . . . . . . . . . . . . . . . . . . . .     -   2F8    3
ASYMS-1         23..30  . . . . . . . . . . . . . . . . . . .     -   280    3
ASYMS-2         31..38  . . . . . . . . . . . . . . . . . . .     -   190    5
ASYMS-3         39..46  . . . . . . . . . . . . . . . . . . .     -   200   10
ASYMS-4         47..54  . . . . . . . . . . . . . . . . . . .     -   300   15
ETH-1           55  . . . . . . . . . . . . . . . . . . . . .     -   300   12
ETH-2           56  . . . . . . . . . . . . . . . . . . . . .     -   360   10
TRH-1           57  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
ETH100-2        59  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
ACB-1           60, 61, 62, 63, 64, 65, 66, 67  . . . . . . .     -   320   15
ACB-2           68, 69, 70, 71, 72, 73, 74, 75  . . . . . . .     -   340   14
ACB-3           76, 77, 78, 79, 64, 65, 66, 67  . . . . . . .     -   2A0   11
EPIB-1         100,  96..99   . . . . . . . . . . . . . . . .     -  CC00   11
BEP-1           80..95  . . . . . . . . . . . . . . . . . . .     -  CE00   10
BRIO-1          17  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
BRIO-2          18  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
BRIO-3          19  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?

S CARD: | Set Card Parameters (Administrator/Super-User)
 | S CARD:type-nnn par:val [par:val]

It sets one or more configuration parameters of the specified board to the specified value.

Boards identifier must be indicated in the form: "type-nnn", where:

"type"
has to be one of the card's mnemonics that are allowed by the system (e.g. ETH100, ESB and so on);
"nnn"
must be a digit in the interval [1 - 255].

If the command is successful the message "COMMAND EXECUTED" is generated.

If the specified board is not currently configured or active the following message will be shown: "CARD NOT PRESENT OR INACTIVE".

For PCI board types, the command allows the user to set the PCI slot identifier of the board, i.e. "SLOTID:" parameter.

For not PCI board types, the command sets the memory address ("ADDR:" parameter) and interrupt ("IRQ:" parameter) of the board.

By typing "S CARD: ?", it is possible to have a complete list of the available configuration parameters. Few examples are reported below:

[14:48:55] ABILIS_CPX: S CARD: ?

S CARD:val par:val [par:val]  Set the specified card parameter(s)

SLOTID:    Slot Id value [0..65534, NONE = Unassegned]      <PCI cards only>
ADDR:      Base Address value                  <HSCB and PCI cards excluded>
IRQ:       Interrupt value                              <PCI cards excluded>

[14:54:21] ABILIS_CPX: S CARD:HSCB-1 ?

HSCB Card parameters:

IRQ:       Interrupt value [3, 4, 5, 7, 10, 11, 12, 14, 15]

[14:54:37] ABILIS_CPX: S CARD:ETH100-1 ?

ETH100H Card parameters:

SLOTID:    Slot Id value [0..65534, NONE = Unassegned]

[14:54:44] ABILIS_CPX: S CARD:ETH-1 ?

ETHH Card parameters:

ADDR:      Base Address value [0x200, 0x220, 0x240, ..., 0x3C0, 0x3E0]
IRQ:       Interrupt value [3, 4, 5, 7, 10, 11, 12, 14, 15]

D PCIDEV | Display PCI devices (User)
 | D PCIDEV

It displays information about PCI boards currently present and active in the system.

Here is an example of the command execution:

[08:44:54] ABILIS_CPX: D PCIDEV

PCI Server Overview:

ID Vendor          Device                    CardName         Slot/F   Ver Irq
-------------------------------------------------------------------------------
1  1106 VIA        0597 BRIDGE HOST          -                   0/0   0.4   -
2  1106 VIA        8598 BRIDGE PCI           -                   1/0   0.0   -
3  1106 VIA        0586 BRIDGE ISA           -                   7/0   4.1   -
4  1106 VIA        0571 STORAGE IDE          -                   7/1   0.6   -
5  1106 VIA        3040 BRIDGE PCI           -                   7/3   1.0   -
6  110A SIEMENS    2102 NETWORK OTHER        ESB2-DSCC4          8/0   2.1  10
7  1011 DEC        0019 NETWORK ETHERNET     TE100-PCIA          9/0   4.1   7
8  110A SIEMENS    2102 NETWORK OTHER        ESB-DSCC4          10/0   2.1  12
9  10DE UNKNOWN    002C DISPLAY VGA          -                  32/0   1.5 255

Information displayed can be easily compared to the one obtained by executing the command D ACT.

The following table offers a brief explanation of the parameter displayed by the command:

Type | Meaning
ID | PCI device identifier
Vendor | Vendor identification code and name
Device | Device identification code and name
CardName | PCI card identification name
Slot/F | Identifier of the used slot
Ver | Device version number
Irq | Used IRQ

Status commands and port statistics top

C S | Clear Statistics (Administrator)
 | C S IPP C S PO:A C S PO:type C S PO:xxx[,yyy,...] C S PO:yyy HD:yy <ARC port only>

This command clears the statistics of all IP ports or it clears the statistics of the specified port(s), if they are currently running.
The following table summarizes the allowed command syntaxes:

C S IPP | Clear the statistics of all currently running IP ports.
C S PO:A | Clear the statistics of all currently running ports.
C S PO:type | Clear the statistics of all ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
C S PO:xxx[,yyy,...] | Clear the statistics of all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.
C S PO:yyy HD:yy | Clear the statistics of the selected hard disk or of any hard disk. The value "yyy" is assumed to be the ARC port identifier. The HD: value must be a disk drive letter in the range [C..Z] or "ALL".

If the command is successful the message "COMMAND EXECUTED" is generated.

If the specified port is not currently configured or active or running the following message will be shown: "PO:xxx PORT NOT PRESENT OR NOT RUNNING".

The following example shows which is the answer in the case that the system is requested to clear the statistic's counters for three ports, but one of them is not currently running:

[15:18:12] ABILIS_CPX: C S PO:301,302,308

PO:308 PORT NOT PRESENT OR NOT RUNNING

COMMAND EXECUTED

The message "COMMAND EXECUTED" advises that the command was successful on 301 and 302 ports, while it fail on the port 308 because it is not currently running.

warning! Statistics clearing generates events neither into the System Log and Events Log, so it is up to user refer statistics values to the correct time interval. Statistics are always cleared when the Abilis CPX starts.

D S | Display Status and compact Statistics (User)
 | D S IPP D S IPP:xx D S PO:A D S PO:type D S PO:xxx[,yyy,...] D S PO:xxx [.] D S PO:yyy IPP:A <IPRTR port only> D S PO:yyy IPP:xx <IPRTR port only>

This command shows status information of one or more running IP port or CPX port. The command also shows, beside the status, useful statistics and information for Abilis technicians to solve eventual problems.

The following table summarizes the allowed command syntaxes:

D S IPP | Display status and statistics information of all IP ports currently configured and active.
D S IPP:xx | Display status and statistics information of the specified IP port, if configured and active. The IP port value must be in the range [0 - 63].
D S PO:A | Display status information of all the active ports currently configured.
D S PO:type | Display status information of all the active ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
D S PO:xxx[,yyy,...] | Display status information of all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.
D S PO:xxx [.] | Display status information of the specified port [0 - 999]. If there is a lower active port that is linked to the requested one, then the command will also display its status information and so on recursively. The recursive visualization is not executed if the '.' (dot) character is added at the end of the command row.
D S PO:yyy IPP:A | Display status information of the IP ports that are currently running. The value "yyy" is assumed to be the IPRTR port identifier.
D S PO:yyy IPP:xx | Display status information of the requested IP port only. The value "yyy" is assumed to be the IPRTR port identifier. The IP port value must be in the range [0 - 63].

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR INACTIVE", where "xxx" is the identifier of the requested port.

Here there are some examples of the command output:

EXAMPLE 1: recursive visualization:

[10:38:10] ABILIS_CPX: D S PO:301

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------
PO:201 ------------------------------------------------------------------------
LAPB   STATE:CONNECTING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      25599|
       REJ        |          0|          0|FRMR       |          0|          0|
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       INFO       |          0|          0|BADF       |          0|           |
       UNK-ADD    |          0|           |
       ------------------------------------------------------------------------
PO:1   ------------------------------------------------------------------------
SYNC   STATE:UP          CARD:ESB2         SP:19200          XTAL:X1-1,8MHz
       DTR:UP            DCD:DOWN          RTS:UP            CTS:DOWN
       LOOP:OFF
       ------------------------------------------------------------------------
       FIFO:USED    RxFrames:165    RxBytes:21120       RxMinFrameOcc:128
                    TxFrames:2      TxBytes:4208        TxMinFrameOcc:2104
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      51200|FRM        |          0|      25600|
       CHR-D      |          0|      51200|FRM-D      |          0|      25600|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

EXAMPLE 2: recursive visualization avoided by the addition of the '.' (dot) character the end of the command line:

[10:38:12] ABILIS_CPX: D S PO:301 .

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

EXAMPLE 3: visualization of a set of ports of the same type:

[10:39:21] ABILIS_CPX: D S PO:X25

PO:301 ------------------------------------------------------------------------
X25    STATE:READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

PO:302 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

EXAMPLE 4: visualization of a set of ports, by specifing the list:

[10:39:44] ABILIS_CPX: D S PO:301,201,1

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

PO:201 ------------------------------------------------------------------------
LAPB   STATE:CONNECTING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      25618|
       REJ        |          0|          0|FRMR       |          0|          0|
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       INFO       |          0|          0|BADF       |          0|           |
       UNK-ADD    |          0|           |
       ------------------------------------------------------------------------

PO:1   ------------------------------------------------------------------------
SYNC   STATE:UP          CARD:ESB2         SP:19200          XTAL:X1-1,8MHz
       DTR:UP            DCD:DOWN          RTS:UP            CTS:DOWN
       LOOP:OFF
       ------------------------------------------------------------------------
       FIFO:USED    RxFrames:165    RxBytes:21120       RxMinFrameOcc:128
                    TxFrames:2      TxBytes:4208        TxMinFrameOcc:2104
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      51238|FRM        |          0|      25619|
       CHR-D      |          0|      51238|FRM-D      |          0|      25619|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

warning! It is important to remark that statistics are cleared every time the Abilis CPX starts.

D SE | Display Statistics Extended (User)
 | D SE IPP D SE IPP:xx D SE PO:A D SE PO:type D SE PO:xxx[,yyy,...] D SE PO:xxx [.] D SE PO:yyy BCHAN:val <EPISDN port only> D SE PO:yyy CH:val <SSL port only> D SE PO:yyy DLCI:val <FR port only> D SE PO:yyy IPP:val <IPRTR port only> D SE PO:yyy PATH:val <PLINKE port only> D SE PO:yyy PU:val <SDLC port only> D SE PO:yyy SES:val <FTP port only> D SE PO:yyy TEI:val <LAPD/EBLAPD/EPLABD port only> D SE PO:yyy VSP-ID:val <EIM port only>

It shows information about status and statistics of one or more running IP port or CPX port, in an extended format.

The following table summarizes the allowed command syntaxes:

D SE IPP | Display statistics information of all the IP ports currently configured and active.
D SE IPP: | Display statistics information of the specified IP port, if currently configured and active. The IP port value must be in the range [0 - 63].
D SE PO:A | Display statistics information of all the active ports currently configured.
D SE PO:type | Display statistics information of all the active ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
D SE PO:xxx[,yyy,...] | Display statistics information of all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.
D SE PO:xxx [.] | Display statistics information of the specified port [0 - 999]. If there is a lower active port that is linked to the requested one, then the command will also display its statistics information and so on recursively. The recursive visualization is not executed if the '.' (dot) character is added at the end of the command row.
D SE PO:yyy BCHAN:A | Display statistics information of all B channels of an EPISDN port. The value "yyy" is assumed to be an EPISDN port identifier.
D SE PO:yyy BCHAN:xx | Display statistics information of the requested B channel only. The value "yyy" is assumed to be an EPISDN port identifier. The B channel identifier must be in the range [1 - 15, 17 - 31].
D SE PO:yyy CH:xxx | Display statistics information of the requested SSL channel only. The value "yyy" is assumed to be the SSL port identifier. The channel identifier must be in the range [1..100].
D SE PO:yyy DLCI:xx | Display statistics information of the requested DLCI only. The value "yyy" is assumed to be a FR port identifier. The DLCI identifier must be in the range [16 - 991, 1024 - 63487, 131072 - 8126463].
D SE PO:yyy IPP:A | Display statistics information of all the IP ports that are currently running. The value "yyy" is assumed to be the IPRTR port identifier.
D SE PO:yyy IPP:xx | Display statistics information of the requested IP port only. The value "yyy" is assumed to be the IPRTR port identifier. The IP port value must be in the range [0 - 63].
D SE PO:yyy PATH:x | Display statistics information of the requested PLINKE path only. The value "yyy" is assumed to be the PLINKE port identifier. The path value must be in the range [1, 2].
D SE PO:yyy PU:A | Display statistics information of all the Physical Units that are currently in use on a SDLC port. The value "yyy" is assumed to be a SDLC port identifier.
D SE PO:yyy PU:xx | Display statistics information of the requested Physical Unit only. The value "yyy" is assumed to be a SDLC port identifier. The Physical Unit identifier must be in the range [0 - 15].
D SE PO:yyy SES:xxx | Display statistics information of the requested FTP session only. The value "yyy" is assumed to be a FTP port identifier. The session identifier must be in the range [0 - 255].
D SE PO:yyy TEI:A | Display statistics information of all the TEIs that are currently in use on a LAPD or EBLAPD or EPLAPD port. The value "yyy" is assumed to be a LAPD or EBLAPD or EPLAD port identifier.
D SE PO:yyy TEI:xx | Display statistics information of the requested TEI only. The value "yyy" is assumed to be a LAPD or EBLAPD or EPLAD port identifier. The TEI identifier must be in the range [0 - 126].
D SE PO:yyy VSP-ID:A | Display statistics information of all the VSPs that are currently present on the EIM port. The value "yyy" is assumed to be the EIM port identifier.
D SE PO:yyy VSP-ID:xx | Display statistics information of the requested VSP service only. The value "yyy" is assumed to be the EIM port identifier. The VSP identifier must be in the range [1 - 31].

Not all the ports support extended statistics. If the extended statistics are not available for the port, requested in the command, the following message will be shown: "EXTENDED STATISTICS NOT AVAILABLE".

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "xxx" is the identifier of the requested port.

warning! It is important to remark that statistics are cleared every time the Abilis CPX starts.

S S | Set Status of DTR signal (Administrator)
 | S S PO:xxx DTR:yyy

It sets the DTR signal status of the specified SYNC port. The specified port value must be in the range [0 - 999] and must correspond to currently active and running port.

Allowed values for DTR signal status are: UP, DOWN, PULSE.

This command works on SYNC port type only; otherwise the message "COMMAND NOT ALLOWED FOR THAT PORT" will be shown.

In the case that the specified port is not currently running, the following error message is generated: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "xxx" is the identifier of the requested port.

warning! It is important to remark that in correspondence of this command execution a set of messages are registered in the System Log, they are shown in the following examples:

EXAMPLE 1: setting DTR signal to "UP":

16/04/2002 16:38:10 I:CP DTR UP p1
16/04/2002 16:38:10 I:p1   DTR UP

EXAMPLE 2: setting DTR signal to "DOWN":

16/04/2002 16:38:13 I:CP DTR DN p1
16/04/2002 16:38:13 I:p1   DTR DN

EXAMPLE 3: setting DTR signal to "PULSE":

16/04/2002 16:38:17 I:CP DTR PL p1
16/04/2002 16:38:17 I:p1   DTR PL

C SC | Clear Statistics Compressor (Administrator)
 | C SC PO:A C SC PO:xxx

It clears the compression statistics of the specified running port. The specified value must be in the interval [0 - 999].

By specifying "PO:A", the command will clear the statistics of all the running ports managed by the Connection Oriented Router.

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "xxx" is the identifier of the requested port.

If the Connection Oriented Router does not manage the specified port, the command will show the following error message: "COMMAND NOT ALLOWED FOR THAT PORT".

warning! This command generates events neither into the System Log and Events Log, so it is up to user refer statistics values to the correct time interval. Compression statistics are always cleared when the Abilis CPX starts.

D SC | Display Statistics Compressor (User)
 | D SC PO:A D SC PO:xxx

It displays the compression statistics of the specified running port. The specified value must be in the interval [0 - 999].

By specifying "PO:A", the command will display the statistics of all the running ports managed by the Connection Oriented Router.

If the requested port is inactive or not present, the command generates the error message: "PO:xxx PORT NOT PRESENT OR NOT RUNNING", where "xxx" is the identifier of the requested port.

If the Connection Oriented Router does not manage the specified port, the command will show the following error message: "COMMAND NOT ALLOWED FOR THAT PORT".

Initialization/activation/deactivation commands top

INIT PO: | Init Port (User)
 | INIT PO:type INIT PO:xxx[,yyy,...]

It initializes the specified port(s), if it is currently active and running. At the same time the command updates configuration parameters that have been modified, activating them.

The following table summarizes the allowed command syntaxes:

INIT PO:type | The initialization is executed for all the ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
INIT PO:xxx[,yyy,...] | The initilization is executed for all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

If the command is successful the message "COMMAND EXECUTED" will be displayed, otherwise the message "COMMAND FAILED ON PO:xxx" will be shown, where "xxx" is the identifier of the port.

The command will work on present, active and running ports only; otherwise the error message "PO:xxx NOT PRESENT OR INACTIVE" will be displayed, where "xxx" is the identifier of the port.

The following example shows which is the answer in the case that the system is requested to initialize three ports, but one of them is not currently running:

[16:52:44] ABILIS_CPX: INIT PO:301,302,308

PO:308 PORT NOT PRESENT OR NOT RUNNING

COMMAND EXECUTED

The message "COMMAND EXECUTED" advises that the command was successful on 301 and 302 ports, while it fail on the port 308 because it is not currently running.

warning! This command generates events neither into the System Log and Events Log.

R PO: | Restart Port (User)
 | R PO:type R PO:xxx[,yyy,...]

It re-initializes the specified port(s), if it is currently active and running.

The following table summarizes the allowed command syntaxes:

R PO:type | The re-initialization is executed for all the ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
R PO:xxx[,yyy,...] | The re-initialization is executed for all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

If the command is successful the message "COMMAND EXECUTED" will be displayed, otherwise the message "COMMAND FAILED ON PO:xxx" will be shown, where "xxx" is the identifier of the port.

The command will work on present, active and running ports only; otherwise the error message "PO:xxx NOT PRESENT OR INACTIVE" will be displayed, where "xxx" is the identifier of the port.

warning! This command generates events neither into the System Log and Events Log.

As it will be shown in the next example, the command cannot be executed in the case that the internal events trace is started for the selected port:

[12:19:25] ABILIS_CPX: TRACE ACT PO:1

COMMAND EXECUTED

[12:19:26] ABILIS_CPX: TRACE START

COMMAND EXECUTED

[12:19:28] ABILIS_CPX: R PO:1

COMMAND NOT ALLOWED FOR PO:1, TRACE IS RUNNING ON THAT PORT

D ACT | Display Active cards and ports
 | D ACT

It displays all the boards and ports currently configured and active.

Boards and ports are active, if they are configured (present), but not necessarily running. Setting changes and visualization are allowed only for active ports and boars.

Boards and ports are running only if they are configured (present) and active when the system starts.

If there are no active boards the message "NO ACTIVE CARDS PRESENT" will be shown. If there are no active ports the message "NO ACTIVE PORTS PRESENT" will be shown.

Here is an example of command execution:
[14:28:49] ABILIS_CPX: D ACT

-------------------------------- Active Cards: --------------------------------
Card-Numb      Port(s)                                       SlotId  Addr  Irq
-------------------------------------------------------------------------------
ESB-1            1,  2,  3,  4  . . . . . . . . . . . . . . .     8   PCI   10
ESB-2            5,  6,  7,  8  . . . . . . . . . . . . . . .    10   PCI   12
ASY-1           21  . . . . . . . . . . . . . . . . . . . . .     -   3F8    4
ETH100-1        58  . . . . . . . . . . . . . . . . . . . . .     9   PCI    7
EBIB-1         100,  80..95   . . . . . . . . . . . . . . . .     -  CE00   11

-------------------------------- Active Ports: --------------------------------
Type    Port(s)
-------------------------------------------------------------------------------
CP        0
SYNC      1   2   3   4   5   6   7   8
ISDN     17
PAD      21
ETH100   58
EBISDN   80  81  82  83
EIM     100
LAPD    117
IPLAN   158
EBLAPD  180 181 182 183
EIR     200
LAPB    201 202 203 204 205 206 207 998
Q931    217
EBQ931  280 281 282 283
X25     301 302 303 304 305 306 307 308 999
SDLC    328
IPRTR   900
TCP     901
UDP     902
RIP     903
SNMP    904
TELNET  905
SSH     906
SNTP    909
DNS     910
MfIde   990
MLM     997

S ACT | Active cards and ports (Administrator)
 | S ACT CARD:xxx[,yyy,...] S ACT PO:xxx[,yyy,...]

It sets active the specified board(s) or port(s).

The following table summarizes the allowed command syntaxes:

S ACT CARD:xxx[,yyy,...] | Activation is executed on all the cards that are specified in the list. The list can specify from 1 up to 50 cards values, separated by ',' (comma) character without spaces, in the form "type-nnn", where: "type" has to be one of the card's mnemonics that are allowed by the system (e.g. ETH100, ESB and so on); "nnn" must be a digit in the interval [1 - 255].
S ACT PO:xxx[,yyy,...] | Activation is executed on all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

warning! Activating a board or a port does not mean to make it run. Activation makes possible to show board's/port's parameters and to modify them. To have a running board/port or activate the changes made on the board/ports, it is needed to save the configuration and restart the system.

If the specified board is not present, the message "CARD:type-nnn NOT PRESENT" will be displayed; if it is already active then "CARD:type-nnn ALREADY ACTIVE" advise will appears. In both cases "type-nnn" is the identifier of the card.

If the specified port is not present, the message "PO:xxx NOT PRESENT" will be displayed; if it is already active then "PO:xxx ALREADY ACTIVE" advise will appears. In both cases "xxx" is the identifier of the port.

D INACT | Display Inactive cards and ports (User)
 | D INACT

It shows all the boards and ports currently configured but inactive.

A board (port) is inactive (or not active) when it is present but it is not running. Setting changes and visualization are not allowed for inactive boards/ports. Moreover configured but inactive boards/ports are ignored when the system starts.

If there are no inactive boards, the following message is generated "NO INACTIVE BOARDS PRESENT". If there are no inactive ports, the following message is generated "NO INACTIVE PORTS PRESENT".

Here is an example of the command execution:

[14:35:50] ABILIS_CPX: D INACT

------------------------------- Inactive Cards: -------------------------------
Card-Numb      Port(s)                                       SlotId  Addr  Irq
-------------------------------------------------------------------------------
HSCB-1           1,  2  . . . . . . . . . . . . . . . . . . .     -  D000    7
HSCB-2           3,  4  . . . . . . . . . . . . . . . . . . .     -  D000    5
HSCB-3           5,  6  . . . . . . . . . . . . . . . . . . .     -  D000   10
HSCB-4           7,  8  . . . . . . . . . . . . . . . . . . .     -  D000   11
ESB-3            9, 10, 11, 12  . . . . . . . . . . . . . . .  NONE   PCI    ?
ESB-4           13, 14, 15, 16  . . . . . . . . . . . . . . .  NONE   PCI    ?
ISDN-1          17  . . . . . . . . . . . . . . . . . . . . .     -   390   11
ISDN-2          18  . . . . . . . . . . . . . . . . . . . . .     -   398   10
ISDN-3          19  . . . . . . . . . . . . . . . . . . . . .     -   3A0    5
ASY-2           22  . . . . . . . . . . . . . . . . . . . . .     -   2F8    3
ASYMS-1         23..30  . . . . . . . . . . . . . . . . . . .     -   280    3
ASYMS-2         31..38  . . . . . . . . . . . . . . . . . . .     -   190    5
ETH-1           55  . . . . . . . . . . . . . . . . . . . . .     -   300   12
ETH-2           56  . . . . . . . . . . . . . . . . . . . . .     -   360   10
TRH-1           57  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
ETH100-2        59  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
ACB-1           60, 61, 62, 63, 64, 65, 66, 67  . . . . . . .     -   320   15
ACB-2           68, 69, 70, 71, 72, 73, 74, 75  . . . . . . .     -   340   14
EPIB-1         100,  96..99   . . . . . . . . . . . . . . . .     -  CC00   11
BEP-1           80..95  . . . . . . . . . . . . . . . . . . .     -  CE00   10
BRIO-1          17  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?
BRIO-2          18  . . . . . . . . . . . . . . . . . . . . .  NONE   PCI    ?

------------------------------- Inactive Ports: -------------------------------
Type    Port(s)
-------------------------------------------------------------------------------
SYNC      9  10  11  12  13  14  15  16
ISDN     18  19
PAD      22  23  24  25  26  27  28  29  30  31  32  33  34  35  36  37  38  39
         40  41  42  43  44  45  46  47  48  49  50  51  52  53  54
ETH      55  56
TR       57
ETH100   59
EBISDN   84  85  86  87  88  89  90  91  92  93  94  95
EPISDN   96  97  98  99
FR      101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116
LAPD    118 119
IPLAN   155 156 157 159
EBLAPD  184 185 186 187 188 189 190 191 192 193 194 195
EPLAPD  196 197 198 199
LAPB    208 209 210 211 212 213 214 215 216 801 802 803 804 805 806 807 808 809
        810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827
        828 829 830 831 832
Q931    218 219
EBQ931  284 285 286 287 288 289 290 291 292 293 294 295
EPQ931  296 297 298 299
X25     309 310 311 312 313 314 315 316 851 852 853 854 855 856 857 858 859 860
        861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878
        879 880 881 882
SDLC    321 322 323 324 325 326 327 329 330 331 332 333 334 335 336
HDLCT   341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356
sQ931   380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397
        398 399
PLINKE  401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418
        419 420 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716
        717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734
        735 736 737 738 739 740 741 742 743 744 745 746 747 748 749
MLM     501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518
        519 520 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766
        767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784
        785 786 787 788 789 790 791 792 793 794 795 796 797 798 799
ML      521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538
        539 540
PPP     541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558
        559 560
XTP     907
ACNT    908
NAT     911

S INACT | Set Inactive cards and ports (Administrator)
 | S INACT CARD:xxx[,yyy,...] S INACT PO:xxx[,yyy,...]

It sets inactive the specified board(s) or port(s).

The following table summarizes the allowed command syntaxes:

S INACT CARD:xxx[,yyy,...] | Deactivation is executed on all the cards that are specified in the list. The list can specify from 1 up to 50 cards values, separated by ',' (comma) character without spaces, in the form "type-nnn", where: "type" has to be one of the card's mnemonics that are allowed by the system (e.g. ETH100, ESB and so on); "nnn" must be a digit in the interval [1 - 255].
S INACT PO:xxx[,yyy,...] | Dectivation is executed on all the ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

warning! Deactivating a board or a port does not mean to make it not run, if it was running after the system start. Deactivation makes not possible to show board's/port's parameters and to modify them. To make a board/port not running, it is needed to save the configuration and restart the system.

If the specified board is not present, the message "CARD:type-nnn NOT PRESENT" will be displayed; if it is already inactive then "CARD:type-nnn ALREADY INACTIVE" advise will appears. In both cases "type-nnn" is the identifier of the card.

If the specified port is not present, the message "PO:xxx NOT PRESENT" will be displayed; if it is already inactive then "PO:xxx ALREADY INACTIVE" advise will appears. In both cases "xxx" is the identifier of the port.

D RUN | Display Running Ports (User)

It shows all the currently running ports.

The running ports are the ones that are configured and active
when at the system start.

A port is still running even if it has been deactivated through the command S INACT.

If there are no running ports the message "NO RUNNING PORTS PRESENT" will be shown. This eventuality cannot happen.

Here is an example of the command execution:

[14:45:59] ABILIS_CPX: D RUN

------------------------------- Running Ports: --------------------------------
Type    Port(s)
-------------------------------------------------------------------------------
CP        0
SYNC      1   2   3   4   5   6   7   8
ISDN     17
PAD      21
ETH100   58
LAPD    117
IPLAN   158
EBLAPD  180 181 182 183
EIR     200
LAPB    201 202 203 204 205 206 207 998
Q931    217
EBQ931  280 281 282 283
X25     301 302 303 304 305 306 307 308 999
SDLC    328
IPRTR   900
TCP     901
UDP     902
RIP     903
SNMP    904
TELNET  905
SSH     906
SNTP    909
DNS     910
MfIde   990
MLM     997

D TREE | Display Ports Tree
 | D TREE

It shows the real status of the connections among protocol ports and link ports.

Resources can be split into 5 groups:

  • Connection Oriented Router: in this section there are all the protocol ports currently set and the link ports connected to them.

  • IP Router and IP Services: this section is dedicated to the IP Router and IP Services currently set. Therefore is shown the IPRTR and IP ports. All the other ports that offer IP Services are shown.

  • Enhanced Isdn Router: this section is dedicated to the ISDN services; EIR port is shown and the P-Link, S-Link connected to it.

  • ACB Voice Router: this section is dedicated to Fxs/Fxo Voice service; therefore the list of all the Fxs/Fxo Voice ports currently set is shown.

  • Unconnected ports: this section is dedicated to all the link ports currently set, but not connected to any protocol port.

Before showing the ports connections, the command automatically executes a validation of the current configuration. If the validation is successful, the command will be executed, otherwise it won't.

It is important to note that "successful validation" means that during the validation process no errors were found in the current configuration and no changes were done on it. For more details on the configuration validation procedure see the Configuration validating section.

Here is an example of successful command execution:

[14:45:59] ABILIS_CPX: D TREE

VALIDATION IN PROGRESS ..
VALIDATION SUCCESSFULLY EXECUTED

------------------------- Connection Oriented Router: -------------------------

CP     PO:0
PAD    PO:21
X25    PO:301--201--001
X25    PO:302--202--002
X25    PO:303--203--003
X25    PO:304--204--004
X25    PO:305--205--005
X25    PO:306--206--006
X25    PO:307--207--007
X25    PO:308
SDLC   PO:328--008
IPRTR  PO:900--...
TELNET PO:905--...
SSH    PO:906--...
X25    PO:999--998--997--217--117--017

------------------------- IP Router and IP Services: --------------------------

IPRTR  PO:900
            |-(Ipp:00)--158--058
TCP    PO:901
UDP    PO:902
RIP    PO:903--902
SNMP   PO:904--902
TELNET PO:905--901
SSH    PO:906--901
SNTP   PO:909--902
DNS    PO:910--902

---------------------------- Enhanced Isdn Router: ----------------------------

EIR    PO:200--100
            |--280--180--080
            |--281--181--081
            |--282--182--082
            |--283--183--083

------------------------------ ACB Voice Router: ------------------------------

NO ACB VOICE ROUTER PORTS
------------------------- PPPoE Access Concentrators: -------------------------

POEAC  PO:163--058
            |-(Lnk:01)--200--...

---------------------------------- Bridges: -----------------------------------

BRIDGE PO:170

-------------------------- Wireless to G.703 bridge: --------------------------

NO GCP or WLP PORTS
----------------------------- Unconnected ports: ------------------------------

Here is an example of unsuccessful command execution:

[14:45:59] ABILIS_CPX: D TREE

VALIDATION IN PROGRESS ...
ERROR: PO:302 >LOWPO> = 201 crossed setting
VALIDATION FAILED

PORT TREE NOT EXECUTED

ALARM RESET | Reset alarm conditions (User)
 | ALARM RESET

It activates a reset procedure of error conditions that generated the alarm.

Ports alarms are detected by a proper procedure, which is executed every 30 seconds and is activated setting the "A" option in the "LOG:" parameter. If the "L" option is also set in the "LOG:" parameter, on alarm detection, acoustic signal and message on the LCD display are generated.

Alarm conditions reset is also possible with an equivalent command that is available in the Utility of the LCD display on the front panel.

ALARM VIEW | View alarm conditions (User)
 | ALARM VIEW

It shows a list of the ports in error conditions that have generated the alarm.

Here is an example of the command execution:

[14:45:59] ABILIS_CPX: ALARM VIEW

PO:501 ------------------------------------------------------------------------
MLM    P-LINK:DOWN2            S-LINK:STOPPED1         ATN:

PO:502 ------------------------------------------------------------------------
MLM    P-LINK:DOWN2            S-LINK:STOPPED1         ATN:

If there are no alarmed ports when the command is executed, the message "NO ALARMED PORTS" will be shown.

Ports alarms are detected by a proper procedure, which is executed every 30 seconds and is activated setting the "A" option in the "LOG:" parameter. If the "L" option is also set in the "LOG:" parameter, on alarm detection, acoustic signal and message on the LCD display are generated.

The list of ports that are in error conditions is also displayed by an equivalent command that is available in the Utility of the LCD display on the front panel.

CALL PO: | Open a connection (User)
 | CALL PO:xxx

It opens a connection on the specified port. The port value must be in the interval [0 - 999] and has to correspond to a port that is active and running.

The command can work only on MLM and PPP port types, otherwise the message "COMMAND NOT ALLOWED FOR THAT PORT" is generated.

If the command is successful the following message will be displayed: "COMMAND EXECUTED", otherwise "COMMAND FAILED".

Open connection must be closed using the DISC PO: command. If the command has been already executed on the specified port, while the DISC PO: one was not, then the message "CONNECTION ALREADY OPENED" will be displayed.

The command will work only on present, active and running ports; otherwise the error message "PORT NOT PRESENT OR NOT RUNNING" will be displayed.

DISC PO: | Close a connection (User)
 | DISC PO:xxx

It closes the connection, previously activated by the CALL PO: command, on the specified port. The port value must be in the interval [0 - 999] and has to correspond to a port that is active and running.

The command can work only on MLM and PPP port types, otherwise the message "COMMAND NOT ALLOWED FOR THAT PORT" is generated.

If the command is successful the following message will be displayed: "COMMAND EXECUTED", otherwise "COMMAND FAILED".

If the command is executed when the channel is already closed the message "CONNECTION ALREADY CLOSED" will be displayed.

The command will work only on present, active and running ports; otherwise the error message "PORT NOT PRESENT OR NOT RUNNING" will be displayed.

Information notes about ports top

A D | Add IP port and CPX port description (Administrator)
 | A D IPP:xx Description A D PO:xxx Description

It allows the user to adds the desired description to be assigned to an IP port and/or to a CPX port.

IP port value must be in the interval [0 - 63], while CPX port value must be in the interval [0 - 999].

The parameter "Description" is a generic ASCII printable string, whose maximum length is 68 characters and that cannot contain spaces.

Here is an example on how to assign a description to an IP or CPX port:

[12:26:01] ABILIS_CPX: A D IPP:0 Internal_Lan

COMMAND EXECUTED

[12:26:01] ABILIS_CPX: A D PO:0 Control_port_for_remote_CPX_management

COMMAND EXECUTED

The modification of the defined descriptions is allowed by the S D command.

Displaying the defined descriptions is allowed by the D D and D DE commands.

[15:09:48] ABILIS_CPX: D D

- Not Saved (SAVE CONF) -------------------------------------------------------

IPP Type             Description
-------------------------------------------------------------------------------
0   LAN              Internal_Lan

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management

The "Not Saved (SAVE CONF)" message is displayed every time informative descriptions are added/cleared/modified but not saved with the SAVE CONF command.

Informative notes that are assigned to IP ports and/or to CPX ports are also displayed in several commands: D IPP, D P, D S, D SE, ALARM VIEW and so on.

For example:

[18:45:45] ABILIS_CPX: D IPP:0

IPP:0  - Internal_Lan ---------------------------------------------------------
ACT    IPADD:192.168.000.213                       MTU:1500
       MASK :255.255.255.000 NAT:NO      SRCV:NO   outbuf:50
       IFTYPE:LAN            REDIS:YES             RP:RIP
       BRD:NET               LOWPO:158   HIDE:NO   FAIRQUEUE:YES
       SPEEDLIMIT:NO
       - RIP section ----------------------------------------------------------
       RIPSEND:RIP2B    RIPRECV:BOTH     RIPNU:YES    RIPMETRIC:1
       - TRFA section ---------------------------------------------------------
       TRFA:YES  TRFA-MODE:IP-PROT   IP-RESERVE:AUTO  TRFA-SIDE:LOCAL
       TRFA-IPADD:001.001.010.255

[12:26:01] ABILIS_CPX: D P PO:0

PO:0   - Control_port_for_remote_CPX_management -------------------------------
CP     PI:ABILIS_CPX:          bsvc:8                  ps:128
       PWD-U:                  PWD-A:                  PWD-S:
       X29A:02010102010302040006050C010D000E000F011008111812121302
       X29B:020100020003000402050006000700080009000A000C000D000E000F001500

The message "IP PORT DESCRIPTION ALREADY EXIST" is displayed, if the IP ports already have a description. While, if the specified IP port is not currently configured, the error message "IP PORT NOT PRESENT" is generated.

The message "PORT PORT DESCRIPTION ALREADY EXIST" is displayed, if the CPX ports already have a description. While, if the specified CPX port is not currently configured, the error message "PORT NOT PRESENT" is generated.

info It is important to remark that ports informative notes, that are added with the present command, are automatically associated by the system to the higher CPX ports that are connected to them, in the eventuality that they don't have their own description.

Through the D D command execution, only directly assigned descriptions will be shown; while, by using the D DE command, it is possible to recognize the ports to which a description has been automatically assigned by the system, because they are marked by the '*' character.

C D | Clear IP port and CPX port description (Administrator)
 | C D IPP:A C D IPP:xx C D PO:A C D PO:xxx

It clears th description previously set for an IP port or a CPX port.

IP port value must be in the interval [0 - 63], while CPX port value must be in the interval [0 - 999].

In both cases, the value "A" can be used to clear descriptions of all IP and CPX ports. The command doesn't ask a confirmation before executing the required operation, then the "A" value must be used very carefully.

If the command is successful the message "COMMAND EXECUTED" is displayed.

The message "IP PORT DESCRIPTION DOESN'T EXIST" is displayed, if the IP ports don't have any description.

The message "PORT DESCRIPTION DOESN'T EXIST" is displayed, if the CPX ports don't have any description.

The "Not Saved (SAVE CONF)" message is displayed every time informative descriptions are added/cleared/modified but not saved with the SAVE CONF command.

D D | Display IP port and CPX port description (User)
 | D D D D IPP:A D D IPP:xx D D PO:A D D PO:type D D PO:xxx[,yyy,zzz,...]

It displays currently configured informative description(s) of IP and CPX ports. The following table summarizes the allowed command syntaxes:

D D | Display all informative description(s) that are currently configured for both IP ports and CPX ports.
D D IPP:A | Display all informative description(s) that are currently configured for IP ports.
D D IPP:xx | Display the informative description that is currently defined for the specified IP port. The IP port value must be in the interval [0 - 63].
D D PO:A | Display all informative description(s) that are currently configured for CPX ports.
D D PO:type | Display informative descriptions(s) of all the CPX ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
D D PO:xxx[,yyy,...] | Display informative descriptions(s) of all the CPX ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

The following example shows the command result in the case that nether IP ports nor CPX ports have a description.

[10:57:42] ABILIS_CPX: D D

IPP Type             Description
-------------------------------------------------------------------------------
                        *** NO IP PORTS INFORMATION ***

PO  Type     Description
-------------------------------------------------------------------------------
                         *** NO PORTS INFORMATION ***
Here there are some additional examples:
[12:25:58] ABILIS_CPX: D D

IPP Type             Description
-------------------------------------------------------------------------------
0   LAN              Internal_Lan
10  PPP              Point_to_Point_Protocol_interface

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
1   SYNC     sync_port_special
904 SNMP     SNMP_Agent_of_version_1

[11:05:11] ABILIS_CPX: D D IPP:A

IPP Type             Description
-------------------------------------------------------------------------------
0   LAN              Internal_Lan
10  PPP              Point_to_Point_Protocol_interface

[11:05:17] ABILIS_CPX: D D IPP:10

IPP Type             Description
-------------------------------------------------------------------------------
10  PPP              Point_to_Point_Protocol_interface

[11:05:27] ABILIS_CPX: D D IPP:1

PORT DESCRIPTION DOESN'T EXIST

[11:02:26] ABILIS_CPX: D D PO:A

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
1   SYNC     sync_port_special
904 SNMP     SNMP_Agent_of_version_1

[11:02:29] ABILIS_CPX: D D PO:SNMP

PO  Type     Description
-------------------------------------------------------------------------------
904 SNMP     SNMP_Agent_of_version_1

[11:02:54] ABILIS_CPX: D D PO:0,904

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
904 SNMP     SNMP_Agent_of_version_1

The "Not Saved (SAVE CONF)" message is displayed every time informative descriptions are added/cleared/modified but not saved with the SAVE CONF command.

D DE | Display IP port and CPX port description extended (User)
 | D DE D DE IPP:A D DE IPP:xx D DE PO:A D DE PO:type D DE PO:xxx[,yyy,zzz,...]

It displays currently configured informative descriptions of IP and CPX ports. Descriptions that are marked by the '*' character are automatically assigned by the system and not manually added by the user.

In fact IP and CPX ports informative notes, that are added with the A D command, are automatically associated by the system to the higher CPX ports that are connected to them, in the eventuality that they don't have their own description.

The following table summarizes the allowed command syntaxes:

D DE | Display all informative description(s) that are currently configured for both IP ports and CPX ports.
D DE IPP:A | Display all informative description(s) that are currently configured for IP ports.
D DE IPP:xx | Display the informative description that is currently defined for the specified IP port. The IP port value must be in the interval [0 - 63].
D DE PO:A | Display all informative description(s) that are currently configured for CPX ports.
D DE PO:type | Display informative descriptions(s) of all the CPX ports of the specified "type". The port "type" must be one of the mnemonics that are allowed by the system, e.g.: X25, MLM, LAPD and so on.
D DE PO:xxx[,yyy,...] | Display informative descriptions(s) of all the CPX ports that are specified in the list. The list can specify from 1 up to 50 port values in the range [0 - 999] separated by ',' (comma) character without spaces.

In the following example we can see several entries that are marked by the '*' character: they correspond to description notes that are recursively inherited by the one that is manually defined for their lowest level SYNC port:

[12:25:58] ABILIS_CPX: D DE

IPP Type             Description
-------------------------------------------------------------------------------
0   LAN            * Internal_Lan
4   PPP              Point_to_Point_Protocol_interface

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
1   SYNC     sync_port_special
58  ETH100   Internal_Lan
101 FR     * sync_port_special
158 IPLAN  * Internal_Lan
201 LAPB   * sync_port_special
202 LAPB   * sync_port_special
301 X25    * sync_port_special
302 X25    * sync_port_special
501 MLM    * sync_port_special
502 MLM    * sync_port_special
904 SNMP     SNMP_Agent_of_version_1

The following example shows the command result in the case that nether IP ports nor CPX ports have a description.

[10:57:42] ABILIS_CPX: D DE

IPP Type             Description
-------------------------------------------------------------------------------
                        *** NO IP PORTS INFORMATION ***

PO  Type     Description
-------------------------------------------------------------------------------
                         *** NO PORTS INFORMATION ***
Here there are some additional examples:
[11:50:54] ABILIS_CPX: D DE PO:A

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
1   SYNC     sync_port_special
58  ETH100   Internal_Lan
101 FR     * sync_port_special
158 IPLAN  * Internal_Lan
201 LAPB   * sync_port_special
202 LAPB   * sync_port_special
301 X25    * sync_port_special
302 X25    * sync_port_special
501 MLM    * sync_port_special
502 MLM    * sync_port_special
904 SNMP     SNMP_Agent_of_version_1

[11:51:05] ABILIS_CPX: D DE PO:x25

PO  Type     Description
-------------------------------------------------------------------------------
301 X25    * sync_port_special
302 X25    * sync_port_special

[11:51:15] ABILIS_CPX: D DE PO:0,101,904

PO  Type     Description
-------------------------------------------------------------------------------
0   CP       Control_port_for_remote_CPX_management
101 FR     * sync_port_special
904 SNMP     SNMP_Agent_of_version_1

info It is important to remark that "inherited" descriptions cannot be ether deleted or modified. See for example the case of the FR port here displayed:

[11:51:15] ABILIS_CPX: D DE PO:101

PO  Type     Description
-------------------------------------------------------------------------------
101 FR     * sync_port_special

[11:51:48] ABILIS_CPX: C D PO:101

PORT DESCRIPTION DOESN'T EXIST

[11:54:16] ABILIS_CPX:

The deletion of it description fails because its information note wasn't added manually by the user but was automatically assigned to it by the system.

The "Not Saved (SAVE CONF)" message is displayed every time informative descriptions are added/cleared/modified but not saved with the SAVE CONF command.

S D | Set IP port and CPX port description (Administrator)
 | S D IPP:xx Description S D PO:xxx Description

It allow to modify the informative description that was previously defined by the user for the specified IP or CPX port.

IP port value must be in the interval [0 - 63], while CPX port value must be in the interval [0 - 999].

The parameter "Description" is a generic ASCII printable string, whose maximum length is 68 characters and that cannot contain spaces.

If the command is successful the message "COMMAND EXECUTED" will be shown.

The message "IP PORT DESCRIPTION DOESN'T EXIST" is displayed, if no description is present for the specified IP port.

The message "PORT DESCRIPTION DOESN'T EXIST", if no description is present for the specified CPX port.

The "Not Saved (SAVE CONF)" message is displayed every time informative descriptions are added/cleared/modified but not saved with the SAVE CONF command.


Commands related to RIP External Routes

RIP External Routes

Other commands

RIP External routes top

A RIP EXTERNAL: | Add RIP external route (Administrator)
 | A RIP EXTERNAL:x.x.x.x/yy PROT:val ACTION:val [METRIC:val]

It adds a new entry to the Table of RIP External Routes, identified by the specified mandatory parameters. The command also sets the eventually indicated parameters to the specified values.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The "ACTION:val" parameter represents the action associated to this entry and must correspond to a value in the range [IGNORE, ACCEPT].

The IP external network, the protocol and the action values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated values matches an already existing entry, the following message will be displayed "RIP EXTERNAL ROUTE ALREADY PRESENT".

If the table is full, i.e. no free record is currently available, the message "RIP EXTERNAL ROUTEs TABLE IS FULL, COMMAND NOT EXECUTED" will be shown.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

If the Abilis CPX version, currently in use, does not support RIP services, the following message will be shown "RIP SERVICE NOT PRESENT".

C RIP EXTERNAL: | Clear RIP external route (Administrator)
 | C RIP EXTERNAL:x.x.x.x/yy PROT:val

It deletes the RIP external route entry identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match an already existing entry, the following message will be displayed "RIP EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the following message is generated: "RIP EXTERNAL ROUTEs TABLE IS EMPTY".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

If the Abilis CPX version, currently in use, does not support RIP services, the following message will be shown "RIP SERVICE NOT PRESENT".

D RIP EXTERNAL | Display RIP external routes table (User)
 | D RIP EXTERNAL

This command shows the content of the Table of RIP External Routes.

Here is an example of the information shown by the command:

[16:54:38] ABILIS_CPX: D RIP EXTERNAL

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

----------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:
----------------------------------------------
192.168.006.002/32   OSPF    ACCEPT          5
192.168.006.000/24   LOCAL   IGNORE          1
010.000.000.000/8    ANY     ACCEPT         10
000.000.000.000/0    ANY     ACCEPT          *
----------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

If the table is empty, the message "*** NO RIP EXTERNAL ROUTEs DEFINED ***" will be displayed.

For a detailed description of RIP External Routes table's entry parameters, please refer to the RIP External Routes filter table section.

If the Abilis CPX version, currently in use, does not support RIP services, the following message will be shown "RIP SERVICE NOT PRESENT".

D RIP EXTERNAL: | Display RIP external route (User)
 | D RIP EXTERNAL:x.x.x.x/yy PROT:val

It displays the RIP external route entry identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

[15:22:05] ABILIS_CPX: D RIP EXTERNAL:010.000.000.001/32 PROT:STATIC

----------------------------------------------
EXTERNAL:            PROT:   ACTION:   METRIC:
----------------------------------------------
010.000.000.001/32   STATIC  ACCEPT          4
----------------------------------------------

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match an already existing entry, the following message will be displayed "RIP EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the message "*** NO RIP EXTERNAL ROUTEs DEFINED ***" will be displayed.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

For a detailed description of RIP External Routes table's entry parameters, please refer to the RIP External Routes filter table section.

If the Abilis CPX version, currently in use, does not support RIP services, the following message will be shown "RIP SERVICE NOT PRESENT".

S RIP EXTERNAL: | Set RIP external route (Administrator)
 | S RIP EXTERNAL:x.x.x.x/yy PROT:val par:val [par:val]

It sets to new values the parameters of the RIP external route entry identified by the specified mandatory parameters.

The "EXTERNAL:" parameter corresponds to the external route IP address and mask in Slash Notation (i.e. x.x.x.x/yy).

Valid network IP addresses must always be expressed in Dotted Decimal Notation. The allowed values are shown in the following table:

HEX: | 00000000 | 01000000 - 7EFFFFFF | 80000000 - DFFFFFFF
DDN: | 0.0.0.0 | 1.0.0.0 - 126.255.255.255 | 128.0.0.0 - 223.255.255.255

IP addresses of class D and E are not currently supported.

Valid values for the network mask must contain sequence of bit set to 1, estimated leaving from the most meaningful bit towards the less meaningful one; therefore they must be in the range [0..32].

Doing the "logical AND" between network IP address and the related network mask, the result should be the network itself.

The "PROT:" parameter represents the Routing protocol and must correspond to a value in the range [ANY, LOCAL, STATIC, RIP].

The IP external network and protocol values unambiguously identify an entry in the system. Two or more entries with the same IP external network value and the same protocol value cannot be present in the same time in the table. If the indicated entry does not match an already existing entry, the following message will be displayed "RIP EXTERNAL ROUTE NOT PRESENT".

If the table is empty, the following message is generated: "RIP EXTERNAL ROUTEs TABLE IS EMPTY".

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of RIP External Routes table's entry parameters, please refer to the RIP External Routes filter table section.

Changes made on the table of RIP External Routes are not immediately active, they can be activated by executing the initialization command INIT PO:xxx, where "xxx" is the RIP port number.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed by executing the initialization command.

If the Abilis CPX version, currently in use, does not support RIP services, the following message will be shown "RIP SERVICE NOT PRESENT".


General and system commands

System accessing commands
General configuration of the system
System information
Commands relating to date and time
CPU Load Measurements
Logging functionalities
Configuration validating and saving
System updating and restarting
Test and trace functionalities

Other commands

System accessing commands top

LOGIN | Login (User)
 | LOGIN LOGIN access-level

It shows the current privilege level, through which the User accessed the Control Port.

[11:38:01] ABILIS_CPX: LOGIN

Currently logged as SUPERUSER

On the contrary, if an access level is specified, the command will login the User to the Control Port using the requested privilege.

Login Access Level | Description
ADMINISTRATOR (or ADMIN) | Login as Administrator
SUPERUSER (or SUPER) | Login as Super User
USER | Login as User
LOGOUT | Logout (User)
 | LOGOUT

It closes the current configuration session and prompts the login request.

If in the current configuration session the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the configuration session is not closed and the Control Port prompt is shown.

[11:38:04] ABILIS_CPX: LOGOUT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? Y

VALIDATION IN PROGRESS...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[11:56:43] ABILIS_CPX:

warning! In this case, the command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

In case of negative answer, the configuration session is closed but the configuration is not saved.

[12:00:31] ABILIS_CPX: LOGOUT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)?N
Login:

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

[11:38:04] ABILIS_CPX: LOGOUT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? A

[11:54:02] ABILIS_CPX:

CLOSE | Close the configuration session (User)
 | CLOSE

It closes the current connection to the Control Port.

If the User was connected to the Control Port through a PAD port (TELNET port), then the command interpreter of the PAD port (TELNET port) will be prompted.

If the User was connected to the Control Port through a TELNET port, then the command interpreter of the TELNET port will be prompted.

If the User executed this command through the off-line configurator, it will terminate the configurator and go back to the MS-DOS prompt.

If in the current configuration session the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the connection is not closed and the Control Port prompt is shown.

[11:38:04] ABILIS_CPX: CLOSE

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? Y

VALIDATION IN PROGRESS...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[11:56:43] ABILIS_CPX:

warning! In this case, the command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

In case of negative answer, the connection to the Control Port is closed but the configuration is not saved.

[11:38:04] ABILIS_CPX: CLOSE

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? N

CLR 00 00

[62.110.59.130] TELNETS>

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

EXIT | Exit program (Available only in off-line Configurator)
 | EXIT

It terminates the execution of the off-line configurator program and goes back to the MS-DOS prompt.

If during off-line configurator program execution the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the off-line configurator program is not terminated and the Control Port prompt is shown.

In case of negative answer, the program is terminated but the configuration is not saved.

 - CONFIG - v. 1022    - 12/03/2004 - For CPX release 1513 - build 1513 -
 - (c) 1994/2004 - Abilis -

Logged as SUPERUSER

[12:33:21] ABILIS_CPX: S P PO:0 PS:128

COMMAND EXECUTED

[12:33:32] ABILIS_CPX: EXIT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? N

Program exits.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

QUIT | Quit program (Available only in off-line Configurator)
 | QUIT

It terminates the execution of the off-line configurator program and goes back to the MS-DOS prompt.

If during off-line configurator program execution the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the off-line configurator program is not terminated and the Control Port prompt is shown.

In case of negative answer, the program is terminated but the configuration is not saved.

 - CONFIG - v. 1022    - 12/03/2004 - For CPX release 1513 - build 1513 -
 - (c) 1994/2004 - Abilis -

Logged as SUPERUSER

[12:33:21] ABILIS_CPX: S P PO:0 PS:128

COMMAND EXECUTED

[12:33:32] ABILIS_CPX: QUIT

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? N

Program exits.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

General configuration of the system top

D G | Display General (User)
 | D G

It shows the parameters of the general configuration of the system. Currently used values and the new configuration values are shown.

Not all the shown parameters can be changed. The note "<Read Only>" refers the not modifiable ones.

Here is an example of the command execution:

ABILIS_CPX: D G

- Not Saved (SAVE CONF) -------------------------------------------------------

         Conf.Value Act.Value                Description
------------------------------------------------------------------------------
vconn:        32        32    Max number of VOICE connections [32..255]
VDIGITS:       3         -    Number of digits used to dial a number [1..4]
VTOUT:         3         3    VOICE connections protection timeout [1..5 sec.]
VCALLT:        5         -    VOICE calling timeout [1..60 sec.]
VALTT:        20         -    VOICE alerting timeout [1..60 sec.]
DTMF:    OUTBAND         -    DTMF processing mode [NO, INBAND, OUTBAND]
DTMFHI:        8         -    Change gains for High tone frequency [1..15]
DTMFLO:        8         -    Change gains for Low tone frequency [1..15]
FDRELAY:     YES         -    Fax/Data relay [NO, YES]
FDLEVEL:       9         -    Generated Fax/Data level in 1 dB step [0..15]
tact:         NO        NO    TRACE activation state [NO, YES]
sound:        ON        ON    Alarm sound enable/disable [OFF, ON]
ndict:         -         0    Number of available dictionaries     <Read Only>
lccomp:        -         0    Max number of compressed LC          <Read Only>
fdict:         -         0    Number of free dictionaries          <Read Only>
hwint:         -     MFIDE    Front Panel/WatchDog interface type  <Read Only>
isapnp:      YES       YES    Enable/disable PNP for ISA cards [NO, YES]
------------------------------------------------------------------------------
DBGF:      ALL
CONTACT:
SYSNAME:
LOCATION:
SYSUPTIME: 0 days 01:20:27 (Tuesday 06/04/2004 13:13:59)           <Read Only>
SYSRBTIME: # (System Reboot time not set)
DATE&TIME: Tuesday 06/04/2004 14:34:26 (GMT+2.00)                  <Read Only>
TIMEZONE:  CET - Central Europe (Rome, Paris, Berlin, Prague, Brussels)

The Not Saved (SAVE CONF) message is shown every time some general parameter is changed, but the modification is not saved with the SAVE CONF command.

S G | Set General (Administrator)
 | S G par:val [par:val]

It sets one or more parameter of the general configuration of the system.

The parameter list, defined in the command, is left to right evaluated: parameters are set one after the other, starting from the leftmost.

Command evaluating will terminate if one of the following events will occur:

  • bad parameter(s) to be set;

  • value of the parameter(s) out of its allowed range;

  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value; the other ones will not be changed.

To activate the new values set, configuration must be saved and the system restarted.

Not all of the shown parameters can be changed. The note "<Read Only>" refers the not modifiable ones.

If the command is executed specifying a read only parameter, the message "COMMAND EXECUTED" will be shown, but the parameter value has not been changed.

SOUND DISABLE | Disable alarm sound generation (User)
 | SOUND DISABLE

It disables the signal acoustic generation on alarm situation occurrence.

The command acts immediately and doesn't need the system restart. it is possible to check its activation through executing the command D G.

If the system has been restarted, the status of the sound alarm generation will be the one previously set by the command S G.

SOUND ENABLE | Enable alarm sound generation (User)
 | SOUND ENABLE

It enables the signal acoustic generation on alarm situation occurrence.

The command acts immediately and doesn't need the system restart. it is possible to check its activation through executing the command D G.

As it was already described (SECTION XX CHAPTER YY), alarms are detected every 30 seconds by a proper procedure, so also the acoustic signal generation comes every 30 seconds.

If the system has been restarted, the status of the sound alarm generation will be the one previously set by the command S G.

System Information top

D I | Display Information (User)
 | D I D I [<version>]

It displays the software version currently in use on the Abilis CPX, information about system memory and files on the disk.

NoFloppyBasedSystem On HD/CF based system only, the option "<version>" allows to displays information about the specified version directory.
The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

Here is an example of the command execution:

[12:25:58] ABILIS_CPX: D I

        Abilis CPX - Ver. 1513 - 02/04/2004 - Build 1513 - 02/04/2004
                            (c) 1994/2004 - Abilis

CPX Serial Number: 00000.00000.00000.00007

Free/Total Memory: 40.713.916/67.108.864  Largest Block: 40.359.704
Free/Used/Total HD/CF space (in KB): 5.096/10.228/15.324

File           Version   Date         Time             Size   Note
-------------------------------------------------------------------------------
CPX.RTB        .......   06/04/2004   15:11:02      1721170
DRIVERS.CFG    v.4.7     06/04/2004   15:14:08         8192   Ok
DRIVERS.BCK    v.4.7     06/04/2004   15:10:44         8192   Ok
CPX.LOG        .......   06/04/2004   15:14:08        10240
CPX.DBG        .......   06/04/2004   15:13:54        10240
CPX.XCP        .......   06/04/2004   15:13:54        10240
TIMEINFO.DAT   .......   06/04/2004   15:13:54           22
ESB2.BIN       v.0013    17/12/2003   13:27:44        17408
FDSP.BIN       v.1.40c   17/12/2003   13:27:44        52224
BUSYTONE.BIN   .......   09/12/2003   12:40:04         3072
READTONE.BIN   .......   17/12/2003   13:27:44         2048
RINGTONE.BIN   .......   17/12/2003   13:27:44         2048
CPX.CSS        .......   17/07/2003   19:27:18         2267
CPX.HTM        .......   15/03/2004   22:21:34          737
SYS.HTM        .......   15/03/2004   22:21:34          750
ABILIS.GIF     .......   28/05/2001   16:52:48         1502
MATT.GIF       .......   16/03/2004   15:40:00         1142
SRVSSL.CER     .......   17/02/2004   10:53:42          806
CLISSL.CER     .......   17/02/2004   10:53:42          806
SRVSSL.KEY     .......   17/02/2004   10:53:42          963
CLISSL.KEY     .......   17/02/2004   10:53:42          951

Other system relevant files:

File           Version   Date         Time             Size   Note
-------------------------------------------------------------------------------
C:\APP\DHCP\DHCP.BND
               v.1.0     06/04/2004   15:14:04        25600

Other files in 'C:\1513':

File                     Date         Time             Size   Note
-------------------------------------------------------------------------------

The first part of the output, is dedicated to the information about version and release date of the software.
The second one shows information about Abilis CPX serial number, system memory and disk.
The third part of the output displays information related to system relevant files, i.e. files used by Abilis during its working (e.g. configuration and configuration backup files, System Log file, ...).

The "Other system relevant files" section displays information about any other system relevant additional files (e.g. DHCP bindings file, ...).

The "Other files:" section shows information about any other additional file that is found on the disk, in the current working version directory.

Eventual detected errors are highlighted with the string "ERR[xx]", where "xx" is the error code detected; it should be eventually told to the Abilis CPX assistance.

warning! On floppy based systems, the command works on the floppy disk. If it is not inserted or any read error occurs, Abilis CPX will show a signalling message.

D VER | Display Versions (User)
 | D VER

It shows the version of the software and its modules currently in used by the Abilis CPX.

Here is an example of the command execution:

[18:38:04] ABILIS_CPX: D VER

        Abilis CPX - Ver. 1513 - 02/04/2004 - Build 1513 - 02/04/2004
                            (c) 1994/2004 - Abilis

CX        : v. 1168    - 10/03/2004       CP        : v. 1745    - 02/04/2004
COR       : v. 1013    - 18/12/2003       CNFG      : v. 1446    - 01/04/2004
COMMON    : v. 1316    - 01/04/2004       CPR/DCP   : v. 1004    - 04/09/2003
PCISRV    : v. 1023    - 12/02/2004       PNPMAN    : v. 1013    - 12/02/2004
HWINT     : v. 1026    - 01/08/2003       FP        : v. 1008    - 11/07/2003
MFIDE     : v. 1014    - 03/10/2003       SYNC-HSCB : v. 1014    - 07/05/2003
CRYPT     : v. 1005    - 09/09/2003       SYNC-ESB  : v. 1072    - 30/09/2003
SDLC      : v. 1005    - 16/01/2003       SYNC-ESB2 : v. 1105    - 01/04/2004
LAPB      : v. 1001    - 02/06/2003       HDLCT     : v. 1005    - 03/09/2003
X25       : v. 1003    - 21/10/2003       FR        : v. 1015    - 12/02/2004
MLM       : v. 1025    - 05/12/2003       ML        : v. 1040    - 11/11/2003
ASYNC     : v. 1002    - 10/09/2003       VOICE     : v. 1028    - 12/06/2003
PAD       : v. 1005    - 23/09/2003       VOICERTR  : v. 1006    - 12/06/2003
SIM       : v. 1006    - 29/09/2003       EBIB      : v. 1023    - 12/06/2003
ETH       : v. 1008    - 10/04/2002       EPIB      : v. 1029    - 12/06/2003
ETH100    : v. 1068    - 05/03/2004       EIR       : v. 1009    - 13/11/2003
TR        : v. 1009    - 31/03/2004       ACNT      : v. 1008    - 05/09/2003
IPLAN     : v. 1031    - 31/03/2004       ISDN      : v. 1008    - 15/07/2002
IPRTR     : v. 1154    - 31/03/2004       EBISDN    : v. 1029    - 12/06/2003
ICMP      : v. 1027    - 17/10/2003       EPISDN    : v. 1029    - 12/06/2003
TCP       : v. 1046    - 17/10/2003       BRIO      : v. 1019    - 16/01/2003
UDP       : v. 1027    - 05/03/2004       LAPD      : v. 1003    - 16/01/2003
TELNET    : v. 1015    - 29/09/2003       EBLAPD    : v. 1003    - 16/01/2003
HTTP      : v. 1106    - 02/04/2004       EPLAPD    : v. 1003    - 16/01/2003
SNMP      : v. 1531    - 12/03/2004       Q931      : v. 1004    - 21/10/2003
RIP       : v. 1037    - 18/02/2004       EBQ931    : v. 1004    - 21/10/2003
SNTP      : v. 1012    - 01/08/2003       EPQ931    : v. 1004    - 21/10/2003
DNS       : v. 1028    - 29/09/2003       sQ931     : v. 1004    - 21/10/2003
XTP       : v. 1018    - 17/10/2003       PLINKE    : v. 1060    - 03/03/2004
NAT       : v. 1081    - 14/11/2003       PPP       : v. 1094    - 18/02/2004
SSH       : v. 1046    - 18/02/2004       POECLI    : v. 1020    - 12/02/2004
DHCP      : v. 1055    - 18/02/2004       POEAC     : v. 1036    - 04/02/2004
OSPF      : v. 1096    - 20/03/2004       DUMMY     : - Module not present -
FTPSRV    : v. 1112    - 06/11/2003       BRIDGE    : v. 1024    - 29/10/2003
ARCHIVE   : v. 1086    - 25/02/2004       WL        : v. 1084    - 20/01/2004
GC        : - Module not present -        WGB       : - Module not present -
SSL       : v. 1043    - 27/01/2004       TRFA      : v. 1097    - 02/04/2004

The first part is dedicated to the information about version and release date of the software.

In the second one, there is a list of all the Abilis CPX software modules. The string "Module not present" refers to the modules that do not belong to the Abilis CPX software currently in use.

Commands relating to date and time top

D T | Display Time (User)
 | D T

It shows date and system local time, time zone and modality of "Standard" or "Daylight Savings" time currently in use.

Here is an example of the command execution.

[18:22:24] ABILIS_CPX: D T

Current Local Time    : Tuesday 06/04/2004 14:49:38 (GMT+2.00)
Local Time Zone       : Central Europe (Rome, Paris, Berlin, Prague, Brussels)
Currently Observing   : Daylight Savings Time (DST)

D TE | Display Time in extended format (User)
 | D TE

It shows date and system local time, current time referred to the GMT time zone, the local time zone, modality of "Standard" or "Daylight Savings" time currently in use and information about the date it will change.

Here is an example of the command execution:

[18:22:24] ABILIS_CPX: D TE

Current Local Time     : Tuesday 06/04/2004 14:49:08 (GMT+2.00)
Current GMT Time       : Tuesday 06/04/2004 12:49:08
Local Time Zone        : CET - Central Europe (Rome, Paris, Berlin, Prague...
Currently Observing    : Daylight Savings Time (DST)
DST time will start on : Sunday 27/03/2005 at 02:00
DST time will end on   : Sunday 31/10/2004 at 03:00

S T | Set Time (Administrator)
 | S T dd/mm/yyyy:hh:mm:ss

It sets the date and system time using the format dd/mm/yyyy:hh:mm:ss.

Date and time inserted format must match the default one, using the same separators.

CPU Load Measurements top

D CPU | Display CPU load percentages (User)
 | D CPU

It gives an estimated percentage of the CPU load for the last 1 second, 15 seconds and 5 minutes.

[09:56:19] ABILIS_CPX: D CPU

+---------+--------------+--------------+--------------+
|         | Last 1 sec.  | Last 15 sec. | Last 5 min.  |
+---------+--------------+--------------+--------------+
|CPU Load |       3%     |      11%     |       1%     |
+---------+--------------+--------------+--------------+

Logging functionalities top

C L | Clear System Log (Administrator)
 | C L

It clears the System Log.

warning! It deletes data on the disk. If the disk is not inserted or any read/write error occurs, Abilis CPX will show a signalling message.

D L | Display System Log (User)
 | D L [dd/mm/yyyy] [hh:mm:ss] [PO:xxx,yyy,...]

It displays the content of the System Log starting from the oldest event.

By specifying the date, the command will display the events occurred since the 00:00:00 of the specified date.

If only the time is specified, the command will show the events occurred since the current date and the specified time.

By specifying time and date, the command will show all the events occurred since the time and date specified.

Doesn't matter the defining sequence of time and date.

Date and time formats must match the indicated ones, by using the same separators. The year field is an exception, because it can accept two or four digits. Moreover, if the seconds are not specified, the Abilis CPX will set them automatically to zero, while if the year is not specified the current one will be used.

It is also possible to define a port list (maximum 50 elements) that allows displaying the events relating to the ports specified in it.

Ports value must be in the interval [0 - 999] and separated by the character "," (comma), without spaces.

warning! The command reads data from the disk. If the disk is not inserted or any read error occurs, Abilis CPX will show a signalling message.

START L | Start System Log real-time displaying (User)
 | START L [PO:xxx,yyy,...]

It makes possible that System Log events are simultaneously sent to the current Control Port session.

[14:09:03] ABILIS_CPX: START L

Current Local Time: Tuesday 06/04/2004 14:50:37 (GMT+2.00)

Start System Log content real-time logging (Type CTRL+C + ENTER to stop):

06/04/2004 15:16:00 I:p1   SYN:UP.00
06/04/2004 15:16:02 I:p1   SYN:UP.01
06/04/2004 15:22:30 System Alive
06/04/2004 15:23:12 I:p2   SYN:UP.11
06/04/2004 15:23:15 I:p201 LAPB:CONN
06/04/2004 15:23:15 I:p205 LAPB:CONN
06/04/2004 15:23:15 I:p301 X25:RDY
06/04/2004 15:23:15 I:p305 X25:RDY

The command is aborted sending Ctrl+C<enter>.

It is also possible to define a port list (maximum 50 elements) that allows displaying the events relating to the ports specified in it.

Ports value must be in the interval [0 - 999] and separated by the character "," (comma), without spaces.

In the case that no System Log event is generated within an interval of 5 minutes, a "System Alive" message is displayed to signal that the connection with the Control Port is still open and that the command is still in progress.

C LDM | Clear Log Debug Memory (Administrator)
 | C LDM

It clears the Events Log stored in the memory.

D LDM | Display Log Debug Memory (User)
 | D LDM [dd/mm/yyyy] [hh:mm:ss] [PO:xxx,yyy,...] [E:val]

It displays the content of the Events Log, stored in the memory, starting from the oldest event.

By specifying the date, the command will display the events occurred since the 00:00:00 of the specified date.

If only the time is specified, then the command will show the events occurred since the current date and the specified time.

By specifying time and date, the command will show all the events occurred since the time and date specified.

Doesn't matter the defining sequence of time and date.

Date and time formats must match the indicated ones, by using the same separators. The year field is an exception, because it can accept two or four digits. Moreover, if the seconds are not specified, the Abilis CPX will set them automatically to zero, while if the year is not specified the current one will be used.

It is also possible to define a port list (maximum 50 elements) that allows displaying the events relating to the ports specified in it.

Ports value must be in the interval [0 - 999] and separated by the character "," (comma), without spaces.

The parameter "E:" specifies the mnemonic of the correspondent events class to be displayed.

Events classes are the following:

Mnemonic | Events classes
DIAG | Events related to port diagnostic and status.
COR | Events related to the Connection Oriented Router.
MLM | Events related to the Multi Link Manager driver.
EIR | Events related to the Enhanced ISDN Router.
EIRE | Extension of the events class related to the Enhanced ISDN Router.
PPP | Events related to the Point-to-Point Protocol driver.
ML | Events related to the Multi Links driver.

it is possible to specify more than one events class at the same time, by separating the mnemonics with the character "," (comma), without space.

For example the command "D LDM E:COR,MLM" will display the events classes COR and MLM.

By omitting the parameter "E:", or specifying "E:ALL", the command will show all the events present in the log.

START LDM | Start Events Log real-time displaying (User)
 | START LDM [PO:xxx,yyy,...] [E:val]

It makes possible that Events Log events are simultaneously sent to the current Control Port session.

[14:31:37] ABILIS_CPX: START LDM

Current Local Time: Tuesday 06/04/2004 14:52:23 (GMT+2.00)

Start Debug Log content real-time logging (Type CTRL+C + ENTER to stop):

060404 145228 905     5 CallRx CG:                CD:00
              PID:01000000 UD:CP           FF:
060404 145228 905     5 Routing Match PR:0
060404 145228   0     2 CallTx CG:                CD:00
              PID:01000000 UD:CP           FF:
060404 145228   0     2 CallConnRx LSN:02 CG:                CD:00
              PID:01000000 UD:CP           FF:
060404 145228 905     5 CallConnTx LSN:02 CG:                CD:
              PID:         UD:             FF:
060404 145257 905     5 ClrRx F0:A3 LSN:02
060404 145257 905     5 ClrConfTx 00:00 LSN:02
060404 145257   0     2 ClrTx 00:00 LSN:02
060404 145257   0     2 ClrConfRx 00:00 LSN:02
¤

PREVIOUS COMMANDS ABORTED

[14:53:08] ABILIS_CPX:

The command is aborted sending Ctrl+C<enter>.

It is also possible to define a port list (maximum 50 elements) that allows displaying the events relating to the ports specified in it.

Ports value must be in the interval [0 - 999] and separated by the character "," (comma), without spaces.

The parameter "E:" specifies the mnemonic of the correspondent events class to be displayed. See D LDM command for the available events classes.

it is possible to specify more than one events class at the same time, by separating the mnemonics with the character "," (comma), without space.

By omitting the parameter "E:", or specifying "E:ALL", the command will send to the Control Port session all the events that are generated.

In the case that no event is generated within an interval of 5 minutes, a "System Alive" message is displayed to signal that the connection with the Control Port is still open and that the command is still in progress.

D LDD | Display Log Debug Disk (User)
 | D LDD [dd/mm/yyyy] [hh:mm:ss] [PO:xxx,yyy,...] [E:val]

It displays the content of the Events Log, saved on disk, starting from the oldest event.

By specifying the date, the command will display the events occurred since the 00:00:00 of the specified date.

If only the time is specified, then the command will show the events occurred since the current date and the specified time.

By specifying time and date, the command will show all the events occurred since the time and date specified.

Doesn't matter the defining sequence of time and date.

Date and time formats must match the indicated ones, by using the same separators. The year field is an exception, because it can accept two or four digits. Moreover, if the seconds are not specified, the Abilis CPX will set them automatically to zero, while if the year is not specified the current one will be used.

It is also possible to define a port list (maximum 50 elements) that allows displaying the events relating to the ports specified in it.

Ports value must be in the interval [0 - 999] and separated by the character "," (comma), without spaces.

The parameter "E:" specifies the mnemonic of the correspondent events class to be displayed.

See D LDM command for the available events classes.

it is possible to specify more than one events class at the same time, by separating the mnemonics with the character "," (comma), without space.

For example the command "D LDD E:COR,PPP" will display the events classes COR and PPP.

By omitting the parameter "E:", or specifying "E:ALL", the command will show all the events present in the log.

warning! The command reads data from the disk. If the disk is not inserted or any read error occurs, Abilis CPX will show a signalling message.

SAVE DEBUG | Save Debug Log on disk (Administrator)
 | SAVE DEBUG

It saves on disk the current Events Log.

warning! The command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

C LE | Clear Log Exception (Administrator)
 | C LE

It clears the Exception Log saved on the disk.

warning! The command works on the disk. If the disk is not inserted or any read error occurs, Abilis CPX will show a signalling message.

D LE | Display Log Exception (User)
 | D LE

It displays the content of the Exception Log saved on the disk.

Information present in this Log is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

warning! The command reads data from the disk. If the disk is not inserted or any read error occurs, Abilis CPX will show a signalling message.

Configuration validating and saving top

VALIDATE | Validate Configuration (User)
 | VALIDATE

This command executed the validation of the configuration currently in use. Configuration validating has been introduced to ensure correct Abilis CPX configurations. By validation it is meant the explicit execution of a series of congruence controls made by Abilis CPX on some important configuration parameters. Base controls on the type and the interval of values, allowed by the configuration parameters, are implicitly carried out by configuration commands, however exists a series of verifications that cannot be executed during the normal routine of configuration. Particularly, configuration parameters of cards and boards are subject to validation.

The output of the validating procedure can be positive without demanding modifications to the configuration, or negative if the validation detects some incongruencies or imprecision in it.

If the command is successful the message "VALIDATION SUCCESSFULLY EXECUTED" will be also shown.

If the validation detects imprecision and it can automatically correct them, the command is however successfully executed. But in such case, the procedure expects the displaying of informative messages which signal to the User the changes, made on the configuration during the validation.

If the validation detects serious incongruencies, in the configuration, that cannot be automatically corrected, the outcome of the command is negative. In such case the procedure expects the displaying of the message "VALIDATION FAILED" and error messages for signalling the detected errors to the User.

The following example shows a successful validation; the procedure required some changes in the configuration (caused by the values of parameters of the same port or different ports connected to it; or caused by incongruencies with the port type).

[18:22:26] ABILIS_CPX: VALIDATE

VALIDATION IN PROGRESS...
PO:201 changed "N1" from 144 to 528 because PO:301 "PS" = 512
PO:1 changed "FRAME" from 144 to 528 because PO:201 "N1" = 528
PO:1 changed "CODING" from NRZI to NRZ because PO:201 is LAPB
VALIDATION FAILED

The following example shows an explicit validation failed because of some, particularly serious, errors detected in the configuration (inconsistent setting of two parameters of the same port, incongruencies between the parameter and the port type, sharing resources among two or more ports):

[18:22:26] ABILIS_CPX: VALIDATE

VALIDATION IN PROGRESS...
ERROR: PO:1 conflicting setting between "CODING" = NRZ and "CLK" = PCLK
ERROR: PO:302 invalid "LOWPO" = 321 type
ERROR: PO:321 "LOWPO" = 1 crossed setting
VALIDATION FAILED

SAVE CONF | Save current configuration (Administrator)
 | SAVE CONF SAVE CONF [<version>]

This command executes the validation of the configuration currently in use. If it is successful, it is saved on the file DRIVERS.CFG on the disk.

NoFloppyBasedSystem On HD/CF based system only, the option "<version>" allows to validate and save the current configuration on to file DRIVERS.CFG in the selected version directory.
The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

The configuration is saved and marked with a configuration state of "configuration saved but not yet loaded".
On the next restart of the Abilis CPX, if the settings of the saved configuration were correct, then the configuration state will become "valid configuration".

it is possible to check the current configuration state through the command D I. In correspondence of the just saved DRIVERS.CFG file, in the notes dedicated section, the string "Saved" will appear.
After the system restart, in correspondence of the just loaded DRIVERS.CFG file, in the notes dedicated section, the string "Ok" will appear.

If the validation and saving are both successful the message "SAVE EXECUTED" will be shown.

If the validation fails, the saving is NOT executed and the message "SAVE NOT EXECUTED" will be shown.

[16:15:50] ABILIS_CPX: SAVE CONF

VALIDATION IN PROGRESS ...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

warning! The command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

SAVE CONF BACKUP | Backup current configuration (Administrator)
 | SAVE CONF BACKUP SAVE CONF BACKUP [<version>]

It creates a backup copy (file DRIVERS.BCK) of the configuration currently saved on disk in the file DRIVERS.CFG.

The backup configuration is loaded at the Abilis CPX start, every time the one, saved in DRIVERS.CFG, is not valid or the same file is missing or corrupted.

Indeed, it is very important that the User makes backup only of those configuration correctly working.

The command will query the User for proceeding or not. The procedure is executed only in case of affirmative answer.

NoFloppyBasedSystem On HD/CF based system only, the option "<version>" allows to create a backup copy of the configuration file DRIVERS.CFG of the specified version directory. The backup file is always named DRIVERS.BCK and will be located in the specified version directory.
The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

Here are two examples of the command execution.

[18:29:04] ABILIS_CPX: SAVE CONF BACKUP

THE CURRENT SAVED CONFIGURATION WILL BECOME THE BACKUP CONFIGURATION.
PROCEED (N/Y)? N

SAVE BACKUP NOT EXECUTED

[18:29:18] ABILIS_CPX: SAVE CONF BACKUP 4-6-1

THE CONFIGURATION SAVED IN 'C:\4-6-1' WILL BECOME THE BACKUP CONFIGURATION
FOR VERSION 4-6-1. PROCEED (N/Y)?y

PROCEEDING WITH SAVE BACKUP...
SAVE BACKUP EXECUTED

warning! On floppy based systems, the command writes data on the floppy disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

SAVE CONF TEST | Save current configuration for test (Administrator)
 | SAVE CONF TEST

This command executes the validation of the configuration currently in use. If it is successful, it is saved on the file DRIVERS.CFG as test configuration: "Saved for Test".

it is possible to check the current configuration state through the command D I. In correspondence of the file DRIVERS.CFG, in the notes dedicated section, the string "Saved for Test" will appear.

On the next system restart, this configuration will be loaded and labelled as configuration under test. it is possible to check the current configuration state through the command D I. In correspondence of the file DRIVERS.CFG, in the notes dedicated section, the string "Under Test" will appear.

If the test configuration is satisfactory, the User can change its state by using the command SAVE CONF, otherwise on the next system restart, the backup configuration (DRIVERS.BCK) will be loaded.

If the validation and saving are both successful the message "SAVE DEFAULTS EXECUTED" will be shown.

If the validation fails, the saving is NOT executed and the message "SAVE DEFAULTS NOT EXECUTED" will be shown.

warning! The command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

System updating and restarting top

CONFLOG BACKUP | Configuration and Log files backup (Administrator)
 | CONFLOG BACKUP [<version>]

It copies configuration and Log files (DRIVERS.CFG, DRIVERS.BCK, DHCP bindings file, CPX.LOG, CPX.DBG and CPX.XCP) of the current version or of the specified version to the floppy disk.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

[14:53:08] ABILIS_CPX: CONFLOG BACKUP

YOU ARE GOING TO BACKUP CONFIGURATION AND LOG FILES OF CURRENT VERSION
TO FLOPPY DISK.
PROCEED (N/Y)? Y

PROCEEDING WITH CONFIGURATION AND LOG FILES BACKUP...
FILE 'DRIVERS.CFG' ... SUCCESSFULLY COPIED.
FILE 'DRIVERS.BCK' ... SUCCESSFULLY COPIED.
FILE 'CPX.LOG' ... SUCCESSFULLY COPIED.
FILE 'CPX.DBG' ... SUCCESSFULLY COPIED.
FILE 'CPX.XCP' ... SUCCESSFULLY COPIED.
FILE 'C:\APP\DHCP\DHCP.BND' ... SUCCESSFULLY COPIED.

COMMAND COMPLETED

warning! The command works on the floppy disk. If the floppy disk is not inserted or any write error occurs, Abilis CPX will show a signalling message.

CONFLOG RESTORE | Configuration files restore (Administrator)
 | CONFLOG RESTORE [<version>]

It copies configuration files (DRIVERS.CFG and DRIVERS.BCK) from the floppy disk to the current version or to the specified version directory.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

[19:16:49] ABILIS_CPX: CONFLOG RESTORE

YOU ARE GOING TO RESTORE CONFIGURATION FILES OF CURRENT VERSION
FROM FLOPPY DISK.
PROCEED (N/Y)? Y

PROCEEDING WITH CONFIGURATION FILES RESTORE...
FILE 'A:\DRIVERS.CFG' ... SUCCESSFULLY COPIED.
FILE 'A:\DRIVERS.BCK' ... SUCCESSFULLY COPIED.

COMMAND COMPLETED

warning! The command works on the floppy disk. If the floppy disk is not inserted or any read error occurs, Abilis CPX will show a signalling message.

FILE COPY | Make a copy of a file (Administrator)
 | FILE COPY srcname dstname

It makes a copy of the "srcname" file into the specified "dtsname" path/file.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "srcname" must be a file name. If the path is omitted the source file is assumed to be located in the current running version directory.

If the "srcname" file is not found, the message "FILE 'namefile' NOT FOUND" will be shown.

The "dstname" can ether a path or a file name (E.g.: A: or C:\4-6-1\ or Fdsp.bin or C:\4-6-2\drivers.cfg). If the path is omitted the destination directory is assumed to be the current running version directory.

Wildcards characters are not accepted either in the source file name nor in the destination name.

File copies to root directory are not allowed.

Log files (Cpx.log, Cpx.dbg and Cpx.xcp) and Cpx.rtb file cannot be overwritten.

If the "dstname" file already exists, the command will request a confirmation before overwrite it.

[12:02:24] ABILIS_CPX: FILE COPY Dhcp.bnd A:\Dhcp.bnd

TARGET FILE 'A:\Dhcp.bnd' ALREADY EXIST.
PROCEED ANYWAY (N/Y)? Y

PROCEEDING WITH FILE COPY...
FILE COPY EXECUTED

FILE DELETE | Delete a file (Administrator)
 | FILE COPY filename

It delete the specified file.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "filename" must be a file name. If the path is omitted the source file is assumed to be located into the current running version directory.

Wildcards characters are not accepted in the file name.

If the "filename" file is not found, the message "FILE 'namefile' NOT FOUND" will be shown.

Files that are located into root directory cannot be deleted.

Configuration files, log files (Cpx.log, Cpx.dbg and Cpx.xcp) and any other system file cannot be deleted from the current running version directory.

The command will always request a confirmation before deleting the specified file.

[12:23:29] ABILIS_CPX: FILE DELETE aaa.txt

FILE 'aaa.txt' IS GOING TO BE DELETED.
PROCEED (N/Y)? Y

FILE 'aaa.txt' DELETED

FILE GET | Get a file (Administrator)
 | FILE GET filename [1K] FILE GET filename [<version>] [1K]

It activates the File Transfer function of the specified file from Abilis CPX to a remote destination, by using the X-Modem protocol.

The option "1K" activates file transferring through the X-Modem 1K protocol.

NoFloppyBasedSystem On HD/CF based system only, the option "<version>" allows to transfer a file of the specified version directory.
The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

If the file is not present, the message "FILE 'namefile' NOT FOUND" will be shown.

The transfer procedure signals its availability to send the file by the message "READY TO SEND FILE..."

When the transfer is completed the following message is shown: "FILE TRANSFER ENDED, PRESS <ENTER> TO CONTINUE...", after pressing the <ENTER> button, an informative message, "FILE TRANSFER SUCCESSFULLY COMPLETED", will be shown if it was successful.

warning! On floppy based systems, the command works on the floppy disk. If it is not inserted or any read error occurs, Abilis CPX will show a signalling message.

FILE PUT | Put a file (Administrator)
 | FILE PUT filename FILE PUT filename [<version>]

It activates the File Transfer function of the specified file from a remote destination to Abilis CPX, by using the X-Modem or X-Modem 1K protocol.

The interested files are the ones already present in the Abilis CPX disk and visualized by executing the command D I.
Only the following files can be uploaded:

  • Configuration files: DRIVERS.CFG, DRIVERS.BCK;
  • Firmware files: ESB2.BIN, FDSP.BIN, BUSYTONE.BIN, READTONE.BIN, RINGTONE.BIN;
  • DHCP binding file: DHCP.BND;
  • SSL certificate/key files: SRVSSL.CER, CLISSL.CER,SRVSSL.KEY, CLISSL.KEY;
  • HTTP pages, image and style sheet files: CPX.CSS, CPX.HTM, SYS.HTM, ABILIS.GIF, MATT.GIF.

The specified file name must be the name relative to the running version directory, i.e. without the file path.

If the file name indicated in the command row does not match any of the above listed file, the following message will be shown: "COMMAND NOT ALLOWED FOR THAT FILE".

NoFloppyBasedSystem On HD/CF based system only, the option "<version>" allows to transfer the file to the specified version directory.
The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

The specified file name must be the name relative to the specified version directory, i.e. without the file path.

The transfer procedure signals its availability to receive the file by the message "READY TO RECEIVE FILE...".

When the transfer is completed the following message is shown: "FILE TRANSFER ENDED, PRESS <ENTER> TO CONTINUE...", after pressing the <ENTER> button, an informative message, "FILE TRANSFER SUCCESSFULLY COMPLETED", will be shown if it was successful.

Once the file is received, it is submitted to a congruence control for checking its content validity. The User is informed through the message "RECEIVED FILE 'nomefile' CHECK IN PROGRESS...". If the file content is not correct, the message "CHECK FAILED: FILE 'namefile' DELETED" is shown and the file deleted.

If file content and version are correct, the message "CHECK PASSED" will be shown and the file overwrites its homonym on the disk.

warning! On floppy based systems, the command works on the floppy disk. If it is not inserted or any read/write error occurs, Abilis CPX will show a signalling message.

SYS COMPACT | Compact directory (Administrator)
 | SYS COMPACT <dir>

This command compacts the specified directory, reducing the allocated size of the directory.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <dir> string must be the physical full name of the directory in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Spaces are allowed and strings holding spaces must be written between quotation marks (e.g. "C:\USR\PUB\MY DIR\").

The command will end reporting the number of recovered entries.

[18:07:01] ABILIS_CPX: SYS COMPACT C:\USR\

COMPACTING DIRECTORY 'C:\USR\' ...
COMMAND EXECUTED, RECOVERED 0 SHORT DIRECTORY ENTRIES

warning! It is recommended to use this command when a lot of files have been deleted or renamed in a directory to reduce its size.

SYS COMPACTR | Compact directory and sub-directories (Administrator)
 | SYS COMPACTR <dir>

This command compacts the specified directory as well as all of its sub-directories. If applied on a root directory, all directories of a logical drive will be compacted.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <dir> string must be the physical full name of the directory in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Spaces are allowed and strings holding spaces must be written between quotation marks (e.g. "C:\USR\PUB\MY DIR\").

The command will lock access to the logical drive where the directory is located. It always requests a confirmation before starting its execution and it will end reporting the number of recovered entries.

[18:26:34] ABILIS_CPX: SYS COMPACT C:\

THIS OPERATION MAY TAKE FEW MINUTES AND LOCKS ACCESS TO DISK C:
PROCEED ANYWAY (N/Y)?y

COMPACTING DIRECTORY 'C:\' AND ALL OF ITS SUBDIRECTORIES...
COMMAND EXECUTED, RECOVERED 2 SHORT DIRECTORY ENTRIES

warning! It is recommended to use this command when a lot of files have been deleted or renamed in a directory to reduce its size.

SYS DELETE PACKAGE | Delete package file (Administrator)
 | SYS DELETE PACKAGE <package>

This command deletes the specified package file.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <package> string must be the name of a package file located in 'C:\PKG' or an absolute package file name (i.e. the full path is required).

The command will always request a confirmation before deleting the specified package file.

SYS DELETE VERSION | Delete version directory (Administrator)
 | SYS DELETE VERSION <version>

This command deletes the specified version directory.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

The currently running version directory cannot be deleted.

The command will always request a confirmation before deleting the specified version directory.

[10:31:57] ABILIS_CPX: SYS DISPLAY VERSIONS

List of available versions:

Version directory                                        Date         Time
------------------------------------------------------------------------------
4-7-1                                                    24/05/2004   16:07:08
4-7-0                                                    19/05/2004   19:30:32
5-0-13                                                   31/03/2004   19:52:00
2423                                                     31/03/2004   21:35:44
2506                                                     25/05/2004   10:09:50
1535                                                     21/05/2004   10:20:52

[10:32:01] ABILIS_CPX: SYS DELETE VERSION 4-7-0

YOU ARE GOING TO DELETE THE 'C:\4-7-0' VERSION DIRECTORY.
PROCEED (N/Y)? Y

VERSION 'C:\4-7-0' DELETED

SYS DIR | List directory (Administrator)
 | SYS DIR [path]

This command shows the directory listing of the specified path. If the path is omitted it lists the content of the currently running version directory.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <path> string must be the physical full name of the directory in DOS notation, i.e. starting with a drive letter in the range ['A'..'Z'] and ending with the '\' character. Spaces are allowed and strings holding spaces must be written between quotation marks (e.g. "C:\USR\PUB\MY DIR\").

Here is an example of the command execution:

[16:38:28] ABILIS_CPX: SYS DIR C:\APP\TRFA\

Directory listing of c:\app\trfa\

.                                                <DIR>   31/03/2004   19:08:00
..                                               <DIR>   31/03/2004   19:08:00
HISTORY                                          <DIR>   31/03/2004   19:08:00
01DA05MI.DAT                                      3326   01/04/2004   14:50:00
01DA05MI.BAK                                      3326   01/04/2004   14:50:00
00DA05MI.BAK                                     12132   08/04/2004   08:35:00
00DA05MI.DAT                                     12132   08/04/2004   08:35:00
00WE30MI.BAK                                      5172   08/04/2004   08:30:00
00WE30MI.DAT                                      5172   08/04/2004   08:30:00
01WE30MI.BAK                                      2860   01/04/2004   14:30:00
01WE30MI.DAT                                      2860   01/04/2004   14:30:00
01MO02HO.DAT                                      3046   01/04/2004   14:00:00
01MO02HO.BAK                                      3046   01/04/2004   14:00:00
00MO02HO.BAK                                      3556   07/04/2004   16:00:04
00MO02HO.DAT                                      3556   07/04/2004   16:00:04

Found 3 directories, 12 files.
Total 14 MB, Used 9 MB, Free 5 MB.

SYS DISK FORMAT | Format a disk drive
 | SYS DISK FORMAT drive: [-SF][par:val]

This command formats a disk drive.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "drive:" must be a drive letter in the range [D,..,Z]. The system drive "C:" cannot be formatted; while for floppy disk formatting the SYS FLPFORMAT command must be used.

The "-SF" option formats the selected drive creating only a single File Allocation Table (FAT). This option should be used to improve performance and efficiency.
By default, two FATs are created. The second copy is maintained as a backup copy for disk repair utilities. If the primary FAT gets corrupted, the disk repair commands can copy the secondary FAT onto the primary FAT. However, drives formatted with a single FAT have a larger capacity and better write performance. The file system software itself will never actually use the second FAT. Thus, the second FAT can improve security, but it always incurs a performance penalty because each FAT update requires twice as many disk write operations as it would for a single FAT volume.

Below it is the list of the additional parameters accepted by the command:

Parameter | Description
CLUSSIZE: | This parameter allows to select the size of the cluster to be created on the formatted drive. Values in the range [4, 8, 16, 32, 64, 128, 256 KB] are accepted. It can be used only when formatting disk drive with size greater then 512 MB.
FAT: | This parameter allows to select the type of the File Allocation Table (FAT) to be created on the formatted drive. Values in the range [16, 32] are accepted, corresponding respectively to FAT-16 and to a FAT-32 file system. If this parameter is not specified, the command will select a FAT type automatically. Drives with less than 16 MB size will be formatted as FAT-12 and drives with less than 512 MB will be formatted as FAT-16. Larger drives are formatted as FAT-32.

warning! Please note that some combinations of CLUSSIZE: and FAT: can prevent the command from setting up a valid file system. For example, a FAT-16 drive must have at least 4085 clusters. However, if a drive has only 10000 sectors, CLUSSIZE: is set to 4, and FAT:16 is specified, the command will return and error message.

SYS DISPLAY BOOT | Display Boot Manager configuration
 | SYS DISPLAY BOOT

This command shows the current Boot Manager configuration. Boot Manager configuration consists of the following information:

  • Previous version: version loaded before the current one;
  • Current version: version that is currently running;
  • Next Version to load: version that will be loaded at next system startup.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[12:28:06] ABILIS_CPX: SYS DISPLAY BOOT

Abilis CPX Boot Manager configuration:

Previous version      Current version       Next Version to load
------------------------------------------------------------------------------
4-6-1                 4-6-1                 4-7-0

SYS DISPLAY BOOT LOG | Display Boot Manager log file (Administrator)
 | SYS DISPLAY BOOT LOG

This command shows the current content of the Boot Manager log file.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[10:36:33] ABILIS_CPX: SYS DISPLAY BOOT LOG

Boot Manager log file:

***** New run at 2004-03-18 20:53:24 *****
Setting current directory
Loading configuration
Loading CPX response file
Accepting 'new' version
Saving configuration
Removing CPX response file
Writing working directory to shared region
Loading file: 4-7-0\CPX.RTB
Starting loaded RTB file

***** New run at 2004-03-20 11:28:55 *****
Setting current directory
Loading configuration
Loading CPX response file
Accepting 'new' version
Saving configuration
Removing CPX response file
Writing working directory to shared region
Loading file: 4-6-1\CPX.RTB
Starting loaded RTB file

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

SYS DISPLAY PACKAGES | Display available package files (Administrator)
 | SYS DISPLAY PACKAGES

This command shows the package files that are present in the 'C:\PKG' directory.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[16:44:32] ABILIS_CPX: SYS DISPLAY PACKAGES

List of available packages in 'C:\PKG':

Package (version)                           Date         Time             Size
------------------------------------------------------------------------------
4-6-1.PKG (4-6-1)                           25/02/2004   16:03:20      1266688
CPX.PKG (4-7-0)                             13/03/2004   11:53:11      1266775

SYS DISPLAY VERSIONS | Display available versions (Administrator)
 | SYS DISPLAY VERSIONS

This command shows the list of versions that are currently available on the system.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[16:44:34] ABILIS_CPX: SYS DISPLAY VERSIONS

List of available versions:

Version directory                                        Date         Time
------------------------------------------------------------------------------
4-6-1                                                    05/03/2004   17:00:00
4-7-0                                                    04/04/2004   13:00:24

SYS DISK CHK | Check HD/CF integrity (Administrator)
 | SYS DISK CHK [drive:][opt]

This command executes an integrity check of a disk drive and eventually fixes detected errors.

NoFloppyBasedSystem The command is available on HD/CF based system only.

By specifying a drive letter in the range [A..Z], the command will execute the integrity check on the selected drive only. Otherwise the verification will be executed on the system disk C:.

Here it is the list of the accepted options:

Option | Description
-F | Enable error fixing, except file size errors.
-FE | Enable error fixing, file size errors included.
-S | Enable silent mode (check disk statistics are displayed only).
-V | Enable verbose mode (this option extends default verbose mode).
-L | Displays the list of the detectable errors.

Here it is a sample of the command execution, when no option is specified.

[16:26:05] ABILIS_CPX: SYS DISK CHK D:

THIS OPERATION MAY TAKE FEW MINUTES AND LOCKS ACCESS TO ALL DISKS.
PROCEED ANYWAY (N/Y)? y

DISK 'D:' INTEGRITY CHECK IN PROGRESS...
DISK 'D:' INTEGRITY CHECK SUCCESSFULLY COMPLETED

NO ERRORs WERE FOUND

Here it is a sample of the command execution, when the "verbose mode" is requested:

[16:34:53] ABILIS_CPX: SYS DISK CHK C: -V

THIS OPERATION MAY TAKE FEW MINUTES AND LOCKS ACCESS TO ALL DISKS.
PROCEED ANYWAY (N/Y)?y

DISK 'C:' INTEGRITY CHECK IN PROGRESS...
checking FAT...
C:\
C:\PKG\
C:\2485\
C:\USR\
C:\USR\PUB\
C:\LOG\
C:\LOG\ARC\
C:\APP\
C:\APP\SSH\
C:\APP\HTTP\
C:\APP\TRFA\
C:\APP\TRFA\HISTORY\
C:\APP\DHCP\
C:\5-0-13\
C:\2423\
C:\2481\
C:\1513\
searching lost clusters...
DISK 'C:' INTEGRITY CHECK SUCCESSFULLY COMPLETED

NO ERRORs WERE FOUND

Here it is the list of disk check detectable errors:

  • File Allocation Table (FAT) mismatch (FATMSM)
  • Invalid directory entries (INVDIR)
  • Invalid file size: file too short (FSHORT) and file too long (FLONG)
  • Cluster chain cross links (CROSSL)
  • Invalid cluster values (INVCL)
  • Lost clusters (LOSTCL)
  • Invalid or orphaned long file names (LNAME)
SYS DISK INFO | Display logical drive information (Administrator)
 | SYS DISK INFO [drive:]

This command shows relevant information related to logical drive(s).

NoFloppyBasedSystem The command is available on HD/CF based system only.

By specifying a drive letter in the range [A..Z], the command shows information related to the selected drive only. Otherwise information related to all logical drive(s) are displayed.

[16:46:24] ABILIS_CPX: SYS DISK INFO

Logical drive(s) information:

Drv Disk   Label       FAT     Free space      Used space      Total space
    UDMA   I/O-bit     Sectors per block       Cluster size
------------------------------------------------------------------------------
A:  Floppy             12      1.364.992 Bytes 92.160 Bytes    1.457.152 Bytes
------------------------------------------------------------------------------
C:  HD-0   CPX_SYSTEM  12      4 MB            9 MB            14 MB
    No     16          1                       4.096 Bytes
------------------------------------------------------------------------------
D:  HD-1   USER_DISK   32      2.436 MB        0 MB            2.436 MB
    No     16          8                       4.096 Bytes
------------------------------------------------------------------------------

SYS DISK LABEL | Set drive label (Administrator)
 | SYS DISK LABEL drive:

This command allows to set the label of the selected drive or remove any existing label.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "drive:" must be a drive letter in the range [D,..,Z]. The system drive "C:" label cannot be changed; while for setting floppy disk label the SYS FLPFORMAT command should be used.

The new label must be a string of up to 11 characters length. The case of the entered label is not preserved, lower case characters will be always converted to upper case.

[19:27:57] ABILIS_CPX: SYS DISK LABEL D:

ENTER VOLUME LABEL (MAX. 11 CHARACTERs, PRESS <ENTER> FOR NO LABEL): UserDisk

COMMAND EXECUTED

[19:28:09] ABILIS_CPX: SYS DISK INFO D:

Logical drive(s) information:

Drv Disk   Label       FAT     Free space      Used space      Total space
    UDMA   I/O-bit     Sectors per block       Cluster size
------------------------------------------------------------------------------
D:  HD-1   USERDISK    32      2.388 MB        47 MB           2.436 MB
    No     16          8                       4.096 Bytes
------------------------------------------------------------------------------

SYS DISK PARTITION ADD | Add new partition to a disk (Administrator)
 | SYS DISK PARTITION ADD HD:val

This command add a new partition to the specified hard disk.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "HD:" parameter must be an hard disk index in the range [0..31].

Here it is a sample of the command execution:

[15:49:49] ABILIS_CPX: SYS DISK PARTITION ADD HD:1

Hard Disk '1' information:

HD  Size          Partition Drive Label       FAT     Size
------------------------------------------------------------------------------
1   2.441 MB      1         D:    USERDISK    32      2.436 MB

HARD DISK '1' ALREADY HOLDS 1 PARTITIONs.
DO YOU WANT TO ADD A NEW PARTITION (N/Y)? Y

THIS OPERATION WILL SPLIT PARTITION 1 ('D:') INTO TWO PARTITIONs.
ALL DATA ON 1 ('D:') PARTITION WILL BE LOST.
PROCEED (N/Y)? Y

PLEASE ENTER THE SIZE YOU WANT TO RESERVE FOR PARTITION 1 ('D:'),
THE REMAINING SPACE WILL BE ASSIGNED TO THE NEW PARTITION,
IN MBytes (0 TO EXIT): 500

THE SIZE OF PARTITION 1 ('D:') WILL BE ABOUT 500 MB
THE SIZE OF THE NEW PARTITION WILL BE ABOUT 1.936 MB
PROCEED (N/Y)? Y

HARD DISK PARTITIONING OPERATIONS REQUIRE THAT NO FILES ARE OPENED.
IF SOME FILES ARE CURRENTLY OPENED IN THE SYSTEM,
THE COMMAND WILL WAIT UNTIL ALL FILES WILL BE CLOSED.
PROCEED (N/Y)? Y

WAITING THAT ALL FILES GET CLOSED (TYPE CTRL+C + ENTER TO STOP)... DONE.

NEW PARTITION CREATION IN PROGRESS... DONE.

PARTITION 1 ('D:') SUCCESSFULLY SPLITTED ON HARD DISK '1'
PARTITION 2 ('E:') SUCCESSFULLY CREATED ON HARD DISK '1'

DRIVE 'D:' FORMAT IN PROGRESS... DONE.

ENTER VOLUME LABEL (MAX. 11 CHARACTERs, PRESS <ENTER> FOR NO LABEL): MY_DISK

DRIVE 'D: FORMATTED:

 FILE SYSTEM IS FAT-16, Size: 495 MB
 Bytes per sector: 512, Sectors per cluster: 16, Clusters: 63467
 Serial N. 3086-7E76, Label: MY_DISK

DRIVE 'E:' FORMAT IN PROGRESS... DONE.

ENTER VOLUME LABEL (MAX. 11 CHARACTERs, PRESS <ENTER> FOR NO LABEL): Y_DISK

DRIVE 'E: FORMATTED:

 FILE SYSTEM IS FAT-32, Size: 1.941 MB
 Bytes per sector: 512, Sectors per cluster: 8, Clusters: 496977
 Serial N. 3086-7E85, Label: Y_DISK

COMMAND COMPLETED

SYS DISK PARTITION INFO | Display partition(s) information (Administrator)
 | SYS DISK PARTITION INFO

This command displays information related to partition(s) defined on all hard disks of the system.

NoFloppyBasedSystem The command is available on HD/CF based system only.

Here it is a sample of the command execution:

[15:52:37] ABILIS_CPX: SYS DISK PARTITION INFO

Available Hard Disk(s) information:

HD  Size          Partition Drive Label       FAT     Size
------------------------------------------------------------------------------
0   15 MB         1         C:    CPX_SYSTEM  12      14 MB
1   2.441 MB      1         D:    MY_DISK     16      495 MB
                  2         E:    Y_DISK      32      1.941 MB

SYS DISK PARTITION RESET | Partition(s) reset (Administrator)
 | SYS DISK PARTITION RESET HD:val SYS DISK PARTITION RESET HD:val P:val

This command allows to reset all existing partition(s) defined on a hard disk and/or to reset partition(s) starting from the specified one.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The "HD:" parameter identifies the hard disk and must be an index in the range [0..31].

The "P:" parameter identifies the disk partition and must be an index in the range [1..4].

Here it is a sample of the command execution:

[16:17:26] ABILIS_CPX: SYS DISK PARTITION RESET HD:1

Hard Disk '1' information:

HD  Size          Partition Drive Label       FAT     Size
------------------------------------------------------------------------------
1   2.441 MB      1         D:    MY_DISK     16      495 MB
                  2         E:    Y_DISK      32      1.941 MB

DO YOU REALLY WANT TO DELETE ALL EXISTING PARTITIONs ON HARD DISK '1' (N/Y)? Y

THIS OPERATION WILL DELETE ALL EXISTING PARTITIONs AND CREATE
A SINGLE NEW PARTITION ON HARD DISK '1'.
PROCEED (N/Y)? Y

HARD DISK PARTITIONING OPERATIONS REQUIRE THAT NO FILES ARE OPENED.
IF SOME FILES ARE CURRENTLY OPENED IN THE SYSTEM,
THE COMMAND WILL WAIT UNTIL ALL FILES WILL BE CLOSED.
PROCEED (N/Y)? Y

WAITING THAT ALL FILES GET CLOSED (TYPE CTRL+C + ENTER TO STOP)... DONE.

CREATING A SINGLE NEW PARTITION ON HARD DISK '1'... DONE.
PARTITION 1 ('D:') SUCCESSFULLY CREATED ON HARD DISK '1'

DRIVE 'D:' FORMAT IN PROGRESS... DONE.

ENTER VOLUME LABEL (MAX. 11 CHARACTERs, PRESS <ENTER> FOR NO LABEL): user_disk

DRIVE 'D: FORMATTED:

 FILE SYSTEM IS FAT-32, Size: 2.436 MB
 Bytes per sector: 512, Sectors per cluster: 8, Clusters: 623729
 Serial N. 3086-82B1, Label: USER_DISK

COMMAND COMPLETED

SYS FLPFORMAT | Format floppy disk (Administrator)
 | SYS FLPFORMAT

This command allows to format a floppy disk inserted in the drive 'A:'.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[14:30:45] ABILIS_CPX: SYS FLPFORMAT

YOU ARE GOING TO FORMAT A FLOPPY DISK, ALL DATA OF THE DISK WILL BE LOST.
PROCEED (N/Y)? Y
INSERT A FLOPPY DISK AND PRESS <ENTER> WHEN READY...<ENTER>
PROCEEDING WITH FLOPPY DISK FORMAT...
ENTER VOLUME LABEL (MAX. 11 CHARACTERs, PRESS <ENTER> FOR NO LABEL): MYDISK
FLOPPY DISK FORMATTED:

 FAT-12, Size: 1.464.320 bytes
 Bytes per sector: 512, Sectors per cluster: 2, Clusters: 1430
 Serial N. 2D3A-73FD, Label: MYDISK

COMMAND COMPLETED

warning! The command works on the floppy disk. If the disk is not inserted or any read/write error occurs, Abilis CPX will show a signalling message.

SYS SET BOOT VERSION | Set the next version to be loaded (Administrator)
 | SYS SET BOOT VERSION [<version>]

This command allows to change Boot Manager configuration setting the version that must be loaded at next system startup.

NoFloppyBasedSystem The command is available on HD/CF based system only.

The <version> string must correspond to an existing version directory in the form 'X.Y.Z' or 'X-Y-Z' or 'Y.Z' or 'Y-Z' or 'Y', where X, Y and Z are decimal digit [0 - 9] (E.g.: 4-6-0 or 1219).

[14:33:23] ABILIS_CPX: SYS DISPLAY BOOT

Abilis CPX Boot Manager configuration:

Previous version      Current version       Next Version to load
------------------------------------------------------------------------------
4-6-0                 4-6-0                 4-6-0

[14:37:59] ABILIS_CPX: SYS SET BOOT VERSION 4-7-0

COMMAND EXECUTED

[14:38:23] ABILIS_CPX: SYS DISPLAY BOOT

Abilis CPX Boot Manager configuration:

Previous version      Current version       Next Version to load
------------------------------------------------------------------------------
4-6-0                 4-6-0                 4-7-0

The list of available versions can be displayed by the command SYS DISPLAY VERSIONS; while the current/new Boot Manager configuration is displayed by the command SYS DISPLAY BOOT.

SYS UPDATE | Update System (Administrator)
 | SYS UPDATE SYS UPDATE <package>

This command makes possible the system software update. It operates in different ways on floppy based system then on HD/CF based systems.

Floppy based systems:

This command makes possible the system software update, by receiving from a remote source the updated system disk image.

The transfer procedure signals its availability to receive the new software file by the following message:

YOU ASKED TO UPDATE A FLOPPY BASED SYSTEM.
PLEASE UPLOAD THE FLOPPY IMAGE FILE.

READY TO RECEIVE DISK IMAGE...

When the transfer is completed the following message is shown:

DISK IMAGE TRANSFER ENDED, PRESS <ENTER> TO CONTINUE...

Once the <ENTER> is pressed by the User, if the transfer was successful, the informative messages, "DISK IMAGE TRANSFER SUCCESSFULLY COMPLETED" and "SYSTEM UPDATE EXECUTED, THE DISK IS BOOTABLE", will be shown, meaning that the software has been updated.

warning! On floppy based systems, the command works on the floppy disk. If the disk is not inserted or any read/write error occurs, Abilis CPX will show a signalling message.

HD/CF based systems:

This command makes possible the system software update in two ways:

  • By receiving from a remote source the package file holding the updated software and installing it on the HD/CF in a proper version directory.
    The transfer procedure signals its availability to receive the package file by the following messages:
    YOU ASKED TO UPDATE A CF/HD BASED SYSTEM.
PLEASE UPLOAD THE UPDATE PACKAGE FILE.

READY TO RECEIVE PACKAGE...

    When the transfer is completed the following message is shown:
    PACKAGE TRANSFER ENDED, PRESS <ENTER> TO CONTINUE...

    Once the <ENTER> is pressed by the User, if the transfer was successful, an informative message will be shown and the system will start the received package integrity check procedure. If the received package passes the validation procedure, the software extraction and installation takes place.
    PACKAGE TRANSFER SUCCESSFULLY COMPLETED

RECEIVED PACKAGE CHECK and EXTRACTION IN PROGRESS...
CHECK PASSED, EXTRACTION DONE.

VERSION '4-6-1' SUCCESSFULLY INSTALLED.
  • By a package file already present in the 'C:\PKG' directory, installing it on the HD/CF in a proper version directory.
    In this case the package file name specification is required by the User on the command line: "SYS UPDATE <package>".
    The <package> string must be the name of a package file located in 'C:\PKG' or an absolute package file name (i.e. the full path is required).
    If the specified package file is not present, the message "FILE '<package>' NOT FOUND" will be shown.
    The procedure starts with a package integrity check. If the package passes the validation phase, the software extraction and installation takes place.
    PACKAGE '4-6-1.PKG' CHECK and EXTRACTION IN PROGRESS...
CHECK PASSED, EXTRACTION DONE.

VERSION '4-6-1' SUCCESSFULLY INSTALLED.

In both cases, if the update package holds software of the same version of the currently running one, before starting the system update, the command will ask an additional confirmation with the following message:

YOU ARE GOING TO UPDATE THE CURRENT VERSION (4-6-0),
DO YOU REALLY WANT TO PROCEED (N/Y)? Y
RECEIVED PACKAGE CHECK and EXTRACTION IN PROGRESS...
CHECK PASSED, EXTRACTION DONE.

VERSION '4-6-0' SUCCESSFULLY INSTALLED.

In both cases, if the package verifications and extraction is successful, the package file is always deleted. On the contrary, if the procedure fails for any reason, the package deletion takes place only after the User confirmation.

The list of currently available package files can be displayed by the command SYS DISPLAY PACKAGES; while a package file can be deleted by the command SYS DELETE PACKAGE.

Once a new software version is installed on the system, it can be set to be loaded at next system startup by the command SYS SET BOOT VERSION.

The list of currently available versions can be displayed by the command SYS DISPLAY VERSIONS.

Old versions, not longer useful, can be deleted by the command SYS DELETE VERSION.

WARM START | System warm start (Administrator)
 | WARM START

This command writes in the System Log the event "WARM START" and executes immediately the reset of the Abilis CPX.

For executing the Abilis CPX restart, is strongly recommended to use this command; use the RESTART SYSTEM command only if it is needed to restart the Abilis after saving the Events Log.

warning! The command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX don't save the event in the Events Log, but executes the reset.

If in the current configuration session the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the reset of the Abilis CPX is not executed and the Control Port prompt is shown.

[11:38:04] ABILIS_CPX: WARM START

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? Y

VALIDATION IN PROGRESS...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[11:56:43] ABILIS_CPX:

In case of negative answer, the configuration is not saved and the reset of the Abilis CPX is executed.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

NoFloppyBasedSystem On HD/CF based system only, if in the current configuration session the Boot Manager configuration was modified, i.e. a version different from the currently running one was set to be loaded at next system start up (SYS SET BOOT VERSION), the command displays a warning message and queries the User for proceeding with system restart.

[11:38:04] ABILIS_CPX: WARM START

BOOT MANAGER CONFIGURATION WAS MODIFIED:
THE NEXT VERSION THAT WILL BE LOADED IS '4-3-1',
WHILE THE CURRENTLY RUNNING VERSION IS '4-6-0'.

PROCEED WITH WARM START (N/Y)? Y

In case of affirmative answer, the system is restarted. In case of negative answer, the command doesn't proceed with the system restart.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

RESTART SYSTEM | Restart system (Administrator)
 | RESTART SYSTEM

It closes the current connections, saves the Events Log on disk, writes in the System Log the event "RESTART SYSTEM" and executes the reset of Abilis CPX software.

For executing the Abilis CPX restart, is strongly recommended to use the command WARM START; use this command only if it is needed to restart the Abilis after saving the Events Log.

warning! The command writes data on the disk. If the disk is not inserted or any write error occurs, Abilis CPX don't save the event in the System Log, but executes the reset.

If in the current configuration session the configuration was modified but not saved, the command displays a warning message and queries the User for proceeding with configuration saving or not.

In case of affirmative answer, the SAVE CONF command is executed, the reset of the Abilis CPX is not executed and the Control Port prompt is shown.

[11:38:04] ABILIS_CPX: RESTART SYSTEM

THE CURRENT CONFIGURATION WAS MODIFIED BUT NOT SAVED.
PROCEED WITH 'SAVE CONF' COMMAND (N/Y/A)? Y

VALIDATION IN PROGRESS...
VALIDATION SUCCESSFULLY EXECUTED

SAVE EXECUTED

[11:56:43] ABILIS_CPX:

In case of negative answer, the configuration is not saved and the reset of the Abilis CPX is executed.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

NoFloppyBasedSystem On HD/CF based system only, if in the current configuration session the Boot Manager configuration was modified, i.e. a version different from the currently running one was set to be loaded at next system start up (SYS SET BOOT VERSION), the command displays a warning message and queries the User for proceeding with system restart.

[11:38:04] ABILIS_CPX: RESTART SYSTEM

BOOT MANAGER CONFIGURATION WAS MODIFIED:
THE NEXT VERSION THAT WILL BE LOADED IS '4-3-1',
WHILE THE CURRENTLY RUNNING VERSION IS '4-6-0'.

PROCEED WITH SYSTEM RESTART (N/Y)? Y

In case of affirmative answer, the system is restarted. In case of negative answer, the command doesn't proceed with the system restart.

Any other answer makes the command to be aborted and the Control Port prompt to be shown again.

Test and trace functionalities top

PING | Ping (User)
 | PING xxx.xxx.xxx.xxx [-opz1 val][-opz2 val]...[-opzN val]

This command executes a Ping to the specified IP address using the options indicated in the command row.

If the IP Router is not present the message "IP SERVICE NOT PRESENT" is shown.

If the IP address is not in the indicated format, it is possible, by typing "PING ?", to have a complete list of the allowed options of the command. For example:

[11:56:41] ABILIS_CPX: PING ?

Usage: ping <address> [-a] [-n count] [-l size] [-i TTL] [-r count] [-w timeout]
                      [-v TOS] [-m] [-s src_address]
Options:
    -a             Resolve addresses to hostnames.
    -n count       Number of echo requests to send.
    -l size        Send buffer size.
    -i TTL         Time To Live.
    -v TOS         Type of service. (use number or D, T, R, C)
    -r count       Record route for count hops.
    -s src_address Source address.
    -w timeout     Timeout in milliseconds to wait for each reply.
    -m             Show MAC address of the response (host or gateway).

TRACERT | Trace Route (User)
 | TRACERT xxx.xxx.xxx.xxx [-opz1 val][-opz2 val]...[-opzN val]

This command traces the route of the IP packet sent to the IP address specified in the command row.

If the IP Router is not present the message "IP SERVICE NOT PRESENT" is shown.

If the IP address is not in the indicated format, it is possible, by typing "TRACERT ?", to have a complete list of the allowed options of the command. For example:

[11:56:44] ABILIS_CPX: TRACERT ?

Usage: tracert <address> [-a] [-h maximum_hops] [-w timeout]
                         [-m] [-s src_address]
Options:
    -a                 Resolve addresses to hostnames.
    -h maximum_hops    Maximum number of hops to search for target.
    -s src_address     Source address.
    -w timeout         Wait timeout milliseconds for each reply.
    -m                 Show MAC address of the response (host or gateway).

IPTRACE ACT | Activate TCP/IP Trace (Administrator)
 | IPTRACE ACT

This command initializes the TCP/IP events trace function, by allocating the data structures needed by it. The message "COMMAND EXECUTED" will be shown after the command execution.

The trace function monitors the events exchanged between the IP Router and the eventual TCP port.

The parameter tracerec:, defined in the IP Router configuration, sets the number of records the TCP/IP trace can store: if this value is set to zero, the TCP/IP trace is not activated.

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

IPTRACE CLEAR | Clear TCP/IP Trace (Administrator)
 | IPTRACE CLEAR

It clears the content of the TCP/IP event trace and shows the message "COMMAND EXECUTED".

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

If the TCP/IP trace has not been yet activated through the command IPTRACE ACT, the following message will be displayed "IPTRACE IS INACTIVE".

IPTRACE DISPLAY | Display TCP/IP Trace (Administrator)
 | IPTRACE DISPLAY

This command shows the content of the TCP/IP event trace. If the command is executed before the trace is stopped, by the IPTRACE STOP one, the error message will be shown: "TRACE STILL RUNNING".

The displaying format requires the information about each TCP/IP event to be shown in two rows.

Here is an example:

[12:07:07] ABILIS_CPX: IPTRACE DISPLAY

2302      O ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 10149908
TCP         ACK 895798600  DATA 2      PSH  WIN 2048
2309      O ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 10149910
TCP         ACK 895798600  DATA 24     PSH  WIN 2048
2313      I ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 895798600
TCP         ACK 10149934    WIN 16270
2332      I ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 895798600
TCP         ACK 10149934   DATA 2      PSH  WIN 16270
2333      O ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 10149934
TCP         ACK 895798602  DATA 2      PSH  WIN 2048
2340      O ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 10149936
TCP         ACK 895798602  DATA 24     PSH  WIN 2048
2343      O ESTABLISH 192.168.000.002:1856  192.168.000.060:23    SEQ 10149960
TCP         ACK 895798602  PSH  WIN 2048

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

If the TCP/IP trace has not been yet activated through the command IPTRACE ACT, the following message will be displayed "IPTRACE IS INACTIVE".

IPTRACE INACT | Deactivate TCP/IP Trace (Administrator)
 | IPTRACE INACT

It deactivates the TCP/IP event trace, releasing the data structure eventually allocated by the command IPTRACE ACT and displaying the message "COMMAND EXECUTED".

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

IPTRACE START | Start TCP/IP Trace (Administrator)
 | IPTRACE START

It starts, once it has been activated by using the command IPTRACE ACT, the TCP/IP events trace and display the message "COMMAND EXECUTED".

Trace is handled in a circular way: once the maximum number of allowed events is reached, the oldest are replaced by the newest.

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

If the TCP/IP trace has not been yet activated through the command IPTRACE ACT, the following message will be displayed "IPTRACE IS INACTIVE".

IPTRACE STOP | Stop TCP/IP Trace (Administrator)
 | IPTRACE STOP

It stops the TCP/IP events trace and shows the message "COMMAND EXECUTED".

If the IP Router is not present or inactive the message "IP SERVICE NOT PRESENT" is shown.

If the TCP/IP trace has not been yet activated through the command IPTRACE ACT, the following message will be displayed "IPTRACE IS INACTIVE".

TRACE ACT | Activate Trace (Administrator)
 | TRACE ACT TRACE ACT PO:xxx[,yyy, ...] [SIZE:val] [DATA:val] [CMD:val] [LSN:val] [TYPE:val]

It activates the internal events trace function.

If no parameter is specified, the following message is displayed: "NO PARAMETER SPECIFIED: USING SAVED VALUES..." and the trace function is activated using the setting already saved through the commands TRACE PARAM SET and TRACE PARAM SAVE.

As alternative, the command will activate the trace function on the specified ports with the options eventually indicated in the command row. Optional parameters not indicated will be set to their values already saved through the commands TRACE PARAM SET and TRACE PARAM SAVE.

The mandatory parameter "PO:" sets the list of ports (minimum 1, maximum 50) that can be traced; their values must be in the interval [0 - 999]. Ports to be traced, must be "RUNNING", if not, the following message will be displayed "PO:xxx NOT PRESENT OR NOT RUNNING" and the trace function won't be activated; "xxx" stands for the identifier of the not present or not running port.

The optional parameter "SIZE:" sets the maximum allocable memory size for the trace function. If the parameter is not specified, all the available memory will be used by the system for trace activating, except the needed quantity for system management. If the system memory is not enough for activating the trace function, it won't be activated and the following message will be displayed "NOT ENOUGH MEMORY TO RUN TRACE".

While the optional parameter "DATA:" sets the maximum allocable memory size for saving the single event, remaining optional parameters "CMD:", "LSN:" and "TYPE:" make possible the activation of filters on the events traced.

Optional parameter | Meaning
DATA: | Maximum allocable memory size for saving a single event (byte) [10 - 2100 byte]
CMD: | Command type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]
LSN: | Local session number to be traced [ALL, 0000..FFFE (Hex.)]
TYPE: | Data type to be traced [DATA, CHK, VOICE]

If the trace function has been already activated, it has to be deactivated through the command TRACE INACT. If the trace is not deactivated, the following message will be displayed "TRACE ALREADY ACTIVE", while if it is already running "TRACE ALREADY RUNNING".

By typing the string "TRACE ACT ?", an informative message about trace activation command syntax will be shown.

For example:

[16:28:48] ABILIS_CPX: TRACE ACT ?

TRACE ACT                          Activate Tracer using saved values
TRACE ACT PO:xx,yy,...             Activate Tracer on specified ports
          [SIZE:val][-M]
          [DATA:val][CMD:val]
          [LSN:val][TYPE:val]

PO:             Ports to be traced (max. 50)                       <Mandatory>
SIZE:           Tracer buffer size [3Kb..8Mb]                       <Optional>
-M              Force Tracer activation                             <Reserved>
DATA:           Max event buffer size [10..2100 bytes]              <Optional>
CMD:            Commands type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]  <Optional>
LSN:            SD/RV lsn to be traced [ALL, 0000..FFFE (Hex.)]     <Optional>
TYPE:           SD/RV type to be traced [DATA, CHK, VOICE]          <Optional>

By typing only the string "TRACE ??", an informative message about every trace command syntax will be shown.

For example:

[12:35:27] ABILIS_CPX: TRACE ??

[19:14:17] ABILIS_CPX:trace  ??

TRACE ACT                          Activate Tracer using saved values
TRACE ACT PO:xx,yy,...             Activate Tracer on specified ports
          [SIZE:val][-M]
          [DATA:val][CMD:val]
          [LSN:hex-val][TYPE:val]
TRACE CLEAR                        Clear the current trace
TRACE DELETE <file>                Delete trace saved in disk in <file> file
TRACE DISPLAY [ST:val or LE:val]   Display trace of sent and received data
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]
TRACE DISPLAY EXTENDED             Display trace of all commands
              [ST:val or LE:val]
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]
TRACE GET [1K]                     Transfer trace using X-Modem or X-Modem 1K
          [ST: and/or LEN:] or [LAST:]
TRACE INACT                        Deactivate Tracer
TRACE PARAM                        Display Tracer configured parameters, active
                                   parameters and the current Tracer state
TRACE PARAM SAVE                   Save current Tracer parameters values
TRACE PARAM SET [PO:xx,yy,...]     Set Tracer parameters
                [SIZE:val][DATA:val]
                [CMD:val]
                [LSN:hex-val][TYPE:val]
TRACE SAVE <file>                  Save trace on disk in <file> file
TRACE START [DATA:val][CMD:val]    Run Tracer
            [LSN:hex-val][TYPE:val]
TRACE STOP                         Stop Tracer

TRACE CLEAR | Clear Trace (Administrator)
 | TRACE CLEAR

It clears the content of the internal events trace previously executed.

Before executing this command, the trace function has to be stopped, by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

If the trace is not active, the message "TRACE INACTIVE" will be shown.

TRACE DELETE | Delete Trace file (Administrator)
 | TRACE DELETE <filename>

This commands allow to delete trace saved on disk in <filename> file.

NoFloppyBasedSystem The command is available on HD/CF based system only.

If the "filename" file is not found, the message "FILE 'namefile' NOT FOUND" will be shown.

Before being deleted, the <filename> file is checked to verify that it corresponds to an Abilis CPX trace file.

[10:33:34] ABILIS_CPX: TRACE DELETE dhcp.bnd

TRACE FILE 'DHCP.BND' BAD FORMAT

Trace can be saved on disk in a file using the command TRACE SAVE.

TRACE DISPLAY | Display Trace (Administrator)
 | TRACE DISPLAY [ST:val o LE:val] [PO:xxx,...] [LSN:val] [TYPE:val]

It shows, in a short format, the content of the internal events trace, previously saved. Only the events of data sending and receiving are displayed.

The optional parameters "ST:", "LE:", "PO:", "LSN:", "TYPE:" make possible the activation of filters on the events traced:

Option | Meaning
ST: | Only the events occurred after the specified time (in milliseconds) will be displayed.
LE: | Only the "LE:" number of events (starting from the end of the trace) will be displayed.
PO: | Only events related to the specified list of ports (max. 50 values in the range [0 - 999]) will be displayed.
LSN: | Only events of the specified type will be displayed.
TYPE: | Only events related to data and/or voice traffic and/or link check will be displayed.

If the trace buffer is empty or got empty by the command TRACE CLEAR, the message "TRACE EMPTY" will be shown.

Before executing this command, the trace function has to be stopped, by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

If the trace is not active, the message "TRACE INACTIVE" will be shown.

By typing the string "TRACE DISPLAY ?", an informative message about command syntax will be shown.

For example:

[16:28:48] ABILIS_CPX: TRACE DISPLAY ?

TRACE DISPLAY [ST:val or LE:val]   Display trace of sent and received data
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]
TRACE DISPLAY EXTENDED             Display trace of all commands
              [ST:val or LE:val]
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]

ST:             Event time from which to start the display    <Optional>
LE:             Number of the last events to be displayed     <Optional>
PO:             Ports value for the events to be displayed    <Optional>
LSN:            Lsn for the events to be displayed (Hex.)     <Optional>
TYPE:           Data type for the events to be displayed      <Optional>

This command is also available in the off-line configurator. In this case, the command syntax is:

TRACE DISPLAY filename [ST:val o LE:val] [PO:xxx,...] [LSN:val] [TYPE:val]

And it will show, in a short format, only the events of data sending and receiving saved on the file "filename".

The optional parameters "ST:", "LE:", "PO:", "LSN:", "TYPE:" work in the same way, as already described.

TRACE DISPLAY EXTENDED | Display Trace in Extended format (Administrator)
 | TRACE DISPLAY EXTENDED [ST:val o LE:val] [PO:xxx,...][LSN:val] [TYPE:val]

It shows, in an extended format, the content of the internal events trace, previously saved.

The optional parameters "ST:", "LE:", "PO:", "LSN:", "TYPE:" make possible the activation of filters on the events traced:

Option | Meaning
ST: | Only the events occurred after the specified time (in milliseconds) will be displayed.
LE: | Only the "LE:" number of events (starting from the end of the trace) will be displayed.
PO: | Only events related to the specified list of ports (max. 50 values in the range [0 - 999]) will be displayed.
LSN: | Only events of the specified type will be displayed.
TYPE: | Only events related to data and/or voice traffic and/or link check will be displayed.

If the trace buffer is empty or got empty by the command TRACE CLEAR, the message "TRACE EMPTY" will be shown.

Before executing this command, the trace function has to be stopped, by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

If the trace is not active, the message "TRACE INACTIVE" will be shown.

By typing the string "TRACE DISPLAY EXTENDED ?", an informative message about command syntax will be shown.

For example:

[16:28:48] ABILIS_CPX: TRACE DISPLAY EXTENDED ?

TRACE DISPLAY [ST:val or LE:val]   Display trace of sent and received data
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]
TRACE DISPLAY EXTENDED             Display trace of all commands
              [ST:val or LE:val]
              [PO:xx,...][LSN:hex-val]
              [TYPE:val]

ST:             Event time from which to start the display    <Optional>
LE:             Number of the last events to be displayed     <Optional>
PO:             Ports value for the events to be displayed    <Optional>
LSN:            Lsn for the events to be displayed (Hex.)     <Optional>
TYPE:           Data type for the events to be displayed      <Optional>

This command is also available in the off-line configurator. In this case, the command syntax is:

TRACE DISPLAY filename [ST:val o LE:val] [PO:xxx,...] [LSN:val] [TYPE:val]

And it will show, in a short format, only the events of data sending and receiving saved on the file "filename".

The optional parameters "ST:", "LE:", "PO:", "LSN:", "TYPE:" work in the same way, as already described.

TRACE GET | Get Trace (Administrator)
 | TRACE GET [1K] [ST:val][LEN:val] o [LAST:val]

It transfer the content of the internal events trace, previously saved by Abilis CPX to a remote destination, by using the X-Modem protocol. Option "1K" activates file transferring through the X-Modem 1K protocol.

By default, the whole content of the trace, starting from the beginning of the saving, it is transferred. it is also possible, by using the proper optional parameter, to transfer only a part of the content:

Option | Meaning
ST: | Offset value (in bytes) where to start sending the trace content from. This parameter can be used alone or together with the parameter "LEN:", for selecting the exact part of the content the User wants to transfer. In such way the whole trace transferring is avoided. The parameter generates a conflict if used with "LAST:".
LEN: | Buffer size (in KB) of the trace to be transferred. The value has to be considered from the beginning of the trace or from the offset set by the parameter "ST:". This parameter can be used alone or together with the parameter "ST:", for selecting the exact part of the content the User wants to transfer. In such way the whole trace transferring is avoided. The parameter generates a conflict if used with "LAST:".
LAST: | This parameter set the buffer size (in KB, starting from the end of the trace) that is going to be transferred. This parameter generates conflicts if used with the parameters "ST:" and "LEN:".

If the trace buffer is empty or got empty by the command TRACE CLEAR, the message "TRACE EMPTY" will be shown.

Before executing this command, the trace function has to be stopped, by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

If the trace is not active, the message "TRACE INACTIVE" will be shown.

The transfer procedure signals its availability to transfer the trace file by the message "READY TO SEND TRACE BUFFER..."

When the transfer is completed the following message is shown: "TRACE BUFFER TRANSFER ENDED, PRESS <ENTER> TO CONTINUE...", after pressing the <ENTER> button, an informative message, "TRACE BUFFER TRANSFER SUCCESSFULLY COMPLETED", will be shown if it was successful.

By typing the string "TRACE GET ?", an informative message about command syntax will be shown.

For example:

[16:53:08] ABILIS_CPX: TRACE GET ?

TRACE GET [1K]                     Transfer trace using X-Modem or X-Modem 1K
          [ST: and/or LEN:] or [LAST:]

1K              Use the X-Modem 1K transfer protocol           <Optional>
ST:             Trace buffer start value [in Kbytes]          <Optional>
LEN:            Number of Kbytes to be transmitted, starting
                from the beginning of the Tracer buffer or
                from the "ST:" value                          <Optional>
LAST:           Number of Kbytes to be transmitted, starting
                from the end of the Tracer buffer             <Optional>

TRACE INACT | Deactivate Trace (Administrator)
 | TRACE INACT

This command deactivates the internal events trace, previously activated.

If the trace has not been activated, the message "TRACE INACTIVE" will be shown, while if it was already inactive the following will be displayed "TRACE ALREADY INACTIVE".

If the trace is running, the message "TRACE RUNNING" will be shown.

TRACE PARAM | Display Trace parameters (Administrator)
 | TRACE PARAM

It shows the parameters settings of the internal events trace and its working mode.

The information shown will depend on the trace state. For example, if the trace is not active, information about its content and length will not be shown.

In the following example, the command is executed, and the trace is active (STATE ACTIVE/READY):

[12:09:18] ABILIS_CPX: TRACE PARAM

        Configured Value       Active Value           Description
------------------------------------------------------------------------------
PO:     NONE                   NONE                   Ports to be traced
SIZE:   100  (Kbytes)          100  (Kbytes)          Tracer buffer size
DATA:   60   (bytes)           60   (bytes)           Max. event buffer size
CMD:    STD                    STD                    Command(s) to be traced
LSN:    ALL                    ALL                    SD/RV lsn to be traced
TYPE:   ALL                    ALL                    SD/RV type to be traced
STATE:  -                      INACTIVE               Current Tracer state

By typing the string "TRACE PARAM ?", an informative message about "TRACE PARAM" command syntax and options will be shown.

For example:

[16:55:06] ABILIS_CPX: TRACE PARAM ?

TRACE PARAM                        Display Tracer configured parameters, active
                                   parameters and the current Tracer state
TRACE PARAM SAVE                   Save current Tracer parameters values
TRACE PARAM SET [PO:xx,yy,...]     Set Tracer parameters
                [SIZE:val][DATA:val]
                [CMD:val]
                [LSN:hex-val][TYPE:val]

TRACE PARAM SAVE | Save Trace parameters (Administrator)
 | TRACE PARAM SAVE

It saves the parameters settings of the internal events trace function, previously activated. Those settings can be used for further activations of the traces. The saved values can be shown by using the command TRACE PARAM.

If the trace has not been activated, the following message will be shown: "TRACE INACTIVE".

TRACE PARAM SET | Set Trace saved parameters (Administrator)
 | TRACE PARAM SET [PO:val] [SIZE:val] [DATA:val] [CMD:val] [LSN:val] [TYPE:val]

This command modifies the trace saved parameters that will be used for further activations of the trace.

The saved values can be shown by using the command TRACE PARAM.

If the trace has not been activated, the following message will be shown: "TRACE INACTIVE".

Parameter | Meaning
PO: | List of ports to be traced (min.1, max. 50).
SIZE: | Trace buffer size (Kbyte) [3 Kb - 8 Mb].
DATA: | Maximum allocable memory size for saving a single event (byte) [10 - 2100 byte].
CMD: | Command type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]
LSN: | Local session number to be traced [ALL, 0000..FFFE (Hex.)]
TYPE: | Data type to be traced [DATA, CHK, VOICE]

By typing the string "TRACE PARAM SET ?", an informative message about the command syntax and options will be shown.

For example:

[16:56:56] ABILIS_CPX: TRACE PARAM SET ?

[19:09:50] ABILIS_CPX:trace param set ?

TRACE PARAM SET [PO:xx,yy,...]     Set Tracer parameters
                [SIZE:val][DATA:val]
                [CMD:val]
                [LSN:hex-val][TYPE:val]

PO:             Ports to be traced (max. 50)                        <Optional>
SIZE:           Tracer buffer size [3Kb..8Mb]                       <Optional>
DATA:           Max event buffer size [10..2100 bytes]              <Optional>
CMD:            Commands type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]  <Optional>
LSN:            SD/RV lsn to be traced [ALL, 0000..FFFE (Hex.)]     <Optional>
TYPE:           SD/RV type to be traced [ALL, DATA, CHK, VOICE]     <Optional>

TRACE SAVE | Save Trace in a file on disk (Administrator)
 | TRACE SAVE <filename>

This command allows to save the content of the internal events trace in the <filename> file on the disk.

NoFloppyBasedSystem The command is available on HD/CF based system only.

Before executing this command, the trace function has to be stopped, by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

If the trace is not active, the message "TRACE INACTIVE" will be shown.

Trace files saved on the disk and no longer useful can be deleted by the command TRACE DELETE.

TRACE START | Start Trace (Administrator)
 | TRACE START [DATA:val] [CMD:val] [LSN:val] [TYPE:val]

This command starts saving the events exchanged among the ports specified in the list, which has been defined during the trace activation (through the command TRACE ACT). If in the command row is not indicated any additional parameter, the trace will start using the settings defined during its activation. The following optional parameters can be specified "LSN:", "DATA:", "TYPE:", "CMD:". In this way trace parameters setting may be edited again.

Parameter | Meaning
DATA: | Maximum allocable memory for saving each single event [10 - 2100 byte].
CMD: | Command type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]
LSN: | Local session number to be traced [ALL, 0000..FFFE (Hex.)]
TYPE: | Data type to be traced [DATA, CHK, VOICE]

If the trace function has not been already activated, use the command TRACE ACT for doing it. If the trace is not active the following message will be displayed "TRACE INACTIVE".

If the trace function is running, it has to be stopped by using the command TRACE STOP, otherwise the message "TRACE RUNNING" will be displayed.

By typing the string "TRACE START ?", an informative message about the command syntax and options will be shown.

For example:

[17:02:28] ABILIS_CPX: TRACE START ?

TRACE START [DATA:val][CMD:val]    Run Tracer
            [LSN:hex-val][TYPE:val]

DATA:           Max event buffer size [10..2100 bytes]              <Optional>
CMD:            Commands type [RSP, RSA, STD, EIRSIG, FR-LMI, ALL]  <Optional>
LSN:            SD/RV lsn to be traced [ALL, 0000..FFFE (Hex.)]     <Optional>
TYPE:           SD/RV type to be traced [ALL, DATA, CHK, VOICE]     <Optional>

TRACE STOP | Stop Trace (Administrator)
 | TRACE STOP

This command stop tracing the events and stores the trace content until the next trace start, through the command TRACE START or the deactivation of the function (command TRACE INACT.

If the trace is not active the following message will be displayed "TRACE INACTIVE".

If the trace function is not running, the message "TRACE NOT RUNNING" will be displayed.

DEBUG BM | Display Boot Manager file (Administrator)
 | DEBUG BM

It shows the current content of the Boot Manager configuration file: BM.CFG.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[19:16:58] ABILIS_CPX: DEBUG BM

Boot Manager configuration file:

<BmCfg>
<CpxLastVer>4-3-1</CpxLastVer>
<CpxNewVer>4-6-0</CpxNewVer>
<CpxNewRuns>1</CpxNewRuns>
</BmCfg>

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

DEBUG CPXRUN | Display CPX run configuration file (Administrator)
 | DEBUG BM

It shows the current content of the CPX run configuration file: CPXRUN.CFG.

NoFloppyBasedSystem The command is available on HD/CF based system only.

[19:16:58] ABILIS_CPX: DEBUG CPXRUN

CPX Run configuration file:

<CpxRun>
<CpxNewVer>4-6-0</CpxNewVer>
<CpxRunning>true</CpxRunning>
</CpxRun>

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

DEBUG FILE | Debug file system (Administrator)
 | DEBUG FILE INFO DEBUG FILE STAT

It shows statistics about the file system.

[17:04:08] ABILIS_CPX: DEBUG FILE ?

INFO           Display RTF currently opened Files Table
STAT           Display RTF Buffer Statistics

If the option "INFO:" is used, information about statistics, related to the files currently in use, will be shown.

If the option "STAT:" is used, information about statistics, related to the buffers currently in use, will be shown.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

DEBUG IRQ | Debug interrupts (Administrator)
 | DEBUG IRQ

It shows statistics about the interrupts.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

Here is an example of the command execution.

[17:14:59] ABILIS_CPX: DEBUG IRQ

Irq information:

 IRQ    Calls  FreeStack  Doubles  Time
-------------------------------------------
   0   253542        432        0  -
   4        2        440        0  -
   6       20        448        0  -
   7    16724        352        0  -
   9    42257       1340        0  -
  10    30369        368        0  -
  12    11125       1344        0  -
  14      511        448        0  -
  15   228635      24828        0  -

DEBUG MEM | Debug memory (Administrator)
 | DEBUG MEM [-H][-D][START:val LEN:val]

It shows information about statistics related to the memory.

[17:05:40] ABILIS_CPX: DEBUG MEM ?

DEBUG MEM                     Display Memory information and statistics

DEBUG MEM -H                  Display Heap content
DEBUG MEM -D                  Display Heap allocated at drivers start-up
DEBUG MEM START:val LEN:val   Display Memory content

START:     Start address [0x00100000..0x7FFFFFFF]        <Mandatory>
LEN:       Length [1..4294967295]                        <Mandatory>

By using the "-H" option it is possible to show the content of the entire system heap.

By using the "-D" option it is possible to show the list of drivers and allocated heap at system start-up.

By using the parameters "START:" and "LEN:" it is possible to specify offset and buffer size of the memory to be displayed.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

Here is an example of the command execution.

[11:58:40] ABILIS_CPX: DEBUG MEM

Physical Memory:     67.108.864

Memory Status:

Free Memory:                  0
Used Memory:         60.604.416
-------------------------------
Total Memory:        60.604.416

Heap information:

Heap status:                 Ok

Free Heap:           40.709.924
Used Heap:           19.144.396
-------------------------------
Total Heap:          59.854.320
Largest Free block:  40.450.676
Largest Used block:      79.804

DEBUG PO: | Debug Port (Administrator)
 | DEBUG PO:xxx [SIZE:] [LSN:] [CMD:]

It shows debugging information about the specified ports.

[17:16:55] ABILIS_CPX: DEBUG PO: ?

DEBUG PO:val [par:val]        Display debug information of the specified port

Additional parameters:

SIZE:      Select debug buffer size [7..63 Kbytes]                 <Optional>
LSN:       Lsn value [0..65534(dec) or 0000..0FFFE(hex), A]        <Optional>
CMD:       Command string (es.: CMD:str or CMD:'str1 str2 ...']    <Optional>

Data are stored in a 6 KB size buffer. Depending on the port type, where the command is executed on, this buffer could not be enough and at the end of the visualization the following message will be displayed "INCOMPLETE INFORMATION: BUFFER SIZE TOO SHORT".

By using the option "SIZE:", User can eventually increase the maximum buffer size used by the command. The indicated value (in KB) must be in the interval [6 - 63].

By using the options "LSN:" and "CMD:" it is possible to select the type of debugging information to be displayed.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

DEBUG SIMULATE | Simulate an event for debugging purposes (Administrator)
 | DEBUG SIMULATE EVENT:val

This command simulates an event for debugging purposes.

The purpose of the command is strictly technical, Abilis CPX technicians could need it for detecting and solving eventual problems.

Currently supported event simulations are: "XCP", i.e. a sw exception, and "WDL", i.e. WDLIVE1 events.

warning! Both these events will cause the system to be restarted, then be careful in executing the present command.

DEBUG TASK | Debug Task (Administrator)
 | DEBUG TASK [SIZE:] [F:] [ALL]

It shows debugging information about tasks.

[17:16:59] ABILIS_CPX: DEBUG TASK ?

DEBUG TASK [par:val]          Display Tasks information and statistics

Additional parameters:

SIZE:      Debug buffer size [64..1024 Kbytes]                      <Optional>
F:         Filtering string for task name (max. 20 chars)           <Optional>
           Strings holding spaces must be written between quotation
           marks (Ex.: F:"str1 str2 str3")
ALL        Request all available debug information                  <Optional>

Statistics are stored in a 64 Kbyte size buffer. Depending on the configuration and system equipment, this buffer could not be enough so that at the end of the visualization the following message will be displayed: "Out of string space", meaning that it wasn't possible to collect all the needed information.

By using the option "SIZE:", User can eventually increase the maximum buffer size used by the command. The indicated value (in Kbyte) must be in the interval [64 - 1024].

For each process present in the system, the command will display a row.

Moreover, by using the option "F:", User can request to display only those rows, which have the specified test string. Strings holding spaces must be written between quotation marks.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems.

Here is an example of the command execution.

[17:20:33] ABILIS_CPX: DEBUG TASK F:"IPR:LNK Init"

Total Number of Tasks:766
Tasks information:

Name            Prio State      R.Del  MStck Scheds  CT% WaitingAt
------------------------------------------------------------------------
IPR:LNK InitIpp    2 BlckdWait          4108      1  -   IPR IPP Init
IPR:LNK InitIpp    2 BlckdWait          4048      3  -   IPR LNK Filt State

DEBUG WDGMEM | Debug Watchdog memory (Administrator)
 | DEBUG WDGMEM [OFFSET:val] [SIZE:val]

Display statistics information saved in case of system critical situation detected by the Watchdog.

Shown information is strictly technical so meaningless for the User, Abilis CPX technicians could need it for detecting and solving eventual problems. Here there a sample:

[17:04:13] ABILIS_CPX: DEBUG WDGMEM

Watchdog memory content (Offset:0, Size:128):

 Address |             Hexadecimal values                  |  Ascii values
---------+-------------------------------------------------+-----------------
00000000 | 31 34 2F 30 34 2F 32 30 30 34 20 32 33 3A 33 37 | 14/04/2004 23:37
00000010 | 3A 30 33 20 2D 20 4C 61 73 74 20 54 68 72 65 61 | :03 - Last Threa
00000020 | 64 20 49 6E 66 6F 20 2D 20 48 61 6E 64 6C 65 3A | d Info - Handle:
00000030 | 30 31 36 33 39 30 43 34 2C 20 4E 61 6D 65 3A 43 | 016390C4, Name:C
00000040 | 50 2D 53 65 6E 64 65 72 2D 53 65 73 3A 31 2C 20 | P-Sender-Ses:1,
00000050 | 53 74 61 74 65 3A 55 4E 4B 4E 4F 57 4E 2C 20 52 | State:UNKNOWN, R
00000060 | 6F 75 74 69 6E 65 3A 30 30 33 43 43 31 31 46 20 | outine:003CC11F
00000070 | 5B 51 4F 55 45 3A 30 30 31 31 38 35 31 43 5D 2E | [QOUE:0011851C].


Commands related to Users Access Control table

Users Access Control table

Other commands

Users Access Control table top

A USER: | Add User entry (Administrator)
 | A USER:username [par:val]

This command adds a new entry in the Users Access Control Table with "USER:" parameter equal to "username" and, eventually, it sets the indicated parameters to the specified values.

There can be up to 151 entries in the Users Access Control Table, each of one is unambiguously identified by the "USER:" parameter value. The table is alphabetically sorted on the base of the "USER:" parameter value and it is automatically resorted each time an entry is added or removed.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. Case is preserved.

There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

Two or more entries with the same "USER:" value cannot be defined. If an entry with the specified "USER:username" already exists in the table, the following message is generated "USER ALREADY EXISTS".

If the table is full and a new entry is going to be added, then an error message will be displayed "USERs ACCESS CONTROL TABLE IS FULL, COMMAND NOT EXECUTED"

Changes made on the Users Access Control Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

C USER: | Clear User entry (Administrator)
 | C USER:username

This command removes from the Users Access Control Table the entry identified by the specified user name value. Because the table is alphabetically sorted on the base of the "USER:" parameter value, it is automatically resorted as soon as the entry is removed.

The "USER:" parameter identifies unambiguously an entry in the system. Two or more entries with the same "USER:" value cannot be present in the same time in the table.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. Case is preserved.

There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

If the indicated user name does not match an already existing entry, the following message will be displayed "USER NOT PRESENT".

If the table is empty, the following message is generated: "USERs ACCESS CONTROL TABLE IS EMPTY".

Changes made on the Users Access Control Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

D USER | Display Users Access Control table summary (User)
 | D USER

This command shows the content of the Users Access Control Table in a synthetic format.

All the users defined with their most important configuration information are displayed.

Here is an example of the information shown by the command:

[12:18:37] ABILIS_CPX: D USER

- Not Saved (SAVE CONF) -------------------------------------------------------

USER:                             PASSWORD:  ENABLED: PPP: FTP: HTTP:
------------------------------------------------------------------------------
admin                                        NO       YES  YES  YES
Leo                                          YES      YES  YES  YES
Konstantin                        *********  YES      NO   YES  YES
test                                         YES      YES  NO   NO

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

For a detailed description of the information displayed, please refer to Configuration of Users Access Control table section of Users Access Control table.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

D USER: | Display User entry in synthetic format (User)
 | D USER:username

This command shows the Users Access Control Table entry identified by the "USER:username" in a synthetic format, i.e. the parameters of the services that are not enabled are omitted.

The "USER:" parameter identifies unambiguously an entry in the system. Two or more entries with the same "USER:" value cannot be present in the same time in the table.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. Case is preserved.

There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

If the indicated user name does not match an already existing entry, the following message will be displayed "USER NOT PRESENT".

Here is an example of the information shown by the command:

[15:45:19] ABILIS_CPX: D USER:Konstantin

Parameter    |Value
-------------------------------------------------------------------------------
USER:         Konstantin
PASSWORD:     *********
ENABLED:      YES
FTP:          YES
FTP-HOMEDIR:  /user/konstt/
FTP-PROT:     PLAIN,SSL
HTTP:         YES
-------------------------------------------------------------------------------

As it can be seen from the previous example, the parameters of the services that are not enabled are omitted.

For a detailed description of the displayed information, please refer to Configuration of Users Access Control table section of Users Access Control table.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

D USERE | Display Users Access Control table in extended format (User)
 | D USERE

This command shows the content of the Users Access Control Table in extended format, i.e. all the users defined with their full set of configuration information are displayed.

Here is an example of the information shown by the command:

[15:18:36] ABILIS_CPX: D USERE

- Not Saved (SAVE CONF) -------------------------------------------------------

Parameter:   |Value:
------------------------------------------------------------------------------
USER:         admin
PASSWORD:
ENABLED:      NO
PPP:          YES
PPP-AUTH:     CHAP
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:
FTP-PROT:     PLAIN,SSL
HTTP:         YES
------------------------------------------------------------------------------
USER:         test
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     ALL
PPP-PO:       541
FTP:          NO
FTP-HOMEDIR:
FTP-PROT:     PLAIN,SSL
HTTP:         NO
------------------------------------------------------------------------------

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

For a detailed description of the information displayed, please refer to Configuration of Users Access Control table section of Users Access Control table.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

D USERE: | Display User entry in extended format (User)
 | D USERE:username

This command shows the Users Access Control Table entry identified by the "USER:username" in an extended format.

The "USER:" parameter identifies unambiguously an entry in the system. Two or more entries with the same "USER:" value cannot be present in the same time in the table.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. Case is preserved.

There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

If the indicated user name does not match an already existing entry, the following message will be displayed "USER NOT PRESENT".

Here is an example of the information shown by the command:

[15:18:38] ABILIS_CPX: D USERE:test

Parameter:   |Value:
------------------------------------------------------------------------------
USER:         test
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     ALL
PPP-PO:       541
FTP:          NO
FTP-HOMEDIR:
FTP-PROT:     PLAIN,SSL
HTTP:         NO
------------------------------------------------------------------------------

For a detailed description of the information displayed, please refer to Configuration of Users Access Control table section of Users Access Control table.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

S USER: | Set User entry (Administrator)
 | S USER:username par:val [par:val]

It sets to new values the parameters of the Users Access Control Table entry specified by "USER:username".

The "USER:" parameter identifies unambiguously an entry in the system. Two or more entries with the same "USER:" value cannot be present in the same time in the table.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. Case is preserved.

There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

If the indicated user name does not match an already existing entry, the following message will be displayed "USER NOT PRESENT".

If the table is empty, the following message is generated: "USERs ACCESS CONTROL TABLE IS EMPTY".

The parameters list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost.

If a parameter is bad or its value out of the allowed range or if it is in conflict with the current value of any other parameter, then the command evaluation will terminate: all the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

For a detailed description of the user's entry parameters, please refer to Configuration of Users Access Control table section of Users Access Control table.

Changes made on the Users Access Control Table are immediately active, they do not require any initialization command to be operative.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".

F USER | Find entry in Users Access Control table (User)
 | F USER:username PPP [port] F USER:username FTP F USER:username HTTP

It allows to verify the presence of a certain user in the Users Access Control Table by the specification of a "username" value.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. The search i case insensitive, i.e. there is no difference between lower case and uppercase characters.

In addition the command checks the acceptance of the specified user by the specified protocol/service:

  • PPP protocol/service: the command verify whether the user will be accepted by PPP driver.
    Optionally also the port number can be specified. The "port" value must be in the interval [0 - 999].
  • FTP protocol/service: the command verify whether the user will be accepted by FTP driver.
    No optional parameters.
  • HTTP protocol/service: the command verify whether the user will be accepted by HTTP driver.
    No optional parameters.

The following example show possible results of the command:

[16:14:43] ABILIS_CPX: D USER:A

Parameter:   |Value:
------------------------------------------------------------------------------
USER:         admin
PASSWORD:
ENABLED:      NO
PPP:          YES
PPP-AUTH:     CHAP
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:
FTP-PROT:     PLAIN,SSL
HTTP:         YES
------------------------------------------------------------------------------
USER:         my_user
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     CHAP
PPP-PO:       542
------------------------------------------------------------------------------
USER:         user_1
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     CHAP
PPP-PO:       541
------------------------------------------------------------------------------
USER:         user_2
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     PAP
PPP-PO:       541
------------------------------------------------------------------------------
USER:         user_3
PASSWORD:
ENABLED:      YES
PPP:          YES
PPP-AUTH:     CHAP,PAP
PPP-PO:       542
------------------------------------------------------------------------------

[16:14:48] ABILIS_CPX: F USER:user_1 PPP 542

USER NOT FOUND

[16:15:06] ABILIS_CPX: F USER:user_1 PPP 541

USER FOUND

[16:17:44] ABILIS_CPX: F USER:user_1 FTP

USER NOT FOUND

If the Abilis CPX version, currently in use, does not support Users Service, the following message will be shown "USERs ACCESS CONTROL SERVICE NOT PRESENT".


Commands relating to the Analogue VOICE Router

Fxs/Fxo VOICE routings
Fxs/Fxo VOICE groups
Data ports for Fxs/Fxo VOICE connections
Fxs/Fxo VOICE connections
Tone Trace
Initialization commands

Other commands

Fxs/Fxo VOICE Routing top

A VR | Add Voice routing (Administrator)
 | A VR ID:xx [par:val]

It adds a new entry to the table of Fxs/Fxo VOICE routings in the "ID:xx" position. The command can also set eventually indicated parameters to the specified values. Not specified parameters are set to default values.

The table of Fxs/Fxo VOICE routings can store up to 64 entries, therefore the routing identifier value must be in the interval [0 - 63]. The table is not automatically maintained with consecutive indexes, then Fxs/Fxo VOICE routing definitions may not have sequential identifiers.

If an entry with the same identifier is already present in the table, is going to be added, the "VOICE ROUTING ALREADY EXISTS" error message will be shown.

If the table of Fxs/Fxo VOICE routings is full and a new routing is asked to be added, an error message is generated: "VOICE ROUTING TABLE IS FULL, COMMAND NOT EXECUTED".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of Fxs/Fxo VOICE routings are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

C VR | Clear Voice routing (Administrator)
 | C VR ID:xx

It deletes the specified entry from the table of Fxs/Fxo VOICE routings. The routing identifier must be in the interval [0 - 63].

If the requested entry is not present in the table, the following error message will be displayed: "VOICE ROUTING NOT PRESENT".

Fxs/Fxo VOICE routings, whose identifier is higher than the deleted one, are not decremented because of table contiguity. So, the deleted definition frees a place in the table of Fxs/Fxo VOICE routings, which won't be displayed by the command D VR.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of Fxs/Fxo VOICE routings are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

D VR | Display Voice routing (Administrator)
 | D VR D VR ID:xx

It shows the table of Fxs/Fxo VOICE routings.

If the identifier is omitted, the command will show all the Fxs/Fxo VOICE routings currently set.

Fxs/Fxo VOICE routing definitions may not have sequential identifiers, that 's the not shown values represent the free places in the table.

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D VR

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

ID:  NUM:  NUMO:  GROUP:   POO:
---------------------------------
0    1     *           #    501
1    2     *           #    501
4    160   *           #     60
5    162   *           #     62

By specifying the Fxs/Fxo VOICE routing identifier, the command will show only the requested routing.

The identifier must be in the interval [0 - 63]. If the requested entry is not present in the table, the message "VOICE ROUTING NOT PRESENT" will be generated.

If the table of Fxs/Fxo VOICE routings is empty, the following message will be shown "*** NO VOICE ROUTINGs DEFINED ***".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

For a more detailed description of the shown information, refer the Configuration of Fxs/Fxo VOICE connections section.

S VR | Set Voice routing (Administrator)
 | S VR ID:xx par:val [par:val]

It sets parameters of the specified Fxs/Fxo VOICE routing to their new values.

The specified Fxs/Fxo VOICE routing identifier value must be in the interval [0 - 63]. If the specified routing is not present in the table, the message "VOICE ROUTING NOT PRESENT" is generated.

If the table of Fxs/Fxo VOICE routings is empty, the following message will be displayed "VOICE ROUTING TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the table of Fxs/Fxo VOICE routings are not immediately active. For activating them, it is needed to execute the initialization command INIT VR

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Fxs/Fxo VOICE Groups top

A VG | Add Voice group (Administrator)
 | A VG ID:xx [par:val]

It adds a new entry to the table of Fxs/Fxo VOICE groups. The command can also set the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

The table of Fxs/Fxo VOICE groups can store up to 15 entries, therefore the specified group identifier must be in the interval [1 - 15]. The group definitions may not have sequential identifiers.

If an entry with the same identifier "ID:xx" is already present in the table, the "VOICE GROUP ALREADY EXISTS" error message will be shown.

If the table of Fxs/Fxo VOICE groups is full and a new entry is going to be added, an error message is generated: "VOICE GROUP TABLE IS FULL, COMMAND NOT EXECUTED".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of Fxs/Fxo VOICE groups are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

C VG | Clear Voice group (Administrator)
 | C VG ID:xx

It deletes the specified entry from the table of Fxs/Fxo VOICE groups. Specified identifier "ID:xx" must be in the interval [0 - 15].

If the specified group is not present in the table, the following error message will be displayed: "VOICE GROUP NOT PRESENT".

Fxs/Fxo VOICE groups, whose identifier is higher than the deleted one, are not decremented because of table contiguity. So, the deleted entry frees place in the table, which won't be displayed by the command D VG.

If the table of Fxs/Fxo VOICE groups is empty, the following message will be displayed "VOICE GROUP TABLE IS EMPTY".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of Fxs/Fxo VOICE groups are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

D VG | Display Voice group (User)
 | D VG D VG ID:x

It shows the table of Fxs/Fxo VOICE groups.

If the identifier is omitted, the command will show all the Fxs/Fxo VOICE groups currently set.

Fxs/Fxo VOICE group definitions may not have sequential identifiers, that is the not shown values represent the free places in the table.

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D VG

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

ID          |1   2   3   4   5  |6  7  8  9  10 |11 12 13 14 15 |16 17 18 19 20
------------|-------------------|---------------|---------------|--------------
1  VS:R VPx:|60  61  62  63  .  |.  .  .  .  .  |.  .  .  .  .  |.  .  .  .  .
   DS:R DPx:|1   2   .   .      |               |               |
------------|-------------------|---------------|---------------|--------------
3  VS:R VPx:|.   .   .   .   .  |.  .  .  .  .  |.  .  .  .  .  |.  .  .  .  .
   DS:R DPx:|.   .   .   .      |               |               |
------------|-------------------|---------------|---------------|--------------

By specifying a Fxs/Fxo VOICE group identifier, the command will show only the requested entry.

The identifier must be in the interval [0 - 15]. If the requested entry is not present in the table, the message "VOICE GROUP NOT PRESENT" will be generated.

If the table of Fxs/Fxo VOICE groups is empty, the following message will be shown "*** NO VOICE GROUPs DEFINED ***".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

For a more detailed description of the shown information, refer the Configuration of Fxs/Fxo VOICE groups section.

S VG | Set Voice group (Administrator)
 | S VG ID:xx par:val [par:val]

It sets parameters of the specified Fxs/Fxo VOICE group to their new values.

The identifier must be in the interval [0 - 15]. If the requested entry is not present in the table, the message "VOICE GROUP NOT PRESENT" will be generated.

If the table of Fxs/Fxo VOICE groups is empty, the following message will be shown "VOICE GROUP TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the table of Fxs/Fxo VOICE groups are not immediately active. For activating them, it is needed to execute the initialization command INIT VR

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Data ports for Fxs/Fxo VOICE connections top

A VD | Add Voice data port (Administrator)
 | A VD ID:xx [par:val]

It adds a new entry to the table of data ports for Fxs/Fxo VOICE connections. The command can also set the eventually indicated parameters to the specified values. Not specified parameters are set to default values.

The table of data ports for Fxs/Fxo VOICE connections can store up to 32 entries. Therefore the specified identifier must be in the interval [0 - 31]. The definitions of Data ports for Fxs/Fxo VOICE connections may not have sequential identifiers

If an entry with the same identifier is already present in the table, the "VOICE DATA PORT ALREADY EXISTS" error message will be shown.

If the table of data ports for Fxs/Fxo VOICE connections is full and a new entry is going to be added, an error message is generated: "VOICE DATA PORT TABLE IS FULL, COMMAND NOT EXECUTED".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of data ports for Fxs/Fxo VOICE connections are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

C VD | Clear Voice data port (Administrator)
 | C VD ID:xx

It deletes the specified entry from the table of data ports for Fxs/Fxo VOICE connections.

The specified identifier must be in the interval [0 - 31].

VOICE data ports, whose identifier is higher than the deleted one, are not decremented because of table contiguity. So, the deleted entry frees place in the table, which won't be displayed by the command D VD.

If the requested entry is not present in the table, the following error message will be displayed: "VOICE DATA PORT NOT PRESENT".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Changes made on the table of data ports for Fxs/Fxo VOICE connections are not immediately active. For activating them, it is needed to execute the initialization command INIT VR.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

D VD | Display Voice data port (User)
 | D VD D VD ID:xx

It shows the table of data ports for Fxs/Fxo VOICE connections.

If the identifier is omitted, the command will show all the data ports for Fxs/Fxo VOICE connections currently set.

The definitions of data ports for Fxs/Fxo VOICE connections may not have sequential identifiers, that is the not shown values represent the free places in the table.

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D VD

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

ID:   PO:   MXBW:    CURBW:
-----------------------------------
0     501    NOMAX        0
1     502    64000    15600
3    NONE    NOMAX        -

By specifying the identifier of a data port for Fxs/Fxo VOICE connections, the command will show only the requested entry.

The identifier must be in the interval [0 - 31]. If the requested entry is not present in the table, the message "VOICE DATA PORT NOT PRESENT" will be generated.

If the table of data ports for Fxs/Fxo VOICE connections is empty, the following message will be shown "*** NO VOICE DATA PORTs DEFINED ***".

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

For a more detailed description of the shown information, refer the Configuration of DATA ports for VOICE connections section.

S VD | Set Voice data port (Administrator)
 | S VD ID:xx par:val [par:val]

It sets parameters of the specified data port for Fxs/Fxo VOICE connections to their new values.

The identifier value must be in the interval [0 - 31]. If the specified entry is not present in the table, the message "VOICE DATA PORT NOT PRESENT" is generated.

If the table of data ports for Fxs/Fxo VOICE connections is empty, the following message will be shown "VOICE DATA PORT TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter (s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

Changes made on the table of Fxs/Fxo VOICE data ports are not immediately active. For activating them, it is needed to execute the initialization command INIT VR

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

The "Not Refreshed (INIT)" message is displayed every time the table is modified but not refreshed with the INIT VR command.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Fxs/Fxo VOICE connections top

C VC | Clear Voice connection (Administrator)
 | C VC ID:x

It forces to clear the specified Fxs/Fxo VOICE connection.

If the requested Fxs/Fxo VOICE connection is not present, the error message "VOICE CONNECTION NOT PRESENT" will be shown.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

D VC | Display Voice connections status (User)
 | D VC

It shows the Fxs/Fxo VOICE connections that are currently present.

If no Fxs/Fxo VOICE connection is present, the message "NO VOICE CONNECTIONS" is generated.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D VC

ID Numi Numo  Poi Chi    State    Grp Poo Cho  VrID    Sp      Bw
-- ---- ----  --- ---  ---------  --- --- ---  ----  ------  ------
0   555  666   60   1  BUSY         1  63   -     0       0       0
1   2    2     61   1  CONNECTED      502   1     4    4800    6200
2   376  20   501   1  CONNECTED       61   2     2    6400    7800

For a more detailed description of the shown information, refer to the Vision of Fxs/Fxo VOICE connections status section.

Tone Trace top

C TT | Clear Tone Trace (Administrator)
 | C TT PO:xxx

It clears the Tone Trace on the requested port. The port identifier must be in the interval [0 - 999] and must correspond to a VOICE port currently present and running.

If the port is not a VOICE port, the error message "COMMAND NOT ALLOWED FOR THAT PORT" is shown.

If the requested port is not present or not properly running this error message will be generated: "PORT NOT PRESENT OR NOT RUNNING".

If the command is successful the following message will be shown: "COMMAND EXECUTED".

If Tone Trace has been activated through the command S TT, the message "TONE TRACE NOT READY" is generated.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

D TT | Display Tone Trace (User)
 | D TT PO:xxx

It shows the Tone Trace relating to the specified port. The port identifier must be in the interval [0 - 999] and must correspond to a VOICE port currently present and running.

If the port is not a VOICE port, the error message "COMMAND NOT ALLOWED FOR THAT PORT" is shown.

If the requested port is not present or not properly running this error message will be generated: "PORT NOT PRESENT OR NOT RUNNING".

If Tone Trace has been activated through the command S TT, the message "TONE TRACE NOT READY" is generated, while if it is still running and it has not been stopped by the command C TT, the following will be shown "TONE TRACE RUNNING".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

S TT | Set Tone Trace (Administrator)
 | S TT PO:xxx

It sets the Tone Trace on the specified port. The port identifier must be in the interval [0 - 999] and must correspond to a VOICE port currently present and running.

If the port is not a VOICE port, the error message "COMMAND NOT ALLOWED FOR THAT PORT" is shown.

If the requested port is not present or not properly running this error message will be generated: "PORT NOT PRESENT OR NOT RUNNING".

If the command is successful the following message will be shown: "COMMAND EXECUTED".

If the Tone Trace is running and it has not been stopped by the command C TT, the following message will be shown "TONE TRACE RUNNING".

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

Initialization commands top

INIT VR | Init Voice Router (User)
 | INIT VR

It reinitializes the Analogue VOICE Router by reloading the table of Fxs/Fxo VOICE routings, the table of Fxs/Fxo VOICE groups and the table of data ports for Fxs/Fxo VOICE connections.

If the command is successful, the message "COMMAND EXECUTED" will be shown.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

R ACB | Restart ACB card (User)
 | R ACB

It reinitializes the driver of the ACB board. If the command is successful, the message "RESTART ACB EXECUTED" will be shown.

If the Abilis CPX version, currently in use, does not support Fxs/Fxo VOICE service, the following message will be shown "VOICE SERVICE NOT PRESENT".

warning! This command works on the file present in the disk. If the disk is not present or a reading errors occur, the following message will be displayed "ERROR LOADING FILE 'xxxx', RESTART ACB NOT EXECUTED", where "xxxx" stands for the file that is needed for correct running of the ACB board.


Commands relating to the Wireless to G.703 Bridge

Wireless to G.703 Routings

Other commands

Wireless to G.703 Routings top

A WGB | Add Wireless to G.703 routing (Administrator)
 | A WGB ID:xx [par:val]

It adds a new entry to the table of Wireless to G.703 routings in the "ID:xx" position. The command can also set eventually indicated parameters to the specified values. Not specified parameters are set to default values.

The table of Wireless to G.703 routings can store up to 4 entries, therefore the routing identifier value must be in the interval [0 - 3]. The table is not automatically maintained with consecutive indexes, then Wireless to G.703 routing definitions may not have sequential identifiers.

If an entry with the same identifier is already present in the table, is going to be added, the "WG BRIDGE ROUTING ALREADY EXISTS" error message will be shown.

If the table of Wireless to G.703 routings is full and a new routing is asked to be added, an error message is generated: "WG BRIDGE ROUTINGS TABLE IS FULL, COMMAND NOT EXECUTED".

If the Abilis CPX version, currently in use, does not support Wireless to G.703 Bridge service, the following message will be shown "WG BRIDGE ROUTINGS SERVICE NOT PRESENT".

The table of Wireless to G.703 routings can be modified while the Abilis CPX is working, but they are not immediately active, to be activated they need the system to be restarted.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

C WGB | Clear Wireless to G.703 routing (Administrator)
 | C WGB ID:xx

It deletes the specified entry from the table of Wireless to G.703 routings. The routing identifier must be in the interval [0 - 3].

If the requested entry is not present in the table, the following error message will be displayed: "WG BRIDGE ROUTING NOT PRESENT".

If the table of Wireless to G.703 routings is empty, the following message will be shown "WG BRIDGE ROUTINGS TABLE IS EMPTY".

Wireless to G.703 routings, whose identifier is higher than the deleted one, are not decremented because of table contiguity. So, the deleted definition frees a place in the table of Wireless to G.703 routings, which won't be displayed by the command D WGB.

If the Abilis CPX version, currently in use, does not support Wireless to G.703 Bridge service, the following message will be shown "WG BRIDGE ROUTINGS SERVICE NOT PRESENT".

The table of Wireless to G.703 routings can be modified while the Abilis CPX is working, but they are not immediately active, to be activated they need the system to be restarted.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

D WGB | Display Wireless to G.703 routing (User)
 | D WGB D WGB ID:xx

It shows the table of Wireless to G.703 routings.

If the identifier is omitted, the command will show all the Wireless to G.703 routings currently set.

Wireless to G.703 routing definitions may not have sequential identifiers, that 's the not shown values represent the free places in the table.

Here is an example of the command execution:

[18:14:08] ABILIS_CPX: D WGB

- Not Saved (SAVE CONF), Not Refreshed (INIT) ---------------------------------

ID:  SRCPORT:  SRCCHAN:  DSTPORT:  DSTCHAN:
---------------------------------------------
0          30         0       600         0
3        NONE         0      NONE         0

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the table of Wireless to G.703 routings is empty, the following message will be shown "*** NO WG BRIDGE ROUTINGs DEFINED ***".

By specifying the Wireless to G.703 routing identifier, the command will show only the requested routing.

[18:14:08] ABILIS_CPX: D WGB ID:0

ID:  SRCPORT:  SRCCHAN:  DSTPORT:  DSTCHAN:
---------------------------------------------
0          30         0       600         0

The identifier must be in the interval [0 - 3]. If the requested entry is not present in the table, the following error message will be displayed: "WG BRIDGE ROUTING NOT PRESENT".

For a more detailed description of the shown information, refer the Configuration of Wireless to G.703 routings section.

If the Abilis CPX version, currently in use, does not support Wireless to G.703 service, the following message will be shown "WG BRIDGE ROUTINGS SERVICE NOT PRESENT".

S WGB | Set Wireless to G.703 routing (Administrator)
 | S WGB ID:xx par:val [par:val]

It sets parameters of the specified Wireless to G.703 routing to their new values.

The specified Wireless to G.703 routing identifier value must be in the interval [0 - 3]. If the requested entry is not present in the table, the following error message will be displayed: "WG BRIDGE ROUTING NOT PRESENT".

If the table of Wireless to G.703 routings is empty, the following message will be shown "WG BRIDGE ROUTINGS TABLE IS EMPTY".

The parameter list, defined in the command, is left to right evaluated: the parameters are set one after the other, starting from the leftmost. Command evaluating will terminate if one the following events will occur:

  • bad parameter(s) to be set;
  • value of the parameter(s) out of its allowed range;
  • conflict between the parameter(s) to be set and others.

All the parameters evaluated, before the error occurrence, will get the new value, the other ones will not be changed.

The table of Wireless to G.703 routings can be modified while the Abilis CPX is working, but they are not immediately active, to be activated they need the system to be restarted.

The "Not Refreshed (INIT)" message is displayed every time the table is modified while the Abilis CPX is working.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

If the Abilis CPX version, currently in use, does not support Wireless to G.703 service, the following message will be shown "WG BRIDGE ROUTINGS SERVICE NOT PRESENT".


Cryptography Keys

Configuration of cryptography keys
Details of the cryptography keys parameters

Configuration of cryptography keys top

In the Table of Cryptography Keys, keys can be added/modified/deleted while Abilis CPX is working. Changes made on the table do not need the Abilis CPX to be restarted: they are immediately active.

Table of Cryptography Keys can store up to 64 key definitions.

Commands for managing the Cryptography Keys are described in the section Commands relating to Cryptography Keys.

The following commands are available:

A CRKEY:
C CRKEY:
D CRKEY
S CRKEY:

Here is an example of the command "D CRKEY" execution.

Displayed values are only examples. As it is possible to note, key values are opportunely masked, moreover keys identifiers do not have to be obligatory sequential:

[18:14:08] ABILIS_CPX: D CRKEY

- Not Saved (SAVE CONF) -------------------------------------------------------

CRKEY:  VAL:      DESC:
------------------------------------------------------------------------------
0       ********  Default_encryption/decryption_key
3       ********  Test_cypher_key_1
10      ********  Test_cypher_key_2

How to show a single cryptography key:

18:14:08] ABILIS_CPX: D CRKEY:3

CRKEY:  VAL:      DESC:
------------------------------------------------------------------------------
3       ********  Test_cypher_key_1

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Details of the cryptography key parameters top

CRKEY: | Identifier of the cryptography key
no value | from 0 to 63

When the user defines a new key, he is requested to specify a numeric identifier for it. The system will refer to that key by using its identifier for every operation on it.

Cryptography key identifiers are not requested to be progressive. The user can select any value in the range [1 - 63], with the condition that the selected index is not already used.

The default key, automatically provided by the system, always occupies zero index position. It can be used whenever the user does not need to define a private cryptographic key. Default key value is fixed; it cannot be modified or deleted.

VAL: | Value of the cryptography key
no value | from 8 up to 8 up to 32 ASCII characters [33..126]

It sets the value of the cryptographic key. Valid keys are strings of characters, whose length can go from 8 up to 32 ASCII characters in the range [33..126], spaces are not allowed.

Cryptography keys themselves are saved ciphered on disk.

Once the value of the key is set, it is not visible anymore. In the table, the value is opportunely masked by a string of eight '*' (asterisk) characters, independently of the real key length.

DESC: | Description associated to the cryptography key
empty | from 0 up to 64 ASCII characters [33..126]

This is a free text that user can enter to identify the key. It can be set and/or modified after creating the key. The cryptography key description is a string, whose length can go from 0 up to 64 ASCII characters in the range [33..126], spaces are not allowed.


Ports numbering and adapters configuration

Numbering of physical and logical ports
Synchronous ports, driver SYNC
Asynchronous ports, driver PAD
Ethernet ports, driver ETH
Token-Ring ports, driver TR
Fast-Ethernet ports, ETH100 driver
Analogue voice ports, driver VOICE
ISDN S0 "only data" ports, driver ISDN
ISDN S0/T0 "voice/data" ports, driver EBISDN
ISDN S2m/T2m "voice/data" ports, driver EPISDN
All assigned port numbers

Adapters configuration
Synchronous ports, HSCB adapters for '486
Synchronous ports, HSCB adapters for Pentium
Synchronous ports, ESB adapter
Asynchronous ports, on-board adapter
Asynchronous ports, multiserial D-FLEX adapter
Asynchronous ports, multiserial MOXA adapter
Analogue voice ports, ACB adapter
ISDN S0 "only data", ITK adapter
ISDN S0 "only data", SpeedCard adapter
10 Mbit/sec Ethernet ports, ETH adapter
4/16 Mbit/sec Token-Ring ports, TR adapter
10/100 Mbit/sec Ethernet ports, ETH100 adapter
Enhanced ISDN S0/T0 ports, EBIB adapters
Enhanced ISDN S2m/T2m ports, EPIB adapters.
Additional ACBM and HDLC controllers, EXP adapters
Enhanced ISDN S0/T0 ports, BEP adapters

Conflicts and their resolution

Numbering of the physical and logical ports top

The following tables show numbering of physical and logical ports (modules) used by Abilis in its three standard configurations:

  • Data application, ISDN S0-TE "only data" interface.
  • Data and voice applications through ISDN, ISDN S0-TE "only data" interfaces and EBIB/EPIB systems.
  • Data and voice applications through analogue interfaces, ISDN S0-TE "only data" interfaces and ACB systems

To check which one of the three configuration is actually in use, it is enough to display the software version trough the following procedures:

  • Front panel commands.
  • Command "D I" sent to the control port (CP).
  • Command "D I" executed by Independent configuration.

The acronym that follows the version, identifies the configuration in use, for example:

  • 3.8.0    : "only data" configuration, no EBIB/EBIP or ACB systems.
  • 3.8.0/E  : configuration of digital voice and data with EBIB/EPIB system, without ACB systems.
  • 3.8.0/V  : configuration of analogue voice and data with ACB systems, without EBIB/EPIB systems.
  • 3.8.0/VE : configuration of analogue voice, digital voice and data, with ACB and EBIB/EPIB systems.

Table 1. Synchronous ports, SYNC driver.
Ports | Type
1-2 | Synchronous ports of the HSCB-1 Silver or Gold adapter, or the ESB-1.
3-4 | Synchronous ports of the HSCB-2 Silver or Gold adapter, or the ESB-1.
5-6 | Synchronous ports of the HSCB-3 Silver or Gold adapter, or the ESB-2.
7-8 | Synchronous ports of the HSCB-4 Silver or Gold adapter, or the ESB-2.
9-10 | Synchronous ports of the HSCB-5 Silver or Gold adapter, or the ESB-3.
11-12 | Synchronous ports of the HSCB-6 Silver or Gold adapter, or the ESB-3.
13-14 | Synchronous ports of the HSCB-7 Silver or Gold adapter, or the ESB-4.
15-16 | Synchronous ports of the HSCB-8 Silver or Gold adapter, or the ESB-4.

Table 2. Asynchronous ports, PAD driver
Ports | Type
21 | Asynchronous configuration port #1 (ASY-1)
22 | Asynchronous configuration port #2 (ASY-2)
23-30 | Asynchronous ports of the multiserial adapter #1 (ASYMS-1)
31-38 | Asynchronous ports of the multiserial adapter #2 (ASYMS-2)
39-46 | Asynchronous ports of the multiserial adapter #3 (ASYMS-3)
47-54 | Asynchronous ports of the multiserial adapter #4 (ASYMS-4)

Table 3. Ethernet ports, ETH driver.
Ports | Type
55 | Ethernet Port #1 (ETH-1)
56 | Ethernet Port #2 (ETH-2)

Table 4. Token-Ring ports, TR driver.
Ports | Type
57 | Token-ring Port #1 (TR-1)

Table 5. Fast-Ethernet Port, ETH100 driver.
Ports | Type
58 | Fast-Ethernet Port #1 (ETH100-1)
59 | Fast-Ethernet Port #2 (ETH100-2)

Table 6. Analogue voice ports, VOICE driver.
Ports | Type
60-63 | Voice ports of the adapter ACB master #1 (ACB-1)
64-67 | Voice ports of the adapter ACB slave #1 (ACB-1)
68-71 | Voice ports of the adapter ACB master #2 (ACB-2)
72-75 | Voice ports of the adapter ACB slave #2 (ACB-2)
76-79 | Voice ports of the adapter ACB master #3 (ACB-3)

Table 7. ISDN S0 "only data" ports, ISDN driver.
Ports | Type
17 | ISDN S0 port of the adapter ISDN S0 "only data" #1 (ISDN-1)
18 | ISDN S0 port of the adapter ISDN S0 "only data" #2 (ISDN-2)
19 | ISDN S0 port of the adapter ISDN S0 "only data" #3 (ISDN-3)

Table 8. ISDN S0/T0 "voice/data" ports, EBISDN driver.
Ports | Type
80-83 | ISDN S0/T0 ports of the adapter EBIB or BEP Master (EBIB-1 o BEP-1)
84-87 | ISDN S0/T0 ports of the adapter EBIB or BEP Slave 1 (EBIB-1 o BEP-1)
88-91 | ISDN S0/T0 ports of the adapter EBIB or BEP Slave 2 (EBIB-1 o BEP-1)
92-95 | ISDN S0/T0 ports of the adapter EBIB or BEP Slave 3 (EBIB-1 o BEP-1)

Table 9. ISDN S2m/T2m "voice/data" ports, EPISDN driver.
Ports | Type
96-97 | Ports ISDN S2m/T2m of the adapter EPIB Master (EPIB-1)
98-99 | Ports ISDN S2m/T2m of the adapter EPIB Slave (EPIB-1)

Table 10. All assigned port numbers.
Ports | Type | Acronym of the driver
0 | Control port | CP
1 - 16 | Synchronous | SYNC
17 - 19 | ISDN "data only" | ISDN
21 - 54 | Asynchronous, PAD X3-X28-X29 | PAD
55 - 56 | Ethernet | ETH
57 | Token-ring | TR
58 - 59 | Fast-Ethernet | ETH100
60 - 79 | Voice | VOICE
80 - 95 | Enhanced Basic rate ISDN | EBISDN
96 - 99 | Enhanced Primary rate ISDN | EPISDN
100 | Enhanced ISDN router "Master port" | EIM
101-116 | Frame-relay | FR
117-119 | LAPD for ISDN "data only" | LAPD
155-159 | IP for Ethernet, Fast-Ethernet and Token ring | IPLAN
180-195 | LAPD for EBISDN | EBLAPD
196-199 | LAPD for EPISDN | EPLAPD
200 | Enhanced ISDN router | EIR
201-216 | LAPB, level2 X.25 | LAPB
217-219 | Q931 for ISDN "data only" | Q931
280-295 | Q931 for EBISDN | EBQ931
296-299 | Q931 for EPISDN | EPQ931
301-316 | X.25, level3 X.25 | X25
321-336 | SDLC | SDLC
341-356 | HDLC-Transparent | HDLCT
380-399 | Q931 simulation | sQ931
401-416 | PLINK-Emulation over UDP | PLINKE
501-520 | ISDN dial-up and backup of a permanent link | MLM
521-540 | Permanent and dial-up multilink aggregation | ML
541-560 | Point to Point Protocol | PPP
701-732 | PLINK-Emulation over UDP | PLINKE
751-782 | ISDN dial-up and backup of a permanent link | MLM
801-832 | LAPB, level2 X.25 | LAPB
851-882 | X.25, level3 X.25 | X25
900 | IP router | IPRTR
901 | Terminal Control Protocol | TCP
902 | User Datagram Protocol | UDP
903 | Routing Information Protocol | RIP
904 | Simple Network Management Protocol | SNMP
905 | Telnet | TLN
906 | SSH 1.5 (secure shell) | SSH
907 | X.25 session Tunnelling Protocol | XTP
908 | Accounting for EIR | ACNT
909 | Simple Network Time Protocol | SNTP
910 | Domain name server | DNS
911 | Network Address Translation | NAT
920-930 | COR data traffic simulator | SIM
997 | MLM for remote maintenance | MLM
998 | LAPB for remote maintenance | LAPB
999 | X25 for remote maintenance | X25

Adapters configuration top

Table 11. Configurations of the synchronous ports adapters HSCB for '486.
Adapter | Address | IRQ | Ports | Jp2 |  |  | Jp5 |  | Jp3
 |  |  |  | 4 | 2 | 1 | 2 | 1 | 15 | 10 | 7
HSCB #1 (Silver/Gold) | 0xE000 | 7 | 1-2 | op | op | op | CL | op | CL | CL | CL
HSCB #2 (Silver) | 0xE000 | 5 | 3-4 | op | op | CL | CL | op |
HSCB #3 (Silver) | 0xE000 | 10 | 5-6 | op | CL | op | CL | op
HSCB #4 (Silver) | 0xE000 | 11 | 7-8 | op | CL | CL | CL | op
HSCB #5 (Silver) | 0xE000 | 14 | 9-10 | CL | op | op | CL | op
HSCB #6 (Silver) | 0xE000 | 15 | 11-12 | CL | op | CL | CL | op
HSCB #7 (Silver) | 0xD000 | 3 | 13-14 | CL | CL | op | CL | op
HSCB #8 (Silver) | 0xD000 | 12 | 15-16 | CL | CL | CL | CL | op

Table 12. Configurations of the synchronous ports adapters HSCB for Pentium.
Adapter | Address | IRQ | Ports | Jp2 |  |  | Jp5 |  | Jp3
 |  |  |  | 4 | 2 | 1 | 2 | 1 | 15 | 10 | 7
HSCB #1 (Silver/Gold) | 0xD000 | 7 | 1-2 | op | op | op | op | CL | CL | CL | CL
HSCB #2 (Silver) | 0xD000 | 5 | 3-4 | op | op | CL | op | CL |
HSCB #3 (Silver) | 0xD000 | 10 | 5-6 | op | CL | op | op | CL
HSCB #4 (Silver) | 0xD000 | 11 | 7-8 | op | CL | CL | op | CL
HSCB #5 (Silver) | 0xD000 | 14 | 9-10 | CL | op | op | op | CL
HSCB #6 (Silver) | 0xD000 | 15 | 11-12 | CL | op | CL | op | CL
HSCB #7 (Silver) | 0xD000 | 3 | 13-14 | CL | CL | op | op | CL
HSCB #8 (Silver) | 0xD000 | 12 | 15-16 | CL | CL | CL | op | CL

Table 13. Configuration of the ESB adapters.
Adapter | Address | IRQ | Ports
ESB #1 | Auto | Auto | 1-4
ESB #2 | Auto | Auto | 5-8
ESB #3 | Auto | Auto | 9-12
ESB #4 | Auto | Auto | 13-16

Being PCI adapters, Address and IRQ configuration is done automatically by the Abilis CPX, according to the PCI and Plug&Play BIOS specifications, that is the same procedures used by personal computers.

Table 14. Configuration of the on-board asynchronous ports.
Adapter | Address | IRQ | Port
First on-board asynchronous port | 0x3F8 | 3 | 21
Second on-board asynchronous port | 0x2F8 | 4 | 22

Table 15. Configuration of the multiserial asynchronous ports D-FLEX.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
Multiserial #1 | 0x280 | A-3 | 23-30 | off | off | ON | off | ON | off | ON | ON
Multiserial #2 | 0x190 | A-5 | 31-38 | off | off | off | off | off | off | ON | ON
Multiserial #3 | 0x200 | A-10 | 39-46 | off | off | ON | ON | ON | off | ON | ON
Multiserial #4 | 0x300 | A-15 | 47-54 | off | off | off | ON | ON | off | ON | ON

Table 16. Configuration of the multiserial asynchronous ports MOXA.
Adapter | Address | IRQ | Ports
 |  |  |  | Multiserial #1 | 0x280 | 3 | 23-30
Multiserial #2 | 0x190 | 5 | 31-38
Multiserial #3 | 0x200 | 10 | 39-46
Multiserial #4 | 0x300 | 15 | 47-54

MOXA multiserial adapters do not have jumpers or dip-switches, they are delivered already configured and numbered.

Table 17. Configuration of voice ports adapters.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4
ACB master #1 | 0x320 | 15 | 60-63 | ON | off | ON | ON
ACB slave #1 | 0x320 | 15 | 64-67 | ON | off | ON | off
ACB master #2 | 0x340 | 14 | 68-71 | off | ON | ON | ON
ACB slave #2 | 0x340 | 14 | 72-75 | off | ON | ON | off
ACB master #3 | 0x2A0 | 11 | 76-79 | ON | ON | off | ON

Table 18. Configuration of the adapters for the ISDN S0 "only data" ITK.
Adapter | Address | IRQ | Ports | JP1
 |  |  |  | 1 | 2 | 3 | 4
ISDN #1 | 0x390 | 11 | 81 | CL | CL | CL | CL
ISDN #2 | 0x398 | 10 | 82 | op | CL | op | CL
ISDN #3 | 0x3A0 | 5 | 83 | CL | op | CL | op

Table 19. Configuration of the adapters for the ISDN S0 "only data" Speed Card.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
ISDN #1 | 0x390 | 11 | 17 | ON | off | ON | ON | off | off | off | off
ISDN #2 | 0x398 | 10 | 18 | off | off | ON | ON | off | off | off | off
ISDN #3 | 0x3A0 | 5 | 19 | ON | ON | off | ON | off | off | off | off

Table 20. Configuration of Ethernet adapters.
Adapter | Address | IRQ | Ports
Ethernet #1 | 0x300 | 12 | 55
Ethernet #2 | 0x360 | 10 | 56

Ethernet adapters do not have jumpers or dip-switches, they are delivered already configured and numbered.

Table 21. Configuration of Token ring adapters.
Adapter | Address | IRQ | Ports
Token-ring #1 | Auto | Auto | 57

Being PCI adapters, Address and IRQ configuration is done automatically by the Abilis CPX, according to the PCI and Plug&Play BIOS specifications, that is the same procedures used by personal computers.

Table 22. Configuration of Fast Ethernet adapters.
Adapter | Address | IRQ | Ports
Fast Ethernet #1 | Auto | Auto | 58
Fast Ethernet #2 | Auto | Auto | 59

Being PCI adapters, Address and IRQ configuration is done automatically by the Abilis CPX, according to the PCI and Plug&Play BIOS specifications, that is the same procedures used by personal computers.

Table 23. Configuration of EBIB adapters.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6
EBIB Master | 0xCE00 | 11 | 80-83 | off | ON | ON | ON | off | off
EBIB Slave 1 | 0xCE00 | - | 84-87 | off | ON | ON | ON | off | off
EBIB Slave 2 | 0xCE00 | - | 88-91 | off | ON | ON | ON | off | off
EBIB Slave 3 | 0xCE00 | - | 92-95 | off | ON | ON | ON | off | off

For configuring JP1, JP3, JP4, JP5, JP6, refer to the chapter about Adapters.

Table 24. Configuration of EPIB adapters.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6
EPIB Master | 0xCC00 | 11 | 96-97 | off | off | ON | ON | off | off
EPIB Slave | 0xCC00 | - | 98-99 | off | off | ON | ON | off | off

For configuring JP1, JP3, JP4, JP5, JP6, JP7, JP8, JP9 refer to the chapter about Adapters.

Table 25. Configuration of EXP adapters.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6
EPIB Master | 0xCC00 | - | - | off | off | ON | ON | off | off
EPIB Slave | 0xCC00 | - | - | off | off | ON | ON | off | off

For configuring JP3, JP4, JP5, JP7, JP8, refer to the chapter about Adapters.

Table 26. Configuration of BEP adapters.
Adapter | Address | IRQ | Ports | SW1
 |  |  |  | 1 | 2 | 3 | 4 | 5 | 6
BEP Master | 0xCE00 | 10 | 80-83 | Off | ON | ON | ON | Off | Off
BEP Slave 1 | 0xCE00 | - | 84-87 | Off | ON | ON | ON | Off | Off
BEP Slave 2 | 0xCE00 | - | 88-91 | Off | ON | ON | ON | Off | Off
BEP Slave 3 | 0xCE00 | - | 92-95 | Off | ON | ON | ON | Off | Off

Conflicts and their resolution top

There are three kind of conflicts:

  • Interrupt conflicts (IRQ)
  • Base address conflicts
  • Conflicts generated by overlapping of addressing areas

By comparing the previous tables it is quite easy to avoid conflicts among the adapters.

Before saving any change made on the software configuration, the system will verify it, so that bad configuration cannot be saved and useful information about the detected conflicts are shown.

Address and IRQ configuration of ISA adapters can be done using the command S CARD, in such a way it can match real adapter configuration and if necessary help solving the most difficult adapters conflicts.


Ports configuration, general elements

Revised for CPX 4.1.0.

Abilis CPX has a lot of different communication ports type and a virtual Control Port. They should be configured according to several parameters.

All the commands for port handling are described in the section Commands relating to ports and boards.

Commands available for setting and displaying port parameters are the following:

D P
S P

Here is an example of displaying all the active ports. Shown values are only examples:

[18:38:04] ABILIS_CPX: D P PO:A

PO:0   - Control_port_for_remote_CPX_management -------------------------------
CP     PI:ABILIS_CPX:          bsvc:3                  ps:128
       PWD-U:                  PWD-A:                  PWD-S:
       X29A:02010102010302040006050C010D000E000F011008111812121302
       X29B:020100020003000402050006000700080009000A000C000D000E000F001500

PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V35     CLK:INT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

PO:17  ------------------------------------------------------------------------
ISDN   LOG:NO      frame:2100    rxbuf:14     txbuf:1

PO:21  ------------------------------------------------------------------------
PAD    01:001 02:001 03:002 04:000 05:001 06:005 07:000 08:000 09:000 10:000
       11:014 12:001 13:004 14:000 15:001 16:008 17:024 18:002 19:002 20:000
       21:000 22:000
       LOG:DS     TYPE:USER  MCAU:NO    ps:128   FS:128      vc:BSVC  AC:NO
       PI:CPX/021:           SP:9600    LE:8     PT:NONE     ST:1     HF:NO
       CD:YES     FDCD:500   FCTS:500   CO:NO    CODLY:0     DTRDN:0
       DW:100     CLRX29:NO  CQ:YES     FC:
       X29:

PO:58  ------------------------------------------------------------------------
ETH100 LOG:NO            MODE:AUTO         DUPLEX:HALF   TPPOL:AUTO
       dma-rxbuf:25      dma-txbuf:25      ip-rxbuf:25   arp-rxbuf:5

PO:117 ------------------------------------------------------------------------
LAPD   LOG:NO      lowpo:17      LINE:MP
       Q931:YES    Q931TEI:AUTO  X25:NO       X25TEI:10
       X25K:7      X25T200:1     X25T203:10   X25N200:3    x25n201:260

PO:158 ------------------------------------------------------------------------
IPLAN  LOG:NO      lowpo:58    arpcache:200   CACHETIMER:120
       rxbuf:4     txbuf:14

PO:201 ------------------------------------------------------------------------
LAPB   LOG:DS      lowpo:1     lapb:DCE      FW:7
       T1:3000     T2:0        T3:9000       N1:2064     N2:10

PO:217 ------------------------------------------------------------------------
Q931   lowpo:117   TYPE:USER     LINE:MP  DIALT:5   T301:60
       NUM:*                     ORCD:0

PO:301 - X25_verso_Agenzia ----------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

Here is an example of displaying a single port (P0:301): all the ports connected to it are also shown. Values are only examples:

[18:38:04] ABILIS_CPX: D P PO:301

PO:301 - X25_verso_Agenzia ----------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3
PO:201 ------------------------------------------------------------------------
LAPB   LOG:DS      lowpo:1     lapb:DCE      FW:7
       T1:3000     T2:0        T3:9000       N1:2064     N2:10
PO:1   ------------------------------------------------------------------------
SYNC   LOG:DS      int:V35     CLK:INT        SP:19200     CODING:NRZ   MPX:NO
       IDLE:FLAG   FDCD:500    FCTS:500       mode:FULL    RTSDLY:0     CD:NO
       frame:2100  d-rxbuf:14  dma-rxbuf:10   dma-txbuf:1

Here is an example of displaying the specified port (P0:301) excluding the ones connected to it. Values are only examples:

[18:38:04] ABILIS_CPX: D P PO:301 .

PO:301 - X25_verso_Agenzia ----------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

Here is an example of displaying a list of active ports (in the example 58 and 158):

[17:38:07] ABILIS_CPX: D P PO:58,158

PO:58  - Lan-interna ----------------------------------------------------------
ETH100 LOG:NO            MODE:AUTO         DUPLEX:HALF   TPPOL:AUTO
       dma-rxbuf:25      dma-txbuf:25      ip-rxbuf:25   arp-rxbuf:5

PO:158 ------------------------------------------------------------------------
IPLAN  LOG:NO      lowpo:NONE  arpcache:200   CACHETIMER:120
       rxbuf:4     txbuf:14

Here is an example of displaying all the active ports of a specified type (in this case "X25"):

[18:38:04] ABILIS_CPX: D P PO:X25

PO:301 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:201   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:302 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:202   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:303 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:203   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:304 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:204   TYPE:USER     MCAU:NO     PW:7     ps:2048
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DCE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

PO:999 ------------------------------------------------------------------------
X25    LOG:DS      lowpo:998   TYPE:NETWORK  MCAU:NO     PW:2     ps:128
       fpvc:1      fisvc:1     fbsvc:1       fosvc:11    x25:DTE
       pvc:0       isvc:0      bsvc:10       osvc:0
       T20:30      T21:30      T22:30        T23:30      N3:3

Please note that only the currently "ACTIVE" ports can be configured. Use the command D ACT to show a list of all the active ports, the command D INACT for the inactive ones. Before displaying and eventually configure an inactive port, it has to be activated using the command S ACT.

Moreover the parameters, whose value is active only after restarting the system, are shown using low case characters, while to activate changes made on the parameters shown by upper case characters, it is only needed to execute the initialization command INIT PO:.

As it was shown in the previous examples, if a port has a description, then the visualization command will be shown on the first row, the informative string set by the user through the command A D.

The following commands allow setting and displaying port information:

A D
C D
D D
D DE
S D

If a single port (PO:xxx) is displayed, the command will also show its eventual description. If there is no description associated to the "xxx" port, the command displays the description of the lower level port connected to it.

How to set a port description:

[18:38:04] ABILIS_CPX: A D PO:503 Cluster_voce/dati_verso_Agenzia

COMMAND EXECUTED

How to display the port description:

[18:38:04] ABILIS_CPX: D D PO:503

PO  Type   Description
-------------------------------------------------------------------------------
503 MLM    Cluster_voce/dati_verso_Agenzia

or

[18:38:04] ABILIS_CPX: D P PO:503

PO:503 - Cluster_voce/dati_verso_Agenzia --------------------------------------
MLM    LOG:DS      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:NONE
       SLINK:200
       RTY:LIN     NRTY:5        TB:3     DDT:220        VDT:10
       CGI:*                     SGI:503
       CDI:*                     SDI:*
       CGO:#                     SGO:#
       CDO:#                     SDO:#

Here is an example of displaying the port LAPB parameters. It has no description associated to it, but it is connected to a lower level port, which has its own informative string:

[18:38:04] ABILIS_CPX: D P PO:203

PO:203 - Cluster_voce/dati_verso_Agenzia --------------------------------------
LAPB   LOG:DS      lowpo:503   lapb:DCE      FW:7
       T1:3000     T2:0        T3:0          N1:2064     N2:10
PO:503 - Cluster_voce/dati_verso_Agenzia --------------------------------------
MLM    LOG:DS      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:3
       SLINK:200
       RTY:LIN     NRTY:5        TB:3     DDT:220        VDT:10
       CGI:*                     SGI:503
       CDI:*                     SDI:*
       CGO:#                     SGO:#
       CDO:#                     SDO:#

The "inherited" description is displayed also when the "recursive" display is requested

[18:38:04] ABILIS_CPX: D P PO:203 .

PO:203 - Cluster_voce/dati_verso_Agenzia --------------------------------------
LAPB   LOG:DS      lowpo:503   lapb:DCE      FW:7
       T1:3000     T2:0        T3:0          N1:2064     N2:10

How to delete a port description:

[18:38:04] ABILIS_CPX: C D PO:503

COMMAND EXECUTED

Displaying port description after its deleting:

[18:38:04] ABILIS_CPX: D D PO:503

PORT DESCRIPTION DOESN'T EXIST

or

[18:38:04] ABILIS_CPX: D P PO:503

PO:503 ------------------------------------------------------------------------
MLM    LOG:DS      MPX:YES LC:YES T1:1000 T3:3000 N2:3  CIPHER:NO    CRKEY:DFT
       PLINK:3
       SLINK:200
       RTY:LIN     NRTY:5        TB:3     DDT:220        VDT:10
       CGI:*                     SGI:503
       CDI:*                     SDI:*
       CGO:#                     SGO:#
       CDO:#                     SDO:#

Here is an example of displaying all the descriptions set by the command "D D PO:A":

[18:38:04] ABILIS_CPX: D D PO:A

PO  Type   Description
-------------------------------------------------------------------------------
2   SYNC   RingFR
58  ETH100 Lan-interna
89  EBISDN TEM-assistenza
90  EBISDN R.A.-CAD-assistenza
91  EBISDN TEM-commerciale-e-X25d
92  EBISDN Fax/Assistenza
95  EBISDN Cellulink
301 X25    X25_verso_Agenzia
315 X25    X25d_emulazione_NT_su_PO:283
513 MLM    TestPort_for_Teles_redirector
701 PLINKE Voice_tunnel_to_cpx-internet


X.25 SVC routings and PVC connections

About SVC and PVC

SVC routings
PVC connections

About PVC and SVC top

X25 provides two different types of virtual circuit: switched virtual circuit (SVC) and permanent virtual circuit (PVC).

Abilis CPX is able to manage SVC channels through the SVC routings table, and PVC channels through the PVC connections table.

In order to properly work, communications ports must be correctly configured with respect to the connected devices. Particular attention must be paid to the logical channels (PVC, ISVC, BSVC, OSVC) numbering. For more detailed information refer to the section X25 Level 3 ports.

The following pictures show the differences between SVC and PVC connections.

Figure 1. SVC connections
Esempio SVC

A virtual call is a dynamically established virtual circuit (channel SVC) using a call setup and a call clearing procedure for every communication session.

Packet routing inside the network (and Abilis CPX) is made according to the data of the call, and to the SVC routings table.

Figure 2. PVC connections
Esempio PVC

A permanent virtual circuit is a permanent, network-assigned, virtual circuit (PVC).

Packets routing inside the network (and Abilis CPX) is made according to a "fixed" table. Routing can be changed only by modifying the configuration tables.

Whenever necessary, DTEs or the network can request to reset the connection trough the reset procedure provided for PVC channels.


Users Access Control table

Configuration of Users Access Control table
Details of the Users Access Control table parameters

Configuration of Users Access Control table top

In the Users Access Control Table, user entries can be added/modified/deleted while Abilis CPX is working. Changes made on the table do not need the Abilis CPX to be restarted: they are immediately active.

The "Not Saved (SAVE CONF)" message is displayed every time the table is modified but not saved with the SAVE CONF command.

Commands for managing the Users Access Control Table are described in the section Commands related to Users Access Control table.

The following commands are available:

A USER:
C USER:
D USER
D USER:
D USERE
D USERE:
S USER:
F USER:

Users Access Control Table can store up to 151 user's entries. It holds by default an user entry defined for the system administrator user and identified by the "admin" name.

The system administrator user record has the following main characteristics:

  • The "admin" user's entry cannot be deleted.
  • The "admin" user's entry is disabled by default, i.e. the ENABLED: field is set to "NO".
  • The PASSWORD: field of the "admin" user's entry is empty by default and the "admin" user's entry cannot be enabled until a password is not set into the PASSWORD: field.
  • When the PASSWORD: field is cleared, the "admin" user's entry is automatically disabled.

Here it is a sample of the system administrator user's record default settings:

[11:36:01] ABILIS_CPX: D USERE:admin

Parameter:   |Value:
------------------------------------------------------------------------------
USER:         admin
PASSWORD:
ENABLED:      NO
PPP:          YES
PPP-AUTH:     CHAP
PPP-PO:       ANY
FTP:          YES
FTP-HOMEDIR:
FTP-PROT:     PLAIN,SSL
HTTP:         YES
------------------------------------------------------------------------------

Here is an example of the command D USER execution. Displayed values are only examples. As it is possible to note, users defined with their most important configuration information are displayed only:

[12:18:37] ABILIS_CPX: D USER

USER:                             PASSWORD:  ENABLED: PPP: FTP: HTTP:
------------------------------------------------------------------------------
admin                             *********  YES      YES  YES  YES
Leo                                          YES      YES  YES  YES
test                              *********  YES      YES  NO   NO
testhttp                          *********  YES      NO   NO   YES
testssl                           *********  YES      NO   YES  NO

The full representation of the defined users properties can be shown using the D USERE command.

Details of the Users Access Control table parameters top

USER: | User's name
no value | from 1 up to 32 ASCII characters [33..126]

This parameter reprents the name of the user, i.e. the mnemonic with which a certain user is identified within the system.

Valid "USER:" names are strings of up to 32 ASCII characters in the range [33..126]. Spaces are not allowed. The case of the entered strings is preserved.
There is no difference between lowercase and uppercase characters. For example the following strings "MyUser", "MYUSER", "myuser" are equivalent.

There can be up to 151 users in the Users Access Control Table, each of one is unambiguously identified by the "USER:" parameter value.

Two or more entries with the same "USER:" value cannot be defined. If a new entry is going to be added and an entry with the same user name already exists in the table, the "USER ALREADY EXISTS" message is generated.

The table is alphabetically sorted on the base of the "USER:" parameter value and it is automatically resorted each time an entry is added or removed.

PASSWORD: | User's password
no value | from 0 up to 32 ASCII characters [33..126]

This parameter represents the password that can be optionally assigned to the user.

Valid "PASSWORD:" values are strings of 32 ASCII characters in the range [33..126]. Spaces are not allowed. The case of the entered password is preserved.

User's password are saved ciphered on disk. Once the value of the password is set, it is not visible anymore.
In the table, the value is opportunely masked by a tring of up to nine '*' (asterisk) characters, independently of the real password length.

ENABLED: | User's enable/disable flag
YES | NO, YES

This parameter allows to disable/enable run-time a certain user in the system, without removing him from the table.

The "admin" user's entry is disabled by default, and it cannot be enabled with an empty password.

All other users are enabled by default.

PPP-ENABLE: | PPP enable/disable flag
NO | NO, YES

This parameter allows to disable/enable run-time a certain user for the PPP protocol service.

The "admin" user's entry is enabled for the PPP protocol service by default, while all other users are disabled by default.

PPP-AUTH: | PPP authentication protocol
CHAP | PAP, CHAP, MSCHAPV1, MSCHAPV2, ALL

This parameter allows to select the PPP authentication protocol set for this user.

Values from the set [PAP, CHAP, MSCHAPV1, MSCHAPV2] can be joined using ',' (comma) character, in any order (e.g. "PAP,CHAP" or "CHAP,PAP"). The value "ALL" is used with the meaning of "all protocols".

PPP-PO: | PPP port
ANY | NONE, ANY, 0-999, 'ListName'

This parameter allows to select the PPP port for this user.

The "NONE" value, means that no port is accepted.

The "ANY" value, means that any ports is accepted.

A value in the range [0-999], can be used to select a specific PPP port.

The name of an list of type CP (i.e. CPX Ports) is also supported, if between primes, for example: 'My_List'. The selected list must be already defined in the Elements List

FTP-ENABLE: | FTP enable/disable flag
NO | NO, YES

This parameter allows to disable/enable run-time a certain user for the FTP protocol service.

The "admin" user's entry is enabled for the FTP protocol service by default, while all other users are disabled by default.

FTP-HOMEDIR: | FTP home directory
no value | from 0 up to 128 characters

This parameter allows to select the FTP protocol service home directory for this user.

Valid "FTP-HOMEDIR:" values are can be strings of up to 128 characters, initiating and terminated by the '/' (slash) character.
Case is preserved. Spaces are allowed. Strings holding spaces must be written between quotation marks (E.g.: "/str1/str2 str3/").

FTP-PROT: | FTP access protocol
PLAIN, SSL | PLAIN, SSL

This parameter allows to set the FTP access protocol for this user.

Values from the set [PLAIN, SSL] can be joined using ',' (comma) character, in any order (e.g. "PLAIN,SSL" or "SSL,PLAIN").

HTTP-ENABLE: | HTTP enable/disable flag
NO | NO, YES

This parameter allows to disable/enable run-time a certain user for the HTTP protocol service.

The "admin" user's entry is enabled for the HTTP protocol service by default, while all other users are disabled by default.


Asynchronous adapters

2 ports multiserial asynchronous
8 ports multiserial asynchronous

Other adapters

2 ports multiserial asynchronous adapter top

The 2 ports multiserial asynchronous adapter has the following interface and provides the following services:

  • 2 asynchronous ports up to 115.200 bit/sec
  • UART 16650, 32bytes receiving and transmitting fifo
  • RTS/CTS Flow control and XON/XOFF managed by hardware
  • 1 SIMM slot for RS232/V24, RS422 or current-loop interface modules
  • 2 DB9-M standard PC-AT connectors
  • ISA bus

In each Abilis CPX it is possible to plug in up to 4 of such adapters.

Multiseriale a 2 porte Dflex
Figure 10. 2 ports Dflex Multiserial.

Table 11. 2 ports Multiserial, switch SW1.
Base address | SW1
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
0x280 | off | off | ON | off | ON | off | ON | ON
0x190 | off | off | off | off | off | off | ON | ON
0x200 | off | off | ON | ON | ON | off | ON | ON
0x300 | off | off | off | ON | ON | off | ON | ON

The jumper JP2 must be opened.

The JP1 jumpers block selects the IRQ level used by the adapter.

To select the requested IRQ level, install the jumper in the suitable A position. No jumpers have to be installed in the position B.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

8 ports multiserial asynchronous adapter top

The 8 ports multiserial asynchronous adapter has the following interface and provides the following services:

  • 8 asynchronous ports up to 115.200 bit/sec
  • UART 16650, 32bytes receiving and transmitting fifo
  • RTS/CTS Flow control and XON/XOFF managed by hardware
  • 4 SIMM slot for RS232/V24, RS422 or current-loop interface modules
  • 8 DB9-M standard PC-AT connectors, using the adapting cable
  • ISA bus

In each Abilis CPX it is possible to plug in up to 4 of such adapters.

Each adapter is provided with a special adapting cable that has 8 DB-9 male connectors, according to the standard PC-AT.

Multiseriale 8 porte DFLEX
Figure 11. 8 ports Dflex Multiserial.

Table 12. 8 ports Multiserial, switch SW1.
Base address | SW1
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
0x280 | off | off | ON | off | ON | off | ON | ON
0x190 | off | off | off | off | off | off | ON | ON
0x200 | off | off | ON | ON | ON | off | ON | ON
0x300 | off | off | off | ON | ON | off | ON | ON

The JP1 jumpers block selects the IRQ level used by the adapter.

To select the requested IRQ level, install a jumper in the suitable A position. No jumpers have to be installed in the position B.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.


Enhanced ISDN adapters

EBIB Master (Enhanced BRI ISDN Board - Master)
EBIB Slave 1/2/3
EPIB Master (Enhanced PRI ISDN Board - Master)
EPIB Slave
EXP 1/2 (EPIB Expansions)
BEP Master (BRI Expansion for EPIB - Master)
BEP Slave 1/2/3
Rules for the correct placement of the EBIB adapters
Rules for the correct placement of the EPIB/EXP/BEP adapters

Other adapters

ISDN-EBIB Master adapter top

Installation of EBIB system in the Abilis CPX is alternative to the EPIB/EXP/BEP one.

For its correct installation, refers to the section Rules for the correct placement of the EBIB adapters.

The ISDN EBIB Master adapter provides the following services and it has the following interfaces:

  • 4 ISDN BRI S0 or T0 ports, RJ45-NT plugs, load termination externally applied.
  • Each port can be set as S0 or T0 port.
  • 4 HDLC controllers for D channel management.
  • 8 HDLC controllers for data transmission on as many B channels.
  • 2 housings for 2 ACBM modules, altogether 4 compressible voice channels.
  • 1 PCM switch matrix with 64 full duplex channels, dedicated to the EBIB subsystem (Master+Slave1+Slave2+Slave3).
  • 1 connector for connecting the adapter to the "EBIB bus".
  • 1 module for call tone generation, if telecom or other devices do not provide them.
  • ISA bus.

At the most, only one EBIB Master adapter can be placed in each Abilis CPX.

The EBIB system can accept up to 3 EBIB slave adapters connected to the EBIB Master one. The most complex configuration allowed, using the "full-optional" Slave adapters, is:

  • 16 BRI S0 or T0 ports, altogether 32 B channels independently switchable.
  • 16 D channels, each of them can support the "X25 over D channel" protocol.
  • 32 HDLC controllers for data transmission on as many B channels.
  • 16 compressible voice channels.

EBIB Master
Figure 19. EBIB-Master Adapter.

If jumpers JP5 and JP6 are present, they don't have to be closed (installed).

The dip-switch SW1, as the figure shows, selects the 0xCE00 address: it must not be changed.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

Table 19. EBIB Master, jumpers JP3.
Internal Line Selection | JP3
 | 1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
EBIB Master | a-b | a-b | a-b | a-b | •┐ •┘ • | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •

Table 20. EBIB Master, jumpers JP4, terminayions on the EBIB bus.
Terminations on the EBIB bus | JP4
 | 1 | 2 | 3
Only EBIB Master | CL | CL | CL
At least one Slave is present | op | op | CL

The JP4 jumpers group allows plugging the suitable terminations on the "EBIB bus".

In order to avoid problems, always check that:

  • EBIB adapters are plugged into the slots in the correct order, starting form the EBIB Master one.
  • EBIB bus adapters are firmly fixed.
  • EBIB bus cable is in perfect condition.
  • Terminations are plugged in the right way.

On the contrary EBIB system could have irregular behaviours, such as:

  • Noise, disturbs, rustles in voice communications.
  • High error rate in data transmission.
  • Not working at all of the whole system
  • Inexplicable crashes of the CPX. Please remember that system crashes are automatically restored by the Watchdog and the messages "I: WDLIVE1" or "I: WDSTART" will be writte in the System Log at the subsequent system startup.

ISDN-EBIB Slave 1/2/3 Adapters top

EBIB adapters numbering do not only refer to a jumper/switches configuration, but to a real hardware difference. The User should pay a lot of attention when requests a new adapter and installs it.

Even if it is possible, it highly recommended to avoid the intallation of adapters in discontinue order (e.g.. Master + Slave 2). Instructions about EBIB system configuration have been simplified by the sequential installation of the Slave adapters.

ISDN EBIB Slave adapter, available in the "voice" and "voice/data" versions, provides the following services and interfaces:

  • 4 ISDN BRI S0 or T0 ports, RJ45-NT plugs, load termination externally applied.
  • Each port can be set as S0 or T0 port.
  • 4 HDLC controllers for D channel management.
  • 8 HDLC controllers for data transmission on as many B channels (present only in the voice/data version).
  • 2 housings for 2 ACBM modules, altogether 4 compressible voice channels.
  • 1 connector for connecting the adapter to the "EBIB bus".
  • ISA bus.

In each Abilis CPX it is not possible to install at the same time two or more EBIB Slave adapters with the same numbering.

EBIB Slave
Figure 20. EBIB-Slave adapter.

The dip-switch SW1, as the figure shows, selects the 0xCE00 address: it must not be changed.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

Table 21. EBIB Slave 1/2/3, jumpers JP3.
Internal line Selection | JP3
 | 1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
Master | a-b | a-b | a-b | a-b | •┐ •┘ • | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •
Slave 1 | b-c | a-b | a-b | a-b | • •┐ •┘ | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •
Slave 2 | a-b | b-c | b-c | b-c | •┐ •┘ • | • •┐ •┘ | • •┐ •┘ | • •┐ •┘
Slave 3 | b-c | b-c | b-c | b-c | • •┐ •┘ | • •┐ •┘ | • •┐ •┘ | • •┐ •┘

Internal lines selection depends only on the adapter itself and not on the others EBIB adapter in use. Usually the factory skips the adapter with the right setting for the JP3 jumper, however the user can quickly check it by reading the previous table.

Table 22. EBIB Slave 1/2/3, jumpers JP4, terminations on the EBIB bus.
EBIB installed adapters | Adapter | JP4
 |  | 1 | 2 | 3
Master + Slave 1 | Master | op | op | CL
 | Slave 1 | CL | CL | op
Master + Slave 1 + Slave 2 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 2 | CL | CL | op
Master + Slave 1 + Slave 2 + Slave 3 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 2 | op | op | op
 | Slave 3 | CL | CL | op

In case of emergency, that is when in the installed EBIB system an intermediate adapter gets bad, it is possible to remove it, temporarily adapt the terminations and obviously modify the software configurations deactivating all its ports.

it is not recommended to use such configurations systematically, but only in case of real emergency.

Table 23. EBIB Slave 1/2/3, jumpers JP4, non standard installations.
EBIB installed adapters | Adapter | JP4
 |  | 1 | 2 | 3
Master + Slave 2 | Master | CL | op | CL
 | Slave 2 | CL | CL | op
Master + Slave 3 | Master | CL | op | CL
 | Slave 3 | CL | CL | op
Master + Slave 2 + Slave 3 | Master | CL | op | CL
 | Slave 2 | op | op | op
 | Slave 3 | CL | CL | op
Master + Slave 1 + Slave 3 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 3 | CL | CL | op

ISDN-EPIB Master Adapters top

Installation of EPIB/EXP/BEP system in the Abilis CPX is alternative to the EBIB one.

For its correct installation, refers to the section Rules for the correct placement of the EPIB/EXP/BEP adapters.

The ISDN EPIB Master adapter provides the following services and it has the following interfaces:

  • 2 G.703 ports, 120 ohm balanced - ISDN PRI S2m or T2m, RJ45-NT plugs.
  • Each port can be set as S2m or T2m port.
  • 2 HDLC controllers for D channel management.
  • 8 HDLC controllers for data transmission on as many B channels.
  • 4 housings for 4 ACBM modules, altogether 8 compressible voice channels.
  • 1 PCM switch matrix with 128 full duplex channels, dedicated to the EPIB subsystem EPIB/EXP/BEP (EPIB-Master + EPIB-Slave + EXP1 + EXP2 + BEP-Master + BEP-Slave 1 + BEP-Slave 2 + BEP-Slave 3).
  • 1 connector for connecting the adapter to the "EPIB bus".
  • 1 connector for connecting EPIB Master and BEP Master.
  • ISA bus.

EPIB Master
Figure 21. EPIB-Master Adapter.

If jumpers JP2-DMA are present, they don't have to be closed (installed).

The dip-switch SW1, as the figure shows, selects the 0xCC00 address: it must not be changed.

Jumpers JP3, JP4, JP5, JP6, JP7, JP8, JP9 always have to be installed as shown in figure; in the future, welded wires may replace them.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

The EPIB bus termination must be plugged in only if there are not other adapters connected to the EPIB bus.

ISDN-EPIB Slave Adapter top

The ISDN EPIB Slave adapter provides the following services and it has the following interfaces:

  • 2 G.703 ports, 120 ohm balanced - ISDN PRI S2m or T2m, RJ45-NT plugs.
  • Each port can be set as S2m or T2m port.
  • 2 HDLC controllers for D channel management.
  • 8 HDLC controllers for data transmission on as many B channels.
  • 4 housings for 4 ACBM modules, altogether 8 compressible voice channels.
  • 1 PCM switch matrix with 128 full duplex channels, dedicated to the EPIB subsystem EPIB/EXP/BEP (EPIB-Master + EPIB-Slave + EXP1 + EXP2 + BEP-Master + BEP-Slave 1 + BEP-Slave 2 + BEP-Slave 3).
  • 1 connector for connecting the adapter to the "EPIB bus".
  • ISA bus.

Epib Slave
Figure 22. EPIB-Slave Adapter.

The dip-switch SW1, as the figure shows, selects the 0xCC00 address: it must not be changed.

Jumpers JP3, JP4, JP5, JP7, JP8 always have to be installed as shown in figure; in the future, welded wires may replace them.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

The EPIB bus termination must be plugged in only if the adapter is the last one on the EPIB bus.

If the BEP Master is not connected to the EPIB master, the jumper block JP9 have to be installed as shown in figure, otherwise JP9/2 and JP9/3 have to be opened. The following table clearly shows the two different configurations:

Table 24. EPIB Slave, jumpers JP9.
Internal line selection | JP9
 | 1 | 2 | 3 | 4
Without BEP Master | • •┐ •┘ | • •┐ •┘ | • •┐ •┘ | • •┐ •┘
With BEP Master | • •┐ •┘ | • • • | • • • | • •┐ •┘

EXP 1/2 (EPIB Expansions) Adapters top

EXP adapters numbering doesn't refer only to a jumper/switches configuration, but to a real hardware difference. The User should pay a lot of attention when requests a new adapter and installs it.

EXP adapters, available in the "voice" and "voice/data" versions, provides the following services and interfaces:

  • 8 HDLC controllers for data transmission on as many B channels (present only in the voice/data version).
  • 4 housings for 4 ACBM modules, altogether 8 compressible voice channels.
  • 1 connector for connecting the adapter to the "EPIB bus".
  • ISA bus

EXP, EPIB expansion
Figure 23. EXP Adapter.

The dip-switch SW1, as the figure shows, selects the 0xCC00 address: it must not be changed.

Jumpers JP3, JP4, JP5, JP7, JP8 always have to be installed as shown in figure; in the future, welded wires may replace them.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

The EPIB bus termination must be plugged in only if the adapter is the last one on the EPIB bus.

ISDN-BEP Master (BRI Expansion for EPIB - Master) Adapter top

Installation of BEP system requires the presence of the EPIB system; in fact, the BEP Master adapter must be connected to the EPIB Master one, through the suitable cable.

If the EPIB system is expanded by using the BEP Master, it won't be possible anymore to use the first port on the EPIB Slave.

The ISDN BEP Master adapter provides the following services and it has the following interfaces:

  • 4 ISDN BRI S0 or T0 ports, RJ45-NT plugs, load termination externally applied.
  • Each port can be set as S0 or T0 port.
  • 4 HDLC controllers for D channel management.
  • 1 connector for connecting the BEP Master to the EPIB Master.
  • 1 connector for connecting the adapter to the "BEP bus".
  • ISA bus.

At the most, only one BEP Master adapter can be placed in each Abilis CPX, the expansion is made connecting to it at most 3 BEP Slave.

The most complex allowed configuration of the EPIB/EXP/BEP system which uses the "full-optional" EXP adapters is:

  • 3 G.703 ports, 120 ohm balanced - ISDN PRI S2m or T2m, RJ45-NT plugs.
  • 3 D-PRI channels, each of them can support the "X25 over D channel" protocol.
  • 32 HDLC controllers for data transmission on as many B channels.
  • 16 housings for 16 ACBM modules, altogether 32 compressible voice channels.
  • 16 D-BRI channels, each of them can support the "X25 over D channel" protocol.
  • 16 BRI S0 o T0 ports, RJ45-NT plugs, load termination externally applied.
  • Altogether 122 B channels independently switchable.

BEP master
Figure 24. BEP-Master adapter.

The dip-switch SW1, as the figure shows, selects the 0xCE00 address: it must not be changed.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

Table 25. BEP Master, jumpers JP3.
Internal line selection | JP3
 | 1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
BEP Master | a-b | a-b | a-b | a-b | •┐ •┘ • | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •

Table 26. BEP Master, jumpers JP4, terminations on the BEP bus.
Terminations on the BEP bus | JP4
 | 1 | 2 | 3
only BEP Master | CL | op | CL
At least one Slave is present | op | op | CL

The JP4 jumpers group allows plugging the suitable terminations on the "BEP bus".

In order to avoid problems, always check that:

  • BEP adapters are plugged into the slots in the right order, starting form the BEP Master one.
  • BEP bus connectors are firmly fixed.
  • BEP bus cable is in perfect conditions.
  • Terminations are plugged in the right way.

On the contrary the EPIB/EXP/BEP system could have irregular behaviours, such as:

  • Noise, disturbs, rustles in voice communications.
  • High error rate in data transmission.
  • Not working at all of the whole system
  • Inexplicable crashes of the CPX. Please remember that system crashes are automatically restored by the Watchdog and the messages "I: WDLIVE1" or "I: WDSTART" will be writte in the System Log at the subsequent system startup.

ISDN-BEP Slave 1/2/3 Adapters top

BEP adapters numbering do not only refer to a jumper/switches configuration, but to a real hardware difference. The User should pay a lot of attention when requests a new adapter and installs it.

Even if it is possible, it highly recommended to avoid the intallation of adapters in discontinue order (e.g.. Master + Slave 2). Instructions about BEP system configuration have been simplified by the sequential installation of the Slave adapters.

ISDN BEP Slave adapter provides the following services and interfaces:

  • 4 ISDN BRI S0 or T0 ports, RJ45-NT plugs, load termination externally applied.
  • Each port can be set as S0 or T0 port.
  • 4 HDLC controllers for D channel management.
  • 1 connector for connecting the adapter to the "BEP bus".
  • ISA bus.

In each Abilis CPX it is not possible to install at the same time two or more BEP Slave adapters with the same numbering.

Bep Slave
Figure 25. BEP-Slave Adapter.

The dip-switch SW1, as the figure shows, selects the 0xCE00 address: it must not be changed.

Table 27. BEP Slave 1/2/3, jumpers JP3.
Internal line selection | JP3
 | 1 | 2 | 3 | 4 | 1 | 2 | 3 | 4
Master | a-b | a-b | a-b | a-b | •┐ •┘ • | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •
Slave 1 | b-c | a-b | a-b | a-b | • •┐ •┘ | •┐ •┘ • | •┐ •┘ • | •┐ •┘ •
Slave 2 | a-b | b-c | b-c | b-c | •┐ •┘ • | • •┐ •┘ | • •┐ •┘ | • •┐ •┘
Slave 3 | b-c | b-c | b-c | b-c | • •┐ •┘ | • •┐ •┘ | • •┐ •┘ | • •┐ •┘

Internal lines selection depends only on the adapter itself and not on the others BEP adapters in use. Usually the factory ships the adapter with the right setting for the JP3 jumper, however the user can quickly check it by reading the previous table.

Table 28. BEP Slave 1/2/3, jumpers JP4, terminations on the BEP bus.
BEP installed adapters | Adapter | JP4
 |  | 1 | 2 | 3
Master + Slave 1 | Master | op | op | CL
 | Slave 1 | CL | op | op
Master + Slave 1 + Slave 2 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 2 | CL | op | op
Master + Slave 1 + Slave 2 + Slave 3 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 2 | op | op | op
 | Slave 3 | CL | op | op

In case of emergency, that is when in the installed BEP system an intermediate adapter gets bad, it is possible to remove it, temporarily adapt the terminations and obviously modify the software configurations deactivating all its ports.

It is not recommended to use such configurations systematically, but only in case of real emergency.

Table 29. BEP Slave 1/2/3, jumpers JP4, non standard installations.
BEP installed adapters | Adapter | JP4
 |  | 1 | 2 | 3
Master + Slave 2 | Master | CL | op | CL
 | Slave 2 | CL | op | op
Master + Slave 3 | Master | CL | op | CL
 | Slave 3 | CL | op | op
Master + Slave 2 + Slave 3 | Master | CL | op | CL
 | Slave 2 | op | op | op
 | Slave 3 | CL | op | op
Master + Slave 1 + Slave 3 | Master | op | op | CL
 | Slave 1 | CL | op | op
 | Slave 3 | CL | op | op

Rules for the correct placement of the EBIB adapters top

For successfully run the EBIB system, the adapters must be plugged in following simple and precise rules. Particularly, they must be plugged sequentially starting from the Master one.

Violation of these rules will surely cause irregular behaviours, such as:

  • Noise, disturbs, rustles in voice communications.
  • High error rate in data transmission.
  • Not working at all of the whole system
  • Inexplicable crashes of the CPX. Please remember that system crashes are automatically restored by the Watchdog and the messages "I: WDLIVE1" or "I: WDSTART" will be writte in the System Log at the subsequent system startup.

The following figure gives some hints to follow and some to avoid.

Disposizione di un sistema EBIB
Figure 26. Placement examples of the EBIB adapters.

Rules for the correct placement of the EPIB/EXP/BEP adapters top

EPIB Master adapters, Slave and EXP can be installed in a more flexible way than the EBIB ones; however it is always needed to follow two rules:

  • EPIB Master adapter has to be an outmost one.
  • The "EPIB bus" termination must be installed only the other outmost adapter of the EPIB/EXP chain.

If the user wants to add BEP adapters, he has to connect the EPIP Master to the BEP Master through the suitable cable; for the BEP adapters, it is nedded to follow the same rules of the EBIB ones (see Rules for the correct placement of the EBIB adapters).

Explanations and examples made for the EBIB adapters can be applied to the BEP ones.

Violation of these rules will surely cause irregular behaviours, such as:

  • Noise, disturbs, rustles in voice communications.
  • High error rate in data transmission.
  • Not working at all of the whole EPIB/EXP/BEP system
  • Inexplicable crashes of the CPX. Please remember that system crashes are automatically restored by the Watchdog and the messages "I: WDLIVE1" or "I: WDSTART" will be writte in the System Log at the subsequent system startup.

The following figure gives some hints to follow and some to avoid.

Disposizione di un sistema EPIB
Figure 27. Placement examples of EPIB/EXP/BEP adapters.


ISDN "only data" adapters

ISDN-BRI S0 only data

Other adapters

ISDN-BRI S0 "only data" adapters top

Two versions of this adapter exist. They both provide the same functionalities, but differ only in the way they have been manufactured and jumpers/switches configuration.

ISDN S0 "only data" adapter provides the following services, it also has the following interfaces:

  • 1 ISDN S0 port with a standard RJ45-TE female connector.
  • Data transmission over B and D channel with HDLC framing.
  • ISA bus

In each Abilis CPX it is possible to plug in up to 3 ISDN-BRI S0 adapters.

ISDN solo dati ITK
Figura 15. ISDN S0 only data "ITK" adapter.

Tabella 16. ISDN S0 ITK, jumpers JP1.
Base address | JP1/ADD |  | IRQ | JP1/IRQ
 | 1 | 2 |  | 3 | 4
0x390 | CL | CL | 11 | CL | CL
0x398 | op | CL | 10 | op | CL
0x3A0 | CL | op | 5 | CL | op

ISDN solo dati SpeedCard
Figura 16. ISDN S0 only data "SpeedCard" adapter.

Tabella 17. ISDN S0 SpeedCard, switch SW1.
Base address | SW1
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
0x390 | ON | off | ON | ON | off | off | off | off
0x398 | off | off | ON | ON | off | off | off | off
0x3A0 | ON | ON | off | ON | off | off | off | off

For correct jumpers/switches configuration, depending on the sotfware one, refer to the chapter Port numbering and adapters configuration.


LAN adapters

Ethernet 10 Mbps
Fast-Ethernet 10/100 Mbps
Token-Ring 4/16 Mbps

Other adapters

Ethernet 10 Mbps adapter top

The Ethernet adapter has the following interface and provides the following services:

  • 1 10Mbit/sec Ethernet/IEEE 802.3 port available on:
    • Thin coax interface through BNC connector
    • TP 10BaseT interface through RJ-45
  • ISA bus

Interface selction is automatically made, depending on which of them is connected to the LAN. The 10BaseT interface has the highest priority.

Above the RJ45 connector (10BaseT interface) there are 2 indicators (leds), LINK and ACT, described in the following table.

In each Abilis it is possible to plug up to 2 Ethernet adapters (more than 2 in the customized Abilis versions).

Ethernet 10 Mpbs
Figure 12. Ethernet 10 Mbps adapter.

Table 13. Ethernet, indicators LINK and ACT.
Indication | Meaning
LINK off | The 10BaseT interface is disconnected or the link cable is not good.
LINK on | The 10BaseT interface is connected and correctly working; the "BNC" interface is deactivated.
LINK intermittent | The link to the 10BaseT is faulty.
ACT off | There is no activity to/from the Ethernet port.
ACT on or intermittent | Activity is present; the Ethernet port is receiving or sending data.

The adapter is configured before it is delivered to the customer: it cannot be reconfigured by the User. The configuration is indicated on the tag place in the adapter itself. For more detailed information refer to the chapter Ports numbering and adapters configuration.

Fast-Ethernet 10/100 Mbps adapter top

The Fast-Ethernet adapter has the following interface and provides the following services:

  • 1 10/100 Mbit/sec Ethernet/IEEE 802.3 with RJ45 connector
  • physical levels 10BastT (UTP3) and 100BaseTX (UTP5)
  • Nways negotiation
  • half/full duplex manually or automatically selectable through the Nways negotiation
  • 10/100 automatic identification towards hub/switch without Nways negotiation
  • PCI bus

Above the RJ45 connector (10BaseT interface) there are 2 indicators (leds), LINK and ACT, described in the following table.

In each Abilis it is possible to plug up to 2 Ethernet adapters (more than 2 in the customized Abilis versions).

Fast-Ethernet 10/100 Mbps
Figure 13. Fast-Ethernet 10/100 Mbps adapter.

Table 14. Fast-Ethernet, indicators LINK and ACT.
Indication | Meaning
LINK off | Interface is disconnected or activated on 10BaseT.
LINK on | Interface is active on 100BaseTx.
LINK intermittent | Link is faulty.
ACT off | There is no activity to/from the Ethernet port.
ACT on or intermittent | Activity is present; the Ethernet port is receiving or sending data.

Being a PCI adapter, no jumpers/switches configuration is needed.

Token-Ring 4/16 Mbps Adapter top

The Token-ring adapter has the following interface and provides the following services:

  • 1 4/16 Mbit/sec Token-ring/IEEE 802.5 port available on:
    • RJ45 connector
    • DB-9 connector
  • DB-9 connector
  • Half/full duplex

L'adattatore Token-ring fornisce i seguenti servizi e dispone delle seguenti interfacce:

  • 1 porta Token-ring/IEEE 802.5 a 4/16 Mbit/sec disponibile su:
    • connettore RJ45
    • connettore DB-9
  • connettore DB-9
  • half/full duplex manually or automatically selectable
  • PCI bus

Above the DB-9 connector there are 2 leds, described in the following table.;

In each Abilis it is possible to plug up to 1 Token-ring (more than 1 in the customized Abilis versions).

TokenRing 4/16 Mbps
Figure 14. Token-ring 4/16 Mbps adapter.

Table 15. Token-Ring, indicators --- and ---.
Indication | Meaning

Being a PCI adapter, no jumpers/switches configuration is needed.


Analogue Voice adapters (FXS/FXO)

ACB

Other adaptors

ACB adapter top

The ACB adapter has the following interfaces and provides the following services:

  • 4 analogue ports
  • 4 housings for interface modules FXS and FXO
  • 2 housings for the voice compression modules (ACBM)
  • 1 connector for Master/Slave connection of 2 ACB adapters
  • 1 connector for connecting the power supply needed by the FXS interfaces
  • ISA bus

In each Abilis CPX it is possible to plug in up to 5 ACB adapters in Master/Slave configuration.

ACB, fonia analogica
Figure 17. ACB adapter.

Table 18. ACB, switch SW1.
Base address | SW1 |  |  | Master/Slave selection | SW1
 | 1 | 2 | 3 |  | 4
0x320 | ON | off | ON | Master | ON
0x340 | off | ON | ON | Slave | off
0x2A0 | ON | ON | off |

The JP1 jumpers block select the IRQ level used by the adapter.

The connector J1 is used to connect the ACB master to the ACB slave, configured for the same address.

The connector J2 is used only if at least one FXS interface is plugged: it supplies the requested power to the telephone connected.

CAUTION
When the connector J2 is used, 48V DC and 80V AC are present on the pins; so that before opening the Abilis CPX always disconnect the electric current plugs.

For correct jumpers/switches configuration, it also depends on the software one, refer to the chapter Ports numbering and adapters configuration.

Each port can be equipped with the chosen interface module, the following figure shows the FXS and FXO modules.

Base configuration of the ACB adapter provides the ports 0 and 1. For being able to use also ports 2 and 3 the following components must be added:

  • module ACBM #1 for port 2/3
  • codecs 2 and 3
  • interface modules 2 and 3

Moduli ACBM,FXS,FXO per ACB
Figure 18. ACB, modules FXS, FXO, ACBM.


Installation

Installation of floppy based systems
Installation of HD/CF based systems on MfIde equipped systems
Installation of HD/CF based systems on Front Panel equipped systems
Installation error messages

Start-up configuration recovery

Standard Abilis CPX installation is a simple procedure and it takes few minutes, however some really important checks are indispensable:

  1. The packing has to be integral; no visible damages (i.e. during the delivering) should be detected.
  2. Once the packing has been opened, the equipment has to be integral; there should also be a packing-list containing description of the model, the installed options and diagram showing the connections between Abilis CPX and its environment.
  3. Check whether in the packing there are all the elements described in the packing-list.

If all the checks are positive, the User can proceed with the installation through one of the the following procedures, otherwise he should contact the Abilis CPX assistance.

Installation of floppy based systems top

  1. Place the Abilis preferably close to the Telecom line terminations.
  2. Plug the power supply cable into the 220V tap.
  3. Connect the provided cable(s) following the included diagram. In case of doubt, refer to the CPX Hardware section.
    So, if the disk is already configured, it is enough to insert it in the floppy drive and switch on the Abilis. In case of disk missing, the configuration has to be done.
  4. Insert one of the two disks provided with the packing.
  5. Switch on the Abilis CPX, by pressing the button POWER of the front panel. After few seconds, two "beep" will be heard in a rapid sequence and the software loading procedure will start.
  6. After the software is loaded, the LEDs 1 and 2 of the front panel will light together; it means the Abilis CPX regularly started.
  7. Activate tools of diagnosis and configuration for setting or verifying the correct equipment programming. If this procedure is executed by a remote operator, the User should contact the tele-control central of his seller. Preferably, the User, before contacting the assistance, should check whether the Abilis CPX is connected to the telephone line through a modem (or ISDN connection) and communicate his number.

warning! The described procedure is reported only for informative purposes for Abilis CPX software versions earlier then 4.7.0.
In fact starting from Abilis CPX software version 4.7.0, the usage of HD/CF based systems is required.

Installation of HD/CF based systems on MfIde equipped systems top

  1. Place the Abilis preferably close to the Telecom line terminations.
  2. Plug the power supply cable into the 220V tap.
  3. Connect the provided cable(s) following the included diagram. In case of doubt, refer to the CPX Hardware section.
  4. Insert the Disk 1 - CPX Installer in the floppy drive.
  5. Switch on the Abilis CPX, by pressing the button POWER of the MfIde front panel. After few seconds, two "beep" will be heard in a rapid sequence and the installation software loading procedure will start.
  6. After the installation software is loaded, the red LEDs 1 and 2 and green LED 3 of the MfIde front panel are switched on while the green LED 4 lightens every second and the installation utility version will appears on the LCD display:

    CPX Installer
    v. XXXX Abilis

    This means the installation software regularly started.
  7. After the installation software version is displayed, the following messages are shown:

    <OK> to Start
    <Left> to Exit

    Press Ok key to proceed with the installation.
    Press Left key to end the procedure.
  8. Once the Ok key is pressed, the procedure will start HD/CF predisposition to Abilis CPX software installation.

    Installation
    in progress...

    A proper set of messages will guide the User through each installation phase:

    HD/CF formatting phase:

    HD/CF format
    in progress...     		High-Lev. Format
    XX% Done     		HD/CF size:
    XXXX MB     		HD/CF format
    completed.

    HD/CF checking phase:

    HD/CF check
    in progress...     		HD/CF check
    completed.

    Boot Manager installation phase:

    BM install
    in progress...     		BM install
    completed.

  9. Once the HD/CF predisposition is completed, the following messages will announce Abilis CPX software installation phase start:

    Insert PKG disk
    and press <OK>

  10. Insert the Disk 2 - CPX Package in the floppy drive and press Ok key to proceed with the installation.
  11. Once the CPX package disk presence is detected, a verification procedure is started on it in order verify whether the Abilis CPX software is provided on a single disk or on several disks and in order to identify the version of the Abilis CPX software that is going to be installed:

    PKG check
    in progress...
    Found CPX.PKG of
    CPX Ver.XXXXXX     		OR Found CPX.001 of
    CPX Ver.XXXXXX
    Install XXXXXX ?
    N=<Left>, Y=<OK>

    The Left allows to replace the current disk with another holding a different Abilis CPX software.
  12. Press Ok key to proceed with the installation. The following message will appear:

    CPX install
    in progress...

    A proper set of messages will guide the User through the nexts Abilis CPX software installation steps:

    Single-disk CPX package:

    Loading package
    file CPX.PKG...     		Package file
    loaded.     		Exctracting
    package file...     		Package file
    extracted.

    Multi-disks CPX package:

    Processing
    disk xx/yy...     		Disk xx
    processed.     		Insert disk xx
    and press <OK>

    On this request, insert next CPX Package disk(s) in the floppy drive and press Ok key to proceed with the installation.

    Loading package
    file CPX.PKG...     		Package file
    loaded.     		Exctracting
    package file...     		Package file
    extracted.

  13. The successful Abilis CPX software installation is announced by the following messages:

    CPX Ver. XXXXXX
    installed.

  14. Once the Abilis CPX software installation is completed, the following messages provide the opportunity to update the Abilis CPX configuration:

    Config update?
    N=<Left>, Y=<OK>

    Press Left key to skip configuration update.
  15. Press Ok key to proceed with the Abilis CPX configuration loading. The following message will appear:

    Insert CFG disk
    and press <OK>

  16. Insert the Disk N - CPX Configuration tools in the floppy drive and press Ok key to proceed. Default system configuration should be always provided with the packing. In case of disk missing, the configuration has to be done.
  17. Once the Ok key is pressed, the procedure will start to load Abilis CPX configuration from the inserted disk:

    Config update
    in progress...

    During the configuration update, a message is shown informing the User about the file that is going to be copied and about the result of the operation. These messages are of the following form:

    Updating
    FFFFFFFF.FFF...     		FFFFFFFF.FFF
    updated.

    Where "FFFFFFFF.FFF" is the name of the file that is going to be processed (DRIVERS.CFG or DRIVERS.BCK).
    The following messages will be displayed to inform about the successful completion of the operation:

    Config update
    completed.

    In case of one configuration file is missing, the following message will appear:

    Config update
    ended with error

    In case that both configuration files are missing, the following message will appear:

    Config update
    not executed.

  18. Once the Abilis CPX software installation and the configuration update are completed, the following messages announce the Abilis CPX installation completion:

    Install process
    completed.     		Extract last
    inserted disk.     		Press <OK> to
    EXIT and REBOOT

  19. Extract last inserted disk from the floppy drive and press OK key. After few seconds the system will be restarted. Two "beep" will be heard in a rapid sequence and the software loading from the HD/FC procedure will start.
  20. After the software is loaded from the HD/FC, the green LED 4 of the MfIde front panel will light every second; it means the Abilis CPX regularly started.
  21. Activate tools of diagnosis and configuration for setting or verifying the correct equipment programming.
    If this procedure is executed by a remote operator, the User should contact the tele-control central of his seller. Preferably, the User, before contacting the assistance, should check whether the Abilis CPX is connected to the telephone line through a modem (or ISDN connection) and communicate his number.

For a complete list of possible error messages generated during the installation, please see Installation error messages section.

Installation of HD/CF based systems on Front Panel equipped systems top

  1. Place the Abilis preferably close to the Telecom line terminations.
  2. Plug the power supply cable into the 220V tap.
  3. Connect the provided cable(s) following the included diagram. In case of doubt, refer to the CPX Hardware section.
  4. Insert the Disk 1 - CPX Installer in the floppy drive.
  5. Switch on the Abilis CPX, by pressing the button POWER of the front panel. After few seconds, two "beep" will be heard in a rapid sequence and the installation software loading procedure will start.
  6. After the installation software is loaded, both both LEDs of the front panel lighten every second and the installation utility version will appears on the LCD display:

    CPX Installer
    v. XXXX Abilis

    This means the installation software regularly started.
  7. After the installation software version is displayed, the following messages are shown:

    <OK> to Start
    <Select> to Exit

    Press Ok key to proceed with the installation.
    Press Select key to end the procedure.
  8. Once the Ok key is pressed, the procedure will start HD/CF predisposition to Abilis CPX software installation.

    Installation
    in progress...

    A proper set of messages will guide the User through each installation phase:

    HD/CF formatting phase:

    HD/CF format
    in progress...     		High-Lev. Format
    XX% Done     		HD/CF size:
    XXXX MB     		HD/CF format
    completed.

    HD/CF checking phase:

    HD/CF check
    in progress...     		HD/CF check
    completed.

    Boot Manager installation phase:

    BM install
    in progress...     		BM install
    completed.

  9. Once the HD/CF predisposition is completed, the following messages will announce Abilis CPX software installation phase start:

    Insert PKG disk
    and press <OK>

  10. Insert the Disk 2 - CPX Package in the floppy drive and press Ok key to proceed with the installation.
  11. Once the CPX package disk presence is detected, a verification procedure is started on it in order verify whether the Abilis CPX software is provided on a single disk or on several disks and in order to identify the version of the Abilis CPX software that is going to be installed:

    PKG check
    in progress...
    Found CPX.PKG of
    CPX Ver.XXXXXX     		OR Found CPX.001 of
    CPX Ver.XXXXXX
    Install XXXXXX ?
    N=<Select>Y=<OK>

    The Select allows to replace the current disk with another holding a different Abilis CPX software.
  12. Press Ok key to proceed with the installation. The following message will appear:

    CPX install
    in progress...

    A proper set of messages will guide the User through the nexts Abilis CPX software installation steps:

    Single-disk CPX package:

    Loading package
    file CPX.PKG...     		Package file
    loaded.     		Exctracting
    package file...     		Package file
    extracted.

    Multi-disks CPX package:

    Processing
    disk xx/yy...     		Disk xx
    processed.     		Insert disk xx
    and press <OK>

    On this request, insert next CPX Package disk(s) in the floppy drive and press Ok key to proceed with the installation.

    Loading package
    file CPX.PKG...     		Package file
    loaded.     		Exctracting
    package file...     		Package file
    extracted.

  13. The successful Abilis CPX software installation is announced by the following messages:

    CPX Ver. XXXXXX
    installed.

  14. Once the Abilis CPX software installation is completed, the following messages provide the opportunity to update the Abilis CPX configuration:

    Config update?
    N=<Select>Y=<OK>

    Press Select key to skip configuration update.
  15. Press Ok key to proceed with the Abilis CPX configuration loading. The following message will appear:

    Insert CFG disk
    and press <OK>

  16. Insert the Disk N - CPX Configuration tools in the floppy drive and press Ok key to proceed. Default system configuration should be always provided with the packing. In case of disk missing, the configuration has to be done.
  17. Once the Ok key is pressed, the procedure will start to load Abilis CPX configuration from the inserted disk:

    Config update
    in progress...

    During the configuration update, a message is shown informing the User about the file that is going to be copied and about the result of the operation. These messages are of the following form:

    Updating
    FFFFFFFF.FFF...     		FFFFFFFF.FFF
    updated.

    Where "FFFFFFFF.FFF" is the name of the file that is going to be processed (DRIVERS.CFG or DRIVERS.BCK).
    The following messages will be displayed to inform about the successful completion of the operation:

    Config update
    completed.

    In case of one configuration file is missing, the following message will appear:

    Config update
    ended with error

    In case that both configuration files are missing, the following message will appear:

    Config update
    not executed.

  18. Once the Abilis CPX software installation and the configuration update are completed, the following messages announce the Abilis CPX installation completion:

    Install process
    completed.     		Extract last
    inserted disk.     		Press <OK> to
    EXIT and REBOOT

  19. Extract last inserted disk from the floppy drive and press OK key. After few seconds the system will be restarted. Two "beep" will be heard in a rapid sequence and the software loading from the HD/FC procedure will start.
  20. After the software is loaded from the HD/FC, both LEDs of the front panel will light every second; it means the Abilis CPX regularly started.
  21. Activate tools of diagnosis and configuration for setting or verifying the correct equipment programming.
    If this procedure is executed by a remote operator, the User should contact the tele-control central of his seller. Preferably, the User, before contacting the assistance, should check whether the Abilis CPX is connected to the telephone line through a modem (or ISDN connection) and communicate his number.

For a complete list of possible error messages generated during the installation, please see Installation error messages section.

Installation error messages top

Installation phase | Messages | Description
HD/CF formatting | ERROR: 'C:' N/A HD/CF Not Found | The program attempted to access the logical drive 'C:' which is probably not mounted.
 | ERROR: nn Bad Partition | The logical drive 'C:' is probably not partitioned.
 | ERROR: 'C:' HD-n C: Not PriMaster | The logical drive 'C:' is probably not the primary master hard disk.
 | ERROR: nn Format Fail | The program attempted to format the logical drive 'C:', but the 'nn' error occurred.
 | ERROR: nn Set Label Fail | The program attempted to set the logical drive 'C:' label, but the 'nn' error occurred.
 | ERROR: nn Partition Error | The program attempted to access the logical drive 'C:', but the 'nn' error occurred.
HD/CF checking | ERROR: nn HD/CF CheckFail | The program executed the integrity check of the logical drive 'C:', but the 'nn' error occurred.
 | ERROR: NO MEMORY HD/CF CheckFail | There is not enough memory to execute the integrity check of the logical drive 'C:'.
Boot Manager installation | ERROR: BM.RTB NotFound | The file BM.RTB was not found on the disk.
 | ERROR: nn BM InstallFail | The program attempted to install the boot loader program, but the 'nn' error occurred.
Abilis CPX software installation | ERROR: Package NotFound | No package file was found on the disk.
 | ERROR: C:\PKG BadCreate | The program fail creating the directory 'C:\PKG' on the disk.
 | ERROR: nn PKG NotCopied | The program attempted to copy the file 'CPX.PKG' on the disk, but the 'nn' error occurred. (Single-disk CPX package)
 | ERROR: CPX.PKG NotFound | The file 'CPX.PKG' was not found on the disk. (Single-disk CPX package)
 | ERROR: CPX.PKG NotOpen | The program fail opening the file 'CPX.PKG'. (Single-disk CPX package)
 | ERROR: CPX.PKG BadWrite | The program fail writing the file 'CPX.PKG'. (Single-disk CPX package)
 | ERROR: CPX.nnn NotFound | The file 'CPX.nnn' was not found on the disk. (Multi-disks CPX package)
 | ERROR: CPX.nnn NotOpen | The program fail opening the 'CPX.nnn' file. (Multi-disks CPX package)
 | ERROR: CPX.nnn BadRead | The program fail reading the 'CPX.nnn' file. (Multi-disks CPX package)
 | ERROR: CPX.nnn BadHead | The 'CPX.nnn' file is corrupted or its format is not correct. (Multi-disks CPX package)
 | ERROR: CPX.nnn BadDisk | The inserted disk is corrupted ot its content is not consistent with the volumes sequence. (Multi-disks CPX package)
 | ERROR: BAD PACKAGE | The CPX package is corrupted or its format is not correct.
 | ERROR: EXTRACT FAIL | The CPX package extraction and installation fail.
 | ERROR: nn USR DirBadCreate | The program attempted to create the directory 'C:\USR', but the 'nn' error occurred.
 | ERROR: nn PUB DirBadCreate | The program attempted to create the directory 'C:\USR\PUB', but the 'nn' error occurred.
 | ERROR: nn LOG DirBadCreate | The program attempted to create the directory 'C:\LOG', but the 'nn' error occurred.
 | ERROR: nn APP DirBadCreate | The program attempted to create the directory 'C:\APP', but the 'nn' error occurred.
Configuration update | ERROR: CFG NotFound | The file 'DRIVERS.CFG' was not found on the disk.
 | ERROR: nn CFG NotCopied | The file 'DRIVERS.CFG' was not copied to/from the disk, because the 'nn' error occurred.
 | ERROR: BCK NotFound | The file 'DRIVERS.BCK' was not found on the disk.
 | ERROR: nn BCK NotCopied | The file 'DRIVERS.BCK' was not copied to/from the disk, because the 'nn' error occurred.


Introduction

Abilis CPX applications
General description
Technical characteristics
General characteristics
Synchronous ports
Asynchronous ports
LAN Ethernet 10 M ports
LAN Ethernet 100 M ports
Token-ring 4/16 ports
Wireless ports
ISDN-BRI "only data" ports
ISDN-BRI "voice/data" ports
ISDN-PRI "voice/data" ports
Analogic VOICE ports

Telecommunication networks between computer are distinguished normally in two categories: Local Area Network (LAN) and Wide Area Network (WAN).

LAN connections cover short distances, and their scope is, typically, a single building or a cluster of buildings, while WAN connections cover great distances, interesting various cities, countries and continents. They are based on transmission supports supplied by big telecommunication companies, generally called "carrier".

The resources, that these suppliers offer, are multiple and go from the traditional telephone lines to ISDN (circuit switching networks; the former with analogical terminations, the latter with digital ones), to dedicated lines (permanent direct connections between two locations) to complex networks specialized for computer communications, like, for example, the networks X25, Frame-Relay and Internet.

These networks introduce performances and very heterogeneous costs, depending only on their usage time, the distance, the channel capacity, the amount of transferred data, etc.

Such costs assume more and more important values in business budgets: for the companies becomes more and more important choosing with shrewdness the more opportune services and suppliers.

Abilis CPX is an Hardware that automatically manages the company telecommunication business (telephony and data transmission), diminishing the costs and, where possible, improving the service.

Abilis CPX is, specially, destined to multi-location companies, where it is installed (in every location) between the customer equipment (informatics systems and Private Branch Exchange) and the Telecom lines (telephone network, ISDN, GSM, X25, FR, Internet; CDN lines, Base-Band...).

The main tasks of Abilis CPX are:

  • for each communication, to find the way to greater efficiency:
  • when more communications (data or voice) are on the same line, to compress and arrange them, in such way they can share the same line.

Abilis CPX connection to the customer equipment and networks is quite easy, because Abilis CPX is compatible with a great number of "protocols" (complex set of rules that manages the communications between electronic devices). The most part of Abilis CPX installations is carried out without modifying or reprogramming the customer equipment and the existing lines.

Abilis CPX applications top

Abilis CPX expands the line capacity thanks to a sophisticated communications encrypting, so that a line, which normally transports a single conversation, can, simultaneously, carry up to 10 conversations. In this way, the user pays for ONE service, but he get 10 services.

Abilis CPX, moreover, filters all the outgoing communications towards the carrier networks and automatically routes them to the more convenient line, that is in the order:

  1. leased line, if existing;
  2. a switched line, but destined to a multiple use;
  3. an alternative carrier.

The Abilis CPX calls this function "Extended Least-Cost Routing".

These two functions make the Abilis CPX the best instrument, today available, for telecommunications optimization.

General description top

Abilis CPX is a hardware similar to a PC, but without monitor and keyboard. It can be configured either locally or from a remote location, by using a PC with programs of common use (TELNET, HyperTerminal...) or specific programs such as SNMP consoles.

For simplest operations the customer can also use the LCD display and two command keys present on the frontal panel.

The main microprocessor is of class PENTIUM and 16MB (or more) as memory RAM.

The Abilis CPX loads the entire operating software at every start, reading a 1.44 MB floppy disk (DOS format), or, since version 4.3.0, from a standard IDE hard disk or a solid state hard disk of CompactFlash type.

The motherboard has a series of slots (bus PCI and ISA) for the I/O modules. Every Abilis CPX is therefore configured according to the user requests.

In the hardware base are also included a local power switching supplier (230/115 VAC) of 150 Watt; "watchdog", that is a microprocessor dedicated to the control of the normal operational cycle; and, at the end, two serials-asynchronous ports (V.24) usable as PAD X28

Technical characteristics top

General characteristics |
Data compression | Available, from 1 up to 32 independent channels, depending on the installed RAM [1].
Remote configuration | Via PAD X28, X25, TELNET-TCP/IP, SSH(v1)-TCP/IP.
IP routing protocol | Static, RIP v.1 and RIP v.2., OSPF v.2.
Network management | SNMP v.1, MIBs standard and Abilis MIB proprietor.
Network services | RIP v.1 and v.2, OSPF v.2, SNMP, Telnet client and server, SSH v.1 client and server, SNTP client and server, DNS client, FTP server with SSL option, HTTP server, NAT, IEEE bridge, XTP [2], PLINKE (IP tunnelling) [3], ACNT-Accounting ISDN calls.
Floppy disk | 1 of 1.44 Mbyte.
Mass storage | 1 of 16 Mbytes CompactFlash (optional 32, 64 or more) and 1 optional standard IDE hard disk of various sizes.
Configuration port | 2 RS232/V24 asynchronous 300-115.200 bit/sec.
Other feature | Hardware watchdog, optional LCD display 2x16 characters.
Power supply | 220 Volt - 50 Hz. Absorbed power 25 - 90 watt.
Physical size | CPX-Base-S: 392x319x180 mm 8 Kg. CPX-Base-L: 440x319x180 mm 10 Kg.

Synchronous ports | Up to 16.
Adapters | HSCB Gold (obsolete), HSCB Silver (obsolete), ESB and ESB2.
Interfaces | RS232/V24/V28, V35, X21/V11, Manchester-V11 [4], E1-G.703 [11], .
Bit-rate | Up to 2,5 Mbit/sec per port.
Protocols | IP, PPP, Frame-relay, SDLC, QLLC, LAPB, X25, Transparent HDLC [5], MPX voice-data [6].
Synchronism | External, internal, symmetric, FM0, FM1, Manchester [7].
Encoding | NRZ, NRZI, FM0, FM1, Manchester [8], HDB3 [12].

Asynchronous ports | Up to 34.
Adapters | Serials "on board", 2 ports multiserials DFLEX, 8 ports multiserials DFLEX and MOXA.
Interfaces | RS232/V24/V28, RS422, Current-Loop [9].
Bit-rate | Up to 115 Kbit/sec per port.
Protocols | PAD X3-X28-X29, XON-XOFF, RTS/CTS.

LAN Ethernet 10 M Port | Up to 2, in standard models (more than 2 in customized ones).
Adapters | Ethernet.
Interfaces | BNC thin Ethernet, TP RJ-45.
Bit-rate | 10 Mbit/sec.
Protocols | IP v.4, ARP.

LAN Ethernet 10/100 M port | Up to 2, in standard models (more than 2 in customized ones).
Adapters | Fast-ethernet.
Interfaces | TP RJ-45.
Bit-rate | 10/100 Mbit/sec with automatic negotiation
Protocols | IP v.4, ARP, PPPoE client and PPPoE AC.

Token-ring 4/16 port | Up to 1, in standard models (more than 1 in customized ones).
Adapters | Token-Ring 4/16.
Interfaces | TP RJ-45, DB-9.
Bit-rate | 4/16 Mbit/sec with automatic negotiation
Protocols | IP v.4, ARP.

Wireless ports | Up to 5.
Adapters | Prism-PCI.
Interfaces | 1 SMA male connector
Bit-rate | 1, 2, 5.5, 11 Mbit/sec.
Protocols | IP over point-to-point 802.11b wireless link
Frequency | 2.4~2.4835 Ghz
Channels | 11 (USA, Canada) 13 (Europe)
Modulation | DSSS, BPSK, QPSK, CCK
Output power | 15 dbm (typical)
Receiver sensivity | -84dbm at 11 Mbit/sec

ISDN-BRI "only data" ports | Up to 3.
Adapters | ISDN "only data" models ITK/SPEEDCARD (obsolete), and BRIO.
Interfaces | S0-TE.
Channel D protocols | EuroISDN, DSS1, LAPD/Q.921, Q.931, X25, QLLC, point-to-point and multipoint configurations.
Channel B protocols | IP, PPP, Frame-relay, SDLC, QLLC, LAPB, X25, Transparent HDLC, MPX voice-data.

ISDN-BRI "voice/data" ports | Up to 16 BASIC-RATE ports.
Adapters | EBIB master, EBIB slave, BEP master, BEP slave.
Interfaces | S0 (TE), T0 (NT)
Functionalities | TE or NT configurable via software, for every port.
Switching | 64k channel "B" transparent switching between basic-rate and/or primary ports. 64kbps B channels or "multirate" B channels for RPVD [10] applications.
Channel D protocols | EuroISDN, DSS1, LAPD/Q.921, Q.931, simulated Q.931, X25, QLLC, point-to-point and multipoint configurations.
Channel B protocols | IP, PPP, Frame-relay, SDLC, QLLC, LAPB, X25, Transparent HDLC, MPX voice-data, RPVD (permanent B channels). Switched 64kbps (single rate) and permanent Nx64kbps (multirate) channels. The limits for a complex system are 32 channels or, altogether, 2Mbit/sec.
Synchronism | Internal or automatically selectable by any S0-TE port.
Voice compression and fax/data relay (optional) | Up to 16 communications.
Compression algorithm | G.723.1 MP-MLQ @ 4.8, 6.4.
Echo canceling | G.165 @16 msec
FAX relay | G.III @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Modem relay | V.32bis @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Other features | Automatic interpolation of bad or missing audio-frames, volume control, "Voice Activity Detection", "Silence Suppression".

ISDN-PRI "voice/data" ports | Up to 4 PRIMARY-RATE ports. Or, if one or more BEP boards are installed, up to 3 PRIMARY-RATE and 16 BASIC-RATE ones.
Adapters | EPIB master, EPIB slave, EPIB expansion.
Interfaces | G.703, 120 W balanced.
Functionalities | TE or NT configurable via software, for every port.
Switching | 64k channel "B" transparent switching between basic-rate and/or primary ports. 64kbps B channels or "multirate" B channels for RPVD applications.
Channel D protocols | EUROisdn, DSS1, LAPD/Q.921, Q.931, simulation Q931, X25, QLLC.
Channel B protocols | IP, PPP, Frame-relay, SDLC, QLLC, LAPB, X25, Transparent HDLC, MPX voice-data, RPVD (permanent B channels). Switched 64kbps (single rate) and permanent Nx64kbps (multirate) channels. The limits for a complex system are 32 channels or, altogether, 2Mbit/sec.
Synchronism | Internal or automatically selectable by any PRI port, NT and TE, or by any BEP-S0-TE port eventually installed.
Voice compression and fax/data relay (optional) | Up to 16 communications.
Compression algorithm | G.723.1 MP-MLQ @ 4.8, 6.4.
Echo canceling | G.165 @16 msec
FAX relay | G.III @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Modem relay | V.32bis @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Other features | Automatic interpolation of bad or missing audio-frames, volume control, "Voice Activity Detection", "Silence Suppression".

Analogic VOICE ports | Up to 20.
Adapters | ACB
Interfaces | FXS, FXO.
Compression algorithm | G.723.1 MP-MLQ @ 4.8, 6.4.
Echo canceling | G.165 @16 msec
FAX relay | G.III @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Modem relay | V.32bis @ 2.4, 4.8, 7.2, 9.6, 14.4 kbit/sec.
Other features | Automatic interpolation of bad or missing audio-frames, volume control, "Voice Activity Detection", "Silence Suppression".

Abilis CPX is always under developing, that's why those specifications are subject to change without notice on this manual.

[1] Some models may not be provided with this feature.
[2] Abilis own protocol.
[3] Abilis own protocol.
[4] Only HSCB adapters.
[5] Abilis own protocol.
[6] Abilis own protocol.
[7] FM0, FM1, Manchester only for HSCB adapters.
[8] FM0, FM1, Manchester only for HSCB adapters.
[9] RS232 and current-loop only for multi-serial DFLEX adapters.
[10] Virtual, Private Digital Network.
[11] Only ESB2 adapter.
[12] Only ESB2 adapter.


Supervision of connections

Vision of COR sessions status
Vision of Fxs/Fxo VOICE connections status
Vision of EIR connections status

System supervision

Vision of COR sessions status top

Each communication port served by the Connection Oriented Router (COR) and "RUNNING" is provided with a maximum number of sessions equal to the sum of the PVC and SVC channels configured in its parameters.

Session numbering always starts from 1 and it is contiguous.

In SVC sessions, the index (SES:) is not related to the number of the logical channel in use (LGCN), while in PVC ones they coincide (SES:=LGCN).

Commands for displaying the sessions status are described in the section COR connections of chapter Commands relating to the Connection Oriented Router. The available commands are:

C C
D C
D CE

The command D C shows the current status of sessions. Here is an example of displaying all the ports status, shown values are examples:

[14:40:11] ABILIS_CPX: D C PO:A

PO:0   SES:1   CONN FROM  PO:905 SES:4    CG:                PR:0
PO:0   SES:2   UP         CLR:00,00
PO:0   SES:3   CONN FROM  PO:905 SES:1    CG:                PR:0

PO:21  SES:1   DOWN       CLR:F0,B0

PO:301 SES:1   UP         CLR:F0,B0
PO:301 SES:2   UP         CLR:F0,B0
PO:301 SES:3   UP         CLR:F0,B0
PO:301 SES:4   UP         CLR:F0,B0
PO:301 SES:5   UP         CLR:F0,B0

PO:328 NO SESSIONS AVAILABLE

PO:900 NO SESSIONS AVAILABLE

PO:905 SES:1   CONN TO    PO:0   SES:3    CD:00              PR:0
PO:905 SES:2   UP         CLR:F0,D0
PO:905 SES:3   UP         CLR:00,00
PO:905 SES:4   CONN TO    PO:0   SES:1    CD:00              PR:0
PO:905 SES:5   UP         CLR:00,00
PO:905 SES:6   UP         CLR:00,00

As the previous example shows, for active connections the following information set is displayed:

  • session status;
  • calling address (CG:) or called address (CD:);
  • routing index (PR:).

For not active connections the following information set is displayed:

  • clearing codes (CLR:) used for closing the connection.

The command D CE shows the current status of sessions, it also displays the call data for active and not active sessions. Here is an example of the information displayed after executing this command. Shown values are examples.

[14:40:11] ABILIS_CPX: D CE PO:A

PO:0   SES:1   CONN FROM  PO:905 SES:4
       CG:                CD:00               PID:01000000 UD:CP
PO:0   SES:2   UP         CLR:00,00
PO:0   SES:3   CONN FROM  PO:905 SES:1
       CG:                CD:00               PID:01000000 UD:CP

PO:21  SES:1   DOWN       CLR:F0,B0

PO:301 SES:1   UP         CLR:F0,B0
PO:301 SES:2   UP         CLR:F0,B0
PO:301 SES:3   UP         CLR:F0,B0
PO:301 SES:4   UP         CLR:F0,B0
PO:301 SES:5   UP         CLR:F0,B0

PO:328 NO SESSIONS AVAILABLE

PO:900 NO SESSIONS AVAILABLE

PO:905 SES:1   CONN TO    PO:0   SES:3
       CG:                CD:00               PID:01000000 UD:CP
PO:905 SES:2   UP         CLR:F0,D0
PO:905 SES:3   UP         CLR:00,00
PO:905 SES:4   CONN TO    PO:0   SES:1
       CG:                CD:00               PID:01000000 UD:CP
PO:905 SES:5   UP         CLR:00,00
PO:905 SES:6   UP         CLR:00,00

For active connections the following information set is displayed:

  • session status;
  • calling address (CG:);
  • called address (CD:);
  • PID (first 4 bytes of user data) content in hexadecimal format (PID:);
  • user data field (UD:) content (starting from the 5th byte) in ASCII format.

For not active connections values related to the last connection or last connection try are displayed:

  • clearing codes (CLR:) used for closing or refusing the connection;
  • calling address (CG:);
  • called address (CD:);
  • PID (first 4 bytes of user data) content in hexadecimal format (PID:);
  • user data field (UD:) content (starting from the 5th byte) in ASCII format.

It is important to underline that these commands work only on "RUNNING" ports, which have also to be served by the COR. To have a list of all the running ports, use the command D RUN.

If a given port is "RUNNING" but neither SVC or PVC sessions have been configured, both the commands will show the message "NO SESSION AVAILABLE" in correspondence of that port.

The following example shows extended information about a single port, the other example demonstrate how to clear a particular connection:

[14:40:11] ABILIS_CPX: D CE PO:0

PO:0   SES:1   CONN FROM  PO:905 SES:4
       CG:                CD:00               PID:01000000 UD:CP
PO:0   SES:2   UP         CLR:00,00
PO:0   SES:3   CONN FROM  PO:905 SES:1
       CG:                CD:00               PID:01000000 UD:CP

ABILIS_CPX: C C PO:0 SES:1

COMMAND EXECUTED

[14:40:11] ABILIS_CPX: D CE PO:0

PO:0   SES:1   UP         CLR:F0,A2
PO:0   SES:2   UP         CLR:00,00
PO:0   SES:3   CONN FROM  PO:905 SES:1
       CG:                CD:00               PID:01000000 UD:CP

Table 1. Parameters of COR sessions status.
Parameter | Values | Meaning
PO: | 0-999 | Source port
SES: | 1-255 | Session of source port
Status message | see further | Status Message
PO: | 0-999 | Destination port
SES: | 1-255 | Session of destination port
CG: | from 0 up to 15 decimal digits | Calling address
CD: | from 0 up to 15 decimal digits | Called address
CLR: | see appendix | Cause and diagnostics clearing codes
RST: | see appendix | Reset cause and diagnostics (Only for PVC)
PID: | from 0 up to 4 hexadecimal digits | Protocol IDentifier, i.e. the first 4 bytes of user data field
UD: | from 0 up to 12 alphanumerical characters | User data starting from the 5th byte
IPSRC: | 0.0.0.0 - 255.255.255.255 | IP source address (Only for SVC and XTP ports)
IPDEST: | 0.0.0.0 - 255.255.255.255 | IP destination address (Only for SVC and XTP ports)
PR: | 0 - 99 | SVC routing identifier in use (Only for SVC)
ID: | 0-31 | PVC routing identifier in use (Only for PVC)

Session status is not identified by a specific parameter, but simply shown. In the following table, is showed the list of the possible "Status Messages" and their meaning (they depend on the session type).

Table 2. State messages of COR sessions.
Message | Meaning
UNDEFINED | Session status at the system start
HALTED | Port is halted
DOWN | Switched session: the port is not in its "READY" state, session cannot be activated
UP | Switched session: the port is in its "READY" state, session can be activated
CALLED | Switched session: call request received
CALLING | Switched session: call request sent
CLEARED | Switched session: clear request received
CLEARING | Switched session: clear request sent
CONN TO | Switched session: the session is active and ready to exchange data after sending the call request (CALLING -> CONN TO)
CONN FROM | Switched session: the session is active and ready to exchange data after receiving the call request (CALLED -> CONN FROM)
OPENING | Permanent connection: opening in progress. The RESET 00,00 is sent
CLOSING | Permanent connection: closing in progress. The RESET F0,40 is sent
CLOSED | Permanent connection: closing complete
PVC-DOWN | Permanent connection: the port is not in its "READY" state, session cannot be activated
PVC-N/U | Permanent connection: connection not or badly configured
PVC-UP | Permanent connection: session active and ready to exchange data
RESET | Session, switched or permanent, has received a RESET packet, but not its acknowledged
RESETTING | Session, switched or permanent, has sent a RESET packet, but not received its acknowledged

Vision of Fxs/Fxo VOICE connections status top

Command for displaying the Fxs/Fxo VOICE connections status are described in the section Fxs/Fxo VOICE connections of chapter Commands relating to the Analogue VOICE Router. The available commands are:

C VC
D VC

The command D VC shows the current status of all the Fxs/Fxo VOICE connections. Here is an example of the command execution. Shown values are only examples.

[14:40:11] ABILIS_CPX: D VC

ID Numi Numo  Poi Chi    State    Grp Poo Cho  VrID    Sp      Bw
-- ---- ----  --- ---  ---------  --- --- ---  ----  ------  ------
0   555  666   60   1  BUSY         1  63   -     0       0       0
1   2    2     61   1  CONNECTED      502   1     4    4800    6200
2   376  20   501   1  CONNECTED       61   2     2    6400    7800

For active connections are displayed:

  • Fxs/Fxo VOICE connection identifier (ID) (usable by the command C VC);
  • input telephone number (Numi);
  • output telephone number (Numo);
  • input port (Poi);
  • logical channel assigned on the input port (Chi);
  • current Fxs/Fxo VOICE connection status (State);
  • output port (Poo);
  • logical channel assigned on the output port (Cho);
  • the Fxs/Fxo VOICE group eventually used for the connection (Grp);
  • index of Fxs/Fxo VOICE routing used to set up the connection (VrID);
  • current transmission speed (Sp);
  • current used bandwidth (Bw).
Table 3. Status parameters of VOICE connections.
Parameter | Values | Meaning
ID | 0 - 255 | Connection identifier
Numi | from 0 up to 4 digits, '0'..'9' | Input number
Numo | from 0 up to 4 digits, '0'..'9' | Output number
Poi | 0 - 999 | Input port
Chi | 1 - 255, - | Input channel
State | see further | Status Message of the connection.
Grp | 1 - 15, no value | VOICE Group
Poo | 0 - 999 | Output port
Cho | 1 - 255, - | Output channel
VrID | from 0 up to 64 | Identifier of the Fxs/Fxo VOICE routing in use
Sp | 4800, 6400, 7200, 8000, 9600, 10400, 12800, 16000 bit/sec. | Actual transmission speed on the connection
Bw | 6200, 7800, 8800, 9400, 11000, 12000, 14200, 17400 bit/sec. | Bandwidth actually used by the connection

Session status is identified by a specific message. In the following table, is showed the list of the possible State parameter values and their meaning.

Table 4. Status messages of Fxs/Fxo VOICE connections.
Status message | Meaning
CALLING | It is going to be set up
BUSY | The number dialled is busy
CLOSING | It is going to be released
CONNECTED | It is active

Vision of EIR connections status top

Command for displaying the EIR connections status are described in the section EIR connections of chapter Commands relating to the Enhanced ISDN Router. The available commands are:

C EC
D EC
D ECE

The command D EC shows the status of the EIR connections actually running. Here is an example of the command execution. Shown values are examples.

[14:40:11] ABILIS_CPX: D EC

ID  Type Input    Output   PR   State   Cgi (Calling Input) Cdo (Called Output)
--- ---- -------- -------- -- --------- ------------------- -------------------
125 TR   291      283      22 CONNECTED                     376390774
181 TR   290      280      19 CONNECTED 381650866           376397398
196 TR   290      282      19 CALLING   444687062           376397398

For active connections are displayed:

  • EIR connection identifier (ID) (eventually usable by the command C EC);
  • EIR connection type (Type);
  • port and/or group and/or identifier value of the input Cluster channel (Input);
  • port and/or group and/or identifier value of the output, remote Cluster channel (Output);
  • priority of the EIR routing used for setting up the connection (PR);
  • current connection state (State);
  • input calling number (Cgi);
  • output called number (Cdo).
Table 5. Parameters of the EIR connection status.
Parameter | Values | Meaning
ID | 0 - 255 | Connection identifier
Type | TR, VtoC, CtoV, CtoC, DATA, Clus | Connection type
Input | 0-999, G00-G32, 'a'-'z', 'A'-'Z' | Port and/or group and/or identifier value of the input Cluster channel
Output | 0-999, G00-G32, 'a'-'z', 'A'-'Z' | Port and/or group and/or identifier value of the output, remote Cluster channel
PR | 0 - 99 | Priority of the EIR routing in use
State | see further | Connection State Message
Cgi | from 0 up to 20 digits, '0'..'9' | Input calling number
Cdo | from 0 up to 20 digits, '0'..'9' | Output called number

The command D ECE shows the status of the EIR connections actually running, using an extended format with more informations. Here is an example of the command execution:

[14:40:11] ABILIS_CPX: D ECE

ID:125 TYPE:TR    POI:291  GPI:#   POO:283  GPO:#   PR:22  ST:CONNECTED
      CGI:                     CGO:
      SGI:                     SGO:
      CDI:376390774            CDO:376390774
      SDI:                     SDO:

ID:181 TYPE:TR    POI:290  GPI:#   POO:280  GPO:#   PR:19  ST:CONNECTED
      CGI:381650866            CGO:381650866
      SGI:                     SGO:
      CDI:376397398            CDO:376397398
      SDI:                     SDO:

ID:197 TYPE:TR    POI:290  GPI:#   POO:282  GPO:#   PR:20  ST:CALLING
      CGI:3486508535           CGO:3486508535
      SGI:                     SGO:
      CDI:376396548            CDO:376396548
      SDI:                     SDO:

Table 6. State parameter of the connection EIR, extended format.
Parameter | Values | Meaning
ID: | 0 - 255 | Connection identifier
TYPE: | TR, VtoC, CtoV, CtoC, DATA, Clus | Connection type
POI: | 0 - 999 | Input port
GPI: | 1 - 15, # | Input Group
POO: | 0..999 | Output port
GPO: | 1 - 15, # | Output Group
PR: | 0 - 99 | Priority of the EIR routing in use
ST: | see further | Current connection state
CGI: | from 0 up to 20 digits, '0'..'9' | Input calling number
SGI: | from 0 up to 20 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Input calling sub-address
CDI: | from 0 up to 20 digits, '0'..'9' | Input called number
SDI: | from 0 up to 20 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Input called sub-address
CGO: | from 0 up to 20 digits, '0'..'9' | Output calling number
SGO: | from 0 up to 20 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Output calling sub-address
CDO: | from 0 up to 20 digits, '0'..'9' | Output called number
SDO: | from 0 up to 20 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Output called sub-address
SR: | from 0 up to 8 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Identifier of the source Cluster channel (only for CtoV, CtoC, Clus connection types)
DS: | from 0 up to 8 characters, '0'..'9', 'a'..'z', 'A'..'Z' | Identifier of the destination Cluster channel (only for VtoC, CtoC, Clus connection types)
SP: | 4800 - 16000 bit/sec. | Actual rate of the compressed speech (only for VtoC, CtoV, CtoC connections type)
BW: | 6200 - 17400 bit/sec. | Currently used bandwidth (only for VtoC, CtoV, CtoC connections type)
SC: | NO, YES | State of silence suppression function (only for VtoC, CtoV, CtoC connections type)

Session status is identified by a specific message. In the following table, is showed the list of the possible ST: parameter values and their meaning.

Table 7. State messages of EIR connections.
State Message | Meaning
CALLING | Call request has been sent to the addressee
ALERTING | The addressee sent back an ALERT message: his telephone is ringing
CONNECTED | Connection is active: the addressee picked up the receiver
CONN-TMD | The connection is still active, however the disconnection timer following inactivity is running. The value of the timer is configured in DT: parameter of EIR cluster routings.
WAIT-REL | Transitory state which occurs only in congestion situations (MXPC: parameter too small): release request has been queued, waiting free resources
RELEASING | Connection is going to be released
ERROR | Internal error. Contact the CPX assistance


Logging functionalities

System Log
Events Log (Debug Log)
Exceptions Log

System supervision

System Log top

A very useful function, that is provided by Abilis CPX, is the recording of all the events that are pertinent to the global working mode and other events of particular importance. These events are stored in textual format in a file called System Log.

The System Log file is a fixed length one (10 Kbytes) and it contains the 256 more recent events. The System Log is saved on the floppy disk and updated every time that an event to save occurs. New events are stored and the oldest ones are progressively deleted. Every event is saved with its date and time of occurrence.

warning! Because System Log file is stored on the floppy disk, that contains the Abilis CPX software and that is inserted in floppy drive, the disk must be NOT WRITE PROTECTED, otherwise, the Abilis CPX keeps on working, but the System Log cannot be saved.

Using the command interpreter of the Control Port, it is possible to inspect the content of the System Log file. Events are displayed starting from the oldest one or from a certain date and time, that must be specified in the displaying command.

Here is an example of System Log content visualization:

[14:40:11] ABILIS_CPX: D L

01/03/2004 15:33:26 --- NEW RUN ----
01/03/2004 15:33:26 I: SYSTEM RESET
01/03/2004 15:33:36 I: EB IDEC f01
01/03/2004 15:33:36 I: EB ESCC8 f01
01/03/2004 15:33:41 I: EB AC f04 r04
01/03/2004 15:33:47 W: C02
01/03/2004 15:33:47 TRACE ACTIVATED
01/03/2004 15:33:50 SYSTEM STARTED
01/03/2004 15:33:50 CONF:ACCEPTED
01/03/2004 15:33:50 CONF:BACKUP
01/03/2004 15:33:50 AUTO SAVE CONF
01/03/2004 15:33:50 I:p1   SYN:UP.01
01/03/2004 15:33:50 I:p2   SYN:UP.01
01/03/2004 15:33:50 I:p3   SYN:UP.11
01/03/2004 15:33:50 I:p4   SYN:UP.11
01/03/2004 15:33:50 I:p5   SYN:UP.01
01/03/2004 15:33:50 I:p6   SYN:UP.01
01/03/2004 15:33:50 I:p7   SYN:UP.01
01/03/2004 15:33:50 I:p8   SYN:UP.01
01/03/2004 15:33:50 I:p21  PAD:dn.01
01/03/2004 15:33:50 I:p196 EPL:dn.in
01/03/2004 15:33:50 I:p197 EPL:dn.in
01/03/2004 15:33:50 I:p201 LAPB:cg
01/03/2004 15:33:50 I:p202 LAPB:cg
01/03/2004 15:33:50 I:p203 LAPB:cg
01/03/2004 15:33:50 I:p204 LAPB:cg
01/03/2004 15:33:50 I:p301 X25:down
01/03/2004 15:33:50 I:p302 X25:down
01/03/2004 15:33:50 I:p303 X25:down
01/03/2004 15:33:50 W: EVENTS LOST
01/03/2004 15:33:51 AUTO SAVE OK
01/03/2004 15:33:58 CONN P:920 L:01
01/03/2004 15:33:58 CONN P:921 L:01
01/03/2004 15:34:16 I:p751 MLM:RD.ln

It is also possible to make System Log events to be simultaneously sent to the current Control Port session. Events are displayed in the same time that they occurs and that they are recorded into the file on the floppy disk.

Here is an example of System Log content real-time listing:

[14:09:03] ABILIS_CPX: START L

Current Local Time: Wednesday 03/04/2002 14:12:37 (GMT+2.00)

Start System Log content real-time logging (Type Ctrl+C to stop logging):

03/04/2002 14:16:00 I:p1   SYN:UP.00
03/04/2002 14:16:02 I:p1   SYN:UP.01
03/04/2002 14:22:30 System Alive
03/04/2002 14:23:12 I:p2   SYN:UP.11
03/04/2002 14:23:15 I:p201 LAPB:CONN
03/04/2002 14:23:15 I:p205 LAPB:CONN
03/04/2002 14:23:15 I:p301 X25:RDY
03/04/2002 14:23:15 I:p305 X25:RDY

The System Log content can also be cleared through an appropriate command.

The commands for managing the System Log are described in the section Logging Functionalities of the chapter General and system commands. They are:

C L
D L
START L

As it can be seen from the previous examples, System Log events can be grouped in four classes on the base of their meanings. Each class is easily identifiable because the text of the message starts with an opportune prefix:

Event type | Prefix | Meaning
GENERAL | no prefix | Signaling of general events such as Abilis CPX start.
ERROR: | E: | Signaling errors that require Abilis CPX restart. All the sessions are closed and Abilis CPX restarts.
WARNING | W: | Warning signaling. The occurred event is not critic, so that Abilis keeps on working.
INFORMATION | I: | Informative signaling. Important events are saved.

For the full list of all the messages saved in the System Log and a short description of their meaning, refer to the Messages in the System Log section.

Events Log (Debug Log) top

Another useful function, that is provided by the Abilis CPX, is the recording of all the events that are pertinent to connection's opening/closing and to port's state changes. These feature is called Events Log (or Debug Log).

This kind of information is highly technical and for being able to use them, it is necessary a deepened knowledge of Abilis CPX and of the X.25/ISDN protocols.

Events that are registered in the Events Log are grouped in the following classes:

Mnemonic | Events classes
DIAG | Events related to port diagnostic and status.
COR | Events related to the Connection Oriented Router.
MLM | Events related to the Multi Link Manager driver.
EIR | Events related to the Enhanced ISDN Router.
EIRE | Extension of the events class related to the Enhanced ISDN Router.
PPP | Events related to the Point-to-Point Protocol driver.
ML | Events related to the Multi Links driver.

Events are recorded in a circular buffer of fixed length that is kept in memory. The buffer maintains the more recent events, progressively eliminating the oldest. Every event is saved with its date and time of occurrence.

Usually the Events Log can store events for few days; however this time interval depends, exclusively, on the number and the type of events to record, that can also change from customer to customer.

The Events Log content is transferred from the memory to a proper file of the floppy disk every time the Abilis CPX is restarted or in correspondence to the user request, without restarting the Abilis CPX.

The system restart can be performed by the user through the RESTART SYSTEM command, that is available from both the the command interpreter of the Control Port and from the UTILITY of the LCD display of the frontal panel.

The user can request Events Log to be saved through the SAVE DEBUG command, that is available from both the the command interpreter of the Control Port and from the UTILITY of the LCD display of the frontal panel.

warning! For being able to transfer the Events Log to the floppy disk, it is essential that the floppy disk, that contains the Abilis CPX software and that is inserted in floppy drive, should be NOT WRITE PROTECTED, otherwise, the Abilis CPX keeps on working, but the Events Log cannot be saved.

Using the command interpreter of the Control Port, it is possible to inspect the content of both the Events Log that is currently saved in memory and of the Events Log file stored on the floppy disk.

In both cases, events are displayed starting from the oldest one or from a certain date and time, that must be specified in the displaying command. it is also possible to select the events to display by specifying their class.

Here is an example of visualization of the Events Log stored in memory:

[14:31:37] ABILIS_CPX: D LDM

Current Local Time: Wednesday 03/03/2004 15:20:42 (GMT+1.00)

Date   Time   Po  Ses   Event and Parameters
------ ------ --- ----- ------------------------------------------------------
020304 165053   1     0 PortDiag SYNC:UP DCD:dn DTR:UP
020304 165053   2     0 PortDiag SYNC:UP DCD:dn DTR:UP
020304 165053  21     0 PortDiag PAD:dn DCD:dn DTR:UP
020304 165053 196     0 PortDiag EPLAPD Q931:dn X25:in
020304 165053 197     0 PortDiag EPLAPD Q931:dn X25:in
020304 165053 201     0 PortDiag LAPB:cg
020304 165053 202     0 PortDiag LAPB:cg
020304 165053 301     0 PortDiag X25:down
020304 165053 302     0 PortDiag X25:down
020304 165053 503     0 PortDiag MLM PLink:ln SLink:ln ATN:
020304 165053 504     0 PortDiag MLM PLink:ln SLink:ln ATN:
020304 165053 521     0 PortDiag ML PLINKs:NO-LINKS    CHANs:STOPPED1
020304 165053 541     0 PortDiag PPP:DOWN
020304 165053 997     0 PortDiag MLM PLink:ln SLink:RD ATN:
020304 165053 998     0 PortDiag LAPB:cg
020304 165053 999     0 PortDiag X25:down
030304 102314 905     6 CallRx CG:                CD:00
              PID:01000000 UD:CP           FF:
030304 102314 905     6 Routing Match PR:1
030304 102314   0     1 CallTx CG:                CD:00
              PID:01000000 UD:CP           FF:
030304 102314   0     1 CallConnRx LSN:01 CG:                CD:00
              PID:01000000 UD:CP           FF:
030304 102314 905     6 CallConnTx LSN:01 CG:                CD:
              PID:         UD:             FF:
030304 102450 905     6 ClrRx F0:A3 LSN:01
030304 102450 905     6 ClrConfTx 00:00 LSN:01
030304 102450   0     1 ClrTx 00:00 LSN:01
030304 102450   0     1 ClrConfRx 00:00 LSN:01

It is also possible to make Events Log records to be simultaneously sent to the current Control Port session. Events are displayed in the same time that they occurs and that they are recorded into the buffer in memory.

Here is an example of Events Log content real-time listing:

[14:31:37] ABILIS_CPX: START LDM

Current Local Time: Wednesday 03/04/2002 14:36:41 (GMT+2.00)

Start Debug Log content real-time logging (Type Ctrl+C to stop logging):

030402 143712 p905 s5   CallRx CG:                CD:00
              PID:01000000 UD:CP           FF:
030402 143712 p905 s5   Routing Match PR:0
030402 143712 p0   s2   CallTx CG:                CD:00
              PID:01000000 UD:CP           FF:
030402 143712 p0   s2   CallConnRx LSN:02 CG:                CD:00
              PID:01000000 UD:CP           FF:
030402 143712 p905 s5   CallConnTx LSN:02 CG:                CD:
              PID:         UD:             FF:
03/04/2002 14:42:10 System Alive
030402 144514 p905 s5   ClrRx F0:A3 LSN:02
030402 144514 p905 s5   ClrConfTx 00:00 LSN:02
030402 144514 p0   s2   ClrTx 00:00 LSN:02
030402 144514 p0   s2   ClrConfRx 00:00 LSN:02

The Events Log content can also be cleared through an appropriate command.

The commands for accessing the Events Log are described in the section Logging Functionalities of the chapter General and system commands. The available commands are:

C LDM
D LDM
D LDD
SAVE DEBUG
START LDM

notice! As it can be seen from the previous examples, the Events Log contains a lot of information that are meaningless for the user, but that are very useful for the Abilis CPX technicians for solving eventual problems.

For a list of all the messages saved in the Events Log and a short description of their meaning, refer to Messages in the Events Log section.

Exceptions Log top

Another very useful function, that is provided by Abilis CPX for problem solving, is the recording of the Exceptions Log.

An exception is an event that cause the Abilis CPX restart. It is generated every time the system is in any particularly critical situation, to prevent the normal operation.

In correspondence of such event, detailed information and circumstances about it are saved in the Exceptions Log.

In correspondence of an exception a message is also stored in the System Log, in this way it is possible to identify the cause of the system restart.

It has to be noted that such events type are very uncommon.

warning! As well as System and Events Logs, the Exceptions Log is saved on disk. Consequently, the floppy disk that contains the Abilis CPX software and that is inserted in floppy drive, must be NOT WRITE PROTECTED, otherwise, the Abilis CPX keeps on working, but the Exceptions Log cannot be saved.

The commands for accessing the Exceptions Log are described in the section Logging Functionalities of the chapter General and system commands. The available commands are:

C LE
D LE

notice! The Exceptions Log contains a lot of information that are meaningless for the user, but that are very useful for the Abilis CPX technicians for solving eventual problems.


Supervision of communication ports

Vision of communication ports status
Vision of compression statistics

System supervision

Vision of communication port status top

Commands for displaying status and statistics information about communication ports are described in the section Status commands and ports statistics. The base commands available are:

C S
D S
D SE
S S

These commands work only on "RUNNING" ports. Execute the command D RUN to have a complete list of running ports.

Example of displaying the ports status:

[14:40:11] ABILIS_CPX: D S PO:A

PO:0   ------------------------------------------------------------------------
CP     STATE:UP
       Ses  State       AccessLevel    Action
       ------------------------------------------------------------------------
       1    CONNECTED   SUPERUSER      COMMAND-MODE
       2    READY
       3    READY
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |       5291|         42|CHAR       |     336826|        410|
       ------------------------------------------------------------------------

PO:1   ------------------------------------------------------------------------
SYNC   STATE:UP          CARD:ESB2         SP:19200          XTAL:X1-1,8MHz
       DTR:UP            DCD:DOWN          RTS:UP            CTS:DOWN
       LOOP:OFF
       ------------------------------------------------------------------------
       FIFO:USED    RxFrames:165    RxBytes:21120       RxMinFrameOcc:128
                    TxFrames:2      TxBytes:4208        TxMinFrameOcc:2104
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      53966|FRM        |          0|      26983|
       CHR-D      |          0|      53966|FRM-D      |          0|      26983|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

PO:21  ------------------------------------------------------------------------
PAD    STATE:DOWN                          L1:DOWN
       DTR:UP            DCD:DOWN          RTS:DOWN          CTS:DOWN
       RXOVR:0           LOST-I:0          PARITY:0          FRAMING:0
       FIFO:USED         TXSIZE:16         RXSIZE:16
       ------------------------------------------------------------------------
       UART:16550A       TXTRIGGER:0       RXTRIGGER:4
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       CALL       |          0|          0|
       ------------------------------------------------------------------------

PO:100 ------------------------------------------------------------------------
EIM    CLK:INT
       ------------------------------------------------------------------------
       HDLC STATE        TS    CPN  Bch   | AC   STATE        TS    CPN  Bch
       -----------------------------------|------------------------------------
       0    FREE         .     .    .     | 0    FREE         .     .    .
       1    FREE         .     .    .     | 1    FREE         .     .    .
       2    FREE         .     .    .     | 2    FREE         .     .    .
       3    FREE         .     .    .     | 3    FREE         .     .    .
       4    FREE         .     .    .     |
       5    FREE         .     .    .     |
       6    FREE         .     .    .     |
       7    FREE         .     .    .     |
       ------------------------------------------------------------------------

PO:200 ------------------------------------------------------------------------
EIR    -- Number of simultaneous calls ----------------------------------------
                      | State: Alerting/Connected |        State: Any         |
       ---------------|---Current---|----Peak-----|---Current---|----Peak-----|
       TR             |            0|            0|            0|            0|
       DATA           |            0|            0|            0|            0|
       CLUS           |            0|            0|            0|            0|
       VtoC           |            0|            0|            0|            0|
       CtoC           |            0|            0|            0|            0|
       CtoV           |            0|            0|            0|            0|
       ALL            |            0|            0|            0|            0|
       ------------------------------------------------------------------------

PO:201 ------------------------------------------------------------------------
LAPB   STATE:CONNECTING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      26982|
       REJ        |          0|          0|FRMR       |          0|          0|
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       INFO       |          0|          0|BADF       |          0|           |
       UNK-ADD    |          0|           |
       ------------------------------------------------------------------------

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

Example of single port visualization:

[14:40:11] ABILIS_CPX: D S PO:301

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------
PO:201 ------------------------------------------------------------------------
LAPB   STATE:CONNECTING
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      27023|
       REJ        |          0|          0|FRMR       |          0|          0|
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       INFO       |          0|          0|BADF       |          0|           |
       UNK-ADD    |          0|           |
       ------------------------------------------------------------------------
PO:1   ------------------------------------------------------------------------
SYNC   STATE:UP          CARD:ESB2         SP:19200          XTAL:X1-1,8MHz
       DTR:UP            DCD:DOWN          RTS:UP            CTS:DOWN
       LOOP:OFF
       ------------------------------------------------------------------------
       FIFO:USED    RxFrames:165    RxBytes:21120       RxMinFrameOcc:128
                    TxFrames:2      TxBytes:4208        TxMinFrameOcc:2104
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      54048|FRM        |          0|      27024|
       CHR-D      |          0|      54048|FRM-D      |          0|      27024|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

The previous example shows that, if the requested port is connected to lower level port, the command execution will also display information about the lower level port. This kind of "recursive" visualization will stop when up to 10 ports are connected to each other.

If the "recursive" visualization of statistics is not needed, it is enough to add the "." (dot) character at the end of the command row. For example, the following command execution will only display the status of the requested ports, without considering the lower level ports connected to it:

[14:40:11] ABILIS_CPX: D S PO:301 .

PO:301 ------------------------------------------------------------------------
X25    STATE:DOWN
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       PCK        |          0|          0|
       ------------------------------------------------------------------------

Example of statistics information visualization for all the ports, using an extended format.

[14:40:11] ABILIS_CPX: D SE PO:A

PO:0   ------------------------------------------------------------------------
CP     --- Cleared 000:22:43:30 ago, on 02/03/2004 at 16:48:57 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |       5552|         48|CHAR       |     353245|        489|
       ------------------------------------------------------------------------

PO:1   ------------------------------------------------------------------------
SYNC   --- Cleared 000:22:43:30 ago, on 02/03/2004 at 16:48:57 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      54092|FRM        |          0|      27046|
       CHR-D      |          0|      54092|FRM-D      |          0|      27046|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

PO:21  ------------------------------------------------------------------------
PAD    --- Cleared 000:22:45:56 ago, on 02/03/2004 at 16:48:56 ----------------
       RXOVR:0           LOST-I:0          PARITY:0          FRAMING:0
       FIFO:USED         TXSIZE:16         RXSIZE:16
       ------------------------------------------------------------------------
       UART:16550A       TXTRIGGER:0       RXTRIGGER:4
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       SEG        |          0|          0|CHAR       |          0|          0|
       CALL       |          0|          0|
       ------------------------------------------------------------------------

PO:100 ------------------------------------------------------------------------
EIM    EXTENDED STATISTICS NOT AVAILABLE

PO:200 ------------------------------------------------------------------------
EIR    --- Cleared 000:22:44:15 ago, on 02/03/2004 at 16:48:57 ----------------
       -- Number of successful (connected) calls, updated at call end ---------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|          0|          0|           |          0|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Seconds of successful (connected) calls, updated at call end --------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|          0|          0|           |          0|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Number of unsuccessful calls ----------------------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       TR         |          0|          0|          0|          0|          0|
       DATA       |          0|          0|          0|           |          0|
       CLUS       |          0|          0|          0|           |          0|
       VtoC       |           |          0|           |          0|          0|
       CtoC       |           |           |           |          0|          0|
       CtoV       |          0|           |           |          0|          0|
       SUM        |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Internal failures for not connected calls ---------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       NoRoute    |           |           |           |           |          0|
       NoDest     |           |           |           |           |          0|
       NoPcmRes   |          0|          0|          0|          0|          0|
       NoAcRes    |          0|          0|           |          0|          0|
       NoHdlcRes  |          0|          0|          0|           |          0|
       PlinkFail  |          0|          0|           |          0|          0|
       ClusFail   |          0|          0|           |          0|          0|
       BwLimit    |           |          0|           |          0|          0|
       IsdnL1down |          0|          0|          0|          0|          0|
       IsdnL2down |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------
       -- Internal failures after call connected ------------------------------
       -----------|---INPUT---|--OUTPUT---|--LOCAL----|--TRANSIT--|----SUM----|
       PlinkFail  |          0|          0|           |          0|          0|
       ClusFail   |          0|          0|           |          0|          0|
       IsdnL1down |          0|          0|          0|          0|          0|
       IsdnL2down |          0|          0|          0|          0|          0|
       ------------------------------------------------------------------------

PO:201 ------------------------------------------------------------------------
LAPB   --- Cleared 000:22:43:30 ago, on 02/03/2004 at 16:48:57 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      27045|
       REP        |          0|          0|INFO       |          0|          0|
       RR         |          0|          0|RNR        |          0|          0|
       REJ        |          0|          0|FRMR       |          0|          0|
       SABM       |          0|      27046|UA         |          0|          0|
       DISC       |          0|          0|RD         |          0|          0|
       DM         |          0|          0|BADF       |          0|           |
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       SHORT      |          0|           |UNK-ADD    |          0|           |
       ------------------------------------------------------------------------

PO:301 ------------------------------------------------------------------------
X25    --- Cleared 000:22:44:15 ago, on 02/03/2004 at 16:48:57 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RES-REQ    |          0|          0|RES-CON    |          0|          0|
       CAL-REQ    |          0|          0|CAL-CON    |          0|          0|
       CLR-REQ    |          0|          0|CLR-CON    |          0|          0|
       RST-REQ    |          0|          0|RST-CON    |          0|          0|
       INT-REQ    |          0|          0|INT-CON    |          0|          0|
       PCK        |          0|          0|SEG        |          0|          0|
       CHAR       |          0|          0|RR         |          0|          0|
       RNR        |          0|          0|REJ        |          0|          0|
       BAD-PCK    |          0|           |T20-OVR    |           |          0|
       T21-OVR    |           |          0|T22-OVR    |           |          0|
       T23-OVR    |           |          0|N3-OVR     |           |          0|
       ------------------------------------------------------------------------

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the extended statistics, shows either the time interval elapsed from the last statistics reset (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Even this command will display information about lower level ports connected to the requested one.

The following example shows information about status of a X25 port, connected to a LAPB one, which is also connected to a SYNC one.
All of the ports will be shown.

[14:40:11] ABILIS_CPX: D SE PO:301

PO:301 ------------------------------------------------------------------------
X25    --- Cleared 000:22:46:18 ago, on 02/03/2004 at 16:48:56 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RES-REQ    |          0|          0|RES-CON    |          0|          0|
       CAL-REQ    |          0|          0|CAL-CON    |          0|          0|
       CLR-REQ    |          0|          0|CLR-CON    |          0|          0|
       RST-REQ    |          0|          0|RST-CON    |          0|          0|
       INT-REQ    |          0|          0|INT-CON    |          0|          0|
       PCK        |          0|          0|SEG        |          0|          0|
       CHAR       |          0|          0|RR         |          0|          0|
       RNR        |          0|          0|REJ        |          0|          0|
       BAD-PCK    |          0|           |T20-OVR    |           |          0|
       T21-OVR    |           |          0|T22-OVR    |           |          0|
       T23-OVR    |           |          0|N3-OVR     |           |          0|
       ------------------------------------------------------------------------
PO:201 ------------------------------------------------------------------------
LAPB   --- Cleared 000:22:46:18 ago, on 02/03/2004 at 16:48:56 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       T1-UP      |           |          0|T1-DN      |           |      27101|
       REP        |          0|          0|INFO       |          0|          0|
       RR         |          0|          0|RNR        |          0|          0|
       REJ        |          0|          0|FRMR       |          0|          0|
       SABM       |          0|      27102|UA         |          0|          0|
       DISC       |          0|          0|RD         |          0|          0|
       DM         |          0|          0|BADF       |          0|           |
       N2-OVER    |           |          0|N1-OVER    |          0|           |
       SHORT      |          0|           |UNK-ADD    |          0|           |
       ------------------------------------------------------------------------
PO:1   ------------------------------------------------------------------------
SYNC   --- Cleared 000:22:46:18 ago, on 02/03/2004 at 16:48:56 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       CHR        |          0|      54204|FRM        |          0|      27102|
       CHR-D      |          0|      54204|FRM-D      |          0|      27102|
       CHR-V      |          0|          0|FRM-V      |          0|          0|
       CHR-C      |          0|          0|FRM-C      |          0|          0|
       RX-OVR     |          0|           |TX-UND     |           |          0|
       BAD-FCS    |          0|           |ABORT      |          0|          0|
       SHORT      |          0|          0|OTHERS     |          0|           |
       LONG-D     |          0|          0|LOST-D     |          0|           |
       LONG-C     |          0|          0|LOST-C     |          0|           |
       LONG-V     |          0|          0|LOST-V     |          0|           |
       CTS-TOUT   |          0|           |
       ------------------------------------------------------------------------

If the "recursive" visualization of statistics is not needed, it is enough to add the "." (dot) character at the end of the command row.

[14:40:11] ABILIS_CPX: D SE PO:301 .

PO:301 ------------------------------------------------------------------------
X25    --- Cleared 000:22:46:18 ago, on 02/03/2004 at 16:48:56 ----------------
       -----------|---INPUT---|--OUTPUT---|-----------|---INPUT---|--OUTPUT---|
       RES-REQ    |          0|          0|RES-CON    |          0|          0|
       CAL-REQ    |          0|          0|CAL-CON    |          0|          0|
       CLR-REQ    |          0|          0|CLR-CON    |          0|          0|
       RST-REQ    |          0|          0|RST-CON    |          0|          0|
       INT-REQ    |          0|          0|INT-CON    |          0|          0|
       PCK        |          0|          0|SEG        |          0|          0|
       CHAR       |          0|          0|RR         |          0|          0|
       RNR        |          0|          0|REJ        |          0|          0|
       BAD-PCK    |          0|           |T20-OVR    |           |          0|
       T21-OVR    |           |          0|T22-OVR    |           |          0|
       T23-OVR    |           |          0|N3-OVR     |           |          0|
       ------------------------------------------------------------------------

Vision of compression statistics top

For each communication port served by the Connection Oriented Router and "running", Abilis CPX saves the statistics regarding data exchanged between DTE user and the network, calculates the compression percentages in characters and segments for being used in technical and economic analysis.

Statistical data are reset either every time the Abilis CPX starts, or by a proper command execution; so that it is not possible to have an archive containing data antecedent the last system start.

Commands for displaying compression statistics are described in the section Status commands and ports statistics. The base commands available are:

C SC
D SC

These commands work only on "RUNNING" ports. Execute the command D RUN to have a complete list of running ports.

Example of displaying all the ports compression statistics:

[14:40:11] ABILIS_CPX: D SC PO:A

PO:0   --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

PO:21  --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

PO:301 --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

PO:900 --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

PO:905 --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

PO:999 --- Cleared 000:22:16:19 ago, on 03/04/2002 at 13:21:13 ----------------
       CIB:0            EOB:0            TUB:0
       COB:0            EIB:0            TNB:0
       CRB:0.00         ERB:0.00         TRB:0.00
       CIS:0            EOS:0            TUS:0
       COS:0            EIS:0            TNS:0
       CRS:0.00         ERS:0.00         TRS:0.00

The information "Cleared DDD:HH:MM:SS ago, at DD/MM/YYYY HH:MM:SS", referred by the compression statistics, shows either the time interval elapsed from the last statistics reset (by the format "days:hours:minutes:seconds") and date/time of its execution (by the format "day:month:year" and "hours:minutes:seconds").

Table 1. Parameters of compression statistics.
Parameter | Value | Meaning
CIB | 0 - 4.294.967.295 | Total number of input (from User to Abilis CPX) bytes to be compressed
COB | 0 - 4.294.967.295 | Total number of output (from Abilis CPX to the network) compressed bytes
CRB | from -999% to +100% | Percent ratio between CIB and COB: bytes sent by the User/bytes sent to the network
CIS | 0 - 4.294.967.295 | Total number of input (from User to Abilis CPX) segments to be compressed
COS | 0 - 4.294.967.295 | Total number of output (from Abilis CPX to the network) compressed segments
CRS | from -999% to +100% | Percent ratio between CIS and COS: segments sent by the User/segments sent to the network
EOB | 0 - 4.294.967.295 | Total number of expansion output bytes (from Abilis CPX to User)
EIB | 0 - 4.294.967.295 | Total number of expansion input bytes (from network to Abilis CPX)
ERB | from -999% to +100% | Percent ratio between EIB and EOB: bytes network/user bytes
EOS | 0 - 4.294.967.295 | Total number of expansion output segments (from Abilis CPX to User)
EIS | 0 - 4.294.967.295 | Total number of expansion input segments (from network to Abilis CPX)
ERS | from -999% to +100% | Percent ratio between EIS and EOS: network segments/ user segments
TUB | 0 - 4.294.967.295 | Total number of user bytes
TNB | 0 - 4.294.967.295 | Total number of network bytes
TRB | from -999% to +100% | Percent ratio between TUB and TNB: user bytes/network bytes
TUS | 0 - 4.294.967.295 | Total number of user segments
TNS | 0 - 4.294.967.295 | Total number of network segments
TRS | from -999% to +100% | Percent ratio between TUS and TNS: user segments/network segments

The following figure can help to understand better the meaning of compression statistics.

Meaning of the compression statistics
Figure 1. Meaning of the compression statistics.


Cpx-Dev menu

Summary
Expanded
Previous
Drivers
Conf rules
CP
PAD
SYNC
LAPB
X.25
SDLC
HDLCT
Frame-relay
MLM
ML
PPP
PPPoE-client
PPPoE-AC
Ethernet
Ethernet 100
Token-ring
IP for LAN
Telnet
Secure shell
DNS resolver
Time
SNMP agent
TRFA
Web server
Ftp server
Address transl.
DHCP
X.25 over TCP
IP Tunnel
X.25 simulator
Dummy X.25


Cpx-Dev menu

Summary
Expanded
Previous Next
Eir / ISDN
Enh. ISDN Router
EIM for EIR
Routings
TDM
ISDN level 1
ISDN level 2
ISDN level 3
Q931 simulation
Accounting


Cpx-Dev menu

Summary
Expanded
Previous Next
Fxs/Fxo
Router
Fxs/Fxo


Cpx-Dev menu

Summary
Expanded
Previous Next
Ip router
IP router
TCP
UDP
Routings
Access lists
RIP
OSPF
IPSEC
IKE


Cpx menu

Summary
Expanded
Next
Start
System
X25 router
Ip router
Eir / ISDN
Fxs/Fxo
Tables
Drivers


Cpx-Dev menu

Summary
Expanded
Start
Introduction
Installation
Philosophy
System
Hardware
Ports
Commands
Off-line conf
Supervision
Lists
Cipher keys
Users
X25 router
X25 SVCs/PVCs
Compressions
Ip router
IP router
TCP
UDP
Routings
Access lists
RIP
OSPF
IPSEC
IKE
Eir / ISDN
Enh. ISDN Router
EIM for EIR
Routings
TDM
ISDN level 1
ISDN level 2
ISDN level 3
Q931 simulation
Accounting
Fxs/Fxo
Router
Fxs/Fxo
Tables
ISDN causes
X.25 causes
Messages
Cables
Drivers
Conf rules
CP
PAD
SYNC
LAPB
X.25
SDLC
HDLCT
Frame-relay
MLM
ML
PPP
PPPoE-client
PPPoE-AC
Ethernet
Ethernet 100
Token-ring
IP for LAN
Telnet
Secure shell
DNS resolver
Time
SNMP agent
TRFA
Web server
Ftp server
Address transl.
DHCP
X.25 over TCP
IP Tunnel
X.25 simulator
Dummy X.25


Cpx-Dev menu

Summary
Expanded
Previous Next
Start
Introduction
Installation
Philosophy


Cpx-Dev menu

Summary
Expanded
Previous Next
System
Hardware
Ports
Commands
Off-line conf
Supervision
Lists
Cipher keys
Users


Cpx-Dev menu

Summary
Expanded
Previous Next
Tables
ISDN causes
X.25 causes
Messages
Cables


Cpx-Dev menu

Summary
Expanded
Previous Next
X25 router
X25 SVCs/PVCs
Compressions


NAT configuration examples

Network scheme for examples 1-2-3-4
Example 1. - Suggest an access from inside workstations to outside networks
Example 2. - Publish an outside server as an inside server
Example 3. - Publish an outside HTTP server as an inside HTTP server
Example 4. - Translation of DNS's requests
Network scheme for example 5
Example 5. - Suggest an access from outside networks to internal servers

NAT port (NAT)

Network scheme for examples 1-2-3-4 top

Example 1. Suggest an access from inside workstations to outside networks.
Record has added to NAT static table:

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                SIPP: DIPP: PAT:
               PROT:                  DPO:                 ADPO:
------------------------------------------------------------------------------
0   IN    SRC  192.168.1.0/24         10.0.0.1/32            *     *    YES
               *                      *
------------------------------------------------------------------------------

Example of IP packet translation:

 | Source IP address | Destination IP address
Before translation: | 192.169.1.2:XXX | 10.0.0.3:ZZZ
After translation: | 10.0.0.1:YYY | 10.0.0.3:ZZZ

Comment. For a source address translation has used a record PR:0

Example 2. Suggest an access from inside workstations to outside networks and publish an outside server as an inside server.

In this example we suggest access to the outside server (in this example it is pc4.mynet.com) from inside network.

Records have added to NAT static table:
------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                SIPP: DIPP: PAT:
               PROT:                  DPO:                 ADPO:
------------------------------------------------------------------------------
0   IN    SRC  192.168.1.0/24         10.0.0.1/32            *     *    YES
               *                      *
1   IN    DST  192.168.50.1/32        10.0.0.2/32            *     *    NO
               *                      *
------------------------------------------------------------------------------

Example of IP packet translation:

 | Source IP address | Destination IP address
 | Source translation |
Before translation: | 192.169.1.2:XXX | 192.168.50.1:YYY
After translation: | 10.0.0.1:ZZZ | 192.168.50.1:YYY
 | Destination translation |
Before translation: | 10.0.0.1:ZZZ | 192.168.50.1:YYY
After translation: | 10.0.0.1:ZZZ | 10.0.0.2:YYY

Comment. For a source address translation has used a record PR:0 and for a destination address translation has used a record PR:1

Example 3. Suggest an access from inside workstations to outside networks and publish an outside HTTP server as an inside HTTP server.

In this example we suggest access to the outside HTTP server (in this example it is pc4.mynet.com) from inside network. Now we can use the next URL (Uniform Resource Identifier) "http://192.168.50.1" in our Internet explorer for connect to WWW on pc4.mynet.com.
But we cannot use URL http://pc4.mynet.com yet. See example 4 for more information.

Records have added to NAT static table:

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                SIPP: DIPP: PAT:
               PROT:                  DPO:                 ADPO:
------------------------------------------------------------------------------
0   IN    SRC  192.168.1.0/24         10.0.0.1/32            *     *    YES
               *                      *
1   IN    DST  192.168.50.1/32        10.0.0.2/32            *     *    YES
               TCP                    http(80)
------------------------------------------------------------------------------

Example of IP packet translation:

 | Source IP address | Destination IP address
 | Source translation |
Before translation: | 192.169.1.2:XXX | 192.168.50.1:80
After translation: | 10.0.0.1:YYY | 192.168.50.1:80
 | Destination translation
Before translation: | 10.0.0.1:YYY | 192.168.50.1:80
After translation: | 10.0.0.1:YYY | 10.0.0.2:80

Comment. For a source address translation has used a record PR:0 and for a destination address translation has used a record PR:1

Example 4. Translation of DNS's requests.

In this example we publish an outside HTTP server (there is 10.0.0.2) as inside (pc4.mynet.com with IP address 192.168.1.2). For allow access to this server NAT must made translation of DNS request which will generate user's Intenet browser. (the Internet browser will make this request when you type URL (Uniform Resource Identifier) "http://pc4.mynet.com" and press "Enter")
For this we must add an additional record in NAT table for translation DNS name.

Records have added to NAT static table:

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                SIPP: DIPP: PAT:
               PROT:                  DPO:                 ADPO:
------------------------------------------------------------------------------
0   IN    SRC  192.168.1.0/24         10.0.0.1/32            *     *    YES
               *                      *
1   IN    DST  192.168.50.1/32        10.0.0.2/32            *     *    YES
               TCP                    http(80)
2   OUT   DST  10.0.0.2/32            192.168.50.1/32        *     *    NO
------------------------------------------------------------------------------

Step 1. Translate DNS request.

 | Source IP address | Destination IP address | Body's contents of DNS message.
 | Source translation |  |
Before translation: | 192.169.1.2:XXX | IP address of DNS :53 | REQ=pc4.mynet.com
After translation: | 10.0.0.1:YYY | IP address of DNS :53 | REQ=pc4.mynet.com

Comment. For a source address translation has used a record PR:0

Step 2. Translate DNS answer.

 | Source IP address | Destination IP address | Body's contents of DNS message.
 | DNS massage translation |  |
Before translation: | IP address of DNS :53 | 10.0.0.1:XXX | REQ=pc4.mynet.com ASW=10.0.0.2
After translation: | IP address of DNS :53 | 10.0.0.1:XXX | REQ=pc4.mynet.com ANW=192.168.50.1

Comment. For a DNS answer address translation has used a record PR:2

Step 3. Translate packet with DNS answer.

 | Source IP address | Destination IP address | Body's contents of DNS message.
 | DNS massage translation |  |
Before translation: | IP address of DNS :53 | 10.0.0.1:XXX | REQ=pc4.mynet.com ANW=192.168.50.1
After translation: | IP address of DNS :53 | 192.169.1.2:YYY | REQ=pc4.mynet.com ANW=192.168.50.1

Comment. For a destination address translation has used a record from NAT dynamic table.

Step 4. Translate HTTP packets.

 | Source IP address | Destination IP address
 | Source translation |
Before translation: | 192.169.1.2:XXX | 192.168.50.1:80
After translation: | 10.0.0.1:YYY | 192.168.50.1:80
 | Destination translation |
Before translation: | 10.0.0.1:YYY | 192.168.50.1:80
After translation: | 10.0.0.1:YYY | 10.0.0.2:80

Comment. For a source address translation has used a record PR:0 and for a destination address translation has used a record PR:1

Network scheme for example 5 top

Example 5. Suggest an access from outside networks to our internal servers.

Goal description. We have just one public IP address and on the internal LAN there are more computers on several IP addresses running the same service with different contents, e.g. a commercial web, a technical web, a restricted access web.

Three our servers have described in outside network (for example Internet) as :
10.0.0.1:80 - a main HTTP server of our company.
10.0.0.1:81 - a HTTP server for technical support.
10.0.0.1:82 - a HTTP server for developers.

Records have added to NAT static table:

------------------------------------------------------------------------------
PR: SIDE: ADD: NET:                   ANET:                SIPP: DIPP: PAT:
               PROT:                  DPO:                 ADPO:
------------------------------------------------------------------------------
0   OUT   DST  10.0.0.1/32            192.168.1.1/32         *     *    YES
               TCP                    81                   80
1   OUT   DST  10.0.0.1/32            192.168.1.2/32         *     *    YES
               TCP                    82                   80
2   OUT   DST  10.0.0.1/32            192.168.1.3/32         *     *    YES
               TCP                    83                   80
------------------------------------------------------------------------------

 | Source IP address | Destination IP address
 | Destination translation |
Before translation: | XXX.XXX.XXX.XXX:YYY | 10.0.0.1:80
After translation: | XXX.XXX.XXX.XXX:YYY | 192.168.1.1:80
 | Destination translation |
Before translation: | XXX.XXX.XXX.XXX:YYY | 10.0.0.1:81
After translation: | XXX.XXX.XXX.XXX:YYY | 192.168.1.2:80
 | Destination translation |
Before translation: | XXX.XXX.XXX.XXX:YYY | 10.0.0.1:82
After translation: | XXX.XXX.XXX.XXX:YYY | 192.168.1.3:80

Comment. For the first destination address translation has used a record PR:0, for the second has used a record PR:1, for the third has used a record PR:2